PHP security updates (RHSA-2007-0888, RHSA-2007-0889 & RHSA-2007-0890)

Original Release Date: November 2, 2007
Last Revised: December 3, 2009
Number: ASA-2007-449
Risk Level: Low
Advisory Version: 6.0
Advisory Status: Final

1. Overview:

PHP is a general purpose scripting language widely used in World Wide Web (WWW) pages and applications.

A number of integer overflow vulnerabilities have been discovered in the PHP gd extension. An attacker could exploit this vulnerability to potentially execute code as the apache user. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2007-3996 to this issue.

An integer overflow vulnerability has been reported in the PHP chunk_split function. An attacker could potentially exploit this vulnerability to execute arbitrary code as the apache user. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2007-2872 to this issue.

A previous security update has introduced a bug into PHP session cookie handling. An attacker could exploit this vulnerability to potentially execute a Cross-Site Scripting (XSS) attack. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2007-4670 to this issue.

A vulnerability has been discovered in the PHP money_format function. An attacker who was able to pass arbitrary data into the vulnerable function could potentially induce an information leak, or cause a denial of service (DoS). The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2007-4658 to this issue.

A vulnerability has been reported in the PHP wordwrap function which could allow an attacker to potentially cause a DoS. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2007-3998 to this issue.

A vulnerability has been discovered in PHP session cookie handling, allowing an attacker to create an XSS cookie insertion attack. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2007-3799 to this issue.

A vulnerability has been reported in the PHP gc extension, which under some circumstances could allow an attacker to cause a DoS. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2007-2756 to this issue.

A flaw was found in the PHP "ftp" extension. If a PHP script used this extension to provide access to a private FTP server, and passed untrusted script input directly to any function provided by this extension, a remote attacker would be able to send arbitrary FTP commands to the server. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2007-2509 to this issue.

More information about these vulnerabilities can be found in the security advisories issued by RedHat Linux:

2. Avaya System Products with PHP installed:

Product: Affected Version(s): Risk Level: Actions:
Avaya Communication Manager CM 3.1, 4.x Low Upgrade to CM 5.0 or later.
Avaya Messaging Storage Server MSS 3.x Low Upgrade to MSS 4.0 or later.
Avaya Message Networking MN 3.1 Low Upgrade to MN 5.2 or later.
Avaya Intuity AUDIX LX IALX 2.0, 2.0SP1, 2.0SP2 Low This will not be addressed as no further releases are planned.
Avaya Application Enablement Services AES 3.1.5 and earlier, 4.2 and earlier Low Customers running AES 4.0.1, 4.1, or 4.2 should upgrade to AES 4.2.1 or later.
Customers running AES 3.1.5 and earlier should upgrade to AES 3.1.6 or later.

Recommended Actions:
For all system products which use vulnerable versions of PHP, Avaya recommends that customers restrict local and network access to the server. This restriction should be enforced through the use of physical security, firewalls, ACLs, VPNs, and other generally-accepted networking practices until such time as an update can be installed.

3. Avaya Software-Only Products:

Avaya software-only products operate on general-purpose operating systems. Occasionally vulnerabilities may be discovered in the underlying operating system or applications that come with the operating system. These vulnerabilities often do not impact the software-only product directly but may threaten the integrity of the underlying platform.

In the case of this advisory Avaya software-only products are not affected by the vulnerability directly but the underlying Linux platform may be. Customers should determine on which Linux operating system the product was installed and then follow that vendor's guidance.

4. Software-Only Products:

Product: Actions:
CVLAN Depending on the Operating System provided by customers, the affected package may be installed on the underlying Operating System supporting the CVLAN application. The CVLAN application does not require the software described in this advisory.
Avaya Integrated Management Suite (IMS) Depending on the Operating System provided by customers, the affected package may be installed on the underlying Operating System supporting the IMS application. The IMS application does not require the software described in this advisory.

Recommended Actions:
In the event that the affected package is installed, Avaya recommends that customers follow recommended actions supplied by RedHat Linux.

5. Additional Information:

Additional information may also be available via the Avaya support website and through your Avaya account representative. Please contact your Avaya product support representative, or dial 1-800-242-2121, with any questions.

6. Disclaimer:

ALL INFORMATION IS BELIEVED TO BE CORRECT AT THE TIME OF PUBLICATION AND IS PROVIDED "AS IS". AVAYA INC., ON BEHALF ITSELF AND ITS SUBSIDIARIES AND AFFILIATES (HEREINAFTER COLLECTIVELY REFERRED TO AS "AVAYA"), DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE AND FURTHERMORE, AVAYA MAKES NO REPRESENTATIONS OR WARRANTIES THAT THE STEPS RECOMMENDED WILL ELIMINATE SECURITY OR VIRUS THREATS TO CUSTOMERS' SYSTEMS. IN NO EVENT SHALL AVAYA BE LIABLE FOR ANY DAMAGES WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH THE INFORMATION OR RECOMMENDED ACTIONS PROVIDED HEREIN, INCLUDING DIRECT, INDIRECT, INCIDENTAL, STATUTORY, CONSEQUENTIAL DAMAGES, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF AVAYA HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

THE INFORMATION PROVIDED HERE DOES NOT AFFECT THE SUPPORT AGREEMENTS IN PLACE FOR AVAYA PRODUCTS. SUPPORT FOR AVAYA PRODUCTS CONTINUES TO BE EXECUTED AS PER EXISTING AGREEMENTS WITH AVAYA.

7. Revision History:

V 1.0 - November 2, 2007 - Initial Statement issued.
V 2.0 - July 24, 2008 - Changed AES affected versions and CM and AES recommended actions.
V 3.0 - January 16, 2009 - Changed AES affected verions and recommended actions, changed MSS and MN recommended actions. Added CVE-2007-2059 information.
V 4.0 - May 19, 2009 - Changed IALX affected versions and actions, and ASA status to final.
V 5.0 - May 29, 2009 - Changed MN actions and ASA status to interim.
V 6.0 - December 3, 2009 - Changed MN actions and ASA status to final.

Send information regarding any discovered security problems with Avaya products to either the contact noted in the product's documentation or securityalerts@avaya.com.

© 2007 Avaya Inc. All Rights Reserved. All trademarks identified by the ® or ™ are registered trademarks or trademarks, respectively, of Avaya Inc. All other trademarks are the property of their respective owners.