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Site preparation checklist

# Task Description Notes

1 Ensure all physical
components are
available on the
customer network.

IP Office Contact Center
server
IP Office server
XMPP server (optional for
chat functionality)
Agent workstations
Telephones

See platform requirements.

2 Ensure that the
additional hard disk
drives for IP Office
server type are
available. (Optional,
only if you want to use 
Contact Recorder)

IP Office Server Edition
IP 500 V2

 Note:
IPOCC does not
support IP 500 V1
server.

For information about the
hard disk drive types
download the documents
from the HP support site or
Dell support site.
For information about adding
additional hard disk drives
see, Contact Recorder.
For information about
deploying IP Office Server
Edition see, Deploying IP
Office Server Edition
Solution.
For information about
installing IP 500 V2 see,
Installing IP500/ IP 500 V2.

 Note:
To Ignite the additional
hard disk drive for Contact
Recorder see, Contact
Recorder.

3 Telephony and internet
services are in place.

Service Providers

IP Office Contact Center server requirements
The requirements are as follows:

IP Office Contact Center server requirements
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Operating system Microsoft® Windows Server 2008 R2 Standard 64–bit Edition SP1

Microsoft® Windows Server 2012 R2 Standard 64–bit Edition

Processor Intel Xenon E3 Quadcore 3.1 GHz

Memory 8 GB DDR3 ECC

Hard drive 1 Seagate ST500DM002 500 GB 7200 RPM, SATA 6 G 16 MB Cache

 Note:
Avaya recommends you to add an additional 500GB Hard Disk Drive
and RAID to support IP Office Contact Center.

Raid controller Raid Controller Intel C202 onboard
Disk space
allocations

- 500 GB disk space for complete OS, databases, and applications

Media DVD-ROM drive

Keyboard Multifunction keyboard

Network 1NIC 1 GB, network or Ethernet card

 Note:
IP Office Contact Center supports only one NIC. If you have multiple
NICs disable all the other NICs.

Agent workstation requirements

Processor Intel Pentium 4 processor 2.2 GHz or higher

Operating system Microsoft® Windows 7, or Windows 8.1
Memory Minimum 4 GB RAM

Hard disk Minimum 10 GB
Keyboard and mouse Multifunction keyboard and mouse
Browser Microsoft® Internet Explorer 8.x or higher

Mozilla Firefox 3.6 or higher

Network Ethernet card

Agent workstation requirements
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Planning checklist

Plan for installation and configuration by meeting with the customer to collect site-specific information and
network information and to ensure that they are prepared for delivery and installation.

# Task Description Notes

1 Download documents
from the Avaya Support
Site Documents and
Downloads.

Use the planning
documents to ensure the
customer site is prepared
and use forms to gather
customer site-specific
data.

On the Avaya Support Site,
in the Enter Your Product
Here field, type IP
Office Contact
Center.

2 Complete the Avaya IP
Office Contact Center
Configuration
Worksheet.

Customer data includes:

• Server information

• Agent information

• Job codes

• Topic assignments

Download and use the
Microsoft® Excel
spreadsheet as a template.

3 Download the
documents from the HP
support site or Dell
Support site.

Use the respective guides
to add an additional hard
disk drive for Contact
Recorder.

4 Download documents
from the Avaya Support
Site Documents and
Downloads.

Use the planning
documents to install and
configure the IP Office
Server Edition or IP 500
V2

On the Avaya Support Site,
in the Enter Your Product
Here field, type IP
Office.

5 Plan endpoint
deployment.

Avaya 1400 series phone
Avaya 1600 series phone
Avaya 9500 series phone
Avaya 96x1 (H.323)
deskphone
Avaya 96x0 (H.323)
deskphone

6 Ensure customer has
required components.

XMPP server
Agent workstations

Use the Site preparation
checklist.
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Key customer configuration information

Using the IP Office Contact Center Configuration Worksheet
The worksheet is a Microsoft® Excel spreadsheet that captures and organizes customer site
information used by the installer during system configuration tasks. Each tab in the workbook
corresponds to an aspect of the system configuration.

Before you begin
Copy the Avaya IP Office Contact Center Configuration Worksheet from the IPOCC_DVD and
save it on a computer with Microsoft® Excel. Typically, Avaya IP Office Contact Center
Configuration Worksheet is located at Utilities.

About this task
Use the worksheet to collect customer configuration data and create export files for server
configuration.

Procedure

1. Open the spreadsheet .

2. Enable macros.

 Important:
Save the spreadsheet as .xlsm format to enable macros.

3. Use Save as to make a copy with a unique name for the customer.

4. Read the instructions on the Brief Instruction tab of the work sheet before you fill
in the required information, marked in red (mandatory field), within each tab.
The spreadsheet populates fields in the other tabs. For more information see, 
Important fields of the configuration worksheet on page 6.

The Change me fields in the spread sheet are optional, used for configuring the
chat and email.

5. Click Create Data Import to generate data import files.

Next steps
During configuration you need the DataImport.exe for IP Office Contact Center Server and
configuration.csv for IP Office.

Key customer configuration information
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Related topics:
Important field descriptions of the configuration worksheet on page 6

Important field descriptions of the configuration worksheet

 Note:
The following table lists only the minimum required fields that you need to fill in the
configuration worksheet. For more details, lookup the tool tips in the configuration
worksheet.

Name Description

Base Data tab Type the following:

• Name of the IP Office Contact Center

• Name of the chat server

• Chat and E-mail domain name. For
example, customer.com
(optional)

 Note:
Check the number range of topics. If you
make any change you must also update
the change in the Topics tab.

Chap tab Type the following ip address:

• IP Office Contact Center server

• IP Office

• DNS

• SIP domain

 Note:
The name of the SIP domain must be the
same as the SIP domain name in System
> LAN1 > VOIP tab of the IP Office
configuration. The name of the SIP
domain must be in lower case.
Verify the number for the SIP extensions.
Do not use this number in the IP Office. If
necessary change the partitioning of the
channels for Queuedevices and IVR. For
Queuedevices automatically the range
70000-70059, for IVR Ports 80000-80029
is used.

Key customer configuration information

6     February 2014



Name Description

Topic tab Type the topic details.

Agent groups tab Type the agent group details.

Agents tab Type the agent details.

Topic-AG-Assigment tab Type the topic and agent assignment
details.

Packaging and order codes
The following IP Office Contact Center license bundles are available:

Material code Description

306493 IP Office Contact Center Base 30

306640 IP Office Contact Center Base 100

306495 IP Office Contact Center 1 voice agent license with skills based
routing and call recording

306496 IP Office Contact Center 1 Multichannel License with email, chat and
outbound campaigns

306497 IP Office Contact Center 1 Supervisor License

306641 IP Office Contact Center Base 30 to Base 100 migration

IP Office Contact Center Base 30 bundle
IP Office Contact Center:

 Note:
Use Avaya WebLM to install the PLDS license.

PLDS license Description

VALUE_CIE_PX_IPO (1) Single PBX connection — IP Office

VALUE_CIE_IVR_CON (1) 1 CHAP port

VALUE_CIE_IVR_PORT (Channels 90) 90 channels (maximum for 32–bit CHAP)

VALUE_CIE_CC_CLIP 10000 addresses

VALUE_CIE_CC_TEAMLEADER (1) Enables supervisor application in UI for
preconfigured monitors and reports

VALUE_CIE_CC_SERVUSER (2) 2 concurrent service users needed for
configuration

Packaging and order codes
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PLDS license Description

VALUE_CIE_CC_UMR Required by C3000 server for email routing

VALUE_PHX_BASE 30 LIC Allows up to 30 agents to be active and
logged in

IP Office:

ADI license Description

CTI Pro License Enabled third-part TAPI license

VMPro Recording Administrators Enables Contact Recorder

Avaya IP Endpoint License For CHAP connection

Also requires IP Office Preferred Edition.

IP Office Contact Center Base 100 bundle
IP Office Contact Center:

 Note:
IP 500 V2 does not support the IP Office Contact Center Base 100 bundle.

PLDS license Description

VALUE_CIE_PX_IPO (1) Single PBX connection — IP Office

VALUE_CIE_IVR_CON (1) 1 CHAP port

VALUE_CIE_IVR_PORT (Channels 90) 90 channels (maximum for 32–bit CHAP)

VALUE_CIE_CC_CLIP 10000 addresses

VALUE_CIE_CC_TEAMLEADER (1) Enables supervisor application in UI for
preconfigured monitors and reports

VALUE_CIE_CC_SERVUSER (2) 2 concurrent service users needed for
configuration

VALUE_PHX_BASE 100 LIC Allows up to 100 agents to be active and
logged in

VALUE_CIE_CC_UMR Required by C3000 server for email routing

IP Office:

 Note:
Use IP Office Manager for Server Edition to install the license for IP Office Server Edition
and use IP Office Manager to install the licenses for IP 500 V2.

ADI license Description

CTI Pro License Enabled third-part TAPI license

Packaging and order codes
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ADI license Description

VMPro Recording Administrators Enables Contact Recorder

Avaya IP Endpoint License For CHAP connection

IP Office Contact Center 1 voice agent license with skills based routing and call
bundle
IP Office Contact Center:

PLDS license Description

VALUE_CIE_CC_USER_VOICE 1 license for each logged in telephony agent

VALUE_CIE_CC_MONTELUSER Extended voice features, 1 license for each
logged in telephony agent

IP Office:

ADI license Description

Preferred Edition Additional VoiceMail Ports Needed for 100% call recording

Also requires IP Office Preferred Edition.

IP Office Contact Center 1 multichannel agent license with email, chat and
outbound campaign bundle
IP Office Contact Center:

PLDS license Description

VALUE_CIE_CC_USER_CHAT 1 license for each logged in chat agent

VALUE_CIE_CC_USER_NONVOICE 1 license for each logged in email agent

VALUE_CIE_CC_TEXTMODULES 1 license for each agent for email textblocks

IP Office: None.

IP Office Contact Center 1 supervisor license bundle
This bundle includes the licenses in bundles 306495 and 306496 plus the following license:

IP Office Contact Center:

PLDS license Description

VALUE_CIE_CC_SUPERVISOR 1 license for supervisor functions and
configuring monitors and reports

VALUE_CIE_CC_TEAMLEADER 1 licence for using pre-configured realtime
and reports

IP Office: None.

Packaging and order codes
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IP Office Contact Center Base 30 to Base 100 migration bundle

PLDS license Description

VALUE_PHX_BASE 100 LIC Allows up to 100 agents to be active and
logged in

Packaging and order codes
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Initial setup and connectivity

Software installation checklist

# Task Description Notes

1 Install the Microsoft®
Windows operating
system.

Microsoft® Windows Server 2008
R2 SP1, or Windows Server 2012
R2

2 Copy the installation
files from the DVD.

Copy from IPOCC-DVD (.iso) the
complete folder Install_Sybase to
local folder (e.g. c:\install) on
IPOCC server.

3 Install Sybase® ASE. Set the system administrator
password.

4 Install Microsoft®
Windows TAPI.

Enter switch IP address and
password.

5 Install IP Office
Contact Center

After installing the server
components of IPOCC, import the
data using Dataimport.exe

Related topics:
Installing Microsoft Windows Server on page 11
Installing Sybase Adaptive Server Enterprise on page 13
Installing and configuring Microsoft® Windows TAPI on page 14
Installing IP Office Contact Center on page 15

Installing Microsoft Windows Server
Procedure

1. Disable Power Management functions.

February 2014     11



2. Activate daylight savings time when setting the system time to the local time
zone.

3. Use TCP/IP as the network protocol.

4. Define the computer name.
Only use digits and letters for the computer name. Do not use the underscore
character. Begin the name with a letter. The name can consist of up to 30
characters.

5. Do not activate SNMP.

6. Enable error reporting unless you are setting up a test system. If you are setting up
a test system, complete the following steps:

a. On the Control Panel, click System.
b. On the Advanced tab, click Error Reporting.
c. Select Disable error reporting.
d. Click OK.

7. Set up a permanent IP address.
IP Office Contact Center works only with one IP address. IP Office Contact Center
does not support multiple IP addresses on the same NIC.

8. Create a system user and password.

a. Grant the user administration privileges to start services.
You must also grant the user the rights to add scheduled tasks. The user needs
this rights to install the Sybase server.

b. For security reasons, do not use the same username and password for other
computers on the network.

9. Ensure that the service Windows firewall is functional.

 Note:
If you need to use a firewall, configure the firewall settings using the appropriate
ports. See Port assignments.

10. In the Power Options Properties dialog box, on the Power Schemes tab, set the
following settings:

a. Set Turn off hard disks to Never.
b. Set System standby to Never.

To add the server to the list of trusted sites go to Internet Explorer > Internet
Options > Security > Trusted sites: http://<hostname>

Software installation checklist
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Installing Sybase Adaptive Server Enterprise
Before you begin

• Copy the complete folder Install_Sybase on your computer from the IPOCC-DVD
or .iso.

 Important:
Do not change the name of the Install_Sybase folder.

• Log in as the system administrator.

Procedure

1. Execute the SybaseDB.exe file.
The system displays the Sybase ASE Installer dialog box.

2. Select the drive for the database server.

a. In the SQL server name field, accept the default setting.
b. In the Password for user sa field, type the new password for the system

administrator (sa) account.
The password must be a combination of numbers and letters and must be at
least eight characters long.

c. In the Confirm password field, type the new password again.
d. Do not change the default values under Page size and Hardware

resources.

Software installation checklist
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3. Click Install.
The system installs Sybase ASE in about 20 minutes. The system displays the
Installation successfully finished
message.

4. Click OK.

5. Restart the server.

Installing and configuring Microsoft® Windows TAPI
Procedure

1. Navigate to the TAPI installation executable on the server.
Typically, it is located at \Server\IPO TAPI\tapiSetup.exe

2. Right-click the file and click Run as administrator from the pop-up menu.
The system displays Select a User Name.

 Note:
The system displays the default User Name and User Password.

a. Click Next.
The system displays the TAPI2 — InstallShield Wizard.

b. Click Next.
The system displays the Select Networked Telephone System.

c. Select the IP Office control unit.
The system displays the Select a User Name window, with the default User
Name and User Password.

d. Click Next.
The system displays the Ready to Install the Program window.

e. Click Install.
The system prompts you to restart the system.

f. Click Yes.
The system restarts and displays the Resuming the InstallShield Wizard for
TAPI2 .

g. Click Next.
The system displays the InstallShield Wizard Completed.

h. Click Finish.

3. Click Start > Control Panel and select Phones and Modem.

4. Select My Location and click Edit.

Software installation checklist
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5. In the Edit Location dialog box, type the country and area code for the customer
site and click OK.

6. In the Phone and Modem dialog box, click Advanced.

7. Select Avaya IPO TAPI2 Service Provider and click Configure

8. In the Avaya TAPI2 configuration dialog box, enter the following settings:

a. In the Switch IP Address field, type the IP address of the IP Office server.
b. In the Switch Password field, type the password of the IP Office server.

The default password of the IP Office server is password. If you have changed
the default password of the IP Office server, please type the new password that
you typed in Security Settings > System > Unsecured Interfaces > System
Password.

c. Click OK.
d. Click Close.

Installing IP Office Contact Center
About this task

 Note:
The system requires 26 GB of disk space to perform a complete install. All databases are
automatically set to Automatic Expansion, so the databases of IP Office Contact Center can
expand in case the system reaches the initial configured database size.

Procedure

1. Install vcredist_x86_2008.exe and vcredist_x86_2010.exe .
Typically, it is located in Server\IP Office Contact Center of the install
DVD.

2. Navigate to the IP Office Contact Center setup wizard on the server.
Typically, it is located in Server\IP Office Contact Center of the install
DVD.

3. Double click the SetupWizard.exe file.
The system displays the Avaya IP Office Contact Center — Setup Wizard dialog
box.

4. Click Complete.
The system displays the Settings for Avaya IP Office Contact Center installation
dialog box.

Software installation checklist
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5. Type the sa password.
Type the password that you set for sa user when installing the Sybase server.
The system displays the Network Adapter IP address of the server you are
currently using.

6. Click Install.
The system displays the list of components installed.

Software installation checklist

16     February 2014



7. Click Finished.

8. Restart the server.
After the system restarts, Watchdog configuration runs automatically.

Next steps
Select Start >Programs > Avaya IP Office Contact Center > Trace System > TT Display
and verify that all the all components are running.

Software installation checklist
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 Note:
Unless you install the licenses, the component SMTPConnector for Runlevel 14 and IVR
services stop automatically and turns red in TTDisplay and the Watchdog restarts the
SMTPConnector for Runlevel 14 and IVR services.

Installing licenses
Before you begin

• Obtain the license file from the Avaya Product Licensing and Delivery System (PLDS)
website at https://plds.avaya.com.

About this task
If you experience problems while installing the license file, see the License file installation
errors section in Administering Avaya WebLM (stand-alone).

Installing licenses
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Procedure

1. Open a browser on IPOCC Server and type https://<hostname>:8443/
WebLM connect to WebLM.

2. In the login page do the following:

• In the User Name field, type admin.

• In the Password field, type weblmadmin.

The password is case sensitive.
If you are logging into WebLM for the first time, the system prompts you to change
the password.
Use the same password that you set as Sybase sa password.

3. In the left navigation pane, click Install license.

4. On the Install license page, enter the license file path. You can also click Browse
to select the license file.

5. Click Install to install the license file. WebLM displays a message upon successful
installation of the license file. The installation of the license file can fail for various
reasons, such as:

• WebLM finds an invalid digital signature on the license file. If you get such an
error, request PLDS to redeliver the license file.

• The current capacity use exceeds the capacity in the installed license.

Next steps
Restart the IPOCC watchdog service.

Installing licenses
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Configuration

Component configuration checklist

# Task Description Notes

1 Import configuration
data file.

Import the
DataImport.exe
file.

Activate the Task Flow
editor

2 Configure IP Office
for telephony.

Import the
Configuration.c
sv file.
General system
settings
SIP extensions

Related topics:
Importing the IP Office Contact Center configuration data file on page 20

Importing the IP Office Contact Center configuration data file
Before you begin

1. Complete all the steps in Using the Avaya IP Office Contact Center Configuration
Worksheet on page 5.

2.
 Important:

Back up the cc and c3k databases. For more information, see Backing up the
database section of Deploying IP Office Contact Center guide.

Procedure

1. Copy the DataImport.exe file to any folder on the computer where the database
is installed.

2. Double click DataImport.exe.
The system displays the CCImportJobber dialog box.

Component configuration checklist
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3. In the DB User field, type sa.

4. In the Password filed, type the password you set for sa user.

5. Click Import Data.

6. Click Finish.

7. Restart the IPOCC server after you import.

Next steps
Activate the task flow editor.

Related topics:
Activating task flow editor on page 21

Activating task flow editor

Before you begin
Select Start > Programs> Avaya IP Office Contact Center > Trace System > TT Display
and verify that all the processes are running.

About this task
Procedure

1. Select Start > Programs> Avaya IP Office Contact Center > User Interface.

Component configuration checklist
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The system displays the Avaya IP Office Contact Center log in page.

2. Type Administrator in the Username field.

3. Type the password in the Password field.
The default password is Administrator.

4. Click Login.
The system displays IP Office Contact Center window.

5. Select Go To > Task Flow Editor.

6. Click the Open icon.
The system displays Open task flow set.

7. Select Import TF-Set.

8. Click OK.
The system displays the Password dialog box. You do not have to type the
password.

9. Click OK.

10. Click Activate.
The system displays Task Flow set successfully activated message.

11. Click OK.

12. In the Task flow set menu, click Close.

13. In the Task flow set menu, click Default task flow set.
The system displays the Use default task flow set dialog box.

14. Select Import TF-set and click OK
The system displays the Password dialog box. You do not have to type the
password.

15. Click OK.

Component configuration checklist
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IP Office server configuration checklist
Configuring IP Office
Use IP Office Manager to complete the following configuration tasks.

# Task Description Notes

1 Import the data file. Configuration.csv
2 Configure general

system settings.
VoIP
SIP Register
DNS

Related topics:
Importing the IP Office configuration data file on page 23
Configuring IP Office on page 24

Importing the IP Office configuration data file
Before you begin

Complete all the steps in Using the Avaya IP Office Contact Center Configuration
Worksheet on page 5.

 Note:
The short codes targeted for each Topic that you create must exist and be the same for the
Server Edition Secondary server and Server Edition Expansion System .

Procedure

1. Copy the configuration.csv file to any folder on the computer where you have
installed IP Office Manager.

2. Start IP Office Manager, and select the IP Office server.

3. Click File > Import/Export > Import.

4. Select Configuration .

5. Navigate to the location where you copied the configuration.csv file and select
it.

6. Click OK to import the file.

IP Office server configuration checklist
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Next steps
Complete the steps in Configuring IP Office on page 24.

Configuring IP Office
Before you begin
Complete all the steps in Importing the IP Office configuration data file on page 23.

 Important:
To avoid restarting the TAPI service every time you add a user in IP Office who is also an
IPOCC user, Avaya recommends you to create a pool of users to be used by IPOCC
Agents. When you configure an Agent in IPOCC, the Agent can login as a user that you
have already reserved.

 Note:
After you create a pool of users you must restart the TAPI service on the IPOCC server, so
that the users are available for the IPOCC server. When the system has exhausted all the
users in the pool that you created, you can create a new pool of users and restart the TAPI
service.

About this task
For more information about the configuration settings, see the IP Office Manager document.

Procedure

1. Select System > LAN 1.

2. In the VoIP tab, set the following values and settings:

a. Select H323 Gatekeeper Enable.
b. Select SIP Trunks Enable.
c. Select SIP Registrar Enable.

3. In the SIP Registrar tab, set the following values and settings:

a. In the Domain Name field, enter server domain name. For example: st4–
ipo1.qas. This is the local SIP registrar domain name through which SIP
endpoints register with the IP Office system.
The domain name must be the same domain name that you typed in Avaya IP
Office Configuration Worksheet.

b. In Layer 4 Protocol, select UDP, TCP, and TLS. Use default ports.
c. Click OK.

4. Select Extension.

IP Office server configuration checklist
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Select the SIP extension that you created for the CHAP connection to the IPOCC
server, then click VoIP tab.

5. Select Custom from the Codec Selection drop-down list.

6. List only G.711 ALAW 64K and G.711 ULAW 64k under Selected.
The system functions only if you list both G.711 ALAW 64K and G.711 ULAW
64k under Selected.
Move the other codecs under Unused list.

7. Click OK.

8. To add the ADI licenses do the following:

a. Select License .
b. Click Add.
c. Type the license key in the License Key field.

The system displays the type of license, the status of the license, instances,
and the date of expiry.

9. Click OK.

10. To send the configuration to the IP Office system, select File > Save
Configuration.

11. Restart the IP Office system.

12. Restart the IP Office Contact Center server.

Installing User Interface on an agent workstation

# Task Notes

1 Install User
Interface on an
agent
workstation.

Double click Contact Center User Interface.msi in folder the
\Client and install User Interface of the install
DVD.

2 Login as an
Agent.

1. Go to Start > Avaya IP Office Contact Center > User
Interface, to start IPOCC User Interface.

2. In the Username field, type Agent1 .
You can also type Agent2 or Agent3 or the name of the
agent that you have set in the IPOCC configuration
worksheet.

3. In the Password field, type cc123456

Installing User Interface on an agent workstation
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# Task Notes

4. Select your extension in the Telephone Extension drop-
down list.

5. Click Login

3 Testing as a
supervisor.

1. Go to Start > Avaya IP Office Contact Center > User
Interface, to start IPOCC User Interface.

2. In the Username field, type Administrator .

3. In the Password field, Administrator

4. Click Login

To observe AG and Topic states, go to Supervision > Realtime
Information > Predefined.

• Double click Realtime Information file AG_Default and select
the Agent Group that thelogged in agent has been assigned.

• Double click Realtime Information file Topic_Default and
select the Topic for which you want to make test calls.

4 Make test calls Dial into a topic.

• If the logged in agent is free and signed on an agent group, the
system distributes the call to the agent and in the Realtime
information AG_Default, the system displays agent as
available.

• If the agent is not free or not signed on, the system plays a music
and the caller listens to the music. In Realtime information
Topic_Default the call is notified.

Installing User Interface on an agent workstation
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Troubleshooting

During the deployment for all troubleshooting information see, the Troubleshooting section of the
Deploying IP Office Contact Center guide.
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