Using Avaya Proactive Contact Supervisor

Release 5.0

December 2011
Notice
While reasonable efforts were made to ensure that the information in this document was complete and accurate at the time of printing, Avaya Inc. can assume no liability for any errors. Changes and corrections to the information in this document might be incorporated in future releases.

Documentation disclaimer
Avaya Inc. is not responsible for any modifications, additions, or deletions to the original published version of this documentation unless such modifications, additions, or deletions were performed by Avaya. Customer and/or End User agree to indemnify and hold harmless Avaya, Avaya's agents, servants and employees against all claims, lawsuits, demands and judgments arising out of, or in connection with, subsequent modifications, additions or deletions to this documentation to the extent made by the Customer or End User.

Link disclaimer
Avaya Inc. is not responsible for the contents or reliability of any linked Web sites referenced elsewhere within this documentation, and Avaya does not necessarily endorse the products, services, or information described or offered within them. We cannot guarantee that these links will work all the time and we have no control over the availability of the linked pages.

Warranty
Avaya Inc. provides a limited warranty on this product. Refer to your sales agreement to establish the terms of the limited warranty. In addition, Avaya's standard warranty language, as well as information regarding support for this product, while under warranty, is available through the Avaya Support Web site:

http://www.avaya.com/support

License
USE OR INSTALLATION OF THE PRODUCT INDICATES THE END USER'S ACCEPTANCE OF THE TERMS SET FORTH HEREIN AND THE GENERAL LICENSE TERMS AVAILABLE ON THE AVAYA WEB SITE.

http://support.avaya.com/LicenseInfo/"GENERAL LICENSE TERMS). IF YOU DO NOT WISH TO BE BOUND BY THESE TERMS, YOU MUST RETURN THE PRODUCT(S) TO THE POINT OF PURCHASE WITHIN TEN (10) DAYS OF DELIVERY FOR A REFUND OR CREDIT.

Avaya grants End User a license within the scope of the license types described below. The applicable number of licenses and units of capacity for which the license is granted will be one (1), unless a different number of licenses or units of capacity is specified in the Documentation or other materials available to End User. "Designated Processor" means a single stand-alone computing device. "Server" means a Designated Processor that hosts a software application to be accessed by multiple users. "Software" means the computer programs in object code, originally licensed by Avaya and ultimately utilized by End User, whether as stand-alone Products or pre-installed on Hardware. "Hardware" means the standard hardware Products, originally sold by Avaya and ultimately utilized by End User.

License type(s)
Copyright
Except where expressly stated otherwise, the Product is protected by copyright and other laws respecting proprietary rights. Unauthorized reproduction, transfer, and or use can be a criminal, as well as a civil, offense under the applicable law.

Third-party components
Certain software programs or portions thereof included in the Product may contain software distributed under third party agreements ("Third Party Components"), which may contain terms that expand or limit rights to use certain portions of the Product ("Third Party Terms"). Information identifying Third Party Components and the Third Party Terms that apply to them is available on the Avaya Support Web site:

http://support.avaya.com/ThirdPartyLicense/

Preventing toll fraud
"Toll fraud" is the unauthorized use of your telecommunications system by an unauthorized party (for example, a person who is not a corporate employee, agent, subcontractor, or is not working on your company's behalf). Be aware that there can be a risk of toll fraud associated with your system and that, if toll fraud occurs, it can result in substantial additional charges for your telecommunications services.

Avaya fraud intervention
If you suspect that you are being victimized by toll fraud and you need technical assistance or support, call Technical Service Center Toll Fraud Intervention Hotline at +1-800-643-2353 for the United States and Canada. For additional support telephone numbers, see the Avaya Support Web site:

http://www.avaya.com/support

Trademarks
Avaya and the Avaya logo are either registered trademarks or trademarks of Avaya Inc. in the United States of America and/or other jurisdictions. All other trademarks are the property of their respective owners.

Downloading documents
For the most current versions of documentation, see the Avaya Support Web site:

http://www.avaya.com/support

Avaya support
Avaya provides a telephone number for you to use to report problems or to ask questions about your product. The support telephone number is 1-800-242-2121 in the United States. For additional support telephone numbers, see the Avaya Support Web site:

http://www.avaya.com/support
# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preface</td>
<td>19</td>
</tr>
<tr>
<td>Purpose</td>
<td>19</td>
</tr>
<tr>
<td>Audience</td>
<td>19</td>
</tr>
<tr>
<td>Related documents</td>
<td>19</td>
</tr>
<tr>
<td>Chapter 1: Introduction</td>
<td>21</td>
</tr>
<tr>
<td>What is new in this release</td>
<td>21</td>
</tr>
<tr>
<td>Real-time record selection support</td>
<td>22</td>
</tr>
<tr>
<td>Automatic record selection for job linking</td>
<td>22</td>
</tr>
<tr>
<td>Unit Work List job compatibility with infinite lists</td>
<td>22</td>
</tr>
<tr>
<td>Multi-Unit selection for Unit Work List jobs</td>
<td>22</td>
</tr>
<tr>
<td>Virtual job opt-out option</td>
<td>23</td>
</tr>
<tr>
<td>Running real-time scheduling</td>
<td>23</td>
</tr>
<tr>
<td>Multiple day selections with hourly recurrence in Schedule</td>
<td>23</td>
</tr>
<tr>
<td>Extend Agent Joblist functionality to Agent API and Proactive Contact Agent</td>
<td>24</td>
</tr>
<tr>
<td>Escape General Recall</td>
<td>24</td>
</tr>
<tr>
<td>Strengthened password support</td>
<td>24</td>
</tr>
<tr>
<td>Simultaneous Campaign Alert</td>
<td>24</td>
</tr>
<tr>
<td>OFCOM enhancements</td>
<td>24</td>
</tr>
<tr>
<td>Avaya Proactive Contact environment</td>
<td>25</td>
</tr>
<tr>
<td>Dialer functions</td>
<td>25</td>
</tr>
<tr>
<td>Multiple dialers (POD configuration)</td>
<td>26</td>
</tr>
<tr>
<td>Pods</td>
<td>26</td>
</tr>
<tr>
<td>Calling lists</td>
<td>27</td>
</tr>
<tr>
<td>Role-Based Authorization for Administrators</td>
<td>28</td>
</tr>
<tr>
<td>Secured Agent</td>
<td>28</td>
</tr>
<tr>
<td>Licensing</td>
<td>28</td>
</tr>
<tr>
<td>License Server Setup</td>
<td>29</td>
</tr>
<tr>
<td>Dialer Configuration</td>
<td>30</td>
</tr>
<tr>
<td>Grace Period</td>
<td>30</td>
</tr>
<tr>
<td>Start Enforcer</td>
<td>30</td>
</tr>
<tr>
<td>Stop Enforcer</td>
<td>30</td>
</tr>
<tr>
<td>Avaya Proactive Contact users</td>
<td>31</td>
</tr>
<tr>
<td>Types of users</td>
<td>31</td>
</tr>
<tr>
<td>Logins and permissions</td>
<td>32</td>
</tr>
<tr>
<td>Log in to Supervisor</td>
<td>34</td>
</tr>
<tr>
<td>Chapter 2: Role Editor</td>
<td>37</td>
</tr>
<tr>
<td>What is a Role</td>
<td>37</td>
</tr>
<tr>
<td>Types of Permissions</td>
<td>38</td>
</tr>
</tbody>
</table>
## Contents

- Operations Permissions .......................................................... 39
- Access Permissions .................................................................. 39
- Predefined Roles ...................................................................... 39

### Chapter 3: Permissions in Role Editor
- Types of Application Permissions ............................................. 41

### Chapter 4: Using Role Editor
- Toolbar Buttons ....................................................................... 44
- Log in to Role Editor .................................................................. 44
- Create a New Role ..................................................................... 45
- Rename a Role .......................................................................... 45
- Merging Roles .......................................................................... 46
- Editing a Merged role ................................................................. 47
- Assign Role(s) to the User .......................................................... 48
- Assign User(s) to the Role ........................................................... 49
- Deleting a role .......................................................................... 50
- Refresh Role Editor data ............................................................. 50
- Reports ..................................................................................... 50
  - Save Reports Data as HTML ..................................................... 51
- Display Online Help ................................................................. 51

### Chapter 5: Scenarios for Role Editor
- Scenario 1: Create a role for Manager to perform a specific task 53
- Scenario 2: Create Identical Role as Administrator ............... 55
- Scenario 3: Assign a User to a Role ............................................ 55
- Scenario 4: Test the Role Permissions ...................................... 56
- Scenario 5: Create a Role with no Permissions ....................... 57
- Scenario 6: Create a Role by Merging two or more Roles .......... 57
- Scenario 7: Assign User to a Merged Role .............................. 58
- Scenario 8: Edit a Merged Role ................................................. 59
- Scenario 9: Rename a Role ....................................................... 60
- Scenario 10: Delete a Role ....................................................... 60
- Scenario 11: Edit a Role Permission ......................................... 61
- Scenario 12: Assign a Role to Users ....................................... 61

### Chapter 6: Understanding Health Manager
- Overall Health Status ............................................................... 63
- Dialer Services ......................................................................... 63
- Mid-Tier Services ..................................................................... 65
### Contents

**System Status** ................................................................. 66

**Chapter 7: Using Health Manager** ...................................... 69
- Log In to Health Manager ................................................... 69
- Change Display Options ...................................................... 69
- Refresh Health Manager Data ............................................... 70
- Sort the List of Dialers, Services, or Events .......................... 71
- View Overall System Health for All Dialers ........................... 71
- View System Health for One Dialer ...................................... 71
  - View Dialer Services .................................................... 72
  - View Mid-Tier Services .................................................. 75
  - View System Status ...................................................... 78
- View System Activity Events .............................................. 82
- Subscribe to Activity Events ............................................. 82
- Set Alerts ........................................................................... 83
- Save Data as HTML ............................................................. 84

**Chapter 8: Maintaining Health Manager** ............................... 89
- Configure Health Manager ................................................... 89
- License Configurator ........................................................... 90
- Start and Stop the Health Bridge Service ............................... 90
- Set Threshold Parameters for System Status ........................... 92

**Chapter 9: Customize Editor** ............................................. 93
- Understanding Editor .......................................................... 93
  - Editor window description ............................................... 93
  - Editor screen layout and usage ........................................... 93
- Navigate among the Tool applications .................................... 95
- Move within Contact Management ........................................ 95
- View icons in the button group ........................................... 96
- Refresh a view ..................................................................... 96

**Chapter 10: Understanding staging** ..................................... 97
- Overview ............................................................................. 97
- Types of configuration files .................................................. 98
  - Primary configuration file ............................................... 98
  - Secondary configuration file ............................................. 98
- Stages of configuration files ................................................ 101
- Basic rules for working with configuration files ....................... 103
## Contents

Backup and restore of configuration files .......................... 107

Chapter 11: Understanding Editor settings ....................... 109
   Enable or disable multi-dialer commands ....................... 109
   Save options ........................................... 110
   Set refresh options ..................................... 110

Chapter 12: Calling Lists ........................................ 113
   Creating a calling list ................................... 113
      Create a new calling list ............................... 114
      Import data to create Download Dictionary ............. 114
   Download From Host ...................................... 116
   Download Dictionary ..................................... 120
   Download Map ............................................ 121
   Import Download Dictionary to Calling List Dictionary .... 124
   Processing ................................................ 124

   Calling list features ..................................... 128
      Postupdate .............................................. 128
      Infinite Jobs .......................................... 129
      Batch Campaign Update .................................. 130
      Real Time Campaign Update .............................. 131
      Native Voice and Data Transfer (NVDT) .................. 131
      Sales Verification ...................................... 132

   Synchronizing calling list data with host .................... 133
      Data Export ............................................. 133
      Upload To Host ......................................... 134
      Upload Dictionary ....................................... 137
      Upload Map ............................................. 138
      Select Records ......................................... 139

   Modifying an existing calling list ............................ 140
      Calling List Reports ..................................... 141
      Status Reports ......................................... 141

   Tools for using calling lists ................................ 141
      Verify .................................................. 141
      Convert Sample ......................................... 142
      Make active ............................................ 142

   Do not Call Groups (DNC) .................................... 143
      View a Do not Call Group ............................... 143
      Prerequisites for creating Do Not Call group ............ 143
      Create a new Do Not Call Group ......................... 144
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Verify a message</td>
<td>166</td>
</tr>
<tr>
<td>Maintaining messages</td>
<td>166</td>
</tr>
<tr>
<td>Remove a message</td>
<td>167</td>
</tr>
<tr>
<td>Rename a message folder</td>
<td>167</td>
</tr>
<tr>
<td>Remove a folder</td>
<td>168</td>
</tr>
<tr>
<td>Understanding scripts</td>
<td>168</td>
</tr>
<tr>
<td>Types of scripts</td>
<td>168</td>
</tr>
<tr>
<td>Script actions</td>
<td>169</td>
</tr>
<tr>
<td>Script examples</td>
<td>170</td>
</tr>
<tr>
<td>Using scripts</td>
<td>171</td>
</tr>
<tr>
<td>Scripts pane</td>
<td>171</td>
</tr>
<tr>
<td>Start Scripts</td>
<td>172</td>
</tr>
<tr>
<td>Add or update scripts</td>
<td>172</td>
</tr>
<tr>
<td>Define a script</td>
<td>173</td>
</tr>
<tr>
<td>Telephony Scripts</td>
<td>174</td>
</tr>
<tr>
<td>Maintaining scripts</td>
<td>174</td>
</tr>
<tr>
<td>Change a script action</td>
<td>175</td>
</tr>
<tr>
<td>Remove a script action</td>
<td>175</td>
</tr>
<tr>
<td>Change a script</td>
<td>175</td>
</tr>
<tr>
<td>Remove a script</td>
<td>176</td>
</tr>
<tr>
<td>Understanding Messages and Scripts dialog boxes</td>
<td>176</td>
</tr>
<tr>
<td>Delete dialog box</td>
<td>176</td>
</tr>
<tr>
<td>Rename Folder dialog box</td>
<td>177</td>
</tr>
<tr>
<td>Chapter 16: Phone strategy</td>
<td>179</td>
</tr>
<tr>
<td>Understanding phone strategy</td>
<td>179</td>
</tr>
<tr>
<td>Phone strategy preparation</td>
<td>179</td>
</tr>
<tr>
<td>Phone strategy settings</td>
<td>180</td>
</tr>
<tr>
<td>Using phone strategies</td>
<td>183</td>
</tr>
<tr>
<td>Create a phone strategy</td>
<td>183</td>
</tr>
<tr>
<td>Copy a phone strategy</td>
<td>185</td>
</tr>
<tr>
<td>View phone strategy settings</td>
<td>185</td>
</tr>
<tr>
<td>Edit a phone strategy</td>
<td>185</td>
</tr>
<tr>
<td>Delete a phone strategy</td>
<td>186</td>
</tr>
<tr>
<td>Maintaining phone strategies</td>
<td>186</td>
</tr>
<tr>
<td>List all phone strategies on a selected dialer</td>
<td>187</td>
</tr>
<tr>
<td>Append a phone strategy row</td>
<td>187</td>
</tr>
<tr>
<td>Insert an initial phone in a phone strategy</td>
<td>187</td>
</tr>
<tr>
<td>Delete a row in a phone strategy</td>
<td>188</td>
</tr>
<tr>
<td>Select all rows in a phone strategy</td>
<td>188</td>
</tr>
</tbody>
</table>
Unselect all rows in a phone strategy .............................................. 188

Chapter 17: Record selection .......................................................... 191
  Understanding record selection ...................................................... 191
  Specify time zones. ................................................................. 192
  Specify completion codes ........................................................ 192
  Specify goals. ............................................................................ 192
  Record selection use ............................................................... 192
  Understand the Selections settings .............................................. 193
  Understand the Selection Reports settings .................................. 195
  Using a record selection ............................................................ 196
    Open and view a record selection .............................................. 197
    Complete the Detail tab ......................................................... 197
    Complete the Records tab ...................................................... 198
    Complete the Time Zones tab ................................................ 198
    Complete the Results tab ...................................................... 198
    Complete the Recalls tab (optional) ....................................... 199
    Complete the Sort tab (optional) ........................................... 200
    Create a record selection ...................................................... 200
    Save a record selection ........................................................ 201
    Edit a record selection .......................................................... 201
    Delete a record selection ....................................................... 201
    Verify a record selection ........................................................ 202
    Run a record selection .......................................................... 202
    Save and print a Record Selections report ............................... 202
  Maintaining a record selection .................................................. 203
    Copy a record selection .......................................................... 203
    List all record selections on a selected dialer ......................... 204
    View selection reports .......................................................... 204
    View record selection settings .............................................. 204
    Append record selection settings ......................................... 205
    Insert a row in a record selection ......................................... 205
    Delete a row in a record selection ......................................... 205
    Move a row up in a record selection ..................................... 206
    Move a row down in a record selection .................................. 206
    Select all rows in a record selection ..................................... 207
    Unselect all rows in a record selection .................................. 207
    Record Selection for Multiple Dialers ...................................... 207

Chapter 18: Jobs ........................................................................... 209
  Understanding jobs ..................................................................... 209
## Contents

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Job types</td>
<td>209</td>
</tr>
<tr>
<td>Outbound jobs</td>
<td>210</td>
</tr>
<tr>
<td>Maximum number of jobs allowed</td>
<td>211</td>
</tr>
<tr>
<td>Call pacing</td>
<td>212</td>
</tr>
<tr>
<td><strong>Understanding job settings</strong></td>
<td>214</td>
</tr>
<tr>
<td>Basic settings</td>
<td>215</td>
</tr>
<tr>
<td>Call pacing settings</td>
<td>217</td>
</tr>
<tr>
<td>Files settings</td>
<td>220</td>
</tr>
<tr>
<td>Job Type settings</td>
<td>221</td>
</tr>
<tr>
<td>Inbound Processing settings</td>
<td>222</td>
</tr>
<tr>
<td>Labels settings</td>
<td>223</td>
</tr>
<tr>
<td>Managed Dialing settings</td>
<td>224</td>
</tr>
<tr>
<td>Outbound Processing settings</td>
<td>225</td>
</tr>
<tr>
<td>Opt-out settings</td>
<td>226</td>
</tr>
<tr>
<td>Post Processing settings</td>
<td>228</td>
</tr>
<tr>
<td>Quota Settings</td>
<td>229</td>
</tr>
<tr>
<td>Recall settings</td>
<td>229</td>
</tr>
<tr>
<td>Service Level settings</td>
<td>230</td>
</tr>
<tr>
<td>Wait Queues settings</td>
<td>231</td>
</tr>
<tr>
<td>Interactive Voice Response settings</td>
<td>231</td>
</tr>
<tr>
<td><strong>Using jobs</strong></td>
<td>232</td>
</tr>
<tr>
<td>Create a job</td>
<td>232</td>
</tr>
<tr>
<td>View job settings</td>
<td>233</td>
</tr>
<tr>
<td>Save a job</td>
<td>233</td>
</tr>
<tr>
<td>Save a job as another name or on a different dialer</td>
<td>233</td>
</tr>
<tr>
<td>Start a job on one or more dialers</td>
<td>234</td>
</tr>
<tr>
<td>Start multiple jobs on currently selected dialer</td>
<td>234</td>
</tr>
<tr>
<td>Share a List or a Job</td>
<td>235</td>
</tr>
<tr>
<td><strong>Office of Communication (OFCOM)</strong></td>
<td>236</td>
</tr>
<tr>
<td>Create a script for OFCOM compliant jobs</td>
<td>236</td>
</tr>
<tr>
<td>Enable OFCOM for a job</td>
<td>237</td>
</tr>
<tr>
<td><strong>Maintaining jobs</strong></td>
<td>238</td>
</tr>
<tr>
<td>Copy a job</td>
<td>238</td>
</tr>
<tr>
<td>Edit a job</td>
<td>238</td>
</tr>
<tr>
<td>Verify a job on one or more dialers</td>
<td>238</td>
</tr>
<tr>
<td>Verify multiple jobs on the currently selected dialer</td>
<td>239</td>
</tr>
<tr>
<td>Delete a job on one or more dialers</td>
<td>239</td>
</tr>
<tr>
<td>Delete multiple jobs on the currently selected dialer</td>
<td>239</td>
</tr>
<tr>
<td>List all jobs on a selected dialer</td>
<td>240</td>
</tr>
<tr>
<td>Understanding Editor system dialog boxes</td>
<td>240</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Set the view set</td>
<td>275</td>
</tr>
<tr>
<td>Set save on exit settings</td>
<td>275</td>
</tr>
<tr>
<td>Set alert monitoring</td>
<td>276</td>
</tr>
<tr>
<td>Chapter 23: Pattern matching rules</td>
<td>277</td>
</tr>
<tr>
<td>Understanding default pattern syntax</td>
<td>277</td>
</tr>
<tr>
<td>Using supported syntaxes</td>
<td>279</td>
</tr>
<tr>
<td>Chapter 24: Hierarchy Manager</td>
<td>289</td>
</tr>
<tr>
<td>Understanding Hierarchy Manager</td>
<td>289</td>
</tr>
<tr>
<td>Agent hierarchies</td>
<td>290</td>
</tr>
<tr>
<td>Job hierarchies</td>
<td>290</td>
</tr>
<tr>
<td>Dialer hierarchies</td>
<td>290</td>
</tr>
<tr>
<td>Using Hierarchy Manager</td>
<td>291</td>
</tr>
<tr>
<td>Start Hierarchy Manager</td>
<td>291</td>
</tr>
<tr>
<td>Create a hierarchy</td>
<td>291</td>
</tr>
<tr>
<td>Open a hierarchy to view or change</td>
<td>293</td>
</tr>
<tr>
<td>Add a level to a hierarchy</td>
<td>293</td>
</tr>
<tr>
<td>Add a data item to a hierarchy</td>
<td>293</td>
</tr>
<tr>
<td>Maintaining Hierarchy Manager</td>
<td>294</td>
</tr>
<tr>
<td>Move a level or item within a hierarchy</td>
<td>294</td>
</tr>
<tr>
<td>Rename a hierarchy level</td>
<td>295</td>
</tr>
<tr>
<td>Remove a level from a hierarchy</td>
<td>295</td>
</tr>
<tr>
<td>Remove a data item from a hierarchy</td>
<td>295</td>
</tr>
<tr>
<td>Rename a hierarchy</td>
<td>296</td>
</tr>
<tr>
<td>Delete a hierarchy</td>
<td>296</td>
</tr>
<tr>
<td>Chapter 25: Customize Monitor</td>
<td>297</td>
</tr>
<tr>
<td>Navigate among the Tool menu applications</td>
<td>297</td>
</tr>
<tr>
<td>Using a Monitor view</td>
<td>297</td>
</tr>
<tr>
<td>View icons in the button bar</td>
<td>298</td>
</tr>
<tr>
<td>Open a standard view</td>
<td>298</td>
</tr>
<tr>
<td>Open a view or view set from another location</td>
<td>298</td>
</tr>
<tr>
<td>Open a view about a specific agent</td>
<td>299</td>
</tr>
<tr>
<td>Customizing Monitor views</td>
<td>299</td>
</tr>
<tr>
<td>Create a custom view</td>
<td>299</td>
</tr>
<tr>
<td>Save current view</td>
<td>300</td>
</tr>
<tr>
<td>Save as a view set</td>
<td>300</td>
</tr>
<tr>
<td>Save view set with a new name</td>
<td>301</td>
</tr>
<tr>
<td>Managing custom views</td>
<td>301</td>
</tr>
</tbody>
</table>
Delete a view set .......................................................... 301
Add a view to the Custom button group ...................... 302
Refresh a view .............................................................. 302

Chapter 26: Monitor view controls ............................. 303
Understanding view controls ......................................... 303
View control toolbar .................................................... 304
Understand scope selectors examples .......................... 304
Using view controls ..................................................... 305
Filter data in a view ...................................................... 305
Set scope selectors ....................................................... 306
Select a time range ....................................................... 307
Select a hierarchy ......................................................... 307
Maintaining Monitor views .......................................... 308
Hide or show columns .................................................. 308
Select Table View or Graphical View ......................... 309
Save a view as HTML ................................................... 309

Chapter 27: Alerts ......................................................... 311
Understanding alerts .................................................... 311
Alerts uses ................................................................. 311
Alert examples ............................................................ 312
Alert settings .............................................................. 313
Using alerts ................................................................. 314
Create an alert ............................................................. 315
Edit an alert ............................................................... 316
Remove an alert .......................................................... 317
Sending e-mail Alert using Health Manager/Monitor Alerts option. ...................................................... 317
Maintaining alerts ......................................................... 318
Enable and disable alerts .............................................. 318
Check the status of each alert ..................................... 318
Understanding Alert dialog boxes ............................... 319
Alert Viewer dialog box .............................................. 319
Alert Editor, Alert Definition tab ................................. 320
Alert Editor, Scope tab ............................................... 320
Alert Editor, Notifications tab ..................................... 321

Chapter 28: Job control functions ............................... 323
Understanding job control functions .......................... 323
Using job control functions ......................................... 323
<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stop a job</td>
<td>324</td>
</tr>
<tr>
<td>Link to job</td>
<td>324</td>
</tr>
<tr>
<td>Set escape recall for a job.</td>
<td>325</td>
</tr>
<tr>
<td>Set automatic record selection trigger value for linked job</td>
<td>326</td>
</tr>
<tr>
<td>Set the minimum hit rate</td>
<td>326</td>
</tr>
<tr>
<td>Set the Expert Calling Ratio</td>
<td>326</td>
</tr>
<tr>
<td>Maintaining job control functions</td>
<td>327</td>
</tr>
<tr>
<td>Adjust Inbound settings</td>
<td>328</td>
</tr>
<tr>
<td>Modify record selection criteria in real-time</td>
<td>328</td>
</tr>
<tr>
<td>Reassign lines</td>
<td>330</td>
</tr>
<tr>
<td>Set a managed dialing job</td>
<td>330</td>
</tr>
<tr>
<td>Select and sort time zones</td>
<td>330</td>
</tr>
<tr>
<td>Set up single or multiple unit work lists</td>
<td>331</td>
</tr>
<tr>
<td>Set and modify a quota</td>
<td>332</td>
</tr>
<tr>
<td>Set the detection mode</td>
<td>333</td>
</tr>
<tr>
<td>Set the alternate initial phone</td>
<td>333</td>
</tr>
<tr>
<td>Set retries</td>
<td>334</td>
</tr>
<tr>
<td>Find a text string</td>
<td>334</td>
</tr>
<tr>
<td>Chapter 29: Agent control functions</td>
<td>335</td>
</tr>
<tr>
<td>Understanding agent control functions</td>
<td>335</td>
</tr>
<tr>
<td>Hierarchies</td>
<td>335</td>
</tr>
<tr>
<td>Using wildcard characters</td>
<td>336</td>
</tr>
<tr>
<td>Using agent control functions</td>
<td>336</td>
</tr>
<tr>
<td>Find an agent</td>
<td>337</td>
</tr>
<tr>
<td>Transfer an agent to another job</td>
<td>337</td>
</tr>
<tr>
<td>Send message to an agent</td>
<td>337</td>
</tr>
<tr>
<td>Monitor agent line</td>
<td>338</td>
</tr>
<tr>
<td>Remove an agent from a job</td>
<td>338</td>
</tr>
<tr>
<td>Show an agent view</td>
<td>339</td>
</tr>
<tr>
<td>Chapter 30: Understanding Monitor dialog boxes</td>
<td>341</td>
</tr>
<tr>
<td>View control dialog boxes</td>
<td>341</td>
</tr>
<tr>
<td>Options dialog box</td>
<td>341</td>
</tr>
<tr>
<td>Customize Status Bar dialog box</td>
<td>343</td>
</tr>
<tr>
<td>Find dialog box</td>
<td>343</td>
</tr>
<tr>
<td>Filter Data dialog box</td>
<td>344</td>
</tr>
<tr>
<td>Job control dialog boxes</td>
<td>344</td>
</tr>
<tr>
<td>Stop Job dialog box</td>
<td>345</td>
</tr>
<tr>
<td>Job Link dialog box</td>
<td>345</td>
</tr>
<tr>
<td>Escape Recall Job dialog box</td>
<td>345</td>
</tr>
<tr>
<td>Content</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Record Selection of Link Job dialog box</td>
<td>346</td>
</tr>
<tr>
<td>Minimum Hit Rate dialog box</td>
<td>346</td>
</tr>
<tr>
<td>Expert Calling Ratio dialog box</td>
<td>346</td>
</tr>
<tr>
<td>Inbound Settings dialog box</td>
<td>347</td>
</tr>
<tr>
<td>Managed Dialing dialog box</td>
<td>347</td>
</tr>
<tr>
<td>Time Zones dialog box</td>
<td>348</td>
</tr>
<tr>
<td>Unit Work Lists dialog box</td>
<td>349</td>
</tr>
<tr>
<td>Quota dialog box</td>
<td>349</td>
</tr>
<tr>
<td>Alternate Initial Phones dialog box</td>
<td>350</td>
</tr>
<tr>
<td>Detection Modes dialog box</td>
<td>350</td>
</tr>
<tr>
<td>Retry dialog box</td>
<td>351</td>
</tr>
<tr>
<td>Lines dialog box</td>
<td>351</td>
</tr>
<tr>
<td>Selection Records dialog box</td>
<td>352</td>
</tr>
<tr>
<td>Selection Results dialog box</td>
<td>352</td>
</tr>
<tr>
<td>Selection Sort dialog box</td>
<td>352</td>
</tr>
<tr>
<td>Agent control dialog boxes</td>
<td>352</td>
</tr>
<tr>
<td>Find Agent dialog box</td>
<td>353</td>
</tr>
<tr>
<td>Transfer Agent dialog box</td>
<td>354</td>
</tr>
<tr>
<td>Send Message dialog box</td>
<td>354</td>
</tr>
<tr>
<td>Monitor Agent dialog box</td>
<td>354</td>
</tr>
<tr>
<td>Chapter 31: Avaya Proactive Contact Analyst</td>
<td>355</td>
</tr>
<tr>
<td>Understanding Analyst</td>
<td>355</td>
</tr>
<tr>
<td>Using Analyst</td>
<td>356</td>
</tr>
<tr>
<td>Using the Analyst Toolbar</td>
<td>357</td>
</tr>
<tr>
<td>Creating a new report configuration</td>
<td>358</td>
</tr>
<tr>
<td>Deleting a report configuration</td>
<td>360</td>
</tr>
<tr>
<td>Changing a report configuration</td>
<td>360</td>
</tr>
<tr>
<td>Previewing a report</td>
<td>361</td>
</tr>
<tr>
<td>Printing a report</td>
<td>361</td>
</tr>
<tr>
<td>Exporting report data</td>
<td>362</td>
</tr>
<tr>
<td>Scheduling a report</td>
<td>363</td>
</tr>
<tr>
<td>Chapter 32: Analyst navigation and personalization</td>
<td>365</td>
</tr>
<tr>
<td>Window arrangement overview</td>
<td>365</td>
</tr>
<tr>
<td>Navigate among the Tool menu applications</td>
<td>366</td>
</tr>
<tr>
<td>Use large icons or small icons on the button bar</td>
<td>366</td>
</tr>
<tr>
<td>Chapter 33: Avaya Proactive Contact Analyst reports</td>
<td>367</td>
</tr>
<tr>
<td>Report categories</td>
<td>367</td>
</tr>
<tr>
<td>Managed Dialing reports</td>
<td>369</td>
</tr>
</tbody>
</table>
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Completion Code Summary reports</td>
<td>370</td>
</tr>
<tr>
<td>Reports per category</td>
<td></td>
</tr>
<tr>
<td>Agent reports</td>
<td>370</td>
</tr>
<tr>
<td>Job Reports</td>
<td>372</td>
</tr>
<tr>
<td>Time of Day Reports</td>
<td>375</td>
</tr>
<tr>
<td>Administrative Reports</td>
<td>379</td>
</tr>
<tr>
<td>Agent Monthly Reports</td>
<td>383</td>
</tr>
<tr>
<td>Job Monthly Reports</td>
<td>384</td>
</tr>
<tr>
<td>Time of Day Monthly Reports</td>
<td>385</td>
</tr>
<tr>
<td>Report calculations</td>
<td>388</td>
</tr>
<tr>
<td>Abandon Calls</td>
<td>390</td>
</tr>
<tr>
<td>Idle Time</td>
<td>391</td>
</tr>
<tr>
<td>Online Time</td>
<td>391</td>
</tr>
<tr>
<td>Job Active Time</td>
<td>392</td>
</tr>
<tr>
<td>Agent Logout Time</td>
<td>392</td>
</tr>
<tr>
<td>Chapter 34: Data dictionary concepts</td>
<td>395</td>
</tr>
<tr>
<td>Data dictionary overview</td>
<td>395</td>
</tr>
<tr>
<td>Setup and requirements</td>
<td>395</td>
</tr>
<tr>
<td>Benefits</td>
<td>395</td>
</tr>
<tr>
<td>Historical performance data concepts</td>
<td>396</td>
</tr>
<tr>
<td>Monthly roll-up dictionaries</td>
<td>397</td>
</tr>
<tr>
<td>Administrative dictionary</td>
<td>397</td>
</tr>
<tr>
<td>Elementary and calculated data</td>
<td>397</td>
</tr>
<tr>
<td>Weighted averages</td>
<td>398</td>
</tr>
<tr>
<td>Data field notes</td>
<td>398</td>
</tr>
<tr>
<td>Idle count fields</td>
<td>398</td>
</tr>
<tr>
<td>Outbound, Inbound, and Combined fields</td>
<td>399</td>
</tr>
<tr>
<td>Guidelines for creating new reports</td>
<td>399</td>
</tr>
<tr>
<td>Modifying an Analyst built-in report</td>
<td>399</td>
</tr>
<tr>
<td>Creating a new report</td>
<td>400</td>
</tr>
<tr>
<td>Chapter 35: Data dictionary reference</td>
<td>401</td>
</tr>
<tr>
<td>Admin rollup</td>
<td>401</td>
</tr>
<tr>
<td>Agent activity</td>
<td>402</td>
</tr>
<tr>
<td>Agent codes</td>
<td>403</td>
</tr>
<tr>
<td>Agent hierarchy</td>
<td>403</td>
</tr>
<tr>
<td>Dialer hierarchy</td>
<td>404</td>
</tr>
<tr>
<td>Job hierarchy</td>
<td>404</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>RAC</td>
<td>405</td>
</tr>
<tr>
<td>Combined call handling times</td>
<td>405</td>
</tr>
<tr>
<td>Combined call statistics</td>
<td>408</td>
</tr>
<tr>
<td>Combined queue statistics</td>
<td>411</td>
</tr>
<tr>
<td>General information</td>
<td>413</td>
</tr>
<tr>
<td>Inbound call handling times</td>
<td>418</td>
</tr>
<tr>
<td>Inbound call statistics</td>
<td>421</td>
</tr>
<tr>
<td>Inbound queue statistics</td>
<td>422</td>
</tr>
<tr>
<td>Managed dialing statistics</td>
<td>424</td>
</tr>
<tr>
<td>Outbound call handling time</td>
<td>425</td>
</tr>
<tr>
<td>Outbound call statistics</td>
<td>428</td>
</tr>
<tr>
<td>Outbound queue statistics</td>
<td>430</td>
</tr>
<tr>
<td>Person to Person call handling times</td>
<td>432</td>
</tr>
<tr>
<td>Person to Person call statistics</td>
<td>434</td>
</tr>
<tr>
<td>Combined RPC and closure statistics</td>
<td>435</td>
</tr>
<tr>
<td>Combined call completion code statistics</td>
<td>437</td>
</tr>
<tr>
<td>Chapter 36: Use Monitor views</td>
<td>445</td>
</tr>
<tr>
<td>Understanding view windows</td>
<td>445</td>
</tr>
<tr>
<td>Types of views</td>
<td>445</td>
</tr>
<tr>
<td>View toolbar</td>
<td>447</td>
</tr>
<tr>
<td>Using views</td>
<td>448</td>
</tr>
<tr>
<td>Dialer Status view</td>
<td>449</td>
</tr>
<tr>
<td>Dialer Agents view</td>
<td>450</td>
</tr>
<tr>
<td>Dialer Lines view</td>
<td>451</td>
</tr>
<tr>
<td>Dialer History view</td>
<td>452</td>
</tr>
<tr>
<td>Job Status view</td>
<td>453</td>
</tr>
<tr>
<td>Job Agents view</td>
<td>455</td>
</tr>
<tr>
<td>Job Detail view</td>
<td>456</td>
</tr>
<tr>
<td>Job Call Handling view</td>
<td>458</td>
</tr>
<tr>
<td>Job Completion Codes view</td>
<td>459</td>
</tr>
<tr>
<td>Job Wait Queues view</td>
<td>463</td>
</tr>
<tr>
<td>Job History view</td>
<td>465</td>
</tr>
<tr>
<td>Completion Code Detail by Agent view</td>
<td>466</td>
</tr>
<tr>
<td>Job Quality view</td>
<td>467</td>
</tr>
<tr>
<td>Supervisor Agents view</td>
<td>469</td>
</tr>
<tr>
<td>Find Agent view</td>
<td>471</td>
</tr>
<tr>
<td>Agent Detail view</td>
<td>472</td>
</tr>
<tr>
<td>Agent Completion Codes view</td>
<td>473</td>
</tr>
</tbody>
</table>
## Contents

**Agent History view** ................................................................. 474

**Chapter 37: Agent Blending** .................................................. 477

- Understanding Agent Blending .................................................. 477
- Agent Blending overview ....................................................... 477
- Predictive Agent Blending ..................................................... 478
- Proactive Agent Blending ....................................................... 479
- Supported ACDs and switch terminology ................................... 479
- Domains .................................................................................... 483
- Domain groups ............................................................................ 484

- Using Agent Blending ............................................................... 487
  - Start the Agent Blending tool .................................................. 488
  - Create a domain group ............................................................ 488
  - Create a domain ....................................................................... 489
  - Edit domain group settings .................................................... 489
  - Edit domain settings ............................................................... 490
  - Delete a domain group ............................................................ 490
  - Delete a domain ....................................................................... 490

- Maintaining Agent Blending ....................................................... 490
  - Move a domain to a different group ........................................... 491
  - Stop the blend engine ............................................................. 491
  - Start the blend engine ............................................................. 492
  - Reset the blend engine ............................................................ 492
  - Resynch the blend engine ....................................................... 492
  - View ACD statistics ................................................................. 493
  - View alerts ................................................................................ 493
  - View transactions ..................................................................... 493

**Chapter 38: PC Analysis Telnet** ................................................ 495

- Understanding PC Analysis Telnet .............................................. 495
- PC Analysis .................................................................................. 495
- PC Analysis Telnet features ..................................................... 496

- Using PC Analysis Telnet ............................................................ 496
  - Start PC Analysis Telnet ............................................................ 497
  - Field Description for PC Analysis extract output files ............... 497
  - Transfer PC Analysis extract output files ................................ 515
  - FTP Client dialog box .............................................................. 516

**Chapter 39: System Telnet** ....................................................... 517

- Understanding System Telnet ..................................................... 517
- System Telnet ............................................................................... 517
Contents

System Telnet features .......................................................... 518
Using System Telnet ............................................................. 518

Appendix A: PDSAgent.ini Parameters ...................................... 521
Agent ................................................................................. 521
DDE .................................................................................. 522
Blend ................................................................................. 523
GUI ................................................................................... 523
Phone ............................................................................... 524
Session ............................................................................. 525
Server .............................................................................. 526
Log .................................................................................... 526
SizeAndPosition ................................................................. 527
Security ............................................................................. 528
DialerList ......................................................................... 529

Index ................................................................................. i
Contents
Preface

This section contains the following topics:

- **Purpose** on page 19
- **Audience** on page 19
- **Related documents** on page 19

---

**Purpose**

The purpose of this guide is to provide detailed information about Avaya Proactive Contact Supervisor. The Avaya Proactive Contact Supervisor consists of the following applications:

- Role Editor
- Editor
- Monitor
- Analyst
- Health Manager

---

**Audience**

This guide is for personnel who create role permissions, configure jobs, select records, create campaigns, and define phone strategies. The Avaya Proactive Contact Supervisor also provides system monitoring and reporting of real-time and historical operations.

---

**Reason for re-issue**

The Avaya Proactive Contact Supervisor guide has been re-issued after updating the following sections:

- **Chapter 12: Calling Lists** on page 113
- **Recall settings** on page 229
Related documents

- Avaya Proactive Contact Overview
- Using Avaya Proactive Contact Agent
- Planning for Avaya Proactive Contact
- Administering Avaya Proactive Contact
- Avaya Proactive Contact Safety and Regulatory Information
Chapter 1: Introduction

Avaya Proactive Contact consists of software, hardware, and network components. The system is comprised of the system cabinet, supervisor workstation, agent workstations, printer, and modem.

Avaya Proactive Contact is available with increased capacities for the Avaya Proactive Contact large cabinet and PG230RM systems (Application Enablement Services implementations will remain at the previous capacity levels). Capacities for both concurrent agents and outbound trunks have been significantly increased to almost double the current capacities of 240 agents and 480 trunks. Actual agent and trunk maximum capacities differ based upon trunk configuration parameters.

The supported capacities are as follows:

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>T1 (non-ISDN)</td>
<td>432 agents / 912 trunks</td>
</tr>
<tr>
<td>T1 ISDN wo/NFAS</td>
<td>414 agents / 874 trunks</td>
</tr>
<tr>
<td>T1 ISDN w/NFAS</td>
<td>432 agents / 854 trunks</td>
</tr>
<tr>
<td>E1-CAS (non-ISDN)</td>
<td>390 agents / 810 trunks</td>
</tr>
</tbody>
</table>

As a system supervisor, you use the supervisor workstation and the Supervisor applications to set up, monitor, modify, and report on your calling activities. The maximum number of Supervisor applications you can connect to are 70 per dialer. If in a Pod environment, you can use a maximum of 280 applications in a pod of maximum four dialers. Agents use the agent workstations to handle inbound and outbound phone calls.

This section contains the following topics:

- [What is new in this release](#) on page 21
- [Avaya Proactive Contact environment](#) on page 25
- [Licensing](#) on page 28
- [Avaya Proactive Contact users](#) on page 31
- [Log in to Supervisor](#) on page 34

---

What is new in this release

Avaya Proactive Contact now provides various features to help you in managing day-to-day contact center functions. These features are described in the following sections:
Real-time record selection support

In the prior releases of Proactive Contact, the only Record Selection “criteria” that could be changed during a running Proactive Contact Job was the ability to turn Time Zones on or off.

The Time Zone feature was designed to help customers implement a “follow-the-sun” strategy. Proactive Contact 5.0 provides the ability to change the Selection Criteria while a Job is running without the requirement to stop and restart the Job. For example, a Job could be running that is targeting 30 day and 60 day delinquent accounts. Midway through the Job the criteria could be modified on the fly to focus on 60 day accounts only.

Automatic record selection for job linking

This feature enhancement allows users to set up a long “chain” of linked Jobs. In prior versions of Proactive Contact, the user had to monitor the current campaign and run the Record Selection for the linked Job just prior to the completion of the current Job. In this release of Proactive Contact, the users are provided with controls that allow them to have the Record Selections on Linked Jobs run automatically right at the end of the current Job. This eliminates the time spent monitoring for the end time of the first Job as well as each subsequent job.

Additionally, by running the Record Selection just before the linked Job starts, ensures that there is no overlap between records selected in the first job and the records to be called in the linked Job(s).

Unit Work List job compatibility with infinite lists

Proactive Contact 5.0 adds the ability to Unit Work List Jobs to run using an Infinite List. This allows users to feed records into Unit Work List Jobs in near real-time. The Unit Work List Job processing then places new calls based on priority and routes them to agents who have joined the Unit ID associated with those records.

Multi-Unit selection for Unit Work List jobs

In Avaya Proactive Contact 4.x or earlier, when using Unit Work List Jobs, agents can log into only one Unit ID. For example:

- When joining a Unit Work List Job, the agents that speak one language select the unit for their one language. However, the agents that speak two of the three languages can not pick their two specific languages.
- Proactive Contact 5.0 provides the option for any agent to “multi-select” from the master list of all Unit IDs. In the example above there would be three unit IDs, one for each
language. The agents that speak two languages can now pick their two specific languages from the pick list.

This enhancement to Unit Work List Jobs reduces the need for agents to join multiple jobs. Users can now set up jobs that span many skills (indicated by various units) and then have agents only receive calls that match their specific skill set/unit(s). Agents can join up to a maximum of 15 unit work lists.

---

**Virtual job opt-out option**

In the prior version of Proactive Contact, the Virtual Job feature was limited to the playing of a message. After playing the message the system would hang-up with no other options allowed for the customer.

In this release of Proactive Contact customers have the ability to “opt-out” of the virtual message by pressing a digit on their phone. Options include opting out to an Intelligent Call Blend Job (or pure Inbound Job) on Proactive Contact or to a VDN within the Inbound Call Center, thus providing the customers options that will allow them to talk to a live agent.

The Proactive Contact CTI system also supports this function but only uses the opt-out to VDN option.

---

**Running real-time scheduling**

In the prior versions of Proactive Contact, all scheduled tasks created, deleted, or changed using the Editor interface were not executed until after a system restart. In some cases, this caused unnecessary inconvenience for users. For example, a Job was scheduled to start at 9:00 AM and at 8:30 AM a supervisor deletes the scheduled item using Editor. In order for the Job to not start at 9:00 AM a system restart was required.

Proactive Contact 5.0 provides the option for users to create, modify, or delete scheduled items and have them executed without a system restart.

---

**Multiple day selections with hourly recurrence in Schedule**

Earlier, hourly recurrence in scheduling was mutually exclusive with the Weekly, Daily, Monthly, and Yearly recurrence patterns. In this release, hourly repetition is an independent option that can be combined with any of the recurrence patterns.
Extend Agent Joblist functionality to Agent API and Proactive Contact Agent

Prior versions of Proactive Contact support restricting the Jobs that agents can join using a feature called Agent Joblist. However, the Joblist feature is only available when using the character-based agent application. This feature enhancement in Proactive Contact 5.0 extends the Joblist functionality into the GUI based PC Agent application and into the Proactive Contact Agent API.

Escape General Recall

This enhancement allows agents to automatically receive recalls scheduled in one job while they are participating in another job. This improves agent productivity by allowing all agents to move from one job to another as the net-new calls on the original Job are depleted. In turn, this improves campaign effectiveness by ensuring that valuable agent set recalls are placed at the customer requested time.

Strengthened password support

In this release, the password security has been enhanced based on various criteria options including the usage of characters, numericals and so on. Also, the threshold for account locking in case of unsuccessful log in attempts and the option to unlock the account has been introduced.

Simultaneous Campaign Alert

This alert warns users that they are about to exceed the maximum number of simultaneous running Jobs allowed on the system. This prevents them from overwriting other Jobs that were started earlier.

OFCOM enhancements

In this release, a new code, Code 97, has been added to the list of completion codes. This code is used to dispose the "Answering Machine" and is applicable only for the outbound calls. This code addresses the changes specified by Ofcom (Office of Communications) in UK on October 30th 2009 in their "Revised statement of policy on the persistent misuse of an electronic communications network or service."
To comply with the new OFCOM policy, the formulas for some of the columns in the OFCOM reports in Monitor and Analyst have been changed.

Avaya Proactive Contact environment

The dialer works with your call center’s equipments and operations to perform call center tasks. Your installation can include more than one dialer.

This section contains the following topics:

- **Dialer functions** on page 25
- **Multiple dialers (POD configuration)** on page 26
- **Pods** on page 26
- **Calling lists** on page 27
- **Role-Based Authorization for Administrators** on page 28
- **Licensing** on page 28

Dialer functions

Following are the primary functions of a dialer:

- Receive customer records from the call center’s host computer.
- Select and sort customer records based on the call center’s business goals.
- Allow agents to update customer information on an agent screen or on the host, depending on the required configuration.
- Pass only specific call types to agents.
- Adjust the calling pace to meet the call center’s requirements.
- Monitor ACD inbound traffic and predict when to acquire and release ACD agents for outbound calling on Avaya Proactive Contact with Agent Blending.
- Support outbound, inbound, and blend jobs.
- Generate a variety of reports, including job, agent, and system reports.
- Upload record information to the host (optional).
Multiple dialers (POD configuration)

The Avaya Proactive Contact system can include multiple dialers. You can connect up to four dialers through a Mid-Tier structure.

An Avaya Proactive Contact system that is connected to more than one dialer through a Mid-Tier structure is called a pod.

Avaya Proactive Contact system can also have a distributed architecture. The system can use the dialers in the following architecture:

- Multiple stand alone dialers
- One or more pods of dialers
- Multiple stand alone dialers and multiple pods of dialers

Multiple stand alone dialers allow you to manage multiple jobs simultaneously, each with its own calling list. If a dialer shuts down, the remaining dialers continue to operate.

**Note:**
You can configure a Pod only if you have LDAP configured on all the dialers that you want to include in the pod.

Pods

A multiple dialer environment that uses a pod increases your company's outreach capacity. A pod allows you to manage large-scale outreach programs from a single administration and Supervisor interface.

A pod provides additional benefits including the following features:

- Calling lists
- Jobs
- Phone strategies
- Record selections
- Completion codes
- Logins

From one Supervisor application, you can run multiple jobs on multiple dialers, monitor calling activities on each dialer, and enable a dialer to use calling list data from another dialer in the pod for calling activities.
Calling lists

A calling list is a file that contains customer records. Avaya Proactive Contact uses two types of calling lists: one for outbound calling and the other for inbound calling on Intelligent Call Blending systems.

The host system creates the download file of customer records for the outbound calling list. The download file contains the records and fields you defined as necessary to your outbound call activities.

Avaya Proactive Contact processes the host file and prepares it for the calling activities. When the calling activities end, the system prepares the calling list to be uploaded to the host.

Process calling lists

After the host downloads the customer records, Avaya Proactive Contact completes the following tasks, as applicable, to create a calling list:

- Check for and flag duplicate records and invalid telephone numbers.
- Identify and mark records that have been on the system for more than the specified number of days.
- Recall the name of the last agent to speak to the customer.
- Store the result of the last call attempt as recorded by the agent.
- Restore the recall information from previous day’s list to today’s list.
- Bring over the following statistics from previous day’s list:
  - Name of the last agent to speak with the customer
  - Date and time of the last call attempt
  - Result of the last call attempt as recorded by the agent on the system
  - Number of days the record has been on the system
  - Record status
  - If configured, data listed is the data that is carried forward from the previous calling list.

After calling activities and at a scheduled time, Avaya Proactive Contact completes the following tasks to upload the file to the host:

- Converts the customer records in a specific calling list to a format specified for your host computer.
- Converts sample file from fixed length or CSV format to sample calling list binary.
- Creates an upload file. The host then updates your customer database with the data in the calling list that has been called on.
Environment

The calling list environment is responsible for the following activities:

- Create the files required to convert host computer data to the Avaya Proactive Contact calling list format.
- Prepare the calling list for the calling activities.
- Create the files required to extract data to send back to the host after calls have been made.

Role-Based Authorization for Administrators

- To meet security requirements, each administrator should only see the view of administration based on his or her assigned role. In Avaya Proactive Contact, there are three types of administrator roles:
  - Auditor - A separate menu for Auditor. The role Auditor can audit system security like bad logins and job operations like job settings, during run-time.

Secured Agent

The Agent application is secured and offers the following benefits:

- Communicates using Secure Socket Layer (SSL).
- Data Transmission is encrypted.
- Certificates are used for client and server authentication.
- Security Settings are saved in PDSAgent.ini file.

Licensing

The Avaya Product Licensing and Delivery System (PLDS) provides customers, Avaya Partners, distributors, and Avaya Associates with easy-to-use tools for managing license entitlements and electronic delivery of software and related license files. Using PLDS, you can perform operations such as license activations, license upgrades, license moves, and software downloads.

Use the License Activation Code (LAC) to activate one or more license entitlements. You may choose to activate all of the licenses or specify the number of licenses that you want to activate from the quantity available. Upon successful activation of the license entitlements, PLDS
creates an Activation Record and sends an Activation Notification e-mail message to the customer that is registered with the entitlements. The Activation Record and Activation Notification provide details on the number of activated licenses and the License Host. The license file can be accessed on the License/Keys tab of the Activation Record in PLDS and is also an attachment to the Activation Notification e-mail message. You need to install the license file on WebLM to use the licenses.

The licensing feature enables licensing of various dialer entities using Web-based License Manager (WebLM) licensing software. WebLM is a standalone Web-based license manager that runs on both Windows and Linux systems. WebLM is designed to support any Avaya software product that needs licensing capabilities.

In a standalone WebLM, a WebLM server is used to support one or more licensed application instances. In this model, an administrator can perform the following tasks through the WebLM server:

- Install a license file on the WebLM server
- Manage WebLM users
- Track feature licenses acquired by licensed applications
- Generate a usage report for the feature licenses

This feature does not replace any of the required configurable limits that are used to limit the capacity of an individual dialer due to hardware limitations or dialer performance.

Licensing is performed in addition to the dialer capacity checks. The licensing feature is not intended to be used for role restriction. The capacities and potential roles of an application will be determined prior to a request for a license.

All the dialer components that use licensing must provide a 30-days grace period that allows access for 30-days in the case of the failure of WebLM server.

This section provides information on the following:

- License Server Setup on page 29
- Dialer Configuration on page 30
- Grace Period on page 30

---

**License Server Setup**

The prerequisites for License server setup are as follows:

- Tomcat Installation
- WebLM Server Installation
- License file Installation on WebLM Server
- License file is generated using Avaya Product Licensing and Delivery System (PLDS)
Dialer Configuration

The WebLM Server URL must be stored in the master.cfg file on the dialer. You can store the URL using any of the following ways:

- By manually entering the WebLM Server URL in the master.cfg file.
- By Using the License Configurator option available in the Tools menu of the Health Manager application.

**Note:**

The dialer must be restarted every time the WebLM Server URL is changed.

The WebLM Server URL is: http://xxx.xxx.xxx.xxx:8080/WebLM/LicenseServer

Grace Period

When the dialer is unable to connect to the WebLM Server and refresh the licenses, then the system goes into a grace period.

The dialer can run into the grace period for 30 days. During the grace period, the Supervisor application will receive grace period messages every 30 minutes indicating the time left for the grace period to expire.

When the connection is re-established with the WebLM server, all licenses are acquired again.

After the expiry of the grace period, the system will restart.

Start Enforcer

You can start Enforcer using the Start All Services option from the Action Menu of the Health Manager application.

Stop Enforcer

You can stop Enforcer using the Stop All Services option from the Action Menu of the Health Manager application.
Avaya Proactive Contact users

Your contact center manages the personnel who use Avaya Proactive Contact and the components that each person can use.

This section discusses the following topics:

- Types of users on page 31
- Logins and permissions on page 32

Types of users

Contact Center personnel who use Avaya Proactive Contact include the following users:

**Administrators** - Set up and maintain the Avaya Proactive Contact system including the following tasks:

- Set up user accounts
- Start and stop dialers
- Define and download calling lists.
- Monitor the health of the system
- Define audio messages and scripts

**Supervisors** - Set up and monitor the contact center calling activities including the following tasks:

- Create and maintain phone strategies
- Create and maintain record selections
- Create jobs that define the calling activities
- Start and stop jobs
- Monitor and maintain calling activities

**Agents** - Handle inbound and outbound calling activities. Throughout the day, agents work on outbound and blend jobs. Agents can also receive inbound calls that customers place to the contact center.
Logins and permissions

In Avaya Proactive Contact, your login determines the applications you can use and the features you can use in the application. For example:

**Administrator login and password** - Allows you to use the administrative features and the supervisor features in the Linux-based application and in the Supervisor application. Administrators can also use Health Manager to monitor and manage the operation of Avaya Proactive Contact.

**Supervisor login and password** - Allows you to use supervisor features in the Linux-based application and in the Supervisor GUI.

**Agent login and password** - Allows you to use the Avaya Proactive Contact Agent application. The type of calling activities that an agent can handle depends on the agent type selected by the agent at the time of logging into the system.

This section contains the following topics:

- [About Passwords](#) on page 32
- [Agent types](#) on page 33
- [Agent logins](#) on page 33

About Passwords

If you are logging in for the first time or your password expires, a prompt appears asking you to change your password. Ensure that your new password is minimum eight character long and includes at least three of the following:

- One upper case letter
- One lower case letter
- One numerical
- One special character

**Note:**

Using a upper case character as the first character of your password and numerical as last character of your password is not counted in fulfilling the above password criteria.

Your password gets locked automatically by the system after three unsuccessful login attempts. You can, however, unlock your password using the createop utility.

**Note:**

The password for the default users does not get locked even after three unsuccessful login attempts.
While resetting your password, ensure that your new password is different from the last seven passwords used by you for logging in to the Avaya Proactive Contact Supervisor application.

**Agent types**

When agents log in, each agent selects an agent type that is set up for your system. The agent type determines the types of calls the agent can handle.

Agents can log in to the Avaya Proactive Contact and select one of the following agent types:

**Outbound agent** - Outbound agents handle outbound calls only. Outbound agents can join the standards outbound jobs, such as:
- Cruise Control
- Unit work list
- Sales Verification
- Infinite

**Managed agent** - Managed agents only handle outbound calls during an outbound job set up as a Managed Dialing job.

**Inbound agent** - Inbound agents handle only inbound calls. They can join inbound or blend jobs. The system receives calls directly from customers or through an ACD.

**Blend agent** - Blend agents handle both outbound and inbound calls. They join blend jobs and can handle customer records on outbound and inbound calling screens.

**Person to Person agent** - Person to Person agents handle outbound calls when outbound agents are not available.

**ACD agent** - ACD agents handle outbound calls on the Avaya Proactive Contact and handle inbound calls on the ACD.

**Agent logins**

**Basic login** - The following table describes the agent logins used, regardless of the blending configuration on your system.

<table>
<thead>
<tr>
<th>Agent type</th>
<th>Login</th>
<th>Joins job</th>
<th>Handles calls</th>
</tr>
</thead>
<tbody>
<tr>
<td>Managed</td>
<td>m</td>
<td>outbound</td>
<td>Outbound calls on Avaya Proactive Contact</td>
</tr>
</tbody>
</table>

December 2011  33
### Agent Blending login

If your system is configured with Agent Blending, the following table describes the agent logins used.

<table>
<thead>
<tr>
<th>Agent type</th>
<th>Login</th>
<th>Joins job</th>
<th>Handles calls</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outbound</td>
<td>o</td>
<td>outbound or blend</td>
<td>Outbound calls on Avaya Proactive Contact</td>
</tr>
<tr>
<td>Person to Person</td>
<td>p</td>
<td>outbound</td>
<td>Outbound calls on Avaya Proactive Contact</td>
</tr>
</tbody>
</table>

### Intelligent Call Blending login

If your system is configured with Intelligent Call Blending, the following table describes the agent login used.

<table>
<thead>
<tr>
<th>Agent type</th>
<th>Login</th>
<th>Joins job</th>
<th>Handles calls</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACD</td>
<td>a</td>
<td>outbound</td>
<td>Outbound calls on the Avaya Proactive Contact and inbound calls on ACD</td>
</tr>
<tr>
<td>ACD</td>
<td>a</td>
<td>managed</td>
<td>Managed Outbound calls on the Avaya Proactive Contact and Inbound calls on ACD</td>
</tr>
</tbody>
</table>

### Agent Blending and Intelligent Call Blending login

If your system is configured for both (Agent Blending and Intelligent Call Blending), the following table describes the additional agent login that you can use.

<table>
<thead>
<tr>
<th>Agent type</th>
<th>Login</th>
<th>Joins job</th>
<th>Handles calls</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACD</td>
<td>a</td>
<td>blend</td>
<td>Outbound calls on Avaya Proactive Contact and Inbound calls on ACD</td>
</tr>
</tbody>
</table>

---

**Log in to Supervisor**

Avaya Proactive Contact uses the Supervisor application to interface with the hardware and software that is included with the system.
The system allows you to access Monitor, Editor, and Analyst applications using a single password.

After you log in to one application, you can access the other applications without entering the user name and password again. To log in to any Supervisor application:

1. Go to **Start > All Programs > Avaya > Proactive Contact > Supervisor** and select Analyst, Editor, Health Manager, Monitor, or Role Editor.
2. Enter your log in name and the password, and then click **OK**.

**Tip:**
If you already have one application from the Supervisor suite open on your computer, you do not need to log in again when you open a second application. If you exit all applications, you will need to log in again.

To display the online help, select **Help > Contents**, or press **F1**.

**Note:**
You might see a message that Internet Explorer restricted the help system from showing active content.

To display the help, complete the following procedure:

1. In Internet Explorer, select **Tools > Internet Options > Advanced** tab.
2. Navigate to the section labeled **Security**.
3. Select the **Allow active content to run in files on My Computer** check box.
4. Click **OK**.
Chapter 2: Role Editor

The Role Editor allows you to assign permissions associated with roles, and assign users to appropriate roles. This chapter consists of the following sections:

- What is a Role on page 37
- Types of Permissions on page 38
- Predefined Roles on page 39

What is a Role

Role can be defined as the actions and activities assigned to, or required, or expected of a person or group. Roles are created for the various job functions in an organization and users are assigned roles based on their responsibilities and qualifications. Users can be easily reassigned from one role to another. Roles can be granted new permissions as new applications and systems are incorporated, and permissions can be revoked from roles as needed.

Roles are closely related to the concept of user groups in access control. However, a role brings together a set of users on one side and a set of permissions on the other, whereas user groups are typically defined as a set of users only. Access control policy is formulated around a role. The particular collection of users and permissions brought together by a role is for a short period of time. The role is more stable because an organization's activities or functions usually change less frequently.

There are several reasons for creating a role. For example:

- A role can represent competency to do specific tasks
- A role can embody authority and responsibility (for example: supervisor or administrator)

Roles can reflect specific duty assignments that are rotated through multiple users, for example, an administrator or shift supervisor. Role Editor is able to conveniently accommodate all of these combinations of the role concept.

Roles allow certain operations on certain managed resources, both of which are controlled by permissions:

- Users are assigned to roles
- Users acquire permissions by their role assignment
- A user can be assigned to many roles and at the same time a single role can have many users.
A single permission can be assigned to many roles and a single role can have many permissions.

You can have a role without any permissions.

A role is a named set of permissions (operations and access). For a user to do anything it has to have a role. The requisite of a role are:

- The name of the role is any valid string.
- Role names are case sensitive
- Maximum length of a role name is 256 characters
- Role names are internationalized

The Role Editor allows the following operations:

- Create roles
- Delete roles
- Rename roles (for example, fix spelling mistakes in the role name)
- View which roles exist
- View all user to role assignments
- View users that are not assigned to any role
- View the permissions that exist
- View the operations and access permissions that are assigned to roles
- View the operations permissions that are not assigned to any role
- Assign permissions to roles
- Remove permissions assignments from a role
- Assign users to a role
- Remove users from a role

**Types of Permissions**

There are two types of permissions. They are:

- [Operations Permissions](#) on page 39
- [Access Permissions](#) on page 39
Operations Permissions

By default, there are a fixed set of operations permissions available in the system. These permissions define the supervisor applications that can be run. Examples of these are permission to run Editor, Monitor, or Health Manager. For more details refer to Chapter 3: Permissions in Role Editor on page 41.

Access Permissions

Access permissions define the degree of control that an allowed operation has over its managed resources. By default, there are a fixed set of access permission provided with the system.

There are three types of access permissions. They are:

- **Read** - Allows a read only access to a feature
- **Job** - Allows use of job control functions, where applicable. This can be added to R access, and is implicit in W access.
- **Write** - Allows read, write, and job control access to a feature. Write includes the ability to create, update, and delete data or information.

The read and write access permissions are hierarchical. There is a basic read permission, then a write permission that includes read. In a few cases a job control permission can be added to the read access permission. The read-write access permission includes job control permission.

Predefined Roles

The default roles in Avaya Proactive Contact are:

- Administrator
- Supervisor
- Role Administrator

**Note:**

There is a default user "roleadm" in Avaya Proactive Contact. This user is part of the Role Administrator role. You must change the password of this user. It is recommended to create a user and assign Role Administrator permission to that user and delete the user "roleadm".
Chapter 3: Permissions in Role Editor

This section describes the various application permissions that can be assigned to roles. This section includes the following:

- Types of Application Permissions on page 41

Types of Application Permissions

The following table provides a bird’s eye view on the various permissions available for various applications.

Note:
The "X" in the table below represents the permission that can be provided. You must have minimum operation permissions of the various supervisor application to access features like Dialer apps, Agent Blend, Hierarchy Manager, and Get Files. These operation permissions cannot be used individually. For example, if you want to use Dialer apps operation permission, you should also have minimum editor permission like Editor Job, Editor Strategy.

<table>
<thead>
<tr>
<th>Application</th>
<th>Sub-Application</th>
<th>Permission Type</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>R (Read)</td>
</tr>
<tr>
<td>Agent Blending</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Analyst</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Dialer Server</td>
<td>CUI Menu</td>
<td></td>
</tr>
<tr>
<td>Editor</td>
<td>Agent Keys</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Call List including Campaign</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Template</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Completion Code</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Jobs</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Messages And Scripts</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Schedules</td>
<td>X</td>
</tr>
</tbody>
</table>
### Chapter 3: Permissions in Role Editor

<table>
<thead>
<tr>
<th>Application</th>
<th>Sub-Application</th>
<th>Permission Type</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>R (Read)</td>
</tr>
<tr>
<td>Selection</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Strategy</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Get Files</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Health Manager</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Hierarchy Manager</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Monitor</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Role Editor</td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>
Chapter 4: Using Role Editor

The Role Editor allows you to create new roles and assign users to roles.

Note:
You cannot create new users with Role Editor. To create new users, use the SYSADM menu on the dialer.

This section contains the following topics:

- Toolbar Buttons on page 44
- Log in to Role Editor on page 44
- Create a New Role on page 45
- Rename a Role on page 45
- Merging Roles on page 46
- Editing a Merged role on page 47
- Assign Role(s) to the User on page 48
- Assign User(s) to the Role on page 49
- Deleting a role on page 50
- Refresh Role Editor data on page 50
- Reports on page 50
- Display Online Help on page 51
Chapter 4: Using Role Editor

Toolbar Buttons

The table provides a toolbar buttons and their description.

<table>
<thead>
<tr>
<th>Name</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td><img src="image" alt="Folder" /></td>
<td>Creates a new role.</td>
</tr>
<tr>
<td>Save</td>
<td><img src="image" alt="Save" /></td>
<td>Saves the changes:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>● After creating a role</td>
</tr>
<tr>
<td></td>
<td></td>
<td>● After using the rename option</td>
</tr>
<tr>
<td>Delete</td>
<td><img src="image" alt="Trash" /></td>
<td>Deletes the selected role.</td>
</tr>
<tr>
<td>Merge</td>
<td><img src="image" alt="Merge" /></td>
<td>Opens the Merge Roles window.</td>
</tr>
<tr>
<td>Report Preview</td>
<td><img src="image" alt="Report" /></td>
<td>Previews the selected report in a browser.</td>
</tr>
<tr>
<td>Help</td>
<td><img src="image" alt="Help" /></td>
<td>Displays the online help.</td>
</tr>
</tbody>
</table>

Log in to Role Editor

To log in to Role Editor:

1. Select **Start > All Programs > Avaya > Proactive Contact > Role Editor** or click the Role Editor icon on the desktop.

2. Type your Role Administrator user name and password, and then click **OK**.

**Note:**
The default username/password is **roleadm/roleadm**. You must change the password of the default user using sysadm menu on the dialer.
Create a New Role

In Avaya Proactive Contact, a permanent account for Role Administrator Role is created. Default role is "Role Administrator" role. This role has permissions to define roles and to assign users to roles.

Note:
Roles are used only for supervisor application access. Agents are not included in the roles.

You can define new roles to meet your business roles and procedures. At the supervisor GUI, a role is defined by naming it and assigning to it the operations permissions and access permissions appropriate for the role.

To create a new role:
1. Login to the Role Editor using "roleadm".
2. Click File > New.
   You can also press Ctrl+N key to bring the Role Wizard window.
3. In the Welcome to Create new Role window, click Next.
4. In the Name the role window, provide a name and brief description for the new role.
5. Click Next.
6. In the Allow application access window, select the application that the new role can access.
7. Click Next.
8. In the Define the type of access window, specify the permission for the various applications that you had selected in the previous step.
9. Click Next.
10. In the Finishing your role definition window, you can see the summary of the role that you created, the applications that you had selected, and their permissions.
11. Click Finish.
   The new role will appear in the center panel under Role Name in the Role Editor window.
   You must save the new role.
12. Click File > Save.
   You can also press Ctrl+S key to save the role.

Rename a Role
Chapter 4: Using Role Editor

You can rename an existing role.

To rename a role:

1. Login to the Role Editor.
2. In the left pane, under Role, click **Administration**.
3. In the center pane, in the Role Name column, select a role to be renamed.
4. Right-click on selected role and select **Rename**.
   - You can also rename the role by selecting the role and pressing F2 key on the keyboard.
   - You can also rename the role using the menu bar. Select the role and click **Edit > Rename**.
   - You can also double click on the selected role and rename the role.
5. Click **File > Save**.
   - You can also press **Ctrl+S** key to save the role.

---

Merging Roles

You can merge two or more roles together. The final permissions of the new role are the highest permissions of the individual roles upon which the new role is based.

To merge two or more roles:

1. Login to the Role Editor.
2. In the left pane, under Role, click **Administration**.
3. In the center pane, in the Role Name column, select a role, right-click on a role and select **Merge....**
   - You can also select the merge icon in the toolbar.
   - The Merge Roles window will appear.
4. In the **New role name** field provide a name for the new merged role.
5. In the **Description** field provide a brief description about the new merged role.
6. In the Available roles box, select the roles that you want to merge.
   - You will see the permissions that the role has in the Effective permissions box on the left, under the Available roles box.
7. Click the right arrow button (＞), to move the selected roles from Available to Assigned roles.
   You can click double right arrow button (＞＞) to assign all the available role to the user.
   You can select a particular role in the Assigned roles box, and click left arrow button (＜) to move the role to Available role box.
   You can click double left arrow button (＜＜) to move all the roles from the Assigned Roles box to the Available roles box.
   You will see the Effective permissions of the Assigned roles in the Effective permissions box on the right, under the Assigned roles box.
8. Click OK.
   You have successfully merged the selected roles.
You can see the new merged role in the center pane. When you select the merged role, you can see the users that are assigned to the merged role in the Users pane located inside the right pane. You can also see the roles that were merged in the Assigned Roles pane located at the bottom right corner.

---

**Editing a Merged role**

You can edit a merged role. You have the following options:

- Merge additional roles to the merged role
- Remove a role that was previously merged

To edit a Merged role:

1. Login to the Role Editor.
2. In the left pane, under Role, click Administration.
3. In the center pane, in the Role Name column, select a merged role, right-click on a merged role and select DeMerge....
   The Merge Roles window appears.
4. Select the roles that you want to merge in the Available roles box or select the roles that you want to remove from the merge from the Assigned Roles box.
5. Click the right arrow button (＞), to move the selected roles from Available to Assigned roles. You can click double right arrow button (＞＞) to assign all the available role to the user. You can select a particular role in the Assigned roles box, and click left arrow button (＜) to move the role to Available role box. You can click double left arrow button (＜＜) to move all the roles from the Assigned Roles box to the Available roles box.
6. You will see the Effective permissions of the Assigned roles in the Effective permissions box on the right, under the Assigned roles box.
7. Click **OK**.

   You have successfully edited a merged role.

---

**Assign Role(s) to the User**

After creating a role, you can assign users to that role.

To assign a role to a user:

1. Login to the Role Editor.
2. In the left pane, under Role, click **Users**.
3. In the center pane, all the available users lists are populated.
4. Click to select the User.

   **Note:** When you click on the user, you will see the roles that are currently assigned to the user on the upper right hand box under Role Name and the permission that the role has in the lower right hand box.

5. Right-click on the user and click **Role Assignment...**.

6. In the Role Assignment window, under Available roles, select the role you want to assign to the user.

   You will see the permissions that the role has in the Effective permissions box on the left, under the Available roles box.

   **Note:** You can assign multiple roles to a user.

7. Click the right arrow button (>) to move the selected roles from Available to Assigned roles.

   You can click double right arrow button (>>) to assign all the available role to the user.

   You can select a particular role in the Assigned roles box, and click left arrow button (<) to move the role to Available role box.

   You can click double left arrow button (<<) to move all the roles from the Assigned Roles box to the Available roles box.

8. You will see the Effective permissions of the Assigned roles in the Effective permissions box on the right, under the Assigned roles box.

9. Click **OK**.
Assign User(s) to the Role

After creating a role, you can assign roles to the user.

1. Login to the Role Editor.
2. In the left pane, under Role, click **Administration**.
3. Select a role.

   **Note:**
   When you select a role, you will see the application permissions that the role has in the upper right hand box and users that are assigned to that role in lower right hand box.

4. Right-click on the role and select **User Assignment**.

5. In the **User Assignment** window, under **Available Users**, select a user you would like to assign to the role.

   You see the effective permissions of the selected user in the Effective permissions box on the left, under the Available Users box.

   **Note:**
   You can assign multiple users to a role. Multiple selections of user will not calculate the effective permission. It will show the permission as Not Applicable in the lower left hand box.

6. Click the right arrow button (>), to move the selected user from Available Users to Assigned Users.

   You can click double right arrow button (>>) to assign all the available users to the role.

   You can select a particular user in the Assigned Users box, and click left arrow button (<) to move the user to Available Users box.

   You can click double left arrow button (<<) to move all the Users from the Assigned Users box to the Available Users box.

7. You will see the Effective permissions of the Assigned Users in the Effective permissions box on the right, under the Assigned Users box.

8. Click **OK**.

   You have successfully assigned a role to a user.
Deleting a role

Before you delete a role, you need to ensure that no user is associated with that role. Before deleting a role, any users of that role must be deleted, assigned or moved to another role.

1. Login to the Role Editor.
2. In the left pane, under Role, click Administration.
3. In the center pane, in the Role Name column, select a role to be deleted.
4. Right-click on selected role and select Delete.
5. In the Role Editor dialog box, click Yes.

Additionally, you can delete the role by selecting the role and clicking the Delete icon in the toolbar.

You can also delete the role using the menu bar. Select the role and click File > Delete or use the Ctrl + D key.

Refresh Role Editor data

To refresh the Role Editor data in any view:

1. On the menu bar, click Settings.
2. In the Settings menu, click Options....

In the Options window, you can set how often you want the data to be refreshed on the screen. The options available are:

- 15 Seconds
- 30 Seconds
- 60 Seconds
- Manual (refresh with F5 key)

You can also refresh the Role Editor data by clicking on View menu and then clicking Refresh.

Reports

You can view three types of reports in Role Editor. They are:

- Role Summary: This report provides a list of roles and their descriptions.
● **Roles assigned to users:** This report provides a list of all users and roles assigned to users.

● **Operations and Access Permissions assigned to Roles:** This report provides a list of all roles, their operations and permissions.

To view reports:

1. In the Role Editor window, in the left pane, under Role, click **Reports**.
2. In the center pane, under Names column, select the required report type.
3. The selected report details are displayed in the right pane.

---

## Save Reports Data as HTML

Save Role Editor Reports data to an HTML file for viewing in a browser.

To save data as HTML:

1. From the **File** menu, click **Save as HTML**.
2. In the **Save As** dialog box, type a file name.
3. Click **Save**.

The Role Editor dialog box appears. If you want to view the saved report click **Yes**, else click **No**.

---

## Display Online Help

To display the online help:

1. Select **Help > Contents**.

**Note:**

You might see a message that Internet Explorer restricted the help system from showing the active content.

To allow active content:

1. In Internet Explorer, select **Tools > Internet Options > Advanced** tab.
2. Navigate to the section labeled **Security**.
3. Select the **Allow active content to run in files on My Computer** check box.
4. Click **OK**.
Chapter 5: Scenarios for Role Editor

The goal of the scenarios explained in this section is to get you familiarized with the user interface of Role Editor and to provide you with a clear understanding of what kind of roles can be made.

Note:
This scenarios explained in this section are examples. You can create a wide variety of roles depending on your organization’s requirement.

- Scenario 1: Create a role for Manager to perform a specific task on page 53
- Scenario 2: Create Identical Role as Administrator on page 55
- Scenario 3: Assign a User to a Role on page 55
- Scenario 4: Test the Role Permissions on page 56
- Scenario 5: Create a Role with no Permissions on page 57
- Scenario 6: Create a Role by Merging two or more Roles on page 57
- Scenario 7: Assign User to a Merged Role on page 58
- Scenario 8: Edit a Merged Role on page 59
- Scenario 9: Rename a Role on page 60
- Scenario 10: Delete a Role on page 60
- Scenario 11: Edit a Role Permission on page 61
- Scenario 12: Assign a Role to Users on page 61

Scenario 1: Create a role for Manager to perform a specific task

The organization requires the creation of a role for Managers enabling them to perform the following tasks:

- Run the job through editor
- Use the CUI menu in the Dialer Applications
- View the real-time data in monitor
- Use Health Manager
- View Analyst Report
- Create Hierarchy Manager
To create the specific role required to be able to perform the above-mentioned tasks, follow these steps:

1. Login to the Role Editor using "roleadm".
2. Click File > New.
   You can also press Ctrl+N key to bring the Role Wizard window.
3. In the Welcome to Create new Role window, click Next.
4. In the Name the role window, provide the name of the role as "Manager" and enter a brief description for the new role.
5. Click Next.
6. In the Allow application access window, select the following applications:
   - Analyst
   - Dialer Server CUI menu
   - Editor Job
   - Health Manager
   - Hierarchy Manager
   - Monitor
7. Click Next.
8. In the Define the type of access window, specify the following permissions next to each application name using the drop-down list:

<table>
<thead>
<tr>
<th>Application</th>
<th>Access</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analyst</td>
<td>W</td>
</tr>
<tr>
<td>Dialer Server CUI Menu</td>
<td>W</td>
</tr>
<tr>
<td>Editor Job</td>
<td>W</td>
</tr>
<tr>
<td>Health Manager</td>
<td>W</td>
</tr>
<tr>
<td>Hierarchy Manager</td>
<td>W</td>
</tr>
<tr>
<td>Monitor</td>
<td>R</td>
</tr>
</tbody>
</table>

9. Click Next.
10. In the Finishing your role definition window, you can see the summary of the role that you created, the applications that you had selected, and their permissions.
11. Click Finish. The new role appears in the center panel under Role Name in the Role Editor window.
12. Click **File > Save** to save the new role.
   You can also press **Ctrl+S** key to save the role.

---

**Scenario 2: Create Identical Role as Administrator**

The administrator wants to create identical role as administrator.

**To create identical roles:**

1. Login to the Role Editor using "roleadm".
2. In the center pane, select the role named "Administrator".
3. Click **File > Save As...**.
4. In the Save dialog box, click **Yes** to save the role.
5. In the Save As window, provide a name and description for the new role.
6. Click **OK**.

You have successfully created a role identical to the role of administrator.

---

**Scenario 3: Assign a User to a Role**

The administrator wants to assign a user to the role created in **Scenario 1: Create a role for Manager to perform a specific task** on page 53.

**To assign user to the role "Manager" created in Scenario 1: Create a role for Manager to perform a specific task on page 53:**

1. Login to the Role Editor.
2. In the left pane, under Role, click **Administration**.
3. In the center pane, all the available roles will be populated.

   **Note:**
   For newly created "Manager" role, there will be no users assigned or listed in the assigned user box.

4. Click to select the "Manager" role.

   **Note:**
   When you click on the Manager role, you will see the application permissions in upper right hand box and the assigned users in the lower right hand box.

5. Right-click on the "Manager" role and select **User Assignment**....
Chapter 5: Scenarios for Role Editor

6. In the User Assignment - Manager window, under Available Users, select a user you would like to assign the "Manager" role.

You will see the permissions that the selected user has in the Effective permissions box on the left, under the Available Users box.

Note:
You can assign multiple users to a role. Multiple selections of user will not calculate the effective permission. It will show as Not Applicable in the lower left box.

7. Click the right arrow button (>,) to move the selected user from Available to Assigned users.

You can click double right arrow button (>>) to assign all the available users to the role.

You can select a particular user in the Assigned users box, and click left arrow button (<) to move the user to Available users box.

You can click double left arrow button (<<) to move all the users from the Assigned Users box to the Available Users box.

8. You will see the Effective permissions of the Assigned user in the Effective permissions box on the right, under the Assigned Users box.

9. Click OK.

You have successfully assigned a user to the "Manager" role.

Verify the permissions and the users assigned to the role:

1. Select the "Manager" role in the left pane.

2. The available permissions and the users assigned to that role will appear in the right pane.

Scenario 4: Test the Role Permissions

Test the role permissions on the supervisor application.

1. Login to the Editor using the user and password that you assigned to the Manager role.

You will see only the Editor Job option. You can perform the following:

- Run a job
- Edit job settings
- Create multiple jobs

2. Click on the system telnet icon on the menu bar. You should now be able to access the dialer using telnet.

3. Start a job.

4. Login an Agent to the job that you started in the above step.
5. Login to the Monitor using the user login that you assigned to the "Manager" role and verify that the data is being shown.
   You can create different hierarchies using the monitor.
6. Login to Analyst to view the historical reports.

Scenario 5: Create a Role with no Permissions

The administrator would like create a role which has no permissions defined.
Follow these steps to create a role which has no permissions:
1. Login to the Role Editor using "roleadm".
2. Click File > New.
   You can also press Ctrl+N key to bring the Role Wizard window.
3. In the Welcome to Create new Role window, click Next.
4. In the Name the role window, provide a name and brief description for the new role.
5. Click Next.
6. In the Allow application access window, click Next.
7. In the Define the type of access window, click Next.
8. In the Finishing your role definition window, you can see the summary of the role that you created, the applications that you had selected, and their permissions.
9. Click Finish.
   The new role will appear in the center panel under Role Name in the Role Editor window.
10. Click File > Save.
    You can also press Ctrl+S key to save the role.

Scenario 6: Create a Role by Merging two or more Roles

The administrator would like to create a new role by merging two or more roles.
To merge two or more roles:
1. Login to the Role Editor.
2. In the left pane, under Role, click Administration.
3. In the center pane, in the Role Name column, select a role, right-click on a role and select Merge....
   The Merge Roles window will appear.
Chapter 5: Scenarios for Role Editor

4. In the **New role name** field, type "mergedrole1" as a name for the new merged role.

5. In the **Description** field provide a brief description about the new merged role.

6. In the Available roles box, select the roles that you want to merge.
   
   You will see the permissions that the role has in the Effective permissions box on the left, under the Available roles box.

7. Click the right arrow button (>) to move the selected roles from Available to Assigned roles.
   
   You can click double right arrow button (>>) to assign all the available role to the user.
   
   You can select a particular role in the Assigned roles box, and click left arrow button (<) to move the role to Available role box.
   
   You can click double left arrow button (<<) to move all the roles from the Assigned Roles box to the Available roles box.
   
   You will see the Effective permissions of the Assigned roles in the Effective permissions box on the right, under the Assigned roles box.

8. Click **OK**.
   
   You have successfully merged the selected roles.

   **Note:**
   
   You can select merged role and create new merged role with the merged roles.

---

**Scenario 7: Assign User to a Merged Role**

Assigning user to a merged role created in Scenario 6: Create a Role by Merging two or more Roles on page 57.

To assign a user to a merged role created in Scenario 6: Create a Role by Merging two or more Roles on page 57:

1. Login to the Role Editor.
2. In the left pane, under Role, click **Administration**.
3. In the center pane, all the available roles will be populated.
4. Click to select "mergedrole1" role.

   **Note:**
   
   When you click on the mergedrole1 role, you will see the application permissions in upper right hand box, assigned users in the center right hand box, and the assigned roles in the lower right hand box.

5. Right-click on the "mergedrole1" role and select **User Assignment**....
6. In the **User Assignment - mergedrole1** window, under **Available Users**, select a user you would like to assign the role "mergedrole1".

   You will see the permissions that the selected user has in the Effective permissions box on the left, under the Available Users box.

   **Note:**
   You can assign multiple users to a role. Multiple selection of users will not calculate the effective permission. It will show as Not Applicable in the lower left box.

7. Click the right arrow button (>) to move the selected user from Available to Assigned users.

   You can click double right arrow button (>>) to assign all the available users to the role.

   You can select a particular user in the Assigned users box, and click left arrow button (<) to move the user to Available users box.

   You can click double left arrow button (<<) to move all the users from the Assigned Users box to the Available Users box.

8. You will see the Effective permissions of the Assigned user in the Effective permissions box on the right, under the Assigned Users box.

9. Click **OK**.

   You have successfully assigned a user to the "mergedrole1" role.

---

### Scenario 8: Edit a Merged Role

The administrator wants to edit a role merged in **Scenario 7: Assign User to a Merged Role** on page 58.

As an administrator, you can edit a merged role. You have the following option:

- Merge additional roles to the merged role
- Remove a role that was previously merged

To edit a Merged role:

1. Login to the Role Editor.

2. In the left pane, under Role, click **Administration**.

3. In the center pane, in the Role Name column, select "mergedrole1", right-click on the merged role and select **DeMerge**....

   The Merge Roles window will appear.

4. Select the roles that you want to merge in the Available roles box or select the roles that you want to remove from the merge from the Assigned Roles box.

5. Click the right arrow button (>) to move the selected roles from Available to Assigned roles.

   You can click double right arrow button (>>) to assign all the available role to the user. You
can select a particular role in the Assigned roles box, and click left arrow button (\(<\)) to move the role to Available role box. You can click double left arrow button (\(<<<\)) to move all the roles from the Assigned Roles box to the Available roles box.

6. You will see the Effective permissions of the Assigned roles in the Effective permissions box on the right, under the Assigned roles box.

7. Click **OK**.

You have successfully edited a merged role.

[Scenario 9: Rename a Role](#)

The administrator wants to rename a role created in [Scenario 1: Create a role for Manager to perform a specific task](#) on page 53.

To rename a role:

1. Login to the Role Editor.
2. In the left pane, under Role, click **Administration**.
3. In the center pane, in the Role Name column, select a role to be renamed.
4. Right-click on selected role and select **Rename**.

You can also rename the role by selecting the role and pressing F2 key on the keyboard.

You can also rename the role using the menu bar. Select the role and click **Edit > Rename**.

[Scenario 10: Delete a Role](#)

The administrator wants to delete a role.

To delete a role:

1. Login to the Role Editor.
2. In the left pane, under Role, click **Administration**.
3. In the center pane, in the Role Name column, select a role to be deleted.
4. Right-click on selected role and select **Delete**.
5. In the **Role Editor** dialog box, click **Yes**.

You can also delete the role by selecting the role and clicking the delete icon in the tools bar.

You can also delete the role using the menu bar. Select the role and click **File > Delete** or use the **Ctrl + D** key.
Scenario 11: Edit a Role Permission

The administrator would like to edit a role permissions.

To edit role permissions:

1. Login to the Role Editor.
2. In the left pane, under Role, click **Administration**.
3. In the center pane, in the Role Name column, select a role whose permission you want to modify.
4. In the right hand pane, under application select the application whose permission needs to be modified.
5. Click the permission field and select the required permissions.
6. Click **File > Save**.
7. You can also press **Ctrl+S** key to save the role.

Scenario 12: Assign a Role to Users

The administrator wants to assign the role created in Scenario 1: Create a role for Manager to perform a specific task on page 53 to users.

To assign role created in Scenario 1: Create a role for Manager to perform a specific task on page 53 to users:

1. Login to the Role Editor.
2. In the left pane, under Role, click **Users**.
3. Select a user name.

   **Note:** When you select a user name, you will see the roles that are assigned to that user in upper right hand box and the application permissions that the user has in the lower right hand box.
4. Right-click on the user name and select **Role Assignment**.
5. In the Role Assignment window, under **Available Roles**, select the role created in Scenario 1: Create a role for Manager to perform a specific task on page 53.

   You will see the effective permissions of the selected role in the Effective permissions box on the left, under the Available Roles box.
Chapter 5: Scenarios for Role Editor

Note:
You can assign multiple roles to a user. Multiple selections of roles will calculate the highest effective permission. It will show the highest applicable permission in the lower right box.

6. Click the right arrow button (>). to move the selected role from Available to Assigned roles.
   You can click double right arrow button (>>>) to assign all the available roles to the user.
   You can select a particular role in the Assigned roles box, and click left arrow button (<) to move the role to Available roles box.
   You can click double left arrow button (<<<) to move all the roles from the Assigned Users box to the Available Roles box.
   You will see the Effective permissions of the Assigned roles in the Effective permissions box on the right, under the Assigned Roles box.

7. Click OK.
   You have successfully assigned a role to a user.
Chapter 6: Understanding Health Manager

This section includes the following topics:

- **Overall Health Status** on page 63
- **Dialer Services** on page 63
- **Mid-Tier Services** on page 65
- **System Status** on page 66

**Note:**
The service names listed in the Health Manager vary according to the features configured on your system.

**Note:**
You can start and stop only the Mid-Tier All services using Health Manager; however, note that stopping or starting Mid-Tier All services does not start or stop some of the Mid-Tier services, such as serviceMonitor, serviceAct, NamingService and so on. The starting and stopping of All Dialer processes has been disabled in Health Manager. Also, the starting and stopping of individual processes in Dialer and Mid-Tier has been disabled in Health Manager.

---

**Overall Health Status**

The **Overall Health Services: Dialer Status** view shows the status of all the dialers in the system. For more information, see [View Overall System Health for All Dialers](#) on page 71.

---

**Dialer Services**

The **Dialer Services** view shows the status of all the services on the selected dialer in the system. From this view, you can view health status for the following dialer service categories:

- **Dialer Services: Core** on page 64
- **Dialer Services: Telephony** on page 64
- **Dialer Services: Data** on page 64
- **Dialer Services: Dialer Command Control and Administration** on page 64
Dialer Services: Core

The Dialer Services: Core view shows the status of core services on the selected dialer in the system. From this view, you can set alerts for the activity events related to each service. For more information, see View Dialer Core Services Information on page 72.

Dialer Services: Telephony

The Dialer Services: Telephony view shows the status of telephony services on the selected dialer in the system. From this view, you can set alerts for activity events related to each service. For more information, see View Dialer Telephony Services Information on page 73.

Dialer Services: Data

The Dialer Services: Data view shows the status of data services on the selected dialer in the system. From this view, you can set alerts for activity events related to each service. For more information, see View Dialer Data Services Health Information on page 74.

Dialer Services: Dialer Command Control and Administration

The Dialer Services: Dialer command control and administration view shows the status of command control and administration services on the selected dialer in the system. From this view, you can set alerts for activity events related to each service. For more information, see View Dialer Command Control and Administration Service Information on page 74.

Dialer Services: Health Related

The Dialer Services: Health related view shows the status of health related services on the selected dialer in the system. From this view, you can set alerts for activity events related to each service. For more information, see View Dialer Health Related Service Information on page 75.
Dialer Services: All

The Dialer Services: All view shows the status of all the services on the selected dialer in the system. From this view, you can set alerts for activity events related to each service. For more information, see View dialer health related service information.

Mid-Tier Services

The Mid-Tier Services view shows the status of all Mid-Tier services on the selected dialer in the system. From this view, you can view health status for the following dialer service categories:

- Mid-Tier Services: Framework on page 65
- Mid-Tier Services: Data on page 65
- Mid-Tier Services: Mid-Tier Command Control and Administration on page 65
- Mid-Tier Services: Health related on page 66
- Mid-Tier Services: All on page 66

Mid-Tier Services: Framework

The Mid-Tier Services: Framework view shows the status of Mid-Tier framework services on the selected dialer in the system. From this view, you can set alerts for activity events related to each service. For more information, see View Mid-Tier Framework Service Information on page 76.

Mid-Tier Services: Data

The Mid-Tier Services: Data view shows the status of Mid-Tier data services on the selected dialer in the system. From this view, you can set alerts for activity events related to each service. For more information, see View Mid-Tier Data Service Information on page 76.

Mid-Tier Services: Mid-Tier Command Control and Administration

The Mid-Tier Services: Mid-Tier Command Control and Administration view shows the status of Mid-Tier command control and administration services on the selected dialer in the system.
system. From this view, you can set alerts for activity events related to each service. For more information, see View Mid-Tier Command Control and Administration Service Information on page 77.

---

**Mid-Tier Services: Health related**

The Mid-Tier Services: Health related view shows the status of Mid-Tier health related services on the selected dialer in the system. From this view, you can set alerts for activity events related to each service. For more information, see View Mid-Tier Health Related Service Information on page 77.

---

**Mid-Tier Services: All**

The Mid-Tier Services: All view shows the status of all the Mid-Tier services on the selected dialer in the system. From this view, you can set alerts for activity events related to each service. For more information, see View All the Mid-Tier Services on page 78.

---

**System Status**

The System Status view shows the selected dialer’s CPU, disk, memory, and process status. From this view, you can view status for the following information:

- System Status: CPU Usage on page 66
- System Status: Disk Usage on page 67
- System Status: Memory Usage on page 67
- System Status: Processes on page 67

---

**System Status: CPU Usage**

The System Status: CPU view shows the selected dialer’s CPU usage statistics. For more information, see View CPU Usage Statistics on page 78.
System Status: Disk Usage

The **System Status: Disk** view shows the selected dialer’s hard-disk usage statistics. For more information, see [View Disk Usage Statistics](#) on page 79.

System Status: Memory Usage

The **System Status: Memory** view shows the selected dialer’s memory usage statistics. For more information, see [View Memory Usage Statistics](#) on page 80.

System Status: Processes

The **System Status: Processes** view shows the selected dialer’s processes statistics. For more information, see [View Processes Statistics](#) on page 81.
Chapter 7: Using Health Manager

Avaya Proactive Contact allows you to monitor the functioning of your system to improve reliability and maintainability.

This section contains the following topics:

- [Log In to Health Manager](#) on page 69
- [Change Display Options](#) on page 69
- [Refresh Health Manager Data](#) on page 70
- [Sort the List of Dialers, Services, or Events](#) on page 71
- [View Overall System Health for All Dialers](#) on page 71
- [View System Health for One Dialer](#) on page 71
- [View System Activity Events](#) on page 82
- [Subscribe to Activity Events](#) on page 82
- [Set Alerts](#) on page 83
- [Save Data as HTML](#) on page 84

---

Log In to Health Manager

To log in to Health Manager:

1. Select **Start > All Programs > Avaya > Proactive Contact > Health Manager** or double-click the Health Manager icon on the desktop.

2. Type your administrator user name and password on the login prompt, and then click **OK**.

When you log in to Health Manager the first time, you will see the **Overall Health Services: Dialer Status** view. From the drop-down menu below the toolbar in the upper left corner, you can choose to view the status of one dialer or all dialers (if you have more than one dialer) in your system.

Each time you log in to the Health Manager, you will see the last view you were viewing when you logged out of Health Manager.

---

Change Display Options

Using Avaya Proactive Contact Supervisor  
December 2011 69
You can choose to show or hide columns and adjust column widths in the right pane when viewing information.

---

**Show or Hide Columns**

To show or hide columns:

1. From the **Edit** menu, click **Hide/Show Columns**.
2. In the **Columns** dialog box, clear or select the check box. Alternatively, you can click the **Show All** or **Hide All** buttons.
3. Click **OK**.

   The Health Manager view changes to reflect your choices. Health Manager saves the column settings and reuses them the next time you log in.

   **Tip:**
   You may need to maximize the window, adjust the column sizes, or use the scroll bar to view all the columns. You can sort the listed items by clicking the column headings.

---

**Adjust Column Widths**

To adjust column widths:

1. Put your cursor near the column heading divider of the column you want to change until it changes into a column icon.
2. Drag the column divider to the desired length.

   The Health Manager view changes to reflect your choices. Health Manager saves the column width settings and re-uses them the next time you log in.

---

**Refresh Health Manager Data**

To refresh the Health Manager data in any view:

- On the **View** menu, click **Refresh**.

  **Note:**
  To refresh data in the **Activity Events Viewer**, click the **Refresh** button.
Sort the List of Dialers, Services, or Events

To sort the lists of dialers, services, or events:

- Click the column heading to sort in ascending or descending order.

  To reverse the sort order, click the column heading a second time. Health Manager saves
  the sort order and reuses it the next time you log in.

---

View Overall System Health for All Dialers

To view overall system health for all dialers:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to
   Health Manager. If this is the first time you have logged into the Health Manager, the
   Overall Health Services: Dialer Status view appears. If you have logged into Health
   Manager before to view system health, the screen you were viewing when you exited
   Health Manager appears.

2. If the Overall Health Services: Dialer Status view does not appear immediately after you
   log in, select All Dialers from the drop-down list in the upper left corner of the screen.

   The system displays the overall health statistics for all the dialers in the right pane.

<table>
<thead>
<tr>
<th>Status Item Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dialer Name</td>
<td>Name of dialer in your system configuration</td>
</tr>
<tr>
<td>Dialer IP Address</td>
<td>IP address for the selected dialer</td>
</tr>
<tr>
<td>Status</td>
<td>Indicates whether the system is up or down</td>
</tr>
<tr>
<td>Uptime</td>
<td>Duration of time the dialer has been up</td>
</tr>
</tbody>
</table>

---

View System Health for One Dialer

To view overall system health for one dialer:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to
   Health Manager. If this is the first time you have logged into Health Manager, the Overall
   Health Services: Dialer Status view appears. If you have logged into Health Manager
before to view system health, the screen you were viewing when you exited Health Manager appears.

2. Select a dialer name from the drop-down list in the upper left corner of the screen, below the toolbar. The left pane changes to show **Dialer Services** with icons for each aspect of dialer service health. From this view you can choose to do the following:

- [View Dialer Services](#) on page 72
- [View Mid-Tier Services](#) on page 75
- [View System Status](#) on page 78

---

### View Dialer Services

From the **Dialer Services** view, you can choose to do the following:

- [View Dialer Core Services Information](#) on page 72
- [View Dialer Telephony Services Information](#) on page 73
- [View Dialer Data Services Health Information](#) on page 74
- [View Dialer Command Control and Administration Service Information](#) on page 74
- [View Dialer Health Related Service Information](#) on page 75
- [View All the Dialer Services](#) on page 75

**Tip:**
You can sort the information in the view by clicking on the column headings.

### View Dialer Core Services Information

To view dialer core services health:

1. Log in to Health Manager as administrator. For information on logging in, see [Log In to Health Manager](#).

2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show **Dialer Services** with icons.

3. In the left pane under **Dialer Services**, click **Core**. Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Service Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AGENT</td>
<td>Agent activity manager</td>
</tr>
<tr>
<td>AGENT_BLENDER</td>
<td>AGENT_BLENDER</td>
</tr>
<tr>
<td>ACD_MONITOR</td>
<td>Blend activity monitor</td>
</tr>
</tbody>
</table>
To view dialer telephony services health:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to Health Manager.
2. In the left pane under **Dialer Services**, click **Telephony**. Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Service name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SWIF_CT</td>
<td>Avaya CT communications service</td>
</tr>
<tr>
<td>SWIF_DGn</td>
<td>Avaya PG230RM communications service (where n indicates the system number)</td>
</tr>
<tr>
<td>IVR_CONN</td>
<td>Dialer to Avaya IR connector</td>
</tr>
</tbody>
</table>

### View Dialer Data Services Health Information

To view dialer data services health:

1. Log in to Health Manager as administrator. For information on logging in, see [Log In to Health Manager](#).
2. In the left pane under **Dialer Services**, click **Data**. Heath Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Service name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HDSC</td>
<td>Historical data services client</td>
</tr>
<tr>
<td>EVENT_SERVICE</td>
<td>Dialer event services</td>
</tr>
<tr>
<td>DATA_MANAGER</td>
<td>Historical data recorder</td>
</tr>
</tbody>
</table>

### View Dialer Command Control and Administration Service Information

To view Dialer Command Control and Administration Service health:

1. Log in to Health Manager as administrator. For information on logging in, see [Log In to Health Manager](#).
2. In the left pane under **Dialer Services**, click **Dialer Command Control and Admin**. Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Service name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DCCS</td>
<td>Dialer command and control service</td>
</tr>
</tbody>
</table>
View Dialer Health Related Service Information

To view dialer health related services health:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to Health Manager.

2. In the left pane under Dialer Services, click Health related. Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Service name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DIALER_SA</td>
<td>Dialer Activation Service</td>
</tr>
<tr>
<td>DIALER_SM</td>
<td>Dialer Health Monitoring Service</td>
</tr>
<tr>
<td>DIALER_SH</td>
<td>Dialer System Health Monitoring Service</td>
</tr>
</tbody>
</table>

View All the Dialer Services

To view all the dialer related services:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to Health Manager.

2. In the left pane under Dialer Services, click All. Health Manager displays all the dialer services information in the right pane.

View Mid-Tier Services

From the Mid-Tier Services view, you can choose to do the following:

- View Mid-Tier Framework Service Information on page 76
- View Mid-Tier Data Service Information on page 76
- View Mid-Tier Command Control and Administration Service Information on page 77
- View Mid-Tier Health Related Service Information on page 77
- View All the Mid-Tier Services on page 78

Tip:
You can sort the information in the view by clicking on the column headings.
View Mid-Tier Framework Service Information

To view Mid-Tier framework services health:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to Health Manager.
2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show Dialer Services with icons.
3. In the left pane, click Middle-Tier Services. The left pane changes to show Mid-Tier services with icons.
4. Click Framework. Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Service name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LOGGER</td>
<td>Primary CORBA logging service</td>
</tr>
<tr>
<td>NAME_SERVICE</td>
<td>CORBA naming service</td>
</tr>
</tbody>
</table>

View Mid-Tier Data Service Information

To view Mid-Tier data services health:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to Health Manager.
2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show Dialer Services with icons.
3. In the left pane, click the Mid-Tier Services tab. The left pane changes to show Mid-Tier services with icons.
4. In the left pane under Mid-Tier Services, click Data. Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Service name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DATA_PUMP</td>
<td>Historical data database writer</td>
</tr>
<tr>
<td>STATS_PUMP</td>
<td>Real-time statistics database writer</td>
</tr>
<tr>
<td>RT_DATA</td>
<td>Real-Time Data Service</td>
</tr>
</tbody>
</table>
View Mid-Tier Command Control and Administration Service Information

To view Mid-Tier command control and administration service health:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to Health Manager.

2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show Dialer Services with icons.

3. In the left pane, click the Mid-Tier Services tab. The left pane changes to show Mid-Tier services with icons.

4. In the left pane under Mid-Tier Services, click Mid-Tier Command Control and Admin. Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Service name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CCS</td>
<td>Primary command and control service</td>
</tr>
</tbody>
</table>

View Mid-Tier Health Related Service Information

To view Mid-Tier health related service health information:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to Health Manager.

2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show Dialer Services with icons.

3. In the left pane, click the Mid-Tier Services tab. The left pane changes to show Mid-Tier services with icons.

4. In the left pane under Mid-Tier Services, click Health related. Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Service name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SERV_MON</td>
<td>Primary Health Monitoring Service</td>
</tr>
<tr>
<td>SERV_ACT</td>
<td>Primary Activation Service</td>
</tr>
<tr>
<td>SYS_HEALTH</td>
<td>Primary System Health Monitoring service</td>
</tr>
</tbody>
</table>
Chapter 7: Using Health Manager

View All the Mid-Tier Services

To view all the dialer related services:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to Health Manager.
2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show Dialer Services with icons.
3. In the left pane, click the Mid-Tier Services tab. The left pane changes to show Mid-Tier services with icons.
4. In the left pane under Mid-Tier Services, click All. Health Manager displays all the Mid-Tier services information in the right pane.

View System Status

From the System Status view, you can choose to do the following:

- View CPU Usage Statistics on page 78
- View Disk Usage Statistics on page 79
- View Memory Usage Statistics on page 80
- View Processes Statistics on page 81

Tip:
You can sort the information in the view by clicking on the column headings.

View CPU Usage Statistics

You can view the overall CPU usage and load of the selected dialer to monitor. This view allows you to detect where the system resources may be tied up serving a limited number of processes, while other critical processes are trying to run.

To view system status information on CPU usage:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to Health Manager.
2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show Dialer Services with icons.
3. In the left pane, click the System Status tab. The left pane changes to show System Status with icons.
4. In the left pane under **System Status**, click **CPU Usage**. Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Status Item Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>% Block Stat</td>
<td>Percentage of time spent in Blocked state</td>
</tr>
<tr>
<td>% Idle Stat</td>
<td>Percentage of time spent in Idle state</td>
</tr>
<tr>
<td>% Nice Stat</td>
<td>Percentage of time spent in Nice state</td>
</tr>
<tr>
<td>Speed (MHz)</td>
<td>Speed of the system in megahertz</td>
</tr>
<tr>
<td>% System State</td>
<td>Percentage of time spent in System state</td>
</tr>
<tr>
<td>% User State</td>
<td>Percentage of time spent in User state</td>
</tr>
<tr>
<td>Load Avg 15 Min</td>
<td>Processor load average during last fifteen minutes</td>
</tr>
<tr>
<td>Load Avg 5 Min</td>
<td>Processor load average during last five minutes</td>
</tr>
<tr>
<td>Load Avg 1 Min</td>
<td>Processor load average during last one minute</td>
</tr>
</tbody>
</table>

**View Disk Usage Statistics**

To view system status information on disk usage:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to Health Manager.
2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show **Dialer Services** with icons.
3. In the left pane, click the **System Status** tab. The left pane changes to show **System Status** with icons.
4. In the left pane under **System Status**, click **Disk Usage**. Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Status Item Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File System Available Blocks (KBytes)</td>
<td>Space available on volume partition</td>
</tr>
<tr>
<td>File System Free Blocks (KBytes)</td>
<td>Free space available on volume partition</td>
</tr>
<tr>
<td>File System Name</td>
<td>Disk volume partition name</td>
</tr>
<tr>
<td>File System % Used</td>
<td>Percentage of used space on volume partition</td>
</tr>
<tr>
<td>File System Total Blocks (KBytes)</td>
<td>Space on volume partition</td>
</tr>
<tr>
<td>File System Used Blocks (KBytes)</td>
<td>Used space on volume partition</td>
</tr>
</tbody>
</table>

**View Memory Usage Statistics**

You can see overall memory usage of the system to determine how much real memory is being used and how much swapping is occurring on the selected system.

To view system status information on memory usage:

1. Log in to Health Manager as administrator. For information on logging in, see **Log In to Health Manager**.
2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show **Dialer Services** with icons.
3. In the left pane, click the **System Status** tab. The left pane changes to show **System Status** with icons.
4. In the left pane under **System Status**, click **Memory Usage**. Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Status Item Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Active Real Memory (KBytes)</td>
<td>Real memory used</td>
</tr>
<tr>
<td>Active Virtual Memory (KBytes)</td>
<td>Virtual memory used</td>
</tr>
<tr>
<td>Free Memory (KBytes)</td>
<td>Free memory</td>
</tr>
<tr>
<td>Physical Memory RAM (MBytes)</td>
<td>Total random access memory (RAM)</td>
</tr>
</tbody>
</table>
View System Health for One Dialer

To view system status information on processes:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to Health Manager.

2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show Dialer Services with icons.

3. In the left pane, click the System Status tab. The left pane changes to show System Status with icons.

4. In the left pane under System Status, click Processes. Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Status Item Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Real Memory (KBytes)</td>
<td>Real memory</td>
</tr>
<tr>
<td>Virtual Memory (KBytes)</td>
<td>Virtual memory</td>
</tr>
<tr>
<td>%Memory Usage</td>
<td>Percentage of memory used</td>
</tr>
</tbody>
</table>

View Processes Statistics

To view system status information on processes:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to Health Manager.

2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show Dialer Services with icons.

3. In the left pane, click the System Status tab. The left pane changes to show System Status with icons.

4. In the left pane under System Status, click Processes. Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Status Item Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Process Name</td>
<td>Name of system process</td>
</tr>
<tr>
<td>Process ID</td>
<td>ID for system process</td>
</tr>
<tr>
<td>User ID</td>
<td>ID of user currently using process</td>
</tr>
<tr>
<td>% CPU Usage</td>
<td>Percentage of time process used by the CPU since last update</td>
</tr>
<tr>
<td>Nice Value</td>
<td>Nice value ranges from -20 to +20 specifying process priority</td>
</tr>
<tr>
<td>Priority</td>
<td>Current process priority</td>
</tr>
<tr>
<td>Size (KBytes)</td>
<td>Total virtual size of process</td>
</tr>
<tr>
<td>Resident set size for Process (KBytes)</td>
<td>Resident size of process</td>
</tr>
<tr>
<td>Time</td>
<td>Number of system and CPU seconds that a process has consumed</td>
</tr>
</tbody>
</table>
View System Activity Events

Use the Activity Event Viewer to see specific event activity which has occurred on the system. You can determine which service events appear in the viewer by subscribing to them. For more information see, Subscribe to Activity Events on page 82.

Tip:

The Activity Event Viewer lists the last 25 activity events. You can change the maximum number of events that Health Manager displays by choosing Tools > Options. The default is 25 events.

You can change the event threshold that triggers the system status events (CPU, memory, and disk usage) by choosing Tools > Options. For more information, see Set Threshold Parameters for System Status on page 92.

You can set the e-mail address to which you want the Health Manager to send activity event notifications by choosing Tools > Options.

If you unsubscribe to all the services, then you will only be notified when a service changes status.

To view system events:

1. Click the Activity Event Viewer icon on the Health Manager toolbar. Health Manager displays the Activity Event Viewer dialog box. The viewer shows the following information for each event:
   - Date and time of the event
   - Dialer name
   - Dialer IP address
   - Service name associated with the event
   - Status of the event with detailed information
   - Event name

   Note:
   DIALERSTATUS is an event, and not a service. Therefore, the value of the service name field for DIALER STATUS is displayed as 0.

2. Click Close to close the dialog box and return to the main Health Manager statistics view.

Subscribe to Activity Events
You can determine which service events appear in the Activity Event Viewer by subscribing to them. For more information about the Activity Event Viewer, see View System Activity Events on page 82.

**Tip:**

The Activity Event Viewer lists the last 25 activity events. You can change the maximum number of events Health Manager display by choosing Tools > Options. The default is 25 events.

You can change the event threshold that triggers the system status events (CPU, memory, and disk usage) by choosing Tools > Options. For more information, see Set Threshold Parameters for System Status on page 92.

You can set the e-mail address to which you want the Health Manager to send activity event notifications by choosing Tools > Options.

If you unsubscribe to all the services, then you will only be notified when a service changes status.

To subscribe to activity events:

1. Click the Action menu, and then click Subscribe to Service Events.
2. In the Subscribe to Activity Events dialog box, click on the service to subscribe. Health Manager displays a description of each service that you select at the bottom. You can also use the Select All or Unselect All buttons to subscribe or unsubscribe to events.
3. Click OK.

   When an event occurs, Health Manager displays the Activity Event Viewer. The viewer shows you the following information for each event:
   
   - Date and time of the event
   - Dialer name
   - Dialer IP address
   - Service name associated with the event
   - Status of the event with detailed information
   - Event name
4. Click Close to close the dialog box and return to the main Health Manager statistics view.

---

**Set Alerts**

You can use the Alert Editor to set alerts for system status conditions and e-mail notifications for events.
To set alerts:

1. From the **Tools** menu, click **Alerts** or click the **Alert Viewer** icon on the Health Manager toolbar.

2. If you have MAPI services available (e-mail services), Health Manager displays the **E-mail Notification Configuration** dialog box. Click **Yes** to set e-mail notifications.

3. In the **Alert Viewer** dialog box, click **Add**. Health Manager displays the **Alert Editor**.

4. On the **Alert Definition** tab, you can select an event and then set a value. Health Manager sends you an alert when an event occurs which meets the condition on the system or pod. For example, you can set the Call Handling event for Average Idle Time to be greater than (> ) 10 minutes. Click **Apply**.

5. On the **Scope** tab, select the option to receive alerts on any or all of the following areas:
   - a specific dialer or any dialer
   - a specific job or any job
   - a specific agent or any agent

   Click **Apply**.

6. On the **Notifications** tab, you can set how the Health Manager displays the alerts. Choose one or more of the following alert notification methods:
   - **Display alert** displays the Alert Viewer.
   - **Sound alert** plays a sound.
   - **Send e-mail** sends an e-mail to the address you enter. You can also add other text that appears in the e-mails sent by Health Manager.

   **Tip:**
   Set the e-mail address to which you want Health Manager to send activity event notifications from **Tools > Options**.

   Click **Apply**.

7. Click **OK**.

---

**Save Data as HTML**

Save Health Manager data to an HTML file for viewing in a browser.

To save data as HTML:

1. From the **File** menu, click **Save as HTML**.
2. In the **Save As** dialog box, type a file name.
3. Click **Save**.
Configure Health Manager

Use the Avaya Proactive Contact Configurator to set the primary dialer and the license server details and location. Health Manager displays the Configurator dialog box when you log in to the Health Manager for the first time. You may need to contact your system administrator for the information.

To configure Health Manager:

1. From the Tools menu, click Mid-Tier Configurator or click the Mid-Tier configurator icon on the Health Manager toolbar.

2. In the Configurator dialog box, enter the following information:
   - Primary Proactive Contact Details:
     - Name: Enter the name of the primary dialer
     - IP Address: Enter the primary dialer IP address
   - Email Server Details:
     - Name: Enter the name of the e-mail server you want to use with Health Manager e-mail notifications
     - IP Address: Enter the e-mail server IP address
   - Database Server Details:
     - Name: Enter the name of your database server
     - IP Address: Enter the database server IP address

3. Click OK to save your settings.
Chapter 8: Maintaining Health Manager

**Important:**
If you change the primary dialer specification, you must stop and then restart the Health Bridge service. For more information, see [Start and Stop the Health Bridge Service](#) on page 90.

---

**License Configurator**

License Configurator is used to provide the URL of the WebLM server which provides the license to the Avaya Proactive Contact.

To change the License server URL:

1. From the **Tools** menu, click **License Configurator**.
2. In the License Configurator dialog box, specify the URL of the WebLM server which has the Proactive Contact license.
3. Click **OK**.

---

**Start and Stop the Health Bridge Service**

Avaya Proactive Contact Health Bridge is a service that provides information about Avaya Proactive Contact systems to Health Manager. This information includes the status of the services on the Dialing Servers, system health (CPU, disk, memory, and processes), and also includes the ability to activate and deactivate services.

The Health Bridge also reports on services and system functioning that may have been hampered and may have gone down to Health Manager.

**Note:**
The physical location of Health Bridge is in %%PDSServices%% directory (which by default is: C:\Program Files\Avaya\Proactive Contact\Services\Common directory).

The Health Bridge can be in one of two states: stopped or started. Additionally, there are two intermediate states for Health Bridge: starting and stopping.

**Important:**
You do not have to manually start Health Bridge. When you start Health Manager, Health Bridge starts automatically.

A reason to manually stop and start the Health Bridge is when you switch between a pod of dialers. You typically do this when you make configuration changes in Health Manager in the
Start and Stop the Health Bridge Service

Configurator dialog box. For more information on the Configurator, see Configure Health Manager on page 89.

⚠️ Important:
Any changes made to the configuration require that you stop and then start the Health Bridge using one of the three methods described below.

You can start or stop Health Bridge services in any of the following three ways:

**From the Microsoft® Management Console -**

To start or stop Health Bridge from the Microsoft Management Console:

1. From the Start menu, select Control Panel > Administrative Tools > Services.
   - The system displays the Microsoft Management Console Services window with a list of services in the right pane.
2. Right-click on Health Bridge, then click Properties.
   - The system displays the Health Bridge properties dialog box.
3. Press Stop under Service status to stop Health Bridge.
4. Press Start under Service status to start Health Bridge.

**From the Command Prompt -**

To start or stop Health Bridge from the command prompt:

1. From the Start menu, select All Programs > Accessories > Command Prompt.
2. Type `net stop HealthBridge` at the prompt and press Enter.
3. Type `net start HealthBridge` at the prompt and press Enter.

**From the Microsoft® Windows Task Manager -**

To stop Health Bridge from the Task Manager:

1. Press Ctrl+Alt+Delete.
2. Click Task Manager.
3. Click on the Process tab.
4. Locate HealthBridge.exe in the processes list.
5. Select HealthBridge.exe and click End Process.

To start Health Bridge from Task Manager:

1. Press Ctrl+Alt+Delete.
2. Click Task Manager.
3. On the menu bar, click on File, and then click New Task (Run...).
4. In the Create New Task window, type HealthBridge.exe.
5. Click **OK**.

---

**Set Threshold Parameters for System Status**

You can change the thresholds that trigger activity events that appear in the *Activity Event Viewer* or that are sent in an e-mail to you. In a pod environment, these thresholds apply to all the dialers in the pod.

**Tip:**

The *Activity Event Viewer* lists the last 25 activity events. You can change the maximum number of events that Health Manager displays by choosing **Tools > Options**. The default is 25 events.

You can set the e-mail address to which you want Health Manager to send activity event notifications by choosing **Tools > Options**.

If you unsubscribe to all the services, then you will only be notified when a service changes status.

For more information, see *Subscribe to Activity Events* on page 82.

To set activity event thresholds:

1. From the **Tools** menu, click **Options**.

2. Under **System Parameter Settings**, type a percentage for each of the following parameters:

   - CPU threshold
   - Memory usage
   - Disk partition usage

   The default percentage is 80%.
Chapter 9: Customize Editor

The Avaya Proactive Contact allows you to customize the appearance of your Editor windows to help you navigate within Editor.

This section contains the following topics:

- Understanding Editor on page 93
- Navigate among the Tool applications on page 95
- Move within Contact Management on page 95
- View icons in the button group on page 96
- Refresh a view on page 96

Understanding Editor

This section provides information that will help you use Editor to create and maintain phone strategies, record selections, and jobs.

This section contains the following topics:

- Editor window description on page 93
- Editor screen layout and usage on page 93

Editor window description

The Contact Management button group in Editor allows you to move among Strategies, Selections, Selection Reports, and Jobs. Each feature has a very similar look and feel.

Editor screen layout and usage

Editor contains two panes with the button group displayed to the left. The left-hand pane contains either summary information or a list of titles or files. The right-hand pane contains a tree with settings that you define and modify.

To display settings in the right-hand pane, select a field in the left-hand pane.

This section contains the following topics:
Chapter 9: Customize Editor

- **Button group** on page 94
- **Sort** on page 94
- **Resize columns** on page 95
- **Resize panes** on page 95

**Button group**

The button group expands and contracts to display additional buttons. When you click the button group, buttons appear. You can resize the buttons.

Depending on your login, you see the **Contact Management**, and **Messages and Scripts** buttons.

Use the **Contact Management** group to move between the following features:
- Strategies
- Selections
- Selection Reports
- Jobs

Use the **Messages and Scripts** group to move between the following features:
- Messages
- Scripts

Use the **Calling Lists** group to move between the following features:
- Calling Lists
- Do Not Call Groups
- Reports

Use the **Agent Keys** group to move between the following features:
- Agent Keys
- Reports

Use the **Schedule** group to move between the following features:
- Activities
- Reports

**Sort**

You can click most column headings to sort the contents of the column.
When you click a heading, you see a small arrow appear alongside the heading. A small arrow that points up indicates that the data is in ascending order. A small arrow that points down indicates that the data is in descending order.

Resize columns

You can resize any column in a view by hovering your cursor between the heading titles until a double-arrow appears. Press the left mouse button while you drag the cursor to the left or to the right.

Resize panes

You can resize the panes by hovering your cursor on the divider line that separates the panes until a double-arrow appears. Press the left mouse button while you drag the cursor to the left or to the right.

Navigate among the Tool applications

Editor comes with tool applications that you access from the Tools menu. To start Tool menu applications:

1. Select Start > All Programs > Avaya Proactive Contact > Supervisor > Editor.
2. To start a tool, select its name from the Tools menu.

While you use the tool, Editor remains open in the background so you can navigate back to it when you are finished using the tool.

Move within Contact Management

Use the Strategies, Selections, Selection Reports, and Jobs buttons on the button bar to move within the Contact Management features. Editor prompts you to save your work when changing to another feature. When prompted, you can choose not to save your work, too.

To select a Contact Management feature:

1. Select Start > All Programs > Avaya Proactive Contact > Supervisor > Editor.
2. Click the Contact Management button group.
3. Click the following buttons:
   - Strategies to launch the phone strategy editor
Chapter 9: Customize Editor

- **Selections** to launch the record selection editor
- **Selection Reports** to launch the record selection reports editor
- **Jobs** to launch the job editor

---

**View icons in the button group**

You can view large or small buttons on the button group. To switch between large and small icons in the button group:

1. On the button group, click to expand the button group whose icon size you want to change.
2. Right-click, and then select either **Large Icons** or **Small Icons**.

   A check mark next to the menu command indicates which view you are currently using.

---

**Refresh a view**

To refresh an open view, press the F5 key.
Chapter 10: Understanding staging

This section describes how a supervisor can modify the dialer configuration files in the Supervisor applications and store and deploy on the Dialer. The processes and requirements described in this section are related to the configuration files and can be modified using the Editor.

This section contains the following topics:

- **Overview** on page 97
- **Types of configuration files** on page 98
- **Stages of configuration files** on page 101
- **Basic rules for working with configuration files** on page 103
- **Backup and restore of configuration files** on page 107

**Note:**

You must have the write access to make any changes to the configuration files using the Editor.

Overview

One of the challenges of editor is the coordination of configuration changes on the dialer. In some cases, a change may be immediately activated on the dialer without impacting any existing processes or files; in others cases a change may be catastrophic. For example, deleting an existing completion code can create a problem if that code used to indicate which records should be uploaded to the host at the end of the day.

Another challenge related to managing changes is the need to introduce changes to the dialer in a timely fashion. For examples:

- You create a new calling list and want to use the calling list immediately.
- You set up a customer's system and want to implement certain data immediately which can be used to configure other parts of the system.
- You add new completion codes and want to immediately set up record selections with these codes.

The solution to this, is to define and implement a set of management rules for how changes are made to the configuration files. The rules coordinate the changes while minimizing their impact on ongoing operations and progress the files through a set of logical stages.
Types of configuration files

A specific configuration file may depend on one or more other configuration files and at the same time, have configuration files that are dependent on it.

The dependency relationships occur when the files are being defined. This dependency does not correspond to run-time dependencies among these files. For example, to configure a job you need the calling list configuration files and to run a job you need only the calling list.

The configuration files are of two types. The types are:

- Primary configuration file
- Secondary configuration file

Primary configuration file

- These are configuration files that other configuration files depend on.
- These files are generally created and changed relatively infrequently.
- Examples are telephony.spt, compcode.cfg, and calling list applications.
- These files are accessible by users having appropriate permissions.
- Changing primary configuration files can function abruptly in catastrophic ways, their manipulation is restricted to having appropriate permissions.
- Some files can be considered primary as the files meet all the criteria but only become Active once dialer restarts.

Secondary configuration file

- These files depend on one or more primary configuration files.
- The secondary configuration files are created and changed frequently by having appropriate permissions.
- These files include jobs, selections, and strategies and are used for day-to-day operations.
- Only users having appropriate permissions can change the secondary configuration files.
- If secondary configuration file stops functioning, you can recover the file by replacing the current changes.

The following table provides a list of characteristics of the configuration files.
<table>
<thead>
<tr>
<th>File Identity</th>
<th>Delete (Yes/No)(^1)</th>
<th>Type</th>
<th>Dependent On</th>
<th>Files Impacted</th>
</tr>
</thead>
<tbody>
<tr>
<td>Job(^2)</td>
<td>Yes</td>
<td>Secondary</td>
<td>● Agent key</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● Calling list application</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● Job</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● Do Not Call (DNC)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● Screen</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● Selection</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● telephny.spt</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● voicemail.cfg</td>
<td></td>
</tr>
<tr>
<td>Selection(^2)</td>
<td>Yes</td>
<td>Secondary</td>
<td>● Calling list application</td>
<td>Job</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● Completion code</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● Strategy</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● Time zone</td>
<td></td>
</tr>
<tr>
<td>Strategy(^2)</td>
<td>Yes</td>
<td>Secondary</td>
<td>● Calling list application</td>
<td>Selection</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● Completion code</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● Time zone</td>
<td></td>
</tr>
<tr>
<td>Completion code</td>
<td>No</td>
<td>Primary</td>
<td></td>
<td>● Agent key</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● Calling list application</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● Job</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● Selection</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● Strategy</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● telephny.spt</td>
<td></td>
</tr>
<tr>
<td>Voice message</td>
<td>No</td>
<td>Primary</td>
<td></td>
<td>● Agent key</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>● telephny.spt</td>
</tr>
<tr>
<td>Calling list application(^3)</td>
<td>Yes, except the calling list data, which can only be deleted using the Character User Interface (CUI).</td>
<td>Primary</td>
<td>● Completion code</td>
<td>● Agent key</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>● Job</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>● Screen</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>● Selection</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>● Strategy</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>● telephny.spt</td>
</tr>
</tbody>
</table>
### Chapter 10: Understanding Staging

<table>
<thead>
<tr>
<th>File Identity</th>
<th>Delete (Yes/No)</th>
<th>Type</th>
<th>Dependent On</th>
<th>Files Impacted</th>
</tr>
</thead>
</table>
| Agent key     | Yes             | Primary | ● Calling list application  
               ● Completion code  
               ● telephony.spt  
               ● Voice message | ● Job           |
| Schedule      | No              | Primary | ● Calling list application  
               ● Job  
               ● Selection |               |
| telephony.spt | No              | Primary | ● Calling list application  
               ● Completion code  
               ● Voice message | ● Agent key  
               ● Job       |

1. A file that cannot be deleted is one that is essential for system operation. In other words, there must always be an Active version of that file, and that file cannot be deleted. A file of the same name in any other stage can be deleted.

2. Users having appropriate permissions can access these files, however, they can make changes only to the versions that are in Active stage. They can also see the instances of effectively Active versions.

3. This is a set of files including .dict, .fdict, .xfr, .prep, and a calling list.
Stages of configuration files

A stage is an attribute of a configuration file, which indicates the file’s current use or status. A file can be in a stage that allows editing, active use, or deletion.

Stages of configuration files are as follows:

- Active
- Pending
- InProgress
- Deleted
- Null

The following table provides a detailed description of the stages of the configuration files, the locations of the files, and their precedences.

<table>
<thead>
<tr>
<th>Stage</th>
<th>Precedence</th>
<th>Description</th>
<th>Location of Files</th>
<th>Further Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Active</td>
<td>1 (highest)</td>
<td>Active stage file is the one that is currently in use by the dialer.</td>
<td>● In a location where it is available for operation.</td>
<td>● Continue the operation</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● When the dialer services start, all files load into the shared memory.</td>
<td>● Basis for revisions</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>● Active</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>● InProgress</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>● Pending files</td>
</tr>
<tr>
<td>Pending</td>
<td>2</td>
<td>The file is modified by one or more users and made active next time when the dialer services are started.</td>
<td>/opt/avaya/pds/staging/pending</td>
<td>● If you edit the configuration file, the file’s stage may remain Pending or changed to InProgress.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>● The editor can explicitly delete a file in this stage.</td>
</tr>
<tr>
<td>Stage</td>
<td>Precedence</td>
<td>Description</td>
<td>Location of Files</td>
<td>Further Use</td>
</tr>
<tr>
<td>-----------</td>
<td>------------</td>
<td>------------------------------------------------------------------------------</td>
<td>----------------------------------------</td>
<td>----------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| InProgress| 3          | The file is modified by one or more users, but it is not ready to become active. The user puts the file in this stage with the intention that additional work needs to be done. | /opt/avaya/pds/staging/inprogress      | • If you edit the file, the file’s stage may remain InProgress or changed to Pending.  
• The editor can explicitly delete a file in this stage. |
| Deleted   | 4          | • The file was Active but replaced by a Pending copy when the dialer was last restarted. Currently the file is in a "wastebasket" and can be recovered until permanently deleted.  
• Only primary configuration files are moved to Deleted stage.  
• Secondary files are immediately deleted when replaced on system restart. | /opt/avaya/pds/staging/pending        | • Deleted stage files can be saved as Pending or InProgress.  
• The editor can explicitly delete a file in this stage.  
• Otherwise Deleted stage files are permanently removed from the system after a configurable period of time has elapsed. |
| Null      | 5 (lowest) | The file is deleted and is no longer recoverable (except, by a restore of a backup set). | Not on the system. The file may be on a backup media. | Only for an unplanned restore. |
Basic rules for working with configuration files

A number of rules are applied to managing changes to the configuration files so as to achieve a flow among tentative changes, desired changes, committed changes, and obsolete configurations.

Users having appropriate permissions can perform the following changes in the Editor:

1. Create new or modify the existing files
   - You can modify the secondary files in any stage and primary files only in Pending or InProgress.

   **Note:**
   Despite Schedule being a primary file, it can be modified in Active stage as well, barring some restricted activities. For more information, refer to *Restrictions for Scheduling* on page 244
   - You can select a "New" option in the Editor to create a file from scratch.

   **Note:**
   In Editor, you cannot select the "New" option for the following files:
   - Completion codes
   - telephny.spt
   - Voice messages
   - Schedule files
   These files cannot be deleted from Active stage.

2. For any depended-on files, you need to designate the stage to use, except the following:
   a. Editor determines the file stage to use
      - If a given file is presented in only one stage, Editor selects that file stage. Otherwise you are presented with a choice of list of file stages.
   b. The depended-on stage can only be Active or Pending (not InProgress or Deleted).
   c. If a file of the designated stage is not available, the next higher precedence available stage is used.
      - If no Pending files are available, the Editor restricts the choice to Active.
      - If the needed file does not exist at any higher precedence stage, this is reported to you.

3. You can save the file to any stage, except the following:
   a. Files cannot be saved to the Deleted stage.
   b. Only secondary files or a calling list application can be saved or "Make Active" to the Active stage if there depended-on files are in active.
c. The saving file’s stage has to be same or lower than the depended-on file’s stage.

d. You can save Agent keys, Calling list application, Job, Selection, and Strategy files under a different name. Any other configuration file of the same name and stage is overwritten according to the following:
   - The same file name is already exist—you are asked to confirm if you want to overwrite that file.
   - All other files have one copy each in any stage and the name is always the same—you are not asked to confirm and the file is overwritten.

e. When saving to a different stage or filename, the original file is kept as it is. You can delete the original file if required.

4. You can perform the following other operations in the editor:

a. Verification of files—the Editor has separate option to verify files; it is not part of the save operations. There may be an exception for telephony.spt.

b. You can explicitly delete files in any stage, except the following:
   - The only files that you can delete from the Active stage are: Agent keys, Calling list application (except the calling list data), Job, Selection, and Strategy.

c. Staging has no impact on file locking or vice versa—for example, you make changes to an Active job but keep the file open for editing so long that the lock expires, you have the normal option of overwriting the existing Active file or saving the file under a new name.

d. When saving to multiple systems in a dialer pod—the associated depended-on files and other files that get replaced, need to be in synchronization, assuming you have consistently propagated changes to the members of the pod. Note that verification can be used as a separate operation to detect any inconsistencies.

The following operation is performed when you restart the dialer:

1. Pending files are moved to the Active stage
2. Primary Active files replaced by a Pending file are moved to the Deleted stage.
3. Secondary Active files replaced by a Pending file are hard deleted.

   **Note:**
   Secondary files do not go to a Deleted stage.

4. Active or Deleted files replaced by a file of the same name are overwritten.
   - Only the latest copy of a Deleted file at any given name is kept.
   - The retention period for Deleted files start anew whenever a newly created Deleted file overwrites a prior Deleted file.

The following operation is performed when retention period of Deleted file is exceeded (you can specify the retention period of the Deleted file):

- Deleted Primary files are hard deleted.

You can backup of configuration files as follows:
Basic rules for working with configuration files

- Configuration files in all stages are backed up as part of backing up all configuration files. For more information on configuration file backup, see [Backup and restore of configuration files on page 107](#).

The following table provides detailed rules descriptions for working with configuration files:

<table>
<thead>
<tr>
<th>Types of Operation</th>
<th>Initial file being changed</th>
<th>Allowed Stage(s) of depended-on files</th>
<th>Allowed Stages for save</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Type</td>
<td>Stage</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Use Editor to build or change a file</td>
<td>Secondary</td>
<td>Active Pending</td>
<td>Active Pending</td>
<td>Any Secondary file can be saved in Active (Require to Active all depended-on files).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>In Progress</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Use Editor to delete</td>
<td>Secondary</td>
<td>Active Pending</td>
<td>N/A</td>
<td>All Secondary files are hard deleted.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>In Progress</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Use Editor to build a new or change an existing file</td>
<td>Primary</td>
<td>Pending In Progress</td>
<td>Active² Pending³</td>
<td>A newly created calling list application can be &quot;Make Active&quot; (Require to Active all depended-on files). New cannot be done for the following:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

1. Stages for save are at or below the selected stage of depended-on files.
2. New cannot be done for the following:
   - Completion Codes
   - telephry Spl.
   - Voice Messages
   - Schedule files.
### Types of Operation

<table>
<thead>
<tr>
<th>Initial file being changed</th>
<th>Allowed Stage(s) of depended-on files[^1]</th>
<th>Allowed Stages for save</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Editor to delete a file</td>
<td>Primary</td>
<td>N/A</td>
<td>Only certain files can be deleted from the Active stage. For more information, see <a href="#">Types of configuration files</a> on page 98.</td>
</tr>
<tr>
<td>Use Editor to recover a Deleted file</td>
<td>Primary</td>
<td>Open file only for purpose of recovery</td>
<td>Exception to precedence allowed recap-turing of Deleted files. <strong>Note:</strong> The primary configuration files on which the deleted file depends may no longer be available or may have changed.</td>
</tr>
</tbody>
</table>

[^1]: Undefined stage; this column is not described in the text.
Backup and restore of configuration files

<table>
<thead>
<tr>
<th>Types of Operation</th>
<th>Initial file being changed</th>
<th>Allowed Stage(s) of depended-on files</th>
<th>Allowed Stages for save</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Restart dialer</td>
<td>Primary, Secondary</td>
<td>Pending</td>
<td>N/A</td>
<td>Active&lt;sup&gt;2&lt;/sup&gt; Pending can move to Active but only by dialer restart. If there is a name conflict (the Pending file has the same name as an existing Active file) the Active file is overwritten.</td>
</tr>
<tr>
<td>Restart dialer after Deleted retention period is exceeded</td>
<td>Primary, Secondary</td>
<td>Deleted</td>
<td>N/A</td>
<td>Null Really deleted Erased</td>
</tr>
<tr>
<td>Primary</td>
<td>Active</td>
<td>N/A</td>
<td>Deleted</td>
<td>Active files replaced by Pending files become Deleted.</td>
</tr>
</tbody>
</table>

1. This is not the designated stage. The depended-on files are opened read-only and read into the Editor. No changes are made to the depended-on files. The designated stage can be Active, in which case only Active depended-on files are used; or it can be Pending, in which case Pending stage is used; or if the needed file doesn’t exist in Pending, then Active is used. For more information, see Basic rules for working with configuration files on page 103.

2. Exception to or constraint on general precedence rule – see comments in table.

3. The user chooses to use Pending files during editing, the user cannot pick and choose between Pending and Active stage of depended-on configuration files. However, if a specifically needed Pending file is not available, the Active file is used. For example, the user is creating a Job, which in turn uses completion codes. If the user select to use Active depended-on files, that is used. If user select to use Pending depended-on, that is used. If the Pending depended-on file is not available, Editor uses the Active version. User cannot change the selected version until quits or saves the initial file.

Backup and restore of configuration files
Chapter 10: Understanding staging

All types of configuration files of all stages are need to be included in applicable backup operations. There several types of backup and restore options are present.

Backup options are mentioned in the following:

- All the system configuration files—backup all types of configuration files of all stages.
- The entire system excluding the calling lists—backup all staged configuration files of all stages excluding the calling list.
- The entire system including the calling lists—backup all staged configuration files of all stages.

Restore options are mentioned in the following:

- All files from any backup tape created using the backup menu commands—restore all stages of configuration files to their correct locations.
- Restore a single file from any backup tape created using the backup menu commands—restore a configuration file, when selected, to its correct location.
- Verification features—operate on all configuration files saved on a backup tape.
Chapter 11: Understanding Editor settings

Editor allows you to see large amounts of information in a single window. The buttons on the left-hand pane filter the type of information you see.

Note:
Refer to Chapter 3: Permissions in Role Editor on page 41 for permissions related to Editor.

Strategies - Lists the existing phone strategies on the right-hand pane in the window. If you select a phone strategy in the list, the settings appear on the tabs. You can add rows and modify phone strategy settings.

Selections - Lists the existing record selections. If you select a record selection, the settings appear on the tabs. To modify the record selection settings, select the fields in the tree structure.

Selections Reports - Lists the record selections that were previously run. Selection Reports contains summary information that you do not modify.

Jobs - Displays a tree structure on the right-hand pane of the window. The tree structure lists the settings for the selected job. To modify the job settings, select the fields in the tree structure.

In Editor, Avaya Proactive Contact allows you to enable or disable multi-dialer commands and set your Save and Refresh options.

This section contains the following topics:

- Enable or disable multi-dialer commands on page 109
- Save options on page 110
- Set refresh options on page 110

Enable or disable multi-dialer commands

To enable or disable multi-dialer commands:

1. In Editor, select Settings > Options.
2. In the Options dialog box, click the Multi-dialer tab.
Note:
This option is only enabled when the dialer is in a pod configuration.

3. Select Enable to enable multi-dialer commands. Select Disable to disable multi-dialer commands. For more information, see the following topics:
   - Options, Multi-dialer tab on page 240
   - Multiple dialers (POD configuration) on page 26
   - Pods on page 26

4. Select the dialer.

5. Click Apply to save your changes.

6. Click OK to save your changes and close the dialog box.

---

Save options

The Save option allows you to display or not to display a confirmation prompt when you select File > Save As to save changes to an exiting file.

To set Save options:

1. In Editor, select Settings > Options.
2. In the Options dialog box, click the Save tab.
3. Select Prompt before overwrite to receive a prompt before saving. Select Overwrite without asking to save without receiving a prompt. For more information, see Options, Save tab on page 240.
4. Click Apply to save your changes.
5. Click OK to save your changes and close the dialog box.

---

Set refresh options

To set how often Editor refreshes the data displayed on your screen:

1. In Editor, select Settings > Options.
2. In the Options dialog box, click the Refresh tab.
3. Select the interval at which you want Editor to refresh. For more information, see Options, Refresh tab on page 241.
4. Click Apply to save your changes.
5. Click **OK** to save your changes and close the dialog box.
Chapter 11: Understanding Editor settings
Chapter 12: Calling Lists

A calling list is a file that contains customer records. Avaya Proactive Contact uses two types of calling lists, one for outbound calling, and one for inbound calling on Intelligent Call Blending systems.

This chapter contains the following sections:

- Creating a calling list on page 113
- Synchronizing calling list data with host on page 133
- Tools for using calling lists on page 141
- Calling list features on page 128
- Do not Call Groups (DNC) on page 143
- Calling List Reports on page 141
- Additional features for using calling list on page 145

Creating a calling list

This section lists the procedures for creating and making a calling list available for calling purposes. The procedures described in this section must be performed in the given sequence to successfully create a calling list.

The following sections provides information about Calling list:

- Create a new calling list on page 114
- Import data to create Download Dictionary on page 114
- Download From Host on page 116
- Download Dictionary on page 120
- Import Download Dictionary to Calling List Dictionary on page 124
- Download Map on page 121
- Processing on page 124
Create a new calling list

To create a new calling list:

1. In the Editor button bar, select New. The Calling List application wizard appears.
2. Click Next to go to the next page of the wizard. Specify the following information:
   - What kind of activity will the calling list support: Specify the calling list as inbound or outbound.
   - Your new calling list will be named: Specify the name of the calling list.
   - Description: Provide a brief description for the new calling list.
3. Click Next. The information provided in the previous page appears in the Review this information section. To change any details, click Back and make the necessary changes.

Note:
To import sample records from a test file to build a Data dictionary, select the Launch Import Wizard check box to launch the Data Import wizard. For more information on steps of Data Import, refer to the Import data to create Download Dictionary on page 114.

4. Click Finish. Your new calling list appears in the list of calling lists in the Calling lists Panel.

Import data to create Download Dictionary

The Data Import Wizard takes a sample host data file, analyzes the file, and creates a download dictionary.

After creating a calling list, you can add calling records data to the Download dictionary either manually or by importing data from a host data file.

You can import data for calling by identifying the record format that you want to use. The data that you wish to import must satisfy the following criteria:

- The sample data file must contain 10-50 records.
- The sample data file must be fixed width or CSV format.

Then verify the analysis of the data import wizard and modify fields as required.

Import a Data File

To import a data file:

1. Right-click the specific list and select Download From Host.
2. In the right-hand pane, click the Download Dictionary tab.
Creating a calling list

3. Right-click and select **Data Import** wizard.

4. Click **Next** when the **Data Import** wizard appears.

5. Select the **Data Type**. The Data type refers to the type of date in a particular field, for example: Delimited or Fixed length. You can select from the following options:

   - **Delimited** - Delimiter refers to csv file that carries fields and records separated with delimiters, which are special characters.
   - **Fixed length** - Fixed width indicates that the width or length of each field is defined and thus the length of the record as a whole is defined. The maximum supported record length is 4096 bytes.

6. If you select **Delimited** as the Data Type for import, perform the following steps:

   1. Click **Browse** to locate your sample file.
   2. Select the **First record contains column names** check box, if the first record in your sample file defines column names. Here, column names means the processed calling list data dictionary field names. The sample file should have the first record with fields populated with the calling list field names to save time later.
   3. Click **Next**.
   4. Specify the criteria used in your host file to differentiate records from each other in the **How are records separated from each other?** field.

   **Tip:**
   If the download file is CSV format and the delimiter is Line Feed, do not enable the Remove Line Feed. Enabling the Remove Line Feed will cause problems in creating calling list on the dialer. For more information on Remove Line feed, see **Download From Host** on page 116.

   5. Specify the criteria used in your host file to differentiate fields from each other in the **How are fields separated from each other?** field.

   6. Click **Next**. The records from the sample file are displayed in columns format on the **Field Names** page. As per the criteria specified in step 4 and 5, the data from the sample file is parsed into the appropriate columns.

   You can define field names at this stage. There must be at least one phone defined, and each phone field should be in the format PHONE1, PHONE2, and so on.

   **Tip:**
   One of the records in the sample file must contain the maximum number of characters that each field can contain in the host database. The wizard, then, will read that in the final calling list and define the maximum character width for the final calling list.

   7. Click **Finish** to import the sample file.
Chapter 12: Calling Lists

7. If you select **Fixed width** as the Data Type for import, perform the following steps:

1. Specify the exact length of each of the records in the **Record Length** field.

2. Click **Browse** to locate your sample file.

3. Click **Next**. All the records are displayed on the **Record Length** page.

4. Click **Next**. The Field Length page displays the analysed field length. To further define the character length of a field, click the specific character in the field length section. For example, if you have clicked number 10 as the character for a specific field, a vertical line automatically appears as the field length. You can also drag the line to specify a different character length as a field length. To remove the vertical line, click the line again. If required, click on each column header to change the name of the field or fields.

5. After you have finalized the field length, Click **Next**. The field name page displays the data populated in the fields as defined by you.

6. To define the name of each calling list field, click on the column header and enter the field names. Also, there must be at least one phone defined, and each phone field must be in the format PHONE1, PHONE2, and so on.

7. Click **Finish** to import the sample file.

---

**Download From Host**

The Download From Host feature displays the configuration data associated with download data from the host to the dialer. This information includes the transfer method, the transfer schedule, the format of the host data, and directions for handling certain types of file data.

The following table displays the name and description of the rows available in the Download From Host tab:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Method</td>
<td>This represents the title row for grouping related data.</td>
</tr>
<tr>
<td>Type of Transfer</td>
<td>This represents the method used to transfer data from the host to the dialer.</td>
</tr>
<tr>
<td></td>
<td>The acceptable values are SFTP transfer initiated by host and SFTP transfer</td>
</tr>
<tr>
<td></td>
<td>initiated by dialer. If you select the Initiated by dialer option, the</td>
</tr>
<tr>
<td></td>
<td>following four data elements are enabled; otherwise, they are disabled.</td>
</tr>
</tbody>
</table>
### Creating a calling list

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Host Name</td>
<td>This represents the name of the Host computer. You can use any of the following as an entry in the Host field.</td>
</tr>
<tr>
<td></td>
<td>- An alias, which must be manually entered into the <code>/etc/hosts</code> file</td>
</tr>
<tr>
<td></td>
<td>- An IP address</td>
</tr>
<tr>
<td></td>
<td>- Or a fully qualified domain name</td>
</tr>
<tr>
<td>Logon Name</td>
<td>This represents the user ID that the dialer uses to logon to the host system.</td>
</tr>
<tr>
<td>Password</td>
<td>This represents the Password that you use to logon to the host computer.</td>
</tr>
<tr>
<td>Host File Name</td>
<td>This represents the name of the data file that is present on the host computer.</td>
</tr>
<tr>
<td>Raw Data File Name</td>
<td>This represents the File name of the Raw Data file. The filename must be changed if the host will be writing a different named file to the dialer CPU when host initiates the FTP.</td>
</tr>
<tr>
<td>Schedule</td>
<td>This represents the title row for grouping related data.</td>
</tr>
<tr>
<td>Stop download time</td>
<td>This represents the time when the system will stop attempting the download of the calling list. This setting works based on the time set on the dialer.</td>
</tr>
<tr>
<td>Retry if download fails</td>
<td>This check box indicates whether you should reattempt a failed download. Failed downloads occurs if the host file is not available at the time of the initial download attempt (automated download from Scheduled events)</td>
</tr>
<tr>
<td>Delay between downloads (sec)</td>
<td>This represents the number of seconds to wait between attempts. This setting works based on the time set on the dialer.</td>
</tr>
<tr>
<td>Format</td>
<td>This represents the title row for grouping related data.</td>
</tr>
<tr>
<td>Record Size</td>
<td>The size in bytes of each host record.</td>
</tr>
<tr>
<td>Block Size</td>
<td>This represents the size in bytes of each block. This field should always be left at default of 10 times of the Record Size.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Blocks Read</td>
<td>This represents the number of blocks read at a time. This field should always be left at default value of 10.</td>
</tr>
<tr>
<td>Skip Records</td>
<td>This represents the number of records to skip before starting to convert the host data. For example, if the host sends a header record of field name data which should not be converted to a calling list record.</td>
</tr>
<tr>
<td>Records to read</td>
<td>This represents the total number of records to read from the host. For example, use this field if the business requires to limit a calling list to X number of records but the host sends more records than expected. If you do not want any limit, leave this field blank.</td>
</tr>
<tr>
<td>Do not verify record length</td>
<td>This check box indicates whether the verification process should be run during download. For example, if this check box is selected, and if the raw file is not evenly divisible by the record length, then the system will cancel the list processing.</td>
</tr>
<tr>
<td>Text case</td>
<td>The options available for selection of text case are Uppercase, Lowercase, and Title case. You need to select the appropriate text case based on case type of the raw data. For example, if the data has all upper case text, then select Uppercase as the Text case.</td>
</tr>
<tr>
<td>Record Format</td>
<td>The options available for record format are Fixed Length and Character Separated Values (CSV). If CSV is chosen, the next two rows are enabled; otherwise, the rows are disabled.</td>
</tr>
<tr>
<td>Record delimiter</td>
<td>This represents the character that marks the boundary between one record and the next. You can either use the drop-down selections or enter another character for the delimiter values.</td>
</tr>
<tr>
<td>Field delimiter</td>
<td>This represents the character that marks the boundary between one field and the next.</td>
</tr>
</tbody>
</table>
## Creating a calling list

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Qualifier</td>
<td>When reading CSV files, when the host data need to include the characters set as the Record or Field Delimiters, the data string can be qualified with this specified value. The default value for this field is double quotes (&quot;'); however, you can configure any other special character as a qualifier (except the following reserved characters - colon, comma, and period). For example, if the field delimiter is set to comma, and qualifier is double quote, when a field values from the host needs to include a comma, it is sent as follows: John Doe,&quot;1234 Tenth Ave, Apt 4b&quot;,Newark (example of NAME,ADDRESS,CITY)</td>
</tr>
<tr>
<td>Preparation</td>
<td>This represents the title row for grouping related data.</td>
</tr>
<tr>
<td>Append records to calling list</td>
<td>This check box indicates that the records in this download must be appended to the existing records instead of overwriting the records.</td>
</tr>
<tr>
<td>Remove Carriage Returns</td>
<td>This check box indicates that carriage returns should be removed from the end of each record from the host data file.</td>
</tr>
<tr>
<td>Remove Line Feeds</td>
<td>This check box indicates that line feeds should be removed from the end of each record from the host data file.</td>
</tr>
<tr>
<td>Run custom process at beginning of download</td>
<td>This allows you to select your own custom scripts at the beginning of a download. You can have more than one custom script. For example: If you want to copy your raw data file name and you have created a custom backup script, you can enter the script name in this field.</td>
</tr>
</tbody>
</table>
This screen displays a list of all fields in the download data file.

Brief description of the columns of the Download Dictionary tab is as follows:

- **Field** - The name of a download field.

  **Note:**
  - The field name has to be in all caps, for example: SYSNUM. Also, the supported length for the field name is 15 characters.

- **Data Type** - This field represents the type of data contained in the field. The drop-down lists all the available data types.

- **Length** - This field represents the length of the data.

  **Note:**
  - The overall length of the record is displayed as a sub-total at the top of the grid and the data is not-editable. This length of the data field is the maximum number of characters that will be read in the case of a CSV file. Therefore, this field should always be set to the maximum number of characters that the host might send for each field.

- **Same Start** - Is a check box to indicate that the field has the same starting position as the previous field.

- **Start** - This field displays the character position in the file where the field starts. Normally this is calculated as the start position of the previous field and the length of the previous field. If you select the Same Start check box, this is calculated as the start position of the previous field.

- **End** - This is a non-editable field that displays the character position that marks the end of the field. This is calculated by adding the field's length to the field's start.

### Download Dictionary

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Run custom process after download</td>
<td>This allows you to select your own custom scripts after download. You can have more than one custom script.</td>
</tr>
<tr>
<td>Switch Year</td>
<td>This represents the year. This option is available if the host is sending two digit years. The year that marks when 20 should prefix or added at the beginning to represent a 2-digit year data. Before this year, 19 is prefixed. The default is 70. This field is used with the &quot;Transformation&quot; map feature to convert host data. For example, MMDDYY is converted into MM/DD/NNYY format.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Name Description</th>
<th>Description</th>
</tr>
</thead>
</table>
Creating a calling list

- Description - This field allows you to enter a user-defined description of the field.
- Host Only Field - This is the associated Host Field name in the calling list.

Note:
When the Host Only Field check box is selected, then the field and data will not be defined in the final calling list when imported to the Calling List Dictionary.

Download Map

The Map tab allows you to configure how download data is transformed into calling list data on a field-by-field basis. You can create a new transformation and also edit and delete existing transformations.

Create a new Download Map

Follow these steps to create a new map transformation of calling list data:

1. Select the specific Calling List.
2. Right-click and select Download from Host.
3. Click the Map tab in the right-hand pane. An empty Map pane appears with the following columns:
   - Download Field
   - Transformation
   - Download Data
   - Calling List Data
4. Right-click on any one the column headers and select New. The Download Map window appears.
5. Select the required field type in the Field Type drop-down list. The available options are:
   - Merge - This option allows you to merge one or multiple fields in the host file to create a new field in the download dictionary.
   - Transformation - This option allows you to change one value into another value based on regular expressions. All the field values that match a specific regular expression are transformed to a specified value. This transformation allows a specified host value to be translated into a specific calling list value.
   - RSM - The RSM option represents Record Specific Messaging. This option allows you to specify a new name for the RSM field and associate a source field to the specific default message. You can also define a message by entering the host data and associating the host data to the specific message. You can also add and remove rows in the Define Message section.
Chapter 12: Calling Lists

6. If you select the field type as **Merge**, perform the following steps:

   1. Type the name of the new merged field in the **Enter name for the new merged field** text box.
   2. Select the fields to be merged from the **Select the fields and the order for merging** list. To select multiple fields from the list, hold down the **Ctrl** key and click on the required fields.
   3. Click **Add** to confirm the fields for merging.
   4. To change the order in which the fields must be merged, select the field and click **Move Up** or **Move Down**.
   5. Click **OK**. The newly created map appears under the Map tab.

7. If you select the field type as **Transformation**, perform the following steps:

   1. Select the field that is to be mapped in the **Select unmapped field** drop-down list.
   2. Click the required tab for the corresponding transformation type and enter the corresponding values. The options are:

      ● **Fill** - You use the Fill tab to apply a fill function to the mapped field. The entered characters are used to fill the specified field. If there is already any content present, it is replaced with the Fill characters.

      ● **Format** - You use the Format tab to define the format of the download field and the mapped field. This option transforms the data strings. For example, you can choose to convert MM DD YY format to MM-DD-NYYY format or convert HHMMSS time format to HH.MM.SS time format. Note that the spaces in the Host format are not expected in the data from the host. The host will send MMDDYY, and the dialer adds spaces and dashes. Therefore, 6 characters from the host convert to 10 characters when it goes from MMDDYY to MM-DD-NYYY. In date formats, the NN in NYYY is the century switch year function.

      You can choose from several options for format transformation.

      ● **Translate** - You use the Translate tab to convert specific strings in the download field to specific strings in the mapped field. Use the Dialer default option to insert the specified value if the host value does not match any of the other values.

   **Note:**

   You can change the field length in the calling list. For example, if the host sends 3 characters, it can be translated into 20 character output, if desired.

   3. Click **OK**.

8. If you select the field type as **RSM**, perform the following steps:

   1. Type a new field name which will contain the RSM information in the **Enter name for new RSM field** text box. This field is specified in the jobs.
   2. Select the field which contains values from the host on which the message choice is based from the **Select source field** drop-down list.
Creating a calling list

3. Select the message to be played from the Default Message drop-down list. The default Message is played if the field value does not contain any other specified value.

4. You can further add conditions to play record specific messages to the records in the calling list. Click Append to add a row in the Define Message pane.

5. Type a specific condition for which a record specific message must be played in the Host Data text box. For example, if you have defined country as the required field in the Select source field, then, you can add a condition that if country equals to Japan, play a message in Japanese language.

Note:
You can use wildcard and regular expressions in the Host Data field.

6. Select the corresponding message from the Message drop-down list for the condition specified in the Host Data field.

Note:
You can add multiple such conditions for RSM by using Appendix button to add a new row. Use Remove button to delete a condition for RSM.

7. Click OK.

Note:
For more information on Record Specific Messaging, see Record Specific Messaging on page 145

Edit a Download Map

Follow these steps to edit an existing download map transformation of calling list data:

1. Select the specific Calling List.
2. Right-click and select Download to Host.
3. In the Map tab, select the required row.
4. Right-click on the row and select Edit.
5. Make the required changes and click OK.

Delete a Download Map

Follow these steps to delete an existing download map transformation of calling list data:

1. Select the specific Calling List.
2. Right-click and select Download to Host.
3. In the Map tab, select the required row.
4. Right-click on the row and select Delete.
   The specific download map transformation is deleted.
Chapter 12: Calling Lists

Note:
If a download map modifies the field lengths or adds new fields (RSM), then the import download dictionary to calling list dictionary should be performed again after the changes are saved.

Import Download Dictionary to Calling List Dictionary

You must import data from the Download Dictionary tab to the Calling List Dictionary for the calling list to function successfully.

To import data from Download Dictionary:

1. Right-click on the required calling list in the Calling List pane and select the Calling List Details option.
2. Click on the Calling List Dictionary tab.
3. Right-click and select the Import from Download Dictionary option. The fields in the Calling List Dictionary are synchronized as per the fields defined in the Download Dictionary.

The Calling List Dictionary tab displays the field names along with the attributes for each of the field. It displays information about the field name, data type whether character or numeric, length of each field, and field description.

If RSM has been activated from the Download from Host > Map tab, then the RSM column is displayed along with the information about the field that has been selected for the RSM feature. Note that it is a non-editable column.

If Latelist has been activated from the Download from Host > Processing tab, then the Latelist column is displayed. You can select the fields on which you want to use the Latelist functionality.

Processing

The Processing tab displays a list of processes that run on the downloaded data as part of the process of converting the data into a calling list.

The processes are listed in the order in which they are run.

The process, Set timezones, is by default the first process to be run and cannot be moved or deleted.

You can change the order of the process by right-clicking on a process, then selecting either Move Up or Move Down from the pop-up menu.
The following table displays the name and description of the rows available in the Processing tab:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set timezones</td>
<td>Sets the timezone for the calling list. This is a non-editable field.</td>
</tr>
<tr>
<td>Index calling list for quick sorting and searching</td>
<td>Select this check box to enable indexing to allow quick searching and sorting of records in a calling list.</td>
</tr>
<tr>
<td>Key field</td>
<td>Specify the key field based on which indexing of records must be performed.</td>
</tr>
<tr>
<td>Index calling list for Do Not Call processing</td>
<td>Select this check box to enable indexing to mark records as Do Not Call in a calling list. For example, if an agent marks a record as DNC, the record is given a unique identifier, which then is added to the Index file. When that record is encountered again, the system searches for the record in the Index file, therefore enabling quick sorting.</td>
</tr>
<tr>
<td>Key field</td>
<td>Specify the key field based on which indexing of records for Do Not Call must be performed.</td>
</tr>
<tr>
<td>Remove Duplicate Records</td>
<td>Select this check box to enable removal of duplicate records in the calling list. Note that the duplicate records are not removed from the system, but marked as duplicate. The first record is marked with a &quot;*&quot; in the DUPE field and subsequent records are marked with an R in the STATUSFLAG, thus making them uncallable.</td>
</tr>
<tr>
<td>Match field</td>
<td>Specify the field based on which the records must be marked as duplicate. For example, ACCTNUM.</td>
</tr>
<tr>
<td>LATELIST</td>
<td>Select this check box to enable Latelist feature for the calling list. Latelist allows field values to be carry forwarded if the same record is in the calling list on the next download.</td>
</tr>
<tr>
<td>Match compcodes</td>
<td>Specify the completion codes which must be used to track the calls. Only those calls with the specified completion codes will be tracked. You can select multiple completion codes.</td>
</tr>
</tbody>
</table>
### Chapter 12: Calling Lists

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calculate aging</td>
<td>Select this check box to enable calculation of days for which a record is appearing in the calling list. This functionality works only if the record based on Match Field appears on all consecutive downloads.</td>
</tr>
<tr>
<td>Match field</td>
<td>Specify the field which must be considered for calculating the age of the record in the calling list.</td>
</tr>
</tbody>
</table>
| Maximum days on system              | Specify the maximum days for which a record can be included in a calling list. After the specified number of days, the record will be marked as uncallable. This parameter has dependency on "Number of days in a work week" parameter. For example, if the "Maximum days on system" is set as 7 and then "Number of days in a work week" is set to 6, the record will be marked uncallable in the next week.  

  **Note:** This parameter will only work if "Mark records uncallable after maximum days" parameter is set to Yes. |
| Number of days in a work week       | Specify the number of days to be considered in a work week. For example, for a Monday to Friday week, the value in this field will be 5.       |
| Mark records uncallable after maximum days | Select this check box to mark a record as uncallable after reaching the maximum number of days as specified in the Maximum days on system field. |
| Restore records formerly marked uncallable | Select this check box to restore records that have been marked as uncallable in the calling list.                                           |
| Run Reports                         | These fields allow you to specify the criteria to run reports. These are CUI reports which you can run upon completion of the download. For more information refer to Administering Avaya Proactive Contact guide. |
### Name | Description
--- | ---
Days on dialer | Select this check box to include the days for which a record has been existing on dialer in the report.
Reject records | Select this check box to include the rejected records in the report.
Release | Select this check box to include the completion code of the record in the report.
Insert area codes based on zip codes | Select this check box to insert area codes in the calling list based on the zip codes. This field cross-references the zip code from each calling list record with a list of predefined zip codes to obtain the corresponding area code, and inserts the area code into the specified calling list field(s).
Zip code field | Specify the field name that corresponds to the zip code in the calling list.
Area field | Specify the field name that corresponds to the area code in the calling list.
Only replace blank area codes | Select this check box to perform zip code to area code conversion only for the records that have blank area codes. This check box prevents accidental overwriting of area codes that already exist.
Custom script | Select this check box to run any custom script that you might want to use for performing any additional action on the calling list. These scripts are executed from /opt/avaya/pds/customs directory on the dialer. To add any custom scripts, contact Avaya support.
Script name | You can select a script from the drop-down menu. The drop-down menu will only be available if there are any custom scripts added in the opt/avaya/pds/customs directory on the dialer.
Script Parameter | Specify the parameters for the custom script.
Calling list features

You can configure various features at the calling list level to enable or disable certain features for the calling list.

To enable various features for calling lists:

1. Right-click on the required calling list and select the **Calling List Details** option.
2. You can configure various features for calling lists under the **Features** tab.

The following table details the features that you can configure for a calling list:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>This is a pre-populated field. This field has two information:</td>
</tr>
<tr>
<td></td>
<td>● Number of phone fields: List the number of phone fields present in the calling list.</td>
</tr>
<tr>
<td></td>
<td>● List is part of the Do Not Call group: This checks whether the list is part of the Do not call group. If yes, there is a check mark next to the &quot;List is part of the Do Not Call group&quot;.</td>
</tr>
<tr>
<td>Post Update</td>
<td>Postupdate on page 128</td>
</tr>
<tr>
<td>Infinite Jobs</td>
<td>Infinite Jobs on page 129</td>
</tr>
<tr>
<td>Campaign Update</td>
<td>Batch Campaign Update on page 130</td>
</tr>
<tr>
<td></td>
<td>Real Time Campaign Update on page 131</td>
</tr>
<tr>
<td>Native Voice and Data Transfer</td>
<td>Native Voice and Data Transfer (NVDT) on page 131</td>
</tr>
<tr>
<td>Sales Verification</td>
<td>Sales Verification on page 132</td>
</tr>
</tbody>
</table>

**Postupdate**

The postupdate binary updates a calling list with information from the job statistics files for each attempt to call a record. The Postupdate process is sometimes referred to also as due diligence. It is imperative for Due Diligence reporting that is required to be maintained by the users to prove that a record was contacted a certain number of times before various actions were taken.
When the calling job completes, if a POSTUPDATE variable is defined in the job file, the postupdate binary is run.

The postupdate binary runs using the configuration parameter values in the file. For example, it tracks the number of attempts made on phones with specified completion codes, and then updates the specified calling list with the data from the job stat file.

To enable postupdate feature:
1. Select a calling list.
2. Right-click the calling list, and select **Calling List Details**.
3. On the **Features** pane, select the **Postupdate** check box. This enables the following four fields.
   - **Number of phones to update**: Specify the number of phone to be updated. Even if there is only one phone in the calling list, two phones must still be configured for the postupdate binary to run. You can configure up to a maximum of nine phones.
   - **Number of call attempts to keep**: Number of call attempts to track per phone. The maximum value for this field is 5 call attempts.
   - **Maintain history of attempts**: This field has two options:
     - Keep initial attempts: Only tracks the results of the first through X attempts (Number of call attempts to keep).
     - Overwrite initial attempts: Tracks the results of the last X attempts (Number of call attempts to keep).
   - **Update record codes**: The release codes to be considered while updating the calling list, for example 02,03,11,13, etc., or * (for all). When you double-click on this field, a Completion Codes window appears. You can select the required completion code from the list. If you select all the Completion Codes, a "*" will appear in the Update records codes field (which will include future completion codes created at a later time). If you select individual codes and new codes are created which need to be tracked, you will need to add those codes here later.

---

**Infinite Jobs**

You can configure the Infinite Job option available under the Features tab in the Calling List section in Editor.

To enable Infinite job feature:
1. Select a calling list.
2. Right-click the calling list, and select Calling List Details.
3. Click the **Features** tab and select the **Infinite job** option.

4. This enables the following five fields.

   a. **Key for removing duplicate records:** Select the unique field from the drop-down. For example: ACCTNUM

   b. **Key for indexing records:** Select the field to be used for searching the records. For example: "ACCTNUM". This field is same as the "Indexing" field used for indexing calling list (Download Dictionary > Processing > Key field for Indexing).

   c. **Key for indexing Do Not Call processing:** Select the field to be used for searching the Do Not Call records. For example: "ACCTNUM". This field is same as the "Index calling list for Do Not Call processing" field used for indexing Do Call Processing (Download Dictionary > Processing > Key field for indexing Do Not Call processing).

   d. **LATELIST:** Latelist allows data from previous day’s calling list to be updated in the new infinite download depending upon completion codes.

   **Note:**
   LATELIST will only update the new records if they exist in the prior day's calling list. LATELIST does not update from records called earlier in the present day.

   e. **Sort newly downloaded records after download:** An option that allows you to choose whether the newly downloaded records will be sorted into the existing records.

   **Key for sorting:** A drop-down of calling list fields that allows you to select the field that will be used for sorting. The fields will be sorted by this field in descending order.

The process of setting calling list into Active stage automatically creates Infinite Job and selection files that is used for Infinite Job Campaign. The infinite job will be available in Jobs under Contact Management as **Infinity##**. The Infinite selection will be available in Selection under Contact Management as **Infinity##**. Here # is number from 1 to 999. This number is the same number as the calling list number.

**Note:**
The Make Active option for calling list will be available only if the calling list is in Pending stage and there is no Active version of the same calling list. If the calling list is in In Progress stage, then save the calling list in Pending stage. Pending staged calling list will be set to Active stage during next maintenance cycle.

**Batch Campaign Update**

The Batch Campaign Update function allows you to specify records that should be marked by the system as uncallable. This is similar to deleting a record.

To enable Batch Campaign Update:

1. Create new outbound calling list or use an existing calling list.

2. Right-click on an outbound calling list, which is created in pending stage, and select **Calling list details** option.
3. Select the **Campaign Update** check box.

4. Select the update mode as Batch from the **Update Mode** drop-down list. You can select **Both** if you want both Batch and Real-time update to be enabled.

5. Select the index value, which is a field in the calling list, from the **Index** drop-down list. This value is used as a unique value using which the records are searched, and the matching records are marked as uncallable. As you select the value of **Index** field, the **Start**, **Length**, and **Type** fields are populated accordingly.

6. If you want to run a custom script on the searched records before the file transfer, provide the name of the script in the **Run custom script on new records before file transfer** field.

7. If you want to run a custom script on the searched records after the file transfer, provide the name of the script in the **Run custom script on new records after file transfer** field.

8. Click **Save**.

For more information on scheduling a campaign update, see **Schedule a Campaign Update** on page 247

---

**Real Time Campaign Update**

Real-time campaign update allows inbound call results to be transferred to the matching account on an outbound calling list. Real-time campaign update marks the outbound record as not-callable on the basis of unique ID, completion code, and job parameters. For example, when inbound calls are received from customers whose accounts have crossed the due date, the real-time update allows this call result to be transferred to the same record on an outbound list so that the customer does not receive additional calls.

To enable Real Time Campaign Update:

1. Create new outbound calling list or use an existing calling list.

2. Right-click on an outbound calling list, which is created in pending stage, and select **Calling list details** option.

3. Select the **Campaign Update** check box.

4. Select the update mode as Real Time from the **Update Mode** drop-down list. You can select **Both** if you want both Batch and Real-time update to be enabled.

5. Click **Save**.

---

**Native Voice and Data Transfer (NVDT)**

The Native Voice and Data Transfer function enables any outbound agent on an Outbound or Blend Job to transfer their current call (both voice and data) to any inbound or blend agent actively joined to an Inbound or Blend Job. When the transfer is made to the inbound agent, the
data from the outbound calling list can be populated in an inbound record. The transfer can be made supervised or unsupervised (blind). On a supervised transfer, the agent stays on the line until the transferee picks up the call, therefore creating a three-way conversation. On a blind (unsupervised) transfer, the agent transfers and releases the call at the same time.

The Native Voice and Data Transfer feature is a standard feature for all Proactive Contact systems with Overflow Blend.

To enable Native Voice and Data Transfer:

1. Create new outbound calling list application and save it in pending stage.
2. Right-click on outbound application, which is created in pending stage, and select Calling list details option.
3. Click the Features tab and select the Native Voice and Data Transfer option.
4. Click the Calling List Dictionary tab and select the fields (For example. ACCTNUM, BALANCE) which are required for NVDT.
5. Save the application.
6. Create inbound calling application in pending stage.
7. Right-click on inbound application, which is created in pending stage, and select Calling list details option.
8. Right-click anywhere on the right pane and select Configure NVDT option. The Inbound NVDT dialog box is displayed which contains the list of all calling lists, which are configured for NVDT.
9. Select the calling list, which was created in Step 1. This will add all the fields selected for outbound list. If the length/type of any field(s) in inbound calling list is mismatching with field(s) of outbound list (which are marked for use in NVDT Step 4) then a message will be displayed.
10. Save the inbound application.
11. Make outbound and inbound application active using Make Active option.
12. In outbound and inbound job, select the respective calling lists for which NVDT feature is configured.

Note:
The Name of Inbound Job to transfer calls to option should have the name of inbound job, which is using the list created above. The Name of Inbound job to transfer calls to option is present in the outbound job configuration.

Sales Verification

The Sales Verification configuration setting verifies a transaction or commitment that the customer made. Use the Sales Verification option when starting a Sales Verification job. You can enable sales verification option for a calling list.
To enable sales verification for a calling list:

1. Right-click on outbound calling list, which is created in pending stage, and select **Calling list details** option.
2. Click the **Features** tab
3. Select the **Sales Verification** check box.

---

**Synchronizing calling list data with host**

You can optionally synchronize the calling list data with host.

To synchronize data with host, you must perform the following procedures:

- [Data Export](#) on page 133
- [Upload To Host](#) on page 134
- [Upload Map](#) on page 138
- [Upload Dictionary](#) on page 137
- [Select Records](#) on page 139

---

**Data Export**

The Data Export Wizard helps you to prepare for uploading calling list data to the host computer. Specifically, the wizard prompts you to select which records and fields should be exported. Based on your responses, as well as information from the associated download (data import), the wizard creates a new upload definition and completes the Upload to Host, Upload Dictionary, Upload Map, and Select records tabs.

The use of this wizard is to quickly create a data export definition that fulfills the needs of most customers. Thus, it supports straightforward implementations. If you have more complex requirements, the wizard may be used to create the basic definition and then you can refine the definition using the full user interface.

**Export a Data File**

To export a data file, you have to define the following fields:

- Define the records you want to export
- Identify the fields of the calling list from which you want to export the data
- Define the fields that will be uploaded to the host
You can export a data file, using any of the following two ways:

To export a data file:

1. Right-click the specific list and select **Upload To Host**.
2. The Data Export Wizard appears. Click **Yes** to start the Data Export wizard.
3. Click **Next**.
4. Select the appropriate **Records**, **Date**, **Results**, **Field**, and **Field Value**.
5. Click **Next**.
6. Select the fields that you want to export by selecting the specific check boxes.
7. Click **Finish**.

If you have selected the **No** option at Step 2 and you want to export the data at a later stage, you can do so by following these steps:

1. Click **Upload Dictionary** tab.
2. Right-click and select **Create New Set**.
3. The Data Export Wizard appears. Click **Next**.
4. Select the appropriate **Records**, **Date**, **Results**, **Field**, and **Field Value**.
5. Click **Next**.
6. Select the fields that you want to export by selecting the specific check boxes.
7. Click **Finish**.

---

**Upload To Host**

The Upload to Host feature displays the configuration data associated with upload data from the dialer to the host. This information includes the transfer method, the transfer schedule, the format of the host data, and directions for handling certain types of file data.

The following table displays the name and description of the rows available in the upload to host tab:
### Name

<table>
<thead>
<tr>
<th>Method</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>This represents the title row for grouping related data.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Type of Transfer</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>This represents the method used to transfer data from the dialer to the host. The available values are File transfer initiated by host and File transfer initiated by dialer. If you select the File transfer initiated by dialer, the following four data elements are enabled; otherwise, they are disabled. If you do not want to enter the host name, logon name, password, and host file name, you must change the sftp enable option in master.cfg file to Yes. For details on configuring SFTP, refer to the Administering Avaya Proactive Contact guide.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Host Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>This represents the name of the Host computer. You can use any of the following as an entry in the Host field.</td>
<td></td>
</tr>
<tr>
<td>● An alias, which must be manually entered into the /etc/hosts file</td>
<td></td>
</tr>
<tr>
<td>● An IP address</td>
<td></td>
</tr>
<tr>
<td>● Or a fully qualified domain name</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Logon Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>This represents the name that you use to logon to the host computer. This field is only available if the File transfer is initiated by dialer.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Password</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>This represents the Password that you use to logon to the host computer. This field is only available if the File transfer is initiated by dialer.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Host File Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>This represents the name (and path if appropriate) of the upload file that will be written to the host computer. The raw data file is transferred from the dialer to the host with the file name being the host file name. This field is only available if the File transfer is initiated by dialer.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Raw Data File Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>This represents the File name of the Raw Data file. The extracted data from calling list based on the export criteria is stored in this file on the dialer.</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Schedule</td>
<td>This represents the title row for grouping related data.</td>
</tr>
<tr>
<td>Stop upload time</td>
<td>This represents the time that marks the end of the period when the upload can be attempted. This setting works based on the time set on the dialer.</td>
</tr>
<tr>
<td>Retry if upload fails</td>
<td>This check box indicates whether you should reattempt a failed upload.</td>
</tr>
<tr>
<td>Delay between uploads (sec)</td>
<td>This represents the number of seconds to wait between attempts. This setting works based on the time set on the dialer.</td>
</tr>
<tr>
<td>Format</td>
<td>This represents the title row for grouping related data.</td>
</tr>
<tr>
<td>Record Size</td>
<td>The size in bytes of each host record. This value is automatically calculated based on fields chosen in the upload dictionary.</td>
</tr>
<tr>
<td>Block Size</td>
<td>This represents the size in bytes of each block. This field should always be left at default of 10 times of the Record Size.</td>
</tr>
<tr>
<td>Blocks Read</td>
<td>This represents the number of blocks read at a time. This field should always be left at default value of 10.</td>
</tr>
<tr>
<td>Text case</td>
<td>The options available for selection of text case are Uppercase, Lowercase, and Title case.</td>
</tr>
<tr>
<td>Record Format</td>
<td>The options available for record format are Fixed Length and Character Separated Values (CSV). If CSV is chosen, the next two rows are enabled; otherwise, the rows are disabled.</td>
</tr>
<tr>
<td>Record delimiter</td>
<td>This represents the character that marks the boundary between one record and the next.</td>
</tr>
<tr>
<td>Field delimiter</td>
<td>This represents the character that marks the boundary between one field and the next.</td>
</tr>
<tr>
<td>Preparation</td>
<td>This represents the title row for grouping related data.</td>
</tr>
</tbody>
</table>
The Upload Dictionary tab displays a list of all the fields in the upload data file. Following is a brief description of the columns of the Upload Dictionary tab:

- **Field** - The name of an upload field.

**Note:**
The field name has to be in all caps, for example: ACCTNUM represents the account number.
Chapter 12: Calling Lists

- **Data Type** - This field represents the type of data contained in the field. The drop-down lists all the available data types.
- **Length** - This field represents the length of the data.

  **Note:**
  The overall length of the record is displayed as a subtotal at the top of the grid and the data is not-editable.

- **Same Start** - This is a check box to indicate that the field has the same starting position as the previous field.
- **Start** - This is a non-editable field that displays the character position in the file where the field starts. Normally this is calculated as the start position of the previous field and the length of the previous field. If you select the Same Start check box, this is calculated as the start position of the previous field.
- **End** - This is a non-editable field that displays the character position that marks the end of the field. This is calculated by adding the field's length to the field's start.
- **Description** - This field allows you to enter a user-defined description of the field.

---

**Upload Map**

The Upload Map tab allows you to configure how calling list data is transformed into upload data on a field-by-field basis. You can create a new transformation and also edit and delete existing transformations.

**Create a new Upload Map**

Follow these steps to create a new upload map transformation of calling list data:

1. Select the specific Calling List.
2. Right-click and select **Upload to Host**.
3. In the Upload Map tab, select **New**.

The Upload Map dialog box appears.

The Upload Map dialog allows you to choose the ways of transforming host data using one of the following methods:

- **Transformation** allows you change one value into another value based on regular expressions. All the records that match a specific regular expression are transformed to a specified value.
- **This transformation allows a specified host value to be translated into a specific calling list value.**

1. **Fill** - The Fill tab is a transformation that allows you to fill a host data field with the specified characters.
2. Format - The Format tab is a transformation that allows you to change the calling list format into a different format for the host upload file.

3. Translate - The Translate tab is a transformation that allows you to change one value into another value based on regular expressions.

**Edit an Upload Map**

Follow these steps to edit an existing upload map transformation of calling list data:

1. Select the specific Calling List.
2. Right-click and select **Upload to Host**.
3. Select the Upload Map. Right-click the Upload Map and select **Edit**.
   
   The Upload Map dialog box appears.

   Following is a brief explanation of each of the transformations:

   - **Fill** - The Fill tab is a transformation that allows you to fill a host data field with the specified characters.
   - **Format** - The Format tab is a transformation that allows you to change the calling list format into a different format for the host upload file
   - **Translate** - The Translate tab is a transformation that allows you to change one value into another value based on regular expressions.

**Delete an Upload Map**

Follow these steps to delete an existing upload map transformation of calling list data:

1. Select the specific Calling List.
2. Right-click and select **Upload to Host**.
3. In the Map tab, select the map row to be deleted.
4. Right-click and select **Delete**.
5. Click Save.

The specific upload map transformation is deleted.

**Select Records**

The Select Record tab allows you to select and upload records based on a combination of one or more values: date called, call results, and calling list field values.

You can identify which records to export based on field criteria.
You can set the selection criteria by choosing records with specific values in specific fields. For example, you may choose to upload all records that were called today and have a CODE2, CODE3, or CODE4 in the CODE field.

You can also enter multiple criteria and join them together using logical operators (And, Or)

The Select records screen allows you to select the following:

1. Date - The Date field allows you to pick a date. All records with the selected date in the Date field will be selected for export. The options available for selection are:
   - Records called today - Use this field to display the records called today.
   - Records called yesterday - Use this field to display the records called yesterday.
   - Records called on this date - Use this field to display the calendar and select the specific date from the calendar for which you want to see all the records.

2. Call Results - Use this field to select one or more call results from the drop-down list.

3. Field - Use this field to select specific fields and enter the field values that you want to export.

---

### Modifying an existing calling list

**Note:**

For an existing list application, if the calling list dictionary is changed and the application is saved to the pending directory, then while restarting pdx, when list is moved from pending to active, ext_list is executed upon the existing calling list. As a result, the existing calling list is transformed as per the new calling list dictionary. In this case, if any of the fields is removed or modified to decrease the length, then the data for that field will be lost. Note that the old calling list file will be backed up in the $CLIST/post_sync_clist_bkp directory temporarily and will be deleted after three days.

For the changes to take effect in the screen file, once the modified calling list becomes active, update the screen file using the screen builder.

You can modify a calling list anytime if you want to make any configuration changes.

To modify an existing calling list:

1. In Editor, select **File > Save As**.
   - The Save As dialog box appears.
2. Select the **Version**.
3. Enter a **New Name** for the calling list.
4. Enter a **Description** for the calling list.
5. Click **OK** to modify an existing calling list.
Calling List Reports

When you select a report, you can then view the full report in the Feature Detail pane at the right side of the window.

Status Reports

This report displays a list of all calling lists. It is very similar to the list that normally appears in the Feature pane, but also includes the Type, Status, and Change Date (Date and Time).

Note:
The Change Date field represents the date and time that the calling list entered this status. For a Pending list, this represents the date and time that the calling list definition was written to the dialer in the directory that holds the files that will be activated on the next restart. For a deleted list, this is the date and time the list was deleted. A Deleted calling list is stored for a period of 30 days in a backup directory. You can only retrieve the list during this period.

You can sort and resize the length of each column. The application saves the resized columns automatically.

Tools for using calling lists

The Calling list has various tools to perform some important functions quickly.

Verify

The verify command checks and validates the data entered in the calling list configuration fields. Ideally there should not be any error appearing when you run the Verify command.

The Verify command checks for the invalid values, missing fields, or empty configuration fields. When the errors are displayed, fix the specific fields and run the Verify command again to validate your changes.

To run the Verify command:

1. Select a calling list, right-click and select the Verify option.

   The configuration errors for the calling list are displayed in the Results window.
OR

1. Select a calling list, click File > Verify.

   The configuration errors for the calling list are displayed in the Results window.

---

**Convert Sample**

The Convert Sample tab allows you to test your download configuration using the sample file that was used by the Import Wizard. This option allows you to verify whether or not your raw data is appearing as required if converted to an actual calling list.

**Note:**

Convert sample is only available for Outbound calling list.

The sample file is used to help create the download configuration file only.

To run the Convert Sample command:

1. Right-click on an outbound calling list and select Convert Sample option.
2. Select the sample CSV text file that contains raw data in the specified format from your local machine.
3. Verify the data fields for a record in the Sample Conversion window.

   **Note:**
   
   You must have the data in the sample file categorized as per the fields defined in the calling list. Otherwise, the Convert Sample option provides incorrect values for each field of a record.

4. Click Next to view the next set of records.

---

**Make active**

The calling lists are created in three stages: Pending, In progress, and Active. Usually a calling list that is created in a pending stage is made active when the dialer is restarted. However, if you want to change the stage of a calling list from pending to active in real time, use the Make Active command.

To run the Make active command:

1. Select a calling list that is in a pending stage.
2. Right-click and select the Make active option.

   **Note:**
   
   This option is only available if there is no calling list set as active with the same calling list name.
Do not Call Groups (DNC)

The Do Not Call (DNC) feature allows an agent to mark a customer record as "Do Not Call" and mark all the matching records (records with the same unique customer identifier) in other selected calling lists as DNC. You can configure a calling list to support Do Not Call by adding the list to a new or an existing Do Not Call group. The calling lists in each group must all have the same unique identifier for the record.

For example, you might have a DNC group for Collections that includes list1, list2, list5, and list6. The DNC group for Telemarketing may include list3 and list4. You can mark the record as uncappable in all the Collections campaigns, but the record will still be callable in a telemarketing campaign, and vice versa.

You must specify the DNC group for each job. Only one DNC group can be designated for each job.

**Note:** When you configure DNC group and linking to a Job, then the DNC group should have the calling list that the Job is running on, else the record in the calling list used by the Job, will not be marked as DNC for Do Not Call request by the Agent.

This section contains the following topics:

- View a Do not Call Group on page 143
- Prerequisites for creating Do Not Call group on page 143
- Create a new Do Not Call Group on page 144

View a Do not Call Group

To view DNC group:

1. Click Do Not Call Groups menu. A list of DNC groups is displayed in the Do Not Call Group pane along with the status of each DNC group.
2. Click DNC group name to view the Setting and Value details of that DNC group in the DNC Group Details pane.

Prerequisites for creating Do Not Call group

Before activating the DNC feature, you must perform the following steps:

1. Select a calling list in the Calling Lists menu.
2. Right-click and select the Download from Host option.
3. Click the **Processing** tab.

4. Select the **Index calling list for quick sorting and searching** check box.
   Indexing is important to enable quick searching of records according to the unique identifier that is defined in the Index calling list for quick sorting and searching field. Key fields are used to create an index file which is used by the system internally to find a record quickly in available records.

5. Define the associated key value.

6. Select the **Index calling list for Do not Call processing** check box.
   This check box enables indexing for DNC group.

7. Define the associated key value.

   **Note:**
   You can set different key fields for the Index calling list for quick sorting and searching and Index calling list for Do not Call processing fields. Based on the key field set for a particular DNC group for the job, the DNC records are searched.

   **Note:**
   To keep the same records marked as DNC in each subsequent download, you must set the STATUSFLAG field in Latemrk/Latelist.

---

**Create a new Do Not Call Group**

The Do Not Call Groups wizard is designed to help you create a new DNC group. You can create one or more DNC groups and associate the DNC group or groups to calling lists.

To create a new do not call group:

1. In the Editor button bar, select **File > New**.
   The **New Do Not Call Group** wizard appears.

   **Note:**
   For English, the maximum length for Do Not Call group name is 32 characters.
   For other languages, the maximum length for Do Not Call group name is 10 characters.

2. Enter a **Name** for the new do not call group.

3. Select a **Version**.

4. Select a **Initial Calling List**.

5. Click **Add**. The wizard adds the new group to the list of groups in the Feature Panel and displays the details of the group in the Feature Detail pane.
Additional features for using calling list

This section describes the additional features for configuring calling lists. These features help in effective creation and maintenance of calling lists.

This section describes following topics:

- **Record Specific Messaging** on page 145
- **Automatic Number Identification (ANI)** on page 147

---

**Record Specific Messaging**

The Record Specific Messaging (RSM) feature allows you to target specific wait queue and virtual messages according to the data in one or more fields of the customer's record. For example, in a call center that handles collections for various local hospitals, you can configure RSM to lookup the name of the hospital in the customer's record and accordingly play a message unique for that hospital.

Before configuring the field in the calling list, the audio messages must be recorded and configured on the system. Also, ensure that the message is active.

To implement this feature, you first create a new RSM field in your calling list to identify the wait queue message for each customer. Next, you choose a source field in the calling list that contains the information you want to use to select the message. You may use any field in the calling list, but Avaya recommends that you select a field for which the data can be easily grouped. For example, if you choose ACCTNUM, you would have to define a message for each possible account number. Instead, you can choose SERVICE_PLAN, for which you would need to define messages for each type of service plan, such as Platinum, Gold, and Silver.

Next, you should define the relationship between the data in that field and different messages. For example, if you want to play messages based on the number of days past due, you could use a DAYS_LATE field. You could specify message1 for customers who are 30 days or less past due, message2 for customers who are 31-60 days past due, and message3 for customers who are more than 60 days past due. During calling list processing, the correct message for each customer is written to the RSM field based on the data in the DAYS_LATE field and the criteria you have created. You can create this relationship in the **Download from Host > Map > RSM** option. You can enter the DAYS_LATE criteria in the Host Data field and specify the associated messages. You can use wildcard and regular expressions in the Host Data field.

You can handle more complicated scenarios by defining additional source fields; for example, you may include PASTDUE_BALANCE field with the DAYS_LATE field in the above example.
Chapter 12: Calling Lists

Configuring Record Specific Messaging using Scripts

For any other type of voice message to be played in a wait queue, create a script to play it.

1. Click **Messages and Scripts**.
2. Click **Scripts**.
3. Click **New**. The Script Wizard appears.
4. Click **Next**.
5. Select **Outbound** from the available list.
6. Click **Next**.
7. Click **Next**.
8. In **Add an action** page, under the **What do you want to do?** prompt, select "Play a record specific message".
9. From the **List name** drop-down list, select the calling list to which you added the Record Specific Messaging feature.
10. From the **Version** drop-down list, select the version of the calling list that you want to use.
11. From the **RSM Fields** drop-down, select the appropriate Record Specific Message field name that was provided during Configuring Record Specific Messages.

**Note:**
You can optionally select the **Default message to play** option. When you select this option, the table below the option gets activated. The message that you select from this table will override the default message provided in the Calling List RSM Map. Refer to Record Specific Messaging on page 145.

12. Click **Next**.
13. In the **Selecting how to handle calls answered by a machine** page, you have the option to select Yes or No.
   
   If you select Yes:
   
   a. In **Add an action** page, under the **What do you want to do?** prompt, select "Play a record specific message".
   b. From the List name drop-down list, select the calling list to which you added the Record Specific Messaging feature.
   c. From the Version drop-down list, select the version of the calling list that you want to use.
   d. From the RSM Fields drop-down, select the appropriate Record Specific Message field name that was provided during Configuring Record Specific Messages.
   e. You can optionally select the Default message to play option. When you select this option, the table below the option gets activated. The message that you select from this
table will override the default message provided in the Calling List RSM Map. Refer to Record Specific Messaging on page 145.

If you select No, follow the next step.

14. Click Next.

15. In Selecting message to play before passing call to agent or into wait queue page, you have the option to select Yes or No.

   If you select Yes:
   a. In Add an action page, under the "What do you want to do?" prompt, select "Play a message".
   b. Under Select a message to play, select a message to be played, and click Next.
   If you select No, follow the next step.

16. Name the script, for example, "Play_RSM", and then type a brief description of the script.

17. Click Next, then click Finish. On the Detail tab on the right, your new script appears.

   At this point, the script, for example, Play_RSM is available for use in any job using your calling list.

18. To assign the script to a job:
   a. Click Contact Management.
   b. Click Jobs.
   c. Select an outbound job.
   d. In the Job Detail pane, under Labels, locate the Script label to use for making call.
   e. From the drop-down list, select Play_RSM1.
   f. Click Save.

---

**Automatic Number Identification (ANI)**

Earlier Automatic Number Identification functionality was only limited to the Hard Dialer. In this release, ANI outpulsing is supported in both Soft and Hard dialer.

ANI is commonly referred to as Caller ID and it is a configuration setting of the phone number sent done only for the system. The ANI values can be defined on a job or on a record basis. As a result, different ANI can be outpulsed for different jobs and for different records within a job.

In case of Job specific ANI, you are required to specify the Calling party number(ANI) for each of the jobs. As a result, different ANI could be outpulsed for different jobs.

In case of Record Specific ANI, you are required to specify Calling party number(ANI) by record. As a result, different ANI could be outpulsed for different records within a job.
The Automated Number Identification allows you to select a field in the calling list that contains ANI values and to use those values during calling. As each record is called, the value in the defined field is outpulsed for ANI.

For example, a call center performing a survey of existing customers may want to use different ANI values for customers with different service agreements. During calling list download you can set a translation using Editor application for setting up the ANI values for dialer depending on the host data. If you want to setup ANI depending on the host data in SERVICE_PLAN field and the SERVICE_PLAN field is set to GOLD, this can be translated to the value 425-999-9999 which is written to the SERVICE_PLAN field. You can translate GOLD to the value 425-999-9999 in the Download from Host > Map > Transformation > Translate option. You can select Unmapped field as SERVICE_PLAN, add GOLD in the Host Data field, and the value 425-999-9999 in the Dialer Data field. As a result, wherever the SERVICE_PLAN field is set to GOLD, it is translated to the value 425-999-9999.

Similarly, if SERVICE_PLAN is set to SILVER, this can be translated to the value 425-999-1000 which is written to the SERVICE_PLAN field.

If a calling list is prepared in this manner, the call center supervisor can create a job using this list and set the “Calling party number (ANI) by record” field to SERVICE_PLAN as described in above example or a field that has ANI information. During dialing, each customer can see a calling party number based on the field.
Chapter 13: Completion Code Manager

Completion Codes is a tool that helps you create, categorize, and maintain completion codes. The changes you make are available the next time the dialers restart.

A completion code identifies the result of a phone call. Either the system or an agent assigns a completion code to each phone call. The system uses completion codes to select records for placing calls, to monitor calling activities, and to select records for reports.

This section contains the following topics:

- Understanding completion codes on page 149
- Using Completion Codes on page 152
- Maintaining completion codes on page 155

Understanding completion codes

This section discusses the following topics to help you use completion codes:

- Completion codes on page 149
- Completion code attributes on page 150
- Completion code categories on page 151
- Multi-dialer environment on page 152

Completion codes

A completion code identifies the result of a phone call. Either the system or an agent assigns a completion code to each phone call.

The system assigns a completion code when the dialer does not pass the phone call to an agent. The only successful call attempts that the system identifies are during Virtual jobs.

An agent assigns a completion code based on the result of a phone call that the dialer passed to the agent.

Examples of completion codes that the system can assign include the following codes:

- BUSY when the dialer detects a busy signal
- SIT when the dialer detects a Special Information Tone that identifies a disconnected number or busy circuits
Chapter 13: Completion Code Manager

- NOANSWER when a party does not answer the phone call within the specified time number of rings

Tip:
You can change the number of times the system attempts to call the customer on the Retries tab in Strategies.

Examples of completion codes that agents can assign include the following codes:
- RECALL to tell the dialer to place the phone call at a later time
- PROMISE when the customer agrees to make a payment
- AUTOVOICE when the job is set up to pass agents phone calls that connect to an answering machine

Completion code attributes

Avaya Proactive Contact assigns a number to each completion code and specifies whether the system or agents assign the completion code. A dialer has 200 completion codes.

A completion code has the following attributes:

Keyword - Identifies the short name for the completion code.

Code - Identifies the assigned number for the completion code. The code numbers range from 0 through 199.

Description - Provides a brief description of the completion code.

Type - Identifies whether the system or an agent assigns the completion code.

Report Header - Identifies the title for the completion code column in the Completion Code Summary report.

You can create the description and report header for the completion codes that agents assign.

You can change the description and report header for the completion codes that agents and the system assign.

You cannot, however, change the code keyword, number, and type for completion codes that agents and the system assign.
The following table provides several examples of completion codes:

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Code</th>
<th>Description</th>
<th>Type</th>
<th>Report Header</th>
</tr>
</thead>
<tbody>
<tr>
<td>RESERVED1</td>
<td>001</td>
<td>Reserved for system.</td>
<td>System</td>
<td></td>
</tr>
<tr>
<td>NOTINZONE</td>
<td>005</td>
<td>The local time for the customer phone is outside the legal hours to place calls.</td>
<td>System</td>
<td>Not within legal hours</td>
</tr>
<tr>
<td>MOFLASH_B</td>
<td>006</td>
<td>Native voice and data transfer: Agent transfers call to inbound agent without remaining on the line.</td>
<td>Agent</td>
<td>Blind transfer</td>
</tr>
<tr>
<td>TRANSFER</td>
<td>018</td>
<td>Transfer release.</td>
<td>Agent</td>
<td>Transferred</td>
</tr>
<tr>
<td>CODE32</td>
<td>032</td>
<td>Schedule appointment, then call</td>
<td>Agent</td>
<td>SchdCall</td>
</tr>
<tr>
<td>DTMF_V</td>
<td>044</td>
<td>Internal system code.</td>
<td>System</td>
<td>Voice DTMF</td>
</tr>
<tr>
<td>VIRTVOICE</td>
<td>091</td>
<td>Virtual voice message to Voice</td>
<td>Agent</td>
<td>Virtual Voice</td>
</tr>
</tbody>
</table>

**Completion code categories**

During a job, agents assign a completion code to a phone call to indicate the result of a call. In Completion Code Manager, you can organize completion codes into four categories for monitoring and reporting purposes.

💡 **Tip:**
You can associate a completion code with more than one category.

For example, an agent placed a call to confirm an order and left a message on the answering machine. The job is set up to pass phone calls that are answered by an answering machine to agents. The agent assigned the answering machine completion code to the customer record. The answering machine completion code can belong to both the Right Party Contacts and Closures categories.

**Right Party Contacts (RPCs)** - Indicates that the agent talked with the correct party.

**Closures** - Indicates that the agent talked with a party and completed the purpose of the phone call. A closure can represent a variety of outcomes, including the following examples:

- Balance paid in full
- Bankruptcy
- Deceased
● Sale verified and completed

**Abandons** - Indicates that a phone call was abandoned and that the dialer disconnected the phone call. An abandon can be result of several events, including the following examples:

● A customer who placed a call to the call center hung up while in the inbound wait queue.
● A customer hung up while in the outbound wait queue.
● A phone call that was held in wait queue for the maximum time allowed.

**Recalls** - Indicates that the phone call did not connect to a customer and that another phone call attempt can be made. The dialer places another phone call to the customer based on the settings you define on the **Retries** tab in Strategies.

---

**Multi-dialer environment**

In Completion Code Manager, you can create and change the completion code description and report header text for completion codes that agents assign. You can also assign completion codes to categories.

If your system uses multiple dialers, the completion codes that you create and change in Completion Code Manager belong to the primary dialer. When you save the codes in Completion Code Manager, Avaya Proactive Contact saves the changes to each dialer in the pod. This ensures a consistent set of codes for reporting and monitoring.

---

**Using Completion Codes**

You can use Completion Codes to create and manage completion codes. You can do the following tasks:

● View the system and agent assigned completion codes.
● Create and maintain completion codes that agents can assign.
● Assign completion codes to categories for monitor and reporting activities.

The changes you make are available the next time the dialers restart.

The following topics discuss Completion Code Manager and the procedures you can use to categorize completion codes:

● [Completion Code window](#) on page 153
● [Start Completion Code Manager](#) on page 153
● [Create a completion code](#) on page 154
● Assign a completion code to a category on page 154

Completion Code window

The Completion Code window provides a means to create, categorize, and maintain completion codes for monitor and reporting activities.

Right-hand pane - The right-hand pane contains a complete list of completion codes for the dialer. For each code, Completion Code lists the keyword, code number, description, whether the system or agent assigns the completion code, and the report column text.

Tip:
You can use the right-click menu in the right-hand pane to select menu options that are available on the Edit and View menus.

The Right-hand pane also displays the following categories:

● RPCs (Right Party Contacts) - Is used to specify that the person contacted was the appropriate person to talk with.

● Closures - Is used to indicate that some form of closure was reached with the contacted party.

● Abandon - Is used to indicate the system abandoned the call after connecting with a person at the called number.

● Recall - Is used to indicate whether or not this completion code can be used to specify that a record can be recalled.

Start Completion Code Manager

Completion Code Manager is available from the View menu.

Note:
The changes you make in Completion Codes are available the next time the dialers restart.

To start Completion Codes:
1. Select Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor.
2. Select Completion Codes.

The Version dialog appears. Select the version that you want to Edit. The default is the Active version. For more information, see Versions on page 159. A list of all the active completion codes appears. For more information, see Completion Code window on page 153.
Chapter 13: Completion Code Manager

Create a completion code

You can assign the code to the Right Party Contact and Closure categories, and include the code in the Completion Codes Summary report.

Later, you can assign the completion code to the Abandon and Recall categories. You can also change the description and report header text directly on the right-hand pane.

To create a completion code.

1. Right-click and Select New OR click the New icon.
   The Completion Code Wizard window opens.
2. Complete the wizard by defining the new code, setting attributes for the code, and verifying the new code entities.

   For more information, see:
   - Change a completion code on page 155.
   - Assign a completion code to a category on page 154.

Assign a completion code to a category

You can assign a completion code to the following categories:

- RPC (Right Party Contact)
- Closure
- Abandon
- Recall

To assign a completion code to a category from the list of completion codes in the right-hand pane:

1. Select one or more completion codes.
2. Select the specific option from the available category.
3. Click Save.
   Completion Code Manager dialog box appears.
4. Click Yes to save a copy in a different version OR click No to Cancel.
   Avaya Proactive Contact saves the completion codes on each dialer in a pod.
Maintaining completion codes

This section discusses the procedures you can use to maintain completion codes:

● Assign or reassign a completion code to a category on page 155
● Change a completion code on page 155
● Filter the completion codes to view on page 156
● Save the completion code information to a file on page 156

Assign or reassign a completion code to a category

To remove a completion code from the following categories:

● Right Party Contact
● Closure
● Abandon
● Recall

1. From the list of completion codes in the right-hand pane, select the completion code that you want to remove from the category.
2. Right-click and select Remove.
   The Delete confirmation dialog box appears.
3. Click OK to remove the completion code from the list of completion codes.

Change a completion code

To change a completion code description and report header text:

1. From the list of completion codes in the right-hand pane of the window, select the completion code that you want to change.
2. Right-click and select Change Description or Change Report Header.
3. Type the new description or report header text, and then press Enter.

Tip:
The report column width is limited to 23 characters in length. You can adjust the text until the report meets your requirements.

Completion Code displays the new information.
Filter the completion codes to view

You can display system completion codes, agent completion codes, or all completion codes.

To display the type of completion codes that you want to view:

1. Select View.
2. Select the type of completion code you want to view.
   Completion Code displays the type of codes you selected.

Save the completion code information to a file

To save the completion code attributes and category information to an HTML file:

1. Select Code > Save as HTML.
2. In the Save As dialog box, browse to the location where you want to save the Completion Code Configuration file.
   You can change the name of the file.
3. Click Save.
Chapter 14: Agent Keys

Agent Keys perform actions that are available on your system, such as releasing a call, transferring a call, displaying an agent screen, and logging an agent out of a job.

The Agent Keys display a list of agent keys files, including the name of the file, the type, the file version, and a brief description.

Using Agent Keys

Use Agent Keys Wizard to add or edit keys to meet your contact center’s changing needs. Agent keys are F1 through F12, depending on the type of keyboard. In addition to the function keys, you can assign key combinations to increase the number of available keys. For example, the agent can press and hold the Ctrl key or Shift key or the Alt key while pressing the function key.

The Agent Keys feature helps you to modify an existing calling list, create a new Agent Key Set, and select Job features, as explained in detail in the subsequent sections.

This section consists of the following topics:

- Create a new Agent Key Set on page 157
- Supported Features on page 158

Create a new Agent Key Set

The Agent Keys screen displays the names of all agent key sets defined on the selected dialer. You can view the individual key assignments defined in the agent keys set by selecting a key set in the Feature Pane. The key assignments appear to the right in the Feature Detail pane.

Note:
In Avaya Proactive Contact 4.0 the agent key module supported the description field of 256 characters and also allowed all special characters. This has changed in Avaya Proactive Contact 4.1 and above. The description field now supports 64 characters in the description field and special characters are not allowed. Avaya Proactive Contact 4.1 and above support the existing agent keys of Avaya Proactive Contact 4.0 with big description. It is recommended that agent key files that are used in Campaign template should not have more than 64 characters.
To create a new agent key set:

1. In the Editor button bar, select **New**.
   The New Agent Keys Wizard appears.
2. Click **Next**.
3. Enter a **Name** for the Agent Key set.
4. Enter a brief **Description** for the Agent Key set.
   
   **Note:**
   The description field has a restriction of 64 characters. Special characters are not allowed.
5. Click **Next**.
6. Select the **Type of Job** that will use this Agent Key set.
   
   **Note:**
   If you select the **Any Type of Job** option, continue from step 7 to 10.
7. Click **Next**.
8. Select the check boxes on the Supported Features Page that should be supported in the new agent key set that you are defining. For more information, refer to **Supported Features** on page 158.
9. Click **Next**.
10. Click **Finish**.

The Agent Keys screen displays the names of all agent keys sets defined on the selected dialer. When the user clicks the Agent Keys icon in the Button Bar, the application requests a list of the agent key files or sets from the selected dialer and displays them in the Feature Pane.

**Note:**
The Avaya Proactive Contact Agent does not honor all key assignments entered in a key file. If you are using the Avaya Proactive Contact Agent, the only key assignments that will be accepted are those related to release codes and automated messages.

A user can display the individual key assignments defined in the agent key set by selecting a key set in the Feature Pane. The key assignments appear to the right in the Feature Detail pane.

---

**Supported Features**

The Supported Features Page in the Agent Keys Set Wizard allows the user to select the job features that you want to support in this agent key set. The job features that allows the agent to perform specific functions are listed as follows:
Using Agent Keys

- Managed Dialing - This job feature allows agents to preview account information and cancel calls before they are made. It also allows them to specify the keys needed to support the user to control the pace and outcome of managed dialing. Specifically, when an agent is previewing a record, the agent may choose to cancel the call and move to the next record or the agent may choose to go ahead and dial the record immediately.

- Sales Verification - This job feature automatically creates a second calling campaign to confirm sales or commitments obtained in a prior campaign. This also allows you to choose the keys needed to support a sales job in a sales verification scenario. When Sales Verification is used, agents use a specific code to release records that resulted in a successful sale. These records are automatically fed to a second verification job. In this job, each record is called and a supervisor verifies that the person at the other end of the line agrees to a sale.

- Native Voice and Data Transfer - This job feature allows you to define the keystrokes for transferring a call to another agent or to a supervisor. One keystroke will immediately transfer the call and allow the agent to receive a new call. The other keystroke allows the agent to stay on the line with the customers until the other agent answers.

- Do Not Call - This job feature allows you to choose the keys needed to support the Do Not Call feature. When an agent uses the defined key combination, the record is released and marked as Do Not Call. This will prevent the dialer from calling the customer at this number for any reason in the future.

- Agent owned recall - This job feature allows you to define the keystrokes for scheduling an agent owned recall as well as the keystrokes for releasing such a record. Note that this feature is different from the feature that simply allows an agent to set up a record to be recalled at another time and to be delivered to any available agent. In this feature, the recalled record is connected to the specific agent who set the recall.

Versions

The Version feature allows you to set privileges.

For example: an user with sysadm privileges has the ability to create and edit configuration data in each of the defined versions, such as Active, Pending, and In Progress. Access to configuration data in the various stages is accomplished in one of two ways, depending on the type of configuration data.

Note:
- Deleted is also a version

For data that is always saved to the same file - completion codes, schedules, telephony scripts, and voice messages - a message appears when you try to edit the data. This message gives you the option of choosing the version that exists in any of the stages.
Using Version Data

If you have sysadm privileges you may want to use data that is Pending or In Progress during the configuration of another type of file. For example, you may want to create a calling list application with upload configuration that depends on a completion code that is Pending. Change this, if you want to create a new telephony script with a voice message that is Pending.

If there are configuration changes in Pending or In Progress, the Configuration Version dialog box appears, the first time you attempt to edit a file. In the above example, the Save As dialog appears as soon as you select New on the Calling List menu.

When you select a version, the configuration data associated with that version is used throughout the editing session. If, for example, you choose to use completion code definitions that are in Pending, the Pending completion codes are loaded into the application and are used in all cases where the user interface offers you a choice of codes.

Once you have chosen a configuration version, the same will remain active until the application is closed or until you choose to change the configuration version by selecting Options - Configuration Version from the main menu.

Saving Version Data

The configuration data can be saved to the dialer and immediately become active; it may be saved to a Pending directory and will not become active until dialer services are restarted; or it may be saved indefinitely to an In Progress directory.

This feature, the ability to save data based on its state of readiness or completeness, is implemented through the UI by prompting the user for the state when the data is saved.

Using Deleted Configuration Files

To work with deleted files, you can recover the files that are placed in special directories and may be available for retrieval by users with sysadm privileges. These files are listed in the Versions dialog and in the feature pane. To work with these files, you must open the file in Deleted, then save the file into another version, either Pending or In Progress.
Chapter 15: Messages and scripts

Messages are the recordings that are played to customers when they are on hold, waiting for an agent, or when an agent plays a message. Scripts are a series of messages that customers hear in the inbound, outbound, and transfer wait queues.

Messages provide the following functions:

- Assure customers that their calls remain connected
- Prepare customers for the upcoming transaction, asking them to have credit cards and order numbers ready
- Answer frequently asked questions
- Promote the business
- Advertise new products and services

You can create messages and scripts if you have administrative privileges. The Messages and Scripts button bar appears in the left-hand pane of Editor.

This section contains the following topics:

- Understanding messages on page 161
- Using messages on page 163
- Maintaining messages on page 166
- Understanding scripts on page 168
- Using scripts on page 171
- Maintaining scripts on page 174
- Understanding Messages and Scripts dialog boxes on page 176

Understanding messages

Messages are the recordings that are played to customers when they are on hold, waiting for an agent, or when an agent plays a message.

On Avaya Proactive Contact with PG230RM, your recorded voice messages must be digitized for Avaya Proactive Contact to use them. You choose message files when you set up jobs on the system. Later you can add and remove the messages.

Avaya Proactive Contact provides a wizard to help you add messages to the system and organize them in folders.
Later you can add and remove the messages and folders.

This section contains the following topics:

- **Plan messages** on page 162
- **Telephony file** on page 162
- **Messages pane** on page 164
- **Record messages** on page 163
- **Define and create message text** on page 163

---

### Plan messages

In Avaya Proactive Contact, you can store up to 1970 digitized messages. Each message can be up to one minute in duration. Avaya Proactive Contact can store up to 35 minutes of recorded messages.

Before you record and digitize messages, it is helpful to compose and print the message text. Consider the following times before you create a message:

- The purpose and use of the message
- The message text
- The male or female voice that delivers the message
- The current number of messages stored in Avaya Proactive Contact
- The category that best identifies the use for the message
- The languages that deliver the message

---

### Telephony file

The telephny.spt files stores scripts. The telephny.spt file on the dialer cannot exceed 1500 lines.

⚠️ **Important:**

If the number of lines exceed 1500, you receive an error. You cannot save scripts when the number of lines exceed the 1500.

If the number of lines exceed 1500, Avaya Proactive Contact might do one of the following:

- Not start jobs
- Start jobs but not deliver messages beyond line 1500

To reduce the number of lines in the telephny.spt file, do one or more of the following:
● Remove scripts and messages that you no longer use.
● Contact your Avaya Proactive Contact vendor for assistance.

---

**Record messages**

Before you use Messages Wizard, you must define, record, and digitize audio messages. You have several options for recording audio messages.

For the Avaya Proactive Contact and Avaya Proactive Contact with PG230RM systems, you can do the following to record messages:

● Record the audio messages yourself and have a third party digitize the messages.
● Use a service bureau to record and digitize the message.
● Use third party software that records and digitizes the messages.

For the Avaya Proactive Contact with Application Enablement Services, the ACD stores the recorded messages. Refer to the ACD documentation for information on recording voice messages.

When the message is ready for use, save the audio file in a location that is readily accessible to the supervisor workstation. From this workstation, you can assign the digitized audio to a message file in Editor and to a dialer.

---

**Define and create message text**

Messages Wizard helps you complete the following tasks in Avaya Proactive Contact:

● Add audio messages to Avaya Proactive Contact with PG230RM systems.
● Update existing messages on Avaya Proactive Contact with PG230RM systems.
● Identify details about the message, such as is it a male voice, female voice, or music.

Although it is not mandatory, most companies have a written record of the message text.

---

**Using messages**

Message Wizard is available to help you do the following tasks:

● Add a message.
● Add an updated audio portion of an message to Avaya Proactive Contact.
● Store these messages in folders for easy access.
Chapter 15: Messages and scripts

This section contains the following topics:

- Messages pane on page 164
- Start Messages on page 164
- Create message folders on page 164
- Add or update messages on page 165
- Verify a message on page 166

Messages pane

The Messages pane provides a means to add and maintain the messages that customers hear. Editor displays a tree view that contains folders for script names and descriptions.

- If messages do not display, click the plus symbol to the left of the message name.
- If a plus symbol does not display, there are no messages assigned to the category.

⚠️ Important:
You use the right-click menu in the right-hand pane to change, or remove messages and folders.

Start Messages

You start Messages from Editor if you have administrative privileges.

To start Messages:
1. Select Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor.
2. Log in to Editor using your user name and password.
3. Click the Messages and Scripts button group.
4. Click Messages.
   The Messages window appears.

Create message folders

You can create one or more folders to organize messages.
To create a folder:

1. Click **Messages**.
   The Messages pane appears.
2. In the right-hand pane, right-click and select **New > Folder**.
   Editor adds a folder in the messages tree and selects the row.
3. Right-click the row and select **Rename Folder**.
   The **Rename Folder** dialog box appears.
4. In the **New Name** field, type a name for the folder and click **OK**.

---

**Add or update messages**

Messages Wizard helps you add a message or update the audio portion of an existing message to the system.

To start the Messages Wizard:

1. Click **Messages**.
   The Messages pane appears.
2. Select a folder or a message in the **Messages** pane.
3. Select **File > New**.

**Note:**
You can use Microsoft Sound Editor to save the voice message file. You should save it using the following format options:
- CCITT U-Law ("Mu-Law")
- 8K Sample (Hz)
- 8-bit
- Mono
Save the file as `<filename>.au` in any convenient file directory.

Editor opens Message Wizard. You can define the following information:

- Location of the audio file
- File name
- Type of message: voice or music, and male or female voice
- Description of the message text
- Folder to store the message

4. Complete the wizard instructions to add or update audio message files to the system.

Use a maximum of eight characters for the file name and three characters for the file extension. When you name the file in the wizard, use a name that clearly identifies the type
of message. For example, "fwait1" can identify the first female message played in a wait queue. "Inmwait1" can identify the first male message playing in an inbound wait queue.

**Note:**
While updating the audio message file, do not change the name of the audio message file. If you update an audio message file using a different name, the system displays the following warning message:

This message may be used by jobs or agent keys which will not function correctly if the name is changed. Are you sure you want to continue?

Click **Yes** if you still want to continue with the update.

Editor adds the message to the Messages folder.

5. Select **File > Save**.

---

**Verify a message**

To verify that a message is available on the system:

1. Click **Messages**.
   The Messages pane appears.
2. Select a folder or a message in the **Messages** pane.
3. Select **File > Verify**.
   Editor opens the **Results** dialog box.
4. Click **OK**.

---

**Maintaining messages**

You can change or remove a message or folder.

This section contains the following topics:

- **Add or update messages** on page 165
- **Remove a message** on page 167
- **Rename a message folder** on page 167
- **Remove a folder** on page 168
Remove a message

Before you remove a message, verify that a script does not use the message.

To remove a message from the Messages pane:

1. Click Messages.
   The Messages pane appears.
2. Click the plus sign to expand the folder that contains the message.
3. Select a message.
   Editor selects the row.
4. Right-click the row and select Remove.
   The Delete dialog box lists the selected message.
5. Verify that the message is the one you want to remove and click OK.
   Editor removes the message from the folder. Editor deletes the message when you save messages.

Rename a message folder

You can rename a folder to organize messages.

To rename a folder:

1. Click Messages.
   The Messages pane appears.
2. Select a message folder.
   Editor selects the row.
3. Right-click the row and select Rename Folder.
   The Rename Folder dialog box appears.
4. In the New Name field, enter a name for the folder and click OK.
Remove a folder

You can remove an empty folder from the Messages pane.

To remove a folder:
1. Click Messages.
   The Messages pane appears.
2. Click the plus sign to expand the folder you want to remove.
3. Remove each message from the folder.
   For more information, see Remove a message on page 167.
4. Select a message folder.
   Editor selects the row.
5. Right-click the row and select Remove Folder.
   Editor removes the folder.

Understanding scripts

Scripts define how customers hear messages during the following occasions:

- While waiting in inbound, outbound, or transfer queues
- When customers answer a call placed by a virtual agent
- When an agent presses a function key

You designate the order in which Avaya Proactive Contact plays messages. You can choose to play music or have silence between messages.

This section contains the following topics:

- Types of scripts on page 168
- Script actions on page 169
- Script examples on page 170

Types of scripts

After you add messages to the system, you create scripts. To create a script, you complete the following tasks:
● Assign messages to a category when the script runs.
● Assign actions to messages.

The following table describes the categories of when scripts run:

<table>
<thead>
<tr>
<th>Script</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automated Messages</td>
<td>Messages that agents play to customers when the agent presses any function key.</td>
</tr>
<tr>
<td>Inbound Wait Queue</td>
<td>Messages that the system plays to customers while waiting for an agent in inbound wait queues.</td>
</tr>
<tr>
<td>Outbound Wait Queue</td>
<td>Messages that the system plays to customers while waiting for an agent in outbound wait queues and or when an answering machines receives the call.</td>
</tr>
<tr>
<td>Transfer Wait Queue</td>
<td>Messages that the system plays to customers while waiting to be transferred.</td>
</tr>
<tr>
<td>Virtual Wait Queue</td>
<td>Messages that the system plays to customers during Virtual Agent jobs. A virtual agent job delivers messages without agent intervention.</td>
</tr>
</tbody>
</table>

**Script actions**

Script actions define a script. Depending on the script you select in the Scripts left-hand pane, you can do the following when defining a script:

● Select to play the script when an answering machine or voice answers the phone call.
● Assign actions that play additional messages.

The following actions appear in the right-hand pane.

**Play message** - Plays a recorded message. You select the name of the message file. The file may contain voice or music.

**Pause** - Specifies how long to wait between messages in inbound, outbound or transfer wait queues. You select the amount of silent delay in seconds.

**Start Looping** - Instructs the system to repeat the wait queue actions that follow in inbound, outbound or transfer wait queues. You must follow this command with a Play statement. When you set up a job, you can set the maximum time a caller can stay in the queue.

**Voice Response** - Instructs the system to wait for a voice response in inbound or outbound wait queues. The dialer verifies that the person who placed or received the call is still on the line. If not, the system disconnects the line.
Script examples

This section provides the following examples of how you can create scripts.

- **Outbound wait queue** on page 170
- **Inbound wait queue** on page 170
- **Automated message** on page 171

**Outbound wait queue**

The following example shows how you can combine messages in a script.

1. Hold the line please. I have a very important call for you from **company name**.
2. 5 second pause.
   This loop begins with line four. The system repeats all lines below the start looping statement for the length of time listed in Editor.
4. Sorry to keep you waiting. I am still trying to connect.
5. 5 second pause.
7. 5 second pause.
8. Still trying to connect. Thank you for waiting.
9. 8 second pause.

**Inbound wait queue**

The following example shows how you can combine messages in a script.

1. Thank you for calling **company name**. A representative will be with you shortly.
2. 5 second pause.
3. Your call is important to us. Please hold for the next available representative.
4. 7 second pause.
5. Please continue to hold. A representative will be with you momentarily.
6. 7 second pause.
7. Start Looping.
   This loop begins with line eight. The system repeats all lines below the start looping statement for the length of time listed in Jobs.
8. Thank you for waiting, please continue to hold.


Automated message

The following script consists of a single message that the system plays when an agent presses a function key.

1. Please call your sales representative for information about a special offer.

Using scripts

Avaya Proactive Contact provides a Message Script wizard to help you create a message script.

This section contains the following topics:

- Scripts pane on page 171
- Start Scripts on page 172
- Add or update scripts on page 172
- Define a script on page 173
- Telephony Scripts on page 174

Scripts pane

The Scripts pane provides a means to create and maintain message scripts that play the messages customers hear.

Left-hand pane - Editor displays a tree view organizes script names and descriptions into categories of when the system runs the script.

- If scripts do not display, click the plus symbol to the left of the script name.
- If a plus symbol does not display, there are no scripts assigned to the category.

Right-hand pane - The right-hand pane appears when you select a script. The Detail tab lists the actions for the script. Depending on the when the script runs, you can assign actions that tells Avaya Proactive Contact how to play messages.
Chapter 15: Messages and Scripts

Tip:
You can use the right-click menu in the right-hand pane to add, change, or remove actions.

Note:
To specify a message, on the Message Script Wizard, select Yes in the "Do you want to play a message automatically before passing call to agent or into wait queue" option. The selected message is indicated in the right-hand pane. Otherwise, the "No message is selected to play" message is displayed in the Script Actions field.

Start Scripts

You start Scripts from Editor.

To start Scripts:
1. Select Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor.
2. Click the Messages and Scripts button group.
3. Click Scripts.
   The Scripts pane appears.

Add or update scripts

Message Scripts Wizard helps you create and update a message script. Scripts define one or more messages that customers can hear.

Important:
The changes you make to a script become available for use the next time you restart the dialer.

You can use the right-click menu in the right-hand pane to add, change, or remove actions.

To start the Messages Script Wizard:
1. Click Scripts.
   The Scripts pane appears.
2. Select File > New.
   Editor opens Message Script Wizard.
3. Complete the wizard instructions to add or update scripts to Avaya Proactive Contact.

Tip:
There is a time limit that you can leave a file open for editing. Depending on your system configuration, the default value is 60 minutes. We recommend that you save each new script after you add or update the script.

4. Select File > Save.

---

Define a script

When you define a script, you can assign one or more of the following actions to the script:

- Play a message
- Play a RSM
- Pause
- Start a loop
- Wait for a response

To define a script:

1. Click Scripts.
   The Scripts pane appears.
2. Select a script in the left-hand pane.
   Depending on the script you select, you can play the script when an answering machine and voice answers the phone call.
3. Select If a machine answers... or While a person is waiting for an agent.
4. Right-click the response and select Add an Action.

Tip:
You can also select a location in the script, then drag and drop an action icon to a location in the script.

Editor displays the Message Script Wizard.
5. Complete the wizard instructions to add an action to the script.
   Editor adds the action below the response. Depending on the script you can select additional actions.
6. To add another action to the response, repeat Step 5 or right-click and select Add an Action.
7. To add actions to the other response, repeat Steps 3, 4, and 5.
8. Select File > Save.

---

**Telephony Scripts**

Telephony scripts are used to define actions for an event. For example, what should the dialer do if a customer answers a call or when an answering machine answers a call.

For the outbound and virtual scripts, in telephony.spt, you can put a message number or ",-1" (for no message) in the end of the "call" command. When you put any number at the end of the "call" command, the dialer will play the message corresponding to that number before transferring the call to a live agent or into wait queue. When you put "-1" as a value at the end of the call command, the dialer will not play any message before transferring the call. In this release, this feature is visible and editable in the Editor application.

To define message number:

1. Log in to the Editor application.
2. Go to the Messages and Scripts tab. Select Scripts.
3. Click an outbound or virtual script.
4. At the end of the Action detail, a new heading named as "Before passing call to agent or into wait queue" is displayed.
5. If a message is selected to play, it shows "Play <message #>". Otherwise (for ",-1"), it shows "No Message is selected to play".
6. You can change this action and also add this action while creating new outbound or virtual script.

---

**Maintaining scripts**

You can change or remove a script action and script.

💡 **Tip:**
You can also use the right-click menu in the right-hand pane to add, change, or remove actions.

This section contains the following topics:

- [Change a script action](#) on page 175
- [Remove a script action](#) on page 175
- [Change a script](#) on page 175
Change a script action

To change an action for a script:
1. Click **Scripts**.
   The Scripts pane appears. Select a script.
2. Click the action you want to change.
3. Right-click the action and select **Change an Action**.
   Editor displays the Message Script Wizard.
4. Complete the wizard instructions to change an action or message to play.
5. To change another action, repeat Steps 2, 3, and 4.
6. Select **File > Save**.

Remove a script action

To remove an action from a script:
1. Click **Scripts**.
   The Scripts pane appears. Select a script.
2. Click the action you want to change.
3. Right-click the action and select **Remove an Action**.
   Editor removes the action from the response.
4. To remove actions for another response, repeat Steps 2 and 3.
5. Select **File > Save**.

Change a script

You can change the name and description of a script.

To change a script:
1. Click **Scripts**.
   The Scripts pane appears.
2. Select a script from a category.
3. Right-click and select **Change**.

   Editor opens the Message Script Wizard window.

4. Complete the wizard instructions to change the script.

5. Select **File > Save**.

---

**Remove a script**

You can remove a script that you or another person created. You cannot remove a script that is reserved by Avaya Proactive Contact.

To remove a script:

1. Click **Scripts**.

   The Scripts pane appears.

2. Click the plus sign to expand the category that contains the message.

3. Select a script from a category.

   Editor selects the row.

4. Right-click the row and select **Remove**.

   Editor removes the script from the category.

---

**Understanding Messages and Scripts dialog boxes**

This section contains the following topics:

- **Delete dialog box** on page 176
- **Rename Folder dialog box** on page 177

---

**Delete dialog box**

The **Delete** dialog box allows you to remove selected message from Avaya Proactive Contact.
Rename Folder dialog box

The Rename Folder dialog box allows you to name or give the folder another name.
Chapter 16: Phone strategy

Avaya Proactive Contact uses phone strategies during jobs to place phone calls to customers more effectively.

A phone strategy is a set of instructions that tells the system when and how to place calls to customers, which customer phone number to dial, and the frequency of calls.

This section contains the following topics:

- Understanding phone strategy on page 179
- Using phone strategies on page 183
- Maintaining phone strategies on page 186

Understanding phone strategy

The system receives and prepares the host data file and creates a calling list. The system places phone calls based on a phone strategy. The phone strategy specifies the phone numbers to dial during a job and how to place the calls.

This section contains the following topics:

- Phone strategy preparation on page 179
- Phone strategy settings on page 180

Phone strategy preparation

Before you create a new phone strategy, identify the following values for each phone strategy:

- The phone number to call first
- The number of rings to allow before disconnecting the call
- The time to wait before retrying a phone number that was busy, unanswered, or disconnected
- The phone number to dial if the first phone number is not answered
- The number of times to retry a busy phone number
- The number of times to dial a phone number before switching to an alternate phone number
- The types of calls to pass to an agent when the dialer detects an answer
You can create wildcard expressions to define a range of values. Each wildcard expression specifies a wildcard character and a value. A value can be a number or letter.

Wildcard characters include the following symbols:

<table>
<thead>
<tr>
<th>Wildcard character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>is equal to</td>
</tr>
<tr>
<td>&lt;&gt; or ~</td>
<td>is not equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>is greater than</td>
</tr>
<tr>
<td>&lt;</td>
<td>is less than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>is greater than or equal to</td>
</tr>
<tr>
<td>&lt;=</td>
<td>is less than or equal to</td>
</tr>
</tbody>
</table>

For more detailed pattern matching rules, see Chapter 23: Pattern matching rules on page 277.

---

Phone strategy settings

This section describes the following phone strategy settings:

- Initial phone on page 180
- Alternate initial phone on page 181
- Detection mode on page 181
- Retries on page 182

Initial phone

The initial phone is the first phone number that the system uses to place a call for each record. The system stores the phone numbers in the calling list phone fields, for example PHONE1 and PHONE2. If a record does not match the phone criteria that you set, the system will not place a call.

The system classifies phone numbers by phone type and assigns a number to each type. For example, the home phone might be phone number 1 and the business phone number 2. The dialer phone type numbers are set during your system configuration.

Example - If your initial phone pane’s fields were as follows: Phone=1, Field= Name=PHONESTAT, and Value=~B?

The system would dial the number in the PHONE1 field for all records whose PHONESTAT field does not contain a “B”, or bad number.
The only fields that are required on the Initial Phone tab are Phone, Field, and Value. The remaining three fields (Logic, Field, and Value) are optional and allow you to combine two statements together using a logic operator.

**Phone** - Click this field to select a phone.

**Field** - Click this field to select one of the fields from your download.

**Value** - Use a value or a wildcard character. Values can be numbers, letters, dates, and times. For example, account balances consist of numbers, while customer names consist of letters. For information on using wildcard characters, see Record selection wildcard characters on page 194.

**Alternate initial phone**

The alternate initial phone setting is the phone number that becomes the initial phone at a specified time of day. The alternate initial phone number also specifies the time the system starts dialing the alternate initial phone.

The system starts dialing the alternative initial phone based on the local time in the selected time zone.

**Example** - You can tell the system to switch from dialing business phones, the initial phone, to dialing home phones, the alternate initial phone, at 6 PM.

**Detection mode**

The system uses the detection mode to identify how the phone number was answered. The system passes phone calls to agents based on the detection mode you specify.

**Example** - A detection mode can be a live voice, an answering machine, or an operator intercept.

**Number of Rings** - Specify the number of rings to allow before the system records a NOANSWER completion code.

**Pass to Agent** - The detection mode tells the system which calls to pass to agents. When the system places a call, the system detects what type of answer occurs for each call and then decides whether or not to pass that call to an agent.

The following table describes the Detection Mode tab options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Voice</td>
<td>A person’s voice was detected</td>
</tr>
<tr>
<td>Autovoice</td>
<td>An answering machine was detected</td>
</tr>
</tbody>
</table>
Chapter 16: Phone strategy

Tip:
To increase your hit rate, decide which detection modes to use. With each additional criteria you select, your agents can handle more calls rather than the system.

Retries

The system uses the retries setting to place another phone call for the same record. The system applies the following criteria based on the result of the initial call:

- How long the system waits before dialing the number again
- How many times the system dials the same phone number
- Which phone number the system dials next

Example - You can tell the system to retry the call in 15 minutes when the initial call result is busy and to stop dialing that phone number if there is no answer after three retries.

Tip:
It is important to understand the difference between a system retry and a customer recall.

- A system retry is a computer generated phone call attempt. If the system detects a busy signal on the first call attempt, the system dials the phone number based on the retry parameters in the phone strategy.
- Agents set up customer recalls. An agent can set either an Agent Owned Recall or a general recall. For an agent owned recall, the system routes the phone call to the agent who set the phone call. For a general recall, the system dials the phone number and routes the phone call to any available agent.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Intercept</td>
<td>An operator intercepted the call</td>
</tr>
<tr>
<td>No circuit</td>
<td>No circuit was available</td>
</tr>
<tr>
<td>Disconnect</td>
<td>Disconnected the phone call</td>
</tr>
<tr>
<td>Vacant</td>
<td>Vacant number</td>
</tr>
<tr>
<td>Reorder</td>
<td>Reorder</td>
</tr>
</tbody>
</table>
Using phone strategies

This section contains procedures that you can use to create, edit, and use phone strategies:

- **Create a phone strategy** on page 183
- **Copy a phone strategy** on page 185
- **View phone strategy settings** on page 185
- **Edit a phone strategy** on page 185
- **Delete a phone strategy** on page 186

Create a phone strategy

To create a phone strategy:

1. Select **Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor**.
2. If necessary, log in to Supervisor. For more information, see **Log in to Supervisor** on page 34.
3. From the drop-down list, select the dialer where you want your phone strategy to reside.

**Tip:**
You can save the phone strategy to other dialers or delete the phone strategy from this dialer at a later time.

4. Click **Strategy** on the button group.
5. Select **File > New**.
6. On **Detail** tab, select a calling list.
7. Select **File > Save**.
   a. In the Save As dialog box, select another dialer if you want to save the phone strategy to a different dialer.
   b. Enter a file name for your strategy, and then click **OK**.
   Editor displays the phone strategy tabs in the right-hand pane.
8. On the **Initial Phone** tab, complete the following settings:
   a. Right-click and select **Append Row**.
   b. Click the **Phone** field and select a phone.
   c. Click the **Field** field and select a field from the download to use base how the system selects phone numbers to place telephone calls.
d. (Optional) Complete the **Logic**, **Field**, and **Value** fields to specify your restrictions. For documentation on wild card characters, see Phone strategy preparation on page 179.

Examples:
- To exclude bad numbers, select PHONESTAT in the **Field** list and Enter ~B? in the **Value** field to specify or not equal to bad numbers.
- To place a call to all records, Enter an asterisk (*) in the **Value** field.

9. (Optional) On the **Alternate Initial** tab, specify alternate initial phone settings.
   a. Right-click and select **Append Row**.
   b. Click the **Time** field to specify the time that you want to switch from the initial phone to the alternate initial phone.
      The system bases the decision to switch phone numbers on the time in the time zone (not the system time).
   c. Select the time zone(s) as appropriate.
      - Right-click and select **Select All** to select all time zones.
      - Right-click and select **Unselect All** to clear all options.

10. On the **Detection Mode** tab, click the **Number of Rings** field and then use the list to select a number.
    Select the check boxes to specify which types of calls to pass to agents.

    **Note:**
    If this strategy is associated with the virtual job that has a low value for the **Number of Rings** field, then the virtual job does not play a message to the answering machine. The recommended minimum value for the **Number of Rings** field is 3.

11. On the **Retries** tab, select the call results that the system will retry. For example, if the system detects a busy signal on the first call attempt, it will retry based on your “Busy signal” values on this pane.
    For each result you select, enter a value in the **Retry Interval** (minutes), **Attempts**, and **Next Phone** columns.

12. Select **File > Save**.
    If multi-dialer is enabled, you can copy the strategy to additional dialers.

    **Note:**
    For English, the maximum length for the strategy name is 20 characters and recommended is 15 characters. For other languages, the maximum length for the strategy name is 15 characters and recommended is 8 characters.
    a. In the Save As dialog box, select another dialer if you want to save the phone strategy to a different dialer.
Using phone strategies

b. Enter a file name for your strategy, and then click **OK**. Avaya Proactive Contact automatically saves the file to the selected dialer.

---

**Copy a phone strategy**

You can copy a phone strategy to another dialer. If the multi-dialer is not enabled, see [Enable or disable multi-dialer commands](#) on page 109 to enable the feature.

To copy a phone strategy.

1. Click the phone strategy you want to copy.
2. Select **File > Save As**.

   If multi-dialer is enabled, you can copy the strategy to additional dialers.
   
   a. In the Save As dialog box, select another dialer if you want to save the phone strategy to a different dialer.
   
   b. Enter a file name for your strategy, and then click **OK**.

   Avaya Proactive Contact automatically copies the file to the selected dialer.

---

**View phone strategy settings**

To view phone strategy settings:

1. Click the phone strategy you want to open.
   
   The phone strategy settings appear in the right-hand pane.
   
2. To navigate through the phone strategy settings, click a tab.

---

**Edit a phone strategy**

Change phone strategy settings when doing so will help your system dial more efficiently. Changes take affect the next time a job that uses the strategy is started.

If you select a different calling list for a phone strategy, you might need to redefine certain phone strategy settings:

- If the newly selected calling list contains the same number of phone fields with the same field names as the original list, the system retains all the phone strategy settings.

- If the newly selected calling list has a different number of phones or the phone field names are different, the system retains the initial phone and alternate initial phone settings, but does not retain the original detection modes and retries settings.
To edit a phone strategy:
1. Click the phone strategy you want to edit.
2. Click a tab to make the necessary edits in the right-hand pane.
   Refer to the Create a phone strategy on page 183 for detailed information.
3. Select File > Save, and then click OK.

Delete a phone strategy

To delete a phone strategy:
1. Click the phone strategy you want to delete.
2. Select File > Delete.
3. When asked if you really want to do this, click OK.
4. If the multi-dialer option is enabled, the Multiple dialer command dialog box appears.
   If the check boxes are grayed out, select Settings > Options to enable the multi-dialer settings.
   a. Click to clear the check boxes of the dialers from which you do not want to delete the strategy.
   b. Click OK.

Maintaining phone strategies

This section contains the following procedures you can use to maintain phone strategies:

- List all phone strategies on a selected dialer on page 187
- Append a phone strategy row on page 187
- Insert an initial phone in a phone strategy on page 187
- Delete a row in a phone strategy on page 188
- Select all rows in a phone strategy on page 188
- Unselect all rows in a phone strategy on page 188
List all phone strategies on a selected dialer

To view a list of all phone strategies on a selected dialer:

1. From the drop-down list, select the dialer for which you want to list the phone strategies.
2. Click **Contact Management**.
3. Click **Strategies**.

Append a phone strategy row

Appending a row adds a row beneath the bottom row on the **Initial Phone** and **Alternative Initial Phone** tabs.

To append a row:

1. On the Editor button bar, click **Contact Management**.
2. Click **Strategies**.
3. Click the phone strategy you want to edit.
4. In the right-hand pane, click the following tabs to append an initial or alternate initial phone:
   - **Initial Phone**
   - **Alternate Phone**
5. Select **Edit > Append Row**.

Insert an initial phone in a phone strategy

Inserting a row adds a row directly above the row you select on the **Initial Phones** or **Alternate Initial** tabs.

To insert a row in your phone strategy:

1. On the Editor button bar, click **Contact Management**.
2. Click **Strategies**.
3. Click the phone strategy you want to edit.
4. In the right-hand pane, click the **Initial Phone** or **Alternate Initial Phone** tabs for the settings you want to edit.
5. Select the row that the new row will appear above.
6. Select **Edit > Insert Row**.
Chapter 16: Phone strategy

Delete a row in a phone strategy

To delete a row on the Initial Phones or Alternate Initial tabs from your phone strategy:

1. On the Editor button bar, click Contact Management.
2. Click Strategies.
3. Click the phone strategy you want to edit.
4. In the right-hand pane, click the Initial Phone or Alternate Initial Phone tabs for the settings you want to edit.
5. Select the row you want to delete.
7. Select the row to move.

Select all rows in a phone strategy

To select all rows that have a check box on the Alternate Initial, Phone, Detection, and Retires tabs:

1. On the Editor button bar, click Contact Management.
2. Click Strategies.
3. Click the phone strategy you want to edit.
4. In the right-hand pane, click one of the following tab:
   - Alternate Initial Phone
   - Detection
   - Retries
5. Select Edit > Select All.
   Editor selects each check box.

Unselect all rows in a phone strategy

To clear all rows that have a check box on the Alternate Initial, Phone, Detection, and Retires tabs:

1. On the Editor button bar, click Contact Management.
2. Click Strategies.
3. Click the phone strategy you want to edit.

4. In the right-hand pane, click one of the following tab:
   - Alternate Initial Phone
   - Detection
   - Retries

5. Select **Edit > Unselect All.**
   Editor clears each check box.
Chapter 17: Record selection

Avaya Proactive Contact uses record selections to determine which records to use to place phone calls during a job.

In Editor, you can create, edit, and view existing record selections or view only the record selections that have been run.

A record selection contains rules or selection criteria. For example, a record selection can place phone calls and select only customers who meet the following criteria:

- Have a balance of less than $5,000
- Live in California

You can use record selections that you saved on more than one job.

This section contains the following topics:

- Understanding record selection on page 191
- Record selection use on page 192
- Using a record selection on page 196
- Maintaining a record selection on page 203
- Record Selection for Multiple Dialers on page 207

Understanding record selection

A record selection contains the set of instructions that tells Avaya Proactive Contact which customer records to select from a calling list.

A record selection consists of selection criteria and a phone strategy. Each job uses the results of a record selection to place calls to customers.

When a record selection starts, Avaya Proactive Contact selects records based on the following criteria:

- Calling list fields
- Time zones
- Previous calling results
- Agent set recalls
- Phone strategy settings
You can verify a record selection before you start a job to determine the number of records that were selected.

This section contains the following topics:

- Specify time zones on page 192
- Specify completion codes on page 192
- Specify goals on page 192

---

### Specify time zones

You can use a record selection to specify time zones such as Eastern, Central, or Pacific. Avaya Proactive Contact places phone calls to only the records whose addresses are in the specific time zones. If time zones are not specified, Avaya Proactive Contact defaults to a “follow the sun” method. Dialers place calls to customers in the east and proceed to the west.

---

### Specify completion codes

You can use a record selection to specify completion codes such as BUSY, NOANSWER, or SIT, special information tones. For example, if you specify the SIT completion code, the record selection looks for phone numbers that are disconnected, redirected, or no longer in service.

---

### Specify goals

You can use a record selection to specify goals, such as the following goals:

- Accounts more than 30 days overdue
- Accounts with a balance over $2,000, or records in a particular state.

---

### Record selection use

In Editor, you can create, edit and view existing record selections or view only the record selections that have been run.

This section discusses the following buttons for record selections:

- Understand the Selections settings on page 193
- Understand the Selection Reports settings on page 195
Understand the Selections settings

Use **Selections** to do the following tasks:

- Create a new record selection
- Edit an existing record selection
- View all existing record selections

Click **Selections** on the button bar to list the existing record selections. Click a record selection name to divide the window into the following panes:

- The left-hand pane lists the record selections.
- The right-hand side contains tabs that you use to edit settings for the record selection.

This section discusses the following topics:

- [Selections tabs](#) on page 193
- [Record selection wildcard characters](#) on page 194

**Selections tabs**

The following table describes the tabs that appear on the right-hand pane of the window.

<table>
<thead>
<tr>
<th>Tab name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Detail</td>
<td>Use the <strong>Detail</strong> tab to specify a calling list, ignore the time zone option, unit work list field, phone strategy file, and selection type. To select a value, click the field and use the drop-down list to select.</td>
</tr>
<tr>
<td>Records</td>
<td>Use the <strong>Records</strong> tab to define which records the system uses during a job based on logic statements that you create. Click <strong>Field</strong> and the drop-down list to select a field. Enter a value. If you use the <strong>Logic</strong> field, you begin to create a multi-line logic statement. Click the <strong>Logic</strong> field to use the drop-down list to select <strong>And</strong> or <strong>Or</strong>. To add a row, select <strong>Edit &gt; Append Row</strong>. For information on using a wildcard character, see <a href="#">Record selection wildcard characters</a> on page 194.</td>
</tr>
<tr>
<td>Time Zones</td>
<td>Use the <strong>Time Zones</strong> tab to select time zones that the system places phone calls. You can right-click and select <strong>Select All</strong> or <strong>Unselect All</strong>.</td>
</tr>
<tr>
<td>Results</td>
<td>Use the <strong>Results</strong> tab to tell the system which phone numbers to dial based on previous calling results. Select each completion code you want the system to call. You can right-click and select <strong>Select All</strong> or <strong>Unselect All</strong>.</td>
</tr>
</tbody>
</table>
A record selection contains options that you define. The system selects a record if it meets specific criteria. The record selection with the phone strategy determines to whom the dialer places phone calls and how the dialer places the phone calls.

Tip:
If you do not know what to enter in a field, click the field to see if there is a list of values to select. A blinking cursor indicates that you can enter a value in the field.

### Record selection wildcard characters

Phone strategies and record selections use wildcard character expressions to specify criteria for a field. A wildcard character expression is a combination of wildcard characters and values. In a record selection, wildcard character expressions allow you to define the subset of records you want to use.

You can create wildcard expressions on the **Records** and **Recalls** tabs. Each wildcard expression specifies a field name from the records in the calling list, a wildcard character, and a value. A value can be numbers, letters, dates, and times. For example, account balances consist of numbers and customer names consist of letters.
Wildcard characters include the following symbols:

<table>
<thead>
<tr>
<th>Wildcard character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>is equal to</td>
</tr>
<tr>
<td>&lt;&gt; or ~</td>
<td>is not equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>is greater than</td>
</tr>
<tr>
<td>&lt;</td>
<td>is less than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>is greater than or equal to</td>
</tr>
<tr>
<td>&lt;=</td>
<td>is less than or equal to</td>
</tr>
</tbody>
</table>

For more detailed pattern matching rules, see Chapter 23: Pattern matching rules on page 277.

Example record selection statements include the following:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACCT_BALANCE</td>
<td>&gt;=500</td>
<td>Customer records with account balances greater than or equal to $500.</td>
</tr>
<tr>
<td>CITY</td>
<td>=Chicago</td>
<td>Customer records with Chicago addresses.</td>
</tr>
</tbody>
</table>

Consider the following tips when you create your record selection statement:

- You can connect two or more statements using the operators **And** and **Or**.
  - Use **And** to narrow the selection to the customer records that meet the criteria in **both** statements.
  - Use **Or** to broaden the selection to select the customer records that meet the conditions in **either** statement.
- Click **Append** to add a line to the bottom of the selection area.
- Click **Insert** to insert a line below the cursor.
- Click **Delete** to delete the selected line.

---

**Understand the Selection Reports settings**

Click **Selection Reports** on the button bar to list the record selections that were previously run.

Selection Reports contains summary information that you do not modify.

To view a selection report, click a selection. The **Details** tab contains the report details that you can copy and paste into a different application or save and print the report. For more information, see Save and print a Record Selections report on page 202.
Chapter 17: Record selection

The Selection Reports pane contains the following headings:

<table>
<thead>
<tr>
<th>Heading</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selection</td>
<td>Record selection file name.</td>
</tr>
<tr>
<td>List</td>
<td>Calling list associated with this record selection</td>
</tr>
<tr>
<td>Status</td>
<td>Record selection status is In Use if it is used for a currently running job or Available if it is not in use.</td>
</tr>
<tr>
<td>Records</td>
<td>Number of customer records associated with this record selection file</td>
</tr>
<tr>
<td>Records Remaining</td>
<td>Number of remaining records to dial. The number changes if the job is running.</td>
</tr>
<tr>
<td>Recalls</td>
<td>Number of recalls or callbacks that the record selection file has flagged.</td>
</tr>
<tr>
<td>Selection Ran at</td>
<td>The time and date when the record selection was run.</td>
</tr>
</tbody>
</table>

Details pane

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Immediate</td>
<td>In the call selection report, the value for &quot;Immediate&quot; field indicates the number of calls that will be made immediately after the job is run as their start time has already passed. For example, if a recall is set to occur at 9:45 A.M. and a job, which uses that record selection, is started at 10:00 A.M., the recall will be made immediately.</td>
</tr>
</tbody>
</table>

Using a record selection

This section contains the following topics to help you create a record selection:

- [Open and view a record selection](#) on page 197
- [Complete the Detail tab](#) on page 197
- [Complete the Records tab](#) on page 198
- [Complete the Time Zones tab](#) on page 198
- [Complete the Results tab](#) on page 198
Using a record selection

- Complete the Recalls tab (optional) on page 199
- Complete the Sort tab (optional) on page 200
- Create a record selection on page 200
- Save a record selection on page 201
- Edit a record selection on page 201
- Delete a record selection on page 201
- Verify a record selection on page 201
- Run a record selection on page 202
- Save and print a Record Selections report on page 202

Open and view a record selection

To open and view a record selection.

1. Select Start > All Programs > Avaya > Supervisor > Editor.
2. On the button bar, click Selections.
   
   The list of selections for the selected dialer appear.
3. To see record selections that have been defined for a different dialer, click the name of the dialer on the button bar, and then click Selections for that dialer.
4. Click a record selection title to display the selection settings in the right-most pane.
5. Click a tab to move through the settings.

Complete the Detail tab

To modify the fields on the Details tab.

1. Click the List field to use the drop-down list. Select a calling list.
2. Click the Ignore Time Zone check box to ignore time zones and to follow the sun. Clear the check box to use time zones.
3. Click the Strategy field to use the drop-down list.
   
   Select a phone strategy file that you have already created.

   It is beneficial to create a phone strategy, record selection and then job, in that order.
4. Click the Unit Field field and select a unit work list.
Chapter 17: Record selection

5. Click the Selection Type field and select Infinite, Verify, or blank.
   Blank is an empty, blank option; in this case it indicates that you want neither Infinite nor Verify.
   Select Infinite if your job is an infinite job; select Verify if your job is a verification job.

Complete the Records tab

Use the Records tab to define your record selection statement.

1. Click the Records tab.
2. Click the Field field to use the drop-down list. Select a field (for example, BALANCE).
3. Double-click the Value field to enter a value (for example, >3000).
4. (Optional) If you use the Logic field, you begin to create a multi-line logic statement. Click the Logic field to use the drop-down list to select And or Or.
5. Click the Group column, on the far left, and use the check box. To start a new group, select the check box at the beginning of the first line of the group. Do not select any other check box unless you want to start another group.
   When you group rows, the Logic column becomes a critical linking component because its logic operator determines how the linked elements resolve as one statement.
6. To add a row, select Edit > Append Row.
7. Repeat Steps 2 through 5 for each selection criteria.

Complete the Time Zones tab

To select which time zones the system will call.

1. Select the time zones you want to call.
   To select all time zones, right-click and select Select All.
2. Clear the each time zone you do not want to include.
   To clear all time zones, right-click and select Unselect All.

Complete the Results tab

To complete the Results tab.

1. Select the completion code you want the system to call.
   Select File > Select All or right-click and select Select All.
2. Clear each completion code you do not want to call.

   Select File > Select All or right-click and select Unselect All to clear all of the completion codes.

   **Tip:**
   New records that have not been called yet are assigned a “Record not yet called” code. You will almost always select the “Record not yet called” box because you have never attempted to call that customer before.

---

**Complete the Recalls tab (optional)**

The Recalls tab is optional. Use the Recalls tab to filter which agent-set recall records that dialer will use to place calls.

To dial all scheduled agent-set recalls, do not complete this tab.

To make only the recalls scheduled during the current job, enter criteria to match the Records tab.

To prevent any agent-set recalls, enter values that cannot be met so that no records can qualify for recall. For example, select the STATE field and enter ZZ (no records will have a STATE value of ZZ, so no records can be selected for recall).

To complete the Recalls tab:

1. If the Recalls tab has no visible rows, select Edit > Append Row or right-click and select Append Row.
2. Click the Field field to select a field (for example, BALANCE).
3. Double-click the Value field to enter a value (for example, >3000).
4. (Optional) If you use the Logic field, you begin to create a multi-line logic statement. Click the Logic field to use the drop-down list to select And or Or.
5. Click the Group column, on the far left, and use the check box. To start a new group, select the check box at the beginning of the first line of the group. Do not select any other check box unless you want to start another group.
   When you group rows, the Logic column becomes a critical linking component because its logic operator determines how the linked elements resolve as one statement.
6. To add a row, select Edit > Append Row.
7. Repeat Steps 2 through 5 for each selection criteria.
Chapter 17: Record selection

Complete the Sort tab (optional)

The Sort tab is optional.

To tell the system how to sort the selected records:

1. If the Sort tab has no visible rows, select Edit > Append Row or right-click and select Append Row.
2. To change the priority, select the Edit menu or right-click the row and then select Move Up or Move Down.
3. Click the Sorts Records By field to use the drop-down list and select a field.
4. Click the Order field to use the drop-down list and select Ascending or Descending.

Tip:
You can set up to 10 sorts.

Create a record selection

To create a record selection:

1. Select the name of the dialer where you want your record selection to reside. (You can save it to additional dialers or delete it from this dialer later.)
2. On the button bar, click Selections.
4. In the right-hand pane, click the List field and select a calling list.
5. Click a tab to complete the settings. For more information, see the following topics:
   - Complete the Detail tab on page 197
   - Complete the Records tab on page 198
   - Complete the Time Zones tab on page 198
   - Complete the Results tab on page 198
   - Complete the Recalls tab (optional) on page 199
   - Complete the Sort tab (optional) on page 200
6. When finished, select File > Save.

Note:
For English, the maximum length for record selection name is 20 characters and recommended is 15 characters. For other languages, the maximum length for record selection name is 15 characters and recommended is 8 characters.
Using a record selection

a. The record selection is automatically saved to the dialer you selected.
   In a multi-dialer environment, select the dialers you want to save the record selection.
   If the additional dialers were unavailable, select Settings > Options to change your multi-dialer settings. For more information, see Options, Multi-dialer tab on page 240.

b. Enter a file name, and then click OK.

Save a record selection

You can save a record selection to another dialer. If the multi-dialer is not enabled, see Enable or disable multi-dialer commands on page 109 to enable the feature. Use the following procedure to save a record selection. When you finish defining settings for a record selection, select File > Save.

If multi-dialer is enabled, you can save the record selection to additional dialers.

1. In the Save As dialog box, select another dialer if you want to save the phone strategy to a different dialer.
2. Enter a file name for your strategy, and then click OK.

   Note: For English, you can enter a record selection name upto a maximum of 20 characters. In other languages, you can enter a record selection name upto a maximum of 15 characters. However, it is recommended that you keep the maximum number of characters for English language as 15 characters and the maximum number of characters for other languages as 8 characters.

Avaya Proactive Contact automatically saves the file to the selected dialer.

Edit a record selection

To edit a record selection:

1. Click on the record selection you want to edit.
2. Make the necessary edits on the tabs.
3. Select File > Save to save the changes.

Delete a record selection

To delete a record selection:

1. Select the record selection you want to delete.
2. Select File > Delete.
3. When asked if you are sure, click Yes if you are sure.

Verify a record selection

To verify that the settings for a particular record selection are complete and that the record selection will run when started.

Avaya Proactive Contact displays a message if an error occurs.

You should review the tabs before verifying a record selection. You cannot verify a record selection until you have saved your work.

1. Select the record selection you want to verify.
2. Select File > Verify, and then click OK.

Run a record selection

To run a record selection:

1. Click the record selection you want to run.
2. Select File > Run, and then click OK.

Tip:
You do not need to run a record selection before you start a job. You can, however, run a record selection to check to determine how many records are selected. When you start a job, the system first verifies the record selection, and then starts the job.

Save and print a Record Selections report

To save a Record Selections report as an HTML file:

1. Click Selections Report in the left-hand pane.
2. Select a selections report in the Record Selections window.
   The report appears in the right-hand pane.
3. Select File > Save As HTML.
   The Save As dialog opens in your preference directory.
4. Enter a file name and click OK.
5. Click **Yes** to display the report.

   Internet Explore displays the report ready for you to print.

6. Select **File > Print** to print the report.

---

**Maintaining a record selection**

This section contains the following topics to help you maintain a record selection:

- **Copy a record selection** on page 203
- **List all record selections on a selected dialer** on page 204
- **View selection reports** on page 204
- **View record selection settings** on page 204
- **Append record selection rows** on page 205
- **Insert a row in a record selection** on page 205
- **Delete a row in a record selection** on page 205
- **Move a row up in a record selection** on page 206
- **Move a row down in a record selection** on page 206
- **Select all rows in a record selection** on page 207
- **Unselect all rows in a record selection** on page 207

---

**Copy a record selection**

To copy a record selection:

1. Select the record selection you want to copy.
2. Select **File > Save As**.
   
   In a multi-dialer environment, select the dialers you want to save the record selection. If the multi-dialer is not enabled, see [Enable or disable multi-dialer commands](#) on page 109 to enable the feature.
3. Enter a name for the copied record selection, and then click **OK**.
List all record selections on a selected dialer

To view a list of all record selections on a selected dialer:
1. Select the name of the dialer whose record selections you want to list.
2. Click Selections. The record selections for the selected dialer appear.

View selection reports

In the button bar, you see both Selections and Selection Reports. The difference between these two is that Selections displays all of the record selections that you have created and Selection Reports displays all of the record selections that you have run. Selection Reports provides detailed information about the results of the record selection.

To view selection reports.
1. On the button bar, select the dialer whose record selection reports you want to view.
2. Click Selection Reports.
   The right-hand pane list the selection reports.
3. Click the selection report you want to open. The right-hand pane populates with your selection report.
4. If you want to copy and paste the report to a different application, right-click and select Select All. Then, right-click and select Copy.

View record selection settings

To view record selection settings:
1. On the Editor button bar, click Selections.
2. Click the record selection you want to open.
   The record selection settings will appear in the right hand pane.
3. Click a tab to navigate through all of the record selection settings.
Append record selection rows

Appending a row adds a row beneath the bottom row.

To append a row in your record selection:
1. On the Editor button bar, click **Contact Management**.
2. Click **Selections**.
3. Click the record selection you want to edit.
4. In the right-hand pane, click one of the following tabs:
   - **Records**
   - **Recalls**
   - **Sort**
5. Select **Edit > Append Row**.

Insert a row in a record selection

Inserting a row adds a row directly above the row you select.

To insert a row to your record selection:
1. On the Editor button bar, click **Contact Management**.
2. Click **Selections**.
3. Click the record selection you want to edit.
4. Click one of the following tabs:
   - **Records**
   - **Recall**
   - **Sort**
5. Select the row that the new row will appear directly above.
6. Select **Edit > Insert Row**.

Delete a row in a record selection

To delete a row from your record selection:
1. On the Editor button bar, click **Contact Management**.
2. Click **Selections**.
3. Click the record selection you want to edit.
4. Click one of the following tabs:
   - Records
   - Recall
   - Sort
5. Select the row you want to delete.

---

### Move a row up in a record selection

You can change the sort order by moving the row up or down on the Sort tab.

To move a row up in your record selection:
1. On the Editor button bar, click **Contact Management**.
2. Click **Selections**.
3. Click the record selection you want to edit.
4. Click the Sort tab.
5. Select the row you want to move.

---

### Move a row down in a record selection

You can change the sort order by moving the row up or down on the Sort tab.

To move a row down in your record selection:
1. On the Editor button bar, click **Contact Management**.
2. Click **Selections**.
3. Click the record selection you want to edit.
4. Click the Sort tab.
5. Select the row you want to move.
Select all rows in a record selection

To select all rows that have a check box on the Time Zones and Results tabs:

1. On the Editor button bar, click Contact Management.
2. Click Selections.
3. Click the record selection you want to edit.
4. Click one of the following tabs:
   ● Time Zones
   ● Results
5. Select Edit > Select All.

Unselect all rows in a record selection

To clear all rows that have a check box on the Time Zones and Results tabs:

1. On the Editor button bar, click Contact Management.
2. Click Selections.
3. Click the record selection you want to edit.
4. Click one of the following tabs:
   ● Time Zones
   ● Results
5. Select Edit > Unselect All.

Record Selection for Multiple Dialers

When a record selection is run for multiple dialers, it will execute on the Proactive Contact that contains the list. However for many dialers it is needed for how many actual call selections are run. They run simultaneously, but if there is calling being done on the same records that are being selected, the records selected may not match 100%. Avaya Proactive Contact that holds the list will then "push" the indexes to the remote system through a socket connection of lists server. You will see a "callsel (for remote)" message in the account log on the PDS containing the list (one callsel message for each call selection run for remote systems). The time stamp for the "callsel (for remote)" account log entry will be in local time of the remote system, which can look odd as it will likely be off from the other times of the nearby messages in that account log.
Once the job has been started on the remote system listserver will "fetch" each record to the job, once the call is completed it will "push" the record back to the list.

Run Record Selections From Command Line

Record Selections can be run from the command line using md_callsel:

```
md_callsel redlab06-list1 xyz
```

Record Selections can run locally on remote list with callsel by using the `callsel -l redlab03-list1 -s xyz -x command`. 
Chapter 18: Jobs

A job contains all the information that Avaya Proactive Contact needs to place phone calls to customers. A job integrates a calling list, phone strategy, record selection, and other settings to place outbound calls and receive inbound calls.

This section contains the following topics:

- Understanding jobs on page 209
- Understanding job settings on page 214
- Using jobs on page 232
- Maintaining jobs on page 238
- Understanding Editor system dialog boxes on page 240

Understanding jobs

A job contains all the information the system needs to place phone call to customers. The type of job you set up determines the type of calling activities that agents handle.

This section contains the following topics to help you create and run jobs:

- Job types on page 209
- Outbound jobs on page 210
- Call pacing on page 212

Job types

Depending on your system configuration, a job can conduct the following types of calling activities:

- Make outbound calls
- Receive inbound calls
- Verify a sale

You can start more than one job at one time.

If you have an Agent Blending system, you can use Editor to set up outbound jobs.
If you have an Intelligent Call Blending system, you can use Editor to set up the following types of jobs:

**Outbound jobs** - During outbound jobs, the system uses a calling list, phone strategy, record selection, and other settings to place outbound calls to customers. For more information, see [Understanding job settings](#) on page 214.

**Inbound jobs** - An inbound job is a job on an Intelligent Call Blending system where the system automatically routes inbound calls to agents.

An Agent Blending system does not have inbound jobs. The ACD controls inbound calling activity rather than the system. The agents on the ACD handle the inbound calls.

**Blend jobs** - A blend job is a job on an Intelligent Call Blending system where the system moves agents between outbound and inbound calling activities. Blend agents receive inbound calls during peak inbound activity and outbound calls when inbound activity decreases.

In Avaya Proactive Contact, a blend job handles both inbound and outbound calls on an Intelligent Call Blending system.

---

### Outbound jobs

During outbound jobs, the system automatically dials phone numbers and routes calls to agents. Depending on your system configuration, the system monitors the phone calls to ensure that agents do not receive phone calls that result in the following connections:

- Answering machines
- Phone operator intercepts
- Busy signals
- Interactive Voice Response systems (IVRs)
- No answers

This section contains the following topics:

- [When a job stops](#) on page 210
- [Types of outbound jobs](#) on page 211

### When a job stops

Avaya Proactive Contact uses quotas as a means to complete a certain number of outbound calls based on a selected outcome.

A quota is a maximum number of releases for a particular completion code. When the job reaches the quota for a unit, no more calls are placed.

In Avaya Proactive Contact, a job can stop when the following occurs:
The job reaches the **Latest Time to Stop** setting.

- You stop the job manually.
- The system placed a call to all initial phones at least once.
- The system placed a call to all recalls at least once.
- The system placed a call to all scheduled recalls, but stops dialing after placing a call to all initial phones at least once.

In Editor, you set and modify a quota that the system applies to the job when the job starts. In Monitor, you set and modify a quota that affects the current job while that job runs.

### Types of outbound jobs

An outbound job uses settings to place calls to customers.

Depending on the configuration for an Intelligent Call Blending system, you can create or modify the following types of jobs:

- **A Unit Work List job** divides customer records into work lists or subsets. Agents work with records only in their assigned work lists.

- **A Managed Dialing job** allows agents to preview or cancel a customer record before the dialer places the call the customer. Depending on your system setup, you can adjust the maximum preview time and allow agents to cancel calls.

- **A Sales Verification job** verifies a transaction or commitment that the customer made. Use the Sales Verification record selection when starting a Sales Verification job.

- **An Infinite job** uses a special record selection to add records for calling to an existing calling list while the job is active. Use the Infinite record selection when starting an Infinite job. An infinite job runs until you stop it manually.

- **A Virtual Agent job** allows the system to run a job without agents. When the system detects a customer or an answering machine, the system plays a recorded message. You can also allow customers to opt-out of the recorded message to talk to an agent. The call is then transferred on a specified VDN or to an inbound/blend job.

In Editor Job Wizard, you define Unit Work List, Managed, Sales Verification, and Virtual jobs on the second screen. The job you select determines the type of additional jobs you can select to create. For example:

- If you select Virtual, you cannot select any other type of job.
- If you select Managed, you can select only Unit Work List.

### Maximum number of jobs allowed

You can run a maximum of 75 active jobs using Editor on your installation. The active jobs includes user-started jobs, linked jobs, and IVR pool jobs; therefore, you can run a sum total of
75 user started jobs, linked jobs, and IVR pool jobs. When you start the 76th active job, then an alert is displayed stating that the maximum limit of jobs that can be run simultaneously has been reached. As a result, the system does not stop any existing job and the 76th job is not started.

In case of Agent Owned Recall feature, which is turned on by default, the following rules are enforced:

- If the Agent Owned Recall feature is turned on, then you can run either of the following:
  - A maximum of 75 active jobs. In this case, when you start the 76th active job, then the maximum limit of simultaneous jobs alert is displayed. As a result, the system does not stop any existing job and the 76th job is not started.
  - Active jobs + the number of shadow jobs, not exceeding 150 jobs.
    - The number of active jobs vary from 0 to 75 jobs.
    - The number of shadow jobs vary from 0 to 150 jobs.

For example, if the number of shadow jobs on your installation reach 75 jobs, then you get the alert when you start the 76th active job. However, if your number of shadow jobs reaches 80, then you can run only 70 active jobs, which makes a total of jobs running on your installation as 150 jobs and an alert is displayed when you attempt to start the 71st active job.

- If you choose to turn off the Agent Owned Recall feature, then you can run a maximum of 150 active jobs. If you attempt to start another active job when the maximum limit of concurrent jobs, that is 150 jobs, is reached, then an alert is displayed when you start the 151st job stating that the maximum limit of jobs that can be run simultaneously has been reached.

In case of Linked jobs, which cannot start due to unavailable resources, this alert message is logged in the account log.

---

**Call pacing**

Avaya Proactive Contact has two methods to pace outbound dialing during an outbound job: Cruise Control and Expert Calling Ratio.

When you define a job in Editor, you set the call pacing method based on the type of calling activity you want to complete. For example:

- If you want to limit abandoned or nuisance calls while maximizing agents handling calls, select **Cruise Control**.
Note:
"After selecting the Require unit ID for agent login check box, if you select the Cruise Control option for the Call Pacing Method field, then the following message is displayed:
Only Expert Calling is allowed with unit work list. You are turning off unit work list feature. "Percent completion of job to run record selection for linked job" is now editable. When you click OK, the Editor clears the Require unit ID for agent login check box and makes the Percent completion of job to run record selection for linked job field editable.

- If you want to pace calling activities based on time in a wait queue or time agents spend handling calls, select Expert Calling Ratio.

You can link a job that uses Cruise Control to a job that uses either the Cruise Control or Expert Calling Ratio method.

Note:
The same job name on different dialers in a pod can use a different call pacing method. To ensure consistent monitoring and reporting, use the same settings for the same job name on each dialer.

This section contains the following topics:

- Cruise Control on page 213
- Expert Calling Ratio on page 214

Cruise Control

Use Cruise Control for outbound jobs when any of the following dialing conditions are important:

- The job is subject to government regulations prohibiting abandoned calls, nuisance calls, or silent calls.
- You want to provide a high level of customer service to the contacted parties.
- You want to supervise agents and calling activities rather than manually supervising the predictive dialing process.
- The number of agents on an outbound job is small or may change. The Cruise Control feature requires at least eight outbound agents to be logged into a job to function correctly.
- Agents perform other activities such as handing inbound calls during the job.

Cruise control automatically maintains the service level of outbound dialing during a job and connects the calls to agents within a specified period of time. During the job, you do not have to monitor or modify the call pacing settings.

When you set up an outbound job that uses Cruise Control, you must define the Desired service level and the Time to connect tolerance settings. The system uses these settings to do the following:

- Predict when to automatically dial phone numbers
Chapter 18: Jobs

- Distribute phone calls within the tolerable time period that you set

Once you start a job that uses Cruise Control, you do not have to change the settings. If you want to change the settings, you must stop the job. To resume calling activities with the new settings, restart the job.

**Expert Calling Ratio**

Use Expert Calling Ratio for any type of outbound job when the following objectives are important:

- Optimize the use of agents during the job.
- Manage and change call handling time during the job.
- Place as many calls as possible during the job.

Expert Calling Ratio allows you to change the way the system determines when to place the next call while a job is running.

When you set up an outbound job that uses Expert Calling Ratio, you select the following settings:

- The method that the system uses to monitor calling activities
- A value that sets the pace at which the system places phone calls

The Expert Calling Ratio method tells the dialer when to place calls based on one of the following values:

- The number of phone calls in the wait queue and the agents waiting for a phone call
- The total time agents spend handling the phone call and customer record
- The time agents spend updating customer records after releasing the phone line

Once you start a job that uses Expert Calling Ratio, you can change the settings in Monitor without stopping the job.

---

**Understanding job settings**

After double-clicking a job or selecting the **New** command, a tree structure appears on the **Job Detail** tab. Use this tree to modify your job settings. Click the fields located in the **Setting** column.

There are several settings that you define for each job. The settings on your system depends on your system configuration.

Job settings appear in the following groups:

- **Basic settings** on page 215
Basic settings

Basic settings are for every type of job: outbound, inbound, and blend.

The following settings are listed in the Basic group:

- **Job description** on page 215
- **Line type(s) for use on job** on page 216
- **Earliest start time** on page 216
- **Latest stop time** on page 216
- **Calling party number (ANI)** on page 216
- **Require unit ID for agent login** on page 216
- **Transaction completion code** on page 217

**Job description** - Select the field to enter a description of the job. For example, type a description that reflects the goal of the job such as 30-day Accounts.

**Percent completion of job to run record selection for linked job** - Select the percentage completion value of the current job after which the automatic record selection for the linked job will start. By default, the value for this field is set to zero, which implies that the automatic record selection for linked job is disabled. To use this functionality, you must have a linked job.
Note:
You can not use this functionality along with the unit work list job.

**Line type(s) for use on job** - Select the group of lines that the system uses for a job.

**Earliest start time** - Select the field to set the time that you want the system to start dialing customer phone numbers and receiving inbound calls. Enter numbers only. The system is preset with recommended start and stop times for different time zones. If you enter a time that is earlier than the recommended start time, the dialer does not dial phone numbers until the system clock reaches the recommended time.

**Latest stop time** - Select the field to set the time that you want the dialer to stop dialing customer phone numbers and receiving customer inbound calls. Enter numbers only.

**Calling party number (ANI)** - Identifies the party that placed the phone call. Displays the phone number of your contact center on the phone of the party that received the phone call.

**Calling party number (ANI) by record** - Identifies the party that placed the phone call to an individual or a group of records. Displays the value of the selected calling list field for which the value has already been mapped in the Calling list pane.

Note:
You can simultaneously configure both Calling party number(ANI) and Calling party number(ANI) by record fields, however, the value in Calling party number(ANI) by record will override the Calling party number(ANI) value for the applicable records. Also, you can set only the numeric values as ANI; alphabets and alphanumeric values are not supported. Note that ANI number must be a valid dialing number.

**Require unit ID for agent login** - Select the field to require an agent to select a single or multiple unit work lists when the agent logs in to Avaya Proactive Contact Agent.

If you select **Require unit ID for agent login** check box, the following message is displayed:

You are turning on unit work list feature. This requires to set "Percent completion of job to run record selection for linked job" to zero. Do you want to proceed?

Select **Yes** to continue with Unit Work List feature. The Editor automatically:

- Selects the **Require unit ID for agent login** check box.
- Sets the **Percent completion of job to run record selection for linked job** field to zero.
- Makes the **Percent completion of job to run record selection for linked job** field as non-editable.

Select **No** to continue with the automatic record selection for the linked job feature.

"If you clear the **Require unit ID for agent login** check box, the following message is displayed:
You are turning off unit work list feature. "Percent completion of job to run record selection for linked job" is now editable.

When you click OK, the Editor:

- Clears the Require unit ID for agent login check box.
- Makes the Percent completion of job to run record selection for linked job field editable.

**Transaction completion code** - Select the field to enter the call completion code to indicate the need to verify the transaction by the Sales Verification job.

---

**Call pacing settings**

Call pacing settings are for outbound and blend jobs.

**Note:**

The same job name on different dialers in a pod can use a different call pacing method. To ensure consistent monitoring and reporting, use the same settings for the same job name on each dialer. For more information, see **Call pacing** on page 212.

The following settings are listed in the **Call Pacing** group:

- **Call Pacing method** on page 217
- **Initial hit rate** on page 218
- **Minimum hit rate** on page 219
- **Cell Phone Campaign Call Progress** on page 219

**Call Pacing method**

Select Cruise Control or Expert Calling Ratio from the drop-down list and press the Enter key to set the call pacing method.

**⚠️ Important:**

If you select Cruise Control, you must set the **Desired service level** and **Time to connect tolerance** settings listed in the **Service Level** group. For more information, see **Service Level settings** on page 230.
Chapter 18: Jobs

The following table contains the settings for the Expert Calling Ratio method:

<table>
<thead>
<tr>
<th>Expert Calling Ratio Setting</th>
<th>Description and recommended setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calls in the wait queue</td>
<td>The system achieves a balance between agents waiting for a call and customers placed in the wait queue. This setting affects the customer wait times. Enter a percent value from 1 through 100. The recommended setting is from 4 through 31 to place fewer customers in the wait queue. A low setting can affect the time that agents wait between phone calls.</td>
</tr>
<tr>
<td>Agent Work Time</td>
<td>The system monitors the time agents take to complete calls and update records, and adjusts the calling pace accordingly. A higher number shortens the average agent idle time and increases the number of customers in the wait queue at any given time. Enter a higher number when update times are relatively short. Enter a percent value from 1 through 100. The recommended setting is from 29 through 71.</td>
</tr>
<tr>
<td>Agent Update Time</td>
<td>The system monitors the time agents take to update records and adjusts the calling pace accordingly. A higher number shortens the average agent idle time and increases the number of customers in the wait queue at any given time. Enter a higher number when update times are relatively short. Enter a percent value from 1 through 100. The recommended setting is from 32 through 78.</td>
</tr>
</tbody>
</table>

**Initial hit rate**

Select the field to enter the initial hit rate. Enter a number.

The initial hit rate determines the average number of calls per agent that the system makes during the first five minutes of the job. The initial hit rate is the number of call completions compared with call attempts.

For example, an initial hit rate of 50 means the system must make approximately two dialing attempts for each agent to get one successful connection, or 50%. When the system gathers statistics from actual call attempts, it readjusts the hit rate automatically to meet the minimum hit rate setting. If you set the rate too low, at 20 to 30, the dialer could make more connects than your agents can handle during the initial dialing period. If you set the rate too high, over 70, the system could fail to make enough connections to keep your agents busy.
Use the following table to adjust the initial hit rate according to the particular needs of the job:

<table>
<thead>
<tr>
<th>If you want to make</th>
<th>Set rate to</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Daytime home calls</td>
<td>30</td>
<td>3 calls per agent for 1 connection</td>
</tr>
<tr>
<td>Evening home calls</td>
<td>50</td>
<td>2 calls per agent for 1 connection</td>
</tr>
<tr>
<td>Weekend home calls</td>
<td>50</td>
<td>2 calls per agent for 1 connection</td>
</tr>
<tr>
<td>Daytime office calls</td>
<td>70</td>
<td>1 call per agent for 1 connection</td>
</tr>
</tbody>
</table>

**Minimum hit rate**

Select the field to set the minimum hit rate for the job. Enter a value from 1 through 100 in increments of 10. A typical setting is 30.

The system uses the minimum hit rate to determine the maximum number of calls to place in order to make an agent connection.

Use minimum hit rate to limit the number of lines a job can use. For example, a minimum hit rate of 30 means the system will make no more than three dialing attempts for each agent, or 30%. This prevents the system from allocating more pooled lines to a poorly performing job at the expense of a more successful job.

**Cell Phone Campaign Call Progress**

Select the field to define a duration for which the system analyses a call as live voice or a voice messages on a cell phone. This field corresponds to a value added to the Job that allows the supervisors to define the duration in the system for which the system should "listen" to the voice before determining if the call is a live voice or an answer machine. The value defined in this field gets translated into a duration predefined in the system.

You can enter a value between 0-4, where 0 denotes that the Enhanced Cell Phone Detection feature is turned off. A value of 1 is the longest duration for which the system analyses the voice, and 4 is the minimum duration set for the analysis.

**Note:**
Enhanced Cell Phone Detection feature should always be disabled in the UK. This is because settings 1-4 increases the chances of false positives and risks violation of OFCOM regulations.

You would require generic 18.0.2 on the PG230RM along with the appropriate changes for the outpulse rules for this feature to work.
Files settings

Files settings are for every type of job: outbound, inbound, and blend. The system displays the appropriate settings for the type of job.

The following settings are listed in the **Files** group:

- **Outbound calling list** on page 220
- **Inbound calling list** on page 220
- **Record selection file name** on page 220
- **Outbound screen(s)** on page 220
- **Inbound screen(s)** on page 220
- **Agent keys definition file name** on page 221
- **Do Not Call group name** on page 221
- **Name of next job** on page 221
- **Transfer to inbound job name** on page 221

**Outbound calling list** - Select a calling list name from the drop-down list. The calling list description, if any, appears to the right of the calling list name.

The job uses the outbound calling list to place calls to customers during outbound and blend jobs. The calling list name includes the host dialer name where the list is stored.

**Inbound calling list** - Select a calling list name from the drop-down list. The calling list description, if any, appears to the right of the calling list name.

The job uses the inbound calling list to identify the calls that customers placed during inbound and blend jobs. The calling list name includes the host dialer name where the list is stored.

**Record selection file name** - Select the name of the record selection from the drop-down list. The record selection defines which records the dialer uses to place phone calls during outbound and blend jobs. The record selection contains the phone strategy for the job.

**Outbound screen(s)** - Select one or more outbound screens from the window. This setting determines the outbound screens that agents see on their workstations and the order in which the screens display. Select outbound screens for outbound and blend jobs.

**Inbound screen(s)** - Select one or more inbound screens from the window. This setting determines the inbound screens that agents see on their workstations and the order in which the screens display. Select inbound screens for inbound and blend jobs.
Understanding job settings

**Agent keys definition file name** - Select the agent keys file name to use during a job from the drop-down list. An agent keys file is configured during installation. The file lists the sets of functions for keys used during types of jobs.

**Do Not Call group name** - Select the name of the Do Not Call group file from the drop-down list.

The system adds customer information to the file when a customer requests to be added to the Do Not Call List.

**Name of next job** - Select the field to select the next outbound or blend job to start from the drop-down list. The system automatically starts the job when the agent on the current job completes the last call and releases the record. The system displays a message telling the agents that they are changing jobs.

The following table describes the types of jobs that can link together:

<table>
<thead>
<tr>
<th>Job type</th>
<th>Can link to</th>
</tr>
</thead>
<tbody>
<tr>
<td>outbound job</td>
<td>Any job, except a virtual job</td>
</tr>
<tr>
<td>Managed Dialing job</td>
<td>Any job, except a virtual job</td>
</tr>
<tr>
<td>inbound job</td>
<td>Any job, except a virtual job</td>
</tr>
<tr>
<td>blend job</td>
<td>Any job, except a virtual job</td>
</tr>
<tr>
<td>virtual job</td>
<td>A virtual job</td>
</tr>
</tbody>
</table>

If you stop a job that is linked to another job, the system displays a confirmation prompt whether to shutdown the linked job, if there is any. If you choose not to shutdown the link job, then in addition, the following prompt is displayed:

Run record selection for link job if it has not been run automatically?

**Transfer to inbound job name** - Select the inbound job name from the drop-down list to identify the job name that agents can use to transfer calls during outbound and blend jobs.

---

**Job Type settings**

Job Type settings are for outbound, inbound, and blend jobs. Select the appropriate check box to identify the type of special job: Sales Verification or Virtual Agent.

**Transaction verification job** - Select the check box to identify that the outbound job is a Sales Verification job.
Run job without agents - Select the check box to identify that the outbound job is a Virtual Agent job. The system runs your job without agents. This field does not appear unless you select Virtual in the Editor Job Wizard when you create a new job.

**Note:**
If the strategy associated with the virtual job has a low value for the Number of Rings field, then the virtual job does not play a message to the answering machine. The recommended minimum value for the Number of Rings field is 3.

---

**Inbound Processing settings**

Inbound Processing settings are for inbound or blend jobs. The system displays the appropriate settings for the type of job.

The following settings are listed in the **Inbound Processing** group:

- **Activate inbound lines at login** on page 222
- **Service inbound calls immediately** on page 222
- **Move blend agents to inb after call** on page 222
- **Max time blend agent idle on inbound** on page 222
- **% calls in queue to inbound agents** on page 222
- **Maximum time call can spend in wait queue (seconds)** on page 222

**Activate inbound lines at login** - elect the check box to activate the inbound lines when agents log in to the inbound or blend job.

**Service inbound calls immediately** - Select the check box to handle the inbound calls immediately during the inbound or blend job.

**Move blend agents to inb after call** - Select the check box to have blend agents handle inbound calls after handling the outbound call during the blend job.

**Max time blend agent idle on inbound** - Select the field to enter the maximum number of seconds that the blend agent can be idle between inbound calls during the blend job. When the time exceeds the setting, the system moves the agent to handle outbound calls.

**% calls in queue to inbound agents** - Select the field to enter the upper percentage limit of the calls waiting to be passed to inbound agents during the inbound or blend job.

**Maximum time call can spend in wait queue (seconds)** - Select the field to enter the longest time in seconds that calls can be held in the wait queue during the inbound or blend job.
Labels settings

Files settings are for every type of job: outbound, inbound, and blend. The system displays the appropriate settings for the type of job.

⚠️ Important:

The changes you make to a script become available for use the next time you restart the system. You can set up a job with a new script but cannot run the job until you restart the system.

The following settings are listed in the Labels group:

- **Script label for call** on page 223
- **Script label for answer** on page 223
- **Main data processing label** on page 223
- **Transfer wait queue label** on page 224

**Script label for call** - Select the script label from the drop-down list. The script label is the name of the script used during the outbound job.

The message script is the message or string of messages customers hear. Jobs can use different wait queue messages.

**Script label for answer** - Select the script label from the drop-down list. The script label is the name of the script used during the inbound job.

The message script is the message or string of messages customers hear. Jobs can use different wait queue messages. Proactive Contact application requires all wait queue messages to be saved in the following format:

You can use Microsoft Sound Editor to save the voice message file. You should save it using the following format options:

- CCITT U-Law ("Mu-Law")
- 8K Sample (Hz)
- 8-bit
- Mono
- Save the file as <filename>.au in any convenient file directory.

To confirm if the audio file has not been saved in a *.wav format, you can open it up in notepad.

If you see WAVEfmt at the top of the file, the message will fail validation.

**Main data processing label** - Select the correct main data processing label from the drop-down list. The main data process label instructs the system to begin job processing and tells the system what to display on the agent screens.
Select the appropriate data process label for the job. Select **virtual** for a virtual job, **verify** for a sales verification job, and **generic** for an outbound job.

**Transfer wait queue label** - Select the correct transfer wait queue label from the drop-down list. The transfer queue label is the name of the transfer script used during the inbound or blend job.

---

**Managed Dialing settings**

During a managed job, an agent can preview a customer record before placing or cancelling the call.

Managed job settings are for outbound jobs.

The following settings are listed in the **Managed Dialing** group:

- **Managed (preview) dialing** on page 224
- **Allow agents to cancel call** on page 224
- **Time limit (seconds) for preview** on page 224
- **Display empty record at preview** on page 225
- **Allow dialing from deleted record** on page 225
- **Method for record search type at preview** on page 225
- **Key field for LIS record search** on page 225

**Managed (preview) dialing** - Select the check box to allow an agent to look at a customer record before the dialer places the phone call.

**Allow agents to cancel call** - When you enable **Managed preview dialing**, you can allow an agent to cancel a Managed Dialing call.

Select the check box to allow an agent to cancel the managed dialing call. Clear the check box to prevent agents from cancelling a managed dialing call.

**Time limit (seconds) for preview** - When you enable Managed preview dialing, you can set up the time limit during which an agent can preview a record before the system dials the number.

Select a number from 1 through 999, or select 0 (zero) to set an unlimited amount of preview time.

**Note:**

If you set the preview time to 0 (zero), then you must use "dial a managed call" option to call the customer.
Display empty record at preview - When you enable Managed preview dialing, you can allow an agent to create a new record during preview from an empty record. The agent then uses the record to place the phone call.

Select the check box to display an empty record during preview. Clear check box to prevent displaying an empty record during preview.

Allow dialing from deleted record - When you enable Managed preview dialing, you can allow an agent to use a record that was identified as not to use. When an agent removes or deletes a record, the record remains on the dialer. The agent can place a phone number from that record.

Select the check box to allow agents to use the record. Clear the check box to prevent dialing a record that was marked not to use.

Method for record search type at preview - When you enable Managed preview dialing, you can select one of the following options from the drop-down list:

<table>
<thead>
<tr>
<th>Method</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HASH</td>
<td>The search is done through the system QuickSearch method. The system searches the calling list until the matching record is found.</td>
</tr>
<tr>
<td>LIS</td>
<td>The system uses the List Indexed Sequential method to search for the customer record. The LIS method processes the calling list into a table that is indexed on a key field from the calling list. That key field is specified during configuration.</td>
</tr>
<tr>
<td>NONE</td>
<td>No search is allowed. The only way for the agent to make a call is to enter a phone number manually.</td>
</tr>
</tbody>
</table>

Key field for LIS record search - Select the field and enter the field name you want to use as the key field for the record search at preview.

Outbound Processing settings

Outbound Processing settings are for outbound and blend jobs.

The following settings are listed in the Outbound Processing group:

Shutdown job when no more calls remain - Select the check box if you want the system to end jobs when each customer has been called at least once.

Clear the check box if you want the system to end jobs after all calls are completed, including recalls.
Make alternative phone lowest priority in selecting next record - Select the field to place calls that are first attempts, retries, and recalls before placing a phone call that uses the alternative phone.

Order calling of records by time zone - Select the check box if you want the system to order calls by times zones. The dialer places phone calls “following the sun” from east to west. With either choice, time zone laws are still applied.

Opt-out settings

Note: These settings are available only for the virtual jobs. This group of settings will not be visible for any other type of job.

A virtual job plays a recorded message to the called party, after which the call is hung up. However, now the called party has an option to opt-out of this recorded message and connect to a live agent. This can be done by pressing a pre-designated digit during the message.

You can configure Opt-out on both hard dialer and Soft dialer; however, the configuration procedure for both are different. For details, refer to:

- Configuring opt-out on hard dialer on page 226
- Configuring Opt-out on Soft dialer on page 228

Configuring opt-out on hard dialer

Important:
Before configuring the Opt-out feature on the hard dialer, ensure that you have made the configuration modifications related to the Opt-out feature in Avaya PG230RM. For the procedure of configuring Opt-out on Avaya PG230RM, refer Administering Avaya Proactive Contact.

On a hard dialer, the call can either be:

- Routed to a specified Vector Directory Number (VDN)

Note:
Each call that is opted out to a VDN will consume one transfer trunk until the call is disconnected. Keep sufficient transfer trunks free during an operation of Opt-out virtual campaign. There should be more than or equal number of trunks than the lines used in the virtual job. The Opt-out job will not report a lack of transfer trunks until it reaches the transfer trunk limit.

- Converted to an inbound call on a specified Inbound/Blend job.

When you choose to route the call to a VDN, you must provide the VDN number. Once an opt-out has been triggered, the system connects the call to that VDN, after which the call is connected.
handled by the VDN as required. For example, it might put the call in a wait queue. The customer data is not passed along with the call.

When you choose the call to be sent to an Inbound/Blend job, the call is converted to an inbound call on the inbound/blend job. In this case, the customer data is passed along with the call depending on the NVDT configuration between the calling lists.

The completion codes associated with this feature are:

- OPTOUT (8) indicates that a call has been successfully opted out by the dialer to the configured destination.
- OPTOUTFAIL (10) indicates that an opt-out was requested by the called party, but the request could not be successfully carried out by the dialer. The reason for this failure is logged in the account log.

The following settings are listed in the Opt-Out Features group:

**Should "opt-outs" be enabled?** - Select this check box to enable the Opt-out feature.

**Opt-out Digit** - This field is visible only when you select the Should "opt-out" be enabled field. This is the digit (0 to 9) that the called customer must press in order to Opt-out of the call.

**When an Opt-out happens, transfer to** - This field is visible only when you select the Should "opt-out" be enabled field. Select the value for this field from the drop-down list. It specifies the action to be performed by the dialer when a customer "opts out" of a call. The options are Transfer to an inbound/blend job and Transfer to a VDN.

**Opt-out Job** - This field is enabled when you select the Transfer to an inbound/blend job option in the When an Opt-out happens, transfer to field. Select an inbound/blend job from the list provided. Calls that are opted out will be transferred to this inbound/blend job as an inbound call.

**Note:**
If you select the Inbound/blend option, then you must first synchronize the virtual job and Inbound/blend job calling list for Native Voice and Data Transfer. For the procedure, refer Native Voice and Data Transfer (NVDT) on page 131

**Opt-out VDN** - This field is enabled when you select the Transfer to a VDN option in the When an Opt-out happens, transfer to field. You must provide a valid VDN in this field. Calls that are opted out will be connected to this VDN.

**Message to be played when Opt-out fails** - This field is visible only when you select the Should "opt-out" be enabled field. Select the voice message to be played from the drop-down list. If an opt-out fails, this is the message that will be played to the customer before the call is hung up.
Configuring Opt-out on Soft dialer

⚠️ Important:
Before configuring the Opt-out feature on Soft dialer, ensure that you have made the configuration modifications related to the Opt-out feature in Communication Manager. For the procedure of configuring Opt-out on Communication Manager, refer Administering Avaya Proactive Contact.

To configure Opt-out feature on Soft dialer GUI:
1. Login to the Editor as sysadm or user having privileges to access Editor.
2. Go to Contact Management > Jobs.
3. Select the required virtual job for which you want to enable the opt-out feature.
4. Make note of the script as displayed in the Script label used for making calls field on the right pane. You can also create a new script specifically for Opt-out.
5. Go to Messages and Scripts > Scripts.
6. Select the script as noted in Step 4 and make a note of the corresponding message number displayed in the Script Actions pane.
7. Go to Messages and Scripts > Messages.
8. Right-click the message number as noted in Step 6, and select Change.
9. In the Where is the message stored? text box, enter the Opt-out VDN as configured on the Communication Manager.
10. Save the messages file. You can save the file in the Pending stage, which will take effect when the dialer is restarted.

The virtual calls are sent to the configured VDN where the call is further processed for the Opt-out feature.

Note:
The dialer cannot identify whether the call opt out happened on the Communication Manager. Therefore, the dialer does not report Opt-outs on the Soft dialer.

Post Processing settings

The following setting in the Post Processing group is for every type of job: outbound, inbound, and blend:

Automatically start Update mode on customer hang up - Select the check box to enable the setting. The system starts to record the time an agent takes to complete the after call work when the customer disconnects the phone call.
Understanding job settings

Quota Settings

The following settings in the Quota Settings group are for outbound or blend jobs.

**Quota setting (completion code, quota)** - Select the field in the drop-down list to select a completion code. Select a quota for the completion code. The system stops the job automatically when the number of completion codes reaches the quota.

**Quota settings file name** - Select the field to enter a name for the file that saves the quota settings.

**Save quota setting when the job ends** - Select this option to save the quota setting when the jobs ends. The system continues to use the quota setting the next time the job starts.

Recall settings

When an agent sets a recall on his name, it is called an agent owned recall.

If the agent leaves the job before the recall time but the job continues to run at the time of recall, in that case, when the time of recall is reached, the recall is converted to a general recall and is passed on to any available agent.

However, if the job is shut down before the time of recall, then at the time of recall, the system creates a shadow job for all the AORs in the job. These AORs are indexed in the shadowjob.lst file located in opt/avaya/pds/lists folder. The system automatically starts the job the next day or when the dialer services are restarted, and repeats it everyday until all AORs are processed.

The shadow job does not take the recall setting from the original job. By default, it takes the settings from master.cfg for the retry and other parameters. The recall interval for shadow job is decided by the RECALL_INTERVAL parameter in master.cfg file. The value for this parameter is defined in minutes. The parameter for number of retries for Jobs is RECALL_NUMOFTRY available in master.cfg file.

The shadow jobs for unresolved AORs continue for an infinite period of time.

The following settings in the Recall group are for outbound or blend jobs.

**Recall reschedule interval (minutes)** - If your system uses Agent Owned Recall, this field is visible. Select the field to enter the minimum number of minutes that must elapse before the system tries to pass the agent a recall.

**Recall notification time (minutes)** - If your system uses Agent Owned Recall, this field is visible. Select the field to enter the time in minutes during which the system looks for the agent who set up the recall on the job and is available for a call.
Chapter 18: Jobs

**Number of recall attempts** - If your system uses Agent Owned Recall, this field is visible. Select the field to enter the number of times to look for the agent that set up the recall. The value can range between 0 to 10. You must note the following before you set this value:

- If this value is set to 0, the system checks for the originating agent and if that agent is not currently on the Job, then the system does not forward the call.
- If this value is set from 1-10, the system checks for the originating agent and if that agent is not currently on the Job, the system changes the Agent Owned Recall to a General Recall (after the number of attempts has been reached) and gives the call to the next available agent.

In both the cases, if the originating agent is still on the Job, then the call goes to that agent.

**Escape General Recall**

**Note:**

This feature is applicable only for the infinite jobs because this feature requires the job to be running when the recall happens.

Earlier if there was no agent on a job, the daily recalls used to expire. As a result, to handle the recalls, at least one agent had to remain on the job even if there was no record to call. However, now the recall can happen even though there is no agent available on the job for which the recall has been set.

You can set the escape agent owned recall through Editor at the time of creating a job. At the same time, you can also define the job from which the agent should be pulled in to address the recall. As the time of recall comes, the system looks for the most appropriate agent who is free to handle the recall, and connects the recall to that agent. After completing the recall, the agent is sent back to the pool.

You can change the job from which the agent to be pulled in using Monitor at run-time.

You can turn on and turn off this feature at the job level in the Job Detail pane. By default, the recall escape feature remains OFF.

The following settings in the Recall group are to enable the Escape general recall functionality:

- **Auto assign recall from Infinite job to agents on another job** - Select the check box to enable the escape recall option.

- **Name of the job to get agent for recall** - Select the name of the job from the drop-down list from which the agent should be pulled in to attend to the recall.

---

**Service Level settings**

The following settings in the Service Level group are for outbound, inbound, and blend jobs.
Important:
If you select Cruise Control in the Call Pacing group, you must set the Desired service level and Time to connect tolerance settings. For more information, see Call pacing settings on page 217.

Avaya Proactive Contact uses the Desired Service Level and Time to connect tolerance settings for real-time monitoring and reporting of outbound, inbound, and blend jobs.

For jobs that use Cruise Control, Avaya Proactive Contact uses the Desired service level and Time to connect tolerance settings to predict when to automatically dial phone numbers and distribute the calls within the tolerable time period.

**Desired service level (percentage)** - The target percentage of serviced calls that you want the system to maintain.
Enter percent value that is from 70 through 99. The default value is 99.

**Time to connect tolerance (seconds)** - The number of seconds that you will allow a phone call to be delayed waiting for an agent before the system designates the call as a nuisance call. Typically you want to allow a minimum time delay before the system sends the phone call to an agent.
Enter a number from 0 (zero) through 9. The default value is 1.

---

**Wait Queues settings**

The following settings in the Wait Queues group are for outbound, inbound, and blend jobs. The system displays the appropriate settings for the job.

**Total wait delay (seconds)** - Select the field to enter the maximum number of seconds for which the customer can wait in the wait queue. You can select the value starting from 0 to 300. Note that if the wait queue handling is of shorter duration, then the call will be hung up irrespective of the value defined in this field.

**Inbound wait queue limit (seconds)** - Select the field to enter the number of seconds from 0 to 999 that the customer can wait in the inbound wait queue before the system ends the call.

**Transfer on hold message number** - Select the field to enter the number of the message that users hear during the call-transfer process.

---

**Interactive Voice Response settings**

The following settings in the Interactive Voice Response group are for outbound, inbound, and blend jobs.
Chapter 18: Jobs

**IVR identifier** - Select the field to enter the IVR identifier.

**Script to run on the IVR** - Select the field to enter the script that customers hear when they answer an IVR phone call.

**IVR agents** - Select the field to allow IVR agents to join the job

**IVR initial script** - Select the field to enter the script agents hear when joining an IVR job.

---

Using jobs

This section contains the following topics that help you create and use jobs:

- [Create a job](#) on page 232
- [View job settings](#) on page 233
- [Save a job](#) on page 233
- [Save a job as another name or on a different dialer](#) on page 233
- [Start a job on one or more dialers](#) on page 234
- [Start multiple jobs on currently selected dialer](#) on page 234
- [Share a List or a Job](#) on page 235

---

Create a job

In a pod, the same job name can exist on each dialer.

To ensure consistent monitoring and reporting, use the same settings for the same job name on each dialer. For more information, see [Outbound jobs](#) on page 210.

To create a job:

1. In the Editor button bar, select a dialer, and then click **Jobs**.
2. Select **File > New**.
3. Click **Next** when the **Editor Job Wizard** appears.
4. Select settings to specify the type of job you want to create, the appropriate outbound or inbound calling list, and the job options you want to use:
   - Sales Verification
   - Unit Work List
   - Virtual
● Managed

5. When you finish the wizard, the default tree structure for your job type (inbound, outbound, blend, and so on) appears in the right-hand pane.

6. Use the Setting and Value columns to select and edit values.

View job settings

To view job settings:

1. Select the job you want to view.
   The job settings appear in the right-hand pane.

Save a job

In a pod, the same job name can exist on each dialer.

To ensure consistent monitoring and reporting, use the same settings for the same job name on each dialer. For more information, see Outbound jobs on page 210.

To save a job:

1. Select File > Save to save the job.
   If needed, provide a name.

   **Note:**
   For English, you can enter a job name up to a maximum of 20 characters. In other languages, you can enter a job name up to a maximum of 15 characters. However, it is recommended that you keep the maximum number of characters for English language as 15 characters and the maximum number of characters for other languages as 8 characters.

2. Click OK.

Save a job as another name or on a different dialer

In Editor application to save a job as another name or on a different dialer:

1. Select the job you want to save.
Chapter 18: Jobs

2. Select File > Save As.

   If the multi-dialer option is enabled, select additional dialers to which you want to save the job.

   If the dialer check boxes are unavailable and you want to enable them, select Settings > Options. For more information, see Enable or disable multi-dialer commands on page 109.

3. Enter a name for your job, and then click OK.

   The job is saved to the dialer you selected in the button bar and it to any additional dialers you selected.

____________________________

Start a job on one or more dialers

You are not required to run a record selection before starting a job. Editor automatically executes the record selection if needed, and starts the job. If the job verification passes, you are offered a choice of starting the job or cancelling the action.

To start a job on one or more dialers:

1. Select the job you want to start.

2. Select File > Run.

   If the multi-dialer option is enabled, you are asked if you want to run the job on additional dialers. Select additional dialers on which you want to start the job.

3. Click OK.

   Note:
   Avaya Proactive Contact allows a maximum of 75 jobs to be running simultaneously. If the job that you want to start exceeds the system limit, then the job will not start and a message is displayed stating that the maximum concurrent job limit has been reached. In this case, to run the desired job, you must stop any other job running at that time. For more information on the calculation of jobs in the system, refer Maximum number of jobs allowed on page 211

____________________________

Start multiple jobs on currently selected dialer

To start multiple jobs on the currently selected dialer:

1. Select the jobs you want to start.

2. Select File > Run, and then click OK.
Share a List or a Job

There are two basic categories for what functionality List Sharing includes:

- Shared Calling List (commonly referred to as list sharing) and
- Shared Campaigns (commonly referred to as job sharing)

**Shared Calling List** - This feature provides you the ability for any dialer in a pod to use a calling list that physically resides on another dialer CPU's Hard Drive. This allows one Dialer Application Server to house a single calling list which 3 other dialer applications in the pod can access and use for calling in their own jobs.

Job sharing goes one step further and effectively allows all dialer applications in a pod to concurrently run the same job on the same call selection (This allows a much larger number of agents spread across multiple systems to call the same records). In actuality, each dialer will have it's own job, with a unique job number and a unique call selection index, but as long as all systems are calling on the campaign, the indexes will keep updating each other so that each system knows which records have already been called and will pick the next available record.

**Shared Campaigns** - This feature allows you to share a campaign across 2 or more dialer Applications in a POD.

This feature can only be used in the GUI (Graphical User Interface), CUI (Character User Interface) does not support this feature, nor will it be added in the future.

You must have "Multi-Dialer" option enabled in CD software. From the CE menu Settings ’ Options ’ Multi-Dialer tab. Click enable in "Multi-dialer settings" and then check the box for each system you wish to control in "Multi-dialer".

With Multi-dialer settings enabled, when a Proactive Contact Supervisor saves their Phone Strategy, Record Selection, and Job configurations, they will be prompted to save the changes to the file to one or more systems.

You will need to save any changes to all dialers which will be sharing the job to ensure that job files amongst the systems are the same. If any configurations in the strategy, selection, or jobs are mismatched in any way, the job sharing feature can result in displaying odd behavior.

When using Shared Campaigns the following configuration files must be the same on all Proactive Contact systems:

- locale.cfg
- timezone.cfg
- telephny.* scripts (telephny.spt, telephny.labels, telephny.alljobs.dat
- postupdate files (if used), there must be PU*.cfg files that specify the - of each remote list.
- ORDERBYZONES must be set to the same on all jobs, either YES or NO

**Note:**

If a single campaign is different than the others, the jobs will compete for records.
Office of Communication (OFCOM)

The Office of Communication (OFCOM) U.K. releases a statement of policy on the persistent misuse of an electronic communication network or service. This policy applies to predictive dialers that make calls in U.K. For details refer to:

http://www.ofcom.org.uk/consult/condocs/persistent_misuse/statement/

OFCOM specified changes in their "Revised statement of policy on the persistent misuse of an electronic communications network or service" on October 30, 2009.

The changes in this policy (applicable only to the United Kingdom) are as follows:

http://www.ofcom.org.uk/consult/condocs/persistent_misuse/amendment/amendment.pdf

Editor application has been updated to enable the new OFCOM policy.

This section provides information on the following:

- Create a script for OFCOM compliant jobs on page 236
- Enable OFCOM for a job on page 237

Create a script for OFCOM compliant jobs

As per section 4.16.2 of the OFCOM policy, an OFCOM compliant message should be created to be played. This message must be used in the OFCOM script.

To create a script for OFCOM compliant jobs:

1. Login to the Editor application.
2. Under Messages and Scripts, click Scripts.
   - The Scripts pane appears.
   - Editor opens Message Script Wizard.
4. In the Message Script Wizard, click Next.
5. In the Selecting when the script should run page, select Outbound.
6. Click Next.
7. In the Selecting how to handle calls answered by a person page, select Yes, and select Apply OFCOM rule on this script option.
8. Click Next.
9. In the Add an action page, under What do you want to do?, select Play a message.
10. Select the created **OFCOM message you want to play** from the *Select a message to play* box.

11. Click **Next**.

12. In the **Do you want to play a message automatically before passing call to agent or into wait queue** page, select **No**.

13. Click **Next**.

14. Name the script and type a brief description of the script.

15. Click **Next**, then click **Finish**. On the **Detail** tab on the right, the new script appears.

16. Click **Save**.

17. In the **Save as** window, select **Pending** stage.

The script will be available for use when the dialer is restarted.

---

**Enable OFCOM for a job**

**Note:**

You can enable OFCOM only on a blend or outbound job.

To enable OFCOM for a job:

1. Login to the Editor application.

2. Under **Contact Management**, select **Jobs**.

3. Select the **Job for which you want to enable OFCOM**.

4. In the **Job Details** pane, under **Job Type**, select **Run job with OFCOM**.

5. Under **Labels**, in the **Script label to use OFCOM**, select the OFCOM script.

6. Under **Service Level**, in the **OFCOM Timer**, provide a value for the OFCOM timer in seconds.

**Note:**

This value must be between 0.5 seconds and 9 seconds and can be specified to a tenth of a second. If a value less than 0.5 seconds is provided, then the default value of 2 seconds is used. If a value more than 9 seconds is provided, then the maximum value of 9 seconds is used.

7. Under **Job Type**, in the **Start Ofcom timer when**, select the event from which the OFCOM timer starts. There are two events available:

   - **Customer begins to speak**: When this is selected, the OFCOM timer will start from the start of voice energy that is when the customer begins to speak.
   - **Customer takes phone off-hook**: When this is selected, the OFCOM timer will start when the customer picks up the phone.
Note:
The OFCOM regulation states that you must save six-months-old detailed data in the database. The users who follow OFCOM regulation are recommended to set the ROLLNCLEAN parameter to 6 in the master.cfg file on the dialer.

Maintaining jobs

This section contains the following topics that help your maintain jobs:

- Copy a job on page 238
- Edit a job on page 238
- Verify a job on one or more dialers on page 239
- Verify multiple jobs on the currently selected dialer on page 239
- Delete a job on one or more dialers on page 239
- Delete multiple jobs on the currently selected dialer on page 239
- List all jobs on a selected dialer on page 240

Copy a job

To copy a job:

1. Select the job you want to copy.
2. Select File > Save As.
   - If the multi-dialer option is enabled, select the dialer where you want to copy a job.
3. Enter a name for the job, and then click OK.

Edit a job

To edit a job:

1. Select File > Open.
2. Select the job you want to edit, and then make the necessary edits in the right-hand pane.
3. Select File > Save to save the job.
   - If the multi-dialer option is enabled, select the additional dialers to save the job to.
4. Enter a name for the job, and then click OK.
Verify a job on one or more dialers

To verify a job on one or more dialers:

1. Select the job you want to verify.
2. Select File > Verify.
3. If the multi-dialer option is enabled, you are prompted to select whether or not to verify the job on additional dialers. Specify your preferences, and then click OK.
   The results of the verification, including any settings that are in error, appear in a separate window.
4. Review the results and click OK.

Verify multiple jobs on the currently selected dialer

To verify multiple jobs on the currently selected dialer:

1. Shift-click to select all the jobs you want to verify.
2. Select File > Verify.

Delete a job on one or more dialers

To delete a job on one or more dialers:

1. Select the job you want to delete.
2. Select File > Delete.
   If the multi-dialer option is enabled, you are prompted to specify whether or not to delete the job from additional dialers. Make your selections, and then click OK.
3. When prompted, click Yes to delete the job.

Delete multiple jobs on the currently selected dialer

To delete multiple jobs on the currently selected dialer:

1. Control-click to select the jobs you want to delete.
2. Select File > Delete.
   If the multi-dialer option is enabled, you are prompted to specify whether or not to delete the job from additional dialers. Make your selections, and then click OK.
3. When prompted, click Yes to delete the jobs.

---

**List all jobs on a selected dialer**

To list all jobs on a selected dialer:

1. Select the dialer name on the button bar.
2. Click Jobs. A list of jobs on the selected dialer appears.

---

**Understanding Editor system dialog boxes**

This section describes the dialog boxes you use in Editor.

This section contains the following topics:

- Options dialog box on page 240
- Screens dialog box on page 241

---

**Options dialog box**

The Options dialog box contains the following tabs:

- Options, Multi-dialer tab on page 240
- Options, Save tab on page 240
- Options, Refresh tab on page 241

**Options, Multi-dialer tab**

The Multi-dialer tab allows you to customize Editor’s interaction with your various dialers.

**Multi-dialer settings, Enable or disable multi-dialer commands** - Select Enable to enable multi-dialer commands. Select Disable to disable multi-dialer commands.

**Multi-dialer commands apply to** - From the list, select the dialer you want to use.

**Options, Save tab**

This Save tab allows you to customize how the Save command behaves.
When saving to an existing filename - Select **Prompt before overwrite** to receive a prompt before saving. Select **Overwrite without asking** to save without receiving a prompt.

### Options, Refresh tab

The **Refresh** tab allows you to specify your Refresh rate preferences.

**How often should data be refreshed on the screen** - Select the interval at which you want Editor to refresh.

---

### Screens dialog box

The **Screens** dialog box allows you to select screens to use during a job.

**Available screens** - Lists the agent screens defined for the system.

**Screens (in order)** - Lists the selected screens in the sequence that a job will use them.

**Selection buttons** - Move one or more selected screens between lists.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&gt;</td>
<td>Moves a selected screen in the <strong>Available screens</strong> list to the <strong>Screens (in order)</strong> list.</td>
</tr>
<tr>
<td>&gt;&gt;</td>
<td>Moves all the screens from the <strong>Available screens</strong> list to the <strong>Screens (in order)</strong> list.</td>
</tr>
<tr>
<td>&lt;</td>
<td>Moves a selected screen from the <strong>Screens (in order)</strong> list to the <strong>Available screens</strong> list.</td>
</tr>
<tr>
<td>&lt;&lt;</td>
<td>Moves all the screens from the <strong>Screens (in order)</strong> list to the <strong>Available screens</strong> list.</td>
</tr>
</tbody>
</table>

**Tip:**

You can also use the up and down arrow keys to change the order in which the screens appear.
Chapter 18: Jobs
Chapter 19: Schedule

The Schedule feature provides the flexibility to automatically schedule activities, create a new dialer activity, and view schedule reports.

Avaya Proactive Contact provides the ability to define and manage schedules.

Using Schedule

When you select Activities from the Schedule feature, calendar is displayed that lists all the scheduled activities. When you select the Activities icon on the Button Bar, the application requests a list of all the scheduled activities from the dialer and displays them in the Calender pane.

Individual activities are not saved as changes are made to activities, but the entire schedule is saved at once.

This section consists of the following topics:

- **Overview** on page 243
- **Restrictions for Scheduling** on page 244
- **Types of Dialer Activities** on page 245
- **Using Recurrence Pattern** on page 252
- **Schedule Reports** on page 253

Overview

You can create new activities and change or delete existing activities. You can create, delete, and modify some of the Active schedule activities directly without going through the pending stage. However, the `save as` command allows only the Pending and In-progress versions.

When you create an activity in Active version and save the schedule, changes are made in the Active version itself. You are not asked to save as Pending or In-progress. This functionality not only allows the creation of a new activity but also the modification and deletion of an existing activity directly in the Active stage. However, the system imposes restrictions on some types of activities. For more information on applicable restrictions, refer to **Restrictions for Scheduling** on page 244.

All the changes made in an Active schedule are overwritten by the Pending schedule, if any, during next system restart. This constitutes creation of new activities and deletion or
modification of existing activities. If you want to retain the changes made in the Active schedule, then make the desired changes in the Pending schedule also. Otherwise, the changes made will be lost after the system restart.

For example, if an activity is deleted directly from the Active schedule and a Pending version of that activity still exists, it will be displayed again after the system restart. If you do not want this, then remove the activity from Pending version also if it has been deleted from Active version.

Restrictions for Scheduling

To ensure that the system sanity is maintained, Editor does not allow scheduling activities that are critical to the system, such as maintenance and backup, directly in Active stage. As a result:

- The New activity wizard does not show the restricted item in the drop-down list.
- Remove and update functionality is disabled for the restricted items.

The restricted activities are supposed to be planned activities. If any change is made in Active schedule directly, there may not be time to revert any inadvertent changes. The following table provides information about the type of activity and the corresponding restrictions:

Table 1: Activity types and restrictions in Active schedule

<table>
<thead>
<tr>
<th>Activity Type</th>
<th>Restrictions in Active schedule</th>
</tr>
</thead>
<tbody>
<tr>
<td>Run a job</td>
<td>NO</td>
</tr>
<tr>
<td>Run a selection</td>
<td>NO</td>
</tr>
<tr>
<td>File Transfer</td>
<td>NO</td>
</tr>
<tr>
<td>Campaign Update</td>
<td>NO</td>
</tr>
<tr>
<td>Custom script</td>
<td>NO</td>
</tr>
<tr>
<td>Backup calling list for latelist</td>
<td>NO</td>
</tr>
<tr>
<td>Restart Proactive Contact</td>
<td>YES</td>
</tr>
<tr>
<td></td>
<td>You cannot create, modify, or delete.</td>
</tr>
<tr>
<td>Proactive Contact maintenance</td>
<td>YES</td>
</tr>
<tr>
<td></td>
<td>You cannot create, modify, or delete.</td>
</tr>
<tr>
<td>MTS maintenance</td>
<td>YES</td>
</tr>
<tr>
<td></td>
<td>You cannot create, modify, or delete.</td>
</tr>
<tr>
<td>DB maintenance</td>
<td>YES</td>
</tr>
<tr>
<td></td>
<td>You cannot create, modify, or delete.</td>
</tr>
<tr>
<td>Backup</td>
<td>YES</td>
</tr>
<tr>
<td></td>
<td>You cannot create, modify, or delete.</td>
</tr>
</tbody>
</table>
Using Schedule

Note:
The system does not allow you to delete or modify the restricted activities in Active version and such activities are highlighted in red color.

Types of Dialer Activities

You use the New Schedule Activity Wizard to schedule the dialer activities such as Backup, Backup calling list for late list, Campaign Update, Custom Script, File Transfer, MTS Maintenance, Proactive Contact Maintenance, Run a Job, Run a Selection, DB Maintenance, and Restart Proactive Contact. The activity details of the new activity are stored as part of the crontab command entry.

You can also perform the following functions:

● You can take a Full Backup or an Incremental Backup. Full and Incremental Backup includes the complete system including OS, Avaya Proactive Contact Configuration files and calling lists, Avaya Proactive Contact system only, and Avaya Proactive Contact System configuration files.

● You can backup the data using DVD/Tape.

● You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly in conjunction with the Hourly recurrence option. For more information on recurrence pattern, refer to Using Recurrence Pattern on page 252.

This section contains the following:

● Schedule a Backup Activity Type on page 246
● Schedule a Backup calling list for latelist on page 246
● Schedule a Campaign Update on page 247
● Schedule a Custom Script on page 248
● Schedule a File Transfer on page 248
● Schedule MTS Maintenance on page 249
● Schedule Proactive Contact Maintenance on page 249
● Schedule Run a Selection on page 250
● Schedule Run a Job on page 250
● Database maintenance as a scheduled activity on page 251
● Schedule Restart Proactive Contact on page 251
● Using Recurrence Pattern on page 252
● Hourly repetition in Schedule Activity wizard on page 252
Chapter 19: Schedule

Schedule a Backup Activity Type

You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly.

To create a new Backup Activity type:
1. In the Schedule button bar, select New.
   The Schedule Activity wizard appears.
2. Click Next.
3. Select Backup as the activity type.
4. Enter a brief Description for the backup.
5. Select the Type of backup.
6. Select the Device for backup. The options are: DVD or DDS.
7. Click Next.
8. Select the Start Date and Time on the Recurrence page of the wizard to schedule the new activity.
9. Select the Recurrence pattern.
10. Click Next.
11. Click Finish.

The new Backup activity that you scheduled appears in the Scheduled list of activities.

Schedule a Backup calling list for latelist

Latelist allows to migrate data from the previous day’s calling list to the current day’s calling list. The Backup calling list for latelist activity type allows you to backup your latelist. To save on idle time during the time of dialer maintenance, it is advisable that you schedule a backup calling list for latelist.

The backup is taken using the database manager script. You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly.

To create a new Backup calling list for latelist activity type:
1. In the Schedule button bar, select New.
   The New Dialer Activity Wizard appears.
2. Click Next.
3. Select Backup calling list for latelist as the activity type.
4. Enter a brief Description for the backup.
5. Select the Recurrence pattern.
6. Click Next.
7. Click **Finish**.

The new Backup calling list for latelist activity that you scheduled appears in the Scheduled list of activities.

**Schedule a Campaign Update**

The Campaign Update activity type allows you to schedule a campaign update feature for a calling list. To use this feature you must enable the Campaign Update by selecting the Campaign Update option available in the Features tab, under Calling List. You can select any of the following update modes:

- Batch
- Both (Batch and Real Time)

**Note:**
You cannot schedule a real time campaign update.

Batch campaign update allows you to periodically send updates to a calling list throughout the day to mark the records that should no longer be called. The batch campaign update uses the `rec_update` binary to mark the calling list records as non-callable.

**Note:**
You should never run the Batch campaign update process for more than fifteen minutes. For large lists, the time interval needs to be even longer. This feature is only supported for calling lists in active or pending versions.

You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly.

To schedule a new Campaign Update:

1. In the Schedule button bar, select **New**.
   
The New Dialer Activity Wizard appears.
2. Click **Next**.
3. Select **Campaign Update** as the activity type.
4. Enter a brief **Description** for the campaign update.
5. Select the **Calling List**.
6. Select the Recurrence pattern.
7. Click **Next**.
8. Click **Finish**.

The new Campaign Update activity that you scheduled appears in the Scheduled list of activities.
Schedule a Custom Script

The Custom Script activity type allows you to create a script and define arguments for the script. You can define your own specific scripts that you would like to be scheduled. You must place the scripts in the customs directory.

You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly.

To schedule a new Custom Script:

1. In the Schedule button bar, select New.
   The New Dialer Activity Wizard appears.
2. Click Next.
3. Select Custom Script as the activity type.
4. Enter a brief Description for the custom script.
5. Select the Script Name.
6. Select the Argument checkbox if you have defined arguments.
7. Click Next.
8. Select the Recurrence pattern.
9. Click Next.
10. Click Finish.
   The new Custom Script activity that you scheduled appears in the Scheduled list of activities.

Schedule a File Transfer

The File Transfer activity type allows you to download calling list data from a host system to a dialer and upload the results of calling from a dialer to the host system. You can schedule the date and time for the new activity and set a recurrence pattern for None, Hourly, Daily, Weekly, Monthly, and Yearly backup.

To schedule a File Transfer:

1. In the Schedule button bar, select New.
   The New Dialer Activity Wizard appears.
2. Click Next.
3. Select File Transfer as the activity type.
4. Enter a brief Description for the backup.
5. Select the **Download** option if you want to download the calling list data to the dialer or select the **Upload** option if you want to upload the results of calling from the dialer to the host system.

6. Select the **Calling List**.

7. Click **Next**.

8. Select the Recurrence pattern.

9. Click **Next**.

10. Click **Finish**.

### Schedule MTS Maintenance

The MTS maintenance activity type allows you to schedule the date, time, and the recurrence pattern for MidTier Maintenance. The MTS Maintenance script performs the following functions:

- Starts MTS
- Clears all the data
- Stop MTS

You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly.

To schedule a MTS Maintenance:

1. In the Schedule button bar, select **New**.
   
   The New Dialer Activity Wizard appears.

2. Click **Next**.

3. Select **MTS Maintenance** as the activity type.

4. Enter a brief **Description** for MTS Maintenance.

5. Click **Next**.

6. Select the Recurrence pattern.

7. Click **Next**.

8. Click **Finish**.

### Schedule Proactive Contact Maintenance

The Proactive Contact maintenance activity type allows you to schedule the date, time, and the recurrence pattern for Proactive Contact Maintenance.

You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly.
To schedule a Proactive Contact Maintenance:

1. In the Schedule button bar, select **New**.
   The New Dialer Activity Wizard appears.
2. Click **Next**.
3. Select **Proactive Contact Maintenance** as the activity type.
4. Enter a brief **Description** for Proactive Contact Maintenance.
5. Click **Next**.
6. Select the Recurrence pattern.
7. Click **Next**.
8. Click **Finish**.

**Schedule Run a Selection**

The Run a Selection activity type allows you to schedule running a selection by selecting a selection. You must also select the calling list that you want to run on the selection.

You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly.

To schedule a Run a selection:

1. In the Schedule button bar, select **New**.
   The New Dialer Activity Wizard appears.
2. Click **Next**.
3. Select **Run a Selection** as the activity type.
4. Enter a brief **Description** for Running a Selection.
5. Select the type of Strategy.
6. Select a **Calling List**.
7. Click **Next**.
8. Select the Recurrence pattern.
9. Click **Next**.
10. Click **Finish**.

**Schedule Run a Job**

The Run a Job activity type allows you to select the job type that you require to be scheduled. The available job types for selection are blend, inbound, managed, outbound, verify, and virtual.

You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly.
To schedule a Run a Job:
1. In the Schedule button bar, select **New**.
   The New Dialer Activity Wizard appears.
2. Click **Next**.
3. Select **Run a Job** as the activity type.
4. Enter a brief **Description** for Running a Job.
5. Select the type of Job.
6. Click **Next**.
7. Select the Recurrence pattern.
8. Click **Next**.
9. Click **Finish**.

**Database maintenance as a scheduled activity**

You can schedule Database Maintenance also from the Editor. You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly.

To set Database maintenance as a scheduled activity:
1. Log in to the Editor application.
2. Go to the **Schedule** tab. Select **Activities**.
3. Click **New**.
4. Follow the instruction on the Schedule wizard.
5. Select the Dialer activity type as ‘**DB Maintenance**’.
6. Select **recurrence type**, **Start Time**, **End Time**, and **Duration** at which you want to run the schedule.
7. Save the schedule.

**Schedule Restart Proactive Contact**

The Restart Proactive Contact activity type allows you to schedule when you would like to restart Proactive Contact.

You can schedule the date and time to schedule a restart of Proactive Contact and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly.

To schedule a Restart of Proactive Contact:
1. In the Schedule button bar, select **New**.
   The New Dialer Activity Wizard appears.
2. Click Next.
3. Select Restart Proactive Contact as the activity type.
4. Enter a brief Description for Running a Job.
5. Click Next.
6. Select the Recurrence pattern.
7. Click Next.
8. Click Finish.

Using Recurrence Pattern

Recurrence pattern represents a set of controls that help you to schedule an activity to occur repeatedly at set intervals. You can choose between None, Daily, Weekly, Monthly, and Yearly. Depending on the type of pattern you choose, one or more additional controls appear.

- None: This activity runs once every year from the date of the scheduled activity. If you select the default selection, None, no additional controls appear and the Start Time (date) control is enabled
- Daily: This activity runs daily from the date of the scheduled activity. If you select Daily recurrence, additional controls let you choose between repeating the activity every n number of days, repeating the activity on every weekday, and repeating the activity every weekend day.
- Weekly: This activity runs weekly from the date of the scheduled activity. If you select the Weekly pattern, you can choose to repeat the activity every week on specific days.
- Monthly: This activity runs monthly from the date of the scheduled activity. If you select the Monthly pattern, you can choose to repeat the activity on the nth day of every month.
- Yearly: This activity runs yearly from the date of the scheduled activity. If you select the Yearly pattern, you can choose to repeat the activity on a specific month and day every year.

Hourly repetition in Schedule Activity wizard

In conjunction to the recurrence types, you can choose Hourly Repetition option to run an activity at repeated hourly interval from the date of the scheduled activity.

Specifying the hourly repetition option in combination with another type of recurrence makes the activity to run at every 'Duration' interval between 'Start time' and 'End time' on day(s) determined by the recurrence in combination.

If you choose 'None', then you can use the date control to specify the date of the hourly repetition.
Note:
Hourly repetition always begins from 00:00:00 hours. Also, you cannot provide
non-absolute start time/end time while scheduling a hourly recurring pattern.

To select hourly repetition option with any of the recurrence types:
1. Login to the Editor application.
2. Go to the Schedule tab. Select Activities.
3. Click New.
4. Go through the Schedule wizard.
5. Select the Hourly Repetition check box.
6. Select Start Time, End Time, and Duration at which you want to run the schedule.
7. Select the Recurrence pattern.
8. Save the schedule.

Schedule Reports

The Schedule Reports screen displays a list of all the available reports related to active
schedules. When you select the Report item in the Button Bar’s Schedules button group, the
application displays a list of available reports in the Feature pane.

You can view the full report by selecting a report in the Feature pane. The report appears to the
right in the Feature Detail pane.
Chapter 20: Using Campaign Template

This section provides overview of the Campaign Template, Campaign Template Environment, Creating a Campaign Template, User preferences in Template such as installation and details related to Errors and Messages:

- **Overview** on page 255
- **Campaign Template Environment** on page 255
- **Create a Campaign Template** on page 258
- **Campaign Template Installation** on page 260
- **Reports in Campaign Template** on page 263
- **Errors Messages** on page 264

---

**Overview**

Campaign Template provides various features which enhances efficiency and effectiveness for any contact center.

With the introduction of Campaign Template you can plan and set up any campaigns that would be run in future.

Campaign Template helps you to respond rapidly to a new campaign request. This feature helps you in creating and deploying a wide range of campaigns quickly and smoothly.

Campaign Template configurations are managed in the Editor application.

---

**Campaign Template Environment**

This section contains the toolbar, and three panes in the Campaign Template Environment, which provide various information about campaign template:

- **How to access Campaign Template** on page 256
- **Toolbar** on page 256
- **Left Pane** on page 257
- **Center Pane** on page 258
- **Right Pane** on page 258
Chapter 20: Using Campaign Template

How to access Campaign Template

There are various ways to access or create a Campaign Template.

Follow these steps to access a Campaign Template:

1. Click Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor.
2. Login as sysadm or user having privileges to access Campaign Template to launch the Editor and access the Campaign Template.
3. Once logged in, you must change your password if you are a new user.
4. Re-login with your new password.
5. Click Campaign Template in the left button bar of the Editor application to display Campaign Template list in the center pane.
6. You can also access Campaign Template from the View Menu > Campaign Template.

Toolbar

The following table contains information about the Campaign Template buttons and their description.

<table>
<thead>
<tr>
<th>Name</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>![icon]</td>
<td>Create a new Campaign Template.</td>
</tr>
<tr>
<td>Open</td>
<td>![icon]</td>
<td>Open an existing Campaign Template.</td>
</tr>
<tr>
<td>Save</td>
<td>![icon]</td>
<td>Save a Campaign Template.</td>
</tr>
<tr>
<td>Delete</td>
<td>![icon]</td>
<td>Delete a campaign template.</td>
</tr>
<tr>
<td>Help</td>
<td>![icon]</td>
<td>Display online help.</td>
</tr>
</tbody>
</table>
### Left Pane

This pane is the left pane which contains buttons like:

- **Contact Management**: Contact Management is the feature which manages Strategies, Selections, Selection Reports, and Jobs of various campaigns.

- **Messages and Scripts**: Messages and Scripts is the feature which allows to play recorded messages to customers when they are on hold, inbound, outbound, and transfer wait queues.

- **Calling Lists**: Calling list is a feature which provides Calling List information, Do Not Call Groups and Reports.

- **Agent Keys**: Agent Keys is the feature that allows releasing a call, transferring a call, displaying an agent screen and logging an agent in a campaign.

- **Schedule**: Schedule is the activity which help to schedule the dialer activities such as Backup, Backup MidTier, Backup Calling List for Late List, Custom Script, File Transfer, MTS Maintenance, Proactive Contact maintenance, run a Job, Run a Selection, and Restart Proactive Contact.

---

<table>
<thead>
<tr>
<th>Name</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search</td>
<td></td>
<td>Search option. Search is based on: All, Template, List, Strategy, Selection, Job, Agent key and Screen.</td>
</tr>
<tr>
<td>Install</td>
<td></td>
<td>Install a campaign template to run.</td>
</tr>
<tr>
<td>Download</td>
<td></td>
<td>Download a campaign template.</td>
</tr>
<tr>
<td>Upload</td>
<td></td>
<td>Upload a campaign template.</td>
</tr>
</tbody>
</table>

**Note:**

You can also right-click in the center pane of the Campaign Template and access the following options **New, Verify, Install, Download, Upload, and Delete**.

**Note:**

Search option in the Campaign Template does not support the regular expressions in the search. To improve the search performance select a particular "Search In" criteria to restrict the search operation. For example, if you want to search the job name say "outbnd" then on search dialog select "Job" as "Search In" criteria instead of "All".
Chapter 20: Using Campaign Template

- **Completion Codes**: Completion Codes is the feature which helps an agent to complete a phone call representing the types of outcomes like: Closures, Abandons, and Recalls.

- **Campaign Template**: Campaign Template is the feature which provides you to create any campaigns and install that campaign at any give time to run a campaign.

Campaign Template has following two options:

- **Template**: Provides various feature of Campaign Template like view a Campaign in the list.

- **Reports**: Provides reports related to any Campaign Template.

**Center Pane**

This pane is the center pane in the Campaign Template environment and named as **Campaign Template** which contains options like:

- **Template**: This feature displays the name of the campaigns in the first column of the center pane.

- **Description**: This feature is the second column in the center pane which provides the description of a particular campaign.

- **List**: This feature is the third column in the center pane which provides the information about the list of a particular campaign, like inbound and outbound.

- **List Description**: This feature is the fourth column in the center pane which provides the information about the campaign like Collections, Verify, Sales and Inbound.

- **Creation Date**: This feature is the last column in the center pane which provides the date of creation for any campaign available in the list.

**Right Pane**

This pane is the right pane in the Campaign Template environment, and contains more descriptive details about the template content. This pane is named as **Template Content**. Following is a brief description of the views available in the template:

- **Tree View**: Provides tree structure view of the template content with nodes named as Strategy, Selection, Job, Agent Key, and Screen.

- **Grid View**: Provides grid structure view of the template content with various details as Strategy, Selection, Job, Agent Key, and Screen

---

**Create a Campaign Template**
Create a Campaign Template

The various scenarios to create a Campaign Template using Campaign Template Wizard are explained in the following sections:

- Create a new Campaign Template on page 259
- Steps to access a Campaign Template Wizard on page 260
- Install Campaign Template on page 261
- Download a Campaign Template on page 262
- Upload a Campaign Template on page 262

---

Create a new Campaign Template

Scenario 1

Follow these steps to create a new Campaign Template:

1. Login to the Editor as sysadm or user having privileges to access Campaign Template.
2. Click the New button from the toolbar to create a new Campaign Template.
3. Click Next in the Campaign Template Wizard.
4. Enter any name and brief description of the new campaign template that you will create, and click Next.
5. Enter type of Lists in Campaign Template Wizard and click Next.
6. Verify the contents in the Campaign Template created using Campaign Template Wizard:
   - Template Name
   - Description
   - List
   - List Description
7. Click Next and then Click Finish.

There are other various steps to create a Campaign Template. You can also create a Campaign Template by using following steps:

Scenario 2:

1. Login to the Editor as sysadm or user having privileges to access Campaign Template and click File > New.
2. Follow the same steps from Step 3 mentioned in the Scenario 1.

Scenario 3:

1. Login to the Editor as sysadm or user having privileges to access Campaign Template.
2. Follow the process to create a new Campaign Template from starting from Step 3 in Scenario 1.

Scenario 4:
1. Login to the Editor as sysadm or user having privileges to access Campaign Template.
2. Click the Campaign Template button, or click the Template button in the left pane.
3. Right-click and select New.
4. Follow the same steps to create a Campaign Template using Wizard starting from Step 3 in Scenario 1.

Scenario 5:
1. Login to the Editor as sysadm or user having privileges to access Campaign Template.
2. Click Calling List button in the left pane and then click the Calling List option to show available calling list.
3. Right-click the Calling List pane and select New.
   
   Note: This step can be performed only when Calling List is in Active status.
4. Follow the same steps to create a Campaign Template using Wizard as mentioned in Step 3 in Scenario 1.

---

Campaign Template Installation

This section provides information about steps to access Campaign Template Wizard for installation and process to install a campaign template using Campaign Template Wizard.

- Steps to access a Campaign Template Wizard on page 260
- Install Campaign Template on page 261
- Download a Campaign Template on page 262
- Upload a Campaign Template on page 262

---

Steps to access a Campaign Template Wizard

Process 1
1. Login to the Editor.
2. Click the Campaign Template button.
3. Select and right-click in the Campaign Template, and click **Install** on install option.

4. **Campaign Template Wizard** opens.

**Process 2**

1. Login to the Editor.
2. Click the Campaign Template button.
3. Click the **Install** button to open **Campaign Template Wizard**.

**Process 3**

1. Login to the Editor.
2. On the menu bar, click **File** and then click **Install** from the menu to open a **Campaign Template Wizard**.

---

**Install Campaign Template**

Follow the steps to install a Campaign Template:

1. Login to the Editor.
2. Click the **Install** button on the toolbar.
3. Click **Next** in the **Campaign Template Wizard**.
4. Select any one Campaign Template from the following options:
   - Use original file names as in template.
   - Append suffix to all template files.
   - Append prefix to all template files.
5. If you select the last two options, please provide any suffix or prefix and click **Next**.
   
   **Note:**
   This field only accepts "_" (underscore sign).
6. Select the list from the **Campaign Template Wizard** drop-down menu and click **Next**.
7. Review the campaign template information in the **Campaign Template Wizard** and click **Next**. Verify the conflicts with the template files in the installation result.
8. Click **Finish**.

**⚠️ Important:**
Once you have installed the Campaign Template verify the following in the Contact Management tab:

1. **Calling list** application is installed on the dialer in pending stage.
Chapter 20: Using Campaign Template

2. **Agent Keys** are installed in pending stage.

3. **Jobs** in pending stage

4. Call **Selections** and **Strategies** in pending stage.

**Note:**
Calling list, Agent Keys, Jobs, Selections, and Strategies will show in pending status until the dialer is not restarted.

⚠️ **Important:**
Dialer should always be restarted as per the maintenance schedule to activate the campaign.

---

**Download a Campaign Template**

Follow the steps to download a Campaign Template:

1. Login to the Editor.
2. Click the **Campaign Template** button.
3. Click the download button in the toolbar to download the campaign template.
4. Save the campaign template.

**Note:**
By default campaign template is saved in ".tar" file format in **C:\Documents and Setting\Administrator\Application Data\Avaya Proactive Contact Supervisor\Editor** folder.

---

**Upload a Campaign Template**

Follow the steps to upload a Campaign Template:

1. Login to the **Editor**.
2. Click the **Campaign Template** button.
3. Click the upload button in the toolbar to upload a campaign template.
4. Browse to the required location and select the template.
5. Click **Open**.
Important:
If blend job is part of the Campaign Template, the calling list other than the
Campaign Template created should not be included in the template. Take backup
of other calling list (outbound/inbound) to avoid creating the calling list used with
the blend job.

Reports in Campaign Template

Reports can be generated in the Campaign Template based on Strategy, Selection, Job, and
Agent Key.

There are two types or reports in the Campaign Template:

- List Assignment Report: Provides report with all campaign templates and lists.
- Template Contents Report: Provides report with all campaign templates with contents.

Follow the steps to access Reports:

1. Login to the Editor.
2. Click the Campaign Template button.
3. Click Reports button in the left pane of the campaign template.
4. Click any Report listed in the center pane to open the Template Content Reports in the
   right pane.
5. Click any one of the following to verify the campaign template:
   - Template
   - List
   - Strategy
   - Selection
   - Job
   - Agent Key
   - Screen
6. To save a report click File > Save as HTML.

Note:
Reports can be viewed in Campaign Template in the Grid view only. You can
view the saved HTML report in Internet Explorer.
**Errors Messages**

The following table provides the description of common messages that appear during the use of Campaign Template:

<table>
<thead>
<tr>
<th>Message</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Please enter template name</td>
<td>This message appears when a user does not enter the template name in the Create Template Wizard.</td>
</tr>
<tr>
<td>Please enter prefix/ suffix</td>
<td>This message appears when a user does not enter the prefix or suffix in the Create Template Wizard.</td>
</tr>
<tr>
<td>Please select list</td>
<td>This message appears when a user does not enter the list name in the Create Template Wizard.</td>
</tr>
<tr>
<td>Please enter new name for the selected file</td>
<td>This message appears when a user enters invalid name or null value for any template file in the install wizard.</td>
</tr>
<tr>
<td>There are some files on the system that conflict with the template files</td>
<td>This message appears when the template files name conflicts with the files already present on the dialer during template installation.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Overwrite the file or change the file name to avoid this message.</td>
</tr>
<tr>
<td>Campaign Template Installation Completed</td>
<td>This message appears after a successful installation of a template.</td>
</tr>
<tr>
<td>The Campaign Template Wizard is open. Do you want to close it now?</td>
<td>This message appears when the template wizard (<em>create</em> or <em>install</em>) is open and the user wants to switch to other component.</td>
</tr>
<tr>
<td>Load Templates Failed</td>
<td>This message appears when there is an error in loading the templates in the <strong>Grid</strong>.</td>
</tr>
<tr>
<td>cannot save as active, one or more depend on files are not active</td>
<td>This message appears when dependent files are not in active stage while saving as active.</td>
</tr>
<tr>
<td>File already exists</td>
<td>This message appears when a template file already exists on the dialer.</td>
</tr>
<tr>
<td>File is protected</td>
<td>This message appears when any Calling List is protected.</td>
</tr>
<tr>
<td>Active version of file is protected</td>
<td>This message appears when any Calling List (active version) is protected.</td>
</tr>
<tr>
<td><strong>Tbl</strong> file is inconsistency</td>
<td>Template <strong>tbl</strong> file is inconsistent.</td>
</tr>
<tr>
<td>Invalid file name</td>
<td>This message appears when a template file name is invalid.</td>
</tr>
<tr>
<td>Message</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Could not transfer template file</td>
<td>This message appears when a tar file in a template is not uploaded or downloaded (sftp error).</td>
</tr>
<tr>
<td>Download is successful</td>
<td>This message appears when a template is downloaded successfully.</td>
</tr>
<tr>
<td>Upload is successful</td>
<td>This message appears when a template is uploaded successfully.</td>
</tr>
<tr>
<td>Download is failed</td>
<td>This message appears when a template download fails.</td>
</tr>
<tr>
<td>Upload is failed</td>
<td>This message appears when a template upload fails.</td>
</tr>
<tr>
<td>Search data not found</td>
<td>This message appears when the data is not found in search operation.</td>
</tr>
<tr>
<td>There are no Strategies, Selections, Agent Keys, jobs and Screens in this template</td>
<td>This message appears when a template does not have any file (except list).</td>
</tr>
</tbody>
</table>
Chapter 21: Using Agent Job List

This section provides overview of using Agent Job List pane for creating, modifying, and deleting agents job lists:

- **Overview** on page 267
- **Working with Agent Job List** on page 267
- **View Agent Job List Reports** on page 269

**Overview**

When an agent joins a job using Avaya Proactive Contact Agent application or a client application that is developed using Agent API, all the running jobs that are included in the joblist of the agent, if there is any, are displayed. Earlier, all the available running jobs were displayed to the agents.

Using Agent Job List pane, you can:

- Map agents to jobs.
- Modify the mapping between agents and jobs.
- View basic reports related to jobs assignment to agent.

There are no active, pending, in-progress, or deleted stages for Agent Joblists. However, you can view a union of active and pending jobs to add them to any agent's joblist. This provides added flexibility to list "going to be active" jobs for an agent.

**Working with Agent Job List**

This section provides information on the tasks you can perform using the Agent Job List pane.

- **Create an agent job list** on page 268
- **Delete an agent job list** on page 268
- **Add a job to an agent job list** on page 268
- **Delete a job from an agent job list** on page 269
Create an agent job list

To create an agent job list:

1. Login to the Editor as administrator or user having privileges to access Agent Job List.
2. Click **Agent Job List** on the left pane.
3. Click **File > New**. The **Agent Job List** wizard is displayed.
4. Click **Next**. The next page displays a list of all the agents and all the active and pending jobs.
5. Assign agents to the jobs by selecting the required check boxes. For example, select the check box for an agent and then select the corresponding check boxes for the jobs to which you want to assign this agent.

   **Note:**
   You can map an agent to a maximum of 80 jobs.
6. Click **Next**. The review Information page appears that enables you to review your selection. To make any modification, click **Back**.
7. Click **Finish**. The mapping between agent and jobs appear in the **Agent Job List** pane.

Delete an agent job list

To delete an agent job list:

1. Login to the Editor as administrator or user having privileges to access Agent Job List.
2. Click **Agent Job List** on the left pane.
3. In the **Agent Job List** pane, select the required agent job list, right-click and select **Delete**.
4. In the **Delete** dialog box, a confirmation message is displayed. Click **OK**.

Add a job to an agent job list

To add a job to an agent job list:

1. Login to the Editor as administrator or user having privileges to access Agent Job List.
2. Click **Agent Job List** on the left pane.
3. Select an agent on the **Agent Job List** pane.
4. In the **Agent Job List Contents** pane, right-click on a row and select **Append Row**.
5. Select a job from the **Job** drop-down list.
Note: You can map an agent to a maximum of 80 jobs.

6. To add more jobs, repeat Step 3 to Step 5.
7. Click on the Save icon.

Delete a job from an agent job list

To delete a job from an agent job list:
1. Login to the Editor as administrator or user having privileges to access Agent Job List.
2. Click Agent Job List on the left pane.
3. Select an agent on the Agent Job List pane.
4. In the Agent Job List Contents pane, right-click on a row and select Delete Row.

View Agent Job List Reports

The Agent Job List menu displays reports on the following two categories:

● Jobs associated with agents - This report displays all the jobs assigned to an agent for whom a joblist has been created.
● Agents associated with jobs - This report displays all the agents assigned to a job that is included in at least one of the joblists.

To view Agent Job List reports:
1. Login to the Editor as administrator or user having privileges to access Agent Job List.
2. Click Agent Job List Reports on the left pane.
3. To view a report on the Jobs associated with each selected agent, select Jobs in the Agent Job List Reports pane. The Jobs associated with agents pane displays a list of jobs to which each agent can join.
4. To view a report on the agents associated with each selected job, select Agents in the Agent Job List Reports pane. The Agents associated with jobs pane displays a list of agents assigned to each job.
Chapter 22: Monitor settings

Avaya Proactive Contact enables you to monitor real-time calling activities using Monitor. Monitor allows you to specify how to view real-time calling activities.

You can specify how to monitor calling activities in the following ways:

- Arrange data
- Specify the time range
- Change a job as the job runs
- Customize a view according to completion code
- Customize a view according to an agent’s state
- Determine the refresh rate and the preferred saving method

You can modify the Monitor default settings during a job from the Monitor toolbar. You can also save the changes to a custom view for use when next time you use Monitor.

Monitor applies the default settings to the view when you open Monitor. To use the customized settings, select the custom view from the button bar.

The button groups on the left pane filter the type of information you see by the following views:

- View set
- Dialer
- Job
- Supervisor
- Agent
- Custom

The buttons in each view set display detailed information about that view.

This section contains the following topics:

- Understanding Monitor on page 271
- Using Monitor settings on page 272

Understanding Monitor

Monitor allows you to define how to view real-time calling activities.

This section contains the following topic:
Monitor window description

Monitor has a button bar on the left-hand side of the screen and the main pane on the right-hand side to display various windows or views.

A view is a window that displays when you click a button in the button bar. In each view, you can filter information and customize how you monitor the calling activities, including sorting data and resizing columns.

**Button group** - Expands and contracts to display buttons associated with the group. Click a button to display a view.

**Views** - Display data based on the type of calling activity and specific criteria. You can use the toolbar options in each view to modify and create views. Monitor lists views that you create in the Custom group.

To sort the contents of a view, click a column heading.

**Tip:**

An arrow appears in the column heading to indicate the sort order. An up arrow indicates that the data is displayed in the ascending order. A down arrow point indicates that the data is displayed in the descending order.

To resize columns in a view:

1. Hover your cursor between the heading titles until a double-arrow appears.
2. Hold down the left mouse button and drag the cursor to resize the columns.

For more information on views, see the following topics:

- To customize individual views using the toolbar, see **Create a custom view** on page 299.
- To learn more about the various Monitor views and how to customize each view, see the **Using view controls** on page 305.

Using Monitor settings

You can modify the Monitor default settings during a job from the Monitor toolbar. You can also save the changes to a custom view for use the next time you use Monitor.

**Note:**

Refer to **Chapter 3: Permissions in Role Editor** on page 41 for information on Monitor related permissions.
Monitor applies the default settings when you open Monitor. To use the customized settings, select the custom view from the button bar.

This section contains the following topics:
- Set the default hierarchy on page 273
- Set time range on page 274
- Set multi-dialer views on page 274
- Set agent states to display on page 274
- Set the view set on page 275
- Set save on exit settings on page 275
- Set alert monitoring on page 276

---

**Set the default hierarchy**

The default hierarchy is set in the **Options** dialog box.

The **Scope** tab affects the options you see in a view’s toolbar.

**Note:**
You must create a custom or an agent/supervisor hierarchy before you can select a hierarchy from the Scope tab.

For example, on the **Scope** tab, you select a hierarchy from the agent/supervisor list, then, when a view is opened and you select _agent/supervisor hierarchy_ from the list that appears when you click the **Hierarchy Manager** toolbar icon, the hierarchy defined on the **Scope** tab is used.

To set the default hierarchy:

1. In Monitor, select **Settings > Options**.
2. In the **Options** dialog box, select the **Scope** tab. For more information, see **Options, Scope tab** on page 341.
3. Under **How should data be arranged**, select a hierarchy from the following drop-down lists:
   - Select a hierarchy from the **Agent/supervisor** list to use as the default view when you select the **Use the agent/supervisor hierarchy** option in any view.
   **Note:**
   If you select **Use custom Hierarchy**, you need to have previously created hierarchies using the Hierarchy Manager tool.
   - Select a custom hierarchy from the **Custom Hierarchy** list to use as the default view when you select the **Use custom hierarchy** option in any view.
4. Click **OK** or **Apply**.
Set time range

The time range is set in the Options dialog box. The preferences that you specify in the Options dialog box’s Scope tab dynamically affect the Time Scope button on all of your views’ toolbars.

To set the time range:

1. In Monitor, select Settings > Options.
2. In the Options dialog box, select the Scope tab. For more information, see Options dialog box on page 341.
3. Under What time range should views support, select Show data for both active and recent jobs if you want to see data both for the currently running jobs and the jobs that have run today but have since shutdown.

Set multi-dialer views

Use the Multi-Dialer tab to choose the dialers for which you can execute commands.

To set multi-dialer views:

1. In Monitor, select Settings > Options.
2. In the Options dialog box, select the Multi-Dialer tab. For more information, see Options, Multi-Dialer Control tab on page 342.
3. To set up how to apply the job changes, complete one of the following steps:
   a. To apply job changes to all the dialers, select Apply job changes to all selected dialers.
      or
      To apply job changes to specific dialers, select the name of each dialer in the Dialer list to which you want to apply job changes.
   b. Click OK.

Set agent states to display

Use the Agent States tab on the Options dialog box to choose the agent states to be displayed.

To display agent states:

1. In Monitor, select Settings > Options.
2. In the **Options** dialog box, select the **Agent States** tab. For more information, see *Options, Agent States tab* on page 342.

3. Select the states to display. You can select from the following options:
   - Talk
   - Update a record
   - Idle
   - ACD
   - Logging off
   - Off job
   - Offline
   - Not Available

4. Click **OK**.

---

**Set the view set**

Use the **Appearance** tab to set the view set and refresh rate.

To set the view and refresh rate:

1. In Monitor, select **Settings > Options**.
2. In the **Options** dialog box, select the **Appearance** tab. For more information, see *Options, Appearance tab* on page 342.
3. Enter the view set to use, or select **Browse** to locate your view set.
4. Click the up or down arrow to set the refresh interval, in seconds, for your views.
5. Click **OK**.

---

**Set save on exit settings**

Use the **Feedback** tab to choose how to save changes to views and view sets when the application closes.

1. In Monitor, select **Settings > Options**.
2. In the **Options** dialog box, select the **Feedback** tab.
3. Select when to save the changes. The options are:
   - When a view closes
   - When the application closes
Chapter 22: Monitor settings

- When a command is initiated
4. Click OK.

---

Set alert monitoring

Use the Alerts tab to start alert monitoring automatically and to disable email alert notifications.

To set alert monitoring:
1. In Monitor, select **Settings > Options**.
2. In the **Options** dialog box, select the **Alerts** tab.
3. Select any of the following check boxes that you want to apply to alerts:
   - **Start alert monitoring automatically**
   - **Disable e-mail notifications**
Chapter 23: Pattern matching rules

Avaya Proactive Contact supports pattern matching syntax including wildcard characters. In Editor, you use basic pattern matching syntaxes when creating and editing phone strategies and record selections. You can also use more complex pattern matching syntaxes.

Avaya Proactive Contact also supports the following pattern matching syntax:

- Integer
- Floating point
- Date
- Time
- String
- Shell-style
- Extended regular expression-style

This section contains the following topics:

- Understanding default pattern syntax on page 277
- Using supported syntaxes on page 279

Understanding default pattern syntax

Field types are supported in dialer calling lists.

This section contains the following topics:

- Expected pattern syntax for field types on page 278
- Explicit pattern syntaxes on page 278
Chapter 23: Pattern matching rules

## Expected pattern syntax for field types

The following table shows which pattern syntax is expected for each field type by default:

<table>
<thead>
<tr>
<th>Field type symbol</th>
<th>Field type description</th>
<th>Default pattern syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>$</td>
<td>Currency Amount</td>
<td>Floating point Numerical comparison syntax</td>
</tr>
<tr>
<td>N</td>
<td>Number</td>
<td>Numerical comparison syntax</td>
</tr>
<tr>
<td>D</td>
<td>Date</td>
<td>Date conversion + Time conversion</td>
</tr>
<tr>
<td>T</td>
<td>Time</td>
<td>Time conversion + Numerical comparison syntax,</td>
</tr>
<tr>
<td>C</td>
<td>Character</td>
<td>String comparison syntax, then Shell-style pattern syntax</td>
</tr>
</tbody>
</table>

If the pattern fails to compile with the default syntax, other syntax types are tried in turn, until one succeeds or fails.

If all compile attempts fail, only the error message for the first failure is reported.

## Explicit pattern syntaxes

You can explicitly designate a pattern syntax by beginning your pattern with the field type symbol of the comparison followed by a ‘@‘ character.

The following table lists the explicit syntax for data types:

<table>
<thead>
<tr>
<th>@ Type</th>
<th>Data description</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>$@</td>
<td>Currency amount</td>
<td>Floating point numerical comparison syntax</td>
</tr>
<tr>
<td>F@</td>
<td>Floating point</td>
<td>Floating point numerical comparison syntax</td>
</tr>
<tr>
<td>N@</td>
<td>Integer</td>
<td>Numerical comparison syntax</td>
</tr>
<tr>
<td>D@</td>
<td>Date</td>
<td>Date conversion + numerical comparison syntax</td>
</tr>
<tr>
<td>T@</td>
<td>Time</td>
<td>Time comparison syntax + numerical comparison syntax</td>
</tr>
<tr>
<td>C@</td>
<td>Character</td>
<td>String comparison syntax, then Shell-style pattern syntax</td>
</tr>
<tr>
<td>S@</td>
<td>String</td>
<td>String comparison syntax</td>
</tr>
</tbody>
</table>
For example, if you are working with a number field but want to use shell-style pattern matching syntax instead of numerical comparison syntax, you could begin the pattern with P@. This is known as explicit pattern syntax specification. For example P@12* would match against any numerical value beginning with 12.

Using supported syntaxes

Integer numerical values can be given in any integer notation, such as optional spaces, followed by an optional + or -, followed by one or more digits.

This section contains the syntaxes used by the Avaya Proactive Contact system:

- **List separators** on page 279
- **Numerical comparisons (type N, $, F)** on page 280
- **Date Comparisons (Type D)** on page 281
- **Time Comparisons (Type T)** on page 281
- **String Comparisons (Type S)** on page 282
- **Shell-style Pattern syntax (Type P)** on page 282
- **Extended Regular Expression syntax (Type E)** on page 284

### List separators

The following syntaxes are supported:

<table>
<thead>
<tr>
<th>@ Type</th>
<th>Data description</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>P@</td>
<td>Any</td>
<td>Shell-style pattern syntax</td>
</tr>
<tr>
<td>E@</td>
<td>Any</td>
<td>Extended regular expression syntax</td>
</tr>
</tbody>
</table>

To use any of these symbols explicitly in a pattern, and not as list separators, you must precede them with a backslash. For example: \\!.
Numerical comparisons (type N, $, F)

A numerical comparison pattern must contain at least one numerical value and one legal numerical comparison operator. It may contain one or more list separators (, ! &).

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>==</td>
<td>Match if equal to</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Match if not equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>Match if greater than</td>
</tr>
<tr>
<td>&lt;</td>
<td>Match if less than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Match if greater than or equal to</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Match if less than or equal to</td>
</tr>
<tr>
<td>-</td>
<td>Match if within inclusive range</td>
</tr>
</tbody>
</table>

Floating point numerical values can be given in any legal floating point notation, such as the following syntax:

\(<\text{optional spaces}>\ <\text{optional + or ->}>\ <\text{one or more digits}>.\ <\text{one or more digits}>\).

<table>
<thead>
<tr>
<th>Example Numerical Comparisons</th>
</tr>
</thead>
<tbody>
<tr>
<td>&gt; 123</td>
</tr>
<tr>
<td>&gt;=123.45</td>
</tr>
<tr>
<td>&lt;-123.</td>
</tr>
<tr>
<td>&lt;=+12.34</td>
</tr>
<tr>
<td>= 123.0</td>
</tr>
<tr>
<td>==123</td>
</tr>
<tr>
<td>123-456.78</td>
</tr>
<tr>
<td>-200--100</td>
</tr>
<tr>
<td>=123,456</td>
</tr>
<tr>
<td>=123!&gt;456</td>
</tr>
<tr>
<td>&gt;123&amp;&lt;&gt;456</td>
</tr>
</tbody>
</table>
Date Comparisons (Type D)

Date comparisons are handled by first converting each date in the pattern to an 8-digit integer with the digit order CCYYMMDD, then compiling the resulting pattern using integer numerical comparison syntax. The same conversion is done to the target date during the comparison operation.

To use this comparison syntax, the dates must follow the format in the DATEFORM parameter of master.cfg. Otherwise, dates could be compared as simple strings using a shell-, ERE-, or string-style pattern notation.

A relative date feature is supported for date comparisons.

Instead of an explicit date, you can use any of the notations "$TODAY", "$TODAY + n", or "$TODAY - n", where n is an integer. These will be converted into today's date +/- n days.

<table>
<thead>
<tr>
<th>Example Date Comparisons</th>
<th>Match if date is 2004/12/31</th>
</tr>
</thead>
<tbody>
<tr>
<td>2004/12/31</td>
<td>Match if date is 2004/12/31</td>
</tr>
<tr>
<td>=2004/12/31</td>
<td>Match if date is 2004/12/31</td>
</tr>
<tr>
<td>&gt;2004/12/31</td>
<td>Match if date is greater than 2004/12/31</td>
</tr>
<tr>
<td>&gt;=2005/01/01</td>
<td>Match if date is greater than or equal to 2005/01/01</td>
</tr>
<tr>
<td>&lt;$TODAY</td>
<td>Match if date is less than today</td>
</tr>
<tr>
<td>&lt;$TODAY-30</td>
<td>Match if date is less than 30 days ago</td>
</tr>
<tr>
<td>2004/02/15-$TODAY</td>
<td>Match if date is within range of 2004/02/15 and today</td>
</tr>
<tr>
<td>$TODAY,$TODAY+1</td>
<td>Match if date is today or tomorrow</td>
</tr>
<tr>
<td>$TODAY-2004/03/15</td>
<td>Match if date is within range of today and 2004/03/15</td>
</tr>
<tr>
<td>$TODAY-1-2004/03/15</td>
<td>Match if date is within range of yesterday and 2004/03/15</td>
</tr>
<tr>
<td>$TODAY!&gt;$TODAY+30</td>
<td>Match if date is today or greater than 30 days from today</td>
</tr>
<tr>
<td>&gt;$TODAY&amp;&lt;$TODAY+30</td>
<td>Match if date is between tomorrow and 29 days out</td>
</tr>
</tbody>
</table>

Time Comparisons (Type T)

Time comparisons are handled by first converting each time in the pattern to a 6-digit integer with the digit order HHMMSS, then compiling the resulting pattern using integer numerical comparison syntax. The same conversion is done to the target date during the comparison operation.
String Comparisons (Type S)

A string comparison pattern should begin with a legal numerical comparison operator.
If the string comparison does not, the pattern compiles as if it does not contain any special characters.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Match if equal to</td>
</tr>
<tr>
<td>==</td>
<td>Match if equal to</td>
</tr>
<tr>
<td>&lt;&gt; or ~</td>
<td>Match if not equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>Match if greater than</td>
</tr>
<tr>
<td>&lt;</td>
<td>Match if less than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Match if greater than or equal to</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Match if less than or equal to</td>
</tr>
</tbody>
</table>

**Note:**
The range operator '-' is not supported for string comparisons.
To compare a range of strings use the '&' list separator. For example ">ABC<&ADZ".

Shell-style Pattern syntax (Type P)

The pattern must not look like a legal numerical comparison.
To match any regular character, use that character in the pattern.
To match any special character (\~ ? + * , ! & [ ] { } ( ) - ^ $) precede the character with a backslash.

### Character Class Shorthand Notation

<table>
<thead>
<tr>
<th>Character Class Shorthand Notation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>*</td>
<td>Match anything (wildcard)</td>
</tr>
<tr>
<td>?</td>
<td>Match any single character</td>
</tr>
<tr>
<td>\a</td>
<td>Match any single alphabetic character</td>
</tr>
<tr>
<td>\c</td>
<td>Match any single control character</td>
</tr>
<tr>
<td>\d</td>
<td>Match any single digit</td>
</tr>
<tr>
<td>\l</td>
<td>Match any single lowercase character</td>
</tr>
<tr>
<td>\p</td>
<td>Match any single punctuation character</td>
</tr>
<tr>
<td>\s</td>
<td>Match any single space (space, tab, nl) character</td>
</tr>
<tr>
<td>\u</td>
<td>Match any single uppercase character</td>
</tr>
<tr>
<td>\w</td>
<td>Match any single word (alphanumeric) character</td>
</tr>
<tr>
<td>\A</td>
<td>Match any single character not matched by \a</td>
</tr>
<tr>
<td>\C</td>
<td>Match any single character not matched by \c</td>
</tr>
<tr>
<td>\D</td>
<td>Match any single character not matched by \d</td>
</tr>
<tr>
<td>\L</td>
<td>Match any single character not matched by \l</td>
</tr>
<tr>
<td>\P</td>
<td>Match any single character not matched by \p</td>
</tr>
<tr>
<td>\S</td>
<td>Match any single character not matched by \s</td>
</tr>
<tr>
<td>\U</td>
<td>Match any single character not matched by \u</td>
</tr>
<tr>
<td>\W</td>
<td>Match any single character not matched by \w</td>
</tr>
</tbody>
</table>

###Modifiers

<table>
<thead>
<tr>
<th>Modifier</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>~</td>
<td>Match everything except what pattern matches (must be first character in pattern)</td>
</tr>
<tr>
<td>[]</td>
<td>Match any single character or character range in set</td>
</tr>
<tr>
<td>[*]</td>
<td>Match any single character or character range not in set</td>
</tr>
<tr>
<td>-</td>
<td>Character range (sets only)</td>
</tr>
<tr>
<td>{}</td>
<td>Subset (subsets can be nested)</td>
</tr>
<tr>
<td>[ ]</td>
<td>List separator ('or' operator)</td>
</tr>
</tbody>
</table>
Patterns without wildcards are considered complete, and will not match on substrings. The following are example patterns.

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>~?*</td>
<td>Match if string is empty</td>
</tr>
<tr>
<td>ABC</td>
<td>Match if string is ABC</td>
</tr>
<tr>
<td>~DEF</td>
<td>Match if string is not DEF</td>
</tr>
<tr>
<td>FOO*</td>
<td>Match if string starts with FOO</td>
</tr>
<tr>
<td>*BAR</td>
<td>Match if string ends with BAR</td>
</tr>
<tr>
<td>SPL?T</td>
<td>Match if string is SPL?T where? can be any character</td>
</tr>
<tr>
<td>[AD-F]</td>
<td>Match if string is the single character A or D - F</td>
</tr>
<tr>
<td>A[^AD-F]*</td>
<td>Match if string starts with an A, whose second character is not the character A or D - F, and ends with anything</td>
</tr>
<tr>
<td>ABC</td>
<td>DEF</td>
</tr>
<tr>
<td>BAZ!FUB*</td>
<td>Match if string is BAZ or starts with FUB</td>
</tr>
<tr>
<td>~{205,425}</td>
<td>Match if string is not 206 or 425</td>
</tr>
<tr>
<td>{DOG</td>
<td>CAT}</td>
</tr>
<tr>
<td>CA{NA,LI,RG}*</td>
<td>Match if string begins with CA; has NA, LI, or RG as its 3rd and 4th characters; and ends in anything. (Would match CANADA, CALIFORNIA, CARGO...)</td>
</tr>
<tr>
<td>\d\d\d-\d\d-\d\d\d\d</td>
<td>Match if string looks like a SSN</td>
</tr>
</tbody>
</table>

**Extended Regular Expression syntax (Type E)**

The expression must begin with the symbol 'E@', which is stripped prior to compiling the pattern with regcomp ().

For more information on ERE syntax, refer to the section entitled "Extended Regular Expressions" in the man page "regexp."

In addition to the standard ERE syntax described by the above mentioned man page, the following extensions are supported:

- Negation (~~)
- Character class shorthand notation (\a, \c, \d, and so on)

The pattern must not look like a legal numerical comparison (above).

To match any regular character, use that character in the pattern.
To match any special character (~ ? + * , ! & | [ ] { } ( ) - ^ $) precede it with a backslash.

<table>
<thead>
<tr>
<th>Character Class Shorthand Notation</th>
</tr>
</thead>
<tbody>
<tr>
<td>.</td>
</tr>
<tr>
<td>\a</td>
</tr>
<tr>
<td>\c</td>
</tr>
<tr>
<td>\d</td>
</tr>
<tr>
<td>\l</td>
</tr>
<tr>
<td>\p</td>
</tr>
<tr>
<td>\s</td>
</tr>
<tr>
<td>\u</td>
</tr>
<tr>
<td>\w</td>
</tr>
<tr>
<td>\A</td>
</tr>
<tr>
<td>\C</td>
</tr>
<tr>
<td>\D</td>
</tr>
<tr>
<td>\l</td>
</tr>
<tr>
<td>\p</td>
</tr>
<tr>
<td>\S</td>
</tr>
<tr>
<td>\U</td>
</tr>
<tr>
<td>\W</td>
</tr>
<tr>
<td>\n</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Modifiers</th>
</tr>
</thead>
<tbody>
<tr>
<td>~</td>
</tr>
<tr>
<td>^</td>
</tr>
<tr>
<td>$</td>
</tr>
<tr>
<td>*</td>
</tr>
<tr>
<td>+</td>
</tr>
</tbody>
</table>
### Modifiers

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>?</td>
<td>Match preceding character 0 or 1 time,</td>
</tr>
<tr>
<td>{}</td>
<td>Match preceding character n or n, m times where n is a number and n,m is a number range.</td>
</tr>
<tr>
<td>[]</td>
<td>Match any single character or character range in set,</td>
</tr>
<tr>
<td>[^]</td>
<td>Match any single character or character range not in set,</td>
</tr>
<tr>
<td>-</td>
<td>Character range for sets only.</td>
</tr>
<tr>
<td>( )</td>
<td>Subset and nested subsets. Subsets are numbered by the order of occurrence of the '(' character.</td>
</tr>
<tr>
<td></td>
<td>List separator 'or'.</td>
</tr>
</tbody>
</table>

Patterns without anchors are considered incomplete or fragments. Each pattern will match on substrings. For example, 'E@RES' matches on 'FRESNO'.

### Example Patterns

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>E@^$</td>
<td>Match if string is empty</td>
</tr>
<tr>
<td>E@^ABC$</td>
<td>Match if string is ABC</td>
</tr>
<tr>
<td>E@~^ABC$</td>
<td>Match if string is not ABC</td>
</tr>
<tr>
<td>E@^ABC</td>
<td>Match if string begins with ABC</td>
</tr>
<tr>
<td>E@^ABC$</td>
<td>Match if string ends with ABC</td>
</tr>
<tr>
<td>E@ABC</td>
<td>Match if string contains ABC</td>
</tr>
<tr>
<td>E@A.*Z</td>
<td>Match if string contains any sequence where A precedes Z</td>
</tr>
<tr>
<td>E@FOO?BAR</td>
<td>Match if string contains FOBAR or FOOBAR</td>
</tr>
<tr>
<td>E@FO+BAR</td>
<td>Match if string contains FOBAR or FOOBAR or FOOOBAR or...</td>
</tr>
<tr>
<td>E@^SPL.T$</td>
<td>Match if string is SPL?T where? can be any character</td>
</tr>
<tr>
<td>E@^[AD-F]$</td>
<td>Match if string is the single character A or D - F</td>
</tr>
<tr>
<td>E@^[AD-F]</td>
<td>Match if string starts with an A, whose second character is not the character A or D - F, and ends with anything</td>
</tr>
<tr>
<td>E@ABC</td>
<td>DEF</td>
</tr>
<tr>
<td>Example Patterns</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>E@^CA(NA</td>
<td>LI</td>
</tr>
<tr>
<td>E@^\d{3}-\d{2}-\d{4}$</td>
<td>Match if string looks like a SSN.</td>
</tr>
</tbody>
</table>
Chapter 24: Hierarchy Manager

Hierarchy Manager is a tool that helps you group and organize data.

Hierarchy Manager allows you to create agent, job, or dialer hierarchies to reflect your company’s or business’ organization. For example, you can create relationships between the Avaya Proactive Contact agents and the management structure of your company.

In Monitor, you can also use hierarchies to adjust the scope of data to view.

In Analyst, you can use hierarchies to group data in reports.

This section contains the following topics:

- Understanding Hierarchy Manager on page 289
- Using Hierarchy Manager on page 291
- Maintaining Hierarchy Manager on page 294

Understanding Hierarchy Manager

A hierarchy contains one or more branches. Each branch contains three hierarchy levels: top, middle, and bottom.

Each branch can contain more than one middle level. Each middle level can contain one or more bottom levels. You can assign one or more data items to the bottom level.

For example: A job hierarchy contains two branches. Each branch follows this structure:

- Top level is Portfolio, such as Loans or Savings.
- Middle level is Account Type, such as Car, Mortgage or Certificate Deposits.
- Bottom level is Term, the length of the loan or savings account such as 60 months, 30 years. The data items in the bottom level data items are job names.

After you add a job or an agent to Avaya Proactive Contact, the job or agent is available for use in Hierarchy Manager. Agents, jobs, and dialers are available in Hierarchy Manager until data in the database expires. This allows for historical reporting.

For example: When you remove an agent login from Avaya Proactive Contact, the database still contains data for that agent. As a result, the agent name appears in the Hierarchy Manager list of available agents.

Hierarchy Manager supports three hierarchy types:

- Agent hierarchies on page 290
- Job hierarchies on page 290
Agent hierarchies

An agent hierarchy creates statistical relationships for individual agent activity and performance data that Avaya Proactive Contact collects during calling activities. Activity and performance data examples include Talk Time, Idle Time, and Connects per Hour.

Agent hierarchies are most effective when monitoring agent views in Monitor and when grouping data in Analyst agent reports.

For example, an agent hierarchy can represent the management structure of a company. Top, middle, and bottom levels represent directors, managers, and supervisors, respectively. Agents are assigned to each supervisor. Monitor can use this hierarchy to group agent activity and performance data by supervisor.

Job hierarchies

A job hierarchy creates statistical relationships for individual job activity data that Avaya Proactive Contact collects during calling activities. Examples of job activity data include Calls Placed, Connects per Hour, and Time in Wait Queue.

Job hierarchies are most effective in Monitor to monitor job views in Monitor and in Analyst to group data in Analyst job reports.

In a multi-dialer environment, job hierarchies apply to all jobs across all dialers unless you create the following environment:

- Create all jobs unique across all dialers
- Create a dialer-job relationship outside of Hierarchy Manager.

For example, when you create a job, include a reference to the dialer in the job name such as job1_dialer1.

Dialer hierarchies

A dialer hierarchy creates relationships for individual dialer activity data that Avaya Proactive Contact collects during calling activities. Dialer activity includes all available job and agent activity and performance data.

Dialer hierarchies are effective to group data by department and dialer.

For example: In a four-dialer pod environment, the collections and marketing departments use the following dialers:
Collections uses dialer1 and dialer2
Marketing department uses dialer3 and dialer4
A hierarchy branch could contain a level for department with individual dialers assigned to the level.

Using Hierarchy Manager

Hierarchy Manager is available from the Tools menu in Analyst or Monitor.

Note: Refer to Chapter 3: Permissions in Role Editor on page 41 for permissions related to Hierarchy Manager.

This section contains the following topics:

- Start Hierarchy Manager on page 291
- Create a hierarchy on page 291
- Open a hierarchy to view or change on page 293
- Add a level to a hierarchy on page 293

Start Hierarchy Manager

To start Hierarchy Manager:
1. Select Start > Programs > Avaya Proactive Contact > Supervisor > Monitor or Analyst.
2. Select Tools > Hierarchy Manager.

The Hierarchy Manager window appears.

Create a hierarchy

You can create an agent, job, or dialer hierarchy based on the hierarchy type you select. When you create a new hierarchy, you add top, middle, and bottom hierarchy levels and assign data items to the bottom hierarchy.
Chapter 24: Hierarchy Manager

Note: If you name two like levels the same under one parent level, Hierarchy Manager combines the two like levels into one level.

For example: A middle level hierarchy contains two bottom levels, both named as Supervisor. Hierarchy Manager combines all the data items assigned to both the Supervisor levels and removes the duplicate level.

To create a hierarchy:

1. On the button bar, click Agent Hierarchies, Job Hierarchies, or Dialer Hierarchies depending on the type of hierarchy you want to create.

2. Select File > New.

   Hierarchy Manager displays a new hierarchy including a default structure. The Available list contains agent, job, or dialer names depending on which hierarchy type you selected.

3. Add hierarchy levels.
   a. Right-click the level above where you want to add a level.
   b. Click Add Level.

      Hierarchy Manager inserts a level named New Level.

4. Rename the new level.

   Right-click New Level, select Rename, enter a new name up to 20 characters, and then press Enter.

5. Repeat Steps 3 and 4 for each level you want to add to the hierarchy.

6. Add data items.

   Drag and drop an item from the Available list onto the bottom level of the branch to which you want to add it.

   After an item is added to the hierarchy, Hierarchy Manager moves the data item from the Available list to the Allocated list.

7. Select File > Save to save the hierarchy settings.

   Hierarchy Manager does not save branches that do not contain data items. Empty branches will no longer appear in the hierarchy after you close and restart Hierarchy Manager.

8. In the Save As dialog box, name for the hierarchy.

   Enter a name up to 64 characters, and then click OK.

   Hierarchy Manager saves the hierarchy settings.
Open a hierarchy to view or change

To open a hierarchy that you want to view or change:

1. On the button bar, click **Agent Hierarchies**, **Job Hierarchies**, or **Dialer Hierarchies** depending on the type of hierarchy you want to open.

   A list of hierarchies appears in the button bar for the selected hierarchy type.

2. Select a hierarchy. The selected hierarchy appears.

Add a level to a hierarchy

To build your organizational structure in Hierarchy Manager, you add levels to a hierarchy. Each branch in a hierarchy contains three levels: top, middle, and bottom.

When you add a level, Hierarchy Manager adds a level below the selected level. For example: If you add a level to a top level item, Hierarchy Manager adds a middle level item. To add a top level item, add a level to the hierarchy name.

To add a level to a hierarchy:

1. Open the hierarchy that you want to change.

2. Right-click the level above where you want to add a level, and then click **Add Level**.

   Hierarchy Manager inserts a level named New Level.

3. Right-click **New Level**, and then select **Rename**.

4. Enter a new name up to 20 characters, and then press **Enter**.

Add a data item to a hierarchy

Hierarchy Manager lets you add data items to only the bottom-most levels of the hierarchy.

To add data items to a hierarchy:

1. Open the hierarchy to which you want to add data items.

2. Select one or more items in the **Available** list, and then drag the items to the appropriate level.

   After an item is added to the hierarchy, Hierarchy Manager moves the data item from the **Available** list to the **Allocated** list.
Chapter 24: Hierarchy Manager

Tip:
To select two or more adjacent items in the Available list, click the first item, and then hold down Shift and click the last item. To select two or more non-adjacent items, click the first item, and then hold down Ctrl and click additional items.

Maintaining Hierarchy Manager

As your organization changes, you might need to rearrange elements in a hierarchy, rename levels or remove levels in a hierarchy to reflect your organizational changes. This section provides the following topics:

- Move a level or item within a hierarchy on page 294
- Rename a hierarchy level on page 295
- Remove a level from a hierarchy on page 295
- Remove a data item from a hierarchy on page 295
- Rename a hierarchy on page 296
- Delete a hierarchy on page 296

Move a level or item within a hierarchy

As your organization changes, you might need to rearrange elements in a hierarchy to reflect the changes.

You can move data items from one bottom level to another. For example: in an agent hierarchy, you can move an agent from one supervisor to another.

You can also move a level within a hierarchy. Items and levels that you move must maintain their same level in the hierarchy. For example: A bottom level cannot be moved to a middle level position.

To move a level or a data item within a hierarchy:

1. Open the hierarchy that you want to change.
2. Select the level or data item that you want to move, and then drag it to the hierarchy level above where you want the level or item to be listed.
3. Repeat Step 2 for each level or item that you want to move.
Rename a hierarchy level

Hierarchy Manager lets you rename levels in a hierarchy to reflect organizational changes.

**Note:**
If you name two like levels the same under one parent level, Hierarchy Manager combines the two like levels into one level.

For example: A hierarchy middle level contains two bottom levels named Supervisor. Hierarchy Manager combines all data items assigned to both Supervisor levels and removes the duplicate level.

To rename a hierarchy level:

1. Open the hierarchy in which you want to rename a level.
2. Right-click the hierarchy level name that you want to change, and then select **Rename**.
3. Type a new name for the level (up to 20 characters), and then press **Enter**.

Remove a level from a hierarchy

As your organization changes, you can use Hierarchy Manager to reflect those changes in your hierarchies.

You can remove a level from your hierarchy to better represent your organization.

To remove a top or middle hierarchy level that contains a bottom level with data items, you must first delete the bottom level (and data items).

To remove a level from a hierarchy:

1. Open the hierarchy from which you want to remove a level.
2. Right-click the level that you want to remove, and then select **Delete**. If the level you select to remove contains data items, Hierarchy Manager displays a message confirming whether you want to delete the selected level and all the agents associated with that level.
3. Click **Yes** to delete the level. Hierarchy Manager removes the level and moves the data items from the **Allocated** list to the **Available** list.

Remove a data item from a hierarchy

You can remove a data item from a hierarchy when the item no longer meets your organizational needs. You can remove individual data items as described in the following
procedure. You can also remove all the data items assigned to a bottom level by removing the bottom level.

1. Open the hierarchy from which you want to remove one or more data items.

2. Right-click a data item that you want to remove, and then select **Delete**. Hierarchy Manager removes the data item from the hierarchy, and moves the data item from the **Allocated** list to the **Available** list.

3. Repeat Step 2 for each data item you want to remove.

---

**Rename a hierarchy**

To rename a hierarchy:

1. Open the hierarchy that you want to change.

2. Select **File > Save As**.

3. In the **Save As** dialog box, enter a unique name for the hierarchy.

   A hierarchy name can contain up to 64 characters and can include the following special characters: parentheses ( ), comma (,), hyphen (-), dollar sign ($), and the pound sign (#).

4. Click **OK**.

   Hierarchy Manager saves the hierarchy settings with the new name.

---

**Delete a hierarchy**

As your organization changes, you might decide to no longer use a particular hierarchy. You can delete a hierarchy from Hierarchy Manager.

1. Open the hierarchy that you want to change.

2. Select **Hierarchy > Delete**. Hierarchy Manager asks you to confirm the delete action.

3. Click **Yes** to delete the hierarchy. Hierarchy Manager removes the selected hierarchy.
Chapter 25: Customize Monitor

Avaya Proactive Contact allows you to navigate among the tool applications and customize the Monitor views.

This section contains the following topics:

- **Navigate among the Tool menu applications** on page 297
- **Using a Monitor view** on page 297
- **Customizing Monitor views** on page 299
- **Managing custom views** on page 301

---

**Navigate among the Tool menu applications**

Monitor comes with the tool applications that you access from the Tools menu.

To start Tools menu applications:

1. Select **Start > All Programs > Avaya > Proactive Contact > Supervisor > Monitor**.
2. To start a tool, select the tool option from the Tools menu.

While you use the tool, Monitor remains open in the background so that you can navigate back to Monitor when you are finished using the tool.

---

**Using a Monitor view**

Monitor comes with tool applications that you access from the Tools menu.

This section contains the following topics to help you open a view:

- **View icons in the button bar** on page 298
- **Open a standard view** on page 298
- **Open a view or view set from another location** on page 298
- **Open a view about a specific agent** on page 299
View icons in the button bar

You can view large or small buttons on the button bar.

To switch between large and small icons in the button bar:
1. On the button bar, click a group name to expand the button bar whose icon size you want to change.
2. Right-click, and then select either Large Icons or Small Icons.
   A check mark next to the menu command indicates the view that you are currently using.

Open a standard view

To open a standard view in Monitor:
1. On the Monitor button bar, click one of the following group of views:
   - View Set
   - Dialer
   - Job
   - Supervisor
   - Agent
   - Custom
2. Click the view you want to open.
   The view opens as a new window in the right-hand pane.

Open a view or view set from another location

To open a view or view set from another location:
1. In Monitor, select File > Open.
2. Locate and select the view or view set you want to open, or type the file name in the File name field, and then click Open.
   The view or view set opens as a new window in the right-hand pane.
Open a view about a specific agent

You can display the following views to list information about a specific agent:

- Agent Detail
- Agent Completion Codes
- Agent History

To open a view about a specific agent:
1. Display a view that lists agents. For example, Dialer Agents or Job Agents.
2. Select an agent in the view.
3. Select **Tools**, and then a view.

Customizing Monitor views

In Monitor, you can customize and save a view. You can also save multiple views as a view set. The Monitor wizard helps you customize how you monitor calling activities for the contact center and specific jobs.

This section contains the following topics to help you customize a view:

- **Create a custom view** on page 299
- **Save current view** on page 300
- **Save as a view set** on page 300
- **Save view set with a new name** on page 301

Create a custom view

To create a custom view:

1. In Monitor, select **File > New**.
   - The **New View Wizard** opens.
2. Follow the steps in the View Wizard to create your custom view.
Save current view

To save a current view:

1. On the Monitor button bar, click one of the following group of views:
   - View Set
   - Dialer
   - Job
   - Supervisor
   - Agent
   - Custom
2. Click the button for the view you want to open.
3. Change the view using the view’s toolbar.
4. When you have the view set up the way you want, select File > Save.
   The next time you select the view, your saved preferences appear.

Save as a view set

In Monitor, you can open one or more views and save the views as set for use later from the View Set button bar.

To save a view set:

1. On the Monitor button bar, click one of the following group of views:
   - View Set
   - Dialer
   - Job
   - Supervisor
   - Agent
   - Custom
2. Select the button for the view you want to open.
   The view opens as a new window in the right-hand pane.
3. Repeat Steps 1 and 2 until you have all the necessary views open.
4. Select File > Save All As.
5. Browse to the location where you want to save the view set, enter a name, and then click OK.

6. In the Add a Custom View dialog, enter the name for the view set, and then click OK.
   A button for the view set appears in the View Set group.

---

### Save view set with a new name

To save a view set with a new name:

1. On the Monitor button bar, click one of the following views:
   - View Set
   - Dialer
   - Job
   - Supervisor
   - Agent
   - Custom

2. Click the button for the view set you want to open. The view set opens.

3. Select File > Save All As.

4. Enter the name you want to give your view set, and then click OK. The view set’s new name appears in the View Set button bar.

---

### Managing custom views

This section contains the following topics to help you manage custom views:

- [Delete a view set](#) on page 301
- [Add a view to the Custom button group](#) on page 302
- [Refresh a view](#) on page 302

---

### Delete a view set

To delete a view set:

1. On the Monitor button bar, click View Set.

2. Right-click the view set you want to delete, and then select Remove View Set.
Add a view to the Custom button group

To create a button, you must have a view open in the main pane.
To add a view to the Custom button group:
1. Open a view that you would like to have as a button.
2. Select File > Save As.
3. Enter a name and then click OK.
   The view automatically appears in the Custom button group.

Refresh a view

To refresh an open view, press the F5 key.
Chapter 26: Monitor view controls

A view is the name of the window that appears in the right-hand pane. Monitor displays the view after you click a button on the button bar. This section describes how to use views in Monitor.

This section contains the following topics:

- Understanding view controls on page 303
- Using view controls on page 305
- Maintaining Monitor views on page 308

Understanding view controls

A view is the name given to the window that appears in the right-hand pane.

In Monitor, you can select a view to monitor calling activities and use the toolbar controls to filter the data that displays.

This section discusses the following topics:

- View control toolbar on page 303
- Understand scope selectors examples on page 304

View control toolbar

Every view opens with a set of tools on a toolbar. Use the toolbar buttons to display data in a view.

The available toolbar buttons vary depending on the view. For example, the time selector option does not appear if you cannot set a time range for data in a view.

<table>
<thead>
<tr>
<th>View tool</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table View</td>
<td><img src="image" alt="Table View" /></td>
<td>If the view has graphical and table modes, this button displays the data without icons. The Table View is available for all views.</td>
</tr>
<tr>
<td>Graphical View</td>
<td><img src="image" alt="Graphical View" /></td>
<td>If the view has graphical and table modes, this button displays the data by showing icons. The Graphical View is not available for all views.</td>
</tr>
</tbody>
</table>
### Understand scope selectors examples

The three drop-down lists in the View toolbar are scope selectors.

A scope selector allows you to change the range of data displayed in a view. Use the scope selectors with the Hierarchy Manager toolbar button. The option you select using the Hierarchy Manager toolbar button dynamically changes the available options in the Monitor scope selectors.

<table>
<thead>
<tr>
<th>View tool</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter Data</td>
<td>![Filter Data icon]</td>
<td>Displays the <strong>Filter Data</strong> dialog box that allows you to filter the data in the view according to the selected criteria.</td>
</tr>
<tr>
<td>Performance Code</td>
<td>![Performance Code icon]</td>
<td>Displays a dialog box that allows you to select a completion code that is used to measure agent performance.</td>
</tr>
<tr>
<td>Hide/Show Columns</td>
<td>![Hide/Show Columns icon]</td>
<td>Displays the <strong>Columns</strong> dialog box that allows you to select which of the available data fields will be displayed.</td>
</tr>
<tr>
<td>Find</td>
<td>![Find icon]</td>
<td>Allows you to search for an item in a view.</td>
</tr>
<tr>
<td>Level 1 Scope Selector</td>
<td>![Level 1 Scope Selector icon]</td>
<td>A drop-down list that allows you to limit the amount of data in the display. The default is a list of dialers.</td>
</tr>
<tr>
<td>Level 2 Scope Selector</td>
<td>![Level 2 Scope Selector icon]</td>
<td>The choices in this list depend on the choices made in the Level1 Scope Selector. Allows you to limit the amount of data in the display. The default is a list of jobs.</td>
</tr>
<tr>
<td>Level 3 Scope Selector</td>
<td>![Level 3 Scope Selector icon]</td>
<td>The choices offered in this list depend on the choices made in the Level1 and Level2 Scope Selectors. Allows you to limit the amount of data in the display. The default is <strong>All Level 3</strong>.</td>
</tr>
<tr>
<td>Hierarchy Manager</td>
<td>![Hierarchy Manager icon]</td>
<td>A pull-down list that allows you to select the types of data that will appear in the Scope Selectors.</td>
</tr>
<tr>
<td>Time Scope</td>
<td>![Time Scope icon]</td>
<td>Allows you to display only running jobs or all jobs in the view.</td>
</tr>
<tr>
<td>Refresh view</td>
<td>![Refresh view icon]</td>
<td>Allows you to refresh a view.</td>
</tr>
</tbody>
</table>
The default Monitor scope selectors are dialer and job. You can select one or all items from each selector.

A list of supervisors appears in the third scope selector if you completed the following:
- Defined an agent/supervisor hierarchy using the Hierarchy Manager tool.
- Designated that hierarchy as the default hierarchy in Monitor.

To use Hierarchy Manager, select **Tools > Hierarchy Manager**.

To set the default hierarchy in Monitor, select **Settings > Options > Scope**. For more information, see **Options, Scope tab** on page 341.

**Example One** - To display a view with data for all dialers, all jobs, and all supervisors, set the first hierarchy selector to All Level 1, the second selector to All Level 2, and the third selector to All Level 3.

If you change the dialer selector to DialerA, Monitor removes the data for all other dialers from the view.

**Example Two** - To display data for all jobs named 30Day regardless of the dialer on which the jobs reside, set the first selector to All Level 1 and the second selector to 30Day.

---

**Using view controls**

This section discusses the following topics to help you use the Monitor view controls:
- **Filter data in a view** on page 305
- **Set scope selectors** on page 306
- **Select a hierarchy** on page 307
- **Select a time range** on page 307

---

**Filter data in a view**

To filter data in a view:

1. With a view open, click **Filter Data**. The **Filter Data** dialog box appears. For more information, see **Filter Data dialog box** on page 344.

2. Select a column from the list. The options in this list are the column headings for the selected view.

3. From the **Operator** list, select an operator.
4. In the **Value** box, type a value.

5. Click **OK**.

---

**Set scope selectors**

Set the scope using the three drop-down lists that are available from any view toolbar.

The Hierarchy Manager settings and the default hierarchy selections on the Monitor **Scope** tab specify which hierarchy options you can select for the view.

The default Monitor scope selectors are dialer and job. You can select one or all items from each selector.

To set scope selectors:

1. With a view open, click the **Hierarchy Manager** icon on the view toolbar.

2. Select either **No hierarchy**, **Agent/supervisor hierarchy**, or **Custom hierarchy**.

   The options coordinate with the Agent/supervisor hierarchy and Custom hierarchy lists on the **Scope** tab.

   Additionally, the option that you select in the Hierarchy Manager list affects the three scope selectors in the drop-down lists in your view.

   For example, if you select MySuperAgentHierarchy on the **Scope** tab’s Agent/supervisor hierarchy list and then select Agent/supervisor hierarchy from the Hierarchy Manager list, your scope selectors will populate with data from MySuperAgentHierarchy.

**Tip:**

The hierarchy selected on the **Scope** tab becomes the default hierarchy that populates your views.

3. From the first scope selector, select an item. By default, a list of dialer names appear.

   If you select **Use custom hierarchy**, the top-level items of the selected hierarchy appear in this list.

   The item you select in the first scope selector typically reduces the options available in the second scope selector. You can select **All Level 1**, which does not narrow your view’s scope.

4. From the second scope selector, select an item. By default, a list of job names appear.

   If you select **Use custom hierarchy**, the middle-level items of the selected hierarchy appear in this list.

   The item you select typically narrows the options available in the third scope selector. You can select **All Level 2**, which does not narrow your view’s scope.
5. From the third scope selector, select an item. By default, the third scope selector contains no options except All Level 3.

If you select either Use default hierarchy or Use custom hierarchy, the bottom-level items of the selected hierarchy appear in this list. The All Level 3 value does not narrow your view’s scope.

---

**Select a time range**

You can expand the default time to view data on only the jobs that are currently running or for all the jobs.

For example, you can change the time range to display a view showing right party contacts for all the instances of Job1 that have run during a single day.

Time selection is limited to views and data fields where summing makes sense. For example, non-numerical data is not summed. Similarly, data whose value is transient, such as the minimum hit rate, is not summed.

To select a time range:

1. With a view open, click the **Time Scope** icon.
2. From the list, select or clear **Show Running Jobs Only**.
   - When you select **Show Running Jobs Only**, your view will display data only for the currently running jobs.
   - When you clear **Show Running Jobs Only**, your view will display data for the currently running as well as the stopped jobs.

---

**Select a hierarchy**

After you create a hierarchy in Hierarchy Manager and use the **Scope** tab in Monitor to select the hierarchy, you can apply the hierarchy to any view.

1. With a view open, click the **Hierarchy Manager** icon.
   
   A list appears.
Chapter 26: Monitor view controls

2. From the list, select No Hierarchy, Agent/supervisor hierarchy, or Custom hierarchy. The No Hierarchy option sets the scope selectors back to their default settings. The first scope selector lists dialers, the second scope selector lists jobs, and the third scope selector contains no items except All Level 3.

Agent/supervisor hierarchy and Custom hierarchy coordinate with the Agent/supervisor hierarchy and Custom hierarchy lists seen on the Scope tab. The option that you select in the Hierarchy Manager list affects the three scope selectors in your view.

For example, if you select MySuperAgentHierarchy in the Scope tab Agent/supervisor hierarchy list and then select Agent/supervisor hierarchy from the Hierarchy Manager list, your scope selectors will populate with data from MySuperAgentHierarchy.

The options that you select in the scope selectors can change the scope of the data displayed in your views.

Maintaining Monitor views

This section provides information on maintaining the Monitor views:

● Hide or show columns on page 308
● Select Table View or Graphical View on page 309
● Save a view as HTML on page 309

Hide or show columns

You can customize your view to display only the columns you want.

To hide or show columns.

1. With a view open, click the Hide/Show columns button.

2. To select or clear a column’s check box, do one or more of the following tasks:
   ● Click Select All to show each column in your current view.
   ● Select a check box to show a column in your current view.
   ● Clear a column’s check box to hide a column in your current view.
   ● Click Hide All to each column in your current view.

3. Click OK.
Select Table View or Graphical View

Table view is the default view.

To display views in table or graphical format:

1. With a view open, click the Graphic View button to switch to a view that uses icons.
2. With a view open, click the Table View button to switch to a view that does not display icons of the data in your view.

Save a view as HTML

To save your view as a HTML file:

1. In Monitor, select the view to save as a HTML file.
2. Select File > Save as HTML.

   Monitor opens a new window with the HTML output.
3. Select File > Save As, browse to a location, and select Save.
Chapter 27: Alerts

Avaya Proactive Contact uses alerts to inform supervisors about the end of a job, when a goal is met, and other events.

This section contains the following topics:

- Understanding alerts on page 311
- Using alerts on page 314
- Maintaining alerts on page 318
- Understanding Alert dialog boxes on page 319

---

Understanding alerts

An alert provides a notification when the job or agent performance, system or job status, or line usage varies beyond predetermined levels.

This section contains the following topics:

- Alerts uses on page 311
- Alert examples on page 312
- Alert settings on page 313

---

Alerts uses

You can define up to 10 alerts that notify you when the following varies beyond predetermined levels:

- Job or agent performance
- System or job status
- Line usage varies

You can set the following types of alerts to identify and correct potential problems before they escalate:

- Audio cues
- Visual cues
- Log files
Chapter 27: Alerts

- Emails
- Pager signal

You can also set an alert to tell you when the system needs attention, for example, a job is approaching completion.

To access alerts, start Monitor and select Settings > Alerts.

**Tip:**
Monitor must be open in order for you to receive a notification of an alert. After you receive an alert notification, you must enable the alert again.

To enable an alert, open the Alert Viewer and select Enabled.

---

**Alert examples**

Avaya Proactive Contact can alert you for many reasons. The following is a sample list:

**Average Idle Time** - The average time that all agents or a specific agent are idle, not talking or updating.

**Average Talk Time** - The average time that all agents or a specific agent spend in talking.

**Average Update Time** - The average update time that all agents or a specific agent spend in updating a customer record.

**Current Talk Time** - The talk time for all agents or a specific agent. Current Talk Time is shown as talking in real-time rather than an average over multiple calls.

**Current Update Time** - The update time for all agents or a specific agent. Current Update Time is shown as updating in real-time rather than an average over multiple calls.

**Total Idle Time** - The total idle time for all agents or a specific agent, as idle time added over the course of a single job.

**Total Talk Time** - The total talk time for all agents or a specific agent, as talk time added over the course of a single job.

**Total Update Time** - The total update time for all agents or a specific agent, as update time added over the course of a single job.

**Line Utilization** - The percentage of lines in use for a given job. For example, Line Utilization provides an alert when 95% of your lines are in use for a job.

**Current Hit Rate** - The ratio or percentage of call connects to call attempts.
For example: A 25% hit rate means that out of 100 attempts, 25 connects were made. Or, it takes 4 calls to connect to one customer. A minimum hit rate keeps a job with a low hit rate from using all the lines when it shares a line pool with other jobs.

**Time on Dialer** - The time of day or night when the dialer sends an alert notification.

**Agent Completion Code Total** - The accumulated total of completion codes that agents have entered.

**Agent Completion Code Average** - The average number of completion codes that agents have entered.

**Job Completion Code Average** - The completion code average per hour. The Job Completion Code Average is useful if you would like an overall sense of job performance.

**Job Completion Code Total** - The total of all job completion codes, as accumulated over the entire life of a job. The Job Completion Code Total is useful if you want to stop a job or reassign agents to another job when the goal for a job has been met.

**Agents Assigned** - The number of agents currently on a job.

**Job End** - The job has ended.

**Records Left** - The number of records still left in the job that need to be dialed.

**Records Left as Percent of Total** - The percent of records in the entire job still left to be dialed.

**Time Remaining** - The estimated time left on a job.

Avaya Proactive Contact also automatically notifies you when the data in Monitor did not update within the previous 12 minutes.

---

**Alert settings**

The following table shows possible combinations of alert settings:

<table>
<thead>
<tr>
<th>Condition</th>
<th>Dialer</th>
<th>Job</th>
<th>Agent</th>
<th>Relation</th>
<th>Value</th>
<th>Modifier</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent Comp Code Totals</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td></td>
<td>Total</td>
</tr>
<tr>
<td>Agent Comp code Avg</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td></td>
<td>Average Per Hour</td>
</tr>
<tr>
<td>Agents Assigned</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>&gt;,&lt;</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
The dialer, job, and agent columns indicate whether a data item is relevant to a particular alert condition. For example, you can set a Job End alert for any job on any dialer, and you can set a Total Talk Time alert on any agent on any job on any dialer.

<table>
<thead>
<tr>
<th>Condition</th>
<th>Dialer</th>
<th>Job</th>
<th>Agent</th>
<th>Relation</th>
<th>Value</th>
<th>Modifier</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average Idle Time</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td>0-1440</td>
<td>minutes</td>
</tr>
<tr>
<td>Average Talk Time</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td>0-1440</td>
<td>minutes</td>
</tr>
<tr>
<td>Average Update Time</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td>0-1440</td>
<td>minutes</td>
</tr>
<tr>
<td>Current Hit Rate</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>&gt;,&lt;</td>
<td>1-100</td>
<td>%</td>
</tr>
<tr>
<td>Current Talk Time</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td>0-1440</td>
<td></td>
</tr>
<tr>
<td>Current Update Time</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td>0-1440</td>
<td></td>
</tr>
<tr>
<td>Job Comp Code Avg</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>&gt;,&lt;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Job Comp Code Total</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>&gt;,&lt;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Job End</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Line Utilization</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>&gt;,&lt;</td>
<td>1-100</td>
<td>%</td>
</tr>
<tr>
<td>Records Left</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>&gt;,&lt;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Records Left Percent</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>&gt;,&lt;</td>
<td>1-100</td>
<td>%</td>
</tr>
<tr>
<td>Time on Dialer</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>&gt;,&lt;</td>
<td>1:00-12:59</td>
<td>AMPM</td>
</tr>
<tr>
<td>Time Remaining</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>&gt;,&lt;</td>
<td>0-1440</td>
<td>minutes</td>
</tr>
<tr>
<td>Total Idle Time</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td>0-1440</td>
<td>minutes</td>
</tr>
<tr>
<td>Total Talk Time</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td>0-1440</td>
<td>minutes</td>
</tr>
<tr>
<td>Total Update Time</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td>0-1440</td>
<td>minutes</td>
</tr>
</tbody>
</table>

Using alerts

In Monitor, you can create, change, or remove an alert.

This section contains the following topics:

- [Create an alert](#) on page 315
- [Edit an alert](#) on page 316
Create an alert

You create alerts in Alerts Viewer, which is available in Monitor.

To create an alert:

1. Select Start > Programs > Avaya > Proactive Contact > Supervisor > Monitor.
2. Select Settings > Alerts. For more information, see Alert Viewer dialog box on page 319.
   If an email configuration wizard appears, either complete it or cancel out of it.
3. In the Alerts Viewer dialog box, click Add.
   The Alert Editor dialog box appears.
4. On the Alert Definition tab, select the condition you want to monitor and complete the conditional statement.
5. On the Scope tab, narrow your alert condition.

   Tip:
   You can skip this tab if you do not want to narrow your alert criteria.
6. On the Notifications tab, select the following options to specify how Avaya Proactive Contact notifies you:
   - Display an alert to open a pop-up alert dialog on your screen.
   - Sound an alert to hear an audible sound.
   - Send e-mail to receive an e-mail with an alert notification.
     If Send e-mail is unavailable, configure your default e-mail client on your computer.
     If Send e-mail is available and you want to receive an e-mail alert notification, type your e-mail address in the To... box.
7. Click OK.
   The alert name and summary information appear in the Alerts Viewer dialog box.

Create E-mail Notification

To create e-mail notification:

1. Set E-mail Server Details (Server name and IP) in Mid-Tier Configurator.
2. To get event related e-mails, go to Email Settings from HealthManager > Tools > Options and mention e-mail address in To (Recipients) and from (Sender) fields.
3. To get Alert e-mails,
Chapter 27: Alerts

1. Go to **AlertViewer**. You can access **AlertViewer** through HealthManger or Monitor application.

2. Click **Add** (If you want to add new alert) or **Edit** (to modify an existing alert) to open the "Alert Editor".

3. On the **Alert Editor** window, go to the **Notification** tab. Select the check box corresponding to the **Send E-mail** option and enter the e-mail address of Sender/Recipient.

4. If your system has McAfee installed, then HealthBridge.exe gets blocked by the port blocking rule. To unblock HealthBridge.exe, perform the following steps:

   5. Right-click on McAfee OAS and open **VirusScan Console**.

   6. Open **Access Protection Properties**.

   7. Select **Anti-virus Standard Protection** in the **Categories** pane.

   8. Select the "**Prevent mass mailing worms from sending mail**" rule.

   9. Click **Edit**. The **Rules Details** window opens. Add "**HealthBridge.exe**" in the **Processes to exclude** section.

      Once you specify these settings, various events, such as dialer processes up/down and alerts as configured in the Alert Viewer, are notified through e-mails.

---

**Edit an alert**

To edit an alert:

1. In Monitor, select **Settings > Alerts**.

   The **Alert Viewer** dialog box appears.

2. Select the alert you want to edit, and then click **Edit**.

   The **Alert Editor** dialog box appears.

3. Use the **Alert Definition**, **Scope**, and **Notifications** tabs to modify the alert.

   For more information, see Alert Editor, Alert Definition tab on page 320, Alert Editor, Scope tab on page 320, and Alert Editor, Notifications tab on page 321.

4. Click **OK**.
Remove an alert

To remove an alert:

1. In Monitor, select Settings > Alerts.
   
   The Alert Viewer dialog box appears. For more information, see Alert Viewer dialog box on page 319.

2. Select the alert you want to delete, and then click Remove.

3. Click Close.

Sending e-mail Alert using Health Manager/Monitor Alerts option

For sending alert e-mails, you must have the e-mail setting configured on your machine.

To set alert e-mails:

1. Set the E-mail Server Details (Server name and IP) in Mid-Tier Configurator.

2. To set event related e-mails:
   a. Login to the Health Manager application.
   b. Click Tools > Options.
   c. Select Email Settings and specify the e-mail address in To (Recipient) and From (Sender) fields.

3. To set Alert e-mails:
   a. Go to Alert Viewer (Accessible through Health Manager or Monitor application).
   b. Click Add (If in case wanted to add new one) or Edit (To modify existing one) to open the "Alert Editor".
   c. In Alert Editor window, go to Notification tab. Select the Send E-mail option and specify the e-mail address of Sender/Recipient.

Antivirus

If you have McAfee installed then HealthBridge.exe is blocked by port blocking rule.

To unblock HealthBridge.exe:

1. Right click McAfee OAS and Open VirusScan Console.


4. Select the rule Prevent mass mailing worms from sending mail.
5. Click the **Edit** option. This will open **Rules Details**. Add **HealthBridge.exe** in the **Processes to exclude** section.

After configuring these settings, various events (for example dialer processes up/down) and alerts (as configured in the Alert Viewer, for example Total Idle Time > 3, Job End, and so on) will be notified through e-mails.

---

**Maintaining alerts**

In Monitor, you can view and modify alerts to inform you about your calling activities.

This section contains the following topics:

- Enable and disable alerts on page 318
- Check the status of each alert on page 318

---

**Enable and disable alerts**

In Alert Viewer, you have the option to disable alerts, which tells Avaya Proactive Contact not to notify you about an alert.

For example: You usually monitor agent Doe everyday because he is a new hire. If agent Doe calls in sick for a day, clear the check box next to the agent Doe alert to disable the alert. When agent Doe returns to work, select the agent Doe alert to reactivate it.

The **Enabled** check box tells you whether or not Avaya Proactive Contact is actively checking the alert’s condition. A check mark indicates that Avaya Proactive Contact is monitoring the condition.

Job Ended, Current Talk Time, and Current Update Time automatically reactivate after their condition is met, but all other alerts require that you re-enable them in Alerts Viewer.

To enable and disable alerts:

1. In Monitor, select **Settings > Alerts**.
2. Select or clear the **Enabled** check box corresponding to the alert.
   - Select the **Enabled** check box to activate monitoring of the alert condition.
   - Clear the **Enabled** check box to deactivate the alert.

---

**Check the status of each alert**

In Alert Viewer, you can check the status of your alerts.
Understanding Alert dialog boxes

- If an alert condition has not been met, its status is **On**.
- If an alert condition has been met, its status is **Off**.

To check the status of each alert:
1. In Monitor, select **Settings > Alerts**.
2. Notice whether the **Status** column has an **On** or **Off** status.

---

Understanding Alert dialog boxes

This section contains the following topics:

- [Alert Viewer dialog box](#) on page 319
- [Alert Editor, Alert Definition tab](#) on page 320
- [Alert Editor, Scope tab](#) on page 320
- [Alert Editor, Notifications tab](#) on page 321

---

Alert Viewer dialog box

You can define up to 10 alerts to provide audio cues, visual cues, log files, e-mails, or pager signals when job or agent performance, system or job status, or line usage varies beyond predetermined levels. This information lets you identify and correct potential problems before they escalate.

The **Alert Viewer** dialog box contains summary information about existing alerts. If you want to edit an alert's settings, click **Edit**. If you want to add an alert, click **Add**.

You can receive alerts only when Monitor is running at the time when the alert's condition is met.

**Enabled** - Indicates if an alert is enabled. If you do not want the system to monitor an alert’s condition, clear the check box located in the **Enabled** field.

Alerts using the Job Ended, Current Talk Time, and Current Update Time conditions automatically re-enable themselves after their condition is met, but for all other alerts, you should manually re-enable them.

**Status** - Displays the current status for each alert. If an alert’s condition has been met, its status is **Off**.

**Condition** - Displays the condition, such as Average Talk Time or Line Utilization, defined for each alert. Click **Edit** to set or change a condition (Alert Editor, Alert Definition tab).
Chapter 27: Alerts

Value - Displays the value associated with the condition for each alert. Click Edit to set or change a condition (Alert Editor, Alert Definition tab).

Scope - Displays the scope settings for each alert. You can narrow the target of an alert by selecting a specific dialer, job, or agent. Narrowing the scope for an alert is optional.

Add - Lets you define a new alert.

Edit - Opens the Alert Editor dialog box in which you set up and change alert settings.

Remove - Removes the selected alert from the list of alerts.

Close - Closes the Alert Viewer dialog box.

Help - Gives information about the Alert Viewer dialog box.

Alert Editor, Alert Definition tab

The Alert Definition tab enables you to create your alert condition statement. Use the Condition list to select the condition you wish to monitor (for example, Current Talk Time). Use the Completion Code, Operator, and Value fields to complete your alert’s conditional statement (for example, >15 minutes). The Completion Code list is available based on the selected condition.

Condition - Lists the available conditions for which you can set an alert to monitor.

Completion Code - Lists completion codes from which you select if your alert condition calls for monitoring a specific completion code.

Operator - Lists available logic operators. A logic operator, such as > (greater than) and < (less than), is used to build your conditional statement.

Value - Identifies the value for the conditional statement. Enter the value that you want the system to test for when evaluating the conditional statement. For example, in this conditional statement: “Current Talk Time > 5 minutes”, the value is 5.

Alert Editor, Scope tab

The Scope tab allows you to make the dialer monitor only a specific parameter. For example, if you only want your alert to track a specific agent, use the Scope tab to specify which agent to monitor.
Dialer - Lists the dialers for which you can set an alert. Select Any Dialer (Avaya Proactive Contact monitors all dialers) or a specific dialer from the list.

Job - Lists the jobs for which you can set an alert. Select Any Job (Avaya Proactive Contact monitors all jobs) or a specific job from the list.

Agent - Lists the agents for whom you can set an alert. Select All Agents (the Avaya Proactive Contact monitors all agents) or a specific agent from the list.

Alert Editor, Notifications tab

The Notifications tab allows you to specify how you want the dialer to alert you. The dialer can alert you only if the Monitor is running at the time when the alert condition is met.

Display alert - Displays a pop-up dialog box on your computer screen to notify you.

Sound alert - Plays an audible sound from your computer to notify you.

Send e-mail - Sends you an e-mail message. If this option is unavailable, open Microsoft Outlook and set it as your default e-mail client. If Send e-mail is available and you want to receive an e-mail notification, type your e-mail address in the To... box.
Chapter 28: Job control functions

Avaya Proactive Contact allows you to adjust job settings while a job is running. You make these adjustments through the Monitor Tools menu. The adjusted settings revert to the default settings when the job ends.

This section contains the following topics:

- Understanding job control functions on page 323
- Using job control functions on page 323
- Maintaining job control functions on page 327

Understanding job control functions

Avaya Proactive Contact allows you to adjust job settings while a job is running. You make these adjustments through the Monitor Tools menu. The adjusted settings expire when the job ends.

Note:

When a job uses the Cruise Control feature, you cannot change the call pacing settings.

Job controls are available from any view that displays a list of jobs, such as the Job Status view or the Job Wait Queue view.

Using job control functions

Job controls are available from any view that displays a list of jobs, such as the Job Status view or the Job Wait Queue view.

This section contains the following topics:

- Stop a job on page 324
- Link to job on page 324
- Set the minimum hit rate on page 326
- Set the Expert Calling Ratio on page 326
Chapter 28: Job control functions

Stop a job

To stop a job:

1. In Monitor, open a view that lists jobs, and then select the job you want to stop.
2. Select Tools > Stop Job.
   
   The Stop Job dialog box appears. For more information, see Stop Job dialog box on page 345.
3. Select one of the following two options:

   | Stop job gracefully as agents complete calls | Allows you to stop a job after the agents complete their current calls. This option allows the agents to end their current calls and release the records. This is the typical method. |
   | Stop job immediately | Allows you to stop a job immediately. Avaya Proactive Contact disconnects all phone conversations and closes the records immediately. As a result, agents cannot finish speaking with a customer or update customer records. |

4. Click OK.
   
   A dialog box with the Are you sure? message appears.
5. Click Yes to stop the job.
6. If the job is linked to another job, a dialog box appears asking you whether you want to shutdown the linked job. If you choose not to shutdown the link job, then in addition, the following prompt is displayed:
   
   Run record selection for link job if it has not been run automatically?
7. Click Yes to remove the job link.

Link to job

Use the Job Link option to identify a job to start automatically when the current job completes. When you link a job, the system transfers agents to the next job as the agents complete their last calls and release the records. The system displays a message specifying that the agents are changing jobs. For rules regarding linking jobs, see Basic settings on page 215.

You can create link to a job in the following ways:

- If you have not yet started a job:
  
  a. Open an Editor view, in Contact Management tab, click Jobs.
b. In the **Job Detail** tab, under **Files** group, click in the **value** column of the **Name of next job to link to** option.

c. Select the next job from the drop-down menu.

d. Click **Save**.

- If a job is already running and you want to add or edit a job link:

  a. Open a Monitor view that lists jobs.

  b. Select a job, and then select **Tools > Job Link**. For more information, see **Job Link dialog box** on page 345.

  c. Select a job, and then click **OK**.

  **Note:**

  It was assumed that the job linking feature would work for campaign share in the same way that it does on a single system, that is, where a series of selections can be run for the linked jobs prior to the starting of the first job. After that, the follow up on jobs would start automatically when the previous job in the link runs out of records and shutdown. During this process, the agents are also automatically moved from one job to the next. However, in a shared campaign, the jobs have to be monitored and the next linked job and selection has to be run manually at the close of the current job.

---

**Set escape recall for a job**

Use the **Escape Recall Job** option to pull in an agent from a different job to address a recall for another job. This functionality is applicable only for Infinite jobs. You can select a running job from which an available agent should attend to the recall that was set for the original job. You can define the job from which the agent should be pulled in using Editor. However, you can change the job in run time using Monitor.

To change the job for addressing recall:

1. In Monitor, open a view that lists jobs, and then select the job you want to stop.

2. Select **Tools > Escape Recall Job**.

3. The **Escape Recall Job** dialog box appears. For more information, see **Escape Recall Job dialog box** on page 345

4. Click **OK**.

   A dialog box with the **Are you sure you want to change this escape recall job?** message appears.

5. Click **Yes**.
Set automatic record selection trigger value for linked job

Use the Autocallsel Trigger option to automatically run the record selection for the next linked job at a configurable percentage completion of the current job. When the system runs the automated record selection, it validates the percentage of records completed until the linked job starts. This ensures that if the percentage of records completed drops below the configured value, then the record selection is re-run once the target is met again.

To change the completion percentage for a job:

1. In Monitor, open a view that lists jobs, and then select the job you want to stop.
2. Select Tools > Autocallsel Trigger.
3. The Record Selection of Linked Job dialog box appears. For more information, see Record Selection of Link Job dialog box on page 346.
4. Click OK.
   A dialog box with the Are you sure you want to change the autocallsel trigger value? message appears.
5. Click Yes.

Set the minimum hit rate

The minimum hit rate prevents Avaya Proactive Contact from allocating more pooled lines to a poorly performing job at the expense of a more successful job.

The minimum hit rate designates the lowest perceived probability of a call attempt that results in a request for an agent. The value of this parameter can reduce the number of call attempts that Avaya Proactive Contact initiates. For example, a job using a minimum hit rate of 30% means the system makes no more than three dialing attempts for each agent.

To set the minimum hit rate:

1. Open a Monitor view that lists jobs.
2. Select a job, and then select Tools > Minimum Hit Rate. For more information, see Minimum Hit Rate dialog box on page 346.
3. Use the slider or type a value from 0 to 100 in increments of 10, and then click OK.

Set the Expert Calling Ratio

Avaya Proactive Contact provides two methods for predicting when to make the next phone call: Cruise Control and Expert Calling Ratio. If the job uses Expert Calling Ratio, you can change the Expert Calling Mode in Monitor. You cannot change the Cruise Control settings.
Expert Calling Ratio changes the way Avaya Proactive Contact predicts when to make the next call. You can select any of the following three ratios:

- Callers in the wait queue
- Agent Work Time
- Agent Update Time

**Tip:**
If you are currently experiencing a high abandonment rate, you may want to lower the percentage. If your agents are experiencing large amounts of idle time, you may want to increase the percentage. This rule is applicable to all of the three ratios.

To set the Expert Calling Ratio:

1. Open a Monitor view that lists jobs.
2. Select a job, and then select **Tools > Expert Calling Ratio**. For more information, see **Expert Calling Ratio dialog box** on page 346.
3. Click the **Expert Calling Mode** field and select either **Callers in the wait queue**, **Agent update time**, or **Agent work time**.
4. Select the **Value** field to enter a value from 0 through 100 in increments of 10, and then click **OK**.

**Tip:**
Wait at least 15 minutes before changing your Expert Calling Ratio again because your changes will not reflect for at least that duration.

---

**Maintaining job control functions**

This section contains the following topics:

- **Adjust Inbound settings** on page 328
- **Modify record selection criteria in real-time** on page 328
- **Reassign lines** on page 330
- **Set a managed dialing job** on page 330
- **Select and sort time zones** on page 330
- **Set up single or multiple unit work lists** on page 331
- **Set and modify a quota** on page 332
- **Set the detection mode** on page 333
Chapter 28: Job control functions

- **Set the alternate initial phone** on page 333
- **Set retries** on page 334
- **Find a text string** on page 334

---

**Adjust Inbound settings**

To adjust your inbound settings:

1. Open a Monitor view that lists jobs.
2. Select an inbound or blend job, and then select **Tools > Inbound Settings**. For more information, see **Inbound Settings dialog box** on page 347.
3. Select the **Value** field to enter settings, and then click **OK**.

---

**Modify record selection criteria in real-time**

Avaya Proactive Contact allows you to modify a selection criterion for a running job in real-time using monitor.

**Note:**
This functionality of changing the record selection criteria in real-time is available only from the monitor. Jobmon does not allow this functionality. Also, this functionality is not applicable for the Inbound and IVR pool jobs.

After specifying the criteria for selecting new set of records, new set of records are selected. If you choose to use the newly selected records, the index file containing the previous records is replaced with the newly selected records.

Note the following before you make the changes to the record selection criteria:

- If the new selection does not have the unit lists that were present in earlier selection, then the agents will stop getting calls for that unit. In that case, the agents will have to logout of that unit and login to a new unit.
- Strategy will be applied afresh to the records being called.
- The new selection will not have recalls set from previous selection; however, the Agent owned recalls will be retained. You will need to update the selection at run-time to specifically select the recalls set prior to the new selection made.
- The new criteria is applied over the base call selection criteria. If the base call selection criteria is modified again, then the new criteria is applied on the new base call selection criteria. If you change the calling list in the base call selection criteria, then it will not have an impact on the new criteria.
When you define a new real-time call selection criteria by using the **Edit the callsel** option, then the previously configured real-time call selection is considered as the base for new configuration.

Before loading the new index, you can choose to maintain current value of hit rate/cruise control parameters or reset it to the values mentioned in the job.

Note that the changes made to the selection criteria are only the run time changes and not the permanent ones. Therefore, in case of fresh downloads the changes made at run time are not applicable and the selection criteria in the selection file is used.

The reports are updated to reflect the calls made as per old selection file as well as new selection file. For example, in jobmon, the "records selected" field is updated to display newly selected records along with the phone calls already made from the previous selection.

To modify the record selection criteria in real-time:

1. Open a Monitor view that lists running jobs.
2. Perform any or all of the following as required:
   1. To modify the record selection, select a job, and then select **Tools > Selection Records**. For more information, see _Selection Records dialog box_ on page 352. A check mark indicates that the selection is in use.
   2. To modify the selection results criteria, select a job, and then select **Tools > Selection Results**. For more information, see _Selection Results dialog box_ on page 352.
   3. To modify the sorting criteria for records, select a job, and then select **Tools > Selection Sort**. For more information, see _Selection Sort dialog box_ on page 352
3. Click **OK** to confirm the selection parameters. The **Results** window displays the details of the records.
4. To apply the new selection criteria, click **Use this selection** option.
5. To use the previously defined hit rate, select the **Revert Current Hit Rate to original value** check box. Otherwise, clear the check box.
6. Click **OK** to confirm the changes made to the record selection criteria. Click **Cancel** to cancel the modifications.
7. If you want to make modification to the selection criteria, select **Edit this selection** option.
8. Select the required option: **Records**, **Results**, or **Sort**.
9. Click **OK** to go to the corresponding dialog box for making modifications.
10. After making the required modifications in the corresponding dialog box, click **OK**. The **Results** window displays the details of the records.
11. Click **OK** to confirm the changes. Click **Cancel** to cancel the modifications.
Reassign lines

When you reassign lines, you alleviate congestion on certain Avaya Proactive Contact lines so that your jobs run more quickly.

To reassign lines:

1. Open a Monitor view that lists running jobs.
2. Select a job, and then select **Tools > Lines**. For more information, see Lines dialog box on page 351. A check mark indicates that the line group is in use.
3. To use line groups, complete one of the following actions:
   - Select the appropriate check box.
   - Click the **Activate All** button to select all of the line groups.
   - Click the **Deactivate All** button to clear all of the line groups.
4. Click **OK**.

Set a managed dialing job

Managed dialing jobs allow agents to preview a customer's record prior to beginning the conversation with the customer. For more information on Managed Dialing settings, see Managed Dialing settings on page 224.

To set the managed dialing job:

1. Open a Monitor view that lists jobs.
2. Select a Managed Dialing job from the list, and then select **Tools > Managed Dialing**. For more information, see Managed Dialing dialog box on page 347.
3. To modify agents' preview time, enter a different value in the **Time Limit** box.
4. Select **Allow agent to cancel calls** check box to immediately allow agents to cancel calls.
5. Click **OK**.

Select and sort time zones

To select time zones and sort calls by time zones:

1. Open a Monitor view that lists jobs.
2. Select a job, and then select **Tools > Time Zones**. For more information, see Time Zones dialog box on page 348.
3. Select the **Call records in order by time zone** check box to sort calls by time zones.
4. To place calls to a time zone, complete one of the following actions:
   - Select the time zone fields where you want to place calls.
   - Clear the time zone fields where you do not want to place calls.
   - Click **Activate All** to select all time zones.
   - Click **Deactivate All** to clear all time zones.

5. Click **OK**.

---

**Set up single or multiple unit work lists**

A unit work list creates a sub-list in a job so that certain agents can be assigned to a unit work list and, therefore, receive only certain calls.

For example: A job calls potential customers to set up appointments with sales people. You can enable the unit work list named sales group for the job. As the dialer places phone calls, agents make appointments for sales people in the sales group. When the sales people's schedules are full, the dialer stops placing calls for appointments.

Agent can select single or multiple units at the time of logging in to a job. Previously, agents were allowed to select all unit work list jobs or only one unit work list job at a time. Now, agents can select multiple unit work lists and can be made available equally across number of units selected. For example, if an agent logs into 10 units, the availability of that agent across each unit will be 10%, which means that out of 10 calls taken by that agent, there will be one call from each of the 10 units to which the agent is logged in.

If all the calls are finished in one of the units, agent's availability is spread to the remaining units. For example, if an agent logs into three units, the availability will be 33% across each unit. If all the calls are finished in one of the units, the agent will be available 50% across remaining two units. The availability of an agent across units will also be valid in case the unit has only recalls left and the rest of the calls are finished. As a result, agents will not have to wait for recall to happen and will have more availability in other units.

You can enable a unit work list for the job before you start the job. During the job, you can enable or disable units. When the job completes the unit work list, the system stops the job.

By default, this option is disabled. To enable the option set the MULTI_UNIT_ACCESS parameter in master.cfg to YES.

**Note:**
When you set unit work lists to run on a blend job, the system must be set to allocate all agents to the units. The "LOGONUNIT: Require unit ID for agent login" parameter in the job file must be set to NO. This rule is enforced in the code because the system cannot easily identify which agent to shift to inbound because of the small pool of agents assigned to each unit. This can result in nuisance calls. Alternatively, you can use agent blending, which allows the agents to logon to campaigns by units. This solution works, but is not as efficient as an outbound only campaign without agent blending.
Chapter 28: Job control functions

The Unit work list functionality is also available with the infinite type of Job; however, because infinite job can download new units, Unit work List functionality is restricted with the infinite job. You can, however, define the expandable units within the system. This will allow the job to manage memory segment for extra downloaded units. To use Unit work list with Infinite jobs, set the MAX_EXPANSION_UNIT parameter in the master.cfg to a maximum of 50 units.

Agent will have to log back to choose the newly downloaded units in infinite job.

To set up a unit work list:

1. Open a Monitor view that lists jobs.
2. Select a job, and then select Tools > Unit Work Lists. For more information, see Unit Work Lists dialog box on page 349.
3. To change a work list ID, complete one of the following actions:
   - Select the Unit ID names that you want to use.
   - Clear the Unit ID names that you do not want to use.
   - Click Activate All to select all Unit ID names.
   - Click Deactivate All to clear Unit ID names.
4. Click OK.

Set and modify a quota

Avaya Proactive Contact uses quota to complete a specified number of outbound calls based on a selected outcome.

A quota is a maximum number of releases for a particular completion code. When the system reaches the quota for a completion code, the dialer stops placing phone calls and the system stops the job.

In Editor, you set and modify a quota that the system applies when the job starts.
In Monitor, you set and modify a quota that affects the current job while the job runs.

To understand how Avaya Proactive Contact uses quotas, you should check when a job stops. For more information on when a job stops, see When a job stops on page 210.

To change the quota value during calling activities:

1. Start Monitor.
2. Select a job, and then select Tools > Quotas. The Quota dialog box appears. For more information, see Quota dialog box on page 349.
3. Select the Unit ID field and type a Unit ID.
4. Select the Completion Code field to select a completion code.
5. Select the Quota field to enter a number greater than 0.
6. Click **OK**.

---

### Set the detection mode

Use the Detection Mode option to determine the types of calls Avaya Proactive Contact passes to agents. For more information on detection modes, see Phone strategy settings on page 180.

To set the detection mode:

1. Open a Monitor view that lists jobs.
2. Select a job, and then select **Tools > Detection Modes**. For more information, see Detection Modes dialog box on page 350.
3. Click the **Phone** field to select a phone.
4. Select the **Rings** field to enter a different number of rings.
5. Select the **Pass to Agents** field to select the type of connections to pass on to an agent.
6. To add a phone, click **Add Phone** and repeat Steps 3 and 4 to edit the fields.
7. To remove a phone, select the phone you want to delete, click **Remove Phone**, and then click **OK**.

---

### Set the alternate initial phone

The alternate initial phone replaces the initial phone as the first phone number to call at a particular time of day. The system begins to call the alternate initial phone number at the time you specify in the alternate initial phone settings. For more information, see Phone strategy settings on page 180.

To set the alternate initial phone:

1. Open a Monitor view that lists jobs.
2. Select a job, and then select **Tools > Alternate Initial**. For more information, see Alternate Initial Phones dialog box on page 350.
3. Click **Add Phone** to append a row, and then configure the new alternate initial phone’s settings.
4. Click the **Phone** field to select a phone.
5. Click the **Local Time** field to edit the time. To toggle between AM and PM, select it, and then use the up and down arrows.
6. Click the **Time Zones** field, and then click the button to display the list of time zones. Select the time zones you want to call.
7. Click **OK**.

To remove a phone, select the phone you want to remove, and then click **Remove Phone**.

---

### Set retries

Use the retries setting to determine how long Avaya Proactive Contact waits before retrying a number, how many times it retries the same phone number, and which phone it calls next.

To set retries:

1. Open a Monitor view that lists jobs.
2. Select a job, and then select **Tools > Retries**. For more information, see *Retry dialog box* on page 351.
3. Select the various fields in the **Retry** dialog box to edit the retries currently configured.

   The **Result** column indicates the calling result of the call. The **Retry Interval** values are displayed in minutes.

4. To change a retry, select the appropriate row, then complete one of the following actions:
   - Click **Add Retry** to insert a row where you can edit a new retry.
   - Click **Remove Retry** to delete a retry.
5. Click **OK**.

---

### Find a text string

To search for a text string in a view:

1. Open a Monitor view that lists jobs.
2. Select a job, and then select **Tools > Find**. For more information, see *Find dialog box* on page 343.
3. Enter the text string of the item you want to find in the current view.
4. To refine your search, select one or both of the following check boxes:
   - **Match case**
   - **Find whole words only**
5. Click **Find Next** to continue the search.
6. Click **OK** to end the search.
Chapter 29: Agent control functions

During calling activities, you can use Monitor to find one or more agents and take an action for that agent.

This section contains the following topics:

- Understanding agent control functions on page 335
- Using agent control functions on page 336

Understanding agent control functions

During calling activities, you can use Monitor to find one or more agents and take the following actions to manage agents:

- Transfer one or more agents to another job
- Send a message to one or more agents
- Monitor an agent line
- Remove an agent from a job

Before performing any of these tasks, you must first find an agent.

This section contains the following topics to help you in finding agents:

- Hierarchies on page 335
- Using wildcard characters on page 336

Hierarchies

You can find agents in several ways. If you know the exact agent login, you can search for a single agent.

Use the following hierarchy groups to search for a single agent or a group of agents.

Job - Search all agents in a job.

Supervisor - Search all agents reporting to a supervisor.

Dialer - Search all agents on a dialer.
Using wildcard characters

In addition to finding a single agent, you can use wildcard characters to search for multiple agents.

The following table lists the common wildcard characters that you can use to find more than one agent:

<table>
<thead>
<tr>
<th>Wildcard character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>*</td>
<td>Search for all agents. Use also for multiple agents with identical characters. For example, *smith will find all agents with anything containing the letters smith.</td>
</tr>
<tr>
<td>?</td>
<td>Search for a single character within an agent login.</td>
</tr>
</tbody>
</table>

Using agent control functions

After you find one or more agents, you can use the Monitor agent control functions to take the following actions to manage agents:

- Transfer one or more agents to another job
- Send a message to one or more agents
- Monitor an agent line
- Remove an agent from a job

This section contains the following topics to help you manage agents during a job:

- Find an agent on page 337
- Transfer an agent to another job on page 337
- Send message to an agent on page 337
- Monitor agent line on page 338
- Remove an agent from a job on page 338
- Show an agent view on page 339
Find an agent

To find an agent:

1. On the Monitor button bar, click Agent, and then click Find Agent.

   The Find Agent view appears. For more information, see Find Agent dialog box on page 353.

2. Type the name of an agent or use wildcard characters to select multiple agents.

3. Use the Dialer, Job, and Supervisor drop-down lists to select a hierarchy to filter the information.

4. Click Find.

   Agent names appear in the lower section of the Find Agent view.

Transfer an agent to another job

To transfer an agent to another job:

1. On the Monitor button bar, click Agent, and then click Find Agent.

2. Select one or more agents in the Find Agent dialog box. For more information, see Find Agent dialog box on page 353.

3. Right-click and select Transfer Agent.

   A list of currently running jobs appears.

4. Select the job to which you want to transfer the agent, and then click OK.

   Tip:
   You may not see the agent transfer immediately. Factors, such as agent talk time and update time, may affect the agent transfer duration.

Send message to an agent

To send a message to an agent:

1. On the Monitor button bar, click Agent, and then click Find Agent.

2. Select one or more agents in the Find Agent dialog box. For more information, see Find Agent dialog box on page 353.

3. Right-click and select Send Message.

   The Send Message dialog box appears.
4. Type the message to send to an agent, and then click OK.

Monitor agent line

**Note:**
This feature is not available for the softdialer because the switching for the monitoring is done inside the PG230.

To monitor an agent line on Avaya Proactive Contact:

1. On the Monitor button bar, click **Agent**, and then click **Find Agent**.
2. Select the agent in the **Find Agent** dialog box. For more information, see Find Agent dialog box on page 353.
3. Right-click and select **Monitor Agent**.
   
   A dialog box appears.
4. Enter the headset ID number, and then click **OK**. An icon along with the name of the agent that you are monitoring appears on the right corner of the screen. To stop monitoring or to reconnect to the agent for monitoring, right-click the icon and select **Stop** or **Connect** options.

When you begin monitoring agents on a dialer, you get a dialback on your phone extension only for the first agent. The system uses the same connection for the duration of your login session, therefore, you do not receive a dialback for the subsequent agents that you choose to monitor. This functionality helps you save time when you switch between multiple agents as now you do not get a dialback for each monitoring instance.

**Note:**
If you use the **Connect** option or if you switch between dialers to monitor agents, then you will receive the dialback on your extension for each switch, but only for the first agent from the switched dialer.

In case, you disconnect the phone line during or after agent monitoring, then:

- If you want to monitor the same agent, right-click the icon on the right corner and click **Resume > Connect**.
- If you want to monitor another agent, select the agent > right-click and select **Monitor Agent > click Connect**.

Remove an agent from a job

You can remove an agent from a job in emergencies when the agent cannot use a normal disconnect method.
**Remove Agent** immediately removes the agent from the job and logs the agent out of Avaya Proactive Contact.

To immediately disconnect an agent from a call:

1. On the Monitor button bar, click **Agent**, and then click **Find Agent**.
2. Select one or more agents in the **Find Agent** dialog box. For more information, see **Find Agent dialog box** on page 353.
3. Right-click and select **Remove Agent**.
   A dialog box appears.
4. Click **OK**.

---

**Show an agent view**

After you find an agent, you can display an agent view for a selected agent.

To display an agent view for a selected agent:

1. On the Monitor button bar, click **Agent**, and then click **Find Agent**.
2. Select an agent in the **Find Agent** dialog box. For more information, see **Find Agent dialog box** on page 353.
3. Right-click and select one of the following views: **Agent Detail**, **Agent Completion Codes**, or **Agent History**.
4. Click **OK**.
   The selected view for the selected agent appears.
Chapter 30: Understanding Monitor dialog boxes

This section contains the following topics that describe the dialog boxes that you use in Monitor:

- View control dialog boxes on page 341
- Job control dialog boxes on page 344
- Agent control dialog boxes on page 352

View control dialog boxes

This section contains the following topics:

- Options dialog box on page 341
- Customize Status Bar dialog box on page 343
- Find dialog box on page 343
- Filter Data dialog box on page 344

Options dialog box

In Monitor, the Options dialog box is available from the Settings menu.

This section contains the following topics:

- Options, Scope tab on page 341
- Options, Multi-Dialer Control tab on page 342
- Options, Agent States tab on page 342
- Options, Appearance tab on page 342
- Options, Feedback tab on page 343
- Options, Alerts tab on page 343

Options, Scope tab

The Scope tab allows you to set your preferences for data display and time range.
How should data be arranged - Select a hierarchy by using the following drop-down lists:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent/supervisor hierarchy</td>
<td>Sets the default hierarchy when you select <strong>Agent/supervisor hierarchy</strong> in any view. Data is arranged according to dialers, jobs, and supervisors and the agents assigned to supervisors according to the selected default agent/supervisor hierarchy.</td>
</tr>
<tr>
<td>Custom hierarchy</td>
<td>Sets the default hierarchy when you select <strong>Custom hierarchy</strong> in any view. Data is arranged based on the three levels defined in a hierarchy that has been set up in the Hierarchy Manager tool.</td>
</tr>
</tbody>
</table>

What time range should views support?

Gives you the option to select **Show data for all jobs run since the last dialer restart, if applicable**.

Options, Multi-Dialer Control tab

The **Multi-Dialer Control** tab allows you to choose the available dialers that you want to include in your view.

**Apply job changes to all selected dialers** - Allows you to select all dialers to appear in the Monitor views.

**Dialers** - Lists individual dialers that you can select to include in the Monitor views.

Options, Agent States tab

This tab allows you to select the agents states to be displayed.

**Display agents with these states** - Allows you to select the states to be displayed in the Monitor views.

Options, Appearance tab

The **Appearance** tab allows you to select a particular view to be used as the appearance for future views and also allows you to set the refresh rate for all views.

**Use this view set** - Allows you to select a default view set to use in Monitor.

**Default refresh rate** - Allows you to specify the number of seconds to wait between each data refresh.
**Options, Feedback tab**

You can choose how the changes to the views and view sets are saved when the application closes. The options are: always save, prompt to save changes, or do not save.

- **When a view closes** - Lists the save options to apply when a view closes.
- **When the application closes** - Lists the save options to apply when Monitor closes.
- **When a command is initiated** - Lists the save options to apply when a command is initiated.

**Options, Alerts tab**

The **Alerts** tab allows you to automatically start the alert monitoring feature and disable e-mail notifications.

---

**Customize Status Bar dialog box**

Use the **Customize Status Bar** dialog box to choose the information you want to see in the Monitor status bar.

- **Available status panels** - Lists the different options in which you can display Monitor in the status bar.

---

**Find dialog box**

Use the **Find** dialog box to search for an item in a view. For example, in a view that lists more agents than you can view on the screen, you can quickly locate a specific agent.

- **Find what** - Type what you want to search for.
- **Match case** - Select **Match case** if you want Monitor to search for items that exactly match the case (upper or lower) that you type. For example, if you type 'Chris' and select **Match case**, Monitor does not include 'chris' in the find results.
- **Find whole words only** - Select **Find whole words only** to force Monitor to conduct a literal search based on what you type. For example, if you type 'chris' and select **Find whole words only**, Monitor includes only 'chris' as a valid search result. Christy, christine, and christopher, for example, would not be valid search results.
Chapter 30: Understanding Monitor dialog boxes

Filter Data dialog box

The Filter Data dialog box allows you to filter the amount of data you see in a view based on a data field contained in the view. For example, in the Dialer History view, you can filter data based on the Status column. The filter statement, "Status Is Finished", causes Monitor to display job data for the completed job instances only. Currently running instances of the jobs are not included in the view.

**Column** - Lists the column headings of the selected view.

**Operator** - Lists the available operators (Is, Is Not, Is Less Than, and Is Greater Than).

**Value** - Lists the available values based on the selected column.

Job control dialog boxes

This section contains the following topics:

- [Stop Job dialog box](#) on page 345
- [Job Link dialog box](#) on page 345
- [Escape Recall Job dialog box](#) on page 345
- [Record Selection of Link Job dialog box](#) on page 346
- [Minimum Hit Rate dialog box](#) on page 346
- [Expert Calling Ratio dialog box](#) on page 346
- [Inbound Settings dialog box](#) on page 347
- [Managed Dialing dialog box](#) on page 347
- [Time Zones dialog box](#) on page 348
- [Unit Work Lists dialog box](#) on page 349
- [Quota dialog box](#) on page 349
- [Alternate Initial Phones dialog box](#) on page 350
- [Detection Modes dialog box](#) on page 350
- [Retry dialog box](#) on page 351
- [Lines dialog box](#) on page 351
- [Selection Records dialog box](#) on page 352
- [Selection Results dialog box](#) on page 352
Stop Job dialog box

The Stop Job dialog box allows you to stop a job.

**Stop job gracefully as agents complete calls** - Allows you to stop a job after the agents complete their current calls. This option allows the agents to end their current calls and release the records.

**Stop job immediately** - Allows you to stop a job immediately. The system disconnects all phone conversations and closes the records immediately. As a result, agents cannot finish speaking with a customer or update customer records.

**Apply changes to all dialers under multi-dialer control** - Available only when multi-dialer control is enabled. Allows you to stop a job with the same name on more than one dialer.

Job Link dialog box

The Job Link dialog box allows you to connect jobs so that a new job automatically begins when one job ends.

When you link a job, the system transfers each agent to the next job after the agent completes the last call and releases the record. The system displays a message telling the agents that they are changing jobs.

**Current link** - Identifies the job currently scheduled to start when the current job ends.

**New link** - Lists the jobs to which the current job can link.

**Apply changes to all dialers under multi-dialer control** - Available only when multi-dialer control is enabled. Allows you to change the job link for the same job on multiple dialers.

Escape Recall Job dialog box

The Escape Recall Job dialog box allows you to change the job from which you want to pull the agent to address the recalls in run time.

**Current Job** - Displays the name of the job that has been selected for addressing the recall.
**Chapter 30: Understanding Monitor dialog boxes**

**New Job** - Displays the list of currently running jobs from which the agents can be pulled in for addressing the recall. Note that selecting a blank turns off the Escape Recall functionality.

**Apply changes to all dialers under multi-dialer control** - Available only when multi-dialer control is enabled. Allows you to change the job link for the same job on multiple dialers.

---

**Record Selection of Link Job dialog box**

The **Record Selection of Link Job** dialog box allows you to change the percentage completion value of a job before the linked job is started.

**Run early** - Use the scroll bar to set the job completion percentage.

**Value** - Alternatively, use the **Value** combo-box to set the job completion percentage using either the arrow keys or by putting the value manually.

**Apply changes to all dialers under multi-dialer control** - Available only when multi-dialer control is enabled. Allows you to change the completion percentage for a job with the same name on more than one dialer.

---

**Minimum Hit Rate dialog box**

Minimum hit rate prevents the dialer from allocating more lines to a poorly performing job at the expense of a more successful job. For example, a minimum hit rate of 30% means the dialer will make no more than three dialing attempts for each agent.

**Value** - The minimum hit rate determines the maximum number of calls the dialer will make as it attempts to make an agent connection. Enter a value from 0 through 100 in the increments of 10, or use the slider bar to set a minimum hit rate value. A typical setting is 30.

**Apply changes to all dialers under multi-dialer control** - Available only when multi-dialer control is enabled. Allows you to change the minimum hit rate for the same job on multiple dialers.

---

**Expert Calling Ratio dialog box**

The **Expert Calling Ratio** affects the wait queue and the calling pace. The dialer achieves a balance between agents waiting for a call and customers placed in the wait queue.
**Expert Calling Mode** - Identifies the current mode (Calls in the wait queue, Agent Work Time, or Agent Update Time) with which the dialer calculates the Expert Calling ratio. Select a different option in this field to change the mode.

**Value** - Displays the current Expert Calling ratio value. Type a percent value from 1 through 100 to change the Expert Calling ratio.

**Apply changes to all dialers under multi-dialer control** - Available only when multi-dialer control is enabled. Allows you to change the Expert Calling ratio for the same job on multiple dialers.

---

**Inbound Settings dialog box**

Inbound settings control the way the dialer transfers blend agents between inbound and outbound calling activities.

**Reassign agents to inbound** - Determines the maximum time a call can be in the wait queue before the system transfers a blend agent to take inbound calls. Decrease the agent wait time if you want to emphasize call center productivity. The **Percentage of clients waiting exceeds** setting overrides the **Client wait exceeds** setting.

For **Client wait exceeds**, type a maximum amount of time, in seconds, from 0 to 999 for which a call can be in the wait queue before the system transfers a blend agent to take inbound calls.

For **Percentage of clients waiting exceeds**, type a number from 100 to 200 to represent the maximum percentage of calls to be in the wait queue. The dialer compares the number of wait queue calls to the number of inbound and blend agents. For example, two blend agents and three inbound agents are on a job. If the **Percentage of clients waiting exceeds** value is 100, five calls (100% of combined inbound and blend agents) must be in the wait queue before the system moves a blend agent to take inbound calls.

**Reassign agents to outbound** - Allows you to set a maximum time, in seconds, for which a blend agent taking inbound calls can remain idle before the system transfers an agent to take outbound calls. The recommended time duration is 20 seconds.

**Apply changes to all dialers under multi-dialer control** - Available only when multi-dialer control is enabled. Allows you to change the inbound settings for the same job on multiple dialers.

---

**Managed Dialing dialog box**

The **Managed Dialing** dialog box allows you to change managed job preferences.
Chapter 30: Understanding Monitor dialog boxes

**Preview length** - Sets the time for which an agent can preview a record before the dialer dials the number. Enter a value (in seconds) from 1 to 999 in the **Time limit** field. Select **No limit** to set an unlimited amount of preview time.

**Allow agents to cancel call** - Allows you to choose whether agents can cancel a Managed Dialing call.

**Apply changes to all dialers under multi-dialer control** - Available only when multi-dialer control is enabled. Allows you to change the Managed Dialing settings for the same job on multiple dialers.

---

**Time Zones dialog box**

Select the time zones you want to call.

**Call records in order by time zone** - Allows you to make the dialer attempt to call all records in one time zone before moving to the next time zone. If you clear this option, the system attempts calls across all selected and available time zones.

**Time Zone** - Lists all the time zones. Selected time zones are highlighted by a check mark.

**Start Time** - Recommended start time for each time zone.

**Stop Time** - Recommended stop time for each time zone.

**Records** - The total number of records selected for calling in each time zone.

**Available** - The current number of records that are eligible to be called at the current time for each time zone.

**Recalls** - The current number of records set for recall in each time zone.

**Active totals** - Displays totals for the Records, Available, and Recalls columns.

**Apply changes to all dialers under multi-dialer control** - Available only when multi-dialer control is enabled. Allows you to change the time zone settings for the same job on multiple dialers.

**Activate All** - Selects all the time zones.

**Deactivate All** - Clears all the time zones.
Unit Work Lists dialog box

If you want a job to have a sub-area so that certain agents can log into a special area and work with certain customers, you can set up a Unit Work List for a job.

**Unit ID** - Lists all available Unit IDs. Selected units are highlighted by a check mark. An Allid Unit ID indicates that the job is not set up for Unit Work Lists.

**Records** - The total number of records selected for each Unit ID.

**Available** - The current number of records that are eligible to be called for each Unit ID.

**Recalls** - The current number of records set for recall for each Unit ID.

**Totals** - Displays totals for the Records, Available, and Recalls columns.

**Apply changes to all dialers under multi-dialer control** - Available only when multi-dialer control is enabled. Allows you to change the Unit Work List settings for the same job on multiple dialers.

**Activate All** - Selects all the unit IDs.

**Deactivate All** - Clears all the unit IDs.

Quota dialog box

A quota is a maximum number of releases defined for a particular completion code. When the quota for a unit is reached, no more records are dialed.

**Unit ID** - Lists all Unit IDs. For non-Unit Work List jobs, Allid is the only Unit ID.

**Completion Code** - Identifies the selected completion code to track.

**Quota** - Displays the quota limit for the selected completion code. Enter a number greater than 0.

**Apply changes to all dialers under multi-dialer control** - Available only when multi-dialer control is enabled. Allows you to change the quota settings for the same job on multiple dialers.
Alternate Initial Phones dialog box

The alternate initial phone replaces the initial phone as the first phone number to call at a particular time of day.

**Phone** - Select the phone to be used as the alternate initial phone.

**Local Time** - Displays the time that the system starts calling the alternate initial phone based on the local time in the selected time zone. Enter the time of day to switch to the alternate phone.

**Time Zones** - Lists the selected time zones for the selected alternate phone.

**Add Phone** - Adds a row for a new alternate initial phone.

**Remove Phone** - Removes the selected alternate initial phone.

**Apply changes to all dialers under multi-dialer control** - Available only when multi-dialer control is enabled. Allows you to change the alternate initial phone settings for the same job on multiple dialers.

Detection Modes dialog box

Detection Mode refers to the types of calls you want the system to pass to agents.

**Phone** - Identifies the phone field to which the system applies the detection modes settings.

**Rings** - Displays the number of rings to allow before the system records a NOANSWER completion code.

**Pass to Agent** - Lists the call detection modes that you can choose to pass to agents. For example, you might select Human Voice and Answering Machine as the types of calls that agents should handle.

**Apply changes to all dialers under multi-dialer control** - Available only when multi-dialer control is enabled. Allows you to change the detection modes settings for the same job on multiple dialers.

**Add Phone** - Adds a new row to define detection modes settings for another phone.

**Remove Phone** - Removes the selected phone and detection modes settings.
Retry dialog box

Retry settings specify how the system should handle the system-set retries.

**Call This Phone** - Lists phones for which recall settings are currently active.

**Result** - Defines the call result for which the system attempts retries.

**Retry Interval** - Defines the number of minutes between retry attempts.

**Attempts** - Defines the maximum number of call attempts that the system places for each result.

**Next Phone** - Defines the next phone that the system calls when it has completed the defined number of attempts.

**Apply changes to all dialers under multi-dialer control** - Available only when multi-dialer control is enabled. Allows you to change the retry settings for the same job on multiple dialers.

**Add Retry** - Adds a new row to set up new retry parameters.

**Remove Retry** - Removes a selected row from the Retry dialog box.

Lines dialog box

Reassign lines when you feel that certain jobs could use more lines and certain jobs do not need as many lines.

**Line Group** - Lists the line groups set up for the system. Active line groups are highlighted by a check mark.

**Type** - Identifies the type of lines, such as outbound or inbound, in each line group.

**Apply changes to all dialers under multi-dialer control** - Available only when multi-dialer control is enabled. Allows you to change the line assignments for the same job on multiple dialers.

**Activate All** - Selects all line groups for the job.

**Deactivate All** - Clears all line groups from the job.
Selection Records dialog box

Use the Selection Records dialog box to define your record selection statement in real-time.

**Field** - Use the drop-down list to select a field (for example, BALANCE) to be used for record selection. The field values are the fields as defined in the calling lists in Editor.

**Value** - Enter a value. For example, >3000

**Logic** - Use this field to create a multi-line logic statement. Click the Logic field to use the drop-down list to select And or Or.

Selection Results dialog box

Use the Selection Results dialog box to define the completion codes for the new record selection in real-time.

**Previous Results** - Select the Completion codes that you want to include for the selection.

**Description** - Description of the completion codes.

Selection Sort dialog box

Use the Selection Sort dialog box to sort the records as per priority, field, and order.

**Priority** - Assign the priority for sorting the records in the selection.

**Sort record by** - Select the field by which you want to sort the selected records.

**Order** - Select the order in which the records should be sorted - Ascending or descending.

Agent control dialog boxes

This section contains the following topics:

- **Find Agent dialog box** on page 353
- **Transfer Agent dialog box** on page 354
Find Agent dialog box

The **Find Agent** dialog box allows you to search for one or more agents. You can then do the following:

- Send selected agents a message
- Remove the selected agents from a job
- Transfer the selected agents to another job
- Monitor the selected agents

**Name** - Enter the name of an agent or use wildcard characters to select multiple agents.

**Dialer, Supervisor, Job** - Use hierarchies to filter information based on dialer, job, or supervisor (if supervisor hierarchy is set up).

**Send a message to agents** icon - Sending instant messages lets you communicate directly with agents. Agents see your messages through their Proactive Contact Agent screen. Agents can receive these instant messages even when they are on a call with a customer.

After finding an agent, click the **Send Message** button.

**Remove agent** icon - Lets you end an agent’s session on a job. Use this option only for emergencies when the agent cannot use a normal disconnect. The agent is immediately removed from the job and logged out of the Avaya Proactive Contact.

After finding an agent, click the **Remove Agent** button.

**Transfer agent** icon - Lets you place an agent on a different calling job.

After finding an agent, click the **Transfer Agent** button.

**Monitor agent** icon - Lets you listen to an agent’s conversation with a customer.

After finding an agent, click the **Monitor Agent** button.

**Show an agent view** icon - Lets you choose to display the Agent Detail view, Agent Completion Codes view, or Agent History view for the selected agent(s).

After finding an agent, click the **Agent Detail** button.
Chapter 30: Understanding Monitor dialog boxes

Transfer Agent dialog box

Select a job to which the dialer will transfer the agent.

Available Jobs - Lists the jobs to which you can transfer an agent.

Send Message dialog box

Allows you to type the message you want to send to agents.

Message text - Type a message that you want to send to the selected agents.

Monitor Agent dialog box

The Monitor Agent dialog box settings allow you to listen to the selected agent’s conversation with a customer.

Headset ID - Allows you to specify your headset ID to allow you to listen to an agent’s conversation.

After finding an agent, click the Monitor Agent button.
Chapter 31: Avaya Proactive Contact Analyst

Avaya Proactive Contact Analyst generates call management reports with the job, agent, and system details based on Avaya Proactive Contact activity.

This section contains the following topics:

- Understanding Analyst on page 355
- Using Analyst on page 356

Understanding Analyst

Analyst provides reports containing statistical information that you can use to evaluate the effectiveness of your jobs. For example, reports can show:

- How agents spend their time.
- Which completion codes are most frequently used.
- The amount of time a particular job ran.
- The hierarchy of managers and agents.

In Analyst, reports are grouped into seven categories:

- Agent
- Job
- Time of Day
- Administrative
- Agent Monthly
- Job Monthly
- Time of Day Monthly

For each category, Analyst provides several reports. For example, the Agent category includes reports about agent activity, performance summary, and completion code summary. For each report, Analyst provides several variations or configurations. The different configurations sort, group, and filter data differently.

In Analyst, report categories appear on the button bar in the left pane. For each category, the reports are listed. When you select a report, the report configurations appear in the right pane.

The right pane displays the following five columns:

- Title
Chapter 31: Avaya Proactive Contact Analyst

- Group 1
- Group 2
- Group 3
- Criteria

The last four columns display the options that were selected for the report configuration. There are many configurations for each report. You might compare the configurations to find one that most accurately meets your needs.

The main pane also provides the option of creating a new report or changing the filter settings of an existing report. You can use these features to create customized report configurations. After you create and save a configuration, the saved configuration appears with the existing configurations for that report.

You can use the Schedule feature to instruct Analyst to automatically generate reports from a specific configuration at a specific time. When you set up a report schedule, you specify the exact time when the report is sent for printing by the system.

---

Using Analyst

This section describes the tasks you can perform using Avaya Proactive Contact Analyst.

**Note:**
Please refer to [Chapter 3: Permissions in Role Editor](#) on page 41 for permissions related to Analyst.

This section contains the following topics:

- [Using the Analyst Toolbar](#) on page 357
- Creating a new report configuration on page 358
- Deleting a report configuration on page 360
- Changing a report configuration on page 360
- Previewing a report on page 361
- Printing a report on page 361
- Exporting report data on page 362
- Scheduling a report on page 363
## Using the Analyst Toolbar

The following table contains information about the Analyst toolbar options and their description.

<table>
<thead>
<tr>
<th>Name</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td><img src="folder.png" alt="Folder" /></td>
<td>Create a new report configuration.</td>
</tr>
<tr>
<td>Change</td>
<td><img src="folder.png" alt="Folder" /></td>
<td>Open an existing report configuration for modification.</td>
</tr>
<tr>
<td>Delete</td>
<td><img src="trash.png" alt="Trash" /></td>
<td>Delete a report configuration.</td>
</tr>
<tr>
<td>Preview</td>
<td><img src="screen.png" alt="Screen" /></td>
<td>Preview a report.</td>
</tr>
<tr>
<td>Print</td>
<td><img src="print.png" alt="Print" /></td>
<td>Print the report.</td>
</tr>
<tr>
<td>Scheduler</td>
<td><img src="clock.png" alt="Clock" /></td>
<td>Schedule the printing frequency for a report.</td>
</tr>
<tr>
<td>Hierarchy Manager</td>
<td><img src="hierarchy.png" alt="Hierarchy" /></td>
<td>Launch Hierarchy manager window.</td>
</tr>
<tr>
<td>System Telnet</td>
<td><img src="system.png" alt="System" /></td>
<td>Launch system telnet.</td>
</tr>
<tr>
<td>PC Analysis Telnet</td>
<td><img src="pc.png" alt="PC" /></td>
<td>Launch PC Analysis telnet.</td>
</tr>
</tbody>
</table>
Chapter 31: Avaya Proactive Contact Analyst

Creating a new report configuration

When you create a new report configuration, you specify:

- Grouping: The indentation and the hierarchical layout of the report data.
- Time frame: The desired time period of the report.
- Filtering: The specific information to include in the report.
- Title: The report identifier in the list of report configurations.
- Completion codes: Completion code information included in the Completion Code Summary reports. This option is available only for the Completion Code Summary reports in these categories:
  - Agent
  - Job
  - Time of Day
  - Agent Monthly
  - Job Monthly
  - Time of Day Monthly

To create a new report configuration:

1. Select a report category on the button bar.
2. Select a report.
3. Select Reports > New or right-click in the right pane and select New.

The system displays the Analyst Report Wizard. The Report Wizard guides you through the configuration process.
Tip:
You can have only one Report Wizard running at a time.

4. Complete the wizard as detailed below:
   a. In the Data Group page, specify the following:
      - First, Group by
      - Second, Group by (Optional)
      - Third, Group by (Optional)
   
      Note: The Group by options vary as per the selected report. If a job is using Job Unit ID as one of the parameters, then while generating Analyst reports, you must select Job Unit as one of the grouping criteria on the Data Group page. If you do not select Job Unit as one of the grouping criteria, the report result may show miscalculations.

   b. Click Next.

   c. In the Date Criteria page, specify the following:
      - Date Criteria field
      - Date Range or Criteria
   
      Note: The Date Range or Criteria options vary as per the selected report.

   d. Click Next.

   e. In the Additional Report Criteria page, specify the following:
      - Second Criteria Field (Optional)
      - Third Criteria Field (Optional)
      - Fourth Criteria Field (Optional)
      - Fifth Criteria Field (Optional)
   
      For each option specified in the criteria fields, the corresponding value options are displayed to further narrow down your report results. Select the corresponding values for the selected criteria field options. The selected value is displayed in front of the criteria field.

   Note: For the Agent, Job, and TimeofDay reports, the secondary criteria fields on the Page 4 of the Analyst new report wizard displays data based on the date criteria selected on the Page 3 of the wizard.
Note:
In the Data Group page, if you select a hierarchy branch as a grouping criteria, you must select the hierarchy name on the Additional Report Criteria page. In the Additional Report Criteria pages, if you leave these settings blank, the report data is not filtered.

Note:
Select up to 14 completion codes for the Completion Code Summary reports.

f. Click Next.
g. Enter a name for the report in the Report title field.
h. To preview the report, click Preview.
i. Click Finish to generate the report.
    To go back to the previous screen in the wizard, click Back.
5. To view the report, double-click the report name in the Activity pane.

Deleting a report configuration

To delete an Analyst report configuration:
1. Select a report category on the button bar.
2. Select a report.
3. Select a report configuration.
4. Select Reports > Delete or right-click in the right pane and select Delete.
5. Click Yes to delete the report configuration, or click No to close the dialog box without deleting the report configuration.

Changing a report configuration

To modify an existing report configuration:
1. Select a report category on the button bar.
2. Select a report.
3. Select a report configuration.
4. Select Reports > Change or right-click in the right pane and select Change.
   The system displays the Analyst Report Wizard, pre-populated with the existing report criteria.
5. Follow the instructions in the Report Wizard to change the report criteria.
Previewing a report

To preview a report:
1. Select a report category on the button bar.
2. Select a report in the report category.
3. Select a report configuration.
4. Select Reports > Preview or right-click in the right pane and select Preview.
   Analyst displays the report in a new window. From this window you can:
   - Print the report
   - Set the printer properties
   - Refresh the report data
   - Export the report data
   - Toggle the group tree outline

For more information about printing, see Printing a report on page 361.
For more information about exporting data, see Exporting report data on page 362.

Printing a report

You can use the following two options to print an Analyst report:
- From the menu
- From the preview window

From the menu

To print a report from the menu:
1. Select a report category on the button bar.
2. Select a report in the category.
3. Select a report configuration.
4. Select Reports > Print or right-click in the right pane and select Print.
5. Select the number of copies you want to print.
6. Click OK.
   The system prints the report to your default printer.
Tip:
Before printing a report, ensure that the printer properties, such as portrait or landscape orientation, are set correctly.

From the preview window

To print a report from the preview window:
1. Click the Printer Setup icon.
   The system displays the Print Setup dialog for your default printer.
2. Click Properties...
3. Verify the settings for your printer.
4. Click OK.
5. Click OK again.
6. Click the Print icon.
7. Select the page range, number of copies, and collation option.
8. Click OK.
   The system prints the file to your default printer.

Exporting report data

Export report data to use or view in a different application:
1. Select a report category on the button bar.
2. Select a report in the category.
3. Select a report configuration.
4. Select Reports > Preview or double-click the report configuration.
   Analyst displays the report in a new window.
5. Click Export In the report window.
6. From the Format list, select a format.
7. From the Destination list, select a destination.
8. Click OK.
   Depending on the format and destination chosen, the system displays a series of dialog boxes containing options for exporting the report data.
Note:
Currently, exporting the report data to the PDF and Word for Windows document formats are not supported. Exporting the report data in Excel 8.0 (XLS) and Excel 8.0 (XLS) (Extended) is not supported for the Korean, Chinese, and Russian languages.

9. In each dialog box, verify that the correct information is selected.
10. Click **OK** to move to the next dialog box, until the data is exported.

---

**Scheduling a report**

To schedule a time to print a report automatically:

1. Select a report category on the button bar.
2. Select a report in the category.
3. Select a report configuration.
4. Select **Reports > Scheduler** or right-click in the right pane and select **Scheduler**.
5. In the **Scheduler** dialog box, select the frequency option to specify how often you want to print the report.

**Note:**
If you select the Weekly or Monthly option, the report prints on Monday only. Use Task Scheduler, available from the Windows Control Panel, to select a different day of the week. The settings you specify in Task Scheduler override the Analyst schedule settings.

6. Select a start time.

**Note:**
The current release of Avaya Proactive Contact supports scheduling only for the absolute time for the hourly scheduled activity. For example, if a Supervisor wants to schedule a job run starting at 10:30 AM and then run the job after every 3 hours until 7:00 PM, the supervisor cannot schedule the job run to start at 10:30 AM. The Supervisor can set the start time to 10:00 AM, 11:00 AM, and so on.

7. Click **OK**.

**Tip:**
After you have scheduled a report, you can view your scheduled reports in the Windows Task Scheduler at the following location: **Start > Control Panel > Scheduled Tasks**.
Scheduling reports after logging off Windows

To allow scheduled reports to run after you logs off Windows:

1. Go to Start > Control Panel > Scheduled Tasks.
2. Select Scheduled report task, right-click and select Properties. The Scheduled report task information is displayed.
3. Clear the Run only if logged on check box. The Set password button is enabled.
4. Click Set password and provide password.
5. Click Apply.
Chapter 32: Analyst navigation and personalization

Avaya Proactive Contact allows you to customize the display of Analyst windows and navigate through the various tools that you can use while generating reports in Analyst.

This section contains the following topics:

- Window arrangement overview on page 365
- Navigate among the Tool menu applications on page 366
- Use large icons or small icons on the button bar on page 366

Window arrangement overview

The Analyst window displays report configurations and summary information of the options that were selected in the Reports Wizard.

This section contains the following topics:

- Analyst window layout and usage on page 365
- Button bar on page 365
- Sort on page 365
- Resize columns on page 365

Analyst window layout and usage - The Analyst window is divided into a button bar on the left pane and a main pane on the right. The main pane will be blank until you click a selection in the button bar. The Analyst button bar contains report categories. By clicking the buttons under the button group headings, you can move among the various reports.

Button bar - You can expand and contract the button bar. When you click the heading of a button group, you expand the group so that its buttons are visible. You can resize the button bar.

Sort - You can click the column headings to sort the contents of the column. When you click a heading, you see a small arrow appear alongside the heading. If the small arrow is pointing up, it indicates that you are sorting the column in the ascending order. If the small arrow is pointing down, it indicates that you are sorting the column in the descending order.

Resize columns - You can resize any column in the main pane by hovering your cursor between the heading titles until a double-arrow appears. Hold down the left mouse button and drag the cursor to resize the columns to the desired width.
Navigate among the Tool menu applications

Analyst comes with the tool applications that you can access from the Tools menu. Use the following procedure to start Tools menu applications:

1. Select Start > All Programs > Avaya Proactive Contact > Supervisor > Analyst.
2. To start a tool, select its name from the Tools menu. While you use the tool, Analyst remains open in the background so that you can navigate back to it when you are finished using the tool.

Use large icons or small icons on the button bar

You can switch between the large or small buttons views of the reports icons on the button bar. Use the following procedure to switch between large and small icons in the button bar:

1. On the button bar, click to expand the button group for which you want to change the icon size.
2. Right-click, and then select either Large Icons or Small Icons. A check mark next to the menu option indicates the view you are using currently.
Chapter 33: Avaya Proactive Contact Analyst reports

This section provides information on the set of reports supplied with Analyst. This section includes the following topics:

- Report categories
- Managed Dialing reports
- Completion Code Summary reports
- Reports per category
- Report calculations

Note: For detailed information about the data contained in the Analyst reports, see Data dictionary reference on page 401.

Report categories

Analyst reports contain the following categories:

- Agent
- Job
- Time of Day
- Administrative
- Agent Monthly
- Job Monthly
- Time of Day Monthly

Agent reports - Agent reports present the statistics on the work time and the performance of an agent. Examples of the work time statistics are total work, update, and idle time. Performance statistics include values such as total connects and connects per hour.

Job reports - Job reports present job statistics by job type: inbound, outbound, or blend. These reports include statistics on how the system ran a job, system information on calling activity, and statistics about combined agent activity during a job.

Several job report configurations also group statistics by system to accommodate a multi-dialer environment.
Chapter 33: Avaya Proactive Contact Analyst reports

**Time of Day reports** - Time of Day reports present job information grouped by time intervals. The interval is set when your system is installed.

Time of Day reports evaluate job performance at intervals of:

- 60 minutes.
- 30 minutes.
- 20 minutes.
- 15 minutes.
- 10 minutes.
- 5 minutes.

The data in any reported interval includes only calls that end during that interval. For example, an agent starts a call at 12:29 and ends the call at 12:32. All data associated with that transaction is reported in the 12:30-1:00 interval.

Several Time of Day report configurations also group statistics by system to support a multi-dialer environment.

**Administrative reports** - Administrative reports present information about:

- Agent hierarchies
- System hierarchies
- Job hierarchies
- Monthly data roll-up status

**Agent Monthly** - Agent Monthly reports present monthly statistics on the work time and the performance of an agent. Example work time statistics are total work, update, and idle time. Performance statistics include values such as total connects and connects per hour.

**Job Monthly** - Job Monthly reports present monthly job statistics by job type: inbound, outbound, or blend. These reports include statistics about how the system ran a job, system information on calling activity, and statistics about combined agent activity during a job. Several job report configurations also group statistics by system to accommodate a multi-dialer environment.

**Time of Day Monthly** - Time of Day Monthly reports present monthly job information grouped by time intervals. The interval is set when your system is installed.

Time of Day Monthly reports evaluate job performance at intervals of:

- 60 minutes.
- 30 minutes.
- 20 minutes.
- 15 minutes.
Managed Dialing reports

These report categories include reports designed for the Managed Dialing jobs:

- Agent
- Job
- Time of Day
- Agent Monthly
- Job Monthly
- Time of Day Monthly

Analyst handles connect and online time statistics for Managed Dialing jobs differently than it does for Outbound, Inbound, and Blend jobs. The following table summarizes the differences:

<table>
<thead>
<tr>
<th>Statistic</th>
<th>Outbound, Inbound or Blend job</th>
<th>Managed Dialing job</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connect</td>
<td>An agent is connected to a call placed by the dialer.</td>
<td>An agent previewed a record and did not cancel the call.</td>
</tr>
<tr>
<td>Online time</td>
<td>Amount of time an agent waited for connects, talked to customers, and updated records.</td>
<td>Job online time plus the time an agent previewed records.</td>
</tr>
</tbody>
</table>
By default, reports for Outbound, Inbound, and Blend jobs do not contain statistics for Managed Dialing jobs. These reports contain criteria to include statistics where the Job Type is Outbound (OUT), Inbound (INB), or Blend (BLND).

If you want a report to include both Managed Dialing statistics and Outbound, Inbound, and Blend statistics, remove the Job Type condition and its associated values on page four of the Report Wizard.

**Tip:**
Online time and connect statistics might be skewed on a report that includes both Managed Dialing and Outbound, Inbound, and Blend job statistics. The skew occurs because of the differences in the way those statistics are calculated.

---

**Completion Code Summary reports**

The Completion Code Summary reports are available in all report categories except in the Administrative reports. The Completion Code Summary reports contain statistics for up to 14 completion codes that the agents can use during the jobs. You can specify the codes that appear on the report.

For the Completion Code Summary reports, the last page of Avaya Report Wizard contains a Select... button. When you click this button, the system displays a dialog box from which you can select up to 14 codes.

In the report, the completion code descriptions appear in a three-line column. You can consider modifying long descriptions so that they are more understandable when you view the report. For example, possible abbreviations for description text Promise to Pay include Prom to Pay or PTP.

Use Completion Code Manager to define the description text. For instructions on managing completion codes, see the Completion Code Manager online help.

---

**Reports per category**

This section describes reports for each report category as defined in [Report categories](#) on page 367. Each description includes:

- The available reports including data fields contained in each report.
- The available variations of each report.
Note: The reports described in this section are the predefined reports included with Analyst. You can add new reports, modify existing reports, or delete reports at your discretion.

This section includes the following topics:

- [Agent reports](#) on page 372
- [Job Reports](#) on page 375
- [Time of Day Reports](#) on page 379
- [Administrative Reports](#) on page 383
- [Agent Monthly Reports](#) on page 384
- [Job Monthly Reports](#) on page 385
- [Time of Day Monthly Reports](#) on page 388
Agent reports

Available reports

The following table provides information on the reports included in the Agent reports category, the associated parameters by which you can group the data for generating the reports, and the data fields included in the reports:

<table>
<thead>
<tr>
<th>Report Title</th>
<th>Grouped by</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td>Agent ID, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, System Name</td>
<td>Date</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Session activity: Login Time, Logout Time, System Time, System Name</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Job activity: Login Time, Logout Time, Session Time, Job Number, Job Name</td>
</tr>
<tr>
<td>Managed Dialing Summary</td>
<td>Agent ID, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name</td>
<td>First Login, Last Logout, Online + Preview Time, Records Previewed, Previews per Hour, Records Canceled, Cancels per Hour, Average Preview Time, Average Work Time, Records Worked, Records Worked per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate</td>
</tr>
<tr>
<td>Performance Summary</td>
<td>Agent ID, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name</td>
<td>First Login, Last Logout, Online Time, Connects, Connects per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate, Outbound Allocation, Inbound Allocation, PTP Allocation, Manual Calls, Manual Call Rate</td>
</tr>
<tr>
<td>Report Title</td>
<td>Grouped by</td>
<td>Data Fields</td>
</tr>
<tr>
<td>---------------------------</td>
<td>---------------------------------------------------------------------------</td>
<td>---------------------------------------</td>
</tr>
<tr>
<td>Completion Code Distribution</td>
<td>Agent ID, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name</td>
<td>Completion Codes</td>
</tr>
<tr>
<td>Completion Code Summary</td>
<td>Agent ID, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name</td>
<td>First Login, Last Logout, Online Time, Connects, Connects per Hour, Custom Use Codes</td>
</tr>
<tr>
<td>Time Summary</td>
<td>Agent ID, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name</td>
<td>First Login, Last Logout, Online Time, Outbound: Online Time, Connects, Connects per Hour, Average Talk Time, Average Update Time, Average Idle Time, Inbound: Online Time, Connects, Connects per Hour, Average Talk Time, Average Update Time, Average Idle Time</td>
</tr>
</tbody>
</table>

**Note:**
If a job is using Job Unit ID as one of the parameters, then while generating Analyst reports, you must select Job Unit as one of the grouping criteria on the wizard. If you do not select Job Unit as one of the grouping criteria, then the report result may show miscalculations.
Chapter 33: Avaya Proactive Contact Analyst reports

Note:
The first log in and last log out time for an agent are displayed as the first log in time and the last log out time irrespective of the number of units they log into. For example, if an agent logs into unit1 and unit2 at 11 AM and logs out from them at 11:30 AM, and again logs into unit3 and unit4 belonging to the same job at 1 PM and logs out at 1:30 PM, the log in and log out time for all the units is displayed as 11 AM and 1:30 PM respectively.

Report variations

All Agent reports present the following variations:

<table>
<thead>
<tr>
<th>Variation</th>
<th>Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>Today</td>
<td>Job Run Date is equal to today</td>
</tr>
<tr>
<td>Yesterday</td>
<td>Job Run Date is equal to yesterday</td>
</tr>
<tr>
<td>Week To Date</td>
<td>From the last Sunday to today. For example, if the report is run on a Tuesday, the report will include data for Sunday, Monday, and Tuesday.</td>
</tr>
<tr>
<td>Month To Date</td>
<td>Job Run Date is from the month to date</td>
</tr>
<tr>
<td>Last 7 days</td>
<td>The last 7 days starting from the present day. For example, if the report is run on Tuesday, the report will include data from last week's Monday to the present day, that is Tuesday.</td>
</tr>
<tr>
<td>Last full week</td>
<td>From Sunday to Saturday for the last completed week. For example, if the report is run on Tuesday, the report will include data from last week's Sunday to the last week's Saturday</td>
</tr>
<tr>
<td>Year to date</td>
<td>Report shows data from 1st January to today. For example, if the report is run on 10th March, 2010, then the report will include data from the 1st January 2010 till 10th March, 2010.</td>
</tr>
</tbody>
</table>
**Reports per category**

<table>
<thead>
<tr>
<th>Variation</th>
<th>Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>Last full month</td>
<td>Report shows data for last full month. For example, if user runs report for last full month on 03 February 2010, it will show data from 1st January to 31st January 2010.</td>
</tr>
<tr>
<td>Existing date in the database</td>
<td>Report shows data for all the existing job run dates available in the database. You can select dates for which you want to run the report.</td>
</tr>
</tbody>
</table>

---

**Job Reports**

**Available reports**

The following table provides information on the reports included in the Job reports category, the associated parameters by which you can group the data for generating the reports, and the data fields included in the reports:

<table>
<thead>
<tr>
<th>Report Title</th>
<th>Grouped by</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Completion Code Configuration</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name</td>
<td>Code Number, Is RPC, Is Abandon, Is Closure, System Name, Job Number, Job Name</td>
</tr>
<tr>
<td>Managed Dialing Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name</td>
<td>First Start, Last End, Online + Preview Time, Records Previewed, Previews per Hour, Records Canceled, Cancels per Hour, Average Preview Time, Average Work Time, Records Worked, Worked per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate</td>
</tr>
<tr>
<td>Report Title</td>
<td>Grouped by</td>
<td>Data Fields</td>
</tr>
<tr>
<td>------------------------------</td>
<td>---------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Performance Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name</td>
<td>First Start, Last End, Online Time, Records Selected, Calls Placed, Calls Offered, Connects, Connects per Hour, RPC, PRC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate, Manual Calls, Manual Call Rate</td>
</tr>
<tr>
<td>Completion Code Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name</td>
<td>Custom Use Codes</td>
</tr>
<tr>
<td>Time Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name</td>
<td>Outbound: Online Time, Calls Placed, Connects, Connects per Hour, Average Queue Time, Calls Abandoned, Average Talk Time, Average Update Time, Average Idle Time</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Inbound: Online Time, Connects, Connects per Hour, Average Queue Time, Calls Abandoned, Average Talk Time, Average Update Time, Average Idle Time</td>
</tr>
<tr>
<td>Quality Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name</td>
<td>First Start, Last End, Online Time, Calls Placed, Calls Offered, Connects, Connects per Hour, Serviced Calls, Desired Service Level, Actual Service Level, Connects Tol., Nuisance Count, Nuisance Rate, Calls to Queue, Average Queue Time, CCM Abandon Rate</td>
</tr>
</tbody>
</table>
### Report Title Grouped by Data Fields

<table>
<thead>
<tr>
<th>Report Title</th>
<th>Grouped by</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Non-contact And Error Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name</td>
<td>Calls Placed, Connects Errors: Miscellaneous Errors, No Dial Tone, Agent Session Failed Virtual: Code 91, Code 92 Special Information Tones: Intercept, No Circuit, Disconnected, Vacant, Re-order Non-Connects: Busy, No Answer, Voice Mail, Fax/Modem Outbound HU/Abandoned, Inbound HU/Abandoned, All Other</td>
</tr>
<tr>
<td>OFCOM</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name</td>
<td>Calls Placed, Calls offered, Connect, CONNEXPIRE, Out Connect, Aban rate</td>
</tr>
</tbody>
</table>

**Note:**
If a job is using Job Unit ID as one of the parameters, then while generating Analyst reports, you must select Job Unit as one of the grouping criteria on the wizard. If you do not select Job Unit as one of the grouping criteria, then the report result may show miscalculations.

**Note:**
The first log in and last log out time for an agent are displayed as the first log in time and the last log out time irrespective of the number of units they log into. For example, if an agent logs into unit1 and unit2 at 11 AM and logs out from them at 11:30 AM, and again logs into unit3 and unit4 belonging to the same job at 1 PM and logs out at 1:30 PM, the log in and log out time for all the units is displayed as 11 AM and 1:30 PM respectively.
## Report variations

All Job reports present the following variations:

<table>
<thead>
<tr>
<th>Variation</th>
<th>Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>Today</td>
<td>Job Run Date is equal to today</td>
</tr>
<tr>
<td>Yesterday</td>
<td>Job Run Date is equal to yesterday</td>
</tr>
<tr>
<td>Week To Date</td>
<td>From the last Sunday to today. For example, if the report is run on</td>
</tr>
<tr>
<td></td>
<td>Tuesday, the report will include data for Sunday, Monday, and Tuesday.</td>
</tr>
<tr>
<td>Month To Date</td>
<td>Job Run Date is from the month to date</td>
</tr>
<tr>
<td>Last 7 days</td>
<td>The last 7 days starting from the present day. For example, if the report</td>
</tr>
<tr>
<td></td>
<td>is run on Tuesday, the report will include data from last week's Monday</td>
</tr>
<tr>
<td></td>
<td>to the present day, that is Tuesday.</td>
</tr>
<tr>
<td>Last full week</td>
<td>From Sunday to Saturday for the last completed week. For example, if the</td>
</tr>
<tr>
<td></td>
<td>report is run on Tuesday, the report will include data from last week's</td>
</tr>
<tr>
<td></td>
<td>Sunday to the last week's Saturday</td>
</tr>
<tr>
<td>Year to date</td>
<td>Report shows data from 1st January to today. For example, if the report</td>
</tr>
<tr>
<td></td>
<td>is run on 10th March, 2010, then the report will include data from the</td>
</tr>
<tr>
<td>Last full month</td>
<td>Report shows data for last full month. For example, If user runs report</td>
</tr>
<tr>
<td></td>
<td>for last full month on 03 February 2010. It will show data from 1st</td>
</tr>
<tr>
<td></td>
<td>January to 31st January 2010.</td>
</tr>
<tr>
<td>Existing date in the</td>
<td>Report shows data for all the existing job run dates available in the</td>
</tr>
<tr>
<td>database</td>
<td>database. You can select dates for which you wants to run the report.</td>
</tr>
</tbody>
</table>
### Time of Day Reports

#### Available reports

The following table provides information on the reports included in the Time of Day reports category, the associated parameters by which you can group the data for generating the reports, and the data fields included in the reports:

<table>
<thead>
<tr>
<th>Report Title</th>
<th>Grouped by</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Managed Dialing Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Time Segment</td>
<td>First Start, Last End, Online + Preview Time, Records Previewed, Previews per Hour, Records Canceled, Cancels per Hour, Average Preview Time, Average Work Time, Records Worked, Worked per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate</td>
</tr>
<tr>
<td>Performance Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Time Segment</td>
<td>First Start, Last End, Online Time, Records Selected, Calls Placed, Calls Offered, Connects, Connects per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate, Manual Calls, Manual Call Rate</td>
</tr>
<tr>
<td>Completion Code Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Time Segment</td>
<td>Custom Use Codes</td>
</tr>
</tbody>
</table>
### Chapter 33: Avaya Proactive Contact Analyst reports

<table>
<thead>
<tr>
<th>Report Title</th>
<th>Grouped by</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Time Segment</td>
<td>Outbound: Online Time, Calls Placed, Connects, Connects per Hour, Average Queue Time, Calls Abandoned, Average Talk Time, Average Update Time, Average Idle Time</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Inbound: Online Time, Connects, Connects per Hour, Average Queue Time, Calls Abandoned, Average Talk Time, Average Update Time, Average Idle Time</td>
</tr>
<tr>
<td>Quality Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Time Segment</td>
<td>First Start, Last End, Online Time, Calls Placed, Calls Offered, Connects, Connects per Hour, Serviced Calls, Desired Service Level, Actual Service Level, Connects Tol., Nuisance Count, Nuisance Rate, Calls to Queue, Average Queue Time, CCM Abandon Rate</td>
</tr>
</tbody>
</table>
### Reports per category

<table>
<thead>
<tr>
<th>Report Title</th>
<th>Grouped by</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Non-contact And Error Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Time Segment</td>
<td>Calls Placed, Connects Errors: Miscellaneous Errors, No Dial Tone, Agent Session Failed Virtual: Code 91, Code 92 Special Information Tones: Intercept, No Circuit, Disconnected, Vacant, Re-order Non-Connects: Busy, No Answer, Voice Mail, Fax/Modem Outbound HU/Abandoned, Inbound HU/Abandoned, All Other</td>
</tr>
<tr>
<td>OFCOM</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name</td>
<td>Calls Placed, Calls offered, Connect, CONNEXPIRE, Out Connect, Aban rate</td>
</tr>
</tbody>
</table>

**Note:**
If a job is using Job Unit ID as one of the parameters, then while generating Analyst reports, you must select Job Unit as one of the grouping criteria on the wizard. If you do not select Job Unit as one of the grouping criteria, then the report result may show miscalculations.

**Note:**
The first log in and last log out time for an agent are displayed as the first log in time and the last log out time irrespective of the number of units they log into. For example, if an agent logs into unit1 and unit2 at 11 AM and logs out from them at 11:30 AM, and again logs into unit3 and unit4 belonging to the same job at 1 PM and logs out at 1:30 PM, the log in and log out time for all the units is displayed as 11 AM and 1:30 PM respectively.
Report variations

All Time of Day reports present the following variations:

<table>
<thead>
<tr>
<th>Variation</th>
<th>Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>Today</td>
<td>Job Run Date is equal to today</td>
</tr>
<tr>
<td>Yesterday</td>
<td>Job Run Date is equal to yesterday</td>
</tr>
<tr>
<td>Week To Date</td>
<td>From the last Sunday to today. For example, if the report is run on Tuesday, the report will include data for Sunday, Monday, and Tuesday.</td>
</tr>
<tr>
<td>Month To Date</td>
<td>Job Run Date is from the month to date</td>
</tr>
<tr>
<td>Last 7 days</td>
<td>The last 7 days starting from the present day. For example, if the report is run on Tuesday, the report will include data from last's week's Monday to the present day, that is Tuesday.</td>
</tr>
<tr>
<td>Last full week</td>
<td>From Sunday to Saturday for the last completed week. For example, if the report is run on Tuesday, the report will include data from last week's Sunday to the last week's Saturday</td>
</tr>
<tr>
<td>Year to date</td>
<td>Report shows data from 1st January to today. For example, if the report is run on 10th March, 2010, then the report will include data from the 1st January 2010 till 10th March, 2010.</td>
</tr>
<tr>
<td>Last full month</td>
<td>Report shows data for last full month. For example, If user runs report for last full month on 03 February 2010. It will show data from 1st January to 31st January 2010.</td>
</tr>
<tr>
<td>Existing date in the database</td>
<td>Report shows data for all the existing job run dates available in the database. You can select dates for which you wants to run the report.</td>
</tr>
</tbody>
</table>
Administrative Reports

Available reports

The Administrative reports category contains the following reports and data fields:

<table>
<thead>
<tr>
<th>Report Title</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent Hierarchies</td>
<td>Agent: Top Level, Middle Level, Bottom Level, Agent ID</td>
</tr>
<tr>
<td></td>
<td>Super/Agent: Top Level, Middle Level, Bottom Level, Agent ID</td>
</tr>
<tr>
<td>System Hierarchies</td>
<td>Top Level, Middle Level, Bottom Level, System Name</td>
</tr>
<tr>
<td>Job Hierarchies</td>
<td>Top Level, Middle Level, Bottom Level, Job Name</td>
</tr>
<tr>
<td>Monthly Data Roll-up Status</td>
<td>Month Beginning, Agent Tables, Job Tables, TD Tables</td>
</tr>
</tbody>
</table>

Report variations

There are no variations for Administrative Reports.
Agent Monthly Reports

Available reports

The following table provides information on the reports included in the Agent Monthly reports category, the associated parameters by which you can group the data for generating the report, and the data fields included in the reports:

<table>
<thead>
<tr>
<th>Report Title</th>
<th>Grouped by</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monthly Managed Dialing</td>
<td>Agent ID, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name</td>
<td>First Login, Last Logout, Online + Preview Time, Records Previewed, Previews per Hour, Records Cancelled, Cancels per Hour, Average Preview Time, Average Work Time, Records Worked, Worked per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate</td>
</tr>
<tr>
<td>Summary</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Monthly Performance Summary</td>
<td>Agent ID, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name</td>
<td>First Login, Last Logout, Online Time, Connects, Connects per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate, Outbound Allocation, Inbound Allocation, PTP Allocation, Manual Calls, Manual Call Rate</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Reports per category

### December 2011

385

### Report variations

All the Agent Monthly reports presents the following variation:

<table>
<thead>
<tr>
<th>Variation</th>
<th>Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>Existing date in the database</td>
<td>Report shows data for all the existing job run dates available in the database. You can select dates for which you wants to run the report.</td>
</tr>
</tbody>
</table>

### Job Monthly Reports

#### Available reports

The following table provides information on the reports included in the Job Monthly reports category, the associated parameters by which you can group the data for generating the reports, and the data fields included in the reports:

<table>
<thead>
<tr>
<th>Report Title</th>
<th>Grouped by</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monthly Completion Code Summary</td>
<td>Agent ID, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name</td>
<td>First Login, Last Logout, Online Time, Connects, Connects per Hour, Custom Use Codes</td>
</tr>
<tr>
<td>Monthly Time Summary</td>
<td>Agent ID, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name</td>
<td>First Login, Last Logout, Online Time, Outbound: Online Time, Connects, Connects per Hour, Average Talk Time, Average Update Time, Average Idle Time Inbound: Online Time, Connects, Connects per Hour, Average Talk Time, Average Update Time, Average Idle Time</td>
</tr>
<tr>
<td>Report Title</td>
<td>Grouped by</td>
<td>Data Fields</td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>---------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Monthly Managed Dialing Summary</td>
<td>Job Name, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name</td>
<td>First Start, Last End, Online + Preview Time, Records Previewed, Previews per Hour, Records Canceled, Cancels per Hour, Average Preview Time, Average Work Time, Records Worked, Worked per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate</td>
</tr>
<tr>
<td>Monthly Performance Summary</td>
<td>Job Name, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name</td>
<td>First Start, Last End, Online Time, Records Selected, Calls Placed, Calls Offered, Connects, Connects per Hour, RPC, PRC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate, Manual Calls, Manual Call Rate</td>
</tr>
<tr>
<td>Monthly Completion Code Summary</td>
<td>Job Name, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name</td>
<td>Custom Use Codes</td>
</tr>
<tr>
<td>Monthly Time Summary</td>
<td>Job Name, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name</td>
<td>Outbound: Online Time, Calls Placed, Connects, Connects per Hour, Average Queue Time, Calls Abandoned, Average Talk Time, Average Update Time, Average Idle Time</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Inbound: Online Time, Connects, Connects per Hour, Average Queue Time, Calls Abandoned, Average Talk Time, Average Update Time, Average Idle Time</td>
</tr>
<tr>
<td>Report Title</td>
<td>Grouped by</td>
<td>Data Fields</td>
</tr>
<tr>
<td>------------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Monthly Quality Summary</td>
<td>Job Name, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name</td>
<td>First Start, Last End, Online Time, Calls Placed, Calls Offered, Connects, Connects per Hour, Serviced Calls, Desired Service Level, Actual Service Level, Connects Tol., Nuisance Count, Nuisance Rate, Calls to Queue, Average Queue Time, CCM Abandon Rate</td>
</tr>
<tr>
<td>Monthly Non-contact And Error Summary</td>
<td>Job Name, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name</td>
<td>Calls Placed, Connects Errors: Miscellaneous Errors, No Dial Tone, Agent Session Failed Virtual: Code 91, Code 92 Special Information Tones: Intercept, No Circuit, Disconnected, Vacant, Re-order Non-Connects: Busy, No Answer, Voice Mail, Fax/Modem Outbound HU/Abandoned, Inbound HU/Abandoned, All Other</td>
</tr>
<tr>
<td>OFCOM</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name</td>
<td>Calls Placed, Calls offered, Connect, CONNEXPIRE, Out Connect, Aban rate</td>
</tr>
</tbody>
</table>
Report variations

All the Job Monthly reports presents the following variation:

<table>
<thead>
<tr>
<th>Variation</th>
<th>Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>Existing date in the database</td>
<td>Report shows data for all the existing job run dates available in the database. You can select dates for which you want to run the report.</td>
</tr>
</tbody>
</table>

Time of Day Monthly Reports

Available reports

The following table provides information on the reports included in the Time of Day Monthly reports category, the associated parameters by which you can group the data for generating the report, and the data fields included in the reports:

<table>
<thead>
<tr>
<th>Report Title</th>
<th>Grouped by</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monthly Managed Dialing Summary</td>
<td>Time Segment, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name</td>
<td>First Start, Last End, Online + Preview Time, Records Previewed, Previews per Hour, RecordsCanceled, Canceled per Hour, Average Preview Time, Average Work Time, Records Worked, Worked per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate</td>
</tr>
<tr>
<td>Monthly Performance Summary</td>
<td>Time Segment, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name</td>
<td>First Start, Last End, Online Time, Records Selected, Calls Placed, Calls Offered, Connects, Connects per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate, Manual Calls, Manual Call Rate</td>
</tr>
<tr>
<td>Report Title</td>
<td>Grouped by</td>
<td>Data Fields</td>
</tr>
<tr>
<td>------------------------------</td>
<td>----------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Monthly Completion Code Summary</td>
<td>Time Segment, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name</td>
<td>Custom Use Codes</td>
</tr>
<tr>
<td>Monthly Time Summary</td>
<td>Time Segment, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name</td>
<td>Outbound: Online Time, Calls Placed, Connects, Connects per Hour, Average Queue Time, Calls Abandoned, Average Talk Time, Average Update Time, Average Idle Time Inbound: Online Time, Connects, Connects per Hour, Average Queue Time, Calls Abandoned, Average Talk Time, Average Update Time, Average Idle Time</td>
</tr>
<tr>
<td>Monthly Quality Summary</td>
<td>Time Segment, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name</td>
<td>First Start, Last End, Online Time, Calls Placed, Calls Offered, Connects, Connects per Hour, Serviced Calls, Desired Service Level, Actual Service Level, Connects Tol., Nuisance Count, Nuisance Rate, Calls to Queue, Average Queue Time, CCM Abandon Rate</td>
</tr>
</tbody>
</table>
Chapter 33: Avaya Proactive Contact Analyst reports

Report variations

All the Time of Day Monthly reports presents the following variation:

<table>
<thead>
<tr>
<th>Variation</th>
<th>Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>Existing date in the database</td>
<td>Report shows data for all the existing job run dates available in the database. You can select dates for which you wants to run the report.</td>
</tr>
</tbody>
</table>

Report calculations
This section provides an overview of several Analyst report calculations.

This section includes the following topics:

- **Abandon Calls** on page 391
- **Idle Time** on page 391
- **Online Time** on page 392
- **Job Active Time** on page 392
- **Agent Logout Time** on page 392

---

**Abandon Calls**

The Abandon Calls field in the Crystal Dictionaries is not used on the supplied Analyst reports. However, the calculation for Abandon Calls field still exists in the Crystal Dictionaries. You can choose to use the Abandon Calls statistic on a custom report. This section describes the calculation for Abandon Calls.

Analyst calculates call abandon events by subtracting the number of called party answers, inbound calls, or both from the number of calls worked by agents. For example, outbound calls that result in a live party answer, or inbound calls not handled by an agent are calculated as abandon calls.

This calculation does not use codes 45 through 49 to calculate abandoned calls. These codes specifically track customer and dialer originated call terminations.

Two abandon rates available in Analyst are: Abandon Rate of Placed and Abandoned Rate of Offered.

- **Abandon Rate of Placed**: The number of calls abandoned as a percentage of the total calls placed by the system. This statistic is available for outbound and combined, that is outbound and inbound together, statistics. In combined statistics, the rate is defined as both outbound and inbound calls abandoned as a percentage of calls placed.

- **Abandon Rate of Offered**: The number of calls abandoned as a percentage of the total calls available for an agent to work. Calls available are outbound calls that result in a live party answer or inbound calls. This statistic is available for outbound and combined, that is outbound and inbound together. In combined statistics, the rate is both outbound and inbound calls abandoned as a percentage of calls available for an agent to work.

---

**Idle Time**

Analyst stores both standard inbound and outbound idle times and transition time as determined by the INFOSTAT file. Analyst Crystal Dictionary and Report formulas include transition time in the idle time figures. Transition time is included in the dialer as Agent and Job history file summaries.
Transition time is defined as the time when a blend agent is transitional between outbound call mode and inbound call mode. The IDLETYPE field of the INFOSTAT file contains an N to indicate the value is the transition time.

Transition time is considered as non-assigned time. The records process that creates the history files does not compute non-assigned time. Therefore, neither the dialer character-based history reports nor Analyst history file-based reports include this data.

Analyst includes transition time data by:

- Checking the CALLTYPE field for a non-assigned idle record.
- Accumulating the non-assigned idle time as either outbound or inbound transition time.

These transition times are added into all idle and online time formulas.

You can remove transition time by editing either the Analyst dictionaries or reports, or both the dictionaries and the reports.

---

**Online Time**

Analyst online time is a combination of all idle, talk, manual calls, and update time that an agent spends on a dialer job. Update time is the time an agent spends on the customer record after ending the conversation. The online formulas also include transition time as described in the Idle Time section.

---

**Job Active Time**

Job Active Time provides statistics on the duration of a job ran from start up to shut down. Analyst computes this figure based on the JOBTIME entry in the INFOSTAT files. The JOBTIME entry is the last entry in the file.

If the JOBTIME entry is missing, Analyst computes Job Active Time based on the first time entry and the last time entry in the file.

**Note:**
This statistic is not used for any standard reports.

---

**Agent Logout Time**

Analyst stores a login and logout entry for each agent on each job. These time entries specify the time when an agent first logs in to a job and the last time when that agent logs out of a job.

The login time is stored by finding the first LOGON entry in the INFOSTAT file for each agent.
The logout time is stored by finding the last record for an agent in the INFOSTAT file. The LOGOFF entry is not used for this calculation because agents often take calls after logoff is requested. Agents take calls after logoff when calls are still pending, but all agents have already requested logoff.
Chapter 34: Data dictionary concepts

This section provides information on the following topics:

- Data dictionary overview on page 395
- Setup and requirements on page 395
- Benefits on page 395
- Historical performance data concepts on page 396
- Data field notes on page 398
- Guidelines for creating new reports on page 399

Data dictionary overview

The Analyst reports provide performance data relative to agents and jobs on Avaya Proactive Contact systems. The reports provide virtually unlimited combinations of data grouping and filtering to support your reporting needs.

However, in certain cases you might require customized reports. This reference guide provides information about the Data Dictionaries provided with Analyst from which you can create custom reports.

Setup and requirements

To use and customize Analyst reports, you must install:

- Avaya Proactive Contact Analyst
- Crystal Reports Professional version 8.5

Note:
Crystal Reports Professional is required only if you are creating custom reports or modifying the existing reports.

Benefits
The Crystal Dictionaries installed with Avaya Proactive Contact Analyst provides access to and built-in join logic for all historical performance data available in the database. Available data fields are presented in an easy-to-use and identifiable format.

Crystal Dictionaries also provide the following benefits:

**Database connection and authorization built-in**
- Removes the need to configure database drivers.
- Removes the need to administer database user rights.
- Can be used from any disk location on a computer that has Avaya Mid-tier Services installed.

**Meta-data named data fields**
- Removes the need to understand and locate vague data table and field names.
- Provides comprehensive listing of all possible data fields available in the historical database.

**Join logic for table relationships built-in**
- Removes the need to understand table relationships and key relationships for historical data schema.
- Allows use of all fields in the dictionary in any combination.

---

**Historical performance data concepts**

The Analyst dictionaries are divided into three main types:

- Job and System Data
- Agent Data
- Time Segment Data

This section includes information on the following topics:

- [Monthly roll-up dictionaries](#) on page 397
- [Administrative dictionary](#) on page 397
- [Elementary and calculated data](#) on page 397
- [Weighted averages](#) on page 398
Monthly roll-up dictionaries

Three additional dictionaries provide monthly "roll-up" summary data for Job and System Data, Agent Data, Time Segment Data. Monthly roll-up data are rows of data created by summarizing all performance data for systems, jobs, and agents over an entire month. For example, in the Agent monthly dictionary (apds-monthagt), each row for an agent represents all activity on all jobs for one month.

Analyst stores monthly roll-up data for up to 7 years.

There is a new parameter named as "ROLLNCLEAN" in the master.cfg. The value for this parameter is the number of months. For example, if you want to store the data for three months, then the value of the parameter will be as follows:

"ROLLNCLEAN : 3"

For example: If the current month is October and you set the value of ROLLNCLEAN parameter to 3, the database maintenance script (db_maintenance) will delete the detailed data older than July, that is, older than three months excluding the current month (October).

Note:
It is recommended to set the value of ROLLNCLEAN parameter to 3. This means that you must execute the db_maintenance script once in every 3 months. The OFCOM regulation states that you must save six-months-old detailed data in the database. The users who follow OFCOM regulation are recommended to set the ROLLNCLEAN parameter to 6.

Administrative dictionary

⚠️ Important:
Do not use the apds-admin dictionary.

This dictionary contains administrative tables and fields, and is not intended to be used for custom report creation. Several categories of data within this dictionary are incompatible with each other. Report errors or system query performance issues can occur if you use incompatible data categories on a report.

Elementary and calculated data

Dictionaries contain fields that represent elementary performance data and calculated performance data. You must observe the following rules when using data from the dictionaries:
**Elementary Performance Fields - Counts & Times** - You can use these fields to create formulas in reports and to create group formulas. These fields are used throughout Analyst built-in reports.

**Calculated Performance Fields - Averages, Rates & Per-Hour Fields**: - You can use these fields in reports that do not require formulas. These fields are especially useful for ad-hoc queries and data analysis. These fields are not used in Analyst built-in reports.

The reference tables in this document are divided into data categories and subdivided into Elementary Performance Data and Calculated Performance Data sections. Each section lists the field and its associated dictionary along with the type of data and a brief description of the field.

---

**Weighted averages**

The important distinction between elementary and calculated fields is whether using them in a report results in non-weighted averages. If you create a formula on a report based on the SUM of Average Talk Time, the resultant value is non-weighted.

Consider this example: the job named "quality" was run twice in one day: job numbers 55 and 62. Job 55 had 100 calls with an average talk time of 3 minutes, for example: 100 calls / 300 minutes. Job 62 had 1000 calls with an average talk time of 2 minutes, for example: 1000 calls / 500 minutes.

Using the AVERAGE function for these two jobs results in a value of 2.5 minutes. However, if weighted properly by the number of calls on job 62, the AVERAGE is 2.1, for example: 1100 calls / 533 minutes. Therefore, you must use the elementary fields when using group functions in reports and creating your own averages, rates, and per-hour formulas.

---

**Data field notes**

This section provides information on the following topics:

- [Idle count fields](#) on page 398
- [Outbound, Inbound, and Combined fields](#) on page 399

---

**Idle count fields**

Idle counts are counters for the number of times that an agent goes idle during the calling jobs. You can use this count to calculate the average idle times and the rates relating to the idle time. There is usually one more idle count than calls worked during each agent session. The
additional count occurs because an agent is idle before the first call and usually after the last call.

Outbound, Inbound, and Combined fields

Outbound counts, times, and calculations represent all outbound activities regardless of the job type or agent type. For instance, an agent logs in to a blend job and takes both outbound and inbound calls. The individual outbound calls are tracked with the outbound fields. The inbound fields are treated in the same manner as the outbound fields.

Combined fields represent the combined total of both outbound and inbound activities.

Guidelines for creating new reports

Avaya does not support modification of Analyst Dictionaries or Reports. However, custom reports can be created from the built-in Analyst reports as a starting point. Custom reports cannot be used within the Analyst application or with the Analyst Report Wizard.

This section includes information about the following topics:

- Modifying an Analyst built-in report on page 399
- Creating a new report on page 400

Modifying an Analyst built-in report

To create a custom report from an Analyst built-in report:

1. Copy report (*.rpt) file from the Analyst\Reports sub-directory to a new location.
2. Remove the read-only attribute from the report file.
3. Open the report file and modify the file as necessary.
4. Save the file.

**Note:** The reports that you create using these guidelines retain pointers to the built-in location of the Analyst dictionary. If you subsequently reinstall Analyst in a different location, the report will not be able to locate the dictionary. In that case, the next time you open the report, you must browse to find the dictionary.
Creating a new report

To create a new report from Analyst dictionaries:

1. Open Crystal Reports and select **New Report**.
2. Choose **Metadata / Query** from the Data Explorer dialog box.
3. Browse to find the appropriate dictionary for the new report.

**Note:**
For information about available data fields in the dictionaries, see [Chapter 35: Data dictionary reference](#) on page 401.
Chapter 35: Data dictionary reference

This section provides information about the following topics:

- Admin rollup on page 401
- Agent activity on page 402
- Agent codes on page 403
- Agent hierarchy on page 403
- Dialer hierarchy on page 404
- Job hierarchy on page 404
- RAC on page 405
- Combined call handling times on page 405
- Combined call statistics on page 408
- Combined queue statistics on page 411
- General information on page 413
- Inbound call handling times on page 418
- Inbound call statistics on page 421
- Inbound queue statistics on page 422
- Managed dialing statistics on page 424
- Outbound call handling time on page 425
- Outbound call statistics on page 428
- Outbound queue statistics on page 430
- Person to Person call handling times on page 432
- Person to Person call statistics on page 434
- Combined RPC and closure statistics on page 435
- Combined call completion code statistics on page 437
This section provides information on the rollup status of the monthly data.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rollup Month</td>
<td>apds-adminjob</td>
<td>Number</td>
<td>Rollup the month data.</td>
</tr>
<tr>
<td>Rollup Success TD</td>
<td>apds-adminjob</td>
<td>String</td>
<td>Rollup is success for the TD table.</td>
</tr>
<tr>
<td>Rollup Success Agent</td>
<td>apds-adminjob</td>
<td>String</td>
<td>Rollup is success for the agent table.</td>
</tr>
<tr>
<td>Rollup Success Job</td>
<td>apds-adminjob</td>
<td>String</td>
<td>Rollup is success for the job table.</td>
</tr>
</tbody>
</table>

### Agent activity

This section provides information about the agent activities.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>System Agent</td>
<td>apds-adminagt</td>
<td>String</td>
<td>Name of an agent.</td>
</tr>
<tr>
<td>System Login</td>
<td>apds-adminagt</td>
<td>Number</td>
<td>The time when an agent logged in to the system.</td>
</tr>
<tr>
<td>System Logout</td>
<td>apds-adminagt</td>
<td>Number</td>
<td>The time when an agent logged out of the system.</td>
</tr>
<tr>
<td>System Date</td>
<td>apds-adminagt</td>
<td>Number</td>
<td>The date when an agent logged in to the system.</td>
</tr>
</tbody>
</table>
Agent codes

This section provides information about the agent code.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Elementary Data</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code</td>
<td>apds-adminagt</td>
<td>String</td>
<td>Agent Code.</td>
</tr>
<tr>
<td></td>
<td>apds-agtreldist</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code Count</td>
<td>apds-adminagt</td>
<td>Number</td>
<td>Total number of agent codes.</td>
</tr>
<tr>
<td></td>
<td>apds-agtreldist</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Agent hierarchy

This section provides information about the hierarchy configuration for agents.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Elementary Data</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>apds-adminagt</td>
<td>String</td>
<td>Agent hierarchy name.</td>
</tr>
<tr>
<td></td>
<td>apds-agtreldist</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Agent Item</td>
<td>apds-adminagt</td>
<td>String</td>
<td>Agent ID/name.</td>
</tr>
<tr>
<td></td>
<td>apds-agtreldist</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Dialer hierarchy

This section provides information about the hierarchy configuration for dialers.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Elementary Data</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>apds-adminjob</td>
<td>String</td>
<td>Dialer hierarchy name.</td>
</tr>
<tr>
<td>Dialer Item</td>
<td>apds-adminjob</td>
<td>String</td>
<td>Dialer name.</td>
</tr>
<tr>
<td>Dialer Level 1</td>
<td>apds-adminjob</td>
<td>String</td>
<td>Dialer hierarchy bottom level.</td>
</tr>
<tr>
<td>Dialer Level 2</td>
<td>apds-adminjob</td>
<td>String</td>
<td>Dialer hierarchy middle level.</td>
</tr>
<tr>
<td>Dialer Level 3</td>
<td>apds-adminjob</td>
<td>String</td>
<td>Dialer hierarchy top level.</td>
</tr>
</tbody>
</table>

Job hierarchy
This section provides information about the hierarchy configuration for jobs.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Elementary Data</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>apds-adminjob</td>
<td>String</td>
<td>Job hierarchy name.</td>
</tr>
<tr>
<td>Job Item</td>
<td>apds-adminjob</td>
<td>String</td>
<td>Job name.</td>
</tr>
<tr>
<td>Job Level 1</td>
<td>apds-adminjob</td>
<td>String</td>
<td>Job hierarchy bottom level.</td>
</tr>
<tr>
<td>Job Level 2</td>
<td>apds-adminjob</td>
<td>String</td>
<td>Job hierarchy middle level.</td>
</tr>
<tr>
<td>Job Level 3</td>
<td>apds-adminjob</td>
<td>String</td>
<td>Job hierarchy top level.</td>
</tr>
</tbody>
</table>

This section provides information about the type of the completion code number.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Elementary Data</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code Number</td>
<td>apds-adminjob</td>
<td>String</td>
<td>Completion code number.</td>
</tr>
<tr>
<td>RPC</td>
<td>apds-adminjob</td>
<td>Boolean</td>
<td>The completion code number is RPC.</td>
</tr>
<tr>
<td>Abandon</td>
<td>apds-adminjob</td>
<td>Boolean</td>
<td>The completion code number is Abandon.</td>
</tr>
<tr>
<td>Closure</td>
<td>apds-adminjob</td>
<td>Boolean</td>
<td>The completion code number is Closure.</td>
</tr>
</tbody>
</table>

Combined call handling times
Total and average times the agent or agents perform inbound and outbound job activities.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Idle Time (Minutes)** | apds-agt
apds-job
apds-tdjob
apds-monthagt
apds-monthjob
apds-monthtdjob | Number | Total number of minutes for which an agent waited between the inbound and outbound connects. |
| **Online Time (Hours)** | apds-agt
apds-job
apds-tdjob
apds-monthagt
apds-monthjob
apds-monthtdjob | Number | Total number of hours for which an agent waited between the inbound and outbound connects, talked to clients, and updated records. |
| **Online Time (Minutes)** | apds-agt
apds-job
apds-tdjob
apds-monthagt
apds-monthjob
apds-monthtdjob | Number | Total number of minutes for which an agent waited between inbound and outbound connects, talked to clients, and updated records. |
| **Online Time (Sec)** | apds-agt
apds-job
apds-tdjob
apds-monthagt
apds-monthjob
apds-monthtdjob | Number | Total number of minutes for which an agent waited between inbound and outbound connects, talked to clients, and updated records. |
| **Talk Time (Minutes)** | apds-agt
apds-job
apds-tdjob
apds-monthagt
apds-monthjob
apds-monthtdjob | Number | Total number of minutes for which an agent talked to inbound and outbound clients. |
## Combined call handling times

### Field Dictionary Format Description

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
</table>
| Update Time (Minutes) | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number   | Total number of minutes for which an agent updated records after an inbound or outbound connect ended. |
| Work Time (Minutes)  | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number   | Total number of minutes for which an agent talked to inbound and outbound clients and updated records. |

### Calculated Data:

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
</table>
| Average Idle Time (Minutes) | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number   | Average number of minutes for which an agent waited between inbound and outbound connects.            |
| Average Idle Time (Seconds) | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number   | Average number of seconds for which an agent waited between inbound and outbound connects.             |
| Average Talk Time (Minutes) | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number   | Average number of minutes for which an agent talked to inbound and outbound clients.                   |
| Average Talk Time (Seconds) | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number   | Average number of seconds for which an agent talked to the inbound and outbound clients.              |
### Field Dictionary Format Description

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average Update Time</td>
<td>apds-agt</td>
<td>Number</td>
<td>Average number of minutes after an inbound or outbound connect ended that</td>
</tr>
<tr>
<td>(Minutes)</td>
<td>apds-job</td>
<td></td>
<td>the agent updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Average Update Time</td>
<td>apds-agt</td>
<td>Number</td>
<td>Average number of seconds after an inbound or outbound connect ended that</td>
</tr>
<tr>
<td>(Seconds)</td>
<td>apds-job</td>
<td></td>
<td>the agent updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Average Work Time</td>
<td>apds-agt</td>
<td>Number</td>
<td>Average number of minutes the agent talked to inbound and outbound clients</td>
</tr>
<tr>
<td>(Minutes)</td>
<td>apds-job</td>
<td></td>
<td>and updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Average Work Time</td>
<td>apds-agt</td>
<td>Number</td>
<td>Average number of seconds the agent talked to inbound and outbound clients</td>
</tr>
<tr>
<td>(Seconds)</td>
<td>apds-job</td>
<td></td>
<td>and updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

---

**Combined call statistics**
This section provides information on the combined inbound and outbound job performance and connectivity data.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calls Offered</td>
<td>apds-job</td>
<td>Number</td>
<td>The number of inbound and outbound calls available for the agents. Outbound available calls might be voice contact or answering machine if the job is set up to pass answering machines. Inbound available calls include calls passed to the agents and calls abandoned in the wait queue. Note that in case of managed jobs, when a call is previewed by an agent, the Calls Offered count gets incremented by one. When that same call is dialed by the agent or system, the Calls Offered count again gets incremented by one.</td>
</tr>
<tr>
<td>Calls Placed</td>
<td>apds-job</td>
<td>Number</td>
<td>Total number of outbound calls made by the system.</td>
</tr>
<tr>
<td>Connects</td>
<td>apds-agt</td>
<td>Number</td>
<td>Total number of inbound and outbound calls passed to the agent.</td>
</tr>
<tr>
<td>Field</td>
<td>Dictionary</td>
<td>Format</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-------------------------------------------------</td>
<td>--------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Custom Calls Abandoned| apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob| Number | Total number calls that were deemed abandoned that agents or the system worked. This calculation is based on the settings in Completion Code Manager before the start of each job. |
| Idle Count            | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob| Number | Total number of idle states for an agent.                                                                                                 |
| Recalls Placed        | apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob| Number | Total number of outbound calls recalled by the system.                                                                                   |
| Manual Calls Placed   | apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob| Number | Total number of manual calls placed by the system.                                                                                        |
| Records Selected      | apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob| Number | Total records selected by the system.                                                                                                     |
| Serviced Calls        | apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob| Number | Total number of serviced calls.                                                                                                           |

**Calculated Data:**
<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
</table>
| Calls Offered per Hour           | apds-job
                       |        | The number of inbound and outbound calls available for the agents divided by the Online Time. This value is calculated from Calls Offered and Online Time. |
|                                  | apds-tdjob
                       |        |                                                                                                                                           |
|                                  | apds-monthjob
                       |        |                                                                                                                                           |
|                                  | apds-monthtdjob
                       |        |                                                                                                                                           |
| Calls Placed per Hour            | apds-job
                       |        | Total number of outbound calls the system made divided by the Online Time. This value is calculated from Calls Placed and Online Time.             |
|                                  | apds-tdjob
                       |        |                                                                                                                                           |
|                                  | apds-monthjob
                       |        |                                                                                                                                           |
|                                  | apds-monthtdjob
                       |        |                                                                                                                                           |
| Connects per Hour                | apds-agt
                       |        | Total number of inbound and outbound calls passed to the agent divided by the Online Time. This value is calculated from Connects and Online Time.  |
|                                  | apds-job
                       |        |                                                                                                                                           |
|                                  | apds-tdjob
                       |        |                                                                                                                                           |
|                                  | apds-monthagt
                       |        |                                                                                                                                           |
|                                  | apds-monthjob
                       |        |                                                                                                                                           |
|                                  | apds-monthtdjob
                       |        |                                                                                                                                           |
| Duty Cycle                       | apds-agt
                       |        | Total time the agent talked to the clients and updated records divided by the Online Time. This value is calculated from Work Time and Online Time. |
|                                  | apds-job
                       |        |                                                                                                                                           |
|                                  | apds-tdjob
                       |        |                                                                                                                                           |
|                                  | apds-monthagt
                       |        |                                                                                                                                           |
|                                  | apds-monthjob
                       |        |                                                                                                                                           |
|                                  | apds-monthtdjob
                       |        |                                                                                                                                           |
| Recalls Placed per Hour          | apds-job
                       |        | Total number of outbound calls the system recalled divided by the Online Time. This value is calculated from Recalls Placed and Online Time.       |
|                                  | apds-tdjob
                       |        |                                                                                                                                           |
|                                  | apds-monthjob
                       |        |                                                                                                                                           |
|                                  | apds-monthtdjob
                       |        |                                                                                                                                           |
Combined inbound and outbound job data on calls placed in the wait queue.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Elementary data</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Calls Abandoned</td>
<td>apds-job</td>
<td>Number</td>
<td>Calls Offered that were not passed to agents.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Calls Queued</td>
<td>apds-job</td>
<td>Number</td>
<td>Calls Offered that were placed in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Time in Wait Queue</td>
<td>apds-job</td>
<td>Number</td>
<td>Total number of hours that Calls Offered were in the wait queue.</td>
</tr>
<tr>
<td>(Hours)</td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Time in Wait Queue</td>
<td>apds-job</td>
<td>Number</td>
<td>Total number of minutes that Calls Offered were in the wait queue.</td>
</tr>
<tr>
<td>(Minutes)</td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Nuisance Calls</td>
<td>apds-job</td>
<td>Number</td>
<td>Total number of nuisance calls in the system.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Calculate data</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Abandon Rate of Offered</td>
<td>apds-job</td>
<td>Number</td>
<td>Calls Offered that clients abandoned divided by the total number of Calls Offered. This value is calculated from Calls Abandoned and Calls Offered.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Abandon Rate of Placed</td>
<td>apds-job</td>
<td>Number</td>
<td>Calls Offered that clients abandoned divided by the total number of Calls Placed. This value is calculated from Calls Abandoned and Calls Placed.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
General job and agent information fields are usually used for identifying a row of data on a report. These fields are also commonly used to group and filter data.
You can optionally use Hierarchy Manager fields to identify, group, and filter report data. For more information about Hierarchy Manager, see the Supervisor online help and the Using Supervisor documentation.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent ID</td>
<td>apds-agt</td>
<td>Character</td>
<td>The name that an agent uses to log in to the system.</td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-adminagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-agtreldist</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hierarchy Bottom Level</td>
<td>apds-agt</td>
<td>Character</td>
<td>Hierarchy level 1. ⬜ apds-agt and apds-monthagt dictionaries: The hierarchy level above Agent IDs. You can assign many agents to a level 1. You can only assign an agent to one level 1.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td>⬜ apds-job, apds-tdjob, apds-monthjob and apds-monthtdjob dictionaries: The hierarchy level above Job Names. You can assign many jobs to a level 1. You can only assign a job to one level 1.</td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hierarchy Middle Level</td>
<td>apds-agt</td>
<td>Character</td>
<td>Hierarchy level 2. You can assign each level 1 to more than one level 2. ⬜ apds-agt and apds-monthagt dictionaries: The second hierarchy level above Agent IDs.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td>⬜ apds-job, apds-tdjob, apds-monthjob and apds-monthtdjob dictionaries: The second hierarchy level above Job Names.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Field | Dictionary | Format | Description
--- | --- | --- | ---
Hierarchy Name | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Character | ● apds-agt and apds-monthagt dictionaries: The name of the hierarchical arrangement for Agent IDs.
● apds-job, apds-tdjob, apds-monthjob and apds-monthtdjob dictionaries: The name of the hierarchical arrangement for the Job Names.

Hierarchy Top Level | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Character | Hierarchy level 3. You can assign each level 2 to more than one level 3.
● apds-agt and apds-monthagt dictionaries: The third hierarchy level above Agent IDs.
● apds-job, apds-tdjob, apds-monthjob and apds-monthtdjob dictionaries: The third hierarchy level above Job Names.

Job Active Time (Hours) | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number | Total time the job called clients and processed calling results. This value includes the time agents were logged in to the system but were off-line. Off-line means agents are not waiting to talk to clients, talking to clients, or updating client records.

Job Record Selection | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob  
apds-adminagt  
apds-adminjob  
apds-agtreldist | Character | Record selection name used with the job.
<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Job Phone Strategy</td>
<td>apds-agt</td>
<td>Character</td>
<td>Phone strategy name used with the job.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-adminagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-adminjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-agtreldist</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Job Calling List</td>
<td>apds-agt</td>
<td>Character</td>
<td>Calling list name used with the job.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-adminagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-adminjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-agtreldist</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Job Description Label</td>
<td>apds-agt</td>
<td>Character</td>
<td>The job's description.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-adminagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-adminjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-agtreldist</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Job End Time</td>
<td>apds-agt</td>
<td>Character</td>
<td>Time when the job ended manually or automatically.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Job Name</td>
<td>apds-agt</td>
<td>Character</td>
<td>The name assigned to the job.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-adminagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-adminjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-agtreldist</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Field</td>
<td>Dictionary</td>
<td>Format</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>------------------------------------------------</td>
<td>---------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Job Number        | apds-agt
apds-job
apds-tdjob
apds-monthagt
apds-monthjob
apds-monthtdjob
apds-adminagt
apds-adminjob
apds-agtreldist   | Number                                         | The unique numeric identifier assigned to the job by the system. |
| Job Run Date      | apds-agt
apds-job
apds-tdjob
apds-monthagt
apds-monthjob
apds-monthtdjob
apds-adminagt
apds-adminjob
apds-agtreldist   | Character                                      | The date on which the job was run. NOTE: For “monthly” dictionaries, this date is the month represented by a date of the first of the month. |
| Job Script        | apds-agt
apds-job
apds-tdjob
apds-monthagt
apds-monthjob
apds-monthtdjob
apds-adminagt
apds-adminjob
apds-agtreldist   | Character                                      | The script name used with the job. |
| Job Start Time    | apds-agt
apds-job
apds-tdjob
apds-monthagt
apds-monthjob
apds-monthtdjob   | Character                                      | The time at which the job was started. |
| Job Type          | apds-agt
apds-job
apds-tdjob
apds-monthagt
apds-monthjob
apds-monthtdjob
apds-adminagt
apds-adminjob
apds-agtreldist   | Character                                      | Type of calls handled during the job: inbound only (INB), outbound only (OUT), or blend (BLND). |
### Field Dictionary Format Description

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Job Unit</td>
<td>apds-agt</td>
<td>Character</td>
<td>The Unit Work List assigned to the outbound job.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-adminagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-adminjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-agtreldist</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Login Time</td>
<td>apds-agt</td>
<td>Character</td>
<td>The first time an agent logged in to the job.</td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Logout Time</td>
<td>apds-agt</td>
<td>Character</td>
<td>The pre-defined time increment used to organize data within a Time of Day query or report. Increment options are:</td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td>● 10 minutes</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● 15 minutes</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● 30 minutes</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>● 60 minutes</td>
</tr>
<tr>
<td>System Name</td>
<td>apds-agt</td>
<td>Character</td>
<td>The name assigned to the calling system.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-adminagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-adminjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-agtreldist</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Time Segment</td>
<td>apds-tdjob</td>
<td>Character</td>
<td>The pre-defined time increment used to organize data within a Time of Day query or report. Increment option is 30 minutes.</td>
</tr>
</tbody>
</table>

---

Inbound call handling times
The total and average times the agent or agents performed inbound calling activities.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inbound Idle Time</td>
<td>apds-agt apds-job apds-tdjjob apds-monthagtt apds-monthjob apds-monthtdjob</td>
<td>Number</td>
<td>Total number of minutes the agent waited between connects.</td>
</tr>
<tr>
<td>(Minutes)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inbound Online Time</td>
<td>apds-agt apds-job apds-tdjjob apds-monthagtt apds-monthjob apds-monthtdjob</td>
<td>Number</td>
<td>Total number of hours the agent waited between connects, talked to clients, and updated records.</td>
</tr>
<tr>
<td>(Hours)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inbound Online Time</td>
<td>apds-agt apds-job apds-tdjjob apds-monthagtt apds-monthjob apds-monthtdjob</td>
<td>Number</td>
<td>Total number of minutes the agent waited between connects, talked to clients, and updated records.</td>
</tr>
<tr>
<td>(Minutes)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inbound Online Time</td>
<td>apds-job apds-tdjjob apds-monthagtt apds-monthjob apds-monthtdjob</td>
<td>Number</td>
<td>Total number of seconds the agent waited between connects, talked to clients, and updated records.</td>
</tr>
<tr>
<td>(Seconds)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inbound Talk Time</td>
<td>apds-agt apds-job apds-tdjjob apds-monthagtt apds-monthjob apds-monthtdjob</td>
<td>Number</td>
<td>Total number of minutes for which the agent talked to clients.</td>
</tr>
<tr>
<td>(Minutes)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inbound Update Time</td>
<td>apds-agt apds-job apds-tdjjob apds-monthagtt apds-monthjob apds-monthtdjob</td>
<td>Number</td>
<td>Total number of minutes after a call ended that the agent updated the records.</td>
</tr>
<tr>
<td>(Minutes)</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Inbound Work Time

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
</table>
| Inbound Work Time (Hours) | apds-job  
apds-monthjob      | Number  | Total number of hours the agent talked to clients and updated records.       |
| Inbound Work Time (Minutes) | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number  | Total number of minutes the agent talked to clients and updated records.     |

### Calculated Data:

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
</table>
| Average Inbound Idle Time (Minutes) | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number  | Average number of minutes the agent waited between connects.                |
| Average Inbound Idle Time (Seconds) | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number  | Average number of seconds the agent waited between connects.                |
| Average Inbound Talk Time (Minutes) | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number  | Average number of minutes the agent talked to the clients.                  |
| Average Inbound Talk Time (Seconds) | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number  | Average number of seconds the agent talked to the clients.                  |
| Average Inbound Update Time (Minutes) | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number  | Average number of minutes after a call ended that the agent updated records. |
Inbound call statistics

Inbound only job performance and connectivity data.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Average Inbound</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Update Time</strong></td>
<td>apds-agt</td>
<td>Number</td>
<td>Average number of seconds after</td>
</tr>
<tr>
<td>(Seconds)</td>
<td>apds-job</td>
<td></td>
<td>a call ended that the agent</td>
</tr>
<tr>
<td></td>
<td>apds-tjob</td>
<td></td>
<td>updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-monthag</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>tjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-montht</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>djob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtd</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Average Inbound</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Work Time</strong></td>
<td>apds-agt</td>
<td>Number</td>
<td>Average number of minutes the agent</td>
</tr>
<tr>
<td>(Minutes)</td>
<td>apds-job</td>
<td></td>
<td>talked to the clients and</td>
</tr>
<tr>
<td></td>
<td>apds-tjob</td>
<td></td>
<td>updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-monthag</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>tjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-montht</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>djob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtd</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Average Inbound</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Work Time</strong></td>
<td>apds-agt</td>
<td>Number</td>
<td>Average number of seconds the agent</td>
</tr>
<tr>
<td>(Seconds)</td>
<td>apds-job</td>
<td></td>
<td>talked to the clients and</td>
</tr>
<tr>
<td></td>
<td>apds-tjob</td>
<td></td>
<td>updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-monthag</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>tjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-montht</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>djob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtd</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>monthtdjob</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Field Dictionary Format Description**

**Elementary Data:**

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Inbound Calls</strong></td>
<td>apds-job</td>
<td>Number</td>
<td>The number of inbound calls handled by the system. This value includes</td>
</tr>
<tr>
<td><strong>Offered</strong></td>
<td>apds-tjob</td>
<td></td>
<td>calls passed to the agents and calls abandoned in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apds-montht</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>djob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Inbound Connects</strong></td>
<td>apds-agt</td>
<td>Number</td>
<td>Total number of calls passed to the agent.</td>
</tr>
<tr>
<td>**</td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>tjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>monthtdjob</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Inbound queue statistics

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inbound Idle Count</td>
<td><code>apds-agt</code> <code>apds-job</code> <code>apds-tdjob</code> <code>apds-monthagt</code> <code>apds-monthjob</code> <code>apds-monthtdjob</code></td>
<td>Number</td>
<td>Total number of inbound idle states for the agent.</td>
</tr>
<tr>
<td>Calculated Data:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inbound Allocation</td>
<td><code>apds-agt</code> <code>apds-job</code> <code>apds-tdjob</code> <code>apds-monthagt</code> <code>apds-monthjob</code> <code>apds-monthtdjob</code></td>
<td>Number</td>
<td>Total time the agent handled inbound calls divided by the Online Time. This value is calculated from Inbound Online Time and Online Time.</td>
</tr>
<tr>
<td>Inbound Calls Offered per Hour</td>
<td><code>apds-job</code> <code>apds-tdjob</code> <code>apds-monthjob</code> <code>apds-monthtdjob</code></td>
<td>Number</td>
<td>The number of Inbound Calls Offered divided by the Inbound Online Time. This value is calculated from Inbound Calls Offered and Inbound Online Time.</td>
</tr>
<tr>
<td>Inbound Connect Rate</td>
<td><code>apds-job</code> <code>apds-monthjob</code></td>
<td>Number</td>
<td>The number of Inbound Connects divided by Inbound Calls Offered.</td>
</tr>
<tr>
<td>Inbound Connects per Hour</td>
<td><code>apds-agt</code> <code>apds-job</code> <code>apds-tdjob</code> <code>apds-monthagt</code> <code>apds-monthjob</code> <code>apds-monthtdjob</code></td>
<td>Number</td>
<td>Total number of calls passed to the agent divided by Inbound Online Time. This value is calculated from Inbound Connects and Inbound Online Time.</td>
</tr>
<tr>
<td>Inbound Duty Cycle</td>
<td><code>apds-agt</code> <code>apds-job</code> <code>apds-tdjob</code> <code>apds-monthagt</code> <code>apds-monthjob</code> <code>apds-monthtdjob</code></td>
<td>Number</td>
<td>Total time the agent talked to inbound clients and updated records divided by the Inbound Online Time. This value is calculated from Inbound Work Time and Inbound Online Time.</td>
</tr>
</tbody>
</table>
Inbound only data on calls placed in the wait queue.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Elementary Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inbound Calls Queued</td>
<td>apds-job</td>
<td>Number</td>
<td>Inbound Calls Offered that were placed in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inbound Calls Abandoned</td>
<td>apds-job</td>
<td>Number</td>
<td>Inbound Calls Offered that were not passed to the agents.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inbound Time on Queue (Hours)</td>
<td>apds-job</td>
<td>Number</td>
<td>Total number of hours inbound calls offered are in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inbound Time on Queue (Minutes)</td>
<td>apds-job</td>
<td>Number</td>
<td>Total number of minutes inbound calls offered are in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Calculated Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Average Inbound Time in Queue (Minutes)</td>
<td>apds-job</td>
<td>Number</td>
<td>Average number of minutes Inbound Calls Offered were in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Average Inbound Time in Queue (Seconds)</td>
<td>apds-job</td>
<td>Number</td>
<td>Average number of seconds Inbound Calls Offered were in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inbound Abandoned Rate of Offered</td>
<td>apds-job</td>
<td>Number</td>
<td>Inbound Calls Offered that clients abandoned divided by the Inbound Calls Offered. This value is calculated from Inbound Calls Abandoned and Inbound Calls Offered.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Managed dialing statistics

This table shows managed dialing data.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Inbound Calls Abandoned per Hour** | apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob | Number | Inbound Calls Offered that were not passed to the agents divided by the Inbound Online Time. This value is calculated from Inbound Calls Abandoned and Inbound Online Time. |
| **Inbound Calls Queued per Hour** | apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob | Number | Inbound Calls Offered that were placed in the wait queue divided by the Inbound Online Time. This value is calculated from Inbound Calls Offered and Inbound Online Time. |

### Elementary Data:

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
</table>
| Calls Canceled                | apds-agt  
apds-job  
apds-tdjob  
apds-monthag  
apds-monthjob  
apds-monthtdjob | Number | Total number of records the agent previewed and then canceled the call.     |
| Records Previewed             | apds-agt  
apds-job  
apds-tdjob  
apds-monthag  
apds-monthjob  
apds-monthtdjob | Number | Total number of records the agent previewed.                               |
| Preview Time (Minutes)        | apds-agt  
apds-job  
apds-tdjob  
apds-monthag  
apds-monthjob  
apds-monthtdjob | Number | Total number of minutes the agent previewed records before the system placed the call or the agent canceled the call. |
<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Calculated Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Average Preview Time</td>
<td>apds-agt</td>
<td>Number</td>
<td>Average number of minutes the agent previewed client records before the system placed the call or canceled the call.</td>
</tr>
<tr>
<td>(Minutes)</td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Average Preview Time</td>
<td>apds-job</td>
<td>Number</td>
<td>Average number of seconds the agent previewed client records before the system placed the call or canceled the call.</td>
</tr>
<tr>
<td>(Seconds)</td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Calls Canceled per</td>
<td>apds-agts</td>
<td>Number</td>
<td>Total number of records the agent previewed and then canceled the call divided by the Online Time. This value is calculated from Calls Canceled and Online Time.</td>
</tr>
<tr>
<td>Hour</td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Records Previewed per</td>
<td>apds-agt</td>
<td>Number</td>
<td>Total number of records the agent previewed divided by the Online Time. This value is calculated from Records Previewed and Online Time.</td>
</tr>
<tr>
<td>Hour</td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
The total and average times the agent performed outbound only calling activities.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Elementary Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Idle Time</td>
<td>apds-agt</td>
<td>Number</td>
<td>Total number of minutes the agent waited between connects.</td>
</tr>
<tr>
<td>(Minutes)</td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Online Time</td>
<td>apds-agt</td>
<td>Number</td>
<td>Total number of hours the agent waited between connects, talked to clients,</td>
</tr>
<tr>
<td>(Hours)</td>
<td>apds-job</td>
<td></td>
<td>and updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Online Time</td>
<td>apds-agt</td>
<td>Number</td>
<td>Total number of minutes the agent waited between connects, talked to clients,</td>
</tr>
<tr>
<td>(Minutes)</td>
<td>apds-job</td>
<td></td>
<td>and updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Online Time</td>
<td>apds-agt</td>
<td>Number</td>
<td>Total number of seconds the agent waited between connects, talked to clients,</td>
</tr>
<tr>
<td>(Seconds)</td>
<td>apds-job</td>
<td></td>
<td>and updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Talk Time</td>
<td>apds-agt</td>
<td>Number</td>
<td>Total number of minutes the agent talked to clients.</td>
</tr>
<tr>
<td>(Minutes)</td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Work Time</td>
<td>apds-job</td>
<td>Number</td>
<td>Total number of hours the agent talked to clients and updated records.</td>
</tr>
<tr>
<td>(Hours)</td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Field</td>
<td>Dictionary</td>
<td>Format</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------</td>
<td>---------------------------------------------------------------------------</td>
<td>--------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Outbound Work Time (Minutes) | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number | Total number of minutes the agent talked to clients and updated records.   |
| Outbound Update Time (Minutes) | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number | Total number of minutes after a call ended that the agent updated records. |

**Calculated Data:**

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
</table>
| Average Outbound Idle Time (Minutes) | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number | Average number of minutes the agent waited between connects.                |
| Average Outbound Idle Time (Seconds) | apds-agts  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number | Average number of seconds the agent waited between connects.               |
| Average Outbound Talk Time (Minutes) | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number | Average number of minutes the agent talked to clients.                     |
| Average Outbound Talk Time (Seconds) | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number | Average number of seconds the agent talked to clients.                     |
### Outbound call statistics

This table describes the Outbound only job performance and connectivity data.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Average Outbound Update</strong>&lt;br&gt;<strong>Time (Minutes)</strong></td>
<td>apds-agt&lt;br&gt;apds-job&lt;br&gt;apds-tdjob&lt;br&gt;apds-monththdagt&lt;br&gt;apds-monthjob&lt;br&gt;apds-monthtdjob</td>
<td>Number</td>
<td>Average number of minutes after a call ended that the agent updated records.</td>
</tr>
<tr>
<td><strong>Average Outbound Update</strong>&lt;br&gt;<strong>Time (Seconds)</strong></td>
<td>apds-agt&lt;br&gt;apds-job&lt;br&gt;apds-tdjob&lt;br&gt;apds-monththdagt&lt;br&gt;apds-monthjob&lt;br&gt;apds-monthtdjob</td>
<td>Number</td>
<td>Average number of seconds after a call ended that the agent updated records.</td>
</tr>
<tr>
<td><strong>Average Outbound Work Time</strong>&lt;br&gt;<strong>Time (Minutes)</strong></td>
<td>apds-agt&lt;br&gt;apds-job&lt;br&gt;apds-tdjob&lt;br&gt;apds-monththdagt&lt;br&gt;apds-monthjob&lt;br&gt;apds-monthtdjob</td>
<td>Number</td>
<td>Average number of minutes the agent talked to clients and updated records.</td>
</tr>
<tr>
<td><strong>Average Outbound Work Time</strong>&lt;br&gt;<strong>Time (Seconds)</strong></td>
<td>apds-agt&lt;br&gt;apds-job&lt;br&gt;apds-tdjob&lt;br&gt;apds-monththdagt&lt;br&gt;apds-monthjob&lt;br&gt;apds-monthtdjob</td>
<td>Number</td>
<td>Average number of seconds the agent talked to clients and updated records.</td>
</tr>
</tbody>
</table>

**Elementary Data:**

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outbound Calls Offered</td>
<td>apds-job&lt;br&gt;apds-tdjob&lt;br&gt;apds-monthjob&lt;br&gt;apds-monthtdjob</td>
<td>Number</td>
<td>The number of Outbound Calls Placed that result in an answer. Outbound Calls Offered might be voice contact or answering machine if the job is set up to pass answering machines to the agents.</td>
</tr>
</tbody>
</table>
### Outbound call statistics

#### Field Dictionary Format Description

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outbound Calls Placed</td>
<td>apds-job</td>
<td>Number</td>
<td>Total number of outbound calls the system made.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Connects</td>
<td>apds-agt</td>
<td>Number</td>
<td>Total number of calls passed to the agent.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthag</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Idle Count</td>
<td>apds-agt</td>
<td>Number</td>
<td>Total number of outbound idle states for the agent.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthag</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Recalls Placed</td>
<td>apds-job</td>
<td>Number</td>
<td>Total number of calls the system recalled.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

#### Calculated Data:

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outbound Allocation</td>
<td>apds-agt</td>
<td>Number</td>
<td>Total time the agent handled outbound calls divided by the Online Time. This value is calculated from Outbound Online Time and Online Time.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthag</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Calls Offered per Hour</td>
<td>apds-job</td>
<td>Number</td>
<td>Outbound Calls Offered to the agents divided by the Outbound Online Time. This value is calculated from Outbound Calls Offered and Outbound Online Time.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Calls Placed per Hour</td>
<td>apds-job</td>
<td>Number</td>
<td>Total number of outbound calls the system made divided by the Outbound Online Time. This value is calculated from Outbound Calls Placed and Outbound Online Time.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Outbound queue statistics

This table shows the outbound only calling data on calls placed in the wait queue.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Outbound Connects per Hour</strong></td>
<td>apds-agt</td>
<td>Number</td>
<td>Total number of calls passed to the agent divided by Outbound Online Time.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monththag</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Outbound Duty Cycle</strong></td>
<td>apds-agt</td>
<td>Number</td>
<td>Total time agent talked to outbound the clients and updated records divided</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td>by the Outbound Online Time. This value is calculated from Outbound Work</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td>Time and Outbound Online Time.</td>
</tr>
<tr>
<td></td>
<td>apds-monththag</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Outbound Recalls Placed per Hour</strong></td>
<td>apds-job</td>
<td>Number</td>
<td>Total number of calls the system recalled divided by the Outbound Online</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td>Time. This value is calculated from Outbound Recalls Placed and Outbound</td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td>Online Time.</td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Elementary Data:

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Outbound Calls Abandoned</strong></td>
<td>apds-job</td>
<td>Number</td>
<td>Outbound Calls Offered that were not passed to the agents.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Outbound Calls Queued</strong></td>
<td>apds-job</td>
<td>Number</td>
<td>Outbound Calls Offered that were placed in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Outbound Time in Queue (Hours)</strong></td>
<td>apds-job</td>
<td>Number</td>
<td>Total number of hours Outbound Calls Offered are in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Field</td>
<td>Dictionary</td>
<td>Format</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>---------------------</td>
<td>--------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Outbound Time in Queue (Minutes)</td>
<td>apds-job</td>
<td>Number</td>
<td>Total number of minutes Outbound Calls Offered were in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Calculated Data:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Average Outbound Time in Queue (Minutes)</td>
<td>apds-job</td>
<td>Number</td>
<td>Average number of minutes Outbound Calls Offered are in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Average Outbound Time in Queue (Seconds)</td>
<td>apds-job</td>
<td>Number</td>
<td>Average number of seconds Outbound Calls Offered are in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Abandoned Rate of Offered</td>
<td>apds-job</td>
<td>Number</td>
<td>Outbound Calls Offered that clients abandoned divided by the total number of</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td>calls answered. This value is calculated from Outbound Calls Abandoned and</td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td>Outbound Calls Offered.</td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Abandon Rate of Placed</td>
<td>apds-job</td>
<td>Number</td>
<td>Outbound Calls Offered that clients abandoned divided by the total number of</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td>calls the system made. This value is calculated from Outbound Calls Abandoned</td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td>and Outbound Calls Placed.</td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Calls Abandoned per Hour</td>
<td>apds-job</td>
<td>Number</td>
<td>Outbound Calls Offered that were not passed to the agents divided by the</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td>Outbound Online Time. This value is calculated from Outbound Calls Abandoned</td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td>and Outbound Online Time.</td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Calls Queued per Hour</td>
<td>apds-job</td>
<td>Number</td>
<td>Outbound Calls Offered that were placed in the wait queue divided by the</td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td>Outbound Online Time. This value is calculated from Outbound Calls Abandoned</td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td>and Outbound Online Time.</td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Person to Person call handling times

Total and average times the Person to Person (PTP) agent or agents performed job activities.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Elementary Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>PTP Idle Time (Minutes)</td>
<td>apds-agt</td>
<td>Number</td>
<td>Total number of minutes the agent waited to talk to clients.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PTP Online Time (Hours)</td>
<td>apds-agt</td>
<td>Number</td>
<td>Total number of hours the agent waited between connects, talked to clients, and updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PTP Online Time (Minutes)</td>
<td>agt-agt</td>
<td>Number</td>
<td>Total number of minutes the agent waited between connects, talked to clients, and updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PTP Online Time (Seconds)</td>
<td>apds-agt</td>
<td>Number</td>
<td>Total number of seconds the agent waited between connects, talked to clients, and updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PTP Talk Time (Minutes)</td>
<td>agt-agt</td>
<td>Number</td>
<td>Total number of minutes the agent talked to clients.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Field</td>
<td>Dictionary</td>
<td>Format</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------</td>
<td>----------------------------------</td>
<td>---------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>PTP Update Time (Minutes)</td>
<td>agt-agt apds-job apds-tdjob apds-monthagt apds-monthjob apds-monthtdjob</td>
<td>Number</td>
<td>Total number of minutes after a call ended that the agent updated records.</td>
</tr>
<tr>
<td>PTP Work Time (Minutes)</td>
<td>agt-agt apds-job apds-tdjob apds-monthagt apds-monthjob apds-monthtdjob</td>
<td>Number</td>
<td>Total number of minutes the agent talked to clients and updated records.</td>
</tr>
</tbody>
</table>

**Calculated Data:**

<table>
<thead>
<tr>
<th>Average PTP Idle Time (Minutes)</th>
<th>apds-agt apds-job apds-tdjob apds-monthagt apds-monthjob apds-monthtdjob</th>
<th>Number</th>
<th>Average number of minutes the agent waited between connects.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average PTP Idle Time (Seconds)</td>
<td>apds-agt apds-job apds-tdjob apds-monthagt apds-monthjob apds-monthtdjob</td>
<td>Number</td>
<td>Average number of seconds the agent waited between connects.</td>
</tr>
<tr>
<td>Average PTP TalkTime (Minutes)</td>
<td>apds-agt apds-job apds-tdjob apds-monthagt apds-monthjob apds-monthtdjob</td>
<td>Number</td>
<td>Average number of minutes the agent talked to clients.</td>
</tr>
<tr>
<td>Average PTP TalkTime (Seconds)</td>
<td>apds-agt apds-job apds-tdjob apds-monthagt apds-monthjob apds-monthtdjob</td>
<td>Number</td>
<td>Average number of seconds the agent talked to clients.</td>
</tr>
</tbody>
</table>
### Person to Person call statistics

This table shows the Person to Person job performance and connectivity data.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Elementary Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>PTP Connects</td>
<td>apds-agt apds-job apds-tdjob apds-monthagt apds-monthjob apds-monthtdjob</td>
<td>Number</td>
<td>Total number of outbound connects passed to an agent.</td>
</tr>
</tbody>
</table>
### Combined RPC and closure statistics

This table shows the Right Party (RPC) and Closure statistics data.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Field</td>
<td>Dictionary</td>
<td>Format</td>
<td>Description</td>
</tr>
<tr>
<td>PTP Idle Count</td>
<td>apds-agt</td>
<td>Number</td>
<td>Total number of PTP idle states for an agent.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PTP Allocation</td>
<td>apds-agt</td>
<td>Number</td>
<td>Total time the agent handled calls divided by the Online Time. This value is calculated from PTP Online Time and Online Time.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PTP Duty Cycle</td>
<td>apds-agt</td>
<td>Number</td>
<td>Total time the agent talked to clients and updated records divided by the Online Time. This value is calculated from PTP Work Time and PTP Online Time.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PTP Connects per Hour</td>
<td>apds-agt</td>
<td>Number</td>
<td>Total number of outbound connects passed to the agent divided by PTP Online Time. This value is calculated from PTP Connects and PTP Online Time.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Field</td>
<td>Dictionary</td>
<td>Format</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>---------------------------------------------------------------------------</td>
<td>----------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Closure Per Hour       | apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number   | Total number of calls that the agent assigned as a closure call completion code per hour.                                                  |
| Closure Rate           | apds-tdjob  
apds-monthtdjob                                             | Number   | Rate of calls that the agent assigned as a closure call completion code.                                                                 |
| Closure Rate of Connects| apds-job  
apds-monthagt  
apds-monthjob                                | Number   | Rate of calls that the agent connects.                                                                                                  |
| Closure Rate of RPC’s  | apds-job  
apds-monthagt  
apds-monthjob                                | Number   | Rate of calls to which the agent assigned as a RPC.                                                                                      |
| Non-Right Party Contact Rate | apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number   | Total number of calls to which the agent did not assign an RPC completion code divided by the total number of calls passed to the agents. This value is calculated from Non-Right Party Contact Count and Connects. |
| Non-Right Party Contact Count | apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number   | Total number of calls to which the agent did not assign an RPC completion code.                                                          |
| Right Party Contact Count | apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number   | Total number of calls to which the agent assigned an RPC completion code.                                                               |
| Right Party Contact Rate | apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Number   | Total number of calls to which the agent assigned an RPC completion code divided by the total number of calls passed to agents. This value is calculated from Right Party Contact Count and Connects. |
### Field Dictionary Format Description

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Right Party Contacts per Hour</td>
<td>apds-job apds-tdjob apds-monthagt apds-monthjob apds-monthtdjob</td>
<td>Number</td>
<td>Total number of calls to which the agent assigned an RPC completion code divided by the Online Time. This value is calculated from Right Party Contact Count and Online Time.</td>
</tr>
<tr>
<td>Non-Right Party Contact per Hour</td>
<td>apds-job apds-tdjob apds-monthagt apds-monthjob apds-monthtdjob</td>
<td>Number</td>
<td>Total number of calls to which the agent did not assign an RPC completion code divided by the Online Time. This value is calculated from Non-Right Party Contact Count and Online Time.</td>
</tr>
<tr>
<td>Right Party Contact Closure Rate</td>
<td>apds-tdjob apds-monthtdjob</td>
<td>Number</td>
<td>Total number of calls to which the agent assigned an RPC completion code divided by the total number of closure calls passed to agents. This value is calculated from Right Party Contact Count and closure call.</td>
</tr>
</tbody>
</table>

---

**Combined call completion code statistics**

This table contains the call completion codes count that the agents or the system uses to record the disposition of contacts and contact attempts.
**Note:**
The Recorded by column replaces the Format column. The Format column identifies whether an agent or the system released the call. All completion code counts are numbers.

The following completion codes and descriptions represent the common configuration of the Avaya Proactive Contact system. The configuration of your system might be different.

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Recorded by</th>
<th>Description</th>
</tr>
</thead>
</table>
| All Agent Call Completion Codes | apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob | Agent       | Total number of agent-generated call completion codes. |
| All Call Completion Codes   | apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob | Agent and System | Total number of agent-generated and system-generated call completion codes. |
| Code00 NOTCALLED            | apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob | System      | The account was not called.                           |
| Code01 CODE1               | apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob | System      | Reserved for system.                                  |
| Code02 ERROR               | apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob | System      | The system detected an invalid phone number.          |
| Code03 TIMEOUT             | agt-agt  
apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob | System      | The system did not receive a dial tone.               |
| Code04 HANG_PORT           | apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob | System      | The system did not receive a dial tone.               |
<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Recorded by</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Code05</td>
<td>apds-job</td>
<td>System</td>
<td>The local time for the client phone is outside calling hours.</td>
</tr>
<tr>
<td>NOTINZONE</td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code06</td>
<td>apds-job</td>
<td>System</td>
<td>Native voice and data transfer: Agent transfers call to inbound agent without remaining on the line. This transfer is known as a blind transfer.</td>
</tr>
<tr>
<td>MOFLASH_B</td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code07</td>
<td>apds-job</td>
<td>System</td>
<td>No agent available for a supervisor transfer.</td>
</tr>
<tr>
<td>HANG_TRANS</td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code08</td>
<td>apds-job</td>
<td>System</td>
<td>ADAPTS API: Agent transfers call without remaining on the line. This transfer is known as a blind hookflash transfer.</td>
</tr>
<tr>
<td>TDSS_HF_B</td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code09 and</td>
<td>apds-job</td>
<td>System</td>
<td>Reserved for system.</td>
</tr>
<tr>
<td>Code10</td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code11</td>
<td>apds-job</td>
<td>System</td>
<td>The system detected a busy signal.</td>
</tr>
<tr>
<td>BUSY</td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code12</td>
<td>apds-job</td>
<td>System</td>
<td>The system detected a continuous tone, such as a fax or modem.</td>
</tr>
<tr>
<td>CONTTONE</td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code13</td>
<td>apds-job</td>
<td>System</td>
<td>The system detected an answering machine.</td>
</tr>
<tr>
<td>AUTOVOICE</td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code14</td>
<td>apds-job</td>
<td>System</td>
<td>Interim code when a person is on the line.</td>
</tr>
<tr>
<td>VOICE</td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Field</td>
<td>Dictionary</td>
<td>Recorded by</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-------------</td>
<td>------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Code15 NOANSWER | apds-job
apds-tdjob
apds-monthjob
apds-monthtdjob                             | System      | The call placed was not answered.                                                                      |
| Code16 RINGING      | apds-agt
apds-job
apds-tdjob
apds-monthagt
apds-monthjob
apds-monthtdjob                             | System      | Can be user defined but is usually defined as a phone call that was still ringing but was passed to an agent. |
| Code17 CUSTHU       | apds-agt
apds-job
apds-tdjob
apds-monthagt
apds-monthjob
apds-monthtdjob                             | System      | Can be user defined but is usually defined as a client hang-up while the call was in the wait queue but the call was passed to an agent. |
| Code18 TRANSFER     | apds-agt
apds-job
apds-tdjob
apds-monthagt
apds-monthjob
apds-monthtdjob                             | System      | Can be user defined but is usually defined as a transfer release.                                       |
| Code19 RECALL       | apds-agt
apds-job
apds-tdjob
apds-monthagt
apds-monthjob
apds-monthtdjob                             | Agent       | Can be user defined but is usually defined as a recall release.                                        |
| Code20 through Code34 | apds-agt
apds-job
apds-tdjob
apds-monthagt
apds-monthjob
apds-monthtdjob                             | Agent       | User defined.                                                                                          |
| Code35 CANCEL       | apds-agt
apds-job
apds-tdjob
apds-monthagt
apds-monthjob
apds-monthtdjob                             | Agent       | Can be user defined but is typically defined as the agent canceled the managed call.                   |
## Combined call completion code statistics

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Recorded by</th>
<th>Description</th>
</tr>
</thead>
</table>
| Code36 INTERCEPT | apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob | System      | Special Information Tone (SIT) indicating an operator intercept.            |
| Code37 NOCIRCUIT | apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | System      | Special Information Tone (SIT) indicating that circuits are unavailable.   |
| Code38 DISCONN | apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob | System      | Special Information Tone (SIT) indicating that the call reached a disconnected number. |
| Code39 VACANT | apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob | System      | Special Information Tone (SIT) indicating that the call cannot be completed as dialed. |
| Code40 RECORDER | apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob | System      | The call resulted in a fast busy tone.                                     |
| Code41 R_RINGING | apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob | System      | Internal system code.                                                      |
| Code42 LINEFAIL | apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob | System      | A failure on the phone line occurred.                                      |
| Code43 OP_RECALL | apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob | System      | Internal system code.                                                      |
| Code44 DTMF_V | apds-job  
apds-tdjob  
apds-monthjob  
apds-monthtdjob | Agent       | Internal system code.                                                      |
<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Recorded by</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Code45 HU_INB</td>
<td>apds-job&lt;br&gt;apds-tdjjob&lt;br&gt;apds-monthjob&lt;br&gt;apds-monthtdjob</td>
<td>System</td>
<td>The client hung-up while in the inbound wait queue.</td>
</tr>
<tr>
<td>Code46 HU_OUT</td>
<td>apds-job&lt;br&gt;apds-tdjjob&lt;br&gt;apds-monthjob&lt;br&gt;apds-monthtdjob</td>
<td>System</td>
<td>The client hung-up while in the outbound wait queue.</td>
</tr>
<tr>
<td>Code47 HANG_INB</td>
<td>apds-job&lt;br&gt;apds-tdjjob&lt;br&gt;apds-monthjob&lt;br&gt;apds-monthtdjob</td>
<td>System</td>
<td>An agent was not available for the inbound call.</td>
</tr>
<tr>
<td>Code48 HANG_OUT</td>
<td>apds-job&lt;br&gt;apds-tdjjob&lt;br&gt;apds-monthjob&lt;br&gt;apds-monthtdjob</td>
<td>System</td>
<td>An agent was not available for the outbound call.</td>
</tr>
<tr>
<td>Code49 OPDIED</td>
<td>apds-job&lt;br&gt;apds-tdjjob&lt;br&gt;apds-monthjob&lt;br&gt;apds-monthtdjob</td>
<td>System</td>
<td>The agent session ended abnormally.</td>
</tr>
<tr>
<td>Code50 R_HSONHOOK</td>
<td>apds-agt&lt;br&gt;apds-job&lt;br&gt;apds-tdjjob&lt;br&gt;apds-monthagt&lt;br&gt;apds-monthjob&lt;br&gt;apds-monthtdjob</td>
<td>System</td>
<td>Internal system code.</td>
</tr>
<tr>
<td>Code51 through Code88 and Code100 through Code199</td>
<td>apds-agt&lt;br&gt;apds-job&lt;br&gt;apds-tdjjob&lt;br&gt;apds-monthagt&lt;br&gt;apds-monthjob&lt;br&gt;apds-monthtdjob</td>
<td>Agent</td>
<td>User defined.</td>
</tr>
<tr>
<td>Code89 MANAGEDA</td>
<td>apds-agt&lt;br&gt;apds-job&lt;br&gt;apds-tdjjob&lt;br&gt;apds-monthagt&lt;br&gt;apds-monthjob&lt;br&gt;apds-monthtdjob</td>
<td>Agent</td>
<td>Managed Dial: Managed non-connection.</td>
</tr>
<tr>
<td>Field</td>
<td>Dictionary</td>
<td>Recorded by</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------------------------------------------</td>
<td>-------------</td>
<td>--------------------------------------------------</td>
</tr>
</tbody>
</table>
| Code90 MANAGEDB | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Agent       | Managed Dial: Managed non-connection.            |
| Code91 VIRTVOICE | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Agent       | Virtual Agent: Virtual message to VOICE.         |
| Code92 VIRTAUTOV | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Agent       | Virtual Agent: Virtual message to AUTOVOICE.     |
| Code93 SOLD | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Agent       | Sales Verification: Sold campaign                |
| Code94 VERIFIED | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Agent       | Sales Verification: Sale verified.               |
| Code95 UNVERIFIED | apds-agt  
apds-job  
apds-tdjob  
apds-monthagt  
apds-monthjob  
apds-monthtdjob | Agent       | Sales Verification: Sales not verified.          |
## Chapter 35: Data dictionary reference

<table>
<thead>
<tr>
<th>Field</th>
<th>Dictionary</th>
<th>Recorded by</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Code96 through Code99</td>
<td>apds-agt</td>
<td>Agent</td>
<td>Reserved for system.</td>
</tr>
<tr>
<td></td>
<td>apds-job</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>All System Call Completion</td>
<td>apds-job</td>
<td>System</td>
<td>Total number of system-generated</td>
</tr>
<tr>
<td>Codes</td>
<td>apds-tdjob</td>
<td></td>
<td>call completion code.</td>
</tr>
<tr>
<td></td>
<td>apds-monthjob</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjob</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Chapter 36: Use Monitor views

Monitor uses the button bar in the left-hand side of the window as the primary navigation point for opening views. Monitor displays views in window on right-hand side of your screen.

You can do the following tasks from the Monitor button bar:

- Open and save favorite views
- Display views according to completion codes
- Display views according to agent and supervisor relationships
- Configure alerts so that you can receive notifications from the Avaya Proactive Contact.

This section contains the following topics

- Understanding view windows on page 445
- Using views on page 448

Understanding view windows

A view displays information about dialers, jobs, agents, and completion codes in a separate window.

In Monitor, you can create views, save the view when you exit Monitor, and then restore the views. This feature allows you to use the same views without recreating specific views.

Use the button bar to access and organize the available views. Use the View toolbar to modify how the view displays data.

This section contains the following topics:

- Types of views on page 445
- View toolbar on page 447

Types of views

Use the Monitor button bar to display the following types of views:

**View Set** - Displays the set of views that you create and save.

**Dialer** - Lists views that display calling activity data about dialers.
Chapter 36: Use Monitor views

- Dialer Status - Displays the job, agent, and line resources used on a dialer. For view details, see Dialer Status view on page 449.
- Dialer Agents - Displays the agents logged in to one or more dialers. For view details, see Dialer Agents view on page 450.
- Dialer Lines - Displays line assignments and activity levels for each job. For view details, see Dialer Lines view on page 451.
- Dialer History - Displays dialer activity over time. For view details, see Dialer History view on page 452.

**Job** - Lists views that display calling activity data about jobs:

- Job Status - Displays the job, agent, and line resources used on a dialer that are grouped and totaled by the job. For view details, see Job Status view on page 453.
- Job Agents - Displays the agents who have joined the jobs. For view details, see Job Agents view on page 455.
- Job Detail - Displays detailed information about the performance of a job, including connect, RPC, and closure rates. For view details, see Job Detail view on page 456.
- Job Call Handling - Displays the amount of time each agent spends on talking to customers, updating records, and waiting for the next call. For view details, see Job Call Handling view on page 458.
- Job Completion Codes - Displays completion codes used during the job. For view details, see Job Completion Codes view on page 459.
- Job Wait Queues - Displays information about calls directed to the wait queue during a job, including the number of calls currently in queue, the number abandoned, and the average wait time for each call. For view details, see Job Wait Queues view on page 463.
- Job History - Displays dialer activity over time grouped by job. For view details, see Job History view on page 465.
- Job Performance - Compares agent performance on a selected completion code. For view details, see Completion Code Detail by Agent view on page 466.
- Job Quality - Displays information about the quality of service that dialers achieve during a job. For view details, see Job Quality view on page 467.

**Supervisor** - Displays information about Supervisor Agents. For view details, see Supervisor Agents view on page 469.

Displays the agents active on one or more dialers grouped by job.

**Agent** - Displays information about. Agent data for a job and allows you to find an agent. For view details, see Find Agent view on page 471.

**Custom** - Displays the customized views that you create.
You can display a view about a specific agent from any view that lists agents from the Tools menu. For more information see, Open a view about a specific agent on page 299.

**Note:**
If two agents log on with the same names to a job on multiple dialers in a pod, then the Monitor views include only one occurrence from one of the dialers.

---

**View toolbar**

You can use the view toolbar to display the information in the following formats:

**Table view** - Displays the data without icons. **Table View** is enabled if the view has two presentation modes.

**Graphic View** - Displays the data with icons. **Graphic View** is enabled if the view has two presentation modes.

**Filter Data** - Allows you to filter the data in the view according to one selected criteria.

**Hide/Show Columns** - Allows you to select which of the available data fields appear.

**Find Item** - Allows you to search for a text string within a view. For example, search for a specific agent or job.

**Hierarchy Manager** - Allows you to choose the type of data that appears in the view:
- No hierarchy
- The default supervisor/agent hierarchy, if one was defined using **Settings > Options**
- Custom Hierarchy, if one was defined using **Settings > Options**

For more information, see [Options dialog box](#) on page 341.

You can define the default supervisor/agent hierarchy and the custom hierarchy.

<table>
<thead>
<tr>
<th>Hierarchy</th>
<th>Scope selector 1</th>
<th>Scope selector 2</th>
<th>Scope selector 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>No hierarchy</td>
<td>Dialer (default)</td>
<td>Job (default)</td>
<td>Empty</td>
</tr>
<tr>
<td>Default agent/supervisor hierarchy</td>
<td>Dialer (default)</td>
<td>Job (default)</td>
<td>Supervisor (bottom level of the selected hierarchy)</td>
</tr>
<tr>
<td>Custom</td>
<td>Top level of the selected hierarchy</td>
<td>Middle level of the selected hierarchy</td>
<td>Bottom level of the selected hierarchy</td>
</tr>
</tbody>
</table>

**Time Scope** - Allows you to monitor running jobs or all jobs in the view.
Refresh - Refreshes the data in the open views.

Using views

Monitor provides a variety of views that allow you to monitor calling activities for the following components and users:

- Dialers
- Jobs
- Supervisors
- Agents

This section contains the following topics:

- Dialer Status view on page 449
- Dialer Agents view on page 450
- Dialer Lines view on page 451
- Dialer History view on page 452
- Job Status view on page 453
- Job Detail view on page 456
- Job Agents view on page 455
- Job Call Handling view on page 458
- Job Completion Codes view on page 459
- Job Wait Queues view on page 463
- Job History view on page 465
- Completion Code Detail by Agent view on page 466
- Job Quality view on page 467
- Supervisor Agents view on page 469
- Find Agent view on page 471
- Agent Detail view on page 472
- Agent Completion Codes view on page 473
- Agent History view on page 474
The Dialer Status view displays the job, agent, and line resources used on a dialer. The view shows the following data:

- Agents and lines assigned to all dialers in the selected scope
- Jobs assigned to all dialers and the state of completion of each job

The following table describes the Dialer Status views:

<table>
<thead>
<tr>
<th>Dialer Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dialer ID</td>
<td>A unique identification number, automatically assigned to a dialer, and is used to identify dialer data in the database.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of a dialer in the current scope.</td>
</tr>
<tr>
<td>Job ID</td>
<td>A unique identification number, automatically assigned to a job (by name), used to identify job data in the database.</td>
</tr>
<tr>
<td>Job</td>
<td>The name of each job running in the current scope.</td>
</tr>
<tr>
<td>Job Instance</td>
<td>A unique identification number, automatically assigned to a single instance of a job, used to identify data associated with that job instance in the database. Each time a job runs, the system assigns it a new job instance ID.</td>
</tr>
<tr>
<td>Job Type</td>
<td>The type of job: outbound, inbound, or blend.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the job. The status types include stopped, running, error, or shutting down.</td>
</tr>
<tr>
<td>Start Date</td>
<td>The date when the job instance started.</td>
</tr>
<tr>
<td>Start Time</td>
<td>The time when the job instance started.</td>
</tr>
<tr>
<td>Stop Date</td>
<td>The date when the job instance stopped or blank if the job is still running.</td>
</tr>
<tr>
<td>Stop Time</td>
<td>The time when the job instance stopped or blank if the job is still running.</td>
</tr>
<tr>
<td>Estimated End Date</td>
<td>The date when the Monitor estimates that the job will end. For an inbound job, the Estimated Job End field is empty.</td>
</tr>
<tr>
<td>Estimated End Time</td>
<td>The time when the Monitor estimates that the job will end. For an inbound job, the Estimated Job End field is empty.</td>
</tr>
<tr>
<td>Inbound Agents</td>
<td>The total number of inbound agents logged in to each job.</td>
</tr>
<tr>
<td>Outbound Agents</td>
<td>The total number of outbound agents logged in to each job.</td>
</tr>
<tr>
<td>Blend Agents</td>
<td>The total number of blend agents logged in to each job.</td>
</tr>
</tbody>
</table>
Chapter 36: Use Monitor views

Dialer Agents view

The Dialer Agents view displays the agents active on one or more dialers.

To choose which agent states to include in the Dialer Agent view:

1. In Monitor, select **Settings > Options**.

2. Select the **Agent States** tab. For more information, see Options, Agent States tab on page 342.

3. Select the agent states that you want to view.

   You can further limit the agent states in a single view by using the **Filter** option.

The graphic mode displays a subset of the data in the table mode. The graphic mode displays data for each agent: agent name, the agent’s status, the time the agent is in that status.

The following table describes the Dialer Agents view:

<table>
<thead>
<tr>
<th>Managed Agents</th>
<th>The total number of managed agents logged in to each job.</th>
</tr>
</thead>
<tbody>
<tr>
<td>PTP Agents</td>
<td>The total number of person-to-person agents logged in to each job.</td>
</tr>
<tr>
<td>ACD Agents</td>
<td>The total number of ACD Agents logged in to each job.</td>
</tr>
<tr>
<td>Total Agents</td>
<td>The total number of agents logged in to each job.</td>
</tr>
<tr>
<td>Total Lines</td>
<td>The total number of lines in use by the job.</td>
</tr>
<tr>
<td>% Complete</td>
<td>The percentage of records called based upon the total number of records selected for calling.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Dialer Agents</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total</td>
<td>The total number of agents within the selected scope.</td>
</tr>
<tr>
<td>Talk</td>
<td>The total number of agents with status “Talk” in the selected scope.</td>
</tr>
<tr>
<td>Update</td>
<td>The total number of agents with status “Update” in the selected scope.</td>
</tr>
<tr>
<td>Idle</td>
<td>The total number of agents with status “Idle” in the selected scope.</td>
</tr>
<tr>
<td>ACD</td>
<td>The total number of ACD agents in the selected scope.</td>
</tr>
<tr>
<td>Unavailable</td>
<td>The total number of agents with the status &quot;Not available&quot; in the selected scope.</td>
</tr>
</tbody>
</table>
### Dialer Lines view

The Dialer Lines view displays line assignments and activity levels for each job.

<table>
<thead>
<tr>
<th><strong>Dialer Agents</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Off Job</td>
<td>The total number of agents that are not on the job in the selected scope.</td>
</tr>
<tr>
<td>Offline</td>
<td>The total number of offline agents in the selected scope.</td>
</tr>
<tr>
<td>Logging Off</td>
<td>The total number of agents that have requested to log off but are still handling calls.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of the dialer on which the job instance is running.</td>
</tr>
<tr>
<td>Job</td>
<td>The name of a currently running job. Available data includes the names of all jobs running in the current scope.</td>
</tr>
<tr>
<td>Job Instance</td>
<td>A unique identification number automatically assigned to a single instance of a job, used to identify data associated with that job instance in the database. Each time a job runs, the system assigns a new job instance ID.</td>
</tr>
<tr>
<td>Agent</td>
<td>The identification name of the agent logged in to the selected dialer.</td>
</tr>
<tr>
<td>Agent ID</td>
<td>The identification number of the agent logged in to the selected dialer.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the Agent. Status types include Talk, Update, Idle, ACD, Offline, Off job, Not available, and Logging off.</td>
</tr>
<tr>
<td>On Status</td>
<td>The duration of the current status of the agent in hh:mm:ss format.</td>
</tr>
<tr>
<td>Agent Type</td>
<td>The type of calling activity that the agent logged in to handle. Acceptable values include Outbound, Inbound, and Blend.</td>
</tr>
<tr>
<td>On Job</td>
<td>The elapsed time that the agent has been working on a job.</td>
</tr>
<tr>
<td>Headset</td>
<td>The headset ID or ACD extension assigned to the agent. The system uses this data to perform audio monitoring of an agent.</td>
</tr>
<tr>
<td>Logon Time</td>
<td>The time when an agent logged on.</td>
</tr>
<tr>
<td>Call Type</td>
<td>The type of the call: Outbound, inbound, or blend.</td>
</tr>
<tr>
<td>Released Time</td>
<td>The time when an agent is released from the blend job.</td>
</tr>
<tr>
<td>Acquired Time</td>
<td>The time when an agent is acquired for the blend job.</td>
</tr>
<tr>
<td>Offline Time</td>
<td>The time when an agent logged out or took a break.</td>
</tr>
</tbody>
</table>
The following table describes the Dialer Lines view:

<table>
<thead>
<tr>
<th>Dialer Lines</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dialer</td>
<td>The name of the dialer on which the job instance is running.</td>
</tr>
<tr>
<td>Job</td>
<td>The name of each job running on the dialer.</td>
</tr>
<tr>
<td>Job Type</td>
<td>The type of the job: outbound or inbound.</td>
</tr>
<tr>
<td>Job Number</td>
<td>The unique number, assigned by the dialer to this instance of the job.</td>
</tr>
<tr>
<td>Job Instance</td>
<td>A unique identification number, automatically assigned to a single instance of a job, to help identify data associated with that job instance in the database. Each time a job runs, the system assigns a new job instance ID.</td>
</tr>
<tr>
<td>Lines In Use</td>
<td>The number of lines currently in use by the job.</td>
</tr>
<tr>
<td>System Lines in Use</td>
<td>The number of system lines in use by the job as a percentage of the total number of lines on the system.</td>
</tr>
<tr>
<td>Job ID</td>
<td>A unique identification number, automatically assigned to a job (by name), used to identify job data in the database.</td>
</tr>
</tbody>
</table>

**Dialer History view**

The Dialer History view shows dialer activity over time. The view lists all instances of a job that have run on a dialer, regardless of the current status of the job.

For example, if Job1 runs from 8:00 until 10:30, then restarts at 11:15, both job instances appear in the view separately. The default value for the time selector is active data + recent data.

The following table describes the Dialer History view:

<table>
<thead>
<tr>
<th>Dialer History</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dialer ID</td>
<td>A unique identification number, automatically assigned to a dialer, used to identify data related to that dialer in the database.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of the dialer in the current scope.</td>
</tr>
<tr>
<td>Job</td>
<td>The name of a job that has run during the current time scope.</td>
</tr>
<tr>
<td>Job ID</td>
<td>A unique identification number, automatically assigned to a job by name, used to identify job data in the database.</td>
</tr>
<tr>
<td>Job Instance</td>
<td>A unique identification number, automatically assigned to a single instance of a job, used to identify data associated with that job instance in the database. Each time a job runs, the system assigns a new job instance ID.</td>
</tr>
</tbody>
</table>
Using views

### Job Status view

The Job Status view displays the same data as the Dialer Status view, but is grouped and totaled by job.

<table>
<thead>
<tr>
<th><strong>Dialer History</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Job Number</td>
<td>The unique number, assigned by the dialer to this instance of the job.</td>
</tr>
<tr>
<td>Job Type</td>
<td>The type of job: outbound, inbound, or blend.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the job. The status types include stopped, running, error, or shutting down.</td>
</tr>
<tr>
<td>Start Date</td>
<td>The date the job started.</td>
</tr>
<tr>
<td>Start Time</td>
<td>The time the job started.</td>
</tr>
<tr>
<td>Stop Date</td>
<td>The date the job stopped.</td>
</tr>
<tr>
<td>Stop Time</td>
<td>The time the job stopped.</td>
</tr>
<tr>
<td>Estimated End Date</td>
<td>The date that Monitor estimates the job will end. For an inbound job, this field is empty.</td>
</tr>
<tr>
<td>Estimated End Time</td>
<td>The time that Monitor estimates the job will end. For an inbound job, this field is empty.</td>
</tr>
<tr>
<td>Connects</td>
<td>The total number of connects, both inbound and outbound, for each job instance. A subtotal appears for each job and each dialer.</td>
</tr>
<tr>
<td>RPCs</td>
<td>The total number of calls released as right-party contacts (RPCs) for each job instance. A subtotal appears for each job and each dialer.</td>
</tr>
<tr>
<td>Closures</td>
<td>The total number of calls released as closures for each job instance. A subtotal appears for each job and each dialer.</td>
</tr>
<tr>
<td>Abandons</td>
<td>The total number of calls released as abandoned for each job instance.</td>
</tr>
<tr>
<td>Elapsed Time</td>
<td>The total time since the job instance started.</td>
</tr>
<tr>
<td>Agent Hours</td>
<td>The total number of hours agents have joined to a job instance over the course of the job. A subtotal appears for each job and each dialer.</td>
</tr>
<tr>
<td>Total Records</td>
<td>The total number of records selected for the job. For inbound jobs, this field is always zero.</td>
</tr>
<tr>
<td>Dials</td>
<td>The total number of records used to call during the course of the job. A subtotal appears for each job and each dialer.</td>
</tr>
</tbody>
</table>
The following table displays the Job Status view:

<table>
<thead>
<tr>
<th>Job Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DialerID</td>
<td>A unique identification number, automatically assigned to a dialer, used to identify data related to that dialer in the database.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of a dialer in the current scope.</td>
</tr>
<tr>
<td>Job ID</td>
<td>A unique identification number, automatically assigned to a job by name, used to identify job data in the database.</td>
</tr>
<tr>
<td>Job</td>
<td>The job name appears in the window title bar.</td>
</tr>
<tr>
<td>Job Instance</td>
<td>A unique identification number, automatically assigned to a single instance of a job, used to identify data associated with that job instance in the database. Each time a job runs, the system assigns a new job instance ID.</td>
</tr>
<tr>
<td>Job Type</td>
<td>The type of job: outbound, inbound, or blend.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the job. The status types include stopped, running, error, or shutting down.</td>
</tr>
<tr>
<td>Start Date</td>
<td>The date the job started running.</td>
</tr>
<tr>
<td>Start Time</td>
<td>The time the job started running.</td>
</tr>
<tr>
<td>Stop Date</td>
<td>The date the job stopped running.</td>
</tr>
<tr>
<td>Stop Time</td>
<td>The time the job stopped running.</td>
</tr>
<tr>
<td>Estimated End Date</td>
<td>The date that Monitor estimates the job will end. For an inbound job, this field is empty.</td>
</tr>
<tr>
<td>Estimated End Time</td>
<td>The time that Monitor estimates the job will end. For an inbound job, this field is empty.</td>
</tr>
<tr>
<td>Inbound Agents</td>
<td>The total number of inbound agents logged in to each job.</td>
</tr>
<tr>
<td>Outbound Agents</td>
<td>The total number of outbound agents logged in to each job.</td>
</tr>
<tr>
<td>Blend Agents</td>
<td>The total number of blend agents logged in to each job.</td>
</tr>
<tr>
<td>Managed Agents</td>
<td>The total number of managed agents logged in to each job.</td>
</tr>
<tr>
<td>PTP Agents</td>
<td>The total number of PTP agents logged in to each job.</td>
</tr>
<tr>
<td>ACD Agents</td>
<td>The total number of ACD agents logged in to each job.</td>
</tr>
<tr>
<td>Total Agents</td>
<td>The total number of agents within the selected scope.</td>
</tr>
<tr>
<td>Total Lines</td>
<td>The number of lines currently in use by each job.</td>
</tr>
<tr>
<td>% Complete</td>
<td>The percentage of records called based upon the total number of records selected for calling.</td>
</tr>
</tbody>
</table>
Under **Job Status view**, when you right-click on an active non-unit work list and non-inbound job, a new option, Autocallsel Trigger, is displayed, using which you can modify the parameter value of Autocallsel Trigger at runtime.

---

### Job Agents view

The Job Agents view displays the same data as the Dialer Agents view, but groups the data by job.

If you select All from the first scope selector and Job2 from the second scope selector, the view displays a summary of data for all jobs called Job2 on all dialers.

To choose which agent states to include in the Dialer Agent view:

1. In Monitor, select **Settings > Options**.
2. Select the **Agent States** tab. For more information, see Options, Agent States tab on page 342.
3. Select the agent states you want to view.
   
   You can further limit the agent states in a single view by using the **Filter** option.

The graphic mode displays a subset of the data in the table mode. The graphic mode displays data for each agent: agent name, the agent’s status, and the time the agent is in that status.

The following table describes the Job Agents view:

<table>
<thead>
<tr>
<th><strong>Job Agents</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Total</td>
<td>The total number of agents within the selected scope.</td>
</tr>
<tr>
<td>Talk</td>
<td>The total number of agents with status “Talk” in the selected scope.</td>
</tr>
<tr>
<td>Update</td>
<td>The total number of agents with status “Update” in the selected scope.</td>
</tr>
<tr>
<td>Idle</td>
<td>The total number of agents with status “Idle” in the selected scope.</td>
</tr>
<tr>
<td>ACD</td>
<td>The total number of ACD agents in the selected scope.</td>
</tr>
<tr>
<td>Acquired</td>
<td>The total number of acquired ACD agents in the selected scope.</td>
</tr>
<tr>
<td>Offline</td>
<td>The total number of offline agents in the selected scope.</td>
</tr>
<tr>
<td>Logging Off</td>
<td>The total number of agents that have requested a log off, but are still handling calls.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of the dialer.</td>
</tr>
<tr>
<td>Job</td>
<td>The name of a currently running job. Available data includes the names of all jobs in the current scope.</td>
</tr>
</tbody>
</table>
Chapter 36: Use Monitor views

Job Agents | Description
--- | ---
Job Instance | A unique identification number, automatically assigned to a single instance of a job, used to identify data associated with that job instance in the database. Each time a job run, the system assigns a new job instance ID.
Agent ID | The identification number of the agent logged in to the selected dialer.
Agent | The name of an agent logged in to the selected dialer.
Status | The current status of the Agent. Status types include Talk, Update, Idle, ACD, Offline, Off job, Not available, and Logging off.
On Status | The duration of the current status of the agent in hh:mm:ss format.
Agent Type | The type of calling activity that the agent logged in to handle. Acceptable values include Outbound, Inbound, and Blend.
On Job | The elapsed time that the agent has actually been working on a job.
Headset | The headset ID or ACD extension assigned to the agent. The system uses this data to perform audio monitoring of an agent.

Job Detail view

The Job Detail view displays detailed information about the performance of a job, including connect, RPC, and closure rates. It also displays static operational information about the job, as well as the current setting of various runtime parameters.

Because the Job Detail view is the lowest-level view of a job, data is not summed over time or dialers. Instead, it is information about a single instance of a job. For historical or summary information about a job, see Job History view on page 465.

The following table describes the Job Detail view:

| Job Detail | Description |
--- | --- |
Dialer | The name of the dialer on which the job instance is running. |
Job Name | The job name appears in the window title bar. |
Job Type | The type of the outbound job. |
Selection | The name of the file that defines which records will be available for calling. If the job is inbound, this field is blank. |
Strategy | The name of the file that defines which records will be available for calling. If the job is inbound, this field is blank. |
Job Number | The unique number assigned to this instance of the job by the dialer. |
<table>
<thead>
<tr>
<th>Job Detail</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Job Instance</td>
<td>A unique identification number, automatically assigned to a single instance of a job, used to help identify data associated with that job instance in the database. Each time a job runs, the system assigns a new job instance ID.</td>
</tr>
<tr>
<td>Current</td>
<td>The current status of the job. The status types include stopped, running, error, or shutting down.</td>
</tr>
<tr>
<td>% Complete</td>
<td>The percentage complete for the job. This value is calculated by dividing the total records called by total records selected for calling. An outbound job will never appear as 100% complete unless all records are called. Inbound jobs always appear as 100% complete.</td>
</tr>
<tr>
<td>Start Date</td>
<td>The time when the job stopped running.</td>
</tr>
<tr>
<td>Start Time</td>
<td>The time when the job started running.</td>
</tr>
<tr>
<td>Estimated End Date</td>
<td>The date that Monitor estimates the job will end. For an inbound job, this field is empty.</td>
</tr>
<tr>
<td>Estimated End Time</td>
<td>The time that Monitor estimates the job will end. For an inbound job, this field is empty.</td>
</tr>
<tr>
<td>Time Left</td>
<td>The estimated time remaining to complete calling for the job. For an inbound job, this field is empty.</td>
</tr>
<tr>
<td>Pacing</td>
<td>The call pacing defined for the job.</td>
</tr>
<tr>
<td>Running Hit Rate</td>
<td>The overall hit rate (percentage of call completions measured against call attempts) for the job calculated from job start to the present.</td>
</tr>
<tr>
<td>Current Hit Rate</td>
<td>The hit rate for the job over the last five to ten minutes. The dialer uses this figure to make adjustments in the Expert Calling Ratio.</td>
</tr>
<tr>
<td>Expert Calling Ratio</td>
<td>The Expert Calling Ratio defined for the job.</td>
</tr>
<tr>
<td></td>
<td>If the job uses the Cruise Control method, this field is blank. If the job is inbound, this field is blank.</td>
</tr>
<tr>
<td>Total Connects</td>
<td>The total number of inbound and outbound connects for the job.</td>
</tr>
<tr>
<td>Inbound Connects</td>
<td>The total number of inbound calls connected.</td>
</tr>
<tr>
<td>Inbound Connects per Hr</td>
<td>The average number of inbound connects per hour. The value is calculated by dividing the total number of inbound connects by the total Online Time (Online Time is the elapsed time since the job instance began).</td>
</tr>
<tr>
<td>Outbound Connects</td>
<td>The total number of outbound calls connected.</td>
</tr>
<tr>
<td>Outbound Connects per Hr</td>
<td>The average number of outbound connects per hour. The value is calculated by dividing the total number of outbound connects by the total Online Time.</td>
</tr>
</tbody>
</table>
Chapter 36: Use Monitor views

Job Call Handling view

The Job Call Handling view displays how much time each agent spends talking to customers, updating records, and waiting for the next call.

For example, select All on the dialer scope selector and Job1 on the second scope selector to display the agents joined to Job1.

<table>
<thead>
<tr>
<th>Job Detail</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Abandons per hour</td>
<td>The total number of calls released as abandoned per hour for each job instance.</td>
</tr>
<tr>
<td>Dials</td>
<td>The total number of records called during the course of the job.</td>
</tr>
<tr>
<td>Total Records</td>
<td>The total number of records selected for calling. For inbound jobs, this field is always zero.</td>
</tr>
<tr>
<td>Records Queued</td>
<td>The number of calls currently in the wait queue.</td>
</tr>
<tr>
<td>Records Left</td>
<td>The number of eligible records not yet called for the job. For inbound jobs, this field is always zero.</td>
</tr>
<tr>
<td>Total RPCs</td>
<td>The total number of RPCs currently recorded.</td>
</tr>
<tr>
<td>Total Closures</td>
<td>The total number of closures currently recorded.</td>
</tr>
<tr>
<td>RPCs per Connect</td>
<td>The number of RPCs as a percentage of the total number of connects. This value is calculated by dividing the total RPC connects by total agent connects.</td>
</tr>
<tr>
<td>Total Abandons</td>
<td>The total number of calls released as abandoned.</td>
</tr>
<tr>
<td>Abandons per connect</td>
<td>The percentage of connects that resulted in calls released as abandoned.</td>
</tr>
<tr>
<td>Connects per Call</td>
<td>The percentage of calls that resulted in a connect.</td>
</tr>
<tr>
<td>RPCs Per Connect</td>
<td>The percentage of connects that resulted in an RPC.</td>
</tr>
<tr>
<td>Closures Per Connect</td>
<td>The percentage of connects that resulted in a closure.</td>
</tr>
<tr>
<td>Closures Per RPC</td>
<td>The percentage of RPCs that resulted in a closure.</td>
</tr>
<tr>
<td>Inbound Wait Queue Total</td>
<td>The total number of inbound calls currently in the wait queue.</td>
</tr>
<tr>
<td>Outbound Wait Queue Total</td>
<td>The total number of outbound calls currently in the wait queue</td>
</tr>
</tbody>
</table>
The graphic mode displays a subset of the data in the table mode. The graphic mode displays data for each type of agent. The table mode displays data for each agent.

The following table describes the Job Call Handling view:

<table>
<thead>
<tr>
<th>Job Call Handling</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent Name</td>
<td>The name of the agent joined to a specific job.</td>
</tr>
<tr>
<td>Agent ID</td>
<td>A unique identification number assigned to each agent by the database.</td>
</tr>
<tr>
<td>Agent Type</td>
<td>The type of calling activity the agent logged in to handle. Acceptable values include Outbound, Inbound, Blend.</td>
</tr>
<tr>
<td>Connects Per Hour</td>
<td>The total number of connects per hour in the selected scope.</td>
</tr>
<tr>
<td>Average Talk</td>
<td>The average time agents of a specific agent type spend talking on each call.</td>
</tr>
<tr>
<td>Average Idle</td>
<td>The average time agents of a specific agent type spend waiting between calls.</td>
</tr>
<tr>
<td>Average Update</td>
<td>The average time agents of a specific agent type spend updating records.</td>
</tr>
<tr>
<td>Average Preview</td>
<td>The average time a managed agent spends previewing records. (For managed agents only.)</td>
</tr>
<tr>
<td>Duty Cycle</td>
<td>The ratio of the average time spent talking and updating to the total time from the beginning of one call to the beginning of the next call.</td>
</tr>
</tbody>
</table>

---

**Job Completion Codes view**

The Job Completion Codes view displays completion codes used during the job. Monitor displays only codes that are defined as RPC, Closure, Abandon, or have a value greater than 0.

Additional information includes the following data:

- Total number of calls, connects, and RPCs
- The per hour number of calls, connects, and RPCs
- The number of RPCs per connect
The following table describes the Job Completion Codes view:

<table>
<thead>
<tr>
<th>Job Completion Codes</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calls</td>
<td>The total number of calls for the job.</td>
</tr>
<tr>
<td>Connects</td>
<td>The total number of calls, both inbound and outbound, for each job instance. A subtotal appears for each job and each dialer.</td>
</tr>
<tr>
<td>RPC</td>
<td>The number of records released with this code as a percentage of the total number of right party connects (RPCs). This number applies to codes marked as RPC only.</td>
</tr>
<tr>
<td>Closures</td>
<td>The number of records released with this code.</td>
</tr>
<tr>
<td>Abandons</td>
<td>The number of records released with this code.</td>
</tr>
<tr>
<td>Code</td>
<td>The unique identification number associated with each completion code.</td>
</tr>
<tr>
<td>RPC</td>
<td>A square indicates that you have defined the code as an RPC in the Completion Code Manager.</td>
</tr>
<tr>
<td>Closure</td>
<td>A square indicates that you have defined the code as a closure in the Completion Code Manager.</td>
</tr>
<tr>
<td>Abandon</td>
<td>A square indicates that you have defined the code as an abandon in the Completion Code Manager.</td>
</tr>
<tr>
<td>Name</td>
<td>The user-defined name or description assigned to each code. This description is defined by the user in the Completion Code Manager.</td>
</tr>
<tr>
<td>Total</td>
<td>The total calls made by the dialer in the selected scope.</td>
</tr>
<tr>
<td>Avg/Hr</td>
<td>The average number of calls released with a completion code during an hour.</td>
</tr>
<tr>
<td>RPC %</td>
<td>For each code designated as an RPC, the percentage of connects recorded for each completion code based on the total number of RPCs for the job.</td>
</tr>
<tr>
<td>Closure %</td>
<td>The percentage of closures recorded for each completion code based on the total number of closures for the job.</td>
</tr>
<tr>
<td>Abandon %</td>
<td>The percentage of abandons recorded for each completion code based on the total number of abandons for the job.</td>
</tr>
</tbody>
</table>
You define which codes are abandoned using Completion Code Manager. By default, codes 45 and 47 are inbound abandons and 46 and 48 are outbound abandons.

Monitor always uses the definitions that were in effect when the dialer started. If you change any of the completion code descriptions in Completion Code Manager, you see the changes the next time the dialer starts.

### Recommendations for Code 96

**Recommendations for Ofcom compliant regions:**

The Supervisor applications use completion code "96" for CONNEXPIRE as a hard-coded value for calculations and reporting, therefore, following is recommended for Ofcom compliant regions:

- Use code 96 only for CONNEXPIRE so that the calculation in Campaign Monitor for the "% of Connects" column is performed as per the guidelines.
- The Analyst application can also display the report using the same formula since it also uses hard-coded value of code 96 for CONNEXPIRE.

**Recommendations for non-Ofcom compliant regions:**

- Do not use completion code 96 for representing anything other than CONNEXPIRE.
- If code 96 is already used for denoting any other completion action, then ignore the value calculated in the "% of Connects" column for code 96. Otherwise mark this "% of..."
Chapter 36: Use Monitor views

Connects” column as hidden in the "Job Completion Code" view in the Campaign Monitor supervisor application.

Note:
If code 96 has not been used in the Supervisor applications, then this information is not applicable.

Recommendation for Code 97

As per OFCOM's revised statement and policy, the formula for the OFCOM's Abandon rate should be as follows:

The Abandoned call rate = Abandoned calls / (Abandoned calls + Live calls) *100/1

Where live call refers to when a person receive the call. It does not include the calls answered by an answering machine.

Usually most of the calls answered by answering machines are filtered out so that the total number of connects on which the nuisance call rate is based normally excludes these calls for calculation purposes. However, most of the calls answered by answering machines are passed through to agents which would, as per the latest Ofcom implementation, now be classified as a connect. This is because call detection is terminated and the call is passed on to an agent to classify the call. OFCOM wants the figure of nuisance calls to be only based on the proportion of calls picked up by a live individual and exclude the calls passed to an agent that are answering machines.

As per latest OFCOM policy, the 'abandoned call' rate should be no more than three per cent of the 'live calls', calculated per campaign (that is, across call centres) or per call centre (that is, across campaigns) over any 24 hour and should include a reasoned estimate of Answer Machine Detection (AMD) false positives.

A new code, Code97, has been added as the "Answering Machine" completion code for agent. Agents should use Code97 to dispose the "Answering Machine".

Note:
Code97 should be used only for the outbound calls.

Job Completion Code view for Campaign Monitor

By default, Campaign Monitor saves the views under the Windows logged-in user's application data directory. In this release, the Job Completion Code view has been updated with an additional column. This new column is applicable to the OFCOM compliant regions only. The application data is not updated with the latest jobCompletionCode.cmv, if already exists. Replacing the existing jobCompletionCode.cmv with the new version will remove any customizations made to the Job Completion Code view.

To get the latest version of the Job Completion Code view:

1. Click Windows Start->Run and type %appdata%, and click OK. This will open the application data for the current user logged-in on the Windows.
2. Navigate to “Avaya Proactive Contact Supervisor\Monitor”.

3. Take a backup of the existing jobCompletionCode.cmv file. If this file does not exist, then ignore the following step.

4. Copy the jobCompletionCode.cmv from <INSTALLDIR>\Avaya\Proactive Contact 4.x\Supervisor\Monitor to the directory opened in Step 2 (%appdata%\Avaya Proactive Contact Supervisor\Monitor). Note that <INSTALLDIR> is the directory where you have installed Avaya Proactive Contact Supervisor.

---

**Job Wait Queues view**

The Job Wait Queues view displays information about calls directed to the wait queue during a job. The information includes the number of calls currently in queue, the number abandoned, and the average wait time for each call.

A historical graph displays the total calls added to the queue at 15-minute intervals for the job instance selected in the upper part of the view.

**Tip:**
You define which codes are abandons using Completion Code Manager. By default, codes 45 and 47 are inbound abandons and 46 and 48 are outbound abandons.

The following table describes the Job Wait Queues view:

<table>
<thead>
<tr>
<th>Job Wait Queues</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Job</td>
<td>The name of each job running in the current scope.</td>
</tr>
<tr>
<td>Job ID</td>
<td>A unique identification number, automatically assigned to a job (by name), used to identify job data in the database.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of the dialer on which the job instance is running.</td>
</tr>
<tr>
<td>Dialer ID</td>
<td>A unique identification number, automatically assigned to a dialer, and is used to identify dialer data in the database.</td>
</tr>
<tr>
<td>Inbound In Queue</td>
<td>The total number of inbound calls currently in the wait queue.</td>
</tr>
<tr>
<td>Outbound In Queue</td>
<td>The total number of outbound calls currently held in the wait queue.</td>
</tr>
<tr>
<td>Total In Queue</td>
<td>The total number of calls currently in the wait queue. The total is also broken down by call type, either inbound or outbound.</td>
</tr>
<tr>
<td>Inbound Queue Total</td>
<td>The total number of inbound calls that have spent time in the wait queue since the job began.</td>
</tr>
<tr>
<td>Outbound Queue Total</td>
<td>The total number of outbound calls that have spent time in the wait queue since the job began.</td>
</tr>
</tbody>
</table>
### Chapter 36: Use Monitor views

<table>
<thead>
<tr>
<th>Job Wait Queues</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Queue Total</td>
<td>The total number of calls, both inbound and outbound, that have spent time in the wait queue.</td>
</tr>
<tr>
<td>Avg Inbound Wait Time</td>
<td>The average number of minutes and seconds that an inbound call spends in the wait queue in the mm:ss format.</td>
</tr>
<tr>
<td>Avg Outbound Wait Time</td>
<td>The average number of minutes and seconds that an outbound call spends in the wait queue in the mm:ss format.</td>
</tr>
<tr>
<td>Avg Wait Time</td>
<td>The average time calls (inbound, outbound) spent in the wait queue. The total figure is a weighted average of inbound and outbound wait times.</td>
</tr>
<tr>
<td>Inbound Connects</td>
<td>The total number of inbound calls connected to an agent.</td>
</tr>
<tr>
<td>Outbound Connects</td>
<td>The total number of outbound calls connected to an agent.</td>
</tr>
<tr>
<td>Total Connects</td>
<td>The total number of calls, both inbound and outbound, connected to an agent.</td>
</tr>
<tr>
<td>Inbound Calls Answered</td>
<td>The total number of inbound calls answered by the dialer. (This number includes all inbound calls connected to an agent plus all inbound calls abandoned in the wait queue.)</td>
</tr>
<tr>
<td>Outbound Calls Answered</td>
<td>The total number of outbound calls answered by a customer. (This number includes all outbound calls connected to an agent plus all outbound calls abandoned in the wait queue.)</td>
</tr>
<tr>
<td>Outbound Calls Placed</td>
<td>The total number of outbound calls dialed, regardless of the final outcome of the call (i.e., abandoned or connected).</td>
</tr>
<tr>
<td>Inbound Abandoned</td>
<td>The total number of inbound calls abandoned by the customer or by the system.</td>
</tr>
<tr>
<td>Outbound Abandoned</td>
<td>The total number of outbound calls abandoned by the customer or by the system.</td>
</tr>
<tr>
<td>Total Abandoned</td>
<td>The total number of calls marked with a completion code that has been defined as an “abandon.”</td>
</tr>
<tr>
<td>% Abandoned Per Inbound Connect</td>
<td>The total number of abandoned calls divided by the total number of inbound connects and multiplied by 100.</td>
</tr>
<tr>
<td>% Abandoned Per Outbound Connect</td>
<td>The total number of abandoned calls divided by the total number of outbound calls and multiplied by 100.</td>
</tr>
<tr>
<td>% Abandoned Per Total Connects</td>
<td>The total number of abandoned calls divided by the total number of connects and multiplied by 100.</td>
</tr>
<tr>
<td>% Abandoned Per Inbound Calls Answered</td>
<td>The total number of abandoned calls divided by the sum of the total inbound connects and the total number of inbound calls abandoned and multiplied by 100.</td>
</tr>
</tbody>
</table>
The Job History view displays the same information as the Dialer History view grouped by job, rather than dialer.

The following table displays the Job History view:

<table>
<thead>
<tr>
<th>Job History</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dialer ID</td>
<td>A unique identification number, automatically assigned to a dialer, used to identify data related to that dialer in the database.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of the dialer in the current scope.</td>
</tr>
<tr>
<td>Job</td>
<td>The name of a job that has run during the current time scope.</td>
</tr>
<tr>
<td>Job ID</td>
<td>A unique identification number, automatically assigned to a job (by name), used to identify job data in the database.</td>
</tr>
<tr>
<td>Job Number</td>
<td>The unique number assigned to this instance of the job by the dialer.</td>
</tr>
<tr>
<td>Job Instance</td>
<td>A unique identification number, automatically assigned to a single instance of a job, used to help identify data associated with that job instance in the database. Each time a job runs, the system assigns a new job instance ID.</td>
</tr>
<tr>
<td>Job Type</td>
<td>The type of the outbound job.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the job. The status types include stopped, running, error, or shutting down.</td>
</tr>
<tr>
<td>Start Date</td>
<td>The date the job started.</td>
</tr>
<tr>
<td>Start Time</td>
<td>The time the job started.</td>
</tr>
<tr>
<td>Stop Date</td>
<td>The date the job stopped.</td>
</tr>
</tbody>
</table>
Chapter 36: Use Monitor views

### Completion Code Detail by Agent view

The Completion Code Detail by Agent view compares agent performance on a selected completion code. The code the system uses for comparison appears at the top of the view.

To display the view:

1. Display the Job Completion Codes view.
2. Select a dialer from the dialer scope selector.
3. Select a job from the job scope selector.
4. Select an agent completion code in the view.

<table>
<thead>
<tr>
<th>Job History</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stop Time</td>
<td>The time the job stopped.</td>
</tr>
<tr>
<td>Estimated End Date</td>
<td>The date that Monitor estimates the job will end. For an inbound job, this field is empty. The estimate is perfected as more calls are made. May not be too accurate during the first minutes of calling.</td>
</tr>
<tr>
<td>Estimated End Time</td>
<td>The time that Monitor estimates the job will end. For an inbound job, this field is empty. The estimate is perfected as more calls are made. May not be too accurate during the first minutes of calling.</td>
</tr>
<tr>
<td>Connects</td>
<td>The total number of connects (both inbound and outbound) for each job instance. A subtotal appears for each job and each dialer.</td>
</tr>
<tr>
<td>RPCs</td>
<td>The total number of calls released as right-party contacts (RPCs) for each job instance. A subtotal appears for each job and each dialer.</td>
</tr>
<tr>
<td>Closures</td>
<td>The total number of calls released as closures for each job instance. A subtotal appears for each job and each dialer.</td>
</tr>
<tr>
<td>Abandons</td>
<td>The total number of calls released as abandoned for each job instance. A subtotal appears for each job and each dialer.</td>
</tr>
<tr>
<td>Agent Hours</td>
<td>The total number of hours agents have logged in to a job instance over the course of the job. A subtotal appears for each job and each dialer.</td>
</tr>
<tr>
<td>Total Records</td>
<td>The total number of records selected for calling. For inbound jobs, this field is always zero.</td>
</tr>
<tr>
<td>Dials</td>
<td>The total number of records called during the course of the job. A subtotal appears for each job and each dialer.</td>
</tr>
</tbody>
</table>
5. Right-click and select Completion Code Detail by Agent.

Monitor displays the Completion Code Detail view.

For example, if you select Code 20, Monitor displays the Completion Code Detail by Agent view that lists Code 20 for each agent on that job.

The view also includes Total Releases, Average Per Hour, and the names of the highest and lowest performers.

You can change the comparison code by clicking **Performance Code**. A red line drawn through the bar charts indicates the current average value for the code.

The following table describes the Completion Code Detail by Agent view:

<table>
<thead>
<tr>
<th>Completion Code Detail by Detail</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Completion Code</td>
<td>The completion code used to compare agent performance.</td>
</tr>
<tr>
<td>Average Per Hour</td>
<td>The average number of calls released with this code by a single agent.</td>
</tr>
<tr>
<td>Average Total</td>
<td>The average number of calls released with this code by a single agent.</td>
</tr>
<tr>
<td>Highest Performer</td>
<td>The name of the agent with the best performance.</td>
</tr>
<tr>
<td>Lowest Performer</td>
<td>The name of the agent with the lowest performance.</td>
</tr>
<tr>
<td>Agent</td>
<td>The name of the agent. This list of agents includes all of the agents assigned to the job.</td>
</tr>
<tr>
<td>Agent ID</td>
<td>A unique identification number assigned to each agent by the database.</td>
</tr>
<tr>
<td>Total</td>
<td>The total number of calls released with this code by an agent.</td>
</tr>
<tr>
<td>Per Hour</td>
<td>The average number of calls released with this code in an hour by this agent.</td>
</tr>
<tr>
<td>Performance</td>
<td>The performance of the selected agent as a percentage of the best performer. The value in this column is calculated as: 'Total number of completion codes released by the selected agent' multiplied by 100 and divided by the 'Total number of completion codes released by the best performer'.</td>
</tr>
</tbody>
</table>

---

**Job Quality view**

The Job Quality view displays calling activity information for a job.
Chapter 36: Use Monitor views

The view describes the quality of service that dialers achieve during a job. The information includes data for call pacing, nuisance calls, and information about phone calls that were in the wait queue or were abandoned.

The following table describes the Job Quality view:

<table>
<thead>
<tr>
<th>Job Quality</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DialerID</td>
<td>A unique identification number, automatically assigned to a dialer, and is used to identify dialer data in the database.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of the dialer on which the job instance is running.</td>
</tr>
<tr>
<td>JobID</td>
<td>A unique identification number, automatically assigned to a job (by name), used to identify job data in the database.</td>
</tr>
<tr>
<td>Job</td>
<td>The name of each job running in the current scope.</td>
</tr>
<tr>
<td>Job Instance</td>
<td>A unique identification number, automatically assigned to a single instance of a job, used to help identify data associated with that job instance in the database. Each time a job runs, the system assigns a new job instance ID.</td>
</tr>
<tr>
<td>Job Type</td>
<td>The type of job: outbound, Managed, Cruise Control, inbound, or blend.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the job. The status types include stopped, running, error, or shutting down.</td>
</tr>
<tr>
<td>Start Date</td>
<td>The date the job instance started.</td>
</tr>
<tr>
<td>Start Time</td>
<td>The time the job instance started.</td>
</tr>
<tr>
<td>Stop Date</td>
<td>The date the job instance stopped or blank if the job is still running.</td>
</tr>
<tr>
<td>Stop Time</td>
<td>The time the job instance stopped or blank if the job is still running.</td>
</tr>
<tr>
<td>Calls Placed</td>
<td>The total number of outbound calls dialed, regardless of the final outcome of the call (i.e., abandoned or connected).</td>
</tr>
<tr>
<td>Calls Offered</td>
<td>The total number of calls detected by the dialer for a given job. Sometimes referred to as the number of &quot;hellos.&quot;</td>
</tr>
<tr>
<td>Connects</td>
<td>The total number of Calls Offered that are connected to agents, both inbound and outbound, for each job instance.</td>
</tr>
<tr>
<td>Connects Per Hour</td>
<td>The total number of connects per hour in the selected scope.</td>
</tr>
<tr>
<td>Serviced Calls</td>
<td>Calls offered, or &quot;hellos,&quot; that the dialer connected to an agent within the Time to connect tolerance duration. Serviced Calls are the Calls Offered minus the cumulative number of nuisance calls.</td>
</tr>
<tr>
<td>Desired Service Level</td>
<td>The target percentage of Serviced Calls that you want the system to maintain. The Desired Service Level is set for the job.</td>
</tr>
</tbody>
</table>
## Supervisor Agents view

The Supervisor Agents view displays the same data as the Dialer Agents view.

This view is only available if you have completed the following setups:

- Defined a agent/supervisor hierarchy
- Selected Settings > Options and select that hierarchy as the default agent/supervisor hierarchy

<table>
<thead>
<tr>
<th>Job Quality</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actual Service Level</td>
<td>The cumulative realized service level for the job. The ratio of the cumulative number of Serviced Calls divided by the cumulative number of Calls Offered.</td>
</tr>
<tr>
<td></td>
<td>● In an Agent Blending system, the service level is the combined service level of outbound jobs.</td>
</tr>
<tr>
<td></td>
<td>● In an Intelligent Call Blending system, the service level is the service level for outbound, inbound, and blend jobs. The sum reflects the service level for Cruise Control and non Cruise Control jobs.</td>
</tr>
<tr>
<td></td>
<td><strong>Important:</strong> If Cruise Control is important for regulatory control, create a report that reports statistics for only Cruise Control jobs.</td>
</tr>
<tr>
<td>Connect Tolerance</td>
<td>The number of seconds that you will allow a phone call to be delayed waiting for an agent before the dialer designates the call as a nuisance call.</td>
</tr>
<tr>
<td>Nuisance Count</td>
<td>The total number of Calls Offered that were not distributed to agents within the Connect Tolerance.</td>
</tr>
<tr>
<td>Total Nuisance Rate</td>
<td>The rate of nuisance calls as a percentage of total Calls Offered. The Nuisance Count divided by the Calls Offered.</td>
</tr>
<tr>
<td>Calls Queued</td>
<td>The total number of calls that have spent time in the wait queue since the job began.</td>
</tr>
<tr>
<td>Avg Queue Time</td>
<td>The average length of time calls that have spent time in the wait queue since the job began.</td>
</tr>
<tr>
<td>Abandon Rate</td>
<td>The rate of abandon calls as a percentage of total calls offered. The formula is: Total number of calls released by Code 96 *100) / (Total number of outbound connects + Total Number of Calls released by Code 96 - Total number of Answering machine (Code 97)</td>
</tr>
<tr>
<td>Elapsed Time</td>
<td>The total time since the job instance started.</td>
</tr>
</tbody>
</table>
To choose which agent states to include in the Supervisor Agents view:

1. In Monitor, select **Settings > Options**.
2. Select the **Agent States** tab. For more information, see **Options, Agent States tab** on page 342.
3. Select the agent states you want to view.

You can further limit the agent states in a single view by using the **Filter** option.

The graphic mode displays a subset of the data in the table mode. The graphic mode displays data for each agent: agent name, the agent’s status, the time the agent is in that status.

The following table describes the Supervisor Agents view:

<table>
<thead>
<tr>
<th>Supervisor Agents</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total</td>
<td>The total number of agents within the selected scope.</td>
</tr>
<tr>
<td>Talk</td>
<td>The total number of agents with status “Talk” in the selected scope.</td>
</tr>
<tr>
<td>Update</td>
<td>The total number of agents with status “Update” in the selected scope.</td>
</tr>
<tr>
<td>Idle</td>
<td>The total number of agents with status “Idle” in the selected scope.</td>
</tr>
<tr>
<td>ACD</td>
<td>The total number of ACD agents in the selected scope.</td>
</tr>
<tr>
<td>Unavailable</td>
<td>The total number of unavailable agents in the selected scope.</td>
</tr>
<tr>
<td>Offline</td>
<td>The total number of offline agents in the selected scope.</td>
</tr>
<tr>
<td>Logging Off</td>
<td>The total number of agents that have requested log off, but are still handling calls.</td>
</tr>
<tr>
<td>Supervisor</td>
<td>The name of the supervisor in the agent/supervisor hierarchy.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of the dialer.</td>
</tr>
<tr>
<td>Job</td>
<td>The name of a currently running job. Available data includes the names of all jobs running in the current scope.</td>
</tr>
<tr>
<td>Job Instance</td>
<td>A unique identification number, automatically assigned to a single instance of a job, used to identify data associated with that job instance in the database. Each time a job runs, the system assigns a new job instance ID.</td>
</tr>
<tr>
<td>Agent</td>
<td>The name of an agent logged in to the selected dialer.</td>
</tr>
<tr>
<td>Agent ID</td>
<td>The identification number of the agent logged in to the selected dialer.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the Agent. Status types include Talk, Update, Idle, ACD, Offline, Off job, Not available, and Logging off.</td>
</tr>
<tr>
<td>On Status</td>
<td>The duration of the current status of the agent in hh:mm:ss format.</td>
</tr>
</tbody>
</table>
Using views

Find Agent view

The Find Agent view helps you locate one or more agents by name, dialer, supervisor, or job. The results appear in a grid at the bottom of the dialog box.

You can select one or more agents from the result list and perform any of the actions on the Find Agent toolbar.

The following table displays the Find Agent view:

<table>
<thead>
<tr>
<th>Find Agent</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent</td>
<td>The name of the agent to search for, or a wildcard character (*).</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the Agent. Status types include Talk, Update, Idle, ACD, Offline, Off job, Not available, and Logging off.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of one or more dialers on which to search. Also available as a column.</td>
</tr>
<tr>
<td>Job</td>
<td>The name of one or more jobs to limit the search.</td>
</tr>
<tr>
<td>Supervisor</td>
<td>The name of the supervisor in the supervisor hierarchy. The supervisor's name is not be available unless the you applied an agent/supervisor hierarchy to the view.</td>
</tr>
<tr>
<td>Headset</td>
<td>The headset ID or ACD extension assigned to the agent. The system uses this data to perform audio monitoring of an agent.</td>
</tr>
</tbody>
</table>
Chapter 36: Use Monitor views

Agent Detail view

The Agent Detail view displays detailed information about the current activity and performance of an agent.

You can display this view for a specific agent from the Tools menu within any view that lists agents. For more information, see Open a view about a specific agent on page 299.

This view is only available if you have selected Settings > Options and select that hierarchy as the default agent/supervisor hierarchy. For more information, see Options dialog box on page 341.

The following table describes the Agent Detail view:

<table>
<thead>
<tr>
<th>Agent Detail</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the agent appears in the title bar.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of the dialer on which the agent is working.</td>
</tr>
<tr>
<td>Supervisor</td>
<td>The name of one or more supervisors to limit the search. This is only valid if you define an agent/supervisor hierarchy.</td>
</tr>
<tr>
<td>Job</td>
<td>The name of the job on which the agent is working.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the Agent. Status types include Talk, Update, Idle, ACD, Offline, Off job, Not available, and Logging off.</td>
</tr>
<tr>
<td>On Status</td>
<td>The time that the agent is on the current status.</td>
</tr>
<tr>
<td>Agent Type</td>
<td>The type of calling activity the agent is logged in to handle. Acceptable values include Outbound, Inbound, and Blend.</td>
</tr>
<tr>
<td>Current Type</td>
<td>The type of calling activity in which the agent is currently engaged. This data is significant for agents that log in as blend, but are normally engaged in either Inbound or Outbound activity. Their agent type is Blend, but their current type varies between Outbound and Inbound. Similarly, for agents that have logged in as ACD, both agent type and current type change to Outbound once the agent has been acquired.</td>
</tr>
<tr>
<td>Total Connects - This Agent</td>
<td>The total number of calls, both inbound and outbound, connected to this agent</td>
</tr>
<tr>
<td>Total Talk - This Agent</td>
<td>The total time spent talking on the job.</td>
</tr>
<tr>
<td>Total Update - This Agent</td>
<td>The total time spent updating records.</td>
</tr>
<tr>
<td>Total Idle - This Agent</td>
<td>The total time spent waiting for a call.</td>
</tr>
</tbody>
</table>
The Agent Completion Codes view displays the calling results in terms of completion codes. Additional information includes the following data:

<table>
<thead>
<tr>
<th>Agent Detail</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Duty Cycle - This Agent</td>
<td>The average ratio between time spent talking and updating a record and the time from the beginning of one call to the beginning of the next call.</td>
</tr>
<tr>
<td>Average Connects - This Agent Average</td>
<td>The average number of calls, both inbound and outbound, connected to an agent.</td>
</tr>
<tr>
<td>Average Talk - This Agent Average</td>
<td>The average time spent talking on each call. The data appears as a number and as a section of the pie chart.</td>
</tr>
<tr>
<td>Average Update - This Agent Average</td>
<td>The average time spent updating records by this agent.</td>
</tr>
<tr>
<td>Average Idle - This Agent Average</td>
<td>The average time the agent spent waiting between calls. The data appears as a number and as a section of the pie chart.</td>
</tr>
<tr>
<td>Average Duty Cycle - This Agent Average</td>
<td>The average ratio between time spent talking and updating a record and the time from the beginning of one call to the beginning of the next call.</td>
</tr>
<tr>
<td>Average Connects - Average of This Type</td>
<td>The average number of calls, both inbound and outbound, connected to this agent type. The data appears as a number and as a section of the pie chart.</td>
</tr>
<tr>
<td>Average Talk - Average of This Type</td>
<td>The average time spent talking on each call by agents of the same type. The data appears as a number and as a section of the pie chart.</td>
</tr>
<tr>
<td>Average Update - Average of This Type</td>
<td>The average time spent updating records by agents of the same type.</td>
</tr>
<tr>
<td>Average Idle - Average of This Type</td>
<td>The average time spent waiting between calls by agents of the same type. The data appears as a number and as a section of the pie chart.</td>
</tr>
<tr>
<td>Average Duty Cycle - Average of This Type</td>
<td>The average ratio between time spent talking and updating a record and the time from the beginning of one call to the beginning of the next call for agents of this type.</td>
</tr>
</tbody>
</table>
Chapter 36: Use Monitor views

- Total number of calls, connects, and RPCs
- The per hour number of calls, connects, and RPCs
- The number of RPCs per connect

You can display this view for a specific agent from the Tools menu within any view that lists agents. For more information see, Open a view about a specific agent on page 299.

The following table displays the Agent Completion Codes view:

<table>
<thead>
<tr>
<th>Agent Completion Codes</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connects</td>
<td>The total number of connects for this agent.</td>
</tr>
<tr>
<td>RPCs</td>
<td>The total number of RPCs for this agent.</td>
</tr>
<tr>
<td>Closures</td>
<td>The total number of closures for this agent.</td>
</tr>
<tr>
<td>Code</td>
<td>The unique identification number associated with each completion code.</td>
</tr>
<tr>
<td>RPC</td>
<td>A square indicates the code is an RPC.</td>
</tr>
<tr>
<td>Closure</td>
<td>A square indicates the code is a closure.</td>
</tr>
<tr>
<td>Name</td>
<td>The user-defined name or description assigned to each code.</td>
</tr>
<tr>
<td>Total</td>
<td>The total number of calls released with each completion code.</td>
</tr>
<tr>
<td>Avg/Hr</td>
<td>The average number of calls released with a completion code during an hour.</td>
</tr>
<tr>
<td>Type Avg/Hr</td>
<td>The average number of calls released by a specific type of agent with a completion code during an hour.</td>
</tr>
<tr>
<td>% of RPCs</td>
<td>For each code designated as an RPC, the percentage of connects recorded for each completion code based on the total number of RPCs for the job. For more information, see Job Completion Codes view on page 459.</td>
</tr>
<tr>
<td>% of Closures</td>
<td>For each code designated as a closure, the percentage of connects recorded for each completion code based on the total number of closures for the job. For more information, see Job Completion Codes view on page 459.</td>
</tr>
<tr>
<td>% of Calls</td>
<td>The number of calls recorded for each code as a percentage of the total number of calls for the job. For more information, see Job Completion Codes view on page 459.</td>
</tr>
</tbody>
</table>

Agent History view

The Agent History view displays detailed information about the past activity and performance of an agent.
You can display this view for a specific agent from the **Tools** menu within any view that lists agents. For more information, see [Open a view about a specific agent](on page 299).

The following table displays the Agent History views:

<table>
<thead>
<tr>
<th>Agent History</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent</td>
<td>The name of the agent logged in to the selected dialer.</td>
</tr>
<tr>
<td>Agent ID</td>
<td>The identification number of the agent logged in to the selected dialer.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of the dialer in the current scope.</td>
</tr>
<tr>
<td>Dialer ID</td>
<td>A unique identification number, automatically assigned to a dialer, used to identify data related to that dialer in the database.</td>
</tr>
<tr>
<td>Current Job</td>
<td>The name the job that is running during the current time scope.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the Agent. Status types include Talk, Update, Idle, ACD, Offline, Off job, Not available, and Logging off.</td>
</tr>
<tr>
<td>All Jobs</td>
<td>The jobs that have run.</td>
</tr>
<tr>
<td>Job ID</td>
<td>A unique identification number, automatically assigned to a job. Used to identify job data in the database. The job ID does not change each time the job runs.</td>
</tr>
<tr>
<td>First Login Date</td>
<td>The date the agent first logged in to a job in the yyyy/mm/dd format.</td>
</tr>
<tr>
<td>First Login Time</td>
<td>The time the agent first logged in to a job in the hh:mm:ss format.</td>
</tr>
<tr>
<td>Last Logout Date</td>
<td>The date the agent last logged out of a job in the yyyy/mm/dd format.</td>
</tr>
<tr>
<td>Last Logout Time</td>
<td>The time the agent last logged out of a job in the hh:mm:ss format.</td>
</tr>
<tr>
<td>Agent Hours</td>
<td>The total number of hours agents have logged in to a job instance over the course of the job.</td>
</tr>
<tr>
<td>Job Number</td>
<td>The number that the system assigned to the job. This is the same number that appears on the JobMon menu in the Linux-based menu system.</td>
</tr>
<tr>
<td>Job Instance</td>
<td>A unique identification number, automatically assigned to a job each time the job runs. Used to identify job data in the database. The job instance changes each time the job runs.</td>
</tr>
</tbody>
</table>
Chapter 36: Use Monitor views


Chapter 37: Agent Blending

Agent Blending is a tool that integrates outbound calling activities on your Avaya Proactive Contact system with inbound calling activities on your ACD.

This section contains the following topics:

- [Understanding Agent Blending](#) on page 477
- [Using Agent Blending](#) on page 487
- [Maintaining Agent Blending](#) on page 490

---

**Understanding Agent Blending**

Agent Blending integrates outbound calling activities on your Avaya Proactive Contact with inbound calling activities on your ACD.

The Agent Blending tool allows you to manage the ACD domains and domain groups. A domain is an ACD call queue. Every domain is a member of a domain group.

This section contains the following topics:

- [Agent Blending overview](#) on page 477
- [Predictive Agent Blending](#) on page 478
- [Proactive Agent Blending](#) on page 479
- [Supported ACDs and switch terminology](#) on page 479
- [Domains](#) on page 483
- [Domain Groups](#) on page 485

---

**Agent Blending overview**

Agent Blending integrates outbound calling activities on your Avaya Proactive Contact with inbound calling activities on your ACD. Avaya Proactive Contact provides two types of Agent Blending: Predictive Agent Blending and Proactive Agent Blending.

Both types of Agent Blending systems use a pool of ACD blend agents for outbound calling. The ACD agents log in to the dialer and the ACD. Agent Blending monitors the activity on the ACD to determine when to move agents between inbound and outbound calling activities.
Chapter 37: Agent Blending

The dialer acquires the pooled agents for outbound calling when the inbound calling activity decreases. The dialer releases the pooled agents to inbound calling when the inbound calling activity increases. The movement between inbound and outbound calling keeps the ACD blend agents busy and the ACD service level within your prescribed limits.

Use Predictive Agent Blending if your priority is servicing your inbound customers and your inbound volume is fairly high.

Use Predictive Agent Blending if your call center has the following amount of work:

- Moderate to heavy inbound traffic
- More than 25 agents in an inbound pool

---

**Predictive Agent Blending**

Use Predictive Agent Blending if your priority is servicing your inbound customers and your inbound volume is fairly high.

Predictive Agent Blending focuses on the inbound mission. Predictive Agent Blending uses events from the ACD to forecast call volume and determine when to move ACD agents between inbound and outbound calling. The dialer predicts when too many agents receive inbound calls. The dialer then acquires agents from the ACD to handle outbound calls until the inbound volume increases.

The system acquires agents for outbound calls when either the settings for the Average Speed to Answer or Service Level domain groups are above the desired value.

To configure Predictive Agent Blending, set up an Average Speed to Answer or a Service Level domain group that contains one or more acquire domains and at least one inbound domain.

**Average Speed to Answer (ASA)** - This domain group type uses the target ASA field (MAAS) to calculate when to acquire and release agents.

- The dialer acquires agents for outbound calls when the average speed to answer for all inbound domains in the group is less than or equal to the targeted value.
- The dialer releases agents when the value rises above the target.

**Service Level (SL)** - This domain group type uses the Service Criterion (SC, seconds), Desired Service Level (DSL, %), and Abatement Service Level (ASL, %) fields for calculating when to acquire and release agents.

- The dialer acquires agents for outbound calls when the percentage of inbound calls answered within the Service Criterion is greater than or equal to the Desired Service Level percentage.
- The dialer no longer acquires agents when the actual service level reaches the Abatement Service Level value.
- The dialer releases agents to inbound when the service level falls below the desired value.
The actual service level is calculated using all inbound domains in the group.

---

**Proactive Agent Blending**

Use Proactive Agent Blending if your focus is on outbound calling, but you need to service a low volume of inbound customers. The tested and supported minimum limit for Proactive Agent Blending is of 8 active agents per domain group. Note the the blend might not work as expected if there are less than 8 active agents.

Proactive Agent Blending focuses on outbound calls and releases agents to inbound only when an inbound call enters a monitored queue on the ACD.

When an ACD agent logs in, the system immediately acquires the agent for outbound calling. When an inbound call arrives in the ACD queue, the dialer releases the agent to handle the call. If inbound calls continue to arrive, the dialer continues to release agents. When the queue is empty, the dialer acquires agents for outbound calls.

**Note:**
For each OB_ONLY domain group, you configure the number of queued calls before agents release to inbound.

---

**Supported ACDs and switch terminology**

Each ACD switch has unique settings and terminology. For each supported ACD, the dialer uses domains and domain groups to control Agent Blending.

This section defines the switch terminology for the following ACDs:

- [Aspect CallCenter](#) on page 479
- [Avaya Communication Manager](#) on page 480
- [Rockwell Spectrum](#) on page 481
- [Northern Telecom Meridian](#) on page 482
- [PINNACLE](#) on page 482
- [Siemens ROLM 9751, Release 900](#) on page 483

**Note:**
The [Planning for Avaya Proactive Contact](#) contains a full description of the requirements for each supported switch.

---

**Aspect CallCenter**

**Agent group** - A set of agents handling similar types of calls. Agents log in to an agent group when they log on to the Aspect CallCenter. Agent groups may be part of an agent super group.
Agent groups correspond to Agent Blending domains. Agent Blending monitors events for domains configured on the system as inbound or acquire.

**Agent Super Group** - A collection of two or more agent groups. Aspect CallCenter simultaneously selects all agent groups in the agent super group. It delivers a call to the agent in the super group who has been available the longest. Agents do not log on to agent super groups.

If you set up the super group as a domain on Avaya Proactive Contact, Agent Blending monitors the activity in the super group.

**Call Control Tables (CCTs)** - Part of the Aspect CallCenter database. CCTs control call routing, queuing, and messaging for agent groups and agent super groups. You can view, set up, edit, or delete CCTs from Aspect CallCenter management workstation. There can be multiple CCTs for each agent group and agent super group.

**Data System Interlink Table** - Part of the Aspect CallCenter database. The table controls communication between the Aspect CallCenter and the dialer. You can view the Data System Interlink Table and set application parameters using the Aspect CallCenter management workstation. However, only an Aspect representative can set system-level parameters.

---

**Avaya Communication Manager**

**Expert Agent Selection (EAS)** - An optional Avaya Communication Manager feature. Expert Agent Selection allows skill types to be assigned to a call type or Vector Directory Number (VDN).

**Hunt group** - An agent queue on an ACD configured without EAS. The ACD hunts for the next available agent in each hunt group. It uses the hunt method defined on the ACD.

**Skill** - Skill types provide a method for call center managers to match the needs of a caller to the talents of the agents. A skill designates a work category such as sales or collections. Skills enable the ACD to route types of calls to queues. Administrators can assign up to four skills or sets of skills to each agent login ID.

**Skill hunt group** - Replaces ACD splits when the ACD is configured with EAS. The ACD can be queued to up to three different skill hunt groups at one time.

**Split** - An ACD split is a hunt group that is designed for a high volume of similar calls. Members of a split are called agents. At any one time, an agent can be logged in to a maximum of three splits.

**Vector** - Vector settings determine how the switch handles incoming calls based on the number dialed. When the Avaya Communication Manager is configured with EAS, the vector directs the incoming call to a split, a hunt group, or a skill hunt group.
**Vector Directory Number** - The extension number that accesses a vector. Agent Blending uses the Vector Directory Number for the domain address and domain extension.

**Rockwell Spectrum**

**Agent Group** - A collection of one or more agents, based on equivalent skills or a specific call center need. In Spectrum, agents may have a primary and a secondary group assignment. However, the dialer requires that agents belong to only one group.

In addition to the agent's skill level, you must assign agents to groups as inbound or acquire. Inbound agents take only inbound calls. Acquire agents take inbound and outbound calls, or they can be outbound-only.

**Application** - The system treats applications as domains. In Spectrum, incoming calls are routed to applications. An application is a type or category of call that you want handled in a similar way. Applications can include:

- Company functions, for example, Customer Service, Accounts Payable
- Special skill groups, for example, bilingual or technical troubleshooters
- Types of products, for example, Savings, Checking Accounts, Mortgages. For each application, the Spectrum tracks performance data such as average speed to answer, number of calls offered, and average handling time.

You associate each application with an Application Telescript. The telescript contains a set of instructions for handling calls. For Agent Blending, the transcript queues agent groups, places calls in wait queues, and allows the dialer to track the call while it is on the Spectrum.

**Application Directory Number (DN)** - You assign an Application Directory Number in Applications Parameters when you create the Spectrum application. When dialed, this number calls the application. The Application Directory Number is used as the domain extension in Agent Blending.

**Application Number** (also called the Application ID) - You assign an Application Number in Applications Parameters when you create the Spectrum application. The Application Number is used as the domain address in Agent Blending.

**Class of Service** - A collection of attributes associated with agents and devices within the Spectrum. One of the class of service attributes is the Host Transaction feature. Host Transaction controls whether or not the Spectrum generates call progress messages on the Transaction Link for the associated agent or device. Agent Blending requires that you enable the Host Transaction feature.

**Host** - The host for the Spectrum is Avaya Proactive Contact.
**Provisioning** - A set of actions that add, alter, or delete system parameters. In the Avaya Proactive Contact documentation, “configuring” has the same meaning as “provisioning” in Spectrum documentation.

**Telescript** - A user-programmable sequence of steps associated with various call routing points within the Spectrum. During inbound call routing, error processing, and call queuing, the Spectrum invokes Routing, Intercept, and Application Telescripts. Feature Telescripts operate as subroutines for the other telescript types.

Configuring an Application Telescript to route to the desired agent groups is key to making Agent Blending work with Spectrum.

**Transaction Link** - The Spectrum name for the Application Enablement Services link. Transaction Link is a communications channel between the Spectrum and the dialer. It is operated over an X.25 or TCP/IP transport facility.

**Trunk Group** - A collection of trunk ports that have common processing characteristics, such as ANI and DNIS. One of the characteristics is the Host Transaction Link feature. It controls whether Spectrum generates call progress messages for calls associated with the trunk group members.

You must enable this feature to allow the dialer to monitor calls on Spectrum.

---

**Northern Telecom Meridian**

**ACD-DN (directory number)** - The ACD address for a call queue. The ACD-DN is the Agent Blending domain address.

**ACD Agent Position ID** - The number that identifies an agent’s telephone extension. Agent Blending agents log in to Avaya Proactive Contact as ACD agents using their ACD Agent Position ID as the ACD extension. During calling operations, managers can assign agents to Agent Blending domains by assigning agent positions to call queues, or agents can log in to call queues that are Agent Blending domains.

**Multiple queue assignment** - A Meridian option that allows agents to log in to multiple call queues.

The domains and domain groups you define and how your agents log into call queues depends on whether your Meridian uses multiple queue assignment.

---

**Pinnacle**

**Call queue** - A destination for call routing, defined by an ACD address. A call queue can be an Agent Blending domain.

**Queue ID** - The ACD address associated with a call queue. Queue IDs are Agent Blending domain addresses.
**Queue pilot number** - The ACD extension associated with an ACD address. Queue pilot numbers are Agent Blending domain extensions.

**Serving Team** - A group of agent identifiers for agents who will work on the same task. PINNACLE can route calls to the serving team for a call queue. Agent Blending inbound agents belong to an inbound serving team. Agent Blending outbound and blend agents belong to an acquire serving team.

---

**Siemens ROLM 9751, Release 900**

**ACD group or agent group** - A group of agent extensions that receives calls from the same pilot number. Each ACD group has telephones and members.

**Call-progress event** - Any change in a call’s state in ROLM 9005. CallBridge passes call-progress event messages from ROLM 9005 to CallPath. Call-progress event messages provide the information Agent Blending needs to acquire and release agents.

**Class of service** - A code indicating the features, extensions, and trunk access available to an ACD address. Agent Blending uses agent groups with the CallPath class of service.

**Directory Number (DN)** - An ACD address or extension associated with an ACD-defined group or with a device such as a telephone or a Voice Response Unit (VRU) port. An ACD-defined group can be an agent group or a hunt group.

**Dummy hunt group** - A hunt group with no members defined on ROLM 9005. It unconditionally forwards calls to an agent group. Agent Blending requires dummy hunt groups to collect call-progress event messages. It uses the dummy hunt group’s pilot number as the auxiliary domain’s extension number.

**Pilot number** - A directory number associated with a group of extension numbers that comprise one ACD group. Agent Blending uses pilot numbers as the domain address. Agent Blending uses the dummy hunt group’s pilot number as the domain extension.

---

**Domains**

The dialer requires domains and domain groups for each type of switch. Domains are the ACD call queues that are defined on the ACD and on the dialer.

Each domain is a member of a domain group. Agent Blending collects calling events for each domain and totals them by domain group for statistic calculation. The dialer uses the statistics to determine when to move ACD agents between inbound and outbound calling. The dialer does not do the following activities:

- Total statistics across domain groups
Chapter 37: Agent Blending

- Monitor activity in call queues that are not part of a domain group

This section contains the following topics:
- **Types of domains** on page 484
- **Agent assignments to domains** on page 484

## Types of domains

The types of domains that you configure depend upon the ACD. The two main domain types are inbound and acquire. All Agent Blending systems must have an acquire domain.

Agent Blending uses inbound domains to determine agent availability by monitoring and analyzing the traffic. The dialer uses acquire domains to acquire agents for outbound calling.

In addition to inbound and acquire domains, the dialer recognizes two additional domains. Some ACDs use auxiliary domains to monitor all calling activity in a domain group. Meridian switches without multiple queues assignment (MQA) use transient domains to temporarily hold agents who are moving between inbound and outbound.

## Agent assignments to domains

After your system is installed, assign your agents to domains based on a skill set. For example, you might divide agents into three sets:
- Agents who handle only credit card customers
- Agents who handle consumer loan customers
- Agents with skills to handle both credit card customers and consumer loan customers

---

## Domain groups

Define each domain group with one of the following four configurations:
- Outbound without inbound domain, which uses the OB_ONLY control method.
- Predictive-Average Speed to Answer, which uses the ASA control method.
- Predictive-Service Level, which uses the SL control method.
- Outbound with inbound domain, which uses the Proactive Blend OB_ONLY control method.

This section contains the following topics:
- **Outbound Agent Blend** on page 485
- **Domain Groups** on page 485
Outbound Agent Blend

Outbound Agent Blending acquires ACD agents to handle outbound calls as soon as they log in to the system and the ACD.

Since there is no inbound domain in the OB_ONLY domain group, agents who are assigned to an Outbound domain will not be released to handle inbound calls.

Domain Groups

During site preparation, you identify which domains you want grouped. A domain group contains one or more domains. A domain can belong to only one domain group. There are three domain group Control Methods: Outbound Only, Average Speed to Answer, and Service Level. The Agent Blending Administrator window changes dynamically depending on which one of the three Control Methods you choose.

Outbound Only - The dialer acquires outbound-only agents to handle outbound calls as soon as they log in to Avaya Proactive Contact and the ACD. Outbound Agent Blending allows you to take advantage of the least-cost routing available on your ACD and to use the detailed reports available on the ACD.

To configure an Outbound Agent Blending job, set up an outbound domain that contains at least one acquire domain. Do not set up an inbound domain. Select Outbound as the domain group type. Assign at least one acquire domain to the group. Do not set up an inbound domain.

If you select Outbound Only, you must enter a Minimum Queued for Release value to set how quickly the system releases agent to inbound calling. Type a value from 0 through 999. The default value is 0.

Average Speed to Answer - If you select Average Speed to Answer, your dialog box changes dynamically, and you need to set values for the required fields.

The Average Speed to Answer fields are described in the following table.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time Interval (required)</td>
<td>The interval that the dialer uses to calculate the Average Speed to Answer. The interval influences how responsive the dialer is to fluctuations in answer delays. The interval begins each time that you start the dialer or restart Agent Blending. Select a value greater than 0.25, in increments of .25. The interval is in hours, so .25 is 1/4 of an hour or 15 minutes. The default is .50 or 30 minutes. The setting represents an average calculated over the Average Speed to Answer interval.</td>
</tr>
<tr>
<td>Average Speed to Answer (required)</td>
<td>The average time within which agents should answer calls. Enter a value from 1 through 999. The default value is 60.</td>
</tr>
</tbody>
</table>
## Chapter 37: Agent Blending

### Parameter | Definition
--- | ---
Agent Utilization Threshold (required) | The percentage of agents available to take calls. Agent Utilization Threshold determines how quickly the system moves agents between inbound and outbound calls. The goal is to prevent agents from being acquired or released too frequently.

- Agents are available if they are not taking calls or updating records.
- Agent Blending tracks calling statistics and uses this information to predict future availability.
- To calculate the threshold, the dialer divides the projected inbound call volume by the projected number of available agents.
- Enter a value from 1 through 999. The default value is 200.

Minimum Agents on Outbound (required) | The minimum number of ACD blend agents, in this domain, dedicated to handling outbound calls. This setting overrides Desired Level. For example, no matter how low the Average Speed to Answer, there will always be this number of agents unavailable to handle inbound calls.

- Use this setting when it is more important to meet outbound goals than to service inbound calls.
- Enter a value from 0 through 999. The default value is 0.

Initial Traffic Rate (optional) | The estimated number of calls each second. The dialer uses this rate for the first 30 calls. It ensures that there are enough agents to handle the first 30 calls.

- Enter a value from 0 through 999.

Talk Time (optional) | The estimated minimum seconds agents spend connected on each inbound call. The system adds Talk time and After Call Work Time to determine agent availability. Agent availability is sometimes called service capacity.

- Enter a value from 0 through 999.

After Call Work Time (optional) | The estimated minimum seconds agents spend, after a call, updating records and processing information.

- Enter a value from 0 through 999.
**Service Level** - If you select **Service Level**, your dialog box changes dynamically, and you need to set values for the required fields. The Service Level fields are described in the following table.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Desired Service Level (required)</td>
<td>The percentage of calls agents should answer within the Service Criteria. Enter a value from 0 through 100 (value must be less than Abatement Service Level). The default value is 80.</td>
</tr>
<tr>
<td>Abatement Service Level (required)</td>
<td>The maximum percentage of inbound calls agents should answer within the Service Level interval. Select a setting from 40 percent to 100 percent. When the service level goes above the abatement service level, the system acquires ACD blend agents for outbound calling. When the service level drops below the abatement service level, the system releases ACD blend agents for inbound calling. Enter a value from 0 through 100. The value must be greater than Desired Service Level. The default value is 95.</td>
</tr>
<tr>
<td>Service Criterion (required)</td>
<td>The maximum time within which an agent should answer a call. As the system runs, it measures the seconds an inbound call is in the ACD queue. Enter a value from 0 through 999. The default value is 60.</td>
</tr>
<tr>
<td>Time Interval (required)</td>
<td>See [Time Interval (required)] on page 485.</td>
</tr>
<tr>
<td>Agent Utilization Threshold (required)</td>
<td>See [Agent Utilization Threshold (required)] on page 486.</td>
</tr>
<tr>
<td>Minimum Agents on Outbound (required)</td>
<td>See [Minimum Agents on Outbound (required)] on page 486.</td>
</tr>
<tr>
<td>Initial Traffic Rate (optional)</td>
<td>See [Initial Traffic Rate (optional)] on page 486.</td>
</tr>
<tr>
<td>Talk Time (optional)</td>
<td>See [Talk Time (optional)] on page 486.</td>
</tr>
<tr>
<td>After Call Work Time (optional)</td>
<td>See [After Call Work Time (optional)] on page 486.</td>
</tr>
</tbody>
</table>
Agent Blending is available from the **Tools** menu in Editor or Monitor.

This section contains the following topics to help you set up Agent Blending:

- **Start the Agent Blending tool** on page 488
- **Create a domain group** on page 488
- **Create a domain** on page 489
- **Edit domain group settings** on page 489
- **Edit domain settings** on page 490
- **Delete a domain group** on page 490
- **Delete a domain** on page 490

### Start the Agent Blending tool

Start the Agent Blending tool from either Monitor or Editor.

1. Select **Start > All Programs > Avaya > Proactive Active Contact > Supervisor > Monitor or Editor**.
2. Select **Tools > Agent Blending Administrator**.
   
   The Agent Blending Administrator window appears.

### Create a domain group

You can edit domain group settings while your blend engine is running.

1. In the Agent Blending Administrator window, select **File > Create Domain Group**.
2. In the New Domain Group box, type a descriptive name for the domain group, such as **MIDWEST**, and then click **OK**.
   
   The name must be 10 or fewer characters. You have now created the domain group name and must now complete the domain group settings.
3. Set values for the domain group fields: **Control Method** (Outbound Only, Service Level, or Average Speed to Answer) and the options that change dynamically based on your Control Method selection.
   
   For help with filling in your fields, see **Outbound Only** on page 485, **Average Speed to Answer** on page 485, and **Service Level** on page 487.
Create a domain

You must stop your blend engine in order to create a domain. For more information, see Stop the blend engine on page 491.

1. The Create Domain option is not available until you select the name of a domain group. The domain will be added to the domain group that you select.

2. In the Agent Blending Administrator window, click the domain group to which you want the new domain to belong, and then, select File > Create Domain.

3. In the New Domain dialog box, type the address of the domain.
   Typical values for this box are 5-digit addresses, such as 20601, and must match your PBX ID exactly to communicate with the PBX.

4. Click OK.
   You have created the domain name and must now define in the domain settings.

5. Define the domain settings: Domain Type (Inbound, Transient Acquire, Team Acquire, and Overflow), Phone Number, Gateway ID, Application ID, and PBX ID.

   For help with filling in your fields, see:
   ● Supported ACDs and switch terminology on page 479
   ● Domains on page 483
   ● Domain groups on page 484

Edit domain group settings

You must stop your blend engine in order to edit domain group settings. For more information, see Stop the blend engine on page 491.

1. In the Agent Blending Administrator window, select the domain group you want to edit.

2. Click the Control Method field to select Outbound Only, Service Level, or Average Speed to Answer.
   The domain group fields change dynamically depending on which Control Method option you select.

3. Set values for the options.
   For help with filling in your fields, see Outbound Only on page 485, Average Speed to Answer on page 485, and Service Level on page 487.

   To determine whether the field has a drop-down list or an editable value for you to use, click the field.

4. Save your work.
Chapter 37: Agent Blending

Edit domain settings

You must stop your blend engine in order to edit domain settings. For more information, see Stop the blend engine on page 491.

1. In the Agent Blending Administrator window, select the domain you want to edit.
2. Click the Domain Type field. Select Inbound, Transient Acquire, Team Acquire, or Overflow.
3. For descriptions of these options, see Domain groups on page 484.
4. Type values for the Phone Number, Gateway ID, Application ID, and PBX ID fields.
   For descriptions of these options, see Domain groups on page 484.

Delete a domain group

You must stop your blend engine in order to delete a domain group. For more information, see Stop the blend engine on page 491.

1. In the Agent Blending Administrator window, select the domain group you want to delete.
2. Select File > Delete Domain Group, and then save your work.

Delete a domain

You must stop your blend engine in order to delete a domain. For more information, see Stop the blend engine on page 491.

1. In the Agent Blending Administrator window, select the domain you want to delete.
2. Select File > Delete Domain, and then save your work.

Maintaining Agent Blending

Agent Blending is available from the Tools menu in Editor or Monitor.

This section contains the following topics to help you maintain Agent Blending:

- Move a domain to a different group on page 491
- Stop the blend engine on page 491
- Start the blend engine on page 492
Maintaining Agent Blending

- Resynch the blend engine on page 492
- Resynch the blend engine on page 492
- View ACD statistics on page 493
- View alerts on page 493
- View transactions on page 493

---

### Move a domain to a different group

You must stop your blend engine in order to move a domain to a different domain group. For more information, see Stop the blend engine on page 491.

Moving a domain is possible by deleting the domain and then adding it to a different domain. Remember to write down its existing settings so that you can recreate them when you add the domain to the new domain group.

1. In the Agent Blending Administrator window, select the domain you want to move (write down its settings first, if necessary), and then, select **File > Delete Domain**.
2. Select the domain group to which you want to add the new domain, and then select **File > Create Domain**.
3. In the **New Domain** dialog box, type the domain address, such as 20601, and then click **OK**.
4. Complete the domain settings.

---

### Stop the blend engine

The **Stop** button shuts down all but two of the Blend processes on a dialer; cbamain and cbauser remain up. This state is also called configure-only mode. It is required for editing or deleting domains. You stop the blend engine by clicking **Stop** in the **Agent Blending Administrator** dialog box. (You must have a dialer selected in the tree view for the **Stop** button to be visible. The dialers are located at the top-most level in the tree view.)

1. Open Monitor or Editor and select **Tools > Agent Blending**.
   
   The Agent Blending Administrator window appears.

2. In the tree view, select a dialer.

3. Select **Blend Engine > Stop**.
Chapter 37: Agent Blending

Start the blend engine

The **Start** button starts the Blend processes that were killed with the **Stop** command on a dialer. You start the blend engine by clicking **Start** in the **Agent Blending Administrator** dialog box. (You must have a dialer selected in the tree view for the **Start** button to be visible. The dialers are located at the top-most level in the tree view.)

1. Open Monitor or Editor and select **Tools > Agent Blending**. The Agent Blending Administrator window appears.
2. In the tree view, select a dialer.
3. Select **Blend Engine > Start**.

Reset the blend engine

The **Reset** button stops and restarts the Blend processes on a dialer. If Blend is not running, the **Reset** button starts the processes on a dialer.

1. Open Monitor or Editor and select **Tools > Agent Blending**.
   The Agent Blending Administrator window appears.
2. In the tree view, select a dialer.
3. Select **Blend Engine > Reset**.

Resynch the blend engine

The **Resynch** button updates the dialer with the current ACD agent queue assignments. Use **Resynch** after a supervisor uses the ACD to reassign agents to different inbound queues.

1. Open Monitor or Editor and select **Tools > Agent Blending**.
   The Agent Blending Administrator window appears.
2. In the tree view, select a dialer.
3. Select **Blend Engine > Resynch**.
View ACD statistics

To view ACD statistics.

1. In the Agent Blending Administrator window, select **Statistics** under the domain group for which you want to view statistics.

View alerts

You are able to view alerts by clicking **Alerts** in the tree view.

1. In the Agent Blending Administrator window, select **Alerts** under the domain group for which you want to view alerts.

View transactions

To view transactions.

1. In the Agent Blending Administrator window, select **Transactions** under the domain group for which you want to view transactions.
Chapter 38: PC Analysis Telnet

PC Analysis Telnet is a tool that allows you to access the Linux-based PC Analysis menus. PC Analysis is a reporting and troubleshooting tool included with the Avaya Proactive Contact. You can also use PC Analysis to define and generate extract output files to a network location. You can use the extract files in third party reporting, spreadsheet, and word processing packages.

This section contains the following topics:

- Understanding PC Analysis Telnet on page 495
- Using PC Analysis Telnet on page 496

Understanding PC Analysis Telnet

The PC Analysis Telnet tool allows you to access the Linux-based PC Analysis menus. You can also use PC Analysis Telnet to move PC Analysis extract output files from the Avaya Proactive Contact to a network location.

PC Analysis Telnet is available from the Analyst Tools menu only.

Note: If access to Supervisor is not available, you need to use a third-party telnet tool to access Avaya Proactive Contact menu system and PC Analysis.

This section contains the following topics:

- PC Analysis on page 495
- PC Analysis Telnet features on page 496

PC Analysis

Use PC Analysis to create reports, charts, and spreadsheets of Avaya Proactive Contact data in third-party spreadsheet, word processing, and reporting applications.

In PC Analysis, you define extract files, generate extract output files, and transfer the extract output files to third-party applications. You can extract files the following formats: *.cfg, *.prn, and *.txt.
Chapter 38: PC Analysis Telnet

PC Analysis Telnet features

Use the PC Analysis Telnet tool to navigate to the Linux-based menus and PC Analysis screens.

The PC Analysis Telnet features appear on the toolbar, **File** menu, and **Tools** menu.

**PC Analysis Telnet contains the following features:**

<table>
<thead>
<tr>
<th>Feature</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connect</td>
<td>![Connect Icon]</td>
<td>Use <strong>Connect</strong> to select the dialer for which you want to generate or transfer extract data files. This feature is not available while you are connected to a system. You must disconnect from a dialer before you can connect to a different dialer.</td>
</tr>
<tr>
<td>Disconnect</td>
<td>![Disconnect Icon]</td>
<td>Use <strong>Disconnect</strong> to end the telnet session for the current dialer. If you exit the menu system, PC Analysis Telnet automatically disconnects your session. After you disconnect, you can connect to a different dialer or exit the PC Analysis Telnet application.</td>
</tr>
<tr>
<td>Exit out of entry</td>
<td>![Exit Icon]</td>
<td>Use <strong>Exit out of entry</strong> to move back one screen in the Linux-based screens. <strong>Exit out of entry</strong> provides the same functionality as <strong>Ctrl-x.</strong></td>
</tr>
<tr>
<td>Done with entry</td>
<td>![Done Icon]</td>
<td>Use <strong>Done with entry</strong> to move to the next Linux-based screen. <strong>Done with entry</strong> provides the same functionality as the <strong>Done</strong> key, <strong>F1.</strong></td>
</tr>
<tr>
<td>Select</td>
<td>![Select Icon]</td>
<td>Use <strong>Select</strong> from the PC Analysis Extraction Configuration Edit screen. <strong>Select</strong> moves your cursor to the Select column. Press <strong>Enter</strong> after typing the <strong>Select</strong> value.</td>
</tr>
<tr>
<td>Criteria</td>
<td>![Criteria Icon]</td>
<td>Use <strong>Criteria</strong> from the PC Analysis Extraction Configuration Edit screen. <strong>Criteria</strong> moves your cursor to the Criteria column. Press <strong>Enter</strong> after typing the <strong>Criteria</strong> statement.</td>
</tr>
<tr>
<td>Run extract</td>
<td>![Run Icon]</td>
<td>Use <strong>Run extract</strong> from the PC Analysis Extraction Configuration Edit screen to generate a PC Analysis extract output file. The file is based on the configuration of the open extract file.</td>
</tr>
<tr>
<td>Get file</td>
<td>![Get Icon]</td>
<td>Use <strong>Get file</strong> to transfer one or more PC Analysis extract output files from the dialer to a network location.</td>
</tr>
</tbody>
</table>

Using PC Analysis Telnet
The PC Analysis Telnet tool allows you to access the Linux-based PC Analysis menus.

PC Analysis Telnet is available from the Analyst **Tools** menu only.

**Note:**
If access to Supervisor is not available, you need to use a third-party telnet tool to access Avaya Proactive Contact menu system and PC Analysis.

For information on how to use the Linux-based PC Analysis menus, see *Administering Avaya Proactive Contact (Linux-based Interface)*.

This section contains the following topics for the PC Analysis Telnet tool:

- [Start PC Analysis Telnet](#) on page 497
- [Transfer PC Analysis extract output files](#) on page 515
- [FTP Client dialog box](#) on page 516

---

**Start PC Analysis Telnet**

The PC Analysis Telnet tool allows you to access the Linux-based PC Analysis menus.

To start PC Analysis Telnet:

1. Select **Start > All Programs > Avaya > Proactive Contact > Supervisor > Analyst**.
2. Select **Tools > PC Analysis Telnet**.
   
The PC Analysis Telnet window appears.
3. Select **File > Connect**.
   
The **Connect to Proactive Contact** dialog box appears.
4. From the **Name** list, select the name of the dialer to which you want to connect, and then click **OK**.
   
The dialer **login:** prompt appears in the Telnet window.
5. Use your system or PC Analysis login to access the PC Analysis menus.
6. Enter your key code and press **Enter**.

---

**Field Description for PC Analysis extract output files**

**Calling List**

The following table contains information about the Calling List fields on the PC Analysis extract.
<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>ABDNDTE</td>
<td>Date, as captured on the system, when the call was abandoned.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>ABDNTME</td>
<td>Time, as captured on the system, when the call was abandoned.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>ABDNCODE</td>
<td>Completion Code assigned to the abandoned call.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>AGENT</td>
<td>ID assigned to the Agent who handled the call.</td>
<td>Character</td>
<td>8</td>
</tr>
<tr>
<td>CODE</td>
<td>Completion code assigned to the call.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>COUNTER</td>
<td>Total of all the retries and recalls on all the numbers dialed from this record.</td>
<td>Numeric</td>
<td>3</td>
</tr>
<tr>
<td>CURPHONE</td>
<td>Phone field that is currently in use: Phone1, Phone2, Phone3</td>
<td>Numeric</td>
<td>2</td>
</tr>
<tr>
<td>CURPHONER</td>
<td>Phone field that is currently in use for a manual recall number (RECALLNUMBER).</td>
<td>Numeric</td>
<td>2</td>
</tr>
<tr>
<td>DAYS_CNT</td>
<td>Number of days for which the record has been maintained on the dialer.</td>
<td>Numeric</td>
<td>3</td>
</tr>
<tr>
<td>DIALERID</td>
<td>ID assigned to the Dialer from which the call has been made.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>DTE</td>
<td>Date, as displayed on the system, when the call was made.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>DUPE</td>
<td>First occurrence of a duplicate record denoted by a * in the DUPE field. The first occurrence of a duplicate record does not have a value in the STATUSFLAG field, however, all subsequent duplicate records have their STATUSFLAG set to R.</td>
<td>Character</td>
<td>1</td>
</tr>
<tr>
<td>System Field Name</td>
<td>Description</td>
<td>Field Type</td>
<td>Length</td>
</tr>
<tr>
<td>-------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>------------</td>
<td>--------</td>
</tr>
<tr>
<td>DUPEREC</td>
<td>The record for which a duplicate is present on the system.</td>
<td>Numeric</td>
<td>10</td>
</tr>
<tr>
<td>DUR1</td>
<td>Total duration since the system issued the call command.</td>
<td>Numeric</td>
<td>9</td>
</tr>
<tr>
<td>DUR2</td>
<td>Total duration since the time the digits are outpulsed until the line is hung up. This duration does not include the update time.</td>
<td>Numeric</td>
<td>9</td>
</tr>
<tr>
<td>DUR3</td>
<td>Total duration since the time the call is answered to the time when the line is hung up.</td>
<td>Numeric</td>
<td>9</td>
</tr>
<tr>
<td>DUR4</td>
<td>Duration since an agent is assigned to a job until the line is released.</td>
<td>Numeric</td>
<td>9</td>
</tr>
<tr>
<td>DUR5</td>
<td>Duration since agents are assigned to a job until they are free.</td>
<td>Numeric</td>
<td>9</td>
</tr>
<tr>
<td>ENTRYDATE</td>
<td>Date when the customer record was downloaded on the dialer.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>FRSTDATE#</td>
<td>Date when customer’s phone number (phone #) was called for the first time.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>FRSTTIME#</td>
<td>Time when the customer’s phone number (phone #) was called for the first time.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>FRSTSTAT#</td>
<td>Completion code assigned to the first call that was made to the customer’s phone number.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>FRSTDATER</td>
<td>Date when the manual recall number (RECALLNUMBER) was called for the first time.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>FRSTTIMER</td>
<td>Time when the manual recall number (RECALLNUMBER) was called for the first time.</td>
<td>Time</td>
<td>8</td>
</tr>
</tbody>
</table>
### System Field Name | Description | Field Type | Length
--- | --- | --- | ---
FRSTSTATR | Completion code assigned to the call when the manual recall number (RECALLNUMBER) was called for the first time. | Character | 3
SCNDDATE# | Date when the customer’s phone number (phone #) was called for the second time. | Date | 10
SCNDTIME# | Time when the customer’s phone number (phone #) was called for the second time. | Time | 8
SCNDSTAT# | Completion code assigned to the second call that was made to the customer's phone number. | Character | 3
SCNDDATER | Date when the manual recall number (RECALLNUMBER) was called for the second time. | Date | 10
SCNDTIMER | Time when the manual recall number (RECALLNUMBER) was called for the second time. | Time | 8
SCNDSTATR | Completion code assigned to the call when the manual recall number (RECALLNUMBER) was called for the second time. | Character | 3
THRDDDATE# | Date when the customer’s phone number (phone #) was called for the third time. | Date | 10
THRDTIME# | Time when the customer’s phone number (phone #) was called for the third time. | Time | 8
THRDSTAT# | Completion code assigned to the third call that was made to the customer's phone number. | Character | 3
THRDDATER | Date when the manual recall number (RECALLNUMBER) was called for the third time. | Date | 10
<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>THRDTIMER</td>
<td>Time when the manual recall number (RECALLNUMBER) was called for the third time.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>THRDSTATR</td>
<td>Completion code assigned to the call when the manual recall number (RECALLNUMBER) was called for the third time.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>FRTHDATE#</td>
<td>Date when the customer’s phone number (phone #) was called for the fourth time.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>FRHTIME#</td>
<td>Time when the customer’s phone number (phone #) was called for the fourth time.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>FRTHSTAT#</td>
<td>Completion code assigned to the fourth call that was made to the customer's phone number.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>FRTHDATER</td>
<td>Date when the manual recall number (RECALLNUMBER) was called for the fourth time.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>FRHTIMER</td>
<td>Time when the manual recall number (RECALLNUMBER) was called for the fourth time.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>FRTHSTATR</td>
<td>Completion code assigned to the call when the manual recall number (RECALLNUMBER) was called for the fourth time.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>FIFTDATE#</td>
<td>Date when the customer’s phone number (phone #) was called for the fifth time.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>FIFTTIME#</td>
<td>Time when the customer’s phone number (phone #) was called for the fifth time.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>FIFTSTAT#</td>
<td>Completion code assigned to the fifth call that was made to the customer's phone number.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>FIFTDATER</td>
<td>Date when the manual recall number (RECALLNUMBER) was called for the fifth time.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>System Field Name</td>
<td>Description</td>
<td>Field Type</td>
<td>Length</td>
</tr>
<tr>
<td>-------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>------------</td>
<td>--------</td>
</tr>
<tr>
<td>FIFT TIMER</td>
<td>Time when the manual recall number (RECALLNUMBER) was called for the fifth time.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>FIFT STAT R</td>
<td>Completion code assigned to the call when the manual recall number (RECALLNUMBER) was called for the fifth time.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>FIN OPER</td>
<td>Name of the last agent who handled the call. This field is used in case of Sales verification of a job.</td>
<td>Character</td>
<td>8</td>
</tr>
<tr>
<td>JOB ID</td>
<td>ID assigned to the job under which the call was made.</td>
<td>Character</td>
<td>8</td>
</tr>
<tr>
<td>JOB NAME</td>
<td>Name of the job under which the call was made.</td>
<td>Character</td>
<td>20</td>
</tr>
<tr>
<td>LAST DATE #</td>
<td>Date when the customer’s phone number (phone #) was called for the last time.</td>
<td>Date</td>
<td>8</td>
</tr>
<tr>
<td>LAST TIME #</td>
<td>Time when the customer’s phone number (phone #) was called for the last time.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>LAST STAT #</td>
<td>Completion code assigned to the last call that was made to the customer’s phone number.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>LAST DATER</td>
<td>Date when the manual recall number (RECALLNUMBER) was called for the last time.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>LAST STAT R</td>
<td>Completion code assigned to the call when the manual recall number (RECALLNUMBER) was called for the last time.</td>
<td>Character</td>
<td>8</td>
</tr>
<tr>
<td>LAST TIMER</td>
<td>Time when the manual recall number (RECALLNUMBER) was called for the last time.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>MASTER ZONE</td>
<td>Time zone of the current phone number in use.</td>
<td>Character</td>
<td>1</td>
</tr>
<tr>
<td>System Field Name</td>
<td>Description</td>
<td>Field Type</td>
<td>Length</td>
</tr>
<tr>
<td>-------------------</td>
<td>-------------</td>
<td>------------</td>
<td>--------</td>
</tr>
<tr>
<td>PHONECNT#</td>
<td>Number of call attempts that were made to the customer number (phone #).</td>
<td>Numeric</td>
<td>2</td>
</tr>
<tr>
<td>PHONECNTR</td>
<td>Number of call attempts on the manual recall number (RECALLNUMBER) of the customer.</td>
<td>Numeric</td>
<td>2</td>
</tr>
</tbody>
</table>
| PHONESTAT         | The PHONESTAT field is set when the setzones is executed during the list preprocessing. PHONESTAT changes constantly during the daily processing. Each phone number in the calling list has a corresponding character in the PHONESTAT field. For example, if list1 has two phone numbers, the PHONESTAT field will contain two characters. The first character corresponds to PHONE1 and the second character corresponds to PHONE2. Each character in the PHONESTAT field may contain one of five different characters:  
  ● N = not called  
  ● B = bad number  
  ● C = called  
  ● O = passed to agent  
  ● A = active/set for recall  
  PHONESTATR is used by the system to determine which phone number is incorrect. Phones that have a B in their corresponding PHONESTAT field will not be attempted. When a job is verified, PHONESTAT fields with C or O are reset back to N. | Character | 3 |
Chapter 38: PC Analysis Telnet

504 Using Avaya Proactive Contact Supervisor

<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
</table>
| PHONESTATR        | PHONESTATR changes constantly during the daily processing. The manual recall phone number in the calling list has a corresponding character in the PHONESTATR field. The PHONESTATR field may contain one of five characters:  
  ● N = not called  
  ● B = bad number  
  ● C = called  
  ● O = passed to agent  
  ● A = active/set for recall  
  PHONESTATR is used by the system to determine which phone number is incorrect. Phones numbers that display B in their corresponding PHONESTATR field are not attempted for recall. | Character   | 1      |
<p>| RECALLDATE        | Date for which the recall timer is set.                                                                                                                                                                    | Date       | 10     |
| RECALLPHONE       | System phone to be recalled. This information is set by the agent at the time of calling.                                                                                                                    | Character  | 2      |
| RECALLNAME        | Name of the customer for which the recall has been set.                                                                                                                                                     | Character  | 30     |
| RECALLNUMBER      | Customer phone number, other than the phone numbers that are reflecting in the customer record, for which the recall has been set.                                                                        | Character  | 12     |
| RECALLTIME        | Time for which the recall timer is set.                                                                                                                                                                     | Time       | 8      |
| SHADOWJOB         | Name of the shadow job associated with the Agent owned recall set for the customer record.                                                                                                                   | Character  | 20     |</p>
<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
</table>
| STATUSFLAG        | Status of the record. If anything other than a “null” (might appear as a blank entry) appears, then the record is considered as not callable:  
  ● T = failed time zone  
  ● B = bad phone number  
  ● D = too many days on system  
  ● R = duplicate record  
  ● E = manual delete via record edit  
  ● C = call on inbound campaign, cancelled in outbound campaign  
  ● N = Do Not Call | Character  | 1        |
| SVJCODE           | Sales verification code. This field is used in case of sales verification jobs. | Character  | 3        |
| TME               | Time, as captured on the system, when the call was made. | Time       | 8        |
| TME_STAMP         | Time displayed as Universal Time Coordinated (UTC), as captured on the system, when the call was made. | Numeric    | 12       |
| ZONEPHONE#        | Time zone associated with the geographical location of the customer phone number (phone #). | Character  | 1        |
| ZONEPHONER        | Time zone associated with the geographical location of the manual recall number (RECALLNUMBER). | Character  | 1        |

**Call Information Statistics**

The following table contains information about the Call Information Statistics fields on the PC Analysis extract.
<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>INF_JOBNUM</td>
<td>System identification number assigned to a job. This number increases each time the system runs the job.</td>
<td>Numeric</td>
<td>6</td>
</tr>
<tr>
<td>INF_DATE</td>
<td>Date on which the event occurred. See INF_EVENTLABL.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>INF_TIME</td>
<td>Time when the event occurred. See INF_EVENTLABL.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>INF_EVENTLABL</td>
<td>The name of the reported event. For example, line usage, hit rate, acquire, release, and log on.</td>
<td>Character</td>
<td>20</td>
</tr>
<tr>
<td>INF_FREE</td>
<td>Data for the event in the event label field. For example, hit rate shows the current hit rate; line usage shows the current line usage.</td>
<td>Character</td>
<td>80</td>
</tr>
<tr>
<td>INF_AGENTNAME</td>
<td>User name assigned to the agent.</td>
<td>Character</td>
<td>8</td>
</tr>
</tbody>
</table>
| INF_CLOCKTIME       | This field has several uses:  
   ● For LOG OFF events, it displays the total work time for last assignment, and not the time since log on.                                                                                     | Numeric    | 8      |
|                     | ● For JOBTIME, it is the last entry in the file displaying the total job time.                                                                                                                                  |            |        |
|                     | ● For agent transfer event, it is the time the agent spent on the previous assignment.                                                                                                                                 |            |        |
| INF_IDLETIME        | Duration of idle time between the same type of calls.                                                                                                                                                         | Numeric    | 8      |
| INF_IDLETYPE        | Job type to which the idle agent is assigned.                                                                                                                                                                | Character  | 1      |
### Call Transaction Statistics

The following table contains information about the Call Transaction Statistics fields on the PC Analysis extract.

<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>TRN_JOBNUM</td>
<td>System identification number assigned to a job.</td>
<td>Numeric</td>
<td>6</td>
</tr>
<tr>
<td>TRN_DATE</td>
<td>Date when the event occurred.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>TRN_TIME</td>
<td>Time when the event occurred.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>TRN_WAITTIME</td>
<td>Total duration for which the customer was in the wait queue.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>TRN_USERFIELD</td>
<td>This field can be defined by the user.</td>
<td>Character</td>
<td>80</td>
</tr>
<tr>
<td>TRN_TELELINE</td>
<td>Line number used by this call.</td>
<td>Numeric</td>
<td>3</td>
</tr>
<tr>
<td>TRN_COMPCODE</td>
<td>Completion code entered by the system for the call.</td>
<td>Numeric</td>
<td>3</td>
</tr>
<tr>
<td>TRN_RECNUM</td>
<td>Number assigned to the customer record.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>TRN_PHONENUM</td>
<td>Phone number of the customer in case of the outbound calling.</td>
<td>Character</td>
<td>20</td>
</tr>
<tr>
<td>TRN_AGENTNAME</td>
<td>User name assigned to the agent who attended this call.</td>
<td>Character</td>
<td>8</td>
</tr>
<tr>
<td>TRN_RECALLCNT</td>
<td>Number of times the system has recalled the record.</td>
<td>Numeric</td>
<td>8</td>
</tr>
</tbody>
</table>
The following table contains information about the Job History fields on the PC Analysis extract.

<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>TRN_TALKTIME</td>
<td>Agent talk time for the call.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>TRN_WORKTIME</td>
<td>Agent work time for the call.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>TRN_V_TO_HANG</td>
<td>Duration between the time the customer answered the call and the release of line. An exception to this calculation is in case of a managed (preview) call. If there is no call progress analysis, the timer starts when the call is delivered to an agent and the call is marked as connect.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>TRN_OFF_TO_HANG</td>
<td>Duration between the time the system initiated the call and the release of line.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>TRN_P_FIELDNUM</td>
<td>Phone number of the customer in case of inbound call</td>
<td>Numeric</td>
<td>1</td>
</tr>
<tr>
<td>TRN_CONNECT</td>
<td>Flag that marks the call as connect.</td>
<td>Numeric</td>
<td>1</td>
</tr>
<tr>
<td>TRN_UNITID</td>
<td>Unit ID assigned to the call</td>
<td>Character</td>
<td>15</td>
</tr>
<tr>
<td>TRN_UPDATETIME</td>
<td>Time taken by the agent for updating the record.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>TRN_PREVTIME</td>
<td>Time spent by the agent while previewing the record on a managed job.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>TRN_TRANSTYPE</td>
<td>Call type: inbound or outbound.</td>
<td>Character</td>
<td>1</td>
</tr>
<tr>
<td>TRN_AGCOMPCODE</td>
<td>Completion code entered by the agent for the call.</td>
<td>Numeric</td>
<td>3</td>
</tr>
<tr>
<td>TRN_LOGTYPE</td>
<td>Agent log on type: outbound, inbound, blend, managed, or PTP.</td>
<td>Character</td>
<td>1</td>
</tr>
</tbody>
</table>

**Job History**

The following table contains information about the Job History fields on the PC Analysis extract.
<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>JOBNAME</td>
<td>Name of the job for which the report has been generated.</td>
<td>Character</td>
<td>20</td>
</tr>
<tr>
<td>JOBNUMBER</td>
<td>System identification number assigned to a job. This number increases each</td>
<td>Character</td>
<td>6</td>
</tr>
<tr>
<td></td>
<td>time the system runs the job.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>JOBTYPE</td>
<td>Indicates the job type: inbound, outbound, or blend.</td>
<td>Character</td>
<td>5</td>
</tr>
<tr>
<td>UNITID</td>
<td>Unit work list key value for a unit work list job. For example, if you base</td>
<td>Character</td>
<td>15</td>
</tr>
<tr>
<td></td>
<td>the unit work lists on ZIP codes, then this field displays the ZIP codes used</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>by that job.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>JOBDATE</td>
<td>Date when the job was started.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>STARTTIME</td>
<td>Time when the job was started.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>ENDTIME</td>
<td>Time when the job was stopped.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>ACTIVETIME</td>
<td>Total job call processing time. This duration does not include the start</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td></td>
<td>time or the suspension time.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>JOB_CLOCKTIME</td>
<td>Total agent hours on a job. It is a total of the following fields: JOB_TALKTIME,</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td></td>
<td>JOB_UPDATETIME, and JOB_IDLETIME fields.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>JOB_IDLETIME</td>
<td>Total duration for which the agents were idle. It does not include the time</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td></td>
<td>between the agents' login and the first call that was made or the time</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>between the release of agents' final record and log off. For a blend job,</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>it includes the transfer time between jobs.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>JOB_TALKTIME</td>
<td>Total talk time for all the agents on all the jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>JOB_UPDATETIME</td>
<td>Total update time for all the agents on all the jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>System Field Name</td>
<td>Description</td>
<td>Field Type</td>
<td>Length</td>
</tr>
<tr>
<td>-------------------</td>
<td>-------------</td>
<td>------------</td>
<td>--------</td>
</tr>
<tr>
<td>JOB_WORKTIME</td>
<td>Total work time for all the agents on all the jobs. This field displays the total of JOB_TALKTIME and JOB_UPDATETIME fields.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>JOB_IDLECOUNT</td>
<td>Number of times the agents were idle.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>JOB_CALLSWORKED</td>
<td>Total number of calls handled by the agents on all the jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>JOB_CALLSANSWERED</td>
<td>Total number of calls handled on inbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>JOB_WAITQUEUETIME</td>
<td>Time (in seconds) that customer spent in the wait queue.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>JOB_CALLSINWAIT</td>
<td>Total number of calls placed in the wait queue.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_CLOCKTIME</td>
<td>Total duration for which the agents were on outbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_IDLETIME</td>
<td>Total duration of idle time on the outbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_TALKTIME</td>
<td>Total duration of talk time on the outbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_UPDATETIME</td>
<td>Total duration of update time on the outbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_WORKTIME</td>
<td>Total work time on outbound jobs. This field displays the total of the OUT_TALKTIME and OUT_UPDATETIME fields.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_IDLECOUNT</td>
<td>Number of times the agents were idle on the outbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_CALLSWORKED</td>
<td>Total number of outbound calls handled by the agents.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_CALLSANSWERED</td>
<td>Total number of outbound calls answered.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_WAITQUEUETIME</td>
<td>Total time outbound customer spent in the wait queue.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>System Field Name</td>
<td>Description</td>
<td>Field Type</td>
<td>Length</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>------------</td>
<td>--------</td>
</tr>
<tr>
<td>OUT_CALLSINWAIT</td>
<td>Total number of outbound calls placed in the wait queue.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_CALLSPLACEDD</td>
<td>Total number of outbound calls placed.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_RECALLSPLACED</td>
<td>Total number of recalls placed.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_CLOCKTIME</td>
<td>Total time spent on inbound calls by agents. This field displays the total of the INB_TALKTIME, INB_UPDATETIME and INB_IDLETIME fields.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_IDLETIME</td>
<td>Total duration of idle time on inbound calls.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_TALKTIME</td>
<td>Total duration of talk time on inbound calls.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_UPDATETIME</td>
<td>Total duration of update time on inbound calls.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_WORKTIME</td>
<td>Total work time on inbound calls. This field displays the total of the INB_TALKTIME and INB_UPDATETIME fields.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_IDLECOUNT</td>
<td>Number of times agents were idle on inbound calls.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_CALLSWORKEDED</td>
<td>Total number of inbound calls that were handled by the agents.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_CALLSANSWERED</td>
<td>Total number of inbound calls received per job.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_WAITQUEUETIME</td>
<td>Total time customer spent in the inbound wait queue.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_CALLSINWAIT</td>
<td>Total number of calls placed in the inbound wait queue.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>XOUT_CLOCKTIME</td>
<td>Total time spent as Person-to-person (PTP) agent.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>XOUT_IDLETIME</td>
<td>Total duration of PTP idle time.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>XOUT_IDLECOUNT</td>
<td>Number of times PTP agents were idle.</td>
<td>Numeric</td>
<td>8</td>
</tr>
</tbody>
</table>
### Agent History

The following table contains information about the Agent History fields on the PC Analysis extract.

<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>XOUT_CALLSWORKED</td>
<td>Total number of PTP calls.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>PREVIEWTIME</td>
<td>Total time agents spent previewing records during Managed Dialing.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>LISTNAME</td>
<td>Name of the calling list.</td>
<td>Character</td>
<td>20</td>
</tr>
<tr>
<td>JOBLABEL</td>
<td>Job description as included in the job file.</td>
<td>Character</td>
<td>40</td>
</tr>
<tr>
<td>SELECTNAME</td>
<td>Name of the record selection file.</td>
<td>Character</td>
<td>20</td>
</tr>
<tr>
<td>STRATEGYNAME</td>
<td>Name of the phone strategy file.</td>
<td>Character</td>
<td>20</td>
</tr>
<tr>
<td>COMPCODEXXX</td>
<td>Call Completion Codes as defined in the system. The range of completion code is between 0-199.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>System Field Name</td>
<td>Description</td>
<td>Field Type</td>
<td>Length</td>
</tr>
<tr>
<td>-------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>------------</td>
<td>--------</td>
</tr>
<tr>
<td>LOGOUTTIME</td>
<td>Time when the agent first logged out.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>AGENTNAME</td>
<td>User name assigned to the agent.</td>
<td>Character</td>
<td>20</td>
</tr>
<tr>
<td>JOB_CLOCKTIME</td>
<td>Total number of agent hours on a job. This field displays the total of JOB_TALKTIME, JOB_UPDATETIME, and JOB_IDLETIME fields.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>JOB_IDLETIME</td>
<td>Total duration of idle time for agent. This field does not include the duration between the logging in of the agents and when they make the first call. This field also does not include time between the release of agents’ final record and log off. For a blend job, it includes transfer time between jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>JOB_TALKTIME</td>
<td>Total duration of talk time for all the agents.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>JOB_UPDATETIME</td>
<td>Total duration of update time for all the agents.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>JOB_WORKTIME</td>
<td>Total duration of work time, which is a total of JOB_TALKTIME and JOB_UPDATETIME fields.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>JOB_IDLECOUNT</td>
<td>Number of times agent was idle.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>JOB_CALLSWORKED</td>
<td>Total number of calls handled during a job.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_CLOCKTIME</td>
<td>Total duration of outbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_IDLETIME</td>
<td>Total duration of idle time on outbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_TALKTIME</td>
<td>Total duration of talk time on outbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_UPDATETIME</td>
<td>Total duration of update time on outbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>System Field Name</td>
<td>Description</td>
<td>Field Type</td>
<td>Length</td>
</tr>
<tr>
<td>-------------------</td>
<td>-------------</td>
<td>------------</td>
<td>--------</td>
</tr>
<tr>
<td>OUT_WORKTIME</td>
<td>Total duration of work time on outbound jobs. This field displays the total of OUT_TALKTIME and OUT_UPDATETIME fields.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_IDLECOUNT</td>
<td>Number of times agent was idle on outbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_CALLSWORKED</td>
<td>Total number of outbound calls handled.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_CLOCKTIME</td>
<td>Total duration of inbound calls. This field displays the total of INB_TALKTIME, INB_UPDATETIME and INB_IDLETIME fields.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_IDLETIME</td>
<td>Total duration of idle time on inbound calls.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_TALKTIME</td>
<td>Total duration of talk time on inbound calls.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_UPDATETIME</td>
<td>Total duration of update time on inbound calling.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_WORKTIME</td>
<td>Total duration of work time on inbound calls. This field displays the total of INB_TALKTIME and INB_UPDATETIME fields.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_IDLECOUNT</td>
<td>Number of times agents were idle on inbound calls.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_CALLSWORKED</td>
<td>Total number of inbound calls handled.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>XOUT_CLOCKTIME</td>
<td>Total time spent on acting as Person to Person (PTP) agent.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>XOUT_IDLETIME</td>
<td>Total duration of PTP idle time.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>XOUT_IDLECOUNT</td>
<td>Number of times PTP agent was idle.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>XOUT_CALLSWORKED</td>
<td>Total number of PTP calls.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>PREVIEWTIME</td>
<td>Total time spent by agents for previewing records during Managed Dialing.</td>
<td>Numeric</td>
<td>8</td>
</tr>
</tbody>
</table>
Transfer PC Analysis extract output files

To transfer generated PC Analysis extract output files from Avaya Proactive Contact to a network location or to a personal computer.

1. Start **PC Analysis Telnet**.
2. Connect to a dialer.
3. Select **Tools > Get File(s)**.
   
   The **FTP Client** dialog box appears. The name of the system to which you are connected appears in the dialog box title.
4. Select one or more extract output files to transfer, and then click **Get file**.
   
   The **Save As** dialog box appears.
5. Browse to the location where you want to transfer the selected extract output file, and then click **Save**.
   
   The system saves the file to the selected location. If you selected more than one extract output file to transfer, the **Save As** dialog box appears for the next file.
6. Repeat Step 5 for each extract output file you selected to transfer.
   
   After you click save for the last output file, the **FTP Client** dialog box appears. For more information, see **FTP Client dialog box** on page 516.
7. Click **Cancel** to close the **FTP Client** dialog box.

<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>LISTNAME</td>
<td>Name of the calling list.</td>
<td>Character</td>
<td>20</td>
</tr>
<tr>
<td>OFFLINE</td>
<td>Total time spent off-line, that is the agents were logged in but not on any job.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>RELEASE</td>
<td>Time spent on releasing the ACD in Predictive Blend.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>COMPCODEXXX</td>
<td>Call Completion Codes as defined in the system. The range of completion code is between 0-199.</td>
<td>Numeric</td>
<td>8</td>
</tr>
</tbody>
</table>
FTP Client dialog box

The FTP Client dialog box allows you to transfer PC Analysis extract files from Avaya Proactive Contact to a network location, such as a personal computer.

File Name - Lists the PC Analysis extract files that currently exist on the selected dialer. Extract files typically have a .prn extension (for example, list1.prn).

Size - Lists the file size of each extract file.

Date - Identifies the date that the extract file was generated.

Get File - Click Get File to transfer one or more selected extract files. The Save As dialog box appears, which lets you choose where you want to save the file.
Chapter 39: System Telnet

System Telnet is a tool that allows you access to the Avaya Proactive Contact Linux-based menus.

This section contains the following topics:

- Understanding System Telnet on page 517
- Using System Telnet on page 518

Understanding System Telnet

System Telnet tool allows you to access the Linux-based Supervisor and Administrative menus.

This section contains the following topics:

- System Telnet on page 517
- System Telnet features on page 518

System Telnet

Use the Linux-based Supervisor and Administrative menus to do the following:

- Manage user accounts
- Check calling list status
- Manage agent job lists
- Access some Monitor and Editor features

Note:
Avaya Proactive Contact does not allow you to change your password using the System Telnet.

System Telnet is available from the Tools menu in Analyst, Editor, or Monitor.

Note:
If access to Supervisor is not available, you will need to use a third-party telnet tool to access Avaya Proactive Contact menu system and PC Analysis.
To access the PC Analysis menus, use the PC Analysis Telnet tool in Analyst.
Chapter 39: System Telnet

System Telnet features

Use the System Telnet window to navigate to the Linux-based menus.

The System Telnet features appear on the System Telnet toolbar, File menu and Tools menu.

System Telnet contains the following features:

<table>
<thead>
<tr>
<th>Feature</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connect</td>
<td>![Icon]</td>
<td>Use the Connect tool to select the dialer for which you want to access Linux-based features. This function is not available while you are connected to a dialer. You must disconnect from a dialer before you can connect to a different dialer.</td>
</tr>
<tr>
<td>Disconnect</td>
<td>![Icon]</td>
<td>Use the Disconnect tool to end the telnet session for the current dialer. If you exit the menu system, System Telnet automatically disconnects your session. After you disconnect, you can connect to a different dialer or exit the System Telnet application.</td>
</tr>
<tr>
<td>Exit out of entry</td>
<td>![Icon]</td>
<td>Use the Exit out of entry tool to move back one screen in the Linux-based screens. Exit out of entry provides the same functionality as Ctrl-x.</td>
</tr>
<tr>
<td>Done with entry</td>
<td>![Icon]</td>
<td>Use Done with entry to move to the next Linux-based screen. Done with entry provides the same functionality as the Done key, F1.</td>
</tr>
</tbody>
</table>

Using System Telnet

To access the Avaya Proactive Contact Linux-based menus:

1. Select Start > All Programs > Avaya > Proactive Contact > Supervisor > Analyst, Editor, or Monitor.
2. Select Tools > System Telnet.
   A System Telnet window appears.
3. Select File > Connect.
   The Connect to Proactive Contact dialog box appears.
4. From the Name list, select the name of the dialer to which you want to connect, then click OK.
   The dialer login: prompt appears in the Telnet window.
5. Type one of the following login and password combinations:
   ● System login and password to access the system menus
   ● Administrator login and password to access the administrative menus

The Linux-based menu system associated with your user name appears in the Telnet window.
Chapter 39: System Telnet
Appendix A: PDSAgent.ini Parameters

PDSAgent.ini contains the settings that an agent application uses. The PDSAgent.ini file is present on the computer which has Avaya Proactive Contact Agent installed. This file is located on the Agent workstation at the:

<Install Path>\Avaya\Proactive Contact \Agent

The various parameters available are:

- **Agent** on page 521
- **DDE** on page 522
- **Blend** on page 523
- **GUI** on page 523
- **Phone** on page 524
- **Session** on page 525
- **Server** on page 526
- **Log** on page 526
- **SizeAndPosition** on page 527
- **Security** on page 528
- **DialerList** on page 529

---

**Agent**

This section contains the agent login related parameters.
### DDE

This section contains the parameter for Dynamic Data Exchange. The primary function of DDE is to allow Windows applications to share data.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>UseActiveExe</td>
<td>TRUE</td>
<td>When this value is TRUE and the agent software is started the agentdde.exe also starts. The call events are passed in DDE format. If this value is FALSE, the agentdde.exe does not start.</td>
</tr>
</tbody>
</table>
Blend

This section contains the parameter for PAB related setting.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GoOffBreakAfterAcquire</td>
<td>FALSE</td>
<td>If this parameter is TRUE, the agent starts making calls as soon as he switches from inbound to outbound.</td>
</tr>
</tbody>
</table>

GUI

This section contains all the GUI related parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NumSocketMessages</td>
<td>1000</td>
<td>Number of the history messages going to and from the server.</td>
</tr>
<tr>
<td>ShowWorkBar</td>
<td>TRUE</td>
<td>If set to TRUE, this enables the work bar in the Agent application.</td>
</tr>
<tr>
<td>ShowPhoneBar</td>
<td>TRUE</td>
<td>If set to TRUE, this enables the telephone bar in the Agent application.</td>
</tr>
<tr>
<td>ShowVolumeBar</td>
<td>TRUE</td>
<td>If set to TRUE, this enables the Volume bar in the Agent application.</td>
</tr>
<tr>
<td>ShowShortcutBar</td>
<td>TRUE</td>
<td>If set to TRUE, this enables the Shortcut bar in the Agent application.</td>
</tr>
<tr>
<td>ShowChat</td>
<td>FALSE</td>
<td>If set to TRUE, this enables the chat window in the Agent application.</td>
</tr>
<tr>
<td>ShowDataBar</td>
<td>FALSE</td>
<td>If set to TRUE, this enables the data bar in the Agent application.</td>
</tr>
</tbody>
</table>
### Appendix A: PDSAgent.ini Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ShowManagedCallBar</td>
<td>FALSE</td>
<td>If set to TRUE, this shows the managed call bar in the Agent application.</td>
</tr>
<tr>
<td>MaxQuickReleaseHistory</td>
<td>5</td>
<td>Maximum number of quick release history.</td>
</tr>
<tr>
<td>MaxFinishWorkHistory</td>
<td>5</td>
<td>Maximum number of finish work history.</td>
</tr>
<tr>
<td>MaxReleaseLineHistory</td>
<td>5</td>
<td>Maximum number of release line history.</td>
</tr>
<tr>
<td>FinishWorkHistory</td>
<td>1,76,13:94,65,90</td>
<td>Holds the history of the most frequently used releases.</td>
</tr>
<tr>
<td>ReleaseLineHistory</td>
<td>1,71,13:1,102:1,10</td>
<td>Holds the history of the most frequently used releases.</td>
</tr>
<tr>
<td>CurCallbackTab</td>
<td>1</td>
<td>If set to 0, you can set call back time at a specific date and time. If set to 1 then you can specify the time after 1 hour and so on.</td>
</tr>
<tr>
<td>UseLargeShortcutIcons</td>
<td>FALSE</td>
<td>If set to FALSE then small shortcut icons are displayed. If set to TRUE then large shortcut icons are displayed.</td>
</tr>
<tr>
<td>CurrentShortcutList</td>
<td>2</td>
<td>Stores the current item of the left button groups that are selected when you run an application.</td>
</tr>
<tr>
<td>CallbackChooseNumber ByDefault</td>
<td>TRUE</td>
<td>If set to True, this allows an agent to select the default telephone numbers present in the data. If set to FALSE then the agent makes a manual entry.</td>
</tr>
<tr>
<td>ConfirmOnRelease</td>
<td>FALSE</td>
<td>If set to True the confirmation message is displayed before releasing the line. If set to False then the confirmation message is not displayed before releasing line.</td>
</tr>
</tbody>
</table>

---

**Phone**

This section contains all the telephone extension related parameters.
### Session

This section contains the session related parameter.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
</table>
| **ServerLogging**               | TRUE          | If you set this value to TRUE, log files for all agent related events are created on the Server. The logs are located at:  
/ opt / avaya / debug  
The name of the log file is <agent id>_API.trans |
| **XferCustHangUpShowReleaseDlg** | TRUE          | Handles the popping up of the Release dialog box that appears when the PDSAgent receives AGTXferCustHungUp notification.  
If this parameter is set to true, then the Release dialog box appears.  
If this parameter is set to false, then the Release dialog box does not appear. |
Appendix A: PDSAgent.ini Parameters

Server

This section contains the Proactive Contact server details.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LastUsedServerIP</td>
<td>Blank</td>
<td>This parameter contains the IP address of the last used Proactive Contact server.</td>
</tr>
</tbody>
</table>

Log

This section contains the log files related parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LogLevel</td>
<td>5</td>
<td>This parameter logs the severity from 1 to 5, where:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>● Catastrophic = 1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>● Critical = 2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>● Error = 3</td>
</tr>
<tr>
<td></td>
<td></td>
<td>● Message = 4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>● Information = 5</td>
</tr>
<tr>
<td>LogFileName</td>
<td>PDSAgent.log</td>
<td>The name of the log file generated on the windows system where you have installed the Proactive Contact Agent application.</td>
</tr>
</tbody>
</table>
This section contains the parameters to set the display settings for the agent.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SocketBufferDumpFileName</td>
<td>SocketBuffer.dmp</td>
<td>The name of the log file where all socket messages are sent to and from agent workstation to Proactive Contact server.</td>
</tr>
<tr>
<td>LogSocketMessages</td>
<td>TRUE</td>
<td>If set to TRUE, messages are written to the log file.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MainFormHeight</td>
<td>10830</td>
<td>Used to set the height of the agent application.</td>
</tr>
<tr>
<td>MainFormLeft</td>
<td>1890</td>
<td>Used to set the form position (distance form the left of screen).</td>
</tr>
<tr>
<td>MainFormTop</td>
<td>2250</td>
<td>Used to set the form position (distance from the top of screen).</td>
</tr>
<tr>
<td>MainFormWidth</td>
<td>12975</td>
<td>Used to set the width of the agent application.</td>
</tr>
<tr>
<td>WorkBarPosition</td>
<td>1</td>
<td>Default position of the Work toolbar.</td>
</tr>
<tr>
<td>ManagedCallBarPosition</td>
<td>4</td>
<td>Default position of the managed call toolbar.</td>
</tr>
<tr>
<td>DataBarPosition</td>
<td>5</td>
<td>Default position of the Data toolbar.</td>
</tr>
<tr>
<td>PhoneBarPosition</td>
<td>2</td>
<td>Default position of the telephone bar position.</td>
</tr>
<tr>
<td>VolumeBarPosition</td>
<td>3</td>
<td>Default position of the volume bar position.</td>
</tr>
<tr>
<td>SplitChatTop</td>
<td>7551</td>
<td>Default top position of split chat.</td>
</tr>
<tr>
<td>SplitWorkLeft</td>
<td>3888</td>
<td>Default left position of split work (distance form the left of screen).</td>
</tr>
</tbody>
</table>
### Security

You can secure the communications from and to the Avaya Proactive Contact agent at the highest security level. The traditional TCP socket communication changed to TCP over SSL (Secure Socket Layer).

The security settings require the parameters listed in the table below.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SplitChatLastDistFromStatBar</td>
<td>2334</td>
<td>Default position of the split chat from the status bar.</td>
</tr>
<tr>
<td>ChatWindowTop</td>
<td>7626</td>
<td>Top position of the chat window.</td>
</tr>
<tr>
<td>WorkBarNewRow</td>
<td>0</td>
<td>Display the toolbar in a new row.</td>
</tr>
<tr>
<td>ManagedCallBarNewRow</td>
<td>1</td>
<td>Display the Managed call toolbar in a new row.</td>
</tr>
<tr>
<td>DataBarNewRow</td>
<td>1</td>
<td>Display the work data toolbar in a new row.</td>
</tr>
<tr>
<td>PhoneBarNewRow</td>
<td>1</td>
<td>Display the Phone data toolbar in a new row.</td>
</tr>
<tr>
<td>VolumeBarNewRow</td>
<td>1</td>
<td>Display the Volume data toolbar in a new row.</td>
</tr>
<tr>
<td>WorkBarWidth</td>
<td>0</td>
<td>Width of the work toolbar.</td>
</tr>
<tr>
<td>ManagedCallBarWidth</td>
<td>0</td>
<td>Width of the managed call bar.</td>
</tr>
<tr>
<td>DataBarWidth</td>
<td>0</td>
<td>Width of the data bar.</td>
</tr>
<tr>
<td>PhoneBarWidth</td>
<td>0</td>
<td>Width of the phone bar.</td>
</tr>
<tr>
<td>VolumeBarWidth</td>
<td>0</td>
<td>Width of the volume bar.</td>
</tr>
</tbody>
</table>
**DialerList**

You can use these parameters to provide a list of multiple dialers.

Ensure that the numbering in this list is not broken. For example: If you have a DialerName6, but no DialerName5, then DialerName6 is not read.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DialerNameX</td>
<td>Host name of Proactive Contact Server</td>
<td>Host name of Proactive Contact Server.</td>
</tr>
<tr>
<td>DialerIPX</td>
<td>IP address of the Proactive Contact Server</td>
<td>IP address of the Proactive Contact Server.</td>
</tr>
<tr>
<td>DialerPort.X</td>
<td>22700</td>
<td>The default port used for socket connection from agent workstation to the Proactive Contact server.</td>
</tr>
</tbody>
</table>
Index

A
Abandon Calls calculation ........................................ 391
abandons, completion code category ....................... 152
Abatement Service Level ........................................... 487
Agent Blending control method parameter .................. 487
Service Level ......................................................... 478
ACD
agent ........................................................................ 33
Agent Blending ....................................................... 479
agent state ................................................................. 275
Aspect CallCenter ...................................................... 480
Avaya Communication Manager ................................. 480
blend agents ............................................................. 487
handle outbound calls .............................................. 485
Northern Telecom Meridian ......................................... 482
PINNACLE ................................................................. 482
Rockwell Spectrum ..................................................... 481
Siemens ROLM .......................................................... 483
Activity Event Viewer ................................................. 82, 83, 92
adjust columns .......................................................... 70
Administrative dictionary ............................................ 397
Administrative reports ................................................ 383
available reports ........................................................ 383
report variations ........................................................ 383
agent
display a view for an agent ......................................... 299
find ........................................................................ 337
hierarchy ................................................................. 290
logins ...................................................................... 33
manage in Monitor ...................................................... 335
monitor line .............................................................. 338
remove from a job in Monitor .................................... 338
remove from job ........................................................ 339
rename Monitor view set ............................................. 301
reporting to a supervisor, find .................................... 335
resources view .......................................................... 471
save as Monitor view set ............................................. 300
save current Monitor views ........................................ 300
standard Monitor views .............................................. 298
states ..................................................................... 274
transfer .................................................................. 337
types of ..................................................................... 33
Agent Blending .......................................................... 477
create a domain ........................................................ 489
create domain group .................................................. 488
delete a domain group ............................................... 490
delete domain .......................................................... 490
described ................................................................. 477
domain group ............................................................. 484
domain groups .......................................................... 485
domain types ............................................................. 484
domains .................................................................. 483
edit a domain ............................................................ 490
edit a domain group ................................................... 489
login ...................................................................... 34
move a domain .......................................................... 491
New Domain dialog box ............................................. 489
Outbound ................................................................. 485
Predictive Agent Blend .............................................. 478
Proactive Agent Blend ............................................... 479
reset the blend engine .............................................. 492
resynch the blend engine .......................................... 492
start ...................................................................... 488
start the blend engine .............................................. 492
stop the blend engine ............................................... 491
supported ACDs ....................................................... 479
tool ...................................................................... 477, 488
uses pooled ACD agents for outbound calling .......... 478
view ACD statistics .................................................. 493
view alerts ............................................................... 493
view transactions ...................................................... 493
Agent Completion Codes .......................................... 473
Agent Completion Codes, Monitor view ....................... 299, 473
agent controls
Find Agent .................................................................. 353
functions .................................................................. 335, 336
Monitor Agent ........................................................... 354
Send Message ........................................................... 354
Transfer Agent .......................................................... 354
Agent Detail .............................................................. 472
Monitor view ............................................................ 299
view ...................................................................... 472
Agent History ........................................................... 474
Agent History, Monitor view ....................................... 299, 474
agent keys definition file name .................................... 221
Agent Logout Time calculation .................................... 392
Agent Monthly reports .............................................. 384
available reports ..................................................... 384
report variations ...................................................... 385
Agent reports ........................................................... 372
available reports ..................................................... 372
report variations ...................................................... 374
agent resources view ................................................. 472, 473
Agent Update Time ................................................... 218
Agent view
defined .................................................................. 446
display .................................................................. 339
Agent Work Time ...................................................... 218
Using Avaya Proactive Contact Supervisor December 2011 i
calling party number (ANI) ........................................ 216
calling results tab ............................................. 198
calls in the wait queue ........................................ 218
category
  assign a completion code ................................... 154
  remove a completion code ................................... 155
Cell Phone Campaign Call Progress ........................................... 219
change
  completion code ............................................. 155
  Monitor default settings .................................. 271
Change a report .................................................. 360
characters, wildcard ............................................ 194
clear
  all rows in a phone strategy ............................. 188
  record selection row ...................................... 207
closures, completion code category ......................... 151
columns ............................................................ 70
Combined call completion code statistics ...................... 437
Combined call handling times .................................. 405
Combined call statistics ........................................ 408
Combined queue statistics .................................... 411
Combined RPC and closure statistics ............................ 435
completion code
  assign a code to a category ................................ 154
  assign to category .......................................... 154
  attributes ...................................................... 150
  categories .................................................... 151
  change .......................................................... 155
  code ............................................................. 150
  defined ........................................................ 149
  description ................................................... 150
  examples ........................................................ 149
  keyword .......................................................... 150
  record selection ............................................. 192
  remove from category ...................................... 155
  save as HTML .................................................. 156
  save configuration .......................................... 156
  type .............................................................. 150
Completion Code Detail by Agent view ........................................... 466
Completion Code Manager ............................................ 149
  assign code to a category ................................ 154
  change a code ................................................ 155
  Completion Code Wizard .................................... 154
  multi-dialers ............................................... 152
  remove a code from a category ............................ 155
  save a completion code .................................... 156
  saves codes as HTML ........................................ 156
  start .............................................................. 153
  Tools menu ..................................................... 153
  window ........................................................... 153
Completion Code Summary reports ................................. 370
Completion Code Wizard ............................................ 154
Configurator ...................................................... 89
copy record selection .......................................... 203
CPU ................................................................. 92
create
  Agent Blending domain ...................................... 489
  alerts ............................................................. 315
  Analyst report ............................................... 358
  hierarchy ....................................................... 291
  job ................................................................. 232
  message script .............................................. 171
  Monitor button ............................................... 302
Create a new report configuration ................................. 358
Creating a new report ........................................... 400
creating a new role ............................................. 45
Cruise Control ..................................................... 33
  benefits ........................................................ 213
  call pacing method ......................................... 212
  Desired Service Level ...................................... 231
  required settings .......................................... 231
  Time to Connect Tolerance .................................. 231
Custom
  button group .................................................. 302
  rename Monitor view set .................................... 301
  save as Monitor view set ................................... 300
  save current Monitor views ................................. 300
  standard Monitor views .................................... 298
  view, defined ................................................ 446
  views, see View .............................................. 272
customize
  Monitor ........................................................ 272
  Monitor windows ............................................. 297
  Status Bar, Monitor dialog box ............................. 343
  view ............................................................... 299

D
Data dictionary concepts ............................................. 395
Data dictionary overview .......................................... 395
Data dictionary reference .......................................... 401
data export ........................................................ 133
data field notes ................................................... 398
data import ........................................................ 114
Database Server IP Address ........................................... 89
Database Server Name .............................................. 89
date
  comparison ....................................................... 281
  pattern matching ............................................. 277
delete
  Agent Blending domain ........................................ 490
  Agent Blending domain group ................................ 490
  Analyst report ............................................... 360
  custom Monitor view ........................................ 301
  hierarchy ....................................................... 296
  hierarchy data item .......................................... 295
  hierarchy level ............................................... 295
  job ................................................................. 239
  Monitor view set ............................................. 301
  multiple jobs ................................................ 239
Index

record selection ............................... 201
record selection row .......................... 205
Delete a report configuration .................. 360
delete a role .................................. 50
Demerging
   Edit a merged role ............................ 47
Desired Service Level .......................... 231
   Agent Blending control method parameter 487
   Service Level ................................ 478
Detail tab ...................................... 197
Detection Mode
dialog box .................................... 350
   set in Monitor .................................. 333
   Strategies .................................... 181
tab .................................................... 184
dailler ............................................ 187, 204
   Agents view ................................... 450
   hierarchy ..................................... 290
   hierarchy, find agents ........................ 335
   History view .................................. 452
   in your views .................................. 274
   Lines view .................................... 451
   multi-dialer commands ........................ 109
   rename Monitor view set ....................... 301
   resources view ................................ 449, 451, 452
   save as Monitor view set ...................... 300
   save current Monitor views ...................... 300
   standard Monitor views ....................... 298
   Status view .................................... 449
   view, defined ................................ 445
Dialer IP Address ................................ 71
Dialer Name .................................... 71
Dialer Services view ................................ 72
dialog box
   Alert Viewer .................................... 319
   Alternate Initial Phone ......................... 350
   Detection Mode ................................ 350
   escape recall job .................................. 345
   Expert Calling Ratio ............................. 346
   Filter Data .................................... 344
   Find ............................................. 343
   Find Agent ...................................... 353, 354
   FTP Client ..................................... 516
   in Monitor ..................................... 341
   Inbound Settings ................................ 347
   Job link ....................................... 345
   Lines ........................................... 351
   Managed Dialing ................................ 347
   Minimum hit rate ................................ 346
   Monitor Agent .................................. 354
   New Domain .................................... 489
   Options ........................................ 240
   Quota .......................................... 349
   record selection of link job ...................... 346
   Retries ........................................ 351
   Screens ........................................ 241
   Selection records ................................ 352
   Selection results ................................ 352
   Selection sort .................................. 352
   Stop Job ........................................ 345
   Time Zones ...................................... 348
   Transfer Agent .................................. 354
   Unit Work Lists ................................ 349
digitized messages, See messages ............... 162
disable an alert .................................. 318
Disk partition .................................... 92
display
   agent view ...................................... 339
   empty record at preview ......................... 225
Display alert .................................... 84
Do Not Call ..................................... 221
donot call groups ................................ 143
domain  ........................................... 483
   create .......................................... 489
   delete .......................................... 490
   edit .............................................. 490
   group in Agent Blending ........................ 485
   move ............................................. 491
types .............................................. 484
domain group
   Agent Blending ................................ 484
   Average Speed to Answer ....................... 478
   configurations ................................ 484
   control methods ................................ 485
   create .......................................... 488
   create in Agent Blending ........................ 488
   delete .......................................... 490
   edit .............................................. 489
   OB_ONLY ........................................ 479
   one or more domains ............................ 485
   Service Level .................................. 478
download .......................................... 27
   calling lists .................................... 27, 113

E

Earliest start time ............................... 216
edit
   alerts .......................................... 316
   Analyst report .................................. 360
domain group in Agent Blending .................. 489
domain in Agent Blending ........................ 489
job .................................................... 238
   record selection ................................ 201
Editor
   Job Wizard ...................................... 232
   Messages and Scripts ........................... 161
Selection Reports .................................. 195, 204
Selections ........................................ 191, 197
### Index

| Strategies | 179 |
| Elementary and calculated data | 397 |
| e-mail | 84 |
| E-mail Notification Configuration dialog box | 84 |
| E-mail Server IP Address | 89 |
| e-mail, send alert notifications | 276 |
| enable an alert | 318 |
| end jobs | 225 |
| environment | 28 |
| escape recall | 230 |
| Escape recall in infinite job | 230 |
| escape recall job | 230 |
| dialog box | 345 |
| Event Viewer dialog box | 84 |
| example scripts | 170 |
| Expert Calling Ratio | 214, 218, 225 |
| Agent Update Time | 218 |
| Agent Work Time | 218 |
| call pacing method | 212, 217 |
| change in Monitor | 327 |
| dialog box | 346 |
| wait queue | 218 |
| export a report | 362 |
| extended regular expression | 277, 284 |

<table>
<thead>
<tr>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>FTA Client dialog box</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td>General information</td>
</tr>
<tr>
<td>grace period</td>
</tr>
<tr>
<td>Graphic View</td>
</tr>
<tr>
<td>in Monitor</td>
</tr>
<tr>
<td>View toolbar</td>
</tr>
<tr>
<td>Group field</td>
</tr>
<tr>
<td>Guidelines for creating new reports</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>Health Bridge</td>
</tr>
<tr>
<td>Health_manager_maintaining_license_configurator</td>
</tr>
<tr>
<td>hide columns</td>
</tr>
<tr>
<td>hide or show columns</td>
</tr>
<tr>
<td>in Monitor</td>
</tr>
<tr>
<td>View toolbar</td>
</tr>
<tr>
<td>hierarchy</td>
</tr>
<tr>
<td>add a level</td>
</tr>
<tr>
<td>add data items to bottom branch</td>
</tr>
<tr>
<td>delete</td>
</tr>
<tr>
<td>find agents in a job</td>
</tr>
<tr>
<td>find agents on a dialer</td>
</tr>
<tr>
<td>find agents reporting to a supervisor</td>
</tr>
<tr>
<td>move a level</td>
</tr>
<tr>
<td>move elements</td>
</tr>
<tr>
<td>remove a data item</td>
</tr>
<tr>
<td>remove a level</td>
</tr>
<tr>
<td>rename</td>
</tr>
<tr>
<td>rename a level</td>
</tr>
<tr>
<td>set default in Monitor</td>
</tr>
<tr>
<td>tree branches</td>
</tr>
<tr>
<td>Hierarchy Manager</td>
</tr>
<tr>
<td>add a level</td>
</tr>
<tr>
<td>add data items</td>
</tr>
<tr>
<td>agent hierarchy</td>
</tr>
<tr>
<td>create a hierarchy</td>
</tr>
<tr>
<td>delete a hierarchy</td>
</tr>
<tr>
<td>dialer hierarchy</td>
</tr>
<tr>
<td>icon on View toolbar</td>
</tr>
<tr>
<td>job hierarchy</td>
</tr>
<tr>
<td>move a hierarchy level</td>
</tr>
<tr>
<td>move elements</td>
</tr>
<tr>
<td>open a hierarchy</td>
</tr>
<tr>
<td>overview</td>
</tr>
<tr>
<td>remove a data item</td>
</tr>
<tr>
<td>remove a hierarchy level</td>
</tr>
<tr>
<td>rename a hierarchy</td>
</tr>
<tr>
<td>rename a hierarchy level</td>
</tr>
<tr>
<td>start</td>
</tr>
<tr>
<td>Historical performance data concepts</td>
</tr>
<tr>
<td>hit rate</td>
</tr>
</tbody>
</table>
## Index

<table>
<thead>
<tr>
<th>HTML</th>
<th>309</th>
</tr>
</thead>
<tbody>
<tr>
<td>Record Selections report</td>
<td>202</td>
</tr>
</tbody>
</table>

### I

<table>
<thead>
<tr>
<th>icons on views toolbar</th>
<th>447</th>
</tr>
</thead>
<tbody>
<tr>
<td>idle agent state</td>
<td>275</td>
</tr>
<tr>
<td>Idle count fields</td>
<td>398</td>
</tr>
<tr>
<td>Idle Time calculation</td>
<td>391</td>
</tr>
<tr>
<td>inbound</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>agent</td>
<td>33</td>
</tr>
<tr>
<td>calling list</td>
<td>220</td>
</tr>
<tr>
<td>jobs</td>
<td>210</td>
</tr>
<tr>
<td>screen(s)</td>
<td>220</td>
</tr>
<tr>
<td>settings</td>
<td>328</td>
</tr>
<tr>
<td>settings dialog box</td>
<td>347</td>
</tr>
<tr>
<td>wait queue limit</td>
<td>231</td>
</tr>
<tr>
<td>Inbound call handling times</td>
<td>418</td>
</tr>
<tr>
<td>Inbound call statistics</td>
<td>421</td>
</tr>
<tr>
<td>inbound processing settings</td>
<td>222</td>
</tr>
<tr>
<td>Inbound queue statistics</td>
<td>422</td>
</tr>
<tr>
<td>inbound wait queue</td>
<td>169</td>
</tr>
<tr>
<td>infinite job</td>
<td>211</td>
</tr>
<tr>
<td>record selection</td>
<td>198</td>
</tr>
<tr>
<td>initial</td>
<td>183</td>
</tr>
<tr>
<td>hit rate</td>
<td>218</td>
</tr>
<tr>
<td>phone</td>
<td>180, 187, 188</td>
</tr>
<tr>
<td>insert record selection row</td>
<td>205</td>
</tr>
<tr>
<td>integer pattern matching</td>
<td>277</td>
</tr>
<tr>
<td>Intelligent Call Blending login</td>
<td>34</td>
</tr>
<tr>
<td>Interactive Voice Response</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>See IVR</td>
<td>231</td>
</tr>
<tr>
<td>Interactive Voice Response job settings</td>
<td>221</td>
</tr>
<tr>
<td>IVR settings</td>
<td>231</td>
</tr>
</tbody>
</table>

### J

| job                      |     |
|                         |     |
| adjust while running,   | 223 |
| agent keys definition file name | 323 |
| Allow agents to cancel call | 221 |
| alternative phone lowest priority | 226 |
| basic settings          | 215 |
| blend                   | 210 |
| call pacing settings    | 217 |
| Calling party number (ANI) | 216 |
| Cell Phone Campaign Call Progress | 219 |
| change inbound settings in Monitor | 328 |
| completion code detail view | 466 |
| Connect Tolerance       | 231 |
| controls                | 323 |
| copy                    | 238 |
| create                  | 232 |
| defined                 | 209 |
| delete                  | 239 |
| Desired Service Level   | 231 |
| Do Not Call             | 221 |
| Earliest start time     | 216 |
| edit                    | 238 |
| Editor Job Wizard       | 232 |
| end                     | 225 |
| Escape recall in infinite job files | 230 |
| hierarchy               | 290 |
| inbound                 | 210 |
| inbound calling list    | 220 |
| Inbound processing settings | 222 |
| inbound screen(s)       | 220 |
| inbound wait queue limit | 231 |
| Infinite                | 211 |
| initial hit rate        | 218 |
| initial hit rate settings | 218 |
| IVR settings            | 231 |
| Job description         | 215 |
| Latest stop time        | 216 |
| Line type(s) for use on job | 216 |
| link a job              | 324 |
| link to job             | 221 |
| list                    | 240 |
| main data processing label |     |
| managed                 | 224 |
| Managed Dialing         | 211, 224 |
| messages                | 161 |
| minimum hit rate        | 219 |
| modify record selection in Monitor | 328 |
| Name of the job to get agent for recall | 230 |
| number of recall attempt | 230 |
| on Intelligent Call Blending system | 210 |
| Options dialog box      | 240 |
| order calls by time zone | 226 |
| outbound                | 210 |
| outbound calling list   | 220 |
| outbound processing settings | 225 |
| outbound screen(s)      | 220 |
| overview                | 209 |
| post processing settings | 228 |
| quota for completion code | 229 |
| quota settings          | 229 |
| recall notification time | 229 |
| recall schedule interval | 229 |
| recall settings         | 229, 230 |
| record selection file name | 220 |
| rename Monitor view set | 301 |
| Require unit ID for agent login | 216 |
| resources view          | 453, 455, 456, 458, 459, 463, 465, 467 |
| Sales Verification      | 211 |
| save                    | 233 |
| save as                 | 233 |
| save as Monitor view set | 300 |
save current Monitor views .......................................................... 300
save on different dialer ............................................................... 233
Screens dialog box ................................................................. 241
Script label for answer ............................................................. 223
script label for answer .............................................................. 223
script label for call ................................................................. 223
scripts ....................................................................................... 161
service level settings ............................................................... 230
settings ...................................................................................... 214
standard Monitor views ........................................................... 298
start on multiple dialers .......................................................... 234
start on selected dialer ............................................................. 234
stop a job .................................................................................. 324
stop gracefully ........................................................................... 324
stop immediately ....................................................................... 324
stop in Monitor ........................................................................... 324
stop when meets quota ............................................................. 210
total wait delay ......................................................................... 231
Transaction completion code .................................................. 217
Transaction verification job ...................................................... 221
transfer on hold message number ........................................... 231
transfer to inbound job ............................................................ 221
transfer to inbound job name .................................................... 221
transfer wait queue .................................................................... 224
transfer wait queue label .......................................................... 224
types ......................................................................................... 33, 209
unit work list ............................................................................ 211, 331
verify .......................................................................................... 239
view settings ............................................................................. 233
Virtual Agent .............................................................................. 211, 222
wait queue settings ................................................................. 231
Job Active Time calculation ..................................................... 392
Job Agents Status ................................................................. 455
Job Call Handling view ............................................................ 458
Job Completion Codes view .................................................... 459
Job Detail view .......................................................................... 456
Job hierarchy, find agents in a job ........................................... 335
Job History view ......................................................................... 465
Job Link ...................................................................................... 324
job link dialog box ..................................................................... 345
Job Monthly reports .............................................................. 385
available reports ..................................................................... 385
report variations ..................................................................... 388
job performance See Completion Code Detail by Agent view ........ 466
Job Quality view ......................................................................... 467
Job reports ................................................................................ 375
available reports ..................................................................... 375
report variations ..................................................................... 378
Job Status view ........................................................................... 323, 453
Job view .................................................................................... 446
Job Wait Queue view ............................................................... 323, 463
L
label main data processing ....................................................... 223
script label for answer .............................................................. 223
script label for call ................................................................. 223
transfer wait queue ................................................................. 224
label settings ............................................................................ 223
Latest stop time ......................................................................... 216
Level 1 Scope Selector ............................................................. 304
Level 2 Scope Selector ............................................................. 304
Level 3 Scope Selector ............................................................. 304
License Configurator ................................................................. 90
licensing .................................................................................... 28
Line type(s) for use on job lines ................................................ 216
dialog box ................................................................................. 351
reassign .................................................................................. 330
link to job .................................................................................. 221, 324
list all record selections ......................................................... 204
jobs ......................................................................................... 240
list separator .............................................................................. 279
log in to role editor .................................................................... 44
logging in .................................................................................. 69
logging off, agent state ........................................................... 275
Logic field .................................................................................. 198
login agent ................................................................................ 33
agent blending .......................................................................... 34
Intelligent Call Blending ............................................................ 34
Supervisor ................................................................................ 35
logs, alert .................................................................................. 317
looping ..................................................................................... 169
M
main data processing label ....................................................... 223
maintaining Health Manager ..................................................... 89
Make alternative phone lowest priority ................................... 226
manage agents .......................................................................... 335
custom views .......................................................................... 301
managed agent ........................................................................ 33
Managed dialing ..................................................................... 211, 224
Allow agents to cancel call ...................................................... 224
Allow dialing from deleted record .......................................... 225
dialog box ................................................................................. 347
display empty record at preview .............................................. 225
Method for record search type at preview .............................. 225
preview ..................................................................................... 224
Time limit (sec.) for preview .................................................... 224
Managed Dialing reports ......................................................... 369
Managed dialing statistics ....................................................... 424
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Merging Roles</td>
<td>46</td>
</tr>
<tr>
<td>Role Merge</td>
<td></td>
</tr>
<tr>
<td>Meridian</td>
<td>482</td>
</tr>
<tr>
<td>messages</td>
<td></td>
</tr>
<tr>
<td>assignments</td>
<td>169</td>
</tr>
<tr>
<td>create</td>
<td>164</td>
</tr>
<tr>
<td>create a script</td>
<td>171</td>
</tr>
<tr>
<td>defined</td>
<td>161</td>
</tr>
<tr>
<td>in automated scripts</td>
<td>169</td>
</tr>
<tr>
<td>in inbound wait queue scripts</td>
<td>169</td>
</tr>
<tr>
<td>in outbound wait queue scripts</td>
<td>169</td>
</tr>
<tr>
<td>in transfer wait queue scripts</td>
<td>169</td>
</tr>
<tr>
<td>in virtual wait queue scripts</td>
<td>169</td>
</tr>
<tr>
<td>maximum</td>
<td>162</td>
</tr>
<tr>
<td>on Avaya Proactive Contact PG230</td>
<td>163</td>
</tr>
<tr>
<td>remove</td>
<td>167</td>
</tr>
<tr>
<td>remove folder</td>
<td>168</td>
</tr>
<tr>
<td>rename folder</td>
<td>167</td>
</tr>
<tr>
<td>send to an agent</td>
<td>337</td>
</tr>
<tr>
<td>start</td>
<td>164</td>
</tr>
<tr>
<td>tasks</td>
<td>163</td>
</tr>
<tr>
<td>verify</td>
<td>166</td>
</tr>
<tr>
<td>wizard</td>
<td>161, 163</td>
</tr>
<tr>
<td>Modify record selection</td>
<td>328</td>
</tr>
<tr>
<td>Message and Scripts</td>
<td></td>
</tr>
<tr>
<td>Editor</td>
<td>161</td>
</tr>
<tr>
<td>start</td>
<td>164</td>
</tr>
<tr>
<td>Messages wizard</td>
<td>165</td>
</tr>
<tr>
<td>Method for record search type at preview</td>
<td>226</td>
</tr>
<tr>
<td>Mid-Tier Configurator</td>
<td>89</td>
</tr>
<tr>
<td>minimum hit rate</td>
<td>219</td>
</tr>
<tr>
<td>change in Monitor</td>
<td>326</td>
</tr>
<tr>
<td>dialog box</td>
<td>346</td>
</tr>
<tr>
<td>on Avaya Proactive Contact PG230</td>
<td>163</td>
</tr>
<tr>
<td>remove</td>
<td>167</td>
</tr>
<tr>
<td>remove folder</td>
<td>168</td>
</tr>
<tr>
<td>rename folder</td>
<td>167</td>
</tr>
<tr>
<td>send to an agent</td>
<td>337</td>
</tr>
<tr>
<td>start</td>
<td>164</td>
</tr>
<tr>
<td>tasks</td>
<td>163</td>
</tr>
<tr>
<td>verify</td>
<td>166</td>
</tr>
<tr>
<td>wizard</td>
<td>161, 163</td>
</tr>
<tr>
<td>Messages and Scripts</td>
<td></td>
</tr>
<tr>
<td>Editor</td>
<td>161</td>
</tr>
<tr>
<td>start</td>
<td>164</td>
</tr>
<tr>
<td>Messages wizard</td>
<td>165</td>
</tr>
<tr>
<td>Method for record search type at preview</td>
<td>226</td>
</tr>
<tr>
<td>Mid-Tier Configurator</td>
<td>89</td>
</tr>
<tr>
<td>minimum hit rate</td>
<td>219</td>
</tr>
<tr>
<td>change in Monitor</td>
<td>326</td>
</tr>
<tr>
<td>dialog box</td>
<td>346</td>
</tr>
<tr>
<td>on Avaya Proactive Contact PG230</td>
<td>163</td>
</tr>
<tr>
<td>remove</td>
<td>167</td>
</tr>
<tr>
<td>remove folder</td>
<td>168</td>
</tr>
<tr>
<td>rename folder</td>
<td>167</td>
</tr>
<tr>
<td>send to an agent</td>
<td>337</td>
</tr>
<tr>
<td>start</td>
<td>164</td>
</tr>
<tr>
<td>tasks</td>
<td>163</td>
</tr>
<tr>
<td>verify</td>
<td>166</td>
</tr>
<tr>
<td>wizard</td>
<td>161, 163</td>
</tr>
<tr>
<td>Monitor</td>
<td>273, 274, 336</td>
</tr>
<tr>
<td>adjust job while running</td>
<td>323</td>
</tr>
<tr>
<td>agent completion codes</td>
<td>473</td>
</tr>
<tr>
<td>agent control dialog box</td>
<td>353, 354</td>
</tr>
<tr>
<td>agent detail view</td>
<td>472</td>
</tr>
<tr>
<td>Agent dialog box</td>
<td>354</td>
</tr>
<tr>
<td>agent history view</td>
<td>474</td>
</tr>
<tr>
<td>agent line</td>
<td>338</td>
</tr>
<tr>
<td>agent states</td>
<td>274</td>
</tr>
<tr>
<td>Agent States tab, Options dialog box</td>
<td>342</td>
</tr>
<tr>
<td>Alternate Initial Phone dialog box</td>
<td>350</td>
</tr>
<tr>
<td>Appearance tab, Options dialog box</td>
<td>342</td>
</tr>
<tr>
<td>change default settings</td>
<td>271</td>
</tr>
<tr>
<td>change Expert Calling Ratio</td>
<td>327</td>
</tr>
<tr>
<td>change managed jobs settings</td>
<td>330</td>
</tr>
<tr>
<td>change minimum hit rate</td>
<td>326</td>
</tr>
<tr>
<td>Completion Code Detail by Agent view</td>
<td>466</td>
</tr>
<tr>
<td>create Custom button group</td>
<td>302</td>
</tr>
<tr>
<td>customize a view</td>
<td>299</td>
</tr>
<tr>
<td>Customize Status Bar dialog box</td>
<td>343</td>
</tr>
<tr>
<td>customize views</td>
<td>297</td>
</tr>
<tr>
<td>delete view set</td>
<td>301</td>
</tr>
<tr>
<td>Detection Mode dialog box</td>
<td>350</td>
</tr>
<tr>
<td>Dialer History view</td>
<td>452</td>
</tr>
<tr>
<td>Dialer Lines view</td>
<td>451</td>
</tr>
<tr>
<td>Dialer Status view</td>
<td>449</td>
</tr>
<tr>
<td>dialer views</td>
<td>274</td>
</tr>
<tr>
<td>dialog boxes</td>
<td>341</td>
</tr>
<tr>
<td>display a view for an agent</td>
<td>299</td>
</tr>
<tr>
<td>display an agent view</td>
<td>339</td>
</tr>
<tr>
<td>Escape recall job dialog box</td>
<td>345</td>
</tr>
<tr>
<td>Expert Calling Ratio</td>
<td>346</td>
</tr>
<tr>
<td>Feedback tab, Options dialog box</td>
<td>343</td>
</tr>
<tr>
<td>Filter Data dialog box</td>
<td>344</td>
</tr>
<tr>
<td>filter view data</td>
<td>305</td>
</tr>
<tr>
<td>Find Agent dialog box</td>
<td>353</td>
</tr>
<tr>
<td>find agents</td>
<td>335</td>
</tr>
<tr>
<td>find an agent view</td>
<td>471</td>
</tr>
<tr>
<td>Find dialog box</td>
<td>343</td>
</tr>
<tr>
<td>find text string</td>
<td>334</td>
</tr>
<tr>
<td>hide or show columns</td>
<td>308</td>
</tr>
<tr>
<td>inbound settings</td>
<td>328</td>
</tr>
<tr>
<td>Inbound Settings dialog box</td>
<td>347</td>
</tr>
<tr>
<td>Job agents view</td>
<td>455</td>
</tr>
<tr>
<td>Job call handling view</td>
<td>458</td>
</tr>
<tr>
<td>Job completion code view</td>
<td>459</td>
</tr>
<tr>
<td>job control dialog box</td>
<td>345, 346, 347, 348, 349, 350, 351, 352</td>
</tr>
<tr>
<td>Job detail view</td>
<td>456</td>
</tr>
<tr>
<td>Job history view</td>
<td>465</td>
</tr>
<tr>
<td>Job link dialog box</td>
<td>345</td>
</tr>
<tr>
<td>job performance</td>
<td>466</td>
</tr>
<tr>
<td>Job quality view</td>
<td>467</td>
</tr>
<tr>
<td>Job status view</td>
<td>453</td>
</tr>
<tr>
<td>Job wait queue view</td>
<td>463</td>
</tr>
<tr>
<td>large or small icons</td>
<td>298</td>
</tr>
<tr>
<td>Lines dialog box</td>
<td>351</td>
</tr>
<tr>
<td>link to a job</td>
<td>324</td>
</tr>
<tr>
<td>manage agents</td>
<td>335</td>
</tr>
<tr>
<td>manage custom views</td>
<td>301</td>
</tr>
<tr>
<td>Managed Dialing dialog box</td>
<td>347</td>
</tr>
<tr>
<td>Minimum Hit Rate dialog box</td>
<td>346</td>
</tr>
<tr>
<td>Monitor Agent dialog box</td>
<td>354</td>
</tr>
<tr>
<td>Multi-Dialer tab, Options dialog box</td>
<td>342</td>
</tr>
<tr>
<td>navigate</td>
<td>297</td>
</tr>
<tr>
<td>open a view</td>
<td>298, 300</td>
</tr>
<tr>
<td>Options dialog box</td>
<td>341</td>
</tr>
<tr>
<td>overview</td>
<td>271</td>
</tr>
<tr>
<td>Quota dialog box</td>
<td>349</td>
</tr>
<tr>
<td>real-time</td>
<td>328</td>
</tr>
<tr>
<td>reassign lines</td>
<td>330</td>
</tr>
<tr>
<td>Record selection of link job dialog box</td>
<td>346</td>
</tr>
<tr>
<td>refresh a view</td>
<td>302</td>
</tr>
<tr>
<td>remove agent from a job</td>
<td>338</td>
</tr>
</tbody>
</table>
Index

Retry dialog box ............................................. 351
save a view as a HTML file .............................. 309
save changes to views ..................................... 275
save current view .......................................... 300
save view as HTML ......................................... 301
Scope tab, Options dialog box .......................... 341
select the hierarchy ...................................... 307
Selection records dialog box ............................. 352
Selection results dialog box ............................. 352
Selection sort dialog box ................................ 352
Send Message dialog box ................................ 354
set a default view ......................................... 309
set alerts .................................................... 276
set alternate initial phone ............................... 333
set Detection Mode ....................................... 333
set or change a quota ..................................... 332
set retries .................................................. 334
set the default hierarchy ............................... 305
set the scope .............................................. 306
set up a unit work list ................................... 331
sort calls by time zone .................................... 330
standard views .............................................. 298
start alert monitoring automatically ................ 276
Stop Job .................................................... 324
Stop Job dialog box ....................................... 345
Stop job immediately ..................................... 324
Supervisor Agents view .................................. 469
Table View or Graphical View ......................... 309
time range .................................................. 307
Time Zones dialog box ................................... 348
toolbar, Filter Data ....................................... 304
toolbar, Find .............................................. 304
toolbar, Graphical view .................................. 303
toolbar, Hide/Show Columns ............................ 304
toolbar, Hierarchy Manager ............................. 304
toolbar, Level 1 Scope Selector ....................... 304
toolbar, Level 2 Scope Selector ....................... 304
toolbar, Level 3 Scope Selector ....................... 304
toolbar, Performance Code ............................. 304
toolbar, Refresh view ...................................... 304
toolbar, Table View ....................................... 303
toolbar, Time Scope ...................................... 304
Transfer Agent dialog box ............................... 354
Unit Work Lists dialog box .............................. 349
use of wildcard characters ............................. 336
use Tools applications ................................... 297
user interface .............................................. 272
view control dialog box ................................ 341, 342, 343, 344
view defined ............................................... 303
view set ..................................................... 275, 300
view time range .......................................... 307
view toolbar ............................................... 303
view, defined .............................................. 272
views ........................................................ 272, 445, 446
monitor an agent line .................................... 338
Monthly roll-up dictionaries ............................ 397
move
Agent Blending domain .................................. 491
record selection row ..................................... 206
multi-dialer
commands .................................................. 109
Completion Code Manager ............................. 152
control ...................................................... 274

N
name of next job ........................................... 221
Name of the job to get agent for recall .............. 230
navigate in Monitor ....................................... 297
Northern Telecom Meridian ............................ 482
not available agent state .............................. 275
Notifications tab .......................................... 84
number of recall attempts ............................. 230
numerical comparison .................................... 280

O
OB_ONLY domain group .................................. 479
off job agent state ....................................... 275
offline agent state ....................................... 275
Online Time calculation .................................. 392
open hierarchy ............................................. 293
Operations in role editor ............................... 38
Options ..................................................... 82
Agent States .............................................. 342
dialog box .................................................. 240, 341
outbound
Agent Blending ............................................ 485
calling list .................................................. 220
Outbound Only ............................................. 485
processing settings ...................................... 225
screen(s) .................................................... 220
wait queue .................................................. 169
Outbound call handling time ............................ 425
Outbound call statistics .................................. 428
outbound job ............................................... 210
Infinite ...................................................... 211
Managed Dialing ......................................... 211
Sales Verification .......................................... 211
script label for call ....................................... 223
special types .............................................. 211
Unit Work List ............................................ 211
Virtual Agent ............................................. 211, 222
Outbound queue statistics .............................. 430
Outbound, Inbound, and Combined fields .......... 399
Overall Health Services Dialer Status view .......... 69, 71
overview
reports ...................................................... 367
Index

P

<table>
<thead>
<tr>
<th>Pattern Matching</th>
<th>Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td>date comparison</td>
<td>281</td>
</tr>
<tr>
<td>explicitly designate syntax</td>
<td>278</td>
</tr>
<tr>
<td>extended regular expression</td>
<td>277, 284</td>
</tr>
<tr>
<td>field type syntax</td>
<td>278</td>
</tr>
<tr>
<td>floating point</td>
<td>280</td>
</tr>
<tr>
<td>list separator</td>
<td>279</td>
</tr>
<tr>
<td>numerical comparison</td>
<td>280</td>
</tr>
<tr>
<td>phone strategy</td>
<td>277</td>
</tr>
<tr>
<td>record selection</td>
<td>277</td>
</tr>
<tr>
<td>shell-style</td>
<td>277, 282</td>
</tr>
<tr>
<td>string</td>
<td>277</td>
</tr>
<tr>
<td>string comparisons</td>
<td>282</td>
</tr>
<tr>
<td>syntaxes</td>
<td>277, 279</td>
</tr>
<tr>
<td>time comparisons</td>
<td>281</td>
</tr>
<tr>
<td>pause</td>
<td>169</td>
</tr>
</tbody>
</table>

PC Analysis

| FTP Client dialog box                                                      | 516   |
| Telnet tool                                                                 | 495   |
| telnet, defined                                                             | 495   |
| telnet, start                                                                | 497   |
| telnet, transfer PC Analysis extract output file                            | 515   |
| transfer extract file                                                        | 515   |
| performance code                                                             | 304   |
| person-to-person agent                                                       | 33    |

Phone Strategy

| alternate initial phone                                                      | 181   |
| append a row                                                                 | 187   |
| call detection mode                                                          | 181   |
| clear all rows                                                               | 188   |
| copy                                                                          | 185   |
| create                                                                        | 183   |
| delete                                                                        | 186   |
| delete an alternate initial phone                                            | 188   |
| delete an initial phone                                                       | 188   |
| edit                                                                          | 185   |
| Editor                                                                        | 179   |
| initial phone                                                                 | 180   |
| insert an alternate initial phone                                            | 187   |
| insert an initial phone                                                       | 187   |
| list all on the dialer                                                        | 187   |
| overview                                                                      | 179   |
| pattern matching                                                              | 277   |
| retries                                                                       | 182   |
| select all rows                                                               | 188   |
| view settings                                                                 | 185   |
| phone, tab                                                                    | 183   |

PINNACLE

| Agent Blending                                                              | 482   |
| play message                                                                | 169   |
| pod, definition                                                              | 26    |
| post processing job settings                                                 | 228   |
| predefined roles                                                            | 39    |
| Predictive Agent Blend                                                       | 478   |
| Service Level                                                                | 478   |
| Preview a report                                                             | 361   |
| primary dialer                                                               | 90    |
| Primary Machine Name                                                         | 89    |
| Print a report                                                               | 361   |
| print Analyst report                                                         | 361   |
| Proactive Agent Blend                                                        | 479   |
| Proactive Contact with Avaya Communication Manager                         | 163   |
| PTP call handling times                                                      | 432   |
| PTP call statistics                                                          | 434   |

Q

| quota                                                                         | 229   |
| defined                                                                      | 210   |
| dialog box                                                                   | 349   |
| job settings                                                                  | 229   |
| set or change in Monitor                                                     | 332   |
| stop an outbound job                                                         | 210   |

R

<p>| reassign                                                                     | 330   |
| reassign lines                                                               | 330   |
| recall                                                                        | 229   |
| recall notification time                                                     | 229   |
| in minutes                                                                    | 229   |
| Recall reschedule interval (min.).                                           | 229   |
| recalls                                                                      | 199   |
| completion code category                                                     | 152   |
| tab                                                                          | 199   |
| record selection                                                             | 191, 220 |
| append row                                                                   | 205   |
| clear rows                                                                   | 207   |
| copy                                                                          | 203   |
| create                                                                        | 200   |
| delete                                                                        | 201   |
| delete row                                                                   | 205   |
| Detail tab                                                                   | 197   |
| edit                                                                          | 201   |
| field, Group                                                                 | 198, 199 |
| insert row                                                                    | 205   |
| list                                                                          | 204   |
| list all on dialer                                                           | 204   |
| Logic field                                                                   | 198   |
| move row                                                                     | 206   |
| open                                                                          | 197   |
| pattern matching                                                             | 277   |
| Recalls tab                                                                  | 195   |
| Records tab                                                                  | 198   |
| Results tab                                                                  | 198   |
| run                                                                           | 202   |</p>
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>select rows</td>
<td>207</td>
</tr>
<tr>
<td>specify completion codes</td>
<td>192</td>
</tr>
<tr>
<td>specify goals</td>
<td>192</td>
</tr>
<tr>
<td>specify time zones</td>
<td>192</td>
</tr>
<tr>
<td>Time Zones tab</td>
<td>198</td>
</tr>
<tr>
<td>Value field</td>
<td>198</td>
</tr>
<tr>
<td>verify</td>
<td>202</td>
</tr>
<tr>
<td>view reports</td>
<td>204</td>
</tr>
<tr>
<td>view selections</td>
<td>204</td>
</tr>
<tr>
<td>record selection of link job</td>
<td>346</td>
</tr>
<tr>
<td>Record Selections report, HTML file</td>
<td>202</td>
</tr>
<tr>
<td>Records tab in Selections</td>
<td>198</td>
</tr>
<tr>
<td>refresh</td>
<td>110</td>
</tr>
<tr>
<td>view</td>
<td>302, 304</td>
</tr>
<tr>
<td>View toolbar</td>
<td>448</td>
</tr>
<tr>
<td>refresh data</td>
<td>50, 70</td>
</tr>
<tr>
<td>remove</td>
<td>339</td>
</tr>
<tr>
<td>agent</td>
<td>339</td>
</tr>
<tr>
<td>alerts</td>
<td>317</td>
</tr>
<tr>
<td>completion code from a category</td>
<td>155</td>
</tr>
<tr>
<td>rename</td>
<td>296</td>
</tr>
<tr>
<td>hierarchy</td>
<td>296</td>
</tr>
<tr>
<td>hierarchy level</td>
<td>295</td>
</tr>
<tr>
<td>rename a role</td>
<td>45</td>
</tr>
<tr>
<td>Report</td>
<td></td>
</tr>
<tr>
<td>Analyst report</td>
<td>362</td>
</tr>
<tr>
<td>report calculations</td>
<td>390</td>
</tr>
<tr>
<td>Report categories</td>
<td>367</td>
</tr>
<tr>
<td>report overview</td>
<td></td>
</tr>
<tr>
<td>Completion Code Summary</td>
<td>370</td>
</tr>
<tr>
<td>Managed Dialing</td>
<td>369</td>
</tr>
<tr>
<td>report variations</td>
<td></td>
</tr>
<tr>
<td>Administrative</td>
<td>383</td>
</tr>
<tr>
<td>Agent Monthly</td>
<td>385</td>
</tr>
<tr>
<td>Agent reports</td>
<td>374</td>
</tr>
<tr>
<td>Job</td>
<td>378</td>
</tr>
<tr>
<td>Job Monthly</td>
<td>388</td>
</tr>
<tr>
<td>Time of Day</td>
<td>382</td>
</tr>
<tr>
<td>Time of Day Monthly</td>
<td>390</td>
</tr>
<tr>
<td>reports</td>
<td>50, 355</td>
</tr>
<tr>
<td>Administrative</td>
<td>383</td>
</tr>
<tr>
<td>Agent</td>
<td>372</td>
</tr>
<tr>
<td>Agent Monthly</td>
<td>384</td>
</tr>
<tr>
<td>Completion Code Summary</td>
<td>370</td>
</tr>
<tr>
<td>Job</td>
<td>375</td>
</tr>
<tr>
<td>Job Monthly</td>
<td>385</td>
</tr>
<tr>
<td>Managed Dialing</td>
<td>369</td>
</tr>
<tr>
<td>Time of Day</td>
<td>379</td>
</tr>
<tr>
<td>Time of Day Monthly</td>
<td>388</td>
</tr>
<tr>
<td>Reports per category</td>
<td>370</td>
</tr>
<tr>
<td>Require unit ID for agent login</td>
<td>216</td>
</tr>
<tr>
<td>reset blend engine</td>
<td>492</td>
</tr>
<tr>
<td>resize columns</td>
<td>272</td>
</tr>
<tr>
<td>Results tab</td>
<td>198</td>
</tr>
<tr>
<td>resynch blend engine</td>
<td>492</td>
</tr>
<tr>
<td>retries</td>
<td>182</td>
</tr>
<tr>
<td>set in Monitor</td>
<td>334</td>
</tr>
<tr>
<td>tab</td>
<td>184</td>
</tr>
<tr>
<td>retry</td>
<td>351</td>
</tr>
<tr>
<td>Right Party Contacts, completion code category</td>
<td>151</td>
</tr>
<tr>
<td>Rockwell Spectrum</td>
<td>481</td>
</tr>
<tr>
<td>Agent Blending</td>
<td>481</td>
</tr>
<tr>
<td>ROLM, see Siemens ROLM</td>
<td>483</td>
</tr>
<tr>
<td>S</td>
<td></td>
</tr>
<tr>
<td>Sales Verification</td>
<td>211</td>
</tr>
<tr>
<td>save</td>
<td>110</td>
</tr>
<tr>
<td>changes to views</td>
<td>275</td>
</tr>
<tr>
<td>completion code HTML file</td>
<td>156</td>
</tr>
<tr>
<td>job settings</td>
<td>233</td>
</tr>
<tr>
<td>Monitor view as HTML</td>
<td>301</td>
</tr>
<tr>
<td>view as a HTML file in Monitor</td>
<td>309</td>
</tr>
<tr>
<td>save data as HTML</td>
<td>84</td>
</tr>
<tr>
<td>Scenarios in Role Editor</td>
<td>53</td>
</tr>
<tr>
<td>Schedule a report</td>
<td>363</td>
</tr>
<tr>
<td>schedule Analyst report</td>
<td>356, 363</td>
</tr>
<tr>
<td>schedules, download and load</td>
<td>27</td>
</tr>
<tr>
<td>Scope</td>
<td></td>
</tr>
<tr>
<td>Scope</td>
<td></td>
</tr>
<tr>
<td>Scope tab</td>
<td>84</td>
</tr>
<tr>
<td>Screens dialog box</td>
<td>241</td>
</tr>
<tr>
<td>script</td>
<td></td>
</tr>
<tr>
<td>actions</td>
<td>169</td>
</tr>
<tr>
<td>automated messages</td>
<td>169</td>
</tr>
<tr>
<td>change</td>
<td>175</td>
</tr>
<tr>
<td>create</td>
<td>171</td>
</tr>
<tr>
<td>create message script</td>
<td>172</td>
</tr>
<tr>
<td>defined</td>
<td>161, 168</td>
</tr>
<tr>
<td>Delete dialog box</td>
<td>176</td>
</tr>
<tr>
<td>examples</td>
<td>170</td>
</tr>
<tr>
<td>hear in wait queue</td>
<td>161</td>
</tr>
<tr>
<td>inbound wait queues</td>
<td>169</td>
</tr>
<tr>
<td>label for answer</td>
<td>223</td>
</tr>
<tr>
<td>label for call</td>
<td>223</td>
</tr>
<tr>
<td>loop message</td>
<td>169</td>
</tr>
<tr>
<td>maximum</td>
<td>162</td>
</tr>
<tr>
<td>outbound wait queues</td>
<td>169</td>
</tr>
<tr>
<td>pane</td>
<td>171</td>
</tr>
<tr>
<td>pause message</td>
<td>169</td>
</tr>
<tr>
<td>plane message</td>
<td>169</td>
</tr>
<tr>
<td>Standard Monitor views</td>
<td>298</td>
</tr>
<tr>
<td>Supervisor Agents view</td>
<td>469</td>
</tr>
<tr>
<td>Supervisor hierarchy</td>
<td>469</td>
</tr>
<tr>
<td>find agents reporting to a supervisor</td>
<td>335</td>
</tr>
<tr>
<td>Supervisor resources view</td>
<td>469</td>
</tr>
<tr>
<td>Supervisor view, defined</td>
<td>446</td>
</tr>
<tr>
<td>supported features</td>
<td>158</td>
</tr>
<tr>
<td>supported syntaxes</td>
<td>279</td>
</tr>
<tr>
<td>syntax</td>
<td>279</td>
</tr>
<tr>
<td>explicit pattern matching</td>
<td>278</td>
</tr>
<tr>
<td>field type pattern matching</td>
<td>278</td>
</tr>
<tr>
<td>list separator</td>
<td>279</td>
</tr>
<tr>
<td>supported</td>
<td>279</td>
</tr>
<tr>
<td>System Parameter Settings</td>
<td>92</td>
</tr>
<tr>
<td>System Telnet</td>
<td>517, 518</td>
</tr>
<tr>
<td>defined</td>
<td>517</td>
</tr>
<tr>
<td>features</td>
<td>518</td>
</tr>
<tr>
<td>start</td>
<td>518</td>
</tr>
<tr>
<td>System Telnet tool</td>
<td>517</td>
</tr>
</tbody>
</table>

### T

| Table View | 303 |
| toolbar | 447 |
| Table view | 447 |
| View toolbar | 447 |
| Table View in Monitor | 309 |
| talk, agent state | 275 |
| telephony.spl | 162 |
| telephone lines | 330 |
| PC Analysis | 497 |
| System | 518 |
| thresholds | 92 |
| time | 281 |
| comparisons, pattern matching | 277 |
| pattern matching | 277 |
| Time limit (sec.) for preview | 224 |
| Time of Day Monthly reports | 388 |
| available reports | 388 |
| report variations | 390 |
| Time of Day reports | 379 |
| available reports | 379 |
| report variations | 382 |
| time range | 274 |
| set in Monitor | 307 |
| view | 307 |
| Time Scope | 304 |
| Time selector, View toolbar | 447 |
| Time to connect tolerance | 231 |
| time zones | 226, 330 |
| dialog box | 348 |
| record selection | 192 |
| select to sort calls | 330 |
| tab | 198 |
| toolbar button in a view | 303 |
| toolbar buttons | 447 |
| Tools | 44 |
| Agent Blending | 477 |
| Completion Code Manager | 149 |
| Hierarchy Manager | 289 |
| menu | 366 |
| PC Analysis Telnet | 495 |
| System Telnet | 517 |
| Total wait delay | 231 |
| Transaction | 231 |
| completion code | 217 |
| verification job | 221 |
| view in Agent Blending | 493 |
| Transfer Agent, dialog box | 354 |
| transfer an agent | 337 |
| Transfer on hold message number | 231 |
| Transfer to inbound job name | 221 |
| transfer wait queue | 169 |
| label for job | 224 |
| Transfer wait queue label | 224 |
| types of application permissions | 41 |
| types of permissions | 41 |
| permission types | 38 |

### U

| Understanding Analyst | 355 |
| Unit Work List | 211 |
| dialog box | 349 |
| set up | 331 |
| update | 318 |
| dialer with ACD queue assignments | 492 |
| record for the agent state | 275 |
| upload | 27 |
| Uptime | 71 |
| using agent keys | 157 |
| Using Analyst | 356 |
| using calling lists | 28 |
| Using or copying an Avaya Proactive Contact Analyst built-in report | 399 |
| using schedule | 243 |

### V

| verification job, record selection | 198 |
| verify | 198 |
| job | 239 |
| multiple jobs | 239 |
| record selection | 202 |
| view | 272 |
| ACD statistics | 493 |
| alert log | 317 |
### Index

- **Analyst report** .......................................................... 361  
- **categories** .............................................................. 445  
- **custom** ................................................................. 299, 445  
- **defined** ................................................................. 303  
- **definition of** ........................................................... 272, 445  
- **in Monitor** ............................................................... 272  
- **job settings** ............................................................. 233  
- **open in Monitor** ......................................................... 298  
- **overview** ................................................................. 445  
- **save as a HTML file** .................................................. 309  
- **save in Monitor** ......................................................... 300  
- **set** .......................................................................... 275  
- **standard views** ......................................................... 298  
- **toolbar** ................................................................. 303, 447  
- **toolbar icons** ........................................................... 447  
- **using** ................................................................. 305  
- **view dialer core services health** ............................. 72  
- **view dialer data services health** .............................. 74  
- **view dialer health related services health** ............... 75, 78  
- **view dialer telephony services health** ..................... 73  
- **view Mid-Tier command control and administration service health** ................................. 77  
- **view Mid-Tier data services health** ......................... 76  
- **View Mid-Tier framework services health** .................. 76  
- **view Mid-Tier health related service health** .............. 77  
- **view overall system health** ........................................ 71  
- **View Set** ................................................................. 445  
- **rename Monitor view set** ........................................... 301  
- **save as Monitor view set** ......................................... 300  
- **save current Monitor views** ...................................... 300  
- **standard Monitor views** ............................................ 298  
- **view system status information on CPU usage** .......... 78  
- **view system status information on disk usage** .......... 79  
- **view system status information on memory usage** ....... 80  
- **view system status information on processes** ............ 81  
- **view the overall CPU usage** ...................................... 78  
- **View toolbar** .......................................................... 447, 448  
- **Virtual Agent** .......................................................... 211, 222  
- **virtual wait queue** ................................................... 169  
- **voice response** ....................................................... 169

### W

- **wait delay in seconds** ............................................. 231  
- **wait queue** ............................................................ 231  
- **scripts** ............................................................... 161  
- **settings** .............................................................. 231  
- **wait queues settings** ............................................. 231  
- **Weighted averages** .................................................. 398  
- **when to use Cruise Control** ..................................... 213  
- **when to use Expert Calling Ratio** ......................... 214  
- **wildcard characters** ............................................... 194  
- **use to find one or more agent** ................................. 336  
- **wizard** .............................................................. 163