Avaya Aura ® Orchestration Designer
Getting Started with Orchestration Designer
Release 6.0
Notice
While reasonable efforts were made to ensure that the information in this
document was complete and accurate at the time of printing, Avaya Inc. can
assume no liability for any errors. Changes and corrections to the information
in this document may be incorporated in future releases.

Documentation disclaimer
Avaya Inc. is not responsible for any modifications, additions, or deletions to
the original published version of this documentation unless such modifications,
additions, or deletions were performed by Avaya. Customer and/or End User
agree to indemnify and hold harmless Avaya, Avaya's agents, servants and
employees against all claims, lawsuits, demands and judgments arising out of,
or in connection with, subsequent modifications, additions or deletions to this
documentation to the extent made by the Customer or End User.

Link Disclaimer
Avaya Inc. is not responsible for the contents or reliability of any linked Web
sites referenced elsewhere within this documentation, and Avaya does not
necessarily endorse the products, services, or information described or offered
within them. We cannot guarantee that these links will work all of the time and
we have no control over the availability of the linked pages.

Warranty
Avaya Inc. provides a limited warranty on this product. Refer to your sales
agreement to establish the terms of the limited warranty. In addition, Avaya's
standard warranty language, as well as information regarding support for this
product, while under warranty, is available through the following Web site:
http://support.avaya.com

License
USE OR INSTALLATION OF THE PRODUCT INDICATES THE END USER'S
ACCEPTANCE OF THE TERMS SET FORTH HEREIN AND THE GENERAL
LICENSE TERMS AVAILABLE ON THE AVAYA WEB SITE AT
http://support.avaya.com/LicenseInfo/ ("GENERAL LICENSE TERMS"). IF
YOU DO NOT WISH TO BE BOUND BY THESE TERMS, YOU MUST
RETURN THE PRODUCT(S) TO THE POINT OF PURCHASE WITHIN TEN
(10) DAYS OF DELIVERY FOR A REFUND OR CREDIT.

Avaya grants End User a license within the scope of the license types
described below. The applicable number of licenses and units of capacity for
which the license is granted will be one (1), unless a different number of
licenses or units of capacity is specified in the Documentation or other
materials available to End User. “Designated Processor” means a single
stand-alone computing device. “Server” means a Designated Processor that
hosts a software application to be accessed by multiple users. “Software”
means the computer programs in object code, originally licensed by Avaya and
ultimately utilized by End User, whether as stand-alone Products or
pre-installed on Hardware. “Hardware” means the standard hardware
Products, originally sold by Avaya and ultimately utilized by End User.

License Type(s)
Copyright
Except where expressly stated otherwise, the Product is protected by copyright
and other laws respecting proprietary rights. Unauthorized reproduction,
transfer, and or use can be a criminal, as well as a civil, offense under the
applicable law.

Third-party Components
Certain software programs or portions thereof included in the Product may
contain software distributed under third party agreements ("Third Party
Components"), which may contain terms that expand or limit rights to use
certain portions of the Product ("Third Party Terms"). Information identifying
Third Party Components and the Third Party Terms that apply to them is
available on Avaya's web site at:
http://support.avaya.com/ThirdPartyLicense/

Avaya Fraud Intervention
If you suspect that you are being victimized by toll fraud and you need technical
assistance or support, call Technical Service Center Toll Fraud Intervention
Hotline at +1-800-643-2353 for the United States and Canada. For additional
support telephone numbers, see the Avaya Web site:
http://support.avaya.com

Trademarks
Avaya is a trademark of Avaya Inc.
All non-Avaya trademarks are the property of their respective owners.
## Contents

### About Avaya Aura ® Orchestration Designer documentation
- Audience: v
- Pre-requisites: vi
- Resources: vi
- Documentation availability: viii
- Orchestration Designer documentation location: ix

### Chapter 1: About Orchestration Designer
- Overview: 2
- Features and benefits: 2

### Chapter 2: Installation and configuration
- License requirements: 4
- Hardware requirements: 5
- Software requirements: 5
- Installing Orchestration Designer: 9
- Configuring basic settings: 10
- Creating Eclipse shortcut: 10
- Setting Up the Workspace: 11
- Setting Orchestration Designer Preferences: 11
- Configuring Microsoft Speech SDK for microphone input: 14
- Installing sample applications: 15
- Upgrading Dialog Designer to Orchestration Designer: 15
- Maintaining the 5.1 environment while installing 6.0: 16
- Installing 6.0 without retaining the 5.1 environment: 17
- Installing Orchestration Designer patch updates: 18
- Prerequisites for installing a patch update: 18
- Installing a patch update: 19

### Chapter 3: Getting familiar with the Orchestration Designer user interface
- Accessing the Concepts section of the Eclipse Workbench User Guide: 20
- Orchestration Designer workbench: 21
- Orchestration Designer Speech Perspective: 21
- Speech Navigator view: 23
- Navigator view: 24
- Editor view: 26
- Orchestration Designer editors: 26
- Editor view tabs: 27
About Avaya Aura ® Orchestration Designer documentation

Avaya Aura ® Orchestration Designer is a suite for combination of self-service products and Avaya Contact Center products, namely, Avaya Aura ® Experience Portal (AAEP), Avaya Interactive Response (IR), Media Processing Server (MPS), and Avaya Aura ® Contact Center. As a single tool, you can use Orchestration Designer to design, simulate, and maintain contact routing scripts along with inbound and outbound self-service support. Orchestration Designer accelerates the service design and deployment, reduces the cost, and enhances the customer experience.

Orchestration Designer documentation provides an insight to the Orchestration Designer tool. The documentation contains information about installing and configuring Orchestration Designer. This documentation also contains information about the various features of Orchestration Designer.

This chapter contains the following topics:

- Audience
- Pre-requisites
- Resources
- Documentation availability

Audience

The intended audience of this documentation are users who need to:

- Install and configure Orchestration Designer.
- Use Orchestration Designer to design and create speech applications for:
  - Avaya Interactive Response (IR) 3.0 or later.
  - Avaya Voice Portal 4.0 or later. The Avaya Voice Portal 6.0 is referred to as Avaya Aura ® Experience Portal (AAEP) 6.0.
  - Avaya Media Processing Server (MPS) 3.5 FP2 or later.

These users include, among others:

- Customers who want to create their own speech applications.
Avaya business partners and independent service vendors who create speech applications for Avaya customers.

Pre-requisites

The primary users of Orchestration Designer are likely to be highly knowledgeable and skilled in telecommunications and Internet technologies. Therefore, this documentation does not cover topics related to those areas. The users must be proficient and knowledgeable in the following areas:

- The operating systems on which the users develop and deploy Orchestration Designer applications.
- Computer networking concepts and technologies.
- Telecommunications concepts and technologies, including switches and gateways.
- Basic programming logic and practice.

Note: Although not required to develop applications in Orchestration Designer, knowledge and experience of Java programming is helpful.

Orchestration Designer is built on several existing technologies and tools. Hence, Orchestration Designer users must become familiar with the following technologies:

- Eclipse open-source software
- Java servlet technology
- Servlet engine technologies
- Speech recognition and synthesis technologies
- Database administration
- Web service technologies

For more information about additional resources for these technologies, see Resources.

Resources

Orchestration Designer depends on the use of several closely related software products and technologies. When using Orchestration Designer, review the documentation of these related products and technologies.

Avaya does not reproduce or package the documentation for these related products and technologies. However, to help locate the appropriate documentation, review the following resources:
Resources

Note:
The following URLs were valid at the time of publication of this document. Avaya is not responsible if these URLs have changed. For more updated URLs, perform a search operation online.

- For Eclipse and supporting Eclipse components (GEF and WTP), go to:
  To view the Eclipse online Help in Orchestration Designer, on the Help menu > click Help Contents.
- For the Java SDK (Software Developer’s Kit), go to:
  [http://java.sun.com/j2se/1.5.0/docs/index.html](http://java.sun.com/j2se/1.5.0/docs/index.html)
- For Tomcat: 5.5 or 6.0, go to:
  [http://tomcat.apache.org/tomcat-5.5-doc/index.html](http://tomcat.apache.org/tomcat-5.5-doc/index.html)
- For IBM WebSphere or WebSphere Express, go to:
- For WebLogic, go to:
- For the Microsoft Speech SDK, go to:
- For databases and JDBC implementation, go to:
  [http://www.firstsql.com/tutor.htm](http://www.firstsql.com/tutor.htm)
- For Web services, go to:
  [http://www.w3.org/TR/wsdl](http://www.w3.org/TR/wsdl)
- For the W3C VoiceXML 2.0 Recommendation, go to:
  [http://www.w3.org/TR/voicexml20/](http://www.w3.org/TR/voicexml20/)
- For the W3C VoiceXML 2.1 Recommendation, go to:
  [http://www.w3.org/TR/voicexml21/](http://www.w3.org/TR/voicexml21/)
- For the W3C CCXML 1.0 Recommendation (January 19, 2007), go to:
  [http://www.w3.org/TR/ccxml/](http://www.w3.org/TR/ccxml/)
For the Speech Recognition Grammar Specification version 1.0, go to:

http://www.w3.org/TR/speech-grammar/#AppJ.5

Documentation availability

The Orchestration Designer documentation consists of four outputs:

- **Getting Started with Avaya Aura ® Orchestration Designer.** This PDF document contains the information needed to install and configure Orchestration Designer for initial use, as well as to understand the basics of Orchestration Designer graphical user interface (GUI).

- **Avaya Aura ® Orchestration Designer online Help.** The online Help provides detailed information and procedures for using Orchestration Designer features and options to create speech and call control applications.

When installing Orchestration Designer, the online Help is installed as an additional Eclipse plug-in.

To view the online Help, perform one of the following actions:

- With the cursor over an item within the interface, press the F1 key to display the help.

- **Avaya Aura ® Orchestration Designer Developer’s Guide.** This PDF document contains the same information as available in the online Help, but in a format that can be printed or viewed using Adobe Acrobat Reader.

- **Programmer Reference Guide.** This online documentation is designed for the programmers of Orchestration Designer. This documentation includes:
  
  - A Constants (Quick reference) guide.
  - A Class Hierarchy reference guide.
  - An API Reference guide.

To view the preceding documentation, on the Help menu, click Help Contents > Avaya Aura ® Orchestration Designer - Self Service > Programmer Reference.
Orchestration Designer documentation location

You can view the Orchestration Designer documentation at the following locations:

- Orchestration Designer DVD (which includes the software).
- In Orchestration Designer application, on the Help menu, click Help Contents > Avaya Aura ® Orchestration Designer - Self Service.
Chapter 1: About Orchestration Designer

Overview

Orchestration Designer is a Java-based tool that you can use to create speech and call control applications that comply with VoiceXML version 2.1 or CCXML version 1.0 January 19, 2007, specification. Designed as an Eclipse plug-in, Orchestration Designer provides an integrated GUI for the design and implementation of speech applications that can operate with Interactive Response, Voice Portal, Media Processing Server, and Avaya Aura ® Experience Portal systems.

Orchestration Designer is based on the widely accepted Eclipse.org development framework. It provides a drag-and-drop environment for development and maintenance of speech and touchtone applications.

Features and benefits

Orchestration Designer:

- Simplifies development, integration, and reusability of speech and touchtone applications.
- Significantly reduces time and cost of application prototyping and design.
- Provides unprecedented coverage of customer self-service, employee-facing productivity, and advanced call control application areas.
- Ensures consistent and more reliable deployment of voice enabled services and applications.
- Maximizes the use of existing tooling investments for more rapid deployment of Web-based voice applications through the open Eclipse-based framework.
Chapter 2: Installation and configuration

This chapter contains information about installing and configuring Orchestration Designer. In addition, this chapter includes procedures for installing sample applications and upgrading Orchestration Designer by installing patches and updates.

Before installing Orchestration Designer, ensure that the hosting system meets the requirements described in the following sections:

- License requirements
- Hardware requirements
- Software requirements

License requirements

You need a valid license to run Orchestration Designer applications on Avaya Aura ® Experience Portal (AAEP), Avaya Voice Portal (VP), Avaya Interactive Response (IR), and Avaya Media Processing Server (MPS), or other supported VXML platform. Orchestration Designer licenses are free. You can contact an Avaya sales representative or channel manager to get the license file. Avaya partners can log on to the Partner Portal to find information on ordering additional licenses.

Orchestration Designer does not require a separate WebLM server. Avaya recommends that you install the Orchestration Designer license on the existing WebLM license server that is installed with Voice Portal, Avaya Aura ® Experience Portal, IR, or another Avaya product utilizing WebLM license server.

You do not require a license to install or run the Eclipse-based Orchestration Designer development and simulation environment. You can purchase the license for the value added features of the Eclipse-based Orchestration Designer development and simulation environment from Avaya. Contact your business partner or Avaya Channel Manager for ordering related information.

**Note:**

You require a valid license to enable the Application Simulator to work with third-party speech servers (TTS/ASR) over Media Resource Control Protocol (MRCP). Contact your business partner or Avaya Channel Manager for acquiring the license.

After you acquire the license, an XML file is generated which has the license related information.
Installation and configuration

Hardware requirements

The system that hosts the Orchestration Designer development environment must meet or exceed the following hardware requirements:

<table>
<thead>
<tr>
<th>Hardware</th>
<th>Minimum</th>
<th>Recommended</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPU speed</td>
<td>1 GHz</td>
<td>2 GHz</td>
</tr>
<tr>
<td>RAM</td>
<td>512 MB</td>
<td>1 GB</td>
</tr>
<tr>
<td>Hard disk drive</td>
<td>40 GB</td>
<td>—</td>
</tr>
<tr>
<td>Monitor resolution</td>
<td>1024 x 768 pixels</td>
<td>—</td>
</tr>
</tbody>
</table>

Software requirements

The system that hosts the Orchestration Designer development environment must have the following software packages installed. You must install these packages before installing and configuring Orchestration Designer. The software required to host the Orchestration Designer development environment is available on the Orchestration Designer 6.0 distribution DVD.

⚠️ Important:
If you want to upgrade Orchestration Designer, see Upgrading Dialog Designer to Orchestration Designer.

Supporting software requirements

<table>
<thead>
<tr>
<th>Software requirement</th>
<th>On DVD</th>
<th>Notes and links¹</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Windows XP (Professional or Home editions, Service Pack 2 or later)</td>
<td>No</td>
<td>You can install Orchestration Designer on any of these operating systems as long as you meet all the hardware requirements and install all the supporting software packages. Note: For the development environment, Orchestration Designer supports Windows 7, 32 bit and 64 bit. However, for 64 bit operating system, you must use 32 bit JRE and Eclipse version.</td>
</tr>
<tr>
<td>Microsoft Windows 7 (Professional and Enterprise versions)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Microsoft Windows Vista (Business or Ultimate editions)²</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

¹ Notes and links: Orchestration Designer supports Windows 7, 32 bit and 64 bit. However, for 64 bit operating system, you must use 32 bit JRE and Eclipse version.
### Supporting software requirements (continued)

<table>
<thead>
<tr>
<th>Software requirement</th>
<th>On DVD</th>
<th>Notes and links</th>
</tr>
</thead>
<tbody>
<tr>
<td>J2SE Development Kit 6.0 (JDK 6.0)</td>
<td>Yes</td>
<td>The JDK includes the Java Run-Time Environment (JRE) and command-line tools, compilers, and debuggers used in developing applets and applications. To install JDK 6.0: 1. Locate the JDK installer on the Orchestration Designer 6.0 DVD. This file is located in the following directory: <code>&lt;DVD_drive&gt;\Installation\Java\</code> 2. Double-click the downloaded executable file to install the JDK.</td>
</tr>
<tr>
<td>Eclipse-3.6-Prereq-AAOD.zip which includes:  ● Eclipse 3.6 SDK  ● GEF 3.6 SDK  ● WTP SDK 3.2  ● emf-xsd 2.6  ● DTP 1.9  <strong>Note:</strong> Orchestration Designer Release 6.0 also supports Eclipse 3.5 with the following features:  ● GEF 3.5  ● WTP 3.1  ● DTP 1.8  ● EMF-SDO-XSD 2.5</td>
<td>Yes</td>
<td>Eclipse is a Java-based open-source integrated development environment (IDE) for software development. Orchestration Designer runs as an Eclipse plug-in. Orchestration Designer uses the Eclipse Graphical Editing Framework plug-ins for Eclipse (GEF) for advanced graphical functions. It also includes the support files for Call Control (CCXML) development. To install the Orchestration Designer Eclipse Prerequisite files, perform the following actions: 1. Locate the package file on the Orchestration Designer 6.0 DVD. This file is located in the following directory: <code>&lt;DVD_drive&gt;\Installation\Eclipse\</code> 2. Extract the .zip file into an installation folder. 3. If you want, create a shortcut for the Eclipse executable. Orchestration Designer is launched through Eclipse. <strong>Note:</strong> For Windows Vista Business, download the prerequisite .zip file before extracting the prerequisite .zip file because the native extract from the Web site does not work properly on Windows Vista Business.</td>
</tr>
</tbody>
</table>
# Installation and configuration

## Supporting software requirements (continued)

<table>
<thead>
<tr>
<th>Software requirement</th>
<th>On DVD</th>
<th>Notes and links</th>
</tr>
</thead>
</table>
| Tomcat 5.5 or Tomcat 6.0 | Yes | Tomcat generates and serves VoiceXML pages to the Avaya Application Simulator. **Note:**  
  - You must have administrative privileges when running Tomcat.  
  - If you upgrade to Tomcat 6.0, you may need to make small adjustments the first time you run Tomcat. If your applications have manually configured build paths or have resources in common/lib or common/classes, then you must manually update the build path to point to <tomcat_installpath>/lib and also put any resources, such as libraries, in that folder.  

To install Tomcat, perform the following actions:  
1. Locate the Tomcat distribution package on the Orchestration Designer 6.0 DVD. These files are located in the following directory:  
   `<DVD_drive>:\Installation\Tomcat\`  
2. Extract the .zip file in a temporary folder.  
3. Review the `RUNNING.txt` file for additional installation instructions.  

⚠️ **Important:**  
Do not install Tomcat as an NT service. Orchestration Designer does not support this configuration because Tomcat does not start and stop appropriately when developing applications.  

**Note:**  
If more than one Java SDK is installed, then you must set the Tomcat [JVM Settings](#) preferences option to JRE1.5.x. The JRE1.5.x must be available in Java before you select it in the Tomcat [JVM Settings](#).
Microsoft Speech SDK 5.1 (SpeechSDK51.exe)  

Yes  

Orchestration Designer uses Microsoft Speech SDK during application testing to perform automated speech recognition (ASR) and text-to-speech (TTS) functions.  

**Note:**  
If Microsoft Speech SDK 5.1 is already installed, verify if the *Speech Recognition* and *Text-to-Speech* tabs are available in *Control Panel > Speech*. If so, you need not install Microsoft Speech SDK.  

To install the Microsoft Speech SDK 5.1, perform the following actions:  
1. Locate the Microsoft Speech SDK file on the Orchestration Designer 6.0 DVD. This file is located in the following directory:  
   `<DVD_drive>:\Installation\MSSpeech\`  
2. Double-click the **Setup.exe** file. The system displays the Microsoft SDK InstallShield wizard.  
3. In the **Welcome** dialog box, click **Next**.  
4. Accept the license terms, and click **Next**.  
5. Enter a User Name and Organization in the **Customer Information** dialog box, then click **Next**.  
6. Accept the default installation folder, when prompted, or navigate to another, if applicable. Then click **Next**.  
7. Click **Install** to begin the Microsoft Speech SDK installation.  
8. Click **Finish** when the installation is complete.

Storm Codec 7.01.19  

You need to install Storm Codec 7.01.19 only if you intend to use 3GP video files for media.  
To launch the Storm Codec installer, see the installation notes available on the DVD.

---

1. Though specific locations on the DVD are described here, it is intended that users simply launch the DVD, and use the displayed HTML index page to navigate to the required resources.  
   By following these instructions, installation will be smoother because the online navigation documentation leads the developer along the correct installation path. This is the preferred methodology for using the DVD and installing Orchestration Designer efficiently.  
2. Requires Eclipse 3.3
Installing Orchestration Designer

The Orchestration Designer installation DVD contains the Orchestration Designer distribution executable. Before running the executable, ensure that all system requirements are met.

Note:
Before installing the Orchestration Designer software, Avaya recommends that you temporarily disable the antivirus software and close any open or running applications. Orchestration Designer installation involves extracting Java-related files from a compressed archive and the antivirus software can slow down the installation process significantly.

⚠️ Important:
The procedure described in this section is for new installations of the Orchestration Designer software. To upgrade Orchestration Designer, see Upgrading Dialog Designer to Orchestration Designer.

To install Orchestration Designer:

1. Insert the Orchestration Designer installation DVD into the DVD drive. The Install wizard starts automatically.

Note:
If the Install wizard does not start automatically, browse to the root directory of the DVD and double-click autorun.exe.

2. An Avaya Software License Agreement is displayed. Review the license agreement, and click I accept. Please continue to accept it.

3. A “start.html” file is displayed. This file provides an overview of the following available resources on the DVD:

   ● Getting Started with Avaya Aura ® Orchestration Designer: A link to a copy of this document on the DVD.
   
   ● Installation Notes: A link to additional installation notes. These notes include information about installing Orchestration Designer and prerequisite software, and localization bundles available in the current release.
   
   ● Sample Applications: A link to a page with information about accessing and using sample applications in Orchestration Designer. Sample applications provide tangible ideas on how to use Orchestration Designer most effectively.

Note:
If you are installing Orchestration Designer on Windows 7, the Internet Explorer browser may not display "start.html" file. You can browse the DVD to locate this file and double-click to view it.

4. Install Orchestration Designer software and supporting software by following the instructions and links in the Installation Notes on the DVD.
5. Optionally, install the Storm Codec 7.01.19. To launch the Storm Codec 7.01.19, refer the Installation Notes on the DVD.

Orchestration Designer is now installed, but before you use Orchestration Designer, you must configure the basic settings. For information about how to configure your development environment settings, see Configuring basic settings.

To determine the installed Orchestration Designer version, click Help > About Eclipse SDK > Feature Details.

Note:
After you complete the installation procedure, read the Eclipse “readme” file located in the /readme subdirectory where Eclipse is installed. The Eclipse readme file includes valuable information and tips for configuring Eclipse.

---

Configuring basic settings

After you install all the required software for Orchestration Designer, you should perform some basic configurations to ensure that the environment is properly configured and ready to use. Perform these configurations before you start creating Orchestration Designer projects:

- Creating Eclipse shortcut
- Setting Up the Workspace
- Setting Orchestration Designer Preferences
- Configuring Microsoft Speech SDK for microphone input

---

Creating Eclipse shortcut

After you complete installing all the installation components, you can launch Eclipse to gain access to Orchestration Designer. For easy access to Eclipse, you can create a Windows desktop shortcut icon to the eclipse.exe Eclipse executable file, which is located where Eclipse is installed.

To create a shortcut and launch Eclipse:

1. To create an Eclipse shortcut, right-click the eclipse.exe Eclipse executable file which is located where Eclipse is installed, and then click Send To > Desktop (create shortcut).
2. Double-click the shortcut file to launch Orchestration Designer. This opens the Workspace Launcher dialog box.
Setting Up the Workspace

After you launch Orchestration Designer, through Eclipse, for the first time, the Eclipse Workspace Launcher dialog box prompts you to specify a workspace location. Specify a directory where you want to save all Orchestration Designer project files.

⚠️ Important:
If you are configuring a new version of Orchestration Designer, create backup copies of all files in the original installation directory before configuring a new directory.

The default directory is relative to the installation path of Eclipse. For example, C:\Eclipse\workspace. You can click Browse to navigate to a different directory.

To stop the Workspace Launcher dialog box from prompting for this directory with every launch of Eclipse, select the Use this as the default and do not ask again option in the dialog box.

Setting Orchestration Designer Preferences

You must configure the Orchestration Designer preferences the first time you use Orchestration Designer. Orchestration Designer uses these configured preferences on subsequent launches.

To gain access to these preference settings, on the Window menu, click Preferences. Verify or configure the preference settings as described in the following table:

<table>
<thead>
<tr>
<th>Orchestration Designer preferences settings</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Preferences area</td>
<td>Notes</td>
</tr>
</tbody>
</table>
| Perspectives                               | In the selection pane on the left, select General > Perspectives. Follow these steps to configure the options:
|                                           | ● In the Open a new perspective panel, select In the same window. |
|                                           | ● In the Open a new view panel, select Within the perspective. |
|                                           | ● In the Open the associated perspective when creating a new project - Prompt panel, select Prompt. |
|                                           | ● In the Available perspectives panel:
|                                           | ● Select either Speech or Call Control as your default perspective, depending on the type of task you are doing. |
|                                           | ● Click Make default. |
Orchestration Designer preferences settings (continued)

<table>
<thead>
<tr>
<th>Preferences area</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tomcat</td>
<td>If Tomcat is installed with default settings, Tomcat Preferences are already configured. If you have installed Tomcat with default settings, you need not configure Tomcat Preferences again. Verify that the appropriate Tomcat version, home directory, and Contexts directory are populated.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong>: If you are running only Orchestration Designer in your development environment, that is, if you are not running deployed applications, you need not install the runtimeconfig to your local Tomcat. This file is installed automatically. You only need to set up your production system when you are deploying and running live applications.</td>
</tr>
<tr>
<td>Avaya Aura &gt; Orchestration Designer</td>
<td>If your design environment is behind a firewall (only), proxy settings are required. Click <strong>Avaya &gt; Orchestration Designer</strong> to view the proxy settings.</td>
</tr>
<tr>
<td></td>
<td><strong>Proxy Settings</strong></td>
</tr>
<tr>
<td></td>
<td>● <strong>Enable HTTP proxy connection</strong>: Select this check box if you need a proxy server for Internet access.</td>
</tr>
<tr>
<td></td>
<td>● <strong>Ignore hosts with addresses</strong>: To allow Orchestration Designer to ignore HTTP hosts with specific addresses, specify the IP addresses. For multiple addresses, use either a comma or semicolon as a separator character.</td>
</tr>
<tr>
<td></td>
<td>● <strong>HTTP proxy host address</strong>: Enter the full HTTP path to, or the URL of, the proxy server.</td>
</tr>
<tr>
<td></td>
<td>● <strong>HTTP proxy host port</strong>: Specify the port that Orchestration Designer can use to access the proxy server.</td>
</tr>
<tr>
<td></td>
<td><strong>Copy HTTP Settings to HTTPS</strong></td>
</tr>
<tr>
<td></td>
<td>● Click this button to copy the configured HTTP settings to HTTPS settings automatically.</td>
</tr>
</tbody>
</table>
### Orchestration Designer preferences settings (continued)

<table>
<thead>
<tr>
<th>Preferences area</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Avaya Aura &gt; Orchestration Designer (continued)</td>
<td></td>
</tr>
<tr>
<td><strong>HTTPS Proxy Settings</strong></td>
<td></td>
</tr>
<tr>
<td>● <strong>Enable HTTPS proxy connection</strong>: Select this check box if you need a proxy server for Internet access. If you do not need a proxy server for Internet access, clear this check box. If cleared, Orchestration Designer disables the other options in this area.</td>
<td></td>
</tr>
<tr>
<td>● <strong>Ignore HTTPS hosts with addresses</strong>: To allow Orchestration Designer to ignore HTTPS hosts with specific addresses, specify the IP addresses. For multiple addresses, use either a comma or a semicolon as a separator character.</td>
<td></td>
</tr>
<tr>
<td>● <strong>HTTPS proxy host address</strong>: Enter the full HTTPS path to, or the URL of, the proxy server. If you do not know this address, look at the proxy server settings for your Internet browser software.</td>
<td></td>
</tr>
<tr>
<td>● <strong>HTTPS proxy host port</strong>: Specify the port that Orchestration Designer can use to access the HTTPS proxy server If you do not know the URI, contact the Avaya technical service representative.</td>
<td></td>
</tr>
<tr>
<td>Note: These settings are required even if proxy options are also set in Microsoft Internet Explorer or any other Web browser.</td>
<td></td>
</tr>
<tr>
<td><strong>Runtime License Server</strong></td>
<td></td>
</tr>
<tr>
<td>Note: You do not need a run-time license to run applications using the Application Simulator. You need to specify a run-time license server only if you have an AAEP or IR accessing your application from the development environment.</td>
<td></td>
</tr>
<tr>
<td>The format for this URI is <strong><a href="http://webServerName:port">http://webServerName:port</a></strong> where:</td>
<td></td>
</tr>
<tr>
<td>● <strong>webServerName</strong> is the fully qualified host name or IP address of your WebLM license server</td>
<td></td>
</tr>
<tr>
<td>● <strong>port</strong> is the number of the HTTP/HTTPS port the system uses to access the license server</td>
<td></td>
</tr>
<tr>
<td>For example <strong><a href="http://licenseServer.myCompany.com:8080">http://licenseServer.myCompany.com:8080</a></strong>.</td>
<td></td>
</tr>
<tr>
<td><strong>Context Files</strong></td>
<td></td>
</tr>
<tr>
<td>Tomcat opens the context files of all the projects each time you simulate a project. Therefore, Orchestration Designer performance can degrade if you have several workspaces with a huge number of projects.</td>
<td></td>
</tr>
</tbody>
</table>
Configuring Microsoft Speech SDK for microphone input

Orchestration Designer uses the Microsoft Speech SDK to handle ASR input from a microphone during application simulation. To use the Microsoft Speech SDK for ASR input, you must configure the SDK to use a microphone.

To configure the Microsoft Speech SDK for using a microphone:

1. On the system where Orchestration Designer is installed, open Control Panel.
2. Double-click the Speech option.
   The system displays the Speech Properties dialog box.
3. On the Speech Recognition tab, with a microphone plugged in and turned on, speak into the microphone. The Level indicator in the Microphone panel should show that the system is receiving microphone input. If it does not, click Audio Input and correct the audio input source settings.
4. Click Configure Microphone to further tune the microphone settings.
5. Click OK.
Installing sample applications

Orchestration Designer includes numerous sample applications. You can use these sample application to understand how finished applications work and operate, and how the features of Orchestration Designer work.

To install and run sample applications:

1. Navigate to the /Sample Applications/files directory on the Orchestration Designer installation DVD.


3. Follow the instructions in this file to finish installing and configuring Orchestration Designer sample applications. This file also contains detailed information about each sample application.

⚠️ Important:

Included sample applications are intended to be used as technical samples for reference only, and not production-ready applications.

Upgrading Dialog Designer to Orchestration Designer

The procedure to upgrade Dialog Designer 5.1 to Orchestration Designer 6.0 is slightly different depending on whether the earlier version (5.1) is available while installing a concurrent new version (6.0).

See the following sections:

- Maintaining the 5.1 environment while installing 6.0
- Installing 6.0 without retaining the 5.1 environment

Note:

Upgrades to Dialog Designer may require updates to connectors or other dependant libraries on the application server. Avaya recommends that you update the connector applications (icconnector.war and aesconnector.war) and run-time support files (runtimeSupport<platform>.zip) after upgrading Orchestration Designer.

For more information about installing the run-time support files and connectors, see Installing Required Files on the Application Server in Avaya Aura ® Orchestration Designer Developer's Guide.
Maintaining the 5.1 environment while installing 6.0

To retain the Dialog Designer 5.1 environment, you can install Orchestration Designer 6.0 into a separate directory. You can retain the Dialog Designer 5.1 environment for reasons such as maintenance of 5.1-based applications.

To do this:

1. Preserve the Dialog Designer 5.1 and Eclipse 3.4 or 3.5 installation and workspace. Dialog Designer 5.1 will continue to use the previous Tomcat installation.

2. Install Orchestration Designer 6.0, and Tomcat 5.5 or 6.0 (Tomcat upgrade is optional) to a separate location (for example, C:\OD6.0)

   **Note:**
   You must install Tomcat under the Orchestration Designer 6.0 installation location to keep it separate.

3. Upgrade a Dialog Designer 5.1 to Orchestration Designer 6.0:
   - Copy the project from the Dialog Designer 5.1 workspace to the Orchestration Designer 6.0 workspace.
     Keep a copy in the 5.1 workspace to ensure that you have a backup in case of upgrade problems.
   - Import the copied project into Orchestration Designer 6.0. The project will be converted for Orchestration Designer 6.0. This project can no longer be opened in Dialog Designer 5.1.

4. If you use a source control system, store the 6.0 application in a different location or a different branch, so that the old 5.1 application can be maintained in the future.
Installation and configuration

The following example installation paths are recommended for multiple Dialog Designer / Eclipse versions. In these paths, (base) means any parent directory.

\( c:\((\text{base})\)DD5.1\)

\text{eclipse}\ (Eclipse 3.4 or 3.5 install, with GEF 3.4 or 3.5 respectively, and Dialog Designer 5.1 features)

\text{tomcat}\ (Tomcat 5.5 or 6.0 for running Dialog Designer 5.1 applications)

\text{workspace}\ (Dialog Designer 5.1 projects)

\( c:\((\text{base})\)OD6.0\)

\text{eclipse}\ (Eclipse 3.6 install, with GEF 3.6, WTP SDK 3.2, EMF-SDO-XSD 2.6, with Orchestration Designer 6.0 features, Eclipse 3.4 or 3.5 install, with GEF 3.4 or 3.5 respectively, and Dialog Designer 5.1 features)

\text{tomcat}\ (Tomcat 5.5 or 6.0 for running Orchestration Designer 6.0 applications)

\text{workspace}\ (Orchestration Designer 6.0 projects)

This is a convenient installation structure that keeps the Dialog Designer 5.1 and Orchestration Designer 6.0 environments and prerequisite software separate.

Note:
After creating a new workspace during an upgrade, click Window > Preferences to configure your preferences before importing old projects. See Setting Orchestration Designer Preferences for more details.

Installing 6.0 without retaining the 5.1 environment

To install Orchestration Designer 6.0 without retaining the Dialog Designer 5.1 environment:

1. Before uninstalling Dialog Designer 5.1, create a backup copy of the projects in your workspace.

2. Uninstall Dialog Designer 5.1 using Control Panel > Add or Remove Programs option. Depending on the location of your workspace, your projects can be removed by the uninstall process.

3. Install Orchestration Designer 6.0 and the supporting software. For more information, see Software requirements.

4. Copy the Dialog Designer 5.1 projects from the backup into the Orchestration Designer 6.0 workspace.

It is a good idea to keep copies of your old backups in the event that there are errors while upgrading.
5. Import each project into Orchestration Designer 6.0. The project is then converted for Orchestration Designer 6.0.

6. If you use a source control system, create a branch or store the 6.0 application in a different location so that the old 5.1 application can be maintained in the future.

**Note:**
After creating a new workspace during an upgrade, click **Window > Preferences** to configure your preferences before importing the old projects. For more information, see Setting Orchestration Designer Preferences.

---

**Installing Orchestration Designer patch updates**

At this time, Avaya does not automatically alert you to the availability of new patches to Orchestration Designer. Therefore, periodically check the Avaya support Web site for the availability of patches. Or, as an alternative, use the Eclipse update mechanism to check for available updates.

The following sections describe the steps for installing Orchestration Designer patches:

- **Prerequisites for installing a patch update**
- **Installing a patch update**

**Note:**
The procedure described in the Installing a Patch Update section is for installing patches or updates to a released software, and not for upgrading software versions completely. For upgrading the software, see Upgrading Dialog Designer to Orchestration Designer.

---

**Prerequisites for installing a patch update**

Before installing a patch update, make backup copies of all files in the default /eclipse installation directory, as well as all files in the designated /workspace directory (if not a subdirectory of /eclipse). Backing up your files helps you to revert an update.

To continue using the older version for existing applications, perform a “clean installation” of the new version in a new directory.
CAUTION:
When opening an application created with a prior release of Orchestration Designer, Orchestration Designer prompts you to update the project to the new version. For project conversion considerations, refer to the Release Notes.

Installing a patch update

Orchestration Designer patch updates are released through the Avaya Support Web site.

To gain access to these updates from within the Eclipse user interface (UI):

1. On the Help menu, click Software Updates > Find and Install.

   Note: If you are unable to connect to the update site, ensure you have correctly configured the proxy settings.

2. In the Install/Update dialog box, select the Search for updates of the currently installed features option.

3. Click Next.

   Orchestration Designer automatically checks both the Eclipse and Avaya Support Web sites for updates. If patches or updates are found, the search mechanism returns the results. Select the updates or features to install, and then follow the prompts.

CAUTION:
The Eclipse Install/Update mechanism can be used by other features besides Orchestration Designer. To ensure that you install compatible features, Avaya recommends that you update only the Orchestration Designer features.

If you are not sure which updates to install or if you have questions about the installation procedure, contact Avaya Support at http://support.avaya.com.
Chapter 3: Getting familiar with the Orchestration Designer user interface

This chapter contains information about accessing the Eclipse Workbench User Guide. This chapter contains more details on Eclipse development environment concepts and terminology used by Orchestration Designer.

In addition, this chapter contains information about the Orchestration Designer GUI, within the Eclipse framework, including the different areas of the Orchestration Designer workbench, menus, and toolbar options.

For more information, see the following sections:

- Accessing the Concepts section of the Eclipse Workbench User Guide
- Orchestration Designer workbench
- Orchestration Designer Menu and Toolbar options

Accessing the Concepts section of the Eclipse Workbench User Guide

Eclipse Workbench User Guide contains an overview of many of the same concepts used within Orchestration Designer, but from the Eclipse development environment framework perspective. You can review this information to get familiar with the Eclipse user interface.

To gain access to the Eclipse Workbench User Guide online Help:

1. Within Orchestration Designer, on the Help menu, click Help Contents. The system displays the Help - Eclipse SDK dialog box.
2. In the Contents pane, click Workbench User Guide.
3. In the right pane, click Concepts. Review the multiple sections of the Concepts section to become familiar with Eclipse.
Orchestration Designer workbench

Note: Be sure that you are familiar with the concepts and terminology of Eclipse. For more information, see Accessing the Concepts section of the Eclipse Workbench User Guide.

The Orchestration Designer workbench is designed as a speech project perspective in Eclipse. The layout of the views and workspace are optimized to assist you in creating speech application projects.

The following descriptions provide information about how the Eclipse environmental elements are arranged in Orchestration Designer and why. However, as with any Eclipse perspective, you can arrange the perspective elements as you want. If this case, the following view descriptions may no longer be applicable.

Orchestration Designer Speech Perspective

This section contains information about the views that are available in the standard Orchestration Designer speech perspective. For information about menus and toolbar items, Orchestration Designer Menu and Toolbar options.

Starting in the upper-left corner of the window and working left-to-right and top-to-bottom, the Orchestration Designer speech perspective consists of the following major elements:

- **Speech Navigator view**
- **Navigator view**
- **Editor view**
- **Outline view**
- **Avaya Application Simulator view**
- **Problems view**
- **Tasks view**
- **Properties view**
- **Console view**

You can manipulate most views or tab groups within the Eclipse perspective. Right-click on a tab label, and select any of the following options:

- **Fast View**: Minimizes the selected tab view, which is accessible through a clickable icon in the lower-left corner, for a “fast view” access later.
- **Detached**: Allows the selected tab view to be detached from the Speech perspective, the same way that the Move option does.
- **Restore**: Restores the default settings of the selected tab view. Alternatively, you can click **Reset Perspective** on the **Window** menu to restore the tab view settings to the default position and size.

- **Move**: Allows the tab view or the complete tab group, if more than one, to be moved outside the perspective. For example, to the Desktop area outside the Eclipse window.

- **Size**: Adjusts the size of the panel border relative to the option selected. Only borders that can be adjusted, per selected tab, are active options. Options are Left, Right, Top, and Bottom. For example, on the Speech Navigator tab, to make the area wider, select **Size > Right**, and then drag the dark blue highlighted border to make the view wider.

- **Minimize**: Minimizes the size of the tab view that you select.

- **Maximize**: Maximizes the size of the tab view that you select.

- **Close**: Closes the tab view that you select.
Speech Navigator view

The **Speech Navigator** view, which is the default Eclipse view when working with Orchestration Designer, provides multiple hierarchical views of the resources in the Orchestration Designer speech project.

The Eclipse Navigator view might get busy because other application developers explore resources and code elements scattered across different speech applications. Hence, Avaya has developed the Speech Navigator view for Orchestration Designer. The Speech Navigator view helps you remain focused while exploring and navigating across the code base.

To view the Speech Navigator view:

1. On the **Window** menu, click **Show View > Other**.
2. In the **Show View** dialog box, click **Orchestration Designer > Speech Navigator**.
3. Click **OK**.

The Speech Navigator view contains a hierarchical view of all your applications. The following options are available on the toolbar of the Speech Navigator view:

- **Collapse All.** Collapses all the expanded folders.
- **Link with Editor.** Links the Speech Navigator item with the currently open editor.

When multiple editors are open and you click an editor, the system highlights the item that is linked to the editor in the **Speech Navigator** view. This makes it easier to locate the item.

Similarly, when you click an item in the **Speech Navigator** view, the system shows the editor that is linked to the item.

**Link with Editor** synchronizes the tree view in the **Speech Navigator** view with the currently open editor.

- **Show Projects.** Similar to the Eclipse Navigator view, **Show Projects** displays the physical structure of Orchestration Designer projects.
- **Show Easy Find.** Shows all elements in your development environment, grouped by resource type, that is, logical structure, and then grouped by application name.
- **Show Custom.** Shows a hybrid view by project, and under project, by resource type.

In the Speech Navigator, you can:

- Drag and drop. For example, drop a .dbop file into the Call Flow editor to create a data node with a database operation defined. Drop a phrase onto a prompt item to create the phrase.
- Launch exports, except in the **Show Easy Find** view.
- Launch resource wizards. When you select a resource in one of the views, the selection persists even if you switch to another view.
- Drill down to variables from all view types.
You can expand any resource group such as, grammars, phrases, phrasesets, prompts, to view the actual resources within the resource group. When you right-click a resource and click **Properties**, Orchestration Designer displays a context-sensitive properties dialog box.

To customize the view further, click the <down arrow> on the toolbar of the tab and click **Customize View**.

---

**Navigator view**

The **Navigator** view is a standard Eclipse view that provides a hierarchical view of the resources in the Orchestration Designer speech project. For greater control over your resources while designing applications, see **Speech Navigator view**.

The following are the main features of the **Navigator** view:

- When you create a speech project in Orchestration Designer, Orchestration Designer automatically creates the following element folders within the project folder:

**Element folders in the Project folder**

<table>
<thead>
<tr>
<th>Folder name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>connectivity</td>
<td>Contains the database and Web service operation files that you create as part of your project.</td>
</tr>
<tr>
<td>data</td>
<td>Contains mostly files that are derived from other files. For example, when you create a grammar file, the Grammar File Editor creates a *.gram file that contains the metadata for the grammar. When you generate the project, Orchestration Designer creates a *.grxml file that contains the actual XML grammar file. This *.grxml file is derived from the *.gram file. Usually, the derived files in this folder are hidden, and are not shown in the <strong>Navigator</strong> view.</td>
</tr>
<tr>
<td></td>
<td><strong>Important:</strong> Do not manually edit these files.</td>
</tr>
<tr>
<td></td>
<td>This folder also contains:</td>
</tr>
<tr>
<td></td>
<td>● <strong>log</strong> folder. The system writes the log files that are created during application testing to the <strong>log</strong> folder. You can view these log files for debugging your applications.</td>
</tr>
<tr>
<td></td>
<td>● <strong>temp</strong> folder. A <strong>temp</strong> folder stores any messages you record during application testing.</td>
</tr>
<tr>
<td>flow</td>
<td>Contains the main.flow file. This file is the core of your call flow application, that is, the speech project. This file is built and edited using the Call Flow Editor.</td>
</tr>
</tbody>
</table>
Element folders in the Project folder

<table>
<thead>
<tr>
<th>Folder name</th>
<th>Description</th>
</tr>
</thead>
</table>
| icons       | Contains several icons used for Orchestration Designer.  

  **Note:**  
  Do not delete or edit these icons. |
| languageName| Contains all the phrase, prompt, media, and grammar definition files of your speech project. Whenever you create or import a phrase file, a prompt file, a media file, or a grammar file, Orchestration Designer stores the file in the appropriate subfolder within this folder.  
The actual name of this folder is the name that you assign to the project primary language. |
| WEB-INF     | Contains all the output files that are created whenever you generate or build the project. These files are packaged when preparing the application for deployment. |
| work        | The Tomcat servlet engine uses this folder as a temporary folder. The system creates this folder when you simulate the project for the first time.  
Do not manually edit the contents of this folder. |

- You can open the editors for the project resources, such as phrases, prompts, and grammars by double-clicking the file in the **Navigator** view. For example, to open a phrase in the Phrase File Editor, double-click the *.phrase file.

- You can also perform other actions on the project resources by right-clicking the resources, and then selecting the appropriate action from the context menu.

**Tip:**  
You can use the **Generate** option to generate individual files and project resources. For example, to regenerate a project grammar without regenerating the entire project, in the **Navigator** view, right-click the *.gram file, and then click **Orchestration Designer > Generate**.

For more information about the Navigator view in Eclipse, see “Navigator view” in the Eclipse **Workbench User Guide**.
Editor view

By default, the Editor view is located in the upper-right area of the window. The main area of this view is called the *workspace*. The workspace is where you do most of the development work for building a speech application project.

Within the Editor view, you can launch numerous sub-editors to create, update, and manage your speech application.

For more information about the Editor view, see the following sections:

- Orchestration Designer editors
- Editor view tabs

Orchestration Designer editors

The following is a high-level overview of the editors available in Orchestration Designer:

<table>
<thead>
<tr>
<th>Editor</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Call Flow Editor" /></td>
<td>Add nodes to this editor and connect the nodes for creating call flows that direct the caller experience. Call Flow Editor is the primary editor of Orchestration Designer.</td>
</tr>
<tr>
<td><img src="image" alt="Phraseset File Editor" /></td>
<td>Use this editor to modify phraseset metadata such as phrase text, relevant comments, and search keywords. You can also record a phraseset and save it in a .wav file format.</td>
</tr>
<tr>
<td><img src="image" alt="Prompt File Editor" /></td>
<td>Use this editor to define and modify prompts, from very simple announcements to very complex prompts involving variables, conditions, and logic.</td>
</tr>
<tr>
<td><img src="image" alt="Variable Editor" /></td>
<td>Use this editor to create, define, and modify variables. You can also use this editor to view the variables that exist in the current project.</td>
</tr>
<tr>
<td><img src="image" alt="Grammar File Editor" /></td>
<td>Use this editor to define custom grammar files or select built-in grammar files.</td>
</tr>
<tr>
<td><img src="image" alt="Database Operation File Editor" /></td>
<td>Use this editor to define and modify the way a project works with databases that you select.</td>
</tr>
<tr>
<td><img src="image" alt="Web Service Operation File Editor" /></td>
<td>Use this editor to define and modify the way a project works with Axis Web services that you select.</td>
</tr>
<tr>
<td><img src="image" alt="Web Service Operation File (Axis2) Editor" /></td>
<td>Use this editor to define and modify the way a project works with Axis2 Web services that you select.</td>
</tr>
</tbody>
</table>
Editors in Orchestration Designer

<table>
<thead>
<tr>
<th>Editor</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🔄 Event Type Editor (available only from within the Call Flow Editor)</td>
<td>Use this editor to define and modify custom events and their implementation within a project. This editor is available only from within the Call Flow Editor.</td>
</tr>
<tr>
<td>🔄 CCXML File Editor</td>
<td>Use this editor to modify the CCXML files that are part of the Call Control projects.</td>
</tr>
<tr>
<td>🔄 JSP File Editor</td>
<td>Use this editor to modify JSP files that are part of the Call Control projects. This is a text-based editor.</td>
</tr>
<tr>
<td>📗 Audio Editor</td>
<td>Use this editor to record audio. You can also use this editor to define and view file properties, file locations, setup an external location, and preview and edit the contents of the audio files.</td>
</tr>
<tr>
<td>📗 Video Editor</td>
<td>Use this editor to preview videos. You cannot use this editor to record videos.</td>
</tr>
<tr>
<td>📗 Image Editor</td>
<td>Use this editor to preview images. You cannot use this editor to capture images.</td>
</tr>
<tr>
<td>📗 Text Editor</td>
<td>Use this editor to view and modify text files.</td>
</tr>
</tbody>
</table>

Editor view tabs

Orchestration Designer (Eclipse) uses two types of tabs in the Editor view:

- **Editor tabs**: The Editor tabs are located on the top of the Editor view. Whenever you open an editor, the Editor view displays the tab for that editor in the view toolbar. Each tab displays an icon representing the type of editor associated with the tab along with the name of the project element that is currently open.

  You can close any editor by clicking the X on the tab.

  **Note:**
  
  To close the Event Type Editor, click the small x in the upper-right corner of the Call Flow Editor workspace.

- **Page tabs (or bottom tabs)**: The Page tabs are located at the bottom of the Editor view. Some editors are multiple page editors. That is, these editors have more than one workspace page associated with them. In such cases, the Editor view displays a page tab at the bottom of the view for each workspace page available in the active editor.

  For example, when the Phrase File Editor is open, the Phrase and Audio page tabs both are available in the bottom toolbar of the Editor view.
Outline view

By default, the Outline view is located in the lower-left corner of the window. The Outline view is a standard Eclipse view. In Orchestration Designer, the Outline view is available only in the following conditions:

- When the Call Flow Editor is the active editor.
- When you edit a Java (*.java) file.

You can select any of the three views in the upper-right corner of the Outline view:

- The Node List view shows the nodes of a call flow in an alphabetical order and also shows all symbolic node references.
- The Thumbnail view allows you to navigate around easier within a call flow if the call flow is complicated. You can drag the shaded area in the Outline view. The system updates the main workspace simultaneously to show the full size view of the shaded area.
- The Bookmark view shows a list of all the bookmarks in a call flow. You can use this list to navigate between bookmarks in a call flow, which is useful in large and complex call flows.

To navigate to a bookmarked node, click the bookmark in the Bookmark view. The system highlights the bookmarked node in the main workspace of the Call Flow Editor.

Avaya Application Simulator view

You can test your applications by simulating the applications in the Application Simulator view tab.

The Application Simulator view tab offers controls to the Avaya Application Simulator to test applications by simulation.

By default, Orchestration Designer shows the Application Simulator view in a tabbed notebook, along with the Problems view and the Tasks view, in the center of the lower area of the window.

Application Simulator view fields and features descriptions

<table>
<thead>
<tr>
<th>Field/Feature name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Available Projects</td>
<td>Shows a list of projects to simulate. You can select only one project at a time.</td>
</tr>
<tr>
<td>Input Parameters</td>
<td>Simulates the input expected from another application module. The format of the simulated input must match the expected format.</td>
</tr>
</tbody>
</table>
Getting familiar with the Orchestration Designer user interface

Application Simulator view fields and features descriptions (continued)

<table>
<thead>
<tr>
<th>Field/Feature name</th>
<th>Description</th>
</tr>
</thead>
</table>
| Run Application    | Click this button to start the simulation. This button is available only when you select a project for simulation in Available Projects.  
**Note:** If there are any errors in the project to be simulated, this button is unavailable. |
| Debug Application  | Click this button to debug the application. This button is available only when you select a project in Available Projects.  
**Note:** Ensure that you set the Debug perspective for running the debugger in Windows > Preferences > Run/Debug > Perspectives to Debug. |
| End Application    | Click this button to end the simulation before the simulation is complete. This button is available only when a project is in the simulation mode.  
**Note:** This action is different from that of the Hang Up simulation. When you click the End Application button, the system stops the application wherever it is. The Hang Up button on the Input tab simulates a situation in which the caller gets disconnected before reaching the end of the call flow either by hanging up or by some other means. |
| Do Not Run As Module | Select this check box to run Orchestration Designer applications that are modules, as standalone applications. If you clear this check box, the system generates a default VXML page to invoke the Orchestration Designer application as a subdialog. |

Problems view

The Problems view tab shows the errors, warnings, and informational messages that are generated while saving a project or any of its elements. At the same time, Orchestration Designer displays a Code Generation error message, unless you click Do not show me this message in the future. This view also shows any errors that are generated while compiling the Java code.

If you double-click the error, warning, or informational message in this view, Orchestration Designer navigates to the exact location where the problem occurs. This feature makes it easier to debug an application and resolve the problem.

By default, Orchestration Designer shows the Problems view in a tabbed notebook, along with the Tasks view and the Application Simulator view, in the center of the lower area of the window.
Tasks view

The **Tasks** view is a standard Eclipse view. The **Tasks** view shows the tasks related to various types of errors that might occur, such as Java syntax errors. You can also manually add tasks to this list for things you want to remember to take care of.

For more information about the **Tasks** view in Eclipse, see the “Tasks view” section in the Eclipse *Workbench User Guide*.

By default, Orchestration Designer shows the **Tasks** view in a tabbed notebook, along with the **Problems** view and the **Application Simulator** view, in the center of the lower area of the window.

Snippets view

The **Snippets** view contains shortcut snippets in JSP or CCXML that you can add onto your CCXML or JSP page while building call control projects.

Properties view

The **Eclipse Properties** view is a modification of the standard Eclipse Properties view. In a layout optimized for Orchestration Designer, it displays property names and values for nodes, palette options, or other items. The properties available for editing vary according to the editor, node, or item you are working with. For more information about the properties you can edit for a particular node, option, or other item, see the online Help topic for that node, option, or item.

For more information about the standard Properties view in Eclipse, see the “Properties view” section in the Eclipse *Workbench User Guide*.

**Note:**

By default, Orchestration Designer shows the **Properties** view in a tabbed notebook, along with the **Console** view, in the lower-right area of the window.

Console view

The **Console** view shows information about the status and activity of the Tomcat server.

- If you run simulations, the system writes the CCXML, VXML, and connector logs to the **Console** view window.
Getting familiar with the Orchestration Designer user interface

- If you enable the debug output for the tracing function, then the Console view shows the VoiceXML output generated by the application. This information is read only, but it can be helpful in debugging applications, especially if you can read and understand VoiceXML code. To enable the debug output for tracing function, see Enabling the debug output for tracing function.

By default, Orchestration Designer shows the Console view in a tabbed notebook, along with the Properties view, in the lower-right area of the window. The Console view appears in the foreground if you start Tomcat or click the Console tab.

Enabling the debug output for tracing function

To enable the debug output for tracing function:

1. On the Window menu, click Preferences.
   The system displays the Preferences dialog box.
2. In the left pane, click Avaya Aura > Application Simulation > Orchestration Designer Simulation.
3. Select the Enable Orchestration Designer logging of tracing output check box.
4. Click Apply, and then click OK.

Tip:
When you enable the Enable Orchestration Designer logging of tracing output option, Orchestration Designer shows the VoiceXML output in the Console view and writes the output to a trace log file. For more information, see Console view. This file is located at applicationName/data/log/trace.log-yyyy-mm-dd.log, where applicationName represents the top level application directory, and yyyy-mm-dd represents “today’s” simulation runs generated. To view this log file, locate the file in the Navigator pane and double-click the file name.

Orchestration Designer Menu and Toolbar options

There are several main menu and toolbar options that are specific to Orchestration Designer. The following table shows a quick reference and summary of these options.
Orchestration Designer menu and toolbar options

<table>
<thead>
<tr>
<th>Icon</th>
<th>Descriptor</th>
<th>Description</th>
<th>Navigation</th>
</tr>
</thead>
</table>
| ![Speech Project](image) | Speech Project | *Speech Perspective only.* Opens the wizard to create a speech project. | ● File menu > New  
● Main toolbar  
● Right-click anywhere in the **Navigator** view or in the **Speech Navigator** view |
| ![CCXML File Editor](image) | CCXML File Editor | *Call Control Perspective only.* Opens an editor to edit CCXML files. | ● File menu > New  
● Main toolbar  
● Right-click anywhere in the **Navigator** view or in the **Speech Navigator** view |
| ![JSP File Editor](image) | JSP File Editor | *Call Control Perspective only.* Opens an editor to edit JSP files. | ● File menu > New  
● Main toolbar  
● Right-click anywhere in the **Navigator** view or in the **Speech Navigator** view |
| ![Call Control Project](image) | Call Control Project | *Call Control Perspective only.* Opens a wizard to create a call control project. | ● File menu > New  
● Main toolbar  
● Right-click anywhere in the **Navigator** view or in the **Speech Navigator** view |
| ![Database Operation File](image) | Database Operation File | *Call Control or Speech Perspective.* Opens the wizard to create a database operation file, and can be used in either a speech application or a call control application. | ● File menu > New  
● Main toolbar  
● Right-click anywhere in the **Navigator** view or in the **Speech Navigator** view |
| ![Grammar File](image) | Grammar File | *Speech Perspective only.* Opens the wizard to create a grammar file. | ● File menu > New  
● Main toolbar  
● Right-click anywhere in the **Navigator** view or in the **Speech Navigator** view |

**Note:**  
This table shows the options that are specific to Orchestration Designer. This table does not include generic Eclipse options.
## Orchestration Designer menu and toolbar options (continued)

<table>
<thead>
<tr>
<th>Icon</th>
<th>Descriptor</th>
<th>Description</th>
<th>Navigation</th>
</tr>
</thead>
</table>
| 📖   | Media file | *Speech Perspective only.* Opens a wizard to create media files such as SMIL file containing audio, video, prompts, text, and graphics. The media elements can also be used in call control applications. | ● File menu > New  
● Main toolbar  
● Right-click anywhere in the Navigator view or in the Speech Navigator view |
| 📒   | Phraseset file | *Speech Perspective only.* Opens the wizard to create a phraseset file. | ● File menu > New  
● Main toolbar  
● Right-click anywhere in the Navigator view or in the Speech Navigator view |
| 🎧   | Prompt File | *Speech Perspective only.* Opens the wizard to create a prompt file. | ● File menu > New  
● Main toolbar  
● Right-click anywhere in the Navigator view or in the Speech Navigator view |
| 🚄   | Web Service Operation File | *Call Control or Speech Perspective.* Opens the wizard to create an Axis Web service operation file, and can be used in either a speech application or a call control application. | ● File menu > New  
● Main toolbar  
● Right-click anywhere in the Navigator view or in the Speech Navigator view |
| 🚄   | Web Service Operation File (Axis2) | *Call Control or Speech Perspective.* Opens the wizard to create an Axis2 Web service operation file, and can be used in either a speech application or a call control application. | ● File menu > New  
● Main toolbar  
● Right-click anywhere in the Navigator view or in the Speech Navigator view |
| 🌐   | Start Tomcat | *Call Control or Speech Perspective.* Starts the Tomcat servlet engine. The Tomcat servlet engine is required to simulate applications in Orchestration Designer. | ● Tomcat menu  
● Main toolbar |
## Orchestration Designer menu and toolbar options (continued)

<table>
<thead>
<tr>
<th>Icon</th>
<th>Descriptor</th>
<th>Description</th>
<th>Navigation</th>
</tr>
</thead>
</table>
| ![Stop icon] | **Stop Tomcat** | *Call Control or Speech Perspective.* Stops the Tomcat servlet engine. The Tomcat servlet engine is required to simulate applications in Orchestration Designer. | ● **Tomcat** menu  
 ● **Main toolbar** |
| ![Restart icon] | **Restart Tomcat** | *Call Control or Speech Perspective.* Restarts the Tomcat servlet engine. The Tomcat servlet engine is required to simulate applications in Orchestration Designer. | ● **Tomcat** menu  
 ● **Main toolbar** |
| ![Update icon] | **Update Context** option | *Call Control or Speech Perspective.* Updates the Tomcat server with the current application information, known as the context definition. This action is required when you update the application, but the changes are not communicated to the Tomcat server. One indication that you may need to update the context is if you get a “General Error 404” message. | ● In the **Navigator** view or in the **Speech Navigator** view, right-click the `<project name>` folder, and then click **Orchestration Designer > Update Context.** |
| ![Generate icon] | **Generate Project** option | *Call Control or Speech Perspective.* Generates the project code. | ● In the **Navigator** view or in the **Speech Navigator** view, right-click the `<project name>` folder, and then click **Orchestration Designer > Generate Project.** |
### Orchestration Designer menu and toolbar options (continued)

<table>
<thead>
<tr>
<th>Icon</th>
<th>Descriptor</th>
<th>Description</th>
<th>Navigation</th>
</tr>
</thead>
</table>
| ![No icon](image) | Validate option  | **Call Control or Speech Perspective. Validates the call flow and the prompts.** | - In the **Navigator** view, expand the `<project name>` folder, and then expand the **flow** folder. Right-click the **main.flow** file, and then click **Orchestration Designer > Validate**.  
- In the **Navigator** view, expand the `<project name>` folder, expand the `<language name>` folder, and then expand the **prompts** folder. Right-click a `.prompt` file, and then click **Orchestration Designer > Validate**. |
| ![Event Type Editor](image) | Event Type Editor | Opens the Event Type Editor.                                                 | - Main toolbar  
- In the **Navigator** view or in the **Speech Navigator** view, expand the `<project name>` folder, expand the **flow** folder, and then double-click **project.events**. |
| ![Add row after](image) | Add row after    | **Grammar File Editor only.** Adds a row after the row that you select in a grammar table. | Main toolbar |
| ![Add row before](image) | Add row before   | **Grammar File Editor only.** Adds a row before the row that you select in a grammar table. | Main toolbar |
| ![Add column after](image) | Add column after | **Grammar File Editor only.** Adds a column after the column that you select in a grammar table. | Main toolbar |
| ![Add column before](image) | Add column before| **Grammar File Editor only.** Adds a column before the column that you select in a grammar table. | Main toolbar |
### Orchestration Designer menu and toolbar options (continued)

<table>
<thead>
<tr>
<th>Icon</th>
<th>Descriptor</th>
<th>Description</th>
<th>Navigation</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Delete Row Icon" /></td>
<td>Delete row</td>
<td>Grammar File Editor only. Deletes the row that you select, from a grammar table.</td>
<td>Main toolbar</td>
</tr>
<tr>
<td><img src="image" alt="Delete Column Icon" /></td>
<td>Delete column</td>
<td>Grammar File Editor only. Deletes the column that you select, from a grammar table.</td>
<td>Main toolbar</td>
</tr>
</tbody>
</table>
Glossary

<table>
<thead>
<tr>
<th>Acronym</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>AACC</td>
<td>Avaya Aura ® Contact Center.</td>
</tr>
<tr>
<td>AAEP</td>
<td>Avaya Aura ® Experience Portal.</td>
</tr>
<tr>
<td>AAS</td>
<td>Avaya Application Simulator.</td>
</tr>
<tr>
<td>ADR</td>
<td>See application detail record (ADR).</td>
</tr>
<tr>
<td>ANI</td>
<td>See automatic number identification (ANI).</td>
</tr>
<tr>
<td>AMS</td>
<td>Avaya Media Server.</td>
</tr>
<tr>
<td>API</td>
<td>See application program interface (API).</td>
</tr>
<tr>
<td>application detail record (ADR)</td>
<td>Data records which contain historical information about an application used as part of a session. These records include information such as the session ID number, a timestamp, and a “friendly name” string determined by the developer who created the application.</td>
</tr>
<tr>
<td>application program interface (API)</td>
<td>A set of routines, protocols, and tools for building software applications. A good API makes it easier to develop a program by providing all the building blocks.</td>
</tr>
<tr>
<td>application server</td>
<td>A computer on which the Orchestration Designer speech application resides and runs. This computer is also where the Orchestration Designer run-time libraries are installed, thus making it possible to run Orchestration Designer applications on that server. The IVR system must be configured to start the speech application from this location.</td>
</tr>
<tr>
<td>ASR</td>
<td>See automated speech recognition (ASR).</td>
</tr>
<tr>
<td>automatic number identification (ANI)</td>
<td>A service that provides the originating telephone number of a call coming in to the system.</td>
</tr>
<tr>
<td>automated speech recognition (ASR)</td>
<td>Technology that employs a computer to recognize spoken words and respond appropriately.</td>
</tr>
<tr>
<td>call flow</td>
<td>As implemented in speech applications, the call flow determines how a call is handled when it enters an interactive voice response system, based on options offered to callers and their responses to those options.</td>
</tr>
<tr>
<td>CCXML</td>
<td>Call Control eXtensible Markup Language.</td>
</tr>
</tbody>
</table>

CCXML is an emerging XML specification, being developed to work in conjunction with VoiceXML and which addresses some of the technical limitations of VoiceXML. It enables the processing of asynchronous events, filtering and routing of incoming calls, and placement of outbound calls. Note that it is not intended to replace VoiceXML but rather to supplement it. See Ian Moraes’s excellent article, “VoiceXML, CCXML, SALT: Architectural Tools for Enabling Speech Applications,” on the Internet.
Computer Telephony Integration (CTI)

Software technology that integrates the use of telephones and computers without the need for special telephones, connectors, computer circuit packs, or other specialized hardware.

CTI

See Computer Telephony Integration (CTI).

dialed number identification service (DNIS)

A service that identifies for the receiving system what telephone number was dialed by the caller. In the Avaya Experience Portal system this is often used to direct the call to a particular speech application, which is identified with that dialed number.

DNIS

See dialed number identification service (DNIS).

DTMF

See dual tone multi-frequency (DTMF).

dual tone multi-frequency (DTMF)

The system used by touchtone telephones, DTMF assigns a specific frequency (consisting of two separate tones) to each telephone key on the keypad, so that it can easily be identified by a microprocessor.

Eclipse

A Java-based open-source extensible IDE (integrated development environment) that provides application developers a feature-rich interface to develop their applications. Orchestration Designer is designed as a set of Eclipse plug-in modules that make it possible for application developers to design and build speech applications without having to write the code manually.

gateway

A network point that acts as an entry point to another network. In the context of Orchestration Designer and VoIP applications, a gateway is the entry point, often associated with one or more switches, to the interactive voice response (IVR) system application environment.

grammar

In the context of Orchestration Designer, a grammar is are speech elements used in conjunction with automated speech recognition (ASR) technology. Grammars are lists of possible responses that callers make when responding to the prompts by using spoken replies. Grammars define which words or phrases the ASR engine can recognize and respond to.

H.323

A hierarchical, IP-based telephony standard for connecting IP telephones and speech applications to switches.

IC

See Interaction Center (IC).

IDE

See integrated development environment (IDE).

integrated development environment (IDE)

A software application that usually provides a GUI environment, a text and/or code editor, a compiler and/or interpreter, and a debugger. This environment means that application or web developers can develop, test, and build their applications or Web sites within a single integrated space.

Interaction Center (IC)

A multichannel contact management platform that enables businesses to align real-time contact center operations with business objectives.

interactive voice response (IVR) system

A system, such as Avaya Experience Portal or Avaya IR, in which callers interact with a self-service application to get information, conduct transactions, or help with problems.

IVR system

See interactive voice response (IVR) system.
JDBC
An application program interface (API) specification in which programs written in Java connect with and access data contained in database programs using Structured Query Language (SQL).

localization
The process of modifying an application to operate and be understood in a different language, or locale. This usually involves modifying any phrases, prompts, and grammars associated with an application.

MPS
Avaya Media Processing Server.

MRCP
Media Resource Control Protocol.

notebook
(Also known as a tabbed or stacked notebook) In the Eclipse context, a notebook is a set of views “stacked” on top of one another as a space saving measure. The views in the notebook are accessible by clicking tabs arranged along the top of the notebook. See the Eclipse documentation.

Open Speech Dialog Module (OSDM)
Speech application modules produced by Nuance software products, similar to application modules created with Orchestration Designer. OSDMs can be used in Orchestration Designer applications. (Orchestration Designer supports the following OSDM versions: Address OSDM 2.0.3, Core OSDM 2.0.4, and Name OSDM 2.0.1.)

OSDM
See Open Speech Dialog Module (OSDM).

palette
In the Orchestration Designer Editor views, this is the pane to the left of the view, in which editor options are displayed and selected.

Real-time Transfer Protocol (RTP)
A protocol for transmitting “real-time” data, such as audio or video data, across the Internet. This protocol does not guarantee “real-time” delivery of such data, but it does provide mechanisms to support data “streaming.”

RTP
See Real-time Transfer Protocol (RTP).

RTSP
The Real Time Streaming Protocol, serves as a control protocol, and as a jumping off point for negotiating transports, such as RTP, multicast and unicast, and negotiating codecs off of servers in a file format independent way.

SCE
See service creation environment (SCE).

service creation environment (SCE)
A set of software tools used to develop, test, and debug speech applications. Orchestration Designer is an SCE.

servlet
A small program that runs on a server, often Java-based.

servlet engine
A program that coordinates the overall operation and integration of a number of servlets. In the context of Orchestration Designer, the supported servlet engines are Apache Jakarta Tomcat and IBM WebSphere/WebSphere Express.

Session Initiation Protocol (SIP)
A signaling protocol for the Internet that makes it possible to set up conferencing, telephony, events notification, and instant messaging. Within a VoIP framework, it initiates call setup, routing, authentication, to endpoints within an IP domain.

SIP
See Session Initiation Protocol (SIP).
<table>
<thead>
<tr>
<th>Term</th>
<th>Definition/Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>speech user interface (SUI)</td>
<td>Any software interface in which the user interacts with the system using speech commands and audio prompts.</td>
</tr>
<tr>
<td>speech recognition</td>
<td>See automated speech recognition (ASR).</td>
</tr>
<tr>
<td>speech synthesis</td>
<td>See text-to-speech (TTS).</td>
</tr>
<tr>
<td>SQL</td>
<td>See Structured Query Language (SQL).</td>
</tr>
<tr>
<td>SSL</td>
<td>Secure Sockets Layer. A protocol for transmitting private data securely over the Internet. By convention, URLs that use SSL require a connection using the HTTPS protocol, rather than just HTTP.</td>
</tr>
<tr>
<td>SSML</td>
<td>Speech Synthesis Markup Language. A W3C standard designed to provide an XML-based markup language for assisting with the generation of synthetic speech in Web and other applications. The essential role of the markup language is to provide authors of synthesizable content a standard way to control aspects of speech such as pronunciation, volume, pitch, rate, and so forth, across different synthesis-capable platforms.</td>
</tr>
<tr>
<td>stacked notebook</td>
<td>See notebook.</td>
</tr>
<tr>
<td>Structured Query Language (SQL)</td>
<td>A standard interactive and programming language for getting data to and from a database.</td>
</tr>
<tr>
<td>SUI</td>
<td>See speech user interface (SUI).</td>
</tr>
<tr>
<td>tabbed notebook</td>
<td>See notebook.</td>
</tr>
<tr>
<td>TDD</td>
<td>See Telecommunications Display Device (TDD).</td>
</tr>
<tr>
<td>Telecommunications Display Device (TDD)</td>
<td>Sometimes designated as a teletypewriter (TTY) device, a telephone equipped with a keyboard and display, used by hearing-impaired or speech-impaired callers to send and receive typed messages.</td>
</tr>
<tr>
<td>telephone user interface (TUI)</td>
<td>Any software interface in which the user interacts with the system using a telephone or similar device.</td>
</tr>
<tr>
<td>teletypewriter (TTY) device</td>
<td>See Telecommunications Display Device (TDD).</td>
</tr>
<tr>
<td>text-to-speech (TTS)</td>
<td>Technology by which information in text format is rendered as audio output using a speech synthesis engine to simulate human speech.</td>
</tr>
<tr>
<td>TTS</td>
<td>See text-to-speech (TTS).</td>
</tr>
<tr>
<td>TTY</td>
<td>See Telecommunications Display Device (TDD).</td>
</tr>
<tr>
<td>TUI</td>
<td>See telephone user interface (TUI).</td>
</tr>
<tr>
<td>VoiceXML</td>
<td>(Sometimes presented as VXML) Voice eXtensible Markup Language.</td>
</tr>
</tbody>
</table>
A specification which provides for a user to interact with Internet-based resources using voice recognition technology. Instead of a typical Web browser that requires a combination of HTML, keyboard, and mouse device, VoiceXML relies on an Internet voice browser and/or telephone. Using VoiceXML, the user interacts with the Web “page” by listening to audio outputs (either pre-recorded or using a technology such as TTS) and by submitting input in the form of the user’s natural speaking voice and/or manual responses, such as telephone key presses.

**Web service**
A standardized way of offering Web-based applications or services. Because Web services are Web-based and standards-based applications, delivered over the Internet, Web services make it possible for organizations to communicate and share data that use different file formats and programming languages.

**workspace**
In Orchestration Designer, the area within the Editor view used to build the functionality for the selected editor. For example, in the Call Flow Editor, this is the space to the right of the palette, in which you place the nodes that represent application functions.

**WSDL**
Web Services Description Language.
An XML-formatted language used to describe a Web service’s capabilities.

**XML**
eXtensible Markup Language.
A specification for the presentation of Internet documents, one which expands on the capabilities of HTML. A pared down version of SGML (Standard Generalized Markup Language), XML makes it possible for designers to create their own customized tags, which in turn makes it possible to do things over the Internet that cannot be done using simple HTML.