PostgreSQL 2012-08-17 Security Update Release

Original Release Date: September 6, 2012
Last Revised: July 22, 2016
Number: ASA-2012-371
Risk Level: Medium
Advisory Version: 7.0
Advisory Status: Final

1. Overview:

The PostgreSQL Global Development Group has released security updates for all active branches of the PostgreSQL database system, including versions 9.1.5, 9.0.9, 8.4.13 and 8.3.20. This update patches security holes associated with libxml2 and libxslt, similar to those affecting other open source projects.

This security release fixes a vulnerability in the built-in XML functionality, and a vulnerability in the XSLT functionality supplied by the optional XML2 extension. Both vulnerabilities allow reading of arbitrary files by any authenticated database user, and the XSLT vulnerability allows writing files as well. The fixes cause limited backwards compatibility issues. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the names CVE-2012-3488 and CVE-2012-3489 to these issues.

More information about these vulnerabilities can be found in the release notes issued by PostgreSQL.org:

2. Avaya System Products with affected version(s) of PostgreSQL installed:

Product: Affected Version(s): Risk Level: Actions:
Avaya Aura® Application Enablement Services 5.2 thru 6.2 Low For 6.1 and earlier upgrade to 6.2 and install Linux Security Update Patch 1 as described in PSN003992u or upgrade to 6.3 or later.
For 6.2 install Linux Security Update Patch 1 as described in PSN003992u or upgrade to 6.3 or later.
Avaya Aura® Experience Portal 6.x Low Upgrade to 7.0 or later.
Avaya Meeting Exchange 6.2 thru 6.2 SP2 Medium Upgrade to 6.2 SP3 or later
Avaya Aura® Presence Services 6.x Low Upgrade to Aura Presence Services 7.0 or later. Further information about this version, as well as the overall Aura 7.0 release, is available on support.avaya.com.
Avaya Aura® Session Manager 6.2.x and earlier Low Upgrade to 6.3 or later.
Avaya Aura® System Manager 5.x, 6.1 thru 6.3.7 Medium Upgrade to 6.3.8 or later.
Avaya Voice Portal 5.x Low Upgrade to Experience Portal 7.0 or later.

Recommended Actions for System Products:
Avaya strongly recommends that customers follow networking and security best practices by implementing firewalls, ACLs, physical security or other appropriate access restrictions. Though Avaya believes such restrictions should always be in place, risk to Avaya products and the surrounding network from this potential vulnerability may be mitigated by ensuring these practices are implemented until such time as an Avaya provided product update or the recommended Avaya action is applied. Further restrictions as deemed necessary based on the customer's security policies may be required during this interim period, but customers should not modify the System Product operating system or application unless the change is approved by Avaya. Making changes that are not approved may void the Avaya product service contract.

Mitigating Factors:

When determining risk, Avaya takes into account many factors as outlined by Avaya's Security Vulnerability Classification Policy. The following table describes factors that mitigate the risk of specific vulnerabilities for affected Avaya products:

Vulnerability Mitigating Factors
CVE-2012-3488
CVE-2012-3489
These are a low risk to Application Enablement Services, Experience Portal, Presence Services, Session Manager and Voice Portal as the affected XML and XSLT functionality is not used by default.
These are a medium risk for Meeting Exchange and System Manager due to the potential for an authenticated database user to access files which they normally would not have acesss to, effectively a privilege escalation.

3. Additional Information:

Additional information may also be available via the Avaya support website and through your Avaya account representative. Please contact your Avaya product support representative, or dial 1-800-242-2121, with any questions.

4. Disclaimer:

ALL INFORMATION IS BELIEVED TO BE CORRECT AT THE TIME OF PUBLICATION AND IS PROVIDED "AS IS". AVAYA INC., ON BEHALF ITSELF AND ITS SUBSIDIARIES AND AFFILIATES (HEREINAFTER COLLECTIVELY REFERRED TO AS "AVAYA"), DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE AND FURTHERMORE, AVAYA MAKES NO REPRESENTATIONS OR WARRANTIES THAT THE STEPS RECOMMENDED WILL ELIMINATE SECURITY OR VIRUS THREATS TO CUSTOMERS' SYSTEMS. IN NO EVENT SHALL AVAYA BE LIABLE FOR ANY DAMAGES WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH THE INFORMATION OR RECOMMENDED ACTIONS PROVIDED HEREIN, INCLUDING DIRECT, INDIRECT, INCIDENTAL, STATUTORY, CONSEQUENTIAL DAMAGES, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF AVAYA HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

THE INFORMATION PROVIDED HERE DOES NOT AFFECT THE SUPPORT AGREEMENTS IN PLACE FOR AVAYA PRODUCTS. SUPPORT FOR AVAYA PRODUCTS CONTINUES TO BE EXECUTED AS PER EXISTING AGREEMENTS WITH AVAYA.

5. Revision History:

V 1.0 - September 6, 2012 - Initial Statement issued.
V 2.0 - May 31, 2013 - Updated AES and SM affected versions and actions.
V 3.0 - August 2, 2013 - Updated AES affected versions and actions and MX affected versions.
V 4.0 - January 8, 2014 - Updated EP and VP actions.
V 5.0 - February 4, 2015 - Updated SMGR affected versions and actions.
V 6.0 - September 9, 2015 - Updated PS actions.
V 7.0 - July 22, 2016 - Updated Meeting Exchange affected versions and actions, and advisory status changed to Final.

Send information regarding any discovered security problems with Avaya products to either the contact noted in the product's documentation or securityalerts@avaya.com.

© 2012 Avaya Inc. All Rights Reserved. All trademarks identifying Avaya products by the ® or ™ are registered trademarks or trademarks, respectively, of Avaya Inc. All other trademarks are the property of their respective owners.