Avaya 2050 IP Softphone User Guide

Avaya Communication Server 1000

Document Status: Standard
Document Version: 05.06
Part Code: NN43119-101
Date: June 2014
Certain software programs or portions thereof included in the Product may contain software distributed under third party
Third Party Components

agreements ("Third Party Components"), which may contain terms that expand or limit rights to use certain portions of the
reproduction, transmission, dissemination, storage, and or use without the express written consent of Avaya can be a criminal,

Avaya provides a limited warranty on this product. Refer to your sales agreement to establish the terms of the limited warranty.
In addition, Avaya’s standard warranty language, as well as information regarding support for this product, while under
warranty, is available to Avaya customers and other parties through the Avaya Support Web site: http://www.avaya.com/
support

Please note that if you acquired the product from an authorized reseller, the warranty is provided to you by said reseller and not
by Avaya.

Warranty
Avaya provides a limited warranty on this product. Refer to your sales agreement to establish the terms of the limited warranty.
In addition, Avaya’s standard warranty language, as well as information regarding support for this product, while under
warranty, is available to Avaya customers and other parties through the Avaya Support Web site: http://www.avaya.com/
support

The trademarks, logos and service marks ("Marks") displayed in this site, the documentation(s) and product(s) provided by
Avaya are the registered or unregistered Marks of Avaya, its affiliates, or other third parties. Users are not permitted to use
such Marks without prior written consent from Avaya or such third party which may own the Mark. Nothing contained in this
site, the documentation(s) and product(s) should be construed as granting, by implication, estoppel, or otherwise, any license
to or in and to the Marks without the express written permission of Avaya or the applicable third party. Avaya is a registered
trademark of Avaya Inc. All non-Avaya trademarks are the property of their respective owners.

Documentation disclaimer
Avaya shall not be responsible for any modifications, additions, or deletions to the original published version of this
documentation unless such modifications, additions, or deletions were performed by Avaya. End User agree to indemnify and
hold harmless Avaya, Avaya’s agents, servants and employees against all claims, lawsuits, demands and judgments arising out
of, or in connection with, subsequent modifications, additions or deletions to this documentation, to the extent made by End
User.

License
Except where expressly stated otherwise, no use should be made of the Documentation(s) and Product(s) provided by Avaya.
All content in this documentation(s) and the product(s) provided by Avaya including the selection, arrangement and design of
the content is owned either by Avaya or its licensors and is protected by copyright and other intellectual property laws
including the sui generis rights relating to the protection of databases. You may not modify, copy, reproduce, republish, upload,
post, transmit or distribute in any way any content, in whole or in part, including any code and software. Unauthorized
including the sui generis rights relating to the protection of databases. You may not modify, copy, reproduce, republish, upload,
post, transmit or distribute in any way any content, in whole or in part, including any code and software. Unauthorized
reproduction, transmission, dissemination, storage, and or use without the express written consent of Avaya can be a criminal,
as well as a civil offense under the applicable law.

Third Party Components
Certain software programs or portions thereof included in the Product may contain software distributed under third party
agreements ("Third Party Components"), which may contain terms that expand or limit rights to use certain portions of the
Product ("Third Party Terms"). Information regarding distributed Linux OS source code (for those Products that have
distributed the Linux OS source code), and identifying the copyright holders of the Third Party Components and the Third
Party Terms that apply to them is available on the Avaya Support Web site: http://support.avaya.com/Copyright.

Copyright

Trademarks

The trademarks, logos and service marks ("Marks") displayed in this site, the documentation(s) and product(s) provided by
Avaya are the registered or unregistered Marks of Avaya, its affiliates, or other third parties. Users are not permitted to use
such Marks without prior written consent from Avaya or such third party which may own the Mark. Nothing contained in this
site, the documentation(s) and product(s) should be construed as granting, by implication, estoppel, or otherwise, any license
to or in and to the Marks without the express written permission of Avaya or the applicable third party. Avaya is a registered
trademark of Avaya Inc. All non-Avaya trademarks are the property of their respective owners.

Downloading documents
For the most current versions of documentation, see the Avaya Support. Web site: http://www.avaya.com/support

Contact Avaya Support
Avaya provides a telephone number for you to use to report problems or to ask questions about your product. The support
telephone number is 1-800-242-2121 in the United States. For additional support telephone numbers, see the Avaya Web site:
http://www.avaya.com/support

Terms and Conditions and Create a Binding Contract Between You and Avaya Inc. or the
Applicable Avaya Affiliate ("Avaya").

Carefully read and understand the following terms and conditions ("Terms and Conditions") which apply to your use of the
software program ("Software"). The Software is a proprietary product of Avaya Inc., an Avaya Affiliate ("Avaya")
(HEREINAFTER REFERRED TO INTERCHANGEABLY AS "YOU" AND "END USER"), AGREE TO THESE TERMS
YOURSELF AND THE ENTITY FOR WHOM YOU ARE INSTALLING, DOWNLOADING OR USING THE SOFTWARE
DOWNLOADING OR USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND ANYONE ELSE USING OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY INSTALLING,
DOWNLOADING OR USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND ANYONE ELSE USING OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY INSTALLING,
DOWNLOADING OR USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND ANYONE ELSE USING OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY INSTALLING,
DOWNLOADING OR USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND ANYONE ELSE USING OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY INSTALLING,
DOWNLOADING OR USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND ANYONE ELSE USING OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY INSTALLING,
DOWNLOADING OR USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND ANYONE ELSE USING OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY INSTALLING,
DOWNLOADING OR USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND ANYONE ELSE USING OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY INSTALLING,
DOWNLOADING OR USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND ANYONE ELSE USING OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY INSTALLING,
DOWNLOADING OR USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND ANYONE ELSE USING OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY INSTALLING,
DOWNLOADING OR USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND ANYONE ELSE USING OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY INSTALLING,
DOWNLOADING OR USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND ANYONE ELSE USING OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY INSTALLING,
DOWNLOADING OR USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND ANYONE ELSE USING OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY INSTALLING,
DOWNLOADING OR USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND ANYONE ELSE USING OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY INSTALLING,
DOWNLOADING OR USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND ANYONE ELSE USING OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY INSTALLING,
DOWNLOADING OR USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND ANYONE ELSE USING OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY INSTALLING,
DOWNLOADING OR USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND ANYONE ELSE USING OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY INSTALLING,
DOWNLOADING OR USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND ANYONE ELSE USING OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY INSTALLING,
DOWNLOADING OR USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND ANYONE ELSE USING OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY INSTALLING,
Revision history

June 2014

Standard 05.06. This document is up-issued to include limitation for display when an ACD call is presented to a 2050PC.

April 2012

Standard 05.05. This document is up-issued to include information regarding answering an incoming call using the Enter key.

March 2012

Standard 05.04. This document is up-issued to support Avaya 2050 Softphone Release 4.3 reflecting support for 64-bit on Windows 7 and Vista operating systems.

August 2011

Standard 05.03. This document is up-issued to support Communication Server 1000 Release 7.5.

June 2011

Standard 05.02. This document is up-issued to support Avaya 2050 Softphone Release 4.0.

October 2010

Standard 05.01. This document is up-issued to support Avaya 2050 Softphone Release 4.0.

June 2010

Standard 04.01. This document is up-issued to support Communication Server Release 7.0.
June 2009

Standard 03.02. This document is up-issued to support IP Softphone 2050 Release 3.3 with Communication Server Release 5.5 and later.

May 2009

Standard 03.01. This document is up-issued to support Communication Server Release 6.0.

July 2008

Standard 02.03. This document is up-issued to support IP Softphone 2050 Release 3.1.

February 2008

Standard 02.02. This document is up-issued to add information to the “USB Headset Adapter features appear dimmed” section. And to add information on using the Reset button in the “Profiles” section.

December 2007

Standard 02.01. This document is up-issued to support IP Softphone 2050 Release 3.0.

July 2007

Standard 01.02. This document is up-issued to update Input Modes.

May 2007

Standard 01.01. This document is issued to support Communication Server 1000 Release 5.0. This document contains information previously contained in the following legacy document, now retired: IP Softphone 2050 User Guide (NN-10300-054).
June 2006

Standard 4.00. This document is up-issued to reflect additional information about reserved keyboard keys.

March 2006

Standard 3.00. This document is up-issued to support Nortel Communication Server 1000 Release 4.5, for the IP Softphone 2050 Version 2.

August 2005

Standard 2.00. This document is up-issued to support Nortel Communication Server 1000 Release 4.5.

March 2005

Standard 1.00. This is the first issue of the document after removing MVC 2050 content.
GNU GENERAL PUBLIC LICENSE

Version 2, June 1991
Copyright (C) 1989, 1991 Free Software Foundation, Inc.
59 Temple Place - Suite 330, Boston, MA 02111-1307, USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but
changing it is not allowed.

Preamble

The licenses for most software are designed to take away your freedom to share and
change it. By contrast, the GNU General Public License is intended to guarantee your
freedom to share and change free software--to make sure the software is free for all its
users. This General Public License applies to most of the Free Software Foundation's
software and to any other program whose authors commit to using it. (Some other Free
Software Foundation software is covered by the GNU Library General Public License
instead.) You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public
Licenses are designed to make sure that you have the freedom to distribute copies of free
software (and charge for this service if you wish), that you receive source code or can get it
if you want it, that you can change the software or use pieces of it in new free programs; and
that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these
rights or to ask you to surrender the rights. These restrictions translate to certain
responsibilities for you if you distribute copies of the software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must
give the recipients all the rights that you have. You must make sure that they, too, receive or
can get the source code. And you must show them these terms so they know their rights.

We protect your rights with two steps: (1) copyright the software, and (2) offer you this
license which gives you legal permission to copy, distribute and/or modify the software.

Also, for each author's protection and ours, we want to make certain that everyone
understands that there is no warranty for this free software. If the software is modified by
someone else and passed on, we want its recipients to know that what they have is not the
original, so that any problems introduced by others will not reflect on the original authors'
reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the
danger that redistributors of a free program will individually obtain patent licenses, in effect
making the program proprietary. To prevent this, we have made it clear that any patent must
be licensed for everyone's free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.
TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0. This License applies to any program or other work which contains a notice placed by the copyright holder saying it may be distributed under the terms of this General Public License. The "Program", below, refers to any such program or work, and a "work based on the Program" means either the Program or any derivative work under copyright law: that is to say, a work containing the Program or a portion of it, either verbatim or with modifications and/or translated into another language. (Hereinafter, translation is included without limitation in the term "modification"). Each licensee is addressed as "you".

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running the Program is not restricted, and the output from the Program is covered only if its contents constitute a work based on the Program (independent of having been made by running the Program). Whether that is true depends on what the Program does.

1. You may copy and distribute verbatim copies of the Program's source code as you receive it, in any medium, provided that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and give any other recipients of the Program a copy of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program, and copy and distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:

   a. You must cause the modified files to carry prominent notices stating that you changed the files and the date of any change.

   b. You must cause any work that you distribute or publish, that in whole or in part contains or is derived from the Program or any part thereof, to be licensed as a whole at no charge to all third parties under the terms of this License.

   c. If the modified program normally reads commands interactively when run, you must cause it, when started running for such interactive use in the most ordinary way, to print or display an announcement including an appropriate copyright notice and a notice that there is no warranty (or else, saying that you provide a warranty) and that users may redistribute the program under these conditions, and telling the user how to view a copy of this License. (Exception: if the Program itself is interactive but does not normally print such an announcement, your work based on the Program is not required to print an announcement.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Program, and can be reasonably considered independent and separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as separate works. But when you distribute the same sections as part of a whole which is a work based on the Program, the distribution of the
whole must be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to control the distribution of derivative or collective works based on the Program.

In addition, mere aggregation of another work not based on the Program with the Program (or with a work based on the Program) on a volume of a storage or distribution medium does not bring the other work under the scope of this License.

3. You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form under the terms of Sections 1 and 2 above provided that you also do one of the following:

   a. Accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

   b. Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than your cost of physically performing source distribution, a complete machine-readable copy of the corresponding source code, to be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

   c. Accompany it with the information you received as to the offer to distribute corresponding source code. (This alternative is allowed only for noncommercial distribution and only if you received the program in object code or executable form with such an offer, in accord with Subsection b above.)

The source code for a work means the preferred form of the work for making modifications to it. For an executable work, complete source code means all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation of the executable. However, as a special exception, the source code distributed need not include anything that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a designated place, then offering equivalent access to copy the source code from the same place counts as distribution of the source code, even though third parties are not compelled to copy the source along with the object code.

4. You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License. Any attempt otherwise to copy, modify, sublicense or distribute the Program is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

5. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the Program or its derivative
works. These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the Program (or any work based on the Program), you indicate your acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Program or works based on it.

6. Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a license from the original licensor to copy, distribute or modify the Program subject to these terms and conditions. You may not impose any further restrictions on the recipients' exercise of the rights granted herein. You are not responsible for enforcing compliance by third parties to this License.

7. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the conditions of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a consequence you may not distribute the Program at all. For example, if a patent license would not permit royalty-free redistribution of the Program by all those who receive copies directly or indirectly through you, then the only way you could satisfy both it and this License would be to refrain entirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to apply and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution system, which is implemented by public license practices. Many people have made generous contributions to the wide range of software distributed through that system in reliance on consistent application of that system; it is up to the author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

8. If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted interfaces, the original copyright holder who places the Program under this License may add an explicit geographical distribution limitation excluding those countries, so that distribution is permitted only in or among countries not thus excluded. In such case, this License incorporates the limitation as if written in the body of this License.

9. The Free Software Foundation may publish revised and/or new versions of the General Public License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Program specifies a version number of this License which applies to it and "any later version", you have the option of following the terms and conditions either of that version or of any later version published by
the Free Software Foundation. If the Program does not specify a version number of this License, you may choose any version ever published by the Free Software Foundation.

10. If you wish to incorporate parts of the Program into other free programs whose distribution conditions are different, write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of preserving the free status of all derivatives of our free software and of promoting the sharing and reuse of software generally.

NO WARRANTY

11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

How to Apply These Terms to Your New Programs

If you develop a new program, and you want it to be of the greatest possible use to the public, the best way to achieve this is to make it free software which everyone can redistribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each source file to most effectively convey the exclusion of warranty; and each file should have at least the "copyright" line and a pointer to where the full notice is found; and one line to give the program’s name and an idea of what it does.

Copyright (C) yyyy name of author
This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.

You should have received a copy of the GNU General Public License along with this program; if not, write to the Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it starts in an interactive mode:

Gnomovision version 69, Copyright (C) year name of author

Gnomovision comes with ABSOLUTELY NO WARRANTY; for details type `show w'. This is free software, and you are welcome to redistribute it under certain conditions; type `show c' for details.

The hypothetical commands `show w' and `show c' should show the appropriate parts of the General Public License. Of course, the commands you use may be called something other than `show w' and `show c'; they could even be mouse-clicks or menu items--whatever suits your program.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a "copyright disclaimer" for the program, if necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest in the program `Gnomovision' (which makes passes at compilers) written by James Hacker.

signature of Ty Coon, 1 April 1989
Ty Coon, President of Vice

This General Public License does not permit incorporating your program into proprietary programs. If your program is a subroutine library, you may consider it more useful to permit linking proprietary applications with the library. If this is what you want to do, use the GNU Library General Public License instead of this License.

MAD

This product contains module MAD, which is distributed in accordance with the terms of the GNU General Public License version 2, provided below.

This product is licensed as described in “GNU GENERAL PUBLIC LICENSE” above.
Contents

Avaya 2050 IP Softphone Overview .......................... 17
New features and support ........................................ 17
Features .......................................................... 17
Components ....................................................... 19

Avaya 2050 IP Softphone Call Control window .......... 21
Accessibility Interface ............................................ 21
Call Control window .............................................. 22
Accessibility Interface ............................................ 23
Call Control window elements and functions ............. 24
Hot keys .......................................................... 27
System tray icon and menu ...................................... 28

Avaya 2050 IP Softphone Directories ......................... 29
Local Directory .................................................... 29
Avaya Communication Server 1000 Directory ............... 30

Installing and setting up the Avaya 2050 IP Softphone ... 34
System requirements .............................................. 34
Installing the Avaya 2050 IP Softphone ....................... 35

Managing contacts from the Local Directory ............... 36
Adding contacts to a Local Directory ......................... 36
Editing contacts in the Local Directory ....................... 37
Deleting contacts from the Local Directory .................. 37
Finding contacts in the Local Directory ....................... 38
Filtering a Local Directory ..................................... 39
Dialing from the Local Directory ............................... 39
Managing Groups in the Shortcut Bar ........................................ 40
Using the Properties dialog box ............................................. 41
Linking to external directories ............................................. 42

Managing contacts from the Avaya CS 1000 Directory .... 47
Adding contacts to the Personal Directory ............................ 47
Editing CS 1000 Directory contacts ...................................... 48
Deleting CS 1000 Directory contacts .................................... 49
Finding CS 1000 Directory contacts ...................................... 49
Dialing from the Personal Directory ...................................... 49
Dialing from the Redial List ............................................... 50
Dialing from the Callers List ................................................ 50

Managing Avaya 2050 IP Softphone calls ......................... 51
Making telephone calls .................................................. 51
Answering telephone calls ............................................... 52
Incoming Call Notification ............................................... 52
Holding and retrieving telephone calls ............................. 53
Using Record On Demand key ........................................ 53
Hanging up telephone calls ............................................. 55
Support for TAPI applications .......................................... 55
Viewing active status .................................................. 56

Avaya 2050 IP Softphone Expansion Module ................. 58
Using the Expansion Module ........................................... 59
Working with Groups .................................................. 59

Graphical External Application Server ......................... 61
Configuring the GXAS plugin ........................................ 61
Starting the GXAS plugin ............................................... 61
Selecting a GXAS application ........................................... 61
Using the session window ........................................... 62

**Avaya 2050 IP Softphone USB Headset Adapter .......... 63**
Answering calls with the USB Headset Adapter ............ 65
Hanging up calls with the USB Headset Adapter .......... 65
Adjusting the volume with the USB Headset Adapter ...... 65
Muting a call ............................................................... 66
Using the Smart Functions menu ................................. 66
Customizing the Smart Functions menu ...................... 67
Custom Functions for Smart Functions menu ................ 67

**Avaya 2050 IP Softphone macros ......................... 70**
Entering a macro .......................................................... 70
Deleting a macro ......................................................... 71
Playing a macro ........................................................... 71

**Avaya 2050 IP Softphone menu commands ............. 72**
Call Control window menu command ......................... 72

**Avaya 2050 IP Softphone Settings ..................... 76**
Opening the Settings window ...................................... 76
Using the Settings window .......................................... 77
Profiles ................................................................. 78
Server ................................................................. 82
License Servers ......................................................... 84
Theme ................................................................. 85
Features ............................................................... 85
Macros ................................................................. 86
Audio ................................................................. 86
Sound Devices ......................................................... 87
Hardware ID ............................................................ 88
Advanced Audio ......................................................... 90
Listener IP .............................................................. 91
Notifications .......................................................... 91
Hot Keys ................................................................. 92
Text Replacements ..................................................... 92
Lamp Sounds .......................................................... 93
Key Type ................................................................. 94
Language ................................................................. 95
Expansion Module ..................................................... 95
Personal Call Recording ............................................... 96
Plantronics USB Bluetooth Headset ................................. 97
USB Headset ........................................................... 97
About ................................................................. 100

Accessibility Interface ................................................. 101
Control groups ......................................................... 101
Accessibility Interface Menu ....................................... 102
Navigating Control Groups and Menu Commands .......... 102
Using hot keys ......................................................... 104
Limitations of Accessibility Interface .......................... 104

Configuring Avaya CS 1000 Directory user preferences 105
Choosing the language .............................................. 105
Configuring the date and time ................................... 106
Enabling the Call Timer ........................................... 106
Configuring Call Log options .................................... 107
Using Password Administration .................................. 110

Avaya 2050 IP Softphone Diagnostics ......................... 113
Overview ............................................................. 113
Using the Avaya 2050 IP Softphone diagnostics  . . . . . . . . . 113

Troubleshooting the Avaya 2050 IP Softphone  . . . . . . . . 115

Connectivity problems .................................................. 115

Audio problems .......................................................... 120

Reset conditions .......................................................... 123

USB Headset problems .................................................. 124

TAPI problems ............................................................. 127

Appendix A: Quick reference  . . . . . . . . . . . . . . . . . . . 131

Index ................................................................. 137
Avaya 2050 IP Softphone Overview

The Avaya 2050 IP Softphone is a business telephone application that you can use to make and take calls over your computer. Using a headset or handset connected to your PC, you control calls with a click of the mouse pointer, from your PC keyboard, or from the USB Audio Adapter.

Designed to work with IP-based phone systems, the Avaya 2050 IP Softphone provides Voice over IP (VoIP) services using a telephony server and your Local Area Network (LAN) or Wide Area Network (WAN).

The server that supports your Avaya 2050 IP Softphone determines the features you can access, such as Call Conference, Call Transfer, and Call Forward.

New features and support

Avaya 2050 IP Softphone Release 4.3 introduces support for the following:

- Windows Vista (64 bit). See “System requirements” on page 34
- Windows 7. See “System requirements” on page 34.
- Secure Call Recording. See “Audio” on page 86.

Features

The Avaya 2050 IP Softphone supports the following features:

- Twelve user-defined feature keys: six Programmable Line (DN)/Feature Keys (self-labeled) and six lines/features accessed by pressing the shift key
- Four soft keys that provide access to a maximum of 10 features
- Four-line display
- Directory capabilities stored locally on your PC or linked to external directories, such as Lightweight Directory Access Protocol (LDAP),
Microsoft Outlook, and Windows Address Book (WAB) contact management software

• Avaya Communication Server 1000 (Avaya CS 1000) Directory features (Personal Directory, Redial List, Callers List, and Password Administration) stored on the application server for systems running Avaya CS 1000 Release 4.0 or later software

• One-click direct dialing from various windows and applications

• Support for TAPI (Telephony Application Programming Interface)

• Five specialized fixed keys:
  — Directory
  — Inbox (Message)
  — Shift (Outbox)
  — Services
  — Expand

• Dedicated call processing keys:
  — Hold
  — Goodbye
  — Answer
  — Volume
  — Mute
  — Navigation
  — Message Waiting

• User-selected ringer that lets the PC speakers or the headset ring for incoming calls

• Choice of the following interfaces:
  — 1100 series theme
  — Compact black and silver themes
  — Accessibility Interface for the visually impaired

• Programmable hot keys that allow single key access to user-definable features
• Supported languages include: Arabic, Chinese (Traditional and Simplified), Czech, Danish, Dutch, English, Finnish, French, German, Greek, Hebrew, Hungarian, Italian, Korean, Japanese, Latvian, Norwegian, Polish, Portuguese, Russian, Spanish, Swedish and Turkish.
• Two input modes: Numeric, Alphabetic
• Support for Bluetooth and standard USB headsets
• Expansion Module (EM)
• Graphical External Application Server (GXAS) capability
• Drag and drop dialing
• Macro functions available for programming long dialing patterns

Components

The Avaya 2050 IP Softphone supports six main components:
• “Call Control window” on page 19
• “Local Directory window” on page 20
• “Settings window” on page 20
• “System tray icon and menu” on page 20
• “Expansion Module” on page 20
• “i2050.exe application” on page 20

Call Control window

The Avaya 2050 IP Softphone Call Control window displays the line keys, feature buttons, and call display. Use this window to make and manage your telephone calls. You also use this window to access both your Local Directory and CS 1000 Directory features (Personal Directory, Application Server Administration, and Password Administration).

For more information about the Call Control window, see “Avaya 2050 IP Softphone Call Control window” on page 21.
Local Directory window

Use the Local Directory window to create, manage, and use a telephone directory stored on your local computer and to access external directories, such as LDAP, Outlook, and WAB.

For more information about the Local Directory, see “Local Directory” on page 29.

Settings window

Use the Settings window—a series of dialog boxes—to set up the various Avaya 2050 IP Softphone features.

For information about opening the Settings window, see “Avaya 2050 IP Softphone Settings” on page 76.

System tray icon and menu

You can right-click the Avaya 2050 IP Softphone system tray icon—located at the right side of the Windows taskbar at the bottom of your screen—to make and manage calls.

Expansion Module

Use the Expansion Module (EM) to display the status of pre-programmed lines for other IP Deskphones on the network.

For more information, see “Avaya 2050 IP Softphone Expansion Module” on page 58.

i2050.exe application

The i2050.exe application lets the Avaya 2050 IP Softphone communicate with the server. This process appears as long as the Avaya 2050 IP Softphone icon appears in the system tray.
Avaya 2050 IP Softphone Call Control window

The Avaya 2050 IP Softphone Call Control window supports the 1100 theme—designed to look and feel like the Avaya 1100 Series IP Deskphones—as well as an additional two compact themes, available in black and silver. The Avaya 2050 IP Softphone also supports an Accessibility Interface for visually impaired users.

To open the Avaya 2050 IP Softphone Call Control window:
1. From your desktop PC, select Start.
2. Select Programs.

Accessibility Interface

To open the Avaya 2050 IP Softphone Accessibility Interface from the Call Control window:
1. From your desktop PC, select Start > Programs > Avaya > Avaya 2050 IP Softphone > Avaya 2050 IP Softphone.
   The Call Control window appears.
2. Click the Menu button.
3. Select File > Settings > Theme.
4. Select Accessibility Interface.
   Note: If the Avaya 2050 IP Softphone is running, you must exit and restart for the change to the Accessibility Interface to take effect.
Call Control window

The Call Control window (see Figure 1 below and Figure 2 on page 23) includes the standard features that let you make and manage telephone calls.

For information about the elements of the Call Control window, see Table 1 on page 24.

Figure 1: Call Control Window—1100 series theme
Accessibility Interface

The Accessibility Interface works with JAWS® for Windows from Freedom Scientific—screen reading software that lets visually impaired users access the full range of Avaya 2050 IP Softphone features. The Accessibility Interface has been tested on JAWS® Version 5.0. The screen is divided into four groups of controls: Display, Line and Feature, Date and Time, and Indicators.

Menu Command options in the Accessibility Interface match those in the standard Call Control window.

High Contrast Mode is a Microsoft Windows feature that increases legibility for visibly impaired users by increasing screen contrast. Activate this feature by navigating to Start > Control Panel > Accessibility Options > Display and selecting the High Contrast checkbox.

For more information about navigating the Accessibility control groups and Menu Command options, see “Accessibility Interface” on page 101.
Call Control window elements and functions

Table 1 describes the elements and functions of the Call Control window.

Table 1: Avaya 2050 IP Softphone components and functions (Part 1 of 3)

<table>
<thead>
<tr>
<th>Element</th>
<th>Function</th>
</tr>
</thead>
</table>
| Primary display| To provide call information (such as Caller ID) and instructions for using certain soft key features.  
When idling, the telephone displays only the date and time. |
| Soft keys      | To access server-definable features, such as Transfer (for connecting calls to other people), Conference (for group calls), and so on.  
To select a feature, click one of the four available soft-labelled soft keys, and then follow the instructions on the display.  
Available soft key features vary, depending on:  
• Your current task: the features available at any time depend on your current call activity.  
• Server support: Avaya 2050 IP Softphone functionality depends on communication server configuration.  
  Note: To view additional features, click the More soft key. |
| Call/Answer    | To make or answer a call.                                                   |
| Copy           | To copy contact information from Avaya Communication Server 1000 Directory features. |
| Quit           | To quit a network service or feature.                                      |
Table 1: Avaya 2050 IP Softphone components and functions (Part 2 of 3)

<table>
<thead>
<tr>
<th>Element</th>
<th>Function</th>
</tr>
</thead>
</table>
| Navigation arrows | To scroll through menus and lists in the display area.  
Use the Send/Enter key at the center of the navigation cluster to confirm menu selection (1100 series theme only). |
| Volume         | To increase or decrease the volume.                                                                                                         |
| decrease       |                                                                                                                                               |
| increase       |                                                                                                                                               |
| Headset        | To answer and make calls using the headset.                                                                                                   |
| Handsfree      | To answer and make calls using the handsfree speaker.                                                                                         |
| Mute           | Mute key functionality is enabled or disabled by your system administrator. Contact your system administrator to determine if your Mute key is enabled.  
If Mute key is enabled, click the Mute key to mute the headset and listen to the receiving party without transmitting. Click the Mute key again to return to two-way conversation.  
Note: If Mute key is not enabled, clicking the Mute key places the call on hold. Click the Mute key again to restore the active call or click the line key to restore the active call. You cannot retrieve this call from hold by clicking the Hold key.  
The handset display indicates the Mute status (Mute On or Mute Off). |
Table 1: Avaya 2050 IP Softphone components and functions (Part 3 of 3)

<table>
<thead>
<tr>
<th>Element</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>📞 Hold</td>
<td>To place an active call on hold.</td>
</tr>
<tr>
<td></td>
<td>The feature key label for the line on hold displays a flashing icon to indicate that the call is on hold.</td>
</tr>
<tr>
<td></td>
<td>Return to the call by clicking the Line button of the call on hold.</td>
</tr>
<tr>
<td>📞 Release</td>
<td>To terminate an active call.</td>
</tr>
<tr>
<td>Line keys</td>
<td>To access one of six programmable <strong>Line</strong> keys. These keys can represent line appearances, DNs, or features.</td>
</tr>
<tr>
<td></td>
<td>The communication server provides the labels that appear on these keys.</td>
</tr>
<tr>
<td>Dialpad</td>
<td>To dial a telephone number. Use your mouse pointer to click the numbers you want to enter.</td>
</tr>
<tr>
<td>📚 Directory</td>
<td>To access Avaya CS 1000 Directory features.</td>
</tr>
<tr>
<td></td>
<td>Depending on how the system administrator sets up this service, use this button to access Personal Directory or other server-based directory services.</td>
</tr>
<tr>
<td></td>
<td>You can use CS 1000 Directory features to place a call. The call is placed on your prime line, unless you select a different line.</td>
</tr>
<tr>
<td>📞 Services</td>
<td>To access a list of network services.</td>
</tr>
<tr>
<td>📞 Expand</td>
<td>To access Graphical External Application Server (GXAS) applications.</td>
</tr>
<tr>
<td>📨 Msg/Inbox</td>
<td>To access voice mail applications.</td>
</tr>
<tr>
<td>📞 Shift/Outbox</td>
<td>To access voice mail applications and toggle between feature key displays.</td>
</tr>
</tbody>
</table>
Hot keys

You can assign keyboard hot keys to access the full range of Call Control window functions and menu options.

- “Adding a hot key” on page 27
- “Removing a hot key” on page 28

Adding a hot key

To add a new hot key:

1. Open the Settings window. For information about opening the Settings window, see “Opening the Settings window” on page 76.
2. Select Hot Keys.
3. Choose the feature group that you want to access: Buttons, Menu, or Select Fields (Accessibility Interface only).
4. From the Items list, select the feature to which you want to assign a hot key.
5. Under Press a new shortcut key, enter the key combination—“Alt + Ctrl + V”, for example—that you want as your hot key.
6. Click Assign.

Note: If the key combination is already taken, the previously assigned feature appears in the Shortcut Key Currently Used By text box.

Note: To activate an item using the Select Fields feature group, click Enter.

To assign a hot key, you can enter any keyboard key combination except for the following:

- A to Z
- Shift-A to Shift-Z
- Alt-A to Alt-Z
- 0 to 9
- Alt+0 to Alt+9
- Asterisk (*)
• Number sign (#)
• Up, down, left, and right arrow keys
• Shift+Up, Shift+Down
• PageUp, PageDn
• Alt+F1 to Alt+F12
• F1, Shift+F1,Ctrl+F1, Ctrl+Alt+F1, Ctrl+Alt+Shift+F1
• Space bar

Removing a hot key

To remove a hot key:

1. Open the Settings window. For information about opening the Settings window, see “Opening the Settings window” on page 76.

2. Select Hot Keys.

3. Choose the feature group that you want to access: Buttons, Menu, or Fields (Accessibility Interface only).

4. From the Items list, select the feature from which you want to remove a hot key.

5. Click Remove.

System tray icon and menu

Use the Avaya 2050 IP Softphone system tray icon menu to manage phone calls and messages without opening the Call Control window.

To access the menu, right-click the Avaya 2050 IP Softphone icon in the Windows taskbar system tray. From this menu, you can make, answer, and manage your calls, as well as access macros and features.
Avaya 2050 IP Softphone Directories

The Avaya 2050 IP Softphone uses the following directories for maintaining and accessing contacts:

- “Local Directory” on page 29—stored on your local drive
- “Avaya Communication Server 1000 Directory” on page 30—stored on your server

Local Directory

The Avaya 2050 IP Softphone Local Directory lets you store as many phone directories on your computer as you need. You can use the Shortcut Bar to organize your contacts into smaller groups of shortcut links.

You can use the Local Directory to:

- Link to external directories such as Outlook, Act, and LDAP.
- Dial from external directories.
- Save contacts locally to your computer.
- Filter long directories so they are easier to use.

Note: Do not confuse the Avaya 2050 IP Softphone Local Directory with the Avaya Communication Server 1000 Directory (accessible by clicking [Directory] on the toolbar).

The Shortcut Bar on the left side of the window lists all groups of shortcut links, including:

- Local Directory—main directory contacts
- Quick Dials—a built-in group for selecting shortcuts to contacts

Opening a Local Directory from the Call Control window

To open a Local Directory:

1. Click the Menu button and select View > Local Directory.
2. Select one of the following:
— On the Shortcut Bar, select **Directories > Local Directory**.
— On the menu, select **View > Local Directory**.

**Note:** To open a previously accessed Local Directory, select **File > Recent Local Directories**, and then select the Local Directory you want to open.

For information about managing contacts and making calls from the Local Directory, see “Managing contacts from the Local Directory” on page 36.

**Avaya Communication Server 1000 Directory**

The Avaya CS 1000 Directory maintains contact information and server-supported features in a remote, central database called the Application Server. Accessible from the Avaya 2050 IP Softphone Call Control window, the CS 1000 Directory supports the following features:

- Personal Directory
- Redial List
- Callers List

**Note:** Redial List and Callers List are Call Log features. The system generates the content of the Redial List and the Callers List during call processing. You can delete individual entries or the entire directory in the Redial List and the Callers List, but you cannot add an entry or permanently change the content of an entry.

**Personal Directory**

You control your own Personal Directory. Use the Personal Directory to create and store up to 100 entries. You can edit, copy, or delete individual entries, or delete the entire list. You can also copy entries from other applications to the Personal Directory (or from the Personal Directory to other applications).

An entry can contain any of the following:

- Last name (up to 24 characters)
- First name (up to 24 characters)
• DN at work (up to 31 characters)
• DN at home (up to 31 characters)
• Cell phone (up to 31 characters)
• Pager (up to 31 characters)

**Callers List**

The Callers List can contain up to 100 entries. When the list is full, the system overwrites the oldest entry.

In Directory View mode, the caller's name displays along with the Callers List entry count. Entries in the Callers List are sorted by Call Log time. The first entry you see is the first new entry. If you press the down navigation key, more new items in the Callers List display. If you press the up navigation key, older items in the list display.

The following list describes the contents of a Callers List entry:
• Last name (24 characters)
• First name (24 characters)
• DN (31 characters)
• Time/date
• Number of calls

*Note:* If the caller name is not defined, then only the telephone number is displayed.

**Redial List**

The Redial List can contain up to 20 entries. When the list is full, the system overwrites the oldest entry.

In Directory View mode, the number you dialed displays. Redial List content updates when you dial out. Entries in the Redial List are sorted by Call Log time. The oldest entry appears at the beginning of the list. To access the oldest entry, click the down navigation key. To access the newest entry, click the up navigation key.
A Redial List entry can contain any of the following:

- User name (up to 24 characters)
- DN (up to 31 characters)
- Time of the last call occurrence
- Time/date

**Note:** If the caller name is not defined, then only the telephone number is displayed.

**Opening CS 1000 Directory features**

To open the Personal Directory, Redial List, or Callers List:

1. From the Call Control window, click **Directory**.
2. Scroll and select an item from the following list:
   - **Personal Directory**
   - **Callers List**
   - **Redial List**
   - **Password Administration**

The Personal Directory, Redial List, and Callers List features have a one-minute time-out control period. If the application rests idle for one minute during any of the operations, the directory feature closes and your Avaya 2050 IP Softphone returns to the idle state.

For information about managing contacts or making calls from the CS1000 Directory, see “Managing contacts from the Avaya CS 1000 Directory” on page 47.

**Password Administration**

For information about using and setting Password Administration, see “Using Password Administration” on page 110.
Application Server Administration

Using the Application Server Administration feature, your system administrator can:

• Back up and restore the database
• Manage user profiles

For information about setting user preferences for CS 1000 Directory features, see “Configuring Avaya CS 1000 Directory user preferences” on page 105.
Installing and setting up the Avaya 2050 IP Softphone

The following describes the requirements for installing and setting up the Avaya 2050 IP Softphone.

System requirements

To use the Avaya 2050 IP Softphone, you require:

- Pentium-compatible CPU (1 GHz or higher)
- 256 Mbytes RAM or higher for Windows XP, Windows Vista, and Windows 7
- 55 Mbytes or higher free hard drive space (all languages)
- 800X600 or higher resolution monitor (16-bit color)
- Universal Serial Bus (USB) port (version 1.1 or 2.0)

Supported operating systems

To use the Avaya 2050 IP Softphone, you must have one of the following operating systems:

- Windows XP (32 bit)
- Windows Vista (32 bit and 64 bit)
- Windows 7 (32 bit and 64 bit)

*Note:* Windows 2000 and Windows XP (64 bit) are not supported.

Avaya USB Audio Kit

The USB Audio Kit lets you hear and speak with your callers. To ensure proper Avaya 2050 IP Softphone functionality, use only the following Avaya-supported (or compatible) USB audio kits:

- Avaya Enhanced USB Adapter (desktop)
- Avaya Mobile USB Adapter (mobile)
- Algo Analog Terminal Adapter (compatible)
The Avaya USB Audio Kit includes:

- USB Headset Adapter (desktop or mobile)
- Installation Guide (English and French only)
- USB cord

Some kits also include a headset.

The Algo Analog Terminal Adapter (ATA) is a USB adapter that lets you use analog terminals instead of headsets. With an Algo ATA users can, for example, use a cordless handset with their Avaya 2050 IP Softphone.

**Note:** The Avaya 2050 IP Softphone is compatible with the Algo ATA. For support, see www.algosolutions.com.

### Installing the Avaya 2050 IP Softphone

For information about installing the Avaya 2050 IP Softphone, see *Avaya IP Phones Fundamentals* (NN43001-368) or consult your system administrator.

### Client Licensing

All new and upgrade installations of the Avaya 2050 IP Softphone software require a valid license for product activation.

**Note:** There is a 30-day evaluation period during which you can use the software without a license. Once the 30-day evaluation period has expired, the software will no longer work until a valid license code is obtained.

Consult your system administrator for details.
Managing contacts from the Local Directory

You can use the following options to manage contacts in the Local Directory:

- “Adding contacts to a Local Directory” on page 36
- “Editing contacts in the Local Directory” on page 37
- “Deleting contacts from the Local Directory” on page 37
- “Finding contacts in the Local Directory” on page 38
- “Filtering a Local Directory” on page 39
- “Dialing from the Local Directory” on page 39
- “Managing Groups in the Shortcut Bar” on page 40
- “Using the Properties dialog box” on page 41

Adding contacts to a Local Directory

You can add contacts to a Local Directory list, or insert contacts into any group of shortcut links in the Shortcut Bar.

To add a contact to the Local Directory list:

1. Open the Local Directory. For details, see “Opening a Local Directory from the Call Control window” on page 29.
2. Select Edit > New Contact, or click New Contact on the toolbar. The Properties dialog box appears.
3. Under the General tab (selected by default), enter the contact’s name, address, telephone numbers, and other personal information.
4. Select the Details tab to enter any of the following contact details: Department, Office, or Assistant.
5. To enter miscellaneous information, select the Notes tab.
6. Select the Settings tab to define the default dialing number as Business, Home, or Mobile.
7. Click **OK**.

**Note:** For more information about entering information in the property fields, see “Using the Properties dialog box” on page 41.

To add a contact to a group:

1. In the Shortcut Bar, select the group of shortcut links to which you want to add a contact.
2. Select the contact you want to add, drag it to the Shortcut Bar, and then drop it under the selected group button.

**Note 1:** You cannot directly add contacts to an external directory from within the Local Directory.

**Note 2:** If the contents of an external directory change, you must first update that directory for the changes to show in the Local Directory. To update, right-click the imported directory and click **Refresh**.

## Editing contacts in the Local Directory

To edit contacts in the Local Directory:

1. Open the **Local Directory**. For details, see “Opening a Local Directory from the Call Control window” on page 29.
2. Using your mouse pointer, highlight the contact you want to edit.
3. Open **Properties** using one of the following methods:
   — Select **File > Properties**.
   — Click **Properties** on the toolbar.
   — Right-click the selection and choose **Properties** from the menu.
4. Select the tab you need and edit the information.
5. Click **OK**.

## Deleting contacts from the Local Directory

You can delete contacts from the Local Directory or remove contacts from a group of shortcut links.
To delete a contact from the Local Directory:

1. Open the **Local Directory**. For details, see “Opening a Local Directory from the Call Control window” on page 29.

2. Using your mouse pointer, select the contact you want to delete.

   **Note:** To delete a range of contacts, click the first contact in the range, and then shift-click the last contact in the range. The entire range highlights. You can also CTRL-click to select a number of contacts in different places.

3. Delete the contact by doing one of the following:
   - Select **Edit > Delete**.
   - Click [Delete](#) on the toolbar.
   - Right-click your selection and choose **Delete** from the menu.

4. To confirm the deletion, click **Yes**.

To remove a contact from a group of shortcut links:

1. On the **Shortcut Bar**, select the group of shortcut links from which you want to delete a contact.

2. Right-click the contact, and choose **Remove Item** from the menu.

---

**Finding contacts in the Local Directory**

You can search for contacts in a Local Directory by name.

To find a contact in one of your directories:

1. Open the **Local Directory**. For details, see “Opening a Local Directory from the Call Control window” on page 29.

2. Select or click either of the following:
   - Select **Edit > Find Contact**.
   - Click [Find Contact](#) on the toolbar.

   The Find Contact window appears.

3. Enter the name of the contact you want to find.
Managing contacts from the Local Directory

**Note:** Names in the directory are formatted as *last name, first name*. Use this format when searching for a contact.

4. Click **Find Now**.
   
   Search results display in the Find Contact window.

5. To stop a search, click **Stop**.

**Filtering a Local Directory**

The Avaya 2050 IP Softphone lets you filter a Local Directory, making it smaller and easier to manage. This feature is useful for dealing with large directories. By filtering a directory, you can reduce the number of names through which you must search.

To filter a directory:

1. Click **Filter** on the toolbar, or **Directory > Filter** from the menu.
   
   The **Filter** dialog box appears.

2. From the **Field** and **Condition** lists, choose your filter criteria.

3. Enter the values you want included in the filtered list. For example, if under the filter criteria **Field: Last Name, Condition: Starts With**, you enter **Value: C**, only contacts with a last name starting with C appear in the Local Directory.

4. To apply the filter, click **Add**.

**Dialing from the Local Directory**

To call a contact stored in the Local Directory:

1. Open the **Local Directory**. For details, see “Opening a Local Directory from the Call Control window” on page 29.

2. Find the contact you want to call. You can dial using any of the following options:
   
   — Double-click the phone number you want to dial.
   
   — Double-click the contact's name.
— Right-click the contact's entry, and then click the desired telephone number in the menu.
— To dial the default telephone number, click **Dial** on the toolbar.
— Click the arrow beside the **Dial** toolbar button, and then click the desired telephone number from the list.

**Managing Groups in the Shortcut Bar**

You can add, remove, or rename groups in the Shortcut Bar of your Local Directory.

To open a group of shortcut links and view its list of contacts, click the desired group from the Shortcut Bar.

To add a group to a Local Directory:
1. Right-click a blank area on the **Shortcut Bar**.
2. Select **Add New Group**.
   A blank group button with a blinking cursor appears at the bottom of the Shortcut Bar.
3. Enter the name you want for the group and press **Enter**.

To remove a group in a Local Directory:
1. Click open the group you want.
2. Right-click anywhere on or under the **Group** button and its list of contacts.
3. Select **Remove Group**.
4. At the “Delete? Are you sure?” prompt, click **Yes**.

To rename a group in a Local Directory:
1. Click open the group you want.
2. Right-click anywhere on or under the **Group** button and list of contacts.
3. Select **Rename Group**.
Managing contacts from the Local Directory

A cursor appears in the Group button.

4. Enter the new name you want the group to be called.

5. Press Enter.

Note: To view the list of contacts within a group, click the desired group in the Shortcut Bar.

Using the Properties dialog box

Use the Properties dialog box to enter or change contact information.

To open the Properties dialog box:

1. Open the Local Directory. For details, see “Opening a Local Directory from the Call Control window” on page 29.

2. Do one of the following:
   — Select Edit > New Contact.
   — Click New Contact on the toolbar.
   — Select a contact.
   — Select File > Properties.
   — Click Properties.

The Properties dialog box contains four tabs:

- “Properties — General tab” on page 42
- “Properties — Details tab” on page 42
- “Properties — Notes tab” on page 42
- “Properties — Settings tab” on page 42

All four tabs offer an Export button. Use this button to export contact information to a *.vcf file. You can import this file into e-mail or contact manager applications, or any other software applications that use the *.vcf file format.
Managing contacts from the Local Directory

Properties — General tab
Use this tab to store a contact’s name, address, e-mail address, company information, and telephone numbers. To create a contact record, enter the contact’s name and at least one telephone number. All other information is optional.

**Note:** To add a half-second delay in the dialing pattern, insert a comma in the telephone number, wherever you want the pause to occur. You can add as many pauses as required by inserting an equal number of commas.

Properties — Details tab
Use the Details tab to enter any of the following contact details:
- Department
- Office
- Assistant

Properties — Notes tab
Use this tab to record miscellaneous information about a contact. You can enter significant dates, recent orders, meeting locations, or any information you require when you call the contact.

Properties — Settings tab
Use this tab to set the default dialling number for the contact.
To set the **Default Dial**, click the desired option button: **Business**, **Home**, or **Mobile**.

To dial a contact’s non-default telephone number, right-click the contact and select any other telephone number that appears in the menu.

Linking to external directories
You can access the following external directories from the Local Directory window:
- Lightweight Directory Access Protocol (LDAP) directory
Managing contacts from the Local Directory

- Outlook directory
- Windows Address Book directory (WAB)

To access these external directories, you must create a link to the desired directory in the Shortcut Bar. After you add the directory, an icon appears in the Shortcut Bar. You can then click the icon to view or dial contacts in that directory.

Linking to the LDAP directory

To add a link to the LDAP directory in the Shortcut Bar:

1. From the Local Directory menu, select **Directory > Add Link To > LDAP Directory**.
   
   A Properties dialog box appears. From the Properties dialog box, you can access the following three tabs: General, Security, and Schema.

2. In the **General** tab, enter the following required information into the corresponding field:
   
   - **Directory Name**: the name of the directory as you want it to appear in the Shortcut Bar.
   
   - **LDAP Path**: the path to the LDAP directory stored on your hard drive.
   
   - **User Name and Password**: if applicable, enter your LDAP user name and password.

3. In the **Security** tab, select from the following security protocols:
   
   - **Use Secure Authentication**
   
   - **Use Encryption**
   
   - **Use SSL Encryption**
   
   - **Use Signing**
   
   - **Use Sealing**

4. In the **Schema** tab, select the desired LDAP schema from the **Schema** list. You can use this tab to add, remove, or modify an LDAP.
Managing contacts from the Local Directory

To add a new schema to the list:
1. From the **Schema** tab, click **Add**.
   A Dialog box opens. The Dialog box lists all current names and fields used by the LDAP directory.
2. In the **Schema Name** field, enter the name you want to use for your new LDAP schema.
3. Click **OK**.

To remove a schema from the list:
1. In the **Schema** tab, select the schema you want to remove from the list.
2. Click **Remove**.
   The LDAP Directory dialog box appears with the message “Remove the schema? Are you sure?”
3. Click **Yes**.

To modify an existing schema:
1. In the **Schema** tab, select the schema you want to modify from the list.
   A Dialog box opens. The Dialog box lists all current names and fields used by the LDAP directory.
2. Modify the **Schema Name**.
3. Click **OK**.

**Linking to Outlook**

To add a link to your Outlook directory in the Shortcut Bar:
1. From the menu, select **Directory > Add Link To > Outlook Directory**.
   A Properties dialog box appears.
2. In the **Directory Name** field, enter the name of your Outlook directory, as you want it to appear in the Shortcut Bar.
3. Click **OK**.
Managing contacts from the Local Directory

Linking to Windows Address Book directory
To add a link to a WAB directory in the Shortcut Bar:

1. From the menu, select **Directory > Add Link To > Windows Address Book.**
   A Properties dialog box appears.

2. In the **Directory Name** field, enter the name of your Windows Address Book directory, as you want it to appear in the Shortcut Bar.

3. In the **WAB Name** field, enter the name of the WAB file you want to link to from the Shortcut Bar.
   
   **Note:** If you do not know the name of the WAB file, click the browse button to the right of the WAB Name field. A Windows Open dialog box appears. Use this dialog box to navigate and select the file you need from your file system.

4. From the **Properties** dialog box, click **OK.**

Adding external contacts to the Local Directory
You can add contacts from any of the external directories to your Local Directory.

To add an external contact to the Local Directory:

1. From the Shortcut Bar, click the external directory icon you want to access.
   A list of contacts from the selected external directory appears.

2. Right-click the contact that you want to add to the Local Directory.

3. From the menu, select **Add to Local Directory.**
   The Properties dialog box appears.

4. If no phone numbers appear in the **Phone Numbers** field, you must input at least one valid phone number. If the telephone numbers in the **Phone Numbers** field look correct, then click **OK.**
   The contact is added to the Local Directory.

5. To access the added contact, click the Local Directory icon in the Shortcut Bar.
**Note 1:** You cannot directly add contacts to an external directory from within the Local Directory.

**Note 2:** If the contents of an external directory change, you must first update that directory for the changes to show in the Local Directory. To update, right-click the imported directory and click **Refresh.**
Managing contacts from the Avaya CS 1000 Directory

Your server supports the following Avaya CS 1000 Directory features:
Personal Directory, Redial List, and Callers List.

You can use the following options to manage contacts in CS 1000 Directory features:

• “Adding contacts to the Personal Directory” on page 47
• “Editing CS 1000 Directory contacts” on page 48
• “Deleting CS 1000 Directory contacts” on page 49
• “Finding CS 1000 Directory contacts” on page 49
• “Dialing from the Personal Directory” on page 49
• “Dialing from the Redial List” on page 50
• “Dialing from the Callers List” on page 50

Adding contacts to the Personal Directory

To add contacts to the Personal Directory:

1. On the Call Control window, click Directory.
2. Select Personal Directory > Add.
   A text editor starts.
3. Enter the contact information.
   Note: To add a pause in the number, click Pause at any time during data entry.
4. To submit the entry, click Done.
Managing contacts from the Avaya CS 1000 Directory

**Note 1:** Unlike the Local Directory, CS 1000 Directory features (Personal Directory, Redial List, Callers List) are stored on the Application Server.

**Note 2:** You can also add contacts to the Personal Directory by copying entries from the Corporate Directory, the Redial List, the Callers List, or other available directory applications. If you are creating multiple entries in the Personal Directory, you can make and edit multiple copies in an existing entry.

**Editing CS 1000 Directory contacts**

To edit contacts in the Personal Directory:

1. On the Call Control window, click **Directory**.
2. From the Directory list, select **Personal Directory**.
3. Search for the desired entry.
4. Highlight the entry.
5. Click **Edit** and make the changes.
6. Click **Done**.

**Making temporary edits to contacts**

Use this option to temporarily edit contacts in the Redial List and the Callers List, and then dial the edited entry. The changes are not retained.

To make temporary edits to contacts:

1. On the Call Control window, click **Directory**.
2. Select **Redial List** or **Callers List** from the Directory list.
3. Search for the desired entry.
4. Highlight the entry.
5. Click **Edit** and make the changes.
6. To dial the edited entry, click **Dial**.
Deleting CS 1000 Directory contacts

To delete a contact from the Personal Directory, Redial List, or Callers List:

1. On the Call Control window, click Directory.
2. Select the Personal Directory, Redial List, or Callers List.
3. Search for the entry.
4. Highlight the entry.
5. Click Delete.
6. Click Confirm or Cancel.

To delete the entire Redial List or Callers List:

1. Click Directory.
2. Select Redial List or Callers List.
3. Click Del.
4. Click Yes.

Finding CS 1000 Directory contacts

To find contacts in Personal Directory, Redial List, or Callers List:

1. On the Call Control window, click Directory.
2. Click the desired directory and do one of the following:
   — Scroll through the directory to the desired entry.
   — To go directly to the desired entry, enter the entry.
   — Search by first name, last name, or number.

Dialing from the Personal Directory

To dial from the Personal Directory:

1. On the Call Control window, click Directory.
2. Select the Personal Directory.
3. Find the contact using one of the following:
   — Scroll to the desired contact.
   — Search for the contact by name or number.
   — Enter the number of the contact to find it.
4. To dial the selected entry, double-click the contact.

### Dialing from the Redial List

To dial from the Redial List in the CS 1000 Directory:

1. On the Call Control window, click **Directory**.
2. Select **Redial List**.
3. Find the contact using one of the following:
   — Scroll to the desired contact.
   — Search for the contact by name or number.
   — Enter the number of the contact to find it.
4. To dial the selected entry, double-click the contact.

### Dialing from the Callers List

To dial from the Callers List in the CS 1000 Directory:

1. On the Call Control window, click **Directory**.
2. Select **Callers List**.
3. Find the contact using one of the following:
   — Scroll to the desired contact.
   — Search for the contact by name or number.
   — Enter the number of the contact to find it.
4. To dial the selected entry, double-click the contact.
Managing Avaya 2050 IP Softphone calls

The following sections describe options for managing Avaya 2050 IP Softphone calls:

- “Making telephone calls” on page 51
- “Answering telephone calls” on page 52
- “Incoming Call Notification” on page 52
- “Holding and retrieving telephone calls” on page 53
- “Hanging up telephone calls” on page 55
- “Support for TAPI applications” on page 55
- “Viewing active status” on page 56

Making telephone calls

Before making a call, ensure that you are wearing your headset.

To make a call:

1. Open a **Line** using one of the following methods:
   - On the Call Control window, click **Answer/Headset**. Your main telephone line appears.
   - Select **Keys > Answer**.
   - From the Call Control window, select a **Line** key.

2. Enter the phone number using one of the following methods:
   - Dial from the number pad of your computer keyboard.
   - Dial from the Call Control window Dialpad, using the mouse pointer.
   - Drag and drop (or copy and paste) a telephone number from Microsoft Outlook or an open Microsoft Word or Excel file onto the Call Control window.
Managing Avaya 2050 IP Softphone calls

— Select a contact from a Microsoft application such as Outlook (if the Avaya 2050 IP Softphone has been selected as a line source in the application dialing properties).

— Select **Keys > Macros**, and then choose the desired macro.

— Click **Directory**, and then:
  b. Scroll through the directory to find the contact you want.
  c. Select **Dial**.

### Answering telephone calls

Before answering a call, ensure that you are wearing your headset. When you receive a call, the speaker to which you set your phone rings, and Caller ID (if available) shows in the display area.

*Note:* To select the speaker you want to ring, click **File > Settings > Sound Devices > Handsfree/Ringing/Paging device > Speaker**. Choose the desired speaker from the list.

You can answer a call using one of the following methods:

— On the Call Control window, click **Answer/Headset**.

— Click the **Line** key of whichever line is ringing.

*Note:* Answering a new call automatically puts any active calls on hold. To switch between active callers, click the appropriate **Line** key to resume your call.

*Note:* The Enter key on the keyboard can also be used to pick up the longest incoming ringing/non-ringing DN by configuring automatic line selection on each phone.

### Incoming Call Notification

A notification window appears above the system tray when incoming calls are received. This window displays the ringing line (DN) and the incoming caller’s name and number, as shown in Figure 3.
Figure 3: Incoming call notification window

When this notification appears you can do one of the following:

- Click **Answer** to answer the call.
- Click **Open** to activate the Avaya 2050 IP Softphone Call Control window and select a call handling feature, such as forwarding the incoming call to another line or to voicemail.
- Click **Close** to close the notification window. This does not disconnect the incoming call, it only removes the message from your screen. You can also close the notification box by clicking the close button in the top right corner.

When the call is disconnected, a “call disconnected” notification appears. The incoming call notification window closes automatically when the call is disconnected.

### Holding and retrieving telephone calls

Before using the phone, ensure that you are wearing your headset.

To put a call on Hold or retrieve a call from Hold:

1. Click the **Line** key for the active call.
2. From the Call Control window, click **Hold**.

### Using Record On Demand key

If this feature is enabled, you can use the Record on Demand (ROD) feature key to record your telephone conversation.
Click the ROD key to start or stop the call recording. This key is associated with the active user ID and is displayed only if a call is active. The ROD key blinks while it is connecting to the call recording application, and is lit when the call is recording.

The ROD key is displayed in the following scenarios:

• Normal operation - Click the ROD key during an active call to record the call.
• Call Recording (CR) application in ROD Mode - Click the ROD key during an active call to record the call.
• Bulk Recording - For an active call or unregistered DN/Position ID, call recording is initiated even though the ROD key is not pressed.

1. Click the ROD key during an active call.

2. To stop the call recording, click the ROD key again.

Using SAVE key

Use the SAVE feature key to save the recording of an active call. This key is associated with the active user ID and is operational only if a call is active.

The SAVE key is displayed in the following scenarios:

• Normal operations - If the SAVE key is clicked during an active call, the call is saved.
• CR application in Bulk Record + Save everything mode - Recorded conversation is saved at the end of the call. If the SAVE key is clicked, then the call is not saved.
• CR application in Bulk Record + Delete everything mode - Recorded conversation is deleted at the end of the call. If the SAVE key is clicked, then the call is saved.
The **SAVE** key lamp status depends on the status of the call recording. If the call is to be saved, then the lamp is lit.

1. Click the **ROD** key during an active call.

2. To stop the call recording, click the **ROD** key again.

3. Click the **SAVE** key to save the conversation.

---

**Hanging up telephone calls**

When your call ends, you must manually terminate the active line.

To terminate a telephone call:
1. Click the appropriate **Line** key to ensure it is selected.
2. From the Call Control window, click **Goodbye/Release**.

**Support for TAPI applications**

The Avaya 2050 IP Softphone has the ability to handle calls placed using TAPI (Telephony Application Programming Interface) compliant applications, such as Microsoft Outlook. This enables you to make calls from your Outlook Contacts list if the Avaya 2050 IP Softphone TAPI Service Provider has been selected as an available line source in your Phone and Modem Options.

The IP Softphone TAPI Service Provider supports the following features:

- Making calls
- Answering calls
- Ending active calls
To enable the IP 2050 Softphone TAPI Service Provider:

1. Select Start > Control Panel > Phone and Modem Options. The Phone and Modems Options window opens.
2. Click Advanced.
3. From the list of available Telephony Providers, select Avaya 2050 IP Softphone TAPI Service Provider.
4. Click OK.

To make a call using Microsoft Outlook:

Note: The Avaya 2050 IP Softphone must be active before making a call.

1. On the Contacts list, right-click on the name of the contact you want to call and select Call Contact.
   The New Call dialog box displays.
2. Click the Dialing Options button.
3. From the Connect using line menu, select Avaya 2050 IP Softphone Line.
4. Click OK.
5. From the New Call dialog box, select Start Call.

For errors encountered when using the Avaya 2050 IP Softphone TAPI Service Provider, see “TAPI problems” on page 127.

**Viewing active status**

The status appears on the window title bar as shown in the following table.

### Table 2: Viewing active status (Part 1 of 2)

<table>
<thead>
<tr>
<th>Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Incoming Call</td>
<td>There is an incoming call.</td>
</tr>
</tbody>
</table>
### Table 2: Viewing active status (Part 2 of 2)

<table>
<thead>
<tr>
<th>Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>On Call</td>
<td>A call is active.</td>
</tr>
<tr>
<td>On Hold</td>
<td>A call is on hold.</td>
</tr>
</tbody>
</table>
Avaya 2050 IP Softphone Expansion Module

The Expansion Module (EM) provides status information about other Avaya 2050 IP Softphone or physical IP Deskphone clients connected to the network, such as whether a client is on-line, off-line, and so on. The EM is similar to the Key Expansion Module (KEM) device available for hardware IP Deskphones.

Figure 4 shows the Expansion Module window.

Figure 4: Avaya 2050 IP Softphone Expansion Module
Up to three EMs can be added to the IP 2050 Call Control Window, with the additional EMs cascading vertically beneath the original window. A scrollbar allows access to additional keys.

Each key has a label and an icon indicating the state of the assigned client. The labels are set automatically by the system administrator; however, users can edit these labels using the Settings menu. The icons have cadences identical to those of external lamp controls. For more information on lamp control cadences, see “Setting external lamp controls” on page 97.

*Note:* Key assignment for the EM is performed by the system administrator.

Settings for the EM are configured using the Avaya 2050 IP Softphone Settings menu. See “Expansion Module” on page 95.

**Using the Expansion Module**

To launch the Expansion Module:

1. Click the **Menu** button.
2. Select **View > Expansion Module**.
   
   The EM window opens.

You can move the EM window so that it docks to the left or right side of the Call Control window or leave it open as a separate window. Calls are retrieved by pressing the appropriate line key.

*Note:* The Expansion Module feature is available only if it is supported by the telephone system. Contact your system administrator to find out if this feature is available.

**Working with Groups**

Keys are organized into groups of 18, with a maximum of three groups or 54 keys per EM. Individual keys can be moved and organized into groups by dragging and dropping them (Group view only).
To create a new group:
1. Right-click on an existing group (such as the General group).
2. Select **Add Group**.
3. Enter a name for the new group.
4. Click **OK**.

To remove a group:
1. Right-click on an existing group.
   
   **Note:** The General group is the default group and cannot be removed.
2. Select **Remove Group**.
   
   A confirmation message appears asking if you want to remove the selected group.
3. Click **Yes** to confirm.
   
   The group is removed and all items belonging to it are moved to the General group.
Graphical External Application Server

The Graphical External Application Server (GXAS) is a plugin for the Avaya 2050 IP Softphone that enables you to launch and interact with applications that are available on a GXAS server from within the Avaya 2050 IP Softphone application.

After selecting an application, you can interact with the application in a separate session window as though it was running locally on your own machine.

The GXAS plugin is automatically installed with the Avaya 2050 IP Softphone application.

Configuring the GXAS plugin

Before the GXAS plugin can be used, the GXAS server must be specified in the Settings menu. For more information, see “Server” on page 82.

Starting the GXAS plugin

You can start the GXAS plugin by double-clicking the Expand to PC button or by selecting View > Graphical External Application Server.

The available applications are shown in the GXAS Applications window.

If a default GXAS application has been previously selected, click the Expand to PC button once to launch the default application in the session window.

Selecting a GXAS application

To launch an application, you can double-click the appropriate icon in the GXAS Applications window or select an application icon by highlighting it and clicking OK.

To exit without selecting an application, close the window or click Cancel.
GXAS applications launch in a separate session window.

**Using the session window**

The active GXAS application is shown in the session window. The title bar at the top of the session window indicates the name of the active application and the bottom of the session window features a status bar that displays the following information:

- If the audio stream for a GXAS application is open (ON) or closed (OFF)
- If the microphone for a GXAS application is open (ON) or closed (OFF)

The status bar background turns red when one or both streams are ON. The session window can be docked to the main interface of the Avaya 2050 IP Softphone or moved to the desired screen location.

Click and type within the session window as if the application was active on your local machine.
Avaya 2050 IP Softphone USB Headset Adapter

You must install an Avaya USB Audio kit before using the Avaya 2050 IP Softphone.

The features of the USB Headset Adapter are described in Table 3.

Table 3: USB Headset Adapter elements and functions (Part 1 of 2)

<table>
<thead>
<tr>
<th>Element</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Message Waiting light</td>
<td>The red Message Waiting light is located at the top of the USB Headset Adapter. The light illuminates when you have voicemail messages waiting. The light flashes when a call is ringing on the Avaya 2050 IP Softphone. Note: You may also hear an audio Message Waiting Indicator (stutter or beeping dial tone) when you obtain dial tone.</td>
</tr>
<tr>
<td>Maximize button</td>
<td>Press the Maximize button to maximize or minimize the Avaya 2050 IP Softphone. If the Avaya 2050 IP Softphone is minimized, press this button to maximize the Avaya 2050 IP Softphone window. If the Avaya 2050 IP Softphone is maximized but behind another window, press this button to bring the Avaya 2050 IP Softphone to the foreground. If the Avaya 2050 IP Softphone is maximized, press this button to minimize the Avaya 2050 IP Softphone.</td>
</tr>
</tbody>
</table>
### Table 3: USB Headset Adapter elements and functions (Part 2 of 2)

<table>
<thead>
<tr>
<th>Element</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Smart Functions button</td>
<td>Available on the desktop adapter only. Press this button to access the Smart Functions menu. For more information, see “Using the Smart Functions menu” on page 66.</td>
</tr>
<tr>
<td>Answer button</td>
<td>To answer an incoming call, press <strong>Answer</strong>. If you have no incoming call when you press this button, the Avaya 2050 IP Softphone selects a line and you hear a dial tone.</td>
</tr>
<tr>
<td>Release button</td>
<td>Press the <strong>Release</strong> button to terminate the current call.</td>
</tr>
<tr>
<td>Mute button</td>
<td>Press the <strong>Mute</strong> button to mute a call. When you mute a call, you can still hear your caller, but your caller cannot hear you. Press the <strong>Mute</strong> button a second time to resume your conversation.</td>
</tr>
<tr>
<td>Mute light</td>
<td>You can find the <strong>Mute</strong> light beside the Mute button. With a call on mute, the Mute light illuminates. With a call off mute, the Mute light remains off.</td>
</tr>
<tr>
<td>Volume button</td>
<td>Use the <strong>Volume</strong> button to control the volume of the headset. When the Smart Functions Menu appears, use these buttons to move up and down in the menu.</td>
</tr>
<tr>
<td>Backlight</td>
<td>The backlight illuminates when your headset is connected to the Avaya 2050 IP Softphone application. To activate or deactivate the backlight feature, click on <strong>File &gt; Settings &gt; USB Headset</strong>, and select or clear the <strong>Use backlight</strong> check box.</td>
</tr>
</tbody>
</table>
Answering calls with the USB Headset Adapter

You can use the USB Headset Adapter to answer calls whenever the Avaya 2050 IP Softphone is running—even if minimized or running in the background.

To answer a call using the USB Headset Adapter:
1. Ensure that you are wearing your headset.
2. Press Answer.

*Note:* If you want to view Caller ID before answering while the Avaya 2050 IP Softphone is minimized or running in the background, press the Maximize button. This brings up the IP Softphone Call Control window.

Hanging up calls with the USB Headset Adapter

You can use the USB Headset Adapter to hang up calls whenever the Avaya 2050 IP Softphone is running—even if minimized or running in the background.

To hang up a telephone call using the USB Headset Adapter, press the Release button.

Adjusting the volume with the USB Headset Adapter

You can adjust the volume of your telephone calls using the USB Headset Adapter. Ensure that you are wearing your headset so you can hear the changes as you make them.

To increase the volume, press the right up arrow on the Volume button.

To decrease the volume, press the left down arrow on the Volume button.
Muting a call

When you mute a call, you can still hear your caller, but your caller cannot hear you.

To mute a call using the Headset adapter, press the **Mute** button.

Using the Smart Functions menu

The Smart Functions menu provides quick access to Avaya 2050 IP Softphone features. You can customize what appears on this menu using the Configuration Utility.

To access the Smart Functions menu:

1. Press the **Smart Functions** button on the USB Headset Adapter.
2. Highlight the feature you want using one of the following:
   - Mouse pointer
   - Keyboard arrow keys
   - **Volume** button on the USB Headset Adapter
3. To select the feature, click **OK**.

**Note 1:** If only one feature shows up in the menu, the **Don’t display this dialog again** check box appears. Select this check box to map the Smart Function button directly to that one available feature. You can then press the Smart Function button to execute the feature directly, bypassing the menu.

**Note 2:** The **Smart Functions** button is available only on the desktop version of the USB Headset Adapter.
Customizing the Smart Functions menu

You can customize the features that appear on the Smart Functions menu using the Configuration Utility.

To customize the Smart Functions menu:

1. From the Call Control window, select File > Settings > USB Headset.
   The USB Headset Settings window opens.
2. Click Configure Smart Functions.
   The Configure Smart Functions dialog box opens.
3. From the dialog box, you can Add, Remove, or Rearrange functions from the Smart Function menu.
   — To add a function, select the function you want from the Available functions list, and then click Add.
   — To remove a function, select the function you want to remove from the list, and then click Remove.
   — To rearrange a function, click the function you want to move either up or down in the menu, and then click the appropriate button: Move Up or Move down.
4. To close the Configure Smart Functions dialog box, click OK.
5. To close the USB Headset dialog box, click OK.

You can also add special functions to the Smart Functions menu.

Custom Functions for Smart Functions menu

From the Configure Smart Functions dialog box, you can add, delete, and modify custom functions on the Smart Functions menu.

To add a custom function:

1. Click New.
2. In the Name box, enter the name you want to appear on the Smart Functions menu.
3. In the **Command** box, enter the pathname and file name of the function you want to add.

   **Note:** If you do not know the pathname or file name of the function, click **Browse** beside the **Command** box. You can then navigate to the correct file, select it, and click **Open**.

4. In the **Arguments** box, enter any arguments that are required for this function.

   **Note:** If you want the Avaya 2050 IP Softphone to prompt you for the argument when you select this special function, select **Prompt for arguments**.

5. In the **Initial directory** box, enter the pathname of the directory you want this function to use.

   **Note:** As with the **Command** box in step 3, if you are unsure of the pathname or filename, click **Browse** next to the Initial directory box. You can then navigate to the correct directory, make your selection, and click **OK** to finish.

6. To change the icon that appears beside this function on the Smart Functions menu, click **Change**, then go through steps 7 to 9. If you do not want to change the icon, go to step 10.

   7. Click **Browse**.
   8. Navigate to the file you entered in the **Command** box and select it.
   9. Click **Open**.

10. Select one of the icons that appears.

11. Click **OK**.

12. To add the new function to the Smart Functions menu, click **OK**.

   To modify a custom function:
   1. Select the custom function you want to modify.
   2. Click **Modify**.
   3. Make the required changes.
   4. Click **OK**.
To remove a custom function:
1. Select the custom function you want to remove.
2. Click Delete.
3. To confirm the deletion, click Yes.
Avaya 2050 IP Softphone macros

Use the Avaya 2050 IP Softphone to enter macros. A macro is a sequence of keystrokes that you can use to automate repetitive actions. For example, you can program a macro that selects a particular telephone line and then dials a telephone number automatically, or a macro that ensures a certain number is always dialed out on a particular telephone line.

To access the Avaya 2050 IP Softphone Macro Settings menu from the Call Control window, click **File > Settings > Macros**.

All macros are listed in the Macros Settings window. You can also access macros by selecting **Keys > Macros**.

The following sections describe how to work with macros:

- “Entering a macro” on page 70
- “Deleting a macro” on page 71
- “Playing a macro” on page 71

**Entering a macro**

You can enter a macro to automate a procedure or repetitive action.

To enter a macro:

1. Open the **Settings** window. For details, see “Opening the Settings window” on page 76.
2. Select **Macros**.
   
   The Macros settings dialog box opens.
3. Click **New Macro**.
   
   The New Macros dialog box opens.
4. Enter the name of your new macro.
5. Create the macro using a combination of the following:
   
   — To enter numbers, click the dialpad.
— Select the actions you want from the Keys menu, and then click Add.

6. To add the new macro to the list, click Apply.

7. To exit the Macros dialog box, click OK.

   **Note 1:** Use the Pause action to introduce a half-second delay in the macro—a requirement for some Interactive Voice Response applications and voicemail systems.

   **Note 2:** You can move macro items up and down the macro list. Select the macro item you want to move, and then use the **up** and **down** arrow keys to move the item in the direction you need.

   **Note 3:** For a list of macro values, refer to Table 1 on page 24.

### Deleting a macro

To delete a macro:

1. From the Macro menu, select the macro you want to delete.

2. Click Delete Macro. This clears the macro.

3. To finalize the change, press Apply.

### Playing a macro

You can play macros to dial telephone numbers or access your voicemail.

To play a macro:

1. From the Call Control window, select Keys > Macros.

2. Select the desired Macro by name.
Avaya 2050 IP Softphone menu commands

The following sections describes the Avaya 2050 IP Softphone Call Control window menu command. See “Call Control window menu command” on page 72.

Call Control window menu command

The Avaya 2050 IP Softphone supports a Windows-style menu command system, with File, Edit, Keys, View, and Help menus available by clicking the Menu button at the top left corner of the Call Control window.

The following sections describe the Menu options:

- “Using the File menu” on page 72
- “Using the Edit menu” on page 73
- “Using the Keys menu” on page 73
- “Using the View menu” on page 74
- “Using the Help menu” on page 74
- “Using the Change menu” on page 75
- “Using the Icon menu” on page 75

Using the File menu

From the File menu, you can choose from any of the following:

- **Run in background**—Sends the Call Control window to the background, but leaves the application running to receive calls.
- **Record this call**—Begin recording all incoming or outgoing calls.

  **Note:** Call Recording (controlled by either a third party (server) or first party (client)) requires either server support or a separate recording application. Contact your system administrator for more information about the Call Recording function.

- **Settings**—Opens the Settings window and the various tabs.
Using the Edit menu

From the Edit menu, you can choose from any of the following:

- **Copy**—Copies the contents in the display window for use in other applications.
- **Paste**—Pastes phone numbers or other dialable strings copied from other applications.
- **Input Mode**—Selects method that the application uses to interpret input from the keyboard. The two methods are:
  - **Numeric**—Select **Numeric** and the Avaya 2050 IP Softphone interprets keyboard characters (a 1-800 number, for example) as single numbers for dialing.
  - **Alphabetic**—Select **Alphabetic** and the Avaya 2050 IP Softphone interprets each keyboard character as a multiple number. For example, pressing 1 will result in two 1’s. Pressing 2 will result in four 2’s.

Using the Keys menu

From the Keys menu, you can choose from any of the following:

- **Headset/Handset**—Select to answer an incoming call, or obtain a dial tone to make a call.
- **Handsfree**—Select to answer or make a call using the handsfree speaker. To set the desired speaker, select **File > Settings > Sound Devices**. From Handsfree/Ringing/Paging device, select your **Speaker** from the speakers list.
- **Answer**—Select to answer an incoming call or obtain a dial tone.
- **Goodbye**—Select to end a call.
- **Hold**—Select to put an active call on hold.
- **Mute**—Select to place your call on mute. You can hear the caller, but the caller cannot hear you.
- **Send**—Select to confirm menu selections and terminate input sequences.
- **Features**—Select to view a list of available, server-supported features.
• **Macros**—From the macros menu, select the macro you want to dial.

**Using the View menu**

From the View menu, you can choose from any of the following:

• **Local Directory**—Select to access the Local Directory window, including links to contacts in Outlook and other applications. See “Local Directory” on page 29 for details.

• **Expansion Module**—Select to show or hide the Expansion Module. See “Avaya 2050 IP Softphone Expansion Module” on page 58 for details.

• **Graphical External Application Server (GXAS)**—Select to launch the GXAS interface. See [link] for details.

**Using the Help menu**

From the Help menu, you can choose from any of the following:

• **Quickstart**—Select to view basic information about operating the Call Control window and the USB headset.

• **Hot Keys**—Select to view a list of both **Buttons** and **Menus** hot keys.

• **License Agreement**—Select to view the current licensing agreement.

• **Contents**—Select to open the contents section of the Avaya 2050 IP Softphone Help system.

• **Search**—Select to search for a specific item in the Avaya 2050 IP Softphone Help system.

• **Index**—Select to open the index section of the Avaya 2050 IP Softphone Help system.

• **Diagnostics**—Select to view diagnostic information about specific Avaya 2050 IP Softphone components. See “Avaya 2050 IP Softphone Diagnostics” on page 113.

• **About Avaya 2050 IP Softphone**—Select to view information about the Avaya 2050 IP Softphone, such as the version number, copyright information.
Using the Change menu

From the Change menu, you can choose any of the following options:

- **Change Font**—Select this option to change the font used on the interface.
- **Change Color**—Select this option to change the color of indicators, including the Mute On and Voice Mail Message indicators.
- **Change Style**—Select this option to change the style of the Accessibility Interface.

Using the Icon menu

From the Icon menu, you can choose any of the following options:

- **Icons Only**—Select this option to view the Accessibility Interface with icons only.
- **Icons + Text**—Select this option to view the Accessibility Interface with icons and text.
- **Text Only**—Select this option to view the Accessibility Interface with text only.
Avaya 2050 IP Softphone Settings

Use the Settings window (shown in Figure 5) to access and configure the many Avaya 2050 IP Softphone features and functions. You can open the Settings window from the Windows Start Menu or from the Avaya 2050 IP Softphone Call Control window.

Figure 5: The Settings Window

Opening the Settings window

Use one of the following options to open the Settings window:

- From the Windows operating system:
  - Select Start > Programs > Avaya > Avaya 2050 IP Softphone > Avaya 2050 IP Softphone Settings.
  - Select Start > Control Panel > Avaya 2050 IP Softphone. (In Windows XP, select Switch to Classic View to view the list of settings.)
From the Avaya 2050 IP Softphone Call Control window:
— Click the Menu button and select File > Settings.

### Using the Settings window

The following sections describe how to configure the various Avaya 2050 IP Softphone features and functions:

- “Profiles” on page 78
- “Server” on page 82
- “License Servers” on page 84
- “Theme” on page 85
- “Features” on page 85
- “Macros” on page 86
- “Audio” on page 86
- “Sound Devices” on page 87
- “Hardware ID” on page 88
- “Advanced Audio” on page 90
- “Listener IP” on page 91
- “Notifications” on page 91
- “Hot Keys” on page 92
- “Text Replacements” on page 93
- “Lamp Sounds” on page 94
- “Key Type” on page 94
- “Language” on page 95
- “Expansion Module” on page 95
- “Personal Call Recording” on page 96
- “Plantronics USB Bluetooth Headset” on page 97
- “USB Headset” on page 97
- “About” on page 100
Features and functions are listed in the left pane of the Avaya 2050 IP Softphone Settings window (see Figure 5 on page 76). Select the desired feature to open the corresponding dialog box.

**Profiles**

Use profiles to configure the Avaya 2050 IP Softphone. Using profiles, you can keep multiple Avaya 2050 IP Softphone configurations on the same computer. When you make changes to any feature or function, the changes affect only the current profile.

*Note:* The name of the current profile appears at the lower right corner of all Avaya 2050 IP Softphone Settings dialog boxes, above the Apply button (see Figure 5 on page 76).

If more than one profile has been created, you are prompted to select a profile to use when starting the Avaya 2050 IP Softphone application.

To open the Profiles dialog box, select Profiles from the list in the left pane of the Settings window.

The following sections describe how to work with Profiles:

- “Creating new profiles” on page 79
- “Removing profiles” on page 79
- “Modifying profile names” on page 79
- “Selecting profiles” on page 80
- “Exporting profiles” on page 80
- “Importing profiles” on page 81

**Reset button**

When you select the Reset button in the following procedures, the phone resets immediately without any warning.

However, if you make a change to the settings and select Apply or OK, the phone indicates that a reset needs to take place. A warning message
appears—"Avaya 2050 IP Softphone must reset for the configuration changes to be complete. Select Yes to reset now or select No if you plan on resetting later". You can select Yes to reset now, or No, to defer it until later.

Creating new profiles
A text box at the top of the Profiles dialog box displays the current profile.

To create a new profile:
1. Click New.
   An empty text box called Profile Name opens.
2. Enter the name of the new profile.
3. Click OK.

Removing profiles
To remove a profile:
1. From the list of profiles, select the profile that you want to remove.
2. Click Remove.
   A “Remove profile? Are you sure?” message appears.
3. Click Yes.
   The profile is deleted from the list.

Note: My Server is a built-in profile name and cannot be deleted.

Modifying profile names
To modify a profile name:
1. From the list of profiles, select the profile that you want to modify.
2. Click Modify Name.
   The Profile Name text box opens, with the name of the profile highlighted.
3. Enter the new profile name.
4. Click OK.
The new name shows in the list.

**Selecting profiles**

To choose which profile the Avaya 2050 IP Softphone uses for your current session:

1. From the list of profiles, select the desired profile.
2. Click *Reset*.

If the Avaya 2050 IP Softphone is currently running, it tries to reestablish communication with the server (as defined by the profile). The Main Application screen opens.

If the Avaya 2050 IP Softphone is not currently running, the Settings window closes. The next time you start the Avaya 2050 IP Softphone, it attempts to connect to the server (as defined by the profile).

*Note:* Check the server dialog box in Avaya 2050 IP Softphone Settings to see which server your current profile uses.

**Exporting profiles**

To back up your personal settings or to use your profiles with other applications, export your Avaya 2050 IP Softphone profiles to your computer hard drive.

To export your profiles:

1. Click *Export*.

   A Save As dialog box opens.

2. Save your profiles using the file name and directory of your choice.

   *Note:* The export and import of profiles is for the backup and retrieval of individual settings only. Profiles are not intended to be shared with other users.

Your current Avaya 2050 IP Softphone profiles are now saved as “Config Backup Files” (*cfx).*
Importing profiles

Use import to restore the backed-up configuration files of your personal settings for current use.

To import saved profiles:
1. Click **Import**.
   - An Open dialog box opens.
2. Locate and select the profile you want to use.
   - The Import Profiles text box opens.
3. Select the profile or profiles that you want to import.
4. Click **OK**.
Server

Use the Server dialog box to configure the connection between the Avaya 2050 IP Softphone and your communications server and, if applicable, the GXAS server. You can either use the default method (DHCP) or manually specify an IP address.

To open the Server dialog box, select Server from the list in the left pane of the Settings window.

The following sections describe the Server settings:

- “Reset button” on page 82
- “Using IP addresses and DNS names” on page 83
- “Restoring defaults” on page 83
- “Resetting the connection” on page 84

Reset button

When you select the Reset button in the following procedures, the phone resets immediately without any warning.

However, if you make a change to the settings and select Apply or OK, the phone indicates that a reset needs to take place. A warning message appears—"Avaya 2050 IP Softphone must reset for the configuration changes to be complete. Select Yes to reset now or select No if you plan on resetting later". You can select Yes to reset now, or No, to defer it until later.

Using DHCP

With Automatic (DHCP) enabled, the Avaya 2050 IP Softphone reads server addresses from a Dynamic Host Configuration Protocol (DHCP) server.

Note: To use DHCP, your Local Area Network (LAN) must include a DHCP server. Contact your System Administrator to configure the server with the correct IP address values.
To use the Automatic (DHCP) method:

1. Select the **Automatic (DHCP)** check box.
2. From the **Server** list, select your server. You can choose from the Primary, Secondary, or Application (GXAS) servers.

   **Note 1:** Primary and Secondary servers are assigned by DHCP.

### Using IP addresses and DNS names

If your communications server does not support DHCP, then you must assign an IP address or DNS name manually.

To assign a manual IP address or DNS name, you must have the following information about your communications server:

- IP address or DNS name
- Port number
- Server type

To assign an IP address or DNS name:

1. From the **Server** list, select the server you want to configure: **Primary, Secondary** or **Application**.
2. Select **IP** and enter the IP address, or select **Name** and enter the DNS name.
3. If the server is an Application server, select the **Graphical** check box. The default port number shows in the Port text box.
4. If your server port number is different from the default number, enter the correct number in the **Port** text box.

   **Note:** Symposium call center agents must select the **Symposium** check box.

### Restoring defaults

To restore the settings dialog to its default settings, click **Restore Defaults**.
Resetting the connection

To reset the server connection while the Avaya 2050 IP Softphone is running, click Reset.

License Servers

Use the License Servers dialog box to add new license servers to the Server Address list and to specify the order in which they are contacted by the Avaya 2050 IP Softphone client. The server at the top of the list is contacted first, followed by the second, and so on.

To add a new License Server:

1. Enter the new server IP address (or DNS name) in the New server field.
2. Click Add.
   The new server is added to the Server Address list.
3. Click OK.

To change the License Server priority:

1. Select the server from the Server Address list.
2. Use the Increase Priority and Decrease Priority buttons to move the server up or down in the list.
3. Click Apply.

For more information about License Servers, see Avaya IP Phones Fundamentals (NN43001-368).
Theme

Use the Theme dialog box to select the 1100 theme or one of two available compact theme colors (black or silver). You can also use this dialog box to switch to the Accessibility Interface.

To choose the theme:

1. From the Theme menu, select **1100, black**, or **silver**.
2. Click **OK**.

If the default path was overwritten during installation, then you must designate the correct path to the Avaya 2050 IP Softphone file.

To select the path to the IP Softphone file:

1. Click **Browse**. A Browse for folders dialog box opens.
2. Locate and select the Avaya 2050 IP Softphone folder in your file system.
3. Click **OK**.

To read the Microsoft Active Accessibility (MSAA) information:

1. Select the MSAA (Screen Reading Advanced Support) check box.
2. Click **OK**.

**Note:** Alternatively, you can use the theme dialog box to configure the Accessibility Interface for Avaya 2050 IP Softphone. For information about opening or using the Accessibility Interface, see “Accessibility Interface” on page 101.

Features

Use the Features dialog box to rearrange the features found under Keys > Features on the Call Control window.
The Feature Menu lists all available server-supported features. Use the arrow keys to move individual items up and down in the list. The list includes:

- Message
- Directory
- Shift
- Services
- Expand
- Copy
- Quit
- Redial List
- Callers List

Note: In Avaya Communication Server 1000 systems, the Available Features list remains empty.

You can access any item on the Available Features list from the Keys > Features list.

Macros

For information about setting macros, see “Avaya 2050 IP Softphone macros” on page 70.

Audio

Use the Audio dialog box to adjust the level of buffering between your audio hardware and the Avaya 2050 IP Softphone. This option is also used by the system administrator to configure Secure Call Recording.

Use the Quality slider to increase or decrease the amount of delay. Less delay speeds up buffering, but reduces audio quality. Higher quality improves audio quality, but slows down buffering.

Note: If your Avaya 2050 IP Softphone audio sounds choppy or broken, move the slider toward Higher Quality.
Use the Ringer Attenuation slider to increase or decrease the ringer volume.

**Sound Devices**

Use the Sound Devices dialog box to select and set the various IP Softphone sound devices.

The dialog box is separated into two areas:

- “Headset or handset device” on page 87
- “Handsfree/Ringing/Paging Device” on page 87

**Headset or handset device**

When using a headset or handset, use this area to:

- Select the microphone and speaker
- Adjust volume
- Select or clear mute status

The Microphone text box displays the currently selected microphone. To change the microphone, select the microphone you want to use from the microphone list.

The Speaker text box displays the currently selected speaker. To change the speaker, select the speaker you want to use from the speaker list.

To adjust the volume of the microphone and speaker, use the volume slider bar.

To mute both devices, select **Mute**.

**Handsfree/Ringing/Paging Device**

When using a handsfree/ringing/paging device, use this area to:

- Select the microphone and speaker
- Adjust volume
- Select or clear mute status
The Microphone text box displays the currently selected microphone. To change the microphone, select the microphone you want to use from the microphone list.

The Speaker text box displays the currently selected speaker. To change the speaker, select the speaker you want to use from the speaker list.

To adjust the volume of the microphone and speaker, use the volume slider bar.

To mute both devices, select **Mute**.

To return the settings to installation defaults, click **Restore Original Values**.

**Hardware ID**

*Note:* This dialog box is intended for expert users only.

Use the Hardware ID dialog box to select the hardware address reported to your communications server. The Hardware ID text box displays the current hardware address.

The following sections describe the Hardware ID settings:

- “MAC addresses” on page 88
- “Reset button” on page 89

**MAC addresses**

The Avaya 2050 IP Softphone default IP address comes from your Ethernet hardware, as a Medium Access Control (MAC) address. If several Ethernet interfaces are installed, then the Avaya 2050 IP Softphone chooses the first MAC address it detects and uses that address in all subsequent re-connections.

*Note:* Some Virtual Private Network (VPN) clients hide their MAC addresses. In this case, you must override the default value to prevent problems communicating with the server.
Reset button

When you select the Reset button in the following procedures, the phone resets immediately without any warning.

However, if you make a change to the settings and select Apply or OK, the phone indicates that a reset needs to take place. A warning message appears—"Avaya 2050 IP Softphone must reset for the configuration changes to be complete. Select Yes to reset now or select No if you plan on resetting later". You can select Yes to reset now, or No, to defer it until later.

Selecting MAC addresses

To select a MAC address:

1. Click Auto-Create. The Hardware ID text box displays the next address in a range of addresses.

2. Continue clicking Auto-Create to move through the range of available addresses, until you find the one you need.

After you click through all available MAC addresses, Auto-Create generates random hardware ID numbers. Select one of these numbers if your Ethernet hardware address is not unique to the server.

To return the settings to their installation defaults, click Restore Defaults.

To reset the Hardware ID while the Avaya 2050 IP Softphone is running, click Reset.

Note: The Firmware Version field displays the latest Avaya 2050 IP Softphone firmware version reported by the server.
Advanced Audio

Note: This dialog box is intended for expert users only.

Use the Advanced Audio dialog box to adjust settings for advanced audio controls.

The following sections describe the Advanced Audio settings:

- “Microphone Automatic Gain Control” on page 90
- “Echo Cancellation” on page 90
- “Noise Reduction” on page 90

Microphone Automatic Gain Control

Selecting the Microphone Automatic Gain Control box allows the system to automatically determine the appropriate level of gain for your microphone. This ensures a comfortable speech level for both parties.

Echo Cancellation

Use the Echo Cancellation slidebar control if echo is detected on the line during a call. Certain types of headsets or PC audio speakers can cause echo to appear on the line.

The slider has three settings:

- Off disables the echo cancellation controls.
- Always On enables echo cancellation for all calls.
- Auto allows the system to enable and disable echo cancellation as required.

Noise Reduction

Use the Noise Reduction slidebar to increase or reduce any unwanted sounds from your environment. Move the slidebar between Off and Max to find the desired level of noise reduction.

To restore the Advanced Audio settings to the default settings, click Restore Defaults.
**Listener IP**

*Note:* This dialog box is intended for expert users only.

Use the Listener IP dialog box to override port assignments when the Avaya 2050 IP Softphone application conflicts with another application on your computer.

Under normal operation, the Avaya 2050 IP Softphone listens for UNISTim traffic on all IP addresses and IP ports. You can set the Avaya 2050 IP Softphone to listen to only one specific IP address or port.

To use a specific address:

1. Select **Use a specific address**.
   The dimmed text box activates.

2. Enter the address to which you want the Avaya 2050 IP Softphone to listen. The format of the IP address is 99.99.99.99.

To use a specific port:

1. Select **Use a specific port**.
   The dimmed text box activates.

2. Enter the port to which you want the Avaya 2050 IP Softphone to listen.

To return the settings to their installation defaults, click **Restore Defaults**.

**Notifications**

Use the Notifications dialog box to select the alarm that sounds when the Avaya 2050 IP Softphone connects to, or disconnects from, a call server. The phone notifies an incoming call.

You can assign a sound to any of the following three events:

- Server connected
- Server unreachable
- Server unresponsive
To assign a sound to an event:

1. From the **Select an event** list, select the event to which you want to assign a sound.
2. Select **Play sound**.
3. Enter the path and file name of the audio file you want to use. You can also search for the file by clicking browse.
   The selected file name appears in the text box.

   **Note:** The Avaya 2050 IP Softphone currently supports only .wav files

To test the selected sound, press the **play** arrow button. To stop the sound while playing, click the **stop** button.

To view the information about a new incoming call:

1. Select the **Show pop-up window in System Tray** option button.
   **Note:** Pop-up windows do not launch for incoming calls to the Expansion Module. The Call Notification popup window will display NA/NONAME when ACD call is presented to 2050PC setup in CS 1000 with AACC. This limitation is specific to instances where Phoneset Display configuration is performed from AACC.
2. Select the **Voice Notifications** check box.
3. Click **OK**.

### Hot Keys

You can assign keyboard hot keys to access the full range of Call Control window functions and menu options.

For information about available hot keys, and for adding or removing hot keys, see “Hot keys” on page 27.
**Text Replacements**

*Note:* This dialog box is available from the Accessibility Interface only.

Use the Text Replacements dialog box to modify the server-supplied text in the Accessibility Interface. Modification lets you shorten or eliminate superfluous language picked up by the screen-reading software.

The text replacement table lists all the text replacement rules that are currently assigned. Both the original text and the replaced text appear in the list.

To add a new text replacement rule, or to modify an existing rule:

1. Click **New** or **Modify**.
   
   A Find and Replace dialog box opens.

2. Enter the text that you want to change in the **Find what** text box. You can assign parameters to the search by selecting any of the following:
   
   — **Whole word** searches for the entire word.
   
   — **Display** searches the display area.
   
   — **Context** searches the context area.
   
   — **Softkeys** searches the softkeys area.
   
   — **Line/Feature Key text** searches the Line/Features area.
   
   — **Date and Time** searches the date and time area.

3. Enter the new text in the **Replace with** text box.

4. Click **OK**.
   
   The **Find what** dialog box closes.

5. Click **Apply**.

To remove an existing text replacement rule:

1. Select the rule you want to remove from the list.

2. Click **Remove**.

   The text rule disappears. The affected text returns to its original form.
Lamp Sounds

Use the Lamp Sounds dialog box to select sound effects that let you know when the message lamp or mute lamp is on.

To assign a sound for either the message or mute lamp:

1. From the Select a condition list, select Message Lamp On or Mute Lamp On.
2. Select Play sound.
3. Enter the path and file name of the audio file you want to use. You can also search for the file by clicking the browse button. When selected, the file name appears in the text box.
4. Enter how often you want the sound repeated in the minutes and seconds fields (found in the Repeat every area).

Note: The Avaya 2050 IP Softphone currently supports only .wav files.

Key Type

The IP Softphone Call Control window supports six line/feature keys (see Figure 2 on page 23). Use the Key Type dialog box to select which keys the Avaya 2050 IP Softphone uses to place calls (line keys). The selected keys will display as available line keys when making a call.

To assign a line key:

1. Select the check box next to the key or keys that you want to use. Key layout corresponds to the layout on the Call Control window.
2. Click Apply.

To return the settings to their installation defaults, click Restore Defaults.

Phone number dialog box

When you make a call from the Local Directory, or select Make Call from the system tray menu, a Phone number dialog box opens. A Select a
**line key** menu in the dialog box lists all selected lines. Use the **Key Type** dialog box to add or remove items from this list.

**Accessibility Interface**

In the Accessibility Interface, selected keys show as Idle or Active. Keys not selected (feature keys) show as Feature Inactive or Feature Active.

**Language**

Use the Language dialog box to select the language for the Avaya 2050 IP Softphone Settings window, Local Directory, and all menus and dialogs associated with the main application.

*Note:* Some language that you encounter in operating the Avaya 2050 IP Softphone comes from your communications server, or from your computer operating system (OS). Setting the language from the Language dialog box does *not* affect either server-supplied or OS-supplied language. To change server-supplied language, see the “Choosing the language” section on page 105.

To change the currently set language:

1. From the language list, select the language you want.
2. Click **OK**.

Supported languages include: Arabic, Chinese (Traditional and Simplified), Czech, Danish, Dutch, English, Finnish, French, German, Greek, Hebrew, Hungarian, Italian, Korean, Japanese, Latvian, Norwegian, Polish, Portuguese, Russian, Spanish, Swedish and Turkish.

**Expansion Module**

Use the Expansion Module dialog box to configure options for the Expansion Module. Use the Expansion Module dialog box to do the following:

- Change the View Style
  - “Group” features one column of 18 keys. Users can move buttons when using this view.
“Default” features three columns of 18 keys. Users cannot move buttons when using this view.

- Add annotations to keys
  - By default, keys display the number assigned by the Terminal Proxy Server and cannot be changed.
  - Keys can be annotated to show user-defined information, such as a particular name or department.

- Restore settings back to defaults.

For information on using the Expansion Module, see “Avaya 2050 IP Softphone Expansion Module” on page 58.

**Personal Call Recording**

To use Personal Call Recording, a call-recording application provided by Algo Solutions must be installed. Use the Personal Call Recording dialog box to:

- Let the Avaya 2050 IP Softphone record calls.
- Launch the Personal Call Recording application.
- Display a warning message when call recording is enabled.

Information about the third party application shows in the following fields:

- **Application** displays the name of the third party application.
- **Version** displays the current version number of the application.
- **Vendor** displays the vendor name of the application.
- **Path** displays the directory and file name where the third party application resides on your computer.

To allow the Avaya 2050 IP Softphone to record calls:

1. Select **Allow this application to record calls**.
2. Click **OK** or **Apply**.
To launch the call recording application on startup:
1. Select Launch the Personal Call Recorder application.
2. Click OK or Apply.

To display warning messages when call recording is enabled:
1. Select Display a warning message when call recording is enabled.
2. Click OK or Apply.

**Plantronics USB Bluetooth Headset**

Use the Plantronics USB Headset to configure settings for Plantronics USB Bluetooth headsets.

**USB Headset**

Use the USB Headset dialog box to do the following:

- “Selecting the headset” on page 97
- “Setting external lamp controls” on page 97
- “Using the backlight” on page 99
- “Configuring Smart Functions” on page 99

**Selecting the headset**

For optimal performance, select the headset from the list that matches the headset currently connected to your USB Headset Adapter.

To choose a headset:
1. From the list, select the headset you are using.
2. Click Apply.

**Setting external lamp controls**

*Note:* The external lamp is available on the desktop adapter only.
The Avaya 2050 IP Softphone supports an optional external LED lamp (also known as an in-use lamp). The lamp provides visual indication of call status, headset connection, and messages waiting.

You can set the lamp to illuminate under the following conditions:

- Manual Override
- Headset Disconnect
- Active Call
- Message Waiting

Select the cadence (how the lamp illuminates) that you want to use for each of the above conditions. Available cadences include:

- None
- On
- Flash
- Flicker
- Blink

**Manual Override**

With Manual Override enabled, you can turn on the external lamp by pressing the Smart Functions button on your USB Headset Adapter.

To enable Manual Override, select the cadence you want from the list. To disable Manual Override, select **None**.

**Headset Disconnect**

With Headset Disconnect enabled, the external lamp activates when the headset registers as disconnected from the USB Headset Adapter.

To enable Headset Disconnect, select the cadence you want from the list. To disable Headset Disconnect, select **None**.

**Active Call**

With Active Call enabled, the external lamp activates when the Avaya 2050 IP Softphone registers an active call.
To enable Active Call, select the cadence you want from the list. To disable Active Call, select **None**.

If you enable Active Call when the USB Headset Adapter is selected as the Ringing Speaker, then the external lamp also activates on incoming calls.

**Note:** Any other application using the same audio channel as the USB Headset Adapter also activates the external lamp.

**Message Waiting**

With Message Waiting enabled, the external lamp activates when the Avaya 2050 IP Softphone registers a message waiting.

To enable Message Waiting, select the cadence you want from the list. To disable Message Waiting, select **None**.

**Priority**

If more than one condition is enabled, then the external lamp activates according to the condition with the highest priority. The priority of the conditions, from highest to lowest, is as follows:

- Manual Override
- Headset Disconnect
- Active Call
- Message Waiting

**Using the backlight**

The USB Headset Adapter uses a backlight to illuminate the buttons, letting you know when the Avaya 2050 IP Softphone is running.

To enable the backlight, select **Use backlight**.

**Configuring Smart Functions**

The Smart Functions button on the desktop USB Headset Adapter provides quick access to Avaya 2050 IP Softphone features.
For information about configuring the Smart Functions button, see “Customizing the Smart Functions menu” on page 67.

Note: The Smart Functions button is available on the desktop version of the USB Headset Adapter only.

About

The About dialog box displays current information about the Avaya 2050 IP Softphone, including the following:

- Current version number
- Copyright information
- Avaya logo
- Global IP Sound logo
Accessibility Interface

The Accessibility Interface works with screen reading software—such as JAWS® for Windows from Freedom Scientific—that lets visually-impaired users access the full range of Avaya 2050 IP Softphone features.

To open the Avaya 2050 IP Softphone Accessibility Interface from the Call Control window:

1. Select **File > Settings > Theme**.
2. Select **Accessibility Interface**.

   **Note:** You must exit and restart the Avaya 2050 IP Softphone for the change to Accessibility Interface to take effect.

Control groups

The Accessibility Interface lets you move through the following four groups of controls:

- “Display” on page 101
- “Line and Feature” on page 102
- “Date and Time” on page 102
- “Indicators” on page 102

Display

Use the Display group to check the current operating conditions of the Avaya 2050 IP Softphone.

When on a call, you can navigate the Display group to:

- Check the calling line ID.
- Check the status of different call-handling options, such as Conference and Transfer.

When not on a call, you can navigate the Display group to:

- Program the Avaya 2050 IP Softphone.
• Access voice mail.
• Use Avaya Communication Server 1000 Directory features (Personal Directory, Redial List, Callers List).

**Line and Feature**

Choose from six available Line and Feature group keys to place or receive calls, or to access a range of server-supported Avaya 2050 IP Softphone features.

*Note:* Only your system administrator can assign Line keys. Contact your system administrator for more information about the available features that your server provides.

**Date and Time**

Use the Date and Time group to check the current date and time. When on a call, you can check the duration of your connection in the top field of the group.

**Indicators**

Use the Indicators group to check if you have a message waiting or to determine if the mute function is off or on.

**Accessibility Interface Menu**

The Accessibility Interface offers a Menu Command system identical to the standard Call Control window. File, Edit, Keys, View, and Help are all supported. For further details, see “Avaya 2050 IP Softphone menu commands” on page 72.

**Navigating Control Groups and Menu Commands**

You can navigate through the four Control Group fields, as well as the Menu Command system, using your keyboard instead of the mouse pointer.

This section describes the following:
Navigating Control groups

Use the following keystrokes to move through the four Control Group fields:

- To move to the next field, press **Tab**.
- To move to the previous field, press **Shift + Tab**.
- To move to the next control group, press **Page down**.
- To move to the previous control group, press **Page up**.
- To skip to the first control group, press **Home**.
- To skip to the last control group, press **End**.
- To read the field at the current cursor location, press **F1**.
- To read the contents of the control group at the current cursor location, press **Shift + F1**.
- To execute a command from the current cursor location (when over an executable field), press **Shift + Enter**.
- To execute the operation at the current cursor location, press **Space**.

Navigating Menu Commands

To access the Menu Command system from the keyboard, press **Alt** + the first letter of the menu you want to access. For example, press **Alt + F** to access the **File** menu.

From within the Menu Command system, you can:

- Use the arrow keys to move left and right among the five menus.
- Use the arrow keys to move up and down the menu, highlighting options as you go.
- To make your selection, press **Enter**. Or press the first letter of the selection you want.
Using hot keys

You can assign keyboard hot keys to access the full range of Call Control window functions and menu options—necessary for using all of the Avaya 2050 IP Softphone features from the Accessibility Interface.

For information about available hot keys, and for adding or removing hot keys, see “Hot keys” on page 27.

Limitations of Accessibility Interface

The following limitations apply to the Avaya 2050 IP Softphone for Windows Release 3.3 Accessibility Interface.

- The Graphical External Application Server (GXAS) interface (added in Release 3.1) is not compliant with the accessibility feature.
- Key Expansion Module (KEM) is not supported for accessibility mode.
Configuring Avaya CS 1000 Directory user preferences

Your server supports the following Avaya CS 1000 Directory features: Personal Directory, Redial List, and Callers List.

To access these features, click **Directory** on the Call Control window. For general information about CS 1000 Directory features, see “Avaya Communication Server 1000 Directory” on page 30. For information about managing contacts or making calls from the CS 1000 Directory features, see “Managing contacts from the Avaya CS 1000 Directory” on page 47.

The following sections describe how to set user preferences for the various CS 1000 Directory features:

- “Choosing the language” on page 105
- “Configuring the date and time” on page 106
- “Enabling the Call Timer” on page 106
- “Configuring Call Log options” on page 107
- “Using Password Administration” on page 110

**Choosing the language**

If the Language setting is password-protected, you must enter a password (SCPW) to change the language. If you enter an incorrect password, an error message is displayed. If you enter an incorrect password more than three times, the password functionality is locked. Contact your system administrator to unlock the password.

To set the language used by CS 1000 Directory features:

1. Click **Services**.
   A list of options appears in the display area.
2. Use the up and down arrows (on either the navigation cluster or on your PC keyboard) to select **Telephone Options > Language**.
Configuring Avaya CS 1000 Directory user preferences

3. From the **Language** list, select the language that you want to use (for example, *German [Deutsch]*).

   **Note:** This procedure affects only the language used by CS 1000 Directory features. To change the language used by the Call Control window, see “Language” on page 95.

### Configuring the date and time

CS 1000 systems support several date and time formats, based on the 12-hour and the 24-hour clocks.

To select a date and time format:

1. Click **Services**.
   
   A list of options appears in the display area.

2. Use the up and down arrows (on either the navigation cluster or on your PC keyboard) to select **Telephone Options > Date/Time**.

3. From the **Date/Time** list, highlight the format that you want to use.
   
   A sample of the highlighted date and time format appears in the display area of the Call Control window.

4. Select the desired format.

### Enabling the Call Timer

With the Call Timer telephone option enabled, the Avaya 2050 IP Softphone automatically measures and displays the length of each call.

To enable Call Timer:

1. Click **Services**.
   
   A list of options appears in the display area.

2. Use the up and down arrows (on either the navigation cluster or on your PC keyboard) to select **Telephone Options > Call Timer**.

3. Select **Call Timer: On**.
Configuring Call Log options

Use the Call Log telephone option to configure the following preferences:

- “Logging all/unanswered incoming calls” on page 107
- “New call indication” on page 107
- “Preferred name match” on page 108
- “Area code setup” on page 109
- “Name display format” on page 109

Logging all/unanswered incoming calls

You can set the Callers List to log either all incoming calls or unanswered incoming calls only.

To log all calls or only incoming calls:

1. Click Services.
   A list of options appears in the display area.
2. Use the up and down arrows (on either the navigation cluster or on your PC keyboard) to select Telephone Options > Call Log Options.
3. Select Incoming calls.
4. Select Log Mode.
5. Select either of the following:
   — To log all calls, select Log All Calls.
   — To log all calls including calls received while the phone was busy, select Log calls if busy
   — To log only unanswered calls, select Log unanswered calls.

The default setting for Log Mode is: Log All Calls.

New call indication

With the new call indication option enabled, the Avaya 2050 IP Softphone displays an indication message when it receives new incoming calls.
Configuring Avaya CS 1000 Directory user preferences

To enable or disable new call indication:

1. Click **Services**.  
   A list of options appears in the display area.

2. Use the up and down arrows (on either the navigation cluster or on your PC keyboard) to select **Telephone Options > Call Log Options**.

3. Select **Incoming calls**.

4. Select **New call indication**.

5. Select either of the following:
   — To enable the feature, select **New call indication: On**.
   — To disable the feature, select **New call indication: Off**.

The default setting for new call indication is: On.

**Preferred name match**

Use preferred name match to set the way names appear in Call Party Name Display (CPND). If set to Off, CPND displays according to your server settings. If set to On, CPND displays according to the matching name found in your CS 1000 Directory (if a match is found).

To enable or disable preferred name match:

1. Click **Services**.  
   A list of options appears in the display area.

2. Use the up and down arrows (on either the navigation cluster or on your PC keyboard) to select **Telephone Options > Call Log Options**.

3. Select **New call indication**.

4. Select either of the following:
   — To enable the feature, select **Pref Name Match: On**.
   — To disable the feature, select **Pref Name Match: Off**.

The default setting for preferred name match is: Off.
Area code setup

Use area code setup to organize the display of incoming telephone numbers. When an incoming call arrives with an area code that matches one of the three stored area codes, the Avaya 2050 IP Softphone reorders the incoming call number to display the telephone number followed by the area code (as opposed to the area code followed by the telephone number).

This reordering also applies to the order of telephone numbers found in the Callers List.

To configure up to three saved area codes:

1. Click Services. A list of options appears in the display area.
2. Use the up and down arrows (on either the navigation cluster or on your PC keyboard) to select Telephone Options > Call Log Options.
5. Enter the area code you want to use, or edit the existing area code.

The default for area code setup is: no area code specified.

Name display format

You can set the Avaya 2050 IP Softphone to display the name of the incoming calling party in either of the following formats:

- first name, last name
- last name, first name

To set the name display format:

1. Click Services. A list of options appears in the display area.
2. Use the up and down arrows (on either the navigation cluster or on your PC keyboard) to select Telephone Options > Name Display format.
3. Select \textit{last name, first name} or \textit{first name, last name}.

The default setting for name display format is: first name, last name.

\textbf{Using Password Administration}

You can access Password Administration from the CS 1000 Directory features list. When the system administrator defines your Station Control Password (SCPW) on the server, you can then set Password Administration functions, such as:

- “Enabling Password Protection” on page 110
- “Changing your personal password” on page 111

With password protection enabled, the Avaya 2050 IP Softphone requires authentication before allowing you to access the Personal Directory, Redial List, or Callers List. When you attempt to access any of these password-protected features, a prompt asking you to enter your password appears.

\textit{Note:} The default setting for Password Protection is: Off.

\textbf{Enabling Password Protection}

To turn Password Protection On/Off:

1. From the Call Control window, click \textit{Directory}. 
2. Select \textit{Change Protection} mode.
   
   If Password Protection is enabled, a prompt asks you to enter your password.

3. Click one of the following:
   
   — To confirm, click \textit{Ent}.
   
   — To delete your password, click \textit{Del}.
   
   — To clear your password, click \textit{Clr}.
   
   — To cancel and return to the Directory list, click \textit{Can}.

4. If you clicked \textit{Ent}, select one of the following:
   
   — \textbf{Enable Pwd Protection}
— **Disable Pwd Protection**

5. Click one of the following:
   — To accept your selection, click **Yes**.
   — To return to the Directory list, click **No**.

6. If you selected **Yes**, click **Done** to enable or disable Password Protection.

**Changing your personal password**

To change your password:

1. Click **Services**.
   
   A list of options appears in the display area.

2. Use the up and down arrows (on either the navigation cluster or on your PC keyboard) to select **Telephone Options**.
   
   A prompt asks you for your password.

3. Enter your password.

4. Select **New Password**.

5. Click one of the following:
   — To select New Password, click **Sel**.
   — To return to the previous menu, click **Del**.
   — To clear your password, click **Clr**.
   — To end, click **Can**.

   **Note:** If you click **Sel**, a prompt asks you to enter a new password.

6. Enter your new password and click **Sel**.
   
   A prompt asks you to confirm your new password.

7. Click one of the following:
   — To select New Password, click **Sel**.
   — To return to the previous menu, click **Del**.
   — To clear your password, click **Clr**.
   — To end, click **Can**.
Note: If you click Sel, your password changes.

If you make three consecutive incorrect password attempts within an hour, the application locks you out of all password-protected features for one hour. “Locked access” displays on your telephone.

The application also locks you out of Virtual Office (if enabled). If you fail to access Virtual Office due to incorrect password attempts, then the application also locks your access to other password-protected features.

If you forget your password or the system locks you out, then your system administrator can reset and unlock your access at any time.
Avaya 2050 IP Softphone Diagnostics

Overview

Avaya 2050 IP Softphone diagnostics are accessible from the Help menu and provide information about specific Avaya 2050 IP Softphone software, hardware, and networking components. This information is useful to advanced users or support personnel when investigating problems with the application.

Using the Avaya 2050 IP Softphone diagnostics

To view the Avaya 2050 IP Softphone diagnostics page:

1. Click the Menu button.
2. Select Help > Avaya 2050 IP Softphone Diagnostics.
   The diagnostics page appears.

When the diagnostics page is open, the Avaya logo button provides basic menu functions such as Open, Save as, Print, View, and Zip and Email Diagnostic Files.

There is also a Quick Access Control toolbar with icons representing the Open, Save, Print, Refresh, and Auto-Refresh functions.

To save the current diagnostic page:

1. Click the Menu button in the top left corner of the diagnostics page window.
2. Select Save as.
3. Browse to the location where the file is to be saved.
4. Enter a name for the file.
5. Click Save.
   The file is saved as type HTM.
To open a previously saved diagnostics page:

1. Click the Menu button in the top left corner of the diagnostics page window.
2. Select Open.
3. Browse to the location of the file you want to open.
4. Select the file.
5. Click Open.

**Using the Diagnostics View menu**

From the View menu, you can choose from the following:

- **Refresh**—Select to refresh the current diagnostics page.
- **Auto-Refresh**—Select to have the diagnostics page refresh automatically after a specified interval.
- **Set Auto-Refresh Interval**—Select to change the auto-refresh interval. The default is 15 seconds. You can set the interval from a minimum of 1 second to a maximum of 600 seconds.
- **System Information**—Select to view system information.

For more information about diagnostics for the Avaya 2050 IP Softphone, see *Avaya IP Phones Fundamentals* (NN43001-368).
Troubleshooting the Avaya 2050 IP Softphone

The following sections describe various troubleshooting issues and suggested remedy actions:

- “Connectivity problems” on page 115
- “Audio problems” on page 120
- “Reset conditions” on page 123
- “USB Headset problems” on page 124
- “TAPI problems” on page 127

Connectivity problems

The following sections describes various connectivity problems and suggested remedy actions:

- “Communication server is unreachable” on page 115
- “Unable to obtain valid license” on page 117
- “Connection is reinitializing” on page 117
- “Authorization failed” on page 118
- “Unable to retrieve communication server parameters from DHCP server” on page 119
- “Unable to connect to GXAS server” on page 119

Communication server is unreachable

Symptom:

One of the following messages appears:

- Connecting...
- Server unreachable. Reconnecting in xx seconds.
- 802.1 QoS is not supported on your network.
Description:
These messages indicate that the connection with the communication server cannot be established. The Avaya 2050 IP Softphone sets a random retry time, after which it attempts to reconnect. This process repeats until the Avaya 2050 IP Softphone successfully connects.

The “Connecting...” message appears briefly (or not at all) under the following conditions:

• The communication server is running and reachable.
• The Avaya 2050 IP Softphone is directed to the correct IP address.

The “Server unreachable” message appears when the Avaya 2050 IP Softphone encounters a problem contacting the communication server.

Potential causes:

• Network down
• Computer not connected to the network
• Invalid communication server settings in the Configuration Utility
• Invalid communication server settings in DHCP configuration
• Communication server down

Action:

• Ping another station on the network.
• Ping the communication server.
• Use the Server dialog box in the Settings window to verify the communication server IP address and port number (for more information, see “Server” on page 82).
• Verify correct configuration of the communication server. Check for the following: an available port, an available license, and for correct security.
Unable to obtain valid license

Symptom:
An error message appears that the license cannot be obtained, is invalid or has expired.

Description:
When the IP 2050 Softphone is launched, an error message appears in the display area indicating that the license server is unreachable or that the existing license code is invalid or has expired.

Potential Causes:
• Possible network connectivity error between the Avaya 2050 IP Softphone client and the Licensing Server.
• An invalid license has been entered.
• The license has expired. Upon installation, there is a 30-day evaluation period during which users can evaluate the software. After the 30 day period, a valid license code must be entered or the software will fail to work.

Action:
Network connectivity issues can interfere with access to the License Server. If connectivity is not restored within a reasonable time, report this to your system administrator. If the license code is invalid or has expired, obtain a valid license code from your system administrator.

Connection is reinitializing

Symptom:
The following message appears: “Connection Established. Reinitializing...”

Description:
This message appears after the Avaya 2050 IP Softphone establishes a connection and sends a request to the communication server to resume connection. The communication server is expected to reply to this request. Some communication servers direct the Avaya 2050 IP Softphone to various subcomponents, causing this
message to appear two or three times in rapid succession during a normal startup.

**Note:** Under normal setup, the “Connection Established. Reinitializing...” message appears briefly, then disappears after successful connection.

**Potential causes:**
- A “Connection Established. Reinitializing...” message indicates a programming error in the communication server.

**Action:**
Wait a moment. Under normal operation, the message disappears after successful connection. If the message continues, check for correct communication server programming.

**Authorization failed**

**Symptom:**
The following message appears: “Authorization failed”.

**Description:**
The Avaya 2050 IP Softphone has no authorization to use the communication server.

**Potential causes:**
- Your system administrator has not authorized the Avaya 2050 IP Softphone.
- The HardwareID found in the Settings window (under the Hardware ID dialog box) does not match the HardwareID provisioned for the communication server.

**Action:**
Contact your system administrator.
Unable to retrieve communication server parameters from DHCP server

**Symptom:**
The following message appears: “DHCP server is not available”.

**Description:**
A connection with the DHCP server cannot be established.

**Potential causes:**
- Network down
- DHCP server configuration error

**Action:**
Contact your system administrator.

Unable to connect to GXAS server

**Symptom:**
A message appears that connection to the GXAS server has failed.

**Description:**
A connection to the GXAS server cannot be established.

**Potential causes:**
- Network down
- GXAS server configuration error
- DHCP server configuration error

**Action:**
Contact your system administrator.

Service denied

**Symptom:**
The following message appears: “Service Denied. Reason XXXX “.

**Description:**
You are not authorized to use the communication server.

**Potential causes:**
- Invalid HardwareID in the Hardware ID dialog box (see “Hardware ID” on page 88)
- Invalid communication server configuration

**Action:**
- Ensure that your communication server programming is correct.
- Contact your system administrator.

**Audio problems**

This following sections describe Audio problems:
- “Basic audio operation” on page 120
- “One-way audio” on page 120
- “Broken or choppy speech” on page 121
- “Windows sound plays from the headset” on page 122
- “Advanced audio problems due to network performance” on page 123

**Basic audio operation**

To verify the physical connection of the USB adapter and headset, as well as proper Windows audio configuration:

1. Record an audio message.
2. Play the message back using the USB headset.

**One-way audio**

If you experience problems with one-way only audio:

- Check that your system administrator has programmed the handsfree option on the communication server.
• Check that the mute button is disabled. If mute is enabled, the mute button on the Call Control window appears red.

• If your server uses a Network Address Translation (NAT) device, check for proper NAT configuration. One-way only audio problems can occur when incorrect NAT configuration causes the Avaya 2050 IP Softphone to attempt to connect to the wrong IP address.

**Broken or choppy speech**

Broken or choppy speech can occur due to any of the following:

• Low level of audio buffering
• Windows transition effects
• Other running applications

**Audio buffering**

Use the Audio dialog box to adjust the level of buffering between your audio hardware and the Avaya 2050 IP Softphone. For details, see “Audio” on page 86.

Use the audio Quality slider to increase or decrease the amount of delay. **Less delay** speeds up buffering, but reduces audio quality. **Higher quality** improves audio quality, but slows down buffering.

When experiencing choppy or broken speech, move the Audio Quality slider toward **Higher Quality**.

**Windows transition effects**

The Windows operating system uses very high process and thread priorities when performing low-level Windows operations, such as minimizing and maximizing applications. This can cause brief breaks in the Avaya 2050 IP Softphone audio streams.

To reduce the severity of these breaks, turn off the Windows transition effects for menus and tool tips.
To turn off the Windows transition effects:

1. Select **Start > Control Panel > Display**.
2. Select the **Effects** tab, (or, in Windows XP, the **Effects** button on the **Appearance** tab).
3. Clear **Use transition effects for menus and tool tips**.

**Other applications**

Other applications running on your computer, especially CPU-intensive applications or applications that intercept or delay packets (such as firewalls), can cause broken audio.

Multiple Ethernet interfaces on a single PC can sometimes conflict with each other. For example, the Avaya 2050 IP Softphone sometimes exhibits intermittent breaks in audio when using docked notebooks that have a Xircom RealPort Cardbus Ethernet 10/100+Modem 56 PC Card (PCMCIA) inserted. In the specific case of this PC card, the problem relates to a version of the Xircom driver. This driver takes CPU cycles even when it is not active and this, in turn, causes Avaya 2050 IP Softphone audio to become choppy.

Solutions for this example are:

- Upgrade your Xircom driver.
- Remove the PC card when the notebook is docked.

To upgrade your Xircom driver:

1. Download and install a new PC card driver from the Xircom web site.
2. Follow the installation instructions provided by Xircom.

*Note:* You require administrator privileges on Windows 2000.

**Windows sound plays from the headset**

**Description:**

Windows sounds play from your headset instead of your computer speakers, interfering with Avaya 2050 IP Softphone audio.

**Action:**
In some cases, the Windows operating system defaults all the sounds to the new sound device.

To set Windows sounds to play from your computer speakers:

2. Select Sounds and Audio Device.
3. Select Audio.
4. From the Sound Playback > Default device list, select your computer sound card.

*Note:* If you do not want to use the Headset Adapter for playback, select another device from the Sound playback > Default device list.

**Advanced audio problems due to network performance**

If network performance causes audio problems, use the Advanced Audio dialog box in the Avaya 2050 IP Softphone Settings window to override your communication server audio values.

For more information about Advanced Audio, see “Advanced Audio” on page 90.

**Reset conditions**

The Avaya 2050 IP Softphone resets when:

- The communication server causes the Avaya 2050 IP Softphone to perform a hard reset.
- You change the Avaya 2050 IP Softphone theme.
- Firewall applications intercept or delay packets, causing the Avaya 2050 IP Softphone to reset due to the expiration of the Watchdog timer.

*Note:* Use care when using firewall applications on the same computer as the Avaya 2050 IP Softphone.

- Excess delay or loss of communication with the server occurs.
# Troubleshooting the Avaya 2050 IP Softphone

## USB Headset problems

The following sections describes various USB headset problems and suggested remedy actions:

- “Headset not functioning” on page 124
- “USB Headset Adapter features appear dimmed” on page 125
- “Cannot hear audio through headset” on page 126
- “Sound still comes out of my computer speakers” on page 127

### Headset not functioning

If you experience any headset problems, try the following actions in the order presented:

1. **Verify that you are using a supported operating system.** For a list of supported operating systems, see “System requirements” on page 34. To check your operating system:
   a. Select **Start**.
   b. Right-click **My Computer**.
   c. Select **Properties**.
      A System Properties window appears.
   d. Select **General**.
      The General tab lists system, registration, and computer information.

2. **Verify that Universal Serial Bus controllers appears in the Windows Device Manager.** To open the Device Manager:
   a. Select **Start**.
   b. Right-click **My Computer**.
   c. Select **Properties**.
      The System Properties window appears.
   d. Select **Hardware**.
      The Hardware dialog tab appears.
e. Click **Device Manager**.

3. If *Universal Serial Bus controllers* does not appear in the Device Manager:
   — Ensure that USB is enabled in your computer setup menu.
   — Check for a BIOS upgrade.
   — Contact your computer supplier.

4. Verify that *USB Audio Device* appears under *Sound, video and game controllers* in the Windows Device Manager. To open the Device Manager, see step 2.

5. Verify that *HID-compliant device* and *USB Human Interface Device* appear under *Human Interface Devices* in the Windows Device Manager. To open the Device Manager, see step 2.

6. If none of the devices in steps 4 and 5 appear in the Windows Device Manager (and the conditions in steps 1 and 2 are correct), then consult the USB Troubleshooting section in Windows Help.

7. Verify that you have selected *USB Audio Device* as the microphone and speaker for the Softphone.

**USB Headset Adapter features appear dimmed**

**Symptom:**
In the USB Headset dialog box of the Avaya 2050 IP Softphone Settings window, all the features appear dimmed.

**Description:**
Either the Avaya 2050 IP Softphone does not recognize the adapter as a supported Avaya adapter, or the adapter is earlier than 2.0. Supported adapters include:

- Enhanced USB Adapter (desktop)
- Avaya Mobile USB Adapter (mobile)
- GN Netcom DuraPlus Binaural Headset
- GN Netcom DuraPlus Monaural Headset
- GN Netcom GN2020 NC Monaural Headset
Troubleshooting the Avaya 2050 IP Softphone

- GN Netcom GN2100 Monaural Headset
- GN Netcom GN2115 ST Binaural Headset
- GN Netcom GN2117 ST Monaural Headset
- GN Netcom GN2125 NC Binaural Headset
- GN Netcom GN2220 NC Monaural Headset
- GN Netcom GN2225 NC Binaural Headset
- Avaya Handset
- Avaya Mobility Kit
- Plantronics Audio 910 Headset
- Plantronics Voyager 510 Headset
- Plantronics CS55 Headset
- Plantronics CS50 USB Headset (not available in Europe)
- Plantronics CS60 USB Headset

Potential causes:
- Your USB Headset Adapter does not support the functions listed on the USB Headset dialog box.
- The USB Headset Adapter has failed to enumerate properly.

Action:
If you suspect faulty enumeration, do the following:
1. Unplug the USB cable from the USB Headset Adapter.
2. Wait one minute.
3. Plug the USB cable into the USB Headset Adapter. This forces the USB Headset Adapter to re-enumerate.

Cannot hear audio through headset
Ensure that your headset manufacturer matches that of the USB adapter.
Check all jacks and plugs for a loose connection.
Sound still comes out of my computer speakers

Description:
The Avaya 2050 IP Softphone configuration does not direct all call audio to the headset.

Action:
To direct all call audio to your headset, select USB Audio Device as both headset microphone and headset speaker in the Sound Devices dialog box (see “Sound Devices” on page 87).

TAPI problems

As the TAPI feature is intended for use with third-party applications, most errors related to TAPI are resolved by consulting the documentation for the application that is generating the errors.
The following sections describe some common errors related to the TAPI feature:

- “Attempting to use TAPI feature when Avaya 2050 IP Softphone is not active” on page 128
- “TAPI service provider is missing” on page 128

### Attempting to use TAPI feature when Avaya 2050 IP Softphone is not active

**Description:**
An error message appears when trying to place a call from a TAPI application indicating that a resource needed is not available.

**Potential causes:**
- This is caused when the Avaya 2050 IP Softphone is not active when trying to make the call.

**Action:**
Make sure the Avaya 2050 IP Softphone is active before using the feature. If it is running, close the application and restart it. Try your call again. If the error is still not resolved, contact your administrator.

### TAPI service provider is missing

**Description:**
An error message appears when placing a call from a TAPI application indicating that a required line is not installed or is unavailable.

**Potential causes:**
- The file needed for TAPI service has been removed from the system or is corrupt.

**Action:**
Verify that the Avaya 2050 IP Softphone TAPI Service Provider is in the list of available telephony service providers by doing the following:
1. Select **Start > Control Panel > Phone and Modem Options > Advanced**.

2. Check the list of available telephony providers for the Avaya 2050 IP Softphone TAPI Service Provider. If it is not listed, click the **Add** button to try and add it.

If you are unable to add the Avaya 2050 IP Softphone TAPI Service Provider to the list, contact your administrator.
Appendix A: Quick reference

This section provides a quick reference guide for the Avaya 2050 IP Softphone. See the following sections for more information:

- “Legend” on page 131
- “Feature operation” on page 133
- “Services menu” on page 135

Legend

Table 4 on page 131 provides a legend of icons used in this section.

Table 4: Legend (Part 1 of 2)

<table>
<thead>
<tr>
<th>Icon</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Click a Line (DN) key button</td>
</tr>
<tr>
<td>Autodial</td>
<td>An icon flashes when a feature is being programmed. An icon lights steadily when a feature is active.</td>
</tr>
<tr>
<td></td>
<td>Click the Services key to access menu options.</td>
</tr>
<tr>
<td></td>
<td>Click the Message/Inbox key.</td>
</tr>
<tr>
<td></td>
<td>Click the Up/Down or Left/Right navigation keys.</td>
</tr>
<tr>
<td></td>
<td>Click the Enter key.</td>
</tr>
<tr>
<td></td>
<td>Click the Headset key.</td>
</tr>
<tr>
<td></td>
<td>Click the Handsfree key.</td>
</tr>
</tbody>
</table>
Table 4: Legend (Part 2 of 2)

<table>
<thead>
<tr>
<th>Icon</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Mute Icon]</td>
<td>Click the <strong>Mute</strong> (on/off) key.</td>
</tr>
<tr>
<td>![Directory Icon]</td>
<td>Click the <strong>Directory</strong> key.</td>
</tr>
<tr>
<td>![Quit/Stop Icon]</td>
<td>Click the <strong>Quit/Stop</strong> key.</td>
</tr>
<tr>
<td>![Hold Icon]</td>
<td>Click the <strong>Hold</strong> key.</td>
</tr>
</tbody>
</table>
Feature operation

Table 5 on page 133 provides a description of features operation.

Table 5: Feature operation (Part 1 of 2)

<table>
<thead>
<tr>
<th>Call Answer</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Image" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Call Forward</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Activate</strong></td>
</tr>
<tr>
<td><strong>Deactivate</strong></td>
</tr>
<tr>
<td><strong>Reinstate</strong></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Call Waiting</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Answer</strong></td>
</tr>
<tr>
<td><strong>Return to first call</strong></td>
</tr>
<tr>
<td><strong>Conference</strong></td>
</tr>
<tr>
<td><strong>Directory</strong></td>
</tr>
<tr>
<td><strong>Activate Headset</strong></td>
</tr>
<tr>
<td><strong>Activate or Deactivate Bluetooth technology headset</strong></td>
</tr>
</tbody>
</table>
### Table 5: Feature operation (Part 2 of 2)

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activate Speaker</td>
<td>![Speaker Icon]</td>
</tr>
<tr>
<td><strong>Hold</strong></td>
<td></td>
</tr>
<tr>
<td>Place a call on hold</td>
<td>(Hold) ![Hold Icon]</td>
</tr>
<tr>
<td>Return to a held call</td>
<td>![Return Icon]</td>
</tr>
<tr>
<td>Last Number Redial</td>
<td>![Number Redial Icon]</td>
</tr>
<tr>
<td>Message</td>
<td>![Message Icon]</td>
</tr>
<tr>
<td>Transfer</td>
<td>![Transfer Icon]</td>
</tr>
<tr>
<td><strong>Adjust volume</strong></td>
<td>(Volume +) ![Volume Plus Icon]</td>
</tr>
<tr>
<td>Mute Microphone</td>
<td>![Mute Icon]</td>
</tr>
</tbody>
</table>
Services menu

The Services menu contains Upgrades, Logs, IM, and Setup options.

Note: The Services menu contains a list of available network services. Some options are not available on all Avaya 2050 IP Softphones. Consult your system administrator.

Table 6 on page 135 provides the most commonly used Services options menu options.

Table 6: Services options menu (Part 1 of 2)

<table>
<thead>
<tr>
<th>Services menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Services)</td>
</tr>
</tbody>
</table>

The following are commonly used options:

<table>
<thead>
<tr>
<th>Telephone Options menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Volume Adjustment</td>
</tr>
</tbody>
</table>

Pick one of:
- Ringer
- Handset Listen
- Handsfree Listen
- Headset Listen
- Buzzer

<table>
<thead>
<tr>
<th>Names Display</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Local Dialpad Tone</th>
</tr>
</thead>
</table>
### Table 6: Services options menu (Part 2 of 2)

#### Services menu

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

#### Ring type

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Play</td>
<td></td>
</tr>
</tbody>
</table>

#### OnHook default path

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Index

A
Accessibility Interface, 101
Active Call, 98
Answer button, 64
Answer, 25
Application Server Administration, 33
Avaya USB Audio Kit, 34
Avaya USB Audio kit, 63

B
Backlight, 64, 99

C
Call Control Window
1140 skin, 22
compact skin, 23
Caller ID, 65
Callers List, 31
Copy, 24
CS 1000 Directory 30, 47
area code setup, 109
call log, 107
call timer 106
date and time 106
language, 105
name display, 109
new call indication, 107
password administration, 110
preferred name match, 108

D
Date and Time, 102
Dialpad, 26
Directory, 26
Display, 101

E
Early Packet and Late Packet Resync, 91
Edit menu, 73
Expand, 26
External directories, 42
External LED lamp, 97

F
File menu, 72

H
Headset Disconnect, 98
Help menu, 74, 75
Highwater Mark, 91
Hold, 26
Hot key, 27

I
i2050.exe application, 20
Inbox/Messages, 26
Incoming call notification window
52
Indicators, 102
IP Softphone TAPI Service Provider, 55

J
Jitter, 91

K
Keys menu, 73
L
Lightweight Directory Access Protocol (LDAP), 42
Line and Feature, 102
Line keys, 26
Line, 51
Local Area Network (LAN), 17
Local Directory, 29, 36

M
MAC addresses, 88
Macros, 70
Manual Override, 98
Maximize button, 63
Menu command, 72
Message Waiting light, 63
Message Waiting, 99
Mute button, 64
Mute light, 64

N
Navigation arrows, 25

O
Outbox/Shift, 26
Outlook directory, 43

P
Password Administration, 110
Personal Directory, 30, 49
Primary display, 24
Priority, 99

Q
Quit, 24

R
Redial List, 31, 50
Release button, 64
Release, 26

S
Services, 26
Settings 76, 77
About, 100
Advanced Audio, 90
Features, 85
Hardware ID, 88
hot keys, 92
Key Type, 94
Lamp Sounds, 93
Language, 95
License Servers, 84
Listener IP, 91
macros, 86
Personal Call Recording, 96
Profiles, 78
Server, 82
Skin, 85
Sound Devices, 87
Sounds, 91
Text Replacements, 93
USB Headset, 97
Smart Functions button, 64
Smart Functions, 66
Soft keys, 24
Speaker, 25
Supported operating systems, 34
System requirements, 34
System tray, 28

T
TAPI, 55
Telephony Application Programming Interface (TAPI), 55

U
USB Headset Adapter, 65
V
View menu, 74
Voice over IP (VoIP), 17
Volume button, 64
Volume, 25

W
Wide Area Network (WAN), 17
Windows Address Book directory, 43