Application Notes for Configuring the ESNA Officelinx iLink Pro 9.1 with Avaya Aura® Agile Communication Environment VE 6.2 FP2, Avaya Aura® Messaging 6.2 and Avaya Communication Server 1000 Release 7.6 - Issue 1.0

Abstract

These Application Notes describe the procedure for configuring the ESNA Officelinx iLink Pro 9.1 SP1, Avaya Agile Communication Environment 6.2 FP2, Avaya Communication Server 1000 Release 7.6 and Avaya Aura® Messaging 6.2. iLink Pro is an application that allows a user to operate a physical telephone and view call and telephone display information through a graphical user interface (GUI). iLink Pro controls a physical telephone using Third Party Call (v2, v2.4), Call Notification 4.0 web service of Avaya Agile Communication Environment 6.2 FP2.

Information in these Application Notes has been obtained through DevConnect compliance testing and additional technical discussions. Testing was conducted via the DevConnect Program at the Avaya Solution and Interoperability Test Lab.
# Table of Contents

1. Introduction ............................................................................................................. 4
2. General Test Approach and Test Result ................................................................. 4
   2.1. Interoperability Compliance Testing ................................................................. 4
   2.2. Test Results ....................................................................................................... 4
   2.3. Support ............................................................................................................. 6
3. Reference Configuration ......................................................................................... 7
4. Equipment and Software Validated ....................................................................... 8
5. Configure Avaya Communication Server 1000 R7.6 ............................................ 8
   5.1. Verify the Communication Server 1000 Packages ........................................... 10
   5.2. Verify that sufficient license parameters and system limits ............................... 10
   5.3. TR/87 solutions ............................................................................................... 11
   5.3.1. Adding an AML ........................................................................................... 11
   5.3.2. Adding VAS ............................................................................................... 12
   5.3.3. Node IP (SIP Gateway) Configuration ........................................................... 12
   5.3.4. IP Phone configuration for SIP CTI (TR/87) .................................................... 16
   5.3.5. Enable ELAN ............................................................................................... 17
5.4. Route, RLB and DSC Configuration ..................................................................... 17
5.5. Endpoint/Telephone Configuration ..................................................................... 22
5.6. Fax setting .......................................................................................................... 23
6. Configure Avaya Aura® Messaging ...................................................................... 25
   6.1. Administer Sites ............................................................................................... 25
   6.2. Administer Telephony Integration .................................................................... 27
   6.3. Configure Dial Rules ........................................................................................ 28
   6.4. Configure Class of Service ............................................................................... 29
   6.5. Administer Subscribers .................................................................................... 30
   6.6. Administer Topology ....................................................................................... 32
   6.7. Administer External Host ................................................................................. 32
   6.8. Recording Format ............................................................................................. 33
   6.9. Configure Notify Me ....................................................................................... 33
7. Configure Avaya Aura® Session Manager .............................................................. 34
   7.1. Configure SIP Domain ...................................................................................... 35
   7.2. Configure Locations ......................................................................................... 35
   7.3. Configure SIP Entities ...................................................................................... 36
   7.4. Configure Entity Links ...................................................................................... 40
   7.5. Configure Routing Policies ............................................................................... 41
   7.6. Configure Dial Patterns .................................................................................... 42
8. Configure Avaya ACE 6.2 FP2 ............................................................................. 45
   8.1. Add Communication Server 1000 TR/78 Service Provider ................................ 45
   8.2. Add User .......................................................................................................... 49
   8.3. Add Role .......................................................................................................... 50
9. Configure the ESNA Telephony Officelinx ............................................................ 51
   9.1. Configure SIP Configuration Tool ...................................................................... 51
   9.2. Configure UC ACE Wizard .............................................................................. 54
   9.3. Administer Company Profiles ......................................................................... 55
9.4. Configure User Mailbox in Officelinx Admin .......................................................... 56
9.5. Configure Fax  ........................................................................................................ 59
9.6. Install and Configure iLink Pro ............................................................................ 60
10. Verification Steps ................................................................................................... 62
10.1. Verify Avaya Communication Server 1000 Release 7.6 ................................. 62
10.2. Verify Avaya Aura® Session Manager ............................................................... 63
  10.2.1. Verify Avaya Aura® Session Manager is Operational .............................. 63
  10.2.2. Verify SIP Entity Link Status ................................................................. 63
10.3. Verify make call using ACE Web Service Trainer ......................................... 64
10.4. Verify Avaya Aura® Avaya ACE ......................................................................... 65
  10.4.1. Verify Avaya ACE Server status .......................................................... 65
10.5. Verify Avaya Aura Messaging ................................................................. 66
  10.5.1. Verify Avaya Aura Messaging can make a call to phones .................... 66
  10.5.2. Verify user can receive and retrieve Avaya Aura Messaging voice message using Google Mail ................................................................. 67
10.6. Verify ESNA Officelinx server and iLink Pro .................................................. 68
  10.6.1. Verify the log file UCServer of ESNA Officelinx ................................. 68
  10.6.2. Verify User can make a call using iLink Pro ........................................ 69
  10.6.3. Verify user can send fax through email .................................................. 70
11. Conclusion ............................................................................................................. 71
12. Additional References ......................................................................................... 71
1. Introduction
These Application Notes describe the procedure for configuring ESNA Telephony Officelinx, Avaya Aura® Agile Communication Environment (ACE), Avaya Communication Server 1000 and Avaya Aura® Messaging (Messaging) solutions.

iLink Pro is Google Application client of ESNA Officelinx that allows a user to operate a physical telephone and view call and telephone display information through a graphical user interface (GUI). iLink Pro controls a physical telephone using Third Party Call (v2 and v2.4), Call Notification 4.0 web service of Avaya Aura® Agile Communication Environment.

2. General Test Approach and Test Result
DevConnect Compliance Testing is conducted jointly by Avaya and DevConnect members. The jointly-defined test plan focuses on exercising APIs and/or standards-based interfaces pertinent to the interoperability of the tested products and their functionalities. DevConnect Compliance Testing is not intended to substitute full product performance or feature testing performed by DevConnect members, nor is it to be construed as an endorsement by Avaya of the suitability or completeness of a DevConnect member’s solution.

2.1. Interoperability Compliance Testing
The general test approach will be to verify the integration of the Esna Officelinx with Avaya IP UNIStim phones only. Phone operations such as off-hook, on-hook, dialing, answering, etc. will be performed from the physical phones and from the iLink Pro application. In addition, phone displays and call states on the physical phones and iLink Pro application will be verified for consistency.

2.2. Test Results
The following testing was covered successfully:
1. Click and call on iLink Pro and the voice path is established on 2 physical phones.
2. Off-hook and on-hook a device, phone states are consistent with its associated physical phone states.
3. Put a call on hold and retrieve call.
4. Transfer a call.
5. Leave an Avaya Aura Messaging voice message and retrieve it on Google mail (Gmail) web. (SMTP replay).
6. Redirect call to Avaya Aura Messaging.
8. Send and receive a fax through Gmail.

The following was observed during testing:

1. User A makes a call to user B. If user B selects the “Take Message” option on the incoming call, the call is re-directed to AAM and A is able to leave the voice message for B. If user A hangs up a call (after leaving a message or not leaving a message) by hanging up the physical device or by selecting the Hang Up option in iLink Pro, then as
observed in the UCACEServer log file, there is no remove CallID event and disconnected event for the completed call. Officelinx needs to have a proper procedure to clean up the callID for a completed call. This “Take Message” option **MUST** be disabled by the ESNA Officelinx Cloudlink Edition Administrator.

2. When a user receives a message, iLink Pro receives and indicates that there is a new message, and the message waiting indicator (MWI) is turned on. When a user retrieves a message using iLink Pro, MWI is turned off on iLink Pro and the physical phone. But when AAM maintenance subsequently runs, MWI is turned on again and AAM indicates there is a new message. This is a known limitation and is due to the fact that Esna Officelinx Cloudlink Edition does not currently use of the ACE Messaging API to “synchronize” the information to Avaya Aura Messaging. This capability is planned for implementation in a future release of ESNA Officelinx Cloudlink Edition.

3. Call extension of parties after a transfer call do not update. This is a known limitation in the current version of Esna Officelinx Cloudlink Edition. A fix is planned for a future release of ESNA Officelinx Cloudlink Edition.

4. Make a call to unavailable iLink Pro user, the call will be forwarded to AAM. If the user hangs up the call (after leave a message or does not leave a message) by hanging up the physical device or by selecting the Hang Up option in iLink Pro, then as observed in the UCACEServer log file, there is no remove CallID event and disconnected event for the completed call. Officelinx need to have a proper procedure to clean up the callID for a completed call. The Administrator **MUST NOT** configure the “HuntGroup” setting on Officelinx to prevent the call being left in an orphan state after the call is completed.

5. A physical phone A is not monitored by ESNA Officelinx. Make a call to iLink Pro user B (physical phone B is monitored) and then phone A performs a consult transfer to iLink Pro user C (physical phone C is monitored). iLink Pro C later tries to put the call on Hold using iLink Pro - Hold option. The call is not put on hold and the user C loses call control UI on iLink Pro. Work around is to put the call on hold using physical phone. This is a known limitation of Esna Officelinx Cloudlink Edition. To avoid this issue all internal phones must be monitored by Officelinx.

6. When Device A (DA) makes a call to iLink Pro user B, and iLink Pro user B transfers the call to iLink Pro user C, iLink Pro user C sometimes receives 2 popup messages: “Call Disconnected from DA” and “Incoming call from DA”. After 3 second the extraneous “Call Disconnected” popup message is closed. iLink Pro user C can click answer on the “Incoming call” popup window to connect the call. The two popup windows do not impact the call operation, however having 2 popup windows displayed at the same time can confuse the user. Users should ignore the extraneous “Call Disconnected” message when it occurs. A fix is planned for a future release of ESNA Officelinx Cloudlink Edition.

7. If the phones of iLink Pro user A, and iLink Pro user B are off-hook (e.g. A and B are on a call), the status of iLink Pro user A and B are displayed to iLink Pro user C as “On the Phone”. If iLink Pro user C makes a call to iLink Pro user A, and iLink Pro user C
then disconnects the call (hangs up) before iLink Pro user A answers, the display of iLink Pro user A’s status on iLink Pro user C is changed to indicate that iLink Pro user A is not on the phone, even though the call between iLink Pro user A and iLink Pro user B is still connected. A fix is planned for a future release of ESNA Officelinx Cloudlink Edition.

8. When a user double clicks on the Answer option, multiple requests for Answer call are sent to ACE which is causing ACE to return an exception.

2.3. Support
Technical support for the ESNA Telephony Officelinx solution can be obtained by contacting ESNA:

- URL - www.esna.com
- Email – techsupport@esna.com
- Phone – (905) 707-1234
3. Reference Configuration

The figure below illustrates the configuration used in these Application Notes. The sample configuration shows an enterprise with a Session Manager and an Avaya Communication Server 1000 Release 7.6. Endpoints include Avaya 1110, 1140 and 2004p1 Series IP Telephones (UNSTim).

ESNA Telephony Officelinx is configured as SIP entity on the Avaya Aura® Session Manager.

A user is able to click and call through the iLink Pro as well as received notify messages from Avaya Aura® Messaging in their Google email.

For Security purposes, public IP addresses have been masked out or altered in this document.
4. Equipment and Software Validated

The following equipment and software/firmware were used for the sample configuration provided:

<table>
<thead>
<tr>
<th>Equipment</th>
<th>Software/Firmware</th>
</tr>
</thead>
<tbody>
<tr>
<td>Avaya Communication Server 1000</td>
<td>Avaya Communication Server Release 7.65 P Deplist 1 (created: 2013-09-24) and Service Update 3 (Created: Sept 24, 2013)</td>
</tr>
<tr>
<td>Avaya Aura® System Manager S8800 Server</td>
<td>Avaya Aura® System Manager 6.3.4</td>
</tr>
<tr>
<td>Avaya Aura® Session Manager S8800 Server</td>
<td>Avaya Aura® Session Manager 6.3SP4</td>
</tr>
<tr>
<td>Avaya Aura® Messaging S8800 Server</td>
<td>Avaya Aura® Messaging 6.2</td>
</tr>
<tr>
<td>Avaya S8800 Server with VMWare 5.1</td>
<td>Avaya Agile Communication Environment VE 6.2.1 FP2</td>
</tr>
<tr>
<td>Avaya UNIStim Telephones: 2004p1, 1110 and 1140</td>
<td>0623C8J</td>
</tr>
<tr>
<td>ESNA Telephony Officelinx Cloudlink Edition</td>
<td>9.1</td>
</tr>
<tr>
<td>iLink Pro</td>
<td>9.1.14.1227</td>
</tr>
</tbody>
</table>

5. Configure Avaya Communication Server 1000 R7.6

This section describes the procedure for setting up Communication Server 1000. A CTI TR/87 link is created between Avaya Communication Server 1000 and Avaya ACE. The steps include setting up and verifying the system availabilities:

- Verify the Communication Server 1000 Packages and license information
- Verify the number of configured SIP access ports
- Configure TR/87 solutions
- Adding an AML
- Adding VAS
- Node IP (SIP Gateway) Configuration
- Save changes and restart signaling Server
- IP Phone configuration for SIP CTI (TR/87)
- Verify SIP route configuration.
- Route, RLB and DSC Configuration
- Endpoint/Telephone Configuration

The values used in this guide may be unique to the example shown. User will have to use values unique to their site, where this solution is being deployed e.g. site’s IP address, extension numbers, etc. Communication Server 1000 configurations are performed through Unified Communications Manager (UCM), Element Manager (EM) and Command Line Interface (CLI) via a telnet session to the Call Server. Review Avaya ACE Service Provider for details of adding TR87 Service Provider on ACE list in Section 12.
5.1. Login Unified Communication Manager

To login UCM, login System Manager, then select Communication Server 1000.

In the UCM, click on EM to open Element manager.

Communication Server 1000 Element Manager launched.
5.2. Verify the Communication Server 1000 Packages

Obtain feature package information using Element Manager.
1. In the CS1000 Element Manager.
2. Navigate to Tools → Logs and reports → Equipped feature packages.
3. Verify that Package 406 (SIP), Package 408 (Multimedia Systems Convergence) have been added.

![Equipped Feature Packages](image1)

5.3. Verify that sufficient license parameters and system limits

When deploying an ACE solution, ensure that the CS 1000 system has sufficient license parameters to support not only the CS 1000 system and CS 1000 system users, but also any ACE applications to be deployed within the existing customer network.

1. In the CS1000 Element Manager. Navigate to Tools → Logs and reports → System License Parameters.
2. Verify that the following licenses have been added:
   - SIP CTI: Configured based on the number of devices that need to be controlled using TR/87.
   - Associates Set (AST): Configured based on the number of monitor keys required for Presence and Call states.

![CS1000 Element Manager](image2)
5.4. TR/87 solutions

Using the Avaya Communication Server 1000 (CS 1000) TR/87 service provider, you can enable Avaya ACE to control a Computer Telephony Integration (CTI) capable terminal on the CS 1000 system. This solution supports telephony and other services such as click-to-dial, call notification, remote call control (RCC), and selected services within Avaya.

5.4.1. Adding an AML

An application module link (AML) path is required to provide access to the call server telephony functions. The Ethernet AML is the main interface that supports call control requests from SIP CTI Clients and the CS 1000 system. Use this procedure to check if the CS1000 system is already set up for CTI services.

Procedure
1. In the CS1000 Element Manager. On the left hand tree view, click Interfaces → Application Module Link.
2. Check the port number associated with CTI. Ensure that the port number is 32 or higher. Ports 0–31 are reserved for other functions. Therefore, assign an available virtual port, 32 or higher. For a small CS1000 system, the link number should be between 32 through 47 (inclusive) and for a large CS1000 system, the link number should be between 32 through 127 (inclusive).
3. If there is no port number assigned to CTI, click Add.
4. In the Port number field, enter a number 32 or higher. E.g. 36 is used during testing
5. In the Description field, enter a suitable description for the AML, for example, CTI.
6. Select the Link control system parameters check box to enable the Maximum octets list.
7. From the Maximum octets list, select the maximum number of octets for each High level Data Link Control (HDLC) frame. (The default is 512).
8. Click Save.

Below show AML 36 is configure in Communication Server 1000:
5.4.2. Adding VAS

One Value Added Server (VAS) must be defined for each configured AML. Because Ports 0-31 are reserved for other functions, assign an available virtual port numbered 32 or above. The port assignment for the AML and the VAS may match, but the matching is not a requirement. However, the responses to ELAN and VSID prompts must match. Use the following procedure to associate a Value Added Server (VAS) with AML over ELAN.

**Procedure**
1. In the CS1000 Element Manager. On the left hand tree view, click Interfaces → Value Added Server.
2. Click Add → Ethernet LAN Link.
3. In the Value Added Server ID field, enter a number 32 or higher. E.g. 36 is used during testing.
4. In the Ethernet LAN Link field, enter a number greater than or equal to 32.
1. The ELAN port configured in ADAN must be greater than or equal to 32.
5. Ensure the Application Security check box is cleared.
6. Ensure that the Interval field is set to 1.
7. Ensure that the Message Count Threshold field is 9999. The range is 10 through 9999 and the default value is 9999.
8. Click Save.

Below is detail of VAS 36 configured on Communication Server 1000:

5.4.3. Node IP (SIP Gateway) Configuration

This section only describes the configuration of the SIP Gateway application running on the Communication Server 1000 signaling server. In the solution test, Node ID 511 is configured, that has the SIP Gateway application enabled on it. For additional information on Nodes configuration, refer to Section 12.

A node is defined as a collection of signaling servers and voice gateway media cards. Each node in the network has a unique Node ID.
To configure the SIP Gateway from EM, navigate to System → IP Network → Nodes: Servers, Media Cards and click on the Node ID 511 as shown in figure below.

Click on the link Gateway (SIPGw) link as shown in figure below.
In the **Proxy Server Route 1. Primary TLAN IP address**, enter the **IP address of the Session Manager**. The rest of the fields are left at default.
In the **SIP URI Map** for Private domain names, verify the **UDP** field is configured as **udp**. The rest of the fields are left as default.

![SIP URI Map](image)

In **SIP CTI Server** section, make sure the **Enable CTI service** checkbox is checked. Using SIP CTI (TR/87) services on the CS 1000 Telephony nodes, applications can send control messages to CS 1000 terminal devices, such as IP phones, to obtain presence information or invoke a make call operation. Enter the rest of information as following: **TLS endpoints only**: Unchecked. After a system reboot, review this setting again. User may have to uncheck this again. **Calling Device URI format**: Select `phone-context=<SIP URI Map Entries>`. Leave other fields as default. Save changes and restart Signaling Server.
5.4.4. IP Phone configuration for SIP CTI (TR/87)

Phones are programmed and printed on an individual basis in linked LDs 10/11/20 or using a supported system management application such as Telephony Manager.

When configuring a phone to support SIP CTI operations, pay special attention to the Class of Service (CLS): TR87A, CMDR; Associated Set (AST) is assigned to 00 - SCR Key 0, and KEY prompts. Make sure that the mnemonic MARP appears by Key 0, the primary directory number (DN) for the phone.

```
TYPE: 1150
TN 96 0 1 3

DES 1150
TN 096 0 01 03 VIRTUAL
TYPE 1150
CDEN 8D
CTYP X DLC
CUST 0
CUR_ZONE 00001
MRT
ERL
CLS CTD ... USMD USRD ULAD CCBD RTDD RBDD PBND FLXD FTTC DNDY DNO3 MCBN
FDSD NOVD VOLA VOUD CDMR PRED RECD MCDD T87A SBMD
KEM3 MSNV FRA PKCH MUTA MWTD DVLD CROD ELCD
CPND_LANG ENG
AST 00
IAPG 0
AACS YES
ACQ AS: AST-DN
ASID 36
SFNB 1 2 3 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23
24 25 32 33 34 35 36 37 38 39
SFNR 32 33 34 35 36 37 38 39
USFB 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
CALB 0 1 2 3 4 5 6 7 8 9 10 11
FCTB
ITNA NO
DGRP
MLWU_LANG 0
MLNG ENG
DNDR 0
KEY 00 SCR 54314 0 MARP
CPND
CPND_LANG ROMAN
NAME 1150E
XPLN 13
DISPLAY_FMT FIRST, LAST
01
02 CWT
03
04
```
5.4.5. Enable ELAN

1. In the left pane directory tree of the Element Manager, navigate to System → Maintenance.
2. Select “Select by Overlay”.
3. Select LD 48
4. The system displays the Select Group window.
5. Select AML diagnostics.
6. Select the ENL ELAN command and click Submit.

5.5. Route, RLB and DSC Configuration

This section explains the steps to configure a routing from the Communication Server 1000 using the RLB and DSC values. After logging into the UCM, click on the EM link of the respective Communication Server 1000 (Not Shown). In the EM navigate to Routes and Trunks → Routes and Trunks. Click on Add route.
The figure below shows the configuration of the route being added. The values that are boxed in red are to be configured by the user. The values shown are examples used during the solution testing.
Example of trunk configured during compliance test:

To configure the RLB using EM navigate to **Dialing and Numbering Plans → Electronic Switched Network → Network Control & Services → Route List Block (RLB)**.
Enter the value of the route list index and click on to Add button to continue the configuration as shown below. During the solution testing the value of 1 was added.

The Route Number 1 being selected to the RLB created. Route 1 is selected since it was the route number assigned while adding a route. Below is detail of RLB 1

To configure the DSC using EM navigate to Dialing and Numbering Plans → Electronic Switched Network → Coordinated Dialing Plan (CDP) → Distant Steering Code (DSC). In the Distant Steering Code List page, select Add from the drop down list as shown below.

Enter the value of the DSC and click on the to Add button (Not Shown). As shown below 39 was added during the solution testing. The value 39 was configured since the pilot DN of the AAM was 39900.
Flexible Length number of digits identifies length of the directory number (DN). During solution testing, a value of 5 was configured.

Route List to be accessed for trunk steering code is selected as 1 from the drop down list. This value is selected based on the RLB created in above step.

For additional information on Route, RLB and DSC configuration, refer to Section 12.
5.6. Endpoint/Telephone Configuration

This section explains the provisioning of an endpoint/telephone that was configured for the solution testing. Endpoint/Telephone can be configured using the CLI of the Communication Server 1000 from overlay LD 11/20. Refer to Section 12 for further information regarding the addition/configuration of endpoints/telephones.

In figure below, values that are shown in red are to be configured by the user. The FDN and HUNT value of 39900 was used during the solution testing as the pilot DN of the Avaya Aura Messaging.

```
Ld 11
REQ: prt
TYPE: 1165
TN   096 0 00 17
FDN  39900

... CLS UNR FBA WTA LPR MTD FNA HTA TDD HFA CRPD
      MWA LMPN RMMN SMWD AAD IMD XHD IRD NLD OLD VCE DRG1
      POD SLKD CCSD SWD LNA CNDA
      CFTD SFA MRD DDD CNID CDCA MSID DAPA BFED RCBD
      ICDD CDMD LLCN MCTD CLBD AUTU
      GPU DPD DNDA CFXA ARHD CLTD ASCD
      CPFA CPTA ABDD CFHD FICD NAID BUZZ AGRD MOAD
      UDI RCC HBT DHD IPND DDGA NAMA MIND PRSD NRWD NRCD NROD
      DRDD EXR0
      USMD USRD ULAD CCBT RTDD RADD RBHD PGND FLXD FTTC DNDY DNO3 MCBN
      FDSD NOVD VOLA VOUO CDMR PRED RECD MCD T87A SBMD
      KEM3 MSSD[MSBT] FRA PRCH MUTA MWTD DVLD CROD ELCD
      CPND_LANG ENG
      RCO  0
      HUNT 39900

... KEY 00 SCR 54312 0 MARP
      CPND
      CPND_LANG ROMAN
      NAME DN 54312
      XPLN 13
      DISPLAY_FMT FIRST, LAST
```
5.7. Fax setting
In the EM navigate to navigate to Media Gateways, verify Enable modem/fax pass through mode and Enable V.21 FAX tone detection are checked.

Verify MGC's (and VGW trunks) should be in a Zone with Best Quality (BQ)
Verify the following Class Of Service is enabled for fax TNB: **FAXA** (Fax allowed) and **MPTD**. This setting will allow lower speed faxes (up to 14.4) to use T.38, and higher speed faxes to use G711 clear channel (no echo cancelation, no nonlinear DSP features).

```
DES  FROX
TN  004 0 05 00 VIRTUAL
TYPE 500
CDEN 4D
CUST 0
MRT
ERL 00000
WRLS NO
DN 54040 0 MARP
CPND
  CPND_LANG ROMAN
  NAME Frox analog
  XPLN 23
  DISPLAY_FMT FIRST,LAST
AST NO
IAFG 0
HUNT
TGAR 1
LDN NO
NCOS 0
SGRP 0
RNFG 0
XLST
SCI 0
SCFW
SFLT NO
CAC_MFC 0
CLS CTD DTN ...
  MBXD CFPA CPTA UDI RCC HBTD IRGD DDGA NAMA MIND
  NRWD NRCD NROD SPKD CRD PRSD MCRD
  EXRO SHL SMD ABDD CFHD DNDY DNO3
  CWD USMD USRD CCBD BNRD OCDT RTDD RBDD RBHD FAXA CNUD CNAD PGND FTTC
  FSDS NOVD CDMR PRED MCDD T87D SBMD PKCH MPTD ELCD
PLEV 02
PUID
UPWD
AACS NO
MLWU_LANG 0
DATE 4 JUL 2011
```
6. Configure Avaya Aura® Messaging

Messaging was configured for SIP communication with Session Manager. The procedures include the following areas:

- Administer Sites
- Administer Telephony Integration
- Administer Dial Rules
- Administer Class of Service to enable Message Waiting
- Administer Subscribers

See references Section 12 for standard installation and configuration information. General knowledge of the configuration tools and interfaces is assumed.

6.1. Administer Sites

A Messaging access number and a Messaging Auto Attendant number needs to be defined. Log into the Messaging System Management Interface (SMI) and go to Administration → Messaging. In the left panel, under Messaging System (Storage) select Sites, click Add New. In the right panel fill in the following:

Under Main Properties:
- Name: Enter site name
- Internal Messaging access number: Enter a Messaging Pilot number
Scroll down to the **Site Internal Dial Plan** section.

Under **Site Internal Dial Plan:**

- **Short Extension Length**   Enter the number of digits in extensions
- **Short Mailbox Length**     Enter the number of digits in mailbox numbers

![Site Internal Dial Plan](image)

Scroll down to the **Auto Attendant** section.

Under **Auto Attendant:**

- **Auto Attendant**      Select **Enabled**
- **Auto Attendant pilot number** Enter an Auto Attendant number
- **Keypad entry**       Select **ENHANCED**
- **Speech recognition** Select **Enabled**

Click **Save** to save changes.

![Auto Attendant](image)
6.2. Administer Telephony Integration

A SIP trunk needs to be configured from Messaging to Session Manager. Log into the Messaging System Management Interface (SMI) and go to Administration → Messaging. In the left panel, under Telephony Settings (Application) select Telephony Integration. In the right panel fill in the following:

Under Basic Configuration:
- Switch Integration Type: SIP
- IP Address Version: IPv4

Under SIP Specific Configuration:
- Transport Method: TCP
- Connection 1 Enter the Session Manager signaling IP address and TCP port number
- Messaging Address Enter the Messaging IP address and TCP port number
- SIP Domain Enter the Messaging and Session Manager domain names

Click Save to save changes.
6.3. Configure Dial Rules
Navigate to Administration Messaging→Server Settings (Application)→Dial Rules to configure the dial rules. Set the **Dial plan handling style** field to **Site definition based** as shown below.

![Dial Rules Configuration](image)

Next select the **Edit Dial-Out Rules** button to verify the appropriate parameters for outbound dialing from Avaya Aura® Messaging were set above. These dial rules help Avaya Aura® Messaging send the correct number and combination of digits when originating a call to Communication Server, whether the call is destined for another extension or ultimately expected to be routed to the PSTN.

![Dial-Out Rules Configuration](image)
6.4. Configure Class of Service

Verify Messaging Waiting is enabled for all subscribers.

Use Administration → Messaging menu and select Class of Service under Messaging System (Storage). Select “Standard” from the Class of Service drop-down menu.

Under General section, enter the following value and use default values for remaining fields.

- Select Dial-out privilege to Local.
- Check Set Message Waiting Indicator (MWI) on user’s desk phone.

Click Save (not shown) to save changes.

The following screen shows the settings defined for the “Standard” Class of Service in the sample configuration.
6.5. Administer Subscribers

Log into the Messaging System Management Interface (SMI) and go to Administration → Messaging. In the left panel, under Messaging System (Storage) select User Management. In the right panel fill in the following:

Under User Properties:

- **First Name** Enter first name.
- **Last Name** Enter last name.
- **Display Name** Enter display name.
- **ASCII name** Enter the ASCII name.
- **Site** Enter site defined in Section 6.1.
- **Mailbox Number** Enter desired mailbox number.
- **Internal identifier** Enter the name for internal use.
- **Numeric address** Enter the mailbox number.
- **Extension** Enter desired extension number.
Scroll down on the page to Class of Service.

- **Class of Service**: Select a Class of Service
- **Pronounceable Name**: Enter a pronounceable name to be used when dialing the extension using voice commands
- **MWI Enabled**: Select Yes to enable the MWI light on phones
- **New Password/Confirm Password**: Enter desired extension password
- **User must change voice messaging password at next logon**: Select the Checkbox

Click **Save** to save changes.
6.6. Administer Topology
Select Topology under Messaging System (Storage).
Verify the site created in above section is Active.

6.7. Administer External Host
Messaging uses an external SMTP relay host to forward text notifications and outbound voice.
Messages enable this function by configuring the mail gateway on the External Hosts Web page.

Select Server Settings (Storage) ➔ External Hosts, and click Add.
In Add a New External Host page:
- IP Address: Enter IP address of the External SMTP Server, in this compliance test it is IP address of ESNA server.
- Host Name: Enter host Name of the External SMTP Server. This case is ESNA host name.

Below is detail of ESNA Server configured in this compliance test:
6.8. Recording Format
This setup is needed as ESNA is only able to recognize the record in GSM format only.

6.9. Configure Notify Me
The Notify Me setting is used to allow a user to be notified on iLink Pro when they have the voice message from Avaya Aura Messaging. In the left panel, under Messaging System (Storage), select User Management. In the right panel enter mailbox number (e.g. 54000) and click Edit. Scroll right down to User Preferences and select Open User Preference for Mailbox number user name:

In the User Preferences detail screen, select Notify Me. In the Notify Me detail page, enable checkbox for Email me a notification for each voice message to iLink Pro user’s email address. For example, during compliance testing, the following email was used for the iLink Pro user that has extension 54000: 54000@ESNAhostname , with the option Include the recording. Click Save.
7. Configure Avaya Aura® Session Manager

This section provides the procedures for configuring Session Manager as provisioned in the reference configuration. Session Manager is comprised of two functional components: the Session Manager server and the System Manager server. All SIP call provisioning for Session Manager is performed through the System Manager Web interface and is then downloaded into Session Manager.

The following sections assume that Session Manager and System Manager have been installed and that network connectivity exists between the two platforms.

In this section, the following topics are discussed:

- SIP Domains
- Locations: Logical/physical location that can be occupied by SIP Entities.
- SIP Entities corresponding to Communication Server 1000, Avaya Aura® Session Manager Messaging and Officelinx.
- Entity Links, which define the SIP trunk parameters used by Avaya Aura® Session Manager when routing calls to/from SIP Entities.
- Routing Policy, which control call routing between the SIP Entities.
- Dial Patterns, which govern to which SIP Entity a call is routed.

It may not be necessary to create all the items above since some of these items would have already been defined as part of the initial Avaya Aura® Session Manager installation. This includes items such as certain SIP domains, locations, SIP entities and Avaya Aura® Session Manager itself. However, each item should be reviewed to verify the configuration.
7.1. Configure SIP Domain
Launch a web browser, enter “https://<IP address of System Manager>/SMGR” in the URL, and log in with the appropriate credentials.

Create a SIP domain for each domain for which Avaya Aura® Session Manager will need to be aware in order to route calls. For the compliance test, this includes the enterprise domain: bvwdev.com.

Add a domain, navigate to Routing → Domains, and click on the New button (not shown) to create a new SIP Domain. Enter the following values and use default values for remaining fields:
- **Name** – Enter the Authoritative Domain Name, which is bvwdev.com.
- **Type** – Select SIP

Click Commit to save. The following screen shows the Domains page used during the compliance test.

![Domains page](image)

7.2. Configure Locations
Locations are used to identify logical and/or physical locations where SIP Entities reside, for purposes of bandwidth management or location-based routing. Navigate to Routing → Locations, and click on the New button (not shown) to create a new SIP endpoint location.

In **General** section, enter the following values and use default values for remaining fields.
- Enter a descriptive Location name in the **Name** field.
- Enter a description in the **Notes** field if desired.

In **Location Pattern** section, click **Add** and enter the following values:
- **IP address Pattern**: Enter the IP Pattern to identify the location.
- **Notes**: Enter a description in the **Notes** field if desired.
The following screen shows the **Locations** page used during the compliance test. Click on the **Commit** button.

### Locations Page

- **General**
  - Name: Belleville
  - Notes: Belleville DevConnect Location

- **Dial Plan Transparency in Survivable Mode**
  - Enabled: False
  - Listed Directory Number: 
  - Associated CM SIP Entity: 

### Location Pattern

- **Add**
- **Remove**

- **IP Address Pattern**
  - *10.33.3.0*
  - *10.10.97.0*
  - *10.10.98.0*
  - *10.30.0.0*
  - *10.10.169.*

- **Notes**
  - IP Phone Net 10.33.3.0
  - IP Phone Net 10.10.97.0
  - IP Phone Net 10.10.98.0
  - 
  - For remote access site

Navigate to **Routing → SIP Entities**, and click on the **New** button (not shown) to create a new SIP entity. Provide the following information:

Enter the following values and use default values for remaining fields.

- **Enter a descriptive name in the Name field.**

### 7.3. Configure SIP Entities

A SIP Entity must be added for Avaya Aura® Session Manager and for each network component that has a SIP trunk provisioned to Session Manager. During the compliance test, the following SIP Entities were configured:

- Session Manager itself.
- Communication Server 1000
- Messaging
- ESNA Officelinx
- Enter **IP address** of SIP Entity that used for SIP signaling. Enter IP address of Communication Server 1000, Session Manager, Messaging and Officelinx.
- From the **Type** drop down menu select a type that best matches the SIP Entity. For Communication Server 1000, select **Other** For Session Manager, select **Session Manager**. For Messaging, select **Modular Messaging**. For **Officelinx**, select **Other**
- Enter a description in the **Notes** field if desired.
- Select the appropriate location.
- Select the appropriate time zone.
- Accept the other default values.

Click on the **Commit** button to save configuration for each SIP Entity. The following screens show the SIP Entities page used during the compliance test.

Session Manager SIP Entity:
Communication Server 1000 SIP Entity:

AAM SIP Entity:
ESNA Officelinx Entity:
7.4. Configure Entity Links

Entity Links define the connections between the SIP Entities and Session Manager. In the compliance test, the 3 entities links are defined: one to Communication Server 1000, one to Messaging and one to Officelinx. Add an entity link, navigate to Routing → Entity Links, and click on the New button (not shown) to create a new entity link. Provide the following information:

- Enter a descriptive name in the Name field.
- In the SIP Entity 1 drop down menu, select the Session Manager SIP Entity.
- In the Protocol drop down menu, select the protocol to be used.
- In the Port field, enter the port to be used, UDP or TCP – 5060
- In the SIP Entity 2 drop down menu, select an entity for desired entity.
- In the Port field, enter the port to be used (e.g. 5060).
- Select the Trusted option.
- Enter a description in the Notes field if desired.

Click on the Commit button to save each Entity Link definition. The following screen shows an Entity Links page (between Session Manager and Messaging) used during the compliance test.

Repeat the steps to define an Entity Link between Session Manager and Communication Server 1000 (UDP – 5060).

Entity Link page (between Session Manager – ESNA Officelinx): DevSM_ESNA_5060_TCP
7.5. Configure Routing Policies
Routing policies describe the conditions under which calls will be routed to the SIP Entities. Three routing policies must be added: one for Communication Server 1000, one for Messaging and one to Officelinx. To add a routing policy, navigate to Routing → Routing Policies in the left-hand navigation pane and click on the New button in the right pane (not shown). The following screen is displayed. Fill in the following: In the General section, enter the following values. Use default values for all remaining fields:
- **Name**: Enter a descriptive name.
- **Notes**: Add a brief description (optional).

In the SIP Entity as Destination section, click Select. The SIP Entity List page opens (not shown). Select the appropriate SIP entity to which this routing policy applies and click Select. The selected SIP entity displays on the Routing Policy Details page as shown below. Use default values for the remaining fields. Click Commit to save. The following screen shows the Routing Policy to Communication Server 1000.

Repeat the steps to define routing policies to others Entities. Routing policy used for Messaging: Route-To-DevAAM.

![Routing Policy Details](image-url)
Routing policy used for ESNA Officelix: **Route_to_ESNA.**

### 7.6. Configure Dial Patterns

Dial Patterns define digit strings to be matched for inbound and outbound calls. In addition, the domain in the request URI is also examined. In the compliance test, the following dial patterns are defined from Session Manager:

- 54xxx – SIP endpoints
- 399xx – Pilot Number.
- 78xxx – Officelix Number

To add a Dial Pattern, select **Routing → Dial Patterns**, and click on the **New** button (not shown) on the right. During the compliance test, 5 digit dial plan was utilized. Provide the following information:

In the **General** section, enter the following values. Use default values for all remaining fields:

- **Pattern**: Enter a dial string that will be matched against the Request-URI of the call.
- **Min**: Enter a minimum length used in the match criteria.
- **Max**: Enter a maximum length used in the match criteria.
- **SIP Domain**: Enter the destination domain used in the match criteria.
- **Notes**: Add a brief description (optional).

In the **Originating Locations and Routing Policies** section, click **Add**. From the **Originating Locations and Routing Policy List** that appears (not shown), select the appropriate originating location for use in the match criteria. Lastly, select the routing policy from the list that will be used to route calls that match the specified criteria. Click **Select**.

Default values can be used for the remaining fields. Click **Commit** to save.
Click the **Commit** button to save the new definition. The following screen shows the dial pattern used for Communication Server 1000 during the compliance test.

Below is Dial Pattern for AAM:
Dial Pattern for ESNA Officelinx: 78xxx.
8. Configure Avaya ACE 6.2 FP2

8.1. Add Communication Server 1000 TR/78 Service Provider

Add an Avaya CS 1000 TR/87 network element as a service provider on the Avaya ACE to enable communications between the Avaya CS 1000 element and the Avaya ACE using TR/87 protocol without advanced services support. On the menu bar, choose Configuration ➔ Service Providers. In the Service Providers window, click Add as shown below:

Select Service Provider type and enter name as below:

- **Type**: select Avaya Communication Server 1000(CS 1000).
- **Name**: enter a name for the CS10000 service provider.

Click **Continue**. Enter detail information for Service Provider:

- **Signaling**: select TR87.
- **Transport**: select UDP.
- **IP Address**: enter the IP address of the Communication Server 1000 Node.
- **Port**: accept the default 5060 as the Transport is UDP.

![Configuration Settings](image1.png)

- **CS 1000 HLOC**: For networks with multiple systems (for example, an IP Peer Network), enter a one to seven-digit Home Location Code (HLOC) for the CS 1000, and click **Add**. To find what is HLOC of CS1K, login to EM, select Dialing and Numbering Plans – Electronic Switch Network (ESN) and click on HLOC.
- **Use CS 1000 Domain Name**: select checkbox. You must specify a CS 1000 domain name (which Avaya ACE appends to the outgoing TR/87 messages) so that messages can be routed to the appropriate node on the CS 1000.
- **Domain Name**: enter the CS 1000 domain name. In compliance test **bvwdev.com** is used.

![Address Configuration](image2.png)

Click **Next** to add Address for CS1K TR87 Service provider. Configure the route address to indicate from where a call is originating.

A route address represents the third party in a third party call control call. When adding a service provider that supports third party call control, the system automatically adds a default route.
address (sip:AppCore@avaya.com), modify this URI if needed. During compliance test the URI was modified to sip:AppCore@bwdev.com

Click **Next** to enter the rule for TR87 Service Provider. Configure simple translation rules to route a web service request to a particular service provider and if necessary, transform the parameters in the request, before presenting them to the service provider.

Enter information for **Calling Party Translation Rule - Simple Configuration** as shown below:

- **URI Scheme** : tel
- **Range From/To**: 54000-54399
- **Activate Rule**: checked box.

Click **Add** to add a new rule.

Click **Switch to Advanced Configuration** to add an Advanced Reserve Transformation rule. This configure is to remove phone-context in the Call event.

- **Matching Pattern** enter: tel:(\d{5});(.+).
- **Transform URI Rule** enter: tel:$1.

This is specific to the DevConnect lab configuration during compliance test in order to transfer tel:54331;phone-context=cdp.udp to tel:54331
Below figure is an example of Calling Party Translation Rules during testing this solution:

Click **Next** to configure called party translation rules. Click **Submit** to save the rule configuration.

Verify the status of added service providers is **“In Service”**: 
8.2. Add User
The web service client ESNA Officelinx – Avaya ACE Wizard is a configured user on Avaya ACE.

The web service client belongs to a user group on Avaya ACE with a group type of user or higher, and with the appropriate access control rules configured for the Third Party Call Control (v2) service. See next section for steps on how to create new role for user.

Select Security  User Management  Create User
- **User ID**: used to login ACE web service of the web client (application) (e.g, ESNA_Admin)
- **Account State**: Enable
- **Password**: password (e.g, DevConnect@123)

Select **Submit** to create user. Below is the screenshot of the ACE user used during compliance test:

![User Management Screenshot](image-url)
8.3. Add Role
This section describes the step on how to create Role for user created in above section.

Select Security ➔ Role Management ➔ Create Role. Enter the following for a new Role:
- **Name:** Enter any name for the new Role.
- **Role Member:** select user in the left panel and move it into the Role member.

This is the screenshot of the role that was used during Compliance Test.

![Role Management screenshot](image)

Click on License Membership tab of Role window, and assign API Integration Suite license to Member Licenses (not shown). Turn ON the following services: CallForwardingService, ThirdPartyCallService, CallNotification Service of API Integration Suite. Click Submit to save changes.

![License Membership screenshot](image)
9. Configure the ESNA Telephony Officelinx

ESNA installs, configures, and customizes the Telephony Officelinx application for their customers. Thus, this section only describes the interface configuration, so that the Telephony Officelinx can talk to Session Manager, ACE and Messaging. See OL_CLIENT_APPS_GUIDE and OL_FEATURE_DESCRIPTION_GUIDE provided on the ESNA website (see Section 12 for the detailed link).

9.1. Configure SIP Configuration Tool

To configure ESNA Telephony Officelinx, navigate to Start ➔ All program ➔ Telephony Officelinx Enterprise Edition ➔ SIP Configuration Tool. Select Avaya under PBX in the left pane. Provide the following information:

- **Name** – Type in any descriptive name.
- **IP Address** – Enter IP address of Session Manager, example: 10.10.97.198.
- **Realm** – Enter a valid domain that is configured in the system, example: bvwdev.com.
- **UDP Port** – Enter 5060
- **TCP Port** – Enter 5060
Click the **Advanced** tab in the right pane, and check the following check boxes:

- **Enable Internal Bridging**
- **Use TCP**
- **Accept Refer**
- **Accept Forward Calls**
Click the **MWI** tab, and check the **Force MWI** checkbox.
Click on the **OK** button.

The following line must be added to the SIP Configuration file (**ETSIPService.ini**, found under `C:\Windows\`) manually under the [PBX#] heading:

**Subscription State for MWI = 0**

This provides a subscription state line in the message body indicating a subscription state is active; this is required even for unsolicited Notify messages for MWI with Session Manager.
Click **PBX – General Settings**. Set **Buffer Size (kb)** to 4096. This configuration allows Officelinx to handle SIP messages sent from Session Manager.

![SIP Configuration Tool](image)

### 9.2. Configure UC ACE Wizard

Double click on UC ACE Wizard shortcut to launch the setup window for Avaya ACE Wizard. Enter information as below:

- **User Name**: Enter user that created on Avaya ACE in **Section 8.2**
- **Password**: the password for the ACE user created in **Section 8.2**.
- **IP Address**: Avaya ACE IP address.
- **Domain**: Enter domain name used in the system, during compliance test bvwddev.com used.

![Avaya ACE Wizard](image)
Click on **Nodes** to open the next window where a user manually enters the device extension to get its notification. Click on **Next** button (not shown).

Select a device from the list of devices on the left side and add it to the right window to start to monitor it. Or a user can remove a device from the monitor list by selecting a device to highlight it and then clicking **Remove**.

---

**9.3. Administer Company Profiles**

In the **Company**, modify the **Domain Name/IP Address** in FQDN format. This domain name is used in **Section 6.9** for **Notify Me** on Avaya Aura Messaging.
9.4. Configure User Mailbox in Officelinx Admin

Expand the Officelinx → Esna Interop → Default → Mailbox Structure. In the right panel, right click on the window, and select new to add new mailbox.

This section describes a sample configuration of mailbox 52167 for device 9608 H323 and this mailbox is linked to Google mail account managed by ESNA dev02@solution.com.

In General tab:

- **Mailbox Number**: enter the extension of physical device.
- **Feature Group**: select 1: Default Users; this is a super group which was setup to ensure there are no conflicts between Officelinx and Gmail. For more information, please see the document from ESNA in Section 12.
- **Last Name**: enter any name, example: ThreeOne.
- **First Name**: enter any name, example: SixSeven.

![Mailbox Configuration Image]

This section describes a sample configuration of mailbox 52167 for device 9608 H323 and this mailbox is linked to Google mail account managed by ESNA dev02@solution.com.

In General tab:

- **Mailbox Number**: enter the extension of physical device.
- **Feature Group**: select 1: Default Users; this is a super group which was setup to ensure there are no conflicts between Officelinx and Gmail. For more information, please see the document from ESNA in Section 12.
- **Last Name**: enter any name, example: ThreeOne.
- **First Name**: enter any name, example: SixSeven.
In **Advanced** tab:

- **Domain Account Name**: enter the *Gmail account* which connects to this mailbox dev02@solution.com.
- **Desktop Capabilities**: select Unified Communications.
In **Synchronization Options** tab:

- **Use Feature Group setting for IMAP**: make sure this option is checked.
- **User Name**: enter google email account.
- **Storage Mode**: IMAP.
- **Voice Format**: MPEG-1 Audio layer 3 (MP3).
- **E-mail**: enter google email account dev02@solution.com

Click the **Save** icon to save the configuration.
9.5. Configure Fax

ESNA installs, configures, and customizes the Telephony Officelinx Fax Server for their customers. Please refer to ESNA Feature Description Guide, Chapters 18 and 19: Faxing and Soft faxing. See References (Section 12) for details.

Thus, this section only describes the interface configuration used during compliance test, so that the user can send a fax-email from a fax machine to an iLink Pro user’s mailbox.

As there are more than one method of setting up fax, and ultimately it will depend on the nature of the enterprise fax requirements for setup, fax setup is out of scope for this application note.

Expand the Officelinx → Esna Interop → Default → Voice Menu. Double click on Menu Number 1 – Test Fax Default. Make sure the Default to Company option is checked. Default: Send to Fax Start Tone (Mailbox=52167…) as shown in below figure:

![Voice Menu - Test Fax Default](image)

Note: This configuration was used because when a user sends the fax to Officelinx, there is no fax tone sent from Officelinx Server, and the fax on Communication Server 1000 is waiting. As a result, the fax gets no answer. It is necessary to check the “Default to Company” option with Default “Send to Fax start Tone” on Officelinx in order for Officelinx send fax tones to a fax machine.
9.6. Install and Configure iLink Pro

Using Google Chrome, browse to Chrome store. Perform the search for iLink Pro. Select the Extensions tab. Click on Add to Chrome to install ESNA iLink Pro. Follow the instructions to install iLink Pro.

In Chrome browser, log in as dev02 Google account. Click on the iLink Pro icon to launch iLink Pro.

- On the login credentials to log in to iLink Pro, select Use Google credentials. Click Login.
Following the instructions on the web to choose a google account to log in iLink Pro (not shown). Below is the screenshot of a user successfully logged in to iLink Pro.
10. Verification Steps

This section provides the tests that can be performed to verify proper configuration of Communication Server 1000, Session Manager, ACE, Messaging and ESNA Officelinx – iLink Pro application.

10.1. Verify Avaya Communication Server 1000 Release 7.6

After the telephone sets have been properly configured on Communication Server 1000, they should be in an “acquired” state which means that they are under control of the AML. This can be verified by using Overlay 20 on Communication Server 1000 to print the Terminal Number Block (TNB) for any phone as per the following example: Phone is in acquired state of the AML 36 setup in Section 5.4.1.

```
Ld 20
REQ: prt
TYPE: tnb
TN  96 0 1 3

DES 1150
TN  096 0 01 03 VIRTUAL
TYPE 1150
CDEN 8D
CTYP XDLC
CUST 0
CUR_ZONE 00001
AST 00
IAFG 0
AACS YES
ACQ AS: AST-DN
ASID 36
SFB  1  2  3  5  6  7  8  9  10  11  12  13  15  16  17  18  19  20  21  22  23
24  25  32  33  34  35  36  37  38  39
SFRB  32  33  34  35  36  37  38  39
USFB  1  2  3  4  5  6  7  8  9  10  11  12  13  14  15
CALB  0  1  2  3  4  5  6  7  8  9  10  11
FCTB
ITNA NO
DGRP
MLWU_LANG 0
MLNG ENG
DNDR 0
KEY  00 SCR 54314 0 MARP
    CPND
    CPND_LANG ROMAN
    NAME 1150E
    XPLN 13
    DISPLAY_FMT FIRST, LAST
    01
    02 CWT
    03
```
10.2. Verify Avaya Aura® Session Manager

10.2.1. Verify Avaya Aura® Session Manager is Operational
Navigate to Elements → Session Manager → Dashboard (not shown) to verify the overall system status for Session Manager.

Specifically, verify the status of the following fields as shown below:
- **Tests Pass:**
- **Security Module:** Up
- **Service State:** Accept New Service

10.2.2. Verify SIP Entity Link Status
Navigate to Elements → Session Manager → System Status → SIP Entity Monitoring (not shown) to view more detailed status information for one of the SIP Entity Links.

Select the SIP Entity for ACE from the All Monitored SIP Entities table (not shown) to open the SIP Entity, Entity Link Connection Status page.

In the All Entity Links to SIP Entity: DevACEsrv table, verify the Conn. Status for the link is “Up” as shown below.

Repeat the same step to verify the status of Messaging, Communication Server and Officelinx are “Up”.

PM; Reviewed: SPOC 4/23/2014 Solution & Interoperability Test Lab Application Notes ©2014 Avaya Inc. All Rights Reserved. ESNA91CS1K76
10.3. Verify make call using ACE Web Service Trainer

Make a call using the ACE Web Service Trainer. Below is an example of using ACE Exhibitor: make a call from 54000 to 54317. Verify the call is made successfully.
10.4. Verify Avaya Aura® Avaya ACE

10.4.1. Verify Avaya ACE Server status

Select Configuration → Server to verify the status of the server:

<table>
<thead>
<tr>
<th>Active Server Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hostname</td>
</tr>
<tr>
<td>Fixed IP Address</td>
</tr>
<tr>
<td>Service IP Address</td>
</tr>
<tr>
<td>Operating System Time</td>
</tr>
<tr>
<td>Operating System Uptime</td>
</tr>
<tr>
<td>Operating System Version</td>
</tr>
<tr>
<td>Application Server Status</td>
</tr>
<tr>
<td>Application Server Uptime</td>
</tr>
<tr>
<td>Application Server Version</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>ACE Core Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application Status</td>
</tr>
<tr>
<td>Application Uptime</td>
</tr>
<tr>
<td>Application Version</td>
</tr>
<tr>
<td>Application Build</td>
</tr>
<tr>
<td>Application HostType</td>
</tr>
<tr>
<td>Associated Information</td>
</tr>
</tbody>
</table>
10.5. Verify Avaya Aura Messaging

10.5.1. Verify Avaya Aura Messaging can make a call to phones
Test calls can be made from AAM to phones that are configured with mailboxes. To perform this
test, select Administration → Messaging. In the left panel, under Diagnostics select
Diagnostics (Application). In the right panel fill in the following:

- Select the test(s) to run: Select Call-out from the drop down menu.
- Telephone number: Enter the number to call.

Click on Run Tests to start the test. The phone will ring and when answered a test message is
played. The Results section of the page will update indicating that the call was ok as shown
below.
10.5.2. Verify user can receive and retrieve Avaya Aura Messaging voice message using Google Mail

Make a call from an iLink Pro to another device. Verify that the call covers to Messaging upon no answer. Leave a voice message. Verify that the MWI light of the called phone turns on. Log on to the ESNA Google mail account of called user to verify that user got the message from Avaya Aura Messaging and listen to the voice message. Verify that the MWI light turns off. (Notes: At this version of Officelinx 9, when messages are read, Officelinx should attempt to extinguish MWI via SIP if possible. This will not reflect actual message status on Aura Messaging). The example below shows a user has an incoming AAM voice message in the mailbox.
10.6. Verify ESNA Officelinx server and iLink Pro

10.6.1. Verify the log file UCServer of ESNA Officelinx.

Log on to Officelinx, and open the log file UCServerYYYYMMDD.log in C:\UC\Logs\VServer. The log screenshot below shows that Officelinx successfully monitored devices on CS1K as well as call information.

```
11:41:07.390-[+] [00000004] [F:Init] client: 135.10.98.120 Port : 88
11:41:07.671-[+] [00000004] [F:Init] VirtualAddr: http://135.10.98.120:88/
11:41:07.796-[+] [0000000C] [F:EventHandler] Start listening
11:41:07.859-[+] [0000000C] [F:EventHandler] assembly location
C:\WINDOWS\system32\UCACEServer.dll
11:41:07.890-[+] [00000004] [F:Initialize] Wait for HttpListener to start listening
11:41:08.437-[+] [00000004] [F:Initialize] Adding Devices to DeviceList
11:41:08.437-[+] [00000008] [F:Initialize] Exit NoOfDevices: 11
11:41:08.500-[+] [00000004] [F:Initialize] HttpListener is listening
11:41:10.125-[+] [00000004] [F:Initialize] Starting EventThread
11:41:10.437-[+] [00000003] [F:ESACEAgent:EventHandlerProc]Entry:
11:41:15.015-[] [00000004] [F:CallNotification:StartNotification] CallNotification(Called) is started at http://135.10.98.120:88/ACENotificationServer
11:41:15.140-[] [00000004] [F:CallNotification:StartNotification] CallNotification(Calling) is started at http://135.10.98.120:88/ACENotificationServer
11:42:25.187-[] [0000000A] [F:MakeCall] Entry Dest: 52156
11:42:25.187-[] [0000000A] [F:MakeCall] DestBuffer: 52156
11:42:25.218-[+] [0000000A] [F:CallControl.MakeCall] Calling: tel:52150 Called: tel:52156
11:42:25.234-[+] [00000010] [F:CallProgressCallBack] Entry Dest: 52156
11:42:25.437-[+] [00000004] [F:makeCallCompleted] Result: 3b21cc7a-4ae4-4b74-b007-ca5e35f75c2e
11:42:25.437-[+] [00000004] [F:UpdateCall] >>>>> Key: 52150 1_3b21cc7a-4ae4-4b74-b007-ca5e35f75c2ewas added
11:42:25.437-[+] [00000004] [F:PutEvent:makeCallCompleted] Event: <CMDRESULT><InvokeID>1</InvokeID><Device EvtDevice="True"><DeviceID>52150</DeviceID><NodeID>1</NodeID><Type>IPPHONE</Type></Device><Call><ID>3b21cc7a-4ae4-4b74-b007-ca5e35f75c2e</ID></Call></CMDRESULT>
11:42:27.484-[+] [00000003] [F:EventHandlerProc] Recieved call Notification: Correlator: Calling ACEServer@135.10.98.120 Event: CalledNumber Desc: Calling: tel:52150 Calling Name: Called: tel:52156 CallID: 3b21cc7a-4ae4-4b74-b007-ca5e35f75c2e
```
10.6.2 Verify User can make a call using iLink Pro

Have a user log in to the ESNA Gmail account as created in Section 9.3. Verify the user is able to click and call another user on the list. Verify the called party is ringing. The called party can pick up the device, anda 2-way voice path is established.

Below is screenshot of the active call along with call information.
10.6.3. Verify user can send fax through email

In the Google mail, click **Compose** to start a new message. In the To: field, enter a full fax address. For example, during the compliance test, `fax=54174@ESNHostname` is used. Enter subject and fax content, and click **Send**.

Verify that the user will received an email from **Postmaster** to ask the user to activate their fax request (shown below). Click on the provided link to confirm (not shown). Verify that fax machine is able to receive and print out the fax content.
11. Conclusion
Interoperability testing of Avaya Aura® Agile Communication Environment, Avaya Aura® Messaging, and Avaya Communication Server 1000 Release 7.6 with Officelinx 9.1 – iLink Pro was completed and passed with observations are noted in Section 2.2.

12. Additional References
The following Avaya product documentation can be found at http://support.avaya.com
1. SIP Line Fundamentals Avaya Communication Server 1000 (NN43001-508).
2. Element Manager System Reference - Administration Avaya Communication Server 1000 November 2013 NN43001-632 Issue 06.03
3. Administering Avaya Aura® Session Manager, June 2013, Release 6.3
5. Avaya Agile Communication Environment™ Service Provider Administration NN10850-005,
6. For an alternate procedure to configure a signing authority as trusted on Avaya ACE, see
  "Trusting a CA or self-signed certificate" in Avaya Agile Communication Environment™
  User and Security Administration (NN10850–010).

The following document was provided by ESNA: