Oracle Java Critical Patch Update (April 2014)

Original Release Date: May 16, 2014
Last Revised: September 11, 2017
Number: ASA-2014-203
Risk Level: Low
Advisory Version: 4.0
Advisory Status: Final

1. Overview:

New Java Critical Patch Updates or Security Alerts have been issued by Oracle on Oracle's Critical Patch Updates and Security Alerts website. Specific updates or alerts pertaining to this advisory are described below. The Oracle Advisory covering content outlined in this Avaya Security Advisory may be found in Oracle Java SE Critical Patch Update Advisory - April 2014 and contains the following security issues.

Vulnerability in the Java SE, JRockit, Java SE Embedded component of Oracle Java SE (subcomponent: 2D). Supported versions that are affected are Java SE 5.0u61, Java SE 6u71, Java SE 7u51, Java SE 8, JRockit R27.8.1, JRockit R28.3.1 and Java SE Embedded 7u51. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized Operating System takeover including arbitrary code execution. Note: Applies to client and server deployment of Java. This vulnerability can be exploited through sandboxed Java Web Start applications and sandboxed Java applets. It can also be exploited by supplying data to APIs in the specified Component without using sandboxed Java Web Start applications or sandboxed Java applets, such as through a web service. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0429 to this issue.

Vulnerability in the Java SE, JRockit, Java SE Embedded component of Oracle Java SE (subcomponent: Libraries). Supported versions that are affected are Java SE 5.0u61, Java SE 6u71, Java SE 7u51, Java SE 8, JRockit R27.8.1, JRockit R28.3.1 and Java SE Embedded 7u51. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized Operating System takeover including arbitrary code execution. Note: Applies to client and server deployment of Java. This vulnerability can be exploited through sandboxed Java Web Start applications and sandboxed Java applets. It can also be exploited by supplying data to APIs in the specified Component without using sandboxed Java Web Start applications or sandboxed Java applets, such as through a web service. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0457 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Hotspot). Supported versions that are affected are Java SE 6u71, Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized Operating System takeover including arbitrary code execution. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0456 to this issue.

Vulnerability in the Java SE, JavaFX, Java SE Embedded component of Oracle Java SE (subcomponent: 2D). Supported versions that are affected are Java SE 5.0u61, Java SE 6u71, Java SE 7u51, Java SE 8, JavaFX 2.2.51 and Java SE Embedded 7u51. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized Operating System takeover including arbitrary code execution. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-2421 to this issue.

Vulnerability in the Java SE component of Oracle Java SE (subcomponent: JavaFX). The supported version that is affected is Java SE 8. Difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized Operating System takeover including arbitrary code execution. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-2410 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Hotspot). Supported versions that are affected are Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized Operating System takeover including arbitrary code execution. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-2397 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Libraries). Supported versions that are affected are Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized Operating System takeover including arbitrary code execution. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0432 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Libraries). Supported versions that are affected are Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized Operating System takeover including arbitrary code execution. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0455 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Libraries). Supported versions that are affected are Java SE 6u71, Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized Operating System takeover including arbitrary code execution. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0461 to this issue.

Vulnerability in the Java SE component of Oracle Java SE (subcomponent: Deployment). Supported versions that are affected are Java SE 7u51 and Java SE 8. Very difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized Operating System takeover including arbitrary code execution. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0448 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Deployment). Supported versions that are affected are Java SE 6u71, Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Very difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized Operating System takeover including arbitrary code execution. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-2428 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: AWT). Supported versions that are affected are Java SE 5.0u61, Java SE 6u71, Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE, Java SE Embedded accessible data as well as read access to a subset of Java SE, Java SE Embedded accessible data and ability to cause a partial denial of service (partial DOS) of Java SE, Java SE Embedded. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-2412 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: AWT). Supported versions that are affected are Java SE 5.0u61, Java SE 6u71, Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE, Java SE Embedded accessible data as well as read access to a subset of Java SE, Java SE Embedded accessible data and ability to cause a partial denial of service (partial DOS) of Java SE, Java SE Embedded. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0451 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: JAX-WS). Supported versions that are affected are Java SE 6u71, Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE, Java SE Embedded accessible data as well as read access to a subset of Java SE, Java SE Embedded accessible data and ability to cause a partial denial of service (partial DOS) of Java SE, Java SE Embedded. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0458 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: JAX-WS). Supported versions that are affected are Java SE 6u71, Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE, Java SE Embedded accessible data as well as read access to a subset of Java SE, Java SE Embedded accessible data and ability to cause a partial denial of service (partial DOS) of Java SE, Java SE Embedded. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-2423 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: JAX-WS). Supported versions that are affected are Java SE 6u71, Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE, Java SE Embedded accessible data as well as read access to a subset of Java SE, Java SE Embedded accessible data and ability to cause a partial denial of service (partial DOS) of Java SE, Java SE Embedded. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0452 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: JAXB). Supported versions that are affected are Java SE 6u71, Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE, Java SE Embedded accessible data as well as read access to a subset of Java SE, Java SE Embedded accessible data and ability to cause a partial denial of service (partial DOS) of Java SE, Java SE Embedded. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-2414 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Libraries). Supported versions that are affected are Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE, Java SE Embedded accessible data as well as read access to a subset of Java SE, Java SE Embedded accessible data and ability to cause a partial denial of service (partial DOS) of Java SE, Java SE Embedded. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-2402 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Libraries). Supported versions that are affected are Java SE 5.0u61, Java SE 6u71, Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE, Java SE Embedded accessible data as well as read access to a subset of Java SE, Java SE Embedded accessible data and ability to cause a partial denial of service (partial DOS) of Java SE, Java SE Embedded. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0446 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Security). Supported versions that are affected are Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE, Java SE Embedded accessible data as well as read access to a subset of Java SE, Java SE Embedded accessible data and ability to cause a partial denial of service (partial DOS) of Java SE, Java SE Embedded. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0454 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Sound). Supported versions that are affected are Java SE 5.0u61, Java SE 6u71, Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE, Java SE Embedded accessible data as well as read access to a subset of Java SE, Java SE Embedded accessible data and ability to cause a partial denial of service (partial DOS) of Java SE, Java SE Embedded. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-2427 to this issue.

Vulnerability in the Java SE, JavaFX component of Oracle Java SE (subcomponent: JavaFX). Supported versions that are affected are Java SE 7u51, Java SE 8 and JavaFX 2.2.51. Difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE, JavaFX accessible data as well as read access to a subset of Java SE, JavaFX accessible data and ability to cause a partial denial of service (partial DOS) of Java SE, JavaFX. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-2422 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Deployment). Supported versions that are affected are Java SE 6u71, Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE, Java SE Embedded accessible data as well as read access to a subset of Java SE, Java SE Embedded accessible data. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-2409 to this issue.

Vulnerability in the Java SE, JRockit, Java SE Embedded component of Oracle Java SE (subcomponent: JNDI). Supported versions that are affected are Java SE 5.0u61, Java SE 6u71, Java SE 7u51, Java SE 8, JRockit R27.8.1, JRockit R28.3.1 and Java SE Embedded 7u51. Difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE, JRockit, Java SE Embedded accessible data as well as read access to a subset of Java SE, JRockit, Java SE Embedded accessible data. Note: Applies to client and server deployment of Java. This vulnerability can be exploited through sandboxed Java Web Start applications and sandboxed Java applets. It can also be exploited by supplying data to APIs in the specified Component without using sandboxed Java Web Start applications or sandboxed Java applets, such as through a web service. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0460 to this issue.

Vulnerability in the Java SE, JRockit, Java SE Embedded component of Oracle Java SE (subcomponent: AWT). Supported versions that are affected are Java SE 6u71, Java SE 7u51, Java SE 8, JRockit R28.3.1 and Java SE Embedded 7u51. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Java SE, JRockit, Java SE Embedded. Note: Applies to client and server deployment of Java. This vulnerability can be exploited through sandboxed Java Web Start applications and sandboxed Java applets. It can also be exploited by supplying data to APIs in the specified Component without using sandboxed Java Web Start applications or sandboxed Java applets, such as through a web service. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2013-6954 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: AWT). Supported versions that are affected are Java SE 5.0u61, Java SE 6u71, Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized read access to a subset of Java SE, Java SE Embedded accessible data. Note: Applies to client and server deployment of Java. This vulnerability can be exploited through sandboxed Java Web Start applications and sandboxed Java applets. It can also be exploited by supplying data to APIs in the specified Component without using sandboxed Java Web Start applications or sandboxed Java applets, such as through a web service. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2013-6629 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Deployment). Supported versions that are affected are Java SE 6u71, Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized read access to a subset of Java SE, Java SE Embedded accessible data. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0449 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: JAXP). Supported versions that are affected are Java SE 6u71, Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized read access to a subset of Java SE, Java SE Embedded accessible data. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-2403 to this issue.

Vulnerability in the Java SE, JavaFX, Java SE Embedded component of Oracle Java SE (subcomponent: 2D). Supported versions that are affected are Java SE 5.0u61, Java SE 6u71, Java SE 7u51, Java SE 8, JavaFX 2.2.51 and Java SE Embedded 7u51. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized read access to a subset of Java SE, JavaFX, Java SE Embedded accessible data. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-2401 to this issue.

Vulnerability in the Java SE component of Oracle Java SE (subcomponent: Scripting). The supported version that is affected is Java SE 8. Difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized read access to a subset of Java SE accessible data. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0463 to this issue.

Vulnerability in the Java SE component of Oracle Java SE (subcomponent: Scripting). The supported version that is affected is Java SE 8. Difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized read access to a subset of Java SE accessible data. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0464 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: 2D). Supported versions that are affected are Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Java SE, Java SE Embedded. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0459 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Libraries). Supported versions that are affected are Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE, Java SE Embedded accessible data. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-2413 to this issue.

Vulnerability in the Java SE, JRockit, Java SE Embedded component of Oracle Java SE (subcomponent: Security). Supported versions that are affected are Java SE 5.0u61, Java SE 6u71, Java SE 7u51, Java SE 8, JRockit R27.8.1, JRockit R28.3.1 and Java SE Embedded 7u51. Very difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE, JRockit, Java SE Embedded accessible data as well as read access to a subset of Java SE, JRockit, Java SE Embedded accessible data. Note: Applies to client and server deployment of Java. This vulnerability can be exploited through sandboxed Java Web Start applications and sandboxed Java applets. It can also be exploited by supplying data to APIs in the specified Component without using sandboxed Java Web Start applications or sandboxed Java applets, such as through a web service. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0453 to this issue.

Vulnerability in the Java SE, JavaFX, JRockit, component of Oracle Java SE (subcomponent: Javadoc). Supported versions that are affected are Java SE 5.0u61, Java SE 6u71, Java SE 7u51, Java SE 8, JavaFX 2.2.51, JRockit R27.8.1 and JRockit R28.3.1. Difficult to exploit vulnerability allows successful authenticated network attacks via HTTP. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE, JavaFX, JRockit, accessible data. Note: Applies to sites that run the Javadoc tool as a service and then host the resulting documentation. It is recommended that sites filter HTML where it is not explicitly allowed for javadocs. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-2398 to this issue.

Vulnerability in the Java SE, JRockit, Java SE Embedded component of Oracle Java SE (subcomponent: Libraries). Supported versions that are affected are Java SE 5.0u61, Java SE 6u71, Java SE 7u51, Java SE 8, JRockit R27.8.1, JRockit R28.3.1 and Java SE Embedded 7u51. Very difficult to exploit vulnerability requiring logon to Operating System. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE, JRockit, Java SE Embedded accessible data and ability to cause a partial denial of service (partial DOS) of Java SE, JRockit, Java SE Embedded. Note: Applies to the unpack200 tool. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-1876 to this issue.

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Deployment). Supported versions that are affected are Java SE 6u71, Java SE 7u51, Java SE 8 and Java SE Embedded 7u51. Very difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE, Java SE Embedded accessible data. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-2420 to this issue.

2. Avaya System Products using affected versions of Java:

Some Avaya system products are delivered with the Java Standard Edition (SE) platform. Actions to be taken on these products are described below.

Product: Affected Version(s): Risk Level: Actions:
Avaya Aura® Application Enablement Services 5.x, 6.x Low Upgrade to 7.0 or later.
Avaya Aura® Application Server 5300:
  • SIP Core
2.x thru 3.0 SP7 Low Upgrade to 3.0 SP8 or later.
Avaya CMS R15.x thru R16 R5, R17 thru R17 R2 Low For R16 R5 and earlier, upgrade to R16 R6 or later.
For R17, upgrade to R17 R3 or later.
Avaya Breeze™ Platform 2.x thru 3.0.x Low Upgrade to Engagement Development Platform 3.1 or later.
Avaya Aura® Communication Manager 5.2.x Low Upgrade to CM 6.0 or later.
Avaya Communication Server 1000:
  • CS1000E
  • CS1000M
  • CS1000E/CS1000M Signaling Server
7.x Low See recommended actions and Mitigating Factors table below. This advisory will not be addressed as no further releases are planned.
Avaya Aura® Conferencing 7.x Low Upgrade to 8.0 or later.
Avaya Aura® Conferencing Standard Edition 6.x Low See recommended actions and Mitigating Factors table below. This advisory will not be addressed as no further releases are planned. It is recommended that customers migrate to one of Avaya's conferencing solutions including Aura® Conferencing 7.0 or later.
Avaya Aura® Experience Portal 6.x, 7.0 Low Upgrade to 7.0.1 or later.
Avaya IP Office Server Edition 8.1 thru 9.1.3 Low Upgrade to 9.1.4 or later.
Avaya IP Office Application Server 8.0 thru 9.1.3 Low Upgrade to 9.1.4 or later.
Avaya IQ 5.0 thru 5.2.5 Low Upgrade to 5.2.6 and install Patch 2 or later.
Avaya Meeting Exchange 5.x through 6.2 SP3 Low Upgrade to 6.2 SP4 or later.
Avaya Message Networking 5.2.x Low Upgrade to 6.3 or later.
Avaya Aura® Messaging 6.x Low Upgrade to 7.0 or later.
Avaya Messaging Application Server 5.2 including SP17 and earlier Low Upgrade to 5.2 SP 18 or later.
Avaya Message Storage Server 5.2.x Low See recommended actions and Mitigating Factors table below. This advisory will not be addressed as no further releases are planned. It is recommended that customers migrate to Avaya Aura Messaging. Please contact your Avaya representative for information on the migration and ordering process.
Avaya Aura® Presence Services 6.x Low Upgrade to Aura Presence Services 7.0 or later. Further information about this version is available on support.avaya.com.
Avaya Proactive Contact 4.2.x thru 5.1.1 Low Upgrade to 5.1.2 or later.
Avaya Aura® Session Manager 5.x thru 6.3.8 Low Upgrade to 6.3.9 or later.
Avaya Aura® System Manager 5.x thru 6.3.11 Low Upgrade to 6.3.12 or later.

Recommended Actions:
Avaya strongly recommends following networking and security best practices by implementing firewalls, ACLs, physical security or other appropriate access restrictions. Though Avaya believes such restrictions should always be in place, risk to Avaya products and the surrounding network from this potential vulnerability may be mitigated by ensuring these practices are implemented until such time as an Avaya provided product update or the recommended Avaya action is applied. Further restrictions as deemed necessary based on the customer's security policies may be required during this interim period, but the System Product operating system or application should not modify unless the change is approved by Avaya. Making changes that are not approved may void the Avaya product service contract.

Mitigating Factors:

When determining risk, Avaya takes into account many factors as outlined by Avaya's Security Vulnerability Classification Policy. The following table describes factors that mitigate the risk of specific vulnerabilities for affected Avaya products:

Vulnerability Mitigating Factors
CVE-2014-0429
CVE-2014-0457
CVE-2014-0460
CVE-2013-6954
CVE-2013-6629
CVE-2014-0453
These are a Low risk for all listed products because execution of non-standard Java applications or applets is not possible without non-standard direct user interaction and/or the affected subcomponent is not used by default.
CVE-2014-0456
CVE-2014-2421
CVE-2014-2410
CVE-2014-2397
CVE-2014-0432
CVE-2014-0455
CVE-2014-0461
CVE-2014-0448
CVE-2014-2428
CVE-2014-2412
CVE-2014-0451
CVE-2014-0458
CVE-2014-2423
CVE-2014-0452
CVE-2014-2414
CVE-2014-2402
CVE-2014-0446
CVE-2014-0454
CVE-2014-2427
CVE-2014-2422
CVE-2014-2409
CVE-2014-0449
CVE-2014-2403
CVE-2014-2401
CVE-2014-0463
CVE-2014-0464
CVE-2014-0459
CVE-2014-2413
CVE-2014-2420
There is no risk for all listed products because the client deployment is not used.
CVE-2014-2398 This is a Low risk to all listed product because the Javadoc tool service is not running and documentation is not hosted by default.
CVE-2014-1876 This is a Low risk for all listed products because the unpack200 utility is not used by default and would require non-standard direct user interaction to exploit.

3. Avaya Software-Only Products:

Avaya software-only products operate on general-purpose operating systems. Occasionally vulnerabilities may be discovered in the underlying operating system or applications that come with the operating system. These vulnerabilities often do not impact the software-only product directly but may threaten the integrity of the underlying platform.

In the case of this advisory, Avaya software-only products are not affected by the vulnerability directly but the underlying platform may be. Customers should determine on which operating system the product was installed and then follow that vendor's guidance.

Product: Actions:
Secure Access Link Gateway Depending on the Operating System provided by customers, the affected version of Java may be installed on the underlying Operating System supporting the Secure Access Link Gateway.

4. Additional Information:

Additional information may also be available via the Avaya support website and through your Avaya account representative. Please contact your Avaya product support representative, or dial 1-800-242-2121, with any questions.

5. Disclaimer:

ALL INFORMATION IS BELIEVED TO BE CORRECT AT THE TIME OF PUBLICATION AND IS PROVIDED "AS IS". AVAYA INC., ON BEHALF ITSELF AND ITS SUBSIDIARIES AND AFFILIATES (HEREINAFTER COLLECTIVELY REFERRED TO AS "AVAYA"), DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE AND FURTHERMORE, AVAYA MAKES NO REPRESENTATIONS OR WARRANTIES THAT THE STEPS RECOMMENDED WILL ELIMINATE SECURITY OR VIRUS THREATS TO CUSTOMERS' SYSTEMS. IN NO EVENT SHALL AVAYA BE LIABLE FOR ANY DAMAGES WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH THE INFORMATION OR RECOMMENDED ACTIONS PROVIDED HEREIN, INCLUDING DIRECT, INDIRECT, INCIDENTAL, STATUTORY, CONSEQUENTIAL DAMAGES, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF AVAYA HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

THE INFORMATION PROVIDED HERE DOES NOT AFFECT THE SUPPORT AGREEMENTS IN PLACE FOR AVAYA PRODUCTS. SUPPORT FOR AVAYA PRODUCTS CONTINUES TO BE EXECUTED AS PER EXISTING AGREEMENTS WITH AVAYA.

6. Revision History:

V 1.0 - May 16, 2014 - Initial Statement issued.
V 2.0 - October 15, 2015 - Updated AES, AS5300, CE, CMS, Conferencing, EP, IPOSE, IPOAS, IQ, MAS, PS, SM and SMGR affected versions and actions.
V 3.0 - January 12, 2017 - Updated MSS and PC affected versions and actions.
V 4.0 - September 11, 2017 - Updated affected versions for MX, actions for MX and AAM, and set Advisory status to Final.

Avaya customers or Business Partners should report any security issues found with Avaya products via the standard support process.
Independent security researchers can contact Avaya at securityalerts@avaya.com.

© 2014 Avaya Inc. All Rights Reserved. All trademarks identifying Avaya products by the ® or ™ are registered trademarks or trademarks, respectively, of Avaya Inc. All other trademarks are the property of their respective owners.