Avaya Scopia Response to GNU Bash (shellshock) Vulnerabilities (CVE-2014-6271, CVE-2014-7169)

Original Release Date: October 6, 2014
Last Revised: September 27, 2017
Number: ASA-2014-386
Risk Level: High
Advisory Version: 2.0
Advisory Status: Final

1. Overview:

GNU Bash through 4.3 processes trailing strings after function definitions in the values of environment variables, which allows remote attackers to execute arbitrary code via a crafted environment, as demonstrated by vectors involving the ForceCommand feature in OpenSSH sshd, the mod_cgi and mod_cgid modules in the Apache HTTP Server, scripts executed by unspecified DHCP clients, and other situations in which setting the environment occurs across a privilege boundary from Bash execution, aka "ShellShock." The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the names CVE-2014-6271, CVE-2014-7169, CVE-2014-7186, CVE-2014-7187, CVE-2014-6277 and CVE-2014-6278 to these issues.

2. Avaya Scopia Products with affected packages installed:

Product: Affected Version(s): Risk Level: Actions:
Scopia Elite 5000 7.3 and later Medium Configure High security mode to disable shell access and contact Avaya support for the necessary process to resolve this issue.
Scopia Elite 6000 8.0 and later Medium Configure High security mode to disable shell access and contact Avaya support for the necessary process to resolve this issue.
Scopia SIP Gateway 7.7 and later High Contact Avaya support for the necessary process to resolve this issue.
Scopia UC Gateway 7.7 and later High Contact Avaya support for the necessary process to resolve this issue.
Scopia Management (Linux) 8.0 and later High Contact Avaya support for the necessary process to resolve this issue.
Scopia Pathfinder 7.7 and later High Contact Avaya support for the necessary process to resolve this issue.

Recommended Actions for System Products:
Avaya strongly recommends that customers follow networking and security best practices by implementing firewalls, ACLs, physical security or other appropriate access restrictions. Though Avaya believes such restrictions should always be in place, risk to Avaya products and the surrounding network from this potential vulnerability may be mitigated by ensuring these practices are implemented until such time as an Avaya provided product update or the recommended Avaya action is applied. Further restrictions as deemed necessary based on the customer's security policies may be required during this interim period, but customers should not modify the System Product operating system or application unless the change is approved by Avaya. Making changes that are not approved may void the Avaya product service contract.

Mitigating Factors:

When determining risk, Avaya takes into account many factors as outlined by Avaya's Security Vulnerability Classification Policy. The following table describes factors that mitigate the risk of specific vulnerabilities for affected Avaya products:

Vulnerability Mitigating Factors
CVE-2014-6271
CVE-2014-7169
CVE-2014-7186
CVE-2014-7187
CVE-2014-6277
CVE-2014-6278
These are a Medium risk for Elite 5000 and 6000 as shell access can be disabled.
These are a High risk for UC Gateway, SIP gateway, Management and Pathfinder because exploiting this vulnerability could bypass security restrictions and allow shell commands to be executed.

3. Avaya Scopia products not affected by Shellshock vulnerbilities:

Product: Version(s): Risk Level:
Scopia Desktop Client All None
Scopia Desktop Server All None
Scopia Mobile Client for Mac OS All None
Scopia Mobile Client for Android All None
Scopia Mobile Client for iOS All None
Scopia ISDN Gateway All None
Scopia XT All None
Scopia Management (Windows) All None

The products listed in table 3 above are not affected as they do not utilize an operating system on which bash is installed.

4. Additional Information:

Additional information may also be available via the Avaya support website and through your Avaya account representative. Please contact your Avaya product support representative, or dial 1-800-242-2121, with any questions.

5. Disclaimer:

ALL INFORMATION IS BELIEVED TO BE CORRECT AT THE TIME OF PUBLICATION AND IS PROVIDED "AS IS". AVAYA INC., ON BEHALF ITSELF AND ITS SUBSIDIARIES AND AFFILIATES (HEREINAFTER COLLECTIVELY REFERRED TO AS "AVAYA"), DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE AND FURTHERMORE, AVAYA MAKES NO REPRESENTATIONS OR WARRANTIES THAT THE STEPS RECOMMENDED WILL ELIMINATE SECURITY OR VIRUS THREATS TO CUSTOMERS' SYSTEMS. IN NO EVENT SHALL AVAYA BE LIABLE FOR ANY DAMAGES WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH THE INFORMATION OR RECOMMENDED ACTIONS PROVIDED HEREIN, INCLUDING DIRECT, INDIRECT, INCIDENTAL, STATUTORY, CONSEQUENTIAL DAMAGES, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF AVAYA HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

THE INFORMATION PROVIDED HERE DOES NOT AFFECT THE SUPPORT AGREEMENTS IN PLACE FOR AVAYA PRODUCTS. SUPPORT FOR AVAYA PRODUCTS CONTINUES TO BE EXECUTED AS PER EXISTING AGREEMENTS WITH AVAYA.

6. Revision History:

V 1.0 - October 6, 2014 - Initial Statement issued.
V 2.0 - September 27, 2017 - Updated affected versions and actions and set advisory status to Final.

Avaya customers or Business Partners should report any security issues found with Avaya products via the standard support process.
Independent security researchers can contact Avaya at securityalerts@avaya.com.

© 2014 Avaya Inc. All Rights Reserved. All trademarks identifying Avaya products by the ® or ™ are registered trademarks or trademarks, respectively, of Avaya Inc. All other trademarks are the property of their respective owners.