Oracle Java Critical Patch Update (April 2015)

Original Release Date: June 16, 2015
Last Revised: October 11, 2017
Number: ASA-2015-238
Risk Level: Low
Advisory Version: 3.0
Advisory Status: Final

1. Overview:

New Java Critical Patch Updates have been issued by Oracle on Critical Patch Updates, Security Alerts and Third Party Bulletin website. Specific information pertaining to this advisory is described below. The Oracle Advisory covering content outlined in this Avaya Security Advisory may be found in Oracle Critical Patch Update Advisory - April 2015 and contains the following security issue.

Vulnerability in the Java SE component of Oracle Java SE (subcomponent: 2D). Supported versions that are affected are Java SE 5.0u81, Java SE 6u91, Java SE 7u76 and Java SE 8u40. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized Operating System takeover including arbitrary code execution. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2015-0469 to this issue.

Vulnerability in the Java SE, JavaFX component of Oracle Java SE (subcomponent: 2D). Supported versions that are affected are Java SE 5.0u81, Java SE 6u91, Java SE 7u76, Java SE 8u40 and Java FX 2.2.76. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized Operating System takeover including arbitrary code execution. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2015-0459 to this issue.

Vulnerability in the Java SE, JavaFX component of Oracle Java SE (subcomponent: 2D). Supported versions that are affected are Java SE 5.0u81, Java SE 6u91, Java SE 7u76, Java SE 8u40 and Java FX 2.2.76. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized Operating System takeover including arbitrary code execution. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2015-0491 to this issue.

Vulnerability in the Java SE component of Oracle Java SE (subcomponent: Hotspot). Supported versions that are affected are Java SE 5.0u81, Java SE 6u91, Java SE 7u76 and Java SE 8u40. Difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized Operating System takeover including arbitrary code execution. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2015-0460 to this issue.

Vulnerability in the Java SE, JavaFX component of Oracle Java SE (subcomponent: JavaFX). Supported versions that are affected are Java SE 7u76, Java SE 8u40 and Java FX 2.2.76. Difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized Operating System takeover including arbitrary code execution. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2015-0492 to this issue.

Vulnerability in the Java SE component of Oracle Java SE (subcomponent: Deployment). Supported versions that are affected are Java SE 6u91, Java SE 7u76 and Java SE 8u40. Very difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized Operating System takeover including arbitrary code execution. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2015-0458 to this issue.

Vulnerability in the Java SE, JavaFX component of Oracle Java SE (subcomponent: JavaFX). Supported versions that are affected are Java SE 7u76, Java SE 8u40 and Java FX 2.2.76. Difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE, JavaFX accessible data as well as read access to a subset of Java SE, JavaFX accessible data and ability to cause a partial denial of service (partial DOS) of Java SE, JavaFX. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2015-0484 to this issue.

Vulnerability in the Java SE component of Oracle Java SE (subcomponent: Tools). Supported versions that are affected are Java SE 5.0u81, Java SE 6u91, Java SE 7u76 and Java SE 8u40. Difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE accessible data and ability to cause a partial denial of service (partial DOS) of Java SE. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2015-0480 to this issue.

Vulnerability in the Java SE component of Oracle Java SE (subcomponent: Deployment). The supported version that is affected is Java SE 8u40. Easily exploitable vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized read access to a subset of Java SE accessible data. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2015-0486 to this issue.

Vulnerability in the Java SE, JRockit component of Oracle Java SE (subcomponent: JSSE). Supported versions that are affected are Java SE 5.0u81, Java SE 6u91, Java SE 7u76, Java SE 8u40 and JRockit R28.3.5. Easily exploitable vulnerability allows successful unauthenticated network attacks via SSL/TLS. Successful attack of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Java SE, JRockit. Note: Applies to client and server deployment of JSSE. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2015-0488 to this issue.

Vulnerability in the Java SE component of Oracle Java SE (subcomponent: Beans). Supported versions that are affected are Java SE 5.0u81, Java SE 6u91, Java SE 7u76 and Java SE 8u40. Difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE accessible data. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2015-0477 to this issue.

Vulnerability in the Java SE component of Oracle Java SE (subcomponent: Hotspot). The supported version that is affected is Java SE 8u40. Difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE accessible data. Note: Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2015-0470 to this issue.

Vulnerability in the Java SE, JRockit component of Oracle Java SE (subcomponent: JCE). Supported versions that are affected are Java SE 5.0u81, Java SE 6u91, Java SE 7u76, Java SE 8u40 and JRockit R28.3.5. Difficult to exploit vulnerability allows successful unauthenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized read access to a subset of Java SE, JRockit accessible data. Note: Applies to client and server deployment of Java. This vulnerability can be exploited through sandboxed Java Web Start applications and sandboxed Java applets. It can also be exploited by supplying data to APIs in the specified Component without using sandboxed Java Web Start applications or sandboxed Java applets, such as through a web service. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2015-0478 to this issue.

Vulnerability in the Java SE, JRockit component of Oracle Java SE (subcomponent: JSSE). Supported versions that are affected are Java SE 5.0u81, Java SE 6u91 and JRockit R28.3.5. Very difficult to exploit vulnerability allows successful unauthenticated network attacks via SSL/TLS. Successful attack of this vulnerability can result in unauthorized update, insert or delete access to some Java SE, JRockit accessible data as well as read access to a subset of Java SE, JRockit accessible data. Note: Applies to client and server deployment of JSSE. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2015-0204 to this issue.

2. Avaya System Products using affected versions of Java:

Some Avaya system products are delivered with the Java Standard Edition (SE) platform. Actions to be taken on these products are described below.

Product: Affected Version(s): Risk Level: Actions:
Avaya Aura® Application Enablement Services 6.x, 7.0.x Low Upgrade to 7.1 or later.
Avaya Aura® Application Server 5300:
  • SIP Core
2.0 thru 3.0 SP10 Low Upgrade to 3.0 SP11 or later.
Avaya CMS R16.x, R17.x Low Upgrade to R18 using a RHEL operating system or later.
Avaya Breeze™ Platform 3.0 thru 3.1 Low Upgrade to 3.1.1 or later.
Avaya Communication Server 1000:
  • CS1000E
  • CS1000M
  • CS1000E/CS1000M Signaling Server
7.x Low See recommended actions and Mitigating Factors table below. This advisory will not be addressed as no further releases are planned.
Avaya Aura® Conferencing 7.2 thru 7.2 SP6, 8.0 thru 8.0 SP4 Low For 7.x, upgrade to 7.2 SP7 or later.
For 8.x, upgrade to 8.0 SP5 or later.
Avaya Aura® Experience Portal 6.x thru 7.0.1 Low Upgrade to 7.0.2 and Avaya Linux for 7.0.2 or later, and install the latest Security Updates.
Avaya IP Office Server Edition 8.1 thru 9.1.5 Low Upgrade to 9.1.6 or later.
Avaya IP Office Application Server 8.x thru 9.1.5 Low Upgrade to 9.1.6 or later.
Avaya IQ 5.x Low See recommended actions and Mitigating Factors table below. This advisory will not be addressed as no further releases are planned. It is recommended to migrate to Avaya Oceanalytics for Elite.
Avaya Meeting Exchange 5.x thru 6.2 SP2 Low Upgrade to 6.2 SP3 or later.
Avaya Message Networking 5.x, 6.x Low See recommended actions and Mitigating Factors table below. This advisory will not be addressed as no further releases are planned.
Avaya Aura® Messaging 6.x Low Upgrade to 7.0 or later.
Avaya Messaging Application Server 5.x Low See recommended actions and Mitigating Factors table below. This advisory will not be addressed as no further releases are planned. It is recommended that customers migrate to Avaya Aura Messaging. Please contact your Avaya representative for information on the migration and ordering process.
Avaya Message Storage Server 5.x Low See recommended actions and Mitigating Factors table below. This advisory will not be addressed as no further releases are planned. It is recommended that customers migrate to Avaya Aura Messaging. Please contact your Avaya representative for information on the migration and ordering process.
Avaya Aura® Presence Services 6.x Low Upgrade to Aura Presence Services 7.0 or later. Further information about this version is available on support.avaya.com.
Avaya Proactive Contact 4.x thru 5.1.1 Low Upgrade to 5.1.2 or later.
Avaya Aura® Session Manager 6.0 thru 6.3.15, 7.0.0.0, 7.0.0.1 Low For 6.x, upgrade to 6.3.16 or later.
For 7.x, upgrade to 7.0.1.0 or later.
Avaya Aura® System Manager 6.0 thru 6.3.13 Low Upgrade to 6.3.14 or later.

Recommended Actions:
Avaya strongly recommends following networking and security best practices by implementing firewalls, ACLs, physical security or other appropriate access restrictions. Though Avaya believes such restrictions should always be in place, risk to Avaya products and the surrounding network from this potential vulnerability may be mitigated by ensuring these practices are implemented until such time as an Avaya provided product update or the recommended Avaya action is applied. Further restrictions as deemed necessary based on the customer's security policies may be required during this interim period, but the System Product operating system or application should not modify unless the change is approved by Avaya. Making changes that are not approved may void the Avaya product service contract.

Mitigating Factors:

When determining risk, Avaya takes into account many factors as outlined by Avaya's Security Vulnerability Classification Policy. The following table describes factors that mitigate the risk of specific vulnerabilities for affected Avaya products:

Vulnerability Mitigating Factors
CVE-2015-0469
CVE-2015-0459
CVE-2015-0491
CVE-2015-0460
CVE-2015-0492
CVE-2015-0458
CVE-2015-0484
CVE-2015-0480
CVE-2015-0486
CVE-2015-0477
CVE-2015-0470
There is no risk for all listed products because the client deployment is not used.
CVE-2015-0204 This is a Low risk because weak keys are disabled by default.
CVE-2015-0478 This is a Low risk because the JCE component is not used to implement RSA signatures by default.
CVE-2015-0488 This is a Low risk because verification and use of untrusted certificates requires non-standard direct user interaction.

3. Avaya Software-Only Products:

Avaya software-only products operate on general-purpose operating systems. Occasionally vulnerabilities may be discovered in the underlying operating system or applications that come with the operating system. These vulnerabilities often do not impact the software-only product directly but may threaten the integrity of the underlying platform.

In the case of this advisory, Avaya software-only products are not affected by the vulnerability directly but the underlying platform may be. Customers should determine on which operating system the product was installed and then follow that vendor's guidance.

4. Additional Information:

Additional information may also be available via the Avaya support website and through your Avaya account representative. Please contact your Avaya product support representative, or dial 1-800-242-2121, with any questions.

5. Disclaimer:

ALL INFORMATION IS BELIEVED TO BE CORRECT AT THE TIME OF PUBLICATION, IS PROVIDED "AS IS", AND IS APPLICABLE ONLY TO PRODUCT VERSIONS ELIGIBLE FOR MANUFACTURER SUPPORT IN ACCORDANCE WITH AVAYA PRODUCT LIFE CYCLE POLICY. AVAYA INC., ON BEHALF ITSELF AND ITS SUBSIDIARIES AND AFFILIATES (HEREINAFTER COLLECTIVELY REFERRED TO AS "AVAYA"), DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE AND FURTHERMORE, AVAYA MAKES NO REPRESENTATIONS OR WARRANTIES THAT THE STEPS RECOMMENDED WILL ELIMINATE SECURITY OR VIRUS THREATS TO CUSTOMERS' SYSTEMS. IN NO EVENT SHALL AVAYA BE LIABLE FOR ANY DAMAGES WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH THE INFORMATION OR RECOMMENDED ACTIONS PROVIDED HEREIN, INCLUDING DIRECT, INDIRECT, INCIDENTAL, STATUTORY, CONSEQUENTIAL DAMAGES, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF AVAYA HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

THE INFORMATION PROVIDED HERE DOES NOT AFFECT THE SUPPORT AGREEMENTS IN PLACE FOR AVAYA PRODUCTS. SUPPORT FOR AVAYA PRODUCTS CONTINUES TO BE EXECUTED AS PER EXISTING AGREEMENTS WITH AVAYA.

6. Revision History:

V 1.0 - June 16, 2015 - Initial Statement issued.
V 2.0 - January 12, 2017 - Updated AS5300, Breeze, AAC, EP, IPOSE, IPOAS, MX, MAS, MSS, PS, PC, SM and SMGR affected versions and actions.
V 3.0 - October 11, 2017 - Updated AES, CMS, IQ, MN and Messaging affected versions and actions, and set advisory status to Final.

Avaya customers or Business Partners should report any security issues found with Avaya products via the standard support process.
Independent security researchers can contact Avaya at securityalerts@avaya.com.

© 2015 Avaya Inc. All Rights Reserved. All trademarks identifying Avaya products by the ® or ™ are registered trademarks or trademarks, respectively, of Avaya Inc. All other trademarks are the property of their respective owners.