© 2013-2018, Avaya Inc. All Rights Reserved.

Notice

While reasonable efforts have been made to ensure that the information in this document is complete and accurate at the time of printing, Avaya assumes no liability for any errors. Avaya reserves the right to make changes and corrections to the information in this document without the obligation to notify any person or organization of such changes.

Documentation disclaimer

“Documentation” means information published in varying mediums which may include product information, operating instructions and performance specifications that are generally made available to users of products. Documentation does not include marketing materials. Avaya shall not be responsible for any modifications, additions, or deletions to the original published version of Documentation unless such modifications, additions, or deletions were performed by or on the express behalf of Avaya. End User agrees to indemnify and hold harmless Avaya, Avaya's agents, servants and employees against all claims, lawsuits, demands and judgments arising out of, or in connection with, subsequent modifications, additions or deletions to this documentation, to the extent made by End User.

Link disclaimer

Avaya is not responsible for the contents or reliability of any linked websites referenced within this site or Documentation provided by Avaya. Avaya is not responsible for the accuracy of any information, statement or content provided on these sites and does not necessarily endorse the products, services, or information described or offered within them. Avaya does not guarantee that these links will work all the time and has no control over the availability of the linked pages.

Warranty

Warranty provides a limited warranty on Avaya hardware and software. Refer to your sales agreement to establish the terms of the limited warranty. In addition, Avaya’s standard warranty language, as well as information regarding support for this product while under warranty is available to Avaya customers and other parties through the Avaya Support website: https://support.avaya.com/helpcenter/

Link disclaimer

Avaya grants You a license within the scope of the license types described below, with the exception of Heritage Nortel Software, for which the scope of the license is detailed below. Where the order documentation does not expressly identify a license type, the applicable license will be a Designated System License as set forth below in the Designated System(s) License (DS) section as applicable. The applicable number of licenses and units of capacity for which the license is granted will be one (1), unless a different number of licenses or units of capacity is specified in the documentation or other materials available to You. “Software” means computer programs in object code, provided by Avaya or an Avaya Channel Partner, whether as stand-alone products, pre-installed on hardware products, and any upgrades, updates, patches, bug fixes, or modified versions thereto. “Designated Processor” means a single stand-alone computing device. “Server” means a set of Designated Processors that hosts (physically or virtually) a software application to be accessed by multiple users. “Instance” means a single copy of the Software executing at a particular time: (i) on one physical machine; or (ii) on one deployed software virtual machine (“VM”) or similar deployment.

License types

Designated System(s) License (DS). End User may install and use each copy or an Instance of the Software only: 1) on a number of Designated Processors up to the number indicated in the order; or 2) up to the number of Instances of the Software as indicated in the order, Documentation, or as authorized by Avaya in writing. Avaya may require the Designated Processor(s) to be identified in the order by type, serial number, feature key, Instance, location or other specific designation, or to be provided by End User through electronic means established by Avaya specifically for this purpose.

Concurrent User License (CU). End User may install and use the Software on multiple Designated Processors or one or more Servers, so long as only the licensed number of Units are accessing and using the Software at any given time. A “Unit” means the unit on which Avaya, at its sole discretion, bases the pricing of its licenses and can be, without limitation, an agent, port or user, an e-mail or voice mail account in the name of a person or corporate function (e.g., workstation or helpdesk), or the administrative database utilized by the Software that permits one user to interface with the Software. Units may be linked to a specific, identified Server or an Instance of the Software.

Heritage Nortel Software

“Heritage Nortel Software” means the software that was acquired by Avaya as part of its purchase of the Nortel Enterprise Solutions Business in December 2009. The Heritage Nortel Software is the
software contained within the list of Heritage Nortel Products located at https://support.avaya.com/Licens Info under the link “Heritage Nortel Products” or such successor site as designated by Avaya. For Heritage Nortel Software, Avaya grants Customer a license to use Heritage Nortel Software provided hereunder solely to the extent of the authorized activation or authorized usage level, solely for the purpose specified in the Documentation, and solely as embedded in, for execution on, or for communication with Avaya equipment. Charges for Heritage Nortel Software may be based on extent of activation or use authorized as specified in an order or invoice.

Copyright
Except where expressly stated otherwise, no use should be made of materials on this site, the Documentation, Software, Hosted Service, or hardware provided by Avaya. All content on this site, the documentation, Hosted Service, and the product provided by Avaya including the selection, arrangement and design of the content is owned either by Avaya or its licensors and is protected by copyright and other intellectual property laws including the sui generis rights relating to the protection of databases. You may not modify, copy, reproduce, republish, upload, post, transmit or distribute in any way any content, in whole or in part, including any code and software unless expressly authorized by Avaya. Unauthorized reproduction, transmission, dissemination, storage, and or use without the express written consent of Avaya can be a criminal, as well as a civil offense under the applicable law.

Virtualization
The following applies if the product is deployed on a virtual machine. Each product has its own ordering code and license types. Note, unless otherwise stated, that each instance of a product must be separately licensed and ordered. For example, if the end user customer or Avaya Channel Partner would like to install two instances of the same type of products, then two products of that type must be ordered.

Third Party Components
“Third Party Components” mean certain software programs or portions thereof included in the Software or Hosted Service may contain software (including open source software) distributed under third party agreements (“Third Party Components”), which contain terms regarding the rights to use certain portions of the Software (“Third Party Terms”). As required, information regarding distributed Linux OS source code (for those products that have distributed Linux OS source code) and identifying the copyright holders of the Third Party Components and the Third Party Terms that apply is available in the product documentation on Avaya’s website at: https://support.avaya.com/Copyright or such successor site as designated by Avaya. The open source software license terms provided as Third Party Terms are consistent with the license rights granted in these Software License Terms, and may contain additional rights benefiting You, such as modification and distribution of the open source software. The Third Party Terms shall take precedence over the Software License Terms, solely with respect to the applicable Third Party Components to the extent that these Software License Terms impose greater restrictions on You than the applicable Third Party Terms.

The following applies only if the H.264 (AVC) codec is distributed with the product. THIS PRODUCT IS LICENSED UNDER THE AVC PATENT PORTFOLIO LICENSE FOR THE PERSONAL USE OF A CONSUMER OR OTHER USES IN WHICH IT DOES NOT RECEIVE REMUNERATION TO (i) ENCODE VIDEO IN COMPLIANCE WITH THE AVC STANDARD (“AVC VIDEO”) AND/OR (ii) DECODE AVC VIDEO THAT WAS ENCODED BY A CONSUMER ENGAGED IN A PERSONAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO PROVIDER LICENSED TO PROVIDE AVC VIDEO. NO LICENSE IS GRANTED OR SHALL BE IMPLIED FOR ANY OTHER USE. ADDITIONAL INFORMATION MAY BE OBTAINED FROM MPEG LA, L.L.C. SEE HTTP://WWW.MPEGLA.COM.

Compliance with Laws
You acknowledge and agree that it is Your responsibility for complying with any applicable laws and regulations, including, but not limited to laws and regulations related to call recording, data privacy, intellectual property, trade secret, fraud, and music performance rights, in the country or territory where the Avaya product is used.

Preventing Toll Fraud
“Toll Fraud” is the unauthorized use of your telecommunications system by an unauthorized party (for example, a person who is not a corporate employee, agent, subcontractor, or is not working on your company’s behalf). Be aware that there can be a risk of Toll Fraud associated with your system and that, if Toll Fraud occurs, it can result in substantial additional charges for your telecommunications services. If You suspect that You are being victimized by Toll Fraud and You need technical assistance or support, call Technical Service Center Toll Fraud Intervention Hotline at +1-800-643-2353 for the United States and Canada. For additional support telephone numbers, see the Avaya Support website: https://support.avaya.com or such successor site as designated by Avaya.

Security Vulnerabilities
Information about Avaya’s security support policies can be found in the Security Policies and Support section of https://support.avaya.com/security.

Suspected Avaya product security vulnerabilities are handled per the Avaya Product Security Support Flow (https://support.avaya.com/cs/P8/documents/100161515).

Downloading Documentation
For the most current versions of Documentation, see the Avaya Support website: https://support.avaya.com, or such successor site as designated by Avaya.

Contact Avaya Support
See the Avaya Support website: https://support.avaya.com for product or Hosted Service notices and articles, or to report a problem with your Avaya product or Hosted Service. For a list of support telephone numbers and contact addresses, go to the Avaya Support website: https://support.avaya.com or such successor site as designated by Avaya. scroll to the bottom of the page, and select Contact Avaya Support.

Trademarks
The trademarks, logos and service marks (“Marks”) displayed in this site, the Documentation, Hosted Service(s), and product(s) provided
Contents

Chapter 1: Introduction .......................................................................................................... 23
    Purpose ................................................................................................................................ 23

Chapter 2: Proactive Contact overview ............................................................................ 24
    Proactive Contact environment ........................................................................................... 24
    Dialer functions ..................................................................................................................... 24
    Multiple dialers .................................................................................................................... 24
    Multitenancy .......................................................................................................................... 25
    Calling lists ............................................................................................................................ 26
    Role-based authorization for Administrators ....................................................................... 28
    Secured Agent application .................................................................................................. 28
    Licensing ................................................................................................................................. 28
    Installing prerequisites for License server ........................................................................ 29
    Configuring the dialer .......................................................................................................... 29
    Grace period .......................................................................................................................... 30
    Security ................................................................................................................................ 30
    Configuring Transport Layer Security and High Ciphers .................................................. 30
    What’s new in Release 5.2 .................................................................................................... 31
    New in Avaya Proactive Contact Release 5.2 ..................................................................... 31
    What’s new in Release 5.1.2 ............................................................................................... 32
    Manual dialing ...................................................................................................................... 32
    Support for TLS 1.0 and High Ciphers .............................................................................. 32
    Answer supervision by job .................................................................................................... 32
    Password length .................................................................................................................... 33
    On-hold message or music .................................................................................................... 33
    Zip To Time Zone for calling lists ....................................................................................... 33
    Shadow jobs in preview mode .............................................................................................. 33
    Microsoft Windows versions supported ............................................................................... 33
    Support for passing called party number for opt out calls to VDN .................................. 33
    What’s new in Release 5.1 .................................................................................................... 34
    Multitenancy .......................................................................................................................... 34
    Increased capacity ................................................................................................................ 34
    Increased dialer support in a pod ......................................................................................... 35
    Enhanced ID field for calling list names ............................................................................. 35
    Out of time zone phone support .......................................................................................... 35
    Automated Release Agent to Ready feature for Voicemail ................................................. 35
    Implementation of FCC 12-21 regulation ............................................................................. 36

Chapter 3: Proactive Contact users, login, and permissions ................................................ 37
    Proactive Contact users ....................................................................................................... 37
    Logins and permissions ....................................................................................................... 38
Chapter 5: Managing users

Password.................................................................................................................................................. 39
Agent types.................................................................................................................................................. 40
Agent logins.................................................................................................................................................. 40
Logging into Supervisor............................................................................................................................ 41
Viewing online help..................................................................................................................................... 42

Chapter 4: Managing roles

Working with multitenancy.......................................................................................................................... 43
Roles.............................................................................................................................................................. 44
Predefined roles.......................................................................................................................................... 45
Mapping of roles.......................................................................................................................................... 45
Role of Lead Administrator.......................................................................................................................... 46
Role of Tenant administrator....................................................................................................................... 47
Types of permissions..................................................................................................................................... 47
Operations permissions............................................................................................................................... 47
Access permissions....................................................................................................................................... 48
Permissions in Role Editor........................................................................................................................... 48
Monitor Agent permission............................................................................................................................ 49
Toolbar buttons.............................................................................................................................................. 50
Logging into Role Editor application.......................................................................................................... 50
Creating a new role...................................................................................................................................... 50
Renaming a role........................................................................................................................................... 51
Merging roles............................................................................................................................................... 52
Editing a merged role.................................................................................................................................... 53
Assigning roles to a user............................................................................................................................... 53
Assigning users to a role............................................................................................................................... 54
Deleting a role............................................................................................................................................... 55
Refreshing the Role Editor data.................................................................................................................. 56
Displaying warning message for tenants without administrators................................................................ 56
Reports.......................................................................................................................................................... 57
Viewing reports............................................................................................................................................ 57
Saving Reports Data as HTML.................................................................................................................... 57

Chapter 5: Managing users

Default users in Proactive Contact............................................................................................................ 58
Logging into Role Editor as a Lead Administrator..................................................................................... 59
Creating a new user....................................................................................................................................... 59
  Add New User field descriptions.............................................................................................................. 60
Modifying a user.......................................................................................................................................... 60
Deleting a user............................................................................................................................................. 61
Assigning and unassigning a user to and from a tenant.......................................................................... 61
Batch user creation or modification.......................................................................................................... 62
  Creating multiple users using Batch User Creation wizard.................................................................. 63
Viewing Dialers and Administered Tenants for a user.............................................................................. 64
Types of reports.......................................................................................................................................... 64
Chapter 6: Managing tenants ................................................................. 65
Logging in to Role Editor as a Lead Administrator .......................... 65
Default tenant ..................................................................................... 65
  Default tenant field descriptions .................................................. 66
Prerequisites for creating a tenant .................................................. 68
Creating a tenant ................................................................. 69
Modifying a tenant .......................................................................... 70
Tenant staging .................................................................................. 70
  Saving a tenant in different stages .............................................. 71
Deletion of tenants ............................................................................ 71
  Deleting a tenant .......................................................................... 72
Assigning and unassigning an agent or supervisor to or from a tenant .......................................................................... 72
Assigning and unassigning an administrator to or from a tenant ........................................................................ 73
Viewing assigned Dialer resources and tenant users ....................... 74
Viewing tenants without an assigned Administrator ...................... 75
Tenant reports .................................................................................. 75
  Viewing tenant reports ................................................................. 76
Chapter 7: Role Editor operations ...................................................... 77
Creating a role for Manager to perform a specific task .................... 77
Creating Identical Role as Administrator ........................................ 78
Assigning a User to a Role .............................................................. 79
  Verifying the permissions and the users assigned to the role ............ 80
Testing the Role Permissions ........................................................ 80
Creating a Role with no Permissions ............................................. 81
Creating a Role by Merging two or more Roles ............................... 81
Assigning User to a Merged Role .................................................. 82
Editing a Merged Role .................................................................... 83
Renaming a Role ............................................................................. 84
Deleting a Role .............................................................................. 84
Editing a Role Permission ............................................................ 85
Assigning a Role to Users ............................................................... 85
Chapter 8: Health Manager ................................................................. 87
Overall Health Status ...................................................................... 87
Dialer Services ................................................................................. 87
Mid-Tier Services ............................................................................ 88
System Status ................................................................................. 89
Health Manager with Multitenancy ............................................... 89
Logging in to Health Manager ....................................................... 90
Change display options .................................................................... 90
  Showing or hiding columns ......................................................... 90
  Adjusting column widths ........................................................... 91
Refreshing the Health Manager data ............................................. 91
Contents

Sorting the list of dialers, services, or events................................................................. 91
Viewing overall system health for all dialers................................................................. 91
  Overall health statistics for all the dialers’ descriptions........................................... 92
Viewing system health for one dialer............................................................................. 92
  View Dialer Services.................................................................................................. 93
  View Mid-Tier Services............................................................................................. 96
  View System Status.................................................................................................. 98
System Activity Events.................................................................................................... 101
  Viewing system events.............................................................................................. 101
About Activity Events...................................................................................................... 102
  Subscribing to Activity Events.................................................................................. 102
Saving Data as HTML..................................................................................................... 103
Configuring Health Manager......................................................................................... 103
License Configurator....................................................................................................... 103
  Changing the License server URL............................................................................. 104
Health Bridge Service..................................................................................................... 104
  Starting or stopping Health Bridge from Microsoft Management Console........... 105
  Starting or stopping Health Bridge from Command Prompt......................... 105
  Stopping Health Bridge from Task Manager......................................................... 105
  Starting Health Bridge from Task Manager......................................................... 106
Set Threshold Parameters for System Status............................................................... 106
  Changing the maximum number of events that Health Manager displays......... 106
  Sending activity event notifications......................................................................... 106

Chapter 9: Editor............................................................................................................. 108
  Editor with Multitenancy......................................................................................... 108
  Logging in to Editor................................................................................................. 109
Editor user interface customization................................................................................ 109
  Button groups......................................................................................................... 109
  Editor button descriptions...................................................................................... 111
  Sorting content of a column.................................................................................... 111
  Resizing columns.................................................................................................... 111
  Resizing panes....................................................................................................... 112
Switching between dialers............................................................................................. 112
Switching between tenants............................................................................................ 112
Navigating among the Tool applications....................................................................... 112
Selecting **Contact Management**............................................................................... 113
Viewing icons in the button group............................................................................... 113
Refreshing a view......................................................................................................... 113
Editor settings............................................................................................................... 114
  Enabling or disabling multi-dialer commands....................................................... 114
  Setting Save options............................................................................................... 114
  Setting Refresh options......................................................................................... 115

Chapter 10: Staging....................................................................................................... 116
Chapter 13: Agent Keys

Chapter 12: Completion Codes

Chapter 14: Messages and scripts
Contents

Completion codes.................................................................................................................. 208
Goals.................................................................................................................................... 208
Selections settings.............................................................................................................. 208
    Selections tab field descriptions.................................................................................. 208
    Record selection wildcard characters....................................................................... 210
    Viewing Selection Reports.......................................................................................... 211
Using a record selection..................................................................................................... 212
    Opening and viewing a record selection.................................................................... 212
    Using the Detail tab..................................................................................................... 213
    Using the Records tab................................................................................................. 213
    Using the Time Zones tab......................................................................................... 214
    Using the Results tab................................................................................................. 214
    Using the Recalls tab................................................................................................. 214
    Using the Sort tab...................................................................................................... 215
Creating a record selection............................................................................................... 216
Saving a record selection................................................................................................. 216
Editing a record selection............................................................................................... 217
Deleting a record selection............................................................................................. 217
Verifying a record selection............................................................................................. 217
Running a record selection.............................................................................................. 218
Saving and printing a Record Selections report as an HTML file.................................. 218
Maintaining a record selection.......................................................................................... 218
    Copying a record selection.......................................................................................... 218
    Listing all record selections on a selected dialer....................................................... 219
    Viewing selection reports........................................................................................... 219
    Viewing record selection settings............................................................................. 219
Appending record selection rows..................................................................................... 220
Inserting a row in a record selection................................................................................ 220
Deleting a row in a record selection................................................................................ 221
Moving a row up in a record selection............................................................................. 221
Moving a row down in a record selection.......................................................................... 222
Selecting all rows in a record selection............................................................................ 222
Clearing all rows in a record selection............................................................................ 223
Record Selection for Multiple Dialers.............................................................................. 223

Chapter 17: Jobs................................................................................................................. 224
    Job types...................................................................................................................... 224
    Outbound jobs............................................................................................................ 225
        When a job stops.................................................................................................... 225
        Types of outbound jobs......................................................................................... 225
    Maximum number of jobs allowed................................................................................ 226
    Automated Release Agent to Ready for Voicemail..................................................... 227
    Call pacing.................................................................................................................. 228
        Using call pacing................................................................................................... 228
Chapter 18: Pattern matching rules

Default pattern syntax
- Expected pattern syntax for field types
- Explicit pattern syntaxes

Supported syntaxes
- List separators
- Numerical comparisons (type N, $, F)
- Date Comparisons (Type D)
- Time Comparisons (Type T)
- String Comparison (Type S)
- Shell-style Pattern syntax (Type P)
- Extended Regular Expression syntax (Type E)

Chapter 19: Schedule

Restrictions for Scheduling

Activities and restrictions

Types of Dialer Activities
- Scheduling a Backup Activity Type
- Scheduling a Backup calling list for late list
- Scheduling backup for a specific calling list in a tenant
- Scheduling a Campaign Update
- Scheduling a Custom Script
- Scheduling a File Transfer
- Scheduling MTS Maintenance
- Scheduling Proactive Contact Maintenance
- Scheduling Run a Selection
## Chapter 24: Monitor views

- Navigating among the Tool menu applications ........................................ 325
- Switching between icons in the button bar ............................................. 325
- Opening a standard view ..................................................................... 326
- Opening a view or view set from another location .............................. 326
- Opening a view about a specific agent ............................................... 326
- Monitor views customization ................................................................. 327
  - Creating a custom view .................................................................. 327
  - Saving current view ....................................................................... 327
  - Saving as a view set ....................................................................... 328
  - Saving view set with a new name .................................................... 328
  - Deleting a view set ....................................................................... 329
  - Adding a view to the Custom button group .................................... 329
  - Refreshing a view ......................................................................... 329

## Chapter 25: Monitor dialog boxes

- View control dialog boxes ................................................................. 330
  - Options dialog box ....................................................................... 330
  - Customize Status Bar dialog box field descriptions ...................... 332
  - Find dialog box field descriptions ............................................... 332
  - Filter Data dialog box field descriptions ...................................... 332
- Job control dialog boxes .................................................................. 333
  - Stop Job dialog box field descriptions ........................................... 333
  - Job Link dialog box field descriptions .......................................... 333
  - Escape Recall Job dialog box field descriptions ......................... 333
  - Record Selection of Link Job dialog box field descriptions ......... 334
  - Minimum Hit Rate dialog box field descriptions ......................... 334
  - Expert Calling Ratio dialog box field descriptions ...................... 335
  - Inbound Settings dialog box field descriptions ............................ 335
  - Managed Dialing dialog box field descriptions ......................... 336
  - Time Zones dialog box field descriptions .................................... 336
  - Unit Work Lists dialog box field descriptions .............................. 337
  - Quota dialog box field descriptions ............................................. 338
  - Alternate Initial Phones dialog box field descriptions .................. 338
  - Detection Modes dialog box field descriptions ............................ 338
  - Retry dialog box field descriptions .............................................. 339
  - Lines dialog box field descriptions ................................................ 339
  - Selection Records dialog box field descriptions ......................... 340
  - Selection Results dialog box field descriptions ........................... 340
  - Selection Sort dialog box field descriptions ................................. 340
- Agent control dialog boxes .............................................................. 341
  - Find Agent dialog box field descriptions ..................................... 341
  - Transfer Agent dialog box field descriptions .................................. 342
  - Send Message dialog box field descriptions .................................. 342
Monitor Agent dialog box field descriptions................................................................. 342

Chapter 26: Monitor view controls.................................................................................. 343
  View control toolbar...................................................................................................... 343
  Scope Selectors............................................................................................................. 344
    Setting Scope Selectors to display data for all dialers, jobs, and supervisors........ 344
    Setting Scope Selectors to display data for all jobs named 30Day......................... 345
  Filtering data in a view................................................................................................. 345
  Setting Scope Selectors............................................................................................... 345
  Selecting time scope.................................................................................................... 346
  Selecting a hierarchy.................................................................................................... 347
    Types of hierarchies................................................................................................... 347
  Maintaining Monitor views.......................................................................................... 348
    Hiding or showing columns....................................................................................... 348
    Selecting Table View or Graphical View................................................................. 348
    Saving a view as a HTML file.................................................................................... 349

Chapter 27: Monitor view windows.................................................................................. 350
  Types of views............................................................................................................. 350
  View toolbar.................................................................................................................. 352
    Hierarchies and scope selectors................................................................................. 353
  Views.............................................................................................................................. 353
    Dialer Status view descriptions.................................................................................. 354
    Dialer Agents view descriptions.................................................................................. 355
    Dialer Lines view descriptions..................................................................................... 357
    Dialer History view descriptions.................................................................................. 358
    Job Status view descriptions....................................................................................... 359
    Job Agents view descriptions....................................................................................... 360
    Job Detail view descriptions......................................................................................... 362
    Job Call Handling view descriptions.......................................................................... 365
    Job Completion Codes view descriptions.................................................................... 365
    Job Wait Queues view descriptions............................................................................. 368
    Job History view descriptions..................................................................................... 370
    Completion Code Detail by Agent view descriptions.................................................. 371
    Job Quality view description....................................................................................... 373
    Supervisor Agents view descriptions.......................................................................... 375
    Find Agent view descriptions..................................................................................... 377
    Agent Detail view descriptions..................................................................................... 377
    Agent Completion Codes view descriptions.............................................................. 379
    Agent History view descriptions.................................................................................. 381

Chapter 28: Job control functions.................................................................................... 383
  Stopping a job.............................................................................................................. 383
  Linking to job............................................................................................................... 384
  Setting escape recall for a job....................................................................................... 385
  Setting automatic record selection.............................................................................. 385
Chapter 29: Agent control functions
   Hierarchies
   Using wildcard characters
   Agent control functions
   Finding an agent
   Transferring an agent to another job
   Sending message to an agent
   Monitoring agent line
   Removing an agent line
   Viewing an agent view

Chapter 30: Alerts
   Alerts uses
   Alert types
   Alert settings
   Creating an alert
   Creating an Email Notification
   Editing an alert
   Removing an alert
   Sending email alert using Health Manager or Monitor Alerts option
   Using antivirus
   Enable and disable alerts
   Enabling and disabling alerts
   Checking the status of each alert
   Alert Viewer dialog box field descriptions
   Alert Editor, Alert Definition tab field descriptions
   Alert Editor, Scope tab field descriptions
   Alert Editor, Notifications tab field descriptions
Chapter 31: Analyst
Multitenancy in Analyst................................................................. 412
Analyst Toolbar.............................................................................. 412
New report configuration data..................................................... 413
  Creating a new report configuration........................................ 414
  Deleting a report configuration................................................. 415
  Changing a report configuration............................................... 416
  Previewing a report.................................................................... 416
  Printing a report from the menu............................................... 417
  Printing a report from the preview window.............................. 417
  Exporting report data............................................................... 418
  Scheduling a report................................................................... 420
  Viewing data of deleted tenants............................................... 421
Window arrangement overview.................................................. 421
Navigating among the Tool menu applications......................... 422
Using large icons or small icons on the button bar................. 422
Chapter 32: Analyst reports........................................................ 423
Report categories.......................................................................... 423
  Report categories descriptions............................................. 423
Managed Dialing reports............................................................. 425
Completion Code Summary reports.......................................... 426
Reports per category.................................................................... 426
  Agent reports......................................................................... 427
  Job Reports........................................................................... 429
  Time of Day Reports.............................................................. 433
  Administrative Reports.......................................................... 436
  Agent Monthly Reports.......................................................... 437
  Job Monthly Reports.............................................................. 438
  Time of Day Monthly Reports................................................. 440
Report calculations....................................................................... 443
  Abandon Calls....................................................................... 443
  FCC nuisance rate................................................................. 443
  Idle Time................................................................................. 444
  Online Time............................................................................ 445
  Job Active Time...................................................................... 445
  Agent Logout Time................................................................. 445
Chapter 33: Concepts of SQL Expressions for Analyst.............. 446
Setup and requirements............................................................... 446
Benefits of Crystal reports........................................................... 446
Historical performance data concepts....................................... 447
  Monthly roll-up reports.......................................................... 447
  Administrative reports............................................................ 448
  Elementary and calculated data.............................................. 448
## Contents

- Weighted averages........................................................................................................ 448
- Data field notes............................................................................................................. 449
  - Idle count fields........................................................................................................ 449
  - Outbound, Inbound, and Combined fields................................................................. 449
- Guidelines for creating new reports............................................................................. 449
  - Modifying an Analyst built-in report........................................................................ 449
  - Creating a new report................................................................................................ 449
- Field reference for Crystal reports SQL Expressions......................................................... 450
  - Admin rollup................................................................................................................ 450
  - Agent activity............................................................................................................... 450
  - Agent codes................................................................................................................ 451
  - Agent hierarchy.......................................................................................................... 451
  - Dialer hierarchy.......................................................................................................... 451
  - Job hierarchy.............................................................................................................. 452
  - Completion codes....................................................................................................... 452
  - Combined call handling times.................................................................................... 453
  - Combined call statistics............................................................................................. 455
  - Combined queue statistics........................................................................................ 458
  - General information.................................................................................................... 459
  - Inbound call handling times....................................................................................... 459
  - Inbound call statistics................................................................................................. 461
  - Inbound queue statistics............................................................................................ 462
  - Managed dialing statistics.......................................................................................... 463
  - Outbound call handling time...................................................................................... 465
  - Outbound call statistics............................................................................................. 470
  - Outbound queue statistics......................................................................................... 472
  - Person to Person call handling times........................................................................ 473
  - Person to Person call statistics.................................................................................. 474
  - Combined RPC and closure statistics....................................................................... 474
  - Combined call completion code statistics................................................................ 478

**Chapter 34: PC Analysis Telnet** .................................................................................. 491

- PC Analysis................................................................................................................... 491
- PC Analysis Telnet icons............................................................................................... 491
- Starting PC Analysis Telnet........................................................................................... 492
- Calling List..................................................................................................................... 493
- Call Information Statistics............................................................................................. 500
- Call Transaction Statistics............................................................................................ 501
- Job History.................................................................................................................... 502
- Agent History............................................................................................................... 505
- Transferring PC Analysis extract output files............................................................... 508
- FTP Client dialog box field descriptions...................................................................... 508

**Chapter 35: Hierarchy Manager** .................................................................................. 509

- Agent hierarchies......................................................................................................... 510
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resynchronizing blend engine</td>
<td>538</td>
</tr>
<tr>
<td>Viewing ACD statistics</td>
<td>538</td>
</tr>
<tr>
<td>Viewing alerts</td>
<td>538</td>
</tr>
<tr>
<td>Viewing transactions</td>
<td>539</td>
</tr>
<tr>
<td><strong>Chapter 38: Resources</strong></td>
<td>540</td>
</tr>
<tr>
<td>Documentation</td>
<td>540</td>
</tr>
<tr>
<td>Finding documents on the Avaya Support website</td>
<td>540</td>
</tr>
<tr>
<td>Training</td>
<td>541</td>
</tr>
<tr>
<td>Viewing Avaya Mentor videos</td>
<td>541</td>
</tr>
<tr>
<td>Support</td>
<td>542</td>
</tr>
<tr>
<td><strong>Appendix A: PDSAgent.ini parameters</strong></td>
<td>543</td>
</tr>
<tr>
<td>PDSAgent.ini parameters overview</td>
<td>543</td>
</tr>
<tr>
<td>Agent</td>
<td>543</td>
</tr>
<tr>
<td>Dynamic Data Exchange</td>
<td>544</td>
</tr>
<tr>
<td>Blend parameter</td>
<td>544</td>
</tr>
<tr>
<td>User interface parameters</td>
<td>544</td>
</tr>
<tr>
<td>Telephone extension parameters</td>
<td>546</td>
</tr>
<tr>
<td>Session parameters</td>
<td>547</td>
</tr>
<tr>
<td>Server parameter</td>
<td>547</td>
</tr>
<tr>
<td>Log parameters</td>
<td>547</td>
</tr>
<tr>
<td>Parameters to set Agent display</td>
<td>548</td>
</tr>
<tr>
<td>Security parameters</td>
<td>549</td>
</tr>
<tr>
<td>DialerList</td>
<td>550</td>
</tr>
</tbody>
</table>
Chapter 1: Introduction

Purpose

This document describes the product overview, feature descriptions, and user tasks of Avaya Proactive Contact Supervisor.

Proactive Contact Supervisor consists of the following applications:

• Role Editor
• Editor
• Analyst
• Health Manager
• Monitor

This document is intended for people who want to understand and use Proactive Contact Supervisor features, functionality, capacities, and limitations.
Chapter 2: Proactive Contact overview

Proactive Contact consists of software, hardware, and network components. The system is comprised of the system cabinet, supervisor workstation, agent workstations, printer, and modem.

Proactive Contact environment

The Proactive Contact system works with the call center equipment and operations to perform call center tasks.

Your installation can include more than one dialer.

Dialer functions

The primary functions of a dialer are as follows:

- Receive customer records from the call center’s host computer.
- Select and sort customer records based on the call center’s business goals.
- Pass only specific call types to agents.
- Allow agents to update customer information on an agent screen or on the host, depending on the required configuration.
- Adjust the calling pace to meet the call center’s requirements.
- Monitor ACD inbound traffic and predict when to acquire and release ACD agents for outbound calling on Proactive Contact with Agent Blending.
- Support outbound, inbound, and blend jobs.
- Generate a variety of reports, including job, agent, and system reports.
- Upload record information to the host (optional).

Multiple dialers

Proactive Contact system can include multiple dialers, which is also called a Pod configuration. You can connect up to 10 dialers through a mid-tier structure. Each of these dialers should be a fresh system without any prior data.
A Proactive Contact system that is connected to more than one dialer through a Mid-Tier structure is called a pod. A multiple dialer environment that uses a pod increases the outreach capacity of your company. Using a pod, you can manage large-scale outreach programs from a single administration and Supervisor interface.

A pod provides the following additional features:

- Calling list sharing
- Jobs
- Phone strategies
- Record selections
- Completion codes
- Log ins

From one Supervisor application, you can run multiple jobs on multiple dialers, monitor calling activities on each dialer, and use calling list data belonging to one dialer from another dialer in the pod for calling activities.

Proactive Contact system can also have a distributed architecture such as:

- Multiple standalone dialers
- One or more pods of dialers
- Multiple standalone dialers and multiple pods of dialers

Using multiple standalone dialers or a pod, you can manage multiple jobs simultaneously, each with its own calling list. If a dialer shuts down, the remaining dialers continue to operate.

---

**Multitenancy**

A tenant is defined as a partition within a dialer that is self-sufficient and mutually exclusive from the other tenants on the same dialer. Using multitenancy, you can administer and use dialer functionalities so that each tenant can perform actions on the dialer without hampering the work of other tenant(s) working on the dialer.

The Multitenancy in Proactive Contact is defined in terms of the following concepts:

- Tenant: A partition of Proactive Contact dialer. You can use tenant independently to perform all dialer functions required to start, manage, and report on dialing campaigns or jobs. Therefore, within a tenant, you can carry out all the tasks without the knowledge of the existence of any other similar partitions on the same dialer.

- Tenant Space: An abstract notion of the resources that a tenant user can gain access to and manage within a tenant. The system allocates the resources in this space at the time of creation of a tenant. For example, for a tenant space, the allocated resources can be 10 jobs, 5 agents, 3 calling lists, and 2 messages.

By default, all the data on the dialer such as, calling lists, agents, and jobs are a part of the default tenant. When upgrading the system to Proactive Contact 5.2, the implementation of multitenancy
does not impact the existing user scenarios as long as the system continues to run with only the default tenant defined. However, you can create up to 20 tenants for each dialer to suit your business needs.

By default, the system has a Lead Administrator role with the permissions to create tenants and add users to that tenant. The administrator of a tenant can view information pertaining to only that tenant. A user can belong to multiple tenancies and can have different roles in different tenancies. However, each user must have only one logon credential in the system, which can be shared across the tenants.

---

**Calling lists**

A calling list is a file that contains customer records. Proactive Contact uses two types of calling lists: one for outbound calling and the other for inbound calling on Intelligent Call Blending systems.

The host system creates the download file of customer records for the outbound calling list. The download file contains the records and fields you defined as necessary to your outbound call activities.

Proactive Contact processes the host file and prepares the records for the calling activities. When the calling activities end, the system prepares the calling list to be uploaded to the host.

**Process calling lists**

After the host downloads the customer records, Proactive Contact completes the following tasks, as applicable, to create a calling list:

- Checks for and flag the duplicate records and invalid telephone numbers.
- Identifies and marks records that have been on the system for more than the specified number of days.
- Recalls the name of the last agent to speak to the customer.
- Stores the result of the last call attempt as recorded by the agent.
- Applies time zones and guard times as defined for specified area codes or zip codes time zone processing.
- Restores the recall information from previous day’s list to today’s list.
- Brings over the following statistics from the previous day’s list:
  - Name of the last agent to speak with the customer.
  - Date and time of the last call attempt.
  - Result of the last call attempt as recorded by the agent on the system.
  - Number of days the record has been on the system.
  - Record status.
- If configured, data listed is the data that is carried forward from the previous calling list

After calling activities and at a scheduled time, Proactive Contact completes the following tasks to upload the file to the host:

- Converts the customer records in a specific calling list to a format specified for your host computer.
- Converts the sample file from fixed length or CSV format to sample calling list binary.
- Creates an upload file.

The host then updates your customer database with the data in the calling list.

**Environment**

The calling list environment is responsible for the following activities:

- Create the files required to convert host computer data to the Proactive Contact calling list format.
- Prepare the calling list for the calling activities.
- Create the files required to extract data to send back to the host after calls have been made.

**Support for backward compatibility for supervisor applications**

**About this task**

Use this procedure for Proactive Contact 5.1.3 supervisor applications to work with Proactive Contact5.2 with respect to the TLS1.2 change on Dialer.

**Procedure**

1. Configure the `/opt/avaya/pds/config/pc_ssl.conf` file on Dialer by changing the value of `DISABLE_CIPHERS` as follows:

   - `CORE_SSL_METHOD:SSLv23`
   - `SERVICE_SSL_METHOD:SSLv23`
   - `SUPPORT_STRONG_CIPHER:NO`
   - `DISABLE_CIPHERS:!MD5:!RC4:!IDEA:!SEED:!CAMELLIA`

2. Change the `SSL_VERSION` to 1.0 in the `sqlnet.ora` and `listener.ora` files.

   For example:
   ```
   SSL_VERSION = 1.0
   ```

3. Change the `SSL_VERSION` to 1.0 in the Supervisor `sqlnet.ora` file.

4. Replace the wallet on Proactive Contact 5.1.3 Supervisor located at `C:\Program Files (x86)\Avaya\Proactive Contact 5.1\Services\3rdParty\Oracle11g\wallet\` by copying it from the Proactive Contact5.2 Dialer `/opt/dbase/wallet`.

5. Ensure that the SSL VERSION of the dialer and supervisor is in synch and remove the `SSL_CIPHER_SUITES` parameter.

   Oracle DB decides the best `SSL_CIPHER_SUITES` automatically. If you want to configure then, select the best Ciphers from the supported list. However ensure that the value of
SSL_VERSION & SSL_CIPHER_SUITES parameter configured in the Supervisor sqlnet.ora file must be in synch with Dialer.

6. Restart the Data base, MTS, and PDS.
7. Verify that the Supervisor applications like Monitor or Analyst are able to connect to the database.

---

Role-based authorization for Administrators

To meet security requirements, each administrator can only see the view of administration that is assigned to the administrator role. For example:

Auditor: The Auditor role has a separate menu. With this role, you can audit system security, such as bad logins, and job operations, such as job settings, during run time.

---

Secured Agent application

The Agent application is a secured application with the following benefits:

- Communicates using Secure Socket Layer (SSL) or Transport Layer Security (TLS).
- Provides encrypted data transmission.
- Uses certificates for the client and server authentication.
- Saves the security settings in the PDSAgent.ini file.

---

Licensing

Avaya Product Licensing and Delivery System (PLDS) provides easy-to-use tools to customers, Avaya Partners, distributors, and Avaya Associates so that they can manage license entitlements and electronic delivery of software and related license files. Using PLDS, you can perform operations such as license activations, license upgrades, license moves, and software downloads.

Use the License Activation Code (LAC) to activate one or more license entitlements. You may choose to activate all of the licenses or specify the number of licenses that you want to activate from the quantity available. Upon successful activation of the license entitlements, PLDS creates an Activation Record and sends an Activation Notification e-mail message to the customer that is registered with the entitlements. The Activation Record and Activation Notification provide details on the number of activated licenses and the License Host. You can gain access to the license file on the License/Keys tab of the Activation Record in PLDS and is also an attachment to the Activation Notification e-mail message. You need to install the license file on WebLM to use the licenses.

With the licensing feature, you can license various dialer entities using the Web-based License Manager (WebLM) licensing software. WebLM is a standalone Web-based license manager that
runs on both Windows and Linux systems. WebLM is designed to support any Avaya software product that needs licensing capabilities.

In a standalone WebLM, a WebLM server is used to support one or more licensed application instances. In this model, an administrator can perform the following tasks through the WebLM server:

• Install a license file on the WebLM server
• Manage WebLM users
• Track feature licenses acquired by licensed applications
• Generate a usage report for the feature licenses

This feature does not replace any of the required configurable limits that are used to limit the capacity of an individual dialer due to hardware limitations or dialer performance.

The system uses licensing in addition to the dialer capacity checks. You cannot use the licensing feature for role restriction. You can determine the capacities and potential roles of an application prior to a request for a license.

All the dialer components that use licensing must provide a 30-days grace period during which you can use the dialer components in case of the failure of WebLM server.

---

## Installing prerequisites for License server

**Procedure**

1. Install Tomcat
2. Install WebLM Server
3. Install the license file on WebLM Server

**Note:**

The license file is generated using Avaya Product Licensing and Delivery System (PLDS).

---

## Configuring the dialer

**About this task**

To configure the dialer, you must add the WebLM Server URL to the master.cfg file on the dialer.

**Note:**

You must contact Avaya Professional Service to configure parameters in the master.cfg file.
Procedure

Perform one of the following steps to add the WebLM Server URL to the master.cfg file:

• Add the http://<IP_Address_WebLM_Server>:8080/WebLM/LicenseServer URL to the master.cfg file manually.

• Add the WebLM Server URL to the master.cfg file through License Configurator.

Note:

Ensure that you restart the dialer every time you change the URL. Also, in the URL, ensure that you use a comma (,) in place of a colon (:).

Grace period

When the dialer is unable to connect to the WebLM Server and refresh the licenses, then the system goes into a grace period.

The dialer can run into the grace period for 30 days. During the grace period, the Supervisor application will receive grace period messages every 30 minutes indicating the time left for the grace period to expire.

When the system re-connects with the WebLM server, the system acquires all the licenses again. After the expiry of the grace period, the system shuts down.

Security

Configuring Transport Layer Security and High Ciphers

Release 5.2 of Proactive Contact supports Transport Layer Security (TLS) 1.2. Supervisor installation creates the configuration file, pc_ssl.conf, in Supervisor\common folder. The installation also creates the following default entry in the pc_ssl.conf file for SSL/TLS configuration:

SERVICE_SSL_METHOD:SSLv23
SUPPORT_HIGH_CIPHER:NO

The installer creates the configuration file %SQL_PATH%\sqlnet.ora file or Oracle SSL/TLS configuration with the following default entry:

SSL_VERSION = 0

Supervisor communicates with Dialer system as per the TLS security configuration in the Dialer system. There will be no restriction in Supervisor client side.
If you have a Proactive Contact set up with IVR, you must disable TLS for IVR to work, because TLS is not supported in IVR.

What's new in Release 5.2

New in Avaya Proactive Contact Release 5.2

Supports Transport Layer Security 1.2 including High Ciphers

Avaya Proactive Contact Release 5.2 supports Transport Layer Security (TLS) 1.2 for connections between the dialer server and the clients including high ciphers. Customers can configure the dialer with TLS 1.2 protocol.

To support TLS 1.2, the following components are modified:

- Agent binary
- Listserver
- PC Agent
- Agent API
- Event SDK
- Internet Monitor
- WebLM
- Supervisor

TLS 1.2 and SHA-2 certificates are now supported between the dialer server and the Avaya Application Enablement Server (AES).

Supports SIP Recording

Avaya Proactive Contact Release 5.2 introduces a unique call-id on the ISDN and H.323 trunks when using the PG230 trunks. The function of such an ID is to enable SIP Recording (SIPREC) recording solutions in cases where PG230 trunks are converted to SIP. The ID provided within the trunks can be correlated with the ID provided by the Event SDK to identify individual calls on the SIP trunks.

Support for custom certificate

Avaya Proactive Contact Release 5.2, introduces deployment of the custom certificate into Proactive Contact system including Dialer, Supervisor, Agent and Event SDK. Customers can create and install their own certificates into PC system and the certificate may sign by any third party Certificate authority (CA).
Java, WebLM, and Tomcat upgrades
Avaya Proactive Contact Release 5.2 upgrades the Java platform on the dialer and supports the following versions of Java, WebLM, and Tomcat:

- Azul JDK version 1.8 and JacORB version 3.2
- WebLM version 7.1.0
- Tomcat version 9.0

Secure System Access
The Enhanced Access Security Gateway (EASG) has been integrated into the Avaya Proactive Contact system. EASG provides secure authentication and auditing of all remote access into the maintenance ports.

Updated Area codes with Time Zone Mapping (U.S and Canada)
Avaya Proactive Contact Release 5.2 has updated Area code mapping tables for the US and Canada. The Area code and time zone information is updated in locale.cfg, timezone.cfg, and sttdday.

What's new in Release 5.1.2

Manual dialing
In this release, an agent can dial a number manually through Proactive Contact or through any third-party software.

You can enable manual dialing by setting the Enable Manual Dialing and Dial with Third Party parameters in the Job Details pane.

Support for TLS 1.0 and High Ciphers
From Release 5.1.2, Avaya Proactive Contact supports Transport Layer Security (TLS) 1.0 and High Ciphers. This enhancement is for improved security.

Answer supervision by job
In this release, you can configure answer supervision for a job. You must select the Answer Supervision check box under Outbound Processing in the Job Details pane to configure answer supervision for a job.
Password length

From Release 5.1.2 of Proactive Contact, the passwords of all Supervisor applications, Proactive Contact Agent, Agent API, CUI login, and Enclient can have a maximum of 20 characters.

This enhancement is applicable only for new passwords.

On-hold message or music

In this release, you can play message or music to a customer while an agent puts a customer on hold. To configure this feature, you must select the appropriate script to be run in the Job Details pane.

Zip To Time Zone for calling lists

In this release, you can configure the Zip To Time Zone feature for calling lists.

Shadow jobs in preview mode

From Release 5.1.2 of Proactive Contact, you can configure shadow jobs to be available in preview mode. With this feature, an agent can view the details of a shadow job in the preview mode before dialing out to a customer.

Microsoft Windows versions supported

Avaya Proactive Contact Release 5.1.2 applications (PC Agent, Supervisor suite, APIs (Agent API), and Event SDK) support Microsoft Windows Vista Enterprise Edition, Microsoft Windows 7, 8.1, and 10, and Microsoft Windows Server 2008.

Avaya Proactive Contact Release 5.1.2 does not support Microsoft Windows XP.

Support for passing called party number for opt out calls to VDN

Avaya Proactive Contact enhances the Opt-out to VDN feature so that the TRANSID feature works with a virtual job to allow one of the calling lists field data to be transferred as ANI to the agent.
What's new in Release 5.1

Multitenancy

Using Multitenancy, you can create various tenants on the Dialer. Within these tenants, you can administer and use dialer and its functionalities so that each tenant performs actions on the dialer without hampering the work of other tenants working on the dialer. Therefore, each tenant can work in the capacity of individual dialer while residing on the same setup. You can allocate campaigns, agents, calling lists, schedules, agent keys, and other components to the tenants.

Multitenancy is an optional feature in the new release. You can continue to use Proactive Contact as the default resource group, without multitenancy. The other new features in this release such as, increased dialer support and out of time zone cellphone support are available in both tenantized and non-tenantized environments.

Increased capacity

Proactive Contact is available with increased capacities for the Proactive Contact large cabinet and PG230RM systems (Application Enablement Services implementations will remain at the previous capacity levels). Capacities for both concurrent agents and outbound trunks have been significantly increased to almost double the current capacities of 240 agents and 480 trunks. Actual agent and trunk maximum capacities differ based upon trunk configuration parameters.

The supported capacities are as follows:

<table>
<thead>
<tr>
<th>Capacity Type</th>
<th>Maximum Capacities</th>
</tr>
</thead>
<tbody>
<tr>
<td>T1 (non-ISDN)</td>
<td>432 agents / 912 trunks</td>
</tr>
<tr>
<td>T1 ISDN wo/NFAS</td>
<td>414 agents / 874 trunks</td>
</tr>
<tr>
<td>T1 ISDN w/NFAS</td>
<td>432 agents / 854 trunks</td>
</tr>
<tr>
<td>E1-CAS (non-ISDN)</td>
<td>390 agents / 810 trunks</td>
</tr>
</tbody>
</table>

As a system supervisor, you use the Supervisor applications to set up, monitor, modify, and report on the calling activities. On each dialer in the system, you can use maximum 100 Supervisor workstations for various Supervisor applications such as, Editor, Monitor, Analyst, Role Editor, and Health Manager. Similarly, in a Pod environment with maximum 10 dialers supported by the system, you can use a maximum of 100 Supervisor workstations on which you can use various Supervisor applications.

Note:

To use some of the features in Proactive Contact Monitor, you might need to configure some parameters in the backend file, master.cfg. To configure these parameters, contact Avaya Professional Services.
Increased dialer support in a pod

In this release, you can include up to 10 dialers in a pod setup.

Enhanced ID field for calling list names

In this release, you can provide meaningful names to calling lists, for example, to indicate the reason for creating the calling list. Earlier, the calling list name only indicated the nature of the calling list, such as inbound or outbound, and the pre-assigned number.

You can use customized calling list names in strategy, call selections, and jobs. You can also create, download, upload, and install a campaign template for a calling list with a customized name. All the reports display customized calling lists names.

The calling list name must be unique at the tenant level. You can use the same calling list name for multiple tenants, but within a tenant, you cannot have more than one list with the same name.

Out of time zone phone support

In some countries, telemarketers are restricted from calling outside the calling hours of the called party whatever the local time zone might be. In previous releases, when a person kept the original mobile phone number after moving to a different time zone, the Avaya Proactive Contact dialer placed a call to the mobile phones outside of the regulatory time zone hours. In this release, you can support calls to mobile phones with an additional time zone identifier assigned.

Automated Release Agent to Ready feature for Voicemail

In the United Kingdom, Proactive Contact customers must connect the called party with agent within two seconds. Therefore, the customers are unable to use the Answering Machine Detection (AMD) feature of Proactive Contact to eliminate agent intervention for any and all calls. The customers typically turn off AMD and answer all calls with a live agent. The live agent passes the call to the correct message, selects the completion code for this result, and then goes back to the ready state. However, this procedure impacts agent productivity significantly.

With the Automated Agent Release to Ready feature, Proactive Contact connects all calls to a live agent and the system continues to detect answering machines. If the system detects an answering machine, the administrator can perform one of the following actions:

- End the call without playing a message and place the agent in the ready mode.
- Play a message on the answering machine but also place the agent in the ready mode.
- Leave the answering machine with an agent.
This feature has been introduced at the job level and you can configure this feature in the Job details pane.

---

**Implementation of FCC 12-21 regulation**

In the earlier release of Proactive Contact, in case of a live call, you can use the Do Not Call (DNC) feature to allow agents to mark the called party record as DNC and mark all the matching records with the same unique called party identifier in other selected calling lists as DNC.

In view of the FCC 12-21 regulation, now in case of virtual job, a pre-recorded message plays to the called party that provides the DNC opt-out option for automatic indication to mark the record as DNC.

In case of outbound live call on Proactive Contact, if a welcome message is played to the called party before connecting to the agent, the system provides the DNC opt-out option to the called party throughout the duration of the welcome and wait queue messages. After the welcome message, the call must be connected to a live agent within two seconds, otherwise, the call is marked as an FCC nuisance call. Also, a report has been added to the Analyst module that provides the details of FCC nuisance calls for a 30-day period.
Chapter 3: Proactive Contact users, login, and permissions

### Proactive Contact users

<table>
<thead>
<tr>
<th>User Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lead Administrator</td>
<td>Sets up tenants and assigns administrators and users to the tenants. Lead Administrator also defines the following resources for a tenant:</td>
</tr>
<tr>
<td></td>
<td>• Maximum number of agents</td>
</tr>
<tr>
<td></td>
<td>• Maximum number of supervisors</td>
</tr>
<tr>
<td></td>
<td>• Maximum number of line pools</td>
</tr>
<tr>
<td></td>
<td>• Maximum number of event server client</td>
</tr>
<tr>
<td></td>
<td>• Completion codes for quota feature</td>
</tr>
<tr>
<td></td>
<td>• Blend group for the tenant</td>
</tr>
<tr>
<td></td>
<td>• Maximum number of calling lists for a tenant</td>
</tr>
<tr>
<td></td>
<td>• Maximum number of message size and message slots assigned to a tenant</td>
</tr>
<tr>
<td></td>
<td>• Completion codes for a tenant</td>
</tr>
<tr>
<td></td>
<td>• Maximum number of campaigns for a tenant</td>
</tr>
<tr>
<td></td>
<td>• Maximum number of scripts for a tenant</td>
</tr>
<tr>
<td>Auditor</td>
<td>Audits the system security during run-time.</td>
</tr>
<tr>
<td>Role administrator</td>
<td>Assigns roles to users within a tenant using the Role Editor application.</td>
</tr>
<tr>
<td>Administrator</td>
<td>Sets up and maintains the Proactive Contact system including the following tasks:</td>
</tr>
<tr>
<td></td>
<td>• Set up user accounts</td>
</tr>
<tr>
<td></td>
<td>• Start and stop dialers</td>
</tr>
<tr>
<td></td>
<td>• Define and download calling lists</td>
</tr>
<tr>
<td></td>
<td>• Monitor the health of the system</td>
</tr>
<tr>
<td></td>
<td>• Define audio messages and scripts</td>
</tr>
<tr>
<td></td>
<td>Applicable only for the default tenant.</td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>User Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tenant Administrator</td>
<td>Administers the operations within a tenant. Tenant Administrator acts as a Role Administrator and Administrator for the tenant to perform the following tasks:</td>
</tr>
<tr>
<td></td>
<td>• Manage campaigns</td>
</tr>
<tr>
<td></td>
<td>• Manage calling list</td>
</tr>
<tr>
<td></td>
<td>• Manage scheduling</td>
</tr>
<tr>
<td>Supervisor</td>
<td>Sets up and monitors the contact center calling activities including the following tasks:</td>
</tr>
<tr>
<td></td>
<td>• Create and maintain phone strategies</td>
</tr>
<tr>
<td></td>
<td>• Create and maintain record selections</td>
</tr>
<tr>
<td></td>
<td>• Create jobs that define calling activities</td>
</tr>
<tr>
<td></td>
<td>• Start and stop jobs</td>
</tr>
<tr>
<td></td>
<td>• Monitor and maintain calling activities</td>
</tr>
<tr>
<td>Agent</td>
<td>Handles inbound and outbound calling activities.</td>
</tr>
<tr>
<td></td>
<td>Agents work on outbound and blend jobs. Agents can also receive inbound calls that customers place to the contact center.</td>
</tr>
</tbody>
</table>

**Note:**
For information about functionalities of the Proactive Contact Agent application, see *Using Avaya Proactive Contact Agent*.

---

**Logins and permissions**

In Proactive Contact, your login determines the applications that you can use and the features that you can use in the application.

<table>
<thead>
<tr>
<th>Login</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lead Administrator login and password</td>
<td>To use lead administrative features in the Role Editor application. Lead Administrators can also use the Role Editor application to monitor and manage the tenant space of Proactive Contact and perform:</td>
</tr>
<tr>
<td></td>
<td>• User Management</td>
</tr>
<tr>
<td></td>
<td>• Tenant Management</td>
</tr>
<tr>
<td></td>
<td>• Role Management for the default tenant</td>
</tr>
<tr>
<td></td>
<td>• Dialer servers CUI menu operations</td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>Login</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Administrator login and password</td>
<td>To use administrative features and supervisor features in the Linux-based application and in the Supervisor application for the default tenant. Administrators can also use the Health Manager application to monitor and manage the operation of Proactive Contact.</td>
</tr>
<tr>
<td>Supervisor login and password</td>
<td>To use supervisor features in the Linux-based application and in the Supervisor GUI</td>
</tr>
<tr>
<td>Agent login and password</td>
<td>To use the Proactive Contact Agent application. The type of calling activities that an agent can handle depends on the agent type selected by the agent at the time of logging into the system.</td>
</tr>
</tbody>
</table>

**Passwords**

The system displays a message to change your password if you login for the first time or your password expires.

Ensure that your new password is minimum eight characters long and includes at least the following:

- One upper case letter
- One lower case letter
- One number
- One special character

**Note:**

If you use an upper case character as the first character of your password and a number as the last character of your password, the password is not counted in fulfilling the password criteria.

The system automatically locks your password after three unsuccessful login attempts. However, you can unlock your password using the createop utility.

**Note:**

For default users, the system does not lock the password even after three unsuccessful login attempts.

While resetting your password, ensure that your new password is different from the last seven passwords.

The password strength criterion is applicable only if the PAMPASS_ENAB parameter is enabled in the master.cfg file. By default, the PAMPASS_CRITERIA parameter is disabled in the system. However, irrespective of the value of the PAMPASS_CRITERIA parameter, the system does not allow leading and trailing spaces in the passwords.
Important:
From release 5.1.2, all Supervisor applications, Proactive Contact Agent, Agent API, CUI login, and Enclient have a password length of maximum 20 characters.
This enhancement is applicable only for new passwords.

Agent types
After logging in, each agent selects an agent type that is set up for your system. The agent type determines the types of calls the agent can handle.
Agents can log in to Proactive Contact and select one of the following agent types:

<table>
<thead>
<tr>
<th>Agent Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outbound</td>
<td>Handles only outbound calls. An Outbound agent can join the standards outbound jobs, such as Cruise Control, Unit work list, Sales Verification, and Infinite.</td>
</tr>
<tr>
<td>Managed</td>
<td>Handles only outbound calls when an outbound job is set up as a Managed Dialing job.</td>
</tr>
<tr>
<td>Inbound</td>
<td>Handle only inbound calls. An Inbound agent can join inbound or blend jobs. The system receives calls directly from customers or through an ACD.</td>
</tr>
<tr>
<td>Blend</td>
<td>Handles both outbound and inbound calls. A Blend agent can join blend jobs and handle customer records on outbound and inbound calling screens.</td>
</tr>
<tr>
<td>Person to Person</td>
<td>Handles outbound calls when an outbound agent is unavailable.</td>
</tr>
<tr>
<td>ACD</td>
<td>Handles outbound calls on Proactive Contact and inbound calls on ACD.</td>
</tr>
</tbody>
</table>

Agent logins
Basic login
The following table describes the agent logins that you can use regardless of the blending configuration on your system.
### Agent Blending login

Use the following agent logins if your system is configured with Agent Blending.

<table>
<thead>
<tr>
<th>Agent Type</th>
<th>Login</th>
<th>Job</th>
<th>Calls</th>
</tr>
</thead>
<tbody>
<tr>
<td>Managed</td>
<td>m</td>
<td>managed</td>
<td>Outbound calls on Proactive Contact</td>
</tr>
<tr>
<td>Outbound</td>
<td>o</td>
<td>outbound or blend</td>
<td>Outbound calls on Proactive Contact</td>
</tr>
<tr>
<td>Person-to-Person</td>
<td>p</td>
<td>outbound</td>
<td>Outbound calls on Proactive Contact</td>
</tr>
</tbody>
</table>

### Intelligent Call Blending login

The following table describes the agent logins that you can use if your system is configured with Intelligent Call Blending.

<table>
<thead>
<tr>
<th>Agent Type</th>
<th>Login</th>
<th>Job</th>
<th>Calls</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACD</td>
<td>a</td>
<td>Outbound</td>
<td>Outbound calls on the Proactive Contact and inbound calls on ACD</td>
</tr>
<tr>
<td>ACD</td>
<td>a</td>
<td>Managed</td>
<td>Managed Outbound calls on the Proactive Contact and Inbound calls on ACD</td>
</tr>
</tbody>
</table>

### Agent Blending and Intelligent Call Blending login

The following table describes the agent login that you can use if your system is configured for both Agent Blending and Intelligent Call Blending.

<table>
<thead>
<tr>
<th>Agent Type</th>
<th>Login</th>
<th>Job</th>
<th>Calls</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACD</td>
<td>a</td>
<td>blend</td>
<td>Outbound calls on Proactive Contact and Inbound calls on ACD</td>
</tr>
</tbody>
</table>

### Logging in to Supervisor

**About this task**

Proactive Contact uses the Supervisor application to interface with the hardware and software that is included with the system.

You can use a single password to gain access to Role Editor, Health Manager, Monitor, Editor, and Analyst applications.

After you log in to an application, you can access the other applications without entering the user name and password again.
Procedure

1. Click **Start > All Programs > Avaya > Proactive Contact > Supervisor**.
2. Click Analyst, Editor, Health Manager, Monitor, or Role Editor.
3. Enter your login name and password.
   
   **Tip:**
   
   If you already have one application from the Supervisor suite open on your computer, do not log in again when you open a second application. If you exit all applications, you must log in again.
4. Click **OK**.

Result

When you log in to any of the Supervisor applications, you can view or perform actions according to the role and permissions assigned to your user login. Also, you can view data only for the tenant that you have been assigned to.

**Note:**

By default, the system initially displays only the sample data for each of the menus in the applications. You can change the data as per your requirements.

---

**Viewing online help**

Procedure

1. To see online help, perform one of the following steps:
   - Click **Help > Contents**.
   - Press **F1**.
2. *(Optional)* If you see a message that Internet Explorer restricted the help system from showing active content, perform the following steps:
   a. In Internet Explorer, click **Tools > Internet Options**.
   b. Click **Advanced** tab and navigate to the **Security** section.
   c. Select the **Allow active content to run in files on My Computer** check box.
   d. Click **OK**.
Chapter 4: Managing roles

To create roles, assign users to roles, create users/tenants, and manage users/tenants, you can use Proactive Contact Role Editor application.

**Note:**
To use some of the features in Role Editor, you might need to configure some parameters in the `master.cfg` file. To configure these parameters, contact Avaya Professional Services.

## Working with multitenancy

By default, all the data on the dialer, such as calling lists, agents, and jobs, is a part of the default tenant. When upgrading the system to Proactive Contact 5.2, the implementation of multitenancy does not impact the existing user scenarios as long as the system runs with only the default tenant. However, you can create up to 20 tenants for each dialer to suit your business needs. The maximum number of tenant allocation for a user is 20 tenants, which includes one default tenant and 19 other tenants.

If a user belongs to the default tenant, then the user can be a part of maximum 19 more tenants. However, if a user does not belong to the default tenant, then the user can be a part of maximum 20 tenants.

The Proactive Contact system environment has a new role named Lead Administrator. You can use the Lead Administrator role to create, modify, and delete new tenants and manage users and roles for the tenants. You can assign multiple users to this role.

The Proactive Contact system environment has another new role named Tenant Administrator. A Tenant Administrator can manage all day-to-day operations within a tenant including managing calling list, scheduling, jobs, messages and scripts, and reporting.

A user can belong to multiple tenancies and can have different roles in different tenancies. However, a user can have only one logon credential in the system, which is shared across the tenants. Users can switch between tenants by using a drop-down, without having to logout.
Roles

A Role is a set of actions and activities assigned to or expected of a person or a group. Roles relate to various job functions in an organization. You can assign roles to users based on responsibilities and qualifications. You can also reassign roles from one user to another, grant new permissions to roles when new applications and systems are incorporated, and revoke permissions as required.

Roles are closely related to the concept of user groups in access control. However, a role brings together a set of users on one side and a set of permissions on the other, whereas user groups are typically defined as a set of users only. Access control policy is formulated around a role. The particular collection of users and permissions brought together by a role is for a short period of time. Roles are more stable because activities or functions of an organization usually change less frequently.

You can create a role for several reasons, for example:

- To represent competency in specific tasks.
- To embody authority and responsibility, for example: supervisor or administrator.

Roles can reflect specific duty assignments that are rotated through multiple users, for example, an administrator or shift supervisor. Role Editor can conveniently accommodate all of these combinations of the role concept.

Using roles and associated permissions, you can perform certain operations on certain managed resources:

- You can assign users to roles.
- You can assign permissions to the users according to their role assignment.
- You can assign many roles to one user, and at the same time, a single role.
- You can assign a single permission to many roles, and a single role can have many permissions.
- You can have a role without any permission.

A role is a named set of permissions, which are for the operations and access. A user must have a role to perform any function. The following are the requisites of a role:

- The name of the role is any valid string.
- The role names are case sensitive.
- The maximum length of a role name is 256 characters.
- The role names are internationalized.

The following functions are possible with the Role Editor application:

- Create tenants.
- Delete tenants.
- Modify tenants.
• Create roles.
• Delete roles.
• Rename roles, for example: fix spelling mistakes in the role name.
• View which roles exist.
• View all user-to-role assignments.
• View tenants that do not have assigned administrators.
• View the permissions that exist.
• View the operations and access permissions that are assigned to roles.
• Assign permissions to roles.
• Remove permissions assignments from a role.
• Assign users to a role.
• Remove users from a role.

Predefined roles

The default roles in Proactive Contact are:

• Lead Administrator
• Administrator
• Supervisor
• Role administrator
• Tenant Administrator

The system has two default users, roleadm and leadadm, in Proactive Contact. These users have the Role Administrator and Lead Administrator roles respectively. You must change the password of these users. You must create two users, assign the Role Administrator and Lead Administrator permissions respectively to the users, and then delete the roleadm and leadadm users.

Mapping of roles

The following table provides information on different roles in Proactive Contact and their respective actions in both default and multitenancy environments:

<table>
<thead>
<tr>
<th>Role</th>
<th>Actions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Role administrator</td>
<td>Manages Role Editor application.</td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>Role</th>
<th>Actions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Administrator</td>
<td>Manages Jobs, Selection, Strategies, Agent job list, Calling list, Messages, Scripts, Completion codes, Schedule, Agent keys, Monitor application, and Analyst application.</td>
</tr>
<tr>
<td>Supervisor</td>
<td>Manages Jobs, Selection, Strategies, Agent job list, Monitor application, and Analyst application.</td>
</tr>
<tr>
<td>Tenant Administrator</td>
<td>Acts as Role administrator and Administrator for the tenant.</td>
</tr>
<tr>
<td>Lead Administrator</td>
<td>Acts as Tenant administrator for the default tenant along with the permissions for user management and tenant management.</td>
</tr>
</tbody>
</table>

### Role of Lead Administrator

Only the Lead Administrator can create, modify, and delete users and tenants. Lead Administrator can also assign an administrator to a tenant.

Lead Administrator can create tenants using two options:

- Creating a new tenant.
- Creating another tenant similar to an existing tenant using the **Save As** option. The **Save As** option carries forward all the assignments and settings of an existing tenant to the newly created tenant.

Lead Administrator can create and modify tenants in only two stages:

- Pending
- In Progress

When you modify an existing tenant by changing the status of the tenant to In Progress, the system considers it as a new tenant. Hence the system calculates the available values of each tenant attribute as the total value available on the dialer minus the value already allocated to the tenant.

For example, the Max Jobs attribute has a total value of 200. You allocated 190 jobs to tenant1. Modify tenant1, by using the **Save as** option, and change the tenant status to In Progress. If you try to allocate 198 jobs to tenant1, the system displays the following error message: **Maximum jobs for the tenant cannot be greater than available limit**

Proactive Contact calculates the available jobs as the total jobs minus the allocated jobs, that is, 200-190=10. Because 10 is smaller than 198, the system displays the error message.

**Note:**

When modifying an existing tenant, ensure that you change the status of the tenant to Pending state. While the tenant state is Pending, the system calculates the attribute value as the allocated value plus the remaining value, that is, 190+10=200. Because 200 is greater than 198, you can successfully modify the tenant.
However, a Lead Administrator can assign users to tenants in three stages:

- Active
- Pending
- In Progress

**Note:**
You cannot assign users to a tenant that is in the 'Deleted' stage.

Lead Administrator role cannot assign to self an administrator or other user role in a tenancy. A Lead Administrator can add users to a tenancy including the self, but a Lead Administrator cannot grant any privileges to the self. However, a Tenant administrator can assign the administrative or other user role privileges to the Lead Administrator user. Also, only Lead Administrator can delete users from the Proactive Contact system.

Lead Administrator can schedule activities on dialer which are global in nature or which affect more than one tenant, such as backup, custom script, MTS maintenance, Proactive Contact maintenance, and restart Proactive Contact.

### Role of Tenant administrator

Tenant administrators can log in to the Role Editor application to administer the roles and other functionalities within their own tenant spaces. Tenant administrator of each tenant can perform all that is currently possible in the Administrator role. However, the changes affect only that particular tenant space, not the whole dialer.

The Tenant administrator of a particular tenant can assign a role to a user to use the Editor application. However, when a user logs into the Editor application, the user can view only the configurations that are defined for the particular tenant to which the user belongs. A user can view and edit data depending on the role and permissions that the Tenant administrator assigned to the user.

### Types of permissions

#### Operations permissions

By default, the system provides a fixed set of Operations permissions. These permissions define the supervisor applications that can be run. For example, permission to run Editor, Monitor, or Health Manager.
Access permissions

Access permissions define the degree of control that an allowed operation has over its managed resources. By default, the system provides a fixed set of Access permissions.

The following table lists and describes various types of Access permissions.

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read</td>
<td>For read-only access to a feature.</td>
</tr>
<tr>
<td>Job Control</td>
<td>For use of job control functions, wherever applicable.</td>
</tr>
<tr>
<td></td>
<td>You can add Job Control to R access. Job Control is implicit in W access.</td>
</tr>
<tr>
<td></td>
<td>R indicates Read permissions and W indicates Write permissions.</td>
</tr>
<tr>
<td>Write</td>
<td>For read, write, and job control access to a feature.</td>
</tr>
<tr>
<td></td>
<td>The Write permission includes the ability to create, update, and delete data or information.</td>
</tr>
</tbody>
</table>

Read and Write permissions are hierarchical. The Read permission is basic and the Write permission includes the read permission. In some cases, you can add a Job Control permission to the Read permission.

Permissions in Role Editor

The following table lists the permissions available for various applications.

<table>
<thead>
<tr>
<th>Application</th>
<th>Sub-Application</th>
<th>Permission Type</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>R (Read)</td>
</tr>
<tr>
<td>Agent Blending</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Analyst</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Dialer Server CUI</td>
<td>Menu</td>
<td></td>
</tr>
<tr>
<td>Editor</td>
<td>Agent Keys</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Call List including Campaign Template</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Completion Codes</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Job</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Job Template</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Messages And Scripts</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Schedules</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Selection</td>
<td>X</td>
</tr>
</tbody>
</table>

Table continues…
## Application Permissions

<table>
<thead>
<tr>
<th>Application</th>
<th>Sub-Application</th>
<th>Permission Type</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>R (Read)</td>
</tr>
<tr>
<td>Strategy</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Get Files</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Health Manager</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Hierarchy Manager</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Monitor</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Monitor Agent</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Role Editor</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Tenant Management</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>User Management</td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>

In this table, X represents the permission that can be provided. You must have minimum Operation permissions of the various supervisor applications to gain access to features such as Dialer apps, Agent Blend, Hierarchy Manager, and Get Files. These Operation permissions cannot be used individually. For example, to use Dialer apps Operation permission, you must have minimum editor permission such as Editor Job or Editor Strategy.

### Monitor Agent permission

In this release, you can assign a new permission to monitor agents using the Monitor application. Prior to this release, any user with Access permissions to the Monitor application could listen to agent calls, as monitoring functions at the permission level were not segregated. In this release, the Tenant Administrator can control the access to the Monitor application and can allow or restrict a user to listen to the agent calls.

Monitor Agent permission has the following two options:

- Job Control
- Blank value

A blank value signifies no access to the agent monitoring functionality.

By default, the Lead Administrator, Supervisor, and Administrator roles have the Job Control permission for the Monitor Agent operation. Similarly, the Tenant Administrator role has the Job Control permission for this operation.

The permission for the Monitor Agent operation is independent of the Monitor operation. For example, if you have only Read permissions for the Monitor application and the Job Control permission for Monitor Agent, you can still monitor an agent.
Toolbar buttons

The following table lists and describes the buttons on the toolbar.

<table>
<thead>
<tr>
<th>Name</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>![image]</td>
<td>Creates a new role, tenant, or user.</td>
</tr>
<tr>
<td>Save</td>
<td>![image]</td>
<td>Saves the changes:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• After creating a role, tenant, or user.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• After using the rename option.</td>
</tr>
<tr>
<td>Delete</td>
<td>![image]</td>
<td>Deletes the selected role, tenant, or user.</td>
</tr>
<tr>
<td>Merge</td>
<td>![image]</td>
<td>Opens the Merge Roles window.</td>
</tr>
<tr>
<td>Report Preview</td>
<td>![image]</td>
<td>Previews the selected report in a browser.</td>
</tr>
<tr>
<td>Help</td>
<td>![image]</td>
<td>Displays the online help.</td>
</tr>
</tbody>
</table>

Logging in to Role Editor application

Procedure

1. Click Start > All Programs > Avaya > Proactive Contact > Role Editor.
   Or click the Role Editor icon on the Windows desktop.
2. Type your Role Administrator user name and password.
   
   ![image] Note:
   The default user name and password is roleadm. The default user name and password
   for Lead Administrator login is leadadm. You must change the password of the default
   user.
3. Click OK.

Creating a new role

About this task

In Proactive Contact, a permanent account is created for the Role Administrator role. The Role Administrator role is the default role with permissions to define roles and to assign users to roles.
Roles are used only to gain access to the supervisor applications. Agents are not included in the roles.

You can define new roles to meet your business roles and procedures. On the supervisor GUI, a role is defined by naming it and assigning to it the operations permissions and access permissions appropriate for the role.

**Procedure**

1. Log in to Role Editor using roleadm or as a user with role administration permission.
2. Click **File > New**.
3. In the Welcome to Create new role wizard, click **Next**.
4. In the Name the role window, provide a name and brief description for the new role.
5. Click **Next**.
6. In the Allow application access window, select the application to which the new role can gain access.
7. Click **Next**.
8. In the Define the type of access window, specify the permission for the various applications that you had selected in the previous step.
9. Click **Next**.
   In the Finishing your role definition window, you can see the summary of the role that you created, the applications that you had selected, and their permissions.
10. Click **Finish**.
    The new role will appear in the center panel under Role Name in the Role Editor window. You must save the new role.
11. Click **File > Save**.
    Editor opens the Message Script Wizard window.

---

**Renaming a role**

**Procedure**

1. Log in to the Role Editor application.
2. In the left pane, under **Role**, click **Administration**.
3. In the center pane, in the Role Name column, select a role to be renamed.
4. Perform any of the following steps and rename the role:
   • Right-click the selected role and click **Rename**.
Managing roles

• Press F2.
• Click Edit > Rename.

5. Click File > Save.

Editor opens the Message Script Wizard window.

---

**Merging roles**

**About this task**

You can merge two or more roles together. The final permissions of the new role are the highest permissions of the individual roles upon which the new role is based.

**Procedure**

1. Log in to the Role Editor application.
2. In the left pane, under Role, click Administration.
3. In the center pane, in the Role Name column, select a role, right-click on a role and select Merge...

   The system displays merger roles window.
4. In the New role name field provide a name for the new merged role.
5. In the Description field provide a brief description about the new merged role.
6. In the Available roles box, select the roles that you want to merge.

   You will see the permissions that the role has in the Effective permissions box on the left, under the Available roles box.
7. Perform one or more of the following steps based on your requirement:
   • Click the right arrow button (> ) to move the selected roles from Available to Assigned roles.
   • Click double right arrow button (>> ) to assign all the Available roles to the user.
   • Click the left arrow button (< ) to move the selected roles from Assigned roles box to Available roles box.
   • Click double left arrow button (<< ) to move all the roles from the Assigned roles box to the Available roles box.

   In the Assigned roles box, you can view Effective permissions of the Assigned roles in the Effective permissions section.
8. Click OK.

   You can see the new merged role in the center pane. When you select the merged role, you can see the users that are assigned to the merged role in the Users pane located...
inside the right pane. You can also see the roles that were merged in the Assigned roles pane located at the bottom right corner.

---

**Editing a merged role**

**About this task**

For editing a merged role you have the following options:

- Merge additional roles to the merged role.
- Remove a role that was previously merged.

**Procedure**

1. Log in to the Role Editor application.
2. In the left pane, under **Role**, click **Administration**.
3. In the center pane, in the Role Name column, select a merged role, right-click on a merged role and select **Demerge...**
   The system displays merger roles window.
4. Select the roles that you want to merge in the Available roles box or select the roles that you want to remove from the merge from the Assigned Roles box.
5. Perform one or more of the following steps based on your requirement:
   - Click the right arrow button (>) to move the selected roles from Available to Assigned roles.
   - Click double right arrow button (>>) to assign all the Available roles to the user.
   - Click the left arrow button (<) to move the selected roles from Assigned roles box to Available roles box.
   - Click double left arrow button (<<) to move all the roles from the Assigned roles box to the Available roles box.
   In the Assigned roles box, you can view Effective permissions of the Assigned roles in the Effective permissions section.
6. Click **OK**.
   You have successfully edited a merged role.

---

**Assigning roles to a user**

**About this task**

After creating a role, you can assign users to that role.
Procedure

1. Log in to the Role Editor application.
2. In the left pane, under Role, click Users.
3. In the center pane, all the available users lists are populated.
4. Click to select the user.
   ✴ Note:
   When you click on the user, you will see the roles that are currently assigned to the user on the upper right hand box under Role Name and the permission that the role has in the lower right hand box.
5. Right-click on the user and click Role Assignment...
6. In the Role Assignment window, under Available roles, select the role you want to assign to the user.
   You will see the permissions that the role has in the Effective permissions box on the left, under the Available roles box.
   ✴ Note:
   You can assign multiple roles to a user.
7. Perform one or more of the following steps based on your requirement:
   • Click the right arrow button (>) to move the selected roles from Available to Assigned roles.
   • Click double right arrow button (>>) to assign all the Available roles to the user.
   • Click the left arrow button (<) to move the selected roles from Assigned roles box to Available roles box.
   • Click double left arrow button (<<) to move all the roles from the Assigned roles box to the Available roles box.
   In the Assigned roles box, you can view Effective permissions of the Assigned roles in the Effective permissions section.
8. Click OK.

Assigning users to a role

About this task
After creating a role, you can assign roles to the user.

Procedure

1. Log in to the Role Editor application.
2. In the left pane, under **Role**, click **Administration**.
3. Select a role.
   
   ✤ **Note:**
   When you select a role, you will see the application permissions that the role has in the upper right hand box and users that are assigned to that role in lower right hand box.

4. Right-click on the role and select **User Assignment**...

5. In the User Assignment window, under Available Users, select a user you would like to assign to the role.
   
   You see the effective permissions of the selected user in the Effective permissions box on the left, under the Available Users box.
   
   ✤ **Note:**
   You can assign multiple users to a role. Multiple selections of user will not calculate the effective permission. It will show the permission as Not Applicable in the lower left hand box.

6. Perform one or more of the following steps based on your requirement:
   
   • Click the right arrow button (>) to move the selected roles from Available to Assigned roles.
   
   • Click double right arrow button (>>>) to assign all the Available roles to the user.
   
   • Click the left arrow button (<) to move the selected roles from Assigned roles box to Available roles box.
   
   • Click double left arrow button (<<) to move all the roles from the Assigned roles box to the Available roles box.
   
   In the Assigned roles box, you can view Effective permissions of the Assigned roles in the Effective permissions section.

7. Click **OK**.
   
   You have successfully assigned a role to a user.

---

**Deleting a role**

**About this task**

Ensure that no user is associated with the role. Also, ensure that any users of the role are deleted, assigned to another role, or moved to another role.

**Procedure**

1. Log in to the Role Editor application.
2. In the left pane, under **Role**, click **Administration**.
3. In the center pane, in the Role Name column, select a role to be deleted.
4. Right-click on selected role and select **Delete**.
5. In the Role Editor dialog box, click **Yes**.
   
   Additionally, you can delete the role by selecting the role and clicking the **Delete** icon in the toolbar.

   You can also delete the role using the menu bar. Select the role and click **File > Delete** or use the Ctrl and D key.

---

**Refreshing the Role Editor data**

**Procedure**

1. On the menu bar, click **Settings**.
2. In the Settings menu, click **Options**.
3. On the Refresh tab, you can set how often you want the data to be refreshed on the screen.
   
   The available options are:
   - 15 Seconds
   - 30 Seconds
   - 60 Seconds
   - Manual (refresh with F5 key)

**Result**

You can also refresh the Role Editor data by clicking on **View** menu and then clicking **Refresh**.

---

**Displaying warning message for tenants without administrators**

**Procedure**

1. On the menu bar, click **Settings**.
2. In the Settings menu, click **Options**.
3. Click the **Preferences** tab.
4. Select the **Show warning if there are tenants without an administrator** check box.
When you close the Role Editor application, the system shows a warning message if there are any tenants for which you have not assigned an administrator.

**Note:**

If you clear the **Show warning if there are tenants without an administrator** check box, then the system does not show the warning message.

---

### Reports

You can view the following types of reports in the Role Editor application:

- **Role Summary:** This report provides a list of roles and their descriptions.
- **Roles assigned to users:** This report provides a list of all users and roles assigned to users.
- **Operations and Access Permissions assigned to Roles:** This report provides a list of all roles, their operations and permissions.

---

### Viewing reports

**Procedure**

1. In the Role Editor window, in the left pane, under Role, click **Reports**.
2. In the center pane, under Names column, select the required report type.
   
   The system displays the details of the selected report in the right pane.

---

### Saving Reports Data as HTML

**About this task**

Save Role Editor Reports data to an HTML file for viewing in a browser.

**Procedure**

1. From the File menu, click **Save as HTML**.
2. In the Save As dialog box, type a file name.
3. Click **Save**.
4. On the Role Editor dialog box, perform one of the following steps:
   
   - If you want to view the saved report, click **Yes**.
   - If you do not want to view the saved report, click **No**.
Chapter 5: Managing users

In Proactive Contact, a default account for Lead Administrator is created. The default role is the Lead Administrator role. This role has permissions to create new users, assign users to roles, and assign users to a tenant.

User Management allows you to:

- Create new users and assign a tenant to a new user.
- Modify an existing user account and reassign the user to a new tenant.
- Modify the password of the existing user.
- Delete a user.
- Perform batch user creation and modification.

Default users in Proactive Contact

Proactive Contact contains various default users on the dialer. The default users in the system are:

<table>
<thead>
<tr>
<th>User Name</th>
<th>User Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>auditor</td>
<td>auditor</td>
<td>The auditor user type can gain access to the auditor menu on the CUI, and perform various functions such as viewing logs.</td>
</tr>
<tr>
<td>admin</td>
<td>system</td>
<td>The admin user can gain access to the dialer and can perform administrative functions on the dialer.</td>
</tr>
<tr>
<td>system</td>
<td>system</td>
<td>The system user is a supervisor user type. This user type can perform Supervisor role on the GUI and can also perform related tasks back-end on the CUI.</td>
</tr>
<tr>
<td>sysadm</td>
<td>sysadm</td>
<td>The sysadm user is an administrative user. This user can perform administrative role on the GUI and also perform back-end administrative functions on the CUI.</td>
</tr>
<tr>
<td>analysis</td>
<td>pcanal</td>
<td>The analysis user type can perform functions at the CUI level. This user type can gain access to a separate analysis menu and reporting menu on the CUI.</td>
</tr>
<tr>
<td>agent1</td>
<td>agent</td>
<td>The agent1 user is the agent operative only for the Agent application.</td>
</tr>
</tbody>
</table>

Table continues…
### Logging in to Role Editor as a Lead Administrator

**Procedure**

1. Click **Start > All Programs > Avaya > Proactive Contact > Role Editor**.
   Or click the Role Editor icon on the Windows desktop.
2. Type your user name and password, belonging to the Lead Administrator user type.
3. Click **OK**.

**Note:**

The default user name and password is **leadadm**. You must change the password of the default user.

### Creating a new user

**About this task**

You can create new users to meet your business requirements and procedures.
Managing users

**Procedure**

1. Log in to the Role Editor application as a Lead Administrator user.
2. In the left pane, click **User Management**.
3. Under User Management, click **Administration**.
4. Perform one of the following steps to create a new user:
   - Click **File > New**.
   - Press **Ctrl** and **N** key.
   - In the User Administration pane, right-click and select **New**.
5. In the Add New User window, enter appropriate values in the fields.
6. Click **Add**.

   The new user will appear in the center panel under User Management in the Role Editor window.

**Important:**

Users belonging to system and sysadm group get additional privileges on the dialer when they log in using the SFTP application. You should assign only trusted users to the system and sysadm user groups.

---

**Add New User field descriptions**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Name</td>
<td>Type a unique name upto 8 characters</td>
</tr>
<tr>
<td>Password</td>
<td>Type a password. For information on password criteria, see About Passwords in the Using Proactive Contact Supervisor guide.</td>
</tr>
<tr>
<td>Confirm Password</td>
<td>Re-type the password.</td>
</tr>
<tr>
<td>Group</td>
<td>Specify the group for the user.</td>
</tr>
<tr>
<td>Description</td>
<td>Provide a brief description for the new user.</td>
</tr>
</tbody>
</table>

---

**Modifying a user**

**Procedure**

1. Log in to the Role Editor application as a Lead Administrator user.
2. In the left pane, under User Management, click **Administration**.
3. In the center pane, under the User Name column, select the user to be modified.
4. Right-click on selected user name and select **Edit**.

5. In the Modify User window, you can modify the following:
   - Password for the user. For information on password criteria, see About Passwords in the Using Proactive Contact Supervisor guide.
   - Group to which the user is assigned.
   - Description for the user.

6. Click **Modify**.

---

**Deleting a user**

**Procedure**

1. Log in to the Role Editor application as a Lead Administrator user.
2. In the left pane, under User Management, click **Administration**.
3. In the center pane, under the User Name column, select a user name to be deleted.
4. Right-click on selected user name and select **Delete**.
5. In the Delete User window, verify the user name that you want to delete.
6. Click **Delete**.

**Result**

You cannot delete a user if the user is assigned to a tenant. In such case, you must first unassign the user from the tenant space.

---

**Assigning and unassigning a user to and from a tenant**

**About this task**

You can assign a user to a maximum of 20 tenants including the default tenant.

**Procedure**

1. Log in to the Role Editor application as a Lead Administrator user.
2. In the left pane, under User Management, click **Administration**.
3. In the center pane, under the User Name column, select a user to be assigned to a tenant.
   - The conditions for assigning a user to a tenant are as follows:
     - You cannot assign auditor group of users to a tenant.
     - You cannot assign admin, dadmin, cust1, and rsync users to a tenant.
• You cannot unassign any user of leadadm group from the default tenant. However, you can assign a user of leadadm group to a tenant.

• You cannot unassign the roleadm user from the default tenant. However, you can assign the roleadm user to a tenant.

4. Right-click on the selected user name and select **Tenant Assignment...**

The Tenant Assignment window is divided into two panes. In the left pane, you can view a list of available tenants. In the right pane, you can view a list of tenants that are assigned to the user.

5. In the Tenant Assignment window, perform one or more of the following steps:

   • Select one or more tenant from the left pane and click > to assign the selected tenant to the user.
   
   • Assign all the available tenants to the user by clicking >>.
   
   • Select a tenant from the right pane and click < to unassign a tenant from the user.
   
   • Unassign all the available tenants from the user by clicking <<. Do not unassign any tenant while the agent is logged in to the system.

   ✴ **Note:**
   
   Ensure that you do not unassign a tenant from a user while the user is logged into the system.

6. Click **OK**.

---

**Batch user creation or modification**

You can create or modify multiple users using the Batch User Creation and Modification wizard. You must identify/create a user data file (text based file). User data file should contain colon data in the following format:

```
<Username>:<Group name>:<Password>:<Description>
```

The details of the format are provided in the following table:

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Field Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>Mandatory</td>
<td>Unique name. Minimum length for user name is 4 characters. Maximum length for the user name is 8 characters.</td>
</tr>
<tr>
<td>Group Name</td>
<td>Mandatory</td>
<td>Group name should be one of the predefined roles/groups such as system, sysadm, and roleadm.</td>
</tr>
</tbody>
</table>

*Table continues...*
<table>
<thead>
<tr>
<th>Field Name</th>
<th>Field Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Password</td>
<td>Optional</td>
<td>The default value is the user name in case user creation. If you are modifying a user, then by default, the password remains the same as earlier.</td>
</tr>
<tr>
<td>Description</td>
<td>Optional</td>
<td>Maximum description length is 30 characters.</td>
</tr>
</tbody>
</table>

For example:

```
john:agent:password:agent John Doe
Ron:sysadm:password:system Admin Ron
```

Creating multiple users using Batch User Creation wizard

Procedure

1. Log in to the Role Editor application as a Lead Administrator user.
2. Click User Management tab.
3. Click File > Import User Data...
4. In the Batch User Creation wizard, click Next.
5. In the Getting started with importing user creation data screen, click Next.
6. In the User input data screen, select one of the following options:
   • Create new users: To create new user accounts based on the user data file.
   • Modify existing users: To modify password, Group Name, and description for the existing users using the user data file.
   
   **Note:**
   The batch file that is used for the batch user creation or modification must have the UTF-8 encoding.
7. Click Next.
8. In the User data screen, verify the user data.
9. Click Add.
   
   Click Update if you are modifying the user information.
10. In the Result Summary screen, the list of users added is displayed.

   **Note:**
   If the system fails to add the user for any reason, such as a user with the same name already present in the system, then the summary page displays the Failed to add user message for that user in the Results column.
11. Click Finish.
**Viewing Dialers and Administered Tenants for a user**

**Procedure**

1. Log in to the Role Editor application as a Lead Administrator user.
2. In the left pane, under User Management, click *Administration*.
3. In the center pane, under the User Name column, select a user.
4. The information is displayed in the right pane. The right pane is divided into two parts.
   - The top right pane displays the Dialer, Tenant Name, and Version (Active/Pending).
   - The bottom right pane displays the Administered Tenants details.

**Types of reports**

The following table lists and describes the types of reports that you can view in User Management in Role Editor.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All Users Summary</td>
<td>This report provides a list of all user details in the system.</td>
</tr>
<tr>
<td>Agents Summary</td>
<td>This report provides a list of all the Agents and their Tenant Assignments.</td>
</tr>
<tr>
<td>Lead Administrators Summary</td>
<td>This report provides a list of all the Lead Administrators and their assigned Tenants.</td>
</tr>
<tr>
<td>Tenant Administrators Summary</td>
<td>This report provides a list of all the Tenant Administrators of various Tenants.</td>
</tr>
<tr>
<td>Supervisors Summary</td>
<td>This report provides a list of all the Supervisors and their assigned Tenants.</td>
</tr>
</tbody>
</table>

**Viewing reports**

**Procedure**

1. In the Role Editor window, in the left pane, click *User Management*.
2. Under User Management, click *Reports*.
3. In the center pane, under Name column, select the required report type.
   - The selected report details are displayed in the right pane.
4. To save a report in the HTML format, select *File > Save as HTML*. 
Chapter 6: Managing tenants

In Proactive Contact, a default account for Lead Administrator is created. Default role is Lead Administrator role. This role has permissions to create new tenants, assign users to roles, and assign users to a tenant.

Using Tenant Management, you can:

- Create new tenants and allocate various dialer resources.
- Modify a tenant account and reassign resources to a new tenant.

Logging in to Role Editor as a Lead Administrator

Procedure

1. Click **Start > All Programs > Avaya > Proactive Contact > Role Editor**.
   
   Or click the Role Editor icon on the Windows desktop.

2. Type your Lead Administrator user name and password, and then click **OK**.

   Note:
   
   The default user name/password is leadadm. You must change the password of the default user.

Default tenant

By default, the default resource pool includes all the users, calling lists, jobs, schedules, and other components of Proactive Contact. If you want to work with Proactive Contact without multitenancy, you can perform all the tasks, as in the earlier releases, in this default tenant. This feature provides backward compatibility with previous releases of Proactive Contact without the multitenancy feature. However, if you choose to work with multitenancy and create tenants in your Proactive Contact environment, you can assign resources such as, lines, users, and calling lists from the default tenant.

The default tenant reflects the available capacities of the dialer. For example, in the default tenant, if you do not use multitenancy, you can create up to 998 calling lists or use 999 completion codes. However, if you create tenants and assign resources to the tenants, these resources get deducted...
from the default tenant. For example, if you assign 20 calling lists to tenant A, then the available calling lists in the default pool are 978. Similarly, you can create up to 20 tenants and assign resources to the tenants from the default tenant.

In the default tenant:

- All the roles and their default permissions remain the same as in the previous releases of Proactive Contact.
- An administrator can perform dialer maintenance. However, in a tenant, the tenant administrator cannot perform dialer maintenance for the tenant.

### Default tenant field descriptions

By default, Proactive Contact creates a default tenant on the dialer. The values allocated to the default tenant are:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Default</td>
<td>Name of the tenant. Tenant name can be alphanumeric.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>✳ <strong>Note:</strong> Role Editor does not allow the user to create a tenant name containing only numeric values.</td>
</tr>
<tr>
<td>Description</td>
<td>Default Tenant</td>
<td>A brief description for the tenant.</td>
</tr>
<tr>
<td>Blend Domain Group</td>
<td></td>
<td>The name of the blend group.</td>
</tr>
<tr>
<td>Line Assign</td>
<td>REG, INB, IVR</td>
<td>The line pools assigned to the default tenant. When you create new tenant, you can allocate the free lines from the default tenant to the new tenant.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The data in the default tenant is derived from the LINEASSIGN parameter in master.cfg.</td>
</tr>
<tr>
<td>Max Agent</td>
<td>432</td>
<td>The number of agents available on the dialer. By default, the full resources of dialer are assigned to the default tenant.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The data in the default tenant is derived from the MAXAGENTS parameter in master.cfg.</td>
</tr>
<tr>
<td>Max Jobs</td>
<td>200</td>
<td>The number of jobs available on the dialer. By default, the full resources of dialer are assigned to the default tenant.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The data in the default tenant is derived from the MAXRUNNINGJOBS parameter in master.cfg.</td>
</tr>
<tr>
<td>Calling Lists</td>
<td>999</td>
<td>The number of calling lists available on the dialer. By default, the full resources of dialer are assigned to the default tenant.</td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>The data in the default tenant is derived from the MAXCALLINGLIST parameter in master.cfg.</td>
</tr>
<tr>
<td>Max Supervisors</td>
<td>100</td>
<td>The number of supervisors available on the dialer. By default, the full resources of dialer are assigned to the default tenant.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The data in the default tenant is derived from the MAXSUPERVISORS parameter in master.cfg.</td>
</tr>
<tr>
<td>Max message size</td>
<td>16777216</td>
<td>The size of messages that can be created on the dialer. By default, the full resources of dialer are assigned to the default tenant.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The data in the default tenant is derived from the AUDIOMSG_P230MAXBYTES parameter in master.cfg.</td>
</tr>
<tr>
<td>Message Slots</td>
<td>1-247, 255-2048</td>
<td>The messages slots that are available on the dialer. By default, the full resources of dialer are assigned to the default tenant.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The data in the default tenant is derived from the AUDIOMSG_P230MAXMSGCOUNT parameter in master.cfg.</td>
</tr>
<tr>
<td>Max Telephony Scripts</td>
<td>200</td>
<td>The number of telephony scripts available on the dialer. By default, the full resources of dialer are assigned to the default tenant.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The data in the default tenant is derived from the MAXTELEPHNYSCRIPTS parameter in master.cfg.</td>
</tr>
<tr>
<td>Completion Codes</td>
<td>20-34, 51-88, 100-999</td>
<td>The completion codes available on the dialer. By default, all the completion codes except for the system codes are assigned to the default tenant.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The data in the default tenant is derived from the QUOTA parameter in master.cfg. If you want to change quota code for the default tenant, make the required changes in master.cfg.</td>
</tr>
<tr>
<td>Quota Codes</td>
<td>20-34, 51-88, 100-999</td>
<td>The quota codes available on the dialer. By default, the full resources of dialer are assigned to the default tenant.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The data in the default tenant is derived from the QUOTA parameter in master.cfg. If you want to change quota code for the default tenant, make the required changes in master.cfg.</td>
</tr>
<tr>
<td>Max Event Clients</td>
<td>20</td>
<td>The number of event clients that can be created on the dialer. By default, the full resources of dialer are assigned to the default tenant.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The data in the default tenant is derived from the MAXESCCLIENT parameter in master.cfg.</td>
</tr>
</tbody>
</table>
## Prerequisites for creating a tenant

Before creating a new tenant, you must have the following information:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Max number agents for this tenant</td>
<td>Maximum number of agents that can log into the tenant.</td>
</tr>
<tr>
<td>Max number of supervisors for this tenant</td>
<td>Maximum number of supervisor that can log into the tenant.</td>
</tr>
<tr>
<td>Max number of jobs that can run on this tenant</td>
<td>Maximum number of concurrent running jobs that can run on the tenant.</td>
</tr>
<tr>
<td>Blend Domain Group for this tenant</td>
<td>Name of the blend domain group if applicable for the tenant.</td>
</tr>
<tr>
<td>Lines to assign to this tenant</td>
<td>Lines that you want to assign to the tenant.</td>
</tr>
<tr>
<td></td>
<td>Note that when you assign a line to a tenant, the other tenants cannot use it.</td>
</tr>
<tr>
<td>Max number of calling lists</td>
<td>Maximum number of calling lists that can be created on the tenant.</td>
</tr>
<tr>
<td></td>
<td>This number includes both inbound and outbound calling lists.</td>
</tr>
<tr>
<td>Max message size</td>
<td>Maximum size of the voice messages that can be assigned to a tenant.</td>
</tr>
<tr>
<td></td>
<td>This is applicable only in case of Proactive Contact with PG230RM.</td>
</tr>
<tr>
<td></td>
<td><strong>Tip:</strong></td>
</tr>
<tr>
<td></td>
<td>To determine the length of a message, divide the byte count of the message by 8000 as each second of message uses 8000 bytes. For example, if a message has 120,000 bytes, the message playing time is 15 seconds.</td>
</tr>
<tr>
<td>Max telephony scripts</td>
<td>Maximum number of the telephony scripts that can be assigned to the tenant.</td>
</tr>
<tr>
<td>Completion codes numbers/range</td>
<td>The completion codes separated by comma or the range of completion codes to be assigned to the tenant. For example: 1,3, 5-12</td>
</tr>
<tr>
<td>Message slots/range</td>
<td>Number of message slots to be assigned to the tenant.</td>
</tr>
<tr>
<td></td>
<td>The message slots separated by comma or range of message slots to be assigned to the tenant. For example 255,300-350</td>
</tr>
<tr>
<td>Completion codes for Quota feature</td>
<td>In case of quota to be used in the tenant, the number of completion codes to be assigned for the quota in the tenant.</td>
</tr>
<tr>
<td>Max number of event clients that can run</td>
<td>Maximum number of event clients you want to assign to the tenant.</td>
</tr>
</tbody>
</table>
Creating a tenant

About this task

You can create tenants on Proactive Contact system to meet your business requirements. You can create a maximum of 20 tenants on a dialer. In a pod, the number of tenants will increase according to the number of dialers in the pod with 20 tenants per dialer.

Procedure

1. Log in to the Role Editor application as a Lead Administrator user.
2. In the left pane, under Tenant Management, click **Administration**.
3. Perform one of the following steps:
   - Click **File > New Tenant**.
   - Press **Ctrl + N** key.
   - In the Tenant Management pane, right-click and select **New...**
4. In the Welcome to the tenant creation and modification wizard screen, click **Next**.
5. In the Name the tenant screen, provide the following information:
   a. Select the dialer from the list on which you want to create a new Tenant.
   b. Provide a unique name for the Tenant. Tenant name can be alphanumeric. The name of the tenant is case-insensitive. For example, the system does not allow you to create two tenants by the names, Tenant1 and tenant1.
   c. Select the version in which you would like to create the tenant. There are two versions:
      - In Progress: Tenant in this stage does not have any effect of dialer restart. Modification of tenant in In Progress stage is allowed.
      - Pending: Tenant in this stage becomes active on next dialer restart. Modification of tenant in Pending stage is allowed.
   d. Provide a brief description for the Tenant.
6. Click **Next**.
7. In the Set Tenant Capacity screen, provide the required information and click **Next**.
8. In the Set Tenant Capacity contd... screen, provide the required information and click **Next**.
9. On the Tenant creation summary screen, review the tenant resource information.
10. Click **Finish**.
    
    The newly created tenant is displayed in the center pane.
Modifying a tenant

About this task
You cannot modify a tenant if the tenant is in the Active or Deleted stage. To modify a tenant in this stage, you must first save the tenant in the Pending or In Progress stage and then make the required modifications.

Procedure
1. Log in to the Role Editor application as a Lead Administrator user.
2. In the left pane, under Tenant Management, click Administration.
3. In the center pane, under the Tenant Name column, select the Tenant to be modified.
4. Right-click on selected Tenant Name and select Edit...
5. In the Welcome to the tenant creation and modification wizard screen, click Next.
6. In the Name the tenant screen, you can modify only the description.
7. Click Next.
8. In the Set Tenant Capacity screen, modify the required values and click Next.
9. In the Set Tenant Capacity contd... screen, modify the required information and click Next.
10. In the Tenant creation summary screen, review the modified tenant resource information.
11. Click Finish.

Tenant staging
The system processes the tenants in the following stages:

• **Active**: A tenant can use dialer resources only in this stage. You cannot modify the tenant in the Active stage.

• **Pending**: In this stage, the tenant becomes Active upon the next dialer restart. You can modify a tenant in the Pending stage.

• **In Progress**: Tenant in this stage does not have any effect of dialer restart. You can modify a tenant in the In Progress stage.

• **Deleted**: Active Tenants that are marked for deletion move to the Deleted stage upon the next dialer restart.

You cannot modify a tenant in the Deleted stage. The versioning rules are the same as the versioning rules in the Editor application.
Saving a tenant in different stages

About this task
You cannot modify a tenant if the tenant is in the Active or Deleted stage. To modify a tenant in this stage, you must first save the tenant in the Pending or In Progress stage and then make the required modifications.

Procedure
1. Log in to the Role Editor application.
2. In the left pane, under Tenant Management, click Administration.
3. In the center pane, under the Tenant Name column, select the Tenant to be modified.
4. Click File > Save As.
   The Welcome to the tenant creation and modification wizard is displayed.
5. Follow the on-screen instructions.

  Note:
  You cannot change the name of the tenant.

Deletion of tenants

A Lead Administrator can delete tenants in the Active, Pending, In Progress, and Deleted versions. When a Lead Administrator deletes a tenant in active or pending stage, the allocated resources such as users, line assignment, and completion code become a part of the Default Tenant.

  Note:
  A Lead Administrator can gain access to Database or Historical data of a deleted tenant as such data is not deleted.

A Lead Administrator cannot delete the tenants in the Active stage if the tenants have data in the following modules defined on dialer. To delete the tenants in the Active stage, the Lead Administrator must first delete the following data:

  • Calling Lists
  • DNC Group
  • Agent Keys
  • Messages
  • Telephony scripts
Managing tenants

• Completion Codes
• Schedules
• Job
• Selection
• Strategy
• User Assignment

When you delete an active tenant, the tenant goes into the Deleted stage. To delete the tenant from the Deleted stage, you must wait for the next dialer restart. After the next dialer restart, delete the tenant from the Deleted stage to permanently delete the tenant.

Deleting a tenant

About this task
To delete an active tenant, you must first unassign all the assigned resources from the tenant. When you delete an active tenant, the tenant goes into the Deleted stage. To delete the tenant from the Deleted stage, you must wait for the next dialer restart. After the next dialer restart, delete the tenant from the Deleted stage to permanently delete the tenant from the system.

Procedure
1. Log in to the Role Editor application as a Lead Administrator user.
2. In the left pane, under Tenant Management, click Administration.
3. In the center pane, under the Tenant Name column, select a Tenant to be deleted.
4. You can delete a Tenant using one of the following methods:
   • Click File > Delete Tenant.
   • Press Ctrl and D key.
   • In the Tenant Management pane, right-click and select Delete.
5. In the Tenant Management dialog box, click Yes.

Assigning and unassigning an agent or supervisor to or from a tenant

Procedure
1. Log in to the Role Editor application as a Lead Administrator user.
2. In the left pane, under Tenant Management, click Administration.
3. In the center pane, under the Tenant Name column, select a Tenant to be assigned to an agent or supervisor.
4. Right-click on selected Tenant name and select **User Assignment**...

The User assignment window is divided in four parts.

- In the top left box you have list of available Supervisors and in the top right box you have list of Supervisors that are assigned to the Tenant.
- In the bottom left box you have list of available Agents and in the bottom right box, you have list of Agents that are assigned to the Tenant.

5. Perform one or more of the following steps:

- Select one or more Supervisor/Agent from the left box and click > to assign the selected Agent/Supervisor to the Tenant.
- To assign all the available Agents/Supervisors to the tenant click >>.
- To unassign the Agent/Supervisor from the Tenant, select the Assigned Agent/Supervisor from the right box and click <.
- To unassign all the Agents/Supervisors from the Tenants, click <<.

**Note:**

Ensure that you do not unassign an agent or supervisor from a tenant while the agent or supervisor is logged into the system.

6. Click **OK**.

7. In the Saved user assignment confirmation box, click **OK**.

---

**Assigning and unassigning an administrator to or from a tenant**

**About this task**

You must assign an Administrator to a tenant. If a tenant is without an Administrator, the system displays a warning message when you change your view from Administrator menu to any other menu.

**Procedure**

1. Log in to the Role Editor application as a Lead Administrator user.
2. In the left pane, under Tenant Management, click **Administration**.
3. In the center pane, under the Tenant Name column, select a Tenant to be assigned to an administrator.
4. Right-click on selected Tenant name and select **Assign Administrator**...

You can assign administrator role to a user belonging to the following user groups:

- system
• sysadm
• RBACadmin
• RABC
• Leadadm

5. The Tenant Administrator Assignment window appears. This window is divided in two parts.
   • In the left box you have list of available Tenant Administrators and in the right box you have list of Tenant Administrators that are assigned to the Tenant.

6. You have following options:
   • Select one or more Tenant Administrators from the left box and click > to assign the selected Tenant Administrator to the Tenant.
   • To assign all the available Tenant Administrators to the tenant click >>.
   • To unassign the Tenant Administrator from the Tenant, select the Assigned Tenant Administrators from the right box and click <.
   • To unassign all the Tenant Administrators from the Tenants, click <<.

   **Note:**
   Ensure that you do not unassign an administrator from a tenant while the administrator is logged into the system.

7. Click **OK**.

---

**Viewing assigned Dialer resources and tenant users**

**Procedure**

1. Log in to the Role Editor application as a Lead Administrator user.
2. In the left pane, under Tenant Management, click **Administration**.
3. In the center pane, under the Tenant Name column, select a Tenant.
4. The information is displayed in the right pane. The right pane is divided into two parts.
   • The top right pane displays the Dialer resources allocated to the tenant.
   • The bottom right pane displays the Tenant users.
Viewing tenants without an assigned Administrator

About this task

You must assign an Administrator to a tenant. If a tenant is without an Administrator, the system displays the following warning message when you change your view from Administrator menu to any other menu:

There are Active and/or Pending tenant(s) without any administrator. Would you like to assign them an administrator now?

The system considers only those tenants that are in active and pending stages without an administrator.

Procedure

1. Click Show Tenants to view tenants that are without administrators.
2. Click Yes to go to the Tenant Administrator Assignment window to assign administrators to the listed tenants.
3. Select Do not show this message again check box if you do not want the system to display warning for any unassigned tenant in future.

Related links

Displaying warning message for tenants without administrators on page 56

Tenant reports

You can view seven types of reports under Tenant Management in Role Editor. They are:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All tenant capacity listing</td>
<td>This report provides a list of all tenant details in the system on a per dialer basis.</td>
</tr>
<tr>
<td>Available Capacity</td>
<td>This report provides a list of all the available capacity from the default tenant on a per dialer basis.</td>
</tr>
<tr>
<td>Tenant user assignment</td>
<td>This report provides a list of all the users assigned to tenants.</td>
</tr>
<tr>
<td>All tenant capacity utilization</td>
<td>This report provides a list of all the Tenant allocated capacity utilization.</td>
</tr>
<tr>
<td>System capacity utilization</td>
<td>This report provides a list of system capacity utilization.</td>
</tr>
<tr>
<td>All tenant active agent and supervisor</td>
<td>This report provides a list of all the tenant active agents and supervisors accounts against the allocated capacity.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Active agent and supervisor across the dialer</td>
<td>This report provides a list of all active agent and supervisor accounts against system capacity.</td>
</tr>
</tbody>
</table>

### Viewing tenant reports

**Procedure**

1. In the Role Editor window, in the left pane, click **Tenant Management**.
2. Under Tenant Management, click **Reports**.
3. In the center pane, under Name column, select the required report type.
4. The selected report details are displayed in the right pane.
Chapter 7: Role Editor operations

The operations explained in this section make you familiarize with the user interface of Role Editor and provide a clear understanding of the types of roles that you can create.

**Note:**

The operations in this section are examples. You can create a wide variety of roles depending on the requirements of your organization.

---

Creating a role for Manager to perform a specific task

**About this task**

The organization requires the creation of a role for Managers enabling them to perform the following tasks:

- Run the job through editor.
- Use the CUI menu in the Dialer Applications.
- View the real-time data in monitor.
- Use Health Manager.
- View Analyst Report.
- Use Hierarchy Manager to create different levels of hierarchies such as Job, Agent, and Dialer.
- Monitor Agents.

**Procedure**

1. Log in to the Role Editor using roleadm.
2. Click **File > New**.
   
   You can also press Ctrl and N key to bring the Role Wizard window.
3. In the Welcome to Create new Role wizard, click **Next**.
4. In the Name the role window, provide the name of the role as manager and enter a brief description for the new role.
5. Click **Next**.
6. In the Allow application access window, select the following applications:
   • Analyst
   • Dialer Server CUI Menu
   • Editor Job
   • Health Manager
   • Hierarchy Manager
   • Monitor
   • Monitor Agent

7. Click **Next**.

8. In the Define the type of access window, specify the following permissions next to each application name using the drop-down list:

<table>
<thead>
<tr>
<th>Application</th>
<th>Permission</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analyst</td>
<td>Write</td>
</tr>
<tr>
<td>Dialer Server CUI Menu</td>
<td>Write</td>
</tr>
<tr>
<td>Editor Job</td>
<td>Write</td>
</tr>
<tr>
<td>Health Manager</td>
<td>Write</td>
</tr>
<tr>
<td>Hierarchy Manager</td>
<td>Write</td>
</tr>
<tr>
<td>Monitor</td>
<td>Read</td>
</tr>
<tr>
<td>Monitor Agent</td>
<td>Job Control</td>
</tr>
</tbody>
</table>

9. Click **Next**.

10. In the Finishing your role definition window, you can see the summary of the role that you created, the applications that you had selected, and their permissions.

11. Click **Finish**.
   The new role appears in the center panel under Role Name in the Role Editor window.

12. Click **Finish**.
   You can also press **Ctrl** and **S** key to save the role.

---

**Creating Identical Role as Administrator**

**About this task**
The administrator wants to create identical role as administrator.

**Procedure**
1. Log in to the Role Editor using roleadm.
2. In the center pane, select the role named Administrator.
3. Click **File > Save As**.
4. In the Save dialog box, click **Yes** to save the role.
5. In the Save As window, provide a name and description for the new role.
6. Click **OK**.

**Result**
You have successfully created a role identical to the role of administrator.

---

**Assigning a User to a Role**

**Procedure**

1. Log in to the Role Editor application.
2. In the left pane, under Role, click **Administration**.
3. In the center pane, all the available roles will be populated.

   **Note:**
   For newly created Manager role, there will be no users assigned or listed in the assigned user box.

4. Click to select the Manager role.

   **Note:**
   When you click on the Manager role, you will see the application permissions in upper right hand box and the assigned users in the lower right hand box.

5. Right-click on the Manager role and select **User Assignment...**

6. In the User Assignment - Manager window, under Available Users, select a user you would like to assign the Manager role.
   
   You will see the permissions that the selected user has in the Effective permissions box on the left, under the Available Users box.

   **Note:**
   You can assign multiple users to a role. Multiple selections of user will not calculate the effective permission. It will show as Not Applicable in the lower left box.

7. Perform one or more of the following steps based on your requirement:
   
   • Click the right arrow button (>) to move the selected roles from Available to Assigned roles.
   
   • Click double right arrow button (>>>) to assign all the Available roles to the user.
   
   • Click the left arrow button (<) to move the selected roles from Assigned roles box to Available roles box.
• Click double left arrow button (<<) to move all the roles from the Assigned roles box to the Available roles box.

In the Assigned roles box, you can view Effective permissions of the Assigned roles in the Effective permissions section.

8. Click OK.

Result
You have successfully assigned a user to the Manager role.

Related links
Creating a role for Manager to perform a specific task on page 77

Verifying the permissions and the users assigned to the role

Procedure
Select the Manager role in the left pane.

The available permissions and the users assigned to that role will appear in the right pane.

Testing the Role Permissions

About this task
Test the role permissions on the supervisor application.

Procedure
1. Log in to the Editor application using the user and password that you assigned to the Manager role.
   
   You will see only the Editor Job option. You can perform the following:
   
   • Run a job
   
   • Edit job settings
   
   • Create multiple jobs
2. Click on the system telnet icon on the menu bar. You should now be able to gain access to the dialer using telnet.
3. Start a job.
4. Log in an Agent, and join the job that you started in Step 3.
5. Log in to the Monitor application using the user login that you assigned to the Manager role, and verify that the data is being shown.
   
   You can create different hierarchies using the monitor.
Creating a Role with no Permissions

About this task
The administrator would like to create a role which has no permissions defined.

Procedure
1. Log in to the Role Editor using roleadm.
2. Click File > New.
   You can also press Ctrl and N key to bring the Role Wizard window.
3. In the Welcome to Create new Role wizard, click Next.
4. In the Name the role window, provide a name and brief description for the new role.
5. Click Next.
6. In the Allow application access window, click Next.
7. In the Define the type of access window, click Next.
8. In the Finishing your role definition window, you can see the summary of the role that you created, the applications that you had selected, and their permissions.
9. Click Finish.
   The new role will appear in the center panel under Role Name in the Role Editor window.
10. Click File > Save.
    You can also press Ctrl and S key to save the role.

Creating a Role by Merging two or more Roles

Procedure
1. Log in to the Role Editor application.
2. In the left pane, under Role, click Administration.
3. In the center pane, in the Role Name column, select a role, right-click on a role and select Merge...
   The Merge Roles window will appear.
4. In the New role name field, type mergedrole1 as a name for the new merged role.
5. In the Description field provide a brief description about the new merged role.
6. In the Available roles box, select the roles that you want to merge.
   You will see the permissions that the role has in the Effective permissions box on the left, under the Available roles box.

7. Perform one or more of the following steps based on your requirement:
   • Click the right arrow button (>) to move the selected roles from Available to Assigned roles.
   • Click double right arrow button (>>) to assign all the Available roles to the user.
   • Click the left arrow button (<) to move the selected roles from Assigned roles box to Available roles box.
   • Click double left arrow button (<<) to move all the roles from the Assigned roles box to the Available roles box.

   In the Assigned roles box, you can view Effective permissions of the Assigned roles in the Effective permissions section.

8. Click OK.
   You have successfully merged the selected roles.

   ✶ Note:
   You can select merged role and create new merged role with the merged roles. If you modify the permissions for any of the roles used in the merged role, then the same is reflected in the merged role.

---

**Assigning User to a Merged Role**

**Procedure**

1. Log in to the Role Editor application.
2. In the left pane, under **Role**, click **Administration**.
3. In the center pane, all the available roles will be populated.
4. Click to select **mergedrole1** role.
   
   ✶ Note:
   When you click the **mergedrole1** role, you will see the application permissions in upper right hand box, assigned users in the center right hand box, and the assigned roles in the lower right hand box.
5. Right-click the **mergedrole1** role and select **User Assignment**...
6. In the User Assignment - mergedrole1 window, under Available Users, select a user you would like to assign the role mergedrole1.

   You will see the permissions that the selected user has in the Effective permissions box on the left, under the Available Users box.
Note:
You can assign multiple users to a role. Multiple selection of users will not calculate the effective permission. It will show as Not Applicable in the lower left box.

7. Perform one or more of the following steps based on your requirement:
   • Click the right arrow button (>) to move the selected roles from Available to Assigned roles.
   • Click double right arrow button (>>) to assign all the Available roles to the user.
   • Click the left arrow button (<) to move the selected roles from Assigned roles box to Available roles box.
   • Click double left arrow button (<<) to move all the roles from the Assigned roles box to the Available roles box.
   In the Assigned roles box, you can view Effective permissions of the Assigned roles in the Effective permissions section.

8. Click OK.
   You have successfully assigned a user to the mergedrole1 role.

---

Editing a Merged Role

About this task
The administrator wants to edit a role merged in Assigning User to a Merged Role on page 82. An administrator can edit a merged role using one of the following options:

• Merge additional roles to the merged role
• Remove a role that was previously merged

Procedure
1. Log in to the Role Editor application.
2. In the left pane, under Role, click Administration.
3. In the center pane, in the Role Name column, select mergedrole1, right-click on the merged role and select Demerge...
   The Merge Roles window will appear.
4. Select the roles that you want to merge in the Available roles box or select the roles that you want to remove from the merge from the Assigned Roles box.
5. Perform one or more of the following steps based on your requirement:
   • Click the right arrow button (>) to move the selected roles from Available to Assigned roles.
• Click double right arrow button (>>) to assign all the Available roles to the user.
• Click the left arrow button (<<) to move the selected roles from Assigned roles box to Available roles box.
• Click double left arrow button (<<) to move all the roles from the Assigned roles box to the Available roles box.

In the Assigned roles box, you can view Effective permissions of the Assigned roles in the Effective permissions section.

6. Click **OK**.

   You have successfully edited a merged role.

---

### Renaming a Role

**Procedure**

1. Log in to the Role Editor application.
2. In the left pane, under **Role**, click **Administration**.
3. In the center pane, in the Role Name column, select a role to be renamed.
4. Right-click on selected role and select **Rename**.
   
   You can also rename the role by selecting the role and pressing F2 key on the keyboard.

   You can also rename the role using the menu bar. Select the role and click **Edit > Rename**.

---

### Deleting a Role

**Procedure**

1. Log in to the Role Editor application.
2. In the left pane, under **Role**, click **Administration**.
3. In the center pane, in the Role Name column, select a role to be deleted.
4. Right-click on selected role and select **Delete**
5. In the Role Editor dialog box, click **Yes**.

   You can also delete the role by selecting the role and clicking the delete icon in the tools bar.

   You can also delete the role using the menu bar. Select the role and click **File > Delete** or use the **Ctrl + D** key.
### Editing a Role Permission

**Procedure**

1. Log in to the Role Editor application.
2. In the left pane, under Role, click **Administration**.
3. In the center pane, in the Role Name column, select a role whose permission you want to modify.
4. In the right hand pane, under application select the application whose permission needs to be modified.
5. Click on the permission field and select the required permissions.
6. Click **File > Save**.
   
   Editor opens the Message Script Wizard window.
7. You can also press **Ctrl** and **S** key to save the role.

### Assigning a Role to Users

**Procedure**

1. Log in to the Role Editor application.
2. In the left pane, under Role, click **Users**.
3. Select a user name.

   ✤ **Note:**
   
   When you select a user name, you will see the roles that are assigned to that user in upper right hand box and the application permissions that the user has in the lower right hand box.
4. Right-click on the user name and select **Role Assignment...**
5. In the Role Assignment window, under Available Roles, select the role created in the *Creating a role for Manager to perform a specific task* topic.
   
   You will see the effective permissions of the selected role in the Effective permissions box on the left, under the Available Roles box.

   ✤ **Note:**
   
   You can assign multiple roles to a user. Multiple selections of roles will calculate the highest effective permission. It will show the highest applicable permission in the lower right box.
6. Perform one or more of the following steps based on your requirement:
   • Click the right arrow button (>) to move the selected roles from Available to Assigned roles.
   • Click double right arrow button (>>) to assign all the Available roles to the user.
   • Click the left arrow button (<) to move the selected roles from Assigned roles box to Available roles box.
   • Click double left arrow button (<<) to move all the roles from the Assigned roles box to the Available roles box.

   In the Assigned roles box, you can view Effective permissions of the Assigned roles in the Effective permissions section.

7. Click **OK**.

   You have successfully assigned a role to a user.

**Related links**

- [Creating a role for Manager to perform a specific task](#) on page 77
Chapter 8: Health Manager

The service names listed in the Health Manager vary according to the features configured on your system.

You can start and stop only the Mid-Tier All services using Health Manager. But stopping or starting Mid-Tier All services does not start or stop all the Mid-Tier services, such as serviceMonitor, serviceAct, and NamingService. The starting and stopping of All Dialer processes has been disabled in Health Manager. Also, the starting and stopping of individual processes in Dialer and Mid-Tier has been disabled in Health Manager.

Overall Health Status

The Overall Health Services: Dialer Status view shows the status of all the dialers in the system.

Related links

Viewing overall system health for all dialers on page 91

Dialer Services

The Dialer Services view shows the status of all the services on the selected dialer in the system.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dialer Services: Core</td>
<td>The Dialer Services: Core view shows the status of core services on the selected dialer in the system. From this view, you can set alerts for the activity events related to each service. For more information, see Viewing Dialer Core Services Information on page 93.</td>
</tr>
<tr>
<td>Dialer Services: Telephony</td>
<td>The Dialer Services: Telephony view shows the status of telephony services on the selected dialer in the system. From this view, you can set alerts for activity events related to each service.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Dialer Services: Data</td>
<td>The Dialer Services: Data view shows the status of data services on the selected dialer in the system. From this view, you can set alerts for activity events related to each service.</td>
</tr>
<tr>
<td></td>
<td>For more information, see Viewing Dialer Telephony Services Information on page 94.</td>
</tr>
<tr>
<td>Dialer Services: Dialer Command Control and Administration</td>
<td>The Dialer Services: Dialer command control and administration view shows the status of command control and administration services on the selected dialer in the system. From this view, you can set alerts for activity events related to each service.</td>
</tr>
<tr>
<td></td>
<td>For more information, see Viewing Dialer Data Services Health Information on page 94.</td>
</tr>
<tr>
<td>Dialer Services: Health Related</td>
<td>The Dialer Services: Health related view shows the status of health related services on the selected dialer in the system. From this view, you can set alerts for activity events related to each service.</td>
</tr>
<tr>
<td></td>
<td>For more information, see Viewing Dialer Health Related Service Information on page 95.</td>
</tr>
<tr>
<td>Dialer Services: All</td>
<td>The Dialer Services: All view shows the status of all the services on the selected dialer in the system. From this view, you can set alerts for activity events related to each service. For more information, see View dialer health related service information.</td>
</tr>
</tbody>
</table>

### Mid-Tier Services

The Mid-Tier Services view shows the status of all Mid-Tier services on the selected dialer in the system.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mid-Tier Services: Framework</td>
<td>The Mid-Tier Services: Framework view shows the status of Mid-Tier framework services on the selected dialer in the system. From this view, you can set alerts for activity events related to each service.</td>
</tr>
<tr>
<td></td>
<td>For more information, see Viewing Mid-Tier Framework Service Information on page 96.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Mid-Tier Services: Data</td>
<td>The Mid-Tier Services: Data view shows the status of Mid-Tier data services on the selected dialer in the system. From this view, you can set alerts for activity events related to each service.</td>
</tr>
<tr>
<td>Mid-Tier Services: Mid-Tier Command Control and Administration</td>
<td>The Mid-Tier Services: Mid-Tier Command Control and Administration view shows the status of Mid-Tier command control and administration services on the selected dialer in the system. From this view, you can set alerts for activity events related to each service.</td>
</tr>
<tr>
<td>Mid-Tier Services: Health related</td>
<td>The Mid-Tier Services: Health related view shows the status of Mid-Tier health related services on the selected dialer in the system. From this view, you can set alerts for activity events related to each service.</td>
</tr>
<tr>
<td>Mid-Tier Services: All</td>
<td>The Mid-Tier Services: All view shows the status of all the Mid-Tier services on the selected dialer in the system. From this view, you can set alerts for activity events related to each service.</td>
</tr>
</tbody>
</table>

### System Status

The System Status view shows the selected dialer’s CPU, disk, memory, and process status.

### Health Manager with Multitenancy

With the introduction of multitenancy in Proactive Contact, the working of Health Manager and the permissions available to the main user groups have changed.
Now, only the Lead Administrator and tenant user, who have sufficient permission to run Health Manager, can view the status of services running on dialer. However, only the Lead Administrator or the default tenant user can start or stop the dialer services.

Only the Lead Administrator and the default tenant user with sufficient permissions can gain access to system-level alerts, such as disk space and service up or down.

**Note:**

This release does not include agent-level and job-level alerting that was earlier available in Health Manager.

---

### Logging in to Health Manager

**Procedure**

1. Select **Start > All Programs > Avaya > Proactive Contact > Health Manager** or double-click the Health Manager icon on the desktop.

2. Type your administrator user name and password on the login message, and then click OK.

When you log in to Health Manager the first time, you will see the Overall Health Services: Dialer Status view. From the drop-down menu below the toolbar in the upper left corner, you can choose to view the status of one dialer or all dialers (if you have more than one dialer) in your system.

Each time you log in to the Health Manager, you will see the last view you were viewing when you logged out of Health Manager.

### Change display options

You can choose to show or hide columns and adjust column widths in the right pane when viewing information.

### Showing or hiding columns

**Procedure**

1. From the Edit menu, click **Hide/Show Columns**.

2. In the Columns dialog box, clear or select the check box. Alternatively, you can click the **Show All** or **Hide All** buttons.

3. Click OK.
The Health Manager view changes to reflect your choices. Health Manager saves the column settings and reuses them the next time you log in.

**Tip:**

You may need to maximize the window, adjust the column sizes, or use the scroll bar to view all the columns. You can sort the listed items by clicking the column headings.

---

### Adjusting column widths

**Procedure**

1. Put your cursor near the column heading divider of the column you want to change until it changes into a column icon.
2. Drag the column divider to the desired length.

   The Health Manager view changes to reflect your choices. Health Manager saves the column width settings and re-uses them the next time you log in.

---

### Refreshing the Health Manager data

**Procedure**

On the View menu, click **Refresh**.

**Note:**

To refresh data in the Activity Events Viewer, click the **Refresh** button.

---

### Sorting the list of dialers, services, or events

**Procedure**

1. Click the column heading to sort in ascending or descending order.
2. To reverse the sort order, click the column heading a second time. Health Manager saves the sort order and reuses it the next time you log in.

---

### Viewing overall system health for all dialers

**Procedure**

1. Log in to the Health Manager application.
If this is the first time you are accessing the Health Manager, the Overall Health Services: Dialer Status view appears. If you have logged into Health Manager before to view system health, the screen you were viewing when you exited Health Manager appears.

2. If the Overall Health Services: Dialer Status view does not appear immediately after you log in, select All Dialers from the drop-down list in the upper left corner of the screen.

Related links
Logging in to Health Manager on page 90

Overall health statistics for all the dialers’ descriptions

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dialer Name</td>
<td>Name of dialer in your system configuration</td>
</tr>
<tr>
<td>Dialer IP Address</td>
<td>IP address for the selected dialer</td>
</tr>
<tr>
<td>Status</td>
<td>Indicates whether the system is up or down</td>
</tr>
<tr>
<td>Uptime</td>
<td>Duration of time the dialer has been up</td>
</tr>
</tbody>
</table>

Viewing system health for one dialer

Procedure

1. Log in to the Health Manager application.

   If this is the first time you have logged in to Health Manager, the Overall Health Services: Dialer Status view appears. If you have logged into Health Manager before to view system health, the screen you were viewing when you exited Health Manager appears.

2. Select a dialer name from the drop-down list in the upper left corner of the screen, below the toolbar. The left pane changes to show Dialer Services with icons for each aspect of the dialer service condition. From the left pane, you can choose to do the following:

   • View Dialer services
   • View mid-tier services
   • View system status

Related links
Logging in to Health Manager on page 90
View Mid-Tier Services on page 96
View System Status on page 98
View Dialer Services

Viewing Dialer Core Services Information

Procedure

1. Log in to the Health Manager application.
2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show Dialer Services with icons.
3. In the left pane under Dialer Services, click Core.

Related links

Logging in to Health Manager on page 90

Dialer core services descriptions

Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AGENT</td>
<td>Agent activity manager</td>
</tr>
<tr>
<td>AGENT_BLENDER</td>
<td>AGENT_BLENDER</td>
</tr>
<tr>
<td>ACD_MONITOR</td>
<td>Blend activity monitor</td>
</tr>
<tr>
<td>DISPATCHER</td>
<td>Outbound agent manager</td>
</tr>
<tr>
<td>CBAMAIN</td>
<td>Agent blend manager</td>
</tr>
<tr>
<td>CTI</td>
<td>ACD gateway</td>
</tr>
<tr>
<td>CEP_PWAY</td>
<td>Call events gateway</td>
</tr>
<tr>
<td>CHGSVR</td>
<td>Switch gateway</td>
</tr>
<tr>
<td>CBA_USER</td>
<td>CBA user</td>
</tr>
<tr>
<td>PORTER</td>
<td>Call process manager (where (n) indicates the PORTER number on the system)</td>
</tr>
<tr>
<td>SIGNALIT</td>
<td>Dialer OS signaling</td>
</tr>
<tr>
<td>PDS_STATUS</td>
<td>PDS_STATUS</td>
</tr>
<tr>
<td>ROUTED</td>
<td>Message router</td>
</tr>
<tr>
<td>CONN_MGR</td>
<td>Agent connection manager</td>
</tr>
<tr>
<td>AGENT_COUNT</td>
<td>Agent counter</td>
</tr>
<tr>
<td>JOB_STARTER</td>
<td>Job linking manager</td>
</tr>
<tr>
<td>SWITCHER</td>
<td>Audio connection manager</td>
</tr>
<tr>
<td>OPMON</td>
<td>Agent headset port manager</td>
</tr>
<tr>
<td>LIST_SERVER</td>
<td>List Sharing manager</td>
</tr>
<tr>
<td>RECALL_RMP</td>
<td>Agent Owned Recall call manager</td>
</tr>
</tbody>
</table>

Table continues…
### Viewing Dialer Telephony Services Information

**Procedure**

1. Log in to the Health Manager application.
2. In the left pane under Dialer Services, click **Telephony**.

**Related links**

[Logging in to Health Manager](#) on page 90

#### Dialer telephony services descriptions

Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SWIF_CT</td>
<td>Avaya CT communications service</td>
</tr>
<tr>
<td>SWIF_DGn</td>
<td>Avaya PG230RM communications service where n indicates the system number</td>
</tr>
<tr>
<td>IVR_CONN</td>
<td>Dialer to Avaya IR connector</td>
</tr>
</tbody>
</table>

*Note:*

If the IVR feature is not available on dialer, then the system disables the processes related to IVR and displays the status as Not Enabled.

### Viewing Dialer Data Services Health Information

**Procedure**

1. Log in to the Health Manager application.
2. In the left pane under Dialer Services, click **Data**.

**Related links**

[Logging in to Health Manager](#) on page 90

#### Dialer data services descriptions

Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HDSC</td>
<td>Historical data services client</td>
</tr>
</tbody>
</table>

*Table continues…*
### Viewing Dialer Command Control and Administration Service Information

**Procedure**

1. Log in to the Health Manager application.
2. In the left pane under Dialer Services, click **Dialer Command Control and Admin**.

**Related links**

[Logging in to Health Manager](#) on page 90

### Dialer Command Control and Administration Service descriptions

Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DCCS</td>
<td>Dialer command and control service</td>
</tr>
</tbody>
</table>

### Viewing Dialer Health Related Service Information

**Procedure**

1. Log in to the Health Manager application.
2. In the left pane under Dialer Services, click **Health related**.

**Related links**

[Logging in to Health Manager](#) on page 90

### Dialer health related service descriptions

Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DIALER_SA</td>
<td>Dialer Activation Service</td>
</tr>
<tr>
<td>DIALER_SM</td>
<td>Dialer Health Monitoring Service</td>
</tr>
<tr>
<td>DIALER_SH</td>
<td>Dialer System Health Monitoring Service</td>
</tr>
</tbody>
</table>

### Viewing All the Dialer Services

**Procedure**

1. Log in to the Health Manager application.
2. In the left pane under Dialer Services, click **All**.
   
   Health Manager displays all the dialer services information in the right pane.
View Mid-Tier Services

Viewing Mid-Tier Framework Service Information

Procedure

1. Log in to the Health Manager application.
2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show Dialer Services with icons.
3. In the left pane, click the Mid-Tier Services tab. The left pane changes to show Mid-Tier services with icons.
4. Click Framework.

Mid-Tier Framework Service descriptions

Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LOGGER</td>
<td>Primary CORBA logging service</td>
</tr>
<tr>
<td>NAME_SERVICE</td>
<td>CORBA naming service</td>
</tr>
</tbody>
</table>

Viewing Mid-Tier Data Service Information

Procedure

1. Log in to the Health Manager application.
2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show Dialer Services with icons.
3. In the left pane, click the Mid-Tier Services tab. The left pane changes to show Mid-Tier services with icons.
4. In the left pane under Mid-Tier Services, click Data.

Mid-Tier Data Service descriptions

Health Manager displays the following information in the right pane:
### Viewing Mid-Tier Command Control and Administration Service Information

**Procedure**

1. Log in to the Health Manager application.
2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show Dialer Services with icons.
3. In the left pane, click the **Mid-Tier Services** tab. The left pane changes to show Mid-Tier services with icons.
4. In the left pane under Mid-Tier Services, click **Mid-Tier Command Control and Admin**.

**Related links**

[Logging in to Health Manager](#) on page 90

### Mid-Tier Command Control and Administration Service descriptions

Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CCS</td>
<td>Primary command and control service</td>
</tr>
</tbody>
</table>

### Viewing Mid-Tier Health Related Service Information

**Procedure**

1. Log in to the Health Manager application.
2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show Dialer Services with icons.
3. In the left pane, click the **Mid-Tier Services** tab. The left pane changes to show Mid-Tier services with icons.
4. In the left pane under Mid-Tier Services, click **Health related**.

**Related links**

[Logging in to Health Manager](#) on page 90

### Mid-Tier Health Related Service descriptions

Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SERV_MON</td>
<td>Primary Health Monitoring Service</td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SERV_ACT</td>
<td>Primary Activation Service</td>
</tr>
<tr>
<td>SYS_HEALTH</td>
<td>Primary System Health Monitoring service</td>
</tr>
</tbody>
</table>

### Viewing All the Mid-Tier Services

**Procedure**

1. Log in to the Health Manager application.
2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show Dialer Services with icons.
3. In the left pane, click the **Mid-Tier Services** tab. The left pane changes to show Mid-Tier services with icons.
4. In the left pane under Mid-Tier Services, click **All**. Health Manager displays all the Mid-Tier services information in the right pane.

**Related links**

[Logging in to Health Manager](#) on page 90

### View System Status

### Viewing CPU Usage Statistics

**About this task**

You can view the overall CPU usage and load of the selected dialer to monitor. This view allows you to detect where the system resources may be tied up serving a limited number of processes, while other critical processes are trying to run.

**Procedure**

1. Log in to the Health Manager application.
2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show Dialer Services with icons.
3. In the left pane, click the **System Status** tab. The left pane changes to show System Status with icons.
4. In the left pane under System Status, click **CPU Usage**.

**Related links**

[Logging in to Health Manager](#) on page 90

**CPU Usage Statistics descriptions**

Health Manager displays the following information in the right pane:
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>% Block Stat</td>
<td>Percentage of time spent in Blocked state</td>
</tr>
<tr>
<td>% Idle Stat</td>
<td>Percentage of time spent in Idle state</td>
</tr>
<tr>
<td>% Nice Stat</td>
<td>Percentage of time spent in Nice state</td>
</tr>
<tr>
<td>Speed (MHz)</td>
<td>Speed of the system in megahertz</td>
</tr>
<tr>
<td>% System State</td>
<td>Percentage of time spent in System state</td>
</tr>
<tr>
<td>% User State</td>
<td>Percentage of time spent in User state</td>
</tr>
<tr>
<td>Load Avg 15 Min</td>
<td>Processor load average during last fifteen minutes</td>
</tr>
<tr>
<td>Load Avg 5 Min</td>
<td>Processor load average during last five minutes</td>
</tr>
<tr>
<td>Load Avg 1 Min</td>
<td>Processor load average during last one minute</td>
</tr>
</tbody>
</table>

**Viewing Disk Usage Statistics**

**Procedure**

1. Log in to the Health Manager application.
2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show Dialer Services with icons.
3. In the left pane, click the System Status tab. The left pane changes to show System Status with icons.
4. In the left pane under System Status, click Disk Usage.

**Related links**

- Logging in to Health Manager on page 90

**Disk Usage Statistics descriptions**

Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File System Available Blocks (KBytes)</td>
<td>Space available on volume partition</td>
</tr>
<tr>
<td>File System Free Blocks (KBytes)</td>
<td>Free space available on volume partition</td>
</tr>
<tr>
<td>File System Name</td>
<td>Disk volume partition name</td>
</tr>
<tr>
<td>File System % Used</td>
<td>Percentage of used space on volume partition</td>
</tr>
<tr>
<td>File System Total Blocks (KBytes)</td>
<td>Space on volume partition</td>
</tr>
<tr>
<td>File System Used Blocks (KBytes)</td>
<td>Used space on volume partition</td>
</tr>
</tbody>
</table>

**Viewing Memory Usage Statistics**

**About this task**

You can see overall memory usage of the system to determine how much real memory is being used and how much swapping is occurring on the selected system.
Procedure

1. Log in to the Health Manager application.
2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show Dialer Services with icons.
3. In the left pane, click the **System Status** tab. The left pane changes to show System Status with icons.
4. In the left pane under System Status, click **Memory Usage**.

Related links
- [Logging in to Health Manager](#) on page 90

### Memory Usage Statistics descriptions

Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Active Real Memory (KBytes)</td>
<td>Real memory used</td>
</tr>
<tr>
<td>Active Virtual Memory (KBytes)</td>
<td>Virtual memory used</td>
</tr>
<tr>
<td>Free Memory (KBytes)</td>
<td>Free memory</td>
</tr>
<tr>
<td>Physical Memory RAM (MBytes)</td>
<td>Total random access memory (RAM)</td>
</tr>
<tr>
<td>Real Memory (KBytes)</td>
<td>Real memory</td>
</tr>
<tr>
<td>Virtual Memory (KBytes)</td>
<td>Virtual memory</td>
</tr>
<tr>
<td>%Memory Usage</td>
<td>Percentage of memory used</td>
</tr>
</tbody>
</table>

Viewing Processes Statistics

Procedure

1. Log in to the Health Manager application.
2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left pane changes to show Dialer Services with icons.
3. In the left pane, click the **System Status** tab. The left pane changes to show System Status with icons.
4. In the left pane under System Status, click **Processes**.

Related links
- [Logging in to Health Manager](#) on page 90

### Processes Statistics descriptions

Health Manager displays the following information in the right pane:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Process Name</td>
<td>Name of system process</td>
</tr>
</tbody>
</table>

*Table continues*...
System Activity Events

Use the Activity Event Viewer to see specific event activity which has occurred on the system. You can determine which service events appear in the viewer by subscribing to them.

Related links
- About Activity Events on page 102

Viewing system events

Procedure

Click the Activity Event Viewer icon on the Health Manager toolbar. Health Manager displays the Activity Event Viewer dialog box. The viewer shows the following information for each event:

Result

- Event name
- Date and time of the event
- Dialer name
- Dialer IP address
- Service name associated with the event
- Status of the event with detailed information

Note:

DIALERSTATUS is an event, and not a service. Therefore, the value of the service name field for DIALER STATUS is displayed as 0.

1. Click Close to close the dialog box and return to the main Health Manager statistics view.
About Activity Events

You can determine which service events appear in the Activity Event Viewer event by subscribing to them.

The Activity Event Viewer lists the last 25 activity events. You can change the maximum number of events Health Manager displays by choosing Tools > Options. The default is 25 events.

You can change the event threshold that triggers the system status events (CPU, memory, and disk usage) by choosing Tools > Options.

You can set the email address to which you want the Health Manager to send activity event notifications by choosing Tools > Options.

If you unsubscribe to all the services, then you will only be notified when a service changes status.

Related links
System Activity Events on page 101
Set Threshold Parameters for System Status on page 106

Subscribing to Activity Events

Procedure

1. Click the Action menu, and then click Subscribe to Service Events.

2. In the Subscribe to Activity Events dialog box, click on the service to subscribe. Health Manager displays a description of each service that you select at the bottom. You can also use the Select All or Unselect All buttons to subscribe or unsubscribe to events.

3. Click OK.

When an event occurs, Health Manager displays the Activity Event Viewer. The viewer shows you the following information for each event:

• Date and time of the event
• Dialer name
• Dialer IP address
• Service name associated with the event
• Status of the event with detailed information
• Event name

4. Click Close to close the dialog box and return to the main Health Manager statistics view.
Saving Data as HTML

Procedure
1. From the File menu, click **Save as HTML**.
2. In the Save As dialog box, type a file name.
3. Click **Save**.

Configuring Health Manager

About this task
Use the Proactive Contact Configurator to set the primary dialer and the license server details and location. Health Manager displays the Configurator dialog box when you log in to the Health Manager application for the first time. You might need to contact your system administrator for the information.

Procedure
1. Log in to the Health Manager application.
2. From the Tools menu, click **Mid-Tier Configurator** or click the Mid-Tier configurator icon on the Health Manager toolbar.
3. In the Configurator dialog box, perform the following steps:
   • Enter the name and IP address of the primary dialer.
   • Enter the name and IP address of the email server.
   • Enter the name and IP address of the database server.
4. Click **OK** to save your settings.

⚠ Important:
If you change the primary dialer specification, you must stop and then restart the Health Bridge service.

Related links
Health Bridge Service on page 104

License Configurator
License Configurator is used to provide the URL of the WebLM server which provides the license to the Proactive Contact.
**Note:**
Only Lead Administrator and the default Tenant user can use this feature, not the Tenant user.

---

**Changing the License server URL**

**Procedure**

1. From the Tools menu, click **License Configurator**.
2. In the License Configurator dialog box, specify the URL of the WebLM server which has the Proactive Contact license.
3. Click **OK**.

---

**Health Bridge Service**

Proactive Contact Health Bridge is a service that provides information about Proactive Contact systems to Health Manager. This information includes the status of the services on the Dialing Servers, system health such as CPU, disk, memory, and processes, and also includes the ability to activate and deactivate services.

The Health Bridge also reports on services and system functioning that may have been hampered and may have gone down to Health Manager.

**Note:**

The physical location of Health Bridge is in %PDSServices% directory in the C:\Program Files\Avaya\Proactive Contact 5.2\Services\Common directory. This location is the default location.

The Health Bridge can be in one of the two states: stopped or started. Additionally, the system provides two intermediate states for Health Bridge: starting and stopping.

**Important:**
You do not have to manually start Health Bridge. When you start Health Manager, Health Bridge starts automatically.

A reason to manually stop and start the Health Bridge is when you switch between a pod of dialers. You typically do this when you make configuration changes in Health Manager in the Configurator dialog box.

**Important:**
Any changes made to the configuration require that you stop and then start the Health Bridge using one of the three methods described as follows.
Starting or stopping Health Bridge from Microsoft Management Console

Procedure
1. From the Start menu, select Control Panel > Administrative Tools > Services.
2. The system displays the Microsoft Management Console Services window with a list of services in the right pane.
3. Right-click on Health Bridge, then click Properties.
4. The system displays the Health Bridge properties dialog box.
5. Press Stop under Service status to stop Health Bridge.
6. Press Start under Service status to start Health Bridge.

Starting or stopping Health Bridge from Command Prompt

Procedure
1. From the Start menu, select All Programs > Accessories > Command Prompt.
2. Type net stop HealthBridge at the prompt and press Enter.
3. Type net start HealthBridge at the prompt and press Enter.

Stopping Health Bridge from Task Manager

Procedure
1. Press Ctrl > Alt > Delete.
2. Click Task Manager.
3. Click on the Process tab.
4. Locate HealthBridge.exe in the processes list.
5. Select HealthBridge.exe and click End Process.
Starting Health Bridge from Task Manager

**Procedure**

1. Press Ctrl > Alt > Delete.
2. Click Task Manager.
3. On the menu bar, click on File, and then click New Task (Run...).
4. In the Create New Task window, type HealthBridge.exe.
5. Click OK.

Set Threshold Parameters for System Status

**Note:**

Only Lead Administrator and the default Tenant user can use this feature, not the Tenant user. You can change the thresholds that trigger activity events that appear in the Activity Event Viewer or that are sent in an email to you. In a pod environment, these thresholds apply to all the dialers in the pod.

**Tip:**

The Activity Event Viewer lists the last 25 activity events.

Changing the maximum number of events that Health Manager displays

**Procedure**

Go to Tools > Options.

The default is 25 events.

Sending activity event notifications

**About this task**

You can set the email address to which you want Health Manager to send activity event notifications by choosing Tools > Options.

If you unsubscribe to all the services, then you will only be notified when a service changes status.
Procedure

1. From the Tools menu, click **Options**.
2. Under System Parameter Settings, type a percentage for each of the following parameters:
   - CPU threshold
   - Memory usage
   - Disk partition usage

   The default percentage is 80%.

Related links

- [Subscribing to Activity Events](#) on page 102
Chapter 9: Editor

Editor is an application using which you can create and maintain phone strategies, record selections, and jobs.

🌟 Note:
In Editor, you must use only period (.) as decimal separator irrespective of the regional language settings.

Editor with Multitenancy

The multitenancy feature in Proactive Contact has changed the functionalities, features, and access permissions in the Editor application.

The features and functionalities available in Editor are applicable only for the tenant that you are supervising. If you are assigned to more than one tenant as Supervisor, you can switch between the tenants using the drop-down box provided in Editor. However, note that the changes that you make for a tenant apply only to that tenant.

As a tenant administrator, you can create and manage:

- Strategies and selections
- Jobs and calling lists
- Do not call groups and Job templates

You can also manage:

- Completion codes and agent keys
- Scheduling, and message and scripts
- Agent job lists and Campaign templates
Logging in to Editor

About this task

In a multitenancy environment, when you log in to Editor, you can view the configurations and settings that are applicable to your tenant. You will not be able to view the configuration of other tenants unless you select the required tenant from the drop-down box.

However, if you are not using multitenancy, you can view all the configurations and data that is available in the default tenant.

Procedure

1. Click Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor.
2. On the login window, enter the user name and password assigned to you.
   The system displays the Editor home page.

Editor user interface customization

The user interface of Editor application contains two panes with the button group displayed to the left. The left-hand pane contains either summary information or a list of titles or files. The right-hand pane contains a tree with settings that you define and modify.

You can customize the user interface of Editor so that you can easily navigate within Editor.

Button groups

The button group expands and contracts to display additional buttons. When you click the button group, buttons appear. You can resize the buttons.

The following table lists and describes the button groups that you see depending on your login:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contact Management</td>
<td>Use the Contact Management group to move between the following features:</td>
</tr>
<tr>
<td></td>
<td>• Strategy</td>
</tr>
<tr>
<td></td>
<td>• Selection</td>
</tr>
<tr>
<td></td>
<td>• Selection Reports</td>
</tr>
<tr>
<td></td>
<td>• Job</td>
</tr>
<tr>
<td></td>
<td>• Job Template</td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Messages and Scripts</td>
<td>Use the Messages and Scripts group to move between the following features: &lt;br&gt;• Messages &lt;br&gt;• Scripts</td>
</tr>
<tr>
<td>Calling List</td>
<td>Use the Calling Lists group to move between the following features: &lt;br&gt;• Calling Lists &lt;br&gt;• Do Not Call Groups &lt;br&gt;• Reports</td>
</tr>
<tr>
<td>Agent Keys</td>
<td>Use the Agent Keys group to move between the following features: &lt;br&gt;• Agent Keys &lt;br&gt;• Reports</td>
</tr>
<tr>
<td>Schedule</td>
<td>Use the Schedule group to move between the following features: &lt;br&gt;• Activities &lt;br&gt;• Reports</td>
</tr>
<tr>
<td>Completion Codes</td>
<td>Use the Completion Codes group to use the following feature: &lt;br&gt;• Completion Codes</td>
</tr>
<tr>
<td>Campaign Template</td>
<td>Use the Campaign Templates group to move between the following features: &lt;br&gt;• Campaign Templates &lt;br&gt;• Reports</td>
</tr>
<tr>
<td>Agent Job List</td>
<td>Use the Agent Job Lists group to move between the following features: &lt;br&gt;• Agent Job List &lt;br&gt;• Agent Job List Reports</td>
</tr>
</tbody>
</table>

**Note:**

The system initially displays by default only the sample data for each of the menu options in the Editor application. Change the data as per your requirements.
Editor button descriptions

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Strategies</td>
<td>Lists the existing phone strategies on the right-hand pane in the window. If you select a phone strategy in the list, the settings appear on the tabs. You can add rows and modify phone strategy settings.</td>
</tr>
<tr>
<td>Selections</td>
<td>Lists the existing record selections. If you select a record selection, the settings appear on the tabs. To modify the record selection settings, select the fields in the tree structure.</td>
</tr>
<tr>
<td>Selections Reports</td>
<td>Lists the record selections that were previously run. Selection Reports contains summary information that you do not modify.</td>
</tr>
<tr>
<td>Jobs</td>
<td>Displays a tree structure on the right-hand pane of the window. The tree structure lists the settings for the selected job. To modify the job settings, select the fields in the tree structure.</td>
</tr>
</tbody>
</table>

In Editor, Proactive Contact allows you to enable or disable multi-dialer commands and set your Save and Refresh options.

---

Sorting content of a column

**Procedure**

Click the column heading.

When you click a heading, you see a small arrow appear alongside the heading. A small arrow that points up indicates that the data is in ascending order. A small arrow that points down indicates that the data is in descending order.

---

Resizing columns

**Procedure**

1. Hover the cursor between the heading titles until a double-arrow appears.
2. Press the left mouse button while you drag the cursor to the left or to the right.
Resizing panes

Procedure

1. Hover the cursor on the divider line that separates the panes until a double-arrow appears.
2. Press the left mouse button while you drag the cursor to the left or to the right.

Switching between dialers

About this task
If you have more than one dialer in a pod environment, then you can switch between the dialers without logging out of the Editor application. You can view only the associated tenants for the selected dialer and if required, then switch between the associated tenants.

Procedure

1. Click Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor.
2. Select the name of the dialer from the dialer drop-down list on the button bar. The system displays the details of one of the associated tenants of the selected dialer.

Switching between tenants

About this task
If you are assigned to more than one tenant, you can switch between tenants without having to log out of the Editor application.

Procedure

1. Click Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor.
2. Select the name of the tenant from the tenant drop-down list on the button bar. The details of the selected tenant are displayed.

Navigating among the Tool applications

Procedure

1. Click Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor.
2. To start a tool, select its name from the Tools menu.
Selecting Contact Management

About this task

Use the Strategies, Selections, Selection Reports, and Job Template buttons on the button bar to move within the Contact Management features. Editor displays a message to save your work when changing to another feature. At the message, you can choose not to save your work.

Procedure

1. Click Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor.
2. Click the Contact Management button group.
3. Click the following buttons:
   • Strategies: to start the phone strategy editor
   • Selections: to start the record selection editor
   • Selections Reports: to start the record selection reports
   • Jobs: to start the job editor
   • Job Template: to create jobs

Viewing icons in the button group

About this task

You can view large or small buttons on the button group. To switch between large and small icons in the button group do the following:

Procedure

1. On the button group, click to expand the button group whose icon size you want to change.
2. Right-click, and then select either Large Icons or Small Icons.
   A check mark next to the menu command indicates which view you are currently using.

Refreshing a view

Procedure

To refresh an open view, press the F5 key.
Editor settings

Using Editor, you can see large amounts of information in a single window. The buttons on the left-hand pane filter the type of information you see.

Related links
Permissions in Role Editor on page 48

Enabling or disabling multi-dialer commands

About this task
This option is available only to the default tenant. This option is enabled only when the dialer is in a pod configuration.

Procedure
1. In Editor, select Settings > Options.
2. In the Options dialog box, click the Multi-dialer tab.
3. Perform one of the following steps:
   • To enable multi-dialer commands, select Enable.
   • To disable multi-dialer commands, select Disable.
4. Select the dialer.
5. Click Apply to save your changes.
6. Click OK.

Related links
Multiple dialers on page 24
Options dialog box field descriptions on page 269

Setting Save options

Procedure
1. In Editor, select Settings > Options.
2. In the Options dialog box, click the Save tab.
3. Perform one of the following steps:
   • To receive a confirmation message before saving, select Prompt before overwrite.
   • To save without receiving a confirmation message, select Overwrite without asking.
4. Click Apply to save your changes.
5. Click OK.
Setting Refresh options

Procedure

1. In Editor, select **Settings > Options**.
2. In the Options dialog box, click the **Refresh** tab.
3. Select the interval at which you want Editor to refresh.
4. Click **Apply** to save your changes.
5. Click **OK**.

Related links

[Options dialog box field descriptions](#) on page 269
Chapter 10: Staging

This section describes how a supervisor can modify the dialer configuration files in the Supervisor applications and store and deploy the files for the tenant on the dialer. The processes and requirements described in this section are related to the configuration files and can be modified using the Editor.

**Note:**

- You must have the write permission to make any changes to the configuration files using the Editor application.
- The information provided in this section is tenant specific. Your modifications are applicable and available only for your tenant.

One of the challenges of Editor is the coordination of configuration changes on the dialer. In some cases, a change might be immediately activated on the dialer without affecting any existing processes or files. In others cases, a change might have catastrophic results. For example, deleting an existing completion code can create a problem if that code used to indicate, which records should be uploaded to the host at the end of the day.

Another challenge related to managing changes is the need to introduce changes to the dialer in a timely fashion. For examples:

- You create a new calling list and want to use the calling list immediately.
- You set up a customer's system and want to implement certain data immediately which can be used to configure other parts of the system.
- You add new completion codes and want to immediately set up record selections with these codes.
- The solution to this is to define and implement a set of management rules for how changes are made to the configuration files. The rules coordinate the changes while minimizing their impact on ongoing operations and progress the files through a set of logical stages.

### Types of configuration files

A specific configuration file may depend on one or more other configuration files and at the same time, have configuration files that are dependent on it.
The dependency relationships occur when the files are being defined. This dependency does not correspond to run-time dependencies among these files. For example, to configure a job you need the calling list configuration files and to run a job you need only the calling list.

The configuration files are of two types. The types are:

- Primary configuration file
- Secondary configuration file

---

**Primary configuration file**

The primary configuration files are those files on which the other configuration files depend. The primary configuration files are generally created and changed relatively infrequently. These files are accessible by users with appropriate permissions.

Examples of the primary configuration files are:

- `telephny.spt`
- `comppcode.cfg`
- `Agent Keys`
- `voicemsg.cfg`
- `calling list applications`

Changing primary configuration files can function abruptly in catastrophic ways. Their manipulation is restricted to having appropriate permissions.

Some files can be considered primary as the files meet all the criteria but only become Active once the dialer restarts.

---

**Secondary configuration file**

The secondary configuration files depend on one or more primary configuration files. The secondary configuration files are created and changed frequently by having appropriate permissions.

These files include jobs, selections, and strategies and are used for day-to-day operations. Only users having appropriate permissions can change the secondary configuration files.

If secondary configuration file stops functioning, you can recover the file by replacing the current changes.

**Configuration file characteristics**

The following table provides a list of characteristics of the configuration files.
<table>
<thead>
<tr>
<th>File Identity</th>
<th>Delete (Yes/No)</th>
<th>Type</th>
<th>Dependent On</th>
<th>Files Impacted</th>
</tr>
</thead>
<tbody>
<tr>
<td>Job 2 on page 119</td>
<td>Yes</td>
<td>Secondary</td>
<td>• Agent key</td>
<td>• Calling list application</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Job</td>
<td>• Do Not Call (DNC)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Screen</td>
<td>• Selection</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• telephny.spt</td>
<td>• voicemsg.cfg</td>
</tr>
<tr>
<td>Selection 2 on page 119</td>
<td>Yes</td>
<td>Secondary</td>
<td>• Calling list application</td>
<td>Job</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Completion code</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Strategy</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Time zone</td>
<td></td>
</tr>
<tr>
<td>Strategy 2 on page 119</td>
<td>Yes</td>
<td>Secondary</td>
<td>• Calling list application</td>
<td>Selection</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Completion code</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Time zone</td>
<td></td>
</tr>
<tr>
<td>Completion code</td>
<td>No</td>
<td>Primary</td>
<td></td>
<td>• Agent key</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Calling list application</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Job</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Selection</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Strategy</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• telephny.spt</td>
<td></td>
</tr>
<tr>
<td>Voice message</td>
<td>No</td>
<td>Primary</td>
<td></td>
<td>• telephny.spt</td>
</tr>
<tr>
<td>Calling list application 3 on page 119</td>
<td>Yes, except the calling list data, which can only be deleted using the Character User Interface (CUI).</td>
<td>Primary</td>
<td>• Completion code</td>
<td>• Agent key</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Job</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Screen</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Selection</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Strategy</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• telephny.spt</td>
</tr>
<tr>
<td>Agent key</td>
<td>Yes</td>
<td>Primary</td>
<td>• Completion code</td>
<td>• Job</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• telephny.spt</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Voice message</td>
<td></td>
</tr>
</tbody>
</table>

*Table continues…*
Stages of configuration files

A stage is an attribute of a configuration file, which indicates the current use or status of a file. A file can be in a stage that allows editing, active use, or deletion.

Stages of configuration files are as follows:

- Active
- Pending
- InProgress
- Deleted
- Null

Stages of configuration files descriptions

The following table provides a detailed description of the stages of the configuration files, the locations of the files, and their precedences.

<table>
<thead>
<tr>
<th>Stage</th>
<th>Precedence</th>
<th>Description</th>
<th>Location of Files</th>
<th>Further Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Active</td>
<td>1 (highest)</td>
<td>Active stage file is the one that is currently in use by the dialer.</td>
<td>In a location where it is</td>
<td>Continue the operation</td>
</tr>
</tbody>
</table>

Notes:

1. You cannot delete the file that is essential for system operation. Therefore, the system must always have an Active version of that file, and you cannot delete that file. You can delete a file of the same name in any other stage.

2. Users having appropriate permissions can gain access to these files. However, they can make changes only to the versions that are in Active stage. They can also see the instances of effectively Active versions.

3. This is a set of files including .dict, .fdict, .xfr, .prep, and a calling list.
<table>
<thead>
<tr>
<th>Stage</th>
<th>Precedence</th>
<th>Description</th>
<th>Location of Files</th>
<th>Further Use</th>
</tr>
</thead>
</table>
| Pending | 2          | The file is modified by one or more users and made active next time when the dialer services are started.                                                                                                                                                                                                                           | /opt/avaya/pds/staging/pending                                                                 | • Basis for revisions  
  - Active  
  - InProgress  
  - Pending files                                                                                                                                                                                                                         |
| InProgress | 3       | The file is modified by one or more users, but it is not ready to become active. The user puts the file in this stage with the intention that additional work needs to be done.                                                                                                                      | /opt/avaya/pds/staging/inprogress                                                  | • If you edit the configuration file, the file's stage may remain Pending or changed to InProgress.  
  • The editor can explicitly delete a file in this stage.                                                                                                                                                                   |
| Deleted | 4          | • The file was Active but replaced by a Pending copy when the dialer was last restarted. Currently the file is in a wastebasket and can be recovered until permanently deleted.  
  • Only primary configuration files are moved to Deleted stage.  
  • Secondary files are immediately deleted when replaced on system restart.                                                                                                                                               | /opt/avaya/pds/staging/deleted                                                   | • Deleted stage files can be saved as Pending or InProgress.  
  • The editor can explicitly delete a file in this stage.  
  • Otherwise Deleted stage files are permanently removed from the system after a configurable period of time has elapsed.                                                                                           |

**Note:**  
In the Active stage, certain files cannot be deleted by the editor or cannot be deleted at

*Table continues…*
<table>
<thead>
<tr>
<th>Stage</th>
<th>Precedence</th>
<th>Description</th>
<th>Location of Files</th>
<th>Further Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Null</td>
<td>5 (lowest)</td>
<td>The file is deleted and is no longer recoverable (except, by a restore of a backup set).</td>
<td>Not on the system. The file may be on a backup media.</td>
<td>Only for an unplanned restore.</td>
</tr>
</tbody>
</table>

Basic rules for working with configuration files

A number of rules are applied to managing changes to the configuration files so as to achieve a flow among tentative changes, desired changes, committed changes, and obsolete configurations.

Users having appropriate permissions can perform the following changes in the Editor:

- Create new or modify the existing files
  - You can modify the secondary files in any stage and primary files only in Pending or InProgress.

  ✪ Note:
  
  Despite Schedule being a primary file, you can modify the file in the Active stage as well, barring some restricted activities.

  - You can select a New option in the Editor to create a file from scratch.

  ✪ Note:

  In Editor, you cannot select the New option for the following files:

  - Completion Codes
  - telephny.spt
  - Voice messages
  - Schedule files

  These files cannot be deleted from Active stage.

- For any depended-on files, you need to designate the stage to use, except the following:
  - Editor determines the file stage to use

    If a given file is presented in only one stage, Editor selects that file stage. Otherwise you are presented with a choice of list of file stages.

    - The depended-on stage can only be Active or Pending (not InProgress or Deleted).
- If a file of the designated stage is not available, the next higher precedence available stage is used.
  • If no Pending files are available, the Editor restricts the choice to Active.
  • If the needed file does not exist at any higher precedence stage, this is reported to you.
• You can save the file to any stage, except the following:
- Files cannot be saved to the Deleted stage.
- Only secondary files or a calling list application can be saved or Make Active to the Active stage if there depended-on files are in active.
- The saving file’s stage has to be same or lower than the depended-on file’s stage.
- You can save Agent keys, Calling list application, Job, Selection, and Strategy files under a different name. Any other configuration file of the same name and stage is overwritten according to the following:
  • The same file name is already exist—you are asked to confirm if you want to overwrite that file.
  • All other files have one copy each in any stage and the name is always the same—you are not asked to confirm and the file is overwritten.
- When saving to a different stage or filename, the original file is kept as it is. You can delete the original file if required.
• You can perform the following other operations in Editor:
- Verification of files—Editor has separate option to verify files; it is not part of the save operations. There may be an exception for telephny.spt.
- You can explicitly delete files in any stage, except the following:
- The only files that you can delete from the Active stage are: Agent keys, Calling list application (except the calling list data), Job, Selection, and Strategy.
- Staging has no impact on file locking or vice versa—for example, you make changes to an Active job but keep the file open for editing so long that the lock expires, you have the normal option of overwriting the existing Active file or saving the file under a new name.
- When saving to multiple systems in a dialer pod—the associated files and other files that get replaced, need to be in synchronization, assuming you have consistently propagated changes to the members of the pod. Note that verification can be used as a separate operation to detect any inconsistencies.

The following operation is performed when you restart the dialer:
• Pending files are moved to the Active stage.
• Primary Active files replaced by a Pending file are moved to the Deleted stage.
• Secondary Active files replaced by a Pending file are hard deleted.
Note:
Secondary files do not go to a Deleted stage.

- Active or Deleted files replaced by a file of the same name are overwritten.
  - Only the latest copy of a Deleted file at any given name is kept.
  - The retention period for Deleted files start anew whenever a newly created Deleted file
    overwrites a prior Deleted file.

The following operation is performed when retention period of Deleted file is exceeded (you can
specify the retention period of the Deleted file):
- Deleted Primary files are hard deleted.

You can backup of configuration files as follows:
- Configuration files in all stages are backed up as part of backing up all configuration files.

Related links
Backup and restore of configuration files on page 125
Restrictions for Scheduling on page 279
Rule descriptions for configuration files on page 123

Rule descriptions for configuration files

The following table provides detailed rules descriptions for working with configuration files:

<table>
<thead>
<tr>
<th>Types of Operation</th>
<th>Initial file being changed</th>
<th>Allowed Stage(s) of depended-on files</th>
<th>Allowed Stages for save</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Editor to build or change a file</td>
<td>Secondary</td>
<td>Active</td>
<td>Active</td>
<td>At or below the selected stage of depended-on files</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Pending</td>
<td>Pending</td>
<td>Any Secondary file can be saved in Active (Require to Active all depended-on files).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>In Progress</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Use Editor to delete</td>
<td>Secondary</td>
<td>Active</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Pending</td>
<td></td>
<td>All Secondary files are hard deleted.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>In Progress</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Use Editor to build a new or change an existing file</td>
<td>Primary</td>
<td>Pending</td>
<td>Active</td>
<td>At or below the selected stage of depended-on files</td>
</tr>
<tr>
<td></td>
<td></td>
<td>In Progress</td>
<td>Active ² on page 125</td>
<td>A newly created calling list application can be Make Active (Require to Active)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Pending ³ on page 125</td>
<td></td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>Types of Operation</th>
<th>Initial file being changed</th>
<th>Allowed Stage(s) of depended-on files</th>
<th>Allowed Stages for save</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Stage(s) of depended-on files&lt;sup&gt;1&lt;/sup&gt;</td>
<td>null</td>
<td>all depended-on files).</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>New cannot be done for the following:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Completion Codes</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• telephny.spt,</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Voice Messages</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Schedule files.</td>
</tr>
<tr>
<td>Use Editor to delete a file</td>
<td>Primary</td>
<td>Active&lt;sup&gt;2&lt;/sup&gt;</td>
<td>N/A</td>
<td>Only certain files can be deleted from the Active stage. For more information, see Types of configuration files on page 116.</td>
</tr>
<tr>
<td>Use Editor to recover a Deleted file</td>
<td>Primary</td>
<td>Deleted</td>
<td>Open file only for purpose of recovery</td>
<td>Pending InProgress&lt;sup&gt;2&lt;/sup&gt; on page 125</td>
</tr>
<tr>
<td>Restart dialer</td>
<td>Primary</td>
<td>Pending</td>
<td>N/A</td>
<td>Active&lt;sup&gt;2&lt;/sup&gt; on page 125</td>
</tr>
</tbody>
</table>

Note:
The primary configuration files on which the deleted file depends may no longer be available or may have changed.
<table>
<thead>
<tr>
<th>Types of Operation</th>
<th>Initial file being changed</th>
<th>Allowed Stage(s) of depended-on files</th>
<th>Allowed Stages for save</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Type</td>
<td>Stage</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Primary</td>
<td>Active</td>
<td>N/A</td>
<td>Deleted</td>
</tr>
<tr>
<td></td>
<td>Secondary</td>
<td>Deleted</td>
<td>N/A</td>
<td>Null</td>
</tr>
</tbody>
</table>

Notes:

1. This is not the designated stage. The depended-on files are opened read-only and read into the Editor. No changes are made to the depended-on files. The designated stage can be Active, in which case only Active depended-on files are used; or it can be Pending, in which case Pending stage is used, or if the needed file doesn’t exist in Pending, then Active is used. For more information, see Basic rules for working with configuration files on page 121.

2. Exception to or constraint on general precedence rule – see comments in table.

3. The user chooses to use Pending files during editing, the user cannot pick and choose between Pending and Active stage of depended-on configuration files. However, if a specifically needed Pending file is not available, the Active file is used. For example, the user is creating a Job, which in turn uses completion codes. If the user select to use Active depended-on files, that is used. If user select to use Pending depended-on, that is used. If the Pending depended-on file is not available, Editor uses the Active version. User cannot change the selected version until quits or saves the initial file.

Related links

Basic rules for working with configuration files on page 121

Backup and restore of configuration files

All types of configuration files of all stages must be included in the applicable backup operations. There several types of backup and restore options are present.

Backup options are mentioned in the following:

- All the system configuration files—backup all types of configuration files of all stages.
• The entire system excluding the calling lists—backup all staged configuration files of all stages excluding the calling list.

• The entire system including the calling lists—backup all staged configuration files of all stages.

🌟 Note:

If the Proactive Contact dialer is deployed on a virtualized server, then you must ensure that the DVD drive on the host system is accessible by Proactive Contact dialer before initiating a backup or restore.

Restore options are mentioned in the following:

• All files from any backup tape created using the backup menu commands—restore all stages of configuration files to their correct locations.

• Restore a single file from any backup tape created using the backup menu commands—restore a configuration file, when selected, to its correct location.

• Verification features—operate on all configuration files saved on a backup tape.
Chapter 11: Calling Lists

A Calling List is a file that contains customer records. Proactive Contact uses two types of calling lists, one for outbound calling, and one for inbound calling on Intelligent Call Blending systems.

This section lists the procedures for creating and making a calling list available for calling purposes. The procedures described in this section must be performed in the given sequence to successfully create a calling list.

A dialer can have maximum 999 unique outbound and 999 unique inbound calling list names. Although the system limit is 999 for each type of calling lists, the tenant limit is decided by the Lead Administrator at the time of tenant creation. You can view only those calling lists that are created in your tenant space. If you try to create a calling list after reaching the limit, the system displays a warning message.

Creating a new calling list

Procedure

1. In the Editor button bar, select New. The Calling List application wizard appears.
2. Click Next to go to the next page of the wizard. Specify the following information:
   - **What kind of activity will the calling list support**: Specify the calling list as inbound or outbound.
   - **Your new calling list will be named**: Specify the name of the calling list in the text box. The name must begin with an alphabet, be of maximum 15 characters, and use only alphabets (a-z, A-Z) and digits (0-9).
     
Note:

The system supports only the English language list names.

   - A list name must be unique at the tenant level. You can create a calling list with an identical list name across multiple tenants, but within a tenant, you must provide a unique name to each calling list.
   - **Description**: Provide a brief description for the new calling list.
3. Click Next. The information provided in the previous page appears in the **Review this information** section. To change any details, click **Back** and make the necessary changes.
**Note:**
To import sample records from a test file, select the **Launch Import Wizard** check box to launch the Data Import wizard.

4. Click **Finish**. Your new calling list appears in the list of calling lists in the Calling lists Panel.

---

**Import data to create Download Dictionary**

The Data Import Wizard takes a sample host data file, analyzes the file, and creates a download dictionary. Using the Data Import Wizard you can only create a calling list.

After creating a calling list, you can add calling records data to the Download dictionary either manually or by importing data from a host data file.

You can import data for calling by identifying the record format that you want to use. The data that you wish to import must satisfy the following criteria:

- The sample data file must contain 10-50 records.
- The sample data file must be fixed width or CSV format.

Then verify the analysis of the data import wizard and modify fields as required.

---

**Importing a Data File**

**Procedure**

1. Right-click the specific list and select **Download from Host**.
2. In the right-hand pane, click the **Download Dictionary** tab.
3. Right-click and select **Data Import** wizard.
4. Click **Next** when the Data Import wizard appears.
5. Select **Data Type**. The Data type refers to the type of date in a particular field, for example: Delimited or Fixed length. You can select from the following options:
   - Delimited - Delimiter refers to csv file that carries fields and records separated with delimiters, which are special characters.
   - Fixed length - Fixed width indicates that the width or length of each field is defined and thus the length of the record as a whole is defined. The maximum supported record length is 4096 bytes.
6. If you select **Delimited** as the Data Type for import, perform the following steps:
   a. Click **Browse** to locate your sample file.
   b. Select the **First record contains column names** check box if the first record in your sample file defines column names. Here, column names means the field names of the
processed calling list SQL Expressions. The sample file should have the first record with fields populated with the calling list field names to save time later.

c. Click Next.

d. Specify the criteria used in your host file to differentiate records from each other in the **How are records separated from each other?** field.

e. If the download file is CSV format and the delimiter is Line Feed, do not enable the Remove Line Feed. Enabling the Remove Line Feed will cause problems in creating calling list on the dialer.

f. Specify the criteria used in your host file to differentiate fields from each other in the **How are fields separated from each other?** field.

g. Click Next. The records from the sample file are displayed in columns format on the Field Names page. As per the criteria specified in step 4 and 5, the data from the sample file is parsed into the appropriate columns.

h. You can define field names at this stage. There must be at least one phone defined, and each phone field should be in the format such as PHONE1 and PHONE2.

i. One of the records in the sample file must contain the maximum number of characters that each field can contain in the host database. The wizard, then, will read that in the final calling list and define the maximum character width for the final calling list.

j. Click Finish to import the sample file.

7. If you select **Fixed width** as the Data Type for import, perform the following steps:

a. Specify the exact length of each of the records in the **Record Length** field.

b. Click **Browse** to locate your sample file.

c. Click Next. All the records are displayed on the Record Length page.

d. Click Next. The Field Length page displays the analyzed field length. To further define the character length of a field, click the specific character in the field length section. For example, if you have clicked number 10 as the character for a specific field, a vertical line automatically appears as the field length. You can also drag the line to specify a different character length as a field length. To remove the vertical line, click the line again. If required, click on each column header to change the name of the field or fields.

e. After you have finalized the field length, click Next. The field name page displays the data populated in the fields as defined by you.

f. To define the name of each calling list field, click on the column header and enter the field names. Also, there must be at least one phone defined, and each phone field must be in the format such as PHONE1, PHONE2, and PHONE3.

g. Click Finish to import the sample file.
Download From Host

The **Download from Host** feature displays the configuration data associated with download data from the host to the dialer. This information includes the transfer method, the transfer schedule, the format of the host data, and directions for handling certain types of file data.

### Download from host tab field description

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Method</strong></td>
<td>This represents the title row for grouping related data.</td>
</tr>
<tr>
<td><strong>Type of Transfer</strong></td>
<td>This represents the method used to transfer data from the host to the dialer. The acceptable values are SFTP transfer initiated by host and SFTP transfer initiated by dialer. If you select the Initiated by dialer option, the following four data elements are enabled; otherwise, they are disabled.</td>
</tr>
<tr>
<td><strong>Host Name</strong></td>
<td>This represents the name of the Host computer. You can use any of the following as an entry in the Host field:</td>
</tr>
<tr>
<td></td>
<td>• An alias, which must be manually entered into the /etc/hosts file</td>
</tr>
<tr>
<td></td>
<td>• An IP address</td>
</tr>
<tr>
<td></td>
<td>• A fully qualified domain name</td>
</tr>
<tr>
<td><strong>Logon Name</strong></td>
<td>This represents the user ID that the dialer uses to logon to the host system.</td>
</tr>
<tr>
<td><strong>Password</strong></td>
<td>This represents the Password that you use to logon to the host computer.</td>
</tr>
<tr>
<td><strong>Host File Name</strong></td>
<td>This represents the name of the data file that is present on the host computer.</td>
</tr>
<tr>
<td><strong>Raw Data File Name</strong></td>
<td>This represents the File name of the Raw Data file. The filename must be changed if the host will be writing a different named file to the dialer when host initiates the FTP. The raw data filename including the path must not exceed 256 characters. In case of multi-tenancy, you can change only the raw data file name, and not the path.</td>
</tr>
<tr>
<td><strong>Schedule</strong></td>
<td>This represents the title row for grouping related data.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Stop download time</td>
<td>This represents the time when the system will stop attempting the download of the calling list. This setting works based on the time set on the dialer.</td>
</tr>
<tr>
<td>Retry if download fails</td>
<td>This check box indicates whether you should reattempt a failed download. Downloads fail if the host file is not available at the time of the initial download attempt (automated download from Scheduled events).</td>
</tr>
<tr>
<td></td>
<td>🔄 Note: If infinite download is scheduled as a recurring task, you must clear this check box.</td>
</tr>
<tr>
<td>Delay between downloads (sec)</td>
<td>This represents the number of seconds to wait between attempts. This setting works based on the time set on the dialer.</td>
</tr>
<tr>
<td>Format</td>
<td>This represents the title row for grouping related data.</td>
</tr>
<tr>
<td>Record Size</td>
<td>This represents the size in bytes of each host record.</td>
</tr>
<tr>
<td>Block Size</td>
<td>This represents the size in bytes of each block. This field should always be left at default of 10 times of the Record Size.</td>
</tr>
<tr>
<td>Blocks Read</td>
<td>This represents the number of blocks read at a time. This field should always be left at default value of 10.</td>
</tr>
<tr>
<td>Skip Records</td>
<td>This represents the number of records to skip before starting to convert the host data. For example, if the host sends a header record of field name data which should not be converted to a calling list record.</td>
</tr>
<tr>
<td>Records to read</td>
<td>This represents the total number of records to read from the host. For example, use this field if the business requires to limit a calling list to X number of records but the host sends more records than expected.</td>
</tr>
<tr>
<td></td>
<td>If you do not want any limit, leave this field blank.</td>
</tr>
<tr>
<td>Do not verify record length</td>
<td>This check box indicates whether the verification process should be run during download. For example, if this check box is selected, and if the raw file is not evenly divisible by the record length, then the system will cancel the list processing.</td>
</tr>
<tr>
<td>Text case</td>
<td>The options available for selection of text case are Uppercase, Lowercase, Title case, or Ignore Case. Select the text case as required. The data</td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>from the raw file is converted in the form of the selected text case. Select <strong>Ignore Case</strong> if you want to ignore case conversion. The <strong>Ignore Case</strong> option has been added to the 5.1.2 version of Proactive Contact Supervisor. The feature is enabled by default. However, you can disable this feature for versions of Proactive Contact prior to 5.1.2 using the IGNORECASE parameter present in the <code>case.conf</code> file. For Proactive Contact Release 5.1.2 and later, the <code>case.conf</code> file is not used, because now Proactive Contact dialer has the capability to use upper, lower, or title case, or ignore the case of the text.</td>
</tr>
</tbody>
</table>

**Record Format**

| Record Format | The options available for record format are Fixed Length and Character Separated Values (CSV). If CSV is chosen, the next two rows are enabled; otherwise, the rows are disabled. |

**Record delimiter**

| Record delimiter | This represents the character that marks the boundary between one record and the next. You can either use the drop-down selections or enter another character for the delimiter values. |

**Field delimiter**

| Field delimiter | This represents the character that marks the boundary between one field and the next. |

**Qualifier**

| Qualifier | When reading CSV files, when the host data need to include the characters set as the Record or Field Delimiters, the data string can be qualified with this specified value. The default value for this field is double quotes (“”); however, you can configure any other special character as a qualifier (except the following reserved characters - colon, comma, and period). For example, if the field delimiter is set to comma, and qualifier is double quote, when a field values from the host needs to include a comma, it is sent as follows: John Doe, 1234 Tenth Ave, Apt 4b, Newark (example of NAME,ADDRESS,CITY) |

**Preparation**

| Preparation | This represents the title row for grouping related data. |

**Append records to calling list**

<p>| Append records to calling list | This check box indicates that the records in this download must be appended to the existing records instead of overwriting the records. |</p>
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remove Carriage Returns</td>
<td>This check box indicates that carriage returns should be removed from the end of each record from the host data file.</td>
</tr>
<tr>
<td>Remove Line Feeds</td>
<td>This check box indicates that line feeds should be removed from the end of each record from the host data file.</td>
</tr>
<tr>
<td>Run custom process at beginning of download</td>
<td>This allows you to select your own custom scripts at the beginning of a download. You can have more than one custom script. For example: If you want to copy your raw data file name and you have created a custom backup script, you can enter the script name in this field.</td>
</tr>
<tr>
<td>Run custom process after download</td>
<td>This allows you to select your own custom scripts after download. You can have more than one custom script.</td>
</tr>
<tr>
<td>Switch Year</td>
<td>This represents the year. This option is available if the host is sending two digit years. The year that marks when 20 should prefix or added at the beginning to represent a 2-digit year data. Before this year, 19 is prefixed. The default is 70. This field is used with the Transformation map feature to convert host data. For example, MMDDYY is converted into MM/DD/NNYY format.</td>
</tr>
</tbody>
</table>

**Download Dictionary tab field description**

This screen displays a list of all fields in the download data file.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Field</td>
<td>The name of a download field.</td>
</tr>
<tr>
<td></td>
<td>🌟 <strong>Note:</strong> The field name has to be in all caps, for example: SYNUM. Also, the supported length for the field name is 15 characters.</td>
</tr>
<tr>
<td>Data Type</td>
<td>This field represents the type of data contained in the field. The drop-down lists all the available data types.</td>
</tr>
<tr>
<td>Length</td>
<td>This field represents the length of the data. The overall length of the record is displayed as a sub-total at the top of the grid and the data is not-</td>
</tr>
</tbody>
</table>
### Name | Description
--- | ---
 | editable. This length of the data field is the maximum number of characters that will be read in the case of a CSV file. Therefore, this field should always be set to the maximum number of characters that the host might send for each field.
**Same Start** | Is a check box to indicate that the field has the same starting position as the previous field.
**Start** | This field displays the character position in the file where the field starts. Normally this is calculated as the start position of the previous field and the length of the previous field. If you select the Same Start check box, this is calculated as the start position of the previous field.
**End** | This is a non-editable field that displays the character position that marks the end of the field. This is calculated by adding the field's length to the field's start.
**Description** | This field allows you to enter a user-defined description of the field.
**Host Only Field** | This is the associated Host Field name in the calling list.

**Note:**
When the Host Only Field check box is selected, then the field and data will not be defined in the final calling list when imported to the Calling List Dictionary.

---

### Download Map

The Map tab allows you to configure how download data is transformed into calling list data on a field-by-field basis. You can create a new transformation and also edit and delete existing transformations.

---

### Creating a new Download Map

**Procedure**

1. Select the specific Calling List.
2. Right-click and select **Download from Host**.
3. In the right-hand pane, click the Map tab.
An empty Map pane appears with the following columns:

- Download Field
- Transformation
- Download Data
- Calling List Data

4. Right-click on any one the column headers and select **New**.
   
The Download Map window appears.

5. From the **Field Type** drop-down list, select the required field type.
   
The available options are:

- **Merge**: This option allows you to merge one or multiple fields in the host file to create a new field in the download dictionary.

- **Transformation**: This option allows you to change one value into another value based on regular expressions. All the field values that match a specific regular expression are transformed to a specified value. This transformation allows a specified host value to be translated into a specific calling list value.

- **RSM**: The RSM option represents Record Specific Messaging. This option allows you to specify a new name for the RSM field and associate a source field to the specific default message. You can also define a message by entering the host data and associating the host data to the specific message. You can also add and remove rows in the Define Message section.

6. If you select the field type as **Merge**, perform the following steps:

   a. Type the name of the new merged field in the Enter name for the new merged field text box.
   
   b. Select the fields to be merged from the Select the fields and the order for merging list. To select multiple fields from the list, hold down the **Ctrl** key and click on the required fields.
   
   c. Click **Add** to confirm the fields for merging.
   
   d. To change the order in which the fields must be merged, select the field and click **Move Up** or **Move Down**.
   
   e. Click **OK**.
      
The newly created map appears under the Map tab.

7. If you select the field type as **Transformation**, perform the following steps:

   a. Select the field that is to be mapped in the **Select unmapped field** drop-down list.
   
   b. Click the required tab for the corresponding transformation type and enter the corresponding values.
The options are:

- Fill: You use the Fill tab to apply a fill function to the mapped field. The entered characters are used to fill the specified field. If there is already any content present, it is replaced with the Fill characters.

- Format: You use the Format tab to define the format of the download field and the mapped field. This option transforms the data strings. For example, you can choose to convert MM-DD-YY format to MM-DD-NNYY format or convert HHMMSS time format to HH.MM.SS time format. Note that the spaces in the Host format are not expected in the data from the host. The host will send MMDDYY, and the dialer adds spaces and dashes. Therefore, 6 characters from the host convert to 10 characters when it goes from MMDDYY to MM-DD-NNYY. In date formats, the NN in NNYY is the century switch year function.

You can choose from several options for format transformation.

- Translate - You use the Translate tab to convert specific strings in the download field to specific strings in the mapped field. Use the Dialer default option to insert the specified value if the host value does not match any of the other values.

**Note:**

You can change the field length in the calling list. For example, if the host sends 3 characters, it can be translated into 20 character output, if desired.

c. Click OK.

8. If you select the field type as RSM, perform the following steps:

   a. Type a new field name which will contain the RSM information in the Enter name for new RSM field text box. This field is specified in the jobs. You can specify the RSM field name up to 15 characters.

   b. Select the field which contains values from the host on which the message choice is based from the Select source field drop-down list.

   c. Select the message to be played from the Default Message drop-down list. The default Message is played if the field value does not contain any other specified value.

   d. You can further add conditions to play record specific messages to the records in the calling list. Click Append to add a row in the Define Message pane.

   e. Type a specific condition for which a record specific message must be played in the Host Data text box. For example, if you have defined country as the required field in the Select source field, then, you can add a condition that if country equals to Japan, play a message in Japanese language.

   **Note:**

   You can use wildcard and regular expressions in the Host Data field.

   f. Select the corresponding message from the Message drop-down list for the condition specified in the Host Data field.
g. You can add multiple such conditions for RSM by using Append button to add a new row. Use Remove button to delete a condition for RSM.

h. Click OK.

Related links
Record Specific Messaging on page 161

---

**Editing a Download Map**

**Procedure**

1. Select the specific Calling List.
2. Right-click and select Download from Host.
3. In the Map tab, select the required row.
4. Right-click on the row and select Edit.
5. Make the required changes and click OK.

---

**Deleting a Download Map**

**Procedure**

1. Select the specific Calling List.
2. Right-click and select Download from Host.
3. In the Map tab, select the required row.
4. Right-click on the row and select Delete.

The specific download map transformation is deleted.

**Note:**

If a download map modifies the field lengths or adds new fields (RSM), then the import download dictionary to calling list dictionary should be performed again after the changes are saved.

---

**Importing Download Dictionary to Calling List Dictionary**

**About this task**

You must import data from the Download Dictionary tab to the Calling List Dictionary for the calling list to function successfully.
Procedure

1. Right-click the required calling list in the Calling List pane and select Calling list details.
2. Click the Calling List Dictionary tab.
3. Right-click and select Import from Download Dictionary. The fields in the Calling List Dictionary are synchronized as per the fields defined in the Download Dictionary.

Result

The Calling List Dictionary tab displays the field names along with the attributes for each of the field. It displays information about the field name, data type whether character or numeric, length of each field, and field description.

Note:

- Ensure that the record size of the calling list is not more than 8192 bytes.
- If RSM is activated on the Map tab in Download from Host, then the RSM column is displayed along with the information about the field that has been selected for the RSM feature. The RSM column is non-editable.
- If Latelist is activated on the Processing tab in Download from Host, then the Latelist column is displayed. You can select the fields on which you want to use the Latelist functionality.

If your system has agent owned recall feature enabled, then you must select the Index field and it should be the first field in your selection for the latelist functionality to work. You can use the Move Up and Move Down options in the right-click menu to change the order of fields.

Configuring Zip To Time Zone for calling lists

Before you begin

You must create the zip to zone file using the sysadm menu before using this feature. For more information about creating the zip to zone file, see Administering Avaya Proactive Contact guide.
Procedure

1. Click Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor.
2. Click the Calling Lists button group.
3. Click the list for which you want to configure the Zip To Time Zone feature. The calling list settings appear in the right-hand side pane.
4. Click the Processing tab.
5. Select the check box next to the Zip To Zone parameter.
6. Click Save.

Related links

Setting prerequisites for the Phone time zone feature on page 148

Processing tab

The Processing tab displays a list of processes that run on the downloaded data as part of the process of converting the data into a calling list.

The processes are listed in the order in which they are run.

The process, Set timezones, is by default the first process to be run and cannot be moved or deleted.

You can change the order of the process by right-clicking on a process, then selecting either Move Up or Move Down from the pop-up menu.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set timezones</td>
<td>Sets the time zone for the calling list. This is a non-editable field.</td>
</tr>
<tr>
<td>Zip To Zones</td>
<td>When you select this option, the parameter ZIPTOZONES in the PREP format section of the dnld file is set to YES and the Zip To Time Zone feature is enabled on the calling list.</td>
</tr>
<tr>
<td></td>
<td>For every phone field in calling list, a new zipcodes field is added to the calling list field. For example, if the list1 has two phone fields as PONE1 and PHONE2 and if the Zip to timezone feature is enabled, then while processing the list, two new fields ZIPCODES1 and ZIPCODES are added to the list.</td>
</tr>
<tr>
<td>Index calling list for quick sorting and searching</td>
<td>A check box to enable indexing for quick searching and sorting of records in a calling list.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Key field</td>
<td>The key field based on which indexing of records must be performed.</td>
</tr>
<tr>
<td>Index calling list for Do Not Call processing</td>
<td>A check box to enable indexing to mark records as Do Not Call in a calling list. For example, if an agent marks a record as DNC, the record is given a unique identifier, which then is added to the Index file. When that record is encountered again, the system searches for the record in the Index file, therefore enabling quick sorting.</td>
</tr>
<tr>
<td>Key field</td>
<td>The key field based on which indexing of records for Do Not Call must be performed.</td>
</tr>
<tr>
<td>Remove Duplicate Records</td>
<td>A check box to enable removal of duplicate records in the calling list. Note that the duplicate records are not removed from the system, but marked as duplicate. The first record is marked with a * in the DUPE field and subsequent records are marked with an R in the STATUSFLAG, thus making them uncallable.</td>
</tr>
<tr>
<td>Match field</td>
<td>The field based on which the records must be marked as duplicate. For example, ACCTNUM.</td>
</tr>
<tr>
<td>LATELIST</td>
<td>A check box to enable the LateList feature for the calling list. LateList allows field values to be carry forwarded if the same record is in the calling list on the next download.</td>
</tr>
<tr>
<td>Match compcodes</td>
<td>The completion codes which must be used to track the calls. Only those calls with the specified completion codes will be tracked. You can select multiple completion codes.</td>
</tr>
<tr>
<td>Calculate aging</td>
<td>A check box to enable calculation of days for which a record is appearing in the calling list. This functionality works only if the record based on Match Field appears on all consecutive downloads.</td>
</tr>
<tr>
<td>Match field</td>
<td>The field which must be considered for calculating the age of the record in the calling list.</td>
</tr>
<tr>
<td>Maximum days on system</td>
<td>The maximum days for which a record can be included in a calling list. After the specified number of days, the record will be marked as uncallable. This parameter has dependency on Number of days in a work week parameter. For example, if the Maximum days on system is set as 7 and then Number of days in a work week is set to 6, the record will be marked uncallable in the next week.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Name</td>
<td>You can use this parameter only if the Mark records uncallable after maximum days parameter is set to Yes.</td>
</tr>
<tr>
<td>Number of days in a work week</td>
<td>The number of days to be considered in a work week. For example, for a Monday to Friday week, the value in this field will be 5.</td>
</tr>
<tr>
<td>Mark records uncallable after maximum days</td>
<td>A check box to mark a record as uncallable after reaching the maximum number of days as specified in the Maximum days on system field.</td>
</tr>
<tr>
<td>Restore records formerly marked uncallable</td>
<td>A check box to restore records that have been marked as uncallable in the calling list.</td>
</tr>
<tr>
<td>Run Reports</td>
<td>The fields that you can use to specify the criteria to run reports. These are CUI reports which you can run upon completion of the download. For more information refer to Administering Avaya Proactive Contact guide.</td>
</tr>
<tr>
<td>Days on dialer</td>
<td>A check box to include the days for which a record has been existing on dialer in the report.</td>
</tr>
<tr>
<td>Reject records</td>
<td>A check box to include the rejected records in the report.</td>
</tr>
<tr>
<td>Release</td>
<td>A check box to include the completion code of the record in the report.</td>
</tr>
<tr>
<td>Insert area codes based on zip codes</td>
<td>A check box to insert area codes in the calling list based on the zip codes. This field cross-references the zip code from each calling list record with a list of predefined zip codes to obtain the corresponding area code, and inserts the area code into the specified calling list field(s).</td>
</tr>
<tr>
<td>Zip code field</td>
<td>The field name that corresponds to the zip code in the calling list.</td>
</tr>
<tr>
<td>Area field</td>
<td>The field name that corresponds to the area code in the calling list.</td>
</tr>
<tr>
<td>Only replace blank area codes</td>
<td>A check box to perform zip code to area code conversion only for the records that have blank area codes. This check box prevents accidental overwriting of area codes that already exist.</td>
</tr>
<tr>
<td>Custom script</td>
<td>A check box to run any custom script that you might want to use for performing any additional action on the calling list. These scripts are executed from /opt/avaya/pds/customs directory on the dialer. To add any custom scripts, contact Avaya support.</td>
</tr>
<tr>
<td>Script name</td>
<td>A script from the drop-down menu. The drop-down menu will only be available if there are any custom</td>
</tr>
</tbody>
</table>
Calling Lists

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>scripts added in the opt/avaya/pds/customs directory on the dialer.</td>
</tr>
<tr>
<td>Script Parameter</td>
<td>The parameters for the custom script.</td>
</tr>
</tbody>
</table>

**Calling list feature descriptions**

The following table details the features that you can configure for a calling list:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>This is a pre-populated field. This field has two information:</td>
</tr>
<tr>
<td></td>
<td>• Number of phone fields: List the number of phone fields present in the calling list.</td>
</tr>
<tr>
<td></td>
<td>• List is part of the Do Not Call group: This checks whether the list is part of the Do not call group. If yes, there is a check mark next to the List is part of the Do Not Call group.</td>
</tr>
<tr>
<td>Post Update</td>
<td>Using postupdate on page 143</td>
</tr>
<tr>
<td>Infinite Jobs</td>
<td>Using Infinite Jobs on page 144</td>
</tr>
<tr>
<td>Campaign Update</td>
<td>Using Batch Campaign Update on page 145</td>
</tr>
<tr>
<td></td>
<td>Using Real Time Campaign Update on page 146</td>
</tr>
<tr>
<td>Native Voice and Data Transfer</td>
<td>Using Native Voice and Data Transfer (NVDT) on page 146</td>
</tr>
<tr>
<td>Sales Verification</td>
<td>Using Sales Verification on page 147</td>
</tr>
<tr>
<td>Cell Phone Time Zone</td>
<td>Cell Phone Time Zone on page 148</td>
</tr>
</tbody>
</table>

**Postupdate**

The postupdate binary updates a calling list with information from the job statistics files for each attempt to call a record. The Postupdate process is sometimes referred to also as due diligence. It is imperative for Due Diligence reporting that is required to be maintained by the users to prove that a record was contacted a certain number of times before various actions were taken. When the calling job completes, if a POSTUPDATE variable is defined in the job file, the postupdate binary is run.

The postupdate binary runs using the configuration parameter values in the file. For example, it tracks the number of attempts made on phones with specified completion codes, and then updates the specified calling list with the data from the job stat file.
Using Postupdate

Procedure

1. Select the specific Calling List.
2. Right-click the calling list, and select Calling list details.
3. On the Features pane, select the Postupdate check box.

Postupdate field descriptions

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of phones to update</td>
<td>Specify the number of phone to be updated. Even if there is only one phone in the calling list, two phones must still be configured for the postupdate binary to run. You can configure up to a maximum of nine phones.</td>
</tr>
<tr>
<td>Number of call attempts to keep</td>
<td>Number of call attempts to track per phone. The maximum value for this field is 5 call attempts.</td>
</tr>
<tr>
<td>Maintain history of attempts</td>
<td>This field has two options:                                                                                           • Keep initial attempts: Only tracks the results of the first through X attempts (Number of call attempts to keep).                                                                                               • Overwrite initial attempts: Tracks the results of the last X attempts (Number of call attempts to keep).</td>
</tr>
<tr>
<td>Update record codes</td>
<td>The release codes to be considered while updating the calling list, for example 02,03,11, and 13, or * (for all). When you double-click on this field, a Completion Codes window appears. You can select the required completion code from the list. If you select all the Completion Codes, a * will appear in the Update records codes field (which will include future completion codes created at a later time). If you select individual codes and new codes are created which need to be tracked, you will need to add those codes here later.</td>
</tr>
</tbody>
</table>

Infinite Jobs

The process of setting calling list into Active stage automatically creates Infinite Job and selection files that is used for Infinite Job Campaign. The infinite job will be available in Jobs under Contact
Management as inf_<calling list name>. The Infinite selection will be available in Selection under Contact Management as inf_<calling list name>.

The Make Active option for calling list is available only if the calling list is in Pending stage and there is no Active version of the same calling list. If the calling list is in the In Progress stage, then save the calling list in Pending stage. The calling list in pending stage is set to Active stage during next maintenance cycle.

**Note:**

After upgrading from any previous version to Proactive Contact 5.2, if you modify an old infinite calling list and then save it as pending, then when the calling list becomes active, the system creates new job and selection files. The system displays a warning message at the time of saving the calling list as pending. In this case, the old job and selection files do not work. You must update your schedule if it includes the older infinite job and selection for the list. However, if you use the old infinite calling list as it is, then the old job and selection files work as earlier.

### Using Infinite Jobs

**About this task**

You can configure the Infinite Job option available under the Features tab in the Calling List section in Editor.

**Procedure**

1. Select the specific Calling List.
2. Right-click the calling list, and select Calling list details.
3. Click the Features tab and select the infinite job option.

### Infinite jobs field description

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Key for removing duplicate records</td>
<td>Select the unique field from the drop-down. For example: ACCTNUM.</td>
</tr>
<tr>
<td>Key for indexing records:</td>
<td>Select the field to be used for searching the records. For example: ACCTNUM. This field is same as the Indexing field used for indexing calling list (Download Dictionary &gt; Processing &gt; Key field for Indexing).</td>
</tr>
<tr>
<td>Key for indexing Do Not Call processing</td>
<td>Select the field to be used for searching the Do Not Call records. For example: ACCTNUM. This field is same as the Indexing field used for Do Not Call processing (Download Dictionary &gt; Processing &gt; Key field for Do Not Call processing).</td>
</tr>
</tbody>
</table>
### LATELIST

Latelist allows data from previous day’s calling list to be updated in the new infinite download depending upon completion codes.

**Note:**

LATELIST will only update the new records if they exist in the prior day’s calling list. LATELIST does not update from records called earlier in the present day.

### Sort newly downloaded records after download

An option that allows you to choose whether the newly downloaded records will be sorted into the existing records.

### Key for sorting

A drop-down of calling list fields that allows you to select the field that will be used for sorting. The fields will be sorted by this field in descending order.

---

**Using Batch Campaign Update**

**About this task**

The Batch Campaign Update function allows you to specify records that should be marked by the system as uncallable. This is similar to deleting a record.

Avaya Proactive Contact Release 5.1.2 enhances the Batch Campaign Update (BCU) feature to update all matching records, and not just the first or the last.

**Note:**

You must contact Avaya Professional Service to configure a parameter in the master.cfg file that controls the functioning of the BCU feature and ensures backward compatibility.

**Procedure**

1. Create new outbound calling list or use an existing calling list.
2. Right-click on an outbound calling list, which is created in pending stage, and select **Calling list details** option.
3. Select the **Campaign Update** check box.
4. Select the update mode as Real Time from the **Update Mode** drop-down list. You can select **Both** to enable both Batch and Real-time updates.
5. Select the index value from the **Index** drop-down list.
   
   This value is used as a unique value using which the records are searched, and the matching records are marked as uncallable. As you select the value of **Index** field, the **Start**, **Length**, and **Type** fields are populated accordingly.

6. To run a custom script on the searched records before the file transfer, provide the name of the script in the **Run custom script on new records before file transfer** field.
7. To run a custom script on the searched records after the file transfer, provide the name of the script in the **Run custom script on new records after file transfer** field.

8. Click **Save**.

---

**Real Time Campaign Update**

Real-time campaign update allows inbound call results to be matched to an outbound calling list on the basis of unique ID, completion code, and job parameters, and then mark the outbound record as not-callable. For example, when inbound calls are received from customers whose accounts have crossed the due date, the real-time update allows this call result to be transferred to the same record on an outbound list so that the customer does not receive additional calls.

This feature is applicable only for the Overflow blending or Intelligent Call Blending setup.

**Using Real Time Campaign Update**

**Procedure**

1. Create new outbound calling list or use an existing calling list.

2. Right-click on an outbound calling list, which is created in pending stage, and select **Calling list details** option.

3. Select the **Campaign Update** check box.

4. Select the update mode as Real Time from the **Update Mode** drop-down list. You can select **Both** to enable both Batch and Real-time updates.

5. Click **Save**.

---

**Native Voice and Data Transfer (NVDT)**

The Native Voice and Data Transfer function enables any outbound agent on an Outbound or Blend Job to transfer their current call (both voice and data) to any inbound or blend agent actively joined to an Inbound or Blend Job. When the transfer is made to the inbound agent, the data from the outbound calling list can be populated in an inbound record. The transfer can be made supervised or unsupervised (blind). On a supervised transfer, the agent stays on the line until the transferee picks up the call, therefore creating a three-way conversation. On a blind (unsupervised) transfer, the agent transfers and releases the call at the same time.

The Native Voice and Data Transfer feature is a standard feature for all Proactive Contact systems with Overflow Blend.

**Using Native Voice and Data Transfer (NVDT)**

**Procedure**

1. Create new outbound calling list application and save it in pending stage.
2. Right-click on outbound application, which is created in pending stage, and select Calling list details option.

3. Click the Features tab and select the Native Voice and Data Transfer option.

4. Click the Calling List Dictionary tab and select the fields. For example, ACCTNUM, BALANCE which are required for NVDT.

5. Save the application.

6. Create inbound calling application in pending stage.

7. Right-click on inbound application, which is created in pending stage, and select Calling list details option.

8. Right-click anywhere on the right pane and select the Configure NVDT option. The Inbound NVDT dialog box is displayed which contains the list of all calling lists, which are configured for NVDT.

9. Select the calling list, which was created in Step 1. This will add all the fields selected for outbound list. If the length/type of any field(s) in inbound calling list is mismatching with field(s) of outbound list (which are marked for use in NVDT Step 4) then a message will be displayed.

10. Save the inbound application.

11. Make outbound and inbound application active using Make Active option.

12. In outbound and inbound job, select the respective calling lists for which NVDT feature is configured.

**Note:**

The Name of Inbound Job to transfer calls to option should have the name of inbound job, which is using the list that you have created. The Name of Inbound Job to transfer calls to option is present in the outbound job configuration.

---

**Sales Verification**

The Sales Verification configuration setting verifies a transaction or commitment that the customer made. Use the Sales Verification option when starting a Sales Verification job. You can enable Sales Verification option for a calling list.

**Using Sales Verification Procedure**

1. Right-click on outbound calling list, which is created in pending stage, and select Calling list details option.

2. Click the Features tab.

3. Select the Sales Verification check box.
Phone Time Zone

Earlier, when the called party moved to other time zones and kept their old numbers, Proactive Contact dialer used to dial numbers on their phones outside of the regulatory time zone hours. This limitation was putting Proactive Contact customers out of compliance or severely reducing the calling times for Dialer customers who deploy phone-centric campaigns.

In this release, you can support calls to mobile phones with an additional time zone identifier assigned.

For this feature, you designate a field that identifies the time zone for each phone number that migrates to a different location. The dialer checks this field for each record for time zone determination. If the value is null, then the dialer continues with the time zone of the original phone number. If the value is not null, then the value in the field sets the time zone for the phone number.

Setting prerequisites for the Phone time zone feature

Procedure

1. Verify that your raw data contains fields for alternate phone numbers such as MODZONEPHONE1 and MODZONEPHONE2.
   The values for the MODZONEPHONE# fields are <Area Code>-<Exchange number>, for example, 270-209. The area code and the exchange number must be of the current location. For example, if the phone number of the called party belong to New York, but the current location of the called party is Chicago, then the host file must contain the area code and the exchange number of Chicago.

2. Set the field values for the zonephone fields in the Download Dictionary tab.

3. Import the data to the calling list dictionary by using the Import from Download Dictionary option.

4. Enable the Cell Phone Time Zone feature.

Using Phone Time Zone

Procedure

1. Right-click on outbound calling list, which is created in pending stage, and select Calling list details.

2. Click the Features tab.

3. Select the Cell Phone Time Zone check box.

Note:

As the dialer determines the time zone based on the area code and exchange numbers, the dialer assigns the area code and exchange numbers of the actual location of the contact. The exchange number is not mandatory in such a case. If an area has multiple exchange numbers with different time zones, then the exchange number is needed. Configure the area number that the customer provides for the
migrated phone number in locale.cfg. Otherwise, the dialer fails to determine the time zone information using that area code.

Examples of values in the <Area Code>-<Exchange number> are 270-209.

270-209 : ZONE:1:D:Eastern Daylight. This field value indicates that the called party is in the Eastern Daylight time zone.

224 : ZONE:1:I:Illinois Daylight. This field value indicates that the called party is in the Illinois Daylight time zone.

Synchronize calling list data with host

Data Export

The Data Export Wizard helps you to prepare for uploading calling list data to the host computer. Specifically, the wizard displays a message to select the records and fields that should be exported. Based on your responses, and also information from the associated download (data import), the wizard creates a new upload definition and completes the Upload to Host, Upload Dictionary, Upload Map, and Select records tabs.

The use of this wizard is to quickly create a data export definition that fulfills the needs of most customers. Thus, it supports straightforward implementations. If you have more complex requirements, the wizard may be used to create the basic definition and then you can refine the definition using the full user interface.

Exporting a data file

Procedure

1. Define the records you want to export.
2. Identify the fields of the calling list from which you want to export the data.
3. Define the fields that will be uploaded to the host.

Exporting a data file instantly

Procedure

1. Right-click the specific list and select Upload To Host.
   
   The system displays Data Export Wizard.

2. Click Yes.
3. Click Next.
4. Select the appropriate Records, Date, Results, Field, and Field Value.
5. Click **Next**.
6. Select the fields that you want to export by selecting the specific check boxes.
7. Click **Finish**.

**Exporting a data file at a later time**

**Procedure**

1. Right-click the specific list and select **Upload To Host**.
   The system displays Data Export Wizard.
2. Click **No**.
3. Click **Upload Dictionary** tab.
4. Right-click and select **Create New Set**.
   The system displays Data Export Wizard.
5. Click **Next**.
6. Select the appropriate **Records**, **Date**, **Results**, **Field**, and **Field Value**.
7. Click **Next**.
8. Select the fields that you want to export by selecting the specific check boxes.
9. Click **Finish**.

---

**Upload To Host**

The Upload to Host feature displays the configuration data associated with upload data from the dialer to the host. This information includes the transfer method, the transfer schedule, the format of the host data, and directions for handling certain types of file data.

**Upload to host tab field descriptions**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Method</strong></td>
<td>This represents the title row for grouping related data.</td>
</tr>
<tr>
<td><strong>Type of Transfer</strong></td>
<td>This represents the method used to transfer data from the dialer to the host. The available values are File transfer initiated by host and File transfer initiated by dialer. If you select the File transfer initiated by dialer, the following four data elements are enabled; otherwise, they are disabled.</td>
</tr>
</tbody>
</table>

pees Note:
If you do not want to enter the host name, logon name, password, and host file name, ...
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>you must contact Avaya Professional Service to configure the sftp parameters in the master.cfg file.</td>
<td></td>
</tr>
<tr>
<td>Host Name</td>
<td>This represents the name of the Host computer. You can use any of the following as an entry in the Host field.</td>
</tr>
<tr>
<td></td>
<td>• An alias, which must be manually entered into the /etc/hosts file</td>
</tr>
<tr>
<td></td>
<td>• An IP address</td>
</tr>
<tr>
<td></td>
<td>• Or a fully qualified domain name</td>
</tr>
<tr>
<td>Logon Name</td>
<td>This represents the name that you use to logon to the host computer. This field is only available if the File transfer is initiated by dialer.</td>
</tr>
<tr>
<td>Password</td>
<td>This represents the Password that you use to logon to the host computer. This field is only available if the File transfer is initiated by dialer.</td>
</tr>
<tr>
<td>Host File Name</td>
<td>This represents the name (and path if appropriate) of the upload file that will be written to the host computer. The raw data file is transferred from the dialer to the host with the file name being the host file name. This field is only available if the File transfer is initiated by dialer.</td>
</tr>
<tr>
<td>Raw Data File Name</td>
<td>This represents the File name of the Raw Data file. The extracted data from calling list based on the export criteria is stored in this file on the dialer. The raw data filename including the path must not exceed 256 characters.</td>
</tr>
<tr>
<td>Schedule</td>
<td>This represents the title row for grouping related data.</td>
</tr>
<tr>
<td>Stop upload time</td>
<td>This represents the time that marks the end of the period when the upload can be attempted. This setting works based on the time set on the dialer.</td>
</tr>
<tr>
<td>Retry if upload fails</td>
<td>This check box indicates whether you should reattempt a failed upload.</td>
</tr>
<tr>
<td>Delay between uploads (sec)</td>
<td>This represents the number of seconds to wait between attempts. This setting works based on the time set on the dialer.</td>
</tr>
<tr>
<td>Format</td>
<td>This represents the title row for grouping related data.</td>
</tr>
<tr>
<td>Record Size</td>
<td>The size in bytes of each host record. This value is automatically calculated based on fields chosen in the upload dictionary.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Block Size                    | This represents the size in bytes of each block. This field should always be left at default of 10 times of the Record Size.  
| Blocks Read                   | This represents the number of blocks read at a time. This field should always be left at default value of 10.  
| Text case                     | The options available for selection of text case are **Uppercase**, **Lowercase**, **Title case**, or **Ignore Case**. Select the text case as required. The data from the raw file is converted in the form of the selected text case. Select **Ignore Case** if you want to ignore case conversion. The **Ignore Case** option has been added to the 5.1.2 version of Proactive Contact Supervisor. This feature is enabled by default. However, you can disable this feature for versions of Proactive Contact prior to 5.1.2 using the IGNORECASE parameter present in the case.conf file. For Proactive Contact Release 5.1.2 and later, the case.conf file is not used, because now Proactive Contact dialer has the capability to use upper, lower, or title case, or ignore the case of the text.  
| Record Format                 | The options available for record format are **Fixed Length** and **Character Separated Values (CSV)**. If CSV is chosen, the next two rows are enabled; otherwise, the rows are disabled.  
| Record delimiter              | This represents the character that marks the boundary between one record and the next.  
| Field delimiter               | This represents the character that marks the boundary between one field and the next.  
| Preparation                   | This represents the title row for grouping related data.  
| Add Carriage Returns          | This check box indicates that carriage returns should be added to the end of each record when the new host data is created for upload.  
| Add Line Feeds                | This check box indicates that line feeds should be added to the end of each record when the new host data is created for upload.  
| Remove duplicate records from upload | This check box indicates whether duplicate records should be removed and not included in the upload.  
| Unique field                  | This drop-down offers a list of calling list fields. You must pick a field that contains unique data, that is, the same field as the field on which the list is index on.  

*Table continues...*
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extraction field</td>
<td>The process of identifying duplicate records involves storing each record's status in a calling list field. The drop-down offers a list of calling list fields. Usually you must select the STATUSFLAG field.</td>
</tr>
<tr>
<td>Extraction Value</td>
<td>All records with this value in the Extraction field will be included in the upload. Usually, this value is not equal to R, where R is the flag added for the duplicate records.</td>
</tr>
<tr>
<td>Terminator</td>
<td>This field a,c,c,c,c,c,c,cc,,,,,,,,,,,,,,,,xxx,x,x, allows you to specify special characters (except for colon, comma, and period) that will be added to every blank position in the records. Leave this field blank to add null characters to the blank positions in each record.</td>
</tr>
</tbody>
</table>

### Upload Dictionary tab field descriptions

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Field</td>
<td>The name of an upload field. The field name has to be in all caps, for example: ACCTNUM represents the account number.</td>
</tr>
<tr>
<td>Data Type</td>
<td>This field represents the type of data contained in the field. The drop-down lists all the available data types.</td>
</tr>
<tr>
<td>Length</td>
<td>This field represents the length of the data. The overall length of the record is displayed as a subtotal at the top of the grid and the data is not-editable.</td>
</tr>
<tr>
<td>Same Start</td>
<td>This is a check box to indicate that the field has the same starting position as the previous field.</td>
</tr>
<tr>
<td>Start</td>
<td>This is a non-editable field that displays the character position in the file where the field starts. Normally this is calculated as the start position of the previous field and the length of the previous field. If you select the Same Start check box, this is calculated as the start position of the previous field.</td>
</tr>
<tr>
<td>End</td>
<td>This is a non-editable field that displays the character position that marks the end of the field. The value for this field is calculated by adding the length of the field to the start of the field.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter a user-defined description of the field.</td>
</tr>
</tbody>
</table>
Upload Map

The Upload Map tab allows you to configure how calling list data is transformed into upload data on a field-by-field basis. You can create a new transformation and also edit and delete existing transformations.

Creating a new Upload Map

Procedure

1. Select the specific Calling List.
2. Right-click and select Upload To Host.
3. In the Upload Map tab, select New.

The Upload Map dialog box appears. Through this dialog box, you can choose the ways of transforming the host data.

Methods for transforming the host data

Transformation allows you to change one value into another value based on regular expressions. All the records that match a specific regular expression are transformed to a specified value. This transformation allows a specified host value to be translated into a specific calling list value.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fill</td>
<td>Using this tab, you can set a transformation that allows you to fill a host data field with the specified characters.</td>
</tr>
<tr>
<td>Format</td>
<td>Using this tab, you can set a transformation that allows you to change the calling list format into a different format for the host upload file.</td>
</tr>
<tr>
<td>Translate</td>
<td>Using this tab, you can set a transformation that allows you to change one value into another value based on regular expressions.</td>
</tr>
</tbody>
</table>

Editing an Upload Map

Procedure

1. Select the specific Calling List.
2. Right-click and select Upload To Host.
3. Select the Upload Map. Right-click the Upload Map and select Edit.

The Upload Map dialog box appears.

Methods for transforming the host data

Transformation allows you to change one value into another value based on regular expressions. All the records that match a specific regular expression are transformed to a specified value. This transformation allows a specified host value to be translated into a specific calling list value.
Name | Description
--- | ---
Fill | Using this tab, you can set a transformation that allows you to fill a host data field with the specified characters.
Format | Using this tab, you can set a transformation that allows you to change the calling list format into a different format for the host upload file.
Translate | Using this tab, you can set a transformation that allows you to change one value into another value based on regular expressions.

### Deleting an Upload Map

**Procedure**

1. Select the specific Calling List.
2. Right-click and select **Upload To Host**.
3. In the Map tab, select the map row to be deleted.
4. Right-click and select **Delete**.
5. Click **Save**.

   The specific upload map transformation is deleted.

### Select Records

The Select Record tab allows you to select and upload records based on a combination of one or more values: date called, call results, and calling list field values.

You can identify which records to export based on field criteria.

You can set the selection criteria by choosing records with specific values in specific fields. For example, you may choose to upload all records that were called today and have a CODE2, CODE3, or CODE4 in the **CODE** field.

You can also enter multiple criteria and join them together using logical operators (And, Or).

### Select records tab field description

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
</table>
| Date | The **Date** field allows you to pick a date. All records with the selected date in the **Date** field will be selected for export. The options available for selection are:  
• Records called today - Use this field to display the records called today. |
|     | |
## Calling List modifications

For an existing list application, if the calling list dictionary is changed and the application is saved to the pending directory, then while restarting pds, when list is moved from pending to active, ext_list is executed upon the existing calling list.

As a result, the existing calling list is transformed as per the new calling list dictionary. In this case, if any of the fields is removed or modified to decrease the length, then the data for that field is lost. The old calling list file is backed up in the $CLIST/post_sync_clist_bkp directory temporarily and is deleted after three days.

For the changes to take effect in the screen file, once the modified calling list becomes active, update the screen file using the screen builder.

After upgrading from any previous version to Proactive Contact 5.2, if you modify an old infinite calling list and then save it as pending, when the calling list becomes active, the system creates new job and selection files. The system displays a warning message at the time of saving the calling list as pending. In this case, the old job and selection files do not work. However, if you use the old infinite calling list as it is, then the old job and selection files work as earlier.

### Modifying an existing calling list

**About this task**

You can modify a calling list anytime if you want to make any configuration changes.

**Procedure**

1. In Editor, select **File > Save As**.
   
   The Save As dialog box appears.
2. Select the **Version**.
3. Enter a **New Name** for the calling list.
4. Enter a **Description** for the calling list.
5. Click **OK** to modify an existing calling list.

---

## Calling List Reports

When you select a report, you can then view the full report in the Feature Detail pane at the right side of the window.

### Status Reports

This report displays a list of all calling lists. It is very similar to the list that normally appears in the Feature pane, but also includes the Type, Status, and Change Date (Date and Time).

The **Change Date** field represents the date and time that the calling list entered this status. For a Pending list, this represents the date and time that the calling list definition was written to the dialer in the directory that holds the files that will be activated on the next restart. For a deleted list, this is the date and time the list was deleted. A Deleted calling list is stored for a period of 30 days in a backup directory. You can only retrieve the list during this period.

You can sort and resize the length of each column. The application saves the resized columns automatically.

---

## Tools for using calling lists

### Using the Verify command

#### About this task

The Verify command checks and validates the data entered in the calling list configuration fields. Ideally there should not be any error appearing when you run the Verify command.

The Verify command checks for the invalid values, missing fields, or empty configuration fields. When the errors are displayed, fix the specific fields and run the Verify command again to validate your changes.

#### Procedure

Select a calling list and do one of the following:

- Right-click the calling list, and select Verify.
- Click **File > Verify**.
The configuration errors for the calling list are displayed in the Results window.

---

**Using Convert Sample command**

**About this task**
The Convert Sample tab allows you to test your download configuration using the sample file that was used by the Import Wizard. This option allows you to verify whether or not your raw data is appearing as required if converted to an actual calling list.

**Note:**
Convert sample is only available for Outbound calling list.
The sample file is used to help create the download configuration file only.

**Procedure**
1. Right-click on an outbound calling list and select **Convert Sample**.
2. Select the sample CSV text file that contains raw data in the specified format from your local machine.
3. Verify the data fields for a record in the Sample Conversion window.
   
   **Note:**
   You must have the data in the sample file categorized as per the fields defined in the calling list. Otherwise, Convert Sample provides incorrect values for each field of a record.

4. Click **Next** to view the next set of records.

---

**Using Make active command**

**About this task**
The calling lists are created in three stages: Pending, In progress, and Active. Usually a calling list that is created in a pending stage is made active when the dialer is restarted. However, if you want to change the stage of a calling list from pending to active in real time, use the Make Active command.

You cannot use the Make active command to activate a calling list if the record length of that calling list is greater than the value set for the MAXRECSIZE parameter in `master.cfg`. In that case, to activate that calling list, you must wait for the next dialer restart.

**Procedure**
1. Select a calling list that is in a pending stage.
2. Right-click and select the Make active option.
Do not Call Groups (DNC)

The Do Not Call (DNC) feature allows an agent to mark a customer record as Do Not Call and mark all the matching records (records with the same unique customer identifier) in other selected calling lists as DNC. You can configure a calling list to support Do Not Call by adding the list to a new or an existing Do Not Call group. The calling lists in each group must all have the same unique identifier for the record.

For example, you might have a DNC group for Collections that includes list1, list2, list5, and list6. The DNC group for Telemarketing may include list3 and list4. You can mark the record as uncallable in all the Collections campaigns, but the record will still be callable in a telemarketing campaign, and vice versa.

You must specify the DNC group for each job. Only one DNC group can be designated for each job.

Note:
When you configure DNC group and linking to a Job, then the DNC group should have the calling list that the Job is running on, else the record in the calling list used by the Job, will not be marked as DNC for Do Not Call request by the Agent.

Viewing a Do not Call Group

Procedure

1. Click Do Not Call Groups.
   A list of DNC groups is displayed in the Do Not Call Group pane along with the status of each DNC group.

2. Click DNC group name to view the Setting and Value details of that DNC group in the DNC Group Details pane.

Setting prerequisites for Do Not Call Group

Procedure

1. Select the specific Calling List.

2. Right-click and select Download from Host.
3. Click **Processing**.
4. On the Processing tab, provide appropriate inputs for the fields.

### Processing tab field descriptions

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Index calling list for quick sorting and searching</td>
<td>A check box to enable indexing for quick searching of records according to the unique identifier that is defined in the Index calling list for quick sorting and searching field. Key fields are used to create an index file which is used by the system internally to find a record quickly in available records. After you select this check box, you must define the associated key value.</td>
</tr>
<tr>
<td>Index calling list for Do not Call processing</td>
<td>A check box to enable indexing for DNC group.</td>
</tr>
<tr>
<td></td>
<td>After you select this check box, you must define the associated key value.</td>
</tr>
</tbody>
</table>

**Note:**

You can set different key fields for the Index calling list for quick sorting and searching and Index calling list for Do not Call processing fields. Based on the key field set for a particular DNC group for the job, the DNC records are searched.

**Note:**

You can keep the same records marked as DNC in each subsequent download in the following two ways:

- Set the STATUSFLAG field in Latemrk/Latelist.
- Use a DNC completion code and have the host determine if the record must be resent or not.

Avaya recommends using a completion code.

---

### Creating a new Do Not Call Group

**About this task**

The Do Not Call Groups wizard is designed to help you create a new DNC group. You can create one or more DNC groups and associate the DNC group or groups to calling lists.

**Procedure**

1. In the Editor button bar, select **File > New**.
   - The New Do Not Call Group wizard appears.
Note:
For English, the maximum length for Do Not Call group name is 32 characters. For other languages, the maximum length for Do Not Call group name is 10 characters.

2. Enter Name. The name must be for the new do not call group.
4. Select Initial Calling List.
5. Click Add.

Additional features for using calling list

Record Specific Messaging
The Record Specific Messaging (RSM) feature allows you to target specific wait queue and virtual messages according to the data in one or more fields of the customer’s record. For example, in a call center that handles collections for various local hospitals, you can configure RSM to lookup the name of the hospital in the customer’s record and accordingly play a message unique for that hospital.

Before configuring the field in the calling list, an audio message must be recorded and configured on the system. Also, ensure that the message is active.

Implementing the RSM feature
Procedure
1. Create a new RSM field in your calling list to identify the wait queue message for each customer.
2. Choose a source field in the calling list that contains the information you want to use to select the message.
   You may use any field in the calling list, but Avaya recommends that you select a field for which the data can be easily grouped. For example, if you choose, you would have to define a message for each possible account number. Instead, you can choose SERVICE_PLAN, for which you would need to define messages for each type of service plan, such as Platinum, Gold, and Silver.
3. Define the relationship between the data in that field and different messages.
   For example, if you want to play messages based on the number of days past due, you could use a DAYS_LATE field. You could specify message1 for customers who are 30 days or less past due, message2 for customers who are 31-60 days past due, and message3 for customers who are more than 60 days past due. During calling list processing, the correct message for each customer is written to the RSM field based on
the data in the DAYS_LATE field and the criteria you have created. You can create this relationship if RSM is activated on the Map tab in Download from Host. You can enter the DAYS_LATE criteria in the Host Data field and specify the associated messages. You can use wildcard and regular expressions in the Host Data field.

You can handle more complicated operations by defining additional source fields; for example, you may include PASTDUE_BALANCE field with the DAYS_LATE field in the given example.

**Configuring Record Specific Messaging using Scripts**

**About this task**

For any other type of voice message to be played in a wait queue, create a script to play it.

**Procedure**

1. Click **Messages and Scripts**.
2. Click **Scripts**.
   
   The Scripts pane appears.
3. Click **New**.
   
   The Script Wizard appears.
4. Click **Next**.
5. Select **Outbound** from the available list.
6. Click **Next**.
7. Click **Next**.
8. In Add an action page, under the What do you want to do? message, select **Play a record specific message**.
9. From the **List name** drop-down list, select the calling list to which you added the Record Specific Messaging feature.
10. From the **Version** drop-down list, select the version of the calling list that you want to use.
11. From the RSM Fields drop-down list, select the appropriate Record Specific Message field name that was provided during Configuring Record Specific Messages.

   **Note:**

   You can optionally select the **Default message to play**. When you select this option, the table below the option gets activated. The message that you select from this table will override the default message provided in the Calling List RSM Map.

12. Click **Next**.
13. In the Selecting how to handle calls answered by a machine page, you have the option to select **Yes** or **No**.
If you select **Yes**:

a. In Add an action page, under the What do you want to do? message, select Play a record specific message.

b. From the List name drop-down list, select the calling list to which you added the Record Specific Messaging feature.

c. From the Version drop-down list, select the version of the calling list that you want to use.

d. From the RSM Fields drop-down, select the appropriate Record Specific Message field name that was provided during Configuring Record Specific Messages.

e. You can optionally select **Default message to play**. When you select this option, the table below the option gets activated. The message that you select from this table will override the default message provided in the Calling List RSM Map. For more details see Record Specific Messaging.

If you select **No**:

14. Click **Next**.

15. In Selecting message to play before passing call to agent or into wait queue page, you have the option to select **Yes** or **No**.

   If you select **Yes**:

   a. In Add an action page, under the What do you want to do? message, select Play a message.

   b. Under Select a message to play, select a message to be played, and click **Next**.

   If you select **No**:

16. Name the script, for example, Play_RSM, and then type a brief description of the script.

17. Click **Next**.

18. Click **Finish**.

19. On the Detail tab on the right, your new script appears.

   At this point, the script, for example, Play_RSM is available for use in any job using your calling list.

20. To assign the script to a job:

   a. Click **Contact Management**.

   b. Click **Jobs**.

   c. Select an outbound job.

   d. In the Job Detail pane, under Labels, locate the **Script label to use for making call**.

   e. From the drop-down list, select **Play_RSM1**.

   f. Click **Save**.
**Related links**

[Record Specific Messaging](#) on page 161

---

**Automatic Number Identification (ANI)**

Earlier Automatic Number Identification functionality was only limited to the Hard Dialer. In this release, ANI outpulsing is supported in both Soft and Hard dialer.

ANI is commonly referred to as Caller ID and it is a configuration setting of the phone number sent done only for the system. The ANI values can be defined on a job or on a record basis. As a result, different ANI can be outpulsed for different jobs and for different records within a job.

In case of Job specific ANI, you are required to specify the Calling Party Number (ANI) for each of the jobs. As a result, different ANI could be outpulsed for different jobs.

In case of Record Specific ANI, you are required to specify Calling Party Number (AN) by record. As a result, different ANI could be outpulsed for different records within a job.

The Automated Number Identification allows you to select a field in the calling list that contains ANI values and to use those values during calling. As each record is called, the value in the defined field is outpulsed for ANI.

For example, a call center performing a survey of existing customers might want to use different ANI values for customers with different service agreements. During calling list download, you can set a translation using the Editor application for setting up the ANI values for dialer depending on the host data.

If you want to setup ANI depending on the host data in `SERVICE_PLAN` field and the `SERVICE_PLAN` field is set to GOLD, then this can be translated to the value 4259999999 written to the `SERVICE_PLAN` field. Through the Translate option in Download from Host > Map > Transformation, you can translate GOLD to the value 4259999999. You can select Unmapped field as `SERVICE_PLAN`, add GOLD in the Host Data field, and the value 4259999999 in the Dialer Data field. As a result, wherever the `SERVICE_PLAN` field is set to GOLD, it is translated to the value 4259999999.

**Note:**

Dialer sends only digits for the representation of ANI. The system removes any other non-digit character that might be included in the ANI information through the Calling list field or Calling party Number (ANI) field of the job. Using Editor, you can provide a maximum of 15 digits for the representation of ANI.

Similarly, if `SERVICE_PLAN` is set to SILVER, then the system can translate this string to the value 4259991000, which is written to the `SERVICE_PLAN` field.

If a calling list is prepared in this manner, the call center supervisor can create a job using this list and set the Calling party number by record (ANI) field to `SERVICE_PLAN` as described in the given example or a field that has ANI information. During dialing, each customer can see a calling party number based on the field.
Note:

You must not download a net new list, while a job is running on the same list.

Avaya Proactive Contact Release 5.1.2 enhances the Opt-out to VDN feature so that the TRANSID feature works with a virtual job to allow one of the calling lists field data to be transferred as ANI to the agent. This feature is available only for Avaya Proactive Contact with PG230.
Chapter 12: Completion Codes

Completion Codes is a tool that helps you create, categorize, and maintain completion codes. The changes you make are available the next time the dialers restart.

A completion code identifies the result of a phone call. Either the system or an agent assigns a completion code to each phone call. The system uses completion codes to select records for placing calls, to monitor calling activities, and to select records for reports.

In the default tenant, you can use all the completion codes available on dialer. The maximum limit of completion codes is 999. In a multitenancy environment, you can view and edit only those completion codes that are assigned to your tenant space by the Lead Administrator at the time of creating the tenant.

The system assigns a completion code when the dialer does not pass the phone call to an agent. The only successful call attempts that the system identifies are during Virtual jobs.

An agent assigns a completion code based on the result of a phone call that the dialer passed to the agent.

Examples of completion codes that the system can assign include the following codes:

<table>
<thead>
<tr>
<th>Completion code</th>
<th>Description to show when the system can assign the completion code</th>
</tr>
</thead>
<tbody>
<tr>
<td>BUSY</td>
<td>when the dialer detects a busy signal.</td>
</tr>
<tr>
<td>SIT</td>
<td>when the dialer detects a Special Information Tone that identifies a disconnected number or busy circuits.</td>
</tr>
<tr>
<td>NOANSWER</td>
<td>when a party does not answer the phone call within the specified time number of rings.</td>
</tr>
</tbody>
</table>

Examples of completion codes that agents can assign include the following codes:

<table>
<thead>
<tr>
<th>Completion code</th>
<th>Description to show when the agents can assign the completion code</th>
</tr>
</thead>
<tbody>
<tr>
<td>RECALL</td>
<td>to tell the dialer to place the phone call at a later time.</td>
</tr>
</tbody>
</table>

Table continues...
Completion Code attributes

Proactive Contact assigns a number to each completion code and specifies whether the system or agents assign the completion code. A dialer has 1000 completion codes.

A completion code has the following attributes:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Keyword</td>
<td>Identifies the short name for the completion code.</td>
</tr>
<tr>
<td>Code</td>
<td>Identifies the assigned number for the completion code. The code numbers range from 0 through 999</td>
</tr>
<tr>
<td>Description</td>
<td>Provides a brief description of the completion code.</td>
</tr>
<tr>
<td>Type</td>
<td>Identifies whether the system or an agent assigns the completion code</td>
</tr>
<tr>
<td>Report Header</td>
<td>Identifies the title for the completion code column in the Completion Code Summary report.</td>
</tr>
</tbody>
</table>

You can create the description and report header for the completion codes that agents assign.

You can change the description and report header for the completion codes that agents and the system assign.

You cannot, however, change the code keyword, number, and type for completion codes that agents and the system assign.

Completion Code examples

The following table provides several examples of completion codes:

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Code</th>
<th>Description</th>
<th>Type</th>
<th>Report Header</th>
</tr>
</thead>
<tbody>
<tr>
<td>RESERVED1</td>
<td>001</td>
<td>Reserved for the system.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>NOTINZONE</td>
<td>005</td>
<td>The local time for the customer phone is outside the legal hours to place calls.</td>
<td>System</td>
<td>Not within legal hours</td>
</tr>
</tbody>
</table>

Table continues…
Completion Codes

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Code</th>
<th>Description</th>
<th>Type</th>
<th>Report Header</th>
</tr>
</thead>
<tbody>
<tr>
<td>MOFLASH_B</td>
<td>006</td>
<td>Native voice and data transfer: Agent transfers call to inbound agent without</td>
<td>Agent</td>
<td>Blind transfer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>remaining on the line.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>TRANSFER</td>
<td>018</td>
<td>Transfer release.</td>
<td>Agent</td>
<td>Transferred</td>
</tr>
<tr>
<td>CODE32</td>
<td>032</td>
<td>Schedule appointment, then call</td>
<td>Agent</td>
<td>SchdCall</td>
</tr>
<tr>
<td>DTMF_V</td>
<td>044</td>
<td>Internal system code.</td>
<td>System</td>
<td>Voice DTMF</td>
</tr>
<tr>
<td>VIRTVOICE</td>
<td>091</td>
<td>Virtual voice message to Voice</td>
<td>Agent</td>
<td>Virtual Voice</td>
</tr>
</tbody>
</table>

**Completion Code categories**

During a job, agents assign a completion code to a phone call to indicate the result of a call. In Completion Code menu, you can organize completion codes into four categories for monitoring and reporting purposes.

**Tip:**

You can associate a completion code with more than one category.

For example, an agent placed a call to confirm an order and left a message on the answering machine. The job is set up to pass phone calls that are answered by an answering machine to agents. The agent assigned the answering machine completion code to the customer record. The answering machine completion code can belong to both the Right Party Contacts and Closures categories.

<table>
<thead>
<tr>
<th>Completion code category</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Right Party Contacts (RPCs)</td>
<td>Indicates that the agent talked with the correct party.</td>
</tr>
<tr>
<td>Closures</td>
<td>Indicates that the agent talked with a party and completed the purpose of the phone call. A closure can represent a variety of outcomes,</td>
</tr>
<tr>
<td></td>
<td>including the following examples:</td>
</tr>
<tr>
<td></td>
<td>• Balance paid in full</td>
</tr>
<tr>
<td></td>
<td>• Bankruptcy</td>
</tr>
<tr>
<td></td>
<td>• Deceased</td>
</tr>
<tr>
<td></td>
<td>• Sale verified and completed</td>
</tr>
<tr>
<td>Abandons</td>
<td>Indicates that a phone call was abandoned and the dialer disconnected the phone call. An abandon can be result of several events, including</td>
</tr>
<tr>
<td></td>
<td>the following examples:</td>
</tr>
<tr>
<td></td>
<td>• A customer who placed a call to the call center hung up while in the inbound wait queue.</td>
</tr>
</tbody>
</table>

Table continues…
### Completion code category

<table>
<thead>
<tr>
<th>Completion code category</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• A customer hung up while in the outbound wait queue.</td>
</tr>
<tr>
<td></td>
<td>• A phone call that was held in wait queue for the maximum time allowed.</td>
</tr>
<tr>
<td>Recalls</td>
<td>Indicates that the phone call did not connect to a customer and that another phone call attempt can be made. The dialer places another phone call to the customer based on the settings you define on the Retries tab in Strategies.</td>
</tr>
</tbody>
</table>

**Related links**

- [Retries](#) on page 199

---

**Multi-dialer environment**

In Completion Code menu, you can create and change the completion code description and report header text for completion codes that agents assign. You can also assign completion codes to categories.

If your system uses multiple dialers, the completion codes that you create and change in Completion Code menu belong to the primary dialer. When you save the codes in Completion Code menu, Proactive Contact saves the changes to each dialer in the pod. This process ensures a consistent set of codes for reporting and monitoring.

**Completion Code window**

Using the Completion Code window, you can create, categorize, and maintain completion codes for monitoring and reporting activities. You can do the following tasks:

- View the system and agent assigned completion codes.
- Create and maintain completion codes that agents can assign.
- Assign completion codes to categories for monitor and reporting activities.

The changes you make are available the next time the dialers restart.

**Completion Code window Right-hand pane**

The right-hand pane of the Completion Code window contains a complete list of completion codes for the dialer. For each code, Completion Code lists the keyword, code number, description, whether the system or agent assigns the completion code, and the report column text.
Tip:
You can use the right-click menu in the right-hand pane to select menu options that are available on the Edit and View menus.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RPCs (Right Party Contacts)</td>
<td>This category specifies that the person contacted was the appropriate person to talk with.</td>
</tr>
<tr>
<td>Closures</td>
<td>This category indicates that some form of closure was reached with the contacted party.</td>
</tr>
<tr>
<td>Abandon</td>
<td>This category indicates that the system abandoned the call after connecting with a person at the called number.</td>
</tr>
<tr>
<td>Recall</td>
<td>This category indicates whether this completion code can be used to specify that a record can be recalled.</td>
</tr>
</tbody>
</table>

Accessing Completion Codes

About this task
The Completion Codes menu is available from the View menu.

Note:
The changes you make in Completion Codes are available the next time the dialers restart.

To start Completion Codes:

Procedure
1. Click Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor.
2. Select Completion Codes.
   The Version dialog appears.
   Select the version that you want to edit. The default is the Active version.

Creating a completion code

About this task
You can assign a code to the Right Party Contact and Closure categories, and include the code in the Completion Codes Summary report.

Later, you can assign the completion code to the Abandon and Recall categories. You can also change the description and report header text directly on the right-hand pane.
Procedure

1. Right-click a strategy and click **New** or click the **New** icon on the toolbar.
   The Completion Code Wizard window opens.

2. Complete the wizard by defining the new code, setting attributes for the code, and verifying the new code entities.

Related links

- Changing a completion code on page 172
- Assigning a completion code to a category on page 172

Assigning a completion code to a category

About this task

You can assign a completion code to the following categories:

- Right Party Contacts (RPCs)
- Closures
- Abandons
- Recalls

To assign a completion code to a category from the list of completion codes in the right-hand pane:

Procedure

1. Select one or more completion codes.
2. Select the specific option from the available category.
3. Click **Save**.
   The Completion Code Manager dialog box is displayed.
4. In case of Active completion codes, you can click **Yes** to save a copy in a different stage. Otherwise, click **No** to cancel.

⚠️ **Note:**

In case of Pending and In progress stages of completion codes, the system does not display the Save As dialog box to save the completion code in a different stage.

Proactive Contact saves the completion codes on each dialer in a pod.
Maintaining completion codes

Assigning a completion code to a category

About this task
To remove a completion code from the following categories:
- Right Party Contact
- Closure
- Abandon
- Recall

Procedure
1. From the list of completion codes in the right-hand pane, select the completion code that you want to remove from the category.
2. Clear the check box corresponding to the category for the required completion code.
3. Click Save.
   The system displays the Completion Code Manager dialog box.
4. For Active completion codes:
   - To save a copy in a different stage, click Yes.
   - To cancel, click No.

*Note:*
In case of Pending and In progress stages of completion codes, the system does not display the Save as dialog box to save the completion code in a different stage.

Result
Avaya Proactive Contact saves the completion codes on each dialer in a pod.

Changing a completion code

About this task
To change a completion code description and report header text:

Procedure
1. From the list of completion codes in the right-hand pane of the window, select the completion code that you want to change.
2. Right-click and select Change Description or Change Report Header.
3. Type the new description or report header text, and then press Enter.

**Tip:**

The report column width is limited to 23 characters in length. You can adjust the text until the report meets your requirements.

Completion Code displays the new information.

---

### Deleting a completion code

**About this task**

To delete a completion code from the system:

**Procedure**

1. From the list of completion codes in the right-hand pane, select the completion code that you want to delete.
2. Right-click and select **Remove**. The Delete confirmation dialog box is displayed.
3. Click **OK** to remove the completion code from the list of completion codes.

---

### Filtering the completion codes to view

**About this task**

You can view system completion codes, agent completion codes, or all completion codes.

To view the required set of completion codes:

**Procedure**

1. Go to **View > Completion Codes**.
2. Select the required category of completion code.

   The right pane displays the list of the specified type of the completion codes.

   Alternatively, you can right-click on the right pane and select the required type of the completion codes.

---

### Saving the completion code information to a file

**About this task**

Use this procedure to save the completion code attributes and category information to an HTML file.
Completion Codes

**Procedure**

1. Select **File > Save as HTML**.
2. In the Save As dialog box, browse to the location where you want to save the Completion Code Configuration file.
   
   You can change the name of the file.
3. Click **Save**.
   
   You can choose to view the saved report.
Chapter 13: Agent Keys

Agent Keys perform actions that are available on your system, such as releasing a call, transferring a call, displaying an agent screen, and logging an agent out of a job.

Note:

You can view only those agent keys that are assigned to your tenant space.

The Agent Keys display a list of agent keys files, including the name of the file, the type, the file version, and a brief description. Use the Agent Keys wizard to add or edit keys to meet the changing needs of your contact center. Agent keys are F1 through F12, depending on the type of keyboard. In addition to the function keys, you can assign key combinations to increase the number of available keys. For example, the agent can press the Ctrl, Shift or the Alt key while pressing the function key.

The Agent Keys feature helps you to modify an existing calling list, create a new Agent Key Set, and select Job features, as explained in detail in the subsequent sections.

Related links

Supported features on page 175

Supported features

The Supported Features Page in the Agent Keys Set Wizard allows the user to select the job features that you want to support in this agent key set. The job features that allow the agent to perform specific functions are listed as follows:

- Managed Dialing: This job feature allows agents to preview account information and cancel calls before they are made. You can specify the keys needed to support the agent to control the pace and outcome of managed dialing. Specifically, when an agent is previewing a record, the agent can choose to cancel the call and move to the next record or the agent can dial the record immediately.

- Sales Verification: This job feature automatically creates a second calling campaign to confirm sales or commitments obtained in a prior campaign. This also allows you to choose the keys needed to support a sales job in a sales verification scenario. When Sales Verification is used, agents use a specific code to release records that resulted in a successful sale. These records are automatically fed to a second verification job. In this job, each record is called and a supervisor verifies that the person at the other end of the line agrees to a sale.
• Native Voice and Data Transfer: This job feature allows you to define the keystrokes for transferring a call to another agent or to a supervisor. One keystroke will immediately transfer the call and allow the agent to receive a new call. The other keystroke allows the agent to stay on the line with the customers until the other agent answers.

• Do Not Call: This job feature allows you to choose the keys needed to support the Do Not Call feature. When an agent uses the defined key combination, the record is released and marked as Do Not Call. This will prevent the dialer from calling the customer at this number for any reason in the future.

• Agent owned recall: This job feature allows you to define the keystrokes for scheduling an agent owned recall as well as the keystrokes for releasing such a record. Note that this feature is different from the feature that simply allows an agent to set up a record to be recalled at another time and to be delivered to any available agent. In this feature, the recalled record is connected to the specific agent who set the recall.

**Supported actions**

Apart from the supported features defined in the Agent Keys Set Wizard, you can also define agent keys for the job functions defined in the following table:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust headset volume</td>
<td>Increases or decreases the headset volume. This feature only works if the</td>
</tr>
<tr>
<td></td>
<td>following conditions are fulfilled:</td>
</tr>
<tr>
<td></td>
<td>• Proactive Contact with PG230RM</td>
</tr>
<tr>
<td></td>
<td>• OLIC cards used for Agent headsets</td>
</tr>
<tr>
<td></td>
<td>This feature is not available if you are running Proactive Contact Agent in</td>
</tr>
<tr>
<td></td>
<td>the soft dialer mode.</td>
</tr>
<tr>
<td>Adjust microphone volume</td>
<td>Increases or decreases the microphone volume. This feature only works if</td>
</tr>
<tr>
<td></td>
<td>the following conditions are fulfilled:</td>
</tr>
<tr>
<td></td>
<td>• Proactive Contact with PG230RM</td>
</tr>
<tr>
<td></td>
<td>• OLIC cards used for Agent headsets</td>
</tr>
<tr>
<td></td>
<td>This feature is not available if you are running Proactive Contact Agent in</td>
</tr>
<tr>
<td></td>
<td>the soft dialer mode.</td>
</tr>
<tr>
<td>Ask Supervisor for help</td>
<td>Send an agent's message for assistance to the supervisor on Jobmon.</td>
</tr>
<tr>
<td>Cancel previewed call</td>
<td>Cancels the previewed call. You can configure multiple cancel keys in the</td>
</tr>
<tr>
<td></td>
<td>agent command key file. When an agent cancels a managed call during the</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>preview mode, a new screen is displayed</td>
<td>with a list of Cancel keys, if you have configured more than one cancel key in the agent command key file. The agent can select from the list and the record is then released with the appropriate completion code.</td>
</tr>
<tr>
<td>Dial the number in the selected field</td>
<td>Dials the number that is displayed in the field selected by the agent.</td>
</tr>
<tr>
<td>Display key pad</td>
<td>Enables the key pad to be used by agents.</td>
</tr>
<tr>
<td>Hangup a manual call</td>
<td>Terminates a manual call.</td>
</tr>
<tr>
<td>Leave a job</td>
<td>Enables the agents to leave a job.</td>
</tr>
<tr>
<td>Mark the record as Do Not Call</td>
<td>Marks the selected record as do not call.</td>
</tr>
<tr>
<td>Move to first field</td>
<td>Moves the cursor to the first field of the record.</td>
</tr>
<tr>
<td>Move to the next screen</td>
<td>Moves to the next screen.</td>
</tr>
<tr>
<td>Place a manual call</td>
<td>Places a manual call.</td>
</tr>
<tr>
<td>Place call on hold</td>
<td>Places the call on hold.</td>
</tr>
<tr>
<td>Place previewed call</td>
<td>Calls up the previewed record.</td>
</tr>
<tr>
<td>Quick release the line</td>
<td>Quick releases the line.</td>
</tr>
<tr>
<td>Release the line</td>
<td>Releases the line.</td>
</tr>
<tr>
<td>Release the record</td>
<td>Releases the record.</td>
</tr>
<tr>
<td>Schedule a callback</td>
<td>Schedules a callback for the record.</td>
</tr>
<tr>
<td>Take call off hold</td>
<td>Takes the call off from the hold position.</td>
</tr>
<tr>
<td>Transfer a call and release the line</td>
<td>Transfers the call and releases the line simultaneously.</td>
</tr>
<tr>
<td>Transfer a call and stay on the line</td>
<td>Transfers the call but stays on the line.</td>
</tr>
<tr>
<td>Transfer a call using hookflash and stay on the line</td>
<td>Transfers the call using hookflash but stays on the line</td>
</tr>
<tr>
<td>Important: You must not assign both hookflash and transfer trunk agent keys in the same agent key set as it might result in system failure.</td>
<td></td>
</tr>
<tr>
<td>Transfer trunks</td>
<td>Transfers the call using Transfer trunk. You must use the transfer trunk agent keys for Transfer trunks.</td>
</tr>
<tr>
<td>Important: You must not assign both hookflash and transfer trunk agent keys in the same agent key set as it might result in system failure.</td>
<td></td>
</tr>
</tbody>
</table>
Agent Keys

The Agent Keys window displays the names of all agent key sets defined on the selected dialer. You can view the individual key assignments defined in the agent keys set by selecting a key set in the Features Pane. The window displays the key assignments in the Feature Detail pane on the right.

When the user clicks the Agent Keys icon in the Button Bar, the application requests a list of the agent key files or sets from the selected dialer and displays the agent key files or sets in the Features pane.

★ Note:

The Proactive Contact Agent does not accept all key assignments entered in a key file. If you are using the Proactive Contact Agent, then the system accepts key assignments related to only release codes and automated messages.

You can display the individual key assignments defined in the agent key set by selecting a key set in the Features pane. The window displays the key assignments in the Feature Detail pane on the right.

Creating a new agent key set

About this task

To create a new agent key set:

Procedure

1. In the Editor button bar, select **New**.
   
   The system displays the New Agent Keys Wizard.

2. Click **Next**.

3. Enter a name for the Agent Key set.

4. Enter a brief description for the Agent Key set.
   
   ★ Note:

   The description field has a restriction of 64 characters. You cannot use special characters.

5. Click **Next**.

6. Select **Type of Job** that will use this Agent Key set.
   
   ★ Note:

   If you select the Any Type of Job option, continue from Step 7 to Step 10.

7. Click **Next**.
8. On the Supported Features page, select the check boxes that are relevant to the new agent key set that you are defining.

9. Click Next.

10. Click Finish.

The Agent Keys screen displays the names of all agent keys sets defined on the selected dialer.

---

### Adding actions to an agent key set

**About this task**

You can modify an agent key set for various features other than the ones specified in the New Agent Keys Wizard.

To assign agent keys to various other job operations:

**Procedure**

1. In the Agent Key Details pane, select a row, and then right-click and select **Insert** or **Append**.

   The Insert option inserts a row below the selected row, whereas the Append option adds a row at the end of the existing rows.

2. Select the required options from the following drop-down lists:
   
   - **Level**: Select from the options: Ctrl, Alt, and Shift.
   
   - **Key**: Select the required function key.
   
   - **Description**: Enter a description for the agent key manually.
   
   - **Action**: Select from the list of available actions.
   
   - **Completion Code**: Select the required completion code for the action associated with the agent key.
   
   - **Message (Optional)**: Select the recorded message to be played for the action associated with the agent key.
   
   - **Screen number**: Specify the screen number as configured in the Job that you want to gain access to upon pressing the key.

**Related links**

- [Supported actions](#) on page 176

---

### Versions

The Version feature allows you to set privileges.
For example: a user with sysadm privileges has the ability to create and edit configuration data in each of the defined versions, such as Active, Pending, and In Progress. You can gain access to the configuration data in various stages in different ways, depending on the type of the configuration data.

**Note:**

Deleted is also a version

For the data that is always saved to the same file, such as completion codes, schedules, telephony scripts, and voice messages, the system displays a message when you try to edit the data. This message gives you the option of choosing the version that exists in any of the stages.

---

### Version Data

If you have sysadm privileges, you can use data that is Pending or In Progress during the configuration of another type of file. For example, you may want to create a calling list application with upload configuration that depends on a completion code that is Pending. Change this, if you want to create a new telephony script with a voice message that is Pending.

If there are configuration changes in Pending or In Progress, the Configuration Version dialog box appears, the first time you attempt to edit a file. In the example, the Save As dialog box appears as soon as you select **New** on the **Calling List** menu.

When you select a version, the configuration data associated with that version is used throughout the editing session. If, for example, you choose to use completion code definitions that are in Pending, the Pending completion codes are loaded into the application and are used in all cases where the user interface offers you a choice of codes.

Once you have chosen a configuration version, the same will remain active until the application is closed or until you choose to change the configuration version by selecting **Options > Configuration Version** from the main menu.

---

### Save Version Data

The configuration data can be saved to the dialer and immediately become active; it may be saved to a Pending directory and will not become active until dialer services are restarted; or it may be saved indefinitely to an In Progress directory.

This feature, the ability to save data based on its state of readiness or completeness, is implemented through the UI by displaying a message to the user to specify the state when the data is saved.
Deleted Configuration Files

To work with deleted files, you can recover the files that are placed in special directories and may be available for retrieval by users with sysadm privileges. These files are listed in the Versions dialog and in the Features pane. To work with these files, you must open the file in Deleted, then save the file into another version, either Pending or In Progress.
Chapter 14: Messages and scripts

Messages are the recordings that are played to customers when they are on hold, waiting for an agent, or when an agent plays a message. Scripts are a series of messages that customers hear in the inbound, outbound, and transfer wait queues.

Messages provide the following functions:

- Assure customers that their calls remain connected
- Prepare customers for the upcoming transaction, asking them to have credit cards and order numbers ready
- Answer frequently asked questions
- Promote the business
- Advertise new products and services

You can create messages and scripts if you have administrative privileges. The Messages and Scripts button bar appears in the left-hand pane of Editor.

Note:
You can view only those messages and scripts that are assigned to your tenant space.

Messages

Messages are the recordings that are played to customers when they are on hold, waiting for an agent, or when an agent plays a message.

On Proactive Contact with PG230RM, your recorded voice messages must be digitized for Proactive Contact to use them. You choose message files when you set up jobs on the system. Later you can add and remove the messages.

Proactive Contact provides a wizard to help you add messages to the system and organize them in folders.

Later you can add and remove the messages and folders.
Plan messages

In Proactive Contact, you can store up to 2048 digitized messages. Each message can be up to one minute in duration. Proactive Contact can store up to 32 minutes of recorded messages.

Before you record and digitize messages, it is helpful to compose and print the message text. Consider the following times before you create a message:

- The purpose and use of the message
- The message text
- The male or female voice that delivers the message
- The current number of messages stored in Proactive Contact
- The category that best identifies the use for the message
- The languages that deliver the message

Telephony file

The telephny.spt files stores scripts. The telephny.spt file on the dialer cannot exceed 6000 lines.

Important:

If the number of lines exceeds 6000, you receive an error. You cannot save scripts when the number of lines exceeds 6000.

If the number of lines exceeds 6000, Proactive Contact might do one of the following:

- Not start jobs
- Start jobs but not deliver messages beyond line 6000

Reducing the number of lines from the telephony file

Procedure

To reduce the number of lines in the telephny.spt file, do one or more of the following:

- Remove scripts and messages that you no longer use.
- Contact your Proactive Contact vendor for assistance.

Recording messages

About this task

Before you use Messages Wizard, you must define, record, and digitize audio messages.
Procedure

1. For the Proactive Contact and Proactive Contact with PG230RM systems, perform one of the following steps to record messages:
   • Record the audio messages yourself and have a third party to digitize the messages.
   • Use a service bureau to record and digitize the message.
   • Use third party software that records and digitizes the messages.

   Note:
   For the Proactive Contact with Application Enablement Services, the ACD stores the recorded messages. Refer to the ACD documentation for information on recording voice messages.

2. Save the audio file to a location that is readily accessible to the supervisor workstation.
   From the workstation, you can assign the digitized audio to a message file in Editor and to a dialer.

Define and create message text

Messages Wizard helps you complete the following tasks in Proactive Contact:
   • Add audio messages to Proactive Contact with PG230RM systems.
   • Update existing messages on Proactive Contact with PG230RM systems.
   • Identify details about the message, such as is it a male voice, female voice, or music.

Although it is not mandatory, most companies have a written record of the message text.

Message Wizard

Message Wizard is available to help you do the following tasks:
   • Add a message.
   • Add an updated audio portion of a message to Proactive Contact.
   • Store these messages in folders for gaining easy access.

Messages pane

The Messages pane provides a means to add and maintain the messages that customers hear.
Editor displays a tree view that contains folders for script names and descriptions.

- If messages do not display, click the plus symbol to the left of the message name.
- If a plus symbol does not display, there are no messages assigned to the category.

**Important:**

You use the right-click menu in the right-hand pane to change, or remove messages and folders.

---

### Accessing messages

**About this task**

You start Messages from Editor if you have administrative privileges.

**Procedure**

1. Click **Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor**.
2. Log in to the Editor application.
3. Click the **Messages and Scripts** button group.
4. Click **Messages**
   
   The Messages window appears.

---

### Creating message folders

**About this task**

You can create one or more folders to organize messages.

**Procedure**

1. Click **Messages**.
   
   The Messages pane appears.
2. In the right-hand pane, right-click and select **New > Folder**.
   
   Editor adds a folder in the messages tree and selects the row.
3. Right-click the row and select **Rename Folder**.
   
   The Rename Folder dialog box appears.
4. In the **New Name** field, type a name for the folder and click **OK**.
Adding or updating messages

About this task

Messages Wizard helps you add a message or update the audio portion of an existing message to the system.

Procedure

1. Click **Messages**.
   The Messages pane appears.

2. Select a folder or a message in the Messages pane.

3. Click **File > New**.

   Note:
   You can use Microsoft Sound Editor or another appropriate sound editor tool to save the voice message file. You should save it using the following format options:- CCITT U-Law (Mu-Law) - 8K Sample (Hz) - 8-bit - Mono Save the file as <filename>.au in any convenient file directory.

Editor opens the Messages Wizard. You can define the following information:

- Location of the audio file
- File name
- Type of message: voice or music, and male or female voice
- Description of the message text
- Folder to store the message

4. Complete the wizard instructions to add or update audio message files to the system.

   Use a maximum of eight characters for the file name and three characters for the file extension. When you name the file in the wizard, use a name that clearly identifies the type of message. For example, fwait1 can identify the first female message played in a wait queue. Inmwait1 can identify the first male message playing in an inbound wait queue.

   Note:
   While updating the audio message file, do not change the name of the audio message file. If you update an audio message file using a different name, the system displays the following warning message: This message may be used by jobs or agent keys which will not function correctly if the name is changed. Are you sure you want to continue?

   Click **Yes** if you still want to continue with the update.

   Editor adds the message to the Messages folder.

5. Click **File > Save**.
Editor opens the Message Script Wizard window.

---

### Verifying a message

**Procedure**

1. Click **Messages**.
   
   The Messages pane appears.
2. Select a folder or a message in the Messages pane.
3. Select **File > Verify**.
   
   Editor opens the Results dialog box.
4. Click **OK**.

---

### Removing a message

**About this task**

Before you remove a message, verify that a script does not use the message.

To remove a message from the Messages pane:

**Procedure**

1. Click **Messages**.
   
   The Messages pane appears.
2. Click the plus sign to expand the folder that contains the message.
3. Select a message.
   
   Editor selects the row.
4. Right-click the row and select **Remove**.
   
   The Delete dialog box lists the selected message.
5. Verify that the message is the one you want to remove and click **OK**.
   
   Editor removes the message from the folder. Editor deletes the message when you save messages.

---

### Renaming a message folder

**About this task**

You can rename a folder to organize messages.

To rename a folder:
Procedure

1. Click **Messages**.
   The Messages pane appears.
2. Select a message.
   Editor selects the row.
3. Right-click the row and select **Rename Folder**.
   The Rename Folder dialog box appears.
4. In the **New Name** field, enter a name for the folder and click **OK**.

---

Removing a folder

**About this task**
You can remove an empty folder from the Messages pane.

To remove a folder:

**Procedure**

1. Click **Messages**.
   The Messages pane appears.
2. Click the plus sign to expand the folder you want to remove.
3. Remove each message from the folder.
   For more information, see [Removing a message](#) on page 187.
4. Select a message.
   Editor selects the row.
5. Right-click the row and select **Remove Folder**.
   Editor removes the folder.

**Related links**

[Removing a message](#) on page 187

---

Scripts

Scripts define how customers hear messages during the following occasions:

- While waiting in inbound, outbound, or transfer queues
- When customers answer a call placed by a virtual agent
• When an agent presses a function key

You designate the order in which Proactive Contact plays messages. You can choose to play music or have silence between messages.

## Types of scripts

After you add messages to the system, you create scripts. To create a script, you must assign messages to a category when the script runs and also assign actions to messages.

The following table describes the script categories and when the scripts are run:

<table>
<thead>
<tr>
<th>Script</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automated Messages</td>
<td>Messages that agents play to customers when the agent presses any function key.</td>
</tr>
<tr>
<td>Inbound Wait Queue</td>
<td>Messages that the system plays to customers while waiting for an agent in inbound wait queues.</td>
</tr>
<tr>
<td>Outbound Wait Queue</td>
<td>Messages that the system plays to customers while waiting for an agent in outbound wait queues and or when an answering machines receives the call.</td>
</tr>
<tr>
<td>Transfer Wait Queue</td>
<td>Messages that the system plays to customers while waiting to be transferred.</td>
</tr>
<tr>
<td>Virtual Wait Queue</td>
<td>Messages that the system plays to customers during Virtual Agent jobs. A virtual agent job delivers messages without agent intervention.</td>
</tr>
</tbody>
</table>

## Script actions

Script actions define a script. Depending on the script you select in the Scripts left-hand pane, you can do the following when defining a script:

• Select to play the script when an answering machine or voice answers the phone call.

• Assign actions that play additional messages.

### Script actions field descriptions

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Play message</td>
<td>Plays a recorded message. You select the name of the message file. The file may contain voice or music.</td>
</tr>
<tr>
<td>Pause</td>
<td>Specifies how long to wait between messages in inbound, outbound or transfer wait queues. You select the amount of silent delay in seconds.</td>
</tr>
</tbody>
</table>
### Start Looping

Instructs the system to repeat the wait queue actions that follow in inbound, outbound or transfer wait queues. You must follow this command with a Play statement. When you set up a job, you can set the maximum time a caller can stay in the queue.

### Voice Response

Instructs the system to wait for a voice response in inbound or outbound wait queues. The dialer verifies that the person who placed or received the call is still on the line. If not, the system disconnects the line.

---

### Script examples

#### Outbound wait queue

The following example shows how you can combine messages in a script.

1. Hold the line please. I have a very important call for you from [company name].

   There is a 5 second pause after which the script starts looping. This loop begins with line four. The system repeats all lines below the start looping statement for the length of time listed in Editor.

2. Sorry to keep you waiting. I am still trying to connect.

   There is a 5 second pause.

3. Still trying, hold please.

   There is a 5 second pause.

4. Still trying to connect. Thank you for waiting.

   There is an 8 second pause.

#### Inbound wait queue

The following example shows how you can combine messages in a script.

1. Thank you for calling [company name]. A representative will be with you shortly.

   There is a 5 second pause.

2. Your call is important to us. Please hold for the next available representative.

   There is a 7 second pause.

3. Please continue to hold. A representative will be with you momentarily.

   There is a 7 second pause.
The script starts looping. This loop begins with line 4. The system repeats all lines below line 3 for the length of time listed in Jobs.

4. Thank you for waiting, please continue to hold.
The caller then listens to music.

Automated message

The following script consists of a single message that the system plays when an agent presses a function key.

Please call your sales representative for information about a special offer.

---

Scripts pane

The Scripts pane provides a means to create and maintain message scripts that play the messages customers hear.

The left-hand pane displays a tree view organizes script names and descriptions into categories of when the system runs the script.

- If scripts do not display, click the plus symbol to the left of the script name.
- If a plus symbol does not display, there are no scripts assigned to the category.

The right-hand pane appears when you select a script. The Detail tab lists the actions for the script. Depending on the when the script runs, you can assign actions that send a signal to Proactive Contact how to play messages.

Tip:

You can use the right-click menu in the right-hand pane to add, change, or remove actions.

---

Accessing Scripts

Procedure

1. Select Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor.
2. Click the Messages and Scripts button group.
3. Click Scripts.
   The Scripts pane appears.
Adding or updating scripts

About this task

Message Script Wizard helps you create and update a message script. Scripts define one or more messages that customers can hear.

⚠️ Important:

The changes you make to a script become available for use the next time you restart the dialer.

🌟 Note:

If you are adding, updating or defining a script for FCC opt-out, add at least 10 seconds of delay after the message is played, or to loop through the message several times. This allows the called party time to enter the digit before the wait queue ends. This delay time must be sufficient to play the confirmation message.

You can use the right-click menu in the right-hand pane to add, change, or remove actions.

Procedure

1. Click Scripts.
   The Scripts pane appears.
2. Click File > New.
   Editor opens the Message Script Wizard window.
3. Click File > New.
4. Complete the wizard instructions to add or update scripts to Avaya Proactive Contact.

🌟 Note:

In case of Avaya Proactive Contact with CTI, in the Message Script Wizard, the system does not provide the Before passing call to agent or into wait queue option for the automated and virtual scripts. In case of Avaya Proactive Contact with PG230RM, the Before passing call to agent or into wait queue option is available only for the outbound and virtual scripts.

📍 Tip:

There is a time limit that you can leave a file open for editing. Depending on your system configuration, the default value is 60 minutes. We recommend that you save each new script after you add or update the script.

5. Click File > Save.
   Editor opens the Message Script Wizard window.
Defining a script

About this task

When you define a script, you can assign one or more of the following actions to the script:

- Play a message
- Play an RSM
- Pause
- Start a loop
- Wait for a response

Note:

If you are adding, updating or defining a script for FCC opt-out, add at least 10 seconds of delay after the message is played, or to loop through the message several times. This allows the called party time to enter the digit before the wait queue ends. This delay time must be sufficient to play the confirmation message.

Procedure

1. Click Scripts.

   The Scripts pane appears.

2. Select a script in the left-hand pane.

   Depending on the script you select, you can play the script when an answering machine and voice answers the phone call.

3. Select one of the following:

   - If a machine answers...
   - While a person is waiting for an agent...

4. Right-click the response and select Add an Action.

   Tip:

   You can also select a location in the script, then drag and drop an action icon to a location in the script.

   Editor displays the Message Script Wizard.

5. Complete the wizard instructions to add an action to the script.

   Editor adds the action below the response. Depending on the script, you can select additional actions.
**Note:**

If the message is intended for playing message or music to the customer while on hold, you must select the Start a loop option. The Music on hold feature does not work without a loop.

6. To add another action to the response, repeat Step 5 or right-click and select **Add an Action**.

7. To add actions to the other response, repeat Steps 3, 4, and 5.

8. Click **File > Save**.

**Note:**

- To specify a message on the Message Script Wizard, select **Yes** for the Do you want to play a message automatically before passing call to agent or into wait queue option. The system indicates the selected message in the right-hand pane. Otherwise, the system displays the message **No message is selected to play message** in the Script Actions field.

- If you want to use the Autorelease agent to voice mail feature, then ensure that you do not select **Yes** for the Do you want to play a message automatically before passing call to agent or into wait queue option.

---

### Removing a script action

**About this task**

To remove an action from a script:

**Procedure**

1. Click **Scripts**.
   
   The **Scripts** pane appears.

2. Click the action you want to change.

3. Right-click the action and select **Remove an Action**.
   
   Editor removes the action from the response.

4. To remove actions for another response, repeat Steps 2 and 3.

5. Click **File > Save**.
   
   Editor opens the Message Script Wizard window.
Changing a script

About this task
You can change the name and description of a script.

To change a script:

Procedure
1. Click Scripts.
   The Scripts pane appears.
2. Select a script from a category.
3. Right-click and select Change.
   Editor opens the Message Script Wizard window.
4. Complete the wizard instructions to change the script.
5. Click File > Save.
   Editor opens the Message Script Wizard window.

Removing a script

About this task
You can remove a script that you or another person created. You cannot remove a script that is reserved by Avaya Proactive Contact.

To remove a script:

Procedure
1. Click Scripts.
   The Scripts pane appears.
2. Click the plus sign to expand the category that contains the message.
3. Select a script from a category.
   Editor selects the row.
4. Right-click the row and select Remove.
   Editor removes the script from the category.
## Messages and Scripts dialog boxes

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete dialog box</td>
<td>The Delete dialog box allows you to remove selected message from Avaya Proactive Contact.</td>
</tr>
<tr>
<td>Rename Folder dialog box</td>
<td>The Rename Folder dialog box allows you to name or give the folder another name.</td>
</tr>
</tbody>
</table>
Chapter 15: Phone strategy

Avaya Proactive Contact uses phone strategies during jobs to place phone calls to customers more effectively.

A phone strategy is a set of instructions that tells the system when and how to place calls to customers, which customer phone number to dial, and the frequency of calls.

The system receives and prepares the host data file and creates a calling list. The system places phone calls based on a phone strategy. The phone strategy specifies the phone numbers to dial during a job and how to place the calls.

In a multitenancy environment, you can create and view strategies only for the selected tenant in the tenant drop-down list on the button bar in the Editor.

Phone strategy preparation

The following are the values that you must identify before creating a new phone strategy.

- The phone number to call first
- The number of rings to allow before disconnecting the call
- The time to wait before retrying a phone number that was busy, unanswered, or disconnected
- The phone number to dial if the first phone number is not answered
- The number of times to retry a busy phone number
- The number of times to dial a phone number before switching to an alternate phone number
- The types of calls to pass to an agent when the dialer detects an answer

Wildcard expression

You can create wildcard expressions to define a range of values. Each wildcard expression specifies a wildcard character and a value. A value can be a number or a letter.

Wildcard characters include the following symbols:
### Wildcard character

<table>
<thead>
<tr>
<th>Wildcard character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>is equal to</td>
</tr>
<tr>
<td>&lt;&gt; or ~</td>
<td>is not equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>is greater than</td>
</tr>
<tr>
<td>&lt;</td>
<td>is less than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>is greater than or equal to</td>
</tr>
<tr>
<td>&lt;=</td>
<td>is less than or equal to</td>
</tr>
</tbody>
</table>

For more details refer to Pattern Matching Rules.

---

**Phone strategy settings**

**Related links**

- Detection Modes dialog box field descriptions on page 338
- Alternate Initial Phone tab field descriptions on page 201

---

**Initial phone**

The initial phone is the first phone number that the system uses to place a call for each record.

The system stores the phone numbers in the calling list phone fields, for example, PHONE1 and PHONE2. If a record does not match the phone criteria that you set, the system will not place a call.

The system classifies phone numbers by phone type and assigns a number to each type. For example, the home phone might be phone number 1 and the business phone number 2. The dialer phone type numbers are set during your system configuration.

For example, if your initial phone pane’s fields were as follows: Phone=1, Field= Name=PHONESTAT, and Value=~B?, the system would dial the number in the PHONE1 field for all records whose PHONESTAT field does not contain a “B”, or bad number.

---

**Alternate initial phone**

The alternate initial phone is the phone number that becomes the initial phone at a specified time of day. The alternate initial phone number also specifies the time the system starts dialing the alternate initial phone.

The system starts dialing the alternative initial phone based on the local time in the selected time zone. For example, you can tell the system to switch from dialing business phones, the initial phone, to dialing home phones, the alternate initial phone, at 6 PM.
Detection mode

The system uses the detection mode to identify how the phone number was answered. The system passes phone calls to agents based on the detection mode you specify. For example, a detection mode can be a live voice, an answering machine, or an operator intercept.

Number of Rings: Specify the number of rings to allow before the system records a NOANSWER completion code.

Pass to Agent: The detection mode tells the system which calls to pass to agents. When the system places a call, the system detects what type of answer occurs for each call and then decides whether or not to pass that call to an agent.

Retries

The system uses the retries setting to place another phone call for the same record.

The system applies the following criteria based on the result of the initial call:

- How long the system waits before dialing the number again
- How many times the system dials the same phone number
- Which phone number the system dials next

For example, you can tell the system to retry the call in 15 minutes when the initial call result is busy and to stop dialing that phone number if there is no answer after three retries.

**Note:**
Retries are bound to a campaign. Hence, the system stops retries after a job ends.

**Tip:**
It is important to understand the difference between a system retry and a customer recall.

- A system retry is a computer generated phone call attempt. If the system detects a busy signal on the first call attempt, the system dials the phone number based on the retry parameters in the phone strategy.
- Agents set up customer recalls. An agent can set either an Agent Owned Recall or a general recall. For an agent owned recall, the system routes the phone call to the agent who set the phone call. For a general recall, the system dials the phone number and routes the phone call to any available agent.
Creating a phone strategy

Procedure

1. Click Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor.

2. (Optional) If required, log in to Editor.

3. From the drop-down list, select the dialer where you want your phone strategy to reside.

   Tip:
   You can save the phone strategy to other dialers or delete the phone strategy from this dialer at a later time.

4. Click Strategy on the button group.

5. Click File > New.

6. On Detail tab, select a calling list.

7. Click File > Save.

   a. In the Save As dialog box, select another dialer if you want to save the phone strategy to a different dialer.

   b. Enter a file name for your strategy, and then click OK.

   Editor displays the phone strategy tabs in the right-hand pane.

8. Right-click the Initial Phone tab, click Append Row, and enter appropriate values in the fields.

9. (Optional) Right-click the Alternate Initial tab, click Append Row, and enter appropriate values in the fields.

10. On the Detection Mode tab, click the Number of Rings field and then use the list to select a number.

11. Select the check boxes to specify which types of calls to pass to agents.

   Note:
   If this strategy is associated with the virtual job that has a low value for the Number of Rings field, then the virtual job does not play a message to the answering machine. The recommended minimum value for the Number of Rings field is 3.

12. On the Retries tab, select the call results that the system will retry. For example, if the system detects a busy signal on the first call attempt, it will retry based on your Busy signal values on this pane.

   For each result you select, enter a value in the Retry Interval (minutes), Attempts, and Next Phone columns.

13. Click File > Save.

   a. In the Save As dialog box, select another dialer if you want to save the phone strategy to a different dialer.
b. Enter a file name for your strategy, and then click OK. Proactive Contact automatically saves the file to the selected dialer.

14. Click **File > Save.**

---

### Initial Phone tab field descriptions

The fields required on the Initial Phone tab include Phone, Field, and Value. The remaining three fields (Logic, Field, and Value) are optional and allow you to combine two statements together using a logic operator.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phone</td>
<td>Click this field to select a phone.</td>
</tr>
<tr>
<td>Field</td>
<td>Click this field to select one of the fields from your download to use base how the system selects phone numbers to place telephone calls.</td>
</tr>
<tr>
<td>Value</td>
<td>Use a value or a wildcard character. Values can be numbers, letters, dates, and times. For example, account balances consist of numbers, while customer names consist of letters.</td>
</tr>
</tbody>
</table>

### Alternate Initial Phone tab field descriptions

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>Click this field to specify the time that you want to switch from the initial phone to the alternate initial phone. The system bases the decision to switch phone numbers on the time in the time zone (not the system time).</td>
</tr>
<tr>
<td>Time Zone(s)</td>
<td>Select the appropriate time zone(s).</td>
</tr>
</tbody>
</table>

### Detection mode tab field descriptions

The following table describes the Detection Mode tab fields:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Voice</td>
<td>A person’s voice was detected</td>
</tr>
<tr>
<td>Autovoice</td>
<td>An answering machine was detected</td>
</tr>
<tr>
<td>Intercept</td>
<td>An operator intercepted the call</td>
</tr>
<tr>
<td>No circuit</td>
<td>No circuit was available</td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disconnect</td>
<td>Disconnected the phone call</td>
</tr>
<tr>
<td>Vacant</td>
<td>Vacant number</td>
</tr>
<tr>
<td>Reorder</td>
<td>Reorder</td>
</tr>
</tbody>
</table>

**Tip:**
To increase your hit rate, decide which detection modes to use. With each additional criterion you select, your agents can handle more calls rather than the system.

---

## Copying a phone strategy

**About this task**
You can copy a phone strategy to another dialer. If the multi-dialer is not enabled, enable the feature.

To copy a phone strategy do the following:

**Procedure**

1. Click the phone strategy you want to copy.
2. Click **File > Save As**.

   If multi-dialer is enabled, you can copy the strategy to additional dialers.
   a. In the Save As dialog box, select another dialer if you want to save the phone strategy to a different dialer.
   b. Enter a file name for your strategy, and then click **OK**.

Avaya Proactive Contact automatically copies the file to the selected dialer.

---

## Viewing phone strategy settings

**Procedure**

1. Click the phone strategy you want to open.
   The phone strategy settings appear in the right-hand pane.
2. To navigate through the phone strategy settings, click a tab.
Editing a phone strategy

About this task
Change phone strategy settings when doing so will help your system dial more efficiently. Changes take affect the next time a job that uses the strategy is started.

If you select a different calling list for a phone strategy, you might need to redefine certain phone strategy settings:

• If the newly selected calling list contains the same number of phone fields with the same field names as the original list, the system retains all the phone strategy settings.

• If the newly selected calling list has a different number of phones or the phone field names are different, the system retains the initial phone and alternate initial phone settings, but does not retain the original detection modes and retries settings.

To edit a phone strategy do the following:

Procedure
1. Click the phone strategy you want to edit.
2. Click a tab to make the necessary edits in the right-hand pane.
3. Click File > Save.
4. Click OK.

Deleting a phone strategy

Procedure
1. Click the phone strategy you want to delete.
2. Select File > Delete.
3. When asked if you really want to do this, click OK.
   If the multi-dialer option is enabled, the Multiple dialer command dialog box appears.
4. If the check boxes are grayed out, select Settings > Options to enable the multi-dialer settings.
   a. Click to clear the check boxes of the dialers from which you do not want to delete the strategy.
   b. Click OK.
Maintaining phone strategies

Viewing phone strategies on a dialer

Procedure
1. From the drop-down list, select the dialer for which you want to list the phone strategies.
2. Click Contact Management.
3. Click Strategies.

Appending a phone strategy row

About this task
Appending a row adds a row beneath the bottom row on the Initial Phone and Alternative Initial Phone tabs.

To append a row do the following:

Procedure
1. On the Editor button bar, click Contact Management.
2. Click Strategies.
3. Click the phone strategy you want to edit.
4. In the right-hand pane, click the following tabs to append an initial or alternate initial phone:
   • Initial Phone
   • Alternate Phone
5. Select Edit > Append Row.

Inserting an initial phone in a phone strategy

About this task
Inserting a row adds a row directly above the row you select on the Initial Phones or Alternate Initial Phones tabs.

To insert a row in your phone strategy do the following:

Procedure
1. On the Editor button bar, click Contact Management.
2. Click Strategies.
3. Click the phone strategy you want to edit.

4. In the right-hand pane, click the Initial Phone or Alternate Initial Phone tabs for the settings you want to edit.

5. Select the row above which you want to add a new row.


---

**Deleting a row in a phone strategy**

**Procedure**

1. On the Editor button bar, click Contact Management.

2. Click Strategies.

3. Click the phone strategy you want to edit.

4. In the right-hand pane, click the Initial Phone or Alternate Initial Phone tabs for the settings you want to edit.

5. Select the row you want to delete.


7. Select the row to move.


---

**Selecting all rows in a phone strategy**

**Procedure**

1. On the Editor button bar, click Contact Management.

2. Click Strategies.

3. Click the phone strategy you want to edit.

4. In the right-hand pane, click one of the following tabs:

   - Alternate Initial Phone
   - Detection
   - Retries

5. Select Edit > Select All.

   Editor selects each check box.
Clearing all rows in a phone strategy

Procedure

1. On the Editor button bar, click **Contact Management**.
2. Click **Strategies**.
3. Click the phone strategy you want to edit.
4. In the right-hand pane, click one of the following tabs:
   - Alternate Initial Phone
   - Detection
   - Retries
5. Select **Edit > Unselect All**.
   
   Editor clears each check box.
Chapter 16: Record selection

Proactive Contact uses record selections to determine which records to use to place phone calls during a job.

In Editor, you can create, edit, and view existing record selections or view only the record selections that have been run.

**Note:**

In a multitenancy environment, you can view only those selections that are assigned to your tenant space.

A record selection contains the set of instructions that tells Proactive Contact which customer records to select from a calling list. You can use record selections that you saved on more than one job.

A record selection consists of selection criteria and a phone strategy. Each job uses the results of a record selection to place calls to customers. For example, a record selection can place phone calls and select only customers who meet the following criteria:

- Have a balance of less than $5,000
- Live in California

When a record selection starts, Proactive Contact selects records based on the following criteria:

- Calling list fields
- Time zones
- Previous calling results
- Agent set recalls
- Phone strategy settings

You can verify a record selection before you start a job to determine the number of records that were selected.

---

**Time zones**

You can use a record selection to specify time zones such as Eastern, Central, or Pacific. Proactive Contact places phone calls to only the records whose addresses are in the specific time zone.
zones. If time zones are not specified, Proactive Contact defaults to a follow the sun method. Dialers place calls to customers in the east and proceed to the west. If you select records across defined time zones for a campaign, then when the campaign starts, it dials records only for those time zones where the calling time is within the Start time and Stop time. For example, the system does not dial records for the time zones where there is mid-night. However, the job percentage complete includes these skipped records and displays the campaign status accordingly.

**Completion codes**

You can use a record selection to specify completion codes such as BUSY, NOANSWER, or special information tones (SIT). For example, if you specify the SIT completion code, the record selection looks for phone numbers that are disconnected, redirected, or no longer in service.

**Goals**

You can use a record selection to specify goals:

- Accounts more than 30 days overdue
- Accounts with a balance over $2,000, or records in a particular state.

**Selections settings**

Using Selections, you can create a new record selection, edit an existing record selection, and view all existing record selections.

You can click a record selection name to divide the window into the following panes:

- The left-hand pane lists the record selections.
- The right-hand side contains tabs that you use to edit settings for the record selection.

**Selections tab field descriptions**

The following table describes the tabs that appear on the right-hand pane of the window.
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Detail</td>
<td>Use the Detail tab to specify a calling list, ignore the time zone option, unit work list field, phone strategy file, and selection type. To select a value, click the field and use the drop-down list to select.</td>
</tr>
</tbody>
</table>
| Records    | Use the Records tab to define which records the system uses during a job based on logic statements that you create. Click **Field** and the drop-down list to select a field. Enter a value.  
If you use the Logic field, you begin to create a multi-line logic statement. Click the **Logic** field to use the drop-down list to select **And** or **Or**.  
To add a row, click **Edit** > **Append Row**.  
For information on using a wildcard character, see [Record selection wildcard characters](#) on page 210. |
| Time Zones | Use the Time Zones tab to select time zones that the system places phone calls.  
You can right-click and select **Select All** or **Unselect All**. |
| Results    | Use the Results tab to tell the system which phone numbers to dial based on previous calling results.  
Select each completion code you want the system to call. You can right-click and select **Select All** or **Unselect All**. |
| Recalls    | Use the Recalls tab to determine which agent-set recalls to include in the record selection.  
To make only the recalls scheduled during the current job, enter criteria to match the Records pane. To prevent any agent-set recalls, enter values that cannot be met (for example, enter a STATE of ZZ).  
Click **Field** and use the drop-down list to select a field. Enter a value.  
If you use the Logic field, you begin to create a multi-line logic statement. Click the **Logic** field to use the drop-down list to select **And** or **Or**.  
To add a row, select **Edit** > **Append Row**.  
Click the **Group** field to enter a letter or number. When you group rows, the Logic column becomes a critical linking component because its logic operator determines how the linked elements resolve as one statement. |
A record selection contains options that you define. The system selects a record if it meets specific criteria. The record selection with the phone strategy determines to whom the dialer places phone calls and how the dialer places the phone calls.

**Tip:**
If you do not know what to enter in a field, click the field to see if there is a list of values to select. A blinking cursor indicates that you can enter a value in the field.

### Record selection wildcard characters

Phone strategies and record selections use wildcard character expressions to specify criteria for a field. A wildcard character expression is a combination of wildcard characters and values.

With wildcard character expressions you can define the subset of records you want to use in a record selection.

You can create wildcard expressions on the Records and Recalls tabs. Each wildcard expression specifies a field name from the records in the calling list, a wildcard character, and a value. A value can be numbers, letters, dates, and times. For example, account balances consist of numbers and customer names consist of letters.

Wildcard characters include the following symbols:

<table>
<thead>
<tr>
<th>Wildcard character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>is equal to</td>
</tr>
<tr>
<td>&lt;&gt; or ~</td>
<td>is not equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>is greater than</td>
</tr>
<tr>
<td>&lt;</td>
<td>is less than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>is greater than or equal to</td>
</tr>
<tr>
<td>&lt;=</td>
<td>is less than or equal to</td>
</tr>
</tbody>
</table>

Example record selection statements include the following:
Consider the following tips when you create your record selection statement:

- You can connect two or more statements using the operators And and Or.
  
  Use And to narrow the selection to the customer records that meet the criteria in both statements.
  
  Use Or to broaden the selection to select the customer records that meet the conditions in either statement.
- Click Append to add a line to the bottom of the selection area.
- Click Insert to insert a line below the cursor.
- Click Delete to delete the selected line.

### Viewing Selection Reports

**Procedure**

1. Click **Selections Reports** on the button bar to list the record selections that were previously run.
   
   Selection Reports contains summary information that you do not modify.
2. To view a selection report, click a selection.
   
   The Detail tab contains the report details that you can copy and paste into a different application. You can also save and print the report.

**Related links**

[Saving and printing a Record Selections report as an HTML file](#) on page 218

**Selection Reports pane field descriptions**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selection</td>
<td>Record selection file name.</td>
</tr>
<tr>
<td>List</td>
<td>Calling list associated with this record selection.</td>
</tr>
<tr>
<td>Status</td>
<td>Record selection status is Unavailable if it is used for a currently running job, or Available if it is not in use.</td>
</tr>
<tr>
<td>Records</td>
<td>Number of customer records associated with this record selection file.</td>
</tr>
</tbody>
</table>
### Details pane field descriptions

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Records Remaining</td>
<td>Number of remaining records to dial. The Records Remaining field displays -:- if a job is currently running. The records remaining number gets updated after the job is stopped.</td>
</tr>
<tr>
<td>Recalls</td>
<td>Number of recalls or callbacks that the record selection file has flagged. The Recalls field displays -:- if a job is currently running. The <strong>Recalls</strong> field is updated after the job is stopped.</td>
</tr>
<tr>
<td>Selection Ran at</td>
<td>The time and date when the record selection was run.</td>
</tr>
</tbody>
</table>

### Using a record selection

#### Opening and viewing a record selection

**Procedure**

1. Click **Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor**.
2. On the button bar, click **Selections**.
   - The list of selections for the selected dialer appears.
3. To see record selections that have been defined for a different dialer, click the name of the dialer on the button bar, and then click **Selections** for that dialer.
4. Click a record selection title to display the selection settings in the right-most pane.
5. Click a tab to move through the settings.
Using the Detail tab

Procedure

1. Click the List field to use the drop-down list. Select a calling list.
2. Click the Ignore Time Zone check box to ignore time zones and to follow the sun. Clear the check box to use time zones.
3. Click the Strategy field to use the drop-down list.
   Select a phone strategy file that you have already created.
   It is beneficial to create a phone strategy, record selection and then job, in that order.
4. Click the Unit Field field and select a unit work list.
5. Click the Selection Type field and select Infinite, Verify, or blank.
   Blank is an empty, blank option; in this case it indicates that you want neither Infinite nor Verify.
   Select Infinite if your job is an infinite job; select Verify if your job is a verification job.

Using the Records tab

About this task
Use the Records tab to define your record selection statement.

Procedure

1. Click the Records tab.
2. Click the Field field to select a field (for example, BALANCE).
3. Double-click the Value field to enter a value, for example, > 3000.
4. (Optional) If you use the Logic field, you begin to create a multi-line logic statement. Click the Logic field to use the drop-down list to select And or Or.
5. Click the Group column, on the far left, and use the check box. To start a new group, select the check box at the beginning of the first line of the group. Do not select any other check box unless you want to start another group. When you group rows, the Logic column becomes a critical linking component because its logic operator determines how the linked elements resolve as one statement.
6. To add a row, select Edit > Append Row.
7. Repeat Steps 2 through 5 for each selection criteria.
Using the Time Zones tab

Procedure

1. Select the time zones you want to call.
   To select all time zones, right-click and select Select All.

2. Clear the each time zone you do not want to include.
   To clear all time zones, right-click and select Unselect All.

   Note:
   If you use a record selection over several days and if, in between, the DST changes, then the system might dial records out of the defined start and stop time for that time zone. To prevent this, you must stop the campaign, run the record selection again, and then restart the campaign so that the campaign points to the new record selection file.

Using the Results tab

Procedure

1. Select the completion code you want the system to call.
   Select File > Select All or right-click and select Select All.

2. Clear each completion code you do not want to call.
   Select File > Select All or right-click and select Unselect All to clear all of the completion codes.

   Tip:
   New records that have not been called yet are assigned a “Record not yet called” code. You will almost always select the Record not yet called box because you have never attempted to call that customer before.

Using the Recalls tab

About this task

The Recalls tab is optional. Use the Recalls tab to filter which agent-set recall records that dialer will use to place calls.

To dial all scheduled agent-set recalls, do not complete this tab.

To make only the recalls scheduled during the current job, enter criteria to match the Records tab.
To prevent any agent-set recalls, enter values that cannot be met so that no records can qualify for recall. For example, select the STATE field and enter ZZ (no records will have a STATE value of ZZ, so no records can be selected for recall).

To complete the Recalls tab do the following:

Procedure

1. If the Recalls tab has no visible rows, select Edit > Append Row or right-click and select Append Row.
2. Click the Field field to select a field (for example, BALANCE).
3. Double-click the Value field to enter a value, for example, > 3000.
4. (Optional) If you use the Logic field, you begin to create a multi-line logic statement. Click the Logic field to use the drop-down list to select And or Or.
5. Click the Group column, on the far left, and use the check box. To start a new group, select the check box at the beginning of the first line of the group. Do not select any other check box unless you want to start another group. When you group rows, the Logic column becomes a critical linking component because its logic operator determines how the linked elements resolve as one statement.
6. To add a row, select Edit > Append Row.
7. Repeat Steps 2 through 5 for each selection criteria.

Using the Sort tab

About this task

The Sort tab is optional.

To tell the system how to sort the selected records:

Procedure

1. If the Sort tab has no visible rows, select Edit > Append Row or right-click and select Append Row.
2. To change the priority, select the Edit menu or right-click the row and then select Move Up or Move Down.
3. Click the Sorts Records By field to use the drop-down list and select a field.
4. Click the Order field to use the drop-down list and select Ascending or Descending.

Tip:

You can set up to 10 sorts.
Creating a record selection

Procedure

1. Select the name of the dialer where you want your record selection to reside. (You can save it to additional dialers or delete it from this dialer later.)

2. On the button bar, click Selections.

3. Click File > New.

The right-hand pane populates.

4. In the right-hand pane, click the List field and select a calling list.

5. Click a tab to complete the settings. For more information, see Related topics.

6. When finished, select File > Save.

★ Note:

For English, the maximum length for record selection name is 20 characters and recommended is 15 characters. For other languages, the maximum length for record selection name is 15 characters and recommended is 8 characters.

a. The record selection is automatically saved to the dialer you selected.

   In a multi-dialer environment, select the dialers you want to save the record selection.

   If the additional dialers were unavailable, select Settings > Options to change your multi-dialer settings. For more information, see Options dialog box field descriptions on page 269.

b. Enter a file name, and then click OK.

Related links

Using the Detail tab on page 213
Using the Records tab on page 213
Using the Time Zones tab on page 214
Using the Results tab on page 214
Using the Recalls tab on page 214
Using the Sort tab on page 215
Options dialog box field descriptions on page 269

Saving a record selection

About this task

You can save a record selection to another dialer. If the multi-dialer is not enabled, enable the feature. Use the following procedure to save a record selection. When you finish defining settings for a record selection, select File > Save.
If multi-dialer is enabled, you can save the record selection to additional dialers.

**Procedure**

1. In the Save As dialog box, select another dialer if you want to save the phone strategy to a different dialer.
2. Enter a file name for your strategy, and then click **OK**.

★ **Note:**

For English, you can enter a record selection name up to a maximum of 20 characters. In other languages, you can enter a record selection name up to a maximum of 15 characters.

---

**Editing a record selection**

**Procedure**

1. Click on the record selection you want to edit.
2. Make the necessary edits on the tabs.
3. Select **File > Save** to save the changes.

---

**Deleting a record selection**

**Procedure**

1. Select the record selection you want to delete.
2. Select **File > Delete**.
3. When asked if you are sure, click **Yes** if you are sure.

---

**Verifying a record selection**

**About this task**

To verify that the settings for a particular record selection are complete and that the record selection will run when started.

Proactive Contact displays a message if an error occurs.

You should review the tabs before verifying a record selection. You cannot verify a record selection until you have saved your work.

**Procedure**

1. Select the record selection you want to verify.
2. Select **File > Verify**, and then click **OK**.
Running a record selection

Procedure

1. Click the record selection you want to run.
2. Select File > Run, and then click OK.

Tips:

You do not need to run a record selection before you start a job. You can, however, run a record selection to check to determine how many records are selected. When you start a job, the system first verifies the record selection, and then starts the job.

Saving and printing a Record Selections report as an HTML file

Procedure

1. Click Selections Reports in the left-hand pane.
2. Select a selections report in the Record Selections window.
   The report appears in the right-hand pane.
3. Select File > Save as HTML.
   The Save As dialog opens in your preference directory.
4. Enter a file name and click OK.
5. Click Yes to display the report.
   Internet Explore displays the report ready for you to print.
6. Select File > Print to print the report.

Maintaining a record selection

Copying a record selection

Procedure

1. Select the record selection you want to copy.
2. Click File > Save As.
   In a multi-dialer environment, select the dialers you want to save the record selection. If the multi-dialer is not enabled, see Related topics section to enable the feature.
3. Enter a name for the copied record selection, and then click **OK**.

### Listing all record selections on a selected dialer

**Procedure**

1. Select the name of the dialer whose record selections you want to list.
2. Click **Selections**.

   The record selections for the selected dialer appear.

### Viewing selection reports

**About this task**

In the button bar, you see both Selections and Selection Reports. The difference between these two is that Selections displays all of the record selections that you have created and Selection Reports displays all of the record selections that you have run.

Selection Reports provides detailed information about the results of the record selection.

**Procedure**

1. On the button bar, select the dialer whose record selection reports you want to view.
2. Click **Selections Reports**.

   The right-hand pane lists the selection reports.
3. Click the selection report you want to open. The right-hand pane populates with your selection report.
4. If you want to copy and paste the report to a different application, right-click and select **Select All**. Then, right-click and select **Copy**.

### Viewing record selection settings

**Procedure**

1. On the Editor button bar, click **Selections**.
2. Click the record selection you want to open.

   The record selection settings will appear in the right-hand pane.
3. Click a tab to navigate through all of the record selection settings.
Appending record selection rows

About this task
Appending a row adds a row beneath the bottom row.

Procedure
1. On the Editor button bar, click Contact Management.
2. Click Selections.
3. Click the record selection you want to edit.
4. Click one of the following tabs:
   - Time Zones
   - Results
5. Click the Sort tab.
6. Select the row you want to move.
7. In the right-hand pane, click one of the following tabs:
   - Records
   - Recalls
   - Sort
8. Select Edit > Append Row.

Inserting a row in a record selection

About this task
Inserting a row adds a row directly above the row you select.

Procedure
1. On the Editor button bar, click Contact Management.
2. Click Selections.
3. Click the record selection you want to edit.
4. Click one of the following tabs:
   - Time Zones
   - Results
5. Click the Sort tab.
6. Select the row you want to move.
7. In the right-hand pane, click one of the following tabs:
   • Records
   • Recalls
   • Sort
8. Select the row above which you want the new row to appear.

---

**Deleting a row in a record selection**

**Procedure**

1. On the Editor button bar, click **Contact Management**.
2. Click **Selections**.
3. Click the record selection you want to edit.
4. Click one of the following tabs:
   • Time Zones
   • Results
5. Click the **Sort** tab.
6. Select the row you want to move.
7. In the right-hand pane, click one of the following tabs:
   • Records
   • Recalls
   • Sort
8. Select the row you want to delete.

---

**Moving a row up in a record selection**

**About this task**

You can change the sort order by moving the row up or down on the Sort tab.

**Procedure**

1. On the Editor button bar, click **Contact Management**.
2. Click **Selections**.
3. Click the record selection you want to edit.
4. Click one of the following tabs:
   - Time Zones
   - Results
5. Click the Sort tab.
6. Select the row you want to move.
7. Select Edit > Move Up.

---

Moving a row down in a record selection

About this task
You can change the sort order by moving the row up or down on the Sort tab.

Procedure
1. On the Editor button bar, click Contact Management.
2. Click Selections.
3. Click the record selection you want to edit.
4. Click one of the following tabs:
   - Time Zones
   - Results
5. Click the Sort tab.
6. Select the row you want to move.
7. Select Edit > Move Down.

---

Selecting all rows in a record selection

About this task
To select all rows that have a check box on the Time Zones and Results tabs:

Procedure
1. On the Editor button bar, click Contact Management.
2. Click Selections.
3. Click the record selection you want to edit.
4. Click one of the following tabs:
   - Time Zones
   - Results
5. Select Edit > Select All.

Clearing all rows in a record selection

About this task
To clear all rows that have a check box on the Time Zones and Results tabs do the following:

Procedure
1. On the Editor button bar, click Contact Management.
2. Click Selections.
3. Click the record selection you want to edit.
4. Click one of the following tabs:
   • Time Zones
   • Results
5. Select Edit > Unselect All.

Record Selection for Multiple Dialers
When a record selection is run for multiple dialers, it will execute on the Proactive Contact that contains the list. However for many dialers it is needed for how many actual call selections are run. They run simultaneously, but if there is calling being done on the same records that are being selected, the records selected may not match 100%. Proactive Contact that holds the list will then push the indexes to the remote system through a socket connection of a list server. You will see a callsel (for remote) message in the account log on the PDS containing the list (one callsel message for each call selection run for remote systems). The time stamp for the callsel (for remote) account log entry will be in local time of the remote system, which can look odd as it will likely be off from the other times of the nearby messages in that account log.

Once the job has been started on the remote system list server will fetch each record to the job, once the call is completed it will push the record back to the list.
Chapter 17: Jobs

A job contains all the information that Proactive Contact needs to place phone calls to customers. A job integrates a calling list, phone strategy, record selection, and other settings to place outbound calls and receive inbound calls. The type of job you set up determines the type of calling activities that agents handle.

In a multitenancy environment, you can view and manage jobs only for your tenant space. Also, the system displays the associated resources, such as calling list, scripts, completion codes, selection, strategies, screens, agent keys, DNC groups, only specific to your tenant space.

Job types

Depending on your system configuration, a job can conduct the following types of calling activities:

- Make outbound calls.
- Receive inbound calls.
- Verify a sale.

You can start more than one job at one time.

If you have an Agent Blending System, you can use Editor to set up outbound jobs.

If you have an Intelligent Call Blending System, you can use Editor to set up the following types of jobs:

- Outbound jobs: During outbound jobs, the system uses a calling list, phone strategy, record selection, and other settings to place outbound calls to customers.
- Inbound jobs: An inbound job is a job on an Intelligent Call Blending System where the system automatically routes inbound calls to agents.

An Agent Blending System does not have inbound jobs. The ACD controls inbound calling activity rather than the system. The agents on the ACD handle the inbound calls.

- Blend jobs: A blend job is a job on an Intelligent Call Blending System where the system moves agents between outbound and inbound calling activities. Blend agents receive inbound calls during peak inbound activity and outbound calls when inbound activity decreases.

In Proactive Contact, a blend job handles both inbound and outbound calls on an Intelligent Call Blending System.
Outbound jobs

During outbound jobs, the system automatically dials phone numbers and routes calls to agents. Depending on your system configuration, the system monitors the phone calls to ensure that agents do not receive phone calls that result in the following connections:

- Answering machines
- Phone operator intercepts
- Busy signals
- Interactive Voice Response systems (IVRs)
- No answers

Related links

- When a job stops on page 225
- Types of outbound jobs on page 225

When a job stops

Proactive Contact uses quotas as a means to complete a certain number of outbound calls based on a selected outcome.

Note:

The quota at the tenant level is exclusive from other tenants on the dialer.

A quota is a maximum number of releases for a particular completion code. When the job reaches the quota for a unit, no more calls are placed.

In Proactive Contact, a job can stop when the following occurs:

- The job reaches the Latest Time to Stop setting.
- You stop the job manually.
- The system placed a call to all initial phones at least once.
- The system placed a call to all recalls at least once.
- The system placed a call to all scheduled recalls, but stops dialing after placing a call to all initial phones at least once.

In Editor, you set and modify a quota that the system applies to the job when the job starts. In Monitor, you set and modify a quota that affects the current job while that job runs.

Types of outbound jobs

An outbound job uses settings to place calls to customers.
Depending on the configuration for an Intelligent Call Blending System, you can create or modify the following types of jobs:

<table>
<thead>
<tr>
<th>Type of job</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unit Work List</td>
<td>Divides customer records into work lists or subsets. Agents work with records only in their assigned work lists.</td>
</tr>
<tr>
<td>Managed Dialing</td>
<td>Allows agents to preview or cancel a customer record before the dialer places the call the customer. Depending on your system setup, you can adjust the maximum preview time and allow agents to cancel calls.</td>
</tr>
<tr>
<td>Sales Verification</td>
<td>Verifies a transaction or commitment that the customer made. Use the Sales Verification record selection when starting a Sales Verification job.</td>
</tr>
<tr>
<td>Infinite</td>
<td>Uses a special record selection to add records for calling to an existing calling list while the job is active. Use the Infinite record selection when starting an Infinite job. An infinite job continues to run even if all the records included in it are called. An infinite job ends only when the specified end time is reached or when you stop it manually.</td>
</tr>
<tr>
<td>Virtual Agent</td>
<td>Allows the system to run a job without agents. When the system detects a customer or an answering machine, the system plays a recorded message. You can also allow customers to opt-out of the recorded message to talk to an agent. The call is then transferred on a specified VDN or to an inbound/blend job.</td>
</tr>
</tbody>
</table>

In Editor Job Wizard, you define Unit Work List, Managed, Sales Verification, and Virtual jobs on the second screen. The job you select determines the type of additional jobs you can select to create. For example:

- If you select Virtual, you cannot select any other type of job.
- If you select Managed, you can select only Unit Work List.

**Maximum number of jobs allowed**

You can run a maximum of 200 active jobs using Editor on your installation. The active jobs include user-started jobs, linked jobs, and IVR pool jobs; therefore, you can run a sum total of 200 user started jobs, linked jobs and IVR pool jobs. When you start the 201st active job, then an alert is displayed stating that the maximum limit of jobs that can be run simultaneously has been reached. As a result, the system does not stop any existing job and the 201st job is not started.

In case of Agent Owned Recall feature, which is turned on by default, the following rules are enforced:

- If the Agent Owned Recall feature is turned on, then you can run either of the following:
  - The maximum number of jobs that can be run is 100 active jobs. When you start the 101st active job, then the maximum limit of simultaneous jobs alert is displayed. As a result, the system does not stop any existing job and the 101st job is not started.
- The number of active jobs and the number of shadow jobs must not exceed 200 jobs.
  
  • The number of active jobs varies from 0 to 100 jobs.
  
  • The number of shadow jobs varies from 0 to 200 jobs.

For example, if the number of shadow jobs on your installation reaches 100 jobs, then you get the alert when you start the 101st active job. However, if your number of shadow jobs reaches 110, then you can run only 90 active jobs, which makes a total of jobs running on your installation as 200 jobs and an alert is displayed when you attempt to start the 91st active job.

• If you choose to turn off the Agent Owned Recall feature, then you can run a maximum of 200 active jobs. If you attempt to start another active job when the maximum limit of concurrent jobs, that is 200 jobs, is reached, then an alert is displayed when you start the 201st job stating that the maximum limit of jobs that can be run simultaneously has been reached.

In case of Linked jobs, which cannot start due to unavailable resources, this alert message is logged in the account log.

In case of multitenancy environment, the following rules are enforced for the maximum number of jobs:

• If the Agent Owned Recall feature is turned on, then you can run jobs meeting the following criteria:

  - The sum of the number of active jobs and the number of shadow jobs must not exceed the maximum number of jobs defined for your tenant space.

  - The number of active jobs can vary from 0 to half of the maximum number of jobs defined for your tenant space. For example, if the maximum number of jobs defined for your tenant space is 20, then the number of active jobs in your tenant space can vary from 0 to 10. However, if the maximum number of jobs defined for your tenant space is 15, then the number of active jobs in your tenant space can vary from 0 to 7.

  - The number of shadow jobs can vary from zero to the maximum number of jobs defined for your tenant space. For example, if the maximum number of jobs defined for your tenant space is 20, then the number of shadow jobs in your tenant space can vary from 0 to 20.

• If you choose to turn off the Agent Owned Recall feature, then you can run as many active jobs as the maximum number of jobs defined for your tenancy.

Automated Release Agent to Ready for Voicemail

In UK, the regulation on contact centers specifies that the called party must be connected to an agent within 2 seconds. Therefore, the contact centers are unable to use the Answering Machine Detection (AMD) feature provided by Proactive Contact to eliminate agent intervention for all the calls. In this case, the contact centers turn off the AMD feature and connect all the calls to live agents. The live agent passes the call to the correct message, selects the completion code for this
result, and then goes back to the ready state. This process has a significant impact on the agent productivity.

The Automated Agent Release to Ready feature connects all the calls to the live agents while the system continues to detect answering machines. If the system detects an answering machine, the system administrator can choose to do any of the following:

- End the call without playing message and at the same time put agent into ready mode.
- Play message onto the answering machine but at the same time put agent into ready mode.
- Leave the answering machine with the agent.

---

**Call pacing**

Proactive Contact has two methods to pace outbound dialing during an outbound job: Cruise Control and Expert Calling Ratio.

You can link a job that uses Cruise Control to a job that uses either the Cruise Control or Expert Calling Ratio method.

The same job name on different dialers in a pod can use a different call pacing method. To ensure consistent monitoring and reporting, use the same settings for the same job name on each dialer.

**Related links**

- [Cruise Control](#) on page 229
- [Expert Calling Ratio](#) on page 229

---

**Using call pacing**

**About this task**

When you define a job in Editor, you set the call pacing method based on the type of calling activity you want to complete. For example:

**Procedure**

1. If you want to limit abandoned or nuisance calls while maximizing agents handling calls, select **Cruise Control**.

   After selecting the **Require unit ID for agent login** check box, if you select the Cruise Control option for the Call Pacing Method field, then the following message is displayed:

   Only Expert Calling is allowed with unit work list. You are turning off unit work list feature. Percent completion of job to run record selection for linked job is now editable.

   When you click **OK**, the Editor clears the **Require unit ID for agent login** check box and makes the Percent completion of job to run record selection for linked job field editable.
2. If you want to pace calling activities based on time in a wait queue or time agents spend handling calls, select **Expert Calling Ratio**.

---

### Cruise Control

Use Cruise Control for outbound jobs when any of the following dialing conditions are important:

- The job is subject to government regulations prohibiting abandoned calls, nuisance calls, or silent calls.
- You want to provide a high level of customer service to the contacted parties.
- You want to supervise agents and calling activities rather than manually supervising the predictive dialing process.
- The number of agents on an outbound job is small or may change. The Cruise Control feature requires at least eight outbound agents to be logged into a job to function correctly.
- Agents perform other activities such as handing inbound calls during the job.

Cruise control automatically maintains the service level of outbound dialing during a job and connects the calls to agents within a specified period of time. During the job, you do not have to monitor or modify the call pacing settings.

When you set up an outbound job that uses Cruise Control, you must define the Desired service level and the Time to connect tolerance settings. The system uses these settings to do the following:

- Predict when to automatically dial phone numbers.
- Distribute phone calls within the tolerable time period that you set.

Once you start a job that uses Cruise Control, you do not have to change the settings. If you want to change the settings, you must stop the job. To resume calling activities with the new settings, restart the job.

---

### Expert Calling Ratio

Use Expert Calling Ratio for any type of outbound job when the following objectives are important:

- Optimize the use of agents during the job.
- Manage and change call handling time during the job.
- Place as many calls as possible during the job.

Expert Calling Ratio allows you to change the way the system determines when to place the next call while a job is running.

When you set up an outbound job that uses Expert Calling Ratio, you select the following settings:

- The method that the system uses to monitor calling activities.
A value that sets the pace at which the system places phone calls.

The Expert Calling Ratio method tells the dialer when to place calls based on one of the following values:

- The number of phone calls in the wait queue and the agents waiting for a phone call.
- The total time agents spend handling the phone call and customer record.
- The time agents spend updating customer records after releasing the phone line.

Once you start a job that uses Expert Calling Ratio, you can change the settings in Monitor without stopping the job.

Accessing job settings

Procedure

1. Double-click a job or select **New**.
   - A tree structure appears on the **Job Detail** tab that you can use to modify your job settings.
2. Click the fields located in the **Setting** column.
   - There are several settings that you define for each job. The settings on your system depend on your system configuration.

Basic settings field descriptions

Basic settings are for every type of job: outbound, inbound, and blend.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Job description</strong></td>
<td>Description of the job. For example, type a description that reflects the goal of the job such as 30-day Accounts.</td>
</tr>
<tr>
<td><strong>Tagged trunk-to-trunk transfer data</strong></td>
<td>Field name from a calling list to tag trunk-to-trunk transfer calls with a field data from the specified calling list.</td>
</tr>
<tr>
<td><strong>Percent complete of job to trigger callsel of link job</strong></td>
<td>The percentage completion value of the current job after which the automatic record selection for the linked job will start. By default, the value for this field is set to zero, which implies that the automatic record selection for linked job is disabled. To use this functionality, you must have a linked job.</td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Note:</strong></td>
<td>You can not use this functionality along with the unit work list job.</td>
</tr>
<tr>
<td><strong>Line type(s) for use on job</strong></td>
<td>The group of lines that the system uses for a job. In a multitenancy environment, you can use only as many lines as are assigned to your tenant space.</td>
</tr>
<tr>
<td><strong>Earliest start time</strong></td>
<td>The field to set the time that you want the system to start dialing customer phone numbers and receiving inbound calls. Enter numbers only.</td>
</tr>
<tr>
<td></td>
<td>The system is preset with recommended start and stop times for different time zones. If you enter a time that is earlier than the recommended start time, the dialer does not dial phone numbers until the system clock reaches the recommended time.</td>
</tr>
<tr>
<td><strong>Latest stop time</strong></td>
<td>The field to set the time that you want the dialer to stop dialing customer phone numbers and receiving customer inbound calls. Enter numbers only.</td>
</tr>
<tr>
<td><strong>Calling party number (ANI)</strong></td>
<td>The party that placed the phone call. Displays the phone number of your contact center on the phone of the party that received the phone call.</td>
</tr>
<tr>
<td><strong>Calling party number (ANI) by record</strong></td>
<td>The party that placed the phone call to an individual or a group of records. Displays the value of the selected calling list field for which the value has already been mapped in the Calling list pane.</td>
</tr>
<tr>
<td></td>
<td>You can simultaneously configure both Calling party number (ANI) and Calling party number (ANI) by record fields. However, the value in Calling party number (ANI) by record field overrides the Calling party number (ANI) value for the applicable records. Also, you can set only the numeric values as ANI alphabets. Do not use alphanumeric values, and ensure that the ANI number is a valid dialing number.</td>
</tr>
<tr>
<td><strong>Require unit ID for agent login</strong></td>
<td>The field to require an agent to select a single or multiple unit work lists when the agent logs in to Proactive Contact Agent.</td>
</tr>
<tr>
<td><strong>Transaction completion code</strong></td>
<td>The field to enter the call completion code to indicate the need to verify the transaction by the Sales Verification job.</td>
</tr>
</tbody>
</table>

**Related links**

- [Using agent permission for Unit list](#) on page 232

_Using Avaya Proactive Contact Supervisor_ 231
Using agent permission for Unit list

About this task
To allow an agent to select single or multiple unit work lists.

Procedure

1. Select Require unit ID for agent login check box.
   The following message is displayed:
   You are turning on unit work list feature. This requires to set Percent completion of job to run record selection for linked job to zero. Do you want to proceed?

2. Select Yes to continue with Unit Work List feature.
   The Editor application automatically:
   • Selects the Require unit ID for agent login check box.
   • Sets the Percent completion of job to run record selection for linked job field to zero.
   • Makes the Percent completion of job to run record selection for linked job field as non-editable.

3. Select No to continue with the automatic record selection for the linked job feature.

4. If you clear the Require unit ID for agent login check box, the following message is displayed:
   You are turning off unit work list feature:
   Percent completion of job to run record selection for linked job is now editable.

5. Click OK.
   The Editor application:
   • Clears the Require unit ID for agent login check box.
   • Makes the Percent completion of job to run record selection for linked job field editable.

Accessing Call Pacing method

Procedure

1. Select Cruise Control or Expert Calling Ratio from the drop-down list.
2. Press the Enter key to set the call pacing method.

⚠ Important:
If you select Cruise Control, you must set the Desired service level and Time to connect tolerance settings listed in the Service Level group.
Expert Calling Ratio method settings field descriptions

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calls in the wait queue</td>
<td>The system achieves a balance between agents waiting for a call and customers placed in the wait queue. This setting affects the customer wait times. Enter a percent value from 1 through 100. The recommended setting is from 4 through 31 to place fewer customers in the wait queue. A low setting can affect the time that agents wait between phone calls.</td>
</tr>
<tr>
<td>Agent Work Time</td>
<td>The system monitors the time agents take to complete calls and update records, and adjusts the calling pace accordingly. A higher number shortens the average agent idle time and increases the number of customers in the wait queue at any given time. Enter a higher number when update times are relatively short. Enter a percent value from 1 through 100. The recommended setting is from 29 through 71.</td>
</tr>
<tr>
<td>Agent Update Time</td>
<td>The system monitors the time agents take to update records and adjusts the calling pace accordingly. A higher number shortens the average agent idle time and increases the number of customers in the wait queue at any given time. Enter a higher number when update times are relatively short. Enter a percent value from 1 through 100. The recommended setting is from 32 through 78.</td>
</tr>
</tbody>
</table>

Initial hit rate

The initial hit rate determines the average number of calls per agent that the system makes during the first five minutes of the job. The initial hit rate is the number of call completions compared with call attempts.

For example, an initial hit rate of 50 means the system must make approximately two dialing attempts for each agent to get one successful connection, or 50%. When the system gathers
statistics from actual call attempts, it readjusts the hit rate automatically to meet the minimum hit rate setting. If you set the rate too low, at 20 to 30, the dialer could make more connects than your agents can handle during the initial dialing period. If you set the rate too high, over 70, the system could fail to make enough connections to keep your agents busy.

Setting initial hit rate

Procedure

In the Call Pacing group, set an appropriate initial hit rate for a job.

Sample settings for initial hit rate

Use the following table to adjust the initial hit rate according to the particular needs of the job:

<table>
<thead>
<tr>
<th>If you want to make</th>
<th>Set rate to</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Daytime home calls</td>
<td>30</td>
<td>3 calls per agent for 1 connection</td>
</tr>
<tr>
<td>Evening home calls</td>
<td>50</td>
<td>2 calls per agent for 1 connection</td>
</tr>
<tr>
<td>Weekend home calls</td>
<td>50</td>
<td>2 calls per agent for 1 connection</td>
</tr>
<tr>
<td>Daytime office calls</td>
<td>70</td>
<td>1 call per agent for 1 connection</td>
</tr>
</tbody>
</table>

Minimum hit rate

The system uses the minimum hit rate to determine the maximum number of calls to place in order to make an agent connection.

Enter a value from 1 through 100 in increments of 10. A typical setting is 30.

Use minimum hit rate to limit the number of lines a job can use. For example, a minimum hit rate of 30 means the system will make no more than three dialing attempts for each agent, or 30%. This prevents the system from allocating more pooled lines to a poorly performing job at the expense of a more successful job.

Setting minimum hit rate

Procedure

In the Call Pacing group, set an appropriate minimum hit rate for a job.
Configuring Answer Supervision for a job

About this task
Answer supervision is a function in telephony line signaling between a telephone exchange and a connected station. It indicates that the connected call has been answered. When you configure answer supervision for a job, the dialer assumes that the output pulse rule uses an answer supervision template which enables the reporting of answer supervision events.

Procedure
1. Click Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor.
2. Click the Contact Management button group.
3. Select a job.
   The system displays the job details in the right-hand side of the pane.
4. Under Outbound Processing, click the Answer Supervision checklist.
5. Click Save.

Playing on-hold message to customer

About this task
Starting from Release 5.1.2 of Proactive Contact, you can play a message or music to a customer when an agent puts the customer on hold and stop the message when the agent puts the customer off hold. When music or message is played to a customer while on hold, Jobmon displays the line status Transfer wait Queue, because Transfer Wait Queue scripts are used for playing on-hold messages.

Before you begin
You must create a Transfer Wait Queue script for playing on-hold message to a customer.

Note:
While defining the script that is intended for playing message or music to the customer while on hold, you must select the Start a loop option. The Music on hold feature does not work without a loop.

Procedure
1. Click Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor.
2. Click the Contact Management button group.
3. Click Jobs
4. Double-click a job or select New.
   A tree structure appears on the Job Detail tab that you can use to modify your job settings.
5. Under the Labels settings, select the appropriate script from the **Script to use when agent put customer on hold** drop-down list.
   
   If you do not select any script, customers will listen to silence when an agent puts them on hold.

6. Click **OK**.

---

### Enabling preview mode settings for shadow jobs

**About this task**

Starting from Release 5.1.2 of Proactive Contact, you can configure shadow jobs to be viewed in the preview mode. With this feature, an agent can view the details of a shadow job in the preview mode before dialing out to a customer.

**Procedure**

1. Log in to the Editor application.
2. Click **Contact Management > Job Templates**
   
   The system displays the Job Templates window.
3. Click **Outbound**.
   
   The system displays the job template settings for outbound calls in the right-hand side of the pane.
4. Select the **Visible** check box next to **SHADOW_IN_PREVIEW**.
5. Click **Save**.

---

### Configuring shadow jobs to be available in preview mode

**Procedure**

1. Log in to the Editor application.
2. Select the job which you want to be available in preview mode.
3. On the Job Detail pane, under Recall, select the **Shadow job in Preview Mode** check box.
4. Click **Save**.

---

### Cell Phone Campaign Call Progress

Use the Cell Phone Campaign Call Progress field to define a duration for which the system analyses a call as live voice or a voice messages on a cell phone. This field corresponds to a value added to the Job that allows the supervisors to define the duration in the system for which...
the system should listen to the voice before determining if the call is a live voice or an answer machine. The value defined in this field gets translated into a duration predefined in the system.

You can enter a value between 0-4, where 0 denotes that the Enhanced Cell Phone Detection feature is turned off. A value of 1 is the longest duration for which the system analyses the voice, and 4 is the minimum duration set for the analysis.

**Note:**

Enhanced Cell Phone Detection feature should always be disabled in the UK. This is because the settings 1-4 increase the chances of false positives and risks violation of OFCOM regulations.

You would require generic 18.0.2 on the PG230RM along with the appropriate changes for the outpulse rules for this feature to work.

---

**Files settings field descriptions**

Files settings are for every type of job: outbound, inbound, and blend. The system displays the appropriate settings for the type of job.

The Files settings are tenant specific. You can view and set these settings only for your tenant.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Outbound calling list</strong></td>
<td>Use this drop-down list to select a calling list name. The calling list description, if any, appears to the right of the calling list name.</td>
</tr>
<tr>
<td></td>
<td>The job uses the outbound calling list to place calls to customers during outbound and blend jobs. The calling list name includes the host dialer name where the list is stored.</td>
</tr>
<tr>
<td><strong>Record selection file name</strong></td>
<td>Use this drop-down list to select the name of the record selection. The record selection defines the records that the dialer uses to place phone calls during outbound and blend jobs. The record selection contains the phone strategy for the job.</td>
</tr>
<tr>
<td><strong>Inbound calling list</strong></td>
<td>Use this drop-down list to select a calling list name. The calling list description, if any, appears to the right of the calling list name.</td>
</tr>
<tr>
<td></td>
<td>The job uses the inbound calling list to identify the calls that customers placed during inbound and blend jobs. The calling list name includes the host dialer name where the list is stored.</td>
</tr>
<tr>
<td><strong>Outbound screen(s)</strong></td>
<td>Use this field to select one or more outbound screens from the window. This setting determines the outbound screens that agents see on their</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>workstations and the order in which the screens display. Select outbound screens for outbound and blend jobs.</strong></td>
<td>Inbound screen(s) Use this field to select one or more inbound screens from the window. This setting determines the inbound screens that agents see on their workstations and the order in which the screens display. Select inbound screens for inbound and blend jobs.</td>
</tr>
<tr>
<td><strong>Use this field to select one or more inbound screens from the window. This setting determines the inbound screens that agents see on their workstations and the order in which the screens display. Select inbound screens for inbound and blend jobs.</strong></td>
<td>Agent keys definition file name Use this drop-down list to select the agent keys file name to use during a job. An agent keys file is configured during installation. The file lists the sets of functions for keys used during types of jobs.</td>
</tr>
<tr>
<td><strong>Use this drop-down list to select the name of the Do Not Call group file.</strong></td>
<td>Do Not Call group name Use this drop-down list to select the name of the Do Not Call group file. The system adds customer information to the file when a customer requests to be added to the Do Not Call List.</td>
</tr>
<tr>
<td><strong>Use this drop-down list to select the field to select the next outbound or blend job to start. The system automatically starts the job when the agent on the current job completes the last call and releases the record. The system displays a message telling the agents that they are changing jobs.</strong></td>
<td>Name of next job to link to Use this drop-down list to select the field to select the next outbound or blend job to start. The system automatically starts the job when the agent on the current job completes the last call and releases the record. The system displays a message telling the agents that they are changing jobs.</td>
</tr>
<tr>
<td><strong>Use this drop-down list to select the inbound job name to identify the job name that agents can use to transfer calls during outbound and blend jobs.</strong></td>
<td>Name of inbound job to transfer calls to Use this drop-down list to select the inbound job name to identify the job name that agents can use to transfer calls during outbound and blend jobs.</td>
</tr>
</tbody>
</table>

## Interactive Voice Response settings field descriptions

The following settings in the Interactive Voice Response group are for outbound, inbound, and blend jobs.
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow IVR agents on job</td>
<td>Use this field to select the field to allow IVR agents to join the job.</td>
</tr>
<tr>
<td>IVR identifier</td>
<td>Use this field to select the field to enter the IVR identifier.</td>
</tr>
<tr>
<td>Initial script to run on the IVR</td>
<td>Use this field to select the field to enter the script agents hear when joining an IVR job.</td>
</tr>
<tr>
<td>Script to run on the IVR</td>
<td>Use this field to select the field to enter the script that customers hear when they answer an IVR phone call.</td>
</tr>
</tbody>
</table>

### Job Type settings field descriptions

Job Type settings are for outbound, inbound, and blend jobs. Select the appropriate check box to identify the type of special job: Sales Verification or Virtual Agent.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transaction verification job</td>
<td>Use this check box to identify that the outbound job is a Sales Verification job.</td>
</tr>
</tbody>
</table>
| Run job without agents                    | Use this check box to identify that the outbound job is a Virtual Agent job. The system runs your job without agents. This field does not appear unless you select Virtual in the Editor Job Wizard when you create a new job.  
  ✠ Note:  
  If the strategy associated with the virtual job has a low value for the Number of Rings field, then the virtual job does not play a message to the answering machine. The recommended minimum value for the Number of Rings field is 3. |
| Run job with OFCOM                        | Use this check box to enable OFCOM regulation for the job. For OFCOM jobs, the cruise control setting, the Time to connect tolerance field is automatically set to 0 seconds, and the system displays a message accordingly. Also, after a system upgrade, the Time to connect tolerance field is automatically set to 0 seconds for the OFCOM enabled jobs. |
| Start OFCOM timer when                    | Use this field to select the event when the ofcom timer must start for the job. The options are:  
  • Customer begins to speak  
  • Customer takes phone off-hook |

Table continues…
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
</table>
|                                                   | After you select the Customer begins to speak option, if the customer does not speak, then the OFCOM timer does not get activated. In this case, dialer continues to wait for any of the following events:  
  • The start of the voice, that is, the time when the customer starts speaking.  
  • Timeout, which you can configure in the switch.  
  • Customer hangs up.  
  Until any of these events happen, the call remains active and the customer hears silence. |
| Completion codes excluded from Abandon rate       | Use this field to select the completion codes that you want to exclude from ACR calculations.  
  ✪ Note:  
  If you want to enable/modify ACR exclude codes in an OFCOM job, you must create a new job instead of adding the codes to an existing job. This is needed to ensure that the ACR Excl Count and Abandon Rate columns in the Summarized monthly OFCOM reports to show correct information. |

### Inbound Processing settings field descriptions

Inbound Processing settings are for inbound or blend jobs. The system displays the appropriate settings for the type of job.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activate inbound lines at login</td>
<td>Use this check box to activate the inbound lines when agents log in to the inbound or blend job.</td>
</tr>
<tr>
<td>Service inbound calls immediately</td>
<td>Use this check box to handle the inbound calls immediately during the inbound or blend job.</td>
</tr>
<tr>
<td>Move blend agents to inb after call</td>
<td>Use this check box to have blend agents handle inbound calls after handling the outbound call during the blend job.</td>
</tr>
<tr>
<td>Max time blend agent idle on inbound</td>
<td>Use this field to enter the maximum number of seconds that the blend agent can be idle between inbound calls during the blend job. When the time exceeds the setting, the system moves the agent to handle outbound calls.</td>
</tr>
</tbody>
</table>
**Labels settings field descriptions**

Files settings are for every type of job: outbound, inbound, and blend. The system displays the appropriate settings for the type of job.

In a multitenancy environment, you can view labels only for your tenant.

⚠️ **Important:**

The changes you make to a script become available for use the next time you restart the system. You can set up a job with a new script but cannot run the job until you restart the system.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>% calls in queue to inbound agents</td>
<td>Use this field to enter the upper percentage limit of the calls waiting to be passed to inbound agents during the inbound or blend job.</td>
</tr>
<tr>
<td>Maximum time call can spend in wait queue (seconds)</td>
<td>Use this field to enter the longest time in seconds that calls can be held in the wait queue during the inbound or blend job.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Script label to use for making call</td>
<td>Use this drop-down list to select the script label. The script label is the name of the script used during the outbound job. The message script is the message or string of messages customers hear. Jobs can use different wait queue messages.</td>
</tr>
<tr>
<td>Script to use when agent puts customer on hold</td>
<td>Select the script you want to run when an agent puts a customer on hold from this drop-down list. This drop-down list displays transfer scripts created on the system. You must select the transfer script that has a loop in it.</td>
</tr>
<tr>
<td>Script label to use OFCOM</td>
<td>The outbound wait queue message to be played if OFCOM is enabled. This field is enabled when you select the Run job with OFCOM check box. You can create an OFCOM message in the Messages and Scripts menu.</td>
</tr>
<tr>
<td>Script label for answer</td>
<td>Use this drop-down list to select the script label. The script label is the name of the script used during the inbound job. The message script is the message or string of messages customers hear. Jobs can use different wait queue messages. Proactive Contact</td>
</tr>
</tbody>
</table>

*Table continues*...
Name | Description
--- | ---
application requires all wait queue messages to be saved in the following format:
You can use Microsoft Sound Editor to save the voice message file. You should save it using the following format options:
- CCITT U-Law (Mu-Law)
- 8K Sample (Hz)
- 8-bit
- Mono
- Save the file as <filename>.au in any convenient file directory.
To confirm if the audio file has not been saved in a *.wav format, you can open it up in notepad.
If you see WAVEfmt at the top of the file, the message will fail validation.

Main data processing label
Use this drop-down list to select the correct main data processing label. The main data process label instructs the system to begin job processing and tells the system what to display on the agent screens.
Select the appropriate data process label for the job. Select **virtual** for a virtual job, **verify** for a sales verification job, and **generic** for an outbound job.

Transfer wait queue label
Use this drop-down list to select the correct transfer wait queue label. The transfer queue label is the name of the transfer script used during the inbound or blend job.

Managed Dialing settings field descriptions
During a managed job, an agent can preview a customer record before placing or cancelling the call.
Managed job settings are for outbound jobs.

Name | Description
--- | ---
Managed (preview) dialing | Use this check box to allow an agent to look at a customer record before the dialer places the phone call.
Allow agents to cancel call in preview mode | When you enable **Managed preview dialing**, an agent can cancel a Managed Dialing call.
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Use this check box to allow an agent to cancel the managed dialing call. Clear the check box to prevent agents from cancelling a managed dialing call. When you enable <strong>Managed preview dialing</strong>, an agent can cancel a Managed Dialing call. Select the check box to allow an agent to cancel the managed dialing call. Clear the check box to prevent agents from cancelling a managed dialing call.</td>
</tr>
<tr>
<td>Time limit (seconds) for preview</td>
<td>When you enable <strong>Managed preview dialing</strong>, you can set up the time limit during which an agent can preview a record before the system dials the number. Use this field to select a number from 1 through 999, or select 0 (zero) to set an unlimited amount of preview time. <strong>Note:</strong> If you set the preview time to 0 (zero), then you must use dial a managed call option to call the customer.</td>
</tr>
<tr>
<td>Display empty record at preview</td>
<td>When you enable <strong>Managed preview dialing</strong>, you can allow an agent to create a new record during preview from an empty record. The agent then uses the record to place the phone call. Use this check box to display an empty record during preview. Clear the check box to prevent displaying an empty record during preview.</td>
</tr>
<tr>
<td>Allow dialing from deleted record</td>
<td>When you enable <strong>Managed preview dialing</strong>, you can allow an agent to use a record that was identified as not to use. When an agent removes or deletes a record, the record remains on the dialer. The agent can place a phone call from that record. Use this check box to allow agents to use the record. Clear the check box to prevent dialing a record that was marked not to use.</td>
</tr>
<tr>
<td>Method for record search type at preview</td>
<td>When you enable <strong>Managed preview dialing</strong>, you can select one of the following options from the drop-down list: <strong>Note:</strong> If you set the preview time to 0 (zero), then you must use dial a managed call option to call the customer.</td>
</tr>
</tbody>
</table>

Table continues…
### Key field for LIS record search

Use this field to enter the field name you want to use as the key field for the record search at preview.

**Important:**

To enable the Preview Search and Creating a new record functionalities for the Agents, you must configure the Managed dialing settings as follows:

- Select the **Display empty record at preview** check box.
- Set the value for the **Method for record search type at preview** field to LIS.
- Set the value for the **Key field for LIS record search field** to account number field name, such as ACCTNUM.

---

## Outbound Processing settings field descriptions

Outbound Processing settings are for outbound and blend jobs.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Shutdown job when no more calls remain</strong></td>
<td>Use this check box if you want the system to end jobs when each customer has been called at least once. Clear the check box if you want the system to end jobs after all calls are completed, including recalls.</td>
</tr>
<tr>
<td><strong>Make alternative phone lowest priority in selecting next record</strong></td>
<td>Use the field to place calls that are first attempts, retries, and recalls before placing a phone call that uses the alternative phone.</td>
</tr>
<tr>
<td><strong>Order calling of records by time zone</strong></td>
<td>Use the check box if you want the system to order calls by times zones. The dialer places phone calls “following the sun” from east to west. With either choice, time zone laws are still applied.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>VDN needed by the CTI dialer only</td>
<td>You require this VDN number only for the soft dialer setup. Do not share this number across multiple active jobs. For this field, you must enable the MAKE_CALL_VDN field in the job. The value for the MAKE_CALL_VDN parameter must not start with a leading zero, for example, 0001 or 020345.</td>
</tr>
<tr>
<td>Answer Supervision</td>
<td>Select this check box if you want to configure answer supervision for the job.</td>
</tr>
</tbody>
</table>

### Opt-out settings

A virtual job plays a recorded message to the called party, after which the call is hung up. However, now the called party has an option to opt-out of this recorded message and connect to a live agent. To opt out, press a pre-designated digit during the message.

You can configure Opt-out on both hard dialer and Soft dialer; however, the configuration procedures for both are different.

⚠️ **Note:**

These settings are available only for the virtual jobs. This group of settings will not be visible for any other type of job.

#### Related links

- [Opt-out configuration on hard dialer](#) on page 245
- [Configuring Opt-out on Soft dialer](#) on page 247

#### Opt-out configuration on hard dialer

⚠️ **Important:**

Before configuring the Opt-out feature on the hard dialer, ensure that you have made the configuration modifications related to the Opt-out feature in Avaya PG230RM. For the procedure of configuring Opt-out on Avaya PG230RM, refer Administering Proactive Contact.

On a hard dialer, the call can either be:

- Routed to a specified Vector Directory Number (VDN)

⚠️ **Note:**

Each call that is opted out to a VDN will consume one transfer trunk until the call is disconnected. Keep sufficient transfer trunks free during an operation of Opt-out virtual campaign. There should be more than or equal number of trunks than the lines used in the virtual job. The Opt-out job will not report a lack of transfer trunks until it reaches the transfer trunk limit.

---

Accessing job settings

Using Avaya Proactive Contact Supervisor

Comments on this document? infodev@avaya.com
• Converted to an inbound call on a specified Inbound/Blend job.

When you choose to route the call to a VDN, you must provide the VDN number. Once an opt-out has been triggered, the system connects the call to that VDN, after which the call is handled by the VDN as required. For example, it might put the call in a wait queue. The customer data is not passed along with the call.

When you choose the call to be sent to an Inbound/Blend job, the call is converted to an inbound call on the inbound/blend job. In this case, the customer data is passed along with the call depending on the NVDT configuration between the calling lists.

The completion codes associated with this feature are:

• OPTOUT (8) indicates that a call has been successfully opted out by the dialer to the configured destination.

• OPTOUTFAIL (10) indicates that an opt-out was requested by the called party, but the request could not be successfully carried out by the dialer. The reason for this failure is logged in the account log.

Opt-Out feature settings field descriptions

The following settings are listed in the **Opt-Out Features** group:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Should opt-outs be enabled?</td>
<td>Use this check box to enable the Opt-out feature.</td>
</tr>
<tr>
<td>Opt-out Digit</td>
<td>This field is visible only when you select the <em>Should opt-out be enabled</em> field. This is the digit (0 to 9) that the called customer must press in order to Opt-out of the call.</td>
</tr>
<tr>
<td>When an Opt-out happens, transfer to</td>
<td>This field is visible only when you select the <em>Should opt-out be enabled</em> field. Select the value for this field from the drop-down list. It specifies the action to be performed by the dialer when a customer opts out of a call. The options are Transfer to an inbound/blend job and Transfer to a VDN.</td>
</tr>
<tr>
<td>Opt-out Job</td>
<td>This field is enabled when you select the Transfer to an inbound/blend job option in the <em>When an Opt-out happens, transfer to</em> field. Select an inbound/blend job from the list provided. Calls that are opted out will be transferred to this inbound/blend job as an inbound call.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Opt-out VDN</td>
<td>This field is enabled when you select the Transfer to a VDN option in the <em>When an Opt-out happens, transfer to</em> field. You must provide a valid VDN in</td>
</tr>
</tbody>
</table>

*Table continues…*
### Passing called party number for opt-out calls to VDN

**About this task**

Avaya Proactive Contact Release 5.1.2 enhances the Opt-out to VDN feature so that the TRANSID feature works with a virtual job to allow one of the calling lists field data to be transferred as ANI to the agent.

**Note:**

This feature is available only for Avaya Proactive Contact with PG230.

**Procedure**

1. Click **Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor**.
2. Click the **Contact Management** button group.
3. Select a virtual job.
   
   The system displays the job details in the right-hand side of the pane.
4. Specify the calling list field name that you want to pass in the **Tagged trunk-to-trunk transfer data** field.
5. Click **Save**.

### Configuring Opt-out on Soft dialer

**About this task**

Before configuring the Opt-out feature on Soft dialer, ensure that you have made the configuration modifications related to the Opt-out feature in Communication Manager. For the procedure of configuring Opt-out on Communication Manager, refer Administering Avaya Proactive Contact.

**Procedure**

1. Log in to the Editor application.
2. Go to **Contact Management > Jobs**.
3. Select the required virtual job for which you want to enable the opt-out feature.
4. Make note of the script as displayed in the **Script label used for making calls** field on the right pane. You can also create a new script specifically for Opt-out.
5. Go to **Messages and Scripts > Scripts**.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>this field. Calls that are opted out will be connected to this VDN.</td>
<td></td>
</tr>
<tr>
<td>Message to be played when Opt-out fails</td>
<td>This field is visible only when you select the <strong>Should opt-out be enabled</strong> field. Select the voice message to be played from the drop-down list. If an opt-out fails, this is the message that will be played to the customer before the call is hung up.</td>
</tr>
</tbody>
</table>
6. Select the script as noted in Step 4 and make a note of the corresponding message number displayed in the **Script Actions** pane.

7. Go to **Messages and Scripts > Messages**.

8. Right-click the message number as noted in Step 6, and select **Change**.

9. In the **Where is the message stored?** text box, enter the Opt-out VDN as configured on the Communication Manager. Ensure that you enter the same VDN as configured on the Communication Manager, otherwise, the opt-out to agent feature might not work.

10. Save the messages file. You can save the file in the Pending stage, which will take effect when the dialer is restarted. The virtual calls are sent to the configured VDN where the call is further processed for the Opt-out feature.

### Post Processing settings field descriptions

The following setting in the **Post Processing** group is for every type of job: outbound, inbound, and blend:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Automatically start Update mode on customer hang up</strong></td>
<td>Use the check box to enable the setting. The system starts to record the time an agent takes to complete the after call work when the customer disconnects the phone call.</td>
</tr>
</tbody>
</table>
| **Autorelease Agent Method to use**           | Use this field to select the method to use when the system identifies the called party as an answering machine. After the system connects the call to a live agent, if the system detects an answering machine, it performs the action specified in this field. You can select from the following options:  
  - Hang-up the call and put the agent in ready mode.  
  - Leave the handling of Autovoice with agent.  
  - Play message and put the agent in ready mode.  
By default, this field is blank which indicates that the feature is disabled.  
This feature is not supported in the following scenarios:  
  - If the agent transfers the call before the system completes Call Progress Analysis (CPA).  
  - If the job is a managed job.  
  - If you select the **Run job with FCC** check box.  
  - If you are using Proactive Contact with CTI.  
For the Autorelease agent to voice mail feature, ensure that for the script used for making calls, you |
### Quota Settings field descriptions

The following settings in the **Quota Settings** group are for outbound or blend jobs.

In a multitenancy environment, you can use quota settings only for your tenant.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Quota setting (completion code, quota)</strong></td>
<td>Use this drop-down list to select a completion code. You can select a quota for the completion code. The system stops the job automatically when the number of completion codes reaches the quota.</td>
</tr>
<tr>
<td><strong>Quota settings file name</strong></td>
<td>Use the field to enter a name for the file that saves the quota settings.</td>
</tr>
<tr>
<td><strong>Save quota setting when the job ends</strong></td>
<td>Use this option to save the quota setting when the jobs end. The system continues to use the quota setting the next time the job starts. However, if the quota reached its limit in the previous run of the same job, then the system resets the quota when the job restarts.</td>
</tr>
</tbody>
</table>

### Recall settings

An agent-owned recall is when an agent sets a recall on the agent name.

An agent might leave the job before the recall time but the job continues to run at the time of recall. In that case, at the time of the recall, the system converts the recall to a general recall after the specified number of retry attempts and then passes the call to an available agent.

However, if the job is shut down before the time of recall, then at the time of recall, the system creates a shadow job for all the AORs in the job. These AORs are indexed in the `shadowjob.lst` file located in `opt/avaya/pds/lists` folder. The system automatically starts
the job the next day or when the dialer services are restarted. The system repeats the job every
day until all the AORs are processed.

In the multitenancy environment, the AORs can be handled only within the tenant and not across
the tenants, even if the agent who had set the recall is active on another tenant. For example, if an
agent belonging to two tenants sets an agent-owned recall on one tenant and, at the time of the
recall, moves to another tenant, then the system converts the AOR into a general recall after the
specified number of retry attempts.

The shadow job does not take the recall setting from the original job. By default, the shadow job
takes the settings from master.cfg for the retry and other parameters. The recall interval for
shadow job is decided by the RECALL_INTERVAL parameter in master.cfg file. The value for
this parameter is defined in minutes. The parameter for number of retries for Jobs is
RECALL_NUMOFTRY available in master.cfg file.

The shadow jobs for unresolved AORs continue for an infinite period of time. You cannot send a
message or monitor an agent line for an agent who is on a shadow job to address an AOR.

Release 5.1.2 of Proactive Contact supports shadow jobs in preview and predictive modes also.

Recall settings field descriptions

The following settings in the Recall group are for outbound or blend jobs.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recall reschedule interval (minutes)</td>
<td>If your system uses Agent Owned Recall, this field is visible. Use the field to enter the minimum number of minutes that must elapse before the system tries to pass the agent a recall.</td>
</tr>
<tr>
<td>Recall notification time (minutes)</td>
<td>If your system uses Agent Owned Recall, this field is visible. Use the field to enter the time in minutes during which the system looks for the agent who set up the recall on the job and is available for a call.</td>
</tr>
</tbody>
</table>
| Number of recall attempts           | If your system uses Agent Owned Recall, this field is visible. Use the field to enter the number of times to look for the agent that set up the recall. The value can range between 0 to 10. You must note the following before you set this value:  

  • If this value is set to 0, the system checks for the originating agent and if that agent is not currently on any job in the system and the same tenant, then the system does not forward the call.

  • If this value is set from 1-10, the system checks for the originating agent and if that agent is not currently on any job in the system and the same tenant, the system changes the Agent Owned Recall to a General Recall (after the number of attempts has been reached) and gives the call to

Table continues…
the next available agent. However, this is true only for the original job where the recall is set. If a job ends, and the recall is not made, the agent owns the recall from that point on and the call is no longer a general recall.

- Latelist/Latemark must be configured to bring recall information forward day-over-day

In both the cases, if the originating agent is still on the Job, then the call goes to that agent.

### Escape General Recall

**Note:**

This feature is applicable only for the infinite jobs because this feature requires the job to be running when the recall happens.

Earlier if there was no agent on a job, the daily recalls used to expire. As a result, to handle the recalls, at least one agent had to remain on the job even if there was no record to call. However, now the recall can happen even though there is no agent available on the job for which the recall has been set.

You can set the escape agent owned recall through Editor at the time of creating a job. At the same time, you can also define the job from which the agent should be pulled in to address the recall. As the time of recall comes, the system looks for the most appropriate agent who is free to handle the recall, and connects the recall to that agent. After completing the recall, the agent is sent back to the pool.

You can change the job from which the agent to be pulled in using Monitor at run-time.

You can turn on and turn off this feature at the job level in the Job Details pane. By default, the recall escape feature remains OFF.

### Escape general recall field descriptions

The following settings in the Recall group are to enable the Escape general recall functionality:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto assign recall from Infinite job to agents on another job</td>
<td>Use this check box to enable the escape recall option.</td>
</tr>
<tr>
<td>Name of the job to get agent for recall</td>
<td>Use this drop-down list to select the name of the job from which the agent should be pulled in to attend to the recall.</td>
</tr>
</tbody>
</table>
Service Level settings field descriptions

Proactive Contact uses the Desired Service Level and Time to connect tolerance settings for real-time monitoring and reporting of outbound, inbound, and blend jobs.

For jobs that use Cruise Control, Proactive Contact uses the Desired Service Level and Time to connect tolerance settings to predict when to automatically dial phone numbers and distribute the calls within the tolerable time period.

Important:

If you select Cruise Control in the Call Pacing group, you must set the Desired Service Level and Time to connect tolerance settings.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Desired service level (percentage)</td>
<td>The target percentage of serviced calls that you want the system to maintain. Enter percent value that is from 70 through 99. The default value is 99.</td>
</tr>
<tr>
<td>Time to connect tolerance (seconds)</td>
<td>The number of seconds that you will allow a phone call to be delayed waiting for an agent before the system designates the call as a nuisance call. Typically you want to allow a minimum time delay before the system sends the phone call to an agent. Enter a number from 0 (zero) through 9. The default value is 1</td>
</tr>
<tr>
<td>OFCOM timer</td>
<td>The duration, in seconds, after which the OFCOM rule is applied to a call.</td>
</tr>
<tr>
<td>OFCOM False Positive Rate</td>
<td>The percentage of acceptable false positives between 0 to 10. As per the OFCOM guideline, the OFCOM False positive rate should always be 3% or less than 3%. The system enables the OFCOM False Positive Rate field only when the Job is configured with the strategy, Voice call to be passed to Agent. If the Job is configured with Voice and Auto Voice calls to be passed to Agent, then the OFCOM False Positive Rate value is reset to 0 and you cannot configure this value.</td>
</tr>
<tr>
<td>Short call Timer</td>
<td>A specific value below which if agent talk in the call, the call is considered as a Short call.</td>
</tr>
</tbody>
</table>

Related links

Accessing Call Pacing method on page 232
Wait Queues settings field descriptions

The following settings in the **Wait Queues** group are for outbound, inbound, and blend jobs. The system displays the appropriate settings for the job.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Total wait delay (seconds)</strong></td>
<td>Use the field to enter the maximum number of seconds for which the customer can wait in the wait queue. You can select the value starting from 0 to 999. Note that if the wait queue handling is of shorter duration, then the call will be hung up irrespective of the value defined in this field.</td>
</tr>
<tr>
<td><strong>Inbound wait queue limit (seconds)</strong></td>
<td>Use the field to enter the number of seconds from 0 to 999 that the customer can wait in the inbound wait queue before the system ends the call.</td>
</tr>
<tr>
<td><strong>Transfer on hold message number</strong></td>
<td>Use the field to enter the number of the message that users hear during the call-transfer process.</td>
</tr>
</tbody>
</table>

Using jobs

Creating a job

About this task

In default tenant, in a pod, the same job name can exist on each dialer. To ensure consistent monitoring and reporting, use the same settings for the same job name on each dialer.

In a multitenancy environment, the job name must be unique for each tenant space.

Job names must adhere to the following guidelines:

- Maximum of 20 characters for an English name
- Maximum of 15 characters for languages other than English
- Special characters, such as dots, are not supported

Procedure

1. In the Editor button bar, select a dialer, and then click **Jobs**.
2. Click **File > New**.
3. Click **Next** when the Editor Job Wizard appears.
4. Select settings to specify the type of job you want to create, the appropriate outbound or inbound calling list, and the job options you want to use:
   • Sales Verification
   • Unit Work List
   • Virtual
   • Managed

5. When you finish the wizard, the default tree structure for your job type, such as inbound, outbound, or blend appears in the right-hand pane.

6. Use the Setting and Value columns to select and edit values.

Related links
   Outbound jobs on page 225

---

**Viewing job settings**

**Procedure**

Select the job you want to view.

The job settings appear in the right-hand pane.

---

**Saving a job**

**About this task**

In a pod, the same job name can exist on each dialer.

To ensure consistent monitoring and reporting, use the same settings for the same job name on each dialer. For more information, see Outbound jobs on page 225.

To save a job:

**Procedure**

1. Select File > Save to save the job.
   If needed, provide a name.
   Job names must adhere to the following guidelines:
   • Maximum of 20 characters for an English name
   • Maximum of 15 characters for languages other than English
   • Special characters, such as dots, are not supported

2. Click OK.

Related links
   Outbound jobs on page 225
Saving a job with another name

About this task
You can save a job with another name. However, the option to save the job on a different dialer is available only for the default tenant.

Procedure

1. Select the job you want to save.
2. Click **File > Save As**. If the multi-dialer option is enabled in case of only the default tenant, select the additional dialers to which you want to save the job. If the dialer check boxes are unavailable and you want to enable them, select **Settings > Options**.
3. Enter a name for your job, and then click **OK**. The job is saved to the dialer you selected.

Starting a job on one or more dialers

About this task
You are not required to run a record selection before starting a job. Editor automatically executes the record selection if needed, and starts the job. If the job verification passes, you are offered a choice of starting the job or cancelling the action.

To start a job on one or more dialers:

Procedure

1. Select the job you want to start.
2. Select **File > Run**. If the multi-dialer option is enabled, you are asked if you want to run the job on additional dialers. Select additional dialers on which you want to start the job.
3. Click **OK**.

**Note:**
Proactive Contact allows a maximum of 200 jobs to be running simultaneously. If the job that you want to start exceeds the system limit, then the job will not start and a message is displayed stating that the maximum concurrent job limit has been reached. In this case, to run the desired job, you must stop any other job running at that time. For more information on the calculation of jobs in the system, see Maximum number of jobs allowed on page 226.

Related links

Maximum number of jobs allowed on page 226
Starting multiple jobs on currently selected dialer

Procedure

1. Select the job you want to start.
2. Select File > Run.
3. Click OK.

List or a Job sharing

This feature is available only for the default tenant.

There are two basic categories for the functionalities that the List Sharing includes:

- Shared Calling List (commonly referred to as list sharing)
- Shared Campaigns (commonly referred to as job sharing)

Shared Calling List: This feature provides the ability for any dialer in a pod to use a calling list that physically resides on another dialer CPU's Hard Drive. This allows one Dialer application Server to house a single calling list which three other dialer applications in the pod can use for calling in their own jobs.

Job sharing goes one step further and effectively allows all dialer applications in a pod to concurrently run the same job on the same call selection. This allows a much larger number of agents spread across multiple systems to call the same records. In actuality, each dialer will have its own job, with a unique job number and a unique call selection index. However, as long as all systems are calling on the campaign, the indexes will keep updating each other so that each system knows which records have already been called and will pick the next available record.

Shared Campaigns: This feature allows you to share a campaign across two or more dialer applications in a POD.

This feature can only be used in the GUI (Graphical User Interface). The CUI (Character User Interface) does not support this feature.

You must have Multi-Dialer option enabled in the Editor. From the Editor menu, go to Settings > Options > Multi-Dialer tab, click enable in Multi-dialer settings and then select the check box for each system you wish to control in Multi-dialer.

With Multi-dialer settings enabled, when a Proactive Contact Supervisor saves the Phone Strategy, Record Selection, and Job configurations, a message is displayed confirming to save the changes to the file to one or more systems.

You will need to save any changes to all dialers which will be sharing the job to ensure that job files amongst the systems are the same. If any configurations in the strategy, selection, or jobs are mismatched in any way, the job sharing feature can result in displaying odd behavior.
When using Shared Campaigns, the following configuration files must be the same on all Proactive Contact systems:

- locale.cfg
- timezone.cfg
- telephny.* scripts (telephny.spt, telephny.labels, telephny.alljobs.dat)
- post update files (if used), there must be PU*.cfg files that specify the remote list.
- ORDERBYZONES must be set to the same on all jobs, either YES or NO

**Note:**
If a campaign is different from the others, the jobs will compete for records.

---

**Office of Communication (OFCOM)**

The Office of Communication (OFCOM) U.K. releases a statement of policy on the persistent misuse of an electronic communication network or service. This policy applies to predictive dialers that make calls in U.K. For details refer to:


OFCOM specified changes in their Revised statement of policy on the persistent misuse of an electronic communications network or service on October 30, 2009.

The changes in this policy (applicable only to the United Kingdom) are as follows:

[http://www.ofcom.org.uk/consult/condocs/persistent_misuse/amendment/amendment.pdf](http://www.ofcom.org.uk/consult/condocs/persistent_misuse/amendment/amendment.pdf)

Editor application has been updated to enable the new OFCOM policy.

**Note:**

<table>
<thead>
<tr>
<th>Hard Dialer with PG230 environment</th>
<th>CTI Dialer/Soft Dialer environment</th>
</tr>
</thead>
<tbody>
<tr>
<td>The OFCOM feature is available only on the Proactive Contact PG230RM dialer.</td>
<td>The OFCOM feature is available only on the Avaya Proactive Contact PG230RM dialer.</td>
</tr>
<tr>
<td>To use the OFCOM feature in Proactive Contact, you might need to configure some parameters in the master.cfg file. To configure these parameters, contact Avaya Professional Services.</td>
<td>This feature is not supported on the Proactive Contact with CTI dialer.</td>
</tr>
<tr>
<td>The Avaya OFCOM feature is not approved for use in the Proactive Contact CTI Dialer (Soft Dialer). If the OFCOM feature is enabled in the customer’s Proactive Contact CTI Dialer (Soft Dialer), it will be subject to the Support Limitations and Exclusions contained in the applicable Service Agreement Supplement, and Avaya will have no obligation to support, diagnose or correct problems caused by or associated with the OFCOM feature.</td>
<td></td>
</tr>
</tbody>
</table>
2016 OFCOM implementation

The existing Abandon Call Rate (ACR) formula is modified to reflect in existing OFCOM reports in both Monitor and Analyst application. The completion codes can be configured to allow the Agents to mark a false negative call. The number of false negative calls are excluded from the ACR formula. Also, the phone numbers associated with these calls are restricted for 24 hours as they were marked as answering machine by Agents. OFCOM reports are also modified to display the Short calls. If a call to one of the number in a record is abandoned, this enhancement also restricts all the numbers associated in that record for 72 hours.

Changes in Editor

Following are the two new parameters introduced in the Editor in the job module:

- Completion codes excluded from Abandon rate - User can select the completion codes to be excluded from ACR calculation.
- Short call Timer – If Agent talk time is less than the value specified, then that call is considered as a Short call.

Note:

To enable or modify ACR exclude codes in an OFCOM job, create a new job instead of adding the codes to an existing job. Creating a new job ensures that the ACR Excl Count and Abandon Rate columns in the summarized monthly OFCOM reports display correct information.

Changes in Monitor

Following are the two new columns added:

- New column Calls Excluded from ACR is introduced in JobCompletionCode view. Calls Excluded from ACR column displays the number of calls marked as false negative by the agents and these calls are excluded from the abandon call rate formula.
- New column Short Calls Count is added in JobQuality view which displays short call count.

Changes in Analyst

Following are the two new columns added in all OFCOM reports:

- ACR Excl Code Count - Displays the number of calls marked as false negative by the agents and these calls are excluded from the abandon call rate formula.
- Short calls count – Displays the Short call count.
Creating a script for OFCOM compliant jobs

About this task

As per section 4.16.2 of the OFCOM policy, an OFCOM compliant message should be created to be played. This message must be used in the OFCOM script.

To create a script for OFCOM compliant jobs:

Procedure

1. Log in to the Editor application.
2. Click Scripts.
   The Scripts pane appears.
3. Click File > New.
   Editor opens the Message Script Wizard window.
5. In the Selecting when the script should run page, select Outbound.
6. Click Next.
7. In the Selecting how to handle calls answered by a person page, select Yes, and select Apply OFCOM rule on this script option.
8. Click Next.
9. In the Add an action page, under What do you want to do?, select Play a message.
10. Select the created OFCOM message you want to play from the Select a message to play box.
11. Click Next.
12. In the Do you want to play a message automatically before passing call to agent or into wait queue page, select No.
13. Click Next.
14. Name the script and type a brief description of the script.
15. Click Next, then click Finish. On the Detail tab on the right, the new script appears.
16. Click Save.
17. In the Save As window, select Pending stage.
   The script will be available for use when the dialer is restarted.
Enabling OFCOM for a job

About this task

You can enable OFCOM only on a blend or outbound job.

To enable OFCOM for a job:

Procedure

1. Log in to the Editor application.
2. Under **Contact Management**, select **Jobs**.
3. Select **Job for which you want to enable OFCOM**.
4. In the Job Details pane, under Job Type, select **Run job with OFCOM**.
5. Under **Labels**, in the Script label to use OFCOM, select the OFCOM script.
6. Under **Service Level**, in the OFCOM Timer, provide a value for the OFCOM timer in seconds.

   **Note:**

   This value must be between 0.5 seconds and 9 seconds and can be specified to a tenth of a second. If a value less than 0.5 seconds is provided, then the default value of 2 seconds is used. If a value more than 9 seconds is provided, then the maximum value of 9 seconds is used.

7. Under **Job Type**, in the **Start Ofcom timer when**, select the event from which the OFCOM timer starts. There are two events available:

   • Customer begins to speak: When this is selected, the OFCOM timer will start from the start of voice energy that is when the customer begins to speak.
   • Customer takes phone off-hook: When this is selected, the OFCOM timer will start when the customer picks up the phone.

   **Note:**

   The OFCOM regulation states that you must save six-months-old detailed data in the database. The users who follow OFCOM regulation are recommended to set the ROLLNCLEAN parameter to 6 in the `master.cfg` file on the dialer.

Result

As per the 24-hour rule of OFCOM, if the system detects an answering machine as the called party, then you must not call the same record again on the same day. A day is from 00:00 a.m. to 11:59 p.m. In a multitenant environment, apply this rule at the job level by setting the OFCOMAMD parameter in the `master.cfg` file to JOB, which is the default option. For a default tenant, set the value of the OFCOMAMD parameter to DIALER or JOB as required.
OFCOM 72–hour compliance

The OFCOM 72-hour regulation specifies that you must have a 72-hour period before a telephone number receiving an abandoned call might be called again without the guaranteed presence of an agent. There must be a live operator if you are making a repeat call to a number to which a nuisance call was made. Proactive Contact supported the OFCOM 72-hour regulation on a per-record basis. From Proactive Contact 5.1.2, Proactive Contact also supports the OFCOM 72-hour regulation on a phone number basis.

To comply with the OFCOM 72-hour regulation, Proactive Contact adds a new parameter, OFCOM72 in the master.cfg file. You can set the OFCOM72 parameter for a job, a tenant, or a dialer. If you set this parameter, without the guaranteed presence of a live operator, no repeat call is made to a number that received a nuisance call in the prior 72 hours.

⚠️ Important:

Avaya Proactive Contact Release 5.1.2 and later supports OFCOM 72–hour regulation on a phone number basis.

You must set the OFCOM parameter in the Job file for the OFCOM72 parameter to be effective. A completion code, CODE 9, is applied to calls that are a repetition of earlier attempted nuisance calls. You can use this completion code in the strategy file to set retries on other phones. You can also use the completion code in selection criteria to select the records for calling again.

FCC 12-21 regulation compliance

This release of Proactive Contact is compliant to the FCC 12-21 regulation. To use the FCC-related changes in Proactive Contact, you must use the PG230 generic firmware 18.1.2 or later.

🌟 Note:

To use the FCC-related changes in Proactive Contact, you might need to configure some parameters in the master.cfg file. To configure these parameters, contact Avaya Professional Services.

Configuring the DNC opt-out feature on dialer

Procedure

Set the following parameters in the master.cfg file:

- FCC_ACT_DATE
- FCC_TIME
- FCC_VDN
Ensure that you set the same VDN for the FCC_VDN parameter as configured on the Communication Manager, otherwise, the DNC opt out feature might not work.

The FCC 12-21 regulation has been implemented on both Proactive Contact with PG230RM and Proactive Contact with CTI.

---

**FCC 12-21 regulation on Proactive Contact with PG230RM**

**FCC 12-21 regulation for a virtual job**

- The called party can opt-out of the virtual call and connect to a live agent by pressing a pre-designated digit. After the call is connected to an agent, the option of DNC opt-out by pressing the pre-designated digit is not available.

- The called party can opt-out of the virtual call and mark the record as DNC in the system by pressing a different pre-designated digit. In this case, the system marks the record as DNC instead of transferring the call to a live agent. The record is marked as DNC in all the calling lists belonging to the DNC group for that campaign.

**Note:**

The DNC opt-out digit must be different from the opt-out to agent digit configured in the virtual job. On the Editor application, the system validates that the opt-out to agent option and opt-out to DNC option do not use the same digit. The DNC opt-out option is available throughout the duration of the call.

**Implementing the FCC 12-21 amendment for a virtual call**

**Procedure**

Configure a message that can be a combination of the following:

- A DNC opt-out message that provides instructions to the called party on how to add their record to the DNC list.

- A general opt-out message that provides instructions to the called party on how to opt out from a voice message and connect to an agent.

- A virtual message for business purpose.

**FCC 12-21 regulation for live outbound calls**

In case of outbound live call on Proactive Contact with PG230RM, if a welcome message is played to the called party before connecting to the agent, the system provides the DNC opt-out option to the called party throughout the duration of the welcome message. After the welcome message, the call must be connected to a live agent within two seconds. The two second timer begins after the end of the welcome message. If the system is not able to find an available agent, then the call is put in the wait queue.

While the call is in wait queue, if the system finds an available agent at any point of time, the call is connected to the agent. If the system cannot find an agent to attend to the call within two seconds
of the end of welcome message, the system marks the call as an FCC nuisance call. However, the called party continues to be in the wait queue until:

- The call is connected to a live agent.
- The called party chooses DNC opt-out.
- The called party terminates the call.
- The system terminates the call.

After the system connects the called party to the agent, then the automated DNC opt-out mechanism becomes unavailable. However, the called party can still request the agent to mark the record as DNC. A new completion code is introduced for DNC opt-out. The code 97 is sent out to the dialer if the called party initiates the DNC opt-out. If you have configured the system to not play a welcome message to the called party, then the FCC timer starts as soon as the call is answered and the wait queue messages are played as configured.

The Analyst module of the Supervisor suite provides a report for FCC nuisance calls that displays the FCC nuisance call data for a job for each 30-day period.

To contain the FCC nuisance rate to the 3% limit for each job automatically, you can use the cruise control job by setting the some parameters.

In case of Proactive Contact with PG230RM:

- An inactive or non-existent DSP2 card configured as DTMF Receiver causes the DNC opt-out feature to fail. This failure can be detected by the dialer only during runtime, and it is logged subsequently. To procure additional DSP2 cards, contact Avaya Customer Care.
- In case of virtual campaigns, you must keep the number of DTMF receivers equal to the total number of outbound ports in the DNC opt-out enabled campaigns. In case of outbound jobs, each call that plays the welcome message or wait queue message requires a DTMF receiver resource for the duration of the message.
- According to your calling activities and requirements, you must set the number of DTMF receivers which must be sufficient to address the following conditions in an outbound call:
  - Welcome message
  - Wait queue
  - Virtual message

**Setting parameters for cruise control job**

**Procedure**

1. Set the FCC_TIME parameter in master.cfg to 2 seconds.
2. Set the NUISANCE_TIME parameter in master.cfg to 1 second.
3. Set the CONNTOLE parameter in the Job file, which is Time to connect tolerance (seconds), to 1 second.
4. Set the desired service level as required, for example, 97% to limit the FCC nuisance rate within 3% for the job.
FCC 12-21 regulation on Proactive Contact with CTI

In case of Proactive Contact with CTI, you must configure the Do not call feature in Avaya Aura® Communication Manager. In Communication Manager, you must set up two VDNs with two different vectors.

When the called party initiates DNC opt-out by pressing the pre-defined digit during the virtual call, then:

- The first VDN redirects the call to the second VDN. Proactive Contact monitors the second VDN.
- When the call reaches the second VDN, Proactive Contact registers that record in the DNC list.
- Dialer terminates the call.

In a virtual job on Proactive Contact with CTI, if the system detects that the called party is an answering machine, then the system does not collect the DNC opt-out or opt-out to agent digits.

In case of an outbound job on Proactive Contact with CTI, if the called party opts for DNC during the welcome message while the data for the call is displayed on the agent screen, then the system performs the following:

- Processes the call for DNC and disconnects the called party.
- Displays the Release Line dialogue box on the agent screen. The agent can select a desired completion code and release the call. However, the dialer overrides the code selected by the agent and marks the call as DNC Opt-Out by automatically assigning completion code 97 to the call.

In case of Proactive Contact with CTI, the voice path gets established after the welcome message completes. Therefore, you must instruct the agents to not release the call manually in case the agents view the customer data on the screen but do not hear any voice on the call. If the called party opts out to DNC during the welcome message, then the agents receive an auto-release message on the screen. If the agent hears the voice, then there is no change in the existing behavior.

**Note:**

You must enable the autowrap functionality if you have a welcome message configured for the job.

In an outbound job, if an agent cannot be found within the FCC timer duration of the called party answering the call, then the call is terminated with code 48, which indicates that the dialer could not find an agent for the outbound call. However, if the called party presses the DNC opt-out digit, then the call is marked as code 97, which is the DNC opt-out completion code.
Enabling FCC nuisance rate reporting for each job on the Editor application

**Procedure**

1. Log in to the Editor application.
2. Click **Job > Job Details**.
3. Select the **Run job with FCC** check box.

**Result**

As you select the **Run job with FCC** check box, the system starts the FCC nuisance rate calculation for the job.

**Note:**

You must not select the **Run job with FCC** check box in Editor for managed jobs as the FCC feature is not required in the managed jobs. If you select the **Run job with FCC** check box for a managed job, the FCC nuisance rate report might display incorrect data.

---

Enabling FCC opt-out for a job

**About this task**

In Proactive Contact Supervisor, using the Editor application, you can configure the FCC opt-out feature at the job level.

**Procedure**

1. Log in to the Editor application.
2. Click **Job > Job Details**.
3. In the Digit to press for FCC opt-out field, enter the digit that must be used for FCC opt-out.
4. **(Optional)** Select a confirmation message from the **Message to be played after FCC opt-out** drop-down list. The system plays this confirmation message to the called party after the called party opts for DNC.

**Note:**

You must enable either the OFCOM or the FCC feature for a job. Do not enable both the features for a job.

**Result**

If the FCC related data, such as FCC opt-out, FCC jobs, and nuisance calls, does not get populated to the database, you can populate the data to the database manually by running the dbpopulate script.
Manual dialing

With Manual dialing, Avaya Proactive Contact does not dial a number automatically. An agent can dial a number manually (digit-by-digit) on an associated phone, assisted by additional software (softphone) or manually through Avaya Proactive Contact. This enhancement is made to allow scenarios where automatic dialing might not be desirable because of regulatory limitations.

You can enable Manual dialing for a new managed job or for an existing managed job by configuring the following parameters:

- Manual Mode Dialing
- Dial with Third Party

If you set the Manual Mode Dialing parameter, the limit for preview is set to zero.

If you set the Dial with Third Party parameter for a job, the dialer cannot dial the call. An agent must dial the phone number through a third-party application. If a the third-party application is integrated with PC Agent, when the agent clicks the Click to dial link, the third-party software on the agent desktop launches. The phone number that the agent selects is passed to the third-party software.

If a third-party application is not integrated with PC Agent, an agent must dial the call manually using the third-party application.

To know which third-party software is supported, see Avaya Support site at https://support.avaya.com/CompatibilityMatrix/Index.aspx

Enabling manual dialing

Procedure

1. Log in to the Editor application.
2. Select a managed job.
3. On the Job Details pane, under Managed Dialing, select the Manual Mode Dialing check box.

   The system displays the following message: Time limit preview will be set to zero for manual dial enabled job.
4. Click OK.
5. Save the job.

Enabling third party dialing

Before you begin

You must enable manual dialing before enabling third party dialing.
Procedure

1. Log in to the Editor application.
2. Select a managed job.
3. On the Job Details pane, under Managed Dialing select the Dial with Third Party Application check box.
4. Save the job.

Maintaining jobs

Copying a job

Procedure

1. Select the job you want to copy.
2. Click File > Save As.
   - If the multi-dialer option is enabled, select the dialer where you want to copy a job.
3. Enter a name for the job, and then click OK.

Editing a job

Procedure

1. Select File > Open.
2. Select the job you want to edit, and then make the necessary edits in the right-hand pane.
3. Click File > Save As.
   - If the multi-dialer option is enabled, select the additional dialers to save the job to.
4. Enter a name for the job, and then click OK.

Verifying a job on one or more dialers

Procedure

1. Select the job you want to verify.
2. Select File > Verify.
3. If the multi-dialer option is enabled, the system displays a message to select whether or not to verify the job on additional dialers. Specify your preferences, and then click OK.
The results of the verification, including any settings that are in error, appear in a separate window.
4. Review the results and click **OK**.

---

### Verifying multiple jobs on the currently selected dialer

**Procedure**

1. Shift-click to select all the jobs you want to verify.
2. Select **File > Verify**.

---

### Deleting a job on one or more dialers

**Procedure**

1. Select the job you want to delete.
2. Select **File > Delete**.
   
   If the multi-dialer option is enabled, the system displays a message to specify whether or not to delete the job from additional dialers. Make your selections, and then click **OK**.
3. When the system displays a message, click **Yes** to delete the job.

---

### Deleting multiple jobs on the currently selected dialer

**Procedure**

1. Control-click to select the jobs you want to delete.
2. Select **File > Delete**.
   
   If the multi-dialer option is enabled, the system displays a message to specify whether or not to delete the job from additional dialers. Make your selections, and then click **OK**.
3. When the system displays a message, click **Yes** to delete the job.

---

### Listing all jobs on a selected dialer

**Procedure**

1. Select the dialer name on the button bar.
2. Click **Job**. A list of jobs on the selected dialer appears.
## Options dialog box field descriptions

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multi-dialer tab</td>
<td></td>
</tr>
<tr>
<td>Multi-dialer settings, Enable or disable multi-dialer commands</td>
<td>Use <strong>Enable</strong> to enable multi-dialer commands. Use <strong>Disable</strong> to disable multi-dialer commands.</td>
</tr>
<tr>
<td>Multi-dialer commands apply to</td>
<td>Use the list to select the dialer you want to use.</td>
</tr>
<tr>
<td>Save tab</td>
<td></td>
</tr>
<tr>
<td>When saving to an existing filename</td>
<td>Use <strong>Prompt before overwrite</strong> to receive a message before saving. Use <strong>Overwrite without asking</strong> to save without receiving a message.</td>
</tr>
<tr>
<td>Refresh tab</td>
<td></td>
</tr>
<tr>
<td>How often should data be refreshed on the screen</td>
<td>Use the interval at which you want Editor to refresh.</td>
</tr>
</tbody>
</table>

## Screens dialog box field description

The Screens dialog box allows you to select screens to use during a job.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Available screens</td>
<td>This field lists the agent screens defined for the system.</td>
</tr>
<tr>
<td>Screens (in order)</td>
<td>This field lists the selected screens in the sequence that a job will use them.</td>
</tr>
<tr>
<td>Selection buttons</td>
<td>Use this field to move one or more selected screens between lists. The options are:</td>
</tr>
<tr>
<td></td>
<td>• &gt;: Moves a selected screen in the Available screens list to the Screens (in order) list.</td>
</tr>
<tr>
<td></td>
<td>• &gt;&gt;: Moves all the screens from the Available screens list to the Screens (in order) list.</td>
</tr>
<tr>
<td></td>
<td>• &lt;: Moves a selected screen from the Screens (in order) list to the Available screens list.</td>
</tr>
<tr>
<td></td>
<td>• &lt;&lt;: Moves all the screens from the Screens (in order) list to the Available screens list.</td>
</tr>
<tr>
<td></td>
<td>You can also use the up and down arrow keys to change the order in which the screens appear</td>
</tr>
</tbody>
</table>
Chapter 18: Pattern matching rules

Default pattern syntax

Proactive Contact supports pattern matching syntax including wildcard characters. In Editor, you use basic pattern matching syntaxes when creating and editing phone strategies and record selections. You can also use more complex pattern matching syntaxes.

Proactive Contact also supports the following pattern matching syntax:

- Integer
- Floating point
- Date
- Time
- String
- Shell-style
- Extended regular expression-style

Field types are supported in dialer calling lists.

Related links

- Expected pattern syntax for field types on page 270
- Explicit pattern syntaxes on page 271

Expected pattern syntax for field types

The following table shows which pattern syntax is expected for each field type by default:

<table>
<thead>
<tr>
<th>Field type symbol</th>
<th>Field type description</th>
<th>Default pattern syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>$</td>
<td>Currency Amount</td>
<td>Floating point Numerical comparison syntax</td>
</tr>
<tr>
<td>N</td>
<td>Number</td>
<td>Numerical comparison syntax</td>
</tr>
<tr>
<td>D</td>
<td>Date</td>
<td>Date conversion + Time conversion</td>
</tr>
<tr>
<td>T</td>
<td>Time</td>
<td>Time conversion + Numerical comparison syntax,</td>
</tr>
<tr>
<td>C</td>
<td>Character</td>
<td>String comparison syntax, then Shell-style pattern syntax</td>
</tr>
</tbody>
</table>
If the pattern fails to compile with the default syntax, other syntax types are tried in turn, until one succeeds or fails.
If all compile attempts fail, only the error message for the first failure is reported.

---

**Explicit pattern syntaxes**

You can explicitly designate a pattern syntax by beginning your pattern with the field type symbol of the comparison followed by a `@` character.

The following table lists the explicit syntax for data types:

<table>
<thead>
<tr>
<th>@ Type</th>
<th>Data description</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>$@</td>
<td>Currency amount</td>
<td>Floating point numerical comparison syntax</td>
</tr>
<tr>
<td>F@</td>
<td>Floating point</td>
<td>Floating point numerical comparison syntax</td>
</tr>
<tr>
<td>N@</td>
<td>Integer</td>
<td>Numerical comparison syntax</td>
</tr>
<tr>
<td>D@</td>
<td>Date</td>
<td>Date conversion + numerical comparison syntax</td>
</tr>
<tr>
<td>T@</td>
<td>Time</td>
<td>Time comparison syntax + numerical comparison syntax</td>
</tr>
<tr>
<td>C@</td>
<td>Character</td>
<td>String comparison syntax, then Shell-style pattern syntax</td>
</tr>
<tr>
<td>S@</td>
<td>String</td>
<td>String comparison syntax</td>
</tr>
<tr>
<td>P@</td>
<td>Any</td>
<td>Shell-style pattern syntax</td>
</tr>
<tr>
<td>E@</td>
<td>Any</td>
<td>Extended regular expression syntax</td>
</tr>
</tbody>
</table>

For example, if you are working with a number field but want to use shell-style pattern matching syntax instead of numerical comparison syntax, you could begin the pattern with P@.

This is known as explicit pattern syntax specification. For example P@12* would match against any numerical value beginning with 12.

---

**Supported syntaxes**

Integer numerical values can be given in any integer notation, such as optional spaces, followed by an optional + or -, followed by one or more digits.

This section contains the syntaxes used by the Proactive Contact system.

---

**List separators**

The following syntaxes are supported:

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>!</td>
<td>List separator ('or' operator)</td>
</tr>
</tbody>
</table>
Pattern matching rules

<table>
<thead>
<tr>
<th>,</th>
<th>List separator ('or' operator)</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;</td>
<td>List separator ('and' operator)</td>
</tr>
</tbody>
</table>

To use any of these symbols explicitly in a pattern, and not as list separators, you must precede them with a backslash. For example: \\!.

**Numerical comparisons (type N, $, F)**

A numerical comparison pattern must contain at least one numerical value and one legal numerical comparison operator. It may contain one or more list separators (, ! &).

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>==</td>
<td>Match if equal to</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Match if not equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>Match if greater than</td>
</tr>
<tr>
<td>&lt;</td>
<td>Match if less than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Match if greater than or equal to</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Match if less than or equal to</td>
</tr>
<tr>
<td>-</td>
<td>Match if within inclusive range</td>
</tr>
</tbody>
</table>

Floating point numerical values can be given in any legal floating point notation, such as the following syntax:

<optional spaces> <optional + or -> <one or more digits>.<one or more digits>.

**Example Numerical Comparisons**

<table>
<thead>
<tr>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&gt;123</td>
<td>Match if greater than 123</td>
</tr>
<tr>
<td>&gt;=123.45</td>
<td>Match if greater than or equal to 123.45</td>
</tr>
<tr>
<td>&lt;=123</td>
<td>Match if less than or equal to 123</td>
</tr>
<tr>
<td>&lt;=+12.34</td>
<td>Match if less than or equal to 12.34</td>
</tr>
<tr>
<td>=123.0</td>
<td>Match if equal to 123</td>
</tr>
<tr>
<td>==123</td>
<td>Match if equal to 123</td>
</tr>
<tr>
<td>123-456.78</td>
<td>Match if in range of 123 to 456.78</td>
</tr>
<tr>
<td>-200–100</td>
<td>Match if in range of -200 to -100</td>
</tr>
<tr>
<td>=123,456</td>
<td>Match if 123 or 456</td>
</tr>
<tr>
<td>=123!&gt;456</td>
<td>Match if 123 or greater than 456</td>
</tr>
<tr>
<td>&gt;123 &amp; &lt;=456</td>
<td>Match if greater than 123 and not equal to 456</td>
</tr>
</tbody>
</table>

**Date Comparisons (Type D)**

Date comparisons are handled by first converting each date in the pattern to an 8-digit integer with the digit order CCYYMMDD, then compiling the resulting pattern using integer numerical
comparison syntax. The same conversion is done to the target date during the comparison operation.

To use this comparison syntax, the dates must follow the format in the DATEFORM parameter of master.cfg. Otherwise, dates could be compared as simple strings using a shell-, ERE-, or string-style pattern notation.

A relative date feature is supported for date comparisons.

Instead of an explicit date, you can use any of the notations $TODAY, $TODAY + n, or $TODAY - n, where n is an integer. These will be converted into today's date +/- n days.

### Example Date Comparisons

<table>
<thead>
<tr>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>2004/12/31</td>
<td>Match if date is 2004/12/31</td>
</tr>
<tr>
<td>=2004/12/31</td>
<td>Match if date is 2004/12/31</td>
</tr>
<tr>
<td>&gt;2004/12/31</td>
<td>Match if date is greater than 2004/12/31</td>
</tr>
<tr>
<td>&gt;=2005/01/01</td>
<td>Match if date is greater than or equal to 2005/01/01</td>
</tr>
<tr>
<td>&lt;$TODAY</td>
<td>Match if date is less than today</td>
</tr>
<tr>
<td>&lt;$TODAY-30</td>
<td>Match if date is less than 30 days ago</td>
</tr>
<tr>
<td>2004/02/15-$TODAY</td>
<td>Match if date is within range of 2004/02/15 and today</td>
</tr>
<tr>
<td>$TODAY,$TODAY+1</td>
<td>Match if date is today or tomorrow</td>
</tr>
<tr>
<td>$TODAY-2004/03/15</td>
<td>Match if date is within range of today and 2004/03/15</td>
</tr>
<tr>
<td>$TODAY-1-2004/03/15</td>
<td>Match if date is within range of yesterday and 2004/03/15</td>
</tr>
<tr>
<td>$TODAY!&gt;$TODAY+30</td>
<td>Match if date is today or greater than 30 days from today</td>
</tr>
<tr>
<td>&gt;$TODAY&amp;&lt;=$TODAY+30</td>
<td>Match if date is between tomorrow and 29 days out</td>
</tr>
</tbody>
</table>

Time Comparisons (Type T)

Time comparisons are handled by first converting each time in the pattern to a 6-digit integer with the digit order HHMMSS, then compiling the resulting pattern using integer numerical comparison syntax. The same conversion is done to the target date during the comparison operation.

String Comparison (Type S)

A string comparison pattern should begin with a legal numerical comparison operator.

If the string comparison does not, the pattern compiles as if it does not contain any special characters.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Match if equal to</td>
</tr>
<tr>
<td>==</td>
<td>Match if equal to</td>
</tr>
<tr>
<td>&lt;&gt; or ~</td>
<td>Match if not equal to</td>
</tr>
</tbody>
</table>
### Pattern matching rules

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&gt;</td>
<td>Match if greater than</td>
</tr>
<tr>
<td>&lt;</td>
<td>Match if less than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Match if greater than or equal to</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Match if less than or equal to</td>
</tr>
</tbody>
</table>

**Note:**

The range operator `-` is not supported for string comparisons.

To compare a range of strings use the `&` list separator. For example `>ABC<&ADZ`.

---

**Shell-style Pattern syntax (Type P)**

The pattern must not look like a legal numerical comparison.

To match any regular character, use that character in the pattern.

To match any special character (`~ ? + * ! | [ ] { } ( ) - ^ $`) precede the character with a backslash.

<table>
<thead>
<tr>
<th>Character Class Shorthand Notation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>*</td>
<td>Match anything (wildcard)</td>
</tr>
<tr>
<td>?</td>
<td>Match any single character</td>
</tr>
<tr>
<td>\a</td>
<td>Match any single alphabetic character</td>
</tr>
<tr>
<td>\c</td>
<td>Match any single control character</td>
</tr>
<tr>
<td>\d</td>
<td>Match any single digit</td>
</tr>
<tr>
<td>\l</td>
<td>Match any single lowercase character</td>
</tr>
<tr>
<td>\p</td>
<td>Match any single punctuation character</td>
</tr>
<tr>
<td>\s</td>
<td>Match any single space (space, tab, nl) character</td>
</tr>
<tr>
<td>\u</td>
<td>Match any single uppercase character</td>
</tr>
<tr>
<td>\w</td>
<td>Match any single word (alphanumeric) character</td>
</tr>
<tr>
<td>\A</td>
<td>Match any single character not matched by \a</td>
</tr>
<tr>
<td>\C</td>
<td>Match any single character not matched by \c</td>
</tr>
<tr>
<td>\D</td>
<td>Match any single character not matched by \d</td>
</tr>
<tr>
<td>\L</td>
<td>Match any single character not matched by \l</td>
</tr>
<tr>
<td>\P</td>
<td>Match any single character not matched by \p</td>
</tr>
<tr>
<td>\S</td>
<td>Match any single character not matched by \s</td>
</tr>
<tr>
<td>\U</td>
<td>Match any single character not matched by \u</td>
</tr>
<tr>
<td>\W</td>
<td>Match any single character not matched by \w</td>
</tr>
</tbody>
</table>
Modifers

<table>
<thead>
<tr>
<th>Modifier</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>~</td>
<td>Match everything except what pattern matches (must be first character in pattern)</td>
</tr>
<tr>
<td>[]</td>
<td>Match any single character or character range in set</td>
</tr>
<tr>
<td>[^]</td>
<td>Match any single character or character range not in set</td>
</tr>
<tr>
<td>-</td>
<td>Character range (sets only)</td>
</tr>
<tr>
<td>{}</td>
<td>Subset (subsets can be nested)</td>
</tr>
<tr>
<td></td>
<td>List separator ('or' operator)</td>
</tr>
</tbody>
</table>

Patterns without wildcards are considered complete, and will not match on substrings. The following are example patterns.

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>~?*</td>
<td>Match if string is empty</td>
</tr>
<tr>
<td>ABC</td>
<td>Match if string is ABC</td>
</tr>
<tr>
<td>~DEF</td>
<td>Match if string is not DEF</td>
</tr>
<tr>
<td>FOO*</td>
<td>Match if string starts with FOO</td>
</tr>
<tr>
<td>*BAR</td>
<td>Match if string ends with BAR</td>
</tr>
<tr>
<td>SPL?T</td>
<td>Match if string is SPL?T where? can be any character</td>
</tr>
<tr>
<td>[AD-F]</td>
<td>Match if string is the single character A or D - F</td>
</tr>
<tr>
<td>A[^AD-F]*</td>
<td>Match if string starts with an A, whose second character is not the character A or D - F, and ends with anything</td>
</tr>
<tr>
<td>ABC</td>
<td>DEF</td>
</tr>
<tr>
<td>BAZ</td>
<td>FUB*</td>
</tr>
<tr>
<td>~{205,425}</td>
<td>Match if string is not 206 or 425</td>
</tr>
<tr>
<td>{DOG</td>
<td>CAT}</td>
</tr>
<tr>
<td>CA(NA,LI,RG)*</td>
<td>Match if string begins with CA; has NA, LI, or RG as its 3rd and 4th characters; and ends in anything. (Would match CANADA, CALIFORNIA, CARGO...)</td>
</tr>
<tr>
<td>\d\d\d-\d\d-\d\d\d\d</td>
<td>Match if string looks like a SSN</td>
</tr>
</tbody>
</table>

---

Extended Regular Expression syntax (Type E)

The expression must begin with the symbol E@, which is stripped prior to compiling the pattern with regcomp ().

For more information on ERE syntax, see Extended Regular Expressions in the man page regexp.

In addition to the standard ERE syntax described by the given man page, the following extensions are supported:

- Negation (~)
- Character class shorthand notation (\a, \c, \d)
The pattern must not look like a legal numerical comparison.
To match any regular character, use the character in the pattern.
To match any special character (~ ? * ! & [ ] { } ( ) - ^ $) precede it with a back slash.

<table>
<thead>
<tr>
<th>Character Class Shorthand Notation</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>.</td>
<td>Match any single character</td>
</tr>
<tr>
<td>\a</td>
<td>Match any single alphabetic character</td>
</tr>
<tr>
<td>\c</td>
<td>Match any single control character</td>
</tr>
<tr>
<td>\d</td>
<td>Match any single digit</td>
</tr>
<tr>
<td>\l</td>
<td>Match any single lowercase character</td>
</tr>
<tr>
<td>\p</td>
<td>Match any single punctuation character</td>
</tr>
<tr>
<td>\s</td>
<td>Match any single space (space, tab, nl) character</td>
</tr>
<tr>
<td>\u</td>
<td>Match any single uppercase character</td>
</tr>
<tr>
<td>\w</td>
<td>Match any single word (alphanumeric) character</td>
</tr>
<tr>
<td>\A</td>
<td>Match any single character not matched by \a</td>
</tr>
<tr>
<td>\C</td>
<td>Match any single character not matched by \c</td>
</tr>
<tr>
<td>\D</td>
<td>Match any single character not matched by \d</td>
</tr>
<tr>
<td>\L</td>
<td>Match any single character not matched by \l</td>
</tr>
<tr>
<td>\P</td>
<td>Match any single character not matched by \p</td>
</tr>
<tr>
<td>\S</td>
<td>Match any single character not matched by \s</td>
</tr>
<tr>
<td>\U</td>
<td>Match any single character not matched by \u</td>
</tr>
<tr>
<td>\W</td>
<td>Match any single character not matched by \w</td>
</tr>
<tr>
<td>\n</td>
<td>Where n is a number, match previously matched subset number n</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Modifiers</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>~</td>
<td>Match everything except what pattern matches (must be first character in pattern after '@'),</td>
</tr>
<tr>
<td>^</td>
<td>Anchor pattern to beginning. For example, the pattern must match from the beginning of the string.</td>
</tr>
<tr>
<td>$</td>
<td>Anchor pattern to end. For example, the pattern must match from the end of the string.</td>
</tr>
<tr>
<td>*</td>
<td>Match preceding character 0 or more times,</td>
</tr>
<tr>
<td>+</td>
<td>Match preceding character 1 or more times,</td>
</tr>
<tr>
<td>?</td>
<td>Match preceding character 0 or 1 time,</td>
</tr>
<tr>
<td>{ }</td>
<td>Match preceding character n or n, m times where n is a number and n,m is a number range.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Match any single character or character range in set.</td>
</tr>
<tr>
<td>[^]</td>
<td>Match any single character or character range not in set.</td>
</tr>
<tr>
<td>-</td>
<td>Character range for sets only.</td>
</tr>
<tr>
<td>( )</td>
<td>Subset and nested subsets. Subsets are numbered by the order of occurrence of the '[' character.</td>
</tr>
<tr>
<td></td>
<td>List separator 'or'.</td>
</tr>
</tbody>
</table>
Patterns without anchors are considered incomplete or fragments. Each pattern matches on substrings. For example, “E@RES” matches on “FRESNO”.

<table>
<thead>
<tr>
<th>Example Patterns</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>E@^$</td>
<td>Match if string is empty</td>
</tr>
<tr>
<td>E@^ABC$</td>
<td>Match if string is ABC</td>
</tr>
<tr>
<td>E@~^ABC$</td>
<td>Match if string is not ABC</td>
</tr>
<tr>
<td>E@^ABC</td>
<td>Match if string begins with ABC</td>
</tr>
<tr>
<td>E@^ABC$</td>
<td>Match if string ends with ABC</td>
</tr>
<tr>
<td>E@ABC</td>
<td>Match if string contains ABC</td>
</tr>
<tr>
<td>E@A.*Z</td>
<td>Match if string contains any sequence where A precedes Z</td>
</tr>
<tr>
<td>E@FOO?BAR</td>
<td>Match if string contains FOBAR or FOOBAR</td>
</tr>
<tr>
<td>E@FO+BAR</td>
<td>Match if string contains FOBAR or FOOBAR or FOOOBAR or...</td>
</tr>
<tr>
<td>E@^SPL.T$</td>
<td>Match if string is SPL?T where? can be any character</td>
</tr>
<tr>
<td>E@^[AD-F]$</td>
<td>Match if string is the single character A or D - F</td>
</tr>
<tr>
<td>E@^A[^AD-F]</td>
<td>Match if string starts with an A, whose second character is not the character A or D - F, and ends with anything</td>
</tr>
<tr>
<td>E@ABC</td>
<td>DEF</td>
</tr>
<tr>
<td>E@^CA(NA</td>
<td>LI</td>
</tr>
<tr>
<td>E@\d{3}-\d{2}-\d{4}$</td>
<td>Match if string looks like a SSN.</td>
</tr>
</tbody>
</table>
Chapter 19: Schedule

The Schedule feature provides the flexibility to automatically schedule activities, create a new dialer activity, and view schedule reports.

Proactive Contact provides the ability to define and manage schedules. When you select Activities from the Schedule feature, calendar is displayed that lists all the scheduled activities. When you select the Activities icon on the Button Bar, the application requests a list of all the scheduled activities from the dialer and displays them in the Calendar pane.

**Note:**

You can view and create schedules only for your tenant space.

The system does not save individual activities as changes made to the activities. The system saves the entire schedule at once.

You can create new activities and change or delete existing activities. You can create, delete, and modify some of the Active schedule activities directly without going through the pending stage. However, the save as option allows only the Pending and In-progress versions.

When you create an activity in Active version and save the schedule, changes are made in the Active version itself. You are not asked to save as Pending or In-progress. This functionality not only allows the creation of a new activity but also the modification and deletion of an existing activity directly in the Active stage. However, the system imposes restrictions on some types of activities.

The system overwrites all the changes made in an Active schedule by the changes in the Pending schedule, if any, during the next system restart. The changes include creation of new activities and deletion or modification of existing activities. If you want to retain the changes made in the Active schedule, then make the desired changes in the Pending schedule also. Otherwise, the changes made will be lost after the system restart.

For example, if you delete an activity directly from the Active schedule and a Pending version of that activity still exists, the system will display the activity again after the system restart. If you do not want the system to display this activity, then remove the activity from the Pending version also if it has been deleted from Active version.

**Related links**

[Restrictions for Scheduling](#) on page 279
Restrictions for Scheduling

To ensure that the system sanity is maintained, Editor does not allow scheduling activities that are critical to the system, such as maintenance and backup, directly in Active stage. As a result:

- The New activity wizard does not show the restricted item in the drop-down list.
- Remove and update functionality is disabled for the restricted items.

The restricted activities are supposed to be planned activities. If any change is made in Active schedule directly, there may not be time to revert any inadvertent changes.

Activities and restrictions

Type of activities and restrictions in active schedule

<table>
<thead>
<tr>
<th>Activity Type</th>
<th>Restrictions in Active schedule for Default Tenant</th>
<th>Restriction in Active schedule for Tenant space</th>
</tr>
</thead>
<tbody>
<tr>
<td>Run a job</td>
<td>NO</td>
<td>NO</td>
</tr>
<tr>
<td>Run a selection</td>
<td>NO</td>
<td>NO</td>
</tr>
<tr>
<td>File Transfer</td>
<td>NO</td>
<td>NO</td>
</tr>
<tr>
<td>Campaign Update</td>
<td>NO</td>
<td>NO</td>
</tr>
<tr>
<td>Custom script</td>
<td>NO</td>
<td>YES You cannot create, modify, or delete.</td>
</tr>
<tr>
<td>Backup calling list for latelist</td>
<td>NO</td>
<td>YES You cannot create, modify, or delete.</td>
</tr>
<tr>
<td>Restart Proactive Contact</td>
<td>YES You cannot create, modify, or delete.</td>
<td>YES You cannot create, modify, or delete.</td>
</tr>
<tr>
<td>Proactive Contact maintenance</td>
<td>YES You cannot create, modify, or delete.</td>
<td>YES You cannot create, modify, or delete.</td>
</tr>
<tr>
<td>MTS maintenance</td>
<td>YES You cannot create, modify, or delete.</td>
<td>YES You cannot create, modify, or delete.</td>
</tr>
<tr>
<td>DB maintenance</td>
<td>YES You cannot create, modify, or delete.</td>
<td>YES You cannot create, modify, or delete.</td>
</tr>
<tr>
<td>Backup</td>
<td>YES You cannot create, modify, or delete.</td>
<td>YES You cannot create, modify, or delete.</td>
</tr>
</tbody>
</table>

**Note:**

The system does not allow you to delete or modify the restricted activities in Active version and such activities are highlighted in red color.
Important:
Irrespective of the stage of the schedule, a tenant administrator cannot schedule the activity types for which there is restriction in the tenant space.

Types of Dialer Activities
You use the New Schedule Activity Wizard to schedule the dialer activities such as Backup, Backup calling list for late list, Campaign Update, Custom Script, File Transfer, MTS Maintenance, Proactive Contact Maintenance, Run a Job, Run a Selection, DB Maintenance, and Restart Proactive Contact. The activity details of the new activity are stored as part of the crontab command entry.

Note:
If the Proactive Contact dialer is deployed on a virtualized server, then you must ensure that the DVD drive on the host system is accessible by Proactive Contact dialer before initiating a backup or restore.

You can also perform the following functions:
- You can take a Full Backup or an Incremental Backup. Full and Incremental Backup includes the complete system excluding OS, Proactive Contact Configuration files and calling lists, Proactive Contact system only, and Proactive Contact System configuration files.
- You can backup the data using DVD/Tape.
- You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly in conjunction with the Hourly recurrence option. For more information on recurrence pattern, refer to Recurrence Pattern on page 289.

Scheduling a Backup Activity Type

About this task
You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly.

To create a new Backup Activity type:

Procedure
1. In the Schedule button bar, select New.
   The Schedule Activity wizard appears.
2. Click Next.
3. Do the following:
   a. Backup: Select backup as the activity type.
b. **Description**: Enter a brief description for backup.

c. **Type**: Select the type of backup.

You cannot schedule or automate network backup, which is a back up or recovery, on a third-party host. You require to type your password multiple times during back up or recovery, on a third-party host.

d. **Device**: Select the device for backup. The options are: DVD, DDS, or USB.

4. Click **Next**.

5. Select **Start Date** and **Time**. This process must be done on the recurrence page of wizard to schedule the new activity.

6. Select the Recurrence pattern.

7. Click **Next**.

8. Click **Finish**.

   The new Backup activity that you scheduled appears in the scheduled list of activities.

---

**Scheduling a Backup calling list for latelist**

**About this task**

Latelist allows migrating data from the previous day’s calling list to the current day’s calling list. The Backup calling list for latelist activity type allows you to backup your latelist. To save on idle time during the time of dialer maintenance, it is advisable that you schedule a backup calling list for latelist.

The backup is taken using the database manager script. You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly.

To create a new Backup calling list for latelist activity type:

**Procedure**

1. In the Schedule button bar, select **New**.

   The New Dialer Activity Wizard appears.

2. Click **Next**.

3. Do the following:

   a. **Backup calling list for latelist**: Select this type as the activity type.

   b. **Description**: Enter a brief description for backup.

4. Select the Recurrence pattern.

5. Click **Next**.

6. Click **Finish**.

   The new Backup calling list for latelist activity that you scheduled appears in the Scheduled list of activities.
Scheduling backup for a specific calling list in a tenant

About this task

In a tenant, a user with Lead Administrator permissions belonging to that tenant can schedule a backup for a specific calling list. The Lead Administrator user belonging to that tenant can create, modify, or delete a backup type activity for a calling list in a tenant. You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly. A tenant specific user with sufficient permissions to use Schedules can only view the activity of a specific calling list backup. A tenant specific user with write permissions for Schedules cannot create or modify a backup activity; however, such a user can delete a backup activity.

Procedure

1. Log in to the Editor application.
   Ensure that the tenant administrator assigns you a role that has the write access permissions to the Schedule menu.
2. Select the required tenant.
3. Save the schedule in the pending stage.
4. In the Schedule button bar, select New.
   The New Dialer Activity Wizard appears.
5. Click Next.
6. Do the following:
   a. **Backup**: Select backup as the activity type.
   b. **Description**: Enter a brief description for backup.
7. Select the Specific calling list option.
8. Select the calling list you want to backup from the available calling lists drop-down.
9. Select the Recurrence pattern.
10. Click Next.
11. Click Finish.

   The backup of specific calling list activity that you scheduled appears in the Scheduled list of activities.

Scheduling a Campaign Update

About this task

The Campaign Update activity type allows you to schedule a campaign update feature for a calling list. To use this feature, you must enable the Campaign Update feature by selecting either the Batch or Both options available in the Features tab, under Calling List.
Note:
You cannot schedule a real time campaign update.

Batch campaign update allows you to periodically send updates to a calling list throughout the day to mark the records that should no longer be called. The batch campaign update uses the rec_update binary to mark the calling list records as non-callable.

Note:
There must be an interval of 15 minutes between two batch campaign update schedules. And the processes must not be scheduled as the same time/interval as an infinite job download. For large lists, the time interval needs to be even longer. This feature is only supported for calling lists in active or pending versions.

You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly.

To schedule a new Campaign Update:

Procedure
1. In the Schedule button bar, select New.
   The New Dialer Activity Wizard appears.
2. Click Next.
3. Select Campaign Update as the activity type.
4. In the Description field, enter a brief description for the campaign update.
5. Select the Calling List.
6. Select the Recurrence pattern.
7. Click Next.
8. Click Finish.

The new Campaign Update activity that you scheduled appears in the Scheduled list of activities.

Scheduling a Custom Script

About this task
The Custom Script activity type allows you to run a script and define arguments for the script. You can define your own specific scripts that you would like to be scheduled. You must place the scripts in the customs directory.

As a Lead Administrator user, you can schedule LIS indexing for the records using the custom scripts activity. The LIS indexing adds and indexes the records added by the agents using the Create and dial a manual record feature available in the PCAgent application. You can schedule the LIS indexing script to run at the required intervals so that the agent created records are dynamically added to the calling list. If you do not run the LIS indexing script, then the system adds the agent created records when you run indexing in the regular cycle.
**Note:**

As a tenant administrator, you cannot schedule custom script for a tenant.

You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly.

To schedule a new Custom Script:

**Procedure**

1. In the Schedule button bar, select **New**.
   
   The New Dialer Activity Wizard appears.

2. Click **Next**.

3. Do the following:
   
   a. **Description**: Enter a brief description for custom script.
   
   b. **Custom Script**: Select this type as the activity type.
   
   c. **Script Name**: Select a name.
   
   d. **Argument**: Select the check box if you have defined arguments.

4. Click **Next**.

5. Select the Recurrence pattern.

6. Click **Next**.

7. Click **Finish**.

   The new Custom Script activity that you scheduled appears in the Scheduled list of activities.

---

**Scheduling a File Transfer**

**About this task**

The File Transfer activity type allows you to download calling list data from a host system to a dialer and upload the results of calling from a dialer to the host system. You can schedule the date and time for the new activity and set a recurrence pattern for None, Hourly, Daily, Weekly, Monthly, and Yearly backup.

To schedule a File Transfer:

**Procedure**

1. In the Schedule button bar, select **New**.

   The New Dialer Activity Wizard appears.

2. Click **Next**.
3. Do the following:
   a. **Description**: Enter a brief description for backup.
   b. **File Transfer**: Select this field as activity type.

4. Select the **Download** option if you want to download the calling list data to the dialer or select **Upload** option if you want to upload the results of calling from the dialer to the host system.

5. Select the specific Calling List.
6. Click **Next**.
7. Select the Recurrence pattern.
8. Click **Next**.
9. Click **Finish**.

---

### Scheduling MTS Maintenance

**About this task**

The MTS maintenance activity type allows you to schedule the date, time, and the recurrence pattern for MidTier Maintenance. The MTS Maintenance script performs the following functions:

- Starts MTS
- Stop MTS

You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly.

**Note:**

You must schedule MTS maintenance only on the primary dialer in a pod.

To schedule a MTS Maintenance:

**Procedure**

1. In the Schedule button bar, select **New**.
   The New Dialer Activity Wizard appears.
2. Click **Next**.
3. Do the following:
   a. **Description**: Enter a brief description for MTS Maintenance.
   b. **MTS Maintenance**: Select this field as the activity type.
4. Click **Next**.
5. Select the Recurrence pattern.
6. Click **Next**.
Scheduling Proactive Contact Maintenance

About this task
The Proactive Contact maintenance activity type allows you to schedule the date, time, and the recurrence pattern for Proactive Contact Maintenance.

You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly.

To schedule a Proactive Contact Maintenance:

Procedure
1. In the Schedule button bar, select **New**.
   The New Dialer Activity Wizard appears.
2. Click **Next**.
3. Do the following:
   a. **Description**: Enter a brief description for Proactive Contact Maintenance.
   b. **Proactive Contact Maintenance**: Select this field as the activity type.
4. Click **Next**.
5. Select the Recurrence pattern.
6. Click **Next**.
7. Click **Finish**.

Scheduling Run a Selection

About this task
The Run a Selection activity type allows you to schedule running a selection by selecting a selection. You must also select the calling list that you want to run on the selection.

You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly.

To schedule a Run a selection:

Procedure
1. In the Schedule button bar, select **New**.
   The New Dialer Activity Wizard appears.
2. Click **Next**.
3. Do the following:
   a. **Description**: Enter a brief description for running a selection.
   b. **Run a Selection**: Select this field as the activity type.
   c. **Type**: Select the type of strategy.

4. Select the specific Calling List.

5. Click **Next**.

6. Select the Recurrence pattern.

7. Click **Next**.

8. Click **Finish**.

---

### Scheduling Run a Job

**About this task**

The Run a Job activity type allows you to select the job type that you require to be scheduled. The available job types for selection are blend, inbound, managed, outbound, verify, and virtual. You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly.

**Procedure**

1. In the Schedule button bar, select **New**.
   The New Dialer Activity Wizard appears.

2. Click **Next**.

3. Do the following:
   a. **Description**: Enter a brief description for running a job.
   b. **Run a Job**: Select this field as the activity type.
   c. **Type**: Select the type of job.

4. Click **Next**.

5. Select the Recurrence pattern.

6. Click **Next**.

7. Click **Finish**.
Running database maintenance as a scheduled activity

About this task
You can schedule Database Maintenance also from the Editor application. You can schedule the date and time for the new activity and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly.

To set Database maintenance as a scheduled activity:

Procedure
1. Log in to the Editor application.
2. Go to the Schedule tab. Select Activities.
3. Click New.
4. Follow the instruction on the Schedule wizard.
5. Select the Dialer activity type as DB Maintenance.
6. Select recurrence type, Start Time, End Time, and Duration at which you want to run the schedule.
7. Save the schedule.

Scheduling Restart Proactive Contact

About this task
The Restart Proactive Contact activity type allows you to schedule when you would like to restart Proactive Contact.

You can schedule the date and time to schedule a restart of Proactive Contact and set a recurrence pattern for None, Daily, Weekly, Monthly, and Yearly.

To schedule a Restart of Proactive Contact:

Procedure
1. In the Schedule button bar, select New.
   The New Dialer Activity Wizard appears.
2. Click Next.
3. Do the following:
   a. Description: Enter a brief description for running a job.
   b. Restart Proactive Contact: Select this field as the activity type.
4. Click Next.
5. Select the Recurrence pattern.
6. Click **Next**.
7. Click **Finish**.

---

**Recurrence Pattern**

Recurrence pattern represents a set of controls that help you to schedule an activity to occur repeatedly at set intervals. You can choose between None, Daily, Weekly, Monthly, and Yearly. Depending on the type of pattern you choose, one or more additional controls appear.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>This activity runs once every year from the date of the scheduled activity. If you select the default selection, <strong>None</strong>, no additional controls appear and the Start Time (date) control is enabled.</td>
</tr>
<tr>
<td>Daily</td>
<td>This activity runs daily from the date of the scheduled activity. If you select <strong>Daily</strong> recurrence, additional controls let you choose between repeating the activity every n number of days, repeating the activity on every weekday, and repeating the activity every weekend day.</td>
</tr>
<tr>
<td>Weekly</td>
<td>This activity runs weekly from the date of the scheduled activity. If you select the <strong>Weekly</strong> pattern, you can choose to repeat the activity every week on specific days.</td>
</tr>
<tr>
<td>Monthly</td>
<td>This activity runs monthly from the date of the scheduled activity. If you select the <strong>Monthly</strong> pattern, you can choose to repeat the activity on the nth day of every month.</td>
</tr>
<tr>
<td>Yearly</td>
<td>This activity runs yearly from the date of the scheduled activity. If you select the <strong>Yearly</strong> pattern, you can choose to repeat the activity on a specific month and day every year.</td>
</tr>
</tbody>
</table>

**Hourly repetition in Schedule Activity wizard**

In conjunction to the recurrence types, you can choose Hourly Repetition option to run an activity at repeated hourly interval from the date of the scheduled activity.

Specifying the hourly repetition option in combination with another type of recurrence makes the activity to run at every Duration interval between Start time and End time on days determined by the recurrence in combination.

If you choose **None**, then you can use the date control to specify the date of the hourly repetition.
Note:
Hourly repetition always begins from 00:00:00 hours. Also, you cannot provide non-absolute start and end times when you schedule an hourly recurring pattern.

Using hourly repetition with recurrence type

Procedure
1. Log in to the Editor application.
2. Go to the Schedule tab. Select Activities.
3. Click New.
4. Go through the Schedule wizard.
5. Select the Hourly Repetition check box.
6. Select Start Time, End Time, and Duration at which you want to run the schedule.
7. Select the Recurrence pattern.
8. Save the schedule.

Schedule Reports
The Schedule Reports screen displays a list of all the available reports related to active schedules. When you select the Report item in the Button Bar’s Schedules button group, the application displays a list of available reports in the Feature pane.

Viewing schedule reports
Procedure
In the Features pane, click a report.
The report details appear in the right side of the Feature Detail pane.
A job contains all the information that Proactive Contact needs to place phone calls to customers. A job integrates a calling list, phone strategy, record selection, and other settings to place outbound calls and receive inbound calls.

You can set the properties of the jobs within your tenant space using the Job template menu in Editor. The system creates the job templates specific to the tenant when a new tenant is moved from a pending version to active version on maintenance cycle. You can use the Job template menu to define certain characteristics of job fields in the Jobs in Editor. You can change the properties of your outbound, inbound, or blend jobs within your tenant space. Note that the changes you make using the Job template menu do not affect the jobs running in other tenant spaces.

**Note:**

You can view the job templates that are specific to your tenant space.

Earlier, you could define certain characteristics of job fields, including the fields to which the Supervisor can gain access, only through the *.edt files on the dialer. In this release, you can manage the job properties pertaining to your tenant space from the Editor application. You can also set the default values for fields. The standard job template exists for inbound, outbound, and blend jobs.

The job templates control field definitions for:

- Sales Verification
- Job Linking
- Managed Dialing
- Campaign Update
- Person to Person
- Line Pooling
- Predictive Blend
- Native Voice and Data Transfer
Setting job template for a job type

Procedure
1. Click **Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor**.
2. Click **Contact Management > Job Templates**.
3. Select the job template file in the Job Template File Name column: Outbound, Inbound, or Blend.

Job template field descriptions
The system displays the Job template settings for the selected job type that include the following information for each keyword:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Keyword</td>
<td>Displays the name of the keyword.</td>
</tr>
<tr>
<td>Description</td>
<td>Displays a brief description of the keyword. You can edit the description if required.</td>
</tr>
<tr>
<td>Default value</td>
<td>Displays the default value of the keyword as defined in the system. You can edit the default value if required.</td>
</tr>
<tr>
<td>Visible</td>
<td>Specifies whether the keyword should be visible in the Job details view.</td>
</tr>
<tr>
<td>Required</td>
<td>Specifies whether the keyword should be made a mandatory property of the job.</td>
</tr>
<tr>
<td>Length</td>
<td>Displays the number of characters allowed in the field.</td>
</tr>
</tbody>
</table>

Keyword description
The following table contains all available keywords defined in an *.edt file. The last column of the table shows which of the three standard job template files (*.edt) the keyword can appear in: inbound (I), outbound (O), or blend (B).

Note:
The Opt-out parameters that appear in outbound.edt are applicable only for the virtual jobs, because the Opt-Out feature is available only for virtual jobs. You cannot change these parameters for the non-virtual jobs. In a CTI Dialer, these parameters are ineffectual for the Opt-out feature as you must configure Opt-outs on a CTI dialer on Communication Manager.
<table>
<thead>
<tr>
<th>Keyword</th>
<th>Values</th>
<th>Explanation</th>
<th>.edt type</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACTONLOGON</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field. YES activates inbound lines on logon. Upon activation, a one-to-one correspondence is established between blend and/or inbound agents and inbound lines. Lines are activated as agents log on and deactivated as agents log out. Lines are activated according to the total number of lines for the job.</td>
</tr>
<tr>
<td>ANI</td>
<td>phone no</td>
<td>The phone number that the customer phone displays if the customer has caller ID.</td>
<td>O</td>
</tr>
<tr>
<td>ANI_FIELD</td>
<td></td>
<td>Calling party number by record.</td>
<td>O, B</td>
</tr>
<tr>
<td>ANSWER_SUP</td>
<td></td>
<td>A supervisor can select this check box to configure answer supervision for a job.</td>
<td>O, B</td>
</tr>
<tr>
<td>AUTOCALLSEL_TRIGGER</td>
<td>Numeric value</td>
<td>The percentage of completion of the current job at which the call selection of the link job triggers automatically. To turn off the feature, set the value to 0. The default setting is 0. The minimum value for this parameter is 0, and the maximum value is 99.</td>
<td>I, O, B</td>
</tr>
<tr>
<td>AUTOEND</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field. Select YES to add an automatic end of field indicator to the agent input.</td>
</tr>
<tr>
<td>AUTORELEASE</td>
<td>YES</td>
<td>NO</td>
<td>A field that releases the phone line from the agent if the customer hangs up and puts the agent in the update mode.</td>
</tr>
<tr>
<td>AUTOREL_AGTRDY_METHOD</td>
<td>Method</td>
<td>Select the method to use when the system identifies the called party as an answering machine. After the system connects the call to a live agent, if the system detects an answering machine, it performs the action specified in</td>
<td>O, B</td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>Keyword</th>
<th>Values</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>AUTOREL_AGTRDY_MS</td>
<td>Message</td>
<td>The message to be played when the system detects the called party as an answering machine.</td>
</tr>
<tr>
<td>BUSYON</td>
<td>YES</td>
<td>NO</td>
</tr>
<tr>
<td>CC</td>
<td>YES</td>
<td>NO</td>
</tr>
<tr>
<td>CONNTOLE</td>
<td>seconds</td>
<td>Number of seconds used in cruise control calculation.</td>
</tr>
<tr>
<td>CPMETHOD</td>
<td>C</td>
<td>E</td>
</tr>
<tr>
<td>DATAPROCESS</td>
<td>text</td>
<td>One of the main labels in the *.dat file named by DATASCRIPt. Available labels in alljobs.dat include: generic, virtual, and verify. The default is generic.</td>
</tr>
<tr>
<td>DATASCRIPt</td>
<td>filename</td>
<td>The *.dat file to use when preprocessing and postprocessing the calling list. Usually alljobs.dat.</td>
</tr>
<tr>
<td>DETAILSTAT</td>
<td>YES</td>
<td>NO</td>
</tr>
<tr>
<td>DISABLE_SHADOWJOB</td>
<td>YES</td>
<td>NO</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Keyword</th>
<th>Values</th>
<th>Explanation</th>
<th>.edt type</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>by the agent to be agent-owned recall.</td>
<td></td>
</tr>
<tr>
<td>DISPLAY</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field. Yes displays an empty record while previewing a record in a managed job.</td>
</tr>
<tr>
<td>DNC_GROUP</td>
<td>text</td>
<td>The name of the Do Not Call group</td>
<td>O,B</td>
</tr>
<tr>
<td>DONE_TME:</td>
<td>YES</td>
<td>NO</td>
<td>This is a toggle field that establishes a test parameter. YES allows a test agent to complete work after each call.</td>
</tr>
<tr>
<td>ECPA</td>
<td></td>
<td>Cell phone campaign call progress. The valid values are 1 to 4. 0 is the regular campaign.</td>
<td>O,B</td>
</tr>
<tr>
<td>EDTFILE</td>
<td>filename</td>
<td>The value of this field establishes the *.edt file to associate with the job. Unless a custom *.edt file exists, the default must be the name of the file as it appears in: inbound, outbound, or blend.</td>
<td>I,O,B</td>
</tr>
<tr>
<td>EXEC:</td>
<td>process</td>
<td>Always caller in standard *.edt files to execute the caller binary. For *.edt files in/usr/vl/tools/editor, this indicates the installation script to run.</td>
<td>I,O,B</td>
</tr>
<tr>
<td>EXPIRED_RECALL</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field. YES indicates that an expired call is recalled immediately.</td>
</tr>
<tr>
<td>FCC</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field to enable or disable the FCC regulation for a job.</td>
</tr>
<tr>
<td>FCC_OPTOUT_DIGIT</td>
<td>Digit</td>
<td>The digit that must be pressed by the called party to indicate for DNC opt-out.</td>
<td>O,B</td>
</tr>
<tr>
<td>FCC_DNC_MSG</td>
<td>Message</td>
<td>The confirmation message that the system plays to the called party after the called party opts out to DNC.</td>
<td>O,B</td>
</tr>
<tr>
<td>HITRATE</td>
<td>percent</td>
<td>A percent (1-100) indicating the initial hit rate for a job.</td>
<td></td>
</tr>
<tr>
<td>HOME</td>
<td>dir</td>
<td>The home directory for job verification; /opt/ avaya/pds/lists is the default.</td>
<td>I,O,B</td>
</tr>
<tr>
<td>IDENT</td>
<td></td>
<td>The identification field.</td>
<td>I,O,B</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Keyword</th>
<th>Values</th>
<th>Explanation</th>
<th>.edt type</th>
</tr>
</thead>
<tbody>
<tr>
<td>IDMODE</td>
<td></td>
<td>A number that indicates the expert calling ratio (formerly called as intelligent dialing mode). Usually set to appear on the Job Verification screen for the supervisor to fill in.</td>
<td>O, B</td>
</tr>
<tr>
<td>IMMSERVICE</td>
<td>YES</td>
<td>NO</td>
<td>Toggle field that enables/disables call forwarding on the ACD. If YES, there is no inbound wait queue; calls are only answered if an agent is available. To use this option, call forwarding must be available on all inbound lines. If set to YES, the SERVETIME and INBQUEFACTOR settings are disabled.</td>
</tr>
<tr>
<td>IN_LIST</td>
<td>text</td>
<td>Indicates the name of the inbound calling list.</td>
<td>I, B</td>
</tr>
<tr>
<td>IN_SCRN</td>
<td>filename</td>
<td>Indicates the *.scrn file to use on the inbound screen of the Linux-based interface.</td>
<td>I, B</td>
</tr>
<tr>
<td>IN_WAITLIM</td>
<td>seconds</td>
<td>Indicates the maximum number of seconds a call can be in the inbound wait queue.</td>
<td>I, B</td>
</tr>
<tr>
<td>INBDATAPOST</td>
<td>text</td>
<td>Indicates the postprocessing calling list label for an inbound job. The default is inbpre. This label must be one of the standard prefixes to a label in the *.dat file in DATASCRIPT (usually alljobs.dat).</td>
<td>I, B</td>
</tr>
<tr>
<td>INBDAPRE</td>
<td>text</td>
<td>Indicates the preprocessing calling list label for an inbound job. The default is inbpost. This label must be one of the standard prefixes to a label in the *.dat file in DATASCRIPT (usually alljobs.dat).</td>
<td>I, B</td>
</tr>
<tr>
<td>INBOUND</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field that enables and disables inbound calling. YES allows inbound calling. The default is always YES.</td>
</tr>
<tr>
<td>Keyword</td>
<td>Values</td>
<td>Explanation</td>
<td>.edt type</td>
</tr>
<tr>
<td>-----------------</td>
<td>---------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-----------</td>
</tr>
<tr>
<td>INBQUEFACTOR</td>
<td>num</td>
<td>A number indicating the inbound queue factor: the maximum percentage of client calls in the queue compared to the number of inbound agents. The range is 100 to 200. Numbers outside this range are meaningless.</td>
<td>I, B</td>
</tr>
<tr>
<td>INBTESTMODE</td>
<td>LOW=num, HIGH=num, PERIOD= num, TIMES= num, COMPUTE= num, SWING= num</td>
<td>Release information for inbound test calls. Each entry defines a test parameter: LOW is the low call volume. HIGH is the high call volume. PERIOD is a cycle period in seconds to cause fluctuation in the call volume. TIMES is the number of times to repeat the cycle. SWING indicates deviation from the cycle period.</td>
<td>I, B</td>
</tr>
</tbody>
</table>
| INF_ESC_RECALL  | Escape RECALL in Infinite job: NO: YES: CHECK KBOX: YES: RECALL L: 6: 3: | If INF_ESC_RECALL parameter is set to YES, then this job can dial general Recall by pulling an agent from another job specified in the INF_RECALL_GETOP_JOB parameter in job file. The condition to place general recall is:  
• The job must be an infinite job.  
• The job must not have a record to dial, only general recall  
• The operator must not be logged in to that job. | O, B      |
<p>| INF_RECALL_GETOP_JOB | Name of the job to get agent for recall: YES: DROPD OWN: NO: RECALL: 7: 31: | You must specify the job name for the parameter INF_RECALL_GETOP_JOB, so that dialer will pull most idle agent from that job to the recall job. | O, B      |
| IVR_AGENTS      | YES|NO | A toggle field. YES allows IVR agents on the job. | I, O      |
| IVR_ID          | text   | The name of the IVR machine. | I, O      |</p>
<table>
<thead>
<tr>
<th>Keyword</th>
<th>Values</th>
<th>Explanation</th>
<th>.edt type</th>
</tr>
</thead>
<tbody>
<tr>
<td>IVR_INITSCRIPT</td>
<td>text</td>
<td>The name of the initial script to run on the IVR.</td>
<td>I, O</td>
</tr>
<tr>
<td>IVR_POOL</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field. YES indicates to pool jobs for IVR agents.</td>
</tr>
<tr>
<td>IVR_SCRIPT</td>
<td>text</td>
<td>The script label on the dialer.</td>
<td>I, O</td>
</tr>
<tr>
<td>JLABEL</td>
<td>num</td>
<td>A brief, unique, and descriptive job label.</td>
<td>I, O, B</td>
</tr>
<tr>
<td>JOBEND</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field. YES = End the job when the initial phone for each record has been called at least once.</td>
</tr>
<tr>
<td>LINKJOB</td>
<td>text</td>
<td>Indicates the name of the job to be linked with this job.</td>
<td>O, B</td>
</tr>
<tr>
<td>LIST</td>
<td>text</td>
<td>Indicates the name of the calling list to use for the job.</td>
<td>O, B</td>
</tr>
<tr>
<td>LOGONALL</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field that determines whether agents must log onto a unit work list (NO), or whether sharing is allowed (YES).</td>
</tr>
<tr>
<td>LOGONUNIT</td>
<td>YES</td>
<td>NO</td>
<td>A unit value. If a unit work list job uses the zip code as a unit, then the agent enters a specific zip code when logging in. YES indicates that a unitID is required for agent login.</td>
</tr>
<tr>
<td>LOWALTQPRIO</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field. YES makes the alternate phone the lowest priority for calling.</td>
</tr>
<tr>
<td>MAPFILE</td>
<td>filename</td>
<td>Indicates the name of the *.fdict file for the calling list.</td>
<td>O, B</td>
</tr>
<tr>
<td>MASTER:</td>
<td>text</td>
<td>A field that determines the supervisor login identification. The default is system.</td>
<td>I, O, B</td>
</tr>
<tr>
<td>MAKE_CALL_VDN</td>
<td>VDN needed by CTI dialer only.</td>
<td>O</td>
<td></td>
</tr>
<tr>
<td>MANUALMODE</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field. YES = Enable manual mode dialing Default value is NO.</td>
</tr>
<tr>
<td>MINHITRATE</td>
<td>percent</td>
<td>A percent (1-100) that indicates the minimum hit rate for the job.</td>
<td>O, B</td>
</tr>
<tr>
<td>MOVEAFTERCALL</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field. YES = Move dual agent to inbound after next call</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Keyword</th>
<th>Values</th>
<th>Explanation</th>
<th>.edt type</th>
</tr>
</thead>
<tbody>
<tr>
<td>NOAGTMSG</td>
<td>Numeric value</td>
<td>The dialer plays NOAGTMSG to the called party in case the system is unable to carry out an Opt-Out request.</td>
<td>O</td>
</tr>
<tr>
<td>OFCOM</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field. YES = Run job with OFCOM.</td>
</tr>
<tr>
<td>OFCOMFR</td>
<td></td>
<td>OFCOM false positive rate.</td>
<td></td>
</tr>
<tr>
<td>OFCOMTIMER</td>
<td></td>
<td>OFCOM timer</td>
<td></td>
</tr>
<tr>
<td>OFCOM_METHOD</td>
<td></td>
<td>OFCOM method to use.</td>
<td></td>
</tr>
<tr>
<td>OPTOUT</td>
<td>YES</td>
<td>NO</td>
<td>Turns on the Opt-Out feature for the job.</td>
</tr>
<tr>
<td>OODIGIT</td>
<td>Single digit numeric value</td>
<td>The dialer initiates an Opt-Out if this digit is pressed during the message play in a call dialed by a Opt-Out enabled virtual job.</td>
<td>O</td>
</tr>
<tr>
<td>OOMETHOD</td>
<td>VDN</td>
<td>JOB</td>
<td>Determines the action taken by the dialer after an Opt-Out is triggered on an Opt-Out virtual job. VDN will send the call to a specified VDN; JOB will send the call through NVDT to a specified inbound/blend job.</td>
</tr>
<tr>
<td>OOJOB</td>
<td>Inbound job name</td>
<td>Specifies the inbound/ blend job to which the opted out call will be transferred. Relevant only if OOMETHOD is JOB.</td>
<td>O</td>
</tr>
<tr>
<td>OOVVDN</td>
<td>Numeric value</td>
<td>Specifies the VDN to which the opted out call will be transferred. Relevant only if OOMETHOD is VDN.</td>
<td>O</td>
</tr>
<tr>
<td>OKEYS</td>
<td>filename</td>
<td>Indicates the name of the agent key definition file (*.ky).</td>
<td>I, O, B</td>
</tr>
<tr>
<td>OPERATORS</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field. YES = Job has agents. NO = Job without agents.</td>
</tr>
<tr>
<td>ORDERZONES</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field. YES = Sort records for calling by time zone.</td>
</tr>
<tr>
<td>OUTDATAPOST</td>
<td>text</td>
<td>Indicates the postprocessing calling list label for an outbound.</td>
<td>O, B</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Keyword</th>
<th>Values</th>
<th>Explanation</th>
<th>.edt type</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>job</td>
<td>The default is usually outpost. This label must be one of the standard prefixes to a label in the *.dat file in DATASCRIPT (usually alljobs.dat).</td>
<td></td>
</tr>
<tr>
<td>OUTDATAPRE</td>
<td>text</td>
<td>This field establishes the pre-processing calling list label for an outbound job. The default is usually outpre. This label must be one of the standard prefixes to a label in the *.dat file in DATASCRIPT (usually alljobs.dat).</td>
<td>O, B</td>
</tr>
<tr>
<td>PORTS</td>
<td>text</td>
<td>The type or types of phone lines used for the job. Typically, no default is specified. Supervisor can edit the field on the Job Verification screen.</td>
<td>I, O, B</td>
</tr>
<tr>
<td>POST_TRANS</td>
<td>text</td>
<td>Indicates the command to update jobs. The default is usually blank. A typical command line: record_ed LIST1 LIST1-p</td>
<td>I, O, B</td>
</tr>
<tr>
<td>POSTUPDATE</td>
<td>text</td>
<td>The name of the update program. The default is usually blank.</td>
<td>I, O, B</td>
</tr>
<tr>
<td>PVCANCEL</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field. YES = Allow an agent to cancel a previewed record.</td>
</tr>
<tr>
<td>PVDIAL</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field for managed dialing. YES = Allow managed dialing.</td>
</tr>
<tr>
<td>PVEMPTYREC</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field for managed dialing. YES = Display empty record at preview. Agents can enter the required information and create a new record for calling. After the manual calling on this record is complete, the system adds this record to the calling list.</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Keyword</th>
<th>Values</th>
<th>Explanation</th>
<th>.edt type</th>
</tr>
</thead>
<tbody>
<tr>
<td>PVIGNOREDEDEL</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field for managed dialing. YES = Allow dialing from deleted record</td>
</tr>
<tr>
<td>PVKEYFLD</td>
<td></td>
<td>Key field for LIS record search.</td>
<td>O</td>
</tr>
<tr>
<td>PVLENGTH</td>
<td>seconds</td>
<td>Indicates the number of seconds an agent can preview a record before dialing begins.</td>
<td>O, B</td>
</tr>
<tr>
<td>PVSEARCHTYPE</td>
<td>LIS</td>
<td>HASH</td>
<td>NONE</td>
</tr>
<tr>
<td>QUOTAVAL</td>
<td>text</td>
<td>Indicates the quota, by completion code, for the job. Format is codenum, quota.</td>
<td>O, B</td>
</tr>
<tr>
<td>QUOTA_EXTFILE</td>
<td>filename</td>
<td>Indicates the quota settings file name.</td>
<td>B</td>
</tr>
<tr>
<td>QUOTA_SAVE</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field. YES tells the dialer to save the quota settings when the job ends.</td>
</tr>
<tr>
<td>RECALL_CPA</td>
<td></td>
<td>Enable CPA for AOR calls</td>
<td>O, B</td>
</tr>
<tr>
<td>RECALL_INTERVAL</td>
<td>minutes</td>
<td>Indicates the number of minutes in an interval to reschedule a job.</td>
<td>O, B</td>
</tr>
<tr>
<td>RECALL_NOTIFY</td>
<td>minutes</td>
<td>The notification in number of minutes that an agent receives before receiving an agent-owned recall.</td>
<td>O, B</td>
</tr>
<tr>
<td>RECALL_NUMOFTRY</td>
<td>num</td>
<td>Indicates the number of recall attempts.</td>
<td>O, B</td>
</tr>
<tr>
<td>REL_DIST</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field used for testing. YES = Release distribution.</td>
</tr>
<tr>
<td>REL_TME</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field used for testing. YES = Wait before releasing test call.</td>
</tr>
<tr>
<td>RETURNTIME:</td>
<td>num</td>
<td>A number indicating the blend agent return time, in seconds. The default is usually blank.</td>
<td>B</td>
</tr>
<tr>
<td>ROPDOWN</td>
<td>YES</td>
<td>NO</td>
<td></td>
</tr>
<tr>
<td>RUNANSWER</td>
<td>text</td>
<td>The label in the calling script, telephny.spt. Use the label to start processing inbound calls. The default is blank.</td>
<td>I, B</td>
</tr>
<tr>
<td>RUNMOH</td>
<td>text</td>
<td>Indicates the script to use when agent puts customer on hold.</td>
<td>I, O, B</td>
</tr>
<tr>
<td>RUNOFCOM</td>
<td>text</td>
<td>Script label to use OFCOM</td>
<td>O, B</td>
</tr>
</tbody>
</table>

*Table continues...*
<table>
<thead>
<tr>
<th>Keyword</th>
<th>Values</th>
<th>Explanation</th>
<th>.edt type</th>
</tr>
</thead>
<tbody>
<tr>
<td>RUNCALL</td>
<td>text</td>
<td>Indicates the label in the calling script, telephony.spt, to use to start processing outbound calls. The default is usually blank.</td>
<td>O, B</td>
</tr>
<tr>
<td>SCREEN or SCREENalphanum</td>
<td>text</td>
<td>Indicates the name to use on the Outbound Screen on Proactive Contact. For gaining multiple screen access, use this keyword multiple times followed by an alphanumeric character, alphanum, for example, SCREEN1 and SCREENA.</td>
<td>O, B</td>
</tr>
<tr>
<td>SELECT</td>
<td>text</td>
<td>Indicates the record selection (*.S) file name. The default is usually left blank.</td>
<td>O, B</td>
</tr>
<tr>
<td>SERVETIME</td>
<td>seconds</td>
<td>The number of seconds an agent sits idle as an inbound agent before the system returns the agent to outbound calling. For Intelligent Call Blending only.</td>
<td>B</td>
</tr>
<tr>
<td>SERVICELEVEL</td>
<td>percent</td>
<td>Indicates the percentage of calls needed for calculation of the cruise control feature.</td>
<td>I, O</td>
</tr>
<tr>
<td>SHADOW_IN_PREVIEW</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field. YES = Display shadow jobs in preview mode. The default is NO.</td>
</tr>
<tr>
<td>SINGLEEDIT</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field. YES = Allow only single edit of field in agent input. The default is usually NO, with no ability to edit on the Job Verification screen.</td>
</tr>
<tr>
<td>STARTTIME</td>
<td>hhmm</td>
<td>The earliest start time for a job in the 24-hour format: hh:mm. The default is blank.</td>
<td>I, O, B</td>
</tr>
<tr>
<td>STOPTIME</td>
<td>hhmm</td>
<td>Latest stop time for a job in 24-hour format hh.mm. Usually, the default is blank.</td>
<td>I, O, B</td>
</tr>
<tr>
<td>THIRD_PARTY.Dial</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field. YES = allows the Dial with third party application option. The default value is NO.</td>
</tr>
<tr>
<td>TESTMODE</td>
<td>code1= num</td>
<td>Indicates the distribution of call completion code results required.</td>
<td>O, B</td>
</tr>
<tr>
<td>Keyword</td>
<td>Values</td>
<td>Explanation</td>
<td>.edt type</td>
</tr>
<tr>
<td>-----------------</td>
<td>----------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-----------</td>
</tr>
<tr>
<td>TESTOPER</td>
<td>[code2= num] [, . . .]</td>
<td>Indicates the number of seconds agents are allowed for talk time and update time. The default is usually blank and screen is NO.</td>
<td>I, O, B</td>
</tr>
<tr>
<td>TITLE</td>
<td>text</td>
<td>This keyword specifies the title text to appear at the top of the Job Verification screen. Maximum 74 characters.</td>
<td>I, O, B</td>
</tr>
<tr>
<td>TRANJOB</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field. YES = Job uses sales verification. The default is usually blank and screen is NO.</td>
</tr>
<tr>
<td>TRANS_CRIT</td>
<td>time=value1 [,value2][,. . .]</td>
<td>Indicates the call completion code criteria the job has to meet to trigger campaign update. Specifies a minimum of one release code. The time must match a field name in the record format of the calling list.</td>
<td>I, O, B</td>
</tr>
<tr>
<td>TRANS_MAP</td>
<td>text</td>
<td>Indicates the field name by which the calling is indexed for record search. The default is usually ACCTNUM or ID. The value must match a field name in the record format of the calling list.</td>
<td>I, O, B</td>
</tr>
<tr>
<td>TRANSFER_TO_JOB</td>
<td>text</td>
<td>Indicates the target job name for a Native Voice and Data Transfer.</td>
<td>O, B</td>
</tr>
<tr>
<td>TRANSTAT</td>
<td>code1,code2, . . .</td>
<td>Used only if TRANJOB = YES. Indicates the call completion codes that will trigger call back for sales verification. The default is usually blank and screen is NO.</td>
<td>I, O, B</td>
</tr>
<tr>
<td>VIRTUAL</td>
<td>YES</td>
<td>NO</td>
<td>A toggle field. YES = This is a virtual job where there are no agents, only automated delivery of messages.</td>
</tr>
<tr>
<td>WAITLIMIT</td>
<td>seconds</td>
<td>Indicates the maximum number of seconds a call will remain in</td>
<td>I, B</td>
</tr>
<tr>
<td>Keyword</td>
<td>Values</td>
<td>Explanation</td>
<td>.edt type</td>
</tr>
<tr>
<td>-----------</td>
<td>--------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-----------</td>
</tr>
<tr>
<td>WAITMSG1</td>
<td>secs</td>
<td>The text message sent to agent screens at various customer wait times. The secs parameter specifies the minimum number of seconds that the call was in queue before the message. Each message is of maximum 20 characters and does not contain commas (,), colons (:), or the equal sign (=).</td>
<td>I, O, B</td>
</tr>
<tr>
<td>WAITMSG2</td>
<td>secs</td>
<td>Indicates message text to be sent to agent screens at various customer wait times. The secs parameter specifies the minimum number of seconds the call is in the queue before the message. Each message is 20 characters maximum, and does not contain commas (,), colons (:), or equal signs (=).</td>
<td>I, O, B</td>
</tr>
<tr>
<td>WAITMSG3</td>
<td>secs</td>
<td>Indicates message text to be sent to agent screens at various customer wait times. The secs parameter specifies the minimum number of seconds the call is in the queue before the message. Each message is 20 characters maximum, and does not contain commas (,), colons (:), or equal signs (=).</td>
<td>I, O, B</td>
</tr>
<tr>
<td>WAITMSG4</td>
<td>secs</td>
<td>Indicates message text to be sent to agent screens at various customer wait times. The secs parameter specifies the minimum number of seconds the call is in the queue before the message. Each message is 20 characters maximum, and does not contain commas (,), colons (:), or equal signs (=).</td>
<td>I, O, B</td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>Keyword</th>
<th>Values</th>
<th>Explanation</th>
<th>.edt type</th>
</tr>
</thead>
<tbody>
<tr>
<td>XFERHOLDMSGNO</td>
<td>text</td>
<td>The message during transfer of a call. Play this message when placing the customer on hold.</td>
<td>O, B</td>
</tr>
<tr>
<td>XFER_WAITQ</td>
<td>text</td>
<td>Indicates the calling script wait queue label in telephony.sptt 0 use during a Native Voice and Data Transfer.</td>
<td>I, B</td>
</tr>
</tbody>
</table>
Chapter 21: Campaign Template

Campaign Template provides various features to enhance the efficiency and effectiveness of a contact center.

Using Campaign Template, you can plan and set up campaigns to be run in the future. You can also quickly respond to a new campaign request and create and deploy a wide range of campaigns smoothly.

Campaign Template configurations are managed in the Editor application.

Note:
You can view only those campaign templates that are created for your tenant space.

Accessing Campaign Template

Procedure
1. Click Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor.
2. To start Editor and to gain access to Campaign Template, log in as sysadm or a user with privileges.
3. After you log in, change your password if you are a new user and log in again.
4. Click Campaign Template in the navigation pane of the Editor application. The system displays the Campaign template list in the central pane.

   You can also gain access to the Campaign template by clicking View > Menu > Campaign Template.

Toolbar

The following table contains information about the Campaign Template buttons and their descriptions.
<table>
<thead>
<tr>
<th>Name</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>![icon]</td>
<td>Create a new Campaign Template.</td>
</tr>
<tr>
<td>Open</td>
<td>![icon]</td>
<td>Open an existing Campaign Template.</td>
</tr>
<tr>
<td>Save</td>
<td>![icon]</td>
<td>Save a Campaign Template.</td>
</tr>
<tr>
<td>Delete</td>
<td>![icon]</td>
<td>Delete a campaign template.</td>
</tr>
<tr>
<td>Help</td>
<td>![icon]</td>
<td>Display online help.</td>
</tr>
<tr>
<td>Search</td>
<td>![icon]</td>
<td>Search option. Search is based on: All, Template, List, Strategy, Selection, Job, Agent key and Screen.</td>
</tr>
<tr>
<td>Install</td>
<td>![icon]</td>
<td>Install a campaign template to run.</td>
</tr>
<tr>
<td>Download</td>
<td>![icon]</td>
<td>Download a campaign template.</td>
</tr>
<tr>
<td>Upload</td>
<td>![icon]</td>
<td>Upload a campaign template.</td>
</tr>
</tbody>
</table>

To gain access to the New, Verify, Install, Download, Upload, and Delete options, you can also right-click the central pane of Campaign Template.

**Note:**

The Search option in the Campaign Template does not support the regular expressions in the search. To improve the search performance, restrict the search operation by selecting a particular Search In criteria. For example, if you want to search a job name, say outbound, then in the Search dialog box, select **Job** as the Search In criteria instead of **All**.

---

### Campaign Template panes field descriptions

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Left pane</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Template</strong></td>
<td>Provides various feature of Campaign Template like view a Campaign in the list.</td>
</tr>
<tr>
<td><strong>Reports</strong></td>
<td>Provides reports related to any Campaign Template.</td>
</tr>
<tr>
<td><strong>Center pane</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Template</strong></td>
<td>Displays the name of the campaigns in the first column of the center pane.</td>
</tr>
<tr>
<td><strong>Description</strong></td>
<td>Provides the description of a particular campaign.</td>
</tr>
<tr>
<td><strong>List</strong></td>
<td>Provides the information about the list of a particular campaign, like inbound and outbound.</td>
</tr>
</tbody>
</table>

Table continues…
### Creating a new Campaign Template

#### Procedure

1. Log in to the Editor application.
2. Perform one of the following steps:
   - Click the **New** icon on the toolbar and launch the Campaign Template wizard.
   - Right-click the right-pane and select **New** or select **File > New**.
3. Click **Calling List** button in the left pane and then click the **Calling List** option to show available calling list.
4. Right-click the **Calling List** pane and select **New**.
   
   ✳ **Note:**
   
   This step can be performed only when Calling List is in Active status.
5. Click **Next** in the Campaign Template wizard.
6. Enter a name and a brief description of the new campaign template in the Wizard, and click **Next**.
7. In the Campaign Template wizard, enter the type of lists and click **Next**.
8. Verify the following information in Campaign Template:
   - Template Name
   - Description
   - List
   - List Description
9. Click **Next > Finish**.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>List Description</td>
<td>Provides information about the campaign such as Collections, Verify, Sales and Inbound.</td>
</tr>
<tr>
<td>Creation Date</td>
<td>Provides the date when a campaign in the list was created.</td>
</tr>
<tr>
<td>Right pane</td>
<td></td>
</tr>
<tr>
<td>Tree View</td>
<td>The tree structure view of the template content with nodes named as Strategy, Selection, Job, Agent Key, and Screen.</td>
</tr>
<tr>
<td>Grid View</td>
<td>The grid structure view of the template content with various details such as Strategy, Selection, Job, Agent Key, and Screen.</td>
</tr>
</tbody>
</table>
Installing Campaign Template

About this task
To install a Campaign Template:

Procedure
1. Log in to the Editor application.
2. Click the Install button on the toolbar.
3. Click Next in the Campaign Template wizard.
4. Select a naming option for the campaign template from the following options:
   • Use same file as in template.
   • Add suffix to name of all template files.
   • Add prefix to name of all template files.
5. If you select the last two options, provide any suffix or prefix and click Next.
   The system accepts alphanumeric characters and the underscore (_) symbol.
6. Select the list from the Campaign Template wizard drop-down menu and click Next.
7. Review the campaign template information in the Campaign Template wizard and click Next. Resolve if there are any conflicts with the template files in the installation result.
8. Click Finish.
9. Verify the following in the Contact Management tab:
   • The Calling list application is installed on the dialer in the pending stage.
   • The Agent Keys are installed in the pending stage.
   • Jobs are in the pending stage.
   • Call Selections and Strategies are in the pending stage. The Calling list, Agent Keys, Jobs, Selections, and Strategies are displayed in the pending stage until the dialer is restarted.
10. Restart the dialer as per the maintenance schedule to activate the campaign.

Downloading a Campaign Template

About this task
To download a Campaign Template:

Procedure
1. Log in to the Editor application.
2. Click **Campaign Template**.
3. Click the download button in the toolbar to download the campaign template.
4. Save the campaign template.

* Note:

By default, the system saves the campaign template in the `.tar` file format in `%appdata%\Avaya Proactive Contact Supervisor\Editor` folder.

# Uploading a Campaign Template

**About this task**

After upgrading or migrating to the latest release of Proactive Contact, if you upload the local copy of a campaign template created on an earlier release of Proactive Contact, then the campaign template does not include the latest configuration parameters. Therefore, as a best practice, you must upload all the existing campaign templates to the dialer before upgrading or migration to the latest release of Proactive Contact.

To upload a Campaign template:

**Procedure**

1. Log in to the Editor application.
2. Click **Campaign Template**.
3. Click the upload button in the toolbar to upload a campaign template.
4. Browse to the required location and select the template.
5. Click **Open**.

* Important:

If your campaign template is created on a calling list that is used in a blend job, then the system includes only the outbound calling list in the campaign template. Additionally, you can create another campaign template using the inbound calling list that is included in the blend job.

---

**Campaign template replication across tenants**

When you upgrade from a previous release of Avaya Proactive Contact to Avaya Proactive Contact 5.2, by default, all the data is added to the default tenant. If you want to move data from the default tenant to the required tenants, use the campaign templates containing the pertinent data.
In this release, using Avaya Proactive Contact, you can copy a campaign template from the default tenant to other tenants in a multitenancy environment. With this functionality, you save time and effort when you use the same campaign template across tenants.

Only a Lead Administrator user can copy campaign template from a default tenant to another tenant. The Lead Administrator user need not belong to or have permission for the tenant from which and to which the campaign template must be copied.

#### Copying campaign template from the default tenant to another tenant

**About this task**

To copy a campaign template from the default tenant to another tenant:

**Procedure**

1. Log in to the Editor application.
2. Ensure that you are in the default tenant.
3. Click **Campaign Template**.
4. If needed, create a new campaign template, based on the calling list and other files referring to that list that you want to copy to other tenants.
5. Select the campaign template that you want to copy.
6. Right-click the selected campaign template, and click **Copy to tenant**.
   
   The system displays the Select Tenants dialog box.
7. Select the tenant to which you want to copy the campaign template.
   
   If you want to copy the campaign template to more than one tenant, you can select multiple tenants in the Select Tenants dialog box.
8. Click **OK**.

#### Copying campaign template from one tenant to another tenant

**About this task**

You can also copy a campaign template across tenants. For example, if you have a campaign template in one tenant and you want to use the same in another tenant, you can copy the template from one tenant to the other. Ideally, you should have administrative rights to both the tenants to be able to copy a campaign template from one tenant to another. Alternatively you can download the campaign template and send the template to the administrator of the tenant to which you want to copy the campaign template.
Note:

You do not need the permission of the Lead Administrator to perform this activity. You only need to have the permissions to gain access to and to use campaign templates.

To copy a campaign template from one tenant to another tenant:

Procedure

1. Log in to the Editor application.
2. Select the tenant to which you want to copy the campaign template.
3. Click Campaign Template.
4. Select the campaign template that you want to copy.
5. Right-click on the selected campaign template and click Download.
6. Save the campaign template.
7. Select the tenant to which you want to copy the campaign template.
8. Click Campaign Template.
9. Right-click in the center pane and click Upload.
10. Browse to the location where you have saved the campaign template on your local drive.
11. Click OK.

Reports in Campaign Template

Reports can be generated in the Campaign template based on Strategy, Selection, Job, and Agent Key.

There are two types or reports in the Campaign template:

- List Assignment Report: Generates reports with all campaign templates and lists.
- Template Contents Report: Generates reports with all campaign templates with contents.

Viewing campaign template reports

About this task

To view campaign template reports

Procedure

1. Log in to the Editor application.
2. Click Campaign Template.
3. Click Reports in the left pane of the campaign template.
4. Click **Template Content Reports** to view the data in the right pane. The report displays data under the following columns:

- Template
- List
- Strategy
- Selection
- Job
- Agent Key
- Screen

5. Click **Line Assignment Reports** to view the data in the right pane. The report displays data under the following columns:

- List
- Template
- Description
- Creation Date

You can view reports in Campaign Template in the Grid view only. You can view the saved HTML report in Internet Explorer.

6. To save a report, click **File > Save as HTML**.

---

## Error Messages

The following table provides the description of common messages that appear during the use of Campaign Template:

<table>
<thead>
<tr>
<th>Message</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Please enter template name</td>
<td>Appears when a user does not enter the template name in the Create Template Wizard.</td>
</tr>
<tr>
<td>Please enter prefix/ suffix</td>
<td>Appears when a user does not enter the prefix or suffix in the Create Template Wizard.</td>
</tr>
<tr>
<td>Please select list</td>
<td>Appears when a user does not enter the list name in the Create Template Wizard.</td>
</tr>
<tr>
<td>Please enter new name for the selected file</td>
<td>Appears when a user enters invalid name or null value for any template file in the install wizard.</td>
</tr>
<tr>
<td>There are some files on the system that conflict with the template files</td>
<td>Appears when the template files name conflicts with the files already present on the dialer during template installation.</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Message</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Note:</td>
<td>Overwrite the file or change the file name to avoid this message.</td>
</tr>
<tr>
<td>Campaign Template Installation Completed</td>
<td>Appears after a successful installation of a template.</td>
</tr>
<tr>
<td>The Campaign Template Wizard is open. Do you want to close it now?</td>
<td>Appears when the template wizard (create or install) is open and the user wants to switch to other component.</td>
</tr>
<tr>
<td>Load Templates Failed</td>
<td>Appears when there is an error in loading the templates in the Grid.</td>
</tr>
<tr>
<td>cannot save as active, one or more depend on files are not active</td>
<td>Appears when dependent files are not in active stage while saving as active.</td>
</tr>
<tr>
<td>File already exists</td>
<td>Appears when a template file already exists on the dialer.</td>
</tr>
<tr>
<td>File is protected</td>
<td>Appears when any Calling List is protected.</td>
</tr>
<tr>
<td>Active version of file is protected</td>
<td>Appears when any Calling List (active version) is protected.</td>
</tr>
<tr>
<td>Tbl file is inconsistence</td>
<td>Template tbl file is inconsistent.</td>
</tr>
<tr>
<td>Invalid file name</td>
<td>Appears when a template file name is invalid.</td>
</tr>
<tr>
<td>Could not transfer template file</td>
<td>Appears when a tar file in a template is not uploaded or downloaded (sftp error).</td>
</tr>
<tr>
<td>Download is successful</td>
<td>Appears when a template is downloaded successfully.</td>
</tr>
<tr>
<td>Upload is successful</td>
<td>Appears when a template is uploaded successfully.</td>
</tr>
<tr>
<td>Download is failed</td>
<td>Appears when a template download fails.</td>
</tr>
<tr>
<td>Upload is failed</td>
<td>Appears when a template upload fails.</td>
</tr>
<tr>
<td>Search data not found</td>
<td>Appears when the data is not found in search operation.</td>
</tr>
<tr>
<td>There are no Strategies, Selections, Agent Keys, jobs and Screens in this template</td>
<td>Appears when a template does not have any file (except list).</td>
</tr>
</tbody>
</table>
Chapter 22: Agent Job List

When an agent joins a job using Proactive Contact Agent application or a client application that is developed using Agent API, all the running jobs that are included in the job list of the agent, if there is any, are displayed. Earlier, all the available running jobs were displayed to the agents. The Agent Job List feature is tenant specific, which means that you can manage the agent job list feature only for the jobs and agents assigned to your tenant space.

Using Agent Job List pane, you can:

• Map agents to jobs within your tenant.
• Modify the mapping between agents and jobs in your tenant.
• View basic reports related to jobs assignment to agents within your tenant.

There are no active, pending, in-progress, or deleted stages for Agent job lists. However, you can view a union of active and pending jobs to add them to any agent's job list. This provides added flexibility to list going to be active jobs for an agent.

Creating an agent job list

About this task
To create an agent job list:

Procedure

1. Log in to the Editor application.
2. Click Agent Job List on the left pane.
3. Click File > New. The Agent Job List wizard is displayed.
4. Click Next. The next page displays a list of all the agents and all the active and pending jobs.
5. Assign agents to the jobs by selecting the required check boxes. For example, select the check box for an agent and then select the corresponding check boxes for the jobs to which you want to assign this agent.

✅ Note:

You can map an agent to a maximum of 80 jobs.
6. Click Next. The system displays the review Information page. On this page, you can review your selection. To make any modification, click Back.

7. Click Finish. The mapping between agent and jobs appear in the Agent Job List pane.

Deleting an agent job list

About this task
To delete an agent job list:

Procedure
1. Log in to the Editor application.
2. Click Agent Job List on the left pane.
3. In the Agent Job List pane, select the required agent job list, right-click and select Delete.
4. In the Delete dialog box, a confirmation message is displayed. Click OK.

Adding a job to an agent job list

Procedure
1. Log in to the Editor application.
2. Click Agent Job List on the left pane.
3. Select an agent on the Agent Job List pane.
4. In the Agent Job List Contents pane, right-click on a row and select Append Row.
5. Select a job from the Job drop-down list.
6. To add more jobs, repeat Step 3 to Step 5.

⚠️ Note:
You can map an agent to a maximum of 80 jobs.

7. Click Save.

Deleting a job from an agent job list

About this task
To delete a job from an agent job list:
**Procedure**

1. Log in to the Editor application.
2. Click **Agent Job List** on the left pane.
3. Select an agent on the **Agent Job List** pane.
4. In the Agent Job List Contents pane, right-click on a row and select **Delete Row**.

---

**Viewing Agent Job List Reports**

**About this task**

The Agent Job List menu displays reports on the following two categories:

- **Jobs associated with agents**: This report displays all the jobs assigned to an agent for whom a job list has been created. This information is tenant-specific.
- **Agents associated with jobs**: This report displays all the agents assigned to a job that is included in at least one of the job lists. This information is tenant-specific.

To view Agent Job List reports:

**Procedure**

1. Log in to the Editor application.
2. Click **Agent Job List** on the left pane.
3. To view a report on the jobs associated with each selected agent, select **Jobs associated with agents** in the Agent Job List Reports pane. The **Jobs associated with agents** pane displays a list of jobs to which each agent can join.
4. To view a report on the agents associated with each selected job, select **Agents associated with jobs** in the Agent Job List Reports pane. The Agents associated with jobs pane displays a list of agents assigned to each job.
Chapter 23: Monitor settings

In Avaya Proactive Contact, you can monitor real-time calling activities using Monitor and also specify how to view real-time calling activities.

You can specify how to monitor calling activities in the following ways:

• Arrange data
• Specify the time range
• Change a job as the job runs
• Customize a view according to completion code
• Customize a view according to an agent’s state
• Determine the refresh rate and the preferred saving method

Note:

In Monitor, you must use only period (.) as decimal separator irrespective of the regional language settings.

You can modify the Monitor default settings during a job from the Monitor toolbar. You can also save the changes to a custom view for use when next time you use Monitor.

Monitor applies the default settings to the view when you open Monitor. To use the customized settings, select the custom view from the button bar.

The button groups on the left pane filter the type of information you see by the following views:

• View set
• Dialer
• Job
• Supervisor
• Agent
• Custom

The buttons in each view set display detailed information about that view. Using Monitor, you can define how to view real-time calling activities.
Monitor settings in multitenant environment

With the introduction of multitenancy in this release, the Monitor application has undergone changes. Now, Supervisors can view and customize reports belonging to only their tenant spaces. If Supervisors belong to multiple tenancies, then Supervisors can switch tenancies without logging out of the Monitor application. If supervisors belong to multiple tenancies, then they have an option to view data belonging to all the tenancies in Monitor.

Lead Administrator can perform both real-time and historical reporting across the dialer and view data of all the tenants. Lead Administrator can also listen to the calls. However, the Lead Administrator can perform these functions only if the Tenant Administrator assigns sufficient permission to the Lead Administrator for these features.

Supervisors having sufficient permission can create a hierarchy at the following levels only for their tenants:

- Agent-level hierarchy
- Job-level hierarchy
- Dialer-level hierarchy

Note: In a dialer-level hierarchy, the system displays only the dialer to which the tenant belongs.

In Monitor, supervisors having sufficient permission can use only those hierarchy filters which belong to the tenant.

When Supervisors choose to view all tenants data, the supervisors cannot modify the run-time environment and use tools such as alerts and hierarchy manager.

Monitor window

Monitor has a button bar on the left-hand side of the screen and the main pane on the right-hand side to display various windows or views.

The button bar expands and contracts to display buttons associated with the group. A view is a window that displays when you click a button in the button bar. In each view, you can filter information and customize how you monitor the calling activities, including sorting data and resizing columns. A view displays data based on the type of calling activity and specific criteria.
You can use the toolbar options in each view to modify and create views. Monitor lists views that you create in the Custom group. You can click a column heading to sort the contents of a view.

**Tip:**

The system displays an arrow in the column heading to indicate the sort order. An Up arrow indicates that the data is in the ascending order. A Down arrow point indicates that the data is displayed in the descending order.

---

### Resizing columns in a view

**Procedure**

1. Place your cursor between the heading titles until the system displays a double arrow.
2. Hold down the left mouse button and drag the cursor to resize the columns.

You can:

- Customize individual views using the toolbar.
- Customize various monitor views.

**Related links**

- [Creating a custom view](#) on page 327
- [Filtering data in a view](#) on page 345

---

### Setting the default hierarchy

**About this task**

The default hierarchy is set in the Options dialog box. In a multitenancy environment, you must set the hierarchy for each tenant. When you set the hierarchy, the system uses the settings for the tenant unless you change the hierarchy again. Since this setting must be made for each tenant, therefore, if you select the All tenants option, then this configuration is disabled.

The Scope tab affects the options you see in a view’s toolbar.

**Note:**

You must create a custom or an agent/supervisor hierarchy before you can select a hierarchy from the Scope tab.

For example, on the Scope tab, you select a hierarchy from the agent/supervisor list, then, when a view is opened and you select agent/supervisor hierarchy from the list that appears when you click the Hierarchy Manager toolbar icon, the hierarchy defined on the Scope tab is used.

To set the default hierarchy:

**Procedure**

1. In Monitor, select **Settings > Options**.
2. In the Options dialog box, select the Scope tab.

3. Under How should data be arranged, select a hierarchy from the following drop-down lists:

Result
• Select a hierarchy from the Agent/supervisor list to use as the default view when you select the Use the agent/supervisor hierarchy option in any view.

   ✱ Note:
   If you select Use custom Hierarchy, you need to have previously created hierarchies using the Hierarchy Manager tool.

• Select a custom hierarchy from the Custom Hierarchy list to use as the default view when you select the Use custom hierarchy option in any view.

   1. Click OK or Apply.

Related links
   Options Scope tab field descriptions on page 330

Setting time range

About this task
The time range is set in the Options dialog box. The preferences that you specify in the Options dialog box’s Scope tab dynamically affect the Time Scope button on all of your views’ toolbars.

To set the time range:

Procedure
1. In Monitor, select Settings > Options.
2. In the Options dialog box, select the Scope tab.
3. Under What time range should views support, select Show data for both active and recent jobs if you want to see data both for the currently running jobs and the jobs that have run today but have since shutdown.

Related links
   Options dialog box on page 330

Setting multi-dialer views

About this task
Use the Multi-Dialer tab to choose the dialers for which you can execute commands.
In a multitenancy environment, the multi-dialer settings are not applicable for tenants. However, for the default tenant, you can set the multi-dialer views as in the previous releases of Avaya Proactive Contact.

To set multi-dialer views:

**Procedure**

1. In Monitor, select **Settings > Options**.
2. In the Options dialog box, select the **Multi-Dialer** tab.
3. To set up how to apply the job changes, complete one of the following steps:
   a. To apply job changes to all the dialers, select **Apply job changes to all selected dialers**.
      or
   b. To apply job changes to specific dialers, select the name of each dialer in the Dialer list to which you want to apply job changes.
4. Click **OK**.

**Related links**

- [Options Multi-Dialer Control tab field descriptions](#) on page 330

---

**Setting agent states to display**

**About this task**

Use the Agent States tab on the Options dialog box to choose the agent states to be displayed.

To display agent states:

**Procedure**

1. In Monitor, select **Settings > Options**.
2. In the Options dialog box, select the **Agent States** tab.
3. Select the states to display. You can select from the following options:
   - Talk
   - Update a record
   - Idle
   - ACD
   - Logging off
   - Off job
   - Offline
Setting the view set

About this task
Use the Appearance tab to set the view set and refresh rate.
To set the view and refresh rate:

Procedure
1. In Monitor, select Settings > Options.
2. In the Options dialog box, select the Appearance tab.
3. Enter the view set to use, or select Browse to locate your view set.
4. Click the Up or Down arrow to set the refresh interval, in seconds, for your views.
5. Click OK.

Related links
Options Appearance tab field descriptions on page 331

Saving exit settings

About this task
Use the Feedback tab to choose how to save changes to views and view sets when the application closes.

Procedure
1. In Monitor, select Settings > Options.
2. In the Options dialog box, select the Feedback tab.
3. Select when to save the changes. The options are:
   • When a view closes
   • When the application closes
   • When a command is initiated
4. Click OK.
Setting alert monitoring

About this task
Use the Alerts tab to start alert monitoring automatically and to disable email alert notifications.

To set alert monitoring:

Procedure

1. In Monitor, select Settings > Options.
2. In the Options dialog box, select the Alerts tab.
3. Select any of the following check boxes that you want to apply to alerts:
   • Start alert monitoring automatically
   • Disable email notifications
Chapter 24: Monitor views

Avaya Proactive Contact allows you to navigate among the tool applications and customize the Monitor views.

★ Note:
To use some of the features in Avaya Proactive Contact Monitor, you might need to configure some parameters in the backend file, master.cfg. To configure these parameters, contact Avaya Professional Services.

Navigating among the Tool menu applications

About this task
Monitor comes with the tool applications that you can gain access to from the Tools menu.

To start Tools menu applications:

Procedure
1. Select Start > All Programs > Avaya > Proactive Contact > Supervisor > Monitor.
2. To start a tool, select the tool option from the Tools menu.
   While you use the tool, Monitor remains open in the background so that you can navigate back to Monitor when you are finished using the tool.

Switching between icons in the button bar

Procedure
1. On the button bar, click a group name to expand the button bar whose icon size you want to change.
2. Right-click and select Large Icons or Small Icons.
   A check mark next to the menu command indicates the view that you are currently using.
Opening a standard view

Procedure

1. On the Monitor button bar, click one of the following groups of views:
   • View Set
   • Dialer
   • Job
   • Supervisor
   • Agent
   • Custom
2. Click the view you want to open.
   The view opens as a new window in the right-hand pane.

Opening a view or view set from another location

Procedure

1. In Monitor, select File > Open.
2. Locate and select the view or view set you want to open, or type the file name in the File name field, and then click Open.
   The view or view set opens as a new window in the right-hand pane.

Opening a view about a specific agent

About this task

You can display the following views to list information about a specific agent:
   • Agent Detail
   • Agent Completion Codes
   • Agent History

To open a view about a specific agent:

Procedure

1. Display a view that lists agents. For example, Dialer Agents or Job Agents.
2. Select an agent in the view.
3. Select **Tools**, and then a view.

---

**Monitor views customization**

In Monitor, you can customize and save a view. You can also save multiple views as a view set. The Monitor wizard helps you customize how you monitor calling activities for the contact center and specific jobs.

---

**Creating a custom view**

**Procedure**

1. In Monitor, select **File > New**.
   
   The **New View Wizard** opens.

2. Follow the steps in the View Wizard to create your custom view.

3. **(Optional)** In a multitenancy environment, you can also select the **Tenant name** in the Choosing data fields page to include the tenant name in the view.

---

**Saving current view**

**Procedure**

1. On the Monitor button bar, click one of the following groups of views:
   
   • **View Set**
   
   • **Dialer**
   
   • **Job**
   
   • **Supervisor**
   
   • **Agent**
   
   • **Custom**

2. Click the view you want to open.
   
   The view opens as a new window in the right-hand pane.

3. Change the view using the view’s toolbar.

4. When you have the view set up the way you want, select **File > Save**.
   
   The next time you select the view, your saved preferences appear.
Saving as a view set

About this task
In Monitor, you can open one or more views and save the views as set for use later from the View Set button bar.

To save a view set:
Procedure
1. On the Monitor button bar, click one of the following groups of views:
   - View Set
   - Dialer
   - Job
   - Supervisor
   - Agent
   - Custom
2. Click the view you want to open.
   The view opens as a new window in the right-hand pane.
3. Repeat Steps 1 and 2 until you have all the necessary views open.
4. Select File > Save All As.
5. Browse to the location where you want to save the view set, enter a name, and then click OK.
6. In the Add a Custom View dialog, enter the name for the view set, and then click OK.
   A button for the view set appears in the View Set group.

Saving view set with a new name

Procedure
1. On the Monitor button bar, click one of the following groups of views:
   - View Set
   - Dialer
   - Job
   - Supervisor
   - Agent
   - Custom
2. Click the button for the view set you want to open. The view set opens.
3. Select File > Save All As.
4. Enter the name you want to give your view set, and then click OK. The view set’s new name appears in the View Set button bar.

Deleting a view set

Procedure
1. On the Monitor button bar, click View Set.
2. Right-click the view set you want to delete, and then select Remove View Set.

Adding a view to the Custom button group

About this task
To create a button, you must have a view open in the main pane.

To add a view to the Custom button group:

Procedure
1. Open a view that you would like to have as a button.
2. Click File > Save As.
3. Enter a name and then click OK.
   The view automatically appears in the Custom button group.

Refreshing a view

Procedure
To refresh an open view, press the F5 key.
Chapter 25: Monitor dialog boxes

View control dialog boxes

Options dialog box

Options Scope tab field descriptions

The Scope tab allows you to set your preferences for data display and time range.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>How should data be arranged</td>
<td>Select a hierarchy by using the following drop-down lists:</td>
</tr>
<tr>
<td></td>
<td>• Agent/supervisor hierarchy: Sets the default hierarchy when you select <strong>Agent/supervisor hierarchy</strong> in any view.</td>
</tr>
<tr>
<td></td>
<td>• Data is arranged according to dialers, jobs, and supervisors and the agents assigned to supervisors according to the selected default agent/supervisor hierarchy.</td>
</tr>
<tr>
<td></td>
<td>• Custom hierarchy: Sets the default hierarchy when you select <strong>Custom hierarchy</strong> in any view.</td>
</tr>
<tr>
<td></td>
<td>• Data is arranged based on the three levels defined in a hierarchy that has been set up in the Hierarchy Manager tool.</td>
</tr>
<tr>
<td>What time range should views support?</td>
<td>Gives you the option to select <strong>Show data for all jobs run since the last dialer restart, if applicable.</strong></td>
</tr>
</tbody>
</table>

Options Multi-Dialer Control tab field descriptions

The Multi-Dialer Control tab allows you to choose the available dialers that you want to include in your view.
### Options Agent States tab field descriptions

This tab allows you to select the agents states to be displayed.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display agents with these states</td>
<td>Allows you to select the states to be displayed in the Monitor views.</td>
</tr>
</tbody>
</table>

### Options Appearance tab field descriptions

The Appearance tab allows you to select a particular view to be used as the appearance for future views and also allows you to set the refresh rate for all views.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use this view set</td>
<td>Allows you to select a default view set to use in Monitor.</td>
</tr>
<tr>
<td>Default refresh rate</td>
<td>Allows you to specify the number of seconds to wait between each data refresh.</td>
</tr>
<tr>
<td>Enable Reconnection with Server</td>
<td>Provides permission for you to specify whether Monitor must connect to the server by default</td>
</tr>
</tbody>
</table>

### Options Feedback tab field descriptions

You can choose how the changes to the views and view sets are saved when the application closes. The options are: always save, prompt to save changes, or do not save.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>When a view closes</td>
<td>Lists the save options to apply when a view closes.</td>
</tr>
<tr>
<td>When the application closes</td>
<td>Lists the save options to apply when Monitor closes.</td>
</tr>
<tr>
<td>When a command is initiated</td>
<td>Lists the save options to apply when a command is initiated.</td>
</tr>
</tbody>
</table>

### Options Alerts tab

The Alerts tab allows you to automatically start the alert monitoring feature and disable email notifications.
Customize Status Bar dialog box field descriptions

Use the Customize Status Bar dialog box to choose the information you want to see in the Monitor status bar.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Available status panels</td>
<td>Lists the different options in which you can display Monitor in the status bar.</td>
</tr>
</tbody>
</table>
Job control dialog boxes

Stop Job dialog box field descriptions

The Stop Job dialog box allows you to stop a job.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stop job gracefully as agents complete calls</td>
<td>Allows you to stop a job after the agents complete their current calls. This option allows the agents to end their current calls and release the records.</td>
</tr>
<tr>
<td>Stop job immediately</td>
<td>Allows you to stop a job immediately. The system disconnects all phone conversations and closes the records immediately. As a result, agents cannot finish speaking with a customer or update customer records.</td>
</tr>
<tr>
<td>Apply changes to all dialers under multi-dialer control</td>
<td>Available only when multi-dialer control is enabled. Allows you to stop a job with the same name on more than one dialer.</td>
</tr>
</tbody>
</table>

Job Link dialog box field descriptions

The Job Link dialog box allows you to connect jobs so that a new job automatically begins when one job ends.

When you link a job, the system transfers each agent to the next job after the agent completes the last call and releases the record. The system displays a message telling the agents that they are changing jobs.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current link</td>
<td>Identifies the job currently scheduled to start when the current job ends.</td>
</tr>
<tr>
<td>New link</td>
<td>Lists the jobs to which the current job can link.</td>
</tr>
<tr>
<td>Apply changes to all dialers under multi-dialer control</td>
<td>Available only when multi-dialer control is enabled. Allows you to change the job link for the same job on multiple dialers.</td>
</tr>
</tbody>
</table>

Escape Recall Job dialog box field descriptions

The Escape Recall Job dialog box allows you to change the job from which you want to pull the agent to address the recalls in run time.
### Record Selection of Link Job dialog box field descriptions

The Record Selection of Link Job dialog box allows you to change the percentage completion value of a job before the linked job is started.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Run early</td>
<td>Use the scroll bar to set the job completion percentage.</td>
</tr>
<tr>
<td>Value</td>
<td>Alternatively, use the Value combo-box to set the job completion percentage using either the arrow keys or by putting the value manually.</td>
</tr>
<tr>
<td>Apply changes to all dialers under multi-dialer control</td>
<td>Available only when multidialer control is enabled. Using this field, you can change the completion percentage for a job with the same name on more than one dialer.</td>
</tr>
</tbody>
</table>

### Minimum Hit Rate dialog box field descriptions

Minimum hit rate prevents the dialer from allocating more lines to a poorly performing job at the expense of a more successful job. For example, a minimum hit rate of 30% means the dialer will make no more than three dialing attempts for each agent.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Value</td>
<td>The minimum hit rate determines the maximum number of calls the dialer will make as it attempts to make an agent connection. Enter a value from 0 through 100 in the increments of 10, or use the slider bar to set a minimum hit rate value. A typical setting is 30.</td>
</tr>
<tr>
<td>Apply changes to all dialers under multi-dialer control</td>
<td>Available only when multi-dialer control is enabled. Allows you to change the minimum hit rate for the same job on multiple dialers.</td>
</tr>
</tbody>
</table>
Expert Calling Ratio dialog box field descriptions

The Expert Calling Ratio affects the wait queue and the calling pace. The dialer achieves a balance between agents waiting for a call and customers placed in the wait queue.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expert Calling Mode</td>
<td>Identifies the current mode (Calls in the wait queue, Agent Work Time, or Agent Update Time) with which the dialer calculates the Expert Calling ratio. Select a different option in this field to change the mode.</td>
</tr>
<tr>
<td>Value</td>
<td>Displays the current Expert Calling ratio value. Type a percent value from 1 through 100 to change the Expert Calling ratio.</td>
</tr>
<tr>
<td>Apply changes to all dialers under multi-dialer control</td>
<td>Available only when multi-dialer control is enabled. Allows you to change the Expert Calling ratio for the same job on multiple dialers.</td>
</tr>
</tbody>
</table>

Inbound Settings dialog box field descriptions

Inbound settings control the way the dialer transfers blend agents between inbound and outbound calling activities.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reassign agents to inbound</td>
<td>Determines the maximum time a call can be in the wait queue before the system transfers a blend agent to take inbound calls. To emphasize the call center productivity, you can decrease the agent wait time. The Percentage of clients waiting exceeds setting overrides the Client wait exceeds setting. For Client wait exceeds, type a maximum amount of time, in seconds, from 0 to 999 for which a call can be in the wait queue before the system transfers a blend agent to take inbound calls. For Percentage of clients waiting exceeds, type a number from 100 to 200 to represent the maximum percentage of calls to be in the wait queue. The dialer compares the number of wait queue calls to the number of inbound and blend agents. For example, two blend agents and three inbound agents are on a job. If the Percentage of clients waiting exceeds value is 100, five calls (100% of combined inbound and blend agents) must be in the wait queue before the system transfers a blend agent to take inbound calls.</td>
</tr>
</tbody>
</table>

Table continues…
### Managed Dialing dialog box field descriptions

The Managed Dialing dialog box allows you to change managed job preferences.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preview length</td>
<td>Sets the time for which an agent can preview a record before the dialer dials the number. You must enter a value (in seconds) from 1 to 999 in the Time limit field. Select <strong>No limit</strong> to set an unlimited amount of preview time.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong></td>
</tr>
<tr>
<td></td>
<td>For a job for which manual dialing is enabled, the preview length you set here is ignored by the dialer.</td>
</tr>
<tr>
<td>Allow agents to cancel call</td>
<td>Allows you to choose whether agents can cancel a Managed Dialing call.</td>
</tr>
<tr>
<td>Apply changes to all dialers under multi-dialer control</td>
<td>Available only when multi-dialer control is enabled. Allows you to change the Managed Dialing settings for the same job on multiple dialers.</td>
</tr>
</tbody>
</table>

### Time Zones dialog box field descriptions

Select the time zones you want to call.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Call records in order by time zone</td>
<td>Allows you to make the dialer attempt to call all records in one time zone before moving to the next time zone. If you clear this option, the system attempts calls across all selected and available time zones.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Time Zones</td>
<td>Lists all the time zones. Selected time zones are highlighted by a check mark.</td>
</tr>
<tr>
<td>Start Time</td>
<td>Recommended start time for each time zone.</td>
</tr>
<tr>
<td>Stop Time</td>
<td>Recommended stop time for each time zone.</td>
</tr>
<tr>
<td>Records</td>
<td>The total number of records selected for calling in each time zone.</td>
</tr>
<tr>
<td>Available</td>
<td>The current number of records that are eligible to be called at the current time for each time zone.</td>
</tr>
<tr>
<td>Recalls</td>
<td>The current number of records set for recall in each time zone.</td>
</tr>
<tr>
<td>Active totals</td>
<td>Displays totals for the Records, Available, and Recalls columns.</td>
</tr>
<tr>
<td>Apply changes to all dialers under multi-dialer control</td>
<td>Available only when multi-dialer control is enabled. Allows you to change the time zone settings for the same job on multiple dialers.</td>
</tr>
<tr>
<td>Activate All</td>
<td>Selects all the time zones.</td>
</tr>
<tr>
<td>Deactivate All</td>
<td>Clears all the time zones.</td>
</tr>
</tbody>
</table>

**Unit Work Lists dialog box field descriptions**

If you want a job to have a sub-area so that certain agents can log into a special area and work with certain customers, you can set up a Unit Work List for a job.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unit ID</td>
<td>Lists all available Unit IDs. Selected units are highlighted by a check mark. An Allid Unit ID indicates that the job is not set up for Unit Work Lists.</td>
</tr>
<tr>
<td>Records</td>
<td>The total number of records selected for each Unit ID.</td>
</tr>
<tr>
<td>Available</td>
<td>The current number of records that are eligible to be called for each Unit ID.</td>
</tr>
<tr>
<td>Recalls</td>
<td>The current number of records set for recall for each Unit ID.</td>
</tr>
<tr>
<td>Totals</td>
<td>Displays totals for the Records, Available, and Recalls columns.</td>
</tr>
<tr>
<td>Apply changes to all dialers under multi-dialer control</td>
<td>Available only when multi-dialer control is enabled. Allows you to change the Unit Work List settings for the same job on multiple dialers.</td>
</tr>
<tr>
<td>Activate All</td>
<td>Selects all the unit IDs.</td>
</tr>
<tr>
<td>Deactivate All</td>
<td>Clears all the unit IDs.</td>
</tr>
</tbody>
</table>
Quota dialog box field descriptions

A quota is a maximum number of releases defined for a particular completion code. When the quota for a unit is reached, no more records are dialed.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unit ID</td>
<td>Lists all Unit IDs. For non-Unit Work List jobs, Allid is the only Unit ID.</td>
</tr>
<tr>
<td>Completion Code</td>
<td>Identifies the selected completion code to track.</td>
</tr>
<tr>
<td>Quota</td>
<td>Displays the quota limit for the selected completion code. You must enter</td>
</tr>
<tr>
<td></td>
<td>a number greater than 0.</td>
</tr>
<tr>
<td>Apply changes to all dialers under multi-dialer</td>
<td>Available only when multi-dialer control is enabled. Allows you to change</td>
</tr>
<tr>
<td>control</td>
<td>the quota settings for the same job on multiple dialers.</td>
</tr>
</tbody>
</table>

Alternate Initial Phones dialog box field descriptions

The alternate initial phone replaces the initial phone as the first phone number to call at a particular time of day.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phone</td>
<td>Select the phone to be used as the alternate initial phone.</td>
</tr>
<tr>
<td>Local Time</td>
<td>Displays the time that the system starts calling the alternate initial phone</td>
</tr>
<tr>
<td></td>
<td>based on the local time in the selected time zone. You must enter the time</td>
</tr>
<tr>
<td></td>
<td>of day to switch to the alternate phone.</td>
</tr>
<tr>
<td>Time Zones</td>
<td>Lists the selected time zones for the selected alternate phone.</td>
</tr>
<tr>
<td>Add Phone</td>
<td>Adds a row for a new alternate initial phone.</td>
</tr>
<tr>
<td>Remove Phone</td>
<td>Removes the selected alternate initial phone.</td>
</tr>
<tr>
<td>Apply changes to all dialers</td>
<td>Available only when multi-dialer control is enabled. Allows you to change</td>
</tr>
<tr>
<td>under multi-dialer control</td>
<td>the alternate initial phone settings for the same job on multiple dialers.</td>
</tr>
</tbody>
</table>

Detection Modes dialog box field descriptions

Detection Mode refers to the types of calls you want the system to pass to agents.
### Phone

**Description:** Identifies the phone field to which the system applies the detection modes settings.

### Rings

**Description:** Displays the number of rings to allow before the system records a NOANSWER completion code.

### Pass to Agent

**Description:** Lists the call detection modes that you can choose to pass to agents. For example, you might select Human Voice and Answering Machine as the types of calls that agents should handle.

### Apply changes to all dialers under multi-dialer control

**Description:** Available only when multi-dialer control is enabled. Allows you to change the detection modes settings for the same job on multiple dialers.

### Add Phone

**Description:** Adds a new row to define detection modes settings for another phone.

### Remove Phone

**Description:** Removes the selected phone and detection modes settings.

---

### Retry dialog box field descriptions

Retry settings specify how the system should handle the system-set retries.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Call This Phone</td>
<td>Lists phones for which recall settings are currently active.</td>
</tr>
<tr>
<td>Results</td>
<td>Defines the call result for which the system attempts retries.</td>
</tr>
<tr>
<td>Retry Interval</td>
<td>Defines the number of minutes between retry attempts.</td>
</tr>
<tr>
<td>Attempts</td>
<td>Defines the maximum number of call attempts that the system places for each result.</td>
</tr>
<tr>
<td>Next Phone</td>
<td>Defines the next phone that the system calls when it has completed the defined number of attempts.</td>
</tr>
<tr>
<td>Apply changes to all dialers under multi-dialer control</td>
<td>Available only when multi-dialer control is enabled. Allows you to change the retry settings for the same job on multiple dialers.</td>
</tr>
<tr>
<td>Add Retry</td>
<td>Adds a new row to set up new retry parameters.</td>
</tr>
<tr>
<td>Remove Retry</td>
<td>Removes a selected row from the Retry dialog box.</td>
</tr>
</tbody>
</table>

---

### Lines dialog box field descriptions

Reassign lines when you feel that certain jobs could use more lines and certain jobs do not need as many lines.
**Monitor dialog boxes**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Line Group</strong></td>
<td>Lists the line groups set up for the system. Active line groups are highlighted by a check mark.</td>
</tr>
<tr>
<td><strong>Type</strong></td>
<td>Identifies the type of lines, such as outbound or inbound, in each line group.</td>
</tr>
<tr>
<td><strong>Apply changes to all dialers under multi-dialer control</strong></td>
<td>Available only when multi-dialer control is enabled. Allows you to change the line assignments for the same job on multiple dialers.</td>
</tr>
<tr>
<td><strong>Activate All</strong></td>
<td>Selects all line groups for the job.</td>
</tr>
<tr>
<td><strong>Deactivate All</strong></td>
<td>Clears all line groups from the job.</td>
</tr>
</tbody>
</table>

**Selection Records dialog box field descriptions**

Use the Selection Records dialog box to define your record selection statement in real-time.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Field</strong></td>
<td>You must use the drop-down list to select a field (for example, BALANCE) to be used for record selection. The field values are the fields as defined in the calling lists in Editor.</td>
</tr>
<tr>
<td><strong>Value</strong></td>
<td>In this field, you must enter a value such as, &gt;3000</td>
</tr>
<tr>
<td><strong>Logic</strong></td>
<td>Use this field to create a multi-line logic statement. You must click the Logic drop-down list and select And or Or.</td>
</tr>
</tbody>
</table>

**Selection Results dialog box field descriptions**

Use the Selection Results dialog box to define the completion codes for the new record selection in real-time.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Previous Results</strong></td>
<td>The Completion codes that you want to include for the selection.</td>
</tr>
<tr>
<td><strong>Description</strong></td>
<td>Description of the completion codes.</td>
</tr>
</tbody>
</table>

**Selection Sort dialog box field descriptions**

Use the Selection Sort dialog box to sort the records as per priority, field, and order.
### Agent control dialog boxes

#### Find Agent dialog box field descriptions

The Find Agent dialog box allows you to search for one or more agents. You can then do the following:

- Send selected agents a message
- Remove the selected agents from a job
- Transfer the selected agents to another job
- Monitor the selected agents

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of an agent or use wildcard characters to select multiple agents.</td>
</tr>
<tr>
<td>Dialer, Supervisor, Job</td>
<td>Use hierarchies to filter information based on dialer, job, or supervisor (if supervisor hierarchy is set up).</td>
</tr>
<tr>
<td>Send a message to agents icon</td>
<td>Sending instant messages lets you communicate directly with agents. Agents see your messages through their Proactive Contact Agent screen. Agents can receive these instant messages even when they are on a call with a customer. After finding an agent, you can click the Send Message button.</td>
</tr>
<tr>
<td>Remove agent icon</td>
<td>Lets you end an agent’s session on a job. Use this option only for emergencies when the agent cannot use a normal disconnect. The agent is immediately removed from the job and logged out of the Proactive Contact. After finding an agent, you can click the Remove Agent button.</td>
</tr>
<tr>
<td>Transfer agent icon</td>
<td>Lets you place an agent on a different calling job. After finding an agent, you can click the Transfer Agent button.</td>
</tr>
</tbody>
</table>
Monitor dialog boxes

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monitor agent icon</td>
<td>Lets you listen to an agent’s conversation with a customer. After finding an agent, you can click the Monitor Agent button.</td>
</tr>
<tr>
<td>Show an agent view icon</td>
<td>Lets you choose to display the Agent Detail view, Agent Completion Codes view, or Agent History view for the selected agents. After finding an agent, you can click the Agent Detail button.</td>
</tr>
</tbody>
</table>

Transfer Agent dialog box field descriptions

Select a job to which the dialer will transfer the agent.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Available Jobs</td>
<td>Lists the jobs to which you can transfer an agent.</td>
</tr>
</tbody>
</table>

Send Message dialog box field descriptions

Allows you to type the message you want to send to agents.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Message text</td>
<td>A message that you want to send to the selected agents.</td>
</tr>
</tbody>
</table>

Monitor Agent dialog box field descriptions

The Monitor Agent dialog box settings allow you to listen to the selected agent’s conversation with a customer.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Headset ID</td>
<td>Allows you to specify your headset ID to allow you to listen to an agent’s conversation. After finding an agent, you can click the Monitor Agent button.</td>
</tr>
</tbody>
</table>
Chapter 26: Monitor view controls

A view defines the window that appears in the right-hand pane. Monitor displays a view after you click a button on the button bar.

In Monitor, you can select a view to monitor calling activities and use the toolbar controls to filter the data that the system displays.

View control toolbar

Every view opens with a set of tools on a toolbar. Use the toolbar icons to display data in a view.

The available toolbar icons vary depending on the view. For example, the system does not display the time selector option if you do not have the permission to set the time range for the data in a view.

<table>
<thead>
<tr>
<th>View tool</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table View</td>
<td>![Table View Icon]</td>
<td>If the view has graphical and table modes, this icon displays the data without icons. The Table View is available for all views.</td>
</tr>
<tr>
<td>Graphical View</td>
<td>![Graphical View Icon]</td>
<td>If the view has graphical and table modes, this icon displays the data by showing icons. The Graphical View is not available for all views.</td>
</tr>
<tr>
<td>Filter Data</td>
<td>![Filter Data Icon]</td>
<td>Displays the Filter Data dialog box with which you can filter the data in the view according to the selected criteria.</td>
</tr>
<tr>
<td>Performance Code</td>
<td>![Performance Code Icon]</td>
<td>Displays a dialog box with which you can select a completion code that is used to measure agent performance.</td>
</tr>
<tr>
<td>Hide/Show Columns</td>
<td>![Hide/Show Columns Icon]</td>
<td>Displays the Columns dialog box with which you can select which of the available data fields will be displayed.</td>
</tr>
<tr>
<td>Find</td>
<td>![Find Icon]</td>
<td>Provides an option to search for an item in a view.</td>
</tr>
<tr>
<td>Level 1 Scope Selector</td>
<td>![Level 1 Scope Selector Icon]</td>
<td>A drop-down list with which you can limit the amount of data in the display. The default is a list of dialers.</td>
</tr>
<tr>
<td>Level 2 Scope Selector</td>
<td>![Level 2 Scope Selector Icon]</td>
<td>The choices in this list depend on the choices made in the Level 1 Scope Selector. Allows you to limit the amount of data in the display. The default is a list of jobs.</td>
</tr>
</tbody>
</table>

Table continues…
Monitor view controls

<table>
<thead>
<tr>
<th>View tool</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Level 3 Scope Selector</td>
<td><img src="image" alt="All Level 3" /></td>
<td>The choices offered in this list depend on the choices made in the Level1 and Level2 Scope Selectors. Allows you to limit the amount of data in the display. The default is All Level 3.</td>
</tr>
<tr>
<td>Hierarchy Manager</td>
<td><img src="image" alt="Hierarchy Manager" /></td>
<td>A pull-down list that allows you to select the types of data that will appear in the Scope Selectors.</td>
</tr>
<tr>
<td>Time Scope</td>
<td><img src="image" alt="Time Scope" /></td>
<td>Allows you to display only running jobs or all jobs in the view.</td>
</tr>
<tr>
<td>Refresh view</td>
<td><img src="image" alt="Refresh view" /></td>
<td>Allows you to refresh a view.</td>
</tr>
</tbody>
</table>

**Scope Selectors**

The three drop-down lists in the View toolbar are called scope selectors.

A scope selector allows you to change the range of data displayed in a view. Use the scope selectors with the **Hierarchy Manager** toolbar button. The option you select using the **Hierarchy Manager** toolbar button dynamically changes the available options in the Monitor scope selectors.

The default Monitor scope selectors are dialer and job. You can select one or all items from each selector.

The system displays a list of supervisors in the third scope selector if you have:

- Defined an agent/supervisor hierarchy using the Hierarchy Manager tool.
- Designated that hierarchy as the default hierarchy in Monitor.

You can set the default hierarchy in Monitor by clicking **Settings > Options > Scope Selectors**.

**Setting Scope Selectors to display data for all dialers, jobs, and supervisors**

**Procedure**

1. Set the first hierarchy selector to All Level 1.
2. Set the second selector to All Level 2.
3. Set the third selector to All Level 3.

**Result**

If you change the dialer selector to DialerA, Monitor removes the data for all other dialers from the view.
Setting Scope Selectors to display data for all jobs named 30Day

Procedure
1. Set the first selector to All Level 1.
2. Set the second selector to 30Day.
   The data is displayed for all jobs named 30Day regardless of the dialer on which the jobs reside.

Filtering data in a view

Procedure
1. With a view open, click Filter Data.
   The Filter Data dialog box appears.
2. Select a column from the list. The options in this list are the column headings for the selected view.
3. From the Operator list, select an operator.
4. In the Value box, type a value.
5. Click OK.

Related links
Filter Data dialog box field descriptions on page 332

Setting Scope Selectors

About this task
Set the scope using the three drop-down lists that are available from all the view toolbars.
The Hierarchy Manager settings and the default hierarchy selections on the Monitor Scope tab specify which hierarchy options you can select for the view.
The default Monitor scope selectors are dialer and job. You can select one or all items from each selector.

Procedure
1. With a view open, click the Hierarchy Manager icon on the view toolbar.
2. Select either No hierarchy, Agent/supervisor hierarchy, or Custom hierarchy.
Monitor view controls

The options coordinate with the Agent/supervisor hierarchy and Custom hierarchy lists on the Scope tab.

Additionally, the option that you select in the Hierarchy Manager list affects the three scope selectors in the drop-down lists in your view.

For example, if you select MySuperAgentHierarchy on the Scope tab’s Agent/supervisor hierarchy list and then select Agent/supervisor hierarchy from the Hierarchy Manager list, your scope selectors will populate with data from MySuperAgentHierarchy.

**Tip:**

The hierarchy selected on the Scope tab becomes the default hierarchy that populates your views.

3. From the first scope selector, select an item. By default, a list of dialer names appears.

   If you select **Use custom hierarchy**, the top-level items of the selected hierarchy appear in this list.

   The item you select in the first scope selector typically reduces the options available in the second scope selector. You can select **All Level 1**, which does not narrow your view’s scope.

4. From the second scope selector, select an item. By default, a list of job names appears.

   If you select **Use custom hierarchy**, the middle-level items of the selected hierarchy appear in this list.

   The item you select typically narrows the options available in the third scope selector. You can select **All Level 2**, which does not narrow your view’s scope.

5. From the third scope selector, select an item. By default, the third scope selector contains no options except All Level 3.

   If you select either **Use default hierarchy** or **Use custom hierarchy**, the bottom-level items of the selected hierarchy appear in this list. The All Level 3 value does not narrow your view’s scope.

---

**Selecting time scope**

**About this task**

You can expand the default time to view data on only the jobs that are currently running or for all the jobs.

For example, you can change the time range to display a view showing right party contacts for all the instances of Job1 that have run during a single day.

Time selection is limited to views and data fields where summing makes sense. For example, non-numerical data is not summed. Similarly, data whose value is transient, such as the minimum hit rate, is not summed.
To select a time range:

**Procedure**
1. With a view open, click the **Time Scope** icon.
2. From the list, select or clear **Show Running Jobs Only**.
   - When you select **Show Running Jobs Only**, your view will display data only for the currently running jobs.
   - When you clear **Show Running Jobs Only**, your view will display data for the currently running as well as the stopped jobs.

---

**Selecting a hierarchy**

**About this task**
After you create a hierarchy in Hierarchy Manager and use the Scope tab in Monitor to select the hierarchy, you can apply the hierarchy to any view.

**Procedure**
1. With a view open, click the **Hierarchy Manager** icon.
   
   A list appears.
2. From the list, select one of the following options:
   - **No hierarchy**
   - **Agent/supervisor hierarchy**
   - **Custom hierarchy**

   **Note:**
   In a multitenancy environment, if you belong to more than one tenant, and if you select the **All Tenants** option, then the **Agent/supervisor hierarchy and Custom hierarchy options are disabled**.

---

**Types of hierarchies**
The No Hierarchy option sets the scope selectors back to their default settings. The first scope selector lists dialers, the second scope selector lists jobs, and the third scope selector contains no items except All Level 3.

Agent/supervisor hierarchy and Custom hierarchy coordinate with the Agent/supervisor hierarchy and Custom hierarchy lists seen on the Scope tab.

The option that you select in the Hierarchy Manager list affects the three scope selectors in your view.
For example, if you select MySuperAgentHierarchy in the Scope tab Agent/supervisor hierarchy list and then select Agent/supervisor hierarchy from the Hierarchy Manager list, your scope selectors will populate with data from MySuperAgentHierarchy.

The options that you select in the scope selectors can change the scope of the data displayed in your views.

---

**Maintaining Monitor views**

**Hiding or showing columns**

**About this task**

You can customize your view to display only the columns you want.

**Procedure**

1. With a view open, click the **Hide/Show columns** button.
2. To select or clear a column’s check box, do one or more of the following tasks:
   - Click **Select All** to show each column in your current view.
   - Select a check box to show a column in your current view.
   - Clear a column’s check box to hide a column in your current view.
   - Click **Hide All** to each column in your current view.
3. Click **OK**.

**Selecting Table View or Graphical View**

**About this task**

Table view is the default view.

**Procedure**

1. With a view open, click the **Graphic View** button to switch to a view that uses icons.
2. With a view open, click the **Table View** button to switch to a view that does not display icons of the data in your view.
Saving a view as a HTML file

Procedure

1. In Monitor, select the view to save as an HTML file.
2. Select File > Save as HTML.
   Monitor opens a new window with the HTML output.
3. Select File > Save As, browse to a location, and click Save.
Chapter 27: Monitor view windows

Monitor uses the button bar in the left-hand side of the window as the primary navigation point for opening views. Monitor displays views in window on right-hand side of your screen.

You can do the following tasks from the Monitor button bar:

- Open and save favorite views
- Display views according to completion codes
- Display views according to agent and supervisor relationships

Configure alerts so that you can receive notifications from the Proactive Contact.

A view displays information about dialers, jobs, agents, and completion codes in a separate window.

In Monitor, you can create views, save the view when you exit Monitor, and then restore the views. This feature allows you to use the same views without recreating specific views.

Use the button bar to gain access to the view and to organize the available views. Use the View toolbar to modify how the view displays data.

**Types of views**

Use the Monitor button bar to display the following types of views:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View Set</td>
<td>Lists views that display calling activity data about dialers.</td>
</tr>
<tr>
<td>Supervisor</td>
<td>Displays information about Supervisor Agents. For view details, see Supervisor Agents view descriptions. Displays the agents active on one or more dialers grouped by job.</td>
</tr>
<tr>
<td>Agent</td>
<td>Displays information about Agent data for a job and allows you to find an agent. For view details, see Find Agent view descriptions.</td>
</tr>
<tr>
<td>Custom</td>
<td>Displays the customized views that you create.</td>
</tr>
</tbody>
</table>

*Table continues…*
### Types of views

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>You can display a view about a specific agent from any view that lists agents from the <strong>Tools</strong> menu. For more information see, <em>Opening a view about a specific agent</em>. When users log in to a dialer as Agents, users must not log in again with the same Agent login ID to the same dialer or to other dialers in a pod.</td>
</tr>
<tr>
<td>Dialer</td>
<td><strong>Dialer Status</strong> Displays the job, agent, and line resources used on a dialer. For view details, see <em>Dialer Status view descriptions</em>.</td>
</tr>
<tr>
<td></td>
<td><strong>Dialer Agents</strong> Displays the agents logged in to one or more dialers. For view details, see <em>Dialer Agents view descriptions</em>.</td>
</tr>
<tr>
<td></td>
<td><strong>Dialer Lines</strong> Displays line assignments and activity levels for each job. For view details, see <em>Dialer Lines view descriptions</em>.</td>
</tr>
<tr>
<td></td>
<td><strong>Dialer History</strong> Displays dialer activity over time. For view details, see <em>Dialer History view descriptions</em>.</td>
</tr>
<tr>
<td>Job</td>
<td><strong>Job Status</strong> Displays the job, agent, and line resources used on a dialer that are grouped and totaled by the job. For view details, see <em>Job Status view descriptions</em>.</td>
</tr>
<tr>
<td></td>
<td><strong>Job Agents</strong> Displays the agents who have joined the jobs. For view details, see <em>Job Agents view descriptions</em>.</td>
</tr>
<tr>
<td></td>
<td><strong>Job Details</strong> Displays detailed information about the performance of a job, including connect, RPC, and closure rates. For view details, see <em>Job Detail view descriptions</em>.</td>
</tr>
<tr>
<td></td>
<td><strong>Job Call Handling</strong> Displays the amount of time each agent spends on talking to customers, updating records, and waiting for the next call. For view details, see <em>Job Call Handling view descriptions</em>.</td>
</tr>
<tr>
<td></td>
<td><strong>Job Completion Codes</strong> Displays completion codes used during the job. For view details, see <em>Job Completion Codes view descriptions</em>.</td>
</tr>
<tr>
<td></td>
<td><strong>Job Wait Queues</strong> Displays information about calls directed to the wait queue during a job, including the number of calls currently in queue, the number abandoned, and the average wait time for each call. For view details, see <em>Job Wait Queues view descriptions</em>.</td>
</tr>
<tr>
<td></td>
<td><strong>Job History</strong> Displays dialer activity over time grouped by job. For view details, see <em>Job History view descriptions</em>.</td>
</tr>
<tr>
<td><strong>Table continues…</strong></td>
<td></td>
</tr>
</tbody>
</table>
## Monitor view windows

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Job Performance</td>
<td>Compares agent performance on a selected completion code. For view details, see Completion Code Detail by Agent view descriptions.</td>
</tr>
<tr>
<td>Job Quality</td>
<td>Displays information about the quality of service that dialers achieve during a job. For view details, see Job Quality view description.</td>
</tr>
</tbody>
</table>

### Related links

- Supervisor Agents view descriptions on page 375
- Find Agent view descriptions on page 377
- Dialer Status view descriptions on page 354
- Dialer Agents view descriptions on page 355
- Dialer Lines view descriptions on page 357
- Dialer History view descriptions on page 358
- Job Status view descriptions on page 359
- Job Agents view descriptions on page 360
- Job Detail view descriptions on page 362
- Job Call Handling view descriptions on page 365
- Job Completion Codes view descriptions on page 365
- Job Wait Queues view descriptions on page 368
- Job History view descriptions on page 370
- Completion Code Detail by Agent view descriptions on page 371
- Job Quality view description on page 373
- Opening a view about a specific agent on page 326

### View toolbar

The following table lists and describes the formats that you can view using the View toolbar.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table view</td>
<td>Displays the data without icons. Table View is enabled if the view has two presentation modes.</td>
</tr>
<tr>
<td>Graphic View</td>
<td>Displays the data with icons. Graphic View is enabled if the view has two presentation modes.</td>
</tr>
<tr>
<td>Filter Data</td>
<td>Filters the data in the view according to one selected criteria</td>
</tr>
<tr>
<td>Hide/Show Columns</td>
<td>Allows you to select which of the available data fields appear.</td>
</tr>
</tbody>
</table>

*Table continues…*
**Find Item**

Allows you to search for a text string within a view. For example, search for a specific agent or job.

**Hierarchy Manager**

Allows you to choose the type of data that appears in the view:
- No hierarchy
- The default supervisor/agent hierarchy, if one was defined using Settings > Options
- Custom Hierarchy, if one was defined using Settings > Options

**Time Scope**

Allows you to monitor running jobs or all jobs in the view.

**Refresh**

Refreshes the data in the open views.

**Related links**
- Options dialog box on page 330
- Hierarchies and scope selectors on page 353

## Hierarchies and scope selectors

The following table lists different types of hierarchies and their scope selectors.

<table>
<thead>
<tr>
<th>Hierarchy</th>
<th>Scope Selector 1</th>
<th>Scope Selector 2</th>
<th>Scope Selector 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>No hierarchy</td>
<td>Dialer (default)</td>
<td>Job (default)</td>
<td>Empty</td>
</tr>
<tr>
<td>Default agent/supervisor hierarchy</td>
<td>Dialer (default)</td>
<td>Job (default)</td>
<td>Supervisor (bottom level of the selected hierarchy)</td>
</tr>
<tr>
<td>Custom</td>
<td>Top level of the selected hierarchy</td>
<td>Middle level of the selected hierarchy</td>
<td>Bottom level of the selected hierarchy</td>
</tr>
</tbody>
</table>

## Views

Monitor provides a variety of views that allow you to monitor calling activities for the following components and users:

- Dialers
- Jobs
- Supervisors
- Agents
### Dialer Status view descriptions

The Dialer Status view displays the job, agent, and line resources used on a dialer. The view shows the following data:

- Agents and lines assigned to all dialers in the selected scope
- Jobs assigned to all dialers and the state of completion of each job

The following table includes descriptions about the Dialer Status views:

<table>
<thead>
<tr>
<th><strong>Name</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Dialer ID</td>
<td>A unique identification number, automatically assigned to a dialer, and is used to identify dialer data in the database.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of a dialer in the current scope.</td>
</tr>
<tr>
<td>Job ID</td>
<td>A unique identification number, automatically assigned to a job (by name), used to identify job data in the database.</td>
</tr>
<tr>
<td>Job</td>
<td>The name of each job running in the current scope.</td>
</tr>
<tr>
<td>Job Instance</td>
<td>A unique identification number, automatically assigned to a single instance of a job, used to identify data associated with that job instance in the database. Each time a job runs, the system assigns it a new job instance ID.</td>
</tr>
<tr>
<td>Job Type</td>
<td>The type of job: outbound, inbound, or blend.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the job. The status types include stopped, running, error, or shutting down.</td>
</tr>
<tr>
<td>Start Date</td>
<td>The date when the job instance started.</td>
</tr>
<tr>
<td>Start Time</td>
<td>The time when the job instance started.</td>
</tr>
<tr>
<td>Stop Date</td>
<td>The date when the job instance stopped or blank if the job is still running.</td>
</tr>
<tr>
<td>Stop Time</td>
<td>The time when the job instance stopped or blank if the job is still running.</td>
</tr>
<tr>
<td>Estimated End Date</td>
<td>The date when the Monitor estimates that the job will end. For an inbound job, the Estimated Job End field is empty.</td>
</tr>
<tr>
<td>Estimated End Time</td>
<td>The time when the Monitor estimates that the job will end. For an inbound job, the Estimated Job End field is empty.</td>
</tr>
<tr>
<td>Inbound Agents</td>
<td>The total number of inbound agents logged in to each job.</td>
</tr>
<tr>
<td>Outbound Agents</td>
<td>The total number of outbound agents logged in to each job.</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blend Agents</td>
<td>The total number of blend agents logged in to each job.</td>
</tr>
<tr>
<td>Managed Agents</td>
<td>The total number of managed agents logged in to each job.</td>
</tr>
<tr>
<td>PTP Agents</td>
<td>The total number of person-to-person agents logged in to each job.</td>
</tr>
<tr>
<td>ACD Agents</td>
<td>The total number of ACD Agents logged in to each job.</td>
</tr>
<tr>
<td>Total Agents</td>
<td>The total number of agents logged in to each job.</td>
</tr>
<tr>
<td>Total Lines</td>
<td>The total number of lines in use by the job.</td>
</tr>
<tr>
<td>% Complete</td>
<td>The percentage of records called based upon the total number of records selected for calling.</td>
</tr>
<tr>
<td>Tenant Name</td>
<td>Name of the tenant for which the system displays the data.</td>
</tr>
</tbody>
</table>

**Dialer Agents view descriptions**

The Dialer Agents view displays the agents active on one or more dialers.

The graphic mode displays a subset of the data in the table mode. The graphic mode displays data for each agent: the agent name, the agent’s status, and the time that the agent is in that status.

The following table describes the Dialer Agents view:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total</td>
<td>The total number of agents within the selected scope.</td>
</tr>
<tr>
<td>Talk</td>
<td>The total number of agents with status “Talk” in the selected scope.</td>
</tr>
<tr>
<td>Update</td>
<td>The total number of agents with status “Update” in the selected scope.</td>
</tr>
<tr>
<td>Idle</td>
<td>The total number of agents with status “Idle” in the selected scope.</td>
</tr>
<tr>
<td>ACD</td>
<td>The total number of ACD agents in the selected scope.</td>
</tr>
<tr>
<td>Acquired</td>
<td>The total number of acquired ACD agents in the selected scope.</td>
</tr>
<tr>
<td>Unavailable</td>
<td>The total number of agents with the status Not available in the selected scope.</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Off Job</td>
<td>The total number of agents that are not on the job in the selected scope.</td>
</tr>
<tr>
<td>Offline</td>
<td>The total number of offline agents in the selected scope.</td>
</tr>
<tr>
<td>Logging Off</td>
<td>The total number of agents that have requested to log off but are still handling calls.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of the dialer on which the job instance is running.</td>
</tr>
<tr>
<td>Job</td>
<td>The name of a currently running job. Available data includes the names of all jobs running in the current scope.</td>
</tr>
<tr>
<td>Job Instance</td>
<td>A unique identification number automatically assigned to a single instance of a job, used to identify data associated with that job instance in the database. Each time a job runs, the system assigns a new job instance ID.</td>
</tr>
<tr>
<td>Agent</td>
<td>The identification name of the agent logged in to the selected dialer.</td>
</tr>
<tr>
<td>Agent ID</td>
<td>The identification number of the agent logged in to the selected dialer.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the Agent. Status types include Talk, Update, Idle, Waiting for acquire, Offline, Off job, Not available, and Logging off.</td>
</tr>
<tr>
<td>On Status</td>
<td>The duration of the current status of the agent in hh:mm:ss format.</td>
</tr>
<tr>
<td>Agent Type</td>
<td>The type of calling activity that the agent logged in to handle. Acceptable values include Outbound, Inbound, and Blend.</td>
</tr>
<tr>
<td>On Job</td>
<td>The elapsed time that the agent has been working on a job.</td>
</tr>
<tr>
<td>Headset</td>
<td>The headset ID or ACD extension assigned to the agent. The system uses this data to perform audio monitoring of an agent.</td>
</tr>
<tr>
<td>Logon Time</td>
<td>The time when an agent logged on.</td>
</tr>
<tr>
<td>Call Type</td>
<td>The type of the call: Outbound, inbound, or blend.</td>
</tr>
<tr>
<td>Released Time</td>
<td>The time when an agent is released from the blend job.</td>
</tr>
<tr>
<td>Acquired Time</td>
<td>The time when an agent is acquired for the blend job.</td>
</tr>
<tr>
<td>Offline Time</td>
<td>The time when an agent logged out or took a break.</td>
</tr>
<tr>
<td>Tenant Name</td>
<td>Name of the tenant for which the system displays the data.</td>
</tr>
</tbody>
</table>
Viewing Dialer agent view

Procedure

1. In Monitor, select **Settings > Options**.
2. Select the **Agent States** tab.
3. Select the agent states that you want to view.

You can further limit the agent states in a single view by using the Filter option.

Related links

- [Options Agent States tab field descriptions on page 331](#)

---

**Dialer Lines view descriptions**

The Dialer Lines view displays line assignments and activity levels for each job.

The following table describes the Dialer Lines view:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dialer</td>
<td>The name of the dialer on which the job instance is running.</td>
</tr>
<tr>
<td>Job</td>
<td>The name of each job running on the dialer.</td>
</tr>
<tr>
<td>Job Type</td>
<td>The type of the job: outbound or inbound.</td>
</tr>
<tr>
<td>Job Number</td>
<td>The unique number, assigned by the dialer to this instance of the job.</td>
</tr>
<tr>
<td>Job Instance</td>
<td>A unique identification number, automatically assigned to a single instance of a job, to help identify data associated with that job instance in the database. Each time a job runs, the system assigns a new job instance ID.</td>
</tr>
<tr>
<td>Lines In Use</td>
<td>The number of lines currently in use by the job.</td>
</tr>
<tr>
<td>System Lines in Use</td>
<td>The number of system lines in use by the job as a percentage of the total number of lines on the system.</td>
</tr>
<tr>
<td>Job ID</td>
<td>A unique identification number, automatically assigned to a job (by name), used to identify job data in the database.</td>
</tr>
<tr>
<td>Tenant Name</td>
<td>Name of the tenant for which the system displays the data.</td>
</tr>
</tbody>
</table>
**Dialer History view descriptions**

The Dialer History view shows dialer activity over time. The view lists all instances of a job that have run on a dialer, regardless of the current status of the job.

For example, if Job1 runs from 8:00 until 10:30, then restarts at 11:15, both job instances appear in the view separately. The default value for the time selector is active data + recent data.

The following table describes the Dialer History view:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dialer ID</td>
<td>A unique identification number, automatically assigned to a dialer, used to identify data related to that dialer in the database.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of the dialer in the current scope.</td>
</tr>
<tr>
<td>Job</td>
<td>The name of a job that has run during the current time scope.</td>
</tr>
<tr>
<td>Job ID</td>
<td>A unique identification number, automatically assigned to a job by name, used to identify job data in the database.</td>
</tr>
<tr>
<td>Job Instance</td>
<td>A unique identification number, automatically assigned to a single instance of a job, used to identify data associated with that job instance in the database. Each time a job runs, the system assigns a new job instance ID.</td>
</tr>
<tr>
<td>Job Number</td>
<td>The unique number, assigned by the dialer to this instance of the job.</td>
</tr>
<tr>
<td>Job Type</td>
<td>The type of job: outbound, inbound, or blend.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the job. The status types include stopped, running, error, or shutting down.</td>
</tr>
<tr>
<td>Start Date</td>
<td>The date the job started.</td>
</tr>
<tr>
<td>Start Time</td>
<td>The time the job started.</td>
</tr>
<tr>
<td>Stop Date</td>
<td>The date the job stopped.</td>
</tr>
<tr>
<td>Stop Time</td>
<td>The time the job stopped.</td>
</tr>
<tr>
<td>Estimated End Date</td>
<td>The date that Monitor estimates the job will end. For an inbound job, this field is empty</td>
</tr>
<tr>
<td>Estimated End Time</td>
<td>The time that Monitor estimates the job will end. For an inbound job, this field is empty</td>
</tr>
<tr>
<td>Connects</td>
<td>The total number of connects, both inbound and outbound, for each job instance. A subtotal appears for each job and each dialer.</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RPCs</td>
<td>The total number of calls released as right-party contacts (RPCs) for each job instance. A subtotal appears for each job and each dialer.</td>
</tr>
<tr>
<td>Closures</td>
<td>The total number of calls released as closures for each job instance. A subtotal appears for each job and each dialer.</td>
</tr>
<tr>
<td>Abandons</td>
<td>The total number of calls released as abandoned for each job instance. A subtotal appears for each job and each dialer.</td>
</tr>
<tr>
<td>Elapsed Time</td>
<td>The total time since the job instance started.</td>
</tr>
</tbody>
</table>
| Agent Hours | The total number of hours agents have joined to a job instance over the course of the job. A subtotal appears for each job and each dialer.
| Total Records | The total number of records selected for the job. For inbound jobs, this field is always zero.                                      |
| Dials    | The total number of records used to call during the course of the job. A subtotal appears for each job and each dialer.                    |
| Tenant Name | Name of the tenant for which the system displays the data.                                                                            |

---

### Job Status view descriptions

The Job Status view displays the same data as the Dialer Status view, but is grouped and totaled by job.

The following table displays the Job Status view:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DialerID</td>
<td>A unique identification number, automatically assigned to a dialer, used to identify data related to that dialer in the database.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of a dialer in the current scope.</td>
</tr>
<tr>
<td>Job ID</td>
<td>A unique identification number, automatically assigned to a job by name, used to identify job data in the database.</td>
</tr>
<tr>
<td>Job</td>
<td>The job name appears in the window title bar.</td>
</tr>
<tr>
<td>Job Instance</td>
<td>A unique identification number, automatically assigned to a single instance of a job, used to identify data associated with that job instance in the database. Each time a job runs, the system assigns a new job instance ID.</td>
</tr>
</tbody>
</table>
### Name | Description
--- | ---
Job Type | The type of job: outbound, inbound, or blend.
Status | The current status of the job. The status types include stopped, running, error, or shutting down.
Start Date | The date the job started running.
Start Time | The time the job started running.
Stop Date | The date the job stopped running.
Stop Time | The time the job stopped running.
Estimated End Date | The date that Monitor estimates the job will end. For an inbound job, this field is empty.
Estimated End Time | The time that Monitor estimates the job will end. For an inbound job, this field is empty.
Inbound Agents | The total number of inbound agents logged in to each job.
Outbound Agents | The total number of outbound agents logged in to each job.
Blend Agents | The total number of blend agents logged in to each job.
Managed Agents | The total number of managed agents logged in to each job.
PTP Agents | The total number of PTP agents logged in to each job.
ACD Agents | The total number of ACD agents logged in to each job.
Total Agents | The total number of agents within the selected scope.
Total Lines | The number of lines currently in use by each job.
% Complete | The percentage of records called based upon the total number of records selected for calling.
Tenant Name | Name of the tenant for which the system displays the data.

Under Job Status view, when you right-click on an active non-unit work list and non-inbound job, a new option, Autocallsel Trigger, is displayed, using which you can modify the parameter value of Autocallsel Trigger at runtime.

---

### Job Agents view descriptions

The Job Agents view displays the same data as the Dialer Agents view, but groups the data by job.

If you select All from the first scope selector and Job2 from the second scope selector, the view displays a summary of data for all jobs called Job2 on all dialers.
The graphic mode displays a subset of the data in the table mode. The graphic mode displays data for each agent: agent name, the agent’s status, and the time the agent is in that status.

The following table describes the Job Agents view:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total</td>
<td>The total number of agents within the selected scope.</td>
</tr>
<tr>
<td>Talk</td>
<td>The total number of agents with status “Talk” in the selected scope.</td>
</tr>
<tr>
<td>Update</td>
<td>The total number of agents with status “Update” in the selected scope.</td>
</tr>
<tr>
<td>Idle</td>
<td>The total number of agents with status “Idle” in the selected scope.</td>
</tr>
<tr>
<td>ACD</td>
<td>The total number of ACD agents in the selected scope.</td>
</tr>
<tr>
<td>Acquired</td>
<td>The total number of acquired ACD agents in the selected scope.</td>
</tr>
<tr>
<td>Offline</td>
<td>The total number of offline agents in the selected scope.</td>
</tr>
<tr>
<td>Logging Off</td>
<td>The total number of agents that have requested a log off, but are still handling calls.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of the dialer.</td>
</tr>
<tr>
<td>Job</td>
<td>The name of a currently running job. Available data includes the names of all jobs in the current scope.</td>
</tr>
<tr>
<td>Job Instance</td>
<td>A unique identification number, automatically assigned to a single instance of a job, used to identify data associated with that job instance in the database. Each time a job run, the system assigns a new job instance ID.</td>
</tr>
<tr>
<td>Agent ID</td>
<td>The identification number of the agent logged in to the selected dialer.</td>
</tr>
<tr>
<td>Agent</td>
<td>The name of an agent logged in to the selected dialer.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the Agent. Status types include Talk, Update, Idle, Waiting for acquire, and Not available.</td>
</tr>
<tr>
<td>On Status</td>
<td>The duration of the current status of the agent in hh:mm:ss format.</td>
</tr>
<tr>
<td>Agent Type</td>
<td>The type of calling activity that the agent logged in to handle. Acceptable values include Outbound, Inbound, and Blend.</td>
</tr>
<tr>
<td>On Job</td>
<td>The elapsed time that the agent has actually been working on a job.</td>
</tr>
</tbody>
</table>
Monitor view windows

### Viewing job agent view

#### About this task

To choose which agent states to include in the Job Agent view:

#### Procedure

1. In Monitor, select **Settings > Options**.
2. Select the **Agent States** tab.
3. Select the agent states that you want to view.

   You can further limit the agent states in a single view by using the Filter option.

#### Related links

- [Options Agent States tab field descriptions](#) on page 331

---

### Job Detail view descriptions

The Job Detail view displays detailed information about the performance of a job, including connect, RPC, and closure rates. It also displays static operational information about the job, as well as the current setting of various runtime parameters.

Because the Job Detail view is the lowest-level view of a job, data is not summed over time or dialers. Instead, it is information about a single instance of a job.

The following table describes the Job Detail view:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dialer</td>
<td>The name of the dialer on which the job instance is running.</td>
</tr>
<tr>
<td>Job Name</td>
<td>The job name appears in the window title bar.</td>
</tr>
<tr>
<td>Job Type</td>
<td>The type of the outbound job.</td>
</tr>
<tr>
<td>Selection</td>
<td>The name of the file that defines which records will be available for calling. If the job is inbound, this field is blank.</td>
</tr>
<tr>
<td>Strategy</td>
<td>The name of the file that defines which records will be available for calling. If the job is inbound, this field is blank.</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Job Number</td>
<td>The unique number assigned to this instance of the job by the dialer.</td>
</tr>
<tr>
<td>Job Instance</td>
<td>A unique identification number, automatically assigned to a single instance of a job, used to help identify data associated with that job instance in the database. Each time a job runs, the system assigns a new job instance ID.</td>
</tr>
<tr>
<td>Current</td>
<td>The current status of the job. The status types include stopped, running, error, or shutting down.</td>
</tr>
<tr>
<td>% Complete</td>
<td>The percentage complete for the job. This value is calculated by dividing the total records called by total records selected for calling. An outbound job will never appear as 100% complete unless all records are called. Inbound jobs always appear as 100% complete.</td>
</tr>
<tr>
<td>Start Date</td>
<td>The time when the job stopped running.</td>
</tr>
<tr>
<td>Start Time</td>
<td>The time when the job started running.</td>
</tr>
<tr>
<td>Estimated End Date</td>
<td>The date that Monitor estimates the job will end. For an inbound job, this field is empty.</td>
</tr>
<tr>
<td>Estimated End Time</td>
<td>The time that Monitor estimates the job will end. For an inbound job, this field is empty.</td>
</tr>
<tr>
<td>Time Left</td>
<td>The estimated time remaining to complete calling for the job. For an inbound job, this field is empty.</td>
</tr>
<tr>
<td>Pacing</td>
<td>The call pacing defined for the job.</td>
</tr>
<tr>
<td>Running Hit Rate</td>
<td>The overall hit rate (percentage of call completions measured against call attempts) for the job calculated from job start to the present.</td>
</tr>
<tr>
<td>Current Hit Rate</td>
<td>The hit rate for the job over the last five to ten minutes. The dialer uses this figure to make adjustments in the Expert Calling Ratio.</td>
</tr>
<tr>
<td>Expert Calling Ratio</td>
<td>The Expert Calling Ratio defined for the job.</td>
</tr>
<tr>
<td></td>
<td>If the job uses the Cruise Control method, this field is blank.</td>
</tr>
<tr>
<td></td>
<td>If the job is inbound, this field is blank.</td>
</tr>
<tr>
<td>Total Connects</td>
<td>The total number of inbound and outbound connects for the job.</td>
</tr>
<tr>
<td>Inbound Connects</td>
<td>The total number of inbound calls connected.</td>
</tr>
<tr>
<td>Inbound Connects per Hr</td>
<td>The average number of inbound connects per hour. The value is calculated by dividing the total number of inbound connects by the total Online Time</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Outbound Connects</strong></td>
<td>The total number of outbound calls connected.</td>
</tr>
<tr>
<td><strong>Outbound Connects per Hr</strong></td>
<td>The average number of outbound connects per hour. The value is calculated by dividing the total number of outbound connects by the total Online Time.</td>
</tr>
<tr>
<td><strong>Abandons per hour</strong></td>
<td>The total number of calls released as abandoned per hour for each job instance.</td>
</tr>
<tr>
<td><strong>Dials</strong></td>
<td>The total number of records called during the course of the job.</td>
</tr>
<tr>
<td><strong>Total Records</strong></td>
<td>The total number of records selected for calling. For inbound jobs, this field is always zero.</td>
</tr>
<tr>
<td><strong>Records Queued</strong></td>
<td>The number of calls currently in the wait queue.</td>
</tr>
<tr>
<td><strong>Records Left</strong></td>
<td>The number of eligible records not yet called for the job. For inbound jobs, this field is always zero.</td>
</tr>
<tr>
<td><strong>Total RPCs</strong></td>
<td>The total number of RPCs currently recorded.</td>
</tr>
<tr>
<td><strong>Total Closures</strong></td>
<td>The total number of closures currently recorded.</td>
</tr>
<tr>
<td><strong>RPCs per Connect</strong></td>
<td>The number of RPCs as a percentage of the total number of connects. This value is calculated by dividing the total RPC connects by total agent connects.</td>
</tr>
<tr>
<td><strong>Total Abandons</strong></td>
<td>The total number of calls released as abandoned.</td>
</tr>
<tr>
<td><strong>Abandons per connect</strong></td>
<td>The percentage of connects that resulted in calls released as abandoned.</td>
</tr>
<tr>
<td><strong>Connects per Call</strong></td>
<td>The percentage of calls that resulted in a connect.</td>
</tr>
<tr>
<td><strong>RPCs Per Connect</strong></td>
<td>The percentage of connects that resulted in an RPC.</td>
</tr>
<tr>
<td><strong>Closures Per Connect</strong></td>
<td>The percentage of connects that resulted in a closure.</td>
</tr>
<tr>
<td><strong>Closures Per RPC</strong></td>
<td>The percentage of RPCs that resulted in a closure.</td>
</tr>
<tr>
<td><strong>Inbound Wait Queue Total</strong></td>
<td>The total number of inbound calls currently in the wait queue.</td>
</tr>
<tr>
<td><strong>Outbound Wait Queue Total</strong></td>
<td>The total number of outbound calls currently in the wait queue.</td>
</tr>
<tr>
<td><strong>Tenant Name</strong></td>
<td>Name of the tenant for which the system displays the data.</td>
</tr>
</tbody>
</table>
**Job Call Handling view descriptions**

The Job Call Handling view displays how much time each agent spends talking to customers, updating records, and waiting for the next call.

For example, select All on the dialer scope selector and Job1 on the second scope selector to display the agents joined to Job1.

The graphic mode displays a subset of the data in the table mode. The graphic mode displays data for each type of agent. The table mode displays data for each agent.

The following table describes the Job Call Handling view:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent Name</td>
<td>The name of the agent joined to a specific job.</td>
</tr>
<tr>
<td>Agent ID</td>
<td>A unique identification number assigned to each agent by the database.</td>
</tr>
<tr>
<td>Agent Type</td>
<td>The type of calling activity the agent logged in to handle. Acceptable values include Outbound, Inbound, and Blend.</td>
</tr>
<tr>
<td>Connects Per Hour</td>
<td>The total number of connects per hour in the selected scope.</td>
</tr>
<tr>
<td>Average Talk</td>
<td>The average time agents of a specific agent type spend talking on each call.</td>
</tr>
<tr>
<td>Average Idle</td>
<td>The average time agents of a specific agent type spend waiting between calls.</td>
</tr>
<tr>
<td>Average Update</td>
<td>The average time agents of a specific agent type spend updating records.</td>
</tr>
<tr>
<td>Average Preview</td>
<td>The average time a managed agent spends previewing records. (For managed agents only.)</td>
</tr>
<tr>
<td>Duty Cycle</td>
<td>The ratio of the average time spent talking and updating to the total time from the beginning of one call to the beginning of the next call.</td>
</tr>
<tr>
<td>Tenant Name</td>
<td>Name of the tenant for which the system displays the data.</td>
</tr>
</tbody>
</table>

**Job Completion Codes view descriptions**

The Job Completion Codes view displays completion codes used during the job. Monitor displays only codes that are defined as RPC, Closure, Abandon, or have a value greater than 0.

Additional information includes the following data:

- Total number of calls, connects, and RPCs
- The per hour number of calls, connects, and RPCs
- The number of RPCs per connect

The following table describes the Job Completion Codes view:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calls</td>
<td>The total number of calls for the job.</td>
</tr>
<tr>
<td>Connects</td>
<td>The total number of calls, both inbound and outbound, for each job instance. A subtotal appears for each job and each dialer.</td>
</tr>
<tr>
<td>RPC</td>
<td>The number of records released with this code as a percentage of the total number of right party connects (RPCs). This number applies to codes marked as RPC only.</td>
</tr>
<tr>
<td>Closures</td>
<td>The number of records released with this code.</td>
</tr>
<tr>
<td>Abandons</td>
<td>The number of records released with this code.</td>
</tr>
<tr>
<td>Code</td>
<td>The unique identification number associated with each completion code.</td>
</tr>
<tr>
<td>RPC</td>
<td>A square indicates that you have defined the code as an RPC.</td>
</tr>
<tr>
<td>Closure</td>
<td>A square indicates that you have defined the code as Closure.</td>
</tr>
<tr>
<td>Abandon</td>
<td>A square indicates that you have defined the code as Abandon.</td>
</tr>
<tr>
<td>Calls Excluded from ACR</td>
<td>Number of calls marked as false negative by an agent. These calls will be excluded from the Abandon call rate formula.</td>
</tr>
<tr>
<td>Name</td>
<td>The user-defined name or description assigned to each code.</td>
</tr>
<tr>
<td>Total</td>
<td>The total calls made by the dialer in the selected scope.</td>
</tr>
<tr>
<td>Avg/Hr</td>
<td>The average number of calls released with a completion code during an hour.</td>
</tr>
<tr>
<td>RPC %</td>
<td>For each code designated as an RPC, the percentage of connects recorded for each completion code based on the total number of RPCs for the job.</td>
</tr>
<tr>
<td>Closure %</td>
<td>The percentage of closures recorded for each completion code based on the total number of closures for the job.</td>
</tr>
<tr>
<td>Abandon %</td>
<td>The percentage of abandons recorded for each completion code based on the total number of abandons for the job.</td>
</tr>
<tr>
<td>% of Calls</td>
<td>The number of calls recorded for each code as a percentage of the total number of calls for the job.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td>% corresponding to a completion code of the connects</td>
<td>The Campaign Monitor Supervisor application calculates the percentage corresponding to a completion code of the connects using the following formula: Percentage corresponding to a completion code of the connects = ((\text{Total Number of Calls released by Code 96} + \text{Agent Connects} \times \text{FR}) \times 100 \div (\text{Total number of outbound connects} + \text{Total Number of Calls released by Code 96})) For other codes, the formula is: Percentage corresponding to a completion code of the connects = ((\text{Total Number of Calls released by the Code} \times 100) \div (\text{Total number of outbound connects}))</td>
</tr>
</tbody>
</table>

**Tip:**

You define which codes are abandoned using the Completion Code menu. By default, codes 45 and 47 are inbound abandons and 46 and 48 are outbound abandons.

Monitor always uses the definitions that were in effect when the dialer started. If you change any of the completion code descriptions in the Completion Code menu, you see the changes when the dialer restarts.

**Recommendations for Code 96**

**Recommendations for Ofcom compliant regions:**

The Supervisor applications use completion code 96 for CONNEXPIRE as a hard-coded value for calculations and reporting, therefore, following is recommended for Ofcom compliant regions:

- Use code 96 only for CONNEXPIRE so that the calculation in Campaign Monitor for the % of Connects column is performed as per the guidelines.
- The Analyst application can also display the report using the same formula since it also uses hard-coded value of code 96 for CONNEXPIRE.

**Recommendations for non-Ofcom compliant regions:**

- Do not use completion code 96 for representing anything other than CONNEXPIRE.
- If code 96 is already used for denoting any other completion action, then ignore the value calculated in the % of Connects column for code 96. Otherwise mark this % of Connects column as hidden in the Job Completion Code view in the Campaign Monitor supervisor application.

**Note:**

If code 96 has not been used in the Supervisor applications, then this information is not applicable.
### Job Wait Queues view descriptions

The Job Wait Queues view displays information about calls directed to the wait queue during a job. The information includes the number of calls currently in queue, the number abandoned, and the average wait time for each call.

A historical graph displays the total calls added to the queue at 15-minute intervals for the job instance selected in the upper part of the view.

**Tip:**
You define which codes are abandons using the Completion Code menu. By default, codes 45 and 47 are inbound abandons and 46 and 48 are outbound abandons.

The following table describes the Job Wait Queues view:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Job</td>
<td>The name of each job running in the current scope.</td>
</tr>
<tr>
<td>Job ID</td>
<td>A unique identification number, automatically assigned to a job (by name), used to identify job data in the database.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of the dialer on which the job instance is running.</td>
</tr>
<tr>
<td>Dialer ID</td>
<td>A unique identification number, automatically assigned to a dialer, and is used to identify dialer data in the database.</td>
</tr>
<tr>
<td>Inbound In Queue</td>
<td>The total number of inbound calls currently in the wait queue.</td>
</tr>
<tr>
<td>Outbound In Queue</td>
<td>The total number of outbound calls currently held in the wait queue.</td>
</tr>
<tr>
<td>Total In Queue</td>
<td>The total number of calls currently in the wait queue. The total is also broken down by call type, either inbound or outbound.</td>
</tr>
<tr>
<td>Inbound Queue Total</td>
<td>The total number of inbound calls that have spent time in the wait queue since the job began.</td>
</tr>
<tr>
<td>Outbound Queue Total</td>
<td>The total number of outbound calls that have spent time in the wait queue since the job began.</td>
</tr>
<tr>
<td>Queue Total</td>
<td>The total number of calls, both inbound and outbound, that have spent time in the wait queue.</td>
</tr>
<tr>
<td>Avg Inbound Wait Time</td>
<td>The average number of minutes and seconds that an inbound call spends in the wait queue in the mm:ss format.</td>
</tr>
<tr>
<td>Avg Outbound Wait Time</td>
<td>The average number of minutes and seconds that an outbound call spends in the wait queue in the mm:ss format.</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Avg Wait Time</td>
<td>The average time calls (inbound, outbound) spent in the wait queue. The total figure is a weighted average of inbound and outbound wait times.</td>
</tr>
<tr>
<td>Inbound Connects</td>
<td>The total number of inbound calls connected to an agent.</td>
</tr>
<tr>
<td>Outbound Connects</td>
<td>The total number of outbound calls connected to an agent.</td>
</tr>
<tr>
<td>Total Connects</td>
<td>The total number of calls, both inbound and outbound, connected to an agent.</td>
</tr>
<tr>
<td>Inbound Calls Answered</td>
<td>The total number of inbound calls answered by the dialer. (This number includes all inbound calls connected to an agent plus all inbound calls abandoned in the wait queue.)</td>
</tr>
<tr>
<td>Outbound Calls Answered</td>
<td>The total number of outbound calls answered by a customer. (This number includes all outbound calls connected to an agent plus all outbound calls abandoned in the wait queue.)</td>
</tr>
<tr>
<td>Outbound Calls Placed</td>
<td>The total number of outbound calls dialed, regardless of the final outcome of the call (i.e., abandoned or connected).</td>
</tr>
<tr>
<td>Inbound Abandoned</td>
<td>The total number of inbound calls abandoned by the customer or by the system.</td>
</tr>
<tr>
<td>Outbound Abandoned</td>
<td>The total number of outbound calls abandoned by the customer or by the system.</td>
</tr>
<tr>
<td>Total Abandoned</td>
<td>The total number of calls marked with a completion code that has been defined as an “abandon.”</td>
</tr>
<tr>
<td>% Abandoned Per Inbound Connect</td>
<td>The total number of abandoned calls divided by the total number of inbound connects and multiplied by 100.</td>
</tr>
<tr>
<td>% Abandoned Per Outbound Connect</td>
<td>The total number of abandoned calls divided by the total number of outbound calls and multiplied by 100.</td>
</tr>
<tr>
<td>% Abandoned Per Total Connects</td>
<td>The total number of abandoned calls divided by the total number of connects and multiplied by 100.</td>
</tr>
<tr>
<td>% Abandoned Per Inbound Calls Answered</td>
<td>The total number of abandoned calls divided by the sum of the total inbound connects and the total number of inbound calls abandoned and multiplied by 100.</td>
</tr>
<tr>
<td>% Abandoned Per Outbound Calls Answered</td>
<td>The total number of abandoned calls divided by the sum of the total number of outbound connects and the total number of outbound calls abandoned and multiplied by 100.</td>
</tr>
</tbody>
</table>

*Table continues…*
### Job History view descriptions

The Job History view displays the same information as the Dialer History view grouped by job, rather than dialer.

The following table displays the Job History view:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dialer ID</td>
<td>A unique identification number, automatically assigned to a dialer, used to identify data related to that dialer in the database.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of the dialer in the current scope.</td>
</tr>
<tr>
<td>Job</td>
<td>The name of a job that has run during the current time scope.</td>
</tr>
<tr>
<td>Job ID</td>
<td>A unique identification number, automatically assigned to a job (by name), used to identify job data in the database.</td>
</tr>
<tr>
<td>Job Number</td>
<td>The unique number assigned to this instance of the job by the dialer.</td>
</tr>
<tr>
<td>Job Instance</td>
<td>A unique identification number, automatically assigned to a single instance of a job, used to help identify data associated with that job instance in the database. Each time a job runs, the system assigns a new job instance ID.</td>
</tr>
<tr>
<td>Job Type</td>
<td>The type of the outbound job.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the job. The status types include stopped, running, error, or shutting down.</td>
</tr>
<tr>
<td>Start Date</td>
<td>The date the job started.</td>
</tr>
<tr>
<td>Start Time</td>
<td>The time the job started.</td>
</tr>
<tr>
<td>Stop Date</td>
<td>The date the job stopped.</td>
</tr>
<tr>
<td>Stop Time</td>
<td>The time the job stopped.</td>
</tr>
</tbody>
</table>

*Table continues...*
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Estimated End Date</td>
<td>The date that Monitor estimates the job will end. For an inbound job, this field is empty. The estimate is perfected as more calls are made. May not be too accurate during the first minutes of calling.</td>
</tr>
<tr>
<td>Estimated End Time</td>
<td>The time that Monitor estimates the job will end. For an inbound job, this field is empty. The estimate is perfected as more calls are made. May not be too accurate during the first minutes of calling.</td>
</tr>
<tr>
<td>Connects</td>
<td>The total number of connects (both inbound and outbound) for each job instance. A subtotal appears for each job and each dialer.</td>
</tr>
<tr>
<td>RPCs</td>
<td>The total number of calls released as right-party contacts (RPCs) for each job instance. A subtotal appears for each job and each dialer.</td>
</tr>
<tr>
<td>Closures</td>
<td>The total number of calls released as closures for each job instance. A subtotal appears for each job and each dialer.</td>
</tr>
<tr>
<td>Abandons</td>
<td>The total number of calls released as abandoned for each job instance. A subtotal appears for each job and each dialer.</td>
</tr>
<tr>
<td>Agent Hours</td>
<td>The total number of hours agents have logged in to a job instance over the course of the job. A subtotal appears for each job and each dialer.</td>
</tr>
<tr>
<td>Total Records</td>
<td>The total number of records selected for calling. For inbound jobs, this field is always zero.</td>
</tr>
<tr>
<td>Dials</td>
<td>The total number of records called during the course of the job. A subtotal appears for each job and each dialer.</td>
</tr>
<tr>
<td>Tenant Name</td>
<td>Name of the tenant for which the system displays the data.</td>
</tr>
</tbody>
</table>

### Completion Code Detail by Agent view descriptions

The following table describes the Completion Code Detail by Agent view:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Completion Code</td>
<td>The completion code used to compare agent performance.</td>
</tr>
</tbody>
</table>

*Table continues...*
### Name | Description
--- | ---
**Average Per Hour** | The average number of calls released with this code by a single agent.
**Average Total** | The average number of calls released with this code by a single agent.
**Highest Performer** | The name of the agent with the best performance.
**Lowest Performer** | The name of the agent with the lowest performance.
**Agent** | The name of the agent. This list of agents includes all of the agents assigned to the job.
**Agent ID** | A unique identification number assigned to each agent by the database.
**Total** | The total number of calls released with this code by an agent.
**Per Hour** | The average number of calls released with this code in an hour by this agent.
**Performance** | The performance of the selected agent as a percentage of the best performer. The value in this column is calculated as:

\[
\frac{\text{Total number of completion codes released by the selected agent}}{\text{Total number of completion codes released by the best performer}} \times 100\%
\]
**Tenant Name** | Name of the tenant for which the system displays the data.

### Viewing Completion Code Detail by Agent view

**About this task**
The Completion Code Detail by Agent view compares agent performance on a selected completion code. The code the system uses for comparison appears at the top of the view.

**Procedure**

1. Display the Job Completion Codes view.
2. Select a dialer from the dialer scope selector.
3. Select a job from the job scope selector.
4. Select an agent completion code in the view.
5. Right-click and select Completion Code Detail by Agent.

Monitor displays the Completion Code Detail view containing Total Releases, Average Per Hour, and the names of the highest and lowest performers.

For example, if you select Code 20, Monitor displays the Completion Code Detail by Agent view that lists Code 20 for each agent on that job.
Job Quality view description

The Job Quality view displays calling activity information for a job.

The view describes the quality of service that dialers achieve during a job. The information includes data for call pacing, nuisance calls, and information about phone calls that were in the wait queue or were abandoned.

The following table describes the Job Quality view:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DialerID</td>
<td>A unique identification number, automatically assigned to a dialer, and is used to identify dialer data in the database.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of the dialer on which the job instance is running.</td>
</tr>
<tr>
<td>JobID</td>
<td>A unique identification number, automatically assigned to a job (by name), used to identify job data in the database.</td>
</tr>
<tr>
<td>Job</td>
<td>The name of each job running in the current scope.</td>
</tr>
<tr>
<td>Job Instance</td>
<td>A unique identification number, automatically assigned to a single instance of a job, used to help identify data associated with that job instance in the database. Each time a job runs, the system assigns a new job instance ID.</td>
</tr>
<tr>
<td>Job Type</td>
<td>The type of job: outbound, Managed, Cruise Control, inbound, or blend.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the job. The status types include stopped, running, error, or shutting down.</td>
</tr>
<tr>
<td>Start Date</td>
<td>The date the job instance started.</td>
</tr>
<tr>
<td>Start Time</td>
<td>The time the job instance started.</td>
</tr>
<tr>
<td>Stop Date</td>
<td>The date the job instance stopped or blank if the job is still running.</td>
</tr>
<tr>
<td>Stop Time</td>
<td>The time the job instance stopped or blank if the job is still running.</td>
</tr>
<tr>
<td>Calls Placed</td>
<td>The total number of outbound calls dialed, regardless of the final outcome of the call (i.e., abandoned or connected).</td>
</tr>
<tr>
<td>Calls Offered</td>
<td>The total number of calls detected by the dialer for a given job. Sometimes referred to as the number of hellos.</td>
</tr>
<tr>
<td>Connects</td>
<td>The total number of Calls Offered that are connected to agents, both inbound and outbound, for each job instance.</td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connects Per Hour</td>
<td>The total number of connects per hour in the selected scope.</td>
</tr>
<tr>
<td>Serviced Calls</td>
<td>Calls offered, or hellos, that the dialer connected to an agent within the Time to connect tolerance duration. Serviced Calls are the Calls Offered minus the cumulative number of nuisance calls.</td>
</tr>
<tr>
<td>Desired Service Level</td>
<td>The target percentage of Serviced Calls that you want the system to maintain. The Desired Service Level is set for the job.</td>
</tr>
<tr>
<td>Actual Service Level</td>
<td>The cumulative realized service level for the job. The ratio of the cumulative number of Serviced Calls divided by the cumulative number of Calls Offered.</td>
</tr>
<tr>
<td></td>
<td>• In an Agent Blending system, the service level is the combined service level of outbound jobs.</td>
</tr>
<tr>
<td></td>
<td>• In an Intelligent Call Blending system, the service level is the service level for outbound, inbound, and blend jobs. The sum reflects the service level for Cruise Control and non Cruise Control jobs.</td>
</tr>
<tr>
<td></td>
<td><strong>Important:</strong></td>
</tr>
<tr>
<td></td>
<td>If Cruise Control is important for regulatory control, create a report that reports statistics for only Cruise Control jobs.</td>
</tr>
<tr>
<td>Connect Tolerance</td>
<td>The number of seconds that you will allow a phone call to be delayed waiting for an agent before the dialer designates the call as a nuisance call.</td>
</tr>
<tr>
<td>Short Calls Count</td>
<td>The number of calls marked as short call as per the Short call timer configured.</td>
</tr>
<tr>
<td>Nuisance Count</td>
<td>The total number of Calls Offered that were not distributed to agents within the Connect Tolerance.</td>
</tr>
<tr>
<td>Total Nuisance Rate</td>
<td>The rate of nuisance calls as a percentage of total Calls Offered. The Nuisance Count divided by the Calls Offered.</td>
</tr>
<tr>
<td>Calls Queued</td>
<td>The total number of calls that have spent time in the wait queue since the job began.</td>
</tr>
<tr>
<td>Avg Queue Time</td>
<td>The average length of time calls that have spent time in the wait queue since the job began.</td>
</tr>
<tr>
<td>Abandon Rate</td>
<td>The rate of abandon calls as a percentage of total calls offered. The formula is:</td>
</tr>
<tr>
<td></td>
<td>Total number of calls released by Code 96 *100) / (Total number of outbound connects + Total Number</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Name</td>
<td>Description of Calls released by Code 96 - Total number of Answering machine (Code 97)</td>
</tr>
<tr>
<td>Elapsed Time</td>
<td>The total time since the job instance started.</td>
</tr>
<tr>
<td>Tenant Name</td>
<td>Name of the tenant for which the system displays the data.</td>
</tr>
</tbody>
</table>

**Supervisor Agents view descriptions**

The Supervisor Agents view displays the same data as the Dialer Agents view.

This view is only available if you have completed the following setups:

- Defined an agent/supervisor hierarchy
- Selected **Settings > Options** and select that hierarchy as the default agent/supervisor hierarchy

The following table describes the Supervisor Agents view:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total</td>
<td>The total number of agents within the selected scope.</td>
</tr>
<tr>
<td>Talk</td>
<td>The total number of agents with status “Talk” in the selected scope.</td>
</tr>
<tr>
<td>Update</td>
<td>The total number of agents with status “Update” in the selected scope.</td>
</tr>
<tr>
<td>Idle</td>
<td>The total number of agents with status “Idle” in the selected scope.</td>
</tr>
<tr>
<td>ACD</td>
<td>The total number of ACD agents in the selected scope.</td>
</tr>
<tr>
<td>Unavailable</td>
<td>The total number of unavailable agents in the selected scope.</td>
</tr>
<tr>
<td>Acquired</td>
<td>The total number of acquired ACD agents in the selected scope.</td>
</tr>
<tr>
<td>Offline</td>
<td>The total number of offline agents in the selected scope.</td>
</tr>
<tr>
<td>Logging Off</td>
<td>The total number of agents that have requested log off, but are still handling calls.</td>
</tr>
<tr>
<td>Supervisor</td>
<td>The name of the supervisor in the agent/supervisor hierarchy.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of the dialer.</td>
</tr>
</tbody>
</table>

*Table continues...*
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Job</td>
<td>The name of a currently running job. Available data includes the names of all jobs running in the current scope.</td>
</tr>
<tr>
<td>Job Instance</td>
<td>A unique identification number, automatically assigned to a single instance of a job, used to identify data associated with that job instance in the database. Each time a job runs, the system assigns a new job instance ID.</td>
</tr>
<tr>
<td>Agent</td>
<td>The name of an agent logged in to the selected dialer.</td>
</tr>
<tr>
<td>Agent ID</td>
<td>The identification number of the agent logged in to the selected dialer.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the Agent. Status types include Talk, Update, Idle, Waiting for acquire, Offline, Off job, Not available, and Logging off.</td>
</tr>
<tr>
<td>On Status</td>
<td>The duration of the current status of the agent in hh:mm:ss format.</td>
</tr>
<tr>
<td>Agent Type</td>
<td>The type of calling activity the agent is logged in to handle. Acceptable values include Outbound, Inbound, and Blend.</td>
</tr>
<tr>
<td>On Job</td>
<td>The amount of time the agent has been on the job in hh:mm:ss format.</td>
</tr>
<tr>
<td>Headset</td>
<td>The headset ID or ACD extension assigned to the agent. The system uses this data to perform audio monitoring of an agent.</td>
</tr>
<tr>
<td>Logon Time</td>
<td>The time when an agent logged on.</td>
</tr>
<tr>
<td>Call Type</td>
<td>The type of the call: Outbound, inbound, or blend.</td>
</tr>
<tr>
<td>Released Time</td>
<td>The time when an agent is released from the blend job.</td>
</tr>
<tr>
<td>Acquired Time</td>
<td>The time when an agent is acquired for the blend job.</td>
</tr>
<tr>
<td>Offline Time</td>
<td>The time when an agent logged out of the job or took a break.</td>
</tr>
</tbody>
</table>

**Viewing Supervisor agents view**

**Procedure**

1. In Monitor, select **Settings > Options**.
2. Select the **Agent States** tab.
3. Select the agent states that you want to view.
   - You can further limit the agent states in a single view by using the Filter option.
Result
The graphic mode displays a subset of the data in the table mode. The graphic mode displays data for each agent: agent name, the agent’s status, the time the agent is in that status.

Related links
Options Agent States tab field descriptions on page 331

Find Agent view descriptions
The Find Agent view helps you locate one or more agents by name, dialer, supervisor, or job. The results appear in a grid at the bottom of the dialog box.

You can use the Use default agent/supervisor hierarchy check box to view the name of the Supervisor who is managing the selected agent. You can select one or more agents from the result list and perform any of the actions on the Find Agent toolbar.

The following table includes descriptions about the Find Agent views:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent</td>
<td>The name of the agent matching the search criteria.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the agent. Status types include Talk, Update, Idle, Waiting for acquire, and Not available.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of one or more dialers to which the agent belongs.</td>
</tr>
<tr>
<td>Job</td>
<td>The name of jobs to which the agent belongs.</td>
</tr>
<tr>
<td>Supervisor</td>
<td>The name of the supervisor in the supervisor hierarchy.</td>
</tr>
<tr>
<td></td>
<td>The supervisor’s name is not be available unless the you applied an agent/supervisor hierarchy to the view.</td>
</tr>
<tr>
<td>Headset</td>
<td>The headset ID or ACD extension assigned to the agent. The system uses this data to perform audio monitoring of an agent.</td>
</tr>
<tr>
<td>Tenant Name</td>
<td>Name of the tenant for which the system displays the data.</td>
</tr>
</tbody>
</table>

Agent Detail view descriptions
The Agent Detail view displays detailed information about the current activity and performance of an agent.

You can display this view for a specific agent from the Tools menu within any view that lists agents.
This view is only available if you have selected **Settings > Options** and select that hierarchy as the default agent/supervisor hierarchy.

The following table describes the Agent Detail view:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the agent appears in the title bar.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of the dialer on which the agent is working.</td>
</tr>
<tr>
<td>Supervisor</td>
<td>The name of one or more supervisors to limit the search. This is only valid if you define an agent/ supervisor hierarchy.</td>
</tr>
<tr>
<td>Job</td>
<td>The name of the job on which the agent is working.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the Agent. Status types include Talk, Update, Idle, Waiting for acquire, Offline, Off job, Not available, and Logging off.</td>
</tr>
<tr>
<td>On Status</td>
<td>The time that the agent is on the current status.</td>
</tr>
<tr>
<td>Agent Type</td>
<td>The type of calling activity the agent is logged in to handle. Acceptable values include Outbound, Inbound, and Blend.</td>
</tr>
<tr>
<td>Current Type</td>
<td>The type of calling activity in which the agent is currently engaged. This data is significant for agents that log in as blend, but are normally engaged in either Inbound or Outbound activity. Their agent type is Blend, but their current type varies between Outbound and Inbound. Similarly, for agents that have logged in as ACD, both agent type and current type change to Outbound once the agent has been acquired.</td>
</tr>
<tr>
<td>Total Connects - This Agent</td>
<td>The total number of calls, both inbound and outbound, connected to this agent.</td>
</tr>
<tr>
<td>Total Talk - This Agent</td>
<td>The total time spent talking on the job.</td>
</tr>
<tr>
<td>Total Update - This Agent</td>
<td>The total time spent updating records.</td>
</tr>
<tr>
<td>Total Idle - This Agent</td>
<td>The total time spent waiting for a call.</td>
</tr>
<tr>
<td>Duty Cycle - This Agent</td>
<td>The average ratio between time spent talking and updating a record and the time from the beginning of one call to the beginning of the next call.</td>
</tr>
<tr>
<td>Average Connects - This Agent</td>
<td>The average number of calls per hour, both inbound and outbound, connected to an agent.</td>
</tr>
<tr>
<td>Average Talk - This Agent Average</td>
<td>The average time per hour spent talking on each call. The data appears as a number and as a section of the pie chart.</td>
</tr>
<tr>
<td>Average Update - This Agent Average</td>
<td>The average time per hour spent updating records by this agent.</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Average Idle - This Agent Average</strong></td>
<td>The average time per hour the agent spent waiting between calls. The data appears as a number and as a section of the pie chart.</td>
</tr>
<tr>
<td><strong>Average Duty Cycle - This Agent Average</strong></td>
<td>The average ratio per hour between time spent talking and updating a record and the time from the beginning of one call to the beginning of the next call.</td>
</tr>
<tr>
<td><strong>Average Connects - Average of This Type</strong></td>
<td>The average number of calls per hour that connect to all agents who belong to the same type as this particular agent. For example, Inbound, Outbound, Blend, and Managed. The calls connected in this case can be inbound connects, outbound connects, or both, depending on the agent type. The data appears as a number and as a section of the pie chart.</td>
</tr>
<tr>
<td><strong>Average Talk - Average of This Type</strong></td>
<td>The average time that agents who belong to the same agent type spend per hour talking on each call. The data appears as a number and as a section of the pie chart.</td>
</tr>
<tr>
<td><strong>Average Update - Average of This Type</strong></td>
<td>The average time spent per hour updating records by agents of the same type.</td>
</tr>
<tr>
<td><strong>Average Idle - Average of This Type</strong></td>
<td>The average time spent per hour waiting between calls by agents of the same type. The data appears as a number and as a section of the pie chart.</td>
</tr>
<tr>
<td><strong>Average Duty Cycle - Average of This Type</strong></td>
<td>The average ratio per hour between time spent talking and updating a record and the time from the beginning of one call to the beginning of the next call for agents of this type.</td>
</tr>
<tr>
<td><strong>Tenant Name</strong></td>
<td>Name of the tenant for which the system displays the data.</td>
</tr>
</tbody>
</table>

**Related links**
- Options dialog box on page 330
- Opening a view about a specific agent on page 326

---

**Agent Completion Codes view descriptions**

The Agent Completion Codes view displays the calling results in terms of completion codes. Additional information includes the following data:

- Total number of calls, connects, and RPCs
- The per hour number of calls, connects, and RPCs
- The number of RPCs per connect
You can display this view for a specific agent from the **Tools** menu within any view that lists agents.

The following table displays the Agent Completion Codes view:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connects</td>
<td>The total number of connects for this agent.</td>
</tr>
<tr>
<td>RPCs</td>
<td>The total number of RPCs for this agent.</td>
</tr>
<tr>
<td>Closures</td>
<td>The total number of closures for this agent.</td>
</tr>
<tr>
<td>Code</td>
<td>The unique identification number associated with each completion code.</td>
</tr>
<tr>
<td>RPC</td>
<td>A square indicates the code is an RPC.</td>
</tr>
<tr>
<td>Closure</td>
<td>A square indicates the code is a closure.</td>
</tr>
<tr>
<td>Name</td>
<td>The user-defined name or description assigned to each code.</td>
</tr>
<tr>
<td>Total</td>
<td>The total number of calls released with each completion code.</td>
</tr>
<tr>
<td>Avg/Hr</td>
<td>The average number of calls released with a completion code during an hour.</td>
</tr>
<tr>
<td>Type Avg/Hr</td>
<td>The average number of calls released by a specific type of agent with a completion code during an hour.</td>
</tr>
<tr>
<td>% of RPCs</td>
<td>For each code designated as an RPC, the percentage of connects recorded for each completion code based on the total number of RPCs for the job. For more information, see Job Completion Codes view descriptions on page 365.</td>
</tr>
<tr>
<td>% of Closures</td>
<td>For each code designated as a closure, the percentage of connects recorded for each completion code based on the total number of closures for the job. For more information, see Job Completion Codes view descriptions on page 365.</td>
</tr>
<tr>
<td>% of Calls</td>
<td>The number of calls recorded for each code as a percentage of the total number of calls for the job. For more information, see Job Completion Codes view descriptions on page 365.</td>
</tr>
<tr>
<td>Tenant Name</td>
<td>Name of the tenant for which the system displays the data.</td>
</tr>
</tbody>
</table>

**Related links**

[Opening a view about a specific agent](#) on page 326
Agent History view descriptions

The Agent History view displays detailed information about the past activity and performance of an agent.

You can display this view for a specific agent from the Tools menu within any view that lists agents.

The following table displays the Agent History views:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent</td>
<td>The name of the agent logged in to the selected dialer.</td>
</tr>
<tr>
<td>Agent ID</td>
<td>The identification number of the agent logged in to the selected dialer.</td>
</tr>
<tr>
<td>Dialer</td>
<td>The name of the dialer in the current scope.</td>
</tr>
<tr>
<td>Dialer ID</td>
<td>A unique identification number, automatically assigned to a dialer, used to identify data related to that dialer in the database.</td>
</tr>
<tr>
<td>Current Job</td>
<td>The name the job that is running during the current time scope.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the Agent. Status types include Talk, Update, Idle, Waiting for acquire, Offline, Off job, Not available, and Logging off.</td>
</tr>
<tr>
<td>All Jobs</td>
<td>The jobs that have run.</td>
</tr>
<tr>
<td>Job ID</td>
<td>A unique identification number, automatically assigned to a job. Used to identify job data in the database. The job ID does not change each time the job runs.</td>
</tr>
<tr>
<td>Last Log in Date</td>
<td>The date in the yyyy/mm/dd format when the agent logged in to the dialer the last time.</td>
</tr>
<tr>
<td>Last Log in Time</td>
<td>The time, in the hh:mm:ss format, when the agent last logged in to the dialer.</td>
</tr>
<tr>
<td>Last Logout Date</td>
<td>The date the agent last logged out of a job in the yyyy/mm/dd format.</td>
</tr>
<tr>
<td>Last Logout Time</td>
<td>The time the agent last logged out of a job in the hh:mm:ss format.</td>
</tr>
<tr>
<td>Agent Hours</td>
<td>The total number of hours agents have logged in to a job instance over the course of the job.</td>
</tr>
<tr>
<td>Job Number</td>
<td>The number that the system assigned to the job. This is the same number that appears on the JobMon menu in the Linux-based menu system.</td>
</tr>
</tbody>
</table>

Table continues…
Monitor view windows

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Job Instance</td>
<td>A unique identification number, automatically assigned to a job each time the job runs. Used to identify job data in the database. The job instance changes each time the job runs.</td>
</tr>
<tr>
<td>Tenant Name</td>
<td>Name of the tenant for which the system displays the data.</td>
</tr>
</tbody>
</table>

Related links

Opening a view about a specific agent on page 326
Chapter 28: Job control functions

Avaya Proactive Contact allows you to adjust job settings while a job is running. You make these adjustments through the Monitor Tools menu. The adjusted settings expire when the job ends.

Note:
When a job uses the Cruise Control feature, you cannot change the call pacing settings.

In a multitenancy environment, you can view data only specific to your tenant. If you select the All tenant option from the Tenant drop-down, then you can view data belonging to all the tenants to which you are assigned; however, you cannot use the job control functions.

Job controls are available from any view that displays a list of jobs, such as the Job Status view or the Job Wait Queue view.

Stopping a job

Procedure

1. In Monitor, open a view that lists jobs, and then select the job you want to stop.
2. Select Tools > Stop Job.

   The Stop Job dialog box appears.
3. Select one of the following options:
   - Stop job gracefully as agents complete calls - Allows you to stop a job after the agents complete their current calls. This option allows the agents to end their current calls and release the records. This is the typical method.
   - Stop job immediately - Allows you to stop a job immediately. Avaya Proactive Contact disconnects all phone conversations and closes the records immediately. As a result, agents cannot finish speaking with a customer or update customer records.
4. Click OK.

   A dialog box with Are you sure? message appears.
5. Click Yes to stop the job.

   If the job is linked to another job, a dialog box appears asking you whether you want to keep the job link.
If you have enabled the Automatic record selection trigger value for linked job feature for the job, and you do not close the link job, then the system displays the following message:

Run record selection for link job if it has not been run automatically?

6. Click Yes to run the record selection of linked job.

Related links
Stop Job dialog box field descriptions on page 333

Linking to job

About this task
Use the Job Link option to identify a job to start automatically when the current job completes. When you link a job, the system transfers agents to the next job as the agents complete their last calls and release the records. The system displays a message specifying that the agents are changing jobs.

In a multitenancy environment, you can view jobs only specific to your tenant.

You can create link to a job in the following ways:

Procedure

1. If you have not yet started a job:
   a. Open an Editor view, in Contact Management tab, click Jobs.
   b. In the Job Detail tab, under Files group, click in the value column of the Name of next job to link to option.
   c. Select the next job from the drop-down menu.
   d. Click Save.

2. If a job is already running and you want to add or edit a job link:
   a. Open a Monitor view that lists jobs.
   b. Select a job, and then select Tools > Job Link.
   c. Select a job, and then click OK.

Related links
Basic settings field descriptions on page 230
Job Link dialog box field descriptions on page 333
Setting escape recall for a job

About this task
Use the Escape Recall Job option to pull in an agent from a different job to address a recall for another job. This functionality is applicable only if you have selected the **Shutdown job when no more calls remain** field in the job. You can select a running job from which an available agent should attend to the recall that was set for the original job. You can define the job from which the agent should be pulled in using Editor. However, you can change the job in run time using Monitor.

Procedure
1. In Monitor, open a view that lists jobs, and then select the job you want to recall.
2. Select **Tools > Escape Recall Job**.
   The Escape Recall Job dialog box appears.
3. Click **OK**.
   A dialog box
   Are you sure you want to change this escape recall job?
   message appears.
4. Click **OK**.
5. Click **Yes**.

Related links
[Escape Recall Job dialog box field descriptions](#) on page 333

Setting automatic record selection

About this task
Use the Autocallsel Trigger option to automatically run the record selection for the next linked job at a configurable percentage completion of the current job. When the system runs the automated record selection, it validates the percentage of records completed until the linked job starts. This ensures that if the percentage of records completed drops below the configured value, then the record selection is re-run once the target is met again.

Procedure
1. In Monitor, open a view that lists jobs, and then select a job.
2. Select **Tools > Autocallsel Trigger**.
   The Record Selection of Linked Job dialog box appears.
3. Click **OK**.
   A dialog box with the
Are you sure you want to change the autocallsel trigger value? 

message appears.

4. Click Yes.

Related links
Record Selection of Link Job dialog box field descriptions on page 334

---

**Setting the minimum hit rate**

**About this task**

The minimum hit rate prevents Avaya Proactive Contact from allocating more pooled lines to a poorly performing job at the expense of a more successful job.

The minimum hit rate designates the lowest perceived probability of a call attempt that results in a request for an agent. The value of this parameter can reduce the number of call attempts that Avaya Proactive Contact initiates. For example, a job using a minimum hit rate of 30% means the system makes no more than three dialing attempts for each agent.

To set the minimum hit rate:

**Procedure**

1. Open a Monitor view that lists jobs.
2. Select a job, and then select Tools > Minimum Hit Rate.
3. Use the slider or type a value from 0 to 100 in increments of 10, and then click OK.

Related links
Minimum Hit Rate dialog box field descriptions on page 334

---

**Setting the Expert Calling Ratio**

**About this task**

Avaya Proactive Contact provides two methods for predicting when to make the next phone call: Cruise Control and Expert Calling Ratio. If the job uses Expert Calling Ratio, you can change the Expert Calling Mode in Monitor. You cannot change the Cruise Control settings.

Expert Calling Ratio changes the way Avaya Proactive Contact predicts when to make the next call. You can select any of the following three ratios:

- Callers in the wait queue
- Agent Work Time
- Agent Update Time
Tip:
If you are currently experiencing a high abandonment rate, you may want to lower the percentage. If your agents are experiencing large amounts of idle time, you may want to increase the percentage. This rule is applicable to all of the three ratios.

Procedure
1. Open a Monitor view that lists jobs.
2. Select a job, and then select Tools > Expert Calling Ratio.
3. Click the Expert Calling Mode field and select either Callers in the wait queue, Agent update time, or Agent work time.
4. Select the Value field to enter a value from 0 through 100 in increments of 10, and then click OK.

Tip:
Wait at least 15 minutes before changing your Expert Calling Ratio again because your changes will not reflect for at least that duration.

Related links
- Expert Calling Ratio dialog box field descriptions on page 335

Maintaining job control functions

Adjusting Inbound settings

Procedure
1. Open a Monitor view that lists jobs.
2. Select an inbound or blend job, and then select Tools > Inbound Settings.
3. Click the Value field to enter settings, and then click OK.

Related links
- Inbound Settings dialog box field descriptions on page 335

Record selection criteria in real-time
Proactive Contact allows you to modify a selection criterion for a running job in real-time using monitor.
**Note:**

This functionality of changing the record selection criteria in real-time is available only from the monitor. You cannot use this functionality through Jobmon. Also, this functionality is not applicable for the Inbound and IVR pool jobs.

After specifying the criteria for selecting new set of records, new set of records are selected. If you choose to use the newly selected records, the index file containing the previous records is replaced with the newly selected records.

Note the following before you make the changes to the record selection criteria:

- If the new selection does not have the unit lists that were present in earlier selection, then the agents will stop getting calls for that unit. In that case, the agents must log out of that unit and log in to a new unit.
- Strategy will be applied afresh to the records being called.
- The new selection will not have recalls set from previous selection; however, the Agent owned recalls will be retained. You will need to update the selection at run-time to specifically select the recalls set prior to the new selection made.
- The new criteria is applied over the base call selection criteria. If the base call selection criteria is modified again, then the new criteria is applied on the new base call selection criteria.
- If you change the calling list in the base call selection criteria, then the new criteria continues to run as earlier, and does not recognize the changed calling list. If you change the calling list, then the system displays the following error message:
  
  Calling list used in the selection has been changed since the job has started.

- When you define a new real-time call selection criteria by using the Edit the callsel option, then the previously configured real-time call selection is considered as the base for new configuration.

Before loading the new index, you can choose to maintain current value of hit rate/cruise control parameters or reset it to the values mentioned in the job.

The changes made to the selection criteria are only run time changes and not permanent changes. For fresh downloads, the changes made at run time are not applicable and the selection criteria in the selection file is used.

The reports are updated to reflect the calls made as per old selection file as well as new selection file. For example, in jobmon, the records selected field is updated to display newly selected records along with the phone calls already made from the previous selection.

---

**Modifying record selection criteria in real-time**

**About this task**

You must not download a net new list, while a job is running on the same list.
Procedure

1. Open a Monitor view that lists running jobs.
2. Perform any or all of the following as required:
   a. To modify the record selection, select a job, and then select Tools > Selection Records. A check mark indicates that the selection is in use.
   b. To modify the selection results criteria, select a job, and then select Tools > Selection Results.
   c. To modify the sorting criteria for records, select a job, and then select Tools > Selection Sort.
3. Click OK to confirm the selection parameters. The Results window displays the details of the records.
4. To apply the new selection criteria, click Use this selection.
5. To use the previously defined hit rate, select the Revert Current Hit Rate to original value check box. Otherwise, clear the check box.
6. Click OK to confirm the changes made to the record selection criteria. Click Cancel to cancel the modifications.
7. If you want to make modification to the selection criteria, select Edit this selection option.
8. Select the required option: Records, Results, or Sort.
9. Click OK to go to the corresponding dialog box for making modifications.
10. After making the required modifications in the corresponding dialog box, click OK. The Results window displays the details of the records.
11. Click OK to confirm the changes. Click Cancel to cancel the modifications.

Related links

- Selection Records dialog box field descriptions on page 340
- Selection Results dialog box field descriptions on page 340
- Selection Sort dialog box field descriptions on page 340

Reassigning lines

About this task

When you reassign lines, you alleviate congestion on certain Avaya Proactive Contact lines so that your jobs run more quickly.

In a multitenancy environment, you can view lines only specific to your tenant.

Procedure

1. Open a Monitor view that lists running jobs.
2. Select a job, and then select **Tools > Lines**. A check mark indicates that the line group is in use.

3. To use line groups, complete one of the following actions:
   - Select the appropriate check box.
   - Click the **Activate All** button to select all of the line groups.
   - Click the **Deactivate All** button to clear all of the line groups.

4. Click **OK**.

Related links

*Lines dialog box field descriptions* on page 339

---

### Setting a managed dialing job

**About this task**

Managed dialing jobs allow agents to preview a customer’s record prior to beginning the conversation with the customer.

**Procedure**

1. Open a Monitor view that lists jobs.
2. Select a Managed Dialing job from the list, and then select **Tools > Managed Dialing**.
3. To modify agents’ preview time, enter a different value in the Time Limit box.
4. Select **Allow agent to cancel calls** check box to immediately allow agents to cancel calls.
5. Click **OK**.

Related links

*Managed Dialing settings field descriptions* on page 242
*Managed Dialing dialog box field descriptions* on page 336

---

### Selecting and sorting time zones

**Procedure**

1. Open a Monitor view that lists jobs.
2. Click a job, and then click **Tools > Time Zones**.
3. Click the **Call records in order by time zone** check box to sort calls by times zones.
4. To place calls to a time zone, complete one of the following actions:
   - Select the time zone fields where you want to place calls.
   - Clear the time zone fields where you do not want to place calls.
• Click Activate All to select all time zones.
• Click Deactivate All to clear all time zones.

5. Click OK.

Related links
Time Zones dialog box field descriptions on page 336

Single or multiple unit work lists

A unit work list creates a sub-list in a job so that certain agents can be assigned to a unit work list and can receive only certain calls.

For example: A job calls potential customers to set up appointments with sales people. You can enable the unit work list named sales group for the job. As the dialer places phone calls, agents make appointments for sales people in the sales group. When the sales people's schedules are full, the dialer stops placing calls for appointments.

Agent can select single or multiple units at the time of logging in to a job. Previously, agents were allowed to select all unit work list jobs or only one unit work list job at a time. Now, agents can select multiple unit work lists and can be made available equally across number of units selected. For example, if an agent logs into 10 units, the availability of that agent across each unit will be 10%, which means that out of 10 calls taken by that agent, there will be one call from each of the 10 units to which the agent is logged in.

If all the calls are finished in one of the units, agent's availability is spread to the remaining units. For example, if an agent logs into three units, the availability will be 33% across each unit. If all the calls are finished in one of the units, the agent will be available 50% across remaining two units. The availability of an agent across units will also be valid in case the unit has only recalls left and the rest of the calls are finished. As a result, agents will not have to wait for recall to happen and will have more availability in other units.

You must enable a unit work list for the job before you start the job. During the job, you can enable or disable units. When the job completes the unit work list, the system stops the job. By default, this option is disabled.

*Note:*

When you set unit work lists to run on a blend job, the system must be set to allocate all agents to the units. Set the LOGONUNIT:Require unit ID for agent log in parameter in the job file to No. This rule is enforced in the code because the system cannot easily identify which agent to shift to inbound because of the small pool of agents assigned to each unit. This can result in nuisance calls. Alternatively, you can use agent blending, which allows the agents to logon to campaigns by units. This solution works, but is not as efficient as an outbound only campaign without agent blending.

The Unit work list functionality is also available with the infinite type of Job; however, because infinite job can download new units, Unit work List functionality is restricted with the infinite job.
You can, however, define the expandable units within the system. This will allow the job to manage memory segment for extra downloaded units.

**Note:**
To use Unit work list with Infinite jobs, you must contact Avaya Professional Service to set the MAX_EXPANSION_UNIT parameter in the `master.cfg` file to a maximum of 50 units.

Agent will have to log back to choose the newly downloaded units in infinite job.

### Enabling a unit work list

**About this task**
Avaya Professional Services must perform this procedure.

**Procedure**
1. Open the `master.cfg` file in a text editor such as Notepad.
2. Set the MULTI_UNIT_ACCESS parameter to `Yes`.

### Setting up a unit work list

**Procedure**
1. Open a Monitor view that lists jobs.
2. Select a job, and then select **Tools > Unit Work Lists**.
3. To change a work list ID, complete one of the following actions:
   - Select the Unit ID names that you want to use.
   - Clear the Unit ID names that you do not want to use.
   - Click **Activate All** to select all Unit ID names.
   - Click **Deactivate All** to clear Unit ID names.
4. Click **OK**.

### Setting and modifying a quota

**About this task**
Avaya Proactive Contact uses quota to complete a specified number of outbound calls based on a selected outcome.

A quota is a maximum number of releases for a particular completion code. When the system reaches the quota for a completion code, the dialer stops placing phone calls and the system stops the job.

In Editor, you set and modify a quota that the system applies when the job starts.
In Monitor, you set and modify a quota that affects the current job while the job runs.
To understand how Avaya Proactive Contact uses quotas, you should check when a job stops. In a multitenancy environment, you can use quota as assigned to your tenant.

**Procedure**
1. Start Monitor.
2. Select a job, and then select **Tools > Quotas**. The Quota dialog box appears.
3. Select the **Unit ID** field and type a Unit ID.
4. Select the **Completion Code** field to select a completion code.
5. Select the **Quota** field to enter a number greater than 0.
6. Click **OK**.

**Related links**
- [When a job stops](#) on page 225
- [Quota dialog box field descriptions](#) on page 338

---

**Setting the detection mode**

**About this task**
Use the Detection Mode option to determine the types of calls Avaya Proactive Contact passes to agents.

**Procedure**
1. Open a Monitor view that lists jobs.
2. Select a job, and then select **Tools > Detection Modes**.
3. Click the **Phone** field to select a phone.
4. Select the **Rings** field to enter a different number of rings.
5. Select the **Pass to Agents** field to select the type of connections to pass on to an agent.
6. To add a phone, click **Add Phone** and repeat Steps 3 and 4 to edit the fields.
7. To remove a phone, select the phone you want to delete, click **Remove Phone**, and then click **OK**.

**Related links**
- [Phone strategy settings](#) on page 198
- [Detection Modes dialog box field descriptions](#) on page 338
**Setting the alternate initial phone**

**About this task**

The alternate initial phone replaces the initial phone as the first phone number to call at a particular time of day. The system begins to call the alternate initial phone number at the time you specify in the alternate initial phone settings.

To set the alternate initial phone:

**Procedure**

1. Open a Monitor view that lists jobs.
2. Select a job, and then select **Tools > Alternate Initial**.
3. Click **Add Phone** to append a row, and then configure the new alternate initial phone’s settings.
4. Click the **Phone** field to select a phone.
5. Click the **Local Time** field to edit the time. To toggle between AM and PM, select it, and then use the up and down arrows.
6. Click the **Time Zones** field, and then click the button to display the list of time zones. Select the time zones you want to call.
7. Click **OK**.

To remove a phone, select the phone you want to remove, and then click **Remove Phone**.

**Related links**

- Phone strategy settings on page 198
- Alternate Initial Phone tab field descriptions on page 201

**Setting retries**

**About this task**

Use the retries setting to determine how long Avaya Proactive Contact waits before retrying a number, how many times it retries the same phone number, and which phone it calls next.

**Procedure**

1. Open a Monitor view that lists jobs.
2. Select a job, and then select **Tools > Retries**.
3. Select the various fields in the Retry dialog box to edit the retries currently configured.

   The Result column indicates the calling result of the call. The Retry Interval values are displayed in minutes.
4. To change a retry, select the appropriate row and complete one of the following actions:
   • Click **Add Retry** to insert a row where you can edit a new retry.
   • Click **Remove Retry** to delete a retry.
5. Click **OK**.

**Related links**
- [Retry dialog box field descriptions](#) on page 339

---

**Finding a text string in a view**

**Procedure**

1. Open a Monitor view that lists jobs.
2. Select a job, and then select **Tools > Find**.
3. Enter the text string of the item you want to find in the current view.
4. To refine your search, select one or both of the following check boxes:
   • Match case
   • Find whole words only
5. Click **Find Next** to continue the search.
6. Click **OK** to end the search.

**Related links**
- [Find dialog box field descriptions](#) on page 332
Chapter 29: Agent control functions

During calling activities, you can use Monitor to find one or more agents and take the following actions to manage agents:

- Transfer one or more agents to another job
- Send a message to one or more agents
- Monitor an agent line
- Remove an agent from a job

Before performing any of these tasks, you must first find an agent.

Related links

Hierarchies on page 396
Using wildcard characters on page 397

Hierarchies

You can find agents in several ways. If you know the exact agent login, you can search for a single agent.

Use the following hierarchy groups to search for a single agent or a group of agents.

<table>
<thead>
<tr>
<th>Hierarchy group</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Job</td>
<td>Search all agents in a job.</td>
</tr>
<tr>
<td>Supervisor</td>
<td>Search all agents reporting to a supervisor.</td>
</tr>
<tr>
<td>Dialer</td>
<td>Search all agents on a dialer.</td>
</tr>
</tbody>
</table>

**Tip:**

An agent must be set up within the supervisor hierarchy for the agent to be found using this function. Set up hierarchies using Hierarchy Manager.
Using wildcard characters

In addition to finding a single agent, you can use wildcard characters to search for multiple agents. The following table lists the common wildcard characters that you can use to find more than one agent:

<table>
<thead>
<tr>
<th>Wildcard character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>*</td>
<td>Search for all agents. Use also for multiple agent login names with identical characters. For example, &quot;smith* will find all agents with anything containing the word smith.</td>
</tr>
<tr>
<td>?</td>
<td>Search for agents with a single character difference in the login name.</td>
</tr>
</tbody>
</table>

Agent control functions

After you find one or more agents, you can use the monitor agent control functions to take the following actions to manage agents:

- Transfer one or more agents to another job
- Send a message to one or more agents
- Monitor an agent line
- Remove an agent from a job

Finding an agent

About this task

To find an agent:

Procedure

1. On the Monitor button bar, click Agent, and then click Find Agent. The Find Agent view appears.
2. Type the name of an agent or use wildcard characters to select multiple agents.
3. Use the Dialer, Job, and Supervisor drop-down lists to select a hierarchy to filter the information.
4. Click Find. Agent names appear in the lower section of the Find Agent view.

Related links

Find Agent dialog box field descriptions on page 341

Comments on this document? infodev@avaya.com
Transferring an agent to another job

About this task

You can transfer an agent to another job only within your tenant space. You can transfer an agent to another job even if that job is not included in the agent’s job list.

Note:
If you try to transfer an agent serving a Shadow job or an AOR, then the system displays a message that the agents who are on shadow job or serving an AOR will not be transferred.

Procedure

1. On the Monitor button bar, click **Agent**, and then click **Find Agent**.
2. Select one or more agents in the Find Agent dialog box.
3. Right-click and select **Transfer Agent**.
   A list of currently running jobs appears.
4. Select the job to which you want to transfer the agent, and then click **OK**.

Tip:
You may not see the agent transfer immediately. Factors, such as agent talk time and update time, may affect the agent transfer duration.

Sending message to an agent

About this task

Note:
You cannot send a message to an agent who is on a shadow job to address Agent Owned Recall.

Procedure

1. On the Monitor button bar, click **Agent**, and then click **Find Agent**.
2. Select one or more agents in the Find Agent dialog box.
3. Right-click and select **Send Message**.
   The Send Message dialog box appears.
4. Type the message to send to an agent, and then click **OK**.

Related links

Find Agent dialog box field descriptions on page 341
Monitoring agent line

About this task
You can monitor an agent line only if the administrator of your tenant assigns you the Job control permission for the Monitor Agent operation.

ほしいNote:
This feature is not available for the Avaya Proactive Contact with CTI.

By default, the Lead Administrator, Supervisor, and Administrator roles are assigned the Job control permission. However, the tenant administrator can modify these permissions for any of the users in the Role Editor application. To monitor an agent line, you must have the access permission for the Monitor application and the Job control permission for the Monitor Agent operation.

ほしいNote:
You cannot monitor agent line for an agent who is on a shadow job to address an AOR.

Procedure
1. On the Monitor button bar, click Agent, and then click Find Agent.
2. Select the agent in the Find Agent dialog box.
3. Right-click and select Monitor Agent.
   A dialog box appears.
4. Enter your headset ID or extension and click OK.
   An icon along with the name of the agent that you are monitoring appears on the right corner of the screen.
5. To stop monitoring or to reconnect to the agent for monitoring, right-click the icon and select the Stop or Connect options.

When you begin monitoring agents on a dialer, you get a dialback on your phone extension only for the first agent. As the system uses the same connection for the duration of the log in session, you do not receive a dialback for the subsequent agents that you choose to monitor. Using this functionality, you can save time when you switch between multiple agents as you do not receive a dialback for each monitoring instance.

ほしいNote:
If you use the Connect option or if you switch between dialers to monitor agents, then you will receive the dialback on your extension for each switch, but only for the first agent from the switched dialer.
6. Perform one of the following steps if you disconnect the phone line during or after agent monitoring:
   • To monitor the same agent, right-click the icon on the right corner and click **Resume > Connect**.

7. To monitor another agent, select the agent, right-click and select **Monitor Agent > Connect**.

**Related links**
Find Agent dialog box field descriptions on page 341

---

**Removing an agent from a job**

**About this task**

You can remove an agent from a job in emergencies when the agent cannot use a normal disconnect method.

Remove Agent immediately removes the agent from the job and logs the agent out of Avaya Proactive Contact.

**Procedure**

1. On the Monitor button bar, click **Agent**, and then click **Find Agent**.
2. Select one or more agents in the Find Agent dialog box.
3. Right-click and select **Remove Agent**.
   
   A dialog box appears.
4. Click **OK**.

**Related links**
Find Agent dialog box field descriptions on page 341

---

**Viewing an agent view**

**About this task**

After you find an agent, you can display an agent view for a selected agent.

**To display an agent view for a selected agent:**

**Procedure**

1. On the Monitor button bar, click **Agent**, and then click **Find Agent**.
2. Select an agent in the Find Agent dialog box.
3. Right-click and select one of the following views: **Agent Detail**, **Agent Completion Codes**, or **Agent History**.
4. Click **OK**.

   The selected view for the selected agent appears.

**Related links**

- [Find Agent dialog box field descriptions](#) on page 341
Chapter 30: Alerts

Avaya Proactive Contact uses alerts to inform supervisors about the end of a job, when a goal is met, and other events. The system uses alerts to notify when the job or agent performance, system or job status, or line usage varies beyond predetermined levels.

In a multitenancy environment, you can set and use alerts only for your tenant. Also, the system displays the data, such as completion codes, only specific to your tenant.

Alerts uses

You can define up to 10 alerts that notify you when the following varies beyond predetermined levels:

- Job or agent performance
- System or job status
- Line usage varies

You can set the following types of alerts to identify and correct potential problems before they escalate:

- Audio cues
- Visual cues
- Log files
- Emails
- Pager signal

You can also set an alert to tell you when the system needs attention, for example, a job is approaching completion.

Tip:

You must keep the Alert viewer open to receive a notification of an alert. After you receive an alert notification, you must enable the alert again.
Alert types

Avaya Proactive Contact can alert you for many reasons. The following is a sample list:

<table>
<thead>
<tr>
<th>Type of alert</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average Idle Time</td>
<td>The average time that all agents or a specific agent are idle, not talking or updating.</td>
</tr>
<tr>
<td>Average Talk Time</td>
<td>The average time that all agents or a specific agent spend in talking.</td>
</tr>
<tr>
<td>Average Update Time</td>
<td>The average update time that all agents or a specific agent spend in updating a customer record.</td>
</tr>
<tr>
<td>Current Talk Time</td>
<td>The talk time for all agents or a specific agent. Current Talk Time is shown as talking in real-time rather than an average over multiple calls.</td>
</tr>
<tr>
<td>Current Update Time</td>
<td>The update time for all agents or a specific agent. Current Update Time is shown as updating in real-time rather than an average over multiple calls.</td>
</tr>
<tr>
<td>Total Idle Time</td>
<td>The total idle time for all agents or a specific agent, as idle time added over the course of a single job.</td>
</tr>
<tr>
<td>Total Talk Time</td>
<td>The total talk time for all agents or a specific agent, as talk time added over the course of a single job.</td>
</tr>
<tr>
<td>Total Update Time</td>
<td>The total update time for all agents or a specific agent, as update time added over the course of a single job.</td>
</tr>
<tr>
<td>Line Utilization</td>
<td>The percentage of lines in use for a given job. For example, Line Utilization provides an alert when 95% of your lines are in use for a job.</td>
</tr>
<tr>
<td>Current Hit Rate</td>
<td>The ratio or percentage of call connects to call attempts. For example, a 25% hit rate means that out of 100 attempts, 25 connects were made. Or, it takes four calls to connect to one customer. A minimum hit rate keeps a job with a low hit rate from using all the lines when it shares a line pool with other jobs.</td>
</tr>
<tr>
<td>Time on Dialer</td>
<td>The time of day or night when the dialer sends an alert notification.</td>
</tr>
<tr>
<td>Agent Completion Code Total</td>
<td>The accumulated total of completion codes that agents have entered.</td>
</tr>
<tr>
<td>Agent Completion Code Average</td>
<td>The average number of completion codes that agents have entered.</td>
</tr>
<tr>
<td>Job Completion Code Average</td>
<td>The completion code average per hour. The Job Completion Code Average is useful if you would like an overall sense of job performance.</td>
</tr>
<tr>
<td>Job Completion Code Total</td>
<td>The total of all job completion codes, as accumulated over the entire life of a job. The Job Completion Code Total is useful if you want to stop a job or reassign agents to another job when the goal for a job has been met.</td>
</tr>
<tr>
<td>Agents Assigned</td>
<td>The number of agents currently on a job.</td>
</tr>
<tr>
<td>Job End</td>
<td>The job has ended.</td>
</tr>
<tr>
<td>Records Left</td>
<td>The number of records still left in the job that need to be dialed.</td>
</tr>
</tbody>
</table>

Table continues...
Alerts

<table>
<thead>
<tr>
<th>Type of alert</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Records Left as Percent of Total</td>
<td>The percent of records in the entire job still left to be dialed.</td>
</tr>
<tr>
<td>Time Remaining</td>
<td>The estimated time left on a job.</td>
</tr>
</tbody>
</table>

**Alert settings**

The following table shows possible combinations of alert settings:

<table>
<thead>
<tr>
<th>Condition</th>
<th>Dialer</th>
<th>Job</th>
<th>Agent</th>
<th>Relation</th>
<th>Value</th>
<th>Modifier</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent Comp Code Totals</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td>Total</td>
<td></td>
</tr>
<tr>
<td>Agent Comp code Avg</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td>Average Per Hour</td>
<td></td>
</tr>
<tr>
<td>Agents Assigned</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>&gt;,&lt;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Average Idle Time</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td>0-1440 minutes</td>
<td></td>
</tr>
<tr>
<td>Average Talk Time</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td>0-1440 minutes</td>
<td></td>
</tr>
<tr>
<td>Average Update Time</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td>0-1440 minutes</td>
<td></td>
</tr>
<tr>
<td>Current Hit Rate</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td>1-100</td>
<td>%</td>
</tr>
<tr>
<td>Current Talk Time</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td>0-1440</td>
<td></td>
</tr>
<tr>
<td>Current Update Time</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td>0-1440</td>
<td></td>
</tr>
<tr>
<td>Job Comp Code Avg</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>&gt;,&lt;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Job Comp Code Total</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>&gt;,&lt;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Job End</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Line Utilization</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>&gt;,&lt;</td>
<td>1-100</td>
<td>%</td>
</tr>
<tr>
<td>Records Left</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>&gt;,&lt;</td>
<td>1-100</td>
<td>%</td>
</tr>
<tr>
<td>Records Left Percent</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>&gt;,&lt;</td>
<td>1-100</td>
<td>%</td>
</tr>
<tr>
<td>Time on Dialer</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>&gt;,&lt;</td>
<td>1:00-12:59 AMPM</td>
<td></td>
</tr>
<tr>
<td>Time Remaining</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>&gt;,&lt;</td>
<td>0-1440</td>
<td>minutes</td>
</tr>
<tr>
<td>Total Idle Time</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td>0-1440</td>
<td>minutes</td>
</tr>
<tr>
<td>Total Talk Time</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td>0-1440</td>
<td>minutes</td>
</tr>
<tr>
<td>Total Update Time</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>&gt;,&lt;</td>
<td>0-1440</td>
<td>minutes</td>
</tr>
</tbody>
</table>

The dialer, job, and agent columns indicate whether a data item is relevant to a particular alert condition. For example, you can set a Job End alert for any job on any dialer, and you can set a Total Talk Time alert on any agent on any job on any dialer.
Creating an alert

Procedure

1. Select Start > All Programs > Avaya > Proactive Contact > Supervisor > Monitor.
2. Select Settings > Alerts
   
   If an email configuration wizard appears, either complete it or cancel out of it.

3. In the Alerts Viewer dialog box, click Add.

   The Alert Editor dialog box appears.

4. On the Alert Definition tab, select the condition you want to monitor and complete the conditional statement.

5. On the Scope tab, narrow your alert condition.

   Tip:
   
   You can skip this tab if you do not want to narrow your alert criteria.

6. On the Notifications tab, select the following options to specify how Avaya Proactive Contact notifies you:
   
   • Display an alert to open a pop-up alert dialog on your screen.
   • Sound an alert to hear an audible sound.
   • Send email to receive an email with an alert notification.
   • If Send email is unavailable, configure your default email client on your computer.
   • If Send email is available and you want to receive an email alert notification, type your email address in the To... box.

7. Click OK.

   The alert name and summary information appear in the Alerts Viewer dialog box.

Related links

Alert Viewer dialog box field descriptions on page 409

Creating an Email Notification

Procedure

1. Set Email Server Details (Server name and IP) in Mid-Tier Configurator.

2. To get event related emails, go to Email Settings from HealthManager > Tools > Options and mention email address in To (Recipients) and from (Sender) fields.

3. To get Alert emails:
   
   a. Go to AlertViewer. You can gain access to AlertViewer through Health Manager or the Monitor application.
b. Click **Add**, if you want to add new alert or click **Edit** to modify an existing alert to open the Alert Editor.

c. On the Alert Editor window, go to the **Notification** tab. Select the check box corresponding to the Send E-mail option and enter the email address of Sender/Recipient.

d. If your system has McAfee installed, then HealthBridge.exe is blocked by the port blocking rule. To unblock HealthBridge.exe, perform the following steps:

e. Right click **McAfee OAS** and Open **VirusScan Console**.

f. Open **Access Protection Properties**.

g. Select **Anti-virus Standard Protection** in the Categories pane.

h. Select the rule **Prevent mass mailing worms from sending mail**.

i. Click the **Edit** option.

   This will open Rules Details.

j. Add **HealthBridge.exe** in the Processes to exclude section.

k. Click **Edit**.

   Once you specify these settings, various events, such as dialer processes up/down and alerts as configured in the Alert Viewer, are notified through emails.

---

**Editing an alert**

**Procedure**

1. In Monitor, select **Settings > Alerts**.

   The Alerts Viewer dialog box appears.

2. Select the alert you want to edit, and then click **Edit**.

   The Alert Editor dialog box appears.

3. Use the Alert Definition, Scope, and Notifications tabs to modify the alert.

4. Click **OK**.

**Related links**

- [Alert Editor, Alert Definition tab field descriptions](#) on page 410
- [Alert Editor, Scope tab field descriptions](#) on page 410
- [Alert Editor, Notifications tab field descriptions](#) on page 411
Removing an alert

Procedure
1. In Monitor, select Settings > Alerts.
   The Alerts Viewer dialog box appears.
2. Select the alert you want to delete, and then click Remove.
3. Click Close.

Related links
Alert Viewer dialog box field descriptions on page 409

Sending email alert using Health Manager or Monitor Alerts option

About this task
For sending alert emails, you must have the email setting configured on your machine.

Procedure
1. Set the email server details (server name and IP) in Mid-Tier Configurator.
2. To set event related emails:
   a. Log in to the Health Manager application.
   b. Click Tools > Options.
   c. Select Email Settings and specify the email address in To (Recipient) and From (Sender) fields.
3. To get Alert emails:
   a. Go to AlertViewer. You can gain access to AlertViewer through Health Manager or the Monitor application.
   b. Click Add, if you want to add new alert or click Edit to modify an existing alert to open the Alert Editor.
   c. On the Alert Editor window, go to the Notification tab. Select the check box corresponding to the Send E-mail option and enter the email address of Sender/Recipient.

Using antivirus

About this task
If you have McAfee installed, then HealthBridge.exe is blocked by port blocking rule.
To unblock HealthBridge.exe:

**Procedure**

1. Right click McAfee OAS and Open VirusScan Console.
4. Select the rule Prevent mass mailing worms from sending mail.
5. Click the Edit option.
   
   This will open Rules Details.
6. Add HealthBridge.exe in the Processes to exclude section.
   
   After you unblock HealthBridge.exe, various events and alerts configured in the Alert Viewer are notified through emails.

---

**Enable and disable alerts**

In Alert Viewer, you have the option to disable alerts, which tells Avaya Proactive Contact not to notify you about an alert.

For example: You usually monitor agent Doe everyday because he is a new hire. If agent Doe calls in sick for a day, clear the check box next to the agent Doe alert to disable the alert. When agent Doe returns to work, select the agent Doe alert to reanimate it.

The Enabled check box tells you whether or not Avaya Proactive Contact is actively checking the alert’s condition. A check mark indicates that Avaya Proactive Contact is monitoring the condition.

Apart from the Job Ended, Current Talk Time, and Current Update Time conditions, when you receive an alert notification for any other condition, then you must enable the alert again to be able to get alert notification in future.

You are not required to enable alerts manually in case of Job Ended, Current Talk Time, and Current Update Time alert conditions. The system continues to send alerts for these conditions until you disable these alerts.

---

**Enabling and disabling alerts**

**Procedure**

1. In Monitor, select Settings > Alerts.
2. Select or clear the Enabled check box corresponding to the alert.
   
   - Select the Enabled check box to activate monitoring of the alert condition.
   
   - Clear the Enabled check box to deactivate the alert.
Checking the status of each alert

About this task

In Alert Viewer, you can check the status of your alerts.

- If an alert condition has not been met, its status is On.
- If an alert condition has been met, its status is Off.

Procedure

1. In Monitor, select Settings > Alerts.
2. Check whether the Status column has an On or Off status.

Alert Viewer dialog box field descriptions

You can define up to 10 alerts to provide audio cues, visual cues, log files, emails, or pager signals when job or agent performance, system or job status, or line usage varies beyond predetermined levels. This information lets you identify and correct potential problems before they escalate.

The Alerts Viewer dialog box contains summary information about existing alerts.

- Use Edit to edit an alert’s settings.
- Use Add to add an alert.

You can receive alerts only when Monitor is running at the time when the alert’s condition is met.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enabled</td>
<td>Indicates if an alert is enabled. If you do not want the system to monitor an alert’s condition, clear the check box located in the Enabled field. Alerts using the Job Ended, Current Talk Time, and Current Update Time conditions automatically re-enable themselves after their condition is met, but for all other alerts, you should manually re-enable them.</td>
</tr>
<tr>
<td>Status</td>
<td>Displays the current status for each alert. If an alert’s condition has been met, its status is Off.</td>
</tr>
<tr>
<td>Condition</td>
<td>Displays the condition, such as Average Talk Time or Line Utilization, defined for each alert. Click Edit to set or change a condition (Alert Editor, Alert Definition tab).</td>
</tr>
<tr>
<td>Value</td>
<td>Displays the value associated with the condition for each alert. Click Edit to set or change a condition (Alert Editor, Alert Definition tab).</td>
</tr>
</tbody>
</table>

Table continues…
### Alert Editor, Alert Definition tab field descriptions

The Alert Definition tab enables you to create your alert condition statement. Use the **Condition** list to select the condition you wish to monitor (for example, Current Talk Time). Use the **Completion Code**, **Operator**, and **Value** fields to complete your alert’s conditional statement (for example, >15 minutes). The **Completion Code** list is available based on the selected condition.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Condition</td>
<td>Lists the available conditions for which you can set an alert to monitor.</td>
</tr>
<tr>
<td>Completion Code</td>
<td>Lists completion codes from which you select if your alert condition calls for monitoring a specific completion code.</td>
</tr>
<tr>
<td>Operator</td>
<td>Lists available logic operators. A logic operator, such as &gt; (greater than) and &lt; (less than), is used to build your conditional statement.</td>
</tr>
<tr>
<td>Value</td>
<td>Identifies the value for the conditional statement. Enter the value that you want the system to test for when evaluating the conditional statement. For example, in this conditional statement: “Current Talk Time &gt; 5 minutes”, the value is 5.</td>
</tr>
</tbody>
</table>

### Alert Editor, Scope tab field descriptions

The Scope tab allows you to make the dialer monitor only a specific parameter. For example, if you only want your alert to track a specific agent, use the Scope tab to specify which agent to monitor.
Alert Editor, Notifications tab field descriptions

The Notifications tab allows you to specify how you want the dialer to alert you. The dialer can alert you only if the Monitor is running at the time when the alert condition is met.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dialer</td>
<td>Lists the dialers for which you can set an alert. Select Any Dialer (Proactive Contact monitors all dialers) or a specific dialer from the list.</td>
</tr>
<tr>
<td>Job</td>
<td>Lists the jobs for which you can set an alert. Select Any Job (Proactive Contact monitors all jobs) or a specific job from the list.</td>
</tr>
<tr>
<td>Agent</td>
<td>Lists the agents for whom you can set an alert. Select All Agents (the Proactive Contact monitors all agents) or a specific agent from the list.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display alert</td>
<td>Displays a pop-up dialog box on your computer screen to notify you.</td>
</tr>
<tr>
<td>Sound alert</td>
<td>Plays an audible sound from your computer to notify you.</td>
</tr>
<tr>
<td>Send e-mail</td>
<td>Sends you an email message. If this option is unavailable, open Microsoft Outlook and set it as your default email client. If Send e-mail is available and you want to receive an email notification, type your email address in the To... box.</td>
</tr>
</tbody>
</table>
Chapter 31: Analyst

Analyst generates call management reports with job, agent, and system details based on the activities of Proactive Contact.

🌟 Note:
To view some of the reports in Analyst, you might need to configure some parameters in the backend file, `master.cfg`. To configure these parameters, contact Avaya Professional Services.

Multitenancy in Analyst

With the introduction of multitenancy, as a Supervisor, you can view reports applicable only to your tenant space in the Analyst module. If you belong to multiple tenancies, then you can switch between tenancies without logging out of the Analyst module. Also, you can view a combined report for the data across all tenants to which you belong. As a Supervisor, you can use only those hierarchy filters that belong to the tenant.

🌟 Note:
You cannot modify data in runtime environment and use tools such as alerts and hierarchy manager when you choose to view data for all the tenants.

The Lead Administrator can, however, view reports for all the tenants. For this ability, the Tenant Administrator must provide the sufficient permission to the Lead Administrator user in the tenancy.

To support the administration of tenants in a multitenancy environment, some new reports have been introduced.

Analyst Toolbar

The following table contains information about the Analyst toolbar options and their description.
New report configuration data

You can also right-click in the main pane of Analyst and gain access to the following options: New, Delete, Change, Preview, Print, and Scheduler.

You can create reports on the basis of the data available for your selected tenant:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Grouping</td>
<td>The indentation and the hierarchical layout of the report data.</td>
</tr>
<tr>
<td>Time frame</td>
<td>The desired time period of the report.</td>
</tr>
<tr>
<td>Filtering</td>
<td>The specific information to include in the report.</td>
</tr>
<tr>
<td>Title</td>
<td>The report identifier in the list of report configurations.</td>
</tr>
<tr>
<td>Completion codes</td>
<td>Completion code information included in the Completion Code Summary reports. This option is available only for the Completion Code Summary reports in these categories:</td>
</tr>
<tr>
<td></td>
<td>• Agent</td>
</tr>
</tbody>
</table>

Table continues…
Creating a new report configuration

About this task
To create a new report configuration:

Procedure
1. Select a report category on the button bar.
2. Select a report.
3. Select Reports > New or right-click in the right pane and select New.

   The system displays the Analyst Report Wizard. The Report Wizard guides you through the configuration process.

   ✪ Tip:
   You can have only one Report Wizard running at a time.

4. Complete the wizard as follows:
   a. In the Data Group page, specify the following:
      • First, Group by
      • Second, Group by (Optional)
      • Third, Group by (Optional)

         ✪ Note:
         The Group by options vary as per the selected report. If a job is using Job Unit ID as one of the parameters, then while generating Analyst reports, you must select Job Unit as one of the grouping criteria on the Data Group page. If you do not select Job Unit as one of the grouping criteria, the report result can show miscalculations.

   b. Click Next.

   c. In the Date Criteria page, specify the following:
      • Date Criteria field
      • Date Range or Criteria
The Date Range or Criteria options vary as per the selected report.

d. Click **Next**.
e. In the Additional Report Criteria page, specify the following:

- Second Criteria Field (Optional)
- Third Criteria Field (Optional)
- Fourth Criteria Field (Optional)
- Fifth Criteria Field (Optional)

For each option specified in the criteria fields, the corresponding value options are displayed to further narrow down your report results. Select the corresponding values for the selected criteria field options. The selected value is displayed in front of the criteria field.

Note:
- For the Agent, Job, and Time of Day reports, the secondary criteria fields on Page 4 of the Analyst new report wizard displays data based on the date criteria selected on Page 3 of the wizard.
- In the Data Group page, if you select a hierarchy branch as a grouping criteria, you must select the hierarchy name on the Additional Report Criteria page. In the Additional Report Criteria pages, if you leave these settings blank, the report data is not filtered.
- Select up to 14 completion codes for the Completion Code Summary reports.

f. Click **Next**.
g. Enter a name for the report in the **Report title** field.
h. To preview the report, click **Preview**.
i. Click **Finish** to generate the report.

To go back to the previous screen in the wizard, click **Back**.

5. To view the report, double-click the report name in the Activity pane.

---

**Deleting a report configuration**

**About this task**

To delete an Analyst report configuration:

**Procedure**

1. Select a report category on the button bar.
2. Select a report.
3. Select a report configuration.
4. Select Reports > Delete or right-click in the right pane and select Delete.
5. Click Yes to delete the report configuration, or click No to close the dialog box without deleting the report configuration.

---

### Changing a report configuration

**About this task**
To modify an existing report configuration:

**Procedure**

1. Select a report category on the button bar.
2. Select a report.
3. Select a report configuration.
4. Select Reports > Change or right-click in the right pane and select Change.
   - The system displays the Analyst Report Wizard, pre-populated with the existing report criteria.
5. Follow the instructions in the Report Wizard to change the report criteria.

---

### Previewing a report

**About this task**
To preview a report:

**Procedure**

1. Select a report category on the button bar.
2. Select a report.
3. Select a report configuration.
4. Select Reports > Preview or right-click in the right pane and select Preview.
   - Analyst displays the report in a new window. In this window, you can:
     - Print the report
     - Set the printer properties
     - Refresh the report data
     - Export the report data
     - Toggle the group tree outline
Printing a report from the menu

About this task
To print a report from the menu:

Procedure
1. Select a report category on the button bar.
2. Select a report.
3. Select a report configuration.
4. Select Reports > Print or right-click in the right pane and select Print.
5. Select the number of copies you want to print.
6. Click OK.

The system prints the report to your default printer.

Tip:
Before printing a report, ensure that the printer properties, such as portrait or landscape orientation, are set correctly.

Printing a report from the preview window

About this task
To print a report from the preview window:

Procedure
1. Click the Printer Setup icon.
   The system displays the Print Setup dialog for your default printer.
2. Click Properties...
3. Verify the settings for your printer.
4. Click OK.
5. Click OK again.
6. Click the Print icon.
7. Select the page range, number of copies, and collation option.
8. Click **OK**.
   The system prints the file to your default printer.

---

**Exporting report data**

**About this task**

Export report data to use or view in a different application:

**Procedure**

1. Select a report category on the button bar.
2. Select a report.
3. Select a report configuration.
4. Select **Reports > Preview** or double-click the report configuration.
   
   Analyst displays the report in a new window.
5. Click **Export** in the report window.
6. From the Format list, select a format.
7. From the Destination list, select a destination.
8. Click **OK**.
   
   Depending on the format and destination chosen, the system displays a series of dialog boxes containing options for exporting the report data.

**Note:**

Currently, exporting the report data to the PDF and Word for Windows document formats are not supported. Exporting the report data in Excel 8.0 (XLS) and Excel 8.0 (XLS) (Extended) is not supported for the Korean, Chinese, and Russian languages.

9. In each dialog box, verify that the correct information is selected.
10. Click **OK** to move to the next dialog box, until the data is exported.

**Supported export formats**

The following export formats are supported by Avaya Proactive Contact Analyst:

<table>
<thead>
<tr>
<th>Export format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CrystalReport</td>
<td>Export format of the report is a Crystal Report (RPT) file.</td>
</tr>
<tr>
<td>Excel</td>
<td>Export format of the report is a Microsoft Excel (97-2003) file.</td>
</tr>
<tr>
<td>ExcelRecord</td>
<td>Export format of the report is a Microsoft Excel (97-2003) Data-Only file.</td>
</tr>
<tr>
<td>HTML32</td>
<td>Export format of the report is an HTML 3.2 file.</td>
</tr>
</tbody>
</table>

*Table continues*
### Export format

<table>
<thead>
<tr>
<th>Export format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTML32</td>
<td>Note: If you select HTML32 as the export format, then MAPI and Exchange folder destination types are not available.</td>
</tr>
<tr>
<td>HTML40</td>
<td>Export format of the report is an HTML 4.0 file. Note: If you select HTML40 as the export format, then MAPI and Exchange folder destination types are not available.</td>
</tr>
<tr>
<td>PortableDocFormat</td>
<td>Export format of the report is a PDF file.</td>
</tr>
<tr>
<td>RichText</td>
<td>Export format of the report is a Rich Text Format (RTF) file.</td>
</tr>
<tr>
<td>WordForWindows</td>
<td>Export format of the report is a Microsoft Word (97-2003) file.</td>
</tr>
<tr>
<td>CharacterSeparatedValue</td>
<td>CSV format. To retain the formatting of the report as it appears on the Analyst application, ensure to select the following options while exporting the report:</td>
</tr>
<tr>
<td></td>
<td>• Under the Report and Page sections, select the <strong>Do not export</strong> option.</td>
</tr>
<tr>
<td></td>
<td>• Under the Group sections, select <strong>Export &gt; Isolate Group sections</strong> option.</td>
</tr>
<tr>
<td>EditableRTF</td>
<td>Microsoft Word - Editable (RTF)</td>
</tr>
<tr>
<td>ExcelWorkbook</td>
<td>Microsoft Excel Data-only is a record-based format that is useful for data transfer.</td>
</tr>
<tr>
<td>TabSeparatedText</td>
<td>Tab Separated Text format is similar to the Text format except that unlike in the Text format, multi-line objects are exported to a single line.</td>
</tr>
<tr>
<td>Text</td>
<td>Export format of the report is a text file.</td>
</tr>
<tr>
<td>XML</td>
<td>Export format of the report is a XML file.</td>
</tr>
<tr>
<td>RPTR</td>
<td>Crystal Reports Read-Only (RPTR)</td>
</tr>
</tbody>
</table>

**Note:**

You can customize the reports according to the options provided for exporting the report with each export format.

### Supported destination types

The following destination types are supported by Proactive Contact Analyst:

<table>
<thead>
<tr>
<th>Destination type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DiskFile</td>
<td>If you export to a disk file, the program saves the report to the disk or diskette that you have specified.</td>
</tr>
<tr>
<td>ExchangeFolder</td>
<td>With Crystal Report, you can export a report file to a Microsoft Exchange folder. The report is stored in the specified folder in the specified format. A Microsoft Exchange folder can contain standard notes (mail), files, and instances of Microsoft Exchange forms.</td>
</tr>
<tr>
<td>Microsoft Mail (MAPI)</td>
<td>This option works only if you have a mail client installed (Microsoft Outlook, Microsoft Mail, or Exchange) and an email account configured properly. This is because the exported report is sent as an attachment to email message.</td>
</tr>
</tbody>
</table>
Scheduling a report

About this task

To schedule a time to print a report automatically:

Procedure

1. Select a report category on the button bar.
2. Select a report.
3. Select a report configuration.
4. Select Reports > Scheduler or right-click in the right pane and select Scheduler.
5. In the Scheduler dialog box, select the frequency option to specify how often you want to print the report.

☆ Note:

If you select the Weekly or Monthly option, the report prints on Monday only. Use Task Scheduler, available from the Windows Control Panel, to select a different day of the week. The settings you specify in Task Scheduler override the Analyst schedule settings.

6. Select a start time.

☆ Note:

The current release of Proactive Contact supports scheduling only for the absolute time for the hourly scheduled activity. For example, if a Supervisor wants to schedule a job run starting at 10:30 AM and then run the job after every 3 hours until 7:00 PM, the supervisor cannot schedule the job run to start at 10:30 AM. The Supervisor can set the start time to absolute values such as 9:00 AM, 10:00 AM, or 11:00 AM.

7. Click OK.

✦ Tip:

After you have scheduled a report, you can view your scheduled reports in the Windows Task Scheduler at the following location: Start > Control Panel > Administrative Tools > Task Scheduler.

Scheduling reports after logging off from Windows

About this task

To run scheduled reports after you log off from Windows:

Procedure

1. Go to Start > Control Panel > Scheduled Tasks.
2. Select Scheduled report task, right-click and select Properties.
The Scheduled report task information is displayed.

3. Clear the Run only if logged on check box.

The Set password button is enabled.

4. Click Set password and provide password.

5. Click Apply.

---

### Viewing data of deleted tenants

**About this task**

To view the data of deleted tenants in the Analyst application:

**Procedure**

1. Log in to the Analyst application.

2. Go to Settings > Deleted tenants.

   If you have deleted tenants, then the system displays the list of those tenants in the drop-down box on the left.

3. Select the deleted tenant for which you need the data.

   You can view the data for the deleted tenant.

---

### Window arrangement overview

Using Proactive Contact, you can customize the display of Analyst windows and navigate through various tools that you can use while generating reports in Analyst.

The Analyst window displays report configurations and summary information of the options that were selected in the Reports Wizard.

The Analyst window is divided into a button bar on the left pane and a main pane on the right. The main pane is blank until you click a selection in the button bar. The Analyst button bar contains report categories. By clicking the buttons in the button group headings, you can move among various available reports.

You can expand and contract the button bar. When you click the heading of a button group, you expand the group so that its buttons are visible. You can resize the button bar.

You can click the column headings to sort the contents of the column. When you click a heading, you see a small arrow appear alongside the heading. If the small arrow is pointing up, it indicates that you are sorting the column in the ascending order. If the small arrow is pointing down, it indicates that you are sorting the column in the descending order.
You can resize any column in the main pane by hovering your cursor between the heading titles until a double-arrow appears. Hold down the left mouse button and drag the cursor to resize the columns to the desired width.

---

**Navigating among the Tool menu applications**

**About this task**

Analyst comes with the tool applications that you can gain access from the Tools menu. Perform the following procedure to start the Tools menu applications:

**Procedure**

1. Select **Start > All Programs > Avaya Proactive Contact > Supervisor > Analyst**.
2. To start a tool, select its name from the Tools menu. While you use the tool, Analyst remains open in the background so that you can navigate back to it when you are finished using the tool.

---

**Using large icons or small icons on the button bar**

**About this task**

You can switch between the large or small buttons views of the reports icons on the button bar. Perform the following procedure to switch between the large and small icons in the button bar:

**Procedure**

1. On the button bar, click to expand the button group for which you want to change the icon size.
2. Right-click, and then select either **Large Icons** or **Small Icons**. A check mark next to the menu option indicates the view you are using currently.
Chapter 32: Analyst reports

Report categories

Analyst reports help in analyzing your contact center data.

Analyst reports contain the following categories:

- Agent
- Job
- Time of Day
- Administrative
- Agent Monthly
- Job Monthly
- Time of Day Monthly

Related links

Field reference for Crystal reports SQL Expressions on page 450

Report categories descriptions

<table>
<thead>
<tr>
<th>Report category</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent reports</td>
<td>Agent reports display the statistics on the work time and the performance of an agent. Examples of the work time statistics are total work, update, and idle time. Performance statistics include values, such as total connects and connects per hour.</td>
</tr>
<tr>
<td>Job reports</td>
<td>Job reports display job statistics by job type: inbound, outbound, or blend. These reports include statistics on how the system ran a job, system information on calling activity, and statistics about combined agent activity during a job. Several job report configurations also group statistics by system to accommodate a multi-dialer and multitenancy environment.</td>
</tr>
<tr>
<td>Time of Day reports</td>
<td>Time of Day reports display job information grouped by time intervals. The interval is set when your system is installed.</td>
</tr>
</tbody>
</table>

Table continues…
### Time of Day Monthly

Time of Day Monthly reports display monthly job information grouped by time intervals. The interval is set when your system is installed.

Time of Day Monthly reports evaluate job performance at intervals of:
- 60 minutes
- 30 minutes
- 20 minutes
- 15 minutes
Report category | Description
--- | ---
 | • 10 minutes
 | • 5 minutes

**Tip:**
- Agent Monthly, Job, and Time of Day reports display agent, job, and time of day data respectively. For these reports, all the data is combined, regardless of type.
- For example, if you are viewing an Agent Monthly report, all Job types are combined together.

Because the data is combined, you must consider the different types of Jobs that ran during the roll-up period. For example, if Outbound and Managed jobs ran, you must consider that the Connects statistic represents different data for each job type.

---

**Managed Dialing reports**

These report categories include reports available for the Managed Dialing jobs:

- Agent
- Job
- Time of Day
- Agent Monthly
- Job Monthly
- Time of Day Monthly

Analyst handles connect and online time statistics for Managed Dialing jobs differently than it does for Outbound, Inbound, and Blend jobs. The following table summarizes the differences:

<table>
<thead>
<tr>
<th>Statistic</th>
<th>Outbound, Inbound or Blend job</th>
<th>Managed Dialing job</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connect</td>
<td>An agent is connected to a call placed by the dialer.</td>
<td>An agent previewed a record and did not cancel the call.</td>
</tr>
<tr>
<td>Online time</td>
<td>Amount of time an agent waited for connects, talked to customers, and updated records.</td>
<td>Job online time plus the time an agent previewed records.</td>
</tr>
</tbody>
</table>

By default, reports for Outbound, Inbound, and Blend jobs do not contain statistics for Managed Dialing jobs. These reports contain criteria to include statistics where the Job Type is Outbound (OUT), Inbound (INB), or Blend (BLND).

If you want a report to include Managed Dialing statistics and Outbound, Inbound, and Blend statistics, remove the Job Type condition and the associated values on Page 4 of the Report Wizard.
Tip:

Online time and connect statistics might be skewed on a report that includes both Managed Dialing and Outbound, Inbound, and Blend job statistics. The skew occurs because of the differences in the way those statistics are calculated.

---

Completion Code Summary reports

The Completion Code Summary reports are available in all report categories except in the Administrative reports. The Completion Code Summary reports contain statistics for up to 14 completion codes that the agents can use during the jobs. You can specify the codes that appear on the report.

For the Completion Code Summary reports, the last page of Avaya Report Wizard contains a Select... button. When you click this button, the system displays a dialog box from which you can select up to 14 codes.

In the report, the completion code descriptions appear in a three-line column. You can consider modifying long descriptions so that they are more understandable when you view the report. For example, possible abbreviations for description text Promise to Pay include Prom to Pay or PTP.

Use the Completion Code menu to define the description text. For instructions on managing completion codes, see the Completion Code menu online help.

---

Reports per category

This section describes reports for each report category as defined in Report categories. Each description includes:

- The available reports including data fields contained in each report.
- The available variations of each report.

Note:

The reports described in this section are the pre-defined reports included with Analyst. You can add new reports, modify existing reports, or delete reports at your discretion.
## Agent reports

### Available Agent reports

The following table provides information on the reports included in the Agent reports category, the associated parameters by which you can group the data for generating the reports, and the data fields included in the reports:

**Note:**

When the Autorelease to agent feature is enabled, then the AMD calls that are auto-disconnected by the system after connecting to an agent are not considered as connected. However, the time taken by the agent to handle the call is added to the agent work time.

By default, the crystal report in Analyst calculates the Job Run Week as the first week of the year, that is, the week that begins with January 1st and treats Sunday as the first day of the week.

<table>
<thead>
<tr>
<th>Report Title</th>
<th>Grouped By</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td>Agent ID, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, System Name, Tenant Name</td>
<td>Date Session activity: Log in Time, Logout Time, System Time, System Name Job activity: Log in Time, Logout Time, Session Time, Job Number, Job Name</td>
</tr>
<tr>
<td>Managed Dialing Summary</td>
<td>Agent ID, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Tenant Name</td>
<td>First Log in, Last Logout, Online + Preview Time, Records Previewed, Previews per Hour, Records Canceled, Closes per Hour, Average Preview Time, Average Work Time, Records Worked, Records Worked per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate</td>
</tr>
<tr>
<td>Performance Summary</td>
<td>Agent ID, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Tenant Name</td>
<td>First Log in, Last Logout, Online Time, Connects, Connects per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate, Outbound Allocation, Inbound Allocation, PTP Allocation, Manual Calls, Manual Call Rate</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Report Title</th>
<th>Grouped By</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Completion Code Distribution</td>
<td>Agent ID, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Tenant Name</td>
<td>Completion Codes</td>
</tr>
<tr>
<td>Completion Code Summary</td>
<td>Agent ID, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Tenant Name</td>
<td>First Log in, Last Logout, Online Time, Connects, Connects per Hour, Custom Use Codes</td>
</tr>
<tr>
<td>Time Summary</td>
<td>Agent ID, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Tenant Name</td>
<td>First Log in, Last Logout, Online Time, Outbound: Online Time, Connects, Connects per Hour, Average Talk Time, Average Update Time, Average Idle Time Inbound: Online Time, Connects, Connects per Hour, Average Talk Time, Average Update Time, Average Idle Time</td>
</tr>
</tbody>
</table>

**Note:**

- If a job is using Job Unit ID as one of the parameters, then while generating Analyst reports, you must select **Job Unit** as one of the grouping criteria on the wizard. If you do not select **Job Unit** as one of the grouping criteria, then the report result may show miscalculations.
- If the system has Hierarchy created, you must select **Hierarchy** as grouping criteria in Analyst.
- The first log in and the last log out time for an agent are displayed as the first log in time and the last log out time irrespective of the number of units they log into. For example, if an agent logs into unit1 and unit2 at 11 AM and logs out from them at 11:30 AM, and again logs into unit3 and unit4 belonging to the same job at 1 PM and logs out at 1:30 PM, the log in and log out time for all the units is displayed as 11 AM and 1:30 PM respectively.
Agent Report variations

All Agent reports provide the following variations:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Today</td>
<td>Job Run Date is equal to today</td>
</tr>
<tr>
<td>Yesterday</td>
<td>Job Run Date is equal to yesterday</td>
</tr>
<tr>
<td>Week To Date</td>
<td>From the last Sunday to today. For example, if the report is run on a Tuesday, the report will include data for Sunday, Monday, and Tuesday.</td>
</tr>
<tr>
<td>Month To Date</td>
<td>Job Run Date includes the data from the month to date. For example, if the report is run on the 10th of the month, then the report includes the data from the 1st of the month to the 10th of the month.</td>
</tr>
<tr>
<td>Last 7 days</td>
<td>The last 7 days starting from the present day. For example, if the report is run on Tuesday, the report will include data from last's week's Monday to the present day, that is Tuesday.</td>
</tr>
<tr>
<td>Last full week</td>
<td>From Sunday to Saturday for the last completed week. For example, if the report is run on Tuesday, the report will include data from last week's Sunday to the last week's Saturday</td>
</tr>
<tr>
<td>Year to date</td>
<td>Report shows data from 1st January to today. For example, if the report is run on 10th March, 2010, then the report will include data from the 1st January 2010 till 10th March, 2010.</td>
</tr>
<tr>
<td>Last full month</td>
<td>Report shows data for last full month. For example, if user runs report for last full month on 03 February 2010. It will show data from 1st January to 31st January 2010.</td>
</tr>
<tr>
<td>Existing date in the database</td>
<td>Report shows data for all the existing job run dates available in the database. You can select dates for which you wants to run the report.</td>
</tr>
</tbody>
</table>

Job Reports

Available Job reports

The following table provides information on the reports included in the Job reports category, the associated parameters by which you can group the data for generating the reports, and the data fields included in the reports:
**Note:**

By default, the crystal report in Analyst calculates the Job Run Week as the first week of the year, that is, the week that begins with January 1st and treats Sunday as the first day of the week.

<table>
<thead>
<tr>
<th>Report Title</th>
<th>Grouped By</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Completion Code Configuration</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Tenant Name</td>
<td>Code Number, Is RPC, Is Abandon, Is Closure, System Name, Job Number, Job Name</td>
</tr>
<tr>
<td>Managed Dialing Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Tenant Name</td>
<td>First Start, Last End, Online + Preview Time, Records Previewed, Previews per Hour, Records Canceled, Cancels per Hour, Average Preview Time, Average Work Time, Records Worked, Worked per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate</td>
</tr>
<tr>
<td>Performance Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Tenant Name</td>
<td>First Start, Last End, Online Time, Records Selected, Calls Placed, Calls Offered, Connects, Connects per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate, Manual Calls, Manual Call Rate</td>
</tr>
<tr>
<td>Completion Code Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Tenant Name</td>
<td>Custom Use Codes</td>
</tr>
<tr>
<td>Time Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job</td>
<td>Outbound: Online Time, Calls Placed, Connects, Connects per Hour, Average Queue Time, Calls</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Report Title</th>
<th>Grouped By</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Tenant Name</td>
<td>Abandoned, Average Talk Time, Average Update Time, Average Idle Time</td>
</tr>
<tr>
<td>Quality Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Tenant Name</td>
<td>First Start, Last End, Online Time, Calls Placed, Calls Offered, Connects, Connects per Hour, Serviced Calls, Desired Service Level, Actual Service Level, Connect Tolerance, Nuisance Count, Nuisance Rate, Calls to Queue, Average Queue Time, CCM Abandon Rate</td>
</tr>
<tr>
<td>Non-contact And Error Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Tenant Name</td>
<td>Calls Placed, Connects Errors: Miscellaneous Errors, No Dial Tone, Agent Session Failed</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Virtual: Code 91, Code 92 Special Information Tones: Intercept, No Circuit, Disconnected, Vacant, Re-order</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Non-Connects: Busy, No Answer, Voice Mail, Fax/Modem Outbound HU/Abandoned, Inbound HU/Abandoned, All Other</td>
</tr>
<tr>
<td>OFCOM</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Tenant Name</td>
<td>Calls Placed, Calls offered, Connect, CONNEXPIRE, Out Connect, Aban rate, ACR Excl Calls, Short Calls</td>
</tr>
<tr>
<td>FCC</td>
<td>System Name, Job Name, Job Data range, Tenant Name</td>
<td>Calls Placed, Out Calls offered, Out Connect, Start Date, End date, FCC nuisance count, FCC nuisance rate</td>
</tr>
<tr>
<td>Manual Dialing Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Tenant Name</td>
<td>First Start, Last End, Online + Preview Time, Records Previewed, Previews per Hour,</td>
</tr>
</tbody>
</table>

Table continues…
You must note the following:

- In blend jobs, OFCOM calculation includes only the Outbound Connects. Inbound calls are not a part of the calculation.

- If a job is using Job Unit ID as one of the parameters, then while generating Analyst reports, you must select Job Unit as one of the grouping criteria on the wizard. If you do not select Job Unit as one of the grouping criteria, then the report result may show miscalculations.

- If you choose Job Unit as one of the Group by field parameters, then the Section Summary and Report summary values in the Records Selected column of the Performance Summary report are displayed as blank.

- The first log in and last log out time for an agent are displayed as the first log in time and the last log out time irrespective of the number of units they log into. For example, if an agent logs into unit1 and unit2 at 11 AM and logs out from them at 11:30 AM, and again logs into unit3 and unit4 belonging to the same job at 1 PM and logs out at 1:30 PM, the log in and log out time for all the units is displayed as 11 AM and 1:30 PM respectively.

**Job Report variations**

All Job reports provide the following variations:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Today</td>
<td>Job Run Date is equal to today</td>
</tr>
<tr>
<td>Yesterday</td>
<td>Job Run Date is equal to yesterday</td>
</tr>
<tr>
<td>Week To Date</td>
<td>From the last Sunday to today. For example, if the report is run on a Tuesday, the report will include data for Sunday, Monday, and Tuesday.</td>
</tr>
<tr>
<td>Month To Date</td>
<td>Job Run Date is from the month to date</td>
</tr>
<tr>
<td>Last 7 days</td>
<td>The last 7 days starting from the present day. For example, if the report is run on Tuesday, the report will include data from last's week's Monday to the present day, that is Tuesday.</td>
</tr>
<tr>
<td>Last full week</td>
<td>From Sunday to Saturday for the last completed week. For example, if the report is run on Tuesday, the report will include data from last week's Sunday to the last week's Saturday</td>
</tr>
</tbody>
</table>

Table continues…”
Reports per category

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Year to date</td>
<td>Report shows data from 1st January to today. For example, if the report is run on 10th March, 2010, then the report will include data from the 1st January 2010 till 10th March, 2010.</td>
</tr>
<tr>
<td>Last full month</td>
<td>Report shows data for last full month. For example, if user runs report for last full month on 03 February 2010. It will show data from 1st January to 31st January 2010.</td>
</tr>
<tr>
<td>Existing date in the database</td>
<td>The report shows data for all the existing job run dates available in the database. Select dates for which you want to run the report.</td>
</tr>
</tbody>
</table>

### Time of Day Reports

#### Available Time of Day reports

The following table provides information on the reports included in the Time of Day reports category, the associated parameters by which you can group the data for generating the reports, and the data fields included in the reports:

**Note:**

By default, the crystal report in Analyst calculates the Job Run Week as the first week of the year, that is, the week that begins with January 1st and treats Sunday as the first day of the week.

<table>
<thead>
<tr>
<th>Report Title</th>
<th>Grouped by</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Managed Dialing Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Time Segment, Tenant Name</td>
<td>First Start, Last End, Online + Preview Time, Records Previewed, Previews per Hour, Records Canceled, Cancels per Hour, Average Preview Time, Average Work Time, Records Worked, Worked per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate</td>
</tr>
<tr>
<td>Performance Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Time Segment, Tenant Name</td>
<td>First Start, Last End, Online Time, Records Selected, Calls Placed, Calls Offered, Connects, Connects per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate, Manual Calls, Manual Call Rate</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Report Title</th>
<th>Grouped by</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Completion Code Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Time Segment, Tenant Name</td>
<td>Custom Use Codes</td>
</tr>
<tr>
<td>Time Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Time Segment, Tenant Name</td>
<td>Outbound: Online Time, Calls Placed, Connects, Connects per Hour, Average Queue Time, Calls Abandoned, Average Talk Time, Average Update Time, Average Idle Time Inbound: Online Time, Connects, Connects per Hour, Average Queue Time, Calls Abandoned, Average Talk Time, Average Update Time, Average Idle Time</td>
</tr>
<tr>
<td>Quality Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Time Segment, Tenant Name</td>
<td>First Start, Last End, Online Time, Calls Placed, Calls Offered, Connects, Connects per Hour, Serviced Calls, Desired Service Level, Actual Service Level, Connect Tolerance, Nuisance Count, Nuisance Rate, Calls to Queue, Average Queue Time, CCM Abandon Rate</td>
</tr>
<tr>
<td>Non-contact And Error Summary</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Time Segment, Tenant Name</td>
<td>Calls Placed, Connects Errors: Miscellaneous Errors, No Dial Tone, Agent Session Failed Virtual: Code 91, Code 92 Special Information Tones: Intercept, No Circuit, Disconnected, Vacant, Re-order Non-Connects: Busy, No Answer, Voice Mail, Fax/Modem Outbound</td>
</tr>
</tbody>
</table>

Table continues…
You must note the following:

- In blend jobs, OFCOM calculation includes only the Outbound Connects. Inbound calls are not a part of the calculation.

- If a job is using Job Unit ID as one of the parameters, then while generating Analyst reports, you must select Job Unit as one of the grouping criteria on the wizard. If you do not select Job Unit as one of the grouping criteria, then the report result may show miscalculations.

- If you choose Job Unit as one of the Group by field parameters, then the Section Summary and Report summary values in the Records Selected column of the Performance Summary report are displayed as blank.

- The first log in and last log out time for an agent are displayed as the first log in time and the last log out time irrespective of the number of units they log into. For example, if an agent logs into unit1 and unit2 at 11 AM and logs out from them at 11:30 AM, and again logs into unit3 and unit4 belonging to the same job at 1 PM and logs out at 1:30 PM, the log in and log out time for all the units is displayed as 11 AM and 1:30 PM respectively.

### Time of Day Report variations

All Time of Day reports provide the following variations:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Today</td>
<td>Job Run Date is equal to today</td>
</tr>
<tr>
<td>Yesterday</td>
<td>Job Run Date is equal to yesterday</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Week To Date</td>
<td>From the last Sunday to today. For example, if the report is run on a Tuesday, the report will include data for Sunday, Monday, and Tuesday.</td>
</tr>
<tr>
<td>Month To Date</td>
<td>Job Run Date is from the month to date</td>
</tr>
<tr>
<td>Last 7 days</td>
<td>The last 7 days starting from the present day. For example, if the report is run on Tuesday, the report will include data from last week's Monday to the present day, that is Tuesday.</td>
</tr>
<tr>
<td>Last full week</td>
<td>From Sunday to Saturday for the last completed week. For example, if the report is run on Tuesday, the report will include data from last week's Sunday to the last week's Saturday.</td>
</tr>
<tr>
<td>Year to date</td>
<td>Report shows data from 1st January to today. For example, if the report is run on 10th March, 2010, then the report will include data from the 1st January 2010 till 10th March, 2010.</td>
</tr>
<tr>
<td>Last full month</td>
<td>Report shows data for last full month. For example, if user runs report for last full month on 03 February 2010. It will show data from 1st January to 31st January 2010.</td>
</tr>
<tr>
<td>Existing date in the database</td>
<td>The report shows data for all the existing job run dates available in the database. Select dates for which you want to run the report.</td>
</tr>
</tbody>
</table>

### Administrative Reports

#### Available Administrative reports

The Administrative reports category contains the following reports and data fields:

<table>
<thead>
<tr>
<th>Report Title</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent Hierarchies</td>
<td>Agent: Top Level, Middle Level, Bottom Level, Agent ID</td>
</tr>
<tr>
<td></td>
<td>Super/Agent: Top Level, Middle Level, Bottom Level, Agent ID</td>
</tr>
<tr>
<td>System Hierarchies</td>
<td>Top Level, Middle Level, Bottom Level, System Name</td>
</tr>
<tr>
<td>Job Hierarchies</td>
<td>Top Level, Middle Level, Bottom Level, Job Name</td>
</tr>
<tr>
<td>Monthly Data Roll-up Status</td>
<td>Month Beginning, Agent Tables, Job Tables, TD Tables</td>
</tr>
<tr>
<td>Tenant Line Usage</td>
<td>Peak Line Usage, Total Tenant Lines, Line Usage Rate, Tenant Name</td>
</tr>
</tbody>
</table>

Table continues…
If you belong to more than one tenant space and create a hierarchy with the same name in those tenants, then if you select All tenants for the Agent Hierarchies and system Hierarchies reports, the data for all those hierarchies is merged.

### Agent Monthly Reports

#### Available Agent Monthly reports

The following table provides information on the reports included in the Agent Monthly reports category, the associated parameters by which you can group the data for generating the report, and the data fields included in the reports:

By default, the crystal report in Analyst calculates the Job Run Week as the first week of the year, that is, the week that begins with January 1st and treats Sunday as the first day of the week.

<table>
<thead>
<tr>
<th>Report Title</th>
<th>Grouped by</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monthly Managed Dialing Summary</td>
<td>Agent ID, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name, Tenant Name</td>
<td>First Log in, Last Logout, Online + Preview Time, Records Previewed, Previews per Hour, Records Cancelled, Cancels per Hour, Average Preview Time, Average Work Time, Records Worked, Worked per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate</td>
</tr>
<tr>
<td>Monthly Performance Summary</td>
<td>Agent ID, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name, Tenant Name</td>
<td>First Log in, Last Logout, Online Time, Connects, Connects per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate, Outbound Allocation, Inbound Allocation, PTP Allocation, Manual Calls, Manual Call Rate</td>
</tr>
<tr>
<td>Monthly Completion Code Summary</td>
<td>Agent ID, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name, Tenant Name</td>
<td>First Log in, Last Logout, Online Time, Connects, Connects per Hour, Custom Use Codes</td>
</tr>
</tbody>
</table>
Agent Monthly Report variations

All the Agent Monthly reports provide the following variation:

<table>
<thead>
<tr>
<th>Variation</th>
<th>Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>Existing date in the database</td>
<td>The report shows data for all the existing job run dates available in the database. Select dates for which you want to run the report.</td>
</tr>
</tbody>
</table>

Job Monthly Reports

Available Job Monthly reports

The following table provides information on the reports included in the Job Monthly reports category, the associated parameters by which you can group the data for generating the reports, and the data fields included in the reports.

By default, the crystal report in Analyst calculates the Job Run Week as the first week of the year, that is, the week that begins with January 1st and treats Sunday as the first day of the week.
<table>
<thead>
<tr>
<th>Report Title</th>
<th>Grouped by</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monthly Performance Summary</td>
<td>Job Name, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name, Tenant Name</td>
<td>First Start, Last End, Online Time, Records Selected, Calls Placed, Calls Offered, Connects, Connects per Hour, RPC, PRC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate, Manual Calls, Manual Call Rate</td>
</tr>
<tr>
<td>Monthly Completion Code Summary</td>
<td>Job Name, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name, Tenant Name</td>
<td>Custom Use Codes</td>
</tr>
<tr>
<td>Monthly Time Summary</td>
<td>Job Name, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name, Tenant Name</td>
<td>Outbound: Online Time, Calls Placed, Connects, Connects per Hour, Average Queue Time, Calls Abandoned, Average Talk Time, Average Update Time, Average Idle Time</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Inbound: Online Time, Connects, Connects per Hour, Average Queue Time, Calls Abandoned, Average Talk Time, Average Update Time, Average Idle Time</td>
</tr>
<tr>
<td>Monthly Quality Summary</td>
<td>Job Name, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name, Tenant Name</td>
<td>First Start, Last End, Online Time, Calls Placed, Calls Offered, Connects, Connects per Hour, Serviced Calls, Desired Service Level, Actual Service Level, Connect Tolerance, Nuisance Count, Nuisance Rate, Calls to Queue, Average Queue Time, CCM Abandon Rate</td>
</tr>
<tr>
<td>Monthly Non-contact And Error Summary</td>
<td>Job Name, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name, Tenant Name</td>
<td>Calls Placed, Connects Errors: Miscellaneous Errors, No Dial Tone, Agent Session Failed</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Virtual: Code 91, Code 92 Special Information Tones: Intercept, No Circuit, Disconnected, Vacant, Re-order</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Non-Connects: Busy, No Answer, Voice Mail, Fax/Modem Outbound HU/Abandoned, Inbound HU/Abandoned, All Other</td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>Report Title</th>
<th>Grouped by</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>OFCOM</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Calling List, Job Description Label, Job Name, Job Number, Job Phone Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week, Job Script, Job Type, Job Unit, System Name, Tenant Name</td>
<td>Calls Placed, Calls offered, Connect, CONNEXPIRE, Out Connect, Aban rate</td>
</tr>
<tr>
<td>Monthly Manual Dialing Summary</td>
<td>Job Name, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name, Tenant Name</td>
<td>First Start, Last End, Online + Preview Time, Records Previewed, Previews per Hour, Records Canceled, Canceled per Hour, Average Preview Time, Average Work Time, Records Worked, Worked per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate</td>
</tr>
</tbody>
</table>

**Note:**

In blend jobs, OFCOM calculation includes only the Outbound Connects. Inbound calls are not a part of the calculation.

**Job Monthly Report variations**

**Note:**

To enable or modify ACR, exclude the codes in an OFCOM job. To ensure that the “ACR Excl Count” and “Abandon Rate” columns in the Summarized monthly OFCOM reports display the correct information, create a new job instead of adding the codes to an existing job.

All the Job Monthly reports provide the following variation:

<table>
<thead>
<tr>
<th>Variation</th>
<th>Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>Existing date in the database</td>
<td>The report shows data for all the existing job run dates available in the database. Select dates for which you want to run the report.</td>
</tr>
</tbody>
</table>

**Time of Day Monthly Reports**

**Available Time of Day Monthly reports**

The following table provides information on the reports included in the Time of Day Monthly reports category, the associated parameters by which you can group the data for generating the report, and the data fields included in the reports:
**Note:**

By default, the crystal report in Analyst calculates the Job Run Week as the first week of the year, that is, the week that begins with January 1st and treats Sunday as the first day of the week.

<table>
<thead>
<tr>
<th>Report Title</th>
<th>Grouped by</th>
<th>Data Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monthly Managed Dialing Summary</td>
<td>Time Segment, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name, Tenant Name</td>
<td>First Start, Last End, Online + Preview Time, Records Previewed, Previews per Hour, Records Canceled, Cancels per Hour, Average Preview Time, Average Work Time, Records Worked, Worked per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate</td>
</tr>
<tr>
<td>Monthly Performance Summary</td>
<td>Time Segment, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name, Tenant Name</td>
<td>First Start, Last End, Online Time, Records Selected, Calls Placed, Calls Offered, Connects, Connects per Hour, RPC, RPC per Hour, RPC Rate, Closures, Closures per Hour, Closure Rate, Manual Calls, Manual Call Rate</td>
</tr>
<tr>
<td>Monthly Completion Code Summary</td>
<td>Time Segment, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name, Tenant Name</td>
<td>Custom Use Codes</td>
</tr>
<tr>
<td>Monthly Time Summary</td>
<td>Time Segment, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name, Tenant Name</td>
<td>Outbound: Online Time, Calls Placed, Connects, Connects per Hour, Average Queue Time, Calls Abandoned, Average Talk Time, Average Update Time, Average Idle Time Inbound: Online Time, Connects, Connects per Hour, Average Queue Time, Calls Abandoned, Average Talk Time, Average Update Time, Average Idle Time</td>
</tr>
<tr>
<td>Monthly Quality Summary</td>
<td>Time Segment, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name, Tenant Name</td>
<td>First Start, Last End, Online Time, Calls Placed, Calls Offered, Connects, Connects per Hour, Serviced Calls, Desired Service Level, Actual Service Level, Connect Tolerance, Nuisance</td>
</tr>
<tr>
<td>Report Title</td>
<td>Grouped by</td>
<td>Data Fields</td>
</tr>
<tr>
<td>------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Monthly Non-contact And Error</td>
<td>Time Segment, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top</td>
<td>Calls Placed, Connects Errors: Miscellaneous Errors, No Dial Tone, Agent</td>
</tr>
<tr>
<td>Summary</td>
<td>Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System Name,</td>
<td>Session Failed Virtual: Code 91, Code 92 Special Information Tones: Intercept,</td>
</tr>
<tr>
<td></td>
<td>Tenant Name</td>
<td>Disconnected, Vacant, Re-order Non-Connects: Busy, No Answer, Voice Mail,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Fax/Modem Outbound HU/Abandoned, Inbound HU/Abandoned, All Other</td>
</tr>
<tr>
<td>OFCOM</td>
<td>Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy Top Level, Job</td>
<td>Calls Placed, Calls offered, Connect, CONNEXPIRE, Out Connect, Aban rate</td>
</tr>
<tr>
<td></td>
<td>Calling List, Job Description Label, Job Name, Job Number, Job Phone</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Strategy, Job Record Selection, Job Run Date, Job Run Month, Job Run Week,</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Job Script, Job Type, Job Unit, System Name, Tenant Name</td>
<td></td>
</tr>
<tr>
<td>Monthly Manual Dialing Summary</td>
<td>Time Segment, Hierarchy Bottom Level, Hierarchy Middle Level, Hierarchy</td>
<td>First Start, Last End, Online + Preview Time, Records Previewed, Previews</td>
</tr>
<tr>
<td></td>
<td>Top Level, Job Run Date, Job Run Month, Job Run Week, Job Type, System</td>
<td>per Hour, Records Canceled, Cancels per Hour, Average Preview Time,</td>
</tr>
<tr>
<td></td>
<td>Name, Tenant Name</td>
<td>Average Work Time, Records Worked, Worked per Hour, RPC, RPC per Hour,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>RPC Rate, Closures, Closures per Hour, Closure Rate</td>
</tr>
</tbody>
</table>

**Note:**

In blend jobs, OFCOM calculation includes only the Outbound Connects. Inbound calls are not a part of the calculation.

**Time of Day Monthly Report variations**

All the Time of Day Monthly reports provide the following variation:
Report calculations

Abandon Calls

Analyst does not use the Abandon Calls field in the Crystal Dictionaries on the supplied Analyst reports. However, the calculation for Abandon Calls field still exists in the Crystal Dictionaries. You can choose to use the Abandon Calls statistic on a custom report. This section describes the calculation for Abandon Calls.

Analyst calculates the call abandon events by subtracting the number of called party answers, inbound calls, or both from the number of calls handled by agents. For example, outbound calls that result in a live party answer, or inbound calls not handled by an agent are calculated as abandon calls.

This system does not use codes 45 through 49 to calculate abandoned calls as these codes track customer and dialer originated call terminations.

Two abandon rates available in Analyst are: Abandon Rate of Placed and Abandoned Rate of Offered.

- Abandon Rate of Placed: The number of calls abandoned as a percentage of the total calls placed by the system. This statistic is available for outbound and combined statistics, that is outbound and inbound together. In combined statistics, the rate is defined as both outbound and inbound calls abandoned as a percentage of calls placed.

- Abandon Rate of Offered: The number of calls abandoned as a percentage of the total calls available for an agent to work. Calls available are outbound calls that result in a live party answer or inbound calls. This statistic is available for outbound and combined statistics, that is outbound and inbound together. In combined statistics, the rate is both outbound and inbound calls abandoned as a percentage of calls available for an agent to work.

FCC nuisance rate

The Analyst module of the Proactive Contact Supervisor suite features a new report for the FCC nuisance rate. The report calculates the nuisance rate for the duration of 30 days for a job.

This report calculates the FCC nuisance rate for a campaign, for every 30 days period since the job was first run on and after the FCC_ACT_DATE mentioned in master.cfg file on the dialer. You
must specify the date for the FCC_ACT_DATE parameter as the date when the FCC 12-21
amendment takes effect.

For example, if a job starts on 15th March, then the system calculates the nuisance rate for 30
days from 15th March, that is, from 15th March to 13th April. If the same job continues to run after
13th April, then the system calculates the FCC nuisance rate from 14th April for the next 30 days.

By default, the value for the FCC_ACT_DATE parameter is set as the date when you upgrade to
or install the Proactive Contact 5.2 and later dialer.

**Note:**

You can change the date for FCC_ACT_DATE parameter only to a later date.

The formula to calculate the FCC nuisance rate is:

\[
FCC \text{ Nuisance call rate} = \left( \frac{FCC \text{ Nuisance calls}}{\text{Total outbound calls offered}} \right) \times 100
\]

A call is treated as a FCC Nuisance call when any of the following condition is met:

- The Called Party WaitTime \(\geq\) FCC_TIME, before the called party gets connected to an
  agent.
- The completion Code on the outbound call is 48, which indicates that no agent was available
  for the outbound call.
- The completion Code on the outbound call is 46 AND the Called Party WaitTime \(\geq\) 
  FCC_TIME

**Note:**

The completion code 46 indicates that the called party hung up in the outbound wait
queue.

If you run a job that runs past mid-night on the last day of a 30-day period, then the post mid-night
data for that job is included in the previous 30-day report. For example, if you run a job on the
morning of 14th June that runs until the morning of 15th June, then the data of that job is
displayed in the 15th May to 14th June report, and not in the 15th June to 14th July report.

---

**Idle Time**

Analyst stores both standard inbound and outbound idle times and transition time as determined
by the INFOSTAT file. Analyst Crystal Dictionary and Report formulas include transition time in the
idle time numbers. Transition time is included in the dialer as Agent and Job history file
summaries.

Transition time is defined as the time when a blend agent is transitional between outbound call
mode and inbound call mode. The IDLETYPE field of the INFOSTAT file contains an N to indicate
the value is the transition time.

Transition time is considered as non-assigned time. The records process that creates the history
files does not compute non-assigned time. Therefore, neither the dialer character-based history
reports nor Analyst history file-based reports include this data.
Analyst includes transition time data by:

- Checking the CALLTYPE field for a non-assigned idle record.
- Accumulating the non-assigned idle time as either outbound or inbound transition time.

These transition times are added into all idle and online time formulas.

You can remove transition time by editing either the Analyst dictionaries or reports, or both the dictionaries and the reports.

---

**Online Time**

Analyst calculates the online time based on a combination of all idle, talk, manual calls, and update time that an agent spends on a dialer job. Update time is the time an agent spends on the customer record after ending the conversation. The online formulas also include transition time as described in the Idle Time section.

If multiple calls are taken across multiple units, a difference of few seconds in the online time calculation is recorded. The difference of few seconds is also recorded in the online time if the agent has answered calls manually.

---

**Job Active Time**

Job Active Time provides statistics on the duration for which a job ran, from the start of the system till the time you turn off the system. Analyst computes this figure based on the JOBTIME entry in the INFOSTAT files. The JOBTIME entry is the last entry in the file.

If the JOBTIME entry is missing, Analyst computes Job Active Time based on the first time entry and the last time entry in the file.

**Note:**

This statistic is not used for any standard reports.

---

**Agent Logout Time**

Analyst stores a log in and log out entry for each agent on each job. These time entries specify the time when an agent first logs in to a job and the last time when that agent logs out of a job.

The login time is stored by finding the first LOGON entry in the INFOSTAT file for each agent.

The logout time is stored by finding the last record for an agent in the INFOSTAT file. The LOGOFF entry is not used for this calculation because agents often take calls after logoff is requested. Agents take calls after logoff when calls are still pending, but agents have already requested logoff.
Chapter 33: Concepts of SQL Expressions for Analyst

The Analyst reports provide performance data about agents and jobs on Proactive Contact systems. The reports provide different combinations of data grouping and filtering to support your reporting needs.

However, in certain cases you might require customized reports. This section provides information about the SQL Expressions provided with Analyst using which you can create custom reports.

Setup and requirements

To use and customize Analyst reports, you must install:

• Proactive Contact Analyst
• SAP Crystal Reports 2011

⭐ Note:

Crystal Reports Professional is required only if you are creating custom reports or modifying the existing reports.

Benefits of Crystal reports

SQL Expressions that are a part of crystal reports used in analyst reports installed with Proactive Contact Analyst provide access and built-in join logic for all historical performance data available in the database. Available data fields are presented in an easy-to-use and identifiable format.

Crystal reports also provide the following benefits:

**Database connection and authorization built-in**

• Removes the need to configure database drivers.
• Removes the need to administer database user rights.
• Can be used from any disk location on a computer that has Avaya Mid-tier Services installed.
**Metadata named data fields**

- Removes the need to understand and locate vague data table and field names.
- Provides comprehensive listing of all possible data fields available in the historical database.

**Join logic for table relationships built-in**

- Removes the need to understand table relationships and key relationships for historical data schema.
- Allows use of all fields in the dictionary in any combination.

---

**Historical performance data concepts**

The Analyst reports are divided into three main types:

- Job and System Data
- Agent Data
- Time Segment Data

---

**Monthly roll-up reports**

Three additional Crystal Report SQL Expressions provide monthly roll-up summary for Job and System Data, Agent Data, and Time Segment Data. Monthly roll-up data are rows of data created by summarizing all performance data for systems, jobs, and agents over an entire month. For example, in the Agent monthly reports, that is apds-monthagt.rpt, each row for an agent represents all the activities on all the jobs for one month.

Analyst stores monthly roll-up data for up to seven years.

There is a new parameter named as ROLLNCLEAN in the `master.cfg`. The value for this parameter is the number of months. For example, if you want to store the data for three months, then the value of the parameter will be as follows:

ROLLNCLEAN: 3

For example, if the current month is October and you set the value of ROLLNCLEAN parameter to 3, the `db_maintenance` script, that is a database maintenance script, deletes the detailed data older than July, that is, older than three months excluding the current month, that is October.

**Note:**

It is recommended to set the value of ROLLNCLEAN parameter to 3. This indicates that you must run the `db_maintenance` script once every three months. The OFCOM regulation states that you must save data of six months in the database. The users who follow OFCOM regulation are recommended to set the ROLLNCLEAN parameter to 6.

The `db_maintenance` script is designed to delete data for one month on each run. This data is the data prior to the defined number of months in the ROLLNCLEAN parameter in `master.cfg`. If
you have not run the db_maintenance script on the system for more than the number of months defined in ROLLNCLEAN parameter, then you must run the db_maintenance script for each of those months.

Administrative reports
As this SQL Expressions contains administrative tables and fields, do not use this SQL Expressions for custom report creation. Several categories of data within this SQL Expressions are incompatible with each other. Report errors or system query performance issues can occur if you use incompatible data categories on a report.

Elementary and calculated data
SQL Expressions contain fields that represent elementary performance data and calculated performance data.

Elementary Performance Fields - Counts & Times
You can use these fields to create formulas in reports and to create group formulas. These fields are used in the Analyst built-in reports.

Calculated Performance Fields - Averages, Rates & Per-Hour Fields
You can use these fields in reports that do not require formulas. These fields are especially useful for ad-hoc queries and data analysis. These fields are not used in Analyst built-in reports.

The reference tables in this document are divided into data categories and subdivided into Elementary Performance Data and Calculated Performance Data sections. Each section lists the field, the associated report, the type of data, and a brief description of the field.

weighted averages
The important distinction between elementary and calculated fields is whether using them in a report results in non-weighted averages. If you create a formula on a report based on the sum of the Average Talk Time, the resultant value is non-weighted.

For example: a job named quality was run twice in a day: job numbers 55 and 62. Job 55 had 100 calls with an average talk time of 3 minutes, for example: 100 calls / 300 minutes. Job 62 had 1000 calls with an average talk time of 2 minutes, for example: 1000 calls / 500 minutes.

Using the AVERAGE function for these two jobs results in a value of 2.5 minutes. However, if weighted properly by the number of calls on job 62, the AVERAGE is 2.1, for example: 1100 calls / 533 minutes. Therefore, you must use the elementary fields when using group functions in reports and creating your own averages, rates, and per-hour formulas.
Idle count fields

Idle counts are counters for the number of times that an agent goes idle during calling jobs. You can use this count to calculate the average idle time and the rates related to the idle time. Usually, one extra idle count is available than the calls worked during each agent session. The additional count is because an agent is idle before the first call and usually after the last call.

Outbound, Inbound, and Combined fields

Outbound counts, times, and calculations represent all outbound activities regardless of the job type or agent type. For example, an agent logs in to a blend job and takes both outbound and inbound calls. The individual outbound calls are tracked with the outbound fields. The inbound fields are treated in the same manner as the outbound fields.

Combined fields represent the combined total of both outbound and inbound activities.

Guidelines for creating new reports

Avaya does not support modification of Analyst Reports. However, custom reports can be created from the built-in Analyst reports as a starting point. Custom reports cannot be used within the Analyst application or with the Analyst Report Wizard.

Modifying an Analyst built-in report

Procedure

1. Copy report (*.rpt) file from the Analyst\Reports sub-directory to a new location.
2. Remove the read-only attribute from the report file.
3. Open the report file and modify the file as necessary.
4. Save the file.

Creating a new report

Procedure

2. In the Data Explorer dialog box, click **Database field > Database expert**.
3. In Create a new connection, select **Oracle server**.
4. Provide the login information.
5. Link the database tables according to the requirement, and create SQL expression fields.

**Related links**
- [Field reference for Crystal reports SQL Expressions](#) on page 450

---

**Field reference for Crystal reports SQL Expressions**

---

**Admin rollup**

This section provides information on the rollup status of the monthly data.

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Elementary Data:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Rollup Month</td>
<td>apds-adminROLLUP</td>
<td>Number</td>
<td>Roll up the month data.</td>
</tr>
<tr>
<td>Rollup Success TD</td>
<td>apds-adminROLLUP</td>
<td>String</td>
<td>Roll up is successful for the TD table.</td>
</tr>
<tr>
<td>Rollup Success Agent</td>
<td>apds-adminROLLUP</td>
<td>String</td>
<td>Roll up is successful for the agent table.</td>
</tr>
<tr>
<td>Rollup Success Job</td>
<td>apds-adminROLLUP</td>
<td>String</td>
<td>Roll up is successful for the job table.</td>
</tr>
</tbody>
</table>

---

**Agent activity**

This section provides information about the agent activities.

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Elementary Data:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>System Agent</td>
<td>apds-agtACTIVITY</td>
<td>String</td>
<td>Name of an agent.</td>
</tr>
<tr>
<td>System Log in</td>
<td>apds-agtACTIVITY</td>
<td>Number</td>
<td>The time when an agent logged in to the system.</td>
</tr>
<tr>
<td>System Logout</td>
<td>apds-agtACTIVITY</td>
<td>Number</td>
<td>The time when an agent logged out of the system.</td>
</tr>
</tbody>
</table>

*Table continues...*
<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>System Date</td>
<td>apds-agtACTIVITY</td>
<td>Number</td>
<td>The date when an agent logged in to the system.</td>
</tr>
<tr>
<td>Session Log in</td>
<td>apds-agtACTIVITY</td>
<td>Number</td>
<td>The time when an agent logged in to the session.</td>
</tr>
<tr>
<td>Session Logout</td>
<td>apds-agtACTIVITY</td>
<td>Number</td>
<td>The time when an agent logged out of the session.</td>
</tr>
</tbody>
</table>

**Agent codes**

This section provides information about the agent code.

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Code</td>
<td>apds-agtRELDIST</td>
<td>String</td>
<td>Agent Code</td>
</tr>
<tr>
<td>Code Count</td>
<td>apds-agtRELDIST</td>
<td>Number</td>
<td>Total number of agent codes</td>
</tr>
</tbody>
</table>

**Agent hierarchy**

This section provides information about the hierarchy configuration for agents.

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>apds-adminAGTHIER</td>
<td>String</td>
<td>Agent hierarchy name.</td>
</tr>
<tr>
<td>Agent Item</td>
<td>apds-adminAGTHIER</td>
<td>String</td>
<td>Agent ID/name.</td>
</tr>
<tr>
<td>Agent Level 1</td>
<td>apds-adminAGTHIER</td>
<td>String</td>
<td>Agent hierarchy bottom level.</td>
</tr>
<tr>
<td>Agent Level 2</td>
<td>apds-adminAGTHIER</td>
<td>String</td>
<td>Agent hierarchy middle level.</td>
</tr>
<tr>
<td>Agent Level 3</td>
<td>apds-adminAGTHIER</td>
<td>String</td>
<td>Agent hierarchy top level.</td>
</tr>
</tbody>
</table>

**Dialer hierarchy**

This section provides information about the hierarchy configuration for dialers.
### Job hierarchy

This section provides information about the hierarchy configuration for jobs.

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Elementary Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Name</strong></td>
<td>apds-adminJOBHIER</td>
<td>String</td>
<td>Job hierarchy name.</td>
</tr>
<tr>
<td><strong>Job Item</strong></td>
<td>apds-adminJOBHIER</td>
<td>String</td>
<td>Job name.</td>
</tr>
<tr>
<td><strong>Job Level 1</strong></td>
<td>apds-adminJOBHIER</td>
<td>String</td>
<td>Job hierarchy bottom level.</td>
</tr>
<tr>
<td><strong>Job Level 2</strong></td>
<td>apds-adminJOBHIER</td>
<td>String</td>
<td>Job hierarchy middle level.</td>
</tr>
<tr>
<td><strong>Job Level 3</strong></td>
<td>apds-adminJOBHIER</td>
<td>String</td>
<td>Job hierarchy top level.</td>
</tr>
</tbody>
</table>

### Completion codes

This section provides information about the type of completion code number.

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Elementary Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Code Number</strong></td>
<td>apds-jobCOMPCODE</td>
<td>String</td>
<td>Completion code number.</td>
</tr>
<tr>
<td><strong>RPC</strong></td>
<td>apds-jobCOMPCODE</td>
<td>Boolean</td>
<td>The completion code number is RPC.</td>
</tr>
<tr>
<td><strong>Abandon</strong></td>
<td>apds-jobCOMPCODE</td>
<td>Boolean</td>
<td>The completion code number is Abandon.</td>
</tr>
<tr>
<td><strong>Closure</strong></td>
<td>apds-jobCOMPCODE</td>
<td>Boolean</td>
<td>The completion code number is Closure.</td>
</tr>
</tbody>
</table>
# Combined call handling times

Total and average time the agent or agents perform inbound and outbound job activities.

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Elementary Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Online Time (Hours)</strong></td>
<td>apds-agtRELEASE.rpt&lt;br&gt;apds-agtPERF.rpt&lt;br&gt;apds-jobPERF.rpt&lt;br&gt;apds-jobQUALITY.rpt&lt;br&gt;apst-tdjobQUALITY&lt;br&gt;apds-tdjobPERF&lt;br&gt;apds-monthagtRELEASE.rpt&lt;br&gt;apds-monthagtPERF.rpt&lt;br&gt;apds-monthjobPERF&lt;br&gt;apds-monthjobQUALITY&lt;br&gt;apds-monthtdjobQUALITY&lt;br&gt;apds-monthtdjobPERF</td>
<td>Number</td>
<td>Total number of hours for which an agent waited between the inbound and outbound connects, talked to clients, and updated records.</td>
</tr>
<tr>
<td><strong>Online Time (Sec)</strong></td>
<td>apds-agtRELEASE.rpt&lt;br&gt;apds-agtPERF.rpt&lt;br&gt;apds-jobPERF.rpt&lt;br&gt;apds-jobQUALITY.rpt&lt;br&gt;apst-tdjobQUALITY&lt;br&gt;apds-tdjobPERF&lt;br&gt;apds-monthagtRELEASE.rpt&lt;br&gt;apds-monthagtPERF.rpt&lt;br&gt;apds-monthjobPERF&lt;br&gt;apds-monthjobQUALITY&lt;br&gt;apds-monthtdjobQUALITY&lt;br&gt;apds-monthtdjobPERF</td>
<td>Number</td>
<td>Total number of minutes for which an agent waited between inbound and outbound connects, talked to clients, and updated records.</td>
</tr>
<tr>
<td><strong>Calculated Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Average Idle Time (Minutes)</strong></td>
<td>apds-agtTIME.rpt&lt;br&gt;apds-jobTIME.rpt&lt;br&gt;apds-tdjobTIME,</td>
<td>Number</td>
<td>Average number of minutes for which an agent waited between</td>
</tr>
<tr>
<td>Field</td>
<td>Report (.rpt)</td>
<td>Format</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------------------------------------</td>
<td>------------------------------------------------------------------------------</td>
<td>--------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>apds-monthagtTIME.rpt</td>
<td></td>
<td>inlet and outbound connects.</td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME.rpt</td>
<td></td>
<td>inlet and outbound connects.</td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME.rpt</td>
<td></td>
<td>inlet and outbound connects.</td>
</tr>
<tr>
<td>Average Idle Time (Seconds)</td>
<td>apds-agtTIME.rpt</td>
<td>Number</td>
<td>Average number of seconds for which an agent waited between inbound and outlet connects.</td>
</tr>
<tr>
<td></td>
<td>apds-jobTIME.rpt</td>
<td></td>
<td>inlet and outbound connects.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjobTIME.rpt</td>
<td></td>
<td>inlet and outlet connects.</td>
</tr>
<tr>
<td></td>
<td>apds-monthagtTIME.rpt</td>
<td></td>
<td>inlet and outlet connects.</td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME.rpt</td>
<td></td>
<td>inlet and outlet connections.</td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME.rpt</td>
<td></td>
<td>inlet and outlet connections.</td>
</tr>
<tr>
<td>Average Talk Time (Minutes)</td>
<td>apds-agtTIME.rpt</td>
<td>Number</td>
<td>Average number of minutes for which an agent talked to outlet and inlet clients.</td>
</tr>
<tr>
<td></td>
<td>apds-jobTIME.rpt</td>
<td></td>
<td>Average number of minutes for which an agent talked to inlet and outlet clients.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjobTIME.rpt</td>
<td></td>
<td>Average number of minutes for which an agent talked to outlet and inlet clients.</td>
</tr>
<tr>
<td></td>
<td>apds-monthagtTIME.rpt</td>
<td></td>
<td>Average number of minutes for which an agent talked to inlet and outlet clients.</td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME.rpt</td>
<td></td>
<td>Average number of minutes for which an agent talked to inlet and outlet clients.</td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME.rpt</td>
<td></td>
<td>Average number of minutes for which an agent talked to inlet and outlet clients.</td>
</tr>
<tr>
<td>Average Update Time (Minutes)</td>
<td>apds-agtTIME.rpt</td>
<td>Number</td>
<td>Average number of minutes after an inlet or outlet connect ended that the agent updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-jobTIME.rpt</td>
<td></td>
<td>Average number of minutes after an inlet or outlet connect ended that the agent updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjobTIME.rpt</td>
<td></td>
<td>Average number of minutes after an inlet or outlet connect ended that the agent updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-monthagtTIME.rpt</td>
<td></td>
<td>Average number of minutes after an inlet or outlet connect ended that the agent updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME.rpt</td>
<td></td>
<td>Average number of minutes after an inlet or outlet connect ended that the agent updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME.rpt</td>
<td></td>
<td>Average number of minutes after an inlet or outlet connect ended that the agent updated records.</td>
</tr>
<tr>
<td>Average Update Time (Seconds)</td>
<td>apds-agtTIME.rpt</td>
<td>Number</td>
<td>Average number of seconds after an inlet or outlet connect ended that the agent updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-jobTIME.rpt</td>
<td></td>
<td>Average number of seconds after an inlet or outlet connect ended that the agent updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjobTIME.rpt</td>
<td></td>
<td>Average number of seconds after an inlet or outlet connect ended that the agent updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-monthagtTIME.rpt</td>
<td></td>
<td>Average number of seconds after an inlet or outlet connect ended that the agent updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME.rpt</td>
<td></td>
<td>Average number of seconds after an inlet or outlet connect ended that the agent updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME.rpt</td>
<td></td>
<td>Average number of seconds after an inlet or outlet connect ended that the agent updated records.</td>
</tr>
</tbody>
</table>

*Table continues…*
### Combined call statistics

This section provides information on the combined inbound and outbound job performance and connectivity data.

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Average Work Time (Minutes)</strong></td>
<td>apds-agtMANAGED.rpt&lt;br&gt;apds-jobMANAGED.rpt&lt;br&gt;apds-tdjobMANAGED&lt;br&gt;apds-monthagtMANAGED.rpt&lt;br&gt;apds-monthjobMANAGED&lt;br&gt;apds-monthtdjobMANAGED</td>
<td>Number</td>
<td>Average number of minutes the agent talked to inbound and outbound clients and updated records.</td>
</tr>
<tr>
<td><strong>Average Work Time (Seconds)</strong></td>
<td>apds-agtMANAGED.rpt&lt;br&gt;apds-jobMANAGED.rpt&lt;br&gt;apds-tdjobMANAGED&lt;br&gt;apds-monthagtMANAGED.rpt&lt;br&gt;apds-monthjobMANAGED&lt;br&gt;apds-monthtdjobMANAGED</td>
<td>Number</td>
<td>Average number of seconds the agent talked to inbound and outbound clients and updated records.</td>
</tr>
</tbody>
</table>

**Elementary Data:**

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Calls Offered</strong></td>
<td>apds-jobOFCOM.rpt&lt;br&gt;apds-jobQUALITY.rpt&lt;br&gt;apst-tdjobQUALITY&lt;br&gt;apst-tdjobOFCOM&lt;br&gt;apds-monthjobQUALITY&lt;br&gt;apds-monthtdjobQUALITY&lt;br&gt;apds-monthjobOFCOM&lt;br&gt;apds-monthtdjobOFCOM&lt;br&gt;apds-tdjobPERF.rpt&lt;br&gt;apds-jobPERF.rpt&lt;br&gt;apds-monthjobPERF.rpt&lt;br&gt;apds-monthtdjobPERF.rpt</td>
<td>Number</td>
<td>The number of inbound and outbound calls available for the agents. The available outbound calls might be voice contact or answering machine if the job is set up to pass answering machines. The available inbound calls include calls passed to the agents and calls abandoned in the wait queue. For managed jobs, when an agent previews a call, the Calls Offered count increases by one. When the agent or system dials the same call, the Calls</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
</table>
| Calls Placed | apds-jobOFCOM.rpt  
apds-jobSYSREL.rpt  
apds-jobTIME.rpt  
apds-tdjjobOFCOM.rpt  
apds-tdjjobTIME  
apds-tdjjobSYSREL  
apds-monthjobOFCOM  
apds-monthjobTIME  
apds-monthjobSYSREL  
apds-monthtdjobOFCOM  
apds-monthtdjobTIME  
apds-monthtdjobSYSREL | Number | Total number of outbound calls that the system makes. |
| Connects | apds-agtRELEASE.rpt  
apds-agtPERF.rpt  
apds-jobOFCOM.rpt  
apds-jobPERF.rpt  
apds-jobQUALITY.rpt  
apds-jobSYSREL.rpt  
apds-tdjjobSYSREL.rpt  
apst-tdjjobQUALITY  
apds-tdjjobPERF  
apds-tdjjobOFCOM  
apds-monthagttRELEASE.rpt  
apds-monthagttPERF.rpt  
apds-monthjobPERF  
apds-monthjobQUALITY  
apds-monthjobOFCOM  
apds-monthjobSYSREL  
apds-monthtdjobSYSREL  
apds-monthtdjobQUALITY | Number | Total number of inbound and outbound calls passed to the agent. |

Table continues…
<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Custom Calls Abandoned</strong></td>
<td>apds-jobQUALITY.rpt</td>
<td>Number</td>
<td>Total number calls handled by the system or agents and that were deemed abandoned. This calculation is based on the settings in Completion Code menu before the start of each job.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Records Selected</strong></td>
<td>apds-jobPERF.rpt</td>
<td>Number</td>
<td>Total records that the system selects.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Manual Calls Placed</strong></td>
<td>apds-jobPERF.rpt</td>
<td>Number</td>
<td>Total number of manual calls that the system places.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Serviced Calls</strong></td>
<td>apds-jobQUALITY.rpt</td>
<td>Number</td>
<td>Total number of serviced calls.</td>
</tr>
<tr>
<td></td>
<td>apst-tdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Calculated Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Connects per Hour</strong></td>
<td>apds-agtPERF.rpt</td>
<td>Number</td>
<td>Total number of inbound and outbound calls passed to the agent divided by the Online Time. This value is calculated from Connects and Online Time.</td>
</tr>
<tr>
<td></td>
<td>apds-jobPERF.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-jobQUALITY.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apst-tdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>ep</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>E</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobPERF</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Combined queue statistics

Combined inbound and outbound job data on calls placed in the wait queue.

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Elementary Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Calls Queued</td>
<td>apds-jobQUALITY.rpt</td>
<td>Number</td>
<td>Calls Offered that were placed in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apst-tdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>aapds-monthjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>E</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Time in Wait Queue (Hours)</td>
<td>apds-jobQUALITY.rpt</td>
<td>Number</td>
<td>Total number of hours that Calls Offered were in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apst-tdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Time in Wait Queue (Minutes)</td>
<td>apds-jobQUALITY.rpt</td>
<td>Number</td>
<td>Total number of minutes that Calls Offered were in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apst-tdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Nuisance Calls</td>
<td>apds-jobQUALITY.rpt</td>
<td>Number</td>
<td>Total number of nuisance calls in the system.</td>
</tr>
<tr>
<td></td>
<td>apst-tdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>aapds-monthjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>E</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Calculated Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Average Time in Queue (Seconds)</td>
<td>apds-jobQUALITY.rpt</td>
<td>Number</td>
<td>Average number of seconds that Calls Offered were in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apst-tdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>aapds-monthjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>E</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Average Time in Queue (Minutes)</td>
<td>apds-jobQUALITY.rpt</td>
<td>Number</td>
<td>Average number of minutes that Calls Offered were in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apst-tdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>aapds-monthjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>E</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobQUALITY</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
General information

General job and agent information fields are usually used for identifying a row of data on a report. These fields are also commonly used to group and filter data. You can optionally use Hierarchy Manager fields to identify, group, and filter report data.

Inbound call handling times

The total and average duration for which agents performed the inbound calling activities.

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Elementary Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inbound Idle Time (Minutes)</td>
<td>apds-agtTIME.rpt</td>
<td>Number</td>
<td>Total number of minutes the agent waited between connects.</td>
</tr>
<tr>
<td></td>
<td>apds-jobTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inbound Online Time (Hours)</td>
<td>apds-agtTIME.rpt</td>
<td>Number</td>
<td>Total number of hours the agent waited between connects, talked to clients,</td>
</tr>
<tr>
<td></td>
<td>apds-agtPERF.rpt</td>
<td></td>
<td>updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-jobTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-agtTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtPERF.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inbound Online Time (Minutes)</td>
<td>apds-agtTIME.rpt</td>
<td>Number</td>
<td>Total number of minutes the agent waited between connects, talked to clients,</td>
</tr>
<tr>
<td></td>
<td>apds-agtPERF.rpt</td>
<td></td>
<td>updated records.</td>
</tr>
<tr>
<td></td>
<td>apds-jobTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-agtTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inbound Online Time</td>
<td>apds-agtTIME.rpt&lt;br&gt;apds-agtPERF.rpt&lt;br&gt;apds-jobTIME.rpt&lt;br&gt;apds-tdjobTIME</td>
<td>Number</td>
<td>Total number of seconds the agent waited between connects, talked to clients, and updated records.</td>
</tr>
<tr>
<td>(Seconds)</td>
<td>apds-agtTIME.rpt&lt;br&gt;apds-monthjobTIME&lt;br&gt;apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inbound Talk Time</td>
<td>apds-agtTIME.rpt&lt;br&gt;apds-jobTIME.rpt&lt;br&gt;apds-tdjobTIME&lt;br&gt;apds-agtTIME.rpt</td>
<td>Number</td>
<td>Total number of minutes the agent talked to clients.</td>
</tr>
<tr>
<td>(Minutes)</td>
<td>apds-monthjobTIME&lt;br&gt;apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inbound Update Time</td>
<td>apds-agtTIME.rpt&lt;br&gt;apds-jobTIME.rpt&lt;br&gt;apds-tdjobTIME&lt;br&gt;apds-agtTIME.rpt</td>
<td>Number</td>
<td>Total number of minutes after a call ended that the agent updated the records.</td>
</tr>
<tr>
<td>(Minutes)</td>
<td>apds-monthjobTIME&lt;br&gt;apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Calculated Data:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Average Inbound Idle</td>
<td>apds-agtTIME.rpt&lt;br&gt;apds-jobTIME.rpt&lt;br&gt;apds-tdjobTIME&lt;br&gt;apds-agtTIME.rpt</td>
<td>Number</td>
<td>Average number of minutes the agent waited between connects.</td>
</tr>
<tr>
<td>Time (Minutes)</td>
<td>apds-monthjobTIME&lt;br&gt;apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Average Inbound Idle</td>
<td>apds-agtTIME.rpt&lt;br&gt;apds-jobTIME.rpt&lt;br&gt;apds-tdjobTIME&lt;br&gt;apds-agtTIME.rpt</td>
<td>Number</td>
<td>Average number of seconds the agent waited between connects.</td>
</tr>
<tr>
<td>Time (Seconds)</td>
<td>apds-monthjobTIME&lt;br&gt;apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Field reference for Crystal reports SQL Expressions

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Average Inbound Talk Time (Minutes)</strong></td>
<td>apds-agtTIME.rpt, apds-jobTIME.rpt, apds-tdjobTIME, apds-agtTIME.rpt, apds-monthjobTIME, apds-monthtdjobTIME</td>
<td>Number</td>
<td>Average number of minutes the agent talked to the clients.</td>
</tr>
<tr>
<td><strong>Average Inbound Talk Time (Seconds)</strong></td>
<td>apds-agtTIME.rpt, apds-jobTIME.rpt, apds-tdjobTIME, apds-agtTIME.rpt, apds-monthjobTIME, apds-monthtdjobTIME</td>
<td>Number</td>
<td>Average number of seconds the agent talked to the clients.</td>
</tr>
<tr>
<td><strong>Average Inbound Update Time (Minutes)</strong></td>
<td>apds-agtTIME.rpt, apds-jobTIME.rpt, apds-tdjobTIME, apds-agtTIME.rpt, apds-monthjobTIME, apds-monthtdjobTIME</td>
<td>Number</td>
<td>Average number of minutes after a call ended that the agent updated records.</td>
</tr>
<tr>
<td><strong>Average Inbound Update Time (Seconds)</strong></td>
<td>apds-agtTIME.rpt, apds-jobTIME.rpt, apds-tdjobTIME, apds-agtTIME.rpt, apds-monthjobTIME, apds-monthtdjobTIME</td>
<td>Number</td>
<td>Average number of seconds after a call ended that the agent updated records.</td>
</tr>
</tbody>
</table>

---

**Inbound call statistics**

Performance and connectivity data for inbound jobs.

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Elementary Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Inbound Calls Offered</strong></td>
<td>apds-agtTIME.rpt, apds-jobTIME.rpt</td>
<td>Number</td>
<td>The number of inbound calls handled by the system. This value includes</td>
</tr>
</tbody>
</table>

*Table continues…*
### Field Report (.rpt)  Format  Description

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>apds-tjobTIME</td>
<td></td>
<td>calls passed to the agents and calls abandoned in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apds-monthagtTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Inbound Connects</strong></td>
<td>apds-agtTIME.rpt</td>
<td>Number</td>
<td>Total number of calls passed to the agent.</td>
</tr>
<tr>
<td></td>
<td>apds-jobTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

#### Calculated Data:

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Inbound Allocation</strong></td>
<td>apds-agtPERF.rpt</td>
<td>Number</td>
<td>Total time the agent handled inbound calls divided by the Online Time. This value is calculated from Inbound Online Time and Online Time.</td>
</tr>
<tr>
<td></td>
<td>apds-monthagtPERF.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Inbound Connects per Hour</strong></td>
<td>apds-agtTIME.rpt</td>
<td>Number</td>
<td>Total number of calls passed to the agent divided by Inbound Online Time. This value is calculated from Inbound Connects and Inbound Online Time.</td>
</tr>
<tr>
<td></td>
<td>apds-jobTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Inbound queue statistics

Inbound only data on calls placed in the wait queue.

#### Table continues…
### Field reference for Crystal reports SQL Expressions

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Inbound Calls Queued</strong></td>
<td>apds-jobTIME.rpt</td>
<td>Number</td>
<td>Inbound calls offered that were placed in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Inbound Calls Abandoned</strong></td>
<td>apds-jobTIME.rpt</td>
<td>Number</td>
<td>Inbound calls offered that were not passed to the agents.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Inbound Time on Queue (Hours)</strong></td>
<td>apds-jobTIME.rpt</td>
<td>Number</td>
<td>Total number of hours inbound calls offered are in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Inbound Time on Queue (Minutes)</strong></td>
<td>apds-jobTIME.rpt</td>
<td>Number</td>
<td>Total number of minutes inbound calls offered are in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Calculated Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Average Inbound Time in Queue</strong></td>
<td>apds-jobTIME.rpt</td>
<td>Number</td>
<td>Average number of minutes inbound calls offered were in the wait queue.</td>
</tr>
<tr>
<td>(Minutes)</td>
<td>apds-tdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Average Inbound Time in Queue</strong></td>
<td>apds-jobTIME.rpt</td>
<td>Number</td>
<td>Average number of seconds inbound calls offered were in the wait queue.</td>
</tr>
<tr>
<td>(Seconds)</td>
<td>apds-tdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Inbound Calls Queued per Hour</strong></td>
<td>apds-jobTIME.rpt</td>
<td>Number</td>
<td>Inbound calls offered that were placed in the wait queue divided by the Inbound Online Time. This value is calculated from Inbound Calls Offered and Inbound Online Time.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

---

**Managed dialing statistics**

This table shows managed dialing data.
<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Calls Canceled</strong></td>
<td>apds-agtMANAGED.rpt</td>
<td>Number</td>
<td>Total number of records cancelled by agent and the calls disposed by the system.</td>
</tr>
<tr>
<td></td>
<td>apds-jobMANAGED.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtMANAGED.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Records Previewed</strong></td>
<td>apds-agtMANAGED.rpt</td>
<td>Number</td>
<td>Total number of records the agent previewed.</td>
</tr>
<tr>
<td></td>
<td>apds-jobMANAGED.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtMANAGED.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Preview Time (Minutes)</strong></td>
<td>apds-agtMANAGED.rpt</td>
<td>Number</td>
<td>Total number of minutes the agent previewed records before the system placed the call or the agent canceled the call.</td>
</tr>
<tr>
<td></td>
<td>apds-jobMANAGED.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtMANAGED.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Calculated Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Average Preview Time (Minutes)</strong></td>
<td>apds-agtMANAGED.rpt</td>
<td>Number</td>
<td>Average number of minutes the agent previewed client records before the system placed the call or canceled the call.</td>
</tr>
<tr>
<td></td>
<td>apds-jobMANAGED.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtMANAGED.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Average Preview Time (Seconds)</strong></td>
<td>apds-jobMANAGED.rpt</td>
<td>Number</td>
<td>Average number of seconds the agent previewed client records before the system placed the call or canceled the call.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtMANAGED.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobMANAGED</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
</table>
| Calls Canceled per Hour | apds-agtMANAGED.rpt  
apds-jobMANAGED.rpt  
apds-tdjobMANAGED  
apds-monthagtMANAGED.rpt  
apds-monthjobMANAGED  
apds-monthtdjobMANAGED | Number | Total number of records cancelled by agent and the calls disposed by the system divided by the Online Time. This value is calculated from Calls Canceled and Online Time. |
| Records Previewed per Hour | apds-agtMANAGED.rpt  
apds-jobMANAGED.rpt  
apds-tdjobMANAGED  
apds-monthagtMANAGED.rpt  
apds-monthjobMANAGED  
apds-monthtdjobMANAGED | Number | Total number of records the agent previewed divided by the Online Time. This value is calculated from Records Previewed and Online Time. |

### Outbound call handling time

The total and average times the agent performed outbound only calling activities.

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
</table>
| Elementary Data:                                               | apds-agtTIME.rpt  
apds-jobTIME.rpt  
apds-tdjobTIME  
apds-monthagtTIME.rpt  
apds-monthjobTIME  
apds-monthtdjobTIME | Number | Total number of minutes the agent waited between connects.                  |
| Outbound Idle Time (Minutes)                                   | apds-agtTIME.rpt  
apds-jobTIME.rpt  
apds-tdjobTIME  
apds-monthagtTIME.rpt  
apds-monthjobTIME  
apds-monthtdjobTIME | Number | Total number of hours the agent waited between connects, talked to clients, and updated records. |

Table continues…
<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>apds-tdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Online Time</td>
<td>apds-agtTIME.rpt</td>
<td>Number</td>
<td>Total number of minutes the agent waited between connects, talked to clients, and updated records.</td>
</tr>
<tr>
<td>(Minutes)</td>
<td>apds-jobTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Online Time</td>
<td>apds-agtPERF.rpt</td>
<td>Number</td>
<td>Total number of seconds the agent waited between connects, talked to clients, and updated records.</td>
</tr>
<tr>
<td>(Seconds)</td>
<td>apds-jobPERF.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-jobQUALITY.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apst-tdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Field</td>
<td>Report (.rpt)</td>
<td>Format</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>--------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Outbound Talk Time</strong></td>
<td>apds-agtTIME.rpt, apds-jobTIME.rpt, apds-tdjobTIME, apds-monthagtTIME.rpt, apds-monthjobTIME, apds-monthtdjobTIME</td>
<td>Number</td>
<td>Total number of minutes the agent talked to clients.</td>
</tr>
<tr>
<td><strong>Outbound Work Time</strong></td>
<td>apds-agtTIME.rpt, apds-jobTIME.rpt, apds-tdjobTIME, apds-monthagtTIME.rpt, apds-monthjobTIME, apds-monthtdjobTIME</td>
<td>Number</td>
<td>Total number of minutes the agent talked to clients and updated records.</td>
</tr>
<tr>
<td><strong>Outbound Update Time</strong></td>
<td>apds-agtTIME.rpt, apds-jobTIME.rpt, apds-tdjobTIME, apds-monthagtTIME.rpt, apds-monthjobTIME, apds-monthtdjobTIME</td>
<td>Number</td>
<td>Total number of minutes after a call ended that the agent updated records.</td>
</tr>
<tr>
<td><strong>Calculated Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Average Outbound Idle Time</strong></td>
<td>apds-agtTIME.rpt, apds-agtTIME.rpt, apds-jobTIME.rpt, apds-tdjobTIME, apds-monthagtTIME.rpt, apds-monthjobTIME, apds-monthtdjobTIME, apds-jobOFCOM.rpt, apds-jobPERF.rpt, apds-jobQUALITY.rpt, apds-jobRELEASE.rpt, apds-jobSYSREL.rpt, apds-jobTIME.rpt, apds-tdjobTIME</td>
<td>Number</td>
<td>Average number of minutes the agent waited between connects.</td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average Outbound Idle Time</td>
<td>apds-agtTIME.rpt apds-jobTIME.rpt apds-tdjobTIME apds-monthagtTIME.rpt apds-monthjobTIME apds-monthtdjobTIME</td>
<td>Number</td>
<td>Average number of seconds the agent waited between connects.</td>
</tr>
<tr>
<td>(Seconds)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Average Outbound Talk Time</td>
<td>apds-agtTIME.rpt apds-jobTIME.rpt apds-tdjobTIME apds-monthagtTIME.rpt apds-monthjobTIME apds-monthtdjobTIME</td>
<td>Number</td>
<td>Average number of minutes the agent talked to clients.</td>
</tr>
<tr>
<td>(Minutes)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Field</td>
<td>Report (.rpt)</td>
<td>Format</td>
<td>Description</td>
</tr>
<tr>
<td>-------</td>
<td>---------------</td>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>Average Outbound Talk Time (Seconds)</td>
<td>apds-agtTIME.rpt, apds-jobTIME.rpt, apds-tdjobTIME, apds-monthagtTIME.rpt, apds-monthjobTIME, apds-monthtdjobTIME</td>
<td>Number</td>
<td>Average number of seconds the agent talked to clients.</td>
</tr>
<tr>
<td>Average Outbound Update Time (Minutes)</td>
<td>apds-agtTIME.rpt, apds-jobTIME.rpt, apds-tdjobTIME, apds-monthagtTIME.rpt, apds-monthjobTIME, apds-monthtdjobTIME</td>
<td>Number</td>
<td>Average number of minutes after a call ended that the agent updated records.</td>
</tr>
<tr>
<td>Average Outbound Update Time (Seconds)</td>
<td>apds-agtTIME.rpt, apds-jobTIME.rpt, apds-tdjobTIME, apds-monthagtTIME.rpt, apds-monthjobTIME, apds-monthtdjobTIME</td>
<td>Number</td>
<td>Average number of seconds after a call ended that the agent updated records.</td>
</tr>
<tr>
<td>Average Outbound Work Time (Minutes)</td>
<td>apds-agtTIME.rpt, apds-jobTIME.rpt, apds-tdjobTIME, apds-monthagtTIME.rpt, apds-monthjobTIME, apds-monthtdjobTIME</td>
<td>Number</td>
<td>Average number of minutes the agent talked to clients and updated records.</td>
</tr>
<tr>
<td>Average Outbound Work Time (Seconds)</td>
<td>apds-agtTIME.rpt, apds-jobTIME.rpt, apds-tdjobTIME, apds-monthagtTIME.rpt, apds-monthjobTIME, apds-monthtdjobTIME</td>
<td>Number</td>
<td>Average number of seconds the agent talked to clients and updated records.</td>
</tr>
</tbody>
</table>
### Outbound call statistics

This table describes the Outbound only job performance and connectivity data.

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Elementary Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Calls Offered</td>
<td>apds-jobOFCOM.rpt, apds-jobPERF.rpt, apds-jobQUALITY.rpt, apst-tdjjobRELEASE</td>
<td>Number</td>
<td>The number of Outbound Calls Placed that were answered. Outbound Calls Offered might be voice contact or answering machine if the job is set up to pass answering machines to the agents.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjjobOFCOM.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobOFCOM.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobOFCOM.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobSYSREL</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobOFCOM.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobOFCOM.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Calls Placed</td>
<td>apds-jobOFCOM.rpt, apds-jobPERF.rpt, apds-jobQUALITY.rpt, apds-jobSYSREL.rpt</td>
<td>Number</td>
<td>Total number of outbound calls the system made.</td>
</tr>
<tr>
<td></td>
<td>apds-jobTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjjobTIME, apds-tdjjobSYSREL, apds-tdjjobOFCOM.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobSYSREL</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobOFCOM.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outbound Connects</td>
<td><strong>apds-agtTIME.rpt</strong>&lt;br&gt;apds-jobMANAGED.rpt&lt;br&gt;apds-jobOFCOM.rpt&lt;br&gt;apds-jobTIME.rpt&lt;br&gt;apds-tdjobTIME,&lt;br&gt;apds-tdjobMANAGED&lt;br&gt;apds-jobOFCOM.rpt&lt;br&gt;apds-monthagtTIME.rpt&lt;br&gt;apds-monthagtOFCOM.rpt&lt;br&gt;apds-monthjobTIME&lt;br&gt;apds-monthjobMANAGED&lt;br&gt;apds-monthjobOFCOM.rpt&lt;br&gt;apds-monthtdjobTIME&lt;br&gt;apds-monthtdjobMANAGED&lt;br&gt;apds-monthtdjobOFCOM.rpt</td>
<td>Number</td>
<td>Total number of calls passed to the agent.</td>
</tr>
<tr>
<td>Outbound Idle Count</td>
<td><strong>apds-agtTIME.rpt</strong>&lt;br&gt;apds-jobTIME.rpt&lt;br&gt;apds-tdjobTIME&lt;br&gt;apds-monthagtTIME.rpt&lt;br&gt;apds-monthjobTIME&lt;br&gt;apds-monthtdjobTIME</td>
<td>Number</td>
<td>Total number of outbound idle states for the agent.</td>
</tr>
<tr>
<td>Calculated Data:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Allocation</td>
<td><strong>apds-agtPERF.rpt</strong>&lt;br&gt;apds-monthagtPERF.rpt</td>
<td>Number</td>
<td>Total time the agent handled outbound calls divided by the Online Time. This value is calculated from Outbound Online Time and Online Time.</td>
</tr>
<tr>
<td>Outbound Connects per Hour</td>
<td><strong>apds-agtTIME.rpt</strong>&lt;br&gt;apds-jobTIME.rpt&lt;br&gt;apds-tdjobTIME</td>
<td>Number</td>
<td>Total number of calls passed to the agent divided by Outbound Online Time. This value is calculated from</td>
</tr>
</tbody>
</table>
### Outbound queue statistics

This table shows the outbound only calling data on calls placed in the wait queue.

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>apds-monthagtTIME.rpt</td>
<td></td>
<td>Outbound Connects and Outbound Online Time.</td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Recalls Placed per Hour</td>
<td>apds-jobMANAGED.rpt</td>
<td>Number</td>
<td>Total number of calls the system recalled divided by the Outbound Online Time.</td>
</tr>
<tr>
<td></td>
<td>apds-jobOFCOM.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-jobPERF.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-jobQUALITY.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-jobRELEASE.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-jobSYSREL.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-jobTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobTIME, apds-tdjobSYSREL, apds-tdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apst-tdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobSYSREL</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME, apds-monthtdjobSYSREL, apds-monthtdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apst-monthtdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobMANAGED</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Outbound queue statistics

This table shows the outbound only calling data on calls placed in the wait queue.
### Field reference for Crystal reports SQL Expressions

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Elementary Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Calls Queued</td>
<td>apds-jobTIME.rpt</td>
<td>Number</td>
<td>Outbound Calls Offered that were placed in the wait queue.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Time in Queue</td>
<td>apds-jobTIME.rpt</td>
<td>Number</td>
<td>Total number of hours Outbound Calls Offered are in the wait queue.</td>
</tr>
<tr>
<td>(Hours)</td>
<td>apds-tdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Time in Queue</td>
<td>apds-jobTIME.rpt</td>
<td>Number</td>
<td>Total number of minutes Outbound Calls Offered were in the wait queue.</td>
</tr>
<tr>
<td>(Minutes)</td>
<td>apds-tdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Calculated Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Average Outbound Time in Queue</td>
<td>apds-jobTIME.rpt</td>
<td>Number</td>
<td>Average number of minutes Outbound Calls Offered are in the wait queue.</td>
</tr>
<tr>
<td>(Minutes)</td>
<td>apds-tdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Average Outbound Time in Queue</td>
<td>apds-jobTIME.rpt</td>
<td>Number</td>
<td>Average number of seconds Outbound Calls Offered are in the wait queue.</td>
</tr>
<tr>
<td>(Seconds)</td>
<td>apds-tdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outbound Calls Abandoned</td>
<td>apds-jobTIME.rpt</td>
<td>Number</td>
<td>Outbound Calls Offered that were not passed to the agents.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

---

**Person to Person call handling times**

Total and average times the Person to Person (PTP) agent or agents performed job activities.

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Elementary Data:</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Table continues...*
### Person to Person call statistics

This table shows the Person to Person job performance and connectivity data.

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Elementary Data:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>PTP Allocation</td>
<td>apds-agtPERF.rpt</td>
<td>Number</td>
<td>Total time the agent handled calls divided by the Online Time. This value is calculated from PTP Online Time and Online Time.</td>
</tr>
</tbody>
</table>

### Combined RPC and closure statistics

This table shows the Right Party Contact (RPC) and Closure statistics data.

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Elementary Data:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Closure Count</td>
<td>apds-agtMANAGED.rpt</td>
<td>Number</td>
<td>Total number of calls that the agent assigned as a closure call completion code.</td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Closure Per Hour</td>
<td></td>
<td></td>
<td>Total number of calls that the agent assigned as a closure call completion</td>
</tr>
<tr>
<td></td>
<td>apds-agtMANAGED.rpt, apds-agtPERF.rpt, apds-jobMANAGED.rpt, apds-jobPERF.rpt</td>
<td>Number</td>
<td>code per hour.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjobPERF, apds-tdjobMANAGED, apds-monthagtPERF.rpt, apds-monthagtMANAGED.rpt, apds-monthjobMANAGED, apds-monthjobPERF, apds-monthtdjobPERF, apds-monthtdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Closure Rate</td>
<td></td>
<td>Number</td>
<td>Rate of calls that the agent assigned as a closure call completion code.</td>
</tr>
<tr>
<td></td>
<td>apds-agtMANAGED.rpt, apds-agtPERF.rpt, apds-jobMANAGED.rpt, apds-jobPERF.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobPERF, apds-tdjobMANAGED, apds-monthagtPERF.rpt, apds-monthagtMANAGED.rpt, apds-monthjobMANAGED, apds-monthjobPERF, apds-monthtdjobPERF, apds-monthtdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Closure Rate of Connects</td>
<td></td>
<td>Number</td>
<td>Rate of calls that the agent connects.</td>
</tr>
<tr>
<td></td>
<td>apds-agtMANAGED.rpt, apds-agtPERF.rpt, apds-jobMANAGED.rpt, apds-jobPERF.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobPERF, apds-tdjobMANAGED, apds-monthagtPERF.rpt, apds-monthagtMANAGED.rpt, apds-monthjobMANAGED, apds-monthjobPERF, apds-monthtdjobPERF, apds-monthtdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Field</td>
<td>Report (.rpt)</td>
<td>Format</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>Field</td>
<td>apds-monthagtPERF.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtMANAGED.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Closure Rate of RPCs</td>
<td>apds-agtMANAGED.rpt</td>
<td>Number</td>
<td>Rate of calls assigned as RPC by the agents.</td>
</tr>
<tr>
<td></td>
<td>apds-agtPERF.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-jobMANAGED.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-jobPERF.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtPERF.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtMANAGED.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Right Party Contact</td>
<td>apds-agtMANAGED.rpt</td>
<td>Number</td>
<td>Total number of calls for which the agent assigned an RPC completion code.</td>
</tr>
<tr>
<td>Count</td>
<td>apds-agtPERF.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-jobMANAGED.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-jobPERF.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtPERF.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtMANAGED.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Right Party Contact</td>
<td>apds-agtMANAGED.rpt</td>
<td>Number</td>
<td>Total number of calls to which the agent assigned an RPC completion code is</td>
</tr>
<tr>
<td>Rate</td>
<td>apds-agtPERF.rpt</td>
<td></td>
<td>divided by the total number of calls passed to agents. This value is</td>
</tr>
<tr>
<td></td>
<td>apds-jobMANAGED.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Field</td>
<td>Report (.rpt)</td>
<td>Format</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-------------------------------------------------------------------------------</td>
<td>--------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>apds-jobPERF.rpt</td>
<td></td>
<td>calculated from Right Party Contact Count and Connects.</td>
</tr>
<tr>
<td></td>
<td>apds-tdjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtPERF.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtMANAGED.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Right Party Contacts</td>
<td>apds-agtMANAGED.rpt</td>
<td>Number</td>
<td>Total number of calls to which the agent assigned an RPC completion code</td>
</tr>
<tr>
<td>per Hour</td>
<td>apds-agtPERF.rpt</td>
<td></td>
<td>divided by the Online Time. This value is calculated from Right Party</td>
</tr>
<tr>
<td></td>
<td>apds-jobMANAGED.rpt</td>
<td></td>
<td>Contact Count and Online Time.</td>
</tr>
<tr>
<td></td>
<td>apds-jobPERF.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtPERF.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtMANAGED.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Right Party Contact</td>
<td>apds-tdjobTIME,</td>
<td>Number</td>
<td>Total number of calls to which the agent assigned an RPC completion code</td>
</tr>
<tr>
<td>Closure Rate</td>
<td>apds-tdjobSYSREL,</td>
<td></td>
<td>divided by the total number of closure calls passed to agents. This value</td>
</tr>
<tr>
<td></td>
<td>apds-tdjobRELEASE</td>
<td></td>
<td>is calculated from Right Party Contact Count and closure call.</td>
</tr>
<tr>
<td></td>
<td>apst-tdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobMANAGED</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME,</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobSYSREL</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobQUALITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobPERF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobMANAGED</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Combined call completion code statistics

This table contains the call completion codes count that the agents or the system uses to record the disposition of contacts and contact attempts.

**Note:**

The Recorded by column replaces the Format column. The Format column identifies whether an agent or the system released the call. All completion code counts are numbers.

The following completion codes and descriptions represent the common configuration of the Avaya Proactive Contact system. The configuration of your system might be different.

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Recorded by</th>
<th>Description</th>
</tr>
</thead>
</table>
| Code00 NOTCALLED | apds-jobRELEASE.rpt  
apds-jobSYSREL.rpt  
apds-tdjobSYSREL,  
apds-tdjobRELEASE  
apds-monthjobRELEASE  
apds-monthjobSYSREL  
apds-monthtdjobSYSREL  
apds-monthtdjobRELEASE | System      | The account was not called.                      |
| Code01 CODE1       | apds-jobRELEASE.rpt  
apds-jobSYSREL.rpt  
apds-tdjobSYSREL,  
apds-tdjobRELEASE  
apds-monthjobRELEASE  
apds-monthjobSYSREL  
apds-monthtdjobSYSREL  
apds-monthtdjobRELEASE | System      | Reserved for system.                             |
| Code02 ERROR      | apds-jobRELEASE.rpt  
apds-jobSYSREL.rpt  
apds-tdjobSYSREL,  
apds-tdjobRELEASE  
apds-monthjobRELEASE  
apds-monthjobSYSREL  
apds-monthtdjobSYSREL  
apds-monthtdjobRELEASE | System      | The system detected an invalid phone number.    |

Table continues…
<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Recorded by</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Code03</strong></td>
<td>apds-jobRELEASE.rpt&lt;br&gt;apds-jobSYSREL.rpt&lt;br&gt;apds-tdjobSYSREL,&lt;br&gt;apds-tdjobRELEASE&lt;br&gt;apds-monthjobRELEASE&lt;br&gt;apds-monthjobSYSREL&lt;br&gt;apds-monthtdjobSYSREL&lt;br&gt;apds-monthtdjobRELEASE</td>
<td>System</td>
<td>The system did not receive a dial tone.</td>
</tr>
<tr>
<td><strong>Code04</strong></td>
<td>apds-jobRELEASE.rpt&lt;br&gt;apds-jobSYSREL.rpt&lt;br&gt;apds-tdjobSYSREL,&lt;br&gt;apds-tdjobRELEASE&lt;br&gt;apds-monthjobRELEASE&lt;br&gt;apds-monthjobSYSREL&lt;br&gt;apds-monthtdjobSYSREL&lt;br&gt;apds-monthtdjobRELEASE</td>
<td>System</td>
<td>The system did not receive a dial tone.</td>
</tr>
<tr>
<td><strong>Code05</strong></td>
<td>apds-jobRELEASE.rpt&lt;br&gt;apds-jobSYSREL.rpt&lt;br&gt;apds-tdjobSYSREL,&lt;br&gt;apds-tdjobRELEASE&lt;br&gt;apds-monthjobRELEASE&lt;br&gt;apds-monthjobSYSREL&lt;br&gt;apds-monthtdjobSYSREL&lt;br&gt;apds-monthtdjobRELEASE</td>
<td>System</td>
<td>The local time for the client phone is outside calling hours.</td>
</tr>
<tr>
<td><strong>Code06</strong></td>
<td>apds-jobRELEASE.rpt&lt;br&gt;apds-jobSYSREL.rpt&lt;br&gt;apds-tdjobSYSREL,&lt;br&gt;apds-tdjobRELEASE&lt;br&gt;apds-monthjobRELEASE&lt;br&gt;apds-monthjobSYSREL&lt;br&gt;apds-monthtdjobSYSREL&lt;br&gt;apds-monthtdjobRELEASE</td>
<td>System</td>
<td>Native voice and data transfer: An agent transfers the call to an inbound agent without remaining on the line. This transfer is known as a blind transfer.</td>
</tr>
</tbody>
</table>

*Table continues*…
<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Recorded by</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Code07 HANG_TRANS** | apds-jobRELEASE.rpt  
apds-jobSYSREL.rpt  
apds-tdjobSYSREL,  
apds-tdjobRELEASE  
apds-monthjobRELEASE  
apds-monthjobSYSREL  
apds-monthtdjobSYSREL  
apds-monthtdjobRELEASE | System      | No agent is available for a supervisor transfer.                           |
| **Code08 TDSS_HF_B** | apds-jobRELEASE.rpt  
apds-jobSYSREL.rpt  
apds-tdjobSYSREL,  
apds-tdjobRELEASE  
apds-monthjobRELEASE  
apds-monthjobSYSREL  
apds-monthtdjobSYSREL  
apds-monthtdjobRELEASE | System      | ADAPTS API: Agent transfers call without remaining on the line. This transfer is known as a blind hookflash transfer. |
| **Code09 and Code10** | apds-jobRELEASE.rpt  
apds-jobSYSREL.rpt  
apds-tdjobSYSREL,  
apds-tdjobRELEASE  
apds-monthjobRELEASE  
apds-monthjobSYSREL  
apds-monthtdjobSYSREL  
apds-monthtdjobRELEASE | System      | Reserved for system.                                                       |
| **Code11 BUSY** | apds-jobRELEASE.rpt  
apds-jobSYSREL.rpt  
apds-tdjobSYSREL,  
apds-tdjobRELEASE  
apds-monthjobRELEASE  
apds-monthjobSYSREL  
apds-monthtdjobSYSREL  
apds-monthtdjobRELEASE | System      | The system detected a busy signal.                                         |
<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Recorded by</th>
<th>Description</th>
</tr>
</thead>
</table>
| Code12 CONTTONE | apds-jobRELEASE.rpt  
apds-jobSYSREL.rpt  
apds-tdjobSYSREL,  
apds-tdjobRELEASE  
apds-monthjobRELEASE  
apds-monthjobSYSREL  
apds-monthtdjobSYSREL  
apds-monthtdjobRELEASE | System      | The system detected a continuous tone, such as a fax or modem.              |
| Code13 AUTOVOICE | apds-jobRELEASE.rpt  
apds-jobSYSREL.rpt  
apds-tdjobSYSREL,  
apds-tdjobRELEASE  
apds-monthjobRELEASE  
apds-monthjobSYSREL  
apds-monthtdjobSYSREL  
apds-monthtdjobRELEASE | System      | The system detected an answering machine.                                  |
| Code14 VOICE | apds-jobRELEASE.rpt  
apds-jobSYSREL.rpt  
apds-tdjobSYSREL,  
apds-tdjobRELEASE  
apds-monthjobRELEASE  
apds-monthjobSYSREL  
apds-monthtdjobSYSREL  
apds-monthtdjobRELEASE | System      | A temporary code when a person is on the line.                             |
| Code15 NOANSWER | apds-jobRELEASE.rpt  
apds-jobSYSREL.rpt  
apds-tdjobSYSREL,  
apds-tdjobRELEASE  
apds-monthjobRELEASE  
apds-monthjobSYSREL  
apds-monthtdjobSYSREL  
apds-monthtdjobRELEASE | System      | The call placed was not answered.                                          |

*Table continues…*
<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Recorded by</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Code16 RINGING</td>
<td>apds-jobRELEASE.rpt, apds-jobSYSREL.rpt, apds-tdjobSYSREL,</td>
<td>System</td>
<td>Can be user defined but is usually defined as a phone call that was still</td>
</tr>
<tr>
<td></td>
<td>apds-monthjobRELEASE, apds-monthjobSYSREL, apds-monthtdjobSYSREL,</td>
<td></td>
<td>ringing but was passed to an agent.</td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code17 CUSTHU</td>
<td>apds-jobRELEASE.rpt, apds-jobSYSREL.rpt, apds-tdjobSYSREL,</td>
<td>System</td>
<td>Can be user defined but is usually defined as a client hang-up as the call</td>
</tr>
<tr>
<td></td>
<td>apds-tdjobRELEASE, apds-monthjobRELEASE, apds-monthjobSYSREL,</td>
<td></td>
<td>was in the wait queue but was passed to an agent.</td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobSYSREL, apds-monthtdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code18 TRANSFER</td>
<td>apds-jobRELEASE.rpt, apds-tdjobRELEASE, apds-monthjobRELEASE,</td>
<td>System</td>
<td>Can be user defined but is usually defined as a transfer release.</td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code19 RECALL</td>
<td>apds-agtRELEASE.rpt, apds-jobRELEASE.rpt, apds-tdjobRELEASE,</td>
<td>Agent</td>
<td>Can be user defined but is usually defined as a recall release.</td>
</tr>
<tr>
<td></td>
<td>apds-monthagtRELEASE, apds-monthjobRELEASE, apds-monthtdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code20 through</td>
<td>apds-agtRELEASE.rpt, apds-jobRELEASE.rpt, apds-tdjobRELEASE,</td>
<td>Agent</td>
<td>User defined.</td>
</tr>
<tr>
<td>Code34</td>
<td>apds-monthagtRELEASE, apds-monthjobRELEASE, apds-monthtdjobRELEASE</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Recorded by</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Code35</strong></td>
<td>apds-agtRELEASE.rpt&lt;br&gt;apds-jobRELEASE.rpt&lt;br&gt;apds-jobSYSREL.rpt&lt;br&gt;apds-tdjjobSYSREL.&lt;br&gt;apds-tdjjobRELEASE&lt;br&gt;apds-monthagtRELEASE.rpt&lt;br&gt;apds-monthjobRELEASE&lt;br&gt;apds-monthjobSYSREL&lt;br&gt;apds-monthtdjobSYSREL&lt;br&gt;apds-monthtdjobRELEASE</td>
<td>Agent</td>
<td>Can be user defined but is defined as the agent canceled the managed call.</td>
</tr>
<tr>
<td><strong>Code36</strong></td>
<td>apds-jobRELEASE.rpt&lt;br&gt;apds-jobSYSREL.rpt&lt;br&gt;apds-tdjjobSYSREL.&lt;br&gt;apds-tdjjobRELEASE&lt;br&gt;apds-monthjobRELEASE&lt;br&gt;apds-monthjobSYSREL&lt;br&gt;apds-monthtdjobSYSREL&lt;br&gt;apds-monthtdjobRELEASE</td>
<td>System</td>
<td>Special Information Tone (SIT) indicating an operator intercept.</td>
</tr>
<tr>
<td><strong>Code37</strong></td>
<td>apds-jobRELEASE.rpt&lt;br&gt;apds-jobSYSREL.rpt&lt;br&gt;apds-tdjjobSYSREL.&lt;br&gt;apds-tdjjobRELEASE&lt;br&gt;apds-monthjobRELEASE&lt;br&gt;apds-monthjobSYSREL&lt;br&gt;apds-monthtdjobSYSREL&lt;br&gt;apds-monthtdjobRELEASE</td>
<td>System</td>
<td>Special Information Tone (SIT) indicating that circuits are unavailable.</td>
</tr>
<tr>
<td><strong>Code38</strong></td>
<td>apds-jobRELEASE.rpt&lt;br&gt;apds-jobSYSREL.rpt&lt;br&gt;apds-tdjjobSYSREL.&lt;br&gt;apds-tdjjobRELEASE&lt;br&gt;apds-monthjobRELEASE&lt;br&gt;apds-monthjobSYSREL</td>
<td>System</td>
<td>Special Information Tone (SIT) indicating that the call reached a disconnected number.</td>
</tr>
<tr>
<td>Field</td>
<td>Report (.rpt)</td>
<td>Recorded by</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>------------------------------------------------------------------------------</td>
<td>-------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Code39 VACANT | apds-jobRELEASE.rpt  
apds-jobSYSREL.rpt  
apds-tdjobSYSREL,  
apds-tdjobRELEASE  
apds-monthjobRELEASE  
apds-monthjobSYSREL  
apds-monthtdjobSYSREL  
apds-monthtdjobRELEASE | System      | Special Information Tone (SIT) indicating that the call cannot be completed as dialed. |
| Code40 RECORDER | apds-jobRELEASE.rpt  
apds-jobSYSREL.rpt  
apds-tdjobSYSREL,  
apds-tdjobRELEASE  
apds-monthjobRELEASE  
apds-monthjobSYSREL  
apds-monthtdjobSYSREL  
apds-monthtdjobRELEASE | System      | The call resulted in a fast busy tone.                                      |
| Code41 R_RINGING | apds-jobRELEASE.rpt  
apds-jobSYSREL.rpt  
apds-tdjobSYSREL,  
apds-tdjobRELEASE  
apds-monthjobRELEASE  
apds-monthjobSYSREL  
apds-monthtdjobSYSREL  
apds-monthtdjobRELEASE | System      | Internal system code.                                                       |
| Code42 LINEFAIL | apds-jobRELEASE.rpt  
apds-jobSYSREL.rpt  
apds-tdjobSYSREL,  
apds-tdjobRELEASE  
apds-monthjobRELEASE  
apds-monthjobSYSREL  
apds-monthtdjobSYSREL  
apds-monthtdjobRELEASE | System      | A failure on the phone line occurred.                                      |
<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Recorded by</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Code46</td>
<td>apds-jobRELEASE.rpt, apds-jobSYSREL.rpt</td>
<td>System</td>
<td>The client hung-up while in the outbound wait queue.</td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Recorded by</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>apds-tdjobSYSREL, apds-tdjobRELEASE apds-monthjobRELEASE apds-monthjobSYSREL apds-monthtdjobSYSREL apds-monthtdjobRELEASE apds-jobTIME.rpt apds-tdjobTIME.rpt apds-monthjobTIME.rpt apds-monthtdjobTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code47</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>HANG_OUT</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Code47 HANG_INB</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-jobRELEASE.rpt apds-jobSYSREL.rpt apds-tdjobSYSREL, apds-tdjobRELEASE apds-monthjobRELEASE apds-monthjobSYSREL apds-monthtdjobSYSREL apds-monthtdjobRELEASE NAGED apds-jobTIME.rpt apds-tdjobTIME.rpt apds-monthjobTIME.rpt apds-monthtdjobTIME.rpt</td>
<td></td>
<td>System</td>
</tr>
<tr>
<td></td>
<td>Code48 HANG_OUT</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Code48 HANG_OUT</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-jobRELEASE.rpt apds-jobSYSREL.rpt apds-tdjobSYSREL, apds-tdjobRELEASE apds-monthjobRELEASE apds-monthjobSYSREL apds-monthtdjobSYSREL apds-monthtdjobRELEASE apds-jobTIME.rpt</td>
<td></td>
<td>System</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>An agent was not available for the inbound call.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>An agent was not available for the outbound call.</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Recorded by</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>apds-tdjobTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code49 OPDIED</td>
<td>apds-jobRELEASE.rpt</td>
<td></td>
<td>System</td>
</tr>
<tr>
<td></td>
<td>apds-jobSYSREL.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tjjobSYSREL, apds-tjjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobSYSREL</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobSYSREL</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code50 R_HSONHOOK</td>
<td>apds-jobRELEASE.rpt</td>
<td></td>
<td>System</td>
</tr>
<tr>
<td></td>
<td>apds-tjjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code51 through Code88 and Code100 through Code999</td>
<td>apds-agtRELEASE.rpt</td>
<td></td>
<td>User defined.</td>
</tr>
<tr>
<td></td>
<td>apds-jobRELEASE.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tjjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code89 MANAGEDA</td>
<td>apds-agtRELEASE.rpt</td>
<td></td>
<td>Managed Dial: Managed non-connection.</td>
</tr>
<tr>
<td></td>
<td>apds-jobRELEASE.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tjjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code90 MANAGEDB</td>
<td>apds-agtRELEASE.rpt</td>
<td></td>
<td>Managed Dial: Managed non-connection.</td>
</tr>
<tr>
<td></td>
<td>apds-jobRELEASE.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tjjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobRELEASE</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Recorded by</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Code91**    | apds-agtRELEASE.rpt  
apds-jobRELEASE.rpt  
apds-tdjobRELEASE  
apds-monthagtRELEASE.rpt  
apds-monthjobRELEASE  
apds-monthtdjobRELEASE  
apds-jobSYSREL.rpt  
apds-tdjobSYSREL.rpt  
apds-monthjobSYSREL.rpt  
apds-monthtdjobSYSREL.rpt | Agent       | Virtual Agent: Virtual message to VOICE.        |
| **Code92**    | apds-agtRELEASE.rpt  
apds-jobRELEASE.rpt  
apds-tdjobRELEASE  
apds-monthagtRELEASE.rpt  
apds-monthjobRELEASE  
apds-monthtdjobRELEASE  
apds-jobSYSREL.rpt  
apds-tdjobSYSREL.rpt  
apds-monthjobSYSREL.rpt  
apds-monthtdjobSYSREL.rpt | Agent       | Virtual Agent: Virtual message to AUTOVOICE.     |
| **Code93**    | apds-agtRELEASE.rpt  
apds-jobRELEASE.rpt  
apds-tdjobRELEASE  
apds-monthagtRELEASE.rpt  
apds-monthjobRELEASE  
apds-monthtdjobRELEASE  
apds-jobSYSREL.rpt  
apds-tdjobSYSREL.rpt  
apds-monthjobSYSREL.rpt  
apds-monthtdjobSYSREL.rpt | Agent       | Sales Verification: Sold campaign                |
| **Code94**    | apds-agtRELEASE.rpt  
apds-jobRELEASE.rpt  
apds-tdjobRELEASE  
apds-monthagtRELEASE.rpt  
apds-monthjobRELEASE  
apds-monthtdjobRELEASE  
apds-jobSYSREL.rpt  
apds-tdjobSYSREL.rpt  
apds-monthjobSYSREL.rpt  
apds-monthtdjobSYSREL.rpt | Agent       | Sales Verification: Sale verified.               |

*Table continues…*
<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th>Recorded by</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Code95</td>
<td>apds-agtRELEASE.rpt</td>
<td>Agent</td>
<td>Sales Verification: Sales not verified.</td>
</tr>
<tr>
<td></td>
<td>apds-jobRELEASE.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtRELEASE.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code96</td>
<td>apds-agtRELEASE.rpt</td>
<td>Agent</td>
<td>Connection to the agent expired.</td>
</tr>
<tr>
<td></td>
<td>apds-jobRELEASE.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtRELEASE.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-jobTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-jobOFCOM.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobOFCOM.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobOFCOM.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobTIME.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobOFCOM.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code97</td>
<td>apds-agtRELEASE.rpt</td>
<td>System</td>
<td>Reserved for system.</td>
</tr>
<tr>
<td></td>
<td>apds-jobRELEASE.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtRELEASE.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code98</td>
<td>apds-agtRELEASE.rpt</td>
<td>Agent</td>
<td>Agent Owned Recall</td>
</tr>
<tr>
<td></td>
<td>apds-jobRELEASE.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-tdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthagtRELEASE.rpt</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Code99</td>
<td>apds-jobRELEASE.rpt</td>
<td>System</td>
<td>Virtual Answering Machine</td>
</tr>
</tbody>
</table>

*Table continues…*
## Field Report (.rpt) Recorded by Description

<table>
<thead>
<tr>
<th>Field</th>
<th>Report (.rpt)</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>apds-tdjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthjobRELEASE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>apds-monthtdjobRELEASE</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Comments on this document? infodev@avaya.com
Chapter 34: PC Analysis Telnet

The PC Analysis Telnet tool allows you to gain access to the Linux-based PC Analysis menus. PC Analysis is a reporting and troubleshooting tool included with the Proactive Contact. You can also use PC Analysis to define and generate extract output files to a network location. You can use the extract files in third party reporting, spreadsheet, and word processing packages.

For information on how to use the Linux-based PC Analysis menus, see Administering Avaya Proactive Contact.

PC Analysis Telnet is available from the Analyst Tools menu only.

**Note:**

If access to Supervisor is not available, you need to use a third-party telnet tool to gain access to Proactive Contact menu system and PC Analysis.

---

**PC Analysis**

Use PC Analysis to create reports, charts, and spreadsheets of Proactive Contact data in third-party spreadsheet, word processing, and reporting applications.

In PC Analysis, you define extract files, generate extract output files, and transfer the extract output files to third-party applications. You can extract files the following formats: *.cfg, *.prn, and *.txt.

---

**PC Analysis Telnet icons**

Using the PC Analysis Telnet tool, you can navigate to the Linux-based menus and PC Analysis screens. The PC Analysis Telnet features appear on the toolbar, File menu, and the Tools menu.

PC Analysis Telnet contains the following features:

<table>
<thead>
<tr>
<th>Name</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connect</td>
<td><img src="image" alt="Connect Icon" /></td>
<td>To select the dialer for which you want to generate or transfer extract data files. This feature is not available while you are connected to a system.</td>
</tr>
</tbody>
</table>

*Table continues…*
Starting PC Analysis Telnet

**About this task**
The PC Analysis Telnet tool allows you to gain access to the Linux-based PC Analysis menus.

**Procedure**

1. Click **Start > All Programs > Proactive Contact > Supervisor > Analyst**.
2. Click **Tools > PC Analysis Telnet**.
   
   The PC Analysis Telnet window appears.
3. Click **File > Connect**.
   
   The Connect to Proactive Contact dialog box appears.
4. From the Name list, select the name of the dialer to which you want to connect, and then click **OK**.
   
   The dialer login: prompt appears in the Telnet window.
5. Use your system or PC Analysis login to gain access to the PC Analysis menus.

---

<table>
<thead>
<tr>
<th>Name</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>You must disconnect from a dialer before you can connect to a different dialer.</td>
</tr>
<tr>
<td>Disconnect</td>
<td>🍃</td>
<td>To end the telnet session for the current dialer. If you exit the menu system, PC Analysis Telnet automatically disconnects your session. After you disconnect, you can connect to a different dialer or exit the PC Analysis Telnet application.</td>
</tr>
<tr>
<td>Exit out of entry</td>
<td>🍃</td>
<td>To move back one screen in the Linux-based screens. Exit out of entry provides the same functionality as Ctrl-x.</td>
</tr>
<tr>
<td>Done with entry</td>
<td>🍃</td>
<td>To move to the next Linux-based screen. Done with entry provides the same functionality as the Done key, F1.</td>
</tr>
<tr>
<td>Select</td>
<td>🍃</td>
<td>Click the icon from the PC Analysis Extraction Configuration Edit screen. Your cursor moves to the Select column. Press Enter after typing the value for the Select column.</td>
</tr>
<tr>
<td>Criteria</td>
<td>🍃</td>
<td>Click the icon from the PC Analysis Extraction Configuration Edit screen. Your cursor moves to the Criteria column. Press Enter after typing the Criteria statement.</td>
</tr>
<tr>
<td>Run extract</td>
<td>🍃</td>
<td>Click the icon from the PC Analysis Extraction Configuration Edit screen to generate a PC Analysis extract output file. The file is based on the configuration of the open extract file.</td>
</tr>
<tr>
<td>Get file</td>
<td>🍃</td>
<td>To transfer one or more PC Analysis extract output files from the dialer to a network location.</td>
</tr>
</tbody>
</table>
6. Enter your key code and press Enter.

# Calling List

The following table contains information about the Calling List fields on the PC Analysis extract.

<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>ABDNDTE</td>
<td>Date, as captured on the system, when the call was abandoned.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>ABDNTME</td>
<td>Time, as captured on the system, when the call was abandoned.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>ABDNCODE</td>
<td>Completion Code assigned to the abandoned call.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>AGENT</td>
<td>ID assigned to the Agent who handled the call.</td>
<td>Character</td>
<td>8</td>
</tr>
<tr>
<td>CODE</td>
<td>Completion code assigned to the call.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>COUNTER</td>
<td>Total of all the retries and recalls on all the numbers dialed from this record.</td>
<td>Numeric</td>
<td>3</td>
</tr>
<tr>
<td>CURPHONE</td>
<td>Phone field that is currently in use: Phone1, Phone2, Phone3</td>
<td>Numeric</td>
<td>2</td>
</tr>
<tr>
<td>CURPHONER</td>
<td>Phone field that is currently in use for a manual recall number (RECALLNUMBER).</td>
<td>Numeric</td>
<td>2</td>
</tr>
<tr>
<td>DAYS_CNT</td>
<td>Number of days for which the record has been maintained on the dialer.</td>
<td>Numeric</td>
<td>3</td>
</tr>
<tr>
<td>DIALERID</td>
<td>ID assigned to the Dialer from which the call has been made.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>DTE</td>
<td>Date, as displayed on the system, when the call was made.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>DUPE</td>
<td>First occurrence of a duplicate record denoted by a *.</td>
<td>Character</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>The first occurrence of a duplicate record does not have a value in the STATUSFLAG field, however, all subsequent duplicate records have their STATUSFLAG set to R.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DUPEREC</td>
<td>The record for which a duplicate is present on the system.</td>
<td>Numeric</td>
<td>10</td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>DUR1</td>
<td>Time for which the customer is in wait queue on the call before getting connected to an agent. For calls resulting in system disposition, this is always be 0.</td>
<td>Numeric</td>
<td>9</td>
</tr>
<tr>
<td>DUR2</td>
<td>Total duration since the time the call is answered to the time when the line is hung up.</td>
<td>Numeric</td>
<td>9</td>
</tr>
<tr>
<td>DUR3</td>
<td>Total duration since the time the digits are outpulsed until the line is hung up. This duration does not include the update time.</td>
<td>Numeric</td>
<td>9</td>
</tr>
<tr>
<td>DUR4</td>
<td>Duration since an agent is assigned to a job until the line is released.</td>
<td>Numeric</td>
<td>9</td>
</tr>
<tr>
<td>DUR5</td>
<td>Duration since agents are assigned to a job until they are free.</td>
<td>Numeric</td>
<td>9</td>
</tr>
<tr>
<td>ENTRYDATE</td>
<td>Date when the customer record was downloaded on the dialer.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>FRSTDATE#</td>
<td>Date when customer’s phone number (phone #) was called for the first time.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>FRSTTIME#</td>
<td>Time when the customer’s phone number (phone #) was called for the first time.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>FRSTSTAT#</td>
<td>Completion code assigned to the first call that was made to the customer’s phone number.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>FRSTDATER</td>
<td>Date when the manual recall number (RECALLNUMBER) was called for the first time.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>FRSTTTIMER</td>
<td>Time when the manual recall number (RECALLNUMBER) was called for the first time.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>FRSTSTATR</td>
<td>Completion code assigned to the call when the manual recall number (RECALLNUMBER) was called for the first time.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>SCNDDATE#</td>
<td>Date when the customer’s phone number (phone #) was called for the second time.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>System Field Name</td>
<td>Description</td>
<td>Field Type</td>
<td>Length</td>
</tr>
<tr>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>------------</td>
<td>--------</td>
</tr>
<tr>
<td>SCNDTIME#</td>
<td>Time when the customer’s phone number (phone #) was called for the second time.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>SCNDSTAT#</td>
<td>Completion code assigned to the second call that was made to the customer’s phone number.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>SCNDDATER</td>
<td>Date when the manual recall number (RECALLNUMBER) was called for the second time.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>SCNDTIMER</td>
<td>Time when the manual recall number (RECALLNUMBER) was called for the second time.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>SCNDSTATR</td>
<td>Completion code assigned to the call when the manual recall number (RECALLNUMBER) was called for the second time.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>THRDDATE#</td>
<td>Date when the customer’s phone number (phone #) was called for the third time.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>THRDTIME#</td>
<td>Time when the customer’s phone number (phone #) was called for the third time.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>THRDSSTAT#</td>
<td>Completion code assigned to the third call that was made to the customer’s phone number.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>THRDDATER</td>
<td>Date when the manual recall number (RECALLNUMBER) was called for the third time.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>THRDTIMER</td>
<td>Time when the manual recall number (RECALLNUMBER) was called for the third time.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>THRDSSTATR</td>
<td>Completion code assigned to the call when the manual recall number (RECALLNUMBER) was called for the third time.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>FRTHDATE#</td>
<td>Date when the customer’s phone number (phone #) was called for the fourth time.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>FRTHTIME#</td>
<td>Time when the customer’s phone number (phone #) was called for the fourth time.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>System Field Name</td>
<td>Description</td>
<td>Field Type</td>
<td>Length</td>
</tr>
<tr>
<td>-------------------</td>
<td>------------------------------------------------------------------------------</td>
<td>------------</td>
<td>--------</td>
</tr>
<tr>
<td>FRTHSTAT#</td>
<td>Completion code assigned to the fourth call that was made to the customer's phone number.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>FRTHDATER</td>
<td>Date when the manual recall number (RECALLNUMBER) was called for the fourth time.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>FRHTTIMER</td>
<td>Time when the manual recall number (RECALLNUMBER) was called for the fourth time.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>FRTHSTATR</td>
<td>Completion code assigned to the call when the manual recall number (RECALLNUMBER) was called for the fourth time.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>FIFTDATE#</td>
<td>Date when the customer's phone number (phone #) was called for the fifth time.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>FIFTTIME#</td>
<td>Time when the customer's phone number (phone #) was called for the fifth time.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>FIFTSTAT#</td>
<td>Completion code assigned to the fifth call that was made to the customer's phone number.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>FIFTDATER</td>
<td>Date when the manual recall number (RECALLNUMBER) was called for the fifth time.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>FIFTTIMER</td>
<td>Time when the manual recall number (RECALLNUMBER) was called for the fifth time.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>FIFTSTATR</td>
<td>Completion code assigned to the call when the manual recall number (RECALLNUMBER) was called for the fifth time.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>FINOPER</td>
<td>Name of the last agent who handled the call. This field is used in case of Sales verification of a job.</td>
<td>Character</td>
<td>8</td>
</tr>
<tr>
<td>JOBID</td>
<td>ID assigned to the job under which the call was made.</td>
<td>Character</td>
<td>8</td>
</tr>
<tr>
<td>JOBNAME</td>
<td>Name of the job under which the call was made.</td>
<td>Character</td>
<td>20</td>
</tr>
<tr>
<td>LASTDATE#</td>
<td>Date when the customer's phone number (phone #) was called for the last time.</td>
<td>Date</td>
<td>8</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>LASTTIME#</td>
<td>Time when the customer’s phone number (phone #) was called for the last time.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>LASTSTAT#</td>
<td>Completion code assigned to the last call that was made to the customer’s phone number.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>LASTDATER</td>
<td>Date when the manual recall number (RECALLNUMBER) was called for the last time.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>LASTSTATR</td>
<td>Completion code assigned to the call when the manual recall number (RECALLNUMBER) was called for the last time.</td>
<td>Character</td>
<td>8</td>
</tr>
<tr>
<td>LASTTIMER</td>
<td>Time when the manual recall number (RECALLNUMBER) was called for the last time.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>MASTERZONE</td>
<td>Time zone of the current phone number in use.</td>
<td>Character</td>
<td>1</td>
</tr>
<tr>
<td>MODZONEPHONE</td>
<td>There is one MODZONEPHONE# field for each PHONE# field and this field contains new area code information for the migrated phone time zone</td>
<td>Character</td>
<td>10</td>
</tr>
<tr>
<td>PHONECNT#</td>
<td>Number of call attempts that were made to the customer number (phone #).</td>
<td>Numeric</td>
<td>2</td>
</tr>
<tr>
<td>PHONECNTR</td>
<td>Number of call attempts on the manual recall number (RECALLNUMBER) of the customer.</td>
<td>Numeric</td>
<td>2</td>
</tr>
<tr>
<td>PHONESTAT</td>
<td>The PHONESTAT field is set when the setzones is executed during the list preprocessing. PHONESTAT changes constantly during the daily processing. Each phone number in the calling list has a corresponding character in the PHONESTAT field. For example, if list1 has two phone numbers, the PHONESTAT field contains two characters. The first character corresponds to PHONE1 and the second character corresponds to PHONE2. Each character in the P</td>
<td>Character</td>
<td>3</td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>PHONESTAT</td>
<td><strong>PHONESTAT field may contain one of five different characters:</strong>&lt;br&gt;• N = not called&lt;br&gt;• B = bad number&lt;br&gt;• C = called&lt;br&gt;• O = passed to agent&lt;br&gt;• A = active/set for recall&lt;br&gt;PHONESTATR is used by the system to determine which phone number is incorrect.&lt;br&gt;Phones that have a B in their corresponding PHONESTAT field will not be attempted.&lt;br&gt;When a job is verified, PHONESTAT fields with C or O are reset back to N.</td>
<td>Character</td>
<td>1</td>
</tr>
<tr>
<td>PHONESTATR</td>
<td>PHONESTATR changes constantly during the daily processing. The manual recall phone number in the calling list has a corresponding character in the PHONESTATR field. The PHONESTATR field may contain one of five characters:&lt;br&gt;• N = not called&lt;br&gt;• B = bad number&lt;br&gt;• C = called&lt;br&gt;• O = passed to agent&lt;br&gt;• A = active/set for recall&lt;br&gt;PHONESTATR is used by the system to determine which phone number is incorrect. Phones numbers that display B in their corresponding PHONESTATR field are not attempted for recall.</td>
<td>Character</td>
<td>1</td>
</tr>
<tr>
<td>RECALLDATE</td>
<td>Date for which the recall timer is set.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>RECALLPHONE</td>
<td>System phone to be recalled. This information is set by the agent at the time of calling.</td>
<td>Character</td>
<td>2</td>
</tr>
<tr>
<td>System Field Name</td>
<td>Description</td>
<td>Field Type</td>
<td>Length</td>
</tr>
<tr>
<td>-------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>------------</td>
<td>--------</td>
</tr>
<tr>
<td>RECALLNAME</td>
<td>Name of the customer for which the recall has been set.</td>
<td>Character</td>
<td>30</td>
</tr>
<tr>
<td>RECALLNUMBER</td>
<td>Customer phone number, other than the phone numbers that are reflecting in the customer record, for which the recall has been set.</td>
<td>Character</td>
<td>12</td>
</tr>
<tr>
<td>RECALLTIME</td>
<td>Time for which the recall timer is set.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>SHADOWJOB</td>
<td>Name of the shadow job associated with the Agent owned recall set for the customer record.</td>
<td>Character</td>
<td>20</td>
</tr>
<tr>
<td>STATUSFLAG</td>
<td>Status of the record. If anything other than a “null” (might appear as a blank entry) appears, then the record is considered as not callable:</td>
<td>Character</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>• T = failed time zone</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• B = bad phone number</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• D = too many days on system</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• R = duplicate record</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• E = manual delete via record edit</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• C = call on inbound campaign, cancelled in outbound campaign</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• N = Do Not Call</td>
<td></td>
<td></td>
</tr>
<tr>
<td>SVJCODE</td>
<td>Sales verification code. This field is used in case of sales verification jobs.</td>
<td>Character</td>
<td>3</td>
</tr>
<tr>
<td>TME</td>
<td>Time, as captured on the system, when the call was made.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>TME_STAMP</td>
<td>Time displayed as Universal Time Coordinated (UTC), as captured on the system, when the call was made.</td>
<td>Numeric</td>
<td>12</td>
</tr>
<tr>
<td>ZONEPHONE#</td>
<td>Time zone associated with the geographical location of the customer phone number (phone #).</td>
<td>Character</td>
<td>1</td>
</tr>
<tr>
<td>ZONEPHONER</td>
<td>Time zone associated with the geographical location of the manual recall number (RECALLNUMBER).</td>
<td>Character</td>
<td>1</td>
</tr>
</tbody>
</table>
## Call Information Statistics

The following table contains information about the Call Information Statistics fields on the PC Analysis extract.

<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>INF_JOBNUM</td>
<td>System identification number assigned to a job. This number increases each time the system runs the job.</td>
<td>Numeric</td>
<td>6</td>
</tr>
<tr>
<td>INF_DATE</td>
<td>Date on which the event occurred. See INF_EVENTLABL.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>INF_TIME</td>
<td>Time when the event occurred. See INF_EVENTLABL.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>INF_EVENTLABL</td>
<td>The name of the reported event. For example, line usage, hit rate, acquire, release, and log on.</td>
<td>Character</td>
<td>20</td>
</tr>
<tr>
<td>INF_FREE</td>
<td>Data for the event in the event label field. For example, hit rate shows the current hit rate; line usage shows the current line usage.</td>
<td>Character</td>
<td>8</td>
</tr>
<tr>
<td>INF_AGENTNAME</td>
<td>User name assigned to the agent.</td>
<td>Character</td>
<td>8</td>
</tr>
<tr>
<td>INF_CLOCKTIME</td>
<td>This field has several uses:</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td></td>
<td>• For LOG OFF events, it displays the total work time for last assignment, and not the time since log on.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• For JOBTIME, it is the last entry in the file displaying the total job time.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• For agent transfer event, it is the time the agent spent on the previous assignment.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>INF_IDLETIME</td>
<td>Duration of idle time between the same type of calls.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INF_IDLETYPE</td>
<td>Job type to which the idle agent is assigned.</td>
<td>Character</td>
<td>1</td>
</tr>
<tr>
<td>INF_CALLTYPE</td>
<td>Type of call: outbound, inbound, or blend.</td>
<td>Character</td>
<td>1</td>
</tr>
<tr>
<td>INF_UNITID</td>
<td>ID assigned to the Unit work list.</td>
<td>Character</td>
<td>15</td>
</tr>
</tbody>
</table>

*Table continues…*
### Call Transaction Statistics

The following table contains information about the Call Transaction Statistics fields on the PC Analysis extract.

<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>INF_LOGTYPE</td>
<td>The log on type of the agent: outbound, inbound, blend, managed, or Person-to-person (PTP).</td>
<td>Character</td>
<td>1</td>
</tr>
<tr>
<td>TRN_JOBNUM</td>
<td>System identification number assigned to a job.</td>
<td>Numeric</td>
<td>6</td>
</tr>
<tr>
<td>TRN_DATE</td>
<td>Date when the event occurred.</td>
<td>Date</td>
<td>10</td>
</tr>
<tr>
<td>TRN_TIME</td>
<td>Time when the event occurred.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td>TRN_WAITTIME</td>
<td>Total duration for which the customer was in the wait queue.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>TRN_USERFIELD</td>
<td>This field can be defined by the user.</td>
<td>Character</td>
<td>80</td>
</tr>
<tr>
<td>TRN_TELELINE</td>
<td>Line number that the call used.</td>
<td>Numeric</td>
<td>3</td>
</tr>
<tr>
<td>TRN_COMPCODE</td>
<td>The completion code that the system entered by for the call.</td>
<td>Numeric</td>
<td>3</td>
</tr>
<tr>
<td>TRN_RECNUM</td>
<td>Number assigned to the customer record.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>TRN_PHONENUM</td>
<td>Phone number of the customer in case of the outbound calling.</td>
<td>Character</td>
<td>20</td>
</tr>
<tr>
<td>TRN_AGENTNAME</td>
<td>User name assigned to the agent who attended this call.</td>
<td>Character</td>
<td>8</td>
</tr>
<tr>
<td>TRN_RECALLCNT</td>
<td>Number of times the system has recalled the record.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>TRN_TALKTIME</td>
<td>Agent talk time for the call.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>TRN_WORKTIME</td>
<td>Agent work time for the call.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>TRN_V_TO_HANG</td>
<td>Duration between the time the customer answered the call and the release of line. An exception to this calculation is in case of a managed (preview) call. If there is no call progress analysis, the timer starts when the call is delivered to an agent.</td>
<td>Numeric</td>
<td>8</td>
</tr>
</tbody>
</table>

Table continues…
<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>TRN_OFF_TO_HNG</td>
<td>Duration between the time the system initiated the call and the release of line.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>TRN_P_FIELDNUM</td>
<td>Phone number of the customer in case of inbound call</td>
<td>Numeric</td>
<td>1</td>
</tr>
<tr>
<td>TRN_CONNECT</td>
<td>Flag that marks the call as connect.</td>
<td>Numeric</td>
<td>1</td>
</tr>
<tr>
<td>TRN_UNITID</td>
<td>Unit ID assigned to the call</td>
<td>Character</td>
<td>15</td>
</tr>
<tr>
<td>TRN_UPDATETIME</td>
<td>Time an agent takes for updating the record.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>TRN_PREVTIME</td>
<td>Time the agent spends while previewing the record on a managed job.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>TRN_TRANSTYPE</td>
<td>Call type: inbound or outbound.</td>
<td>Character</td>
<td>1</td>
</tr>
<tr>
<td>TRN_AGCOMPCODE</td>
<td>The completion code that the agent entered for the call.</td>
<td>Numeric</td>
<td>3</td>
</tr>
<tr>
<td>TRN_LOGTYPE</td>
<td>Agent log on type: outbound, inbound, blend, managed, or PTP.</td>
<td>Character</td>
<td>1</td>
</tr>
</tbody>
</table>

### Job History

The following table contains information about the Job History fields on the PC Analysis extract.

<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>JOBNAME</td>
<td>Name of the job for which the report has been generated.</td>
<td>Character</td>
<td>20</td>
</tr>
<tr>
<td>JOBNUMBER</td>
<td>System identification number assigned to a job. This number increases each time the system runs the job.</td>
<td>Character</td>
<td>6</td>
</tr>
<tr>
<td>JOBTYPE</td>
<td>Indicates the job type: inbound, outbound, or blend.</td>
<td>Character</td>
<td>5</td>
</tr>
<tr>
<td>UNITID</td>
<td>Unit work list key value for a unit work list job. For example, if you base the unit work lists on ZIP codes, then this field displays the ZIP codes used by that job.</td>
<td>Character</td>
<td>15</td>
</tr>
<tr>
<td>JOBDAY</td>
<td>Date when the job was started.</td>
<td>Date</td>
<td>10</td>
</tr>
</tbody>
</table>

*Table continues...*
<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>STARTTIME</strong></td>
<td>Time when the job was started.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td><strong>ENDTIME</strong></td>
<td>Time when the job was stopped.</td>
<td>Time</td>
<td>8</td>
</tr>
<tr>
<td><strong>ACTIVETIME</strong></td>
<td>Total job call processing time. This duration does not include the start time or the suspension time.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td><strong>JOB_CLOCKTIME</strong></td>
<td>Total agent hours on a job. It is a total of the following fields: JOB_TALKTIME, JOB_UPDATETIME, and JOB_IDLETIME fields.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td><strong>JOB_IDLETIME</strong></td>
<td>Total duration for which the agents were idle. It does not include the time between the agents' login and the first call that was made or the time between the release of agents' final record and log off. For a blend job, it includes the transfer time between jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td><strong>JOB_TALKTIME</strong></td>
<td>Total talk time for all the agents on all the jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td><strong>JOB_UPDATETIME</strong></td>
<td>Total update time for all the agents on all the jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td><strong>JOB_WORKTIME</strong></td>
<td>Total work time for all the agents on all the jobs. This field displays the total of JOB_TALKTIME and JOB_UPDATETIME fields.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td><strong>JOB_IDLECOUNT</strong></td>
<td>Number of times the agents were idle.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td><strong>JOB_CALLSWORKED</strong></td>
<td>Total number of calls handled by the agents on all the jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td><strong>JOB_CALLSANSWERE D</strong></td>
<td>Total number of calls handled on inbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td><strong>JOB_WAITQUEUE TIME</strong></td>
<td>Time (in seconds) that customer spent in the wait queue.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td><strong>JOB_CALLSINWAIT</strong></td>
<td>Total number of calls placed in the wait queue.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td><strong>OUT_CLOCKTIME</strong></td>
<td>Total duration for which the agents were on outbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td><strong>OUT_IDLETIME</strong></td>
<td>Total duration of idle time on the outbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td><strong>OUT_TALKTIME</strong></td>
<td>Total duration of talk time on the outbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>OUT_UPDATETIME</td>
<td>Total duration of update time on the outbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_WORKTIME</td>
<td>Total work time on outbound jobs. This field displays the total of the OUT_TALKTIME and OUT_UPDATETIME fields.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_IDLECOUNT</td>
<td>Number of times the agents were idle on the outbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_CALLSWORKED</td>
<td>Total number of outbound calls handled by the agents.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_CALLSANSWERED</td>
<td>Total number of outbound calls answered.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_WAITQUEUETIME</td>
<td>Total time outbound customer spent in the wait queue.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_CALLSINWAIT</td>
<td>Total number of outbound calls placed in the wait queue.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_CALLSPLACED</td>
<td>Total number of outbound calls placed.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_RECALLSPLACED</td>
<td>Total number of recalls placed.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_CLOCKTIME</td>
<td>Total time spent on inbound calls by agents. This field displays the total of the INB_TALKTIME, INB_UPDATETIME and INB_IDLETIME fields.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_IDLETIME</td>
<td>Total duration of idle time on inbound calls.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_TALKTIME</td>
<td>Total duration of talk time on inbound calls.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_UPDATETIME</td>
<td>Total duration of update time on inbound calls.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_WORKTIME</td>
<td>Total work time on inbound calls. This field displays the total of the INB_TALKTIME and INB_UPDATETIME fields.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_IDLECOUNT</td>
<td>Number of times agents were idle on inbound calls.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_CALLSWORKED</td>
<td>Total number of inbound calls that were handled by the agents.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_CALLSANSWERED</td>
<td>Total number of inbound calls received per job.</td>
<td>Numeric</td>
<td>8</td>
</tr>
</tbody>
</table>

Table continues...
### Agent History

The following table contains information about the Agent History fields on the PC Analysis extract.

<table>
<thead>
<tr>
<th>System Field Name</th>
<th>Description</th>
<th>Field Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>INB_WAITQUEUETIME</td>
<td>Total time customer spent in the inbound wait queue.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_CALLSINWAIT</td>
<td>Total number of calls placed in the inbound wait queue.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>XOUT_CLOCKTIME</td>
<td>Total time spent as Person-to-person (PTP) agent.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>XOUT_IDLETIME</td>
<td>Total duration of PTP idle time.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>XOUT_IDLECOUNT</td>
<td>Number of times PTP agents were idle.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>XOUT_CALLSWORKED</td>
<td>Total number of PTP calls.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>PREVIEWTIME</td>
<td>Total time agents spent previewing records during Managed Dialing.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>LISTNAME</td>
<td>Name of the calling list.</td>
<td>Character</td>
<td>20</td>
</tr>
<tr>
<td>JOBLABEL</td>
<td>Job description as included in the job file.</td>
<td>Character</td>
<td>40</td>
</tr>
<tr>
<td>SELECTNAME</td>
<td>Name of the record selection file.</td>
<td>Character</td>
<td>20</td>
</tr>
<tr>
<td>STRATEGYNAME</td>
<td>Name of the phone strategy file.</td>
<td>Character</td>
<td>20</td>
</tr>
<tr>
<td>COMPCODEXXX</td>
<td>Call Completion Codes as defined in the system. The range of completion code is between 0-199.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>System Field Name</td>
<td>Description</td>
<td>Field Type</td>
<td>Length</td>
</tr>
<tr>
<td>---------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>------------</td>
<td>--------</td>
</tr>
<tr>
<td>AGENTNAME</td>
<td>User name assigned to the agent.</td>
<td>Character</td>
<td>20</td>
</tr>
<tr>
<td>JOB_CLOCKTIME</td>
<td>Total number of agent hours on a job. This field displays the total of JOB_TALKTIME, JOB_UPDATETIME, and JOB_IDLETIME fields.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>JOB_IDLETIME</td>
<td>Total duration of idle time for agent. This field does not include the duration between the logging in of the agents and when they make the first call. This field also does not include time between the release of agents’ final record and log off. For a blend job, it includes transfer time between jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>JOB_TALKTIME</td>
<td>Total duration of talk time for all the agents.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>JOB_UPDATETIME</td>
<td>Total duration of update time for all the agents.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>JOB_WORKTIME</td>
<td>Total duration of work time, which is a total of JOB_TALKTIME and JOB_UPDATETIME fields.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>JOB_IDLECOUNT</td>
<td>Number of times agent was idle.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>JOB_CALLSWORKED</td>
<td>Total number of calls handled during a job.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_CLOCKTIME</td>
<td>Total duration of outbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_IDLETIME</td>
<td>Total duration of idle time on outbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_TALKTIME</td>
<td>Total duration of talk time on outbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_UPDATETIME</td>
<td>Total duration of update time on outbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_WORKTIME</td>
<td>Total duration of work time on outbound jobs. This field displays the total of OUT_TALKTIME and OUT_UPDATETIME fields.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_IDLECOUNT</td>
<td>Number of times agent was idle on outbound jobs.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>OUT_CALLSWORKED</td>
<td>Total number of outbound calls handled.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>System Field Name</td>
<td>Description</td>
<td>Field Type</td>
<td>Length</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>------------</td>
<td>--------</td>
</tr>
<tr>
<td>INB_CLOCKTIME</td>
<td>Total duration of inbound calls. This field displays the total of INB_TALKTIME, INB_UPDATETIME and INB_IDLETIME fields.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_IDLETIME</td>
<td>Total duration of idle time on inbound calls.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_TALKTIME</td>
<td>Total duration of talk time on inbound calls.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_UPDATETIME</td>
<td>Total duration of update time on inbound calling.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_WORKTIME</td>
<td>Total duration of work time on inbound calls. This field displays the total of INB_TALKTIME and INB_UPDATETIME fields.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_IDLECOUNT</td>
<td>Number of times agents were idle on inbound calls.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>INB_CALLSWORKED</td>
<td>Total number of inbound calls handled.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>XOUT_CLOCKTIME</td>
<td>Total time spent on acting as Person to Person (PTP) agent.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>XOUT_IDLETIME</td>
<td>Total duration of PTP idle time.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>XOUT_IDLECOUNT</td>
<td>Number of times PTP agent was idle.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>XOUT_CALLSWORKED</td>
<td>Total number of PTP calls.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>PREVIEWTIME</td>
<td>Total time spent by agents for previewing records during Managed Dialing.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>LISTNAME</td>
<td>Name of the calling list.</td>
<td>Numeric</td>
<td>20</td>
</tr>
<tr>
<td>OFFLINE</td>
<td>Total time spent off-line, that is the agents were logged in but not on any job.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>RELEASE</td>
<td>Time spent on releasing the ACD in Predictive Blend.</td>
<td>Numeric</td>
<td>8</td>
</tr>
<tr>
<td>COMPCODEXXX</td>
<td>Call Completion Codes as defined in the system. The range of completion code is between 0-199.</td>
<td>Numeric</td>
<td>8</td>
</tr>
</tbody>
</table>
Transferring PC Analysis extract output files

Procedure

1. Start **PC Analysis Telnet**.
2. Connect to a dialer.
3. Select **Tools > Get file**.
   - The FTP Client dialog box appears. The name of the system to which you are connected appears in the dialog box title.
4. Select one or more extract output files to transfer, and then click **Get file**.
   - The Save As dialog box appears.
5. Browse to the location where you want to transfer the selected extract output file, and then click **Save**.
   - The system saves the file to the selected location. If you selected more than one extract output file to transfer, the Save As dialog box appears for the next file.
6. Repeat Step 5 for each extract output file you selected to transfer.
   - After you click save for the last output file, the FTP Client dialog box appears.
7. Click **Cancel** to close the FTP Client dialog box.

FTP Client dialog box field descriptions

With the FTP Client dialog box you can transfer PC Analysis extract files from Avaya Proactive Contact to a network location, such as a personal computer.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File Name</td>
<td>Lists the PC Analysis extract files that currently exist on the selected dialer. Extract files typically have a .prn extension (for example, list1.prn).</td>
</tr>
<tr>
<td>Size</td>
<td>Lists the file size of each extract file.</td>
</tr>
<tr>
<td>Date</td>
<td>Identifies the date that the extract file was generated.</td>
</tr>
<tr>
<td>Get file</td>
<td>Use <strong>Get file</strong> to transfer one or more selected extract files. The Save As dialog box appears, which lets you choose where you want to save the file.</td>
</tr>
</tbody>
</table>
Chapter 35: Hierarchy Manager

With Hierarchy Manager, you can group and organize data.

Hierarchy Manager allows you to create agent, job, or dialer hierarchies to reflect your company’s or business’ organization. For example, you can create relationships between the Proactive Contact agents and the management structure of your company.

In Monitor, you can also use hierarchies to adjust the scope of data to view.

In Analyst, you can use hierarchies to group data in reports.

A hierarchy contains one or more branches. Each branch contains three hierarchy levels: top, middle, and bottom.

Each branch can contain more than one middle level. Each middle level can contain one or more bottom levels. You can assign one or more data items to the bottom level.

For example: A job hierarchy contains two branches. Each branch follows this structure:

- Top level is Portfolio, such as Loans or Savings.
- Middle level is Account Type, such as Car, Mortgage or Certificate Deposits.
- Bottom level is Term, the length of the loan or savings account such as 60 months, 30 years.

The data items in the bottom level data items are job names.

Note:

In the multitenancy environment, you can create, modify, or view hierarchies only for your tenant.

After you add a job or an agent to Proactive Contact, the job or agent is available for use in Hierarchy Manager. Agents, jobs, and dialers are available in Hierarchy Manager until data in the database expires. This allows for historical reporting.

Example

For example: When you remove an agent login from Proactive Contact, the database still contains data for that agent. As a result, the agent name appears in the Hierarchy Manager list of available agents.
Agent hierarchies

An agent hierarchy creates statistical relationships for individual agent activity and performance data that Proactive Contact collects during calling activities. Activity and performance data examples include Talk Time, Idle Time, and Connects per Hour.

Agent hierarchies are most effective when monitoring agent views in Monitor and when grouping data in Analyst agent reports.

For example, an agent hierarchy can represent the management structure of a company. Top, middle, and bottom levels represent directors, managers, and supervisors, respectively. Agents are assigned to each supervisor. Monitor can use this hierarchy to group agent activity and performance data by supervisor.

Job hierarchies

A job hierarchy creates statistical relationships for individual job activity data that Proactive Contact collects during calling activities. Examples of job activity data include Calls Placed, Connects per Hour, and Time in Wait Queue.

Job hierarchies are most effective in Monitor to monitor job views and in Analyst to group data in Analyst job reports.

In a multi-dialer environment, job hierarchies apply to all jobs across all dialers unless you:

- Create all jobs unique across all dialers
- Create a dialer-job relationship outside of Hierarchy Manager.

For example, when you create a job, include a reference to the dialer in the job name such as job1_dialer1.

Dialer hierarchies

A dialer hierarchy creates relationships for individual dialer activity data that Proactive Contact collects during calling activities. Dialer activity includes all available job and agent activity and performance data.

Dialer hierarchies are effective to group data by department and dialer.

For example: In a four-dialer pod environment, the collections and marketing departments use the following dialers:

- Collections uses dialer1 and dialer2
- Marketing department uses dialer3 and dialer4
A hierarchy branch could contain a level for department with individual dialers assigned to the level.

---

**Starting Hierarchy Manager**

**Procedure**

1. Click one of the following:
   - Start > All Programs > Avaya > Proactive Contact > Supervisor > Monitor.
   - Start > All Programs > Avaya > Proactive Contact > Supervisor > Analyst.
2. Click **Tools > Hierarchy Manager**.
   The Hierarchy Manager window appears.

---

**Creating a hierarchy**

**About this task**

You can create an agent, job, or dialer hierarchy based on the hierarchy type you select. When you create a new hierarchy, you add top, middle, and bottom hierarchy levels and assign data items to the bottom hierarchy.

**Note:**

If you name two like levels the same under one parent level, Hierarchy Manager combines the two like levels into one level.

For example, a middle level hierarchy contains two bottom levels, both named as Supervisor. Hierarchy Manager combines all the data items assigned to both the Supervisor levels and removes the duplicate level.

**Procedure**

1. On the button bar, click **Agent Hierarchies**, **Job Hierarchies**, or **Dialer Hierarchies** depending on the type of hierarchy you want to create.
2. Click **File > New**.
   - The **Available** list contains agent, job, or dialer names depending on which hierarchy type you selected.
   - Hierarchy Manager displays a new hierarchy including a default structure.
3. Right-click the level to add a level.
4. Click **Add Level**.
   - Hierarchy Manager inserts a level named New Level.
5. Right-click **New Level** and select **Rename**.
6. Enter a new name up to 20 characters, and then press **Enter**.
7. Repeat Steps 3 and 4 for each level you want to add to the hierarchy.
8. Drag and drop a data item from the **Available** list onto the bottom level of the branch to which you want to add it.

   Hierarchy Manager moves the data item from the **Available** list to the **Allocated** list.
9. Click **File > Save** to save the hierarchy settings.

   Hierarchy Manager does not save branches that do not contain data items. Empty branches do not appear in the hierarchy after you close and restart Hierarchy Manager.
10. In the Save As dialog box, enter a name for the hierarchy and click **OK**.

    The name can have up to 64 characters.

---

**Opening a hierarchy to view or change**

**Procedure**

1. On the button bar, click **Agent Hierarchies**, **Job Hierarchies**, or **Dialer Hierarchies** depending on the type of hierarchy you want to open.

   A list of hierarchies appears in the button bar for the selected hierarchy type.

2. Click a hierarchy.

   The selected hierarchy appears.

---

**Adding a level to a hierarchy**

**About this task**

To build your organizational structure in Hierarchy Manager, you add levels to a hierarchy. Each branch in a hierarchy contains three levels: top, middle, and bottom.

When you add a level, Hierarchy Manager adds a level below the selected level. For example: If you add a level to a top level item, Hierarchy Manager adds a middle level item. To add a top level item, add a level to the hierarchy name.

**Procedure**

1. Open the hierarchy that you want to change.

2. Right-click the level to add a level.

3. Click **Add Level**.
Adding a data item to a hierarchy

About this task
Hierarchy Manager lets you add data items to only the bottom-most levels of the hierarchy.

Procedure
1. Open the hierarchy to which you want to add data items.
2. Select one or more items in the Available list and drag the items to the appropriate level.

   After an item is added to the hierarchy, Hierarchy Manager moves the data item from the Available list to the Allocated list.

   Tip:
   To select two or more adjacent items in the Available list, click the first item, and then hold down Shift and click the last item. To select two or more non-adjacent items, click the first item, and then hold down Ctrl and click additional items.

Maintaining Hierarchy Manager
As your organization changes, you might need to rearrange elements in a hierarchy, rename levels or remove levels in a hierarchy to reflect your organizational changes.

Moving a level or item within a hierarchy

About this task
As your organization changes, you might need to rearrange elements in a hierarchy to reflect the changes.

You can move data items from one bottom level to another. For example: in an agent hierarchy, you can move an agent from one supervisor to another.

You can also move a level within a hierarchy. Items and levels that you move must maintain their same level in the hierarchy. For example: A bottom level cannot be moved to a middle level position.

To move a level or a data item within a hierarchy:
Procedure

1. Open the hierarchy that you want to change.
2. Select the level or data item that you want to move, and then drag it to the hierarchy level above which you want the level or item to be listed.
3. Repeat Step 2 for each level or item that you want to move.

Renaming a hierarchy level

About this task

Hierarchy Manager lets you rename levels in a hierarchy to reflect organizational changes.

Note:

If you name two like levels the same under one parent level, Hierarchy Manager combines the two like levels into one level.

For example: A hierarchy middle level contains two bottom levels named Supervisor. Hierarchy Manager combines all data items assigned to both Supervisor levels and removes the duplicate level.

To rename a hierarchy level:

Procedure

1. Open the hierarchy in which you want to rename a level.
2. Right-click the hierarchy level name that you want to change, and then select Rename.
3. Type a new name for the level (up to 20 characters), and then press Enter.

Removing a level from a hierarchy

About this task

As your organization changes, you can use Hierarchy Manager to reflect those changes in your hierarchies.

You can remove a level from your hierarchy to better represent your organization.

To remove a top or middle hierarchy level that contains a bottom level with data items, you must first delete the bottom level (and data items).

To remove a level from a hierarchy:

Procedure

1. Open the hierarchy from which you want to remove a level.
2. Right-click the level that you want to remove, and then select Delete. If the level you select to remove contains data items, Hierarchy Manager displays a message confirming whether you want to delete the selected level and all the agents associated with that level.
3. Click **Yes** to delete the level. Hierarchy Manager removes the level and moves the data items from the **Allocated** list to the **Available** list.

---

**Removing a data item from a hierarchy**

**About this task**

You can remove a data item from a hierarchy when the item no longer meets your organizational needs. You can remove individual data items as described in the following procedure. You can also remove all the data items assigned to a bottom level by removing the bottom level.

**Procedure**

1. Open the hierarchy from which you want to remove one or more data items.
2. Right-click a data item that you want to remove, and then select **Delete**. Hierarchy Manager removes the data item from the hierarchy, and moves the data item from the **Allocated** list to the **Available** list.
3. Repeat Step 2 for each data item you want to remove.

---

**Renaming a hierarchy**

**About this task**

To rename a hierarchy:

**Procedure**

1. Open the hierarchy that you want to change.
2. Click **File > Save**.
3. In the Save As dialog box, enter a unique name for the hierarchy.
   - A hierarchy name can contain up to 64 characters and can include the following special characters: parentheses ( ), comma (,), hyphen (-), dollar sign ($), and the pound sign (#).
4. Click **OK**.
   - Hierarchy Manager saves the hierarchy settings with the new name.

---

**Deleting a hierarchy**

**About this task**

As your organization changes, you might decide to no longer use a particular hierarchy. You can delete a hierarchy from Hierarchy Manager.
Procedure

1. Open the hierarchy that you want to change.
2. Select **Hierarchy** > **Delete**. Hierarchy Manager asks you to confirm the delete action.
3. Click **Yes** to delete the hierarchy. Hierarchy Manager removes the selected hierarchy.
Chapter 36: System Telnet

With System Telnet tool, you can access the Linux-based Supervisor and Administrative menus.

Note:

System Telnet is not available in the Proactive Contact Supervisor suite for Chinese, Japanese, and Korean (CJK) languages. When you start System Telnet the first time, the system displays a message: System Telnet is not available. You must then provide the path of the custom Telnet application. You can start Telnet without any error from the Supervisor application.

A supervisor of tenant space can gain access to the system telnet session. Supervisors can gain access to only the configurations that are within the tenant space.

Use the Linux-based Supervisor and Administrative menus to perform the following within the defined tenant space:

• Check calling list status
• Manage agent job lists
• Gain access to some Monitor and Editor features

However, you can use the Linux-based Supervisor and Administrative menus to manage user accounts for the default tenant. Lead Administrator can also perform the management of user account using the Supervisor and Administrative menus.

System Telnet is available from the Tools menu in Analyst, Editor, or Monitor.

Note:

• Proactive Contact does not allow you to change your password using the System Telnet.
• If access to Supervisor is not available, you must use a third-party telnet tool to gain access to the Proactive Contact menu system and PC Analysis.

To access the PC Analysis menus, use the PC Analysis Telnet tool in Analyst.

System Telnet features

Use the System Telnet window to navigate to the Linux-based menus.

The System Telnet features appear on the System Telnet toolbar, File menu and Tools menu.
System Telnet has the following features:

<table>
<thead>
<tr>
<th>Feature</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connect</td>
<td><img src="icon.png" alt="Icon" /></td>
<td>With Connect, select the dialer for which you want to gain access to Linux-based features. This function is not available while you are connected to a dialer. You must disconnect from a dialer before you can connect to a different dialer.</td>
</tr>
<tr>
<td>Disconnect</td>
<td><img src="icon.png" alt="Icon" /></td>
<td>With Disconnect, end the telnet session for the current dialer. If you exit the menu system, System Telnet automatically disconnects your session. After you disconnect, you can connect to a different dialer or exit the System Telnet application.</td>
</tr>
<tr>
<td>Exit out of entry</td>
<td><img src="icon.png" alt="Icon" /></td>
<td>With Exit out of entry, move back one screen in the Linux-based screens. Exit out of entry provides the same functionality as the Ctrl-x key.</td>
</tr>
<tr>
<td>Done with entry</td>
<td><img src="icon.png" alt="Icon" /></td>
<td>With Done with entry, move to the next Linux-based screen. Done with entry provides the same functionality as the Done key, F1. The results of clicking the Done with entry button and pressing Enter on the keyboard are different. Therefore, you must click Done with entry when the system displays such a message.</td>
</tr>
</tbody>
</table>

### Accessing System Telnet

**Procedure**

1. Do any one of the following:
   - Click **Start > All Programs > Avaya > Proactive Contact > Supervisor > Editor**
   - Click **Start > All Programs > Avaya > Proactive Contact > Supervisor > Monitor**

2. Click **Tools > System Telnet**.
   The System Telnet window appears.

3. Click **File > Connect**.
   The dialog box appears.

4. From the **Name** list, select the name of the dialer to which you want to connect, and then click **OK**.
   The dialer message appears in the System Telnet window.

5. Type one of the following login and password combinations:
   - System login and password to gain access to the system menus
   - Administrator login and password to gain access to the administrative menus
   The Linux-based menu system associated with your user name appears in the System Telnet window.
Pointing to the correct third party client for CJK languages

Procedure

1. Do any one of the following:
   • Select **Start** > **All Programs** > **Avaya** > **Proactive Contact** > **Supervisor** > **Editor**
   • Select **Start** > **All Programs** > **Avaya** > **Proactive Contact** > **Supervisor** > **Monitor**

2. Select **Tools** > **System Telnet**.
   The system displays the System Telnet window.
   The system displays a message:
   Unable to locate Telnet.exe. Do you want to browse for it?

3. Click **Yes**.

4. Select any Telnet application, for example, putty.exe

   ✴ **Note:**
   The choice of the telnet application depends on the customer.
Agent Blending integrates outbound calling activities on your Proactive Contact system with inbound calling activities on your ACD.

The Agent Blending tool allows you to manage the ACD domains and domain groups. A domain is an ACD call queue. Every domain is a member of a domain group.

Proactive Contact provides two types of Agent Blending: Predictive Agent Blending and Proactive Agent Blending.

Both Agent Blending systems use a pool of ACD blend agents for outbound calling. The ACD agents log in to the dialer and the ACD. Agent Blending monitors the activity on the ACD to determine when to move agents between inbound and outbound calling activities. You can acquire agents from a domain which is within the same tenant space as the running job. You can view only those configurations that are defined for the tenant to which you belong.

A single ACD agent can be assigned to different tenants with each tenant having a domain group data. If you want to move an agent from one tenant to another tenant, you must first log out of ACD from your phone and log in with the appropriate ACD login ID for your tenant.

Only the Lead Administrator can start or stop the blend services and make blend configurations.

The dialer acquires the pooled agents for outbound calling when the inbound calling activity decreases. The dialer releases the pooled agents to inbound calling when the inbound calling activity increases. The movement between inbound and outbound calling keeps the ACD blend agents busy and the ACD service level within your prescribed limits.

Use Predictive Agent Blending if your priority is servicing your inbound customers and your inbound volume is fairly high.

Use Predictive Agent Blending if your call center has:

- Moderate to heavy inbound traffic
- More than 25 agents in an inbound pool

Predictive Agent Blending

Use Predictive Agent Blending if your priority is servicing your inbound customers and your inbound volume is fairly high.
Predictive Agent Blending focuses on the inbound mission. With Predictive Agent Blending you can use events from the ACD to forecast call volume and determine when to move ACD agents between inbound and outbound calling. The dialer predicts when too many agents receive inbound calls. The dialer then acquires agents from the ACD to handle outbound calls until the inbound volume increases.

The system acquires agents for outbound calls when either the settings for the **Average Speed to Answer** or **Service Level** domain groups have more than the desired value.

To configure Predictive Agent Blending, set up an **Average Speed to Answer** or a **Service Level** domain group that contains one or more acquire domains and at least one inbound domain.

---

**Average Speed to Answer**

This domain group type uses the target **Average Speed to Answer** field to calculate when to acquire and release agents.

- The dialer acquires agents for outbound calls when the average speed to answer for all inbound domains in the group is less than or equal to the targeted value.
- The dialer releases agents when the value rises more than the target.

---

**Service Level**

This domain group type uses the **Service Criterion (SC, seconds)**, **Desired Service Level (DSL, %)**, and **Abatement Service Level (ASL, %)** fields for calculating when to acquire and release agents.

- The dialer acquires agents for outbound calls when the percentage of inbound calls answered within the **Service Criterion** field is greater than or equal to the **Desired Service Level** percentage.
- The dialer stops acquiring agents when the actual service level reaches the **Abatement Service Level** value.
- The dialer releases agents to inbound when the service level falls below the desired value.

The actual service level is calculated using all inbound domains in the group.

---

**Proactive Agent Blending**

Use Proactive Agent Blending if you focus on outbound calling, but need to service a low volume of inbound customers. The minimum limit for Proactive Agent Blending is eight active agents for each domain group. The blend might not work with less than eight active agents.

Proactive Agent Blending focuses on outbound calls and releases agents to inbound only when an inbound call enters a monitored queue on the ACD.
When an ACD agent logs in, the system immediately acquires the agent for outbound calling. When an inbound call arrives in the ACD queue, the dialer releases the agent to handle the call. If inbound calls continue to arrive, the dialer continues to release agents. When the queue is empty, the dialer acquires agents for outbound calls.

🌟 Note:
For each OB_ONLY domain group, you configure the number of queued calls before agents release to inbound.

---

**Supported ACDs and switch terminology**

Each ACD switch has unique settings and terminology. For each supported ACD, the dialer uses domains and domain groups to control agent blending.

This section defines the switch terminology for:

- Aspect Call Center
- Avaya Communication Manager
- Rockwell Spectrum
- Northern Telecom Meridian
- PINNACLE
- Siemens ROLM 9751, Release 900

🌟 Note:
For more information about the requirements for each supported switch, see *Planning for Avaya Proactive Contact*.

---

**Aspect CallCenter**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent group</td>
<td>A set of agents handling similar types of calls. Agents log in to an agent group when they log on to the Aspect CallCenter. Agent groups can be a part of an agent super group. Agent groups correspond to Agent Blending domains. Agent Blending monitors events for domains configured on the system as inbound or acquire.</td>
</tr>
</tbody>
</table>

*Table continues…*
### Name | Description
--- | ---
Agent Super Group | A collection of more than two agent groups. Aspect CallCenter simultaneously selects all agent groups in the agent super group. Aspect CallCenter delivers a call to the agent in the super group that has been available for the longest time. Agents do not log on to agent super groups. If you set up the super group as a domain on Proactive Contact, Agent Blending monitors the activity in the super group.

Call Control Tables (CCTs) | Part of the Aspect CallCenter database. CCTs control call routing, queuing, and messaging for agent groups and agent super groups. You can view, set up, edit, or delete CCTs from Aspect CallCenter management workstation. Each agent group and agent super group can have multiple CCTs.

Data System Interlink Table: | Part of the Aspect CallCenter database. The table controls communication between the Aspect CallCenter and the dialer. You can view the Data System Interlink Table and set application parameters using the Aspect CallCenter management workstation. However, only an Aspect representative can set system-level parameters.

---

### Avaya Communication Manager

**Expert Agent Selection**

An optional Avaya Communication Manager feature, Expert Agent Selection (EAS) allows skill types to be assigned to a call type or VDN.

**Hunt group**

A Hunt group is an agent queue on an ACD configured without EAS. The ACD hunts for the next available agent in each hunt group. It uses the hunt method defined on the ACD.

**Skill**

Skill types provide a method for call center managers to match the needs of a caller to the talents of the agents. A skill designates a work category such as sales or collections. Skills enable the ACD to route types of calls to queues. Administrators can assign up to four skills or sets of skills to each agent login ID.
Skill hunt group

Replaces ACD splits when the ACD is configured with EAS. The ACD can be queued to up to three different skill hunt groups at a time.

ACD split

An ACD split is a hunt group that is designed for a high volume of similar calls. Members of a split are called agents. At any one time, an agent can be logged in to a maximum of three splits.

Vector

Vector settings determine how the switch handles the incoming calls based on the number dialed. When the Avaya Communication Manager is configured with EAS, the vector directs the incoming call to a split, a hunt group, or a skill hunt group.

Vector Directory Number

The extension number that gains access to a vector. Agent Blending uses the Vector Directory Number for the domain address and domain extension.

Rockwell Spectrum

Agent Group

A collection of one or more agents, based on equivalent skills or a specific call center need. In Spectrum, agents may have a primary and a secondary group assignment. However, the dialer requires that agents belong to only one group.

In addition to the agent’s skill level, you must group agents as Inbound or Acquire. Inbound agents take only inbound calls. Acquire agents take inbound and outbound calls, or they can be outbound-only.

Application

The system treats applications as domains. In Spectrum, incoming calls are routed to applications. An application is a type or category of call that you want handled in a similar way. Applications can include:

- Company functions. For example, Customer Service and Accounts Payable
- Special skill groups. For example, bilingual or technical troubleshooters
- Types of products. For example, Savings, Checking Accounts, and Mortgages.

For each application, Spectrum tracks performance data, such as the average speed to answer, the number of calls offered, and the average handling time.

You must associate each application with an application telescript. The telescript contains a set of instructions for handling calls. For Agent Blending, the transcript queues agent groups, places calls in wait queues, and allows the dialer to track the call while it is on Spectrum.
Application Directory Number

You assign an Application Directory Number (DN) in Application Parameters when you create the Spectrum application. When dialed, this number calls the application. The DN is used as the domain extension in Agent Blending.

Application Number

You assign an Application Number, also called an Application ID, in Application Parameters when you create the Spectrum application. The Application Number is used as the domain address in Agent Blending.

Class of Service

A collection of attributes associated with agents and devices within the Spectrum. One of the class of service attributes is the Host Transaction feature. Host Transaction controls whether or not the Spectrum generates call progress messages on the Transaction Link for the associated agent or device. Agent Blending requires that you enable the Host Transaction feature.

Host

The host for Spectrum is Avaya Proactive Contact.

Provisioning

A set of actions that add, alter, or delete system parameters. In the Avaya Proactive Contact documentation, “configuring” has the same meaning as “provisioning” in Spectrum documentation.

Telescript

A user-programmable sequence of steps associated with various call routing points within Spectrum. During inbound call routing, error processing, and call queuing, Spectrum invokes Routing, Intercept, and Application telescripts. Feature telescripts operate as sub-routines for the other types of telescripts.

Configuring an Application telescript to route to the desired agent groups is key to making Agent Blending work with Spectrum.

Transaction Link

The Spectrum name for the Application Enablement Services link. Transaction Link is a communications channel between Spectrum and the dialer. It is operated over an X.25 or TCP/IP transport facility.

Trunk Group

A collection of trunk ports that have common processing characteristics, such as ANI and DNIS. One of the characteristics is the Host Transaction Link feature. It controls whether Spectrum generates call progress messages for calls associated with the trunk group members.

You must enable this feature to allow the dialer to monitor calls on Spectrum.
Northern Telecom Meridian

ACD-directory number

The ACD address for a call queue. The ACD-directory number (ACD-DN) is the Agent Blending domain address.

ACD Agent Position ID

The number that identifies an agent’s telephone extension. Agent Blending agents log in to Avaya Proactive Contact as ACD agents using their ACD Agent Position ID as the ACD extension. During calling operations, managers can assign agents to Agent Blending domains by assigning agent positions to call queues. Agents can also log in to call queues that are Agent Blending domains.

Multiple queue assignment

A Meridian option that allows agents to log in to multiple call queues.

The domains and domain groups you define and how your agents log in to call queues depend on whether your Meridian uses multiple queue assignment.

PINNACLE

Call queue

A destination for call routing defined by an ACD address, a call queue can be an Agent Blending domain.

Queue ID

The ACD address associated with a call queue, a Queue ID is the address of the Agent Blending domain.

Queue pilot number

The ACD extension associated with an ACD address, Queue pilot numbers are Agent Blending domain extensions.

Serving Team

A group of agent identifiers for agents who work on the same task. PINNACLE can route calls to the serving team for a call queue. Agent Blending inbound agents belong to an inbound serving team. Agent Blending outbound and blend agents belong to an acquire serving team.
Siemens ROLM 9751, Release 900

ACD group or agent group

A group of agent extensions that receives calls from the same pilot number. Each ACD group has telephones and members.

Call-progress event

Any change in a call’s state in ROLM 9005. CallBridge passes call-progress event messages from ROLM 9005 to CallPath. call-progress event messages provide the information Agent Blending needs to acquire and release agents.

Class of service

A code indicating the features, extensions, and trunk access available to an ACD address. Agent Blending uses agent groups with the CallPath class of service.

Directory Number

An ACD address or extension associated with an ACD-defined group or with a device such as a telephone or a Voice Response Unit (VRU) port. An ACD-defined group can be an agent group or a hunt group.

Dummy hunt group

A hunt group with no members defined on ROLM 9005. It unconditionally forwards calls to an agent group. Agent Blending requires dummy hunt groups to collect call-progress event messages. It uses the dummy hunt group’s pilot number as the auxiliary domain’s extension number.

Pilot number

A directory number associated with a group of extension numbers that comprise one ACD group. Agent Blending uses pilot numbers as the domain address. Agent Blending uses the dummy hunt group’s pilot number as the domain extension.

Domains

The dialer requires domains and domain groups for each type of switch. Domains are the ACD call queues that are defined on the ACD and on the dialer.

Each domain is a member of a domain group. Agent Blending collects calling events for each domain and totals them by domain group for statistic calculation. The dialer uses the statistics to determine when to move ACD agents between inbound and outbound calling. The dialer does not:

- Total statistics across domain groups
• Monitor activity in call queues that are not part of a domain group

Types of domains

The types of domains that you configure depend upon the ACD. The two main domain types are inbound and acquire. All Agent Blending systems must have an acquire domain.

Agent Blending uses inbound domains to determine agent availability by monitoring and analyzing the traffic. The dialer uses acquire domains to acquire agents for outbound calling.

Besides inbound and acquire domains, the dialer recognizes two more domains. Some ACDs use auxiliary domains to monitor all calling activity in a domain group. Meridian switches without multiple queues assignment (MQA) use transient domains to temporarily hold agents who are moving between inbound and outbound.

Agent assignments to domains

After your system is installed, assign your agents to domains based on a skill set. For example, you might divide agents into three sets:

• Agents who handle only credit card customers
• Agents who handle consumer loan customers
• Agents with skills to handle both credit card customers and consumer loan customers

Domain groups configurations

Define each domain group with one of the following four configurations:

• Outbound without inbound domain, which uses the OB_ONLY control method.
• Predictive-Average Speed to Answer, which uses the ASA control method.
• Predictive-Service Level, which uses the SL control method.
• Outbound with inbound domain, which uses the Proactive Blend OB_ONLY control method.

Outbound Agent Blend

Outbound Agent Blending acquires ACD agents to handle outbound calls when they log in to the system and the ACD.

Agents who are assigned to an outbound domain are not released to handle inbound calls, because there is no inbound domain in the OB_ONLY domain group.

Domain groups

During site preparation, you must identify which domains you want grouped. A domain group contains one or more domains. A domain can belong to only one domain group. There are three domain group control methods: Outbound Only, Average Speed to Answer, and Service Level. The Agent Blending Administrator window changes dynamically depending on the control method you choose.
Outbound Only

The dialer acquires outbound-only agents to handle outbound calls as soon as they log in to Avaya Proactive Contact and the ACD. With Outbound Agent Blending you can use the least-cost routing available on your ACD and the detailed reports available on the ACD.

To configure an Outbound Agent Blending job, set up an outbound domain that contains at least one acquire domain. Do not set up an inbound domain. Select Outbound as the domain group type. Assign at least one acquire domain to the group.

If you select Outbound Only, you must specify a limit for the system to release agents to inbound calling in the Minimum Queued for Release field. Type a value from 0 through 999. The default value is 0.

Average Speed to Answer

If you select Average Speed to Answer as your domain group control method, your dialog box changes dynamically, and you need to set values for the required fields.

The Average Speed to Answer fields are described in the following table.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time Interval (required)</td>
<td>The interval that the dialer uses to calculate the average speed to answer. The interval influences how responsive the dialer is to fluctuations in answer delays. The interval begins each time that you start the dialer or restart Agent Blending. Select a value greater than 0.25, in increments of .25. The interval is in hours, so .25 is 1/4 of an hour or 15 minutes. The default is .50 or 30 minutes. The setting represents an average calculated over the Average Speed to Answer interval.</td>
</tr>
<tr>
<td>Average Speed to Answer (required)</td>
<td>The average time within which agents must answer calls. Enter a value from 1 through 999. The default value is 60.</td>
</tr>
<tr>
<td>Agent Utilization Threshold (required)</td>
<td>The percentage of agents available to take calls. Agent Utilization Threshold determines how quickly the system moves agents between inbound and outbound calls. The goal is to prevent agents from being acquired or released too frequently. Agents are available if they are not taking calls or updating records. Agent Blending tracks calling statistics and uses this information to predict future availability.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>To calculate the threshold, the dialer divides the</td>
<td>To calculate the threshold, the dialer divides the projected inbound call volume by the projected number of available agents. Enter a value from 1 through 999. The default value is 200.</td>
</tr>
<tr>
<td>project inbound call volume by the projected</td>
<td></td>
</tr>
<tr>
<td>number of available agents.</td>
<td></td>
</tr>
<tr>
<td>Minimum Agents on Outbound (required)</td>
<td>The minimum number of ACD blend agents, in this domain, dedicated to handling outbound calls. This setting overrides Desired Level. For example, however low the Average Speed to Answer, there will always be this number of agents unavailable to handle inbound calls. Use this setting when it is more important to meet outbound goals than to service inbound calls. Enter a value from 0 through 999. The default value is 0.</td>
</tr>
<tr>
<td>Initial Traffic Rate (optional)</td>
<td>The estimated number of calls each second. The dialer uses this rate for the first 30 calls. It ensures that there are enough agents to handle the first 30 calls. Enter a value from 0 through 999.</td>
</tr>
<tr>
<td>Talk Time (optional)</td>
<td>The estimated minimum seconds agents spend connected on each inbound call. The system adds Talk time and After Call Work Time to determine agent availability. Agent availability is sometimes called service capacity. Enter a value from 0 through 999.</td>
</tr>
<tr>
<td>After Call Work Time (optional)</td>
<td>The estimated minimum seconds agents spend, after a call, updating records and processing information. Enter a value from 0 through 999.</td>
</tr>
</tbody>
</table>

**Service Level**

If you select **Service Level** as the domain group control method, the dialog box changes dynamically and you must set values for the required fields. The following table includes descriptions about Service Level fields.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Desired Service Level (required)</td>
<td>The desired percentage of inbound calls that satisfy the service criterion. The Service level (SL) control uses the DSL parameter. The default value is 80. When the service level goes above the Desired Service Level value, the system acquires ACD</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Name</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td><strong>Abatement Service Level (required)</strong></td>
<td>The percentage of inbound calls that satisfy the service criterion set above which there is no perceived benefit. Select a setting from 40 percent to 100 percent. (suggested as 5-10 points) above the established DSL. The value must be greater than the <strong>Desired Service Level</strong> value (up to 100%) The Service level (SL) control method uses this parameter. The default value is 95.</td>
</tr>
<tr>
<td><strong>Service Criterion (required)</strong></td>
<td>The maximum time within which an agent should answer a call. As the system runs, it measures the seconds an inbound call is in the ACD queue. Enter a value from 0 through 999. The default value is 60.</td>
</tr>
<tr>
<td><strong>Time Interval (required)</strong></td>
<td>The interval that the dialer uses to calculate the average speed to answer. The interval influences how responsive the dialer is to fluctuations in answer delays. The interval begins each time that you start the dialer or restart Agent Blending. Select a value greater than 0.25, in increments of .25. The interval is in hours, so .25 is 1/4 of an hour or 15 minutes. The default is .50 or 30 minutes. The setting represents an average calculated over the Average Speed to Answer interval.</td>
</tr>
<tr>
<td><strong>Agent Utilization Threshold (required)</strong></td>
<td>The percentage of agents available to take calls. Agent Utilization Threshold determines how quickly the system moves agents between inbound and outbound calls. The goal is to prevent agents from being acquired or released too frequently. Agents are available if they are not taking calls or updating records. Agent Blending tracks calling statistics and uses this information to predict future availability. To calculate the threshold, the dialer divides the projected inbound call volume by the projected number of available agents. Enter a value from 1 through 999. The default value is 200.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Minimum Agents on Outbound</strong> (required)</td>
<td>The minimum number of ACD blend agents, in this domain, dedicated to handling outbound calls. This setting overrides Desired Level. For example, however low the Average Speed to Answer, there will always be this number of agents unavailable to handle inbound calls. Use this setting when it is more important to meet outbound goals than to service inbound calls. Enter a value from 0 through 999. The default value is 0.</td>
</tr>
<tr>
<td><strong>Initial Traffic Rate</strong> (optional)</td>
<td>The estimated number of calls each second. The dialer uses this rate for the first 30 calls. It ensures that there are enough agents to handle the first 30 calls. Enter a value from 0 through 999.</td>
</tr>
<tr>
<td><strong>Talk Time</strong> (optional)</td>
<td>The estimated minimum seconds agents spend connected on each inbound call. The system adds Talk time and After Call Work Time to determine agent availability. Agent availability is sometimes called service capacity. Enter a value from 0 through 999.</td>
</tr>
<tr>
<td><strong>After Call Work Time</strong> (optional)</td>
<td>The estimated minimum seconds agents spend, after a call, updating records and processing information. Enter a value from 0 through 999.</td>
</tr>
</tbody>
</table>

### Starting Agent Blending

**About this task**

Only the Lead Administrator can start or stop the agent blending tool.

**Procedure**

1. Click **Start > All Programs > Avaya > Proactive Contact > Supervisor**.
2. Select Monitor or Editor.
3. Select **Tools > Agent Blending Administrator**.

The system displays the Agent Blending Administrator window.
Creating a domain group

About this task
Only the Lead Administrator and the default tenant user with sufficient permissions can create domain group.

Procedure
1. In the Agent Blending Administrator window, click **File > Create Domain Group**.
2. In the **New Domain Group** box, type a descriptive name for the domain group.
   
   For example, MIDWEST.

   The name must be 9 or fewer characters. You have now created the domain group name and must now complete the domain group settings.
3. Click **OK**.
4. Select the appropriate control method in the **Control Method** field
   
   The fields in the window change dynamically based on the control method you select.

Related links
- [Service Level](#) on page 530
- [Average Speed to Answer](#) on page 529
- [Outbound Only](#) on page 529

Creating a domain

Before you begin
You must select a domain group name before creating a domain. The **Create Domain** option is not available until you select the name of a domain group. The domain is added to the domain group that you select.

You must stop your blend engine in order to create a domain.

About this task
Only the Lead Administrator and the default tenant user with sufficient permissions can create a domain.

Procedure
1. In the Agent Blending Administrator window, click the domain group to which you want the new domain to belong, and then, select **File > Create Domain**.
2. In the New Domain dialog box, type the address of the domain.
   
   Typical values for this box are 5-digit addresses, such as 20601, and must match your PBX ID exactly to communicate with the PBX.
3. Click **OK**.

4. Select one of the following the domain types in the **Domain Type** field:
   - Inbound
   - Transient Acquire
   - Overflow

5. Define the domain settings in **Phone Number**, **Gateway ID**, **Application ID**, and **PBX ID** fields.

**Related links**
- [Stopping the blend engine](#) on page 536
- [Supported ACDs and switch terminology](#) on page 522
- [Domain groups configurations](#) on page 528
- [Domains](#) on page 527

---

**Editing domain group settings**

**Before you begin**
You must stop your blend engine to edit domain group settings.

**About this task**
Only the Lead Administrator and the default tenant user with sufficient permissions can edit domain group settings.

**Procedure**
1. In the Agent Blending Administrator window, select the domain group you want to edit.
2. Modify the required fields.
   - To determine whether the field has a drop-down list or an editable value for you to use, click the field.
3. Click **Save**.

**Related links**
- [Stopping the blend engine](#) on page 536
- [Outbound Only](#) on page 529
- [Average Speed to Answer](#) on page 529
- [Service Level](#) on page 530

---

**Editing domain settings**

**Before you begin**
You must stop your blend engine in order to edit domain settings.
About this task
Only the Lead Administrator and the default tenant user with sufficient permissions can edit domain settings.

Procedure
1. In the Agent Blending Administrator window, select the domain you want to edit.
2. Modify the values in Domain Type, Phone Number, Gateway ID, Application ID, and PBX ID fields.

Related links
Stopping the blend engine on page 536
Domain groups configurations on page 528

Deleting a domain group

Before you begin
You must stop your blend engine to delete a domain group.

About this task
Only the Lead Administrator and the default tenant user with sufficient permissions can delete a domain group.

Procedure
1. In the Agent Blending Administrator window, select the domain group you want to delete.
2. Select File > Delete Domain Group.
3. Click Save.

Related links
Stopping the blend engine on page 536

Deleting a domain

Before you begin
You must stop your blend engine to delete a domain.

About this task
Only the Lead Administrator and the default tenant user with sufficient permissions can delete a domain.

Procedure
1. In the Agent Blending Administrator window, select the domain you want to delete.
2. Click File > Delete Domain.
3. Click **Save**.

**Related links**
- [Stopping the blend engine on page 536](#)

---

**Moving a domain to a different group**

**Before you begin**

You must stop the blend engine to move a domain to a different domain group in your tenant.

**About this task**

Only the Lead Administrator and the default tenant user with sufficient permissions can move a domain to a different group.

Moving a domain is possible by deleting the domain and then adding it to a different domain. Remember to write down its existing settings so that you can recreate them when you add the domain to the new domain group.

**Procedure**

1. In the Agent Blending Administrator window, select the domain you want to move (write down the domain’s settings, if necessary), and then, select **File > Delete Domain**.
2. Select the domain group to which you want to add the new domain, and then select **File > Create Domain**.
3. In the New Domain dialog box, type the domain address. For example, 20601.
4. Click **OK**.
5. Complete the domain settings.

**Related links**
- [Stopping the blend engine on page 536](#)

---

**Stopping the blend engine**

**About this task**

Only the Lead Administrator and the default tenant user with sufficient permissions can stop the blend engine.

You can stop all but two of the blend processes on a dialer by clicking **Stop**. Only cbamain and cbauser run. This state is also called configure-only mode. It is required for editing or deleting domains.

You must have a dialer selected in the tree view for the **Stop** button to be visible. The dialers are located at the top-most level in the tree view.

**Procedure**

1. Click **Start > All Programs > Avaya > Proactive Contact > Supervisor**
2. Open Monitor or Editor.
3. Click **Tools > Agent Blending**.
   The system displays the Agent Blending Administrator window
4. In the tree view, select a dialer.
5. Click **Blend Engine > Stop**.

---

### Starting the blend engine

**About this task**

Only the Lead Administrator and the default tenant user with sufficient permissions can start the blend engine.

You can start the blend process that was stopped using the Stop command on a dialer by clicking **Start**.

You must have a dialer selected in the tree view for the **Start** button to be visible. The dialers are located at the top-most level in the tree view.

**Procedure**

1. Click **Start > All Programs > Avaya > Proactive Contact > Supervisor**
2. Open Monitor or Editor.
3. Click **Tools > Agent Blending**.
   The system displays the Agent Blending Administrator window
4. In the tree view, select a dialer.
5. Click **Blend Engine > Start**.

---

### Resetting the blend engine

**About this task**

Only the Lead Administrator and the default tenant user with sufficient permissions can reset the blend engine.

With the **Reset** button you can stop and restart the blend processes on a dialer. If blend is not running, the **Reset** button starts the processes on a dialer.

**Procedure**

1. Click **Start > All Programs > Avaya > Proactive Contact > Supervisor**
2. Open Monitor or Editor application.
3. Click **Tools > Agent Blending**.
   The Agent Blending Administrator window appears.
4. In the tree view, select a dialer.
5. Select Blend Engine > Reset.

---

**Resynchronizing blend engine**

**About this task**

Only the Lead Administrator and the default tenant user with sufficient permissions can resynchronize the blend engine.

With the Resynch button, you can update the dialer with the current ACD agent queue assignments. Resynchronize the blend engine after a supervisor uses the ACD to reassign agents to different inbound queues.

**Procedure**

1. Click Start > All Programs > Avaya > Proactive Contact > Supervisor
2. Open Monitor or Editor.
3. Click Tools > Agent Blending.
   The Agent Blending Administrator window appears.
4. In the tree view, select a dialer.
5. Select Blend Engine > Resynch.

---

**Viewing ACD statistics**

**Procedure**

1. Click Start > All Programs > Avaya > Proactive Contact > Supervisor
2. Open Monitor or Editor.
3. Click Tools > Agent Blending.
   The Agent Blending Administrator window appears.
4. Click Statistics under the domain group for which you want to view statistics.

---

**Viewing alerts**

**Procedure**

1. Click Start > All Programs > Avaya > Proactive Contact > Supervisor
2. Open Monitor or Editor.
3. Click Tools > Agent Blending.
   The Agent Blending Administrator window appears.
4. Click Alerts under the domain group for which you want to view alerts.
5. (Optional) You can also view alerts by clicking Alerts in the tree view.

---

**Viewing transactions**

**Procedure**

1. Click Start > All Programs > Avaya > Proactive Contact > Supervisor
2. Open Monitor or Editor.
3. Click Tools > Agent Blending.
   The Agent Blending Administrator window appears.
4. Click Transactions under the domain group for which you want to view transactions.
Chapter 38: Resources

Documentation

The following table lists the related documents for the Avaya Proactive Contact product. You can download the documents from the Avaya Support website at http://support.avaya.com.

<table>
<thead>
<tr>
<th>Title</th>
<th>Description</th>
<th>Audience</th>
</tr>
</thead>
</table>
| Avaya Proactive Contact Overview           | Provides an overview of Avaya Proactive Contact, the new features, capacities and interoperability. | • Business partners  
                                          |                                                                              | • Avaya Professional Services  
                                          |                                                                              | • Customers                      |
| Planning for Avaya Proactive Contact       | Provides detailed description of the planning process for Avaya Proactive Contact. | • Sales engineers  
                                          |                                                                              | • Avaya Professional Services  
                                          |                                                                              | • Design engineers               |
| Maintaining and Troubleshooting Avaya Proactive Contact | Provides detailed information about hardware and software maintenance of Avaya Proactive Contact. | • Avaya Professional Services  
                                          |                                                                              | • Business partners               |
| Safety and Regulatory for Avaya Proactive Contact | Provides information about safety regulations.                          | • Avaya Professional Services  
                                          |                                                                              | • Customers                      |
| Using Avaya Proactive Contact Agent        | Provides detailed description of Avaya Proactive Contact Agent.              | • Contact center agents  
                                          |                                                                              | • Customers                      |
| Administering Avaya Proactive Contact      | Provides detailed information about the operation of the Avaya Proactive Contact system through a Linux-based menu. | • Avaya Professional Services  
                                          |                                                                              | • Customers                      |
| Avaya Proactive Contact Software Technical Reference | Provides detailed information about the binaries, scripts, and configuration files of Avaya Proactive Contact. | • Avaya Professional Services  
                                          |                                                                              | • Business partners               |

Finding documents on the Avaya Support website

Procedure

2. At the top of the screen, type your username and password and click **Login**.

3. Click **Support by Product > Documents**.

4. In **Enter your Product Here**, type the product name and then select the product from the list.

5. In **Choose Release**, select an appropriate release number.

6. In the **Content Type** filter, click a document type, or click **Select All** to see a list of all available documents.
   
   For example, for user guides, click **User Guides** in the **Content Type** filter. The list displays the documents only from the selected category.

7. Click **Enter**.

---

### Training

The following courses are available on the Avaya Learning website at [www.avaya-learning.com](http://www.avaya-learning.com)

Enter the course code in the **Search** field, and click **Go** to search for the course.

<table>
<thead>
<tr>
<th>Course code</th>
<th>Course title</th>
</tr>
</thead>
<tbody>
<tr>
<td>1C00010W</td>
<td>What's New with Proactive Contact 5.2</td>
</tr>
<tr>
<td>AVA00989H00</td>
<td>Avaya Proactive Contact 5.0 Basic System Supervisor</td>
</tr>
<tr>
<td>AVA00990H00</td>
<td>Avaya Proactive Contact 5.0 Advanced System Supervisor</td>
</tr>
<tr>
<td>AVA01013WEN</td>
<td>Avaya Proactive Contact Solutions 5.0 Overview - Assessment</td>
</tr>
</tbody>
</table>

---

### Viewing Avaya Mentor videos

Avaya Mentor videos provide technical content on how to install, configure, and troubleshoot Avaya products.

**About this task**

Videos are available on the Avaya Support website, listed under the video document type, and on the Avaya-run channel on YouTube.

**Procedure**

- To find videos on the Avaya Support website, go to [http://support.avaya.com](http://support.avaya.com) and perform one of the following actions:
  - In **Search**, type **Avaya Mentor Videos** to see a list of the available videos.
  - In **Search**, type the product name. On the Search Results page, select **Video** in the **Content Type** column on the left.
• To find the Avaya Mentor videos on YouTube, go to www.youtube.com/AvayaMentor and perform one of the following actions:
  - Enter a key word or key words in the Search Channel to search for a specific product or topic.
  - Scroll down Playlists, and click the name of a topic to see the available list of videos posted on the website.

★ Note:

Videos are not available for all products.

Support

Go to the Avaya Support website at http://support.avaya.com for the most up-to-date documentation, product notices, and knowledge articles. You can also search for release notes, downloads, and resolutions to issues. Use the online service request system to create a service request. Chat with live agents to get answers to questions, or request an agent to connect you to a support team if an issue requires additional expertise.
Appendix A: PDSAgent.ini parameters

PDSAgent.ini parameters overview

The PDSAgent.ini file is on the computer on which Avaya Proactive Contact Agent is installed and contains the settings that an agent application uses. The PDSAgent.ini file is located on the Agent workstation at: <Install Path>\Avaya\Proactive Contact

Related links

- Agent on page 543
- Dynamic Data Exchange on page 544
- Blend parameter on page 544
- User interface parameters on page 544
- Telephone extension parameters on page 546
- Session parameters on page 547
- Server parameter on page 547
- Log parameters on page 547
- Parameters to set Agent display on page 548
- Security parameters on page 549
- DialerList on page 550

Agent

This section contains the agent login related parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>UserID</td>
<td>agent id</td>
<td>Agent user name using which the agent logs in to Proactive Contact.</td>
</tr>
<tr>
<td>AgentType</td>
<td>O</td>
<td>The six roles that an agent can be assigned to are:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Outbound: O</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Managed: M</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Inbound: I</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Blend: B</td>
</tr>
</tbody>
</table>

Table continues...
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IsACDAgent</td>
<td>FALSE</td>
<td>If the agent type is ACD, then this value is TRUE, otherwise FALSE. This is used in Predictive Agent Blending (PAB)</td>
</tr>
<tr>
<td>ACDID</td>
<td>Any valid ACD ID on ACD</td>
<td>Agent’s ACD login ID used in PAB.</td>
</tr>
<tr>
<td>PBXID</td>
<td>1</td>
<td>If there are more than one ACD/PBX, then this parameter defines on which ACD/PBX the agent logs in.</td>
</tr>
<tr>
<td>AutoCallbackComcodes</td>
<td>19 - Recall Release 98 - Agent owned recall</td>
<td>A list of completion codes separated by comma (,). For this set of completion codes, the Callback pop-up window is displayed automatically to set the callback time. For these completion codes, the line is not released unless the callback time is set.</td>
</tr>
</tbody>
</table>

**Dynamic Data Exchange**

This section contains the parameter for Dynamic Data Exchange (DDE). The primary function of DDE is to allow Windows applications to share data.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>UseActivexExe</td>
<td>TRUE</td>
<td>When this value is TRUE and the agent software is started, the agentdde.exe also starts. The call events are passed in DDE format. If this value is FALSE, the agentdde.exe does not start.</td>
</tr>
</tbody>
</table>

**Blend parameter**

This section contains the parameter for PAB related setting.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GoOffBreakAfterAcquire</td>
<td>FALSE</td>
<td>If this parameter is TRUE, the agent starts making calls as soon as he switches from inbound to outbound.</td>
</tr>
</tbody>
</table>

**User interface parameters**

This section contains all the GUI related parameters.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NumSocketMessages</td>
<td>1000</td>
<td>Number of the history messages going to and from the server.</td>
</tr>
<tr>
<td>ShowWorkBar</td>
<td>TRUE</td>
<td>If set to TRUE, this enables the work bar in the Agent application.</td>
</tr>
<tr>
<td>ShowPhoneBar</td>
<td>TRUE</td>
<td>If set to TRUE, this enables the telephone bar in the Agent application.</td>
</tr>
<tr>
<td>ShowVolumeBar</td>
<td>TRUE</td>
<td>If set to TRUE, this enables the Volume bar in the Agent application.</td>
</tr>
<tr>
<td>ShowShortcutBar</td>
<td>TRUE</td>
<td>If set to TRUE, this enables the Shortcut bar in the Agent application.</td>
</tr>
<tr>
<td>ShowChat</td>
<td>FALSE</td>
<td>If set to TRUE, this enables the chat window in the Agent application.</td>
</tr>
<tr>
<td>ShowDataBar</td>
<td>FALSE</td>
<td>If set to TRUE, this enables the data bar in the Agent application.</td>
</tr>
<tr>
<td>ShowManagedCallBar</td>
<td>FALSE</td>
<td>If set to TRUE, this shows the managed call bar in the Agent application.</td>
</tr>
<tr>
<td>MaxQuickReleaseHistory</td>
<td>5</td>
<td>Maximum number of quick release history.</td>
</tr>
<tr>
<td>MaxFinishWorkHistory</td>
<td>5</td>
<td>Maximum number of finish work history.</td>
</tr>
<tr>
<td>MaxReleaseLineHistory</td>
<td>5</td>
<td>Maximum number of release line history.</td>
</tr>
<tr>
<td>FinishWorkHistory</td>
<td>1,76,13:94,65,90</td>
<td>Holds the history of the most frequently used releases.</td>
</tr>
<tr>
<td>ReleaseLineHistory</td>
<td>1,71,13:1,102:1,100,13 :94,65,109:1,102,13</td>
<td>Holds the history of the most frequently used releases.</td>
</tr>
<tr>
<td>CurCallbackTab</td>
<td>1</td>
<td>If set to 0, you can set call back time at a specific date and time. If set to 1 then you can specify the time after 1 hour.</td>
</tr>
<tr>
<td>UseLargeShortcutIcons</td>
<td>FALSE</td>
<td>If set to FALSE then small shortcut icons are displayed. If set to TRUE then large shortcut icons are displayed.</td>
</tr>
<tr>
<td>CurrentShortcutList</td>
<td>2</td>
<td>Stores the current item of the left button groups that are selected when you run an application.</td>
</tr>
<tr>
<td>CallbackChooseNumberByDefault</td>
<td>TRUE</td>
<td>If set to TRUE, this allows an agent to select the default telephone numbers present in the data. If set to FALSE then the agent makes a manual entry.</td>
</tr>
<tr>
<td>ConfirmOnRelease</td>
<td>FALSE</td>
<td>If set to TRUE, Agent displays a confirmation message before releasing the line. If set to FALSE, Agent does not display a confirmation message before releasing the line.</td>
</tr>
<tr>
<td>ClickToDialAppPath</td>
<td>Blank</td>
<td>The complete path of the third-party dialing software.</td>
</tr>
</tbody>
</table>
### PDSAgent.ini parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ClickToDialArgument</td>
<td>Blank</td>
<td>The argument required for third-party software to dial.</td>
</tr>
<tr>
<td>ShowTelephoneLinkBar</td>
<td>TRUE</td>
<td>If set to TRUE, this enables the TelephoneLink bar in the Agent application.</td>
</tr>
<tr>
<td>HideCallbackPhoneNumber</td>
<td>FALSE</td>
<td>If set to TRUE, Proactive Contact Agent does not display the customer contact number in the callback dialog box.</td>
</tr>
<tr>
<td>XferCustHangUpShowReleaseDlg</td>
<td>FALSE</td>
<td>If set to FALSE, Agent does not display the Release dialog box when PDSAgent receives the AGTXferCustHundUp notification. If set to TRUE, Agent displays the Release dialog box when PDSAgent receives the AGTXferCustHundUp notification.</td>
</tr>
<tr>
<td>CallbackCompCodes</td>
<td>19,98</td>
<td>Specifies the callback completion code used by the dialer. Proactive Contact Agent ensures that an agent has to provide a callback time if a call is released by any of these completion codes.</td>
</tr>
</tbody>
</table>

---

### Telephone extension parameters

This section contains all the telephone extension related parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PBXID</td>
<td>1</td>
<td>If there are more than 1 ACD/PBX, then this parameter defines on which ACD/PBX the agent logs in.</td>
</tr>
<tr>
<td>HeadsetID</td>
<td>1001</td>
<td>The station/extension number of the PBX/ACD using which the agent logs into Proactive Contact.</td>
</tr>
<tr>
<td>HeadsetVolumeEar</td>
<td>0</td>
<td>Default position of the slider pointer of headset ear volume.</td>
</tr>
<tr>
<td>HeadsetVolumeMouth</td>
<td>2</td>
<td>Default position of the slider pointer of headset mouth volume.</td>
</tr>
<tr>
<td>HeadsetVolumeEarHigh</td>
<td>8</td>
<td>Maximum headset ear volume.</td>
</tr>
<tr>
<td>HeadsetVolumeEarLow</td>
<td>1</td>
<td>Minimum headset ear volume.</td>
</tr>
<tr>
<td>HeadsetVolumeMouthHigh</td>
<td>8</td>
<td>Maximum headset mouth volume.</td>
</tr>
<tr>
<td>HeadsetVolumeMouthLow</td>
<td>1</td>
<td>Minimum headset mouth volume.</td>
</tr>
</tbody>
</table>
Session parameters

This section contains the session related parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ServerLogging</td>
<td>TRUE</td>
<td>If you set this value to TRUE, log files for all agent related events are created on the Server. The logs are located at: /opt/avaya/debug.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The name of the log file is &lt;agent id&gt;_API.trans.</td>
</tr>
<tr>
<td>XferCustHangUpShowReleaseDlg</td>
<td>TRUE</td>
<td>Handles the display of the Release dialog box that appears when the PDSAgent receives AGTXferCustHundUp notification.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If you set this parameter to True, then the Release dialog box appears.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If you set this parameter to False, then the Release dialog box does not appear.</td>
</tr>
</tbody>
</table>

Server parameter

This section contains the Proactive Contact server details.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LastUsedServerIP</td>
<td>Blank</td>
<td>This parameter contains the IP address of the last used Proactive Contact server.</td>
</tr>
</tbody>
</table>

Log parameters

This section contains the log files related parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LogLevel</td>
<td>5</td>
<td>This parameter logs the severity from 1 to 5, where:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Catastrophic = 1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Critical = 2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Error = 3</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Message = 4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Information = 5</td>
</tr>
</tbody>
</table>
### PDSAgent.ini parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LogFileName</td>
<td>PDSAgent.log</td>
<td>The name of the log file generated on the Windows system where you have installed the Proactive Contact Agent application.</td>
</tr>
<tr>
<td>SocketBufferDumpFileName</td>
<td>SocketBuffer.dmp</td>
<td>The name of the log file where all socket messages are sent to and from agent workstation to Proactive Contact server.</td>
</tr>
<tr>
<td>LogSocketMessages</td>
<td>TRUE</td>
<td>If set to TRUE, messages are written to the log file.</td>
</tr>
</tbody>
</table>

### Parameters to set Agent display

This section contains the parameters to set the display settings for the agent.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MainFormHeight</td>
<td>10830</td>
<td>Used to set the height of the agent application.</td>
</tr>
<tr>
<td>MainFormLeft</td>
<td>1890</td>
<td>Used to set the form position (distance form the left of screen).</td>
</tr>
<tr>
<td>MainFormTop</td>
<td>2250</td>
<td>Used to set the form position (distance from the top of screen).</td>
</tr>
<tr>
<td>MainFormWidth</td>
<td>12975</td>
<td>Used to set the width of the agent application.</td>
</tr>
<tr>
<td>WorkBarPosition</td>
<td>1</td>
<td>Default position of the Work toolbar.</td>
</tr>
<tr>
<td>ManagedCallBarPosition</td>
<td>4</td>
<td>Default position of the managed call toolbar.</td>
</tr>
<tr>
<td>DataBarPosition</td>
<td>5</td>
<td>Default position of the Data toolbar.</td>
</tr>
<tr>
<td>PhoneBarPosition</td>
<td>2</td>
<td>Default position of the telephone bar position.</td>
</tr>
<tr>
<td>VolumeBarPosition</td>
<td>3</td>
<td>Default position of the volume bar position.</td>
</tr>
<tr>
<td>SplitChatTop</td>
<td>7551</td>
<td>Default top position of split chat.</td>
</tr>
<tr>
<td>SplitWorkLeft</td>
<td>3888</td>
<td>Default left position of split work (distance from the left of screen).</td>
</tr>
<tr>
<td>SplitChatLastDistFromStatBar</td>
<td>2334</td>
<td>Default position of the split chat from the status bar.</td>
</tr>
<tr>
<td>ChatWindowTop</td>
<td>7626</td>
<td>Top position of the chat window.</td>
</tr>
<tr>
<td>WorkBarNewRow</td>
<td>0</td>
<td>Display the toolbar in a new row.</td>
</tr>
<tr>
<td>ManagedCallBarNewRow</td>
<td>1</td>
<td>Display the Managed call toolbar in a new row.</td>
</tr>
<tr>
<td>DataBarNewRow</td>
<td>1</td>
<td>Display the work data toolbar in a new row.</td>
</tr>
<tr>
<td>PhoneBarNewRow</td>
<td>1</td>
<td>Display the Phone data toolbar in a new row.</td>
</tr>
<tr>
<td>VolumeBarNewRow</td>
<td>1</td>
<td>Display the Volume data toolbar in a new row.</td>
</tr>
<tr>
<td>WorkBarWidth</td>
<td>0</td>
<td>Width of the work toolbar.</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ManagedCallBarWidth</td>
<td>0</td>
<td>Width of the managed call bar.</td>
</tr>
<tr>
<td>DataBarWidth</td>
<td>0</td>
<td>Width of the data bar.</td>
</tr>
<tr>
<td>PhoneBarWidth</td>
<td>0</td>
<td>Width of the phone bar.</td>
</tr>
<tr>
<td>VolumeBarWidth</td>
<td>0</td>
<td>Width of the volume bar.</td>
</tr>
<tr>
<td>TelephoneLinkBarNewRow</td>
<td>1</td>
<td>Display the TelephoneLink toolbar in a new row.</td>
</tr>
<tr>
<td>TelephoneLinkBarPosition</td>
<td>6</td>
<td>Default position of the TelephoneLink bar.</td>
</tr>
<tr>
<td>TelephoneLinkBarWidth</td>
<td>0</td>
<td>Width of the TelephoneLink bar.</td>
</tr>
</tbody>
</table>

**Security parameters**

You can secure the communications from and to Avaya Proactive Contact Agent at the highest security level. The traditional TCP socket communication changed to TCP over SSL (Secure Socket Layer).

The security settings require the parameters listed in the following table.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ServerCertificate</td>
<td>TRUE</td>
<td>This parameter checks if the CA Certificate for server is present in Microsoft Certificate Store</td>
</tr>
<tr>
<td>ClientCertificate</td>
<td>TRUE</td>
<td>This parameter checks if the Certificate for client is present or not</td>
</tr>
<tr>
<td>ClientCertificatePath</td>
<td>agentClient_cert.pem</td>
<td>The path for the client certificate</td>
</tr>
<tr>
<td>ClientCertificateKeyPath</td>
<td>agentClient_key.pem</td>
<td>Path for the client certificate</td>
</tr>
<tr>
<td>SSLMethod</td>
<td>SSLv23</td>
<td>If the agent server in dialer system is configured with TLSv1.2 then the SSLMethod parameter value must be modified in PDSAgent.ini file to SSLMethod=TLSv1.2</td>
</tr>
</tbody>
</table>

*Note:* Supervisor communicates with Dialer system as per the TLS security

Table continues…
DialerList

Use the following parameters to provide a list of multiple dialers.

Ensure that the numbering in this list is not broken. For example, if you have a DialerName6, but no DialerName5, then DialerName6 is not read.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DialerName X</td>
<td>Host name of Proactive Contact Server</td>
<td>Host name of Proactive Contact Server.</td>
</tr>
<tr>
<td>DialerIP X</td>
<td>IP address of the Proactive Contact Server</td>
<td>IP address of the Proactive Contact Server.</td>
</tr>
<tr>
<td>DialerPort X</td>
<td>22700</td>
<td>The default port used for socket connection from agent workstation to the Proactive Contact server.</td>
</tr>
</tbody>
</table>
Index

Special Characters

..edt file
  keyword description .......................................................... 292

A

Abandon Calls calculation .................................................. 443
abandons, completion code category .................................. 168
Abatement Service Level
  Agent Blending control method parameter .......................... 530
  Service Level ................................................................. 521
accessing campaign template ............................................. 306
ACD ................................................................. 40
  Agent Blending ............................................................. 522
  agent state ................................................................. 322
  Avaya Communication Manager ...................................... 523
  blend agents ................................................................. 530
  class of service ........................................................... 527
  handle outbound calls ................................................... 528
  hunt group ................................................................. 523
  Northern Telecom Meridian ............................................ 526
  Rockwell Spectrum ....................................................... 524
  skill hunt group .......................................................... 524
  switch terminology ........................................................ 522
ACD group
  agent group ................................................................. 527
  same pilot number ......................................................... 527
ACD split
  hunt group ................................................................. 524
active schedule
  activities .......................................................................... 279
  restrictions ..................................................................... 279
Activity Event Viewer ........................................................ 101, 102, 106
adding actions to an agent key set .................................... 179
adding a job to an agent job list ......................................... 316
add new user field descriptions ........................................ 60
adjust columns .................................................................. 90
adjusting column widths .................................................. 91
administered tenants .......................................................... 64
administration .................................................................... 60, 79
Administrative dictionary ................................................... 448
Administrative reports
  available reports ............................................................. 436
administrator .................................................................... 78
Administrator .................................................................... 37
agent
  ACD ................................................................. 523
  display a view for an agent ............................................ 326
  find .............................................................................. 397
  hierarchy ..................................................................... 510
  login parameters .......................................................... 543
  manage in Monitor .......................................................... 396
agent (continued)
  monitor line ................................................................. 399
  remove from a job in Monitor .......................................... 400
  remove from job ............................................................ 400
  rename Monitor view set ............................................... 328
  reporting to a supervisor, find ......................................... 396
  resources view ............................................................. 377
  save as Monitor view set ............................................... 328
  save current Monitor views ........................................... 327
  skill ........................................................................... 523
  standard Monitor views ................................................ 326
  states ............................................................................ 322
  transfer ......................................................................... 398
Agent
  agent activity
    date ............................................................................ 450
    log in .......................................................................... 450
    logout ......................................................................... 450
    session ........................................................................ 450
    system ......................................................................... 450
  agent assignments
    domains ................................................................. 528
  agent blending
    domain groups ............................................................ 528
    login .......................................................................... 41
    VDN ........................................................................ 524
Agent Blending
  create a domain ............................................................ 533
  create domain group ....................................................... 533
  delete a domain group .................................................... 535
  delete domain ............................................................... 535
  domain group ................................................................ 528, 534
  domains ......................................................................... 527
  domain types ................................................................. 528
  edit ............................................................................. 534
  edit a domain ................................................................ 534
  move a domain ............................................................. 536
  New Domain dialog box .................................................. 533
  Outbound ........................................................................ 528
  Predictive Agent Blend ................................................... 520
  Proactive Agent Blend .................................................... 521
  reset the blend engine .................................................... 537
  resynch the blend engine ................................................ 538
  start ............................................................................. 532
  start the blend engine ..................................................... 532
  stop the blend engine ..................................................... 536
  supported ACDs ............................................................. 522
  tool ............................................................................. 520, 532
  uses pooled ACD agents for outbound calling ..................... 520
  view ACD statistics ........................................................ 538
  view alerts ..................................................................... 538
  view transactions ............................................................ 539
agent codes

July 2018 Using Avaya Proactive Contact Supervisor

Comments on this document? infodev@avaya.com

551
agent codes (continued)
   code .............................................................. 451
   code count .................................................. 451
Agent Completion Codes ................................. 379
Agent Completion Codes, Monitor view ............... 326, 379
agent controls
   Find Agent .................................................. 341
   functions .................................................... 396, 397
   Send Message ............................................. 342
   Transfer Agent ........................................... 342
Agent Detail .................................................... 377
   Monitor view .............................................. 326
   view .......................................................... 377
Agent display settings
   parameters .................................................. 546
Agent History .................................................. 381
Agent History, Monitor view ......................... 326, 381
Agent History fields
   PC Analysis extract ....................................... 505
agent job list .................................................. 315
agent keys ..................................................... 117, 178
agent keys definition file name ......................... 237
Agent Logout Time calculation ......................... 445
Agent Monthly reports
   available reports ......................................... 437
   report variations ......................................... 438
agent permission ............................................ 49
Agent Position ID
   ACD extension ............................................ 526
Agent reports
   available reports ......................................... 427
   report variations ......................................... 429
agent resources view ..................................... 377, 379, 381
agents
   basic login .................................................. 40
   hierarchy configuration .................................. 451
agent types .................................................... 40
Agent Update Time .......................................... 233
Agent view
   defined ........................................................ 350
   display ....................................................... 400
Agent Work Time ............................................ 233
Alert Editor
   Alert Definition tab ....................................... 410
   Notifications tab .......................................... 411
   Scope tab ................................................... 410
alerts
   Alert Editor ................................................ 410, 411
   Alert Viewer dialog box ................................. 409
   check status ............................................... 409
   control ....................................................... 324
   create ....................................................... 405
   disable ...................................................... 408
   edit .......................................................... 406
   enable ........................................................ 408
   examples .................................................... 403
   log ............................................................ 407
alerts (continued)
   purpose ...................................................... 402
   remove ....................................................... 407
   start monitoring ......................................... 324
   types ........................................................ 402
   view in Agent Blending .................................. 538
alert setting
   combinations .............................................. 404
   Alert Viewer ............................................... 407
   check alert status ....................................... 409
   create alerts .............................................. 405
   dialog box ............................................... 409
   Allow agents to cancel call ......................... 242
   Allow dialing from deleted record ................ 242
   alternate initial phone ................................. 204, 205
   alternate initial phone tab field descriptions ... 201
   alternate phone ......................................... 244
   Analyst ..................................................... 412
   change a report .......................................... 416
   delete a report .......................................... 415
   export a report .......................................... 418
   overview ................................................... 412
   preview a report ......................................... 416
   print a report ............................................. 417
   schedule a report ....................................... 420
   analyst report ............................................ 77
   Analyst report categories ............................. 423
   answer supervision ...................................... 32
   job .......................................................... 32
   record selection row .................................... 220
   row in phone strategy .................................. 204
   application ............................................... 524
   Rockwell Spectrum ...................................... 524
   telescript ............................................... 524
   Application Directory Number
   Spectrum ................................................... 525
   application enablement services .................... 34
   application number ..................................... 525
   ASA .......................................................... 521
   Average Speed to Answer .............................. 521
   assign ....................................................... 526
   Meridian .................................................... 526
   multiple queues ........................................ 526
   assigning .................................................. 72, 73
   assigning a role to users .............................. 85
   Assign roles .............................................. 53
   Assign users .............................................. 54
   Auditor ..................................................... 37
automated message ......................................................... 191
automated messages ....................................................... 189
automated release agent .................................................. 227
automatic number identification ...................................... 164
available reports
  Administrative ............................................................... 436
  Agent ........................................................................ 427
  Agent Monthly ............................................................ 437
  Job .......................................................................... 429
  Job Monthly ............................................................... 438
  Time of Day ............................................................... 433
  Time of Day Monthly ................................................... 440
Avaya Communication Manager
  vector ........................................................................ 524
Avaya Communication Manager, agent blending ................. 523
Avaya Proactive Contact
  host ........................................................................ 24
  overview .................................................................. 24
  PG230 messages ........................................................ 183
  Spectrum ................................................................... 525
  with Avaya Communication Manager ........................... 183
Average Speed to Answer
  Agent Blending control method .................................... 529
  domain group ........................................................... 521
B
Backup
  calling list ................................................................. 282
  tenant ..................................................................... 282
backup and restore of configuration files ............................ 125
backward compatibility .................................................... 27
basic login
  agents ...................................................................... 40
Batch Campaign Update .................................................. 145
batch user ................................................................... 62
Benefits ....................................................................... 446
blend agent ................................................................... 40
blending ....................................................................... 532
blend jobs ..................................................................... 224
branch, hierarchy tree .................................................... 509
button
  bar .......................................................................... 319
  change icon size ....................................................... 422
  Custom group ........................................................... 329
  large or small icons ................................................... 325
button group ................................................................. 113
button groups ................................................................ 109
buttons ......................................................................... 306
C
calculated performance fields ............................................ 448
calculations
  Abandon Calls .......................................................... 443
  Agent Logout Time .................................................... 445
calculations (continued)
  Idle Time .................................................................. 444
  Job Active Time ........................................................ 445
  Online Time .............................................................. 445
call completion code statistics
  combined .................................................................. 478
call detection mode ...................................................... 199
call handling times
  inbound .................................................................... 459
  PTP .......................................................................... 473
  Call handling times
  combined .................................................................. 453
calling list
  download .................................................................. 26
  overview .................................................................. 26
  call list dictionary ..................................................... 137
  calling list feature .................................................... 142
Calling List fields
  descriptions .............................................................. 493
  length ...................................................................... 493
  type ......................................................................... 493
  calling list modifications .......................................... 156
  calling list reports .................................................... 157
  calling lists
    configure zip to time zone ....................................... 138
  calling results tab .................................................... 214
  call pacing ................................................................ 228
  Expert Calling Ratio .................................................. 233
  initial hit rate ........................................................... 233
  methods .................................................................. 232
  minimum hit rate ....................................................... 234
Call-progress event ........................................................ 527
Call queue
  Agent Blending domain ............................................. 526
calls in the wait queue ..................................................... 233
call statistics
  combined .................................................................. 455
  inbound .................................................................... 461
  person to person ...................................................... 474
  PTP .......................................................................... 474
call transaction
  statistics .................................................................. 501
campaign template ....................................................... 306
Campaign Template
  error messages ........................................................... 313
  campaign template panes field descriptions .................. 307
  campaign template replication across tenants .............. 310
capacity ..................................................................... 34
category
  assign a completion code .......................................... 171
  remove a completion code ........................................ 172
Cell Phone Campaign Call Progress .................................. 236
change
  completion code ....................................................... 172
  Monitor default settings ............................................ 318
Change a report ............................................................. 416
changing the maximum number of events that health manager displays ............................................... 106
characters, wildcard .......................................................................................................................... 210
CJK language .................................................................................................................................. 519
class of service 
  ACD ............................................................................................................................................ 527
clear 
  all rows in a phone strategy ......................................................................................................... 206
  record selection row .......................................................................................................................... 223
closures, completion code category .................................................................................................. 168
columns ............................................................................................................................................... 90
combined 
  call completion code statistics ....................................................................................................... 478
  call statistics ................................................................................................................................... 455
  queue statistics ................................................................................................................................. 458
  RPC and closure statistics .................................................................................................................. 474
Combined ............................................................................................................................................. 449
completion code 
  assign a code to a category ............................................................................................................ 171
  assign to category ............................................................................................................................. 170
  attributes .......................................................................................................................................... 167
  categories ......................................................................................................................................... 168
  change .............................................................................................................................................. 172
  code ................................................................................................................................................ 167
defined .................................................................................................................................................. 166
description .......................................................................................................................................... 167
elements .............................................................................................................................................. 166
keyword .............................................................................................................................................. 167
record selection .................................................................................................................................... 208
remove from category .......................................................................................................................... 172
save as HTML ....................................................................................................................................... 173
save configuration ................................................................................................................................. 173
type .................................................................................................................................................... 167
Completion Code 
  gain access ....................................................................................................................................... 170
Completion Code Detail by Agent view ............................................................................................... 371
Completion Code Manager .................................................................................................................. 166
  assign code to a category .................................................................................................................. 170
  change a code .................................................................................................................................... 172
  Completion Code Wizard .................................................................................................................. 170
  multi-dialers ...................................................................................................................................... 169
  remove a code from a category .......................................................................................................... 172
  save a completion code ..................................................................................................................... 173
  saves as HTML .................................................................................................................................. 173
  start .................................................................................................................................................... 170
  Tools menu ....................................................................................................................................... 170
  window ............................................................................................................................................... 169
completion code number 
  Abandon ............................................................................................................................................ 452
  closure .............................................................................................................................................. 452
  RPC .................................................................................................................................................. 452
type .................................................................................................................................................... 452
completion codes examples .................................................................................................................. 167
Completion Code Summary reports .................................................................................................... 426
completion code window right-hand pane ........................................................................................... 427
Completion Code Wizard .................................................................................................................... 170
configuration files ............................................................................................................................... 121
Configurator ......................................................................................................................................... 103
configure 
  answer supervision ........................................................................................................................... 235
  calling lists ....................................................................................................................................... 138
  jobs .................................................................................................................................................. 235
  shadow jobs in preview mode ......................................................................................................... 236
  zip to time zone ................................................................................................................................ 138
configuring opt-out on soft dialer ....................................................................................................... 247
configuring record specific messaging using scripts ......................................................................... 162
configuring the dnc opt out feature .................................................................................................... 261
contact management .......................................................................................................................... 113
copying campaign template from default tenant to another tenant .................................................. 311
copying campaign template from one tenant from one tenant to another ........................................ 311
copy record selection .......................................................................................................................... 218
CPU ..................................................................................................................................................... 106
cpu usage statistics descriptions ........................................................................................................ 98
create 
  Agent Blending domain .................................................................................................................. 533
  alerts ............................................................................................................................................... 405
  hierarchy ......................................................................................................................................... 511
  job .................................................................................................................................................. 253
  Monitor button ................................................................................................................................. 329
Create 
  new .................................................................................................................................................. 449
  report .............................................................................................................................................. 449
Create a new report configuration ....................................................................................................... 413
creating an agent job list ..................................................................................................................... 315
creating a new agent key set ............................................................................................................... 178
creating a new calling list ................................................................................................................... 127
creating a new campaign template ..................................................................................................... 308
creating a new do not call group ......................................................................................................... 160
creating a new download map .......................................................................................................... 134
creating a new report configuration .................................................................................................. 414
creating a new role ............................................................................................................................. 50
creating a new upload map .................................................................................................................. 154
creating a script for OFCOM compliant jobs ...................................................................................... 259
creating a tenant ................................................................................................................................. 69
creating email notification .................................................................................................................. 405
Creating multiple users using Batch User Creation wizard ................................................................ 63
Cruise Control 
  benefits ............................................................................................................................................ 229
call pacing method ............................................................................................................................. 228
  Desired Service Level ....................................................................................................................... 252
  required settings ............................................................................................................................... 252
  Time to Connect Tolerance .............................................................................................................. 252
Custom
  button group ..................................................................................................................................... 329
  rename Monitor view set .................................................................................................................. 328
  save as Monitor view set .................................................................................................................. 328
  save current Monitor views .............................................................................................................. 327
  standard Monitor views ................................................................................................................... 326
  view, defined .................................................................................................................................... 350
  views, see View ................................................................................................................................. 319
disable an alert ......................................................... 408
Disk partition .......................................................... 106
disk usage statistics descriptions .............................. 99
display
agent view ................................................................. 400
empty record at preview ........................................... 242
documentation .......................................................... 540
domain ................................................................. 527, 528
  create ...................................................................... 533
  delete ...................................................................... 535
  edit ........................................................................ 534
  move ...................................................................... 536
  types ...................................................................... 528
domain extension
  Application Directory Number ................................. 525
  DN ......................................................................... 525
domain group
  Agent Blending ........................................................ 528
  ASA ........................................................................ 521
  Average Speed to Answer ......................................... 521
  configurations .......................................................... 528
  control methods ...................................................... 528
  create ...................................................................... 533
  create in Agent Blending ........................................... 533
  delete ...................................................................... 535
  edit ........................................................................ 534
  OB_ONLY .................................................................. 521
  one or more domains ................................................. 528
  Service Level .......................................................... 521
domain groups
  agent blending ........................................................ 528
  Do Not Call ............................................................. 237
  group name .............................................................. 237
  do not call groups ..................................................... 159
download ................................................................. 26
  calling lists .............................................................. 26, 127
download dictionary .................................................. 133
download from host .................................................... 130
download from host tab
  field description ....................................................... 130
downloading a campaign template ............................... 309
download map ............................................................. 134
dummy hunt group
  Agent Blending ........................................................ 527
dynamic data exchange
  parameter ................................................................. 544
e
edit
alerts ........................................................................ 406
Analyst report ........................................................... 416
domain group in Agent Blending ................................. 534
domain in Agent Blending ........................................... 534
job ................................................................. 267
record selection ........................................................ 217
editing a merged role .................................................. 83
editing an upload map ................................................. 154
editing a role permission ........................................... 85
editor ............................................................... 41, 47, 108, 109
Editor
  Job Wizard .............................................................. 253
  Selection Reports ..................................................... 211, 219
  Selections ................................................................. 207, 212
  Strategies ................................................................. 197
  editor button ............................................................ 111
  editor settings .......................................................... 114
email alert .................................................................. 324
  Elementary and calculated data ................................ 448
  elementary performance fields ................................ 448
  e-mail, send alert notifications .................................... 448
  email alert ................................................................. 407
  email alert ................................................................. 407
  enable ..................................................................... 408
  enabling and disabling alerts ..................................... 408
  enabling a unit work list ............................................ 392
  enabling FCC nuisance rate reporting ....................... 265
  enabling OFCOM for a job ....................................... 260
  enabling or disabling multidialer commands ............. 114
  end jobs ................................................................. 244
  enhanced ID field for calling list names ..................... 35
  environment ........................................................... 27
  error messages ........................................................ 313
  escape general recall ............................................... 251
  escape recall ........................................................... 251
  escape recall job ........................................................ 251
  job settings ............................................................. 251
  Escape recall in infinite job ........................................ 251
  expert calling ratio ................................................... 229, 233, 244
  Expert Calling Ratio .................................................. 229, 233, 244
  AGENT UPDATE TIME .............................................. 233
  AGENT WORK TIME ............................................... 233
  call pacing method ................................................... 228, 232
  change in Monitor .................................................... 386
  dialog box ................................................................ 335
  dialog box ................................................................. 335
  wait queue ............................................................... 233
  export a report .......................................................... 418
  export formats .......................................................... 418
  export a data file ....................................................... 149, 150
  exporting a data file instantly ..................................... 149
  extended regular expression ...................................... 270, 275
F
favorite view ............................................................ 350
FCC 12–21 regulation compliance ............................... 261
FCC 12–21 regulation for a virtual job .......................... 262
FCC 12–21 regulation for live outbound calls .................. 262
Index

FCC 12–21 regulation on proactive contact with CTI .................................................. 264
fcc nuisance rate ................................................................................................. 443
features .................................................................................................................. 491
features 5.1.2 ........................................................................................................ 33
PC Analysis Telnet ............................................................................................... 491
hierarchies ............................................................................................................. 353
hierarchies 5.1.2 ................................................................................................. 353
sending called party number for opt out calls to VDN ........................................ 33
support for windows 8.1 ..................................................................................... 33
Feedback Options dialog box tab ........................................................................ 331
field description ..................................................................................................... 130
field descriptions ................................................................................................... 144
fields ...................................................................................................................... 449
files ....................................................................................................................... 237
agent keys definition file name .......................................................................... 237
Do Not Call ........................................................................................................... 237
inbound calling list ............................................................................................. 237
inbound screen(s) ............................................................................................... 237
names .................................................................................................................... 237
outbound screen(s) ............................................................................................. 237
record selection file name .................................................................................. 237
filter ....................................................................................................................... 343
Data ...................................................................................................................... 343
Filter Data ........................................................................................................... 352
Filter Data in Monitor ......................................................................................... 332
Filter Data ........................................................................................................... 345
filtering the completion codes to view .................................................................. 173
Find ....................................................................................................................... 343
Agent .................................................................................................................... 377
Monitor dialog box ............................................................................................ 332
search for a text string in Monitor .................................................................... 395
Find Agent ........................................................................................................... 397
dialog box ........................................................................................................... 341
view ...................................................................................................................... 377
Find Item, View toolbar ..................................................................................... 352
floating point ....................................................................................................... 272
pattern matching ................................................................................................. 270
FTP Client dialog box .......................................................................................... 508
G

gain access .............................................................................................................. 35
Completion Code Manager .................................................................................. 170
General information ............................................................................................. 459
grace period ......................................................................................................... 30
Graphic View ....................................................................................................... 343
in Monitor ............................................................................................................ 348
View toolbar ........................................................................................................ 352
Group field .......................................................................................................... 213, 214
group name ........................................................................................................ 62
Guidelines for creating new reports ..................................................................... 449
H

Health_manager_maintaining_license_configurator ............................................. 103
Health Bridge ....................................................................................................... 104
health manager ................................................................................................. 41, 77
Health Manager .................................................................................................. 87
health status .......................................................................................................... 87
hide columns ......................................................................................................... 90
hide or show columns .......................................................................................... 343
in Monitor ............................................................................................................ 348
View toolbar ........................................................................................................ 352
Hierarchies .......................................................................................................... 353
scope selectors .................................................................................................... 353
Hierarchy Manager .............................................................................................. 343
hierarchy ................................................................................................................ 320, 347, 509
add a level ............................................................................................................. 512
add data items to bottom branch ...................................................................... 513
delete .................................................................................................................. 515
dialers ................................................................................................................... 451
find agents on a dialer ......................................................................................... 396
find agents reporting to a supervisor .................................................................. 396
job ......................................................................................................................... 452
move a level .......................................................................................................... 513
move elements ..................................................................................................... 513
remove a data item ............................................................................................. 515
remove a level ..................................................................................................... 514
rename .................................................................................................................. 515
rename a level ..................................................................................................... 514
set default in Monitor ......................................................................................... 344
tree branches ...................................................................................................... 509
hierarchy configuration

agents ..................................................................................................................... 451
Hierarchy Manager .............................................................................................. 343
add a level ............................................................................................................. 512
add data items ..................................................................................................... 513
agent hierarchy .................................................................................................... 510
create a hierarchy ............................................................................................... 511
delete a hierarchy ............................................................................................... 515
dialer hierarchy ................................................................................................... 510
icon on View toolbar .......................................................................................... 352
job hierarchy ........................................................................................................ 510
move a hierarchy level ......................................................................................... 513
move elements ..................................................................................................... 513
open a hierarchy ................................................................................................. 512
overview .............................................................................................................. 509
remove a data item ............................................................................................. 515
remove a hierarchy level .................................................................................... 514
rename a hierarchy ............................................................................................. 515
rename a hierarchy level .................................................................................... 514
start ....................................................................................................................... 511
Historical performance data concepts .................................................................. 447
hit rate ................................................................................................................... 233
home Time Zone ................................................................................................. 148
host

Spectrum .............................................................................................................. 525
hourly repetition in schedule activity wizard ..................................................... 289
html ....................................................................................................................... 57
HTML .................................................................................................................... 349
Record Selections report ..................................................................................... 218
hunt group

July 2018
Using Avaya Proactive Contact Supervisor
Comments on this document? infodev@avaya.com

557
**Index**

**hunt group (continued)***
- ACD ................................................................. 523
- ACD split ......................................................... 524
- split ................................................................. 524

**I**
- icons on views toolbar ........................................ 352
- idle agent state .................................................. 322
- Idle count fields ............................................... 449
- Idle Time calculation ........................................... 444
- implementation of fcc 12–21 regulation .................. 36
- implementing the FCC 12-21 amendment ................. 262
- implementing the RSM feature ............................ 161
- importing a data file ......................................... 128

**Inbound**
- calling list ....................................................... 237
- jobs ................................................................. 224
- screen(s) ......................................................... 237
- settings .......................................................... 387
- settings dialog box ........................................... 335
- wait queue limit ............................................... 253

**Inbound**
- call handling time .......................................... 459
- call statistics .................................................. 461
- inbound processing settings ............................... 240
- inbound wait queue ......................................... 189, 190
- infinite job ..................................................... 225
- record selection ............................................... 213
- infinite job option ............................................. 144
- infinite jobs .................................................... 143
- initial ............................................................... 200
- hit rate ............................................................ 233, 234
- phone .............................................................. 198, 204, 205
- initial hit rate job ............................................. 234
- initial phone tab field descriptions ....................... 201
- insert record selection row ................................ 220
- installing campaign template ............................. 309
- integer pattern matching ................................... 270
- Intelligent Call Blending agent logins .................. 41
- Interactive Voice Response See IVR ......................... 238
- Interactive Voice Response job settings ................. 239
- interface customization .................................... 109
- IVR settings .................................................... 238

**J**
- job ................................................................. 241
- adjust while running ........................................ 383
- agent keys definition file name .......................... 237
- Allow agents to cancel call ............................... 242
- alternative phone lowest priority ...................... 244
- answer supervision ......................................... 32
- basic settings ............................................... 230
- blend ............................................................ 224
call pacing settings ............................................ 232
Cell Phone Campaign Call Progress .................... 236
change inbound settings in Monitor ..................... 387
completion code detail view ............................... 372
Connect Tolerance ............................................. 252
controls .......................................................... 383
copy .................................................................. 267
create .............................................................. 253
delete ............................................................... 268
delete multiple jobs ......................................... 268
Desired Service Level ........................................ 252
Do Not Call ..................................................... 237
edit .................................................................. 267
Editor Job Wizard ............................................. 253
EDT ................................................................. 291
enable FCC opt-out .......................................... 265
end .................................................................. 244
Escape recall in infinite job files ............................ 251
hierarchy ......................................................... 510
inbound ........................................................... 224
inbound calling list .......................................... 237
Inbound processing settings ............................... 240
inbound screen(s) ............................................. 237
inbound wait queue limit .................................... 253
Infinite ............................................................ 225
initial hit rate .................................................... 233, 234
initial hit rate settings ....................................... 234
IVR settings .................................................... 238
Line type(s) for use on job ................................... 230
link a job ......................................................... 384
link to job ......................................................... 237
list .................................................................. 268
main data processing label .................................. 241
managed ........................................................ 242
Managed Dialing ............................................. 225, 242
messages ........................................................ 182
minimum hit rate .............................................. 234
modify record selection in Monitor ..................... 387
Name of the job to get agent for recall ................. 251
number of recall attempt ................................... 250
on Intelligent Call Blending system ..................... 224
order calls by time zone .................................... 244
outbound ......................................................... 224, 225
outbound processing settings ............................. 244
outbound screen(s) ............................................ 237
overview ........................................................ 224
post processing settings .................................... 248
quota for completion code .................................. 249
quota settings .................................................. 249
recall notification time ....................................... 250
recall schedule interval ..................................... 250
recall settings .................................................. 250, 251
record selection file name ................................... 237
rename Monitor view set .................................... 328

---

 Comments on this document? infodev@avaya.com

July 2018

Using Avaya Proactive Contact Supervisor

558
Monitor (continued)

Find Agent dialog box .......................................................... 341
find an agent view .................................................................. 377
Find dialog box ....................................................................... 332
find text string ...................................................................... 395
hide or show columns ............................................................. 348
Inbound Settings dialog box .................................................... 335
Job agents view .................................................................... 360
Job call handling view ........................................................... 365
Job completion code view ....................................................... 365
job control dialog box ............................................................. 333–340
Job detail view ......................................................................... 362
Job history view ....................................................................... 370
Job link dialog box .................................................................. 333
job performance ..................................................................... 372
Job quality view ....................................................................... 373
Job status view ........................................................................ 359
Job wait queue view ............................................................... 368
large or small icons ................................................................ 325
Lines dialog box ...................................................................... 339
link to a job ............................................................................. 384
manage agents ....................................................................... 396
Managed Dialing dialog box ................................................... 336
Minimum Hit Rate dialog box .................................................. 334
Multi-Dialer tab, Options dialog box ........................................ 330
navigate .................................................................................. 325
going back or forward ............................................................. 326, 328
open a view ............................................................................. 326, 328
Options dialog box .................................................................. 330
overview .................................................................................. 318
Quota dialog box ..................................................................... 338
real-time .................................................................................... 387
reassign lines ......................................................................... 389
Record selection of link job dialog box ..................................... 334
remove agent from a job ......................................................... 400
Retry dialog box ....................................................................... 339
save a view as an HTML file .................................................... 349
save changes to views ............................................................. 323
save current view ..................................................................... 327
save view as HTML .................................................................. 328
Scope tab, Options dialog box .................................................. 330
Selection records dialog box .................................................... 340
Selection results dialog box ..................................................... 340
Selection sort dialog box .......................................................... 340
select the hierarchy .................................................................. 347
Send Message dialog box .......................................................... 342
set a default view ..................................................................... 346
set alternate initial phone ......................................................... 324
set Detection Mode .................................................................. 393
set or change a quota .............................................................. 392
set retries ................................................................................. 394
set the default hierarchy .......................................................... 344
set the scope ........................................................................... 345
set up a unit work list ............................................................... 391
sort calls by time zone ............................................................. 390
standard views ........................................................................ 326

Monitor (continued)

start alert monitoring automatically ........................................ 324
Stop Job .................................................................................. 383
Stop Job dialog box ............................................................... 333
Stop job immediately ............................................................. 383
Supervisor dialog box ............................................................. 333
Supervisor Agents view .......................................................... 375
Table View or Graphical View ................................................ 348
time range ............................................................................. 346
Time Zones dialog box ............................................................ 336
toolbar, Filter Data .................................................................. 343
toolbar, Find ........................................................................... 343
toolbar, Graphical view ........................................................... 343
toolbar, Hide/Show Columns .................................................. 343
toolbar, Hierarchy Manager .................................................... 343
toolbar, Level 1 Scope Selector ................................................. 343
toolbar, Level 2 Scope Selector ............................................... 343
toolbar, Level 3 Scope Selector ............................................... 343
toolbar, Performance Code ..................................................... 343
toolbar, Refresh view ............................................................. 343
toolbar, Table View ............................................................... 343
toolbar, Time Scope .................................................................. 343
Transfer Agent dialog box ....................................................... 342
Unit Work Lists dialog box ...................................................... 337
use of wildcard characters ...................................................... 397
user interface ......................................................................... 319
use Tools applications ............................................................ 325
view, defined ........................................................................... 319
view control dialog box .......................................................... 330–332
view defined ............................................................................ 343
views ....................................................................................... 319, 350
view set .................................................................................... 323, 328
view time scope ....................................................................... 346
view toolbar ............................................................................. 343
monitor an agent line ............................................................. 399
monitor settings in multi-tenant environment ............................ 318
monthly data ............................................................................. 450
Monthly roll-up dictionaries ...................................................... 447
move ......................................................................................... 536
Agent Blending domain ........................................................... 221, 222
multi-dialer ................................................................................. 169
Completion Code Manager ....................................................... 321
control ...................................................................................... 321
multi-tenant ............................................................................. 34, 43, 89, 108, 109
multi-tenant in analyst ............................................................ 412

N

name of next job ....................................................................... 237
Name of the job to get agent for recall .................................... 251
native voice and data transfer .................................................. 146
Native Voice and Data Transfer ............................................... 146
navigate in Monitor ............................................................... 325
new in this release ............................................................... 328
manual dialing ......................................................................... 92
TLS 1.0 and high ciphers .......................................................... 92

Comments on this document? infodev@avaya.com
Index

new user ............................................................ 59
not available agent state ................................. 322
not supported
  Windows XP .................................................. 33
number of recall attempts ................................ 250
numerical comparison .................................... 272

O

OB_ONLY domain group ................................ 521
OFCOM ........................................................ 258
  72 hour compliance ...................................... 261
office of communication .................................. 257
off job agent state ......................................... 322
offline agent state ......................................... 322
on hold
  play message .............................................. 235
  play music .................................................. 235
online help .................................................... 42
Online Time calculation .................................. 445
open hierarchy .............................................. 512
operations permissions .................................. 47
Options
  Agent States ............................................... 331
  dialog box .................................................. 330
  options alerts tab ....................................... 331
  options dialog box field descriptions .............. 269
  opt-out configuration on hard dialer ................. 245
  opt-out feature settings field descriptions ......... 246
  opt-out settings .......................................... 245
  opt-out to VDN
    TRANSID ............................................... 247
  Opt-out to VDN
    TRANSID feature ...................................... 33
outbound
  Agent Blending .......................................... 528
  Outbound Only .......................................... 529
  processing settings ..................................... 244
  screen(s) .................................................. 237
  wait queue ................................................ 189
Outbound ....................................................... 449
Outbound call handling time ......................... 465
outbound job .................................................. 224, 225
  Infinite ...................................................... 225
  Managed Dialing ........................................ 225
  Sales Verification ....................................... 225
  script label for call .................................... 241
  special types .......................................... 225
  Unit Work List .......................................... 225
  Virtual Agent ............................................ 225, 239
outbound wait queue ...................................... 190
  statistics .................................................. 472
out of time zone phone support ...................... 36
Overall Health Services Dialer Status view ........ 90, 91
overview ....................................................... 24

P

PAB
  parameter .................................................. 544
  blend ......................................................... 544
  parameters ............................................... 547
    Agent display settings ............................... 548
    dialerlist ................................................. 550
    log files ................................................ 547
    security ................................................. 549
    server .................................................. 547
    session .................................................. 547
    telephone extension numbers ...................... 546
    user interface ........................................ 544
pass
  called party number .................................. 247
passing ......................................................... 247
password length
  CUI Login
    Agent API ............................................... 33
    EnClient ................................................. 33
    Proactive Contact Agent ............................ 33
passwords ..................................................... 39
pattern matching
  date comparison ....................................... 272
  explicitly designate syntax ......................... 271
  extended regular expression ....................... 270, 275
  field type syntax ....................................... 270
  floating point .......................................... 272
  list separator .......................................... 271
  numerical comparison ................................ 272
  phone strategy ......................................... 270
  record selection ....................................... 270
  shell-style ............................................... 270, 274
  string ..................................................... 270
  string comparisons ................................... 273
  syntaxes .................................................. 270, 271
  time comparisons ...................................... 273
pause .......................................................... 189
PC Analysis
  FTP Client dialog box .................................. 508
  telnet, defined ......................................... 491
  telnet, start ............................................. 492
  telnet, transfer PC Analysis extract output file .... 508
  transfer extract file .................................. 508
PC analysis telnet ........................................ 491
PC Analysis Telnet
  features .................................................. 491
  performance code ...................................... 343
  permissions .............................................. 48, 81
  person to person
    call statistics ......................................... 474
  Person to Person
    call handling times .................................. 473
  phone, tab ............................................... 200
  phone strategy .........................................
Index

<table>
<thead>
<tr>
<th>Record selection (continued)</th>
<th>( \text{specify completion codes} )</th>
<th>208</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>( \text{specify goals} )</td>
<td>208</td>
</tr>
<tr>
<td></td>
<td>( \text{specify time zones} )</td>
<td>207</td>
</tr>
<tr>
<td></td>
<td>( \text{Time Zones tab} )</td>
<td>214</td>
</tr>
<tr>
<td></td>
<td>( \text{Value field} )</td>
<td>213</td>
</tr>
<tr>
<td></td>
<td>( \text{verify} )</td>
<td>217</td>
</tr>
<tr>
<td></td>
<td>( \text{view reports} )</td>
<td>219</td>
</tr>
<tr>
<td></td>
<td>( \text{view selections} )</td>
<td>219</td>
</tr>
<tr>
<td>Record selection for multiple dialers</td>
<td></td>
<td>223</td>
</tr>
<tr>
<td>Record selection of link job</td>
<td>( \text{dialog box} )</td>
<td>334</td>
</tr>
<tr>
<td></td>
<td>( \text{Record Selections report, HTML file} )</td>
<td>218</td>
</tr>
<tr>
<td></td>
<td>( \text{record specific messaging} )</td>
<td>161</td>
</tr>
<tr>
<td>Records tab in Selections</td>
<td>( \text{recurrence pattern} )</td>
<td>289</td>
</tr>
<tr>
<td></td>
<td>( \text{reducing the number of lines from the telephony file} )</td>
<td>183</td>
</tr>
<tr>
<td>refresh</td>
<td>( \text{refresh tab} )</td>
<td>115</td>
</tr>
<tr>
<td></td>
<td>( \text{view} )</td>
<td>343</td>
</tr>
<tr>
<td></td>
<td>( \text{View toolbar} )</td>
<td>352</td>
</tr>
<tr>
<td>refresh data</td>
<td>( \text{refresh data} )</td>
<td>56, 91</td>
</tr>
<tr>
<td>refreshing a view</td>
<td>( \text{refreshing a view} )</td>
<td>113, 329</td>
</tr>
<tr>
<td>remove</td>
<td>( \text{remove} )</td>
<td>400</td>
</tr>
<tr>
<td></td>
<td>( \text{agent} )</td>
<td>407</td>
</tr>
<tr>
<td></td>
<td>( \text{alerts} )</td>
<td>407</td>
</tr>
<tr>
<td></td>
<td>( \text{completion code from a category} )</td>
<td>172</td>
</tr>
<tr>
<td>removing a script action</td>
<td>( \text{removing a script action} )</td>
<td>194</td>
</tr>
<tr>
<td>rename</td>
<td>( \text{rename hierarchy} )</td>
<td>515</td>
</tr>
<tr>
<td></td>
<td>( \text{hierarchy level} )</td>
<td>514</td>
</tr>
<tr>
<td>renaming a role</td>
<td>( \text{rename a role} )</td>
<td>51</td>
</tr>
<tr>
<td>Report</td>
<td>( \text{renaming a role} )</td>
<td>84</td>
</tr>
<tr>
<td>Report categories</td>
<td>( \text{Report Analyst report} )</td>
<td>418</td>
</tr>
<tr>
<td></td>
<td>( \text{agent monthly reports} )</td>
<td>423</td>
</tr>
<tr>
<td></td>
<td>( \text{agent reports} )</td>
<td>423</td>
</tr>
<tr>
<td></td>
<td>( \text{job monthly reports} )</td>
<td>423</td>
</tr>
<tr>
<td></td>
<td>( \text{job reports} )</td>
<td>423</td>
</tr>
<tr>
<td></td>
<td>( \text{time of day reports} )</td>
<td>423</td>
</tr>
<tr>
<td>report overview</td>
<td>( \text{report overview} )</td>
<td>426</td>
</tr>
<tr>
<td></td>
<td>( \text{Completion Code Summary} )</td>
<td>426</td>
</tr>
<tr>
<td></td>
<td>( \text{Managed Dialing} )</td>
<td>425</td>
</tr>
<tr>
<td>reports</td>
<td>( \text{reports} )</td>
<td>57, 64</td>
</tr>
<tr>
<td></td>
<td>( \text{category} )</td>
<td>426</td>
</tr>
<tr>
<td></td>
<td>( \text{Completion Code Summary} )</td>
<td>426</td>
</tr>
<tr>
<td></td>
<td>( \text{Managed Dialing} )</td>
<td>425</td>
</tr>
<tr>
<td>reports in campaign template</td>
<td>( \text{reports in campaign template} )</td>
<td>312</td>
</tr>
<tr>
<td>report variations</td>
<td>( \text{Agent Monthly reports} )</td>
<td>438</td>
</tr>
<tr>
<td></td>
<td>( \text{Agent reports} )</td>
<td>429</td>
</tr>
<tr>
<td></td>
<td>( \text{Job} )</td>
<td>432</td>
</tr>
<tr>
<td></td>
<td>( \text{Job Monthly} )</td>
<td>440</td>
</tr>
<tr>
<td></td>
<td>( \text{Time of Day} )</td>
<td>435</td>
</tr>
<tr>
<td></td>
<td>( \text{Time of Day Monthly} )</td>
<td>442</td>
</tr>
<tr>
<td>reset blend engine</td>
<td>( \text{reset blend engine} )</td>
<td>537</td>
</tr>
<tr>
<td>resize</td>
<td>( \text{resize} )</td>
<td>537</td>
</tr>
</tbody>
</table>

| Resize (continued)         | \( \text{columns} \)                | 320 |
|                            | \( \text{resizing columns} \)       | 111 |
|                            | \( \text{resizing panes} \)         | 112 |
|                            | \( \text{restrictions} \)           | 279 |
|                            | \( \text{activities} \)             | 279 |
|                            | \( \text{restrictions for scheduling} \) | 279 |
|                            | \( \text{Results tab} \)            | 214 |
|                            | \( \text{resynch blend engine} \)   | 538 |
|                            | \( \text{reties} \)                 | 199 |
|                            | \( \text{set in Monitor} \)         | 394 |
|                            | \( \text{tab} \)                    | 200 |
| retry                      | \( \text{dialog box} \)             | 339 |
|                            | \( \text{Right Party Contacts, completion code category} \) | 168 |
| Rockwell Spectrum          | \( \text{Agent Blending} \)         | 524 |
|                            | \( \text{Role Administrator} \)     | 37  |
|                            | \( \text{role editor} \)            | 65  |
|                            | \( \text{Role Editor operations} \)  | 77  |
|                            | \( \text{role permissions} \)       | 80  |
|                            | \( \text{roles} \)                  | 44  |
|                            | \( \text{rollup status} \)          | 450 |
|                            | \( \text{RPC and closure statistics} \) | 474 |
|                            | \( \text{rule descriptions for configuration files} \) | 123 |
|                            | \( \text{running a database maintenance as a scheduled activity} \) | 288 |

S

sales verification          | 147 |
Sales Verification          | 147, 225 |
save                        | 114 |
changes to views            | 323 |
completion code HTML file   | 173 |
job settings                | 254 |
Monitor view as HTML        | 328 |
view as a HTML file in Monitor | 349 |
save data as HTML           | 103 |
save version data           | 180 |
saving a record selection   | 216 |
saving a tenant in different stages | 71 |
schedule Analyst report     | 420 |
Schedule a report           | 420 |
schedule reports           | 290 |
schedules, download and load | 26 |
scheduling a backup activity type | 280 |
scheduling a backup calling list for latelist | 281 |
scheduling a campaign update | 282 |
scheduling a custom script  | 283 |
scheduling a file transfer  | 284 |
scheduling a selection      | 286 |
scheduling MTS maintenance  | 285 |
scheduling proactive contact maintenance | 286 |
scheduling restart proactive contact | 288 |
scheduling run a job        | 287 |
Using Avaya Proactive Contact Supervisor

Index

Scope
 Appearance tab .......................................................... 331
 Multi-Dialer Control tab ........................................ 330
 Options dialog box tab ........................................... 330
 Selector ................................................................. 343
 scope selector
 defined ................................................................. 344
 examples .............................................................. 344
 set ......................................................................... 345
 Screens dialog box .................................................. 269
 script
 actions ...................................................................... 189
 automated messages ............................................. 189
 change ..................................................................... 195
 create message script ............................................ 192
 defined .................................................................... 182, 188
 Delete dialog box .................................................... 196
 inbound wait queues ............................................. 189
 label for answer .................................................... 241
 label for call .......................................................... 241
 maximum .................................................................. 183
 outbound wait queues .......................................... 189
 pane ........................................................................ 191
 pause message ....................................................... 189
 plane message ......................................................... 189
 remove ..................................................................... 195
 Rename Folder dialog box ..................................... 196
 start ........................................................................ 185
 start Scripts .......................................................... 191
 telephony.spt ........................................................ 183
 transfer wait queues ............................................. 189
 types ........................................................................ 189
 virtual wait queues ............................................... 189
 wizard ..................................................................... 192
 secondary configuration file .................................. 117
 security
 parameters .......................................................... 549
 select
 all rows in a phone strategies ................................ 205
 hierarchy ................................................................ 347
 hierarchy in Monitor .............................................. 347
 record selection row ............................................. 222
 Selection records
 dialog box ............................................................. 340
 Selection Reports .................................................... 211
 Editor ..................................................................... 219
 overview of tabs ................................................... 211
 view ......................................................................... 219
 Selection results
 dialog box ............................................................. 340
 Selections
 append row ............................................................ 220
 button ..................................................................... 212
 clear rows .............................................................. 223
 delete row .............................................................. 221
 Detail tab ............................................................... 213
 Editor ..................................................................... 207
 Selections (continued)
 Group field ........................................................... 213, 214
 infinite job ............................................................ 213
 insert row .............................................................. 220
 Logic field ............................................................. 213
 move row .............................................................. 221, 222
 overview .............................................................. 207
 Recalls tab ............................................................. 214
 Records tab ........................................................... 213
 Results tab ............................................................ 214
 select rows ........................................................... 222
 tabs ........................................................................ 208
 Time Zones tab ....................................................... 214
 Value field ............................................................. 213
 verification job ....................................................... 213
 view record selections ........................................... 219
 Selection sort
 dialog box ............................................................. 340
 selections settings ................................................ 208
 select records ........................................................ 155
 select records tab field description ...................... 155
 Send Message dialog box ....................................... 342
 server
 parameters .......................................................... 547
 Service Criterion ................................................... 521
 Service Level
 serving team .......................................................... 526
 session ................................................................. 547
 set
 default hierarchy .................................................. 320
 scope in Monitor .................................................... 345
 time range ............................................................ 321
 setting
 automatic record selection ................................... 385
 setting job template for a job type ......................... 292
 setting parameters for cruise ................................ 263
 setting prerequisites for do not call group ............... 159
 settings, job .......................................................... 230
 setting scope selectors to display data for all jobs named 30Day ........................................................... 345
 Setup and requirements ........................................ 446
 shadow jobs
 preview ................................................................... 33
 preview mode ........................................................ 236
 shell-style .............................................................. 270, 274
 show columns ....................................................... 90
 showing or hiding columns ................................... 90
 skill
 ACD ....................................................................... 523
 agents ................................................................. 523
 skill hunt group

July 2018

Comments on this document? infodev@avaya.com
telescript (continued)
  user-programmable steps ............................................ 525
telnet
  PC Analysis ............................................................ 492
  System ....................................................................... 518
tenant ............................................................................ 61
tenant administrator ........................................................ 47
Tenant Administrator .................................................... 37
tenant reports ................................................................. 75
tenant staging ................................................................ 70
tenant users ..................................................................... 74
thresholds ........................................................................ 106
time
  comparisons, pattern matching .................................... 273
  pattern matching .......................................................... 270
Time limit (sec.) for preview ........................................... 242
Time of Day Monthly reports
  available reports .......................................................... 440
  report variations .......................................................... 442
Time of Day reports
  available reports .......................................................... 433
  report variations .......................................................... 435
time range ..................................................................... 321
  set in Monitor ............................................................... 346
time scope
  view ............................................................................. 346
  Time Scope .................................................................... 343
  Time selector, View toolbar .......................................... 352
  Time to connect tolerance ............................................ 252
time zones ...................................................................... 244, 390
dialog box ...................................................................... 336
  record selection ........................................................... 207
  select to sort calls ........................................................ 390
  set up ........................................................................... 214
TLS and high ciphers
  support .......................................................................... 30
tool applications ............................................................ 112	
toolbar ............................................................................ 306
  button in a view ................................................................ 343
  within a view ................................................................... 352
toolbar buttons ................................................................ 50
Tools
  Agent Blending ............................................................ 520
  Completion Code Manager .......................................... 166
  Hierarchy Manager ....................................................... 509
  menu .............................................................................. 422
Total wait delay .............................................................. 253
training ............................................................................ 541
Transaction
  verification job .............................................................. 239
  view in Agent Blending .................................................. 539
Transaction Link
  communications channel .............................................. 525
  Spectrum ....................................................................... 525
Transfer Agent, dialog box .............................................. 342
transfer an agent ............................................................. 398
Transfer on hold message number ................................... 253
transfer wait queue ......................................................... 189
  label for job ................................................................. 241
Transfer wait queue label ................................................ 241
Transport wait queue label .............................................. 30
trunk group
  Spectrum ....................................................................... 525
types of application permissions ..................................... 48
types of configuration files ............................................. 116
types of dialer activities ................................................ 280
types of operation ............................................................ 123
U
unassigned administrator .................................................. 75
unassigning ..................................................................... 72, 73
Understanding Analyst .................................................... 412
Unit Work List ................................................................ 225
dialog box ...................................................................... 337
set up .............................................................................. 391
update
  dialer with ACD queue assignments .............................. 538
  record for the agent state .............................................. 322
  upload ........................................................................... 26
  upload dictionary tab field ............................................. 153
  upload host to tab field .................................................. 150
  uploading a campaign template ..................................... 310
  upload map ..................................................................... 154
  upload to host ............................................................... 150
Uptime ............................................................................. 92
user .................................................................................. 60, 79
user interface
  parameters ....................................................................... 544
  user management .......................................................... 61
  user name ....................................................................... 61, 62
  using agent keys .......................................................... 175
  Using Analyst ................................................................... 412
  using antivirus ............................................................... 407
  using calling lists .......................................................... 28
  using call pacing ........................................................... 228
  using convert sample command .................................... 158
  using hourly repetition with recurrence type .................. 290
  using make active command ........................................... 158
  Using or copying an Avaya Proactive Contact Analyst built-in
  report .............................................................................. 449
  using phone time zone .................................................. 148
  using postupdate ........................................................... 143
  using schedule ............................................................. 278
  using the verify command ............................................. 157
V
VDN
  agent blending .............................................................. 524
vector
  Avaya Communication Manager .................................... 524
verification features ......................................................... 125
verification job, record selection ..................................... 213
Index

verify job ................................................................. 267
multiple jobs ......................................................... 268
record selection .................................................... 217
verifying the permissions and the users assigned to the role ........................................... 80
version data .......................................................... 180
versions ................................................................ 179
videos .................................................................. 541
view .................................................................... 319
ACD statistics ......................................................... 538
alert log ................................................................. 407
Analyst report ....................................................... 416
categories ............................................................ 350
columns .................................................................. 320
custom ................................................................. 327, 350
defined ................................................................. 343
definition of .......................................................... 319, 350
in Monitor ............................................................. 319
job settings ............................................................ 254
open in Monitor ...................................................... 326
overview ............................................................... 350
resize .................................................................... 320
save as a HTML file .............................................. 349
save in Monitor ...................................................... 327
set ......................................................................... 323
standard views ...................................................... 326
toolbar .................................................................. 343, 352
toolbar icons .......................................................... 352
using ..................................................................... 345
view dialer core services health ......................... 93
view dialer data services health ......................... 94
view dialer health related services health ............ 95, 98
view dialer telephony services health ................. 94
viewing dialer agent view ...................................... 357
supervisor agents view ........................................... 376
viewing a do not call group .................................... 159
viewing agent job list reports ............................... 317
viewing campaign template reports ..................... 312
viewing data of deleted tenants ............................. 421
viewing dialers ...................................................... 64
viewing job agent view ........................................... 362
viewing reports ...................................................... 57, 64
viewing schedule reports ....................................... 290
viewing system events ........................................... 101
viewing tenant reports ......................................... 76
viewing tenants ..................................................... 75
view Mid-Tier command control and administration service health.......................... 97
view Mid-Tier data services health ....................... 96
View Mid-Tier framework services health ............. 96
view Mid-Tier health related service health .......... 97
view overall system health .................................... 91, 92
views .................................................................... 353
View Set defined ................................................... 350

View Set (continued)
rename Monitor view set ...................................... 328
save as Monitor view set ........................................ 328
save current Monitor views ................................... 327
standard Monitor views ........................................ 326
view system status information on CPU usage .......... 98
view system status information on disk usage ........ 99
view system status information on memory usage ..... 99
view system status information on processes .......... 100
view the overall CPU usage .................................. 98
View toolbar ......................................................... 352
Virtual Agent ....................................................... 225, 239
virtual wait queue ................................................ 189

W

wait delay in seconds ........................................... 253
wait queue settings ............................................... 253
wait queues settings ............................................. 253
Weighted averages .............................................. 448
when to use Cruise Control ................................. 229
when to use Expert Calling Ratio ......................... 229
wildcard character value ....................................... 197
wildcard characters ............................................. 210
use to find one or more agent ............................... 397
wildcard expression ............................................. 197
window arrangement overview ............................. 421
wizard ................................................................. 183
add messages to dialer ........................................ 183
messages tasks .................................................... 184
script ................................................................. 192

Z

zip to time zone calling lists .................................. 33