© 2014-2019, Avaya Inc. All Rights Reserved.

Notice
While reasonable efforts have been made to ensure that the information in this document is complete and accurate at the time of printing, Avaya assumes no liability for any errors. Avaya reserves the right to make changes and corrections to the information in this document without the obligation to notify any person or organization of such changes.

Documentation disclaimer
"Documentation" means information published in varying mediums which may include product information, operating instructions and performance specifications that are generally made available to users of products. Documentation does not include marketing materials. Avaya shall not be responsible for any modifications, additions, or deletions to the original published version of Documentation unless such modifications, additions, or deletions were performed by or on the express behalf of Avaya. End User agrees to indemnify and hold harmless Avaya, Avaya's agents, servants and employees against all claims, lawsuits, demands and judgments arising out of, or in connection with, subsequent modifications, additions or deletions to this documentation, to the extent made by End User.

Link disclaimer
Avaya is not responsible for the contents or reliability of any linked websites referenced within this site or Documentation provided by Avaya. Avaya is not responsible for the accuracy of any information, statement or content provided on these sites and does not necessarily endorse or guarantee the products, services, or information described or offered within them. Avaya does not guarantee that these links will work all the time and has no control over the availability of the linked pages.

Warranty
Avaya provides a limited warranty on Avaya hardware and software. Refer to your sales agreement to establish the terms of the limited warranty. In addition, Avaya’s standard warranty language, as well as information regarding support for this product while under warranty is available to Avaya customers and other parties through the Avaya Support website, https://support.avaya.com/helpcenter/getGenericDetails?detailId=c320091126112456651010 under the link "Warranty & Product Lifecycle" or such successor site as designated by Avaya. Please note that if You acquired the product(s) from an authorized Avaya Channel Partner outside of the United States and Canada, the warranty is provided to You by said Avaya Channel Partner and not by Avaya.

"Hosted Service" means an Avaya hosted service subscription that You acquire from either Avaya or an authorized Avaya Channel Partner (as applicable) and which is described further in Hosted SAS or other service description documentation regarding the applicable hosted service. If You purchase a Hosted Service subscription, the foregoing limited warranty may not apply but You may be entitled to support services in connection with the Hosted Service as described further in your service description documents for the applicable Hosted Service. Contact Avaya or Avaya Channel Partner (as applicable) for more information.

Hosted Service
THE FOLLOWING APPLIES ONLY IF YOU PURCHASE AN AVAYA HOSTED SERVICE SUBSCRIPTION FROM AVAYA OR AN AVAYA CHANNEL PARTNER (AS APPlicable). THE TERMS OF USE FOR HOSTED SERVICES ARE AVAILABLE ON THE AVAYA WEBSITE, HTTPS://SUPPORT.AVAYA.COM/LICENSEINFO UNDER THE LINK "Avaya Terms of Use for Hosted Services" OR SUCH SUCCESSOR SITE AS DESIGNATED BY AVAYA, AND ARE APPLICABLE TO ANYONE WHO ACQUIRES OR USES THE HOSTED SERVICE. BY ACCESSING OR USING THE HOSTED SERVICE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF YOURSELF AND THE ENTITY FOR WHOM YOU ARE DOING SO (HEREINAFTER REFERRED TO INTERCHANGEABLY AS "YOU" AND "END USER"), AGREE TO THE TERMS OF USE. IF YOU ARE ACCEPTING THE TERMS OF USE ON BEHALF OF A COMPANY OR OTHER LEGAL ENTITY, YOU REPRESENT THAT YOU HAVE THE AUTHORITY TO BIND SUCH ENTITY TO THESE TERMS OF USE. IF YOU DO NOT HAVE SUCH AUTHORITY, OR IF

YOU DO NOT WISH TO ACCEPT THESE TERMS OF USE, YOU MUST NOT ACCESS OR USE THE HOSTED SERVICE OR AUTHORIZE ANYONE TO ACCESS OR USE THE HOSTED SERVICE.

Licenses
THE SOFTWARE LICENSE TERMS AVAILABLE ON THE AVAYA WEBSITE, HTTPS://SUPPORT.AVAYA.COM/LICENSEINFO, UNDER THE LINK "AVAYA SOFTWARE LICENSE TERMS (Avaya Products)" OR SUCH SUCCESSOR SITE AS DESIGNATED BY AVAYA, ARE APPLICABLE TO ANYONE WHO DOWNLOADS, USES AND/OR INSTALLS AVAYA SOFTWARE, PURCHASED FROM AVAYA INC., ANY AVAYA AFFILIATE, OR AN AVAYA CHANNEL PARTNER (AS APPLICABLE) UNDER A COMMERCIAL AGREEMENT WITH AVAYA OR AN AVAYA CHANNEL PARTNER. UNLESS OTHERWISE AGREED TO BY AVAYA IN WRITING, AVAYA DOES NOT EXTEND THIS LICENSE IF THE SOFTWARE WAS OBTAINED FROM ANYONE OTHER THAN AVAYA, AN AVAYA AFFILIATE OR AN AVAYA CHANNEL PARTNER. AVAYA RESERVES THE RIGHT TO TAKE LEGAL ACTION AGAINST YOU AND ANYONE ELSE USING OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY INSTALLING, DOWNLOADING OR USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF YOURSELF AND THE ENTITY FOR WHOM YOU ARE INSTALLING, DOWNLOADING OR USING THE SOFTWARE (HEREINAFTER REFERRED TO INTERCHANGEABLY AS "YOU" AND "END USER"), AGREE TO THESE TERMS AND CONDITIONS AND CREATE A BINDING CONTRACT BETWEEN YOU AND AVAYA. OR THE APPLICABLE AVAYA AFFILIATE ("AVAYA").

Avaya grants You a license within the scope of the license types described below, with the exclusion of Heritage Nortel Software, for which the scope of the license is detailed below. Where the order documentation does not expressly identify a license type, the applicable license will be a Designated System License as set forth below in the Designated System(s) License (DS) section as applicable. The applicable number of licenses and units of capacity for which the license is granted will be one (1), unless a different number of licenses or units of capacity is specified in the documentation or other materials available to You. "Software" means computer programs in object code, provided by Avaya or an Avaya Channel Partner, whether as stand-alone products, pre-installed on hardware products, and any upgrades, updates, patches, bug fixes, or modified versions thereto. "Designated Processor" means a single stand-alone computing device. "Server" means a set of Designated Processors that hosts (physically or virtually) a software application to be accessed by multiple users. "Instance" means a single copy of the Software executing at a particular time: (i) on one physical machine; or (ii) on one deployed software virtual machine ("VM") or similar deployment.

License types
Designated System(s) License (DS). End User may install and use each copy or an Instance of the Software only: 1) on a number of Designated Processors up to the number indicated in the order; or 2) up to the number of Instances of the Software as indicated in the order, Documentation, or as authorized by Avaya in writing. Avaya may require the Designated Processor(s) to be identified in the order by type, serial number, feature key, Instance, location or other specific designation, or to be provided by End User to Avaya through electronic means established by Avaya specifically for this purpose.

 Concurrent User License (CU). End User may install and use the Software on multiple Designated Processors or one or more Servers, so long as only the licensed number of Units are accessing and using the Software at any given time. A "Unit" means the unit on which Avaya, at its sole discretion, bases the pricing of its licenses and can be, without limitation, an agent, port or user, an e-mail or voice mail account in the name of a person or corporate function (e.g., webmaster or helpdesk), or an administrative database utilized by the Software that permits one user to interface with the Software. Units may be linked to a specific, identified Server or an Instance of the Software.

Named User License (NU). You may: (i) install and use each copy or Instance of the Software on a single Designated Process or Server per authorized Named User (defined below); or (ii) install and use each copy or Instance of the Software on a Server so long as only authorized Named Users access and use the Software. *Named
User”, means a user or device that has been expressly authorized by Avaya to access and use the Software. At Avaya’s sole discretion, a “Named User” may be, without limitation, designated by name, corporate function (e.g., webmaster or helpdesk), an e-mail or voice mail account in the name of a person or corporate function, or a directory entry in the administrative database utilized by the Software that permits one user to interface with the Software.

Shrinkwrap License (SR). You may install and use the Software in accordance with the terms and conditions of the applicable license agreements, such as “shrinkwrap” or “clickthrough” license accompanying or applicable to the Software (“Shrinkwrap License”).

Heritage Nortel Software

“Heritage Nortel Software” means the software that was acquired by Avaya as part of its purchase of the Nortel Enterprise Solutions Business in December 2009. The Heritage Nortel Software is the software contained within the list of Heritage Nortel Products located at https://support.avaya.com/Licensinfo under the link “Heritage Nortel Products” or such successor site as designated by Avaya. For Heritage Nortel Software, Avaya grants Customer a license to use Heritage Nortel Software provided hereunder solely to the extent of the authorized activation or authorized usage level, solely for the purpose specified in the Documentation, and solely as embedded in, for execution on, or for communication with Avaya equipment. Charges for Heritage Nortel Software may be based on extent of activation or use authorized as specified in an order or invoice.

Copyright

Except where expressly stated otherwise, no use should be made of materials on this site, the Documentation, Software, Hosted Service, or hardware provided by Avaya. All content on this site, the documentation, Hosted Service, and the product provided by Avaya including the selection, arrangement and design of the content is owned either by Avaya or its licensors and is protected by copyright and other intellectual property laws including the sui generis rights relating to the protection of databases. You may not modify, copy, reproduce, republish, upload, post, transmit or distribute in any way any content, in whole or in part, including any code and software unless expressly authorized by Avaya. Unauthorized reproduction, transmission, dissemination, storage, and or use without the express written consent of Avaya can be a criminal, as well as a civil offense under the applicable law.

Virtualization

The following applies if the product is deployed on a virtual machine. Each product has its own ordering code and license types. Unless otherwise stated, each Instance of a product must be separately licensed and ordered. For example, if the end user customer or Avaya Channel Partner would like to install two instances of the same type of products, then two products of that type must be ordered.

Third Party Components

“Third Party Components” mean certain software programs or portions thereof included in the Software or Hosted Service may contain software (including open source software) distributed under third party agreements (“Third Party Components”), which contain terms regarding the rights to use certain portions of the Software (“Third Party Terms”). As required, information regarding distributed Linux OS source code (for those products that have distributed Linux OS source code) and identifying the copyright holders of the Third Party Components and the Third Party Terms that apply is available in the products, Documentation or on Avaya’s website at: https://support.avaya.com/Copyright or such successor site as designated by Avaya. The open source software license terms provided as Third Party Terms are consistent with the license rights granted in these Software License Terms, and may contain additional rights benefiting You, such as modification and distribution of the open source software. The Third Party Terms shall take precedence over these Software License Terms, solely with respect to the applicable Third Party Components to the extent that these Software License Terms impose greater restrictions on You than the applicable Third Party Terms. The following applies only if the H.264 (AVC) codec is distributed with the contract. THIS PRODUCT IS LICENSED UNDER THE AVC PATENT PORTFOLIO LICENSE FOR THE PERSONAL USE OF A CONSUMER OR OTHER USES IN WHICH IT DOES NOT RECEIVE REMUNERATION TO (i) ENCODE VIDEO IN COMPLIANCE WITH THE AVC STANDARD (“AVC VIDEO”) AND/OR (ii) DECODE AVC VIDEO THAT WAS ENCODED BY A CONSUMER ENGAGED IN A PERSONAL ACTIVITY AND OR WAS OBTAINED FROM A VIDEO PROVIDER LICENSED TO PROVIDE AVC VIDEO. NO LICENSE IS GRANTED OR SHALL BE IMPLIED FOR ANY OTHER USE. ADDITIONAL INFORMATION MAY BE OBTAINED FROM MPEG LA, L.L.C. SEE HTTP://WWW.MPEGLA.COM.

Service Provider

THE FOLLOWING APPLIES TO AVAYA CHANNEL PARTNER’S HOSTING OF AVAYA PRODUCTS OR SERVICES. THE PRODUCT OR HOSTED SERVICE MAY USE THIRD PARTY COMPONENTS SUBJECT TO THIRD PARTY TERMS AND REQUIRE A SERVICE PROVIDER TO BE INDEPENDENTLY LICENSED DIRECTLY FROM THE THIRD PARTY SUPPLIER. AN AVAYA CHANNEL PARTNER’S HOSTING OF AVAYA PRODUCTS MUST BE AUTHORIZED IN WRITING BY AVAYA AND IF THOSE HOSTED PRODUCTS USE OR EMBED CERTAIN THIRD PARTY SOFTWARE, INCLUDING BUT NOT LIMITED TO MICROSOFT SOFTWARE OR CODECS, THE AVAYA CHANNEL PARTNER IS REQUIRED TO INDEPENDENTLY OBTAIN ANY APPLICABLE LICENSE AGREEMENTS, AT THE AVAYA CHANNEL PARTNER’S EXPENSE, DIRECTLY FROM THE APPLICABLE THIRD PARTY SUPPLIER.

WITH RESPECT TO CODECS, IF THE AVAYA CHANNEL PARTNER IS HOSTING ANY PRODUCTS THAT USE OR EMBED THE H.264 CODEC OR H.265 CODEC, THE AVAYA CHANNEL PARTNER ACKNOWLEDGES AND AGREES THE AVAYA CHANNEL PARTNER IS RESPONSIBLE FOR ANY AND ALL RELATED FEES AND/OR ROYALTIES. THE H.264 (AVC) CODEC IS LICENSED UNDER THE AVC PATENT PORTFOLIO LICENSE FOR THE PERSONAL USE OF A CONSUMER OR OTHER USES IN WHICH IT DOES NOT RECEIVE REMUNERATION TO: (i) ENCODE VIDEO IN COMPLIANCE WITH THE AVC STANDARD (“AVC VIDEO”) AND/OR (ii) DECODE AVC VIDEO THAT WAS ENCODED BY A CONSUMER ENGAGED IN A PERSONAL ACTIVITY AND OR WAS OBTAINED FROM A VIDEO PROVIDER LICENSED TO PROVIDE AVC VIDEO. NO LICENSE IS GRANTED OR SHALL BE IMPLIED FOR ANY OTHER USE. ADDITIONAL INFORMATION FOR H.264 (AVC) AND H.265 (HEVC) CODECS MAY BE OBTAINED FROM MPEG LA, L.L.C. SEE HTTP://WWW.MPEGLA.COM.

Compliance with Laws

You acknowledge and agree that it is Your responsibility for complying with any applicable laws and regulations, including, but not limited to laws and regulations related to calling recording, data privacy, intellectual property, trade secret, fraud, and music performance rights, in the country or territory where the Avaya product is used.

Preventing Toll Fraud

“Toll Fraud” is the unauthorized use of your telecommunications system by an unauthorized party (for example, a person who is not a corporate employee, agent, subcontractor, or is not working on your company’s behalf). Be aware that there can be a risk of Toll Fraud associated with your system and that, if Toll Fraud occurs, it can result in substantial additional charges for your telecommunications services.

Avaya Toll Fraud intervention

If you suspect that you are being victimized by Toll Fraud and you need technical assistance or support, call Technical Service Center Toll Fraud Intervention Hotline at +1-800-643-2353 for the United States and Canada. For additional support telephone numbers, see the Avaya Support website: https://support.avaya.com or such successor site as designated by Avaya.

Security Vulnerabilities

Information about Avaya’s security support policies can be found in the Security Policies and Support section of https://support.avaya.com/security.

Suspected Avaya product security vulnerabilities are handled per the Avaya Product Security Support Flow (https://support.avaya.com/css/P7/documents/100161515).
Downloading Documentation

For the most current versions of Documentation, see the Avaya Support website: https://support.avaya.com, or such successor site as designated by Avaya.

Contact Avaya Support

See the Avaya Support website: https://support.avaya.com for product or Hosted Service notices and articles, or to report a problem with your Avaya product or Hosted Service. For a list of support telephone numbers and contact addresses, go to the Avaya Support website: https://support.avaya.com (or such successor site as designated by Avaya), scroll to the bottom of the page, and select Contact Avaya Support.

Trademarks

The trademarks, logos and service marks (“Marks”) displayed in this site, the Documentation, Hosted Service(s), and product(s) provided by Avaya are the registered or unregistered Marks of Avaya, its affiliates, its licensors, its suppliers, or other third parties. Users are not permitted to use such Marks without prior written consent from Avaya or such third party which may own the Mark. Nothing contained in this site, the Documentation, Hosted Service(s) and product(s) should be construed as granting, by implication, estoppel, or otherwise, any license or right in and to the Marks without the express written permission of Avaya or the applicable third party.

Avaya is a registered trademark of Avaya Inc.

All non-Avaya trademarks are the property of their respective owners. Linux® is the registered trademark of Linus Torvalds in the U.S. and other countries.
# Contents

## Chapter 1: Introduction
- Purpose............................................................................................................ 7
- New in this release............................................................................................ 7
- Change history................................................................................................. 7
- Warranty........................................................................................................... 8
- Viewing the Eclipse documentation............................................................... 8
- Viewing the Orchestration Designer documentation........................................ 8
- Documentation for related products and technologies...................................... 8

## Chapter 2: Installation and configuration
- Overview......................................................................................................... 11
- Features and benefits....................................................................................... 12
- System requirements....................................................................................... 13
  - License requirements.................................................................................... 13
  - Hardware requirements................................................................................. 14
  - Software requirements............................................................................... 14
- WebLM license server installation and configuration....................................... 18
- Installing Orchestration Designer manually................................................. 18
- Installing Orchestration Designer using a pre-packaged installation.............. 21
- Viewing the version number of an installed Orchestration Designer software... 21
- Basic configuration.......................................................................................... 22
  - Creating an Eclipse shortcut...................................................................... 22
  - Configuring the workspace......................................................................... 22
- Settings configuration...................................................................................... 23
  - Configuring the default perspective............................................................ 23
  - Configuring Tomcat Preferences................................................................ 23
- Orchestration Designer preferences management........................................... 24
  - Considerations for enabling an HTTP or HTTPS proxy connection............ 24
  - Enabling an HTTP or HTTPS proxy connection......................................... 25
  - Configuring a run-time license server........................................................ 25
  - Removing the context files on closing a project......................................... 26
  - Configuring Secure Fetch Port.................................................................... 27
  - Orchestration Designer preferences field descriptions............................... 27
- Verifying the Java JRE...................................................................................... 30
- Setting the Java JDK compiler compliance level............................................ 30
- Configuring Microsoft Speech API for microphone inputs.......................... 31
- Installing sample applications....................................................................... 31
- Orchestration Designer Upgrade..................................................................... 32
  - Maintaining the 7.1 environment while installing 7.2.3............................. 32
  - Maintaining the 7.2.0, 7.2.1 or 7.2.2 environment while installing 7.2.3...... 33
  - Recommended installation paths for multiple Orchestration Designer and Eclipse versions... 34
Chapter 1: Introduction

Purpose

This document describes the methods and the system requirements used to create speech applications that comply with VoiceXML version 2.1, call control applications that comply with CCXML specification and, message applications that comply with TextXML, and mobile applications that comply with the HTML5 specification.

Intended audience

This document is intended for anyone who wants to gain a high-level understanding of the product features, functionality, capacities, and limitations within the context of solutions and verified reference configurations.

New in this release

The following changes are introduced for Orchestration Designer 7.2.3:

- Updated the system requirements to support Orchestration Designer 7.2.3.
- Updated the procedure to install Orchestration Designer 7.2.3.
- Updated the procedure to upgrade Orchestration Designer 7.2.3.

Change history

The following changes are part of this issue:

<table>
<thead>
<tr>
<th>Issue</th>
<th>Date</th>
<th>Summary of changes</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.1</td>
<td>September 2019</td>
<td>Added a note to the Software requirements table on the latest version of Orchestration Designer to support only 64 bit Eclipse.</td>
</tr>
</tbody>
</table>
Warranty

Avaya Inc. provides a 90-day limited warranty on Orchestration Designer. Refer to your sales agreement or other applicable documentation to establish the terms of the limited warranty. In addition, Avaya’s standard warranty language as well as details regarding support for Orchestration Designer, while under warranty, is available on the support website at http://www.avaya.com/support.

Viewing the Eclipse documentation

About this task

The documentation for Eclipse and supporting Eclipse components (GEF and WTP) is available at http://www.eclipse.org/documentation/, and in the form of an online Help.

• On the Eclipse user interface, click Help > Help Contents.
  The Eclipse user interface displays the Eclipse documentation.

Viewing the Orchestration Designer documentation

About this task

The Getting Started with Avaya Aura® Orchestration Designer guide is available on the Orchestration Designer installation ISO image.

You can view the Orchestration Designer documentation on the Avaya support website: http://support.avaya.com

The Orchestration Designer documentation is also available in the form of an online Help.

• On the Eclipse user interface, click Help > Help Contents > Avaya Aura® Orchestration Designer - Self Service.

Documentation for related products and technologies

Orchestration Designer depends on the use of several closely related software products and technologies. When using Orchestration Designer, review the documentation of these related products and technologies.

Avaya does not reproduce or package the documentation for these related products and technologies. However, to help locate the appropriate documentation, review the following resources:
Note:
The following URLs were valid at the time of publication of this document. Avaya is not responsible if these URLs have changed. For more updated URLs, perform a search operation online.

• For Eclipse and supporting Eclipse components (GEF and WTP), go to:
  http://www.eclipse.org/documentation/
  For more information, see Viewing the Eclipse documentation on page 8.

• For the Java SDK (Software Developer’s Kit), go to:
  http://docs.oracle.com/javase/8/docs/index.html
  http://docs.oracle.com/javase/9/docs/index.html

• For Tomcat 7.0, 8.0, 8.5, or 9.0 go to:
  http://tomcat.apache.org/tomcat-8.5-doc/index.html

• For IBM WebSphere or WebSphere Express, go to:
  http://www.ibm.com/websphere

• For WebLogic, go to:

• For Redhat JBoss EAP, go to:
  https://developers.redhat.com/products/eap/overview/

• For JBoss Wildfly, go to:
  http://wildfly.org/

• For databases and JDBC implementation, go to:
  http://www.sql.org/
  http://www.firstsql.com/tutor.htm

• For Web services, go to:
  http://www.w3.org/TR/wsd1
  http://www.ws-i.org/Profiles/BasicProfile-1.1-2004-08-24.html

• For the W3C VoiceXML 2.0 Recommendation, go to:
  http://www.w3.org/TR/voicexml20/

• For the W3C VoiceXML 2.1 Recommendation, go to:
  http://www.w3.org/TR/voicexml21/
Introduction

• For the W3C CCXML 1.0 Recommendation (January 19, 2007), go to:
  http://www.w3.org/TR/ccxml/

• For the Speech Recognition Grammar Specification version 1.0, go to:
  http://www.w3.org/TR/speech-grammar/#AppJ.5
Chapter 2: Installation and configuration

Overview

Avaya Aura® Orchestration Designer is a Java-based tool that you can use to create the following:

- Speech applications that comply with VoiceXML version 2.1.
- Call control applications that comply with specifications of CCXML version 1.0, January 19, 2007.
- Message applications that comply with TextXML.

The tool is designed as an Eclipse plug-in, which provides an integrated GUI for the design and implementation of the following:

- Speech applications that can operate with Interactive Response, Voice Portal, Media Processing Server, and Avaya Aura® Experience Portal systems
- Message applications that can operate with the Avaya Aura® Experience Portal system
- Data only applications that can operate with the Avaya Aura® Experience Portal system
- HTML5 applications that can operate with the Avaya Aura® Experience Portal system

Orchestration Designer is also a suite of self-service products and Avaya Contact Center products, namely, Avaya Aura® Experience Portal, Avaya Interactive Response (IR), Media Processing Server (MPS), and Avaya Aura® Contact Center. As a single tool, you can use Orchestration Designer to design, simulate, and maintain the contact routing scripts with inbound and outbound self-service support. It accelerates service design and deployment, reduces cost, and enhances customer experience.

Orchestration Designer integrates seamlessly with Avaya Breeze® platform. With this integration, the Orchestration Designer application can interact with the Engagement Designer workflows and pass the collected data in several ways:

- Orchestration Designer can start a workflow and pass collected data to that workflow by using Context Store. The workflow receives data from Orchestration Designer to process the information and complete the transaction.
- Orchestration Designer supports integration of Orchestration Designer SMS and Email applications with Engagement Designer workflow. With this integration, the Orchestration Designer application receives data from Engagement Designer workflow, interacts using one more text messages, and returns the data to the Engagement Designer workflow.
- An Engagement Designer workflow can initiate a new call to the customer and plug Orchestration Designer into the call to provide IVR services.
An Engagement Designer workflow can also plug Orchestration Designer into an existing call.

Orchestration Designer works with the widely accepted Eclipse.org development framework. It provides a drag-and-drop environment for development and maintenance of speech, touchtone, and message applications.

**Multi-Channel Self Service**

With the Multi-Channel Self Service (MCSS), you can extend the current Experience Portal or Orchestration Designer product capabilities to include channels other than inbound voice, telephony.

Key capabilities of MCSS include:

- Application processing of inbound SMS and Email.
- Send response to an inbound SMS and email.
- Send outbound SMS and email from cross channel applications.
  For example, a speech application sending an SMS or email confirmation.
- New application type **Web** in Orchestration Designer.
- Application design palettes specific to a channel.
- Generic message flow with custom XML generation for social media and other channels.
- Transfer items to AACC agent for handling with reply using SMS and email.
- Web channel to collect information through HTML5 pages.

Inbound processing of SMS and email adds text channels to Experience Portal. You can build Orchestration Designer applications to process and respond to incoming SMS and email. With the outbound SMS and email, the application on a given channel can provide additional feedback to the user through another channel.

For example, a speech application sends confirmation of a transaction to the user by SMS or email. Items that cannot be handled in Self Service can be transferred to an AACC agent by using a connector.

---

**Features and benefits**

Avaya Orchestration Designer provides the following benefits:

- Simplifies development, integration, and reusability of speech and touchtone applications.
- Significantly reduces time and cost of application prototyping and design.
- Provides unprecedented coverage of customer self-service, employee-facing productivity, and advanced call control application areas.
- Ensures consistent and more reliable deployment of voice supporting services and applications.
Maximizes the use of tooling investments for more rapid deployment of web-based voice applications through an open Eclipse based framework.

Integrates with Avaya Breeze® platform and Avaya Context Store Snap-in providing a centralized location to store context information.

Provides the capability to integrate Orchestration Designer voice, SMS, and email applications with Engagement Designer and receive and send data to the Engagement Designer workflow.

Supports mobile application with HTML5.

Provides two-way integration with Avaya Breeze® platform and Avaya Engagement Designer.

Provides multi-channel support.

Starting with the JTAPI 3.1 driver, the OD CTI (AES) connector can use the Universal Call ID (UCID) to keep track of call IDs. To use this feature, you must enable OD CTI (AES) connector on your switch. This feature is optional, but you can use it to prevent recycling of the call IDs during high call volumes.

System requirements

License requirements

You need a valid license to run Avaya Aura Orchestration Designer applications on the following and other supported VXML platforms:

- Avaya Aura® Experience Portal
- Avaya Voice Portal
- Avaya Interactive Response (IR)
- Avaya Media Processing Server (MPS)

The Orchestration Designer licenses are free, and you can get them from an Avaya sales representative or the channel manager. Avaya partners can log on to Partner Portal to find information about ordering additional licenses.

If you run the Orchestration Designer applications on Voice Portal, Avaya Aura® Experience Portal, IR, or other Avaya products that use the WebLM license server, then Orchestration Designer does not require a separate WebLM license server. You must install the Orchestration Designer license on the existing WebLM license server that is installed with Voice Portal, Avaya Aura® Experience Portal, IR, or other Avaya products that use the WebLM license server.

If you run the Orchestration Designer applications on MPS, then you must install the WebLM license server and configure the license information of Orchestration Designer. You must install a separate WebLM license server because the system does not install the WebLM license server during the MPS installation.
You must have a valid license for Context Store and Avaya Breeze® platform. For more information, see Avaya Context Store Snap-in Reference.

Orchestration Designer license has a grace period of 30 days. If the WebLM license server is unavailable after Orchestration Designer obtains the license from the WebLM license server, Orchestration Designer is available for use for 30 days.

You do not require a license to install or run the Eclipse-based Orchestration Designer development and the simulation environment.

Related links
WebLM license server installation and configuration on page 18

### Hardware requirements

The system that hosts the Avaya Orchestration Designer development environment must meet the following hardware requirements:

<table>
<thead>
<tr>
<th>Hardware</th>
<th>Minimum requirement</th>
<th>Preferred value</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPU speed</td>
<td>1 GHz</td>
<td>2 GHz</td>
</tr>
<tr>
<td>RAM</td>
<td>1 GB</td>
<td>2 GB</td>
</tr>
<tr>
<td>Hard disk drive</td>
<td>40 GB</td>
<td>—</td>
</tr>
<tr>
<td>Monitor resolution</td>
<td>1024 x 768 pixels</td>
<td>—</td>
</tr>
</tbody>
</table>

### Software requirements

You must install the software required to host Avaya Orchestration Designer development environment before installing and configuring Orchestration Designer.

<table>
<thead>
<tr>
<th>Software requirements</th>
<th>On ISO image</th>
<th>Notes and links</th>
</tr>
</thead>
<tbody>
<tr>
<td>Install one of the following operating systems:</td>
<td>No</td>
<td>You can install Orchestration Designer on any of these operating systems if you meet all hardware requirements and install all the supporting software packages. For the development environment, Orchestration Designer supports Windows 7, 32 bit and 64 bit. Note: From Release 7.2.3 onwards, Orchestration Designer no longer provides the 32-bit Eclipse version. However, the older Eclipse versions, 4.8 and 4.7, which customers already possess, will continue to work.</td>
</tr>
<tr>
<td>• Microsoft Windows 7 (Professional and Enterprise versions)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Microsoft Windows 10</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Table continues…
## Software requirements

<table>
<thead>
<tr>
<th>Software requirements</th>
<th>On ISO image</th>
<th>Notes and links</th>
</tr>
</thead>
<tbody>
<tr>
<td>Install one of the following browsers:</td>
<td></td>
<td>You must install Google Chrome 57, Microsoft Internet Explorer 11, or Mozilla Firefox 43 for simulation of HTML5 application.</td>
</tr>
<tr>
<td>• Google Chrome 57</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>• Mozilla Firefox 43</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Microsoft Internet Explorer 11</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• J2SE Development Kit 7.0 (JDK 7.0)</td>
<td>No</td>
<td>The JDK includes Java Run-Time Environment (JRE) and command-line tools, compilers, and debuggers used in developing applets and applications. Java 7 supports SHA2 certificates. Orchestration Designer 7.2.1 requires Java version 7 or later and is not backward compatible with earlier versions. It supports OpenJDK and the following versions of Oracle JDK:</td>
</tr>
<tr>
<td>• J2SE Development Kit 8.0 (JDK 8.0)</td>
<td></td>
<td>• JDK 7</td>
</tr>
<tr>
<td>• J2SE Development Kit 9.0 (JDK 9.0)</td>
<td></td>
<td>• JDK 8</td>
</tr>
<tr>
<td>• J2SE 1.10 (OpenJDK 1.10)</td>
<td></td>
<td>• JDK 9</td>
</tr>
<tr>
<td>• Open JDK 11</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Open JDK 12</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Install one of the following Eclipse versions:</td>
<td>Yes</td>
<td>Eclipse is a Java-based open-source integrated development environment (IDE) for software development. Orchestration Designer:</td>
</tr>
<tr>
<td>• Eclipse-4.5-Prereq-AAOD.zip (Mars)</td>
<td></td>
<td>• Runs as an Eclipse plug-in</td>
</tr>
<tr>
<td>• Eclipse-4.6-Prereq-AAOD.zip (Neon)</td>
<td></td>
<td>• Uses the Eclipse Graphical Editing Framework plug-ins for Eclipse (GEF) for advanced graphical functions.</td>
</tr>
<tr>
<td>• Eclipse-4.7-Prereq-AAOD.zip (Oxygen)</td>
<td></td>
<td>• Includes the support files for Call Control (CCXML) development.</td>
</tr>
<tr>
<td>• Eclipse-4.8-Prereq-AAOD.zip (Photon)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Eclipse-4.11-Prereq-AAOD.zip</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Install one of the following Tomcat versions:</td>
<td>Yes</td>
<td>Tomcat generates and serves VoiceXML pages to the Avaya Application Simulator.</td>
</tr>
<tr>
<td>• Apache Tomcat 7.0</td>
<td></td>
<td>• You must have administrative privileges when running Tomcat.</td>
</tr>
<tr>
<td>• Apache Tomcat 8.0</td>
<td></td>
<td>• If you upgrade to Tomcat 8.x version and your applications have manually configured build paths or resources in common/lib or common/classes, then manually update the build path and point to <code>&lt;tomcat_installpath&gt;/lib</code>. You must also place any resources such as libraries, in this folder.</td>
</tr>
<tr>
<td>• Apache Tomcat 8.5</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Apache Tomcat 9.0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Software requirements</td>
<td>On ISO image</td>
<td>Notes and links</td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>--------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Avaya Breeze® platform 3.3</td>
<td>No</td>
<td>Avaya Breeze® platform provides a virtualized and secure application platform where Java programmers can develop and dynamically deploy advanced collaboration capabilities. For more information on installing Avaya Breeze® platform, see Deploying Avaya Breeze® platform.</td>
</tr>
<tr>
<td>Avaya Engagement Designer 3.3</td>
<td>No</td>
<td>Avaya Engagement Designer offers business analysts, non-technical resources, and developers the opportunity to write logical business process flows. These process flows can leverage any Avaya Breeze® platform snap-in that have an associated palette of tasks. For more information about Avaya Engagement Designer, see Avaya Engagement Designer Reference.</td>
</tr>
<tr>
<td>Experience Portal snap-in tasks:</td>
<td>No</td>
<td>Experience Portal snap-in tasks start Orchestration Designer SMS and email application. For more information about Experience Portal snap-in tasks, see Experience Portal Tasks.</td>
</tr>
<tr>
<td>• Launch SMS Service</td>
<td>No</td>
<td>Avaya Context Store provides flexible and easy integration among different applications, providing a centralized solution to store context information. For more information about installing Avaya Context Store, see Avaya Context Store Snap-in Reference.</td>
</tr>
<tr>
<td>• Launch Email Service</td>
<td>No</td>
<td>Orchestration Designer uses Microsoft SAPI Speech during application testing to perform automated speech recognition (ASR) and text-to-speech (TTS) functions. Note: Microsoft Windows 7 already has Microsoft Speech components installed. If Microsoft SAPI Speech is installed on Windows 7, go to Control Panel &gt; Speech Recognition &gt; Text-to-Speech to verify that the Speech Recognition and Text-to-Speech tabs are available.</td>
</tr>
<tr>
<td>Avaya Context Store Snap-in 3.3</td>
<td>No</td>
<td>You must install Storm Codec 7.01.19 only if you need Third Generation Partnership (3GP) video files for media. To open the Storm Codec installer, see the installation notes available on the ISO image.</td>
</tr>
<tr>
<td>Microsoft SAPI Speech 6.0</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>Storm Codec 7.01.19</td>
<td>Yes</td>
<td></td>
</tr>
</tbody>
</table>
### Software requirements

<table>
<thead>
<tr>
<th>Software</th>
<th>On ISO image</th>
<th>Notes and links</th>
</tr>
</thead>
</table>
| Ambulant player 2.1        | No           | Orchestration Designer uses Ambulant player 2.1 for playing and previewing media files.  
|                            |              | In Ambulant player 2.1, do not use all menu, toolbar, and controls.             |
| Nuance Recognizer 9/10     | No           | You must acquire Nuance Recognizer directly from the vendor.                   |
| (MRCPv1)                   |              |                                                                                 |
| Loquendo Speech Server 7   | No           | You must acquire Loquendo Speech Server directly from the vendor.              |
| MRCPv1 Server 7.2 or higher|              |                                                                                 |

Open the ISO image and use the displayed HTML index page to navigate to the required resources because specific locations on the ISO image are described here. By following these instructions, installation is smoother because the online navigation documentation leads you to the correct installation path. You must follow these instructions to use the ISO image and install the software package efficiently.

### General upgrades

<table>
<thead>
<tr>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.2.1 Before upgrading your application server, you must back up the</td>
</tr>
<tr>
<td>tsapi.pro, ddconfig.xml, trusted_weblm_certs.jksfile files. You can</td>
</tr>
<tr>
<td>then restore the files if they are overwritten by the upgrade.</td>
</tr>
<tr>
<td>3.2.2 The Orchestration Designer upgrade process does not change any</td>
</tr>
<tr>
<td>custom code. The application developer must manually resolve the</td>
</tr>
<tr>
<td>errors or warnings that occur from version upgrade, such as variable</td>
</tr>
<tr>
<td>name changes, that affect the custom code.</td>
</tr>
<tr>
<td>3.2.3 If you have an existing installation in which you have updated</td>
</tr>
<tr>
<td>the certificate trusted_weblm_certs.jks file, then you must save a</td>
</tr>
<tr>
<td>copy of the file while reinstalling the runtime support files.</td>
</tr>
<tr>
<td>3.2.4 While upgrading applications from Windows XP to Windows 7, the</td>
</tr>
<tr>
<td>call flow visual representation can experience some issues because of</td>
</tr>
<tr>
<td>the difference in the graphics layer between the Windows releases.</td>
</tr>
<tr>
<td>Some corrections are required.</td>
</tr>
<tr>
<td>3.2.5 Framework updates occur that can result in Java compilation</td>
</tr>
<tr>
<td>errors after upgrading. To correct this, regenerate projects</td>
</tr>
<tr>
<td>reporting errors.</td>
</tr>
<tr>
<td>3.2.6 After upgrading, you must ensure that there are no older versions of jar files on the application server. Some examples of jar files are: commons-httpclient-3.1.jar commons-logging-1.1.1.jar log4j-1.2.15.jar wss4j-1.5.8.jar scertcommon-07.01.08.04.jar scertcommon-07.01.07.01.jar</td>
</tr>
</tbody>
</table>
WebLM license server installation and configuration

If you run the Avaya Orchestration Designer applications on MPS, then you must install the WebLM license server and configure the license information of Orchestration Designer. You must install a separate WebLM license server because the system does not install the WebLM license server during the MPS installation.

Use the WebLM.war file that is available on the Orchestration Designer 7.2.3 installation ISO image to install the WebLM license server software.

For WebLM 6.3.11 and later, the WebLM server accepts requests only over TLS 1.0 and later. If the product application is configured to send requests on SSLv2 or SSLv3, then the communication between the product application fails. So, if the product application upgrades WebLM to 6.3.11 and later, then ensure that the product application is configured to send requests only over TLS 1.0 and later.

For information about installing and configuring the WebLM license server software, see Licensing Installation Instructions for WebLM and Licensing Release Notes for WebLM.

The WebLM.war file, Licensing Installation Instructions for WebLM guide, and Licensing Release Notes for WebLM are available on the Orchestration Designer 7.2.3 installation ISO image at:

<absolute path of ISO image>:\Software\WebLM\

Related links

License requirements on page 13

Installing Orchestration Designer manually

About this task

Use this procedure to install new Orchestration Designer software only. The Orchestration Designer installation ISO image contains the Orchestration Designer distribution executable. Before running the executable, ensure that you meet all system requirements, as mentioned in System requirements.

Important:

The procedure described in this section is for new installation of the Orchestration Designer software. To upgrade Orchestration Designer, see Orchestration Designer Upgrade.

• Disable the antivirus software and close any open or running applications. The antivirus software can slow down the installation process.

• Extract Java-related files from a compressed archive to install Orchestration Designer.

Procedure

1. Copy the Orchestration Designer installation ISO image to the local drive.

2. Download and install the Open or Oracle JDK installer.
For Oracle JDK 7, see http://www.oracle.com/technetwork/java/javase/downloads/java-archive-downloads-javase7-521261.html.

For Oracle JDK 8, see http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html.

For Oracle JDK 9, see http://www.oracle.com/technetwork/java/javase/downloads/jdk9-downloads-3848520.html.

3. Install Eclipse along with the prerequisite features. Do the following:
   a. Locate the package file on the Orchestration Designer 7.2.3 ISO image, which is in the following directory: `<absolute path of ISO image>:\Software\Eclipse`
   
   b. Extract the .zip file to an installation folder.
   
   c. (Optional) Create a shortcut for the Eclipse executable. Eclipse starts the Orchestration Designer software.

4. Install Orchestration Designer software. Do the following:
   a. Locate the AAOD_7.2.3.XXX.jar installation archive on the Orchestration Designer 7.2.3 ISO image and copy to a temporary location.

      The installation archive is located in the `<absolute path of ISO image>:\UpdateSites\` directory.

   b. On the Eclipse user interface, click Help > Install New Software.

   c. On the Available software page, click Add.

   d. On the Add Repository page, enter a name and click Archive to specify the location of the AAOD_7.2.3.XXX.jar file.

   e. Click OK.

   f. Click Select All.

   g. On the Available software page, clear the Contact all update site sites during install to find the required software check box and then click Next.

   h. On the Install Details page, click Next.

      The Eclipse user interface displays Avaya Software License Agreement.

   i. Review the license agreement and then click I accept the term of the license agreement.

   j. Click Finish.

   k. When prompted to trust the certificates, click Select All.

   l. Click OK.

   m. Click Restart Now to restart Eclipse.
5. Install Tomcat. Do the following:
   a. Locate the Tomcat distribution package on the Orchestration Designer 7.2.3 ISO image, which is located in the <absolute path of ISO image>:\Software\Tomcat\ directory.
   b. Extract the .zip file to a temporary folder.
   c. Review the RUNNING.txt file for more installation instructions.

   ! Important:
   Do not install Tomcat as an NT service. Orchestration Designer does not support this configuration because Tomcat does not start and stop appropriately while developing applications.

6. *(Optional)* Install Microsoft Speech API 6.0:
   a. Copy the Orchestration Designer 7.2.3 installation ISO image to the local drive.
   b. Go to <absolute path of ISO image> > Software > MSSpeech.
   c. Double-click the Setup.exe file.
      The system displays the Microsoft SAPI Speech wizard.
   d. In the Welcome dialog box, click Next.
   e. Accept the license terms and then click Next.
   f. In the Customer Information dialog box, type a user name and the organization name.
   g. Click Next.
   h. When prompted, select the default installation folder, or navigate to another, if applicable.
   i. Click Next.
   j. Click Install to begin the Microsoft SAPI Speech installation.
   k. Click Finish when the installation is complete.

7. *(Optional)* Install the Storm Codec 7.01.19. See Installation Notes on the ISO image.

Next steps
- After you complete the installation procedure, read the Eclipse “readme” file located in the /readme subdirectory where Eclipse is installed. The Eclipse readme file includes information and tips for configuring Eclipse.
- Before you use Orchestration Designer, you must configure the basic settings. For information, see Basic Configuration.
Installing Orchestration Designer using a pre-packaged installation

About this task
The Orchestration Designer ISO image contains a pre-packaged Orchestration Designer installation that contains both the Self Service and Contact Center features, and Tomcat installation.

Install the Java Development Kit.

Procedure

1. Copy the Orchestration Designer installation ISO image to the local drive and navigate to the root folder of the ISO image.
2. Copy the AAOD7.2.3 folder to C:\ directory.
3. In the AAOD7.2.3\eclipse folder, double-click eclipse.exe file to install and open Orchestration Designer.

Tip:
To access the Orchestration Designer, you can create a shortcut to eclipse.exe and place the shortcut in a convenient location.

4. Open Orchestration Designer and configure the preferences for the location of the Tomcat installation:
   a. On the Eclipse user interface, click Window > Preferences > Tomcat.
   b. In the Tomcat section, in the Tomcat home field, click Browse and select the location for Tomcat installation.

      For example, if you copied the AAOD7.2.3 folder to your C:\ drive, then the Tomcat home value is C:\AAOD7.2.3\apache-tomcat-7.0.55.

Viewing the version number of an installed Orchestration Designer software

Procedure

1. On the Eclipse user interface, click Help > About Eclipse SDK.
2. In the About Eclipse SDK dialog box, click Installation Details.
   The Eclipse user interface displays the Eclipse SDK Installation Details dialog box, which contains the installation and configuration details.
Basic configuration

Before you start creating Orchestration Designer projects, you must perform some basic configurations to ensure that the environment is configured and ready to use.

Creating an Eclipse shortcut

About this task

After installing all components, you can start Eclipse to access the Orchestration Designer. For easy access to Eclipse, you can create a shortcut of the `eclipse.exe` file on your Windows desktop. The `eclipse.exe` file is located in the folder where Eclipse is installed.

Procedure

1. Right-click the `eclipse.exe` file, and then click **Send To > Desktop (create shortcut)**.
2. Double-click the shortcut file to start Orchestration Designer.
   
   Eclipse displays the Workspace Launcher dialog box.

Configuring the workspace

About this task

When you start Orchestration Designer for the first time, the Eclipse Workspace Launcher dialog box prompts you to specify a workspace location. Specify a directory where you want to save all Orchestration Designer project files.

⚠️ **Important:**

If you are configuring a new version of Orchestration Designer, back up all files in the original installation directory before configuring a new directory.

Procedure

1. Double-click the shortcut of the `eclipse.exe` file.
2. In the Workspace Launcher dialog box, click **Browse** and select a location.
   
   The default directory is relative to the installation path of Eclipse. For example, `C:\Eclipse\workspace`.
3. **(Optional)** If you do not want the Workspace Launcher dialog box to prompt for a location, select the **Use this as the default and do not ask again** check box.
4. Click **OK**.
Configuring the default perspective

About this task
You must configure the preferences the first time that you use Orchestration Designer. On subsequent launches, Orchestration Designer uses these configured preferences.

Procedure
1. On the Eclipse user interface, click Window > Preferences.
   The Eclipse user interface displays the Preferences page.
2. In the navigation pane, double-click General.
3. Click Perspectives.
4. In the Open a new perspective area, select In the same window.
5. In the Open the associated perspective when creating a new project area, select Prompt.
6. In the Available perspectives pane, click one of the following to set the default perspective:
   • Speech
   • Call Control
   • Message
   • Web
7. Click Make default.
8. Click Apply.
9. Click Apply and Close.

Configuring Tomcat Preferences

About this task
Tomcat preferences provide settings that determine how Orchestration Designer works with the Apache Tomcat servlet engine during simulations.

If you install Tomcat with the default settings, Tomcat preferences are already configured. Verify that the Tomcat version, home directory, and contexts directory are appropriate.
**Note:**
If you are running only Orchestration Designer in your development environment without running deployed applications, the `runtimeconfig` file is installed automatically. You only have to set up your production system when you are deploying and running live applications.

**Important:**
Do not run `runtimeconfig` on your ADE. Otherwise, connection timeout exceptions occur. To recover, stop Tomcat, stop Orchestration Designer, restart Orchestration Designer, and change your configuration in Preferences.

**Procedure**
1. On the Eclipse user interface, click **Window > Preferences**.
   The Eclipse user interface displays the Preferences dialog box.
2. In the navigation pane, click **Tomcat**.
3. In the Tomcat version area, click the Tomcat version that is installed on your computer.
4. In the **Tomcat home** field, click **Browse** and select the directory where Tomcat is installed.
5. In the Context declaration mode area, click **Context files**.
6. In the **Contexts directory** field, click **Browse** and select the context directory.
7. Click **Apply**.
8. Click **Apply and Close**.

---

**Orchestration Designer preferences management**

**Considerations for enabling an HTTP or HTTPS proxy connection**

The Orchestration Designer Preferences panel includes a setting to enable an HTTP or HTTPS proxy connection.

Proxy settings are required when all of the following conditions are true:

- The system where Orchestration Designer is installed is behind a firewall.
- Access is required to resources that reside outside the firewall for your Orchestration Designer speech projects. These resources can include Web services, databases, or other outside resources.
- Access to these resources requires the use of either an HTTP or HTTPS proxy server.

When these conditions are true, proxy settings for Orchestration Designer must be configured, even if proxy settings are already configured for your Internet browser or email client. If you have a proxy server configured for your Internet browser, use the same proxy settings for Orchestration...
Enabling an HTTP or HTTPS proxy connection

 Procedure

1. On the Eclipse user interface, click Window > Preferences.
   The Eclipse user interface displays the Preferences dialog box.
2. In the navigation pane, double-click Avaya Aura.
3. Click Orchestration Designer.
4. In the Orchestration Designer pane, do one of the following:
   • In the Proxy Settings area, configure the HTTP proxy settings.
   • In the HTTPS Proxy Settings area, configure the HTTPS proxy settings.
5. Click Apply.
6. Click Apply and Close.

Related links
Considerations for enabling an HTTP or HTTPS proxy connection on page 24
Orchestration Designer preferences field descriptions on page 27

Configuring a run-time license server

About this task
You can configure a run-time license server for your application. If you run the applications through Application Simulator, you do not need the run-time license.

⚠️ Note:
Specify a run-time license server only if Avaya Aura® Experience Portal, IR, or MPS accesses your application from the development environment.

 Procedure

1. On the Eclipse user interface, click Window > Preferences.
   The Eclipse user interface displays the Preferences dialog box.
2. In the navigation pane, double-click Avaya Aura.
3. Click Orchestration Designer.
4. In the **Runtime License Server** area, in the **Server URI** field, enter the URI of the run-time license server.

   The format of this URI is `http://webServerName:port`, where:

   - **webServerName** is the fully qualified host name or IP address of your WebLM license server.
   - **port** is the number of the HTTP/HTTPS port that the system uses to access the license server.


5. In the **License Check Timeout** field, enter the time in seconds.

   The system must wait for a response from the WebLM license server for the specified time while attempting to connect to the WebLM license server.

   The default value is zero seconds. Zero indicates that there is no timeout.

6. Click **Apply**.

7. Click **Apply and Close**.

**Related links**

- [Orchestration Designer preferences field descriptions](#) on page 27

---

**Removing the context files on closing a project**

**About this task**

Tomcat opens the context files of all projects each time you simulate a project. Therefore, Orchestration Designer performance can degrade if you have several workspaces with a large number of projects.

Orchestration Designer recreates the context file when a project is reopened. This improves the performance by controlling the size of the workspaces.

**Note:**

This option does not affect the projects that are not opened in the current session. This applies only to Orchestration Designer projects that you open and close subsequently.

**Procedure**

1. On the Eclipse user interface, click **Window > Preferences**.

   The Eclipse user interface displays the Preferences dialog box.

2. In the navigation pane, double-click **Avaya Aura**.

3. Click **Orchestration Designer**.

4. In the Orchestration Designer pane, in the **Context Files** area, select the **Remove context files on project close** check box.
Orchestration Designer automatically deletes the corresponding context files when you close the Orchestration Designer projects.

5. Click **Apply**.

6. Click **Apply and Close**.

Related links
Orchestration Designer preferences field descriptions on page 27

---

**Configuring Secure Fetch Port**

*About this task*
You can specify the port number used by the application server to use HTTPS to get and post data from form nodes, such as prompt and collect, announce, menu, record, and transfer. If you are using Tomcat, the default port is 8443.

*Procedure*
1. On the Eclipse user interface, click **Window > Preferences**.
   The Eclipse user interface displays the Preferences dialog box.

2. In the navigation pane, double-click **Avaya Aura**.

3. Click **Orchestration Designer**.

4. In the **Secure Fetch** area, in the **Secure Fetch Port** field, enter the port number that the application server uses.

5. Click **Apply**.

6. Click **Apply and Close**.

Related links
Orchestration Designer preferences field descriptions on page 27

---

**Orchestration Designer preferences field descriptions**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Proxy Settings</td>
<td></td>
</tr>
<tr>
<td>Enable HTTP proxy connection</td>
<td>Select to enable HTTP proxy connection if you need a proxy server for Internet access.</td>
</tr>
<tr>
<td>Ignore hosts with addresses</td>
<td>Specify the IP address of the HTTP hosts. Orchestration Designer ignores HTTP hosts with these addresses. For multiple addresses, use a comma or semicolon as a separator.</td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTTP proxy host address</td>
<td>Specify the full HTTP path or the URL of the proxy server.</td>
</tr>
<tr>
<td>HTTP proxy host port</td>
<td>Specify the port that Orchestration Designer can use to access the proxy server.</td>
</tr>
<tr>
<td>Copy HTTP settings to HTTPS</td>
<td>Click to copy the configured HTTP settings to HTTPS settings automatically.</td>
</tr>
<tr>
<td>HTTPS Proxy Settings</td>
<td></td>
</tr>
<tr>
<td>Enable HTTPS proxy connection</td>
<td>Select to enable HTTPS proxy connection if you need a proxy server for Internet access. Clear the check box if you do not need a proxy server for Internet access. If cleared, Orchestration Designer disables the other options in the HTTPS Proxy Settings area.</td>
</tr>
<tr>
<td>Ignore HTTPS hosts with addresses</td>
<td>Specify the IP address of the HTTPS hosts. Orchestration Designer ignores HTTPS hosts with these addresses. For multiple addresses, use a comma or a semicolon as a separator.</td>
</tr>
<tr>
<td>HTTPS proxy host address</td>
<td>Specify the full HTTPS path or the URL of the proxy server. If you do not know this address, see the proxy server settings of your Internet browser software.</td>
</tr>
<tr>
<td>HTTPS proxy host port</td>
<td>Specify the port that Orchestration Designer can use to access the HTTPS proxy server. If you do not know the URI, contact the Avaya technical service representative.</td>
</tr>
</tbody>
</table>

**Note:**
These settings are required even if proxy options are set in Microsoft Internet Explorer or any other web browser.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Runtime License Server</td>
<td></td>
</tr>
</tbody>
</table>

*Table continues…*
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Server URI**                | Specify the URI of the run-time license server.  
**Note:**  
You must specify a run-time license server only if Avaya Aura® Experience Portal, IR, or MPS accesses your application from the development environment.  
If you run applications through Application Simulator, you do not need a run-time license.  
The format of this URI is `http://webServerName:port` where:  
• `webServerName` is the fully qualified host name or IP address of your WebLM license server.  
• `port` is the number of the HTTP/HTTPS port the system uses to access the license server.  
| **License Check Timeout**     | Specify the time in seconds. The system must wait for a response from the WebLM license server for the specified time while attempting to connect to the WebLM license server.  
The default value is zero seconds. Zero indicates that there is no timeout. |
| **Context Files**             |             |
| **Remove context files on project close** | Select to automatically delete corresponding context files when you close Orchestration Designer projects.  
Orchestration Designer recreates the context file when a project is reopened. This improves the performance by controlling the size of the workspaces.  
If you clear this check box, Tomcat opens the context files of all projects each time you simulate a project. Therefore, Orchestration Designer performance can degrade if you have several workspaces with a huge number of projects.  
**Note:**  
This option does not affect the projects that are not opened in the current session. This applies only to Orchestration Designer projects which you open and close subsequently. |
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Secure Fetch</td>
<td>Specify the port number used by the application server. Use this only if you want to use HTTPS to get and post data from form nodes, such as prompt and collect, announce, menu, record, and transfer. If you are using Tomcat, the default port is 8443.</td>
</tr>
<tr>
<td>Secure Fetch Port</td>
<td></td>
</tr>
</tbody>
</table>

**Related links**
- [Enabling an HTTP or HTTPS proxy connection](#) on page 25
- [Configuring a run-time license server](#) on page 25
- [Removing the context files on closing a project](#) on page 26
- [Configuring Secure Fetch Port](#) on page 27

**Verifying the Java JRE**

**Procedure**

1. On the Eclipse user interface, click **Window > Preferences**.
   
The Eclipse user interface displays the Preferences dialog box.
2. In the navigation pane, double-click **Java**.
3. Click **Installed JREs**.
4. Verify that one of the following versions of JRE is selected:
   - jre7
   - jre8
   - jre9
5. *(Optional)* If the required JRE versions do not appear in the list, click **Add** and complete the wizard to add the JRE. For more information, see *Java Development User Guide*.
6. Click **OK**.

**Setting the Java JDK compiler compliance level**

**Procedure**

1. On the Eclipse user interface, click **Window > Preferences**.
   
The Eclipse user interface displays the Preferences page.
2. In the navigation pane, double-click **Java**.
3. Click **Compiler**.
4. In the **JDK Compliance** area, click **Compiler compliance level**.
5. Click **Apply**.
6. Click **Apply and Close**.

---

### Configuring Microsoft Speech API for microphone inputs

**About this task**

Avaya Aura Orchestration Designer uses the Microsoft Speech API 6.0 (SAPI) to handle ASR input from a microphone during application simulation. To use the Microsoft SAPI for ASR input, you must configure the Microsoft SAPI to use a microphone.

**Procedure**

1. On the computer where Orchestration Designer is installed, open Control Panel.
2. Click **Speech Recognition** to configure your speech recognition.
3. With a microphone plugged in and volume turned on, speak into the microphone.
   - The **Level** indicator in the Microphone Setup Wizard shows whether the system is receiving microphone input. Otherwise, you must rectify the audio input source settings.
4. Follow the wizard steps to further fine tune the microphone settings.
5. Click **OK**.

---

### Installing sample applications

**About this task**

Avaya Aura Orchestration Designer includes numerous sample applications. You can use these sample applications to understand how finished applications work and operate, and how the features of Orchestration Designer work.

You can use these applications as technical samples for reference only, and not production-ready applications.

**Procedure**

1. On the Orchestration Designer installation ISO image, navigate to the `/Sample Applications` directory.
3. Follow the instructions in this file to install and configure Orchestration Designer sample applications.
   This file also contains detailed information about each sample application.

---

**Orchestration Designer Upgrade**

You can upgrade to Orchestration Designer 7.2.3 from the following versions either by maintaining or without retaining the previous environment:

- Orchestration Designer 7.1
- Orchestration Designer 7.2.0
- Orchestration Designer 7.2.1
- Orchestration Designer 7.2.2

After upgrading Orchestration Designer, you must update to connectors or other dependant libraries on the application server. You must update the connector applications `icconnector.war` and `aesconnector.war`, and run-time support files `runtimeSupport platform.zip`.

For more information about installing the run-time support files and connectors, see prerequisite files on the application server in *Avaya Aura® Orchestration Designer Developer's Guide*.

**Related links**

- [Maintaining the 7.1 environment while installing 7.2.3](#) on page 32
- [Maintaining the 7.2.0, 7.2.1 or 7.2.2 environment while installing 7.2.3](#) on page 33
- [Recommended installation paths for multiple Orchestration Designer and Eclipse versions](#) on page 34
- [Installing 7.2.3 without retaining the 7.1 environment](#) on page 35
- [Installing 7.2.3 without retaining the 7.2.0, 7.2.1 or 7.2.2 environment](#) on page 36

---

**Maintaining the 7.1 environment while installing 7.2.3**

**About this task**

Install Avaya Aura Orchestration Designer 7.2.3 in a separate directory to retain Orchestration Designer 7.1 environment. You can retain this environment to maintain applications based on 7.1.

For information about the recommended installation paths, see [Recommended installation paths for multiple Orchestration Designer and Eclipse versions](#) on page 34.

**Procedure**

1. Save the Orchestration Designer 7.1 projects and workspace, and Eclipse installation.
2. Install the following software to a separate location. For example, `C:\OD7.2.3\`.
   - Orchestration Designer 7.2.3
   - Tomcat 7.0, 8.0, or 8.5

   Upgrading from Tomcat 7.0 to the next supported version of Tomcat is optional.
   However, Orchestration Designer 7.1 continues to use the previous Tomcat installation.

3. Do the following to upgrade Orchestration Designer 7.1 projects to Orchestration Designer 7.2.3 projects:
   a. Copy the projects from the Orchestration Designer 7.1 workspace to the Orchestration Designer 7.2.3 workspace.
   b. Take a backup of Orchestration Designer 7.1 projects. You can use the backed up projects if there are any issues during the upgrade.
   b. Import the projects to Orchestration Designer 7.2.3.

   Orchestration Designer converts the projects to Orchestration Designer 7.2.3. You cannot open these projects in Orchestration Designer 7.1.

4. **(Optional)** If you use a source control system, save the 7.1 application at a different location or a different branch, so that you can maintain the earlier 7.1 application in future.

5. After creating a new workspace, click **Window > Preferences** to configure your preferences before importing the earlier projects.

---

**Maintaining the 7.2.0, 7.2.1 or 7.2.2 environment while installing 7.2.3**

**About this task**

Install Avaya Aura Orchestration Designer 7.2.3 in a separate directory to retain Orchestration Designer 7.2.0, 7.2.1, or 7.2.2 environment. You can retain this environment to maintain applications based on 7.2.0, 7.2.1, or 7.2.2.

For information about the recommended installation paths, see **Recommended installation paths for multiple Orchestration Designer and Eclipse versions** on page 34.

**Procedure**

1. Save the Orchestration Designer 7.2.0, 7.2.1, or 7.2.2 projects and workspace, and Eclipse installation.

2. Install the following software to a separate location. For example, `C:\OD7.2.3\`.
   - Orchestration Designer 7.2.3
   - Tomcat 7.0, 8.0, or 8.5
Upgrading from Tomcat 7.0 to the next supported version of Tomcat is optional. However, Orchestration Designer 7.2.0, 7.2.1, or 7.2.2 continues to use the previous Tomcat installation.

3. Do the following to upgrade Orchestration Designer 7.2.0, 7.2.1, or 7.2.2 projects to Orchestration Designer 7.2.3 projects:
   a. Copy the projects from the Orchestration Designer 7.2.0, 7.2.1, or 7.2.2 workspace to the Orchestration Designer 7.2.3 workspace.
      Take a backup of Orchestration Designer 7.2.0, 7.2.1, or 7.2.2 projects. You can use the backed-up projects, if there are any issues during the upgrade.
   b. Import the projects to Orchestration Designer 7.2.3.
      The Orchestration Designer coverts the projects to Orchestration Designer 7.2.3. You cannot open these projects in Orchestration Designer 7.2.0, 7.2.1, or 7.2.2.

4. (Optional) If you use a source control system, save the 7.2.0, 7.2.1, or 7.2.2 application at a different location or a different branch, so that you can maintain the earlier 7.2.0, 7.2.1, or 7.2.2 application in the future.

5. After creating a new workspace, click Window > Preferences to configure your preferences before importing the earlier projects.

Related links
Orchestration Designer Upgrade on page 32

Recommended installation paths for multiple Orchestration Designer and Eclipse versions

Avaya recommends the following installation paths for multiple Avaya Aura Orchestration Designer and Eclipse versions:

- `c:\(base)\OD7.2.3\`
  For any parent directory.
- `eclipse`
  For Eclipse 4.5 installation with GEF 3.9 SDK, WTP SDK 3.4, emf-xsd 2.8, DTP 1.10, and Orchestration Designer 7.2.3 features.
- `tomcat`
  Tomcat 7.0, Tomcat 8.0, Tomcat 8.5, or Tomcat 9.0 for running Orchestration Designer 7.2.3 applications.
- `workspace`
  For Orchestration Designer 7.2.3 projects.

These installation paths are convenient structures that separately retain the Orchestration Designer 7.2, Orchestration Designer 7.2.1, and Orchestration Designer 7.2.3 environments and the prerequisite software.
Installing 7.2.3 without retaining the 7.1 environment

Before you begin
Create a backup of the Orchestration Designer 7.1 projects in your workspace.

Procedure

1. To uninstall Orchestration Designer 7.1, do the following:
   a. On the Eclipse interface, click **Windows > Preferences**.
   b. In the Preferences dialog box, click **Install/Update**.
   c. In the **Install/Update** area, click the **Uninstall or update** link.
      The Eclipse user interface displays the Eclipse SDK Installation Details dialog box.
   d. In the **Installed Software** tab, click **Avaya Aura Orchestration Designer Developer Guide**.
   e. Click **Uninstall**.
      Depending on the location of your workspace, you can remove your projects by the uninstall process.
   f. Click **Close**.
   g. Click **Apply and Close**.

2. Install Orchestration Designer 7.2.3 and the supporting software.

3. Copy the Orchestration Designer 7.1 projects from the backup into the Orchestration Designer 7.2.3 workspace.
   Keep a copy of your earlier projects.

4. Import the projects to Orchestration Designer 7.2.3.
   The Orchestration Designer converts the projects to Orchestration Designer 7.2.3.

5. **(Optional)** If you use a source control system, create a branch or save the 7.2.3 application in a different location so that you can maintain the earlier 7.1 application in future.

6. After creating a new workspace, click **Window > Preferences** to configure your preferences before importing the earlier projects.

Related links

- [Orchestration Designer Upgrade](#) on page 32
Installing 7.2.3 without retaining the 7.2.0, 7.2.1 or 7.2.2 environment

Before you begin
Create a backup of the Orchestration Designer 7.2.0, 7.2.1, or 7.2.2 projects in your workspace.

Procedure
1. To uninstall Orchestration Designer, do the following:
   a. On the Eclipse interface, click Windows > Preferences.
   b. In the Preferences dialog box, click Install/Update.
   c. In the Install/Update area, click the Uninstall or update link.
      The Eclipse user interface displays the Eclipse SDK Installation Details dialog box.
   d. In the Installed Software tab, select Avaya Aura Orchestration Designer Developer Guide.
   e. Click Uninstall.
      Depending on the location of your workspace, you can remove your projects by the uninstall process.
   f. Click Close.
   g. Click Apply and Close.
2. Install Orchestration Designer 7.2.3 and the supporting software.
3. Copy the Orchestration Designer 7.2.0, 7.2.1, or 7.2.2 projects from the backup into the Orchestration Designer 7.2.3 workspace.
   Keep a copy of your earlier projects.
4. Import each project into Orchestration Designer 7.2.3.
   The system converts the projects for Orchestration Designer 7.2.3.
5. (Optional) If you use a source control system, create a branch or save the 7.2.3 application in a different location so that you can maintain the earlier 7.2.0, 7.2.1, or 7.2.2 application in future.
6. After creating a new workspace, click Window > Preferences to configure your preferences before importing the earlier projects.

Related links
Orchestration Designer Upgrade on page 32
Orchestration Designer patch updates

Avaya does not send automatic alerts about the availability of new patches for Orchestration Designer. Therefore, you must periodically check the Avaya support website or use the Eclipse update mechanism to check for available updates.

The following sections describe the steps for installing Orchestration Designer patches:

- Prerequisite to install a patch update.
- Installation of patches or updates of a released software, not for upgrading software versions.
- Upgrading of software.

🌟 Note:

The procedure described in the Installing an Orchestration Designer patch update on page 37 section is for installing patches or updates of a released software, and not for upgrading software versions completely. For upgrading the software, see Orchestration Designer Upgrade on page 32.

Prerequisite to installing an Orchestration Designer patch update

Before installing a patch update, you must back up all files in the default /eclipse installation directory or a subdirectory of /eclipse, and in the designated /workspace directory.

To continue using the earlier version of the existing applications, perform a clean installation of the new version in a new directory.

⚠️ Caution:

When you open an application created with an earlier release of Orchestration Designer, the tool prompts you to update the project to a new version. For project conversion considerations, see the Release Notes.

Installing an Orchestration Designer patch update

About this task

Avaya Support website releases Orchestration Designer patch updates. You can gain access to these updates from the Eclipse user interface.

If you are unsure which updates to install or if you have questions about the installation procedure, contact Avaya Support website at http://support.avaya.com.

🌟 Note:

The procedure described in this section is for installing patches or updates to a released software, and not for upgrading software versions completely. For upgrading the software, see Orchestration Designer Upgrade on page 32.
Procedure

1. On the Eclipse user interface, click Help > Install New Software.
2. In the Install dialog box, clear the Contact all update sites during install to find required software check box.
3. In the Work with field, click the Orchestration Designer patch update website name that you specified.
4. Ensure that the Orchestration Designer patch update website is added to Eclipse. For more information, see Adding the website for Orchestration Designer patch updates on page 38.
5. (Optional) If you cannot connect to the update website, ensure that you have correctly configured the proxy settings. The system automatically checks for the Orchestration Designer patch updates. If patches or updates are found, the search mechanism returns the results.
6. Select the Orchestration Designer patch updates that you want to install.
7. Click Next, and then follow the prompts.

You can use the Eclipse Install New Software mechanism for features besides Orchestration Designer. To ensure that you install compatible features, update only the Orchestration Designer features.

---

Adding the website for Orchestration Designer patch updates

About this task

To get Avaya Aura Orchestration Designer patch updates, you must add the Orchestration Designer patch update website to Eclipse.

Procedure

1. On the Eclipse user interface, do one of the following:
   - Click Help > Install New Software and then select All Available Sites.
   - Click Window > Preferences.
2. In the Preferences dialog box, double-click Install/Update.
3. Click Available Software Sites.
4. In the Available Software Sites pane, click Add.
5. In the Add Site dialog box, in the Name field, type a name for the Orchestration Designer patch update website. For example, AAOD.
6. In the Location field, type http://support.avaya.com/OrchestrationDesigner/SS/Updates/.
7. Click OK.
# Chapter 3: Resources

## Related resources

### Documentation

The following table lists the documents related to this product. Download the documents from the Avaya Support website at http://support.avaya.com

<table>
<thead>
<tr>
<th>Title</th>
<th>Description</th>
<th>Audience</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Getting Started with Avaya Aura® Orchestration Designer</strong></td>
<td>This PDF document contains the information needed to install and configure Orchestration Designer for initial use, and to understand the basics of Orchestration Designer graphical user interface (GUI).</td>
<td>• Application Developers&lt;br&gt;  • Implementation Engineers</td>
</tr>
</tbody>
</table>
### Title

<table>
<thead>
<tr>
<th>Title</th>
<th>Description</th>
<th>Audience</th>
</tr>
</thead>
</table>
| Deploying Avaya Breeze® platform | This document provides information and procedures on deploying the Avaya Breeze® platform services. | • System administrators  
• Services and Support personnel  
• Avaya Professional Services  
• Implementation engineers |
| Avaya Context Store Snap-in Reference | This document is intended for anyone who wants to install, configure, and administer Context Store. | • Application Developers  
• Implementation Engineers |
| Deploying Avaya Analytics™ | This document is intended for anyone who wants to deploy Avaya Analytics™. | • Application Developers  
• Implementation Engineers |

For information about viewing the Orchestration Designer documentation, see [Viewing the Orchestration Designer documentation](#) on page 8.

**Related links**

- [Finding documents on the Avaya Support website](#) on page 40
- [Avaya Documentation Portal navigation](#) on page 41

**Finding documents on the Avaya Support website**

**Procedure**

1. Go to [https://support.avaya.com](https://support.avaya.com).
2. At the top of the screen, type your username and password and click **Login**.
3. Click **Support by Product > Documents**.
4. In **Enter your Product Here**, type the product name and then select the product from the list.
5. In **Choose Release**, select an appropriate release number.
6. In the **Content Type** filter, click a document type, or click **Select All** to see a list of all available documents.
   - For example, for user guides, click **User Guides** in the **Content Type** filter. The list displays the documents only from the selected category.
7. Click **Enter**.

**Related links**

- [Documentation](#) on page 39
Avaya Documentation Portal navigation

Customer documentation for some programs is now available on the Avaya Documentation Portal at [https://documentation.avaya.com](https://documentation.avaya.com).

**Important:**

For documents that are not available on the Avaya Documentation Portal, click Support on the top menu to open [https://support.avaya.com](https://support.avaya.com).

Using the Avaya Documentation Portal, you can:

- Search for content in one of the following ways:
  - Type a keyword in the Search field.
  - Type a keyword in Search, and click Filters to search for content by product, release, and document type.
  - Select a product or solution and then select the appropriate document from the list.
- Find a document from the Publications menu.
- Publish a PDF of the current section in a document, the section and its subsections, or the entire document.
- Add content to your collection by using My Docs (⭐).

Navigate to the My Content > My Docs menu, and do any of the following:

- Create, rename, and delete a collection.
- Add content from various documents to a collection.
- Save a PDF of selected content in a collection and download it to your computer.
- Share content in a collection with others through email.
- Receive content that others have shared with you.

- Add yourself as a watcher by using the Watch icon (👀).

Navigate to the My Content > Watch list menu, and do the following:

- Set how frequently you want to be notified, starting from every day to every 60 days.
- Unwatch selected content, all content in a document, or all content on the Watch list page.

As a watcher, you are notified when content is updated or deleted from a document, or the document is removed from the portal.

- Share a section on social media platforms, such as Facebook, LinkedIn, and Twitter.
- Send feedback on a section and rate the content.

**Note:**

Some functionality is only available when you log in to the portal. The available functionality depends on the role with which you are logged in.
Training

The following courses are available on the Avaya Learning website at www.avaya-learning.com. After logging into the website, enter the course code or the course title in the Search field and click Go to search for the course.

<table>
<thead>
<tr>
<th>Course Code</th>
<th>Course Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>4C00095W</td>
<td>Avaya Aura Orchestration Designer for Developers</td>
</tr>
<tr>
<td>5C00092V</td>
<td>Avaya Aura Experience Portal, Avaya Aura Orchestration Designer, and Avaya Proactive Outreach Manager Installation, Maintenance and Troubleshooting Essentials</td>
</tr>
<tr>
<td>3610C</td>
<td>Avaya Aura Contact Center - Orchestration Designer Scripting</td>
</tr>
<tr>
<td>2C00081O</td>
<td>Selling Avaya Aura Orchestration Designer</td>
</tr>
<tr>
<td>5C00080E</td>
<td>Knowledge Access: Avaya Aura Contact Center Orchestration Designer Scripting Administration</td>
</tr>
</tbody>
</table>

W: Web (online) course  
V: Virtual  
E: Self-paced in virtual campus  
O: On Demand

Viewing Avaya Mentor videos

Avaya Mentor videos provide technical content on how to install, configure, and troubleshoot Avaya products.

About this task

Videos are available on the Avaya Support website, listed under the video document type, and on the Avaya-run channel on YouTube.

Procedure

- To find videos on the Avaya Support website, go to https://support.avaya.com/ and do one of the following:
  - In Search, type Avaya Mentor Videos, click Clear All and select Video in the Content Type.
  - In Search, type the product name. On the Search Results page, click Clear All and select Video in the Content Type.
The **Video** content type is displayed only when videos are available for that product.

In the right pane, the page displays a list of available videos.

- To find the Avaya Mentor videos on YouTube, go to [www.youtube.com/AvayaMentor](http://www.youtube.com/AvayaMentor) and do one of the following:
  - Enter a key word or key words in the **Search Channel** to search for a specific product or topic.
  - Scroll down Playlists, and click a topic name to see the list of videos available for the topic. For example, Contact Centers.

**Note:**

Videos are not available for all products.

---

**Support**

Go to the Avaya Support website at [https://support.avaya.com](https://support.avaya.com) for the most up-to-date documentation, product notices, and knowledge articles. You can also search for release notes, downloads, and resolutions to issues. Use the online service request system to create a service request. Chat with live agents to get answers to questions, or request an agent to connect you to a support team if an issue requires additional expertise.
# Glossary

<table>
<thead>
<tr>
<th>Acronym</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AACC</td>
<td>Avaya Aura® Contact Center.</td>
</tr>
<tr>
<td>AAEP</td>
<td>Avaya Aura® Experience Portal</td>
</tr>
<tr>
<td>AAS</td>
<td>Avaya Application Simulator.</td>
</tr>
<tr>
<td>ADR</td>
<td>See application detail record (ADR) on page 44.</td>
</tr>
<tr>
<td>AMS</td>
<td>Avaya Aura® Media Server.</td>
</tr>
<tr>
<td>ANI</td>
<td>See automatic number identification (ANI) on page 44.</td>
</tr>
<tr>
<td>API</td>
<td>See application program interface (API) on page 44.</td>
</tr>
<tr>
<td>application detail record (ADR)</td>
<td>Data records which contain historical information about an application used as part of a session. These records include information such as the session ID number, a timestamp, and a “friendly name” string determined by the developer who created the application.</td>
</tr>
<tr>
<td>application program interface (API)</td>
<td>A set of routines, protocols, and tools for building software applications. A good API makes it easier to develop a program by providing all the building blocks.</td>
</tr>
<tr>
<td>application server</td>
<td>A computer on which the Orchestration Designer speech application resides and runs. This computer is also where the Orchestration Designer run-time libraries are installed, thus making it possible to run Orchestration Designer applications on that server. The IVR system must be configured to start the speech application from this location.</td>
</tr>
<tr>
<td>ASR</td>
<td>See automated speech recognition (ASR) on page 44.</td>
</tr>
<tr>
<td>automated speech recognition (ASR)</td>
<td>Technology that employs a computer to recognize spoken words and respond appropriately.</td>
</tr>
<tr>
<td>automatic number identification (ANI)</td>
<td>A service that provides the originating telephone number of a call coming in to the system.</td>
</tr>
<tr>
<td>call flow</td>
<td>As implemented in speech applications, the call flow determines how a call is handled when it enters an interactive voice response system, based on options offered to callers and their responses to those options.</td>
</tr>
</tbody>
</table>
Call Control eXtensible Markup Language.

An emerging XML specification, being developed to work in conjunction with VoiceXML and which addresses some of the technical limitations of VoiceXML. It enables the processing of asynchronous events, filtering and routing of incoming calls, and placement of outbound calls. Note that it is not intended to replace VoiceXML but rather to supplement it. See Ian Moraes’s excellent article, “VoiceXML, CCXML, SALT: Architectural Tools for Enabling Speech Applications,” on the Internet.

Software technology that integrates the use of telephones and computers without the need for special telephones, connectors, computer circuit packs, or other specialized hardware.

A service that identifies for the receiving system what telephone number was dialed by the caller. In the Avaya Aura® Experience Portal system this is often used to direct the call to a particular speech application, which is identified with that dialed number.

See dual tone multi-frequency (DTMF) on page 45.

The system used by touchtone telephones, DTMF assigns a specific frequency (consisting of two separate tones) to each telephone key on the keypad, so that it can easily be identified by a microprocessor.

A Java-based open-source extensible IDE (integrated development environment) that provides application developers a feature-rich interface to develop their applications. Orchestration Designer is designed as a set of Eclipse plug-in modules that make it possible for application developers to design and build speech applications without having to write the code manually.

A network point that acts as an entry point to another network. In the context of Orchestration Designer and VoIP applications, a gateway is the entry point, often associated with one or more switches, to the interactive voice response (IVR) system application environment. See interactive voice response (IVR) system on page 46.

Elements that recognize the input received through inbound voice calls and messages.

In the context of IVR or speech applications, a grammar is a predefined set of words or DTMF tones that a speech application uses in conjunction with automated speech recognition (ASR) technology to interpret and respond to caller inputs. That is, grammars are lists of possible responses that callers make when responding to prompts by using spoken replies.
Grammars define which words or phrases the ASR engine can recognize and respond to.

In the context of text-based applications, a grammar is a predefined set of words in a message application that a text-processing system can use to interpret and respond to an inbound SMS or email message. The text-processing system collects and recognizes the input from inbound SMS and email messages and uses this input to direct the flow of a message application.

**H.323**  
A hierarchical, IP-based telephony standard for connecting IP telephones and speech applications to switches.

**IC**  
See [Interaction Center (IC)] on page 46.

**IDE**  
See [integrated development environment (IDE)] on page 46.

**integrated development environment (IDE)**  
A software application that usually provides a GUI environment, a text and/or code editor, a compiler and/or interpreter, and a debugger. This environment means that application or web developers can develop, test, and build their applications or Web sites within a single integrated space.

**Interaction Center (IC)**  
A multichannel contact management platform that enables businesses to align real-time contact center operations with business objectives.

**interactive voice response (IVR) system**  
A system, such as Avaya Aura® Experience Portal or Avaya IR, in which callers interact with a self-service application to get information, conduct transactions, or help with problems.

**IVR system**  
See [interactive voice response (IVR) system] on page 46.

**JDBC**  
An [application program interface (API)] on page 44 specification in which programs written in Java connect with and access data contained in database programs using [Structured Query Language (SQL)] on page 48.

**localization**  
The process of modifying an application to operate and be understood in a different language, or locale. This usually involves modifying any phrases, prompts, and grammars associated with an application.

**MPS**  
Media Processing Server.

**MRCP**  
Media Resource Control Protocol.

**NDM**  
See [Nuance Dialog Module (NDM)] on page 47.

**notebook**  
(Also known as a tabbed or stacked notebook) In the Eclipse context, a notebook is a set of views "stacked" on top of one another as a space saving measure. The views in the notebook are accessible by clicking...
tabs arranged along the top of the notebook. See the Eclipse documentation.

**Nuance Dialog Module (NDM)**

Speech application modules produced by Nuance software products, similar to speech application modules created by using Orchestration Designer. You can use NDMs in the Orchestration Designer speech applications. Orchestration Designer supports NDM version 5.0 and later.

Before version 5.0, Nuance Dialog Module (NDM) was known as Open Speech Dialog Module (OSDM).

See [Open Speech Dialog Module (OSDM)](#) on page 47.

**Open Speech Dialog Module (OSDM)**

Speech application modules produced by Nuance software products, similar to application modules created with Orchestration Designer. OSDMs can be used in Orchestration Designer applications. (Orchestration Designer supports the following OSDM versions: Address OSDM 2.0.3, Core OSDM 2.0.4, and Name OSDM 2.0.1.)

OSDM is renamed to Nuance Dialog Module (NDM) from version 5.0 and later.

**OSDM**

See [Open Speech Dialog Module (OSDM)](#) on page 47.

**palette**

In the Orchestration Designer Editor views, this is the pane to the left of the view, in which editor options are displayed and selected.

**Real-time Transfer Protocol (RTP)**

A protocol for transmitting “real-time” data, such as audio or video data, across the Internet. This protocol does not guarantee “real-time” delivery of such data, but it does provide mechanisms to support data “streaming.”

**RTP**

See [Real-time Transfer Protocol (RTP)](#) on page 47.

**RTSP**

The Real Time Streaming Protocol, serves as a control protocol, and as a jumping off point for negotiating transports, such as RTP, multicast and unicast, and negotiating codecs off of servers in a file format independent way.

**SCE**

See [service creation environment (SCE)](#) on page 47.

**service creation environment (SCE)**

A set of software tools used to develop, test, and debug speech applications. Orchestration Designer is an SCE.

**servlet**

A small program that runs on a server, often Java-based.

**servlet engine**

A program that coordinates the overall operation and integration of a number of servlets. In the context of Orchestration Designer, the supported servlet engines are Apache Jakarta Tomcat, IBM WebSphere/ WebSphere Express, Oracle WebLogic, and JBoss EAP/Wildfly.
### Glossary

**Session Initiation Protocol (SIP)**
A signaling protocol for the Internet that makes it possible to set up conferencing, telephony, events notification, and instant messaging. Within a VoIP framework, it initiates call setup, routing, authentication, to endpoints within an IP domain.

**SIP**
See [Session Initiation Protocol (SIP)](#) on page 48.

**speech recognition**
See [automated speech recognition (ASR)](#) on page 44.

**speech synthesis**
See [text-to-speech (TTS)](#) on page 49.

**speech user interface (SUI)**
Any software interface in which the user interacts with the system using speech commands and audio prompts.

**SQL**
See [Structured Query Language (SQL)](#) on page 48.

**SSL**
Secure Sockets Layer.
A protocol for transmitting private data securely over the Internet. By convention, URLs that use SSL require a connection using the HTTPS protocol, rather than just HTTP.

**SSML**
Speech Synthesis Markup Language.
A W3C standard designed to provide an XML-based markup language for assisting with the generation of synthetic speech in Web and other applications. The essential role of the markup language is to provide authors of synthesizable content a standard way to control aspects of speech such as pronunciation, volume, pitch, rate, and so forth, across different synthesis-capable platforms.

**stacked notebook**
See [notebook](#) on page 46.

**Structured Query Language (SQL)**
A standard interactive and programming language for getting data to and from a database.

**SUI**
See [speech user interface (SUI)](#) on page 48.

**tabbed notebook**
See [notebook](#) on page 46.

**TDD**
See [Telecommunications Display Device (TDD)](#) on page 48.

**Telecommunications Display Device (TDD)**
Sometimes designated as a teletypewriter (TTY) device, a telephone equipped with a keyboard and display, used by hearing- or speech-impaired callers to send and receive typed messages.

**telephone user interface (TUI)**
Any software interface in which the user interacts with the system using a telephone or similar device.

**teletypewriter (TTY) device**
See [Telecommunications Display Device (TDD)](#) on page 48.
text-to-speech (TTS) Technology by which information in text format is rendered as audio output using a speech synthesis engine to simulate human speech.

TTS See text-to-speech (TTS) on page 49.

TTY See Telecommunications Display Device (TDD) on page 48.

TUI See telephone user interface (TUI) on page 48.

vector A user-defined sequence of functions that may be performed, such as routing the call to a destination, giving a busy signal, or playing a recorded message.

VoiceXML (Sometimes presented as VXML) Voice eXtensible Markup Language.

A specification which provides for a user to interact with Internet-based resources using voice recognition technology. Instead of a typical Web browser that requires a combination of HTML, keyboard, and mouse device, VoiceXML relies on an Internet voice browser and/or telephone. Using VoiceXML, the user interacts with the Web “page” by listening to audio outputs (either pre-recorded or using a technology such as TTS) and by submitting input in the form of the user’s natural speaking voice and/or manual responses, such as telephone key presses.

Web service A standardized way of offering Web-based applications or services. Because Web services are Web-based and standards-based applications, delivered over the Internet, Web services make it possible for organizations to communicate and share data that use different file formats and programming languages.

workspace In Orchestration Designer, the area within the Editor view used to build the functionality for the selected editor. For example, in the Call Flow Editor, this is the space to the right of the palette, in which you drag the nodes that represent application functions.

See palette on page 47.

WSDL Web services Description Language.

An XML-formatted language used to describe a Web service’s capabilities.

XML eXtensible Markup Language.

A specification for the presentation of Internet documents, one which expands on the capabilities of HTML. A pared-down version of SGML (Standard Generalized Markup Language), XML makes it possible for designers to create their own customized tags, which in turn makes it possible to do things over the Internet that cannot be done using simple HTML.
## Index

### A
- access options
  - creating .......................................................... 22
- Avaya support website support ....................................... 43

### C
- collection
  - delete ........................................................................... 41
  - edit name ..................................................................... 41
  - generating PDF .......................................................... 41
  - sharing content .......................................................... 41
- configuring
  - default perspective ..................................................... 23
  - fetch secure port .......................................................... 27
  - run-time license server ................................................... 25
  - workspace ....................................................................... 22
- content
  - publishing PDF output .................................................... 41
  - searching ...................................................................... 41
  - sharing .......................................................................... 41
  - watching for updates ....................................................... 41
- courses .............................................................................. 42
- creating
  - Eclipse shortcut ............................................................. 22

### D
- database operations
  - documentation support .................................................. 8
- default perspective
  - configuring ................................................................. 23
- documentation
  - Dialog Designer outputs .................................................. 8
  - Getting Started with Dialog Designer PDF guide .................. 8
  - other resources ............................................................. 8
- documentation portal ........................................................ 41
- finding content ................................................................. 41
- navigation ......................................................................... 41
- document changes ............................................................ 7

### E
- Eclipse
  - documentation ............................................................... 8
  - version required ............................................................ 14
- Eclipse shortcut
  - creating ........................................................................ 22
- enable proxy settings .......................................................... 24
- enabling
  - HTTP proxy connection .................................................. 25
  - enabling (continued)
    - HTTPS proxy connection ................................................ 25

### F
- finding content on documentation portal ................................. 41

### G
- Getting Started with Dialog Designer PDF guide ......................... 8
- Graphical Editing Framework, version required .......................... 14

### H
- hardware required for installation of Dialog Designer .................. 14
  - http ............................................................................... 24
  - https ............................................................................. 24

### I
- IBM WebSphere, documentation support ................................... 8
- installation
  - pre-packaged installation ................................................... 21
  - installation and configuration
    - configuring the workspace .............................................. 22
    - initial configuration ......................................................... 22
    - required hardware .......................................................... 14
    - required software ........................................................... 14
    - sample applications ........................................................ 31
  - installation and configuration, Microsoft Speech API,
    configuring microphone input ........................................... 31
  - installing
    - Orchestration Designer patches ........................................ 37
    - Orchestration Designer upgrades ....................................... 37
    - patch update .................................................................. 37
    - sample applications ........................................................ 31
  - installing 7.2.3 ................................................................ 35, 36

### J
- Jakarta Tomcat .................................................................... 14
  - see also Tomcat ............................................................. 8
- Java
  - 2 SDK ........................................................................... 14
  - SDK, documentation support ............................................. 8
- JDBC
  - documentation support .................................................... 8

### M
- manual, Custom, Typical installation, Custom installation
manual, Custom, Typical installation, Custom installation (continued)
installation and configuration, options for installation ... 18
Microsoft SAPI Speech documentation support ................................. 8
Microsoft Speech API (SAPI) .......................................................... 14
My Docs ........................................................................................ 41

O
OD 7.2.3
new features ........................................................................ 7
OD upgrade ............................................................................... 32
operating systems supported for Orchestration Designer ... 14
orchestration designer .............................................................. 8
purpose .................................................................................... 7
Orchestration Designer installation path .................................. 34

P
patches, installing ...................................................................... 37
PDF guides
  Getting Started with Dialog Designer ................................. 8
  proxy connection .................................................................. 24

R
related documentation ............................................................. 39
requirements
  hardware, for installation .................................................. 14
  software, for installation .................................................... 14

S
sample applications, installing and running .............................. 31
searching for content ................................................................ 41
setting, JDK compliance level ................................................ 30
setting up workspace ................................................................ 22
sharing content ........................................................................ 41
software required for installation of Orchestration Designer 14
Speech API (SAPI), Microsoft ................................................... 14
support .................................................................................... 43

T
Tomcat
documentation support .......................................................... 8
version required ........................................................................ 14
training ...................................................................................... 42

U
upgrade ...................................................................................... 32
upgrades, installing .................................................................. 37

verifying
Java JRE .............................................................................. 30
videos ..................................................................................... 42

W
warranty ..................................................................................... 8
watch list .................................................................................. 41
Web service operations
documentation support .......................................................... 8
workspace, setting up .............................................................. 22
Workspace Launcher ................................................................ 22