Modular Messaging

Release 5.1 with the Avaya MSS

Messaging Application Server (MAS) Administration Guide

June 2009
© 2009 Avaya Inc.  
All Rights Reserved.

Notice
While reasonable efforts were made to ensure that the information in this document was complete and accurate at the time of printing, Avaya Inc. can assume no liability for any errors. Changes and corrections to the information in this document might be incorporated in future releases.

Documentation disclaimer
Avaya Inc. is not responsible for any modifications, additions, or deletions to the original published version of this documentation unless such modifications, additions, or deletions were performed by Avaya. Customer and/or End User agree to indemnify and hold harmless Avaya, Avaya's agents, servants and employees against all claims, lawsuits, demands and judgments arising out of, or in connection with, subsequent modifications, additions or deletions to this documentation to the extent made by the Customer or End User.

Link disclaimer
Avaya Inc. is not responsible for the contents or reliability of any linked Web sites referenced elsewhere within this documentation, and Avaya does not necessarily endorse the products, services, or information described or offered within them. We cannot guarantee that these links work all the time and we have no control over the availability of the linked pages.

Warranty
Avaya Inc. provides a limited warranty on this product. Refer to your sales agreement to establish the terms of the limited warranty. In addition, Avaya's standard warranty language, as well as information regarding support for this product, while under warranty, is available through the Avaya Support Web site: http://www.avaya.com/support

License
USE OR INSTALLATION OF THE PRODUCT INDICATES THE END USER'S ACCEPTANCE OF THE TERMS SET FORTH HEREIN AND THE GENERAL LICENSE TERMS AVAILABLE ON THE AVAYA WEB SITE: http://support.avaya.com/LicenseInfo/ ("GENERAL LICENSE TERMS"). IF YOU DO NOT WISH TO BE BOUND BY THESE TERMS, YOU MUST RETURN THE PRODUCT(S) TO THE POINT OF PURCHASE WITHIN TEN (10) DAYS OF DELIVERY FOR A REFUND OR CREDIT.

Avaya grants End User a license within the scope of the license types described below. The applicable number of licenses and units of capacity for which the license is granted will be one (1), unless a different number of licenses or units of capacity is specified in the Documentation or other materials available to End User. "Designated Processor" means a single stand-alone computing device. "Server" means a Designated Processor that hosts a software application to be accessed by multiple users. "Software" means the computer programs in object code, originally licensed by Avaya and ultimately utilized by End User, whether as stand-alone Products or pre-installed on Hardware. "Hardware" means the standard hardware Products, originally sold by Avaya and ultimately utilized by End User.

License Type(s)
Designated System(s) License (DS). End User may install and use each copy of the Software on only one Designated Processor, unless a different number of Designated Processors is indicated in the Documentation or other materials available to End User. Avaya may require the Designated Processor(s) to be identified by type, serial number, feature key, location or other specific designation, or to be provided by End User to Avaya through electronic means established by Avaya specifically for this purpose.

 Concurrent User License (CU). End User may install and use the Software on multiple Designated Processors or one or more Servers, so long as only the licensed number of Units are accessing and using the Software at any given time. A "Unit" means the unit on which Avaya, at its sole discretion, bases the pricing of its licenses and can be, without limitation, an agent, port or user, an e-mail or voice mail account in the name of a person or corporate function (e.g., webmaster or helpdesk), or a directory entry in the administrative database utilized by the Product that permits one user to interface with the Software. Units may be linked to a specific, identified Server.

Named User License (NU). Customer may: (i) install and use the Software on a single Designated Processor or Server per authorized Named User (defined below); or (ii) install and use the Software on a Server so long as only authorized Named Users access and use the Software. "Named User," means a user or device that has been expressly authorized by Avaya to access and use the Software. At Avaya's sole discretion, a "Named User" may be, without limitation, designated by name, corporate function (e.g., webmaster or helpdesk), an e-mail or voice mail account in the name of a person or corporate function, or a directory entry in the administrative database utilized by the Product that permits one user to interface with the Product.

Shrinkwrap License (SR). With respect to Software that contains elements provided by third party suppliers, End user may install and use the Software in accordance with the terms and conditions of the "shrinkwrap" or "clickwrap" license accompanying the Software ("Shrinkwrap License"). The text of the Shrinkwrap License will be available from Avaya upon End User's request (see "Copyright" below for more information).

Copyright
Except where expressly stated otherwise, the Product is protected by copyright and other laws respecting proprietary rights. Unauthorized reproduction, transfer, and or use can be a criminal, as well as a civil, offense under the applicable law.

Third-party Components
Certain software programs or portions thereof included in the Product may contain software distributed under third party agreements ("Third Party Components"). Information identifying Third Party Components and the Third Party Terms that apply to them is available on the Avaya Support Web site: http://support.avaya.com/ThirdPartyLicense/

Third-party royalty-free license agreements
This product and future updates and service packs to this product might contain third-party royalty-free technology which is provided to you under terms and conditions which are different from your Avaya product license agreement. A file containing these third-party royalty-free licenses, 3plrdm.txt or a similar name, is in the root directory of the product CD. Your use of this technology described in this file is subject to the terms and conditions of such other license agreements, and not the Avaya product license agreement.

Preventing Toll Fraud
"Toll fraud" is the unauthorized use of your telecommunications system by an unauthorized party (for example, a person who is not a corporate employee, agent, subcontractor, or is not working on your company's behalf). Be aware that there might be a risk of toll fraud associated with your system and that, if toll fraud occurs, it can result in substantial additional charges for your telecommunications services.

Avaya Fraud Intervention
If you suspect that you are being victimized by toll fraud and you need technical assistance or support, call Technical Service Center Toll Fraud Intervention Hotline at +1-800-643-2353 for the United States and Canada. For additional support telephone numbers, see the Avaya Support Web site: http://www.avaya.com/support

Providing Telecommunications Security
Telecommunications security (voice, data, and/or video communications) is the prevention of any type of intrusion to (that is, either unauthorized or malicious access to or use of) your company's telecommunications equipment by some party.

Your company's "telecommunications equipment" includes both this Avaya product and any other voice/data/video equipment that can be accessed by this Avaya product (that is, "networked equipment"). An "outside party" is anyone who is not a corporate employee, agent, subcontractor, or is not working on your company's behalf. Whereas, a "malicious party" is anyone (including someone who might be otherwise authorized) who accesses your telecommunications equipment with either malicious or mischievous intent.

June 2009 Avaya Modular Messaging Release 5.1 with the Avaya MSS
MAS Administration Guide

LG-1
Such intrusions might be either to or through synchronous (time-multiplexed and/or circuit-based), or asynchronous (character-, message-, or packet-based) equipment, or interfaces for reasons of:

- Utilization (of capabilities special to the accessed equipment)
- Theft (such as, of intellectual property, financial assets, or toll facility access)
- Eavesdropping (privacy invasions to humans)
- Mischief (troubling, but apparently innocuous, tampering)
- Harm (such as harmful tampering, data loss or alteration, regardless of motive or intent)

Be aware that there might be a risk of unauthorized intrusions associated with your system and/or its networked equipment. Also realize that, if such an intrusion should occur, it might result in a variety of losses to your company (including but not limited to, human/data privacy, intellectual property, material assets, financial resources, labor costs, and/or legal costs).

Responsibility for Your Company's Telecommunications Security
The final responsibility for securing both this system and its networked equipment rests with you — Avaya’s customer system administrator, your telecommunications peers, and your managers. Base the fulfillment of your responsibility on acquired knowledge and resources from a variety of sources including but not limited to:

- Installation documents
- System administration documents
- Security documents
- Hardware-software-based security tools
- Shared information between you and your peers
- Telecommunications security experts

To prevent intrusions to your telecommunications equipment, you and your peers should carefully program and configure:

- Your Avaya-provided telecommunications systems and their interfaces
- Your Avaya-provided software applications, as well as their underlying hardware/software platforms and interfaces
- Any other equipment networked to your Avaya products

TCP/IP Facilities
Customers might experience differences in product performance, reliability and security depending upon network configurations/design and topologies, even when the product performs as warranted.

Standards Compliance
Avaya Inc. is not responsible for any radio or television interference caused by unauthorized modifications of this equipment or the substitution or attachment of connecting cables and equipment other than those specified by Avaya Inc. The correction of interference caused by such unauthorized modifications, substitution or attachment is the responsibility of the user. Pursuant to Part 15 of the Federal Communications Commission (FCC) Rules, the user is cautioned that changes or modifications not expressly approved by Avaya Inc. might void the user’s authority to operate this equipment.

Federal Communications Commission Statement
Part 15:

Note: This equipment has been tested and found to comply with the limits for a Class A digital device, pursuant to Part 15 of the FCC Rules. These limits are designed to provide reasonable protection against harmful interference when the equipment is operated in a commercial environment. This equipment generates, uses, and can radiate radio frequency energy and, if not installed and used in accordance with the instruction manual, may cause harmful interference to radio communications. Operation of this equipment in a residential area is likely to cause harmful interference in which case the user will be required to correct the interference at his own expense.

Canadian Department of Communications (DOC) Interference Information
This Class A digital apparatus complies with Canadian ICES-003. Cet appareil numérique de la classe A est conforme à la norme NMB-003 du Canada.

This equipment meets the applicable Industry Canada Terminal Equipment Technical Specifications. This is confirmed by the registration number. The abbreviation, IC, before the registration number signifies that registration was performed based on a Declaration of Conformity indicating that Industry Canada technical specifications were met. It does not imply that Industry Canada approved the equipment.

European Union Declarations of Conformity


Copies of these Declarations of Conformity (DoCs) can be obtained by contacting your local sales representative and are available on the Avaya Support Web site:
http://www.avaya.com/support

Trademarks
Aria, AUDIX, Avaya, DEFINITY, INTUITY, Octel and Serenade are registered trademarks of Avaya Inc.
COMPAS and Mailbox Manager are trademarks of Avaya Inc.
All non-Avaya trademarks are the property of their respective owners.

Document ordering information:
Avaya Publications Center
For the most current versions of documentation, go to the Avaya Support Web site:
http://www.avaya.com/support

COMPAS
This document is also available from the COMPAS database. The COMPAS ID for this document is 140741.

Avaya support
Avaya provides a telephone number for you to use to report problems or to ask questions about your product. The support telephone number is 1-800-676-2835 in the United States. For additional support telephone numbers, see the Avaya Support Web site:
http://www.avaya.com/support
<table>
<thead>
<tr>
<th>Contents</th>
</tr>
</thead>
</table>

**Preface 1**

**Chapter 1**  Introduction to the Messaging Application Server (MAS)
- The Messaging Application Server .................................................. 1-2
- Logging on to a Messaging Application Server .................................. 1-2
- Opening Messaging Application Server Programs .............................. 1-2
- Modular Messaging Services ......................................................... 1-2
- System Administration Tools ....................................................... 1-4
  - Voice Mail System Configuration ................................................ 1-4
  - Visual Voice Editor ...................................................................... 1-4
  - Caller Applications Editor ......................................................... 1-4
  - Password Policy Editor ............................................................... 1-5
- Diagnostic and Reporting Tools ..................................................... 1-7
  - Reporting Tool ............................................................................ 1-8
  - Operation History Viewer ............................................................ 1-8
  - System Performance Monitoring Tools .......................................... 1-8
  - Modular Messaging Snapshot Utility .............................................. 1-8
  - MM Audit Log Viewer ................................................................. 1-9
- Preventative Maintenance .............................................................. 1-10
  - Backing Up & Restoring MAS System Data .................................. 1-11
    - Backing Up MAS System Data .................................................... 1-11
    - Restoring MAS System Data ...................................................... 1-14
  - Rebooting MASs for Routine Maintenance .................................... 1-17

**Chapter 2**  Voice Mail System Configuration (VMSC)
- Voice Mail System Configuration Window ........................................ 2-2
- Voice Mail Domain Nodes & MAS Nodes ........................................... 2-4
- VMSC Menu Commands ................................................................. 2-6

**Chapter 3**  VMSC - Voice Mail Domain (VMD) Configuration
- Overview of VMD Configuration in VMSC ....................................... 3-3
  - Adding a New Voice Mail Domain ................................................ 3-12
## Contents

Removing a Voice Mail Domain ................................................................. 3-13
Renaming a Voice Mail Domain ............................................................... 3-14
Changing the Home MAS ............................................................................ 3-15
Sites Dialog Box .......................................................................................... 3-16
   Sites - Site Configuration Dialog Box . .................................................. 3-19
      Setting Preferences for the Telephone or Multimedia Audio Device . ....... 3-21
Adding a Site Group . .................................................................................. 3-22
Adding a Site . ............................................................................................ 3-23
Deleting a Site Group Or a Site ................................................................. 3-25
Sites - Site Properties Dialog Box ............................................................... 3-27
      Site Properties - General Tab ............................................................... 3-29
      Site Properties - TUI Tab ................................................................. 3-30
      Site Properties - Auto Attendant tab ................................................. 3-32
      Site Properties - Auto Attendant Holidays tab ............................... 3-35
      Site Properties - Auto Attendant Keys tab ....................................... 3-36
Telephone User Interface Dialog Box ......................................................... 3-38
      Telephone User Interface - General Tab ........................................... 3-40
      Telephone User Interface - Receptionist Tab ..................................... 3-43
      Telephone User Interface - Time/Greeting Tab ................................. 3-46
      Telephone User Interface - Message Timing Tab ............................... 3-48
      Telephone User Interface - Subscriber Tab ....................................... 3-50
      Telephone User Interface - Caller Tab .............................................. 3-52
      Telephone User Interface - Personal Operator Schedules Tab ............. 3-54
         Schedule Grid .................................................................................. 3-56
      Telephone User Interface - Dial By Name Tab .................................... 3-58
Auto Attendant Dialog Box ......................................................................... 3-59
      Auto Attendant - Attendant Main Menu Editor Tab ............................ 3-62
      Auto Attendant - Holidays Tab ......................................................... 3-65
      Auto Attendant - Time of Day Tab .................................................... 3-66
      Auto Attendant - Language/Key Association Tab .............................. 3-67
Call Me Dialog Box ..................................................................................... 3-69
Notify Me Dialog Box ................................................................................ 3-71
Message Waiting Indicator Dialog Box ....................................................... 3-73
      Message Waiting Indicator - General Tab .......................................... 3-75
      Message Waiting Indicator - Update Schedule Tab ............................ 3-77
Start On-Demand MWI Update Dialog Box .............................................. 3-78
Fax Dialog Box ........................................................................................... 3-80
      Fax - Fax Cover Page Dialog Box ...................................................... 3-83
      Fax - Advanced Fax Dialog Box ....................................................... 3-84
      Fax - Access Codes Dialog Box ....................................................... 3-85
      Microsoft Fax Printer Configuration ............................................... 3-86
Security Roles Dialog Box ......................................................................... 3-88
Create/Copy/Rename Roles Dialog Box ..................................................... 3-92
Chapter 4  VMSC - Messaging Application Server (MAS) Configuration

Overview of MAS Configuration in VMSC ................................. 4-2
  Adding a New Messaging Application Server .......................... 4-7
  Removing a Message Application Server .............................. 4-8
  Re-deploying Caller Applications .................................. 4-9
  Telephony Configuration Wizard .................................. 4-10
MAS - Messaging Dialog Box .............................................. 4-11
  MAS - Messaging - General Tab .................................. 4-12
MAS - Languages Dialog Box ............................................. 4-13
MAS - Telephony Interface Dialog Box ................................. 4-14
  MAS - Telephony Interface Dialog Box (Analog) .................. 4-15
  MAS - Telephony Interface Dialog Box (QSIG) .................... 4-17
  MAS - Telephony Interface Dialog Box (Set Emulation) .......... 4-19
    MAS - Telephony Interface - ACD Tab (Set Emulation) ....... 4-21
  MAS - Telephony Interface Dialog Box (IP H.323/IP SIP) ....... 4-23
MAS - Port Groups Dialog Box ......................................... 4-25
  Rules for Creating Port Groups .................................. 4-27
  MAS - Port Groups - General Tab .................................. 4-29
  MAS - Port Groups - Usage Tab .................................. 4-31
Contents

MAS - PBX Integration Dialog Box ................................................. 4-33
  MAS - PBX Integration - General Tab ........................................ 4-36
  MAS - PBX Integration - Serial General Tab ................................ 4-38
    MAS - PBX Integration - Serial Settings Dialog Box .................... 4-40
  MAS - PBX Integration - Serial NEC/Ericsson/DMID Tab ................... 4-41
  MAS - PBX Integration - Inband Tab .......................................... 4-43
    MAS - PBX Integration - Inband Protocol Settings Dialog Box .......... 4-47
  MAS - PBX Integration - MWI Settings Dialog Box .......................... 4-50
  MAS - PBX Integration - Remote Tab ......................................... 4-51
  MAS - PBX Integration - QSIG/SE Tab ........................................ 4-52
  MAS - PBX Integration - Avaya C-LAN Tab .................................... 4-54
  MAS - PBX Integration - IP H.323 Tab .................................... 4-56
  MAS - PBX Integration - IP SIP Tab ......................................... 4-59
  MAS - PBX Type Dialog Box .................................................. 4-61
  MAS - Serviceability Dialog Box ............................................. 4-62
    MAS - Serviceability - General Tab ....................................... 4-63
    MAS - Serviceability - Modem Configuration Tab .......................... 4-65
  MAS - Trace File Size Dialog Box .......................................... 4-67

Chapter 5 Visual Voice Editor (Custom Prompts)
  Understanding Custom Prompts .............................................. 5-2
  Understanding the Automated Attendant Prompts ............................ 5-3
  Editing the CustomPrompt.OVF File ......................................... 5-5
  Customizing Prompts .......................................................... 5-7
    Customizing Prompts - Setting Up the Audio Device ................. 5-8
    Customizing Prompts - Recording Customized Prompts ............... 5-10
    Customizing Prompts - Playing Customized Prompts .................... 5-12
    Customizing Prompts - Editing Customized Prompts ................. 5-13
  Deploying the Custom Prompts ............................................. 5-16
  Configuring the Deployed Custom Prompts ................................ 5-17
  Visual Voice Editor (VVE) Window .......................................... 5-19
    Prompts View & Comments View ........................................... 5-21
    Waveform View .................................................................. 5-23
      Waveform View - Toolbar, Info, Overview & Detailed View .......... 5-24
      Waveform View - Voice Player .......................................... 5-26
    All Visual Voice Editor Menus & Icons ................................... 5-28

Chapter 6 Caller Applications Editor
  Understanding Caller Applications .......................................... 6-3
  Using the Caller Applications Software .................................... 6-4
  Planning Your Caller Applications .......................................... 6-6
  Creating & Editing Caller Applications .................................... 6-7
  Importing or Recording Application Prompts .............................. 6-10
Deploying Caller Applications to a VMD .......................................................... 6-13
Creating Associations with the TUI ................................................................. 6-17
Analyzing Deployed Caller Applications ......................................................... 6-20
Modular Messaging Caller Applications Window & Nodes ............................... 6-22
  Modular Messaging Software Caller Apps Node .............................................. 6-25
  Caller Applications Node .............................................................................. 6-26
  Application (Action) Node ............................................................................ 6-28
  Deployed Applications Node ........................................................................ 6-30
  Voice Mail Domain Node .............................................................................. 6-31
  Associations Node .......................................................................................... 6-32
  Application Analysis Node ............................................................................ 6-33
Modular Messaging Software Caller Apps Properties Dialog Box .................... 6-34
Open Caller Application Dialog Box .................................................................. 6-36
New Caller Application Dialog Box ................................................................... 6-38
Add Node Dialog Box ....................................................................................... 6-40
Properties Dialog Box ....................................................................................... 6-43
  Properties - General Tab .............................................................................. 6-44
  Properties - General - Menu Action Type ...................................................... 6-46
  Properties - General - Transfer Action Type ................................................. 6-48
  Properties - General - Goto Action Type ...................................................... 6-50
  Properties - General - Conditional Goto Action Type .................................... 6-51
  Properties - General - Send Message Action Type ....................................... 6-52
  Properties - General - Termination Action Type ......................................... 6-54
  Schedule Grid ................................................................................................. 6-55
  Properties - Prompt Tab ................................................................................ 6-57
    Using the Prompt Recording Device ............................................................ 6-60
  Properties - Application Tab ......................................................................... 6-62
  Properties - Languages Tab .......................................................................... 6-66
Change Key Dialog Box .................................................................................... 6-67
Message Application Server Dialog Box ........................................................... 6-68
Caller Application Deployment Wizard ............................................................ 6-69
Caller Application Undeployment Wizard ......................................................... 6-70
Add Association/Association Properties Dialog Box ........................................... 6-71
Application Analysis Properties Dialog Box ...................................................... 6-73
Analysis Results Properties Dialog Box ............................................................ 6-74

Chapter 7 Reporting Tool

  Understanding Reports ...................................................................................... 7-2
  Enabling Transaction Generation ..................................................................... 7-3
  Selecting a Data Source .................................................................................... 7-4
  Reporting Tool Window .................................................................................... 7-7
  Options Dialog Box .......................................................................................... 7-10
  Hourly Statistics Dialog Box ........................................................................... 7-11
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hourly Statistics Report</td>
<td>7-12</td>
</tr>
<tr>
<td>Login Failures Dialog Box</td>
<td>7-13</td>
</tr>
<tr>
<td>Login Failures Report</td>
<td>7-14</td>
</tr>
<tr>
<td>Port Statistics Dialog Box</td>
<td>7-15</td>
</tr>
<tr>
<td>Port Statistics Report</td>
<td>7-17</td>
</tr>
<tr>
<td>System Usage Dialog Box</td>
<td>7-19</td>
</tr>
<tr>
<td>System Usage Report</td>
<td>7-20</td>
</tr>
<tr>
<td>User Mailbox Statistics Dialog Box</td>
<td>7-23</td>
</tr>
<tr>
<td>User Mailbox Statistics Report</td>
<td>7-25</td>
</tr>
<tr>
<td>Basic Metrics Dialog Box</td>
<td>7-27</td>
</tr>
<tr>
<td>Basic Metrics Report</td>
<td>7-28</td>
</tr>
<tr>
<td>Export Dialog Box</td>
<td>7-30</td>
</tr>
<tr>
<td>Exporting a Report</td>
<td>7-32</td>
</tr>
<tr>
<td>All Reporting Tool Menus &amp; Icons</td>
<td>7-34</td>
</tr>
</tbody>
</table>

### Chapter 8 Operation History Viewer

- Understanding Operation History Events                                 | 8-2 |
- Enabling the Collection of Operation History Events                    | 8-3 |
- Selecting a Data Source & ODBC Tracing                                | 8-4 |
- Creating, Viewing & Exporting Sessions                                | 8-8 |
- Operation History Viewer Window                                       | 8-14 |
- Session Properties Dialog Box                                          | 8-17 |
- Event Properties Dialog Box                                           | 8-20 |
- Options Dialog Box                                                     | 8-21 |
  - Options - Events View Tab                                            | 8-22 |
  - Options - Columns Tab                                                | 8-23 |
  - Options - Text Export Tab                                            | 8-24 |
- Values Dialog Box                                                      | 8-25 |
- Export Operation History Events Dialog Box                             | 8-26 |
- All Operation History Viewer Menus & Icons                            | 8-27 |

### Chapter 9 System Performance Monitoring

- Port Monitor                                                          | 9-2 |
- Message Application Servers Dialog Box                                | 9-3 |
- Port Monitor Window                                                   | 9-4 |
- Port Monitor - Disabling/Enabling Ports                               | 9-6 |
- Port Monitor - Toolbar & Menus                                        | 9-7 |
- Dialogic Line Tester (Dialogic Analog, Set Emulation & QSIG)          | 9-8 |
- Performance Monitoring - Modular Messaging Counters                   | 9-10 |
- Adding Modular Messaging Counters                                     | 9-11 |
- Descriptions of the Modular Messaging Counters                        | 9-12 |
  - MM MAS                                                               | 9-13 |
  - MM MAS MWI Activity                                                  | 9-14 |
Contents

MM MAS Service ................................................................. 9-15
MM MAS Voice Port ............................................................ 9-15
MM MWI Server ................................................................. 9-15
MM MWI Server Queue ......................................................... 9-15

Chapter 10 MM Audit Log Viewer

MAS Auditing Overview ....................................................... 10-2
MM Audit Log Viewer Window ............................................... 10-4
   Event Nodes ................................................................. 10-6
   Events List ................................................................. 10-7
Connect to MM Audit Database Dialog Box ......................... 10-8
Properties Dialog Box ......................................................... 10-9
Event Properties Dialog Box ................................................. 10-11

Chapter 11 MAS Event, Error & Alarm Logs

Overview of MAS Event, Error & Alarm Logs ......................... 11-2
Displaying MAS Event & Error Logs ..................................... 11-3
Displaying MAS Alarm Logs ................................................ 11-4

Appendix A: MAS Alarms

MAS Alarms - CM (Call Me) ................................................... A-3
   MAS Alarm - CM CALLME 1 ........................................... A-3
MAS Alarms - MM (Mailbox Monitor) ..................................... A-4
   MAS Alarm - MM IMAPI 1 ............................................. A-5
   MAS Alarm - MM IMAPI 2 ............................................. A-6
   MAS Alarm - MM PERF 17 ............................................. A-7
   MAS Alarm - MM PERF 18 ............................................. A-8
MAS Alarms - MT (Maintenance) ........................................... A-9
   MAS Alarm - MT ABS_PROC 1 ....................................... A-11
   MAS Alarm - MT ABS_PROC 2 ....................................... A-12
   MAS Alarm - MT ABS_PROC 3 ....................................... A-13
   MAS Alarm - MT ABS_PROC 4 ....................................... A-14
   MAS Alarm - MT ABS_PROC 5 ....................................... A-15
   MAS Alarm - MT ABS_PROC 6 ....................................... A-16
   MAS Alarm - MT ABS_PROC 7 ....................................... A-17
   MAS Alarm - MT ABS_PROC 8 ....................................... A-18
   MAS Alarm - MT ALARM_ORIG 0 .................................... A-19
   MAS Alarm - MT ALARM_ORIG 1 .................................... A-20
   MAS Alarm - MT OHDB 1 ............................................. A-21
   MAS Alarm - MT PERF 6 .............................................. A-22
   MAS Alarm - MT PERF 7 .............................................. A-23
   MAS Alarm - MT PERF 10 ............................................. A-24
   MAS Alarm - MT PERF 19 ............................................. A-25
   MAS Alarm - MT PERF 24 ............................................. A-26
## Contents

MAS Alarm - VS OPHIST 1 ................................................................. A-68
MAS Alarm - VS PERF 1 ................................................................. A-69
MAS Alarm - VS PERF 2 ................................................................. A-70
MAS Alarm - VS PERF 3 ................................................................. A-71
MAS Alarm - VS PERF 4 ................................................................. A-72
MAS Alarm - VS PERF 11 ............................................................... A-73
MAS Alarm - VS PERF 12 ............................................................... A-74
MAS Alarm - VS PERF 20 ............................................................... A-75
MAS Alarm - VS PORT 0 ................................................................. A-76
MAS Alarm - VS PORT 1 ................................................................. A-77
MAS Alarm - VS PORT 2 ................................................................. A-78
MAS Alarm - VS PORT 3 ................................................................. A-79
MAS Alarm - VS PORT 4 ................................................................. A-80
MAS Alarm - VS PORT 5 ................................................................. A-81
MAS Alarm - VS PORT 6 ................................................................. A-82
MAS Alarm - VS PORT 7 ................................................................. A-83
MAS Alarm - VS SERVICE 6 ........................................................... A-84
MAS Alarm - VS SHUTDOWN 1 ........................................................ A-85
MAS Alarm - VS SPOOL 1 ............................................................. A-86
MAS Alarm - VS SWLINK 1 ........................................................... A-87
MAS Alarm - VS VER_CHK ............................................................. A-88
MAS Alarm - VS VOICE 1 ............................................................... A-89
MAS Alarm - VS VOICE 2 ............................................................... A-90
MAS Alarm - VS VOICE 3 ............................................................... A-91
MAS Alarm - VS VOICE 4 ............................................................... A-91
MAS Alarms - Auditing ............................................................... A-92
MAS Alarm - AS WINEVT 1858 ....................................................... A-93
MAS Alarm - AS WINEVT 1860 ....................................................... A-94
MAS Alarm - AS WINEVT 1861 ....................................................... A-95
MAS Alarm - AS WINEVT 1862 ....................................................... A-96
MAS Alarm - AS WINEVT 1863 ....................................................... A-97

### Appendix B: Examples of Caller Applications

Example 1: Alternative “Auto Attendant” Main Menu ............................. B-2
Example 2: Call Transfer Using Dial By Name ...................................... B-10
Example 3: Automated Fax Attendant ................................................. B-13
Example 4: Shared Extension ......................................................... B-15
Example 5: Non-Resident Subscribers .............................................. B-20
Example 6: Bulletin Boards & Daily Announcements .......................... B-22
A Word to AUDIX Users ............................................................... B-25

### Appendix C: Modular Messaging (MM) Services

Stopping/Restarting a Modular Messaging Service ............................. C-3
Preface

This is a reference guide for administering the Avaya Modular Messaging software on a Messaging Application Server (MAS). This guide provides descriptions of each control on each screen of the software for configuring the MAS and Voice Mail Domain (VMD). It also gives instructions for other related tasks, like running diagnostic tools.

Audience

This guide is intended for use by system administrators. It assumes familiarity with message store server administration. The audience should also have a basic understanding of Avaya Modular Messaging concepts, as outlined in the Modular Messaging documentation.

Modular Messaging Documentation

The documentation library available on the support.avaya.com Web site contains all documentation about Avaya Modular Messaging, including instructions for administration, installation, and maintenance.

For Private Branch Exchange (PBX) integration documentation, see the configuration notes available from the Modular Messaging support representative or from the Avaya Support Center at http://www.avaya.com/support. Configuration notes are general guidelines that provide integration information for several types of PBXs and fax devices. They include comprehensive step-by-step instructions on various tasks including configuring the Modular Messaging system for PBX integration and the related PBX programming.

Modular Messaging Support

For support and up-to-date information on Avaya Modular Messaging, visit your Avaya Support Center at http://www.avaya.com/support.
Chapters Included in this Guide

- **Chapter 1**, "Introduction to the Messaging Application Server (MAS)'.
- **Chapter 2**, "Voice Mail System Configuration (VMSC)'.
- **Chapter 3**, "VMSC - Voice Mail Domain (VMD) Configuration'.
- **Chapter 4**, "VMSC - Messaging Application Server (MAS) Configuration'.
- **Chapter 5**, "Visual Voice Editor (Custom Prompts)'.
- **Chapter 6**, "Caller Applications Editor'.
- **Chapter 7**, "Reporting Tool'.
- **Chapter 8**, "Operation History Viewer'.
- **Chapter 9**, "System Performance Monitoring'.
- **Chapter 10**, "MM Audit Log Viewer"
- **Chapter 11**, "MAS Event, Error & Alarm Logs'.
- **Appendix A**, "MAS Alarms".
- **Appendix B**, "Examples of Caller Applications".
- **Appendix C**, "Modular Messaging (MM) Services".
- **Appendix D**, "Glossary".
Introduction to the Messaging Application Server (MAS)

This chapter introduces Messaging Application Server (MAS) administration, diagnostic, and reporting tools.

Topics included in this chapter:

- The Messaging Application Server on page 1-2.
- System Administration Tools on page 1-4.
- Diagnostic and Reporting Tools on page 1-7.
- Preventative Maintenance on page 1-10.
- Backing Up & Restoring MAS System Data on page 1-11.
- Rebooting MASs for Routine Maintenance on page 1-17.
The Messaging Application Server

The Messaging Application Server (MAS) provides an interface between the message store (and directory) and the telephone system. In older documentation, the MAS is sometimes referred to as the “voice server”.

A Modular Messaging system consists of at least one MAS and an Avaya-produced Message Store Server (Avaya MSS). Modular Messaging supports a maximum of five MAS units in a voice mail domain; plus a standalone supplementary server.

In this release, all new installations of the MAS software reside on the Avaya-provided S8730 server platform running Microsoft Windows 2003 R2 Server Appliance Kit. The MAS software of the upgraded Modular Messaging releases can reside on the Avaya-provided S3500 server platform.

Avaya Modular Messaging Release 5.1 introduces a new feature, MultiSite, through which you can use a single Modular Messaging system to serve subscribers at multiple locations. With MultiSite, MASs in a single Voice Mail Domain (VMD) communicate with multiple PBXs possibly with different dial plans, in different locations. MultiSite enables you to use a single Modular Messaging system consisting of many MASs to service a global organization. With MultiSite you can group distributed Modular Messaging sites under a single Voice Mail Domain (VMD).

In a MultiSite-enabled environment, the MASs are co-located with the Avaya MSS server in a data center, but the subscribers can be anywhere. The MASs communicate through the WAN with distributed SIP gateways that are installed near the PBXs at the various sites to service the subscribers. All MASs in the voice mail domain can handle requests from subscribers associated with any site and from any configured switch.

Logging on to a Messaging Application Server

As a customer administrator, you normally use the customer account when administering an MAS. This account is created on your Active Directory during installation and applies to each MAS in your Modular Messaging system.

Opening Messaging Application Server Programs

To open the administration, diagnostic, and reporting tools, click the Start > Programs > Avaya Modular Messaging menu on the Windows desktop.

Modular Messaging Services

There are a number of Avaya Modular Messaging services which can be managed from the standard Windows Services dialog box.
Each enabled service must have a startup type of **Automatic** and show a status of **Started**.

For a list of the Modular Messaging services, and information on how to stop and start these services, see [Appendix C, Modular Messaging (MM) Services](#).
System Administration Tools

The following administration tools can be used to configure the Avaya Messaging Application Server (MAS): **Voice Mail System Configuration**, **Visual Voice Editor**, **Caller Application Editor**.

Voice Mail System Configuration

The **Voice Mail System Configuration** tool has a collection of dialog boxes for configuring and maintaining the voice mail system. You can centrally configure properties that are shared across MASs grouped in a voice mail domain. Any changes made to a voice mail domain’s properties are then updated and replicated automatically to all MASs in the domain.

For more information, see:
- Chapter 2, “Voice Mail System Configuration (VMSC)”.
- Chapter 3, “VMSC - Voice Mail Domain (VMD) Configuration”.
- Chapter 4, “VMSC - Messaging Application Server (MAS) Configuration”.

Visual Voice Editor

The **Visual Voice Editor** provides a graphical user interface for recording company prompts for use by the automated attendant. Customized prompts can be recorded using the local multimedia capabilities on a personal computer. The **Visual Voice Editor** displays audio data as a waveform to enable precise editing of a prompt.

For more information, see Chapter 5, “Visual Voice Editor (Custom Prompts)”.

Caller Applications Editor

You can use the **Caller Applications Editor** to customize the MAS Telephone User Interface (TUI) by creating additional levels of menus and prompts. It is added to the Avaya Modular Messaging menu during installation.

For more information, see:
- Chapter 6, “Caller Applications Editor”.
- Appendix B, Examples of Caller Applications.
Password Policy Editor

You can use the **Modular Messaging Password Policy Editor** to ensure the compatibility of subscriber password policies on all client machines in the voice mail domain. This is necessary when adding new client machines to an existing installation.

The password policy in the voice mail domain must be at least as low as the oldest clients. For example, if you have a system installed with Modular Messaging Release 3.0, and you add machines installed with Release 5.0, the Password Policy must be set to 3.0.

Launching the Application

You can launch the executable from the **Avaya_Support** directory, under **Tools\PasswordPolicyEditor\PasswordPolicyEditor.exe**.

Configuring the Screen Controls

- The check boxes are for information only. They are selected or deselected based on the VMD default configuration setting.

- **[pwd_numeric]** Must contain digits (0 .. 9) only  Subscribers must set passwords with numeric digits only.

- **[pwd_leadingzero]** Must not start with 0  Subscribers must not set passwords starting with the numeric digit 0.

- **[pwd_repeated]** Must not be the same character, repeated  Subscribers must not set passwords containing a repeated digit. For example, 4227.

- **[pwd_consecutive]** Must not be an ascending or descending sequence  Subscribers must not set passwords that have sequential digits, either in ascending or descending order. For example, 1234, or 4321.

- **[pwd_length]** Must be at least as long as the VMD minimum  Subscribers must not set passwords that are shorter than the minimum length configured for the voice mail domain.

---

**Note:** The minimum is set via the Voice Mail System Configuration application, Telephone User Interface dialog box, Subscriber tab, Minimum Password Length field. See **VMSC - VMD - Telephone User Interface - Subscriber Tab** on page 3-50.

- **[pwd_notsameasmailbox]** Must not be the same as the mailbox number  Subscribers must not set passwords that are identical to their mailbox numbers.
— [pwd_notreverseofmailbox] Must not be the reverse of the mailbox number  
  Subscribers must not set passwords that are the sequential reverse of their mailbox numbers.

— [pwd_notsameaspreviousn] Must not be the same as the previous password(s)  
  Subscribers must not set their new passwords to be exactly the same as their previous passwords.

Each subscriber has a user profile containing a list of their previous passwords.

**Note:** The number of previous passwords stored in the user profile is set via the Voice Mail System Configuration application, Telephone User Interface dialog box, Subscriber tab, Number of Previous Passwords Disallowed field.

— [pwd_updatefrequency] Must not be changed too frequently  
  Subscribers must not change their passwords at less than 2 minute intervals. This is to guard against unauthorized access by malicious parties.

**VMD default configuration** You can select the default Modular Messaging configuration for all password policies in the voice mail domain. You should select the oldest release that is installed on a machine in your voice mail domain.

The current options are: MM 1.1, MM 2.0, MM 3.0, MM 3.1, MM 4.0, or 5.0. 5.1. These policies are preset for you by Avaya and are displayed in the check box settings above.
Diagnostic and Reporting Tools

The following diagnostic and reporting tools are provided: Reporting Tool, Operation History Viewer, Port Monitor, Performance Monitor - Modular Messaging Counters, Modular Messaging Snapshot Utility, and MM Audit Log Viewer.
Reporting Tool

Using the Reporting Tool, you can generate a number of reports for monitoring voice mail system usage, planning capacity, and tracking security. Once you have generated a report, you can view it on the screen or print it for easy reference. You can also export a report to many popular file formats or attach it to a message sent using a MAPI-enabled e-mail system.

For more information, see Chapter 7, "Reporting Tool".

Operation History Viewer

Using the Operation History Viewer, you can view events generated by voice mail system activity and logged in the operation history database. By creating a “session”, you restrict the events to only those that meet your criteria. You can view live events as they are added to the operation history database, or view historical events.

For more information, see Chapter 8, "Operation History Viewer".

System Performance Monitoring Tools

Using the following diagnostic tools, you can check the performance of MASs: Port Monitor and Performance Monitoring - Modular Messaging Counters.

For more information, see Chapter 9, "System Performance Monitoring”

Port Monitor

The Port Monitor provides a graphical user interface for checking and changing the status of ports on an MAS.

Performance Monitoring - Modular Messaging Counters

Modular Messaging exports a variety of Performance Counters through the Windows Performance Monitoring API, which can be used to gauge the overall status of an MAS at any given time.

Modular Messaging Snapshot Utility

The Modular Messaging Snapshot Utility (MMSnap) is a program that collects information about the system on which it is run, creates a compressed archive, and (optionally) transmits that archive to another system.

The archive is created under the Avaya_Support\Snaps directory of the first fixed drive (usually C:).
Some of the information that the utility collects relates directly to Avaya Modular Messaging; for example, it will collect recent debug log files. The remainder of the information is more general; for example, the name of the system (NetBIOS and fully-qualified domain names).

By default, the Modular Messaging Snapshot Utility runs in interactive mode, in which it displays a graphical user interface that can be used to trigger the snapshot, and to adjust the program’s configuration.

The utility also has a “silent” mode, where it immediately takes a snapshot and then exits, without displaying a user interface. This allows it to be used from command scripts (batch files) or other programs, where human interaction is not required, or not possible. This mode is selected by one of the command line options that the utility supports.

Launching the Application

To launch the Modular Messaging Snapshot Utility click the Start > Programs > Avaya Modular Messaging > Capture Configuration Data menu.

Note: The application is not documented in this guide. It has its own online help file, MMSnap.chm. The help is launched when you press the F1 key on your keyboard.

MM Audit Log Viewer

With MAS Auditing, an audit event is logged whenever a security role-controlled administrative operation is attempted by an MAS.

You can use the MM Audit Log Viewer to view and filter the results of the audit logging.

For more information, see Chapter 10, “MM Audit Log Viewer”.
Preventative Maintenance

To help prevent possible disk problems and minimize disk errors, Avaya recommends that the MAS drive be maintained by running the following Windows maintenance tools:

- **Disk Defragmenter system tool**  This should be run every three months as standard.

  **Note:** This should also be run if the disk fragmentation level exceeds 60%.

- **chkdsk command**  This should be run once a month.
Backing Up & Restoring MAS System Data

This section describes how to back up Messaging Application Server (MAS) data and how to restore data to the MAS.

Backing Up MAS System Data

You can back up data on a Messaging Application Server (MAS) on a regular basis by scheduling an unattended back up, or at any time by performing an attended back up.

You can use the backed-up data to restore data to the MAS. This data includes custom tone files, custom prompt files, deployed caller applications and messages.

Note: There is no back up on a supplementary server.

Backed Up Data

To facilitate back up, the system copies all caller application configuration data stored in *.uma files from C:\Program Files\Avaya Modular Messaging\Vserver\Callerapps to C:\Program Files\Avaya Modular Messaging\Vserver\CABACKUP. This file is then backed up to the Avaya MSS.

There are two backup files: %ComputerName%MASAll.bkf and %ComputerName%MASSingle.bkf. The first MAS, which was installed first as the Domain Controller, gets both the backup files as output. Any subsequent MAS running the MM Messaging Application Server Service only gets %ComputerName%MASAll.bkf:

- %ComputerName%MASAll.bkf  This file is output on the first MAS and any subsequent MASs. It contains:
  - C:\Avaya_Support\Tone_Files\n  - C:\Program Files\Avaya Modular Messaging\Vserver\CustomPrompts.ovf
  - C:\Program Files\Avaya Modular Messaging\Vserver\CustomPrompts_G711.ovf
  - C:\Program Files\Avaya Modular Messaging\Web Subscriber Options\masinfo.cfg
  - C:\Program Files\Avaya Modular Messaging\OpenSSL\AVA\dh1024.pem
  - C:\Program Files\Avaya Modular Messaging\OpenSSL\CommonTrust\AvayaRoot\avayaprca.crt
Introduction to the Messaging Application Server (MAS)

MAS Unattended Back Up

The installation technician administers each MAS to automatically back up MAS data when your Avaya Modular Messaging system is installed.

The MAS performs the unattended backup using the private LAN to copy data from the MAS to the Avaya Message Store Server (Avaya MSS). After the MAS data are copied to the Avaya MSS, the files are backed up again along with critical Avaya MSS system files during the Avaya MSS unattended backup.

A scheduled task runs nightly on the MAS to run a DCT Analyze. The output file is backup.mmdct. This file is stored on C:\Program Files\Avaya Modular Messaging\Install\miscm\cfg. The scheduled backup task copies all *.mmdct files from this folder to the Avaya MSS, along with the normal backup file. The Avaya MSS then backs up the \mss1\masbackup shares.

**Note:** The scheduled MAS unattended backup overwrites the backed-up MAS data each night. If you want to restore any data from a previous day, such as the previous version of a custom tone file or prompt, you must restore the data before the nightly backup occurs.

The MAS unattended backup is usually scheduled to run one hour before midnight. You can reschedule this time, if it does not meet the needs of your company.

- Do not schedule MAS unattended backups to occur between midnight and 4 AM. This avoids any conflict with important system audits that run each night at midnight. Also, the unattended backup for the complete Modular Messaging system runs each night at 3:05 AM.

- Schedule MAS unattended backups to occur on a daily basis. Do this to ensure that you have a backup of the most recent MAS files.
If your Modular Messaging System contains more than one MAS, schedule each MAS unattended backup to occur at a different time. Avaya recommends you use 15-minute intervals, with the backup for each subsequent MAS running 15 minutes earlier than the one before. For example, schedule the unattended backup for your first MAS to occur 1 hour before midnight. Schedule the unattended backup for the second MAS to run at 10:45 PM and for the third MAS to run at 10:30 PM.

Procedure 1: Rescheduling the MAS Unattended Backup

1. On the Desktop, double-click the **Scheduled Tasks** icon. The system displays the **Scheduled Tasks** window.

2. Right click the backup task and select **Properties**.

3. Select the **Schedule** tab.

4. Change the time and frequency settings as needed.

5. Click **OK** to save the changes.

   You are prompted to re-enter the password of the account under which the scheduled task will run, that is for example, privdom1\dom-admin.

6. Enter the password and click **OK**.

7. After you update all tasks as required, close the **Scheduled Tasks** window.

Procedure 2: Performing an MAS Attended Back Up

You can back up MAS data at any time by performing an attended backup. You might want to do an attended backup to save new data. For example, if you create or modify custom tone files or prompts, you might want to do an attended backup to save your work.

1. On the Desktop, double-click the **Scheduled Tasks** icon. The system displays the **Scheduled Tasks** window.

2. Right click the backup task and select **Run**.

   The **Status** column shows the task as running, and the system immediately starts to copy data from the MAS to the Avaya Message Store Server (Avaya MSS) using the private LAN. When the backup is complete, the **Status** column goes blank.

3. Press the F5 key to refresh the **Scheduled Tasks** window and update the display.
Restoring MAS System Data

These procedures concern restoring MAS system data from the backup files in a scenario where some files have been accidentally corrupted and you need to restore the previous settings.

**Note:** The *.mmdct files would only be used in a disaster recovery scenario. In this instance, you should contact Avaya Technical Support to retrieve them.

1. Stop all Modular Messaging services on the MAS.
2. Follow "Procedure 1", below, to restore backed-up MAS data.
3. Follow "Procedure 2", below, to restore deployed Caller Applications.
4. Restart all Modular Messaging services on the MAS.

**Procedure 1: Restoring the Backed-Up MAS Data**

1. Map to the backup drive for this MAS on the Avaya MSS:
   a. On the desktop, right-click **My Computer** and select **Map Network Drive**.
   b. In the **Map Network Drive** window, in the **Folder** field, type `\mss1\masbackup`.
   c. Clear the **Reconnect at logon** check box.
   d. Click **Connect using a different user name**.
   e. In the **Connect As** window, for **User name**, enter the Windows domain name and the domain administrator account name in the format `domain\account name`. For example, type `privdom1\dom-admin`.
   f. Enter the password for this account. Click **OK**.
   g. In the **Map Network Drive** window, click **Finish**.
   
   The system opens a window to the designated drive letter, such as `Z:`.

2. Double-click the **Backup** icon on the desktop.

3. In the **Backup Utility** window, on the **Welcome** tab, click **Restore Wizard**.

4. On the **Welcome** screen for the **Restore Wizard**, click **Next**.
5. On the **What to Restore** screen, click **Browse**.
   a. In the **Open Backup File** window, click **Browse**.
   b. In the **Select file to catalog** window, under **Look in**, navigate to the mapped drive.
   c. Double-click on the backup file. If this is the first MAS and you wish to restore Caller Application *.uma files, select the MYMAS1MASSingle.bkf file. On any MAS, choose MYMAS1MASAll.bkf to restore other data files.
   d. In the **Open Backup File** window, click **OK**.
      The system returns to the **What to Restore** screen.

6. Verify that the system displays the full name of the MAS backup file in the right pane under **Media Location**.

7. In the left pane under **Items to restore**, expand **File**.
   a. Expand the entry for the daily backup of this MAS. For example, **Daily Backup of MYMAS1**.
   b. Expand **C:**

8. Select the specific folders and files to restore as follows:
   a. Click the check box next to **Avaya_Support**. This folder includes the **Tone_Files** folder, which contains any custom tone files.
   b. Expand the folders **Program Files > Avaya Modular Messaging > VServer**.
   c. Select **VServer** in the left pane so that the folder is highlighted.
   d. In the right pane, under **Name**, click the check box next to each of the items that you want to restore:
      - **CABACKUP folder** Contains deployed Caller Applications folders and *.uma files
      - **Custom prompt files** These are in the VServer directory, if any are present. For example, CustomPrompts.ovf and CustomPrompts_G711.ovf.

      **Note:** These files are always present on an MAS but this restores any customized versions that were backed up.

   e. Click **Next**.

9. On the **Completing the Restore Wizard** screen, click **Advanced**.
   a. On the **Where to Restore** screen, select **Original location**. Click **Next**.
   b. On the **How to Restore** screen, select **Replace existing files**. Click **Next**.
c. On the Advanced Restore Options screen, verify the following settings before clicking Next:

- Click the Restore security and Restore junction points, not the folders and file data they reference check boxes.
- Leave Preserve existing volume mount points selected.

10. On the Completing the Restore Wizard screen, review the restore information. Click Finish.

The Restore Progress window displays restore information.

11. When the data restoration is complete, close the Restore Progress window.


13. Disconnect the mapped drive:

   a. On the desktop, right-click My Computer and select Disconnect Network Drive.

   b. In the Disconnect Network Drives window, under Network Drives, select the mapped drive \mss1\masbackup. Click OK.

   **Note:** You must disconnect the mapped drive, or automatic nightly backups might fail.

---

**Procedure 2: Restoring Deployed Caller Applications**

If Caller Applications must be restored on this MAS, run the Caller Applications restore script:

1. Follow “Procedure 1”, above, to ensure that the CABACKUP folder is restored (see Step 8d).

2. Click Start > Run to open a Command prompt window.

3. In the Run window Open field, type the following and press Enter:

   C:\Avaya_Support\CMD\CARestore.bat

A command window opens. The script copies all previously deployed Caller Applications to the server. The script takes a few seconds to run.

**Note:** Before copying the Caller Applications, the script stops the MM Message Application Server Service, if it has not already been stopped.
Rebooting MASs for Routine Maintenance

Messaging Application Servers (MASs) must be rebooted as part of routine administration and ongoing maintenance.

Reboot Frequency

You must reboot your MASs at regular intervals. The exact period depends on your system. See your Maintenance Checklist for details.

Disabling Alarming Before a Reboot

Before you reboot an MAS, you should disable alarming on the Avaya MSS.

Once the MAS is back up and running, go to the Alarm Log to verify that the alarm has been resolved. This normally takes about 5 minutes. Then reactivate the alarming on the Avaya MSS.

For more information, see Chapter 11, “MAS Event, Error & Alarm Logs” and the Avaya Modular Messaging MSS Administration Guide.

Note: If you reboot the Avaya MSS, you should first disable alarming on the MAS. For the setting to disable alarming, see Serviceability - General Tab on page 3-191.

Rebooting Multiple MAS Systems

For a Modular Messaging system with multiple MASs, you must reboot the primary MAS first, then reboot each of the other MASs in any order. You must reboot one MAS at a time, waiting for each to come back before rebooting the next.

The reboot of each MAS should be an orderly shutdown and restart.
Voice Mail System Configuration (VMSC)

This chapter gives an overview of the Voice Mail System Configuration application, which typically runs on a Messaging Application Server (MAS).

**Note:** Avaya recommends that you run only one instance of Voice Mail System Configuration at a time in the voice mail domain.

**Overview Topics:**
- [Voice Mail System Configuration Window](#) on page 2-2.
- [Voice Mail Domain Nodes & MAS Nodes](#) on page 2-4.
- [VMSC Menu Commands](#) on page 2-6.

**Other Main Chapter Topics:**
- [Overview of VMD Configuration in VMSC](#) on page 3-3.
- [Overview of MAS Configuration in VMSC](#) on page 4-2.
Voice Mail System Configuration Window

You can use the Voice Mail System Configuration (VMSC) application to define how Messaging Application Servers (MASs) in a Voice Mail Domain (VMD) interact with other parts of the messaging environment.

Notes:

- Avaya recommends that you run only one instance of Voice Mail System Configuration at a time in the voice mail domain.


On your Windows desktop, click the Start > Programs > Avaya Modular Messaging > Voice Mail System Configuration menu to launch the Voice Mail System Configuration window. See Figure 2-1, below.

The Voice Mail System Configuration window has a tree structure so that you can access configuration screens for each voice mail domain and each MAS within the voice mail domain. Properties can be configured on three levels. At Voice Mail Domain level properties are shared across MAS groups in a voice mail domain. At Message Application Server level properties are specific to an MAS. In a MultiSite-enabled voice mail domain, the properties can also be configured for each site. See Voice Mail Domain Nodes & MAS Nodes on page 2-4.

For an overview of the MultiSite feature and a detailed description of the concepts underlying MultiSite, such as sites and translation rules, see Avaya Modular Messaging MultiSite Guide.

The window has a top menu bar and some right-click menus. These are enabled depending on which node is selected in the tree. See VMSC Menu Commands on page 2-6.
Voice Mail Domain Nodes & MAS Nodes

The **Voice Mail System Configuration** (VMSC) window has a tree structure so that you can access configuration screens for each voice mail domain and each Messaging Application Server (MAS) within the voice mail domain.

**Expanding the Nodes of the VMSC Window**

1. In the **Voice Mail System Configuration** window, if it is not already expanded, double-click **Voice Mail Domains**.

2. Double-click the appropriate voice mail domain. This expands the tree to show all the available voice mail domain nodes. One of these nodes is **Message Application Servers**.

3. Double-click **Message Application Servers**.

4. Double-click the appropriate MAS under the **Message Application Servers** branch. This expands the tree to show all the available MAS nodes.

**Properties can be configured on three levels:**

- **Voice Mail Domain Level**  The properties are shared across MAS groups in a voice mail domain. Configuration is carried out centrally. Any changes made to a voice mail domain’s properties are updated and replicated automatically to all MASs in the voice mail domain.

  Double-click each of these nodes to launch the voice mail domain screens: **Sites, Telephone User Interface, Auto Attendant, Call Me, Notify Me, Message Waiting Indicator, Fax, Security Roles, Security, Auditing, PBXs, PBX Integration, Languages, Audio Encoding, Dialing Rules, Messaging, Serviceability, Licensing and Tracing System**.

  For an overview of these nodes, followed by detailed descriptions of the voice mail domain screens, see **Overview of VMD Configuration in VMSC** on page 3-3.

- **Message Application Server Level**  The properties are specific to an MAS. Configuration is carried out for each MAS in a voice mail domain.

  Double-click each of these nodes to launch the MAS screens: **Messaging, Languages, Telephony Interface, Port Groups, PBX Integration, PBX Type, Serviceability and Trace File Size**.

  For an overview of these nodes, followed by detailed descriptions of the MAS screens, see **Overview of MAS Configuration in VMSC** on page 4-2.
- **Site Level** The properties are specific to a Modular Messaging site, if MultiSite is enabled for a voice mail domain. Configuration is carried out for each site in a voice mail domain.

When the MultiSite feature is enabled, the following settings specific to the voice mail domain are removed: **Telephone User Interface** - certain settings on the **Receptionist** tab and **Time/Greeting** tab, **Automated Attendant**, and **Languages**. The properties are instead configured for each site. Double-click the **Sites** node to launch the **Sites Configuration for <VMD name>** screen. Click **Properties** to configure the properties for each site.

For an overview of the **Sites** node, followed by detailed descriptions of the **Sites** screens, see **Sites Dialog Box** on page 3-16.
VMSC Menu Commands

The Voice Mail System Configuration window has a top menu bar and some right-click menus. These are enabled depending on which node is selected in the tree (see Voice Mail Domain Nodes & MAS Nodes on page 2-4).

The following menu commands are available along the top of the Voice Mail System Configuration window. Some are grayed out unless you have selected a particular node in the tree. Certain menu commands are also available when you right-click a particular node in the Voice Mail System Configuration window’s tree.

File - Top Level Menu

- File > Exit Closes down the Voice Mail System Configuration application.

Edit - Top Level Menu (& Right-Click)

- Edit > New Voice Mail Domain Opens the Add New Voice Mail Domain dialog box, where you can add a new voice mail domain.
  
  This command is also available when you right-click the Voice Mail Domain node in the tree.

  **Note:** If you are using an Avaya message store server, you can only have one voice mail domain.

  For more information, see Adding a New Voice Mail Domain on page 3-12.

- Edit > Remove Voice Mail Domain Removes the voice mail domain selected in the tree.
  
  This command is only available when a voice mail domain node is selected in the tree. You can also right-click the node to select the command.

  For more information, see Removing a Voice Mail Domain on page 3-13.

  **Note:** Removing or renaming a voice mail domain can have serious repercussions for your Modular Messaging system.

- Edit > Rename Voice Mail Domain Opens the Rename Voice Mail Domain dialog box, where you can rename the selected voice mail domain.
  
  This command is only available when a voice mail domain node is selected in the tree. You can also right-click the node to select the command.
For more information, see Renaming a Voice Mail Domain on page 3-14.

- **Edit > Refresh Domain Languages**  Refreshes the languages for the selected voice mail domain. This should be used, if you have installed a language and cannot see it for any reason.

  This command is only available when a voice mail domain node is selected in the tree. You can also right-click the node to select the command.

- **Edit > Add Message Application Server**  Opens the Add New Message Application Server dialog box, where you can add a new MAS to the voice mail domain.

  This command is also available when you right-click the Message Application Servers node in the tree.

  For more information, see Adding a New Messaging Application Server on page 4-7.

- **Edit > Remove Message Application Server**  Removes the selected MAS from the voice mail domain.

  This command is only available when an MAS node is selected in the tree. You can also right-click the node to select the command.

  For more information, see Removing a Message Application Server on page 4-8.

- **Edit > Re-deploy Caller Applications**  Re-deploys caller applications already deployed on the selected MAS to any new MASs in the voice mail domain.

  This command is only available when an MAS node is selected in the tree. You can also right-click the node to select the command.

  For more information, see Re-deploying Caller Applications on page 4-9.

- **Edit > Add PBX Type**  Opens the Add New PBX dialog box, where you can add new PBXs to the voice mail domain.

  This command is only available when the PBXs node is selected in the tree. You can also right-click the node to select the command.

  For more information, see Add New PBX Dialog Box on page 3-118.

- **Edit > Remove PBX Type**  Removes the selected PBX type from the voice mail domain.

  This command is only available when a PBX type node is selected in the tree. You can also right-click the node to select the command.
- **Edit > Telephony Configuration Wizard**  Launches the Telephony Configuration Wizard for the selected MAS. You can quickly configure the telephony interface, add PBXs, configure a PBX type, and the number of ports/time slots.

  This command is also available when you right-click the MAS node in the tree.

  For more information, see Telephony Configuration Wizard on page 4-10.

- **Edit > Refresh**  Refreshes the Voice Mail System Configuration window.

**Tools - Top Level Menu**

- **Tools > Options**  Opens the Options dialog box, where you can change the home MAS for the voice mail domain.

  For more information, see Changing the Home MAS on page 3-15.

**Telephone User Interface Node - Right-Click Menu**

- **Copy schedule IDs to clipboard**  Copies the names and globally unique identifiers (GUIDs) of all the personal operator schedules to the Windows Clipboard. You can then paste this into a word processing document to view the information.

**Message Waiting Indicator Node - Right-Click Menu**

- **Start MWI Update**  Opens the Start On-Demand MWI Update dialog box, where you can perform an on-demand update of mailboxes by the MWI service.

- **Show MWI Progress**  Show a Progress window during an on-demand MWI update.

  For more information on both these commands, see Start On-Demand MWI Update Dialog Box on page 3-78.

**Security Roles Node - Right-Click Menu**

- **Create New Role**  Opens the Create New Role window, where you can create a new security role.

  The following menu items appear, when you select an existing security role in the tree:

  - **Copy Role**  Opens the Copy Role window, where you can specify a name for a new role, which is a copy of the selected security role.
— **Rename Role**  Opens the **Rename Role** window, where you can rename the selected customer-created security role.

— **Remove Role**  Removes the selected customer-created security role. You are prompted to confirm the deletion.

For more information on all these commands, see [Security Roles Dialog Box](#) on page 3-88.

**Licensing Node - Right-Click Menu**

- **Import License**  Launches the **License Import Wizard**, which guides you through the installation of a permanent license for the system.

- **Copy Host ID to Clipboard**  Copies the selected Voice Mail Domain Identifier (VMDID) to the Windows Clipboard. You must determine the VMDID so that you can obtain the license file.

For more information on both these commands, see [Host ID & License Import Wizard](#) on page 3-204.

- **Feature Codes**  Opens the **Feature Codes** dialog box. Use this dialog box to enter feature strings to enable a certain feature for select users with authorization from Avaya.
VMSC - Voice Mail Domain (VMD) Configuration

This chapter describes how to configure the screens available in the Voice Mail Domains tree displayed in the Voice Mail System Configuration window.

Topics included in this chapter:

- Overview of VMD Configuration in VMSC on page 3-3. This topic describes general voice mail domain configuration in the VMSC. It also gives an overview of the usage of each of the following screens.
  - Sites Dialog Box on page 3-16.
  - Telephone User Interface Dialog Box on page 3-38.
  - Auto Attendant Dialog Box on page 3-59.
  - Call Me Dialog Box on page 3-69.
  - Notify Me Dialog Box on page 3-71.
  - Message Waiting Indicator Dialog Box on page 3-73.
  - Fax Dialog Box on page 3-80.
  - Security Roles Dialog Box on page 3-88.
  - Security - Message Servers Dialog Box on page 3-111.
  - Auditing Dialog Box on page 3-113.
  - PBXs Configuration on page 3-117.
  - PBX Integration Dialog Box on page 3-165.
  - Languages Dialog Box on page 3-166.
Related topics in other chapters:

- Chapter 2, “Voice Mail System Configuration (VMSC)”.
- Overview of MAS Configuration in VMSC on page 4-2.
Overview of VMD Configuration in VMSC

You can configure properties for the selected voice mail domain using the Voice Mail Domains tree in the Voice Mail System Configuration (VMSC) window.

Notes:

- Voice mail domain properties are shared among all Messaging Application Servers (MASs) in the voice mail domain. If you administer a voice mail domain property on an MAS, the changes are propagated to all MASs in the voice mail domain, regardless of which one you administered it on.

- You may be prompted to stop and restart the MM Messaging Application Server service after you have made changes to a property in Voice Mail System Configuration. If so, the changes will not take effect until you do so. See Appendix C, Modular Messaging (MM) Services.

- When configuring a voice mail domain, changes to domain-wide properties may take a few minutes to become effective on all MASs.

- Avaya recommends that you run only one instance of Voice Mail System Configuration at a time in the voice mail domain.

- The nodes you see in the Voice Mail Domains tree in the Voice Mail System Configuration (VMSC) window are controlled by the security roles configured by the system administrator. See Security Roles Dialog Box on page 3-88.

Required Reading

- An overview of the entire Voice Mail System Configuration window. See Chapter 2, “Voice Mail System Configuration (VMSC)”.

- An overview of MultiSite concepts and requirements. See Avaya Modular Messaging MultiSite Guide.

Launching the Application & Opening the VMD Node

1. On your Windows desktop, click the Start > Programs > Avaya Modular Messaging > Voice Mail System Configuration menu. This launches the Voice Mail System Configuration window.

2. If it is not already expanded, double-click Voice Mail Domains, then double-click the appropriate voice mail domain.
Configuring the Voice Mail Domain

- Adding a New Voice Mail Domain on page 3-12.
- Removing a Voice Mail Domain on page 3-13.
- Renaming a Voice Mail Domain on page 3-14.
- Changing the Home MAS on page 3-15.

Configuring Voice Mail Domain Nodes

- **Sites** Use this node to enable the MultiSite feature, configure maximum call costs, sites, site groups, and site-level properties for a voice mail domain. See Sites Dialog Box on page 3-16.

- **Telephone User Interface** Use this node to configure Telephone User Interface (TUI) properties for a voice mail domain.

  Callers and subscribers use the TUI to access the Modular Messaging system over the telephone.

  The **Copy schedule IDs to clipboard** right-click menu command copies the names and globally unique identifiers (GUIDs) of all the personal operator schedules to the Windows Clipboard. You can then paste this into a word processing document to view the information.

  You can use the Telephone User Interface dialog box to configure aspects of many features of the Modular Messaging system. See Telephone User Interface Dialog Box on page 3-38.

  — **General** Use this tab to configure basic TUI properties for a voice mail domain, such as call duration and timeout. You can enable the Automated Attendant, Caller Applications, and the Private Call-Answered Message facility. You can also set properties for subscribers’ mailboxes, such as new mailbox initialization.

  — **Receptionist** Use this tab to configure operator properties for a voice mail domain. You can set up operator mailbox numbers, specify the conditions for transferring a caller to the operator, and allow personal operators for non-local extensions or mailboxes.

  **Note:** In a MultiSite-enabled voice mail domain, the settings for the Default receptionist mailbox number and After hours receptionist mailbox number on the Receptionist tab are disabled. You can configure these properties for each site. See Sites - Site Properties Dialog Box on page 3-27.

  — **Time/Greeting** Use this tab to configure time and greeting properties for a voice mail domain. You can define your organization’s daily business hours and control when certain greetings are played by the Automated Attendant.
Note: In a MultiSite-enabled voice mail domain, the Time/Greeting tab is not displayed. You can configure the time and greeting properties for each site. See Sites - Site Properties Dialog Box on page 3-27.

- **Message Timing** Use this tab to configure message timing properties for a voice mail domain. You can configure the voice message playback controls on the telephone keypad, and specify the number of seconds permitted for recording personalized prompts.

- **Subscriber** Use this tab to configure subscriber properties for a voice mail domain. You can set up message deletion confirmation and configure mailbox password security.

- **Caller** Use this tab to configure caller properties for a voice mail domain. You can permit callers to use directory services and leave multiple messages. You can also set out-calling restrictions to prevent telephone toll fraud.

- **Personal Operator Schedules** Use this tab to configure personal operator schedules for a voice mail domain. You can edit existing schedules and create new schedules.

  If the schedule is associated with a subscriber’s personal operator, then the personal operator replaces the system-wide operator during the times specified in the schedule.

- **Dial by Name** Use this tab to configure the Dial By Name feature for the voice mail domain. With Dial By Name, callers can spell out a recipient’s name on the telephone keypad.

  You can configure the way in which recipients names are stored. If they have given names or family names which are difficult to map to a telephone keypad, you can configure their e-mail addresses instead.

- **Auto Attendant** Use this node to configure the Automated Attendant for a voice mail domain.

  Modular Messaging’s Automated Attendant is used to prompt callers with the system greeting and collect their input, in the form of Dual Tone Multi-Frequency (DTMF) key presses. It can be configured to offer single-digit menu choices, for transfers or quick messages, and use the Dial By Name feature to reach subscribers.

  The Auto Attendant dialog box has four tabs: Attendant Main Menu Editor, Holidays, Time of Day, and Language/Key Association. See Auto Attendant Dialog Box on page 3-59.

  You can use this dialog box to assign Custom Prompts for the Automated Attendant main menu, for special holidays, for different times of day, and in different languages. You can also configure Automated Attendant main menu properties for DTMF key pad numbers.
**Note:** When the MultiSite feature is enabled, the Automated Attendant node is not displayed in the Voice Mail System Configuration tree. The Automated Attendant settings are configured for each site and not for the entire voice mail domain.

- **Call Me**  Use this node to configure Call Me properties for a voice mail domain.

  With Call Me, subscribers can configure the system to call them, at one or more designated numbers, each time they receive a message that meets certain criteria. The subscriber can then log on to the TUI in order to review the message.

  You can use the Call Me dialog box to enable the Call Me feature for the voice mail domain. You can specify the MAS on which the MM Call Me Server service is installed. You can also configure concurrency, interval and retry settings. See Call Me Dialog Box on page 3-69.

- **Notify Me**  Use this node to configure Notify Me properties.

  With Notify Me, subscribers can configure the system to send an e-mail or e-mail client to their pager, each time they receive a message that meets certain criteria. The subscriber can then call the Modular Messaging system in order to review the message.

  You can use the Notify Me dialog box to enable the Notify Me feature for the voice mail domain. See Notify Me Dialog Box on page 3-71.

- **Message Waiting Indicator**  Use this node to configure Message Waiting Indicator (MWI) properties for a voice mail domain.

  With MWI, subscribers can configure the system to alert them, using a lamp indicator on their telephone, or an audible tone (stutter dial-tone), each time they receive a message that meets certain criteria. The indicator is cleared when the message is opened, saved, or deleted using the TUI or a client.

  The Message Waiting Indicator dialog box has two tabs: General and Update Schedule. See Message Waiting Indicator Dialog Box on page 3-73.

  You can use this dialog box to enable the MWI feature. You can specify the MAS on which the MM Message Waiting Indicator Server service is installed, and list any MASs that support MWI. You can configure and enable a schedule for when mailboxes should be updated by the MWI service, and manage the frequency of MWI update requests. You can also configure the system to check MWI lamp states either in the message store or in the local cached MWI database.
If you wish to perform an on-demand update, you must use the Start On-Demand MWI Update dialog box. You can update either a single mailbox, a range, or all mailboxes in the voice mail domain. You can configure the system to check MWI lamp states either in the message store or in the local cached MWI database. You can also set a priority level for the update and view the progress, if you wish. See Start On-Demand MWI Update Dialog Box on page 3-78.

- **Fax** Use this node to configure Fax for a voice mail domain. With Fax, subscribers can send and receive faxes using their mailboxes.

  You can use the Fax dialog box to configure Avaya’s Native Fax Support for a voice mail domain. See Fax Dialog Box on page 3-80.

  With Avaya’s Native Fax Support, you may also need to configure the Microsoft Fax Printer and alter some Registry settings. For more information, see Microsoft Fax Printer Configuration on page 3-86.

- **Security Roles** Use this node to configure Role-Based Access Control (RBAC) for the voice mail domain.

  You can use the Security Roles dialog box to set up the permissions constituting a Modular Messaging Security Role and assign users, groups, or computers to perform that role. See Security Roles Dialog Box on page 3-88.

  There are preset roles for Servers, System Administrator, System Auditor, Subscriber Administrator, Subscriber Auditor and Subscriber Helpdesk; each of these have a limited number of permissions available. You can also create new roles with permissions of your choice.

- **Security - Messaging Servers Administration** Use this node to set up a list of message stores with which the MAS can communicate in the Message Servers dialog box. You can also set up the list of protocols the MAS uses to get subscriber data from the message store. See Security - Message Servers Dialog Box on page 3-111.

- **Auditing** Use this node to configure MAS Auditing for the voice mail domain.

  With MAS Auditing, an audit event is logged whenever a role-controlled administrative operation is attempted by an MAS or supplementary server. User-friendly information is logged as well as the typical system data.

  You can use the Auditing dialog box, General tab, to configure auditing for the voice mail domain.

  You can use the Syslog tab to configure the use of the “syslog” protocol. This allows third-party system administration tools to be used on the Modular Messaging system. See Auditing Dialog Box on page 3-113.
PBXs Use this node to determine the way in which the Private Branch Exchange (PBX) communicates with the voice mail domain. The PBX is sometimes referred to as the “switch”.

You can use the Add New PBX dialog box to add one or more PBXs to the voice mail domain. See Add New PBX Dialog Box on page 3-118.

You can use the PBX Configuration dialog box to configure the PBX voice mail system volume, Dual Tone Multi-Frequency (DTMF) dialing tones, call transfer codes, hangup detection, and intercom paging.

The screens and available settings differ, depending on the type of PBX integration. You will see the appropriate sub-node under PBX in the tree:

— Dialogic Click this sub-node, if you are using Dialogic Analog voice cards. The dialog box has four tabs: General, Call Transfer, Hangup Detection, and Intercom Paging. See PBX Configuration Dialog Box (Dialogic Analog) on page 3-120.

— QSIG Click this sub-node, if you are using Q-Signaling (QSIG) cards. The dialog box has five tabs: General, Transfer/Outcall, Tone Detection, Outgoing Call, and Intercom Paging. See PBX Configuration Dialog Box (QSIG) on page 3-129.

— Set Emulation Click this sub-node, if you are using set emulation cards. The dialog box has four tabs: General, Transfer/Outcall, Tone Detection, and Intercom Paging. See PBX Configuration Dialog Box (Set Emulation) on page 3-138.

— IP H.323 Click this sub-node, if you are using H.323-based IP integration. The dialog box has three tabs: Transfer/Outcall, Tone Detection, and Outgoing Call. See PBX Configuration Dialog Box (IP H.323) on page 3-147.

— IP SIP Click this sub-node, if you are using SIP-based IP integration. The dialog box has four tabs: General, Call Transfer, Tone Detection, and SIP. See PBX Configuration Dialog Box (IP SIP) on page 3-153.

Note: If the MultiSite feature is enabled, you can only add IP SIP PBXs because all MASs in the voice mail domain must use SIP-based IP integration to communicate with the PBX.

PBX Integration Use this node to configure Private Branch Exchange (PBX) integration for the voice mail domain. This determines how the selected PBX type passes call information to the MAS. See PBX Integration Dialog Box on page 3-165.

Use this node to configure SIP-based IP integration.

Languages Use this node to configure languages for a voice mail domain.
You can use the **Languages** dialog box to configure multiple languages for use by the TUI and enable multilingual Text-to-Speech (TTS), if you wish.

You must set a primary language for the voice mail domain. This is played by the TUI, unless instructed otherwise, for example, by caller language selection, or by subscriber mailbox configuration. If multilingual text-to-speech conversion is requested and the language of the text cannot be determined, then this language is used. See **Languages Dialog Box** on page 3-166.

**Note:** When the MultiSite feature is enabled, the primary language is configured for each site and not for the entire voice mail domain. See **Sites - Site Properties Dialog Box** on page 3-27.

- **Audio Encoding** Use this node to configure Modular Messaging audio encoding formats.

  Audio encoding formats determine the way in which audio is recorded on every MAS in the voice mail domain. This, in turn, determines the format of voice messages sent using the TUI and desktop clients. The client applications are then automatically configured to use the selected audio encoding format.

  You can use the **Audio Encoding** dialog box to set up the default audio encoding format and enable support for teletypewriter (TTY) devices in the voice mail domain. See **Audio Encoding Dialog Box** on page 3-168.

- **Dialing Rules** Use this node to configure dialing rules for the voice mail domain.

  With Dialing Rules, local subscribers are given the option to either reply to call-answered messages from remote subscribers, or to return the call. You can configure rules for recognizing the remote subscriber’s calling party number so that the option to return the call is given, and configure the rules for returning that call.

  You can use the **Dialing Rules** dialog box to manage a list of dialing rules configured in the **Telephony Dialing Rule** dialog box. See **Dialing Rules Dialog Box** on page 3-170 and **Dialing Rules - Telephony Dialing Rule Dialog Box** on page 3-173.

- **Messaging** Use this node to configure messaging for the voice mail domain. See **Messaging Dialog Box** on page 3-174.

  — **General** Use this tab to configure the privacy enforcement level for a voice mail domain. You can set the Privacy Enforcement Level to control how the system behaves with respect to subscriber attempts to forward messages marked as private, or attempts to reply to messages with the original private messages attached.
— **Offline Access**  Use this tab to configure Offline Access for a voice
mail domain.

With Offline Access, subscribers can use the TUI to access recently
recorded call-answered messages, even when the message store
server is not accessible. For more information on Offline Access, see
Understanding Offline Access on page 3-180.

You can use the **Offline Access** tab to determine whether
call-answered messages are kept up-to-date in the offline message
store, how long they are kept up-to-date, and how often.

- **Web Subscriber Options**  Use this node to configure the functionality
available to subscribers when they are using the **Web Subscriber Options**
(WSO) application, the **Avaya Voice Player** (AVP), and the local player.

You can also determine the e-mail domains accessible to subscribers
when they are configuring Notify Me, and creating Personal Distribution
Lists (PDLs).

The **Web Subscriber Options** dialog box has two tabs: **General** and
**Email Domain Restriction**. See Web Subscriber Options Dialog Box on
page 3-186.

- **Serviceability**  Use this node to configure serviceability for the voice mail
domain.

The **Serviceability** dialog box has five tabs: **General**, **SNMP Trap
Destinations, Communities, Query Originators**, and **Internet
Proxies**. See Serviceability Dialog Box on page 3-189.

You can use the dialog box to configure the ability of the MAS to
generate logs and notifications related to system errors and alarms. You
can also control voice port service on the MAS.

Notifications can be sent out automatically to one designated support
site, either Avaya Technical Support, your own Network Management
Station (NMS), or a trusted business partner. These notifications are
sent out using Avaya Initialization and Administration System (INADS),
Simple Network Management Protocol (SNMP) traps to an NMS, or
Internet Proxies.

- **Licensing**  Use this node to configure licensing for the voice mail domain.

The **Licensing** dialog box has two tabs: **General** and **Text-to-Speech**.
See Licensing Dialog Box on page 3-201.

You can configure licensing information for the platform, the number of
seats (voice mail-enabled mailboxes), and the number of TTS sessions
per TTS engine. You can also configure the distribution of TTS licenses
across one or more MASs.
When you right-click the **Licensing** node in the **Voice Mail Domain System Configuration** window you can use menu commands to obtain your host ID and import the permanent license for the system. See **Host ID & License Import Wizard** on page 3-204.

- **Tracing System** Use this node to configure the tracing system for the voice mail domain.

  **Note:** If you have not installed a tracing system, this node is not displayed in the **Voice Mail System Configuration** window.

The tracing system is a Windows 2003 service where information about voice mail system activity (operation history events) is logged. These events are dynamically stored in the Operation History database. Periodically, this database is purged and summarized information is stored in the Transaction database.

The **Tracing System** dialog box has three tabs: **General**, **Operation History Collection**, and **Transaction Generation**. See **Tracing System Dialog Box** on page 3-206.

You can use the dialog box to view the tracing server machine name and specify the Home MAS for the tracing system. You can configure operation history database properties for event logging in the voice mail domain, and transaction database properties for transaction logging.

- **Message Application Servers** Use this node to view a list of MASs in the voice mail domain. The node for each MAS expands to show many sub-nodes for configuring that MAS.

  Double-click each of these nodes to launch the MAS screens: **Messaging, Languages, Telephony Interface, Port Groups, PBX Integration, PBX Type, Serviceability** and **Trace File Size**.

  For an overview of each of these nodes, followed by detailed descriptions of the MAS screens, see **Overview of MAS Configuration in VMSC** on page 4-2.
Adding a New Voice Mail Domain

This topic describes how to use the Add New Voice Mail Domain dialog box to add a new voice mail domain.

Important: You can only have one voice mail domain. This is set up at the time of installation. You should not use this command to try to add another.

Launching the Screen

In the Voice Mail System Configuration window, click the Edit > New Voice Mail Domain menu or use the right-click menu.

The system displays the Add New Voice Mail Domain dialog box.

Configuring the Screen Controls

Note: To configure this dialog box, you must be a member of a security role assigned the Voice Mail Domain - Administer task. If you are a member of a role assigned the Voice Mail Domain - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

- **Voice Mail Domain Name** Enter a unique name for the new voice mail domain.
  
  1. When you click OK, you are prompted with the Connect to Message Application Server window.
  
  2. Enter the name of the MAS server which uses a peer message store server in the site in which you wish to create a voice mail domain. You can use the Browse button, if necessary.
  
  3. Click OK. The new voice mail domain then appears in the Voice Mail System Configuration tree.
Removing a Voice Mail Domain

This topic describes how to remove a voice mail domain.

**Important:** Removing a voice mail domain can have serious repercussions for your Modular Messaging system. You can only have one voice mail domain. This is set up at the time of installation. You should not use this command to try to remove it.

**Procedure 1: Removing a Voice Mail Domain**

**Note:** To use this command, you must be a member of a security role assigned the Voice Mail Domain - Administer task. See Security Roles Dialog Box on page 3-88.

1. In the Voice Mail System Configuration window, select a voice mail domain.

2. Click the Edit > Remove Voice Mail Domain menu or use the right-click menu. The system prompts you to confirm this action.

3. When you click OK, you are prompted with the Connect to Message Application Server window.

4. Enter the name of an the MAS server which uses a peer message store server in the site which contains the voice mail domain you wish to remove. You can use the Browse button, if necessary.

5. Click OK. The voice mail domain is then removed from the Voice Mail System Configuration tree.
Renaming a Voice Mail Domain

This topic describes how to use the **Rename Voice Mail Domain** dialog box to alter the name of a voice mail domain.

**Important:** Renaming a voice mail domain can have repercussions for your Modular Messaging system.

**Launching the Screen**

1. In the **Voice Mail System Configuration** window, select a voice mail domain.
2. Click the **Edit > Rename Voice Mail Domain** menu or use the right-click menu.
   
The system displays the **Rename Voice Mail Domain** dialog box.

**Configuring the Screen Controls**

**Note:** To configure this dialog box, you must be a member of a security role assigned the **Voice Mail Domain - Administer** task. If you are a member of a role assigned the **Voice Mail Domain - View** task, you have read-only access to this dialog box. See **Security Roles Dialog Box** on page 3-88.

- **Voice Mail Domain Name** Enter a different unique name for the voice mail domain.
  
  1. When you click **OK**, you are prompted with the **Connect to Message Application Server** window.
  2. Enter the name of an the MAS server which uses a peer message store server in the site which contains the voice mail domain you wish to rename. You can use the **Browse** button, if necessary.
  3. Click **OK**. The voice mail domain then appears with its new name in the **Voice Mail System Configuration** tree.
Changing the Home MAS

This topic describes how to use the Options dialog box to change the home Messaging Application Server (MAS) for the voice mail domain.

The home MAS is any machine in the voice mail domain from which you administer system configuration. You can change the home MAS by providing the Voice Mail System Configuration application with a new MAS name. It may be necessary to do this, if the server or servers that it was previously using are not running or have been removed from the voice mail domain.

Launching the Screen

1. In the Voice Mail System Configuration window, click the Tools > Options menu.

   The system displays the Options dialog box.

Configuring the Screen Controls

Note: To configure this dialog box, you must be a member of a security role assigned the Voice Mail Domain - Administer task. If you are a member of a role assigned the Voice Mail Domain - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

- Home Message Application Server  Enter the name of the new home MAS. You can use the Browse button to locate it.
Sites Dialog Box

**Note:** For a detailed overview of voice mail domain configuration in the **Voice Mail System Configuration** (VMSC) application, see [Overview of VMD Configuration in VMSC](#) on page 3-3.

This topic describes how to use the **Sites** dialog box to configure sites and site groups for the voice mail domain. You can also configure the maximum call costs and enable the MultiSite feature on this dialog box.

**Notes:**

- For more information on the MultiSite feature and the concepts underlying MultiSite, such as sites and translation rules, see *Avaya Modular Messaging MultiSite Guide*.

- You can enable and disable MultiSite using the **Sites** dialog box. The option is not enabled by default. Enabling MultiSite requires careful planning, because when you disable MultiSite, you must configure the site-level settings again to apply to the entire voice mail domain. You must also reconfigure the mailbox length for the voice mail domain.

- To configure this dialog box, you must be a member of a security role assigned the **MultiSite - Administer** task. By default, **MultiSite - Administer** task is not assigned to any role. To enable or disable MultiSite, you must be a member of role assigned the **MultiSite - Enable** task. If you are a member of a role assigned the **MultiSite - View** task, you have read-only access to this dialog box. See *Security Roles Dialog Box* on page 3-88.

- You can configure sites and site groups for a voice mail domain regardless of whether MultiSite is enabled. However, the configurations will take effect only after MultiSite is enabled.

- MultiSite can only be enabled if all MASs in the voice mail domain have Avaya Modular Messaging Release 5.1 software installed.

- MultiSite can only be enabled if all MASs in the voice mail domain are running and available.

- All MASs in the voice mail domain must use SIP-based IP integration to communicate with the PBX.

- In a MultiSite-enabled VMD, you can only add SIP PBXs to a voice mail domain. See *PBX Configuration - SIP Tab (IP SIP)* on page 3-158 and *PBX Integration Dialog Box* on page 3-165.

- Once created, you cannot change the identifier of a site or site-group. See *Sites - Site Configuration Dialog Box* on page 3-19.
Launching the Screen

1. In the **Voice Mail System Configuration** window, click the voice mail domain (VMD).

2. Double-click **Sites**. The system displays the **Sites** dialog box for the selected voice mail domain.

Configuring the Screen Controls

- **Enable MultiSite** Select this option to enable MultiSite for the voice mail domain. In case of a new installation of Avaya Modular Messaging Release 5.1, this check box is selected if MultiSite is enabled when creating a *.mmdct file using the Data Collection Tool (DCT).

- **Costs controlling outbound calls** In a MultiSite-enabled environment, a cost is associated with all outgoing calls. The associated cost is a just a relative value, and it is not meant to be literal. Calls with higher costs are more expensive to make than calls with lower costs.

  The cost of an outgoing call is determined by the following conditions:

  a. The number being dialed.

  b. The outgoing translation rules for the PBX through which the call is being made. The outgoing translation rules are configured using the **Voice Mail System Configuration** (VMSC) application. For detailed instructions for configuring the translation rules see [PBX Configuration - SIP Tab (IP SIP) - Translation Rules Dialog Box](#) on page 3-161.

When a canonical phone number is converted into a switch-native number using the phone number translation rules, a corresponding cost is also determined. If the call cost is less than or equal to the limit that you set in this field, then system dials the number, else the system rejects the call.

The costs specified for outbound calls control whether, for example, a subscriber is allowed to call just the local extensions, or national, international, or premium rate numbers.

Enter appropriate values to configure the costs for outbound calls in the following fields:

- **Maximum costs for Automated Attendant outcalls** These costs determine the numbers that can be dialed by external callers using the Automated Attendant. Enter a number between 0 and 10000. The default is 100.

- **Maximum costs for subscriber outcalls** These costs determine the numbers that can be dialed by the subscribers. Enter a number between 0 and 10000. The default is 100.

For example, if 100 is the cost associated with internal calls, then subscribers are only allowed to call local extensions.
Note: Avaya recommends that you increase the value of this field so that subscribers are allowed to place calls that are denied to callers using the Automated Attendant, for example, calls to numbers that are not on the local PBX. If this setting is too restrictive, the utility of Modular Messaging features such as Call Me, Find Me, and reply by calling sender is reduced.

- **Configure** Click to open the Site Configuration for <VMD name> dialog box where you can configure site groups, sites, and the mailbox numbering schemes for the selected voice mail domain. See [Sites - Site Configuration Dialog Box](#) on page 3-19.
Sites - Site Configuration Dialog Box

This topic describes how to use the Site Configuration dialog box to configure sites and site groups for the voice mail domain. It also describes how to configure properties for each site.

**Note:** Sites and site groups can be configured whether MultiSite is enabled or not, but the configuration is only used when MultiSite is enabled.

Configuring Sites and Site Groups

- [Adding a Site Group](#) on page 3-22.
- [Adding a Site](#) on page 3-23.
- [Sites - Site Properties Dialog Box](#) on page 3-27.
- [Deleting a Site Group Or a Site](#) on page 3-25.

Launching the Screen

**Note:** To configure this dialog box, you must be a member of a security role assigned the MultiSite - Administer task. By default, MultiSite - Administer task is not assigned to any role. To enable or disable MultiSite, you must be a member of a role assigned the MultiSite - Enable task. If you are a member of a role assigned the MultiSite - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).
2. Double-click Sites. The system displays the Sites dialog box for the selected voice mail domain.
3. Click Configure to open the Site Configuration for <VMD name> dialog box. The dialog box shows the sites and sites groups that have been configured for the voice mail domain, organized in a tree, along with a summary of the most important settings. The dialog box provides a preview of the following elements that can be configured for a site or site group:
   - **Site/group** Shows the display name of the site or site group.
   - **ID** Shows the numeric identifier for a site or site group.
   - **Mailbox Number** Shows the configured length of the mailbox numbers for a particular site.
- **Full** Shows the configured length of the full mailbox numbers for a particular site. Double-click to make the field editable.

- **Short** Shows the configured length of the short mailbox numbers for a particular site. Double-click to make the field editable.

- **Preview** Shows the preview of the full mailbox number. It is color-coded to indicate the site identifier and short mailbox number components of the full mailbox number.

  Double-click any of these fields to launch the Properties dialog box for that site.

- **Name** Click the speaker icon to launch the Voice Player to record a name for the site. The recorded name is used to identify the site for use by the Telephone User Interface.

  - ![Speaker icon](image) Signifies that the site name is yet to be recorded.
  - ![Speaker icon](image) Signifies that the site name is recorded.

  Click to delete the prompt associated with the site. Click **Yes** to confirm deletion.

  - Right-click the icon to change the audio device for recording the site name to:

    - **1 Multimedia** - If you use a multimedia PC with a microphone, you can begin recording immediately.
    - **2 Telephone** - If you use a telephone to record the prompt, you must wait for the system to dial the telephone and the telephone to ring. For information on configuring the telephone properties, see [Setting Preferences for the Telephone or Multimedia Audio Device](#) on page 3-21.

  Click any of the other fields on the dialog box to close the Voice Player.

- **PBX** Shows the name of the switch that handles the calls for a particular site. For information on configuring a switch, see [Add New PBX Dialog Box](#) on page 3-118.
Setting Preferences for the Telephone or Multimedia Audio Device

1. On the Site Configuration for <VMD name> dialog box click Tools > Options. The system displays the Options dialog box.

2. In the Prompt recording and playback field, click one of the following:
   - **Telephone** This activates the Configure button. Proceed to Step 3.
   - **Multimedia** Proceed to Step 5.

3. Click Configure. The system displays the Telephone Properties screen.
   - **Extension number** Enter the number of the extension that will be used for recording and playing prompts.
   - **Mailbox number** Enter the full or partial mailbox number that will be used to identify you to the desired MAS in the voice mail domain.
   - **Message Application Server name** Enter the name of an MAS in the voice mail domain. If necessary, use the Browse button to locate the desired MAS.

4. Click OK.

5. The system displays the selected icon in the Voice Player.
Adding a Site Group

This topic describes how to use the Voice Mail System Configuration application’s Site Configuration for <VMD name> dialog box to configure sites groups. Avaya recommends that you read and understand the Avaya Modular Messaging MultiSite Guide before you attempt to add site groups to the voice mail domain.

**Note:** To configure this dialog box, you must be a member of a security role assigned the MultiSite - Administer task. If you are a member of a role assigned the MultiSite - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).
2. Double-click Sites. The system displays the Sites dialog box for the selected voice mail domain.
3. Click Configure to open the Site Configuration for <VMD name> dialog box.
4. On the Site Configuration dialog box, click the Add drop-down list or right-click a site group. Select Add site group to open the New Site Group dialog box.
5. From the Parent Site Group drop-down list, select the site group you want the new site group to be the child of.
   
   If you select <Root> as the Parent Site Group, the new site group appears at the top level of the Site/group tree.
6. In the Site Group name field, enter a name for the site group.
7. In the Identifier field, enter a unique number, for example, the country code.
   
   If you do not want to assign a site identifier for the site group, select the Group container only check box.
8. Click Add. The new site group appears in the Site/group tree.
9. Click OK to close the Site Configuration dialog box.
Adding a Site

This topic describes how to use the Voice Mail System Configuration application's Site Configuration for <VMD name> dialog box to configure sites. Avaya recommends that you must read and understand the Avaya Modular Messaging MultiSite Guide before you attempt to add sites to the voice mail domain.

**Note:** To configure this dialog box, you must be a member of a security role assigned the MultiSite - Administer task. If you are a member of a role assigned the MultiSite - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).

2. Double-click Sites. The system displays the Sites dialog box for the selected voice mail domain.

3. Click Configure to open the Site Configuration for <VMD name> dialog box. The dialog box provides a preview of the following elements that can be configured for a site or site group:

4. In the Site Configuration dialog box, click the Add drop-down list or right-click a site group. Select Add site to open the New Site dialog box.

5. From the Parent Site Group drop-down list, select the site-group you want the new site to be the child of.

6. In the Site name field, enter a name for the site.

7. In the Site Identifier field, enter a unique number, for example, the country code and area code. The identifier of the parent site group always forms the start of the site identifier and it cannot be modified.

   You must carefully choose the site identifier, because you cannot change its identifier, once the site is created.

8. In the Full mailbox length field, enter the length of the full mailbox number.

   The full mailbox number of a subscriber in a MultiSite-enabled voice mail domain includes the site group and site identifiers and the short mailbox number. For example, if John belongs to the Boston site with a site identifier 1617, which is part of the United States site group with site identifier 1, and his short mailbox number is 3564088, then his full mailbox number is 16173564088.
However, when the site identifier and the short mailbox numbers overlap, the last digits of the site identifier are also the first digits of the short mailbox number. For example, the length of Mary’s full mailbox number is set to 8. If the site identifier is 4 digits (8867) and the length of the short mailbox number is 6 (674092), then the last digits of the site identifier, 67, and the first digits of the short mailbox number, are common.

9. In the **Short mailbox length** field, enter the length of the short mailbox number.

10. From the **PBX** drop-down list, select the switch that handles the incoming and outgoing calls for the site.

11. Click **Add**. The new site appears in the **Site/group** tree.

12. Click **OK** to close the **Site Configuration** dialog box.
Deleting a Site Group Or a Site

Note: To configure this dialog box, you must be a member of a security role assigned the MultiSite - Administer task. If you are a member of a role assigned the MultiSite - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).

2. Double-click Sites. The system displays the Sites dialog box for the selected voice mail domain.

3. Click Configure to open the Site Configuration for <VMD name> dialog box. The dialog box provides a preview of the following elements that can be configured for a site or a site group.

4. In the Site Configuration dialog box, select the site or site group you want to delete. Or right-click a site or a site group to be deleted.

5. Click Delete.

6. Click Yes when prompted for confirmation.
Notes:

- When you choose to delete a parent site group, all the child site groups and the child sites are deleted.

- You must carefully plan the site configuration and the numbering scheme for each of the site or site group in your organization to reduce the possibility of having to delete a site. Use the procedure in the following cases.
  
  — To reflect a change in your organization structure when a new office is opened, an existing office is closed down, or in case of a merger.

  — To implement a numbering scheme to accommodate the expansion of a site.

  — To change the subscribers' mailbox numbers to assign them to a different existing site.

  — You can not recover the site once it is deleted. You must do the entire site configuration again.

- When a site or site group is deleted, the subscribers of that site or site group are not associated with any site. However, they can still use the Modular Messaging system. To associate subscribers to a site complete one of the following activities:

  — Create a new site with an identifier that matches the start of the existing mailbox numbers.

  — Create a new site and change the subscribers' mailbox numbers so that the changed mailbox numbers begin with the identifier of the new site.
Sites - Site Properties Dialog Box

This topic describes how to use the Voice Mail System Configuration application’s Sites > Configure > <Site name> Properties dialog box to configure properties specific to a site.

**Note:** To configure this dialog box, you must be a member of a security role assigned the MultiSite - Administer task. If you are a member of a role assigned the MultiSite - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

If MultiSite is enabled for a voice mail domain then the following VMD-wide settings are either disabled or not displayed. These settings are instead configured for each site:

1. Default receptionist mailbox number and After hours receptionist mailbox number (on the Receptionist tab of the Telephone User Interface node). See Telephone User Interface - Receptionist Tab on page 3-43.

2. All settings relating to office opening and closing times on the Time / Greeting tab of the Telephone User Interface node. See Telephone User Interface - Time/Greeting Tab on page 3-46.

3. All settings on all tabs of the Auto Attendant node. See Auto Attendant Dialog Box on page 3-59.

4. Primary Language setting on the Languages node. See Languages Dialog Box on page 3-166.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).

2. Double-click Sites. The system displays the Sites dialog box for the selected voice mail domain.

3. Click Configure to open the Site Configuration for <VMD name> dialog box.

4. Select the site for which you want to configure properties and click Properties, or double-click the site name. The system displays the <Site name> Properties dialog box.

Tabs available in this dialog

- **General** Use this tab to configure the primary language, time zone for the site, and hunt group number. See Site Properties - General Tab on page 3-29.
- **TUI** Use this tab to configure a site with the prompts to play at certain times of the day. You can set up different prompts for morning, afternoon, evening, or closed for business hours. See Site Properties - TUI Tab on page 3-30.

- **Auto Attendant** Use this tab to configure the greetings to play at certain times of the day. You can also configure languages, if you require more than one language to be available to callers in a site. See Site Properties - Auto Attendant tab on page 3-32.

- **Auto Attendant Holidays** Use this tab to configure the Automated Attendant holiday prompts for a site. See Site Properties - Auto Attendant Holidays tab on page 3-35.

- **Auto Attendant Keys** Use this tab to configure the Automated Attendant main menu for a site.

  You can assign a custom prompt to the Automated Attendant main menu and configure properties for DTMF key pad numbers. See Site Properties - Auto Attendant Keys tab on page 3-36.
Site Properties - General Tab

**Note:** To configure this dialog box, you must be a member of a security role assigned the **MultiSite - Administer** task. If you are a member of a role assigned the **MultiSite - View** task, you have read-only access to this dialog box. See [Security Roles Dialog Box](#) on page 3-88.

Launching the Screen

1. In the **Voice Mail System Configuration** window, click the voice mail domain (VMD).
2. Double-click **Sites**. The system displays the **Sites** dialog box for the selected voice mail domain.
3. Click **Configure** to open the **Site Configuration for <VMD name>** dialog box.
4. Select the site for which you want to configure properties and click **Properties**, or double-click the site name. The system displays the **<Site name> Properties** dialog box with the **General** tab active.

Configuring the Screen Controls

- **Primary language**  Select the primary language for the site. The list contains all the languages in the voice mail domain.

- **Time Zone**  Select the time zone of the site instead of the system time zone. The default is `<System Default>`.

- **Hunt Group**  Enter a canonical hunt group number that is used by the Automated Attendant to determine which site-specific data should be used when handling an incoming call.

The hunt group number is only required if multiple sites are configured to use the same PBX. If a PBX only hosts a single site then the hunt group number is not required for normal operation.
Site Properties - TUI Tab

Use the Site Properties dialog box, TUI tab to configure the operator mailbox number and define your organization’s daily business hours and control when certain greetings are played by the Automated Attendant.

**Note:** To configure this dialog box, you must be a member of a security role assigned the MultiSite - Administer task. If you are a member of a role assigned the MultiSite - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

---

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).

2. Double-click Sites. The system displays the Sites dialog box for the selected voice mail domain.

3. Click Configure to open the Site Configuration for <VMD name> dialog box.

4. Select the site for which you want to configure properties and click Properties, or double-click the site name. The system displays the <Site name> Properties dialog box.

5. Click the TUI tab.

Configuring the Screen Controls

- **Receptionist Mailbox**
  - **Open business hours mailbox** Enter the mailbox number to which callers are transferred, when they require operator assistance during business hours.
  - **Out of hours mailbox** Enter the mailbox number to which callers are transferred, when they require operator assistance outside of business hours.

**Note:** You can enter the full, short, or partial mailbox number in the Open business hours mailbox and Out of hours mailbox fields, but you must ensure that the number is not ambiguous.

- **Greeting start times**
  - **Morning start time** Enter the start time for the morning greeting. The default is 09:00.
- **Afternoon start time**  Enter the start time for the afternoon greeting.  
  The default is 12:00

- **Evening start time**  Enter the start time for the evening greeting.  The  
  default is 18:00.

- **Business hours**

  - **Day**  Select the day of the week for which you want to define  
  business hours.  For the selected day, you can then select one of  
  three options: **Open All Day**, **Closed All Day** or **Open during**.  Avaya  
  recommends that you set up business hours for each day of the  
  week.

  - **Open All Day**  Select to specify that the office is open all day.  For  
  any day this is set, the Automated Attendant greets callers with  
  the appropriate morning, afternoon, or evening greeting.  It uses  
  the start times you specify in the **Morning start time**, **Afternoon  
  start time** and **Evening start time** fields to determine which  
  greeting to play.  This is the default setting.

  - **Closed All Day**  Select to specify that the office is closed all day.  
  For any day this is set, the Automated Attendant plays the closed  
  greeting to callers.  They are then transferred to the after-hours  
  operator mailbox.

  - **Open during**  Select to specify the business and after-business  
  hours for a particular day.  If you select this option, you must enter  
  the **Open time** and **Close time**.

  - **Open time**  Enter the time designated as the start of business hours  
  for the selected day.  During business hours, the appropriate greeting  
  (morning, afternoon, or evening) is played.  The default is 09:00.

  - **Close time**  Enter the time designated as the end of business hours  
  for the selected day.  After business hours, the closed greeting is  
  played.  The default is 17:00.
Site Properties - Auto Attendant tab

**Note:** To configure this dialog box, you must be a member of a security role assigned the **MultiSite - Administer task**. If you are a member of a role assigned the **MultiSite - View** task, you have read-only access to this dialog box. See **Security Roles Dialog Box** on page 3-88.

Launching the Screen

1. In the **Voice Mail System Configuration** window, click the voice mail domain (VMD).

2. Double-click **Sites**. The system displays the **Sites** dialog box for the selected voice mail domain.

3. Click **Configure** to open the **Site Configuration for <VMD name>** dialog box.

4. Select the site for which you want to configure properties and click **Properties**, or double-click the site name. The system displays the **<Site name> Properties** dialog box.

5. Click the **Auto Attendant** tab.

Configuring the Screen Controls

- **Day greetings**

  **Main Menu** Enter the number of the main Automated Attendant prompt as recorded in **Visual Voice Editor**. The range is 0 through 9999, and the default is 0.

  The Automated Attendant’s main menu helps callers to navigate through the Telephone User Interface (TUI). It provides them with menu options they can select using DTMF key presses.

  You can assign a custom prompt, for example, “For sales, press 1. For technical support, press 2. For accounting, press 3.” You can also
configure Automated Attendant main menu properties for DTMF key pad numbers.

If the **Main Menu** prompt is not customized, the default is: “Please enter the mailbox number of the person you are calling. If you have a mailbox on this system, press #. For assistance, press 0.”

Then, if callers are allowed to use Dial by Name: “If you do not know the mailbox number, press * to spell the name.”

Followed by: “If you do not have a DTMF telephone or require assistance, please stay on the line.”

The system overwrites the options in the **Main Menu**, if any languages have been selected from the **Language** drop-down list, and a keypad digit and prompt number are associated with the language.

---

**Note:** You can record custom prompts or import recordings to assign to custom prompts using the **Visual Voice Editor** application. Avaya recommends that you create these prompts and make a note of their prompt numbers, before configuring the dialog box. See [Chapter 5, “Visual Voice Editor (Custom Prompts)”.](#)

---

- **Morning** Enter the number of the custom prompt that greets callers during the morning business hours.

- **Afternoon** Enter the number of the custom prompt that greets callers during the afternoon business hours.

- **Evening** Enter the number of the custom prompt that greets callers during the evening business hours.

- **Closed** Enter the number of the custom prompt that greets callers after business hours, as recorded in **Visual Voice Editor**.

  For each prompt, the range is 0 through 9999, and the default is 0. If 0 is selected, the system plays the standard prompt: “Welcome to Avaya Messaging.”

- **Multilingual greetings**

  - **Languages** Enter a prompt number in this field, if you want to replace the default system language selection prompt with a custom prompt recorded in **Visual Voice Editor**. The range is 0 through 9999, and the default is 0.

    If 0 is selected, the system uses the default system language selection prompt similar to the following: “For English, press one.”
Pour français, appuyez sur le deux." The prompt for each language is in that language.

Callers can select the desired language by pressing the appropriate key on their DTMF keypads. When they do, they hear all subsequent prompts in the selected language.

- **Languages** Select the language that you want to configure in each of these three fields. You can select any language supported by the TUI. A previously selected language does not appear in the drop-down list and cannot be set again.

- **Key** Double-click to edit the keypad digit for each language supported by the Telephone User Interface (TUI). Callers can select the desired language by pressing the appropriate key on their DTMF keypads. When they do, they hear all subsequent prompts in the selected language.

- **Prompt** Double-click to edit the default prompt number for the language specific Automated Attendant main menu greeting. By default, 0 is assigned when you select a language. Selecting any language option from the Languages drop-down list automatically disables the Auto Attendant Main Menu prompt.
Site Properties - Auto Attendant Holidays tab

Note: You can record custom prompts or import recordings to assign to custom prompts using the Visual Voice Editor application. Avaya recommends that you create these prompts and make a note of their prompt numbers, before configuring the Properties dialog box. See Chapter 5, “Visual Voice Editor (Custom Prompts)” For more information, see Visual Voice Editor Help.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).

2. Double-click Sites. The system displays the Sites dialog box for the selected voice mail domain.

3. Click Configure to open the Site Configuration for <VMD name> dialog box.

4. Select the site for which you want to configure properties and click Properties, or double-click the site name. The system displays the <Site name> Properties dialog box.

5. Click the Auto Attendant Holidays tab.

Configuring the Screen Controls

- **Date** Enter the date on which an alternate greeting is to be played. The format is DD/MM. You can specify up to 18 dates as holidays.

- **Prompt number** Enter the number of the holiday prompt as recorded in Visual Voice Editor. The range is 0 through 9999, and the default is 0.

  If 0 is selected, no holiday prompt is played.
Site Properties - Auto Attendant Keys tab

**Note:** To configure this dialog box, you must be a member of a security role assigned the MultiSite - Administer task. If you are a member of a role assigned the MultiSite - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).
2. Double-click Sites. The system displays the Sites dialog box for the selected voice mail domain.
3. Click Configure to open the Site Configuration for <VMD name> dialog box.
4. Select the site for which you want to configure properties and click Properties, or double-click the site name. The system displays the <Site name> Properties dialog box.
5. Click the Auto Attendant Keys tab.

Configuring the Screen Controls

- **Key** Select a DTMF keypad digit to configure, 1 through 9.

  **Note:** The keys for 0, *, and # are reserved for system use and cannot be configured.

When you have selected a number, use the **Action** option to configure the properties for that number.

- **Action** Double-click the option to configure the selected key number above.
  
  - **Invalid** Select to indicate this key is an invalid option. Use this setting, if you specifically do not want to associate any action with the key press. This is the default.
  
  - **Directory** Select to allow the caller to use the Dial By Name feature, when this key is pressed. The Dial By Name feature allows a caller to search for a subscriber extension or mailbox number by “spelling” the person’s name using the telephone keypad.
- **Message**: Select to allow a caller to leave a voice message, when this key is pressed and followed by the mailbox number. This feature is called Quick Message.

**Notes:**

- If you select this option, ensure that you perform one of these actions:
  
  - Either record your Automated Attendant main menu prompt to notify callers that they must enter this key press, followed by the extension of the subscriber they are trying to reach.
  
  - Or instruct your subscribers that they must include this key press as the first digit, when giving their extension number to potential callers.

- If the key number you configure as **Message** happens to be the same as the first digit of a mailbox number, Automated Attendant will go directly to voicemail instead of performing the transfer to the extension associated with the mailbox.

  Some customers use this feature to create ranges of mailboxes that would never have physical transfers.

- **Transfer**: Select to allow the caller to transfer to the mailbox number you enter in the **Mailbox Number** field.

  This option is useful for transferring callers to particular departments. For example, “For technical support, press 2”.

- **Mailbox**: If you select **Transfer** as the **Action**, double-click the adjoining field to enter the number of the mailbox you want to transfer to.
Telephone User Interface Dialog Box

**Note:** For a detailed overview of voice mail domain configuration in the Voice Mail System Configuration (VMSC) application, see Overview of VMD Configuration in VMSC on page 3-3.

This topic describes how to use the Voice Mail System Configuration application’s Telephone User Interface dialog box to configure Telephone User Interface (TUI) properties for a voice mail domain.

Callers and subscribers use the TUI to access the Modular Messaging system over the telephone.

You can use the Telephone User Interface dialog box to configure aspects of many features of the Modular Messaging system. For example, Caller settings, Subscriber settings and permissions, Automated Attendant, Caller Applications, Messaging, Call-Answered Messaging, Call Me, Notify Me, Operators, Personal Operators, and Dial By Name.

**Launching the Screen**

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).

2. Double-click Telephone User Interface. The system displays the Telephone User Interface dialog box for the selected voice mail domain.

**Tabs Available in this Dialog Box**

**Note:** To configure this dialog box, you must be a member of a security role assigned the Telephone User Interface - Administer task. If you are a member of a role assigned the Telephone User Interface - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

- **General** Use this tab to configure basic TUI properties for a voice mail domain, such as call duration and timeout. You can enable the Automated Attendant, Caller Applications, and the Private Call-Answered Message facility. You can also set properties for subscribers’ mailboxes, such as new mailbox initialization. See Telephone User Interface - General Tab on page 3-40.
Receptionist  Use this tab to configure operator properties for a voice mail domain. You can set up operator mailbox numbers, specify the conditions for transferring a caller to the operator, and allow personal operators for non-local extensions or mailboxes. See Telephone User Interface - Receptionist Tab on page 3-43.

Time/Greeting  Use this tab to configure time and greeting properties for a voice mail domain. You can define your organization’s daily business hours and control when certain greetings are played by the Automated Attendant. See Telephone User Interface - Time/Greeting Tab on page 3-46.

Message Timing  Use this tab to configure message timing properties for a voice mail domain. You can configure the voice message playback controls on the telephone keypad, and specify the number of seconds permitted for recording personalized prompts. See Telephone User Interface - Message Timing Tab on page 3-48.

Subscriber  Use this tab to configure subscriber properties for a voice mail domain. You can set up message deletion confirmation and configure mailbox password security. See Telephone User Interface - Subscriber Tab on page 3-50.

Caller  Use this tab to configure caller properties for a voice mail domain. You can permit callers to use directory services and leave multiple messages. You can also set out-calling restrictions to prevent telephone toll fraud. See Telephone User Interface - Caller Tab on page 3-52.

Personal Operator Schedules  Use this tab to configure personal operator schedules for a voice mail domain. You can edit existing schedules and create new schedules.

If the schedule is associated with a subscriber’s personal operator, then the personal operator replaces the system-wide operator during the times specified in the schedule. See Telephone User Interface - Personal Operator Schedules Tab on page 3-54.

Dial by Name  Use this tab to configure the Dial By Name feature for the voice mail domain. With Dial By Name, callers can spell out a recipient’s name on the telephone keypad.

You can configure the way in which recipients’ names are stored. If they have given names or family names which are difficult to map to a telephone keypad, you can configure their e-mail addresses instead. See Telephone User Interface - Dial By Name Tab on page 3-58.

VMSC Tree - Telephone User Interface Node - Right-Click Menu

Copy schedule IDs to clipboard  This menu command copies the names and globally unique identifiers (GUIDs) of all the personal operator schedules to the Windows Clipboard. You can then paste this into a word processing document to view the information.
VMSC - Voice Mail Domain (VMD) Configuration

Telephone User Interface - General Tab

Use the **Telephone User Interface** dialog box, **General** tab to configure basic Telephone User Interface (TUI) properties for a voice mail domain, such as call duration and timeout. You can enable the Automated Attendant, Caller Applications, and the Private Call-Answered Message facility. You can also set properties for subscribers’ mailboxes, such as new mailbox initialization.

Launching the Screen

1. In the **Voice Mail System Configuration** window, click the voice mail domain.
2. Double-click **Telephone User Interface**. The system displays the **Telephone User Interface** dialog box for the selected voice mail domain, with the **General** tab active.

Configuring the Screen Controls

- **Enable Automated Attendant**  Select this option to enable the Automated Attendant for the voice mail domain. The Automated Attendant is used to manage the automated greetings and instructions heard by callers to the TUI. By default, this check box is selected.

  When enabled, the system can be set to present callers with a list of menu options from which to choose. If your PBX does not support Direct Inward Dialing (DID), Avaya recommends that you enable the Automated Attendant.

  When the Automated Attendant is disabled, the system transfers callers directly to the subscriber’s mailbox, where they can leave a message. They cannot transfer to the subscriber’s extension.

  You can configure Automated Attendant properties using the **Auto Attendant** dialog box. For more information about the Automated Attendant, see **Auto Attendant Dialog Box** on page 3-59.

- **Enable Caller Applications**  Select to enable Caller Applications in the voice mail domain. Caller Applications are used to extend or even replace the system Automated Attendant, with additional menus and prompts. By default, this check box is selected.

  When Caller Applications are disabled, deployed applications are ignored by the MASs in the voice mail domain. If a caller application is in use when it is disabled, it will continue to work until it is no longer in use.
For more information about Caller Applications, see Chapter 6, “Caller Applications Editor”.

**Number of Digits in a Mailbox** Enter the number of digits in a subscriber's mailbox number. The range is 2 through 10. The default is 4.

---

**Note:** If MultiSite is enabled, this field is disabled.

Avaya recommends that you make subscribers' mailbox numbers the same as their telephone extension numbers. If a subscriber has multiple extension numbers, make the mailbox number the same as the primary extension number.

For guidance on setting up a mailbox numbering scheme, see *Avaya Modular Messaging Concepts and Planning Guide*.

---

**Note:** The primary extension number is the one that defines call handling behavior for the subscriber. It is used for the Message Waiting Indicator, if configured for that.

- **Enable New Mailbox Initialization** Select to play the setup tutorial to new subscribers the first time they open their mailboxes. The tutorial guides new subscribers through the process of changing their passwords and recording personalized prompts. This check box is selected by default.

- **Maximum Call Duration in Minutes** Enter the number of minutes that callers or subscribers are permitted to spend using the TUI during one session. When this time is up, they are disconnected. The range is 0 through 99 and the default is 0. If 0 is configured, there is no time limit on a TUI session.

---

**Note:** If subscribers reach the maximum duration time while recording a message, when they finish recording they are disconnected and cannot address or send the message.

- **Default Input Timeout in Seconds** Enter the number of seconds the TUI waits for a dual tone multi-frequency (DTMF) response from callers before prompting them to proceed. This timeout period begins anew each time a key is pressed. The range is 0 through 99 and the default is 5.

If a caller exceeds this timeout at any prompt, then the system prompts the caller to try again. In the case of a login attempt, the user is told that the login attempt was invalid and is prompted to try again.
If the caller exceeds the timeout four consecutive times, then the system terminates the call.

**Note:** This is an inter-digit timeout and is used only for the Aria TUI. For the AUDIX TUI and Serenade TUI, the value is fixed at 30 seconds.

- **Allow Private Call Answer Messages** Select this option to allow callers to mark as private messages left for subscribers. When this option is selected, the caller hears a prompt at the end of the message allowing the message to be marked as private. When this option is cleared, the privacy option prompt does not play. This option is selected by default.

- **Enable Transfer to Voicemail Using Extension Number** Select this option to allow callers to transfer to subscribers’ voice mail using an extension number rather than a mailbox number.

  If Modular Messaging does not recognize the number as a mailbox, it validates the number against a subscriber’s extension, then transfers the caller to the corresponding mailbox.

  **Note:** Typically, this option would be used when the number of digits in an extension is higher than 10, which is the maximum number of digits allowed for a Modular Messaging mailbox.

Selecting this option enables the **Maximum Number of Digits in a PBX Extension** field.

- **Maximum Number of Digits in a PBX Extension** Enter the maximum number of digits for a Private Branch Exchange (PBX) extension. The range is 2 through 50. The default is taken from the current **Maximum Number of Digits in a Mailbox** setting.
Telephone User Interface - Receptionist Tab

Use the **Telephone User Interface** dialog box, **Receptionist** tab to configure operator properties for a voice mail domain. You can set up operator mailbox numbers, specify the conditions for transferring a caller to the operator, and allow personal operators for non-local extensions or mailboxes.

Launching the Screen

1. In the **Voice Mail System Configuration** window, click the voice mail domain.
2. Double-click **Telephone User Interface**. The system displays the **Telephone User Interface** dialog box for the selected voice mail domain, with the **General** tab active.
3. Click the **Receptionist** tab.

Configuring the Screen Controls

- **Default Receptionist Mailbox Number** Enter the mailbox number to which callers are transferred, when they require operator assistance. The default is 0.

- **After Hours Receptionist Mailbox Number** Enter the mailbox number to which callers are transferred, when they require operator assistance outside of business hours. The default is 0.

*Note:* When the MultiSite feature is enabled, settings for the default and after hours receptionist mailbox number are disabled on the **Receptionist** tab. These settings are configured for each site and not for the entire voice mail domain. See [Sites - Site Properties Dialog Box](#) on page 3-27.

- **Inform Subscriber Transfer is from Auto Attendant** Select to enable the Automated Attendant to inform a subscriber before it transfers a caller to the subscriber’s extension. This check box is cleared by default.

  When cleared, the Automated Attendant transfers the caller immediately, without telling them it is doing so.

- **Disconnect all Rotary Callers** Select to disconnect callers using a non-DTMF telephone. This check box is cleared by default.

  When cleared, callers are transferred to the operator. If you select to disconnect callers from non-DTMF telephones, ensure that your system greetings give another number to dial.
- **Number Attempts Rotary Transfer to Busy Receptionist** Specify the number of times the Telephone User Interface (TUI) attempts to transfer a caller from a non-DTMF telephone to a busy operator. The range is 0 to 9 and the default is 3.

  If the number of attempts is exceeded, callers are transferred to the operator mailbox, where they can leave a message.

- **Maximum Number of Errors** Specify the number of errors a caller is permitted to make, when attempting to use the TUI. The range is 0 through 9, and the default is 3.

  If the maximum number of errors is exceeded, the caller is disconnected or transferred to the operator. If you enter 0 as the maximum number of errors, the caller is disconnected after making the first error.

  If you want to transfer callers to the operator, ensure that the **Transfer Calls to Receptionist after Maximum Errors** check box is selected.

- **Maximum Number of No Entries** Specify the number of “no entries” a caller is permitted to make when using the TUI. The range is 0 through 9 and the default is 3.

  A “no entry” is defined as no response from the caller when prompted to proceed. If the maximum number of no entries is exceeded, the caller is politely disconnected. If you enter 0 as the maximum number of no entries, the caller is disconnected after the first no entry occurrence. If the callers do not respond after your initial office greeting, they are transferred to the operator.

- **Transfer Calls to Receptionist after Maximum Errors** Select to transfer callers to the operator if they exceed the number of permitted errors when using the TUI. This check box is selected by default.

  If this check box is cleared, callers are disconnected.

- **Transfer Invalid Mailboxes during Business Hours** Select to specify what happens to calls to an invalid mailbox number during business hours. The check box is cleared by default.

  When selected, the TUI dials the extension number, if the mailbox number is invalid. When cleared, callers are informed that the mailbox number is invalid.

  If callers exceed the maximum number of errors, they are politely disconnected or transferred to the business hours operator.

---

**Note:** If you want callers to be transferred to the business hours operator or to the personal operator, ensure that the **Transfer Calls to Receptionist after Maximum Errors** check box is selected.
VMSC - Voice Mail Domain (VMD) Configuration

- **Transfer Invalid Mailboxes after Business Hours** Select to specify what happens to calls to an invalid mailbox number after business hours. This check box is cleared by default.

  When selected, the TUI dials the extension number, if the mailbox number is invalid. When cleared, callers are informed that the mailbox number is invalid.

  If callers exceed the maximum number of errors, they are politely disconnected or transferred to the after-hours operator.

  **Note:** If you want callers to be transferred to the after-hours operator or to the personal operator, ensure that the Transfer Calls to Receptionist after Maximum Errors check box is selected.

- **Allow personal operators that are not local mailboxes** Select to allow subscribers to set their personal operator numbers to extensions which are not associated with Modular Messaging mailboxes.

  If this setting is not selected, subscribers can only set their personal operator numbers to Modular Messaging mailbox numbers.

  For information about configuring personal operator schedules, see Telephone User Interface - Personal Operator Schedules Tab on page 3-54.

- **Leave failed zero-out messages in** Select to specify whether the callers are allowed to leave messages in the Operator Mailbox or the Subscriber Mailbox in case the called party fails to answer the call. The default is Operator Mailbox.

  **Note:** This option is only valid if you are using Q-Signaling (QSIG) integration.
Telephone User Interface - Time/Greeting Tab

Use the Telephone User Interface dialog box, Time/Greeting tab to configure time and greeting properties for a voice mail domain. You can define your organization's daily business hours and control when certain greetings are played by the Automated Attendant.

Notes:

- When the MultiSite feature is enabled, the Time/Greeting tab is not displayed. These settings are configured for each site and not for the entire voice mail domain. See Sites - Site Properties Dialog Box on page 3-27.

- The system applies the time zone in the following order of priority for the purpose of your organization’s daily business hours:
  
  - The time zone set by the subscriber using Web Subscriber Options or Subscriber Options.
  
  - The site’s time zone, if MultiSite is enabled for the voice mail domain. See Site Properties - General Tab on page 3-29.
  
  - The time zone defined in the subscriber’s class of service (COS) on the Avaya MSS.
  
  - The MAS’s system time zone.

For information on configuring time of day greetings in the Automated Attendant, see Auto Attendant - Time of Day Tab on page 3-66.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Telephone User Interface. The system displays the Telephone User Interface dialog box for the selected voice mail domain, with the General tab active.

3. Click the Time/Greeting tab.

Configuring the Screen Controls

- **Daily Settings** Select the day of the week for which you want to define business hours.
For the selected day, you can then select one of three options: **Open All Day, Closed All Day** or **Selected Hours**. Avaya recommends that you set up business hours for each day of the week.

— **Open All Day**  Select to specify that the office is open all day. For any day this is set, the Automated Attendant greets callers with the appropriate morning, afternoon, or evening greeting. It uses the start times you specify in the **Start of Morning**, **Start of Afternoon** and **Start of Evening** fields to determine which greeting to play.

— **Closed All Day**  Select to specify that the office is closed all day. For any day this is set, the Automated Attendant plays the closed greeting to callers. They are then transferred to the after-hours operator mailbox.

— **Selected Hours**  Select to specify the business and after-business hours for a particular day. This is the default setting. If you select this option, you must enter the **Open** and **Close** times:

  ■ **Open**  Enter the time designated as the start of business hours for the selected day. During business hours, the appropriate greeting (morning, afternoon, or evening) is played. The default is 09:00.

  ■ **Close**  Enter the time designated as the end of business hours for the selected day. After business hours, the closed greeting is played. The default is 17:00.

  ■ **Start of Morning**  Enter the start time for the morning greeting. The default is 09:00.

  ■ **Start of Afternoon**  Enter the start time for the afternoon greeting. The default is 12:00.

  ■ **Start of Evening**  Enter the start time for the evening greeting. The default is 18:00.
Telephone User Interface - Message Timing Tab

Use the Telephone User Interface dialog box, Message Timing tab to configure message timing properties for a voice mail domain. You can configure the voice message playback controls on the telephone keypad, and specify the number of seconds permitted for recording personalized prompts.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Telephone User Interface. The system displays the Telephone User Interface dialog box for the selected voice mail domain, with the General tab active.

3. Click the Message Timing tab.

Configuring the Screen Controls

- **Seconds to Rewind Message When Rewind Button Pressed** Enter the amount of time, in seconds, by which subscribers can rewind a voice message when they press the Rewind key on the keypad. The range is 0 through 99 and the default is 5.

- **Seconds to Pause Message When Pause Button Pressed** Enter the amount of time, in seconds, by which a message is paused when a subscriber presses the Pause key on the keypad while playing or recording a voice message. The range is 0 through 99 and the default is 5.

- **Seconds to Fast Forward Message When Fast Forward Button Pressed** Enter the amount of time, in seconds, by which subscribers can fast forward a voice message when they press the Fast Forward key on the keypad. The range is 0 through 99 and the default is 5.

- **Maximum Mailbox Prompt Length in Seconds** Enter the amount of time, in seconds, that subscribers are given for recording a mailbox prompt such as a personal greeting. The range is 1 through 999 and the default is 90.

When using the Telephone User Interface (TUI), subscribers hear a warning message 10 seconds before the end of the prompt length. To avoid this warning message playing at the start of a recording it is recommended that you enter at least a value of 20.

**Note:** This setting does not apply to the Spoken Name prompt. The maximum length of the Spoken Name prompt depends on the audio encoding format selected. For GSM 6.10, it is 20 seconds. For G.711 μ-law (mu-law), it is 7.5 seconds. For G.711 A-law, it is 7.5 seconds.
Minimum Message Length in Seconds  Enter the amount of time, in seconds, that defines the shortest allowable voice message from an external caller. Any shorter voice messages are discarded. The range is 0 through 9, and the default is 0.

If you set the minimum message length to 0, no messages are discarded.
Telephone User Interface - Subscriber Tab

Use the Telephone User Interface dialog box, Subscriber tab to configure subscriber properties for a voice mail domain. You can set up message deletion confirmation and configure mailbox password security.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Telephone User Interface. The system displays the Telephone User Interface dialog box for the selected voice mail domain, with the General tab active.

3. Click the Subscriber tab.

Configuring the Screen Controls

- **Enable Confirmation before Deleting Messages** Select to prompt subscribers to confirm message deletions. This check box is cleared by default.

  When cleared, deleted messages can still be reviewed during the same session.

  **Note:** This setting is used by Aria Telephone User Interfaces (TUIs) only.

- **Enable Extended Password Security** Select to force subscribers to press [#] after entering their mailbox password. This check box is selected by default.

  If subscribers do not press [#] when this check box is selected, the system waits for a response and then permits access, as long as the correct password was entered.

  When this check box is cleared, subscribers can open their mailboxes as soon as the last digit of their password is entered.

- **Minimum Password Length** Enter a value to specify the minimum number of digits for a mailbox password. The range is 1 through 15. The default is 4.

  Increasing the number of digits in a password lowers the probability that an unauthorized user can gain access.
If you change the minimum password length to a higher value, existing subscribers are prompted to enter a new password containing the new minimum number of digits before they can proceed.

**Note:** The setting in this field can be used to force a password change for new subscribers on initial login. The administrators can set an initial password that is shorter than this value so that, when the subscriber logs in for the first time, the system forces a password change.

- **Enable Password Expiry** Select to expire a subscriber's password after the time interval you specify in the **Days before Password Expiry** field. This check box is cleared by default.

  Selecting this option enables the **Days before Password Expiry** field.

  — **Days before Password Expiry** Enter the time interval, in days, from the date subscribers last changed their passwords before they are forced to change them again. The range is 1 through 999, and the default is 60.

  Avaya recommends that subscribers enter a new password at least every six months to reduce unauthorized user access.

- **Login Failures before Mailbox Lockout** Enter a number to specify how many password entry errors per call subscribers can make before they are locked out of their mailbox. The range is 3 through 999, and the default is 5.

- **Number of Previous Passwords Disallowed** Enter the number of different passwords a user must use before any old (previous) passwords can be reused.

- **Give incoming call priority to** Select to specify whether you want to give priority to **Callers** or **Subscribers**. If the priority is given to **Subscribers**, the number of times the subscribers have to press "#" when logging on to the TUI, from a phone other than their own, is reduced. By default, **Callers** is selected.
Telephone User Interface - Caller Tab

Use the Telephone User Interface dialog box, Caller tab to configure caller properties for a voice mail domain. You can permit callers to use directory services and leave multiple messages. You can also set out-calling restrictions to prevent telephone toll fraud.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Telephone User Interface. The system displays the Telephone User Interface dialog box for the selected voice mail domain, with the General tab active.

3. Click the Caller tab.

Configuring the Screen Controls

- **Permit Callers to Leave Multiple Messages** Select to allow callers to leave more than one voice message per call. This check box is selected by default.

  If cleared, callers are disconnected after leaving the first voice message.

- **Permit Callers to Access Directory Services** Select to allow callers to use Dial By Name to search for a subscriber extension or mailbox number by spelling the subscriber's name using the telephone keypad. This check box is selected by default.

- **Outcalling Restrictions** Clear the digits that callers are not allowed to enter as the initial digit in an invalid mailbox when the Transfer Invalid Mailboxes during Business Hours or Transfer Invalid Mailboxes after Business Hours check boxes are selected on the Receptionist tab. All digits are selected by default.

Avaya recommends that you clear the digits used to request external lines from the Private Branch Exchange (PBX). This helps prevent telephone toll fraud by prohibiting callers from obtaining an external line when dialing the initial digit of an invalid mailbox number. For example, if 9 is configured to request an external line from the PBX, and 9 is cleared, dialing the invalid mailbox 9004 does not get an external line.
**Note:** The translation rules replace Outcalling Restrictions when MultiSite is enabled. In a MultiSite-enabled voice mail domain, the option to set outcalling restrictions is removed from the **Caller** tab. For information on configuring translation rules, see *PBX Configuration - SIP Tab (IP SIP) - Translation Rules Dialog Box* on page 3-161. For an overview of the MultiSite feature and a detailed description of the concepts underlying MultiSite, such as translation rules, see *Avaya Modular Messaging MultiSite Guide*.

For information on the **Receptionist** tab, see *Telephone User Interface - Receptionist Tab* on page 3-43.
Telephone User Interface - Personal Operator Schedules Tab

Use the Telephone User Interface dialog box, Personal Operator Schedules tab to configure personal operator schedules for a voice mail domain. You can edit existing schedules and create new schedules.

If the schedule is associated with a subscriber’s personal operator, then the personal operator replaces the system-wide operator during the times specified in the schedule.

Notes:

- If no schedule is associated, then the personal operator is always active by default.
- Use the General tab to configure settings for allowing subscribers to set their personal operator numbers to extensions which are not associated with Modular Messaging mailboxes. See Telephone User Interface - General Tab on page 3-40.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Telephone User Interface. The system displays the Telephone User Interface dialog box for the selected voice mail domain, with the General tab active.

3. Click the Personal Operator Schedules tab.

Configuring the Screen Controls

- Schedules  This displays a list of schedules. When one of the schedules is selected in the list, the schedule times are displayed in the schedule grid.

You can use that grid to set the times for a new schedule or alter the times of an existing schedule. See Schedule Grid on page 3-56.

- Add...  Use this button to add new schedule.

  1. Click the button. The system displays the Enter Personal Operator Schedule Name dialog box.

  2. In the Schedule Name field, type the desired name for the schedule.

  **Note:** You should use a unique schedule name each time.
3. Click OK to return to the **Personal Operator Schedules** tab. The new schedule is then displayed in the **Schedules** list.

- **Copy As...** Use this button to copy an existing schedule.
  1. Select an existing item in the **Schedules** list.
  2. Click the button. The system displays the **Enter Personal Operator Schedule Name** dialog box.
  3. In the **Schedule Name** field, type the desired name for the schedule.

  **Note:** You should use a unique schedule name each time.

  4. Click OK to return to the **Personal Operator Schedules** tab. The new schedule is then displayed in the **Schedules** list.

- **Rename...** Use this button to rename an existing schedule.
  1. Select an existing item in the **Schedules** list.
  2. Click the button. The system displays the **Enter Personal Operator Schedule Name** dialog box.
  3. In the **Schedule Name** field, type the revised name for the schedule.

  **Note:** You should use a unique schedule name each time.

  4. Click OK to return to the **Personal Operator Schedules** tab. The schedule is then displayed in the **Schedules** list with the revised name.

- **Delete** Use this button to delete an existing schedule.
  1. Select an existing item in the **Schedules** list.
  2. Click the button. The system deletes the schedule from the list.

  **Note:** If the deleted schedule is currently in use by a subscriber, their personal operator will be set to having no schedule and therefore always active by default.

- **Interval** Select **1 Hour** (default), **15 minutes** or **5 Minutes** to set the time intervals for the cells in the schedule grid.
Schedule Grid

The schedule grid is displayed on several screens:

- In the **Telephone User Interface** dialog box, **Personal Operator Schedules** tab. See **Telephone User Interface - Personal Operator Schedules Tab** on page 3-54.

- In the **Message Waiting Indicator** dialog box, **Update Schedule** tab. See **Message Waiting Indicator - Update Schedule Tab** on page 3-77.

The grid has weekdays along the y-axis and the time of day along the x-axis. Cells on the grid represent a time interval, depending on the currently selected **Interval**, either 1 hour (default), 15 minutes or 5 minutes.

You can click the cells in the grid to set the times (see Figure 3-2).

**Figure 3-2. Schedule Grid**

1. Select all cells in the grid
2. Column headers
3. Row headers

Configuring the Screen Controls

- Clicking a cell toggles its state:
  - The Off state is shown in white.
  - The On state is shown in blue, if your system has a low number of colors available, or a variant of gold, if your system has enough colors.

- To toggle all the cells in a row to the same state, click inside a row header.

- To toggle all the cells in a column to the same state, click inside a column header.
To change all cells to the same state as the top left cell, click inside the top left cell.

To toggle multiple cells at once, click and hold inside a cell and drag the mouse cursor over other cells.
Telephone User Interface - Dial By Name Tab

Use the **Telephone User Interface** dialog box, **Dial By Name** tab to configure the Dial By Name feature for the voice mail domain. With Dial By Name, callers can spell out a recipient’s name on the telephone keypad.

**Launching the Screen**

1. In the **Voice Mail System Configuration** window, click the voice mail domain.

2. Double-click **Telephone User Interface**. The system displays the **Telephone User Interface** dialog box for the selected voice mail domain, with the **General** tab active.

3. Click the **Dial By Name** tab.

**Configuring the Screen Controls**

- **Match names using** Select the method to use when matching names using Dial By Name.
  
  — **Lastname, Firstname** Stores the subscriber’s last name followed by their first name. Avaya recommends selecting this setting.

  **Note:** If you select this option, when all the last names in the directory have been found, the system searches e-mail aliases for matches.

  — **E-mail Address** Stores the subscriber’s e-mail address. This enables callers to use Dial by Name for names that contain characters that do not appear on the telephone keypad.

  **Note:** Avaya recommends that you use this setting, only if the FEDB contains names that are not easily mapped to a telephone keypad, such as Far Eastern names. Enter only the first part of the subscriber’s e-mail address (before the @ symbol) for example, JSmith.
Auto Attendant Dialog Box

**Note:** For a detailed overview of voice mail domain configuration in the **Voice Mail System Configuration** (VMSC) application, see Overview of VMD Configuration in VMSC on page 3-3.

This topic describes how to use the **Voice Mail System Configuration** application’s **Auto Attendant** dialog box to configure the Automated Attendant properties for the voice mail domain.

**Note:** When the MultiSite feature is enabled, the Automated Attendant node is not displayed in the **Voice Mail System Configuration** tree. The Automated Attendant settings are configured for each site and not for the entire voice mail domain. See Sites - Site Properties Dialog Box on page 3-27.

Modular Messaging’s Automated Attendant is used to prompt callers with the system greeting and collect their input, in the form of Dual Tone Multi-Frequency (DTMF) key presses. It can be configured to offer single-digit menu choices, for transfers or quick messages, and use the Dial By Name feature to reach subscribers.

**Notes:**

- If you are familiar with or are migrating from an Intuity AUDIX environment, you should be aware that the use of the term “Automated Attendant” in Avaya Modular Messaging systems carries somewhat different connotations than in AUDIX systems.

  In Modular Messaging, Caller Applications provide roughly the same functionality as AUDIX nested and other Automated Attendants. For more information, see Chapter 6, “Caller Applications Editor”.

- Avaya recommends using the Automated Attendant, if your Private Branch Exchange (PBX) does not support Direct Inward Dialing (DID) or if you want to use other call handling features, such as intercom paging, call blocking, and call screening.

- You can enable the Automated Attendant for the voice mail domain, using the **Voice Mail System Configuration** application’s **Telephone User Interface** dialog box, **General** tab. See Telephone User Interface - General Tab on page 3-40.

- You can record custom prompts or import recordings to assign to custom prompts using the **Visual Voice Editor** application. Avaya recommends that you create these prompts and make a note of their prompt numbers, before configuring the **Auto Attendant** dialog box. See Chapter 5, “Visual Voice Editor (Custom Prompts)”.


You can use the **Auto Attendant** dialog box to assign custom prompts for the Automated Attendant main menu, for special holidays, for different times of day, and in different languages. You can also configure Automated Attendant main menu properties for DTMF key pad numbers.

### Launching the Screen

1. In the **Voice Mail System Configuration** window, click the voice mail domain (VMD).
2. Double-click **Auto Attendant**. The system displays the **Auto Attendant** dialog box for the selected voice mail domain.

### Tabs Available in this Dialog Box

**Note:** To configure this dialog box, you must be a member of a security role assigned the **Auto Attendant - Administer** task. If you are a member of a role assigned the **Auto Attendant - View** task, you have read-only access to this dialog box. See **Security Roles Dialog Box** on page 3-88.

- **Attendant Main Menu Editor** Use this tab to configure the Automated Attendant main menu for a voice mail domain.

  You can assign a custom prompt to the Automated Attendant main menu and configure properties for DTMF key pad numbers. See **Auto Attendant - Attendant Main Menu Editor Tab** on page 3-62.

- **Holidays** Use this tab to configure the Automated Attendant holiday prompts for a voice mail domain.

  You can set up custom prompts to be played on up to 18 specific dates, for example, when the office is closed for a public holiday. See **Auto Attendant - Holidays Tab** on page 3-65.

- **Time of Day** Use this tab to configure a voice mail domain with the prompts to play at certain times of the day. You can set up different prompts for morning, afternoon, evening, or closed for business hours. See **Auto Attendant - Time of Day Tab** on page 3-66.

- **Language/Key Association** Use this tab to configure languages, if you require more than one language to be available to callers in a voice mail domain.
You can set the system to present a list of language options to callers as the first prompt they hear, when calling in to the system. You can also assign a keypad digit and Automated Attendant main menu greeting to each language supported by the Telephone User Interface (TUI). See Auto Attendant - Language/Key Association Tab on page 3-67.

**Note:** Selecting any language options in the Language/Key Association tab automatically disables the Auto Attendant Main Menu Prompt on the Attendant Main Menu Editor tab. If you want your initial prompt to callers to include other options as well as language selection, you should *not* use the Language/Key Association tab. Instead, you can use the system Automated Attendant and Caller Applications.
Auto Attendant - Attendant Main Menu Editor Tab

The Automated Attendant’s main menu helps callers to navigate through the Telephone User Interface (TUI). It provides them with menu options they can select using DTMF key presses.

Use the Auto Attendant dialog box, Attendant Main Menu Editor tab to configure the Automated Attendant main menu.

You can assign a custom prompt, for example, “For sales, press 1. For technical support, press 2. For accounting, press 3.” You can also configure Automated Attendant main menu properties for DTMF key pad numbers.

If the Auto Attendant Main Menu Prompt is not customized, the default is: “Please enter the mailbox number of the person you are calling. If you have a mailbox on this system, press #. For assistance, press 0.”

Then, if callers are allowed to use Dial by Name: “If you do not know the mailbox number, press * to spell the name.”

Followed by: “If you do not have a DTMF telephone or require assistance, please stay on the line.”

**Note:** The options in the Attendant Main Menu Editor tab are unavailable, if any languages have been selected in the Language/Key Association tab, see Auto Attendant - Language/Key Association Tab on page 3-67.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Auto Attendant. The system displays the Auto Attendant dialog box for the selected voice mail domain, with the Attendant Main Menu Editor tab active.
Configuring the Screen Controls

- **Auto Attendant Main Menu Prompt**  Enter the number of the main Automated Attendant prompt as recorded in **Visual Voice Editor**. The range is 0 through 9999, and the default is 0.

  If 0 is selected, the system uses the pre-recorded system prompt: “Please enter the mailbox number of the person you are calling. If you have a mailbox on this system, press #. For assistance, press 0.”

  **Note:** You can record custom prompts or import recordings to assign to custom prompts using the **Visual Voice Editor** application. Avaya recommends that you create these prompts and make a note of their prompt numbers, before configuring the **Auto Attendant** dialog box. See Chapter 5, “**Visual Voice Editor (Custom Prompts)**”.

- **1, 2, 3, 4, 5, 6, 7, 8, 9**  Select a DTMF keypad digit to configure, 1 through 9.

  **Note:** The keys for *, # and 0 are reserved for system use and cannot be configured.

  When you have selected a number, use the **Key Settings** option button to configure the properties for that number. The selection then appears in the grayed out box to the right of the number.

- **Key Settings**  Use these option buttons to configure the selected key number above.

  - **Invalid**  Select to indicate this key is an invalid option. Use this setting, if you specifically do not want to associate any action with the key press. This is the default.

  - **Directory**  Select to allow the caller to use the Dial By Name feature, when this key is pressed. The Dial By Name feature allows a caller to search for a subscriber extension or mailbox number by “spelling” the person’s name using the telephone keypad.
— **Message**  Select to allow a caller to leave a voice message, when this key is pressed and followed by the mailbox number. This feature is called Quick Message.

---

**Notes:**

- If you select this option, ensure that you perform one of these actions:
  
  — Either record your Automated Attendant main menu prompt to notify callers that they must enter this key press, followed by the extension of the subscriber they are trying to reach.
  
  — Or instruct your subscribers that they must include this key press as the first digit, when giving their extension number to potential callers.

- If the key number you configure as **Message** happens to be the same as the first digit of a mailbox number, Automated Attendant will go directly to voicemail instead of performing the transfer to the extension associated with the mailbox.

  Some customers use this feature to create ranges of mailboxes that would never have physical transfers. If you wish to disable this feature, you can do so in the Registry on every MAS. For more information, see your Registry Configuration notes.

---

— **Transfer to**  Select to allow the caller to transfer to the mailbox number you enter in the **Mailbox Number** field.

This option is useful for transferring callers to particular departments. For example, “For technical support, press 2”.

— **Mailbox Number**  Enter the number of the mailbox to transfer to.

---

**Notes:**

- The mailbox number you enter must have the correct number of digits, as required by the **Number of Digits in a Mailbox** field in the **Telephone User Interface** dialog, **General** tab (see **Telephone User Interface - General Tab** on page 3-40).

- This mailbox number can be associated with a caller application. For more information, see Chapter 6, “Caller Applications Editor”. 
Auto Attendant - Holidays Tab

Use the Auto Attendant dialog box, Holidays tab to configure the Automated Attendant holiday prompts for a voice mail domain. You can set up alternate prompts to be played on specific dates, for example, when the office is closed for a public holiday. You can configure up to 18 holidays to be active at one time.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Auto Attendant. The system displays the Auto Attendant dialog box for the selected voice mail domain, with the Attendant Main Menu Editor tab active.

3. Click the Holidays tab.

Configuring the Screen Controls

- **Date**  Enter the date on which an alternate greeting is to be played. The format is DD/MM. You can specify up to 18 dates as holidays.

- **Prompt** Enter the number of the holiday prompt as recorded in Visual Voice Editor. The range is 0 through 9999, and the default is 0.

  If 0 is selected, no holiday prompt is played.

---

**Note:** You can record custom prompts or import recordings to assign to custom prompts using the Visual Voice Editor application. Avaya recommends that you create these prompts and make a note of their prompt numbers, before configuring the Auto Attendant dialog box. See Chapter 5, “Visual Voice Editor (Custom Prompts)”.
Auto Attendant - Time of Day Tab

Use the **Auto Attendant** dialog box, **Time of Day** tab to configure a voice mail domain with the prompts to play at certain times of the day. This means that you can set up different prompts for morning, afternoon, evening or closed for business hours.

**Notes:**

- Your organization’s daily business hours are defined in the **Telephone User Interface** dialog box, **Time/Greeting** tab. See **Telephone User Interface - Time/Greeting Tab** on page 3-46.

- You can record custom prompts or import recordings to assign to custom prompts using the **Visual Voice Editor** application. Avaya recommends that you create these prompts and make a note of their prompt numbers, before configuring the **Auto Attendant** dialog box. See Chapter 5, “Visual Voice Editor (Custom Prompts)”.

**Launching the Screen**

1. In the **Voice Mail System Configuration** window, click the voice mail domain.

2. Double-click **Auto Attendant**. The system displays the **Auto Attendant** dialog box for the selected voice mail domain, with the **Attendant Main Menu Editor** tab active.

3. Click the **Time of Day** tab.

**Configuring the Screen Controls**

- **Morning Prompt** Enter the number of the custom prompt that greets callers during morning business hours, as recorded in **Visual Voice Editor**.

- **Afternoon Prompt** Enter the number of the custom prompt that greets callers during afternoon business hours, as recorded in **Visual Voice Editor**.

- **Evening Prompt** Enter the number of the custom prompt that greets callers during evening business hours, as recorded in **Visual Voice Editor**.

- **Closed Prompt** Enter the number of the custom prompt that greets callers after business hours, as recorded in **Visual Voice Editor**.

For each prompt, the range is 0 through 9999, and the default is 0. If 0 is selected, the standard prompt is played: “Welcome to Avaya Messaging.”
Auto Attendant - Language/Key Association Tab

Use the Auto Attendant dialog box, Language/Key Association tab to configure languages, if you require more than one language to be available to callers.

You can set the system to present a list of language options to callers as the first prompt they hear, when calling in to the system. You can also assign a keypad digit and Automated Attendant main menu greeting to each language supported by the Telephone User Interface (TUI).

Notes:

- You can record custom prompts or import recordings to assign to custom prompts using the Visual Voice Editor application. Avaya recommends that you create these prompts and make a note of their prompt numbers, before configuring the Auto Attendant dialog box. See Chapter 5, “Visual Voice Editor (Custom Prompts)”.

- Selecting any language options in the Language/Key Association tab automatically disables the Auto Attendant Main Menu Prompt on the Attendant Main Menu Editor tab. See Auto Attendant - Attendant Main Menu Editor Tab on page 3-62.

If you want your initial prompt to callers to include other options as well as language selection, you should not use the Language/Key Association tab. Instead, you can use the system Automated Attendant and Caller Applications, see Chapter 6, “Caller Applications Editor”.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Auto Attendant. The system displays the Auto Attendant dialog box for the selected voice mail domain, with the Attendant Main Menu Editor tab active.

3. Click the Language/Key Association tab.

Configuring the Screen Controls

- Language 1, 2, 3 Select the language that you want to configure in each of these three fields. You can select any language supported by the TUI.
- **DTMF Key 1, 2, 3** Select Dual Tone Multi-Frequency (DTMF) keys for each associated language. You can select any DTMF key from 1 through 9.

  **Note:** The keys for *, # and 0 are reserved for system use and cannot be configured.

- **Main Menu Greeting 1, 2, 3** Enter the number of the main Automated Attendant custom prompt, as recorded in Visual Voice Editor, for each associated language. The range is 0 through 9999, and the default is 0.

  If 0 is selected, the system uses the pre-recorded system prompt in the appropriate language.

- **Custom Language Selection Greeting** Enter a prompt number in this field, if you want to replace the default system language selection prompt with a custom prompt recorded in Visual Voice Editor. The range is 0 through 9999, and the default is 0.

  If 0 is selected, the system uses the default system language selection prompt similar to the following: “For English, press one. Pour français, appuyez sur le deux.” The prompt for each language is in that language.

  Callers can select the desired language by pressing the appropriate key on their DTMF keypads. When they do, they hear all subsequent prompts in the selected language.
Call Me Dialog Box

**Note:** For a detailed overview of voice mail domain configuration in the Voice Mail System Configuration (VMSC) application, see Overview of VMD Configuration in VMSC on page 3-3.

This topic describes how to use the Call Me dialog box to configure Call Me for a voice mail domain.

With Call Me, subscribers can configure the system to call them, at one or more designated numbers, each time they receive a message that meets certain criteria. The subscriber can then log on to the Telephone User Interface (TUI) in order to review the message.

You can use the Call Me dialog box to enable the Call Me feature for the voice mail domain. You can specify the Messaging Application Server (MAS) on which the MM Call Me Server service is installed. You can also configure concurrency, interval and retry settings.

**Notes:**

- When the message store server (Avaya MSS) is offline and Offline Access to call-answered messages is configured, the Call Me feature does not operate unless the MM Mailbox Monitor service is still online and the MM Call Me Server service is able to contact an MAS in the voice mail domain. For more information about Offline Access, see Understanding Offline Access on page 3-180.

- You can use the Voice Mail System Configuration application’s Call Me dialog box to configure the Call Me feature for the entire system. Individual settings can be configured for each subscriber:
  
  — Subscribers set up their own rules for using Call Me in Subscriber Options. For more information, see Avaya Modular Messaging Subscriber Options Guide.

- For more information on Call Me, see Avaya Modular Messaging Concepts and Planning Guide.

**Launching the Screen**

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Call Me. The system displays the Call Me dialog box for the selected voice mail domain, with the General tab active.
Configuring the Screen Controls

**Note:** To configure this dialog box, you must be a member of a security role assigned the **Call Me - Administer** task. If you are a member of a role assigned the **Call Me - View** task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

- **Enable Call Me**  To enable the Call Me feature, select this check box. By default, this check box is cleared and this feature is not enabled.

  Selecting this check box enables the other fields in the tab.

  - **MAS Call Me Server**  Enter the name of the MAS, or supplementary server, on which the **MM Call Me Server** service is installed. You can use the browse button (…) to locate the server. For more information on services, see Appendix C, Modular Messaging (MM) Services.

  - **Maximum number of concurrent calls**  This parameter controls the number of concurrent Call Me processes supported by the voice mail system. This number should not exceed the number of ports configured for Call Me in the voice mail domain. The range is 1 through 24, and the default is 5.

  The value of this field also controls the maximum number of outcalls that the voice mail system can initiate simultaneously. However, once a call has been initiated and connected, another process takes over. The system is then free to initiate another outcall. This means you can have more than 24 ports with outcalls in progress.

  For information on configuring port groups for Call Me, see MAS - Port Groups Dialog Box on page 4-25.

  - **System minimum interval between calls (mins)**  Enter the time, in minutes, for the minimum interval between calls. The interval determines the minimum time allowed between mailbox checks for messages meeting specified criteria. It also determines the minimum time allowed between call retries to the subscriber's telephone number, if the line is busy. The range is 1 through 1000, and the default is 3.

  - **System default interval between calls (mins)**  Enter the time, in minutes, for the default interval between calls. The system displays the default interval time in the Call Me rule. The range is 1 through 1000, and the default is 10.

  - **Line busy retries**  Enter the maximum number of retries attempted for a number, if the system receives a line busy signal. The range is 0 through 5, and the default is 2.
Notify Me Dialog Box

Note: For a detailed overview of voice mail domain configuration in the Voice Mail System Configuration (VMSC) application, see Overview of VMD Configuration in VMSC on page 3-3.

This topic describes how to use the Notify Me dialog box to configure Notify Me for a voice mail domain.

With Notify Me, subscribers can configure the system to send an e-mail or e-mail client to their pager, each time they receive a message that meets certain criteria. The subscriber can then call the Modular Messaging system in order to review the message.

You can use the Notify Me dialog box to enable the Notify Me feature for the voice mail domain.

Notes:

- The Call Me feature does not need to be enabled, but the MM Call Me Server service must be running in the voice mail domain, before the Notify Me feature can be enabled. For more information, see Appendix C, Modular Messaging (MM) Services.

- You can use the Notify Me dialog box to configure the Notify Me feature for the entire system. Individual settings can be configured for each subscriber:
  - Subscribers set up their own rules for using Notify Me in Subscriber Options. For more information, see Avaya Modular Messaging Subscriber Options Guide.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Notify Me. The system displays the Notify Me dialog box for the selected voice mail domain, with the General tab active.
Configuring the Screen Controls

**Note:** To configure this dialog box, you must be a member of a security role assigned the **Notify Me - Administer** task. If you are a member of a role assigned the **Notify Me - View** task, you have read-only access to this dialog box. See **Security Roles Dialog Box** on page 3-88.

- **Enable Notify Me**  To enable the Notify Me feature for the voice mail domain, select this check box. By default, this check box is enabled.
Message Waiting Indicator Dialog Box

Note: For a detailed overview of voice mail domain configuration in the Voice Mail System Configuration (VMSC) application, see Overview of VMD Configuration in VMSC on page 3-3.

This topic describes how to use the Message Waiting Indicator dialog box to configure the message waiting indicator (MWI) for a voice mail domain.

With MWI, subscribers can configure the system to alert them, using a lamp indicator on their telephone, or an audible tone (stutter dial-tone), each time they receive a message that meets certain criteria. The indicator is cleared using the Telephone User Interface (TUI) or a client.

You can use the Message Waiting Indicator dialog box to enable the MWI feature. You can specify the Messaging Application Server (MAS) on which the MM Message Waiting Indicator Server service is installed, and list any MASs that support MWI. You can configure and enable a schedule for when mailboxes should be updated by the MWI service, and manage the frequency of MWI update requests. You can configure the system to check MWI lamp states either in the message store or in the local cached MWI database.

If you wish to perform an on-demand update, you must use the Start On-Demand MWI Update dialog box. See Start On-Demand MWI Update Dialog Box on page 3-78.

Notes:

- If you find it necessary to re-install the MWI software after the initial system installation, you must first stop all Avaya Modular Messaging services on the MAS before installing it. Remember to restart those services when the software installation is complete. See Appendix C, Modular Messaging (MM) Services.

- When the message store server (Avaya MSS) is offline and Offline Access to call-answered messages is configured, the MWI feature does not operate unless the MWI server is still online and the MM Message Waiting Indicator Server service is able to contact another MAS in the voice mail domain. MWI is never triggered by the arrival of call-answered messages at an offline MAS. For more information about Offline Access, see Understanding Offline Access on page 3-180.

- You can use the Message Waiting Indicator dialog box and Start On-Demand MWI Update dialog box to configure the MWI feature for the entire system. Individual mailboxes can be configured for each subscriber:
  
  — Subscribers set up their own rules for using MWI in Subscriber Options. For more information, see Avaya Modular Messaging Subscriber Options Guide.
Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).

2. Double-click Message Waiting Indicator. The system displays the Message Waiting Indicator dialog box for the selected voice mail domain.

Tabs Available in this Dialog Box

Note: To configure this dialog box, you must be a member of a security role assigned the Message Waiting Indicator - Administer task. You must also have local admin rights in Windows. If you are a member of a role assigned the Message Waiting Indicator - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

- **General**  Use this tab to configure MWI properties for a voice mail domain. You can enable the MWI feature, enable scheduled updates, and manage the frequency of MWI update requests. You can specify the MAS on which the MM Message Waiting Indicator Server service is installed, and list any MASs that support MWI.

  See Message Waiting Indicator - General Tab on page 3-75.

- **Update Schedule**  Use this tab to configure a schedule for when mailboxes should be updated by the MWI service. You can configure the system to check MWI lamp states in the message store or just in the local cached MWI database.

  See Message Waiting Indicator - Update Schedule Tab on page 3-77.
Message Waiting Indicator - General Tab

Use the Message Waiting Indicator dialog box, General tab to configure MWI properties for a voice mail domain. You can enable the MWI feature, enable scheduled updates, and manage the frequency of MWI update requests. You can specify the Messaging Application Server (MAS) on which the MM Message Waiting Indicator Server service is installed, and list any MASs that support MWI.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Message Waiting Indicator. The system displays the Message Waiting Indicator dialog box for the selected voice mail domain, with the General tab active.

Configuring the Screen Controls

- **Enable Message Waiting Indicator (MWI)** Select to enable MWI for the system. By default, this check box is cleared.

  When this check box is selected, the other fields in the tab are activated.

  **Note:** If your system has more than one MAS, you should enable MWI on only one MAS.

- **MAS MWI server** Enter the name of the MAS, or supplementary server, on which the MM Message Waiting Indicator Server service is installed. You can use the browse button (…) to locate the server. For more information on services, see Appendix C, Modular Messaging (MM) Services.

- **Scheduled MWI updates** Select Active to activate the scheduled times for updating the MWI service. If you select Inactive, there are no scheduled MWI updates.

  **Note:** The scheduled times are set on the Update Schedule tab. See Message Waiting Indicator - Update Schedule Tab on page 3-77.

- **Limit requests** Select the check box to restrict the number of MWI requests made per minute. By default, this check box is cleared.

  Selecting this check box activates the Maximum requests per minute field.
— **Maximum requests per minute** Enter the maximum number of MWI requests that can be made to the MWI MAS per minute. The default is 60.

**Note:** This field is available, only if you have selected the Limit requests check box.

**Message Application Servers that support MWI** This displays a list of MASs in the voice mail domain that support MWI.

**Note:** If you are using per-port integration (e.g. Inband, QSIG or set emulation), an MAS can support MWI, only if it has an MWI port group defined. See [Rules for Creating Port Groups](#) on page 4-27.

— Adds a line to the list. You can then enter the name of the MAS or select the server using the browse button (...).

— Deletes the MAS selected in the list. The system prompts you to confirm the deletion.

— Moves the selected MAS up or down the list. The first MAS in the list is the first MAS to which MWI requests are made.
Message Waiting Indicator - Update Schedule Tab

Use the Message Waiting Indicator dialog box, Update Schedule tab to configure a schedule for when mailboxes should be updated by the MWI service. You can configure the system to check MWI lamp states in the message store or just in the local cached MWI database.

Notes:

- If there are no known issues, Avaya recommends that you do not use the automated update schedule as it could impact the performance of the system.

- Avaya recommends that necessary updates be done at non-peak hours, not at midnight, when the Avaya MSS backup is done, and not during the hours when tracing jobs are scheduled to run.

- If you wish to perform an on-demand update, you must use the Start On-Demand MWI Update dialog box. See Start On-Demand MWI Update Dialog Box on page 3-78.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Message Waiting Indicator. The system displays the Message Waiting Indicator dialog box for the selected voice mail domain, with the General tab active.

3. Click the Update Schedule tab.

Configuring the Screen Controls

- Use cached MWI lamp state Select this option, if you wish the system to check the local cached MWI database to see whether the user has messages. This option is faster but the data may be out-of-date.

- Re-evaluate mailbox MWI rules for lamp state Select this option, if you wish the system to go to the message store to see whether the user has messages. This option takes longer but provides the most up-to-date data.

- Interval Select 1 Hour (default), 15 minutes or 5 Minutes to set the time intervals for the cells in the schedule grid.

For information on how to set up the times in the schedule grid, see Schedule Grid on page 3-56.
Start On-Demand MWI Update Dialog Box

Note: For a detailed overview of voice mail domain configuration in the Voice Mail System Configuration (VMSC) application, see Overview of VMD Configuration in VMSC on page 3-3. For more information about Message Waiting Indicator settings, see Message Waiting Indicator Dialog Box on page 3-73.

Use the Start On-Demand MWI Update dialog box to perform an on-demand update of mailboxes by the MWI service. You can update either a single mailbox, a range, or all mailboxes in the voice mail domain. You can configure the system to check MWI lamp states either in the message store or in the local cached MWI database. You can set a priority level for the update and view the progress, if you wish.

Notes:

- Avaya recommends that necessary updates be done at non-peak hours, not at midnight, when the Avaya MSS backup is done, and not during the hours when tracing jobs are scheduled to run.

- If you wish to perform scheduled updates, you must configure the Message Waiting Indicator dialog box, Update Schedule tab. See Message Waiting Indicator - Update Schedule Tab on page 3-77.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).
2. Click the Message Waiting Indicator node.
3. Select Start MWI Update... from the right-click menu. The system displays the Start On-Demand MWI Update dialog box for the selected voice mail domain.

Configuring the Screen Controls

Note: To configure this dialog box, you must be a member of a security role assigned the Message Waiting Indicator - Administer task or Message Waiting Indicator - Reset Lamps task. If you are a member of a role assigned the Message Waiting Indicator - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

- Update the Message Waiting Indicator for the following  Select the appropriate option.
— **All mailboxes in voice mail domain**  (Default) Select to perform an MWI update of all mailboxes in the voice mail domain.

— **Mailbox**  Select to perform an MWI update on a particular mailbox. Enter the mailbox number in the field to the right.

— **Mailboxes in the following range** Select to perform an MWI update on a range of mailboxes.
  - **From/To** Enter the lowest and highest mailbox numbers respectively in these fields.

— **When should the mailboxes be updated by the MWI server?** Select the appropriate option.

— **Use cached MWI lamp state**  Select this option, if you wish the system to check the local cached MWI database to see whether the user has messages. This option is faster but the data may be out-of-date.

— **Re-evaluate mailbox MWI rules for lamp state**  Select this option, if you wish the system to go to the message store to see whether the user has messages. This option takes longer but provides the most up-to-date data.

— **Priority level** Select the priority level for the update, if several MWI updates are in the queue. The options are **Low** (default), **Standard** or **High**.

— **Description** Enter a short name to identify the MWI update. This name appears on the tab for the update, in the **Progress** window.

— **Show progress window** Select to show a **Progress** window during the on-demand MWI update. This window contains tabs for each update which is currently in progress.

**Note:** If you do not select this check box before clicking **OK**, you can still choose to show the **Progress** window. Select **Show MWI Progress** from the right-click menu off the **Message Waiting Indicator** node.
With Fax, Modular Messaging subscribers can send and receive faxes using their mailboxes.

This topic describes how to use the Fax dialog box to configure Avaya’s Native Fax Support for a voice mail domain.

Notes:

- With Avaya’s Native Fax Support:
  
  — Only one server, a Messaging Application Server (MAS) or supplementary server, is selected to use the **MM Fax Sender Server** service to process outgoing faxes for the voice mail domain.

  — During the Modular Messaging installation on this server, the **MM Fax Service Provider** is installed and registered automatically, and a Local Fax Printer is created. You can make this printer available as a Network Fax Printer. For more information, see *Microsoft Fax Printer Configuration* on page 3-86.

  — In order for Modular Messaging subscribers to be able to print using the Network Fax Printer, the Windows Fax service must be installed on their PC client. For more information, see *Avaya Modular Messaging Subscriber Options Guide*.

  — Whenever a subscriber successfully sends a fax, the system generates a message to the subscriber’s mailbox confirming that the fax was successfully sent. If you do not want this confirmation sent out for every fax message, you can disable it. For more information, see your Registry Configuration notes.

- Fax is currently unavailable for IP H.323 integrations.
Launching the Screen

1. In the **Voice Mail System Configuration** window, click the voice mail domain.

2. Double-click **Fax**. The system displays the **Fax** dialog box for the selected voice mail domain, with the **General** tab active.

Configuring the Screen Controls

**Note:** To configure this dialog box, you must be a member of a security role assigned the **Fax - Administer** task. If you are a member of a role assigned the **Fax - View** task, you have read-only access to this dialog box. See **Security Roles Dialog Box** on page 3-88.

- **Fax Enable**  
  Select to enable Fax for the voice mail domain. This check box is cleared by default. When this check box is selected, the other fields in the tab are enabled.

- **Native Fax Support**

  — **MAS Fax Sender Server**  
  Enter the name of the MAS, or supplementary server, on which the **MM Fax Sender Server** service is installed. You can use the **Browse** button to locate the server. For more information on services, see **Appendix C. Modular Messaging (MM) Services**.

  — **Fax Mailbox**  
  Enter the mailbox number of the mailbox which is used for outgoing faxes on the Avaya Message Store Server (Avaya MSS).

  **Note:** This number must match the number in the **Fax Mailbox Number** field on the **Configure Subscriber Management** page of the Avaya MSS.

  — **Company Fax Number**  
  Enter the fax number that appears on any outgoing fax cover pages.

  — **Cover Page...**  
  Use this button to define company identification that appears on the cover page. See **Fax - Fax Cover Page Dialog Box** on page 3-83.

  — **Advanced...**  
  Use this button to define advanced parameters for fax transmissions. See **Fax - Advanced Fax Dialog Box** on page 3-84.

- **Fax Send Speed**  
  Select the speed with which the fax is sent, in baud. The range is 4800 to 14400. The default is 9600.

- **Fax Receive Speed**  
  Select the speed with which the fax is received, in baud. The range is 4800 to 14400. The default is 9600.
- **Canonical Addressing** Select this check box, if your fax servers support canonical addressing. This enables the **Country Code** and **Area Code** fields, and the **Access Codes** button.

Canonical addressing specifies the full fax telephone number for the voice mail domain, for use by the Telephone User Interface (TUI). When a subscriber wants to send a fax, the system prompts for these outgoing numbers or allows alternative entries as an aid to addressing. The canonical address also allows the system to prevent unnecessary toll calls, if the receiver of the fax uses the same country code or area code as the sender.

The canonical address precedes the subscriber number with the country code and area code, for example, +1408.

If you enable canonical addressing, you must specify a default country code and area code for this voice mail domain.

- **Country Code** Enter the code for the country.

- **Area Code** Enter the code for the area within the country.

- **Access Codes...** Use this button to configure access codes required for fax transmission. See *Fax - Access Codes Dialog Box* on page 3-85.
Fax - Fax Cover Page Dialog Box

With Avaya’s Native Fax Support, you can use the Fax Cover Page dialog box to define the text of fax cover pages.

Launching the Screen

To reach this dialog box, you must click the Cover Page... button on the General tab of the Fax dialog box (see Fax Dialog Box on page 3-80).

Configuring the Screen Controls

- **Company Name**  Enter your company name. Any characters are accepted.

- **Company Address** Enter the address of your company. Any characters are accepted.

  Press the Enter key on your keyboard before each part of the address that you want to appear on a separate line on the cover page. For example:

  55555 W. Main St.
  New York, NY 10005
  U.S.A.

- **Send cover page for fax printer jobs** Select to include a Modular Messaging cover page for fax messages sent using the Client Fax Printer.

  **Note:** If this check box is not selected, then Client Fax Printer jobs must have a subscriber-provided cover page.
Fax - Advanced Fax Dialog Box

With Avaya’s Native Fax Support, you can use the Advanced Fax dialog box to configure advanced settings for faxes.

Launching the Screen

To reach this dialog box, you must click the Advanced… button on the General tab of the Fax dialog box (see Fax Dialog Box on page 3-80).

Configuring the Screen Controls

- **Retry Interval**

  **Note:** This setting is only valid for faxes sent using the Telephone User Interface (TUI). For faxes sent from client machines, this setting is controlled by the Microsoft Fax Service.

  - **Normal Messages (sec)** Enter the maximum time allowed between retries, in seconds, when sending non-urgent fax messages. The range is 30 through 1800. The default is 300.

  - **Urgent Messages (sec)** Enter the maximum time allowed between retries, in seconds, when sending urgent fax messages. The range is 30 through 1800. The default is 120.

- **Max No. Retries** Enter the maximum number of retries allowed, when sending fax messages. The range is 1-99. The default is 12.

  **Note:** This setting is only valid for faxes sent using the TUI. For faxes sent from client machines, this setting is controlled by the Microsoft Fax Service.

- **Max Concurrent Outgoing Calls** Enter the maximum number of concurrent outgoing fax calls allowed. The range is 0-200. The default is 0, which means use as many lines as possible.

- **Max Pages Per Fax** Enter the maximum number of pages that a single fax can include. The range is 1-100. The default is 100.
Fax - Access Codes Dialog Box

The Access Codes dialog box allows you to enter access codes for the fax address, if you are using canonical addressing.

Launching the Screen

To reach this dialog box, you must click the Access Codes... button on the General tab of the Fax dialog box (see Fax Dialog Box on page 3-80).

Configuring the Screen Controls

- **Trunk Code**  Enter the code used to dial outside of the local dialing plan.

- **Long Distance Code**  Enter the code to dial a number outside the local area codes. For example, 1, if you are in the United States.

- **International Code**  Enter the code used to dial an international number. For example 011, if you are dialing from the United States.
Microsoft Fax Printer Configuration

With Native Fax Support, only one server in the voice mail domain, either a Messaging Application Server (MAS) or supplementary server, uses the MM Fax Sender Server service to process outgoing faxes. For more information on services see, Appendix C, Modular Messaging (MM) Services.

During the Modular Messaging installation on this server, the MM Shared Fax Driver is installed, the MM Fax Service Provider is installed and registered automatically, and a Local Fax Printer is created.

You must make this printer available as a Network Fax Printer. You may also need to modify the rights on the share and fax object to control access to it.

Note: In order for Modular Messaging subscribers to be able to print using the Network Fax Printer, the Windows Fax service must be installed on their PC client. For more information, see Avaya Modular Messaging Subscriber Options Guide.

Procedure 1: Sharing the Microsoft Fax Printer on the MAS Running the MM Fax Sender Server Service

1. Verify that the MM Fax Sender Service is Started and set to Automatic.

2. On your Windows desktop, click the Start > Settings > Printers and Faxes menu to launch the Printers and Faxes window.

3. Right-click the Fax and select Properties. This opens the Properties dialog box.

4. In the Sharing tab, select Share this printer. Leave the Share name as Fax, and enable the List in the directory check box.

   Note: Steps 5, 6, and 7 are applicable if the MM Shared Fax Driver is installed on a S8730 server platform running Microsoft Windows Server 2003 R2. Otherwise, proceed to step 8.

5. Click Additional Drivers to install additional print drivers. Installing additional print drivers enables users of different Windows versions to connect to the shared network printer. This opens the Additional Drivers dialog box.

6. Select the operating systems that are allowed to download the installed drivers on connecting to the network.

7. Click OK.

8. In the Configuration tab, select Fax Service Manager.
9. Right-click **Fax (local)** and select **Properties**.

10. In the **Security** tab, add the **Network Service Account** to the list of users and groups with access.

    **Note:** If this system uses the private Windows domain, add the **MM Fax User Account** to the list of users and groups with access.

11. Assign **Fax**, **Manage Fax Configuration** and **Manage Fax Documents** permissions to the **Network Service Account**.

12. You can configure any other settings as necessary, then click **OK**.
Security Roles Dialog Box

**Note:** For a detailed overview of voice mail domain configuration in the Voice Mail System Configuration (VMSC) application, see Overview of VMD Configuration in VMSC on page 3-3.

This topic describes how to use the Security Roles dialog box to set up members and tasks for Role-Based Access Control (RBAC) in the voice mail domain.

**Note:** To configure the Security Roles dialog box and use these menu commands, you must be a member of a security role assigned the Security - Administer task. If you are a member of a role assigned the Security - View task, you have read-only access to this dialog box.

With RBAC, the members of the role are the people who have the capabilities of the role, and the tasks control what the members of the role are allowed to do.

There are preset roles for Servers, System Administrator, System Auditor, Subscriber Administrator, Subscriber Auditor, and Subscriber Helpdesk. These are standard configurations with the optimum tasks assigned to the role. You can assign members to these roles.

**Note:** The preset role for Servers is intended for servers to have access to perform their duties. This role has the full range of system administration and subscriber administration tasks.

You can create new roles where you can select task assignments from a list, and assign members to these roles.
Notes:

- Permission to administer the message store server (Avaya MSS) is controlled by the store itself, not the MAS.

- Security roles apply to all Modular Messaging Windows servers in a voice mail domain, including Web Client servers, MASs, and supplementary servers.

- Changes to roles are enforced as soon as possible by the Modular Messaging Windows servers, but within 5 minutes of the changes. It is not necessary to restart the servers when changes are made to roles.

- You can use security roles to control access to configuring:
  - These system administration tools: Voice Mail System Configuration, the parts of the Caller Applications Editor that control deployment.
  - This diagnostic and reporting tool: Port Monitor.
  - These subscriber administration tools: Subscriber Options in administrator mode.

- Security roles do not apply to:
  - This system administration tool: Visual Voice Editor. You can, however, set the permissions on the prompt files so that only the required users have permissions to write to them.
  - These diagnostic and reporting tools: Reporting Tool, Operation History Viewer, Performance Monitoring - Modular Messaging Counters, the Dialogic Line Tester, the Modular Messaging Snapshot Utility, and the MM Audit Log Viewer.

- If you prefer to perform most of your role administration using Windows Active Directory then you could, for example, create a domain group called “MM System Administrators”, and add that as a member of the System Administrator role. You could then grant users permission to administer Modular Messaging by adding them to a Windows group. You should be careful to monitor the membership of this group, however, to ensure that changes do not affect access to Modular Messaging.
Preset Roles

- **Servers**  This role is intended for servers to have access to perform their duties. This role has the full range of system administration and subscriber administration tasks.

  **Note:** All MASs in the voice mail domain must be members of this role. When an MAS is added to the voice mail domain, it is added as a member automatically.

- **System Administrator**  The tasks assigned to this role mean that its members can view and change anything in Voice Mail System Configuration, Port Monitor, Password Policy Editor, and the parts of the Caller Applications Editor that control deployment. This replaces the System Administration ACL that was used in previous versions of Avaya Modular Messaging.

  **Note:** The other administrative and diagnostic tools that run on the MAS are not security controlled.

- **System Auditor**  The tasks assigned to this role mean that its members have read-only access to all the system administration settings listed above.

- **Subscriber Administrator**  The tasks assigned to this role mean that its members can start Subscriber Options in administrator mode, to administer a mailbox on behalf of a subscriber. This replaces the Subscriber Administration ACL that was used in previous versions of Avaya Modular Messaging.

- **Subscriber Auditor**  The tasks assigned to this role mean that its members have read-only access to all the subscriber administration settings listed above.

- **Subscriber Helpdesk**  The tasks assigned to this role mean that its members can reset the fax authorization code, but have view-only access to other settings.

Configuring Customer-Created Roles

You can also create new roles where you can select task assignments from a list. For information on creating, copying, renaming or deleting these roles, see Create/Copy/Rename Roles Dialog Box on page 3-92.
Launching the Security Roles Dialog Box

1. In the **Voice Mail System Configuration** window, click the voice mail domain.

2. Double-click **Security Roles**.

   The system displays preset roles **Servers**, **System Administrator**, **System Auditor**, **Subscriber Administrator**, **Subscriber Auditor**, and **Subscriber Helpdesk**.

   There might also be customer-configured roles.

3. Double-click the required role. The system displays the **Security Roles** dialog box for the selected role.

Tabs Available in this Dialog Box

- **Members** Use this tab to configure the users and groups who should have the capabilities of the role.

  See **Security Roles - Members Tab** on page 3-94.

- **Tasks** Use this tab to view which tasks the role is allowed to perform. For customer-configured roles, you can change the tasks that are allowed.

  See **Security Roles - Tasks Tab** on page 3-96.
Create/Copy/Rename Roles Dialog Box

You can create new roles, copy existing roles, rename them or delete them.

Creating a New Role

1. In the Voice Mail System Configuration window, click the voice mail domain node.

2. Right-click the Security Roles node in the Voice Mail Domain System Configuration window.

3. Click the Create New Role... command. This opens the Create New Role window.

4. Type in the Role name and click OK. The role then appears in the tree.

When you open the dialog box, you can add tasks and assign members.

Copying an Existing Role

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Click the Security Roles node. All the roles appear in the tree.

3. Right-click one of the preset roles ( and ), or a customer-configured role.

4. Click the Copy Role... menu command. This opens the Copy Role window.

5. Type in the Role name and click OK. The role then appears in the tree.

When you open the dialog box for that role, the tasks of the role you copied are already selected. You can then add/remove tasks and assign members.
Renaming a Customer-Configured Role

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Click the Security Roles node. All the roles appear in the tree.
3. Right-click a customer-configured role.

4. Click the Rename Role... menu command. This opens the Rename Security Role window.
5. Type in the new Role name and click OK. The role then appears in the tree with a new name. The tasks and members remain as they were.

Removing a Customer-Configured Role

The Remove Role menu command deletes the customer-configured role. You are prompted to confirm the deletion.

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Click the Security Roles node. All the roles appear in the tree.
3. Right-click a customer-configured role.

   **Note:** You cannot remove any of the preset roles ( and ).

4. Click the Remove Role menu command. You are prompted to confirm the deletion.

   The role is then removed from the tree.
Security Roles - Members Tab

Use the Security Roles dialog box, Members tab to configure the users and groups who should have the capabilities of the role.

Notes:

- The Servers role is the only role where you can add computer local system accounts as members.
- When the Modular Messaging system is first installed, all server local system accounts are included as members of the Servers role.
- All MASs in the voice mail domain must be members of the Servers role. When an MAS is added to the voice mail domain, it is added as a member automatically.
- When the Modular Messaging system is first installed, the Customer and Technical support accounts are included as members of the System Administrator role.
- If the Modular Messaging system has been upgraded from a previous version, the System Administrator role is populated with the former members of the System Administration ACL; and the Subscriber Administrator role, the Subscriber Administration ACL. These users or groups can be removed from the roles, if necessary.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.


   The system displays preset roles Servers, System Administrator, System Auditor, Subscriber Administrator, Subscriber Auditor, and Subscriber Helpdesk.

   There might also be customer-configured roles.

3. Double-click the required role. The system displays the Security Roles dialog box for the selected role, with the Members tab active.
Configuring the Screen Controls for the Servers Role

- **Members** This displays a list of the computer local system accounts as members of the Servers role. The MAS service account is also included, and there may be other users and groups.

  **Note:** The list can contain local or domain (private or corporate) Windows computers, users, or groups. The Modular Messaging system authenticates against a Windows domain controller; any number of computers, users, or groups that are known to the domain controller can be used.

- **Add...** Click to add a user, computer, group or built-in security principal to the role, using the Select User, Computer, or Group dialog box.

  **Note:** See your Windows documentation for information about how to use this dialog box.

- **Remove** Click to remove the selected computer, user, or group from the Members list.

Configuring the Screen Controls for the Other Preset Roles or Customer-Created Roles

- **Members** This displays a list of the groups and users who have the capabilities of the role.

  **Note:** The list can contain local or domain (private or corporate) Windows users or groups. The Modular Messaging system authenticates against a Windows domain controller; any number of users or groups that are known to the domain controller can be used.

- **Add...** Click to add a user, group or built-in security principal to the role, using the Select User or Group dialog box.

  **Note:** See your Windows documentation for information about how to use this dialog box.

- **Remove** Click to remove the selected user or group from the Members list.
Security Roles - Tasks Tab

Use the Security Roles dialog box, Tasks tab to view which tasks the security role is allowed to perform. For customer-configured roles, you can change the tasks that are allowed.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.


The system displays preset roles Servers, System Administrator, System Auditor, Subscriber Administrator, Subscriber Auditor, and Subscriber Helpdesk.

There might also be customer-configured roles.

3. Double-click the required role. The system displays the Security Roles dialog box for the selected role, with the Members tab active.

4. Click the Tasks tab.

Tasks for Servers

The Servers role is intended for servers to have access to perform their duties. It has the full range of system administration and subscriber administration tasks.

The following tasks are preset for servers. You cannot alter them using the Add... and Remove buttons.

- **MultiSite Enable** Members of a role with this task can enable and disable MultiSite and configure the following VMSC application screens.
  - **Sites** dialog box. See Sites Dialog Box on page 3-16.
  - **Add New PBX** dialog box, **PBX type** tree node menu commands, and **PBX Configuration** dialog box. See Add New PBX Dialog Box on page 3-118, PBX Configuration Dialog Box (IP SIP) on page 3-153, and MAS - PBX Type Dialog Box on page 4-61.
  - **PBX Integration** dialog box. See PBX Integration Dialog Box on page 3-165.
Tasks for System Administrator

The tasks assigned to the System Administrator role mean that its members can view and change anything in Voice Mail System Configuration, Port Monitor, Password Policy Editor, and the parts of the Caller Applications Editor that control deployment. This replaces the System Administration ACL that was used in previous versions of Avaya Modular Messaging.

Note: The other administrative and diagnostic tools that run on the MAS are not security controlled.

The following tasks are preset for system administrators. You cannot alter them using the Add... and Remove buttons.

- **Auditing - Administer** Members of a role with this task can configure the VMSC application, Auditing dialog box. See Auditing Dialog Box on page 3-113.

- **Auto Attendant - Administer** Members of a role with this task can configure the VMSC application, Auto Attendant dialog box. See Auto Attendant Dialog Box on page 3-59.

- **Call Me - Administer** Members of a role with this task can configure the VMSC application, Call Me dialog box. See Call Me Dialog Box on page 3-69.

- **Caller Applications - Administer** Members of a role with this task can use the Caller Applications Editor application to deploy caller applications and analyze deployed caller applications. See Caller Application Deployment Wizard on page 6-69.

  Note: Any user can create caller applications, using the Caller Applications Editor, but only administrators can deploy them to the voice mail domain.

- **Fault Monitor - Generate Dump** Members of a role with this task can use the Fault Monitor to generate a process dump on demand, to aid debugging.

- **Fax - Administer** Members of a role with this task can configure the VMSC application, Fax dialog box. See Fax Dialog Box on page 3-80.

- **Languages - Administer** Members of a role with this task can configure these VMSC application screens:

  — **Languages** dialog box and **MAS - Languages** dialog box. See Languages Dialog Box on page 3-166 and MAS - Languages Dialog Box on page 4-13.

  — The voice mail domain tree node, Edit > Refresh Domain Languages menu command.
Licensing - Administer  Members of a role with this task can configure the VMSC application, Licensing dialog box, and the Licensing tree node right-click menu commands. See Licensing Dialog Box on page 3-201.

Message Waiting Indicator - Administer  Members of a role with this task can configure these VMSC application screens:

- Message Waiting Indicator dialog box. See Message Waiting Indicator Dialog Box on page 3-73.
- Start On-Demand MWI Update dialog box. See Start On-Demand MWI Update Dialog Box on page 3-78.
- Message Waiting Indicator tree node, right click menu, Show MWI Progress command.

Message Waiting Indicator - Update Lamps  Members of a role with this task can configure the VMSC application, Start On-Demand MWI Update dialog box, and the Message Waiting Indicator tree node, right click menu, Show MWI Progress command.

Messaging - Administer  Members of a role with this task can configure the VMSC application, Audio Encoding dialog box, Messaging dialog box, and MAS - Messaging dialog box. See Audio Encoding Dialog Box on page 3-168, Messaging Dialog Box on page 3-174, and MAS - Messaging Dialog Box on page 4-11.

Notify Me - Administer  Members of a role with this task can configure the VMSC application, Notify Me dialog box. See Notify Me Dialog Box on page 3-71.

Octel Analog Networking - Administer.

Note: This setting is not applicable to Avaya Modular Messaging with the Avaya MSS.

Password Policy - Administer  Members of a role with this task can configure the Password Policy Editor application. See Password Policy Editor on page 1-5.

Port Monitoring - Administer  Members of a role with this task can use the Port Monitor application to change the status of ports. See Port Monitor on page 9-2.

Security - Administer  Members of a role with this task can configure the VMSC application, Security Roles dialog box, and use the Security Roles tree node right-click commands. See Security Roles Dialog Box on page 3-88.

Serviceability - Administer  Members of a role with this task can configure the VMSC application, Serviceability dialog box, and the MAS - Serviceability dialog box. See Serviceability Dialog Box on page 3-189 and MAS - Serviceability Dialog Box on page 4-62.
- **Software Upgrade - Administer** Members of a role with this task can use the **Installation Wizard** to apply a software upgrade patch to their existing Modular Messaging installation. For more information about patches, see *Avaya Modular Messaging Installation and Upgrades Guide*.

- **Telephone User Interface - Administer** Members of a role with this task can configure the **VMSC** application, **Telephone User Interface** dialog box, and use the **Telephone User Interface** node right-click menu commands. See **Telephone User Interface Dialog Box** on page 3-38.

- **Telephony - Administer** Members of a role with this task can configure these **VMSC** application screens:
  - **Telephony Configuration Wizard.** See **Telephony Configuration Wizard** on page 4-10.
  - **Add New PBX** dialog box, **PBX type** tree node menu commands and **PBX Configuration** dialog box. See **Add New PBX Dialog Box** on page 3-118 and **PBXs Configuration** on page 3-117.
  - **Dialing Rules** dialog box. See **Dialing Rules Dialog Box** on page 3-170.
  - **MAS - Telephony Interface** dialog box. See **MAS - Telephony Interface Dialog Box** on page 4-14.
  - **MAS - Port Groups** dialog box. See **MAS - Port Groups Dialog Box** on page 4-25.
  - **MAS - PBX Integration** dialog box and **MAS - PBX Type** dialog box. See **MAS - PBX Integration Dialog Box** on page 4-33 and **MAS - PBX Type Dialog Box** on page 4-61.

- **Tracing - Administer** Members of a role with this task can configure the **VMSC** application, **Tracing System** dialog box, and the **MAS - Trace File Size** dialog box. See **Tracing System Dialog Box** on page 3-206 and **MAS - Trace File Size Dialog Box** on page 4-67.

- **Voice Mail Domain - Administer** Members of a role with this task can configure these **VMSC** application screens:
  - **Add New Voice Mail Domain** dialog box, **Edit > Remove Voice Mail Domain** menu command, and **Rename Voice Mail Domain** dialog box. See **Adding a New Voice Mail Domain** on page 3-12, **Removing a Voice Mail Domain** on page 3-13 and **Renaming a Voice Mail Domain** on page 3-14.
  - **Options** dialog box. See **Changing the Home MAS** on page 3-15.
  - **Add New Message Application Server** dialog box, and **Edit > Remove Message Application Server** menu command. See **Adding a New Messaging Application Server** on page 4-7 and **Removing a Message Application Server** on page 4-8.
- **Web Subscriber Options - Administer** Members of a role with this task can configure the VMSC application, **Web Subscriber Options** dialog box. See [Web Subscriber Options Dialog Box](#) on page 3-186.

- **MultiSite - Administer** Members of a role with this task can configure the following VMSC application screens:
  
  - **Sites** dialog box. See [Sites Dialog Box](#) on page 3-16.
  
  - **PBX Integration** dialog box. See [PBX Integration Dialog Box](#) on page 3-165.

However, members of a role with this task cannot enable or disable MultiSite.
Tasks for System Auditor

The tasks assigned to the System Auditor role mean that its members have view-only access to configuration settings in Voice Mail System Configuration, Port Monitor, Password Policy Editor, and the parts of the Caller Applications Editor that control deployment.

**Note:** The other administrative and diagnostic tools that run on the MAS are not security controlled.

The following tasks are preset for system auditors. You cannot alter them using the Add... and Remove buttons.

- **Auditing - View** Members of a role with this task have view-only access to the VMSC application, Auditing dialog box.

- **Auto Attendant - View** Members of a role with this task have view-only access to the VMSC application, Auto Attendant dialog box.

- **Call Me - View** Members of a role with this task have view-only access to the VMSC application, Call Me dialog box.

- **Caller Applications - View** Members of a role with this task can use the Caller Applications Editor to analyze the caller applications that have already been deployed.

- **Fault Monitor - View** Members of a role with this task have view-only access to the processes that are allowed to generate process dumps in Fault Monitor.

- **Fax - View** Members of a role with this task have view-only access to the VMSC application, Fax dialog box.

- **Languages - View** Members of a role with this task have view-only access to the VMSC application, Languages dialog box, and the MAS - Languages dialog box.

- **Licensing - View** Members of a role with this task have view-only access to the VMSC application, Licensing dialog box.

- **Message Waiting Indicator - View** Members of a role with this task have view-only access to these VMSC application screens:
  
  — Message Waiting Indicator dialog box.
  
  — Start On-Demand MWI Update dialog box.
  
  — Message Waiting Indicator tree node, right click menu, Show MWI Progress command.
VMSC - Voice Mail Domain (VMD) Configuration

- **Messaging - View** Members of a role with this task have view-only access to the VMSC application, **Audio Encoding** dialog box, **Messaging** dialog box, and **MAS - Messaging** dialog box.

- **Notify Me - View** Members of a role with this task have view-only access to the VMSC application, **Notify Me** dialog box.

- **Octel Analog Networking - View**

  **Note:** This setting is not applicable to Avaya Modular Messaging with the Avaya MSS.

- **Password Policy - View** Members of a role with this task have view-only access to the **Password Policy Editor** application.

- **Port Monitoring - View** Members of a role with this task can use the **Port Monitor** application to view the status of ports on MASs.

- **Security - View** Members of a role with this task have view-only access to the VMSC application, **Security Roles** dialog box, and the **Security Roles** tree node right-click commands.

- **Serviceability - View** Members of a role with this task have view-only access to the VMSC application, **Serviceability** dialog box, and the **MAS - Serviceability** dialog box.

- **Telephone User Interface - View** Members of a role with this task have view-only access to the VMSC application, **Telephone User Interface** dialog box, and the **Telephone User Interface** node right-click menu commands.

- **Telephony - View** Members of a role with this task have view-only access to these VMSC application screens:
  
  — **Telephony Configuration Wizard**.
  
  — **Add New PBX** dialog box, **PBX type** tree node menu commands, and **PBX Configuration** dialog box.
  
  — **Dialing Rules** dialog box.
  
  — **MAS - Telephony Interface** dialog box.
  
  — **MAS - Port Groups** dialog box.
  
  — **MAS - PBX Integration** dialog box, and **MAS - PBX Type** dialog box.
  
  — The voice mail domain tree node, **Edit > Refresh Domain Languages** menu command.

- **Tracing - View** Members of a role with this task have view-only access to the VMSC application, **Tracing System** dialog box, and the **MAS - Trace File Size** dialog box.
- **Voice Mail Domain - View** Members of a role with this task have view-only access to the VMSC application, **Options** dialog box.

- **Web Subscriber Options - View** Members of a role with this task have view-only access to the VMSC application, **Web Subscriber Options** dialog box.

- **MultiSite - View** Members of a role with this task have view-only access to the following VMSC application screens:
  - **Sites** dialog box. See [Sites Dialog Box](#) on page 3-16.
  - **PBX Integration** dialog box. [PBX Integration Dialog Box](#) on page 3-165.

**Tasks for 📞 Subscriber Administrator**

The tasks assigned to the **Subscriber Administrator** role mean that its members can start **Subscriber Options** in administrator mode, to administer a mailbox on behalf of a subscriber. This replaces the **Subscriber Administration ACL** that was used in previous versions of Avaya Modular Messaging.

The following tasks are preset for subscriber administrators. You cannot alter them using the **Add...** and **Remove** buttons.

- **Subscriber - Administer** Members of a role with this task can configure **Subscriber Options**. See the [Avaya Modular Messaging Subscriber Options Guide](#).

- **Subscriber - Reset Fax Authorization Code** Members of a role with this task can reset the **Fax Authorization Code**, when they are logged into **Subscriber Options** as an administrator.

- **Subscriber - Reset Password**

  **Note:** This setting is not applicable to Avaya Modular Messaging with the Avaya MSS.

- **Subscriber - Unlock Mailbox**

  **Note:** This setting is not applicable to Avaya Modular Messaging with the Avaya MSS.
Tasks for Subscriber Auditor

The tasks assigned to the Subscriber Administrator role mean that its members can start Subscriber Options in administrator mode, but have view-only access to the screens.

The following tasks are preset for subscriber auditors. You cannot alter them using the Add... and Remove buttons.

- **Subscriber - View** Members of a role with this task can start Subscriber Options in administrator mode, but have view-only access to the screens.

Tasks for Subscriber Helpdesk

The tasks assigned to the Subscriber Helpdesk role mean that its members can start Subscriber Options in administrator mode. They can reset the fax authorization code, but have view-only access to other settings.

The following tasks are preset for the subscriber helpdesk. You cannot alter them using the Add... and Remove buttons.

- **Subscriber - Reset Fax Authorization Code** Members of a role with this task can reset the Fax Authorization Code, when they are logged into Subscriber Options as an administrator.

- **Subscriber - View** Members of a role with this task can start Subscriber Options in administrator mode, but have view-only access to the screens.

Tasks for Customer-Created Roles

**Note:** For information on creating new roles, see Create/Copy/Rename Roles Dialog Box on page 3-92.

There are no pre-set tasks for customer-created roles. You must set up the tasks using these buttons:

- **Add...** Click to open the Add Task dialog box, where you can select one or more tasks from a list. See Security Roles - Add Task Dialog Box on page 3-105. When you close the dialog box, the selected tasks appear in the Tasks list.

- **Remove** Click to remove the selected task from the Tasks list. You are prompted to confirm the removal.
Security Roles - Add Task Dialog Box

Use the Add Task dialog box configure the permissions of customer-created security roles.

Launching the Screen

To reach this dialog box, you must click the Add... button on the Tasks tab of the Security Roles dialog box (see Security Roles - Tasks Tab on page 3-96).

Configuring the Screen Controls

- **Telephone User Interface - Administer** Members of a role with this task can configure the VMSC application, Telephone User Interface dialog box, and use the Telephone User Interface node right-click menu commands. See Telephone User Interface Dialog Box on page 3-38.

- **Telephone User Interface - View** Members of a role with this task have view-only access to the VMSC application, Telephone User Interface dialog box, and the Telephone User Interface node right-click menu commands.

- **Auto Attendant - Administer** Members of a role with this task can configure the VMSC application, Auto Attendant dialog box. See Auto Attendant Dialog Box on page 3-59.

- **Auto Attendant - View** Members of a role with this task have view-only access to the VMSC application, Auto Attendant dialog box.

- **Call Me - Administer** Members of a role with this task can configure the VMSC application, Call Me dialog box. See Call Me Dialog Box on page 3-69.

- **Call Me - View** Members of a role with this task have view-only access to the VMSC application, Call Me dialog box.

- **Notify Me - Administer** Members of a role with this task can configure the VMSC application, Notify Me dialog box. See Notify Me Dialog Box on page 3-71.

- **Notify Me - View** Members of a role with this task have view-only access to the VMSC application, Notify Me dialog box.

- **Message Waiting Indicator - Administer** Members of a role with this task can configure these VMSC application screens:
  
  — **Message Waiting Indicator** dialog box. See Message Waiting Indicator Dialog Box on page 3-73.
  
  — **Start On-Demand MWI Update** dialog box. See Start On-Demand MWI Update Dialog Box on page 3-78.
— **Message Waiting Indicator** tree node, right click menu, **Show MWI Progress** command.

- **Message Waiting Indicator - Update Lamps** Members of a role with this task can configure the **VMSC** application, **Start On-Demand MWI Update** dialog box, and the **Message Waiting Indicator** tree node, right click menu, **Show MWI Progress** command.

- **Message Waiting Indicator - View** Members of a role with this task have view-only access to these **VMSC** application screens:
  
  — **Message Waiting Indicator** dialog box.
  
  — **Start On-Demand MWI Update** dialog box.
  
  — **Message Waiting Indicator** tree node, right click menu, **Show MWI Progress** command.

- **Fax - Administer**  Members of a role with this task can configure the **VMSC** application, **Fax** dialog box. See **Fax Dialog Box** on page 3-80.

- **Fax - View**  Members of a role with this task have view-only access to the **VMSC** application, **Fax** dialog box.

- **Security - Administer** Members of a role with this task can configure the **VMSC** application, **Security Roles** dialog box, and use the **Security Roles** tree node right-click commands. See **Security Roles Dialog Box** on page 3-88.

- **Security - View** Members of a role with this task have view-only access to the **VMSC** application, **Security Roles** dialog box, and the **Security Roles** tree node right-click commands.

- **Telephony - Administer** Members of a role with this task can configure these **VMSC** application screens:
  
  — **Telephony Configuration Wizard**. See **Telephony Configuration Wizard** on page 4-10.
  
  — **Add New PBX** dialog box, **PBX type** tree node menu commands and **PBX Configuration** dialog box. See **Add New PBX Dialog Box** on page 3-118 and **PBXs Configuration** on page 3-117.

  — **Dialing Rules** dialog box. See **Dialing Rules Dialog Box** on page 3-170.

  — **MAS - Telephony Interface** dialog box. See **MAS - Telephony Interface Dialog Box** on page 4-14.

  — **MAS - Port Groups** dialog box. See **MAS - Port Groups Dialog Box** on page 4-25.
— **MAS - PBX Integration** dialog box, and **MAS - PBX Type** dialog box. See [MAS - PBX Integration Dialog Box](#) on page 4-33 and [MAS - PBX Type Dialog Box](#) on page 4-61.

- **Telephony - View** Members of a role with this task have view-only access to these VMSC application screens:
  - **Telephony Configuration Wizard**.
  - **Add New PBX** dialog box, **PBX type** tree node menu commands, and **PBX Configuration** dialog box.
  - **Dialing Rules** dialog box.
  - **MAS - Telephony Interface** dialog box.
  - **MAS - Port Groups** dialog box.
  - **MAS - PBX Integration** dialog box, and **MAS - PBX Type** dialog box.

- **Languages - Administer** Members of a role with this task can configure these VMSC application screens:
  - **Primary Domain Language** dialog box. See [Adding a New Messaging Application Server](#) on page 4-7.
  - **Languages** dialog box, and **MAS - Languages** dialog box. See [MAS - Languages Dialog Box](#) on page 4-13.
  - The voice mail domain tree node, **Edit > Refresh Domain Languages** menu command.

- **Languages - View** Members of a role with this task have view-only access to the VMSC application, **Languages** dialog box, and the **MAS - Languages** dialog box.

- **Octel Analog Networking - Administer**.

  **Note:** This setting is not applicable to Avaya Modular Messaging with the Avaya MSS.

- **Octel Analog Networking - View**

  **Note:** This setting is not applicable to Avaya Modular Messaging with the Avaya MSS.

- **Messaging - Administer** Members of a role with this task can configure the VMSC application, **Audio Encoding** dialog box, **Messaging** dialog box, and **MAS - Messaging** dialog box. See [Audio Encoding Dialog Box](#) on page 3-168, [Messaging Dialog Box](#) on page 3-174, and [MAS - Messaging Dialog Box](#) on page 4-11.
- **Messaging - View** Members of a role with this task have view-only access to the VMSC application, **Messaging** dialog box, the **Audio Encoding** dialog box, and the **MAS - Messaging** dialog box.

- **Web Subscriber Options - Administer** Members of a role with this task can configure the VMSC application, **Web Subscriber Options** dialog box. See **Web Subscriber Options Dialog Box** on page 3-186.

- **Web Subscriber Options - View** Members of a role with this task have view-only access to the VMSC application, **Web Subscriber Options** dialog box.

- **Serviceability - Administer** Members of a role with this task can configure the VMSC application, **Serviceability** dialog box, and the **MAS - Serviceability** dialog box. See **Serviceability Dialog Box** on page 3-189 and **MAS - Serviceability Dialog Box** on page 4-62.

- **Serviceability - View** Members of a role with this task have view-only access to the VMSC application, **Serviceability** dialog box, and the **MAS - Serviceability** dialog box.

- **Licensing - Administer** Members of a role with this task can configure the VMSC application, **Licensing** dialog box, and the **Licensing** tree node right-click menu commands. See **Licensing Dialog Box** on page 3-201.

- **Licensing - View** Members of a role with this task have view-only access to the VMSC application, **Licensing** dialog box.

- **Tracing - Administer** Members of a role with this task can configure the VMSC application, **Tracing System** dialog box, and the **MAS - Trace File Size** dialog box. See **Tracing System Dialog Box** on page 3-206 and **MAS - Trace File Size Dialog Box** on page 4-67.

- **Tracing - View** Members of a role with this task have view-only access to the VMSC application, **Tracing System** dialog box, and the **MAS - Trace File Size** dialog box.

- **Port Monitoring - Administer** Members of a role with this task can use the **Port Monitor** application to change the status of ports. See **Port Monitor** on page 9-2.

- **Port Monitoring - View** Members of a role with this task can use the **Port Monitor** application to view the status of ports on MASs.

- **Caller Applications - Administer** Members of a role with this task can use the **Caller Applications Editor** application to deploy caller applications and analyze deployed caller applications. See **Caller Application Deployment Wizard** on page 6-69.

---

**Note:** Any user can create caller applications, using the **Caller Applications Editor**, but only administrators can deploy them to the voice mail domain.
- **Caller Applications - View** Members of a role with this task can use the **Caller Applications Editor** to analyze the caller applications that have already been deployed.

- **Voice Mail Domain - Administer** Members of a role with this task can configure these **VMSC** application screens:
  - Add New Voice Mail Domain dialog box, Edit > Remove Voice Mail Domain menu command, and Rename Voice Mail Domain dialog box. See Adding a New Voice Mail Domain on page 3-12, Removing a Voice Mail Domain on page 3-13 and Renaming a Voice Mail Domain on page 3-14.
  - Options dialog box. See Changing the Home MAS on page 3-15.
  - Add New Message Application Server dialog box, and Edit > Remove Message Application Server menu command. See Adding a New Messaging Application Server on page 4-7 and Removing a Message Application Server on page 4-8.

- **Voice Mail Domain - View** Members of a role with this task have view-only access to the **VMSC** application Options dialog box.

- **Password Policy - Administer** Members of a role with this task can configure the **Password Policy Editor** application. See Password Policy Editor on page 1-5.

- **Password Policy - View** Members of a role with this task have view-only access to the **Password Policy Editor** application.

- **Auditing - Administer** Members of a role with this task can configure the **VMSC** application, Auditing dialog box. See Auditing Dialog Box on page 3-113.

- **Auditing - View** Members of a role with this task have view-only access to the **VMSC** application, Auditing dialog box.

- **Software Upgrade - Administer** Members of a role with this task can use the **Installation Wizard** to apply a software upgrade patch to their existing Modular Messaging installation. For more information about patches, see Avaya Modular Messaging Installation and Upgrades Guide.

- **Fault Monitor - Generate Dump** Members of a role with this task can use the **Fault Monitor** to generate a process dump on demand, to aid debugging.

- **Fault Monitor - View** Members of a role with this task have view-only access to the processes that are allowed to generate process dumps in Fault Monitor.

- **Subscriber - Administer** Members of a role with this task can configure **Subscriber Options**. See the Avaya Modular Messaging Subscriber Options Guide.
- **Subscriber - View** Members of a role with this task can start **Subscriber Options** in administrator mode, but have view-only access to the screens.

- **Subscriber - Unlock Mailbox**

  **Note:** This setting is not applicable to Avaya Modular Messaging with the Avaya MSS.

- **Subscriber - Reset Password**

  **Note:** This setting is not applicable to Avaya Modular Messaging with the Avaya MSS.

- **Subscriber - Reset Fax Authorization Code** Members of a role with this task can reset the **Fax Authorization Code**, when they are logged into **Subscriber Options** as an administrator.
Security - Message Servers Dialog Box

Note: For a detailed overview of voice mail domain configuration in the Voice Mail System Configuration (VMSC) application, see Overview of VMD Configuration in VMSC on page 3-3.

This topic describes how to use the Message Servers dialog box to configure the Avaya Message Store Server (Avaya MSS) with which the MASs can communicate. You can also set up the list of protocols the MASs use to get subscriber data from the message store.

Note: For more information about system security, see the “Getting Started” section on your system documentation CD.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Double-click Security. The node expands to show the available security administration options.
3. Double-click Messaging Servers Administration. The system displays the Message Servers dialog box for the selected voice mail domain, with the Message Servers tab active.

Configuring the Screen Controls

- **Message Servers** This displays the name of the Avaya Message Store Server (Avaya MSS) with which the MASs can communicate.
  - Adds a line to the Message Servers list. You can then enter the name of the Avaya MSS or select the server using the browse button (...).
  - Deletes the Avaya MSS selected in the Message Servers list. The system prompts you to confirm the deletion.

- **Credentials** This displays a list of protocols the MASs use to get subscriber data from the Avaya MSS.
  - Adds a line to the Credentials list. You can then configure one of the of four available Protocol accounts.

Note: You must add at least one but can add all four, depending on the needs of your system.
— X Deletes the protocol selected in the **Credentials** list. The system prompts you to confirm the deletion.

— **Protocol** Select the desired access protocol used on the message store.

The access protocol is the interface used to access mailbox data. Normally, you add **IMAPI**, **IMAP4**, and **LDAP**. You would add **FAX**, only if your system supports FAX. The choices are as follows:

- **LDAP** This protocol is necessary to retrieve subscriber data.
- **IMAP4** This protocol is necessary for the MAS to access the Avaya MSS.
- **IMAPI** This protocol is necessary for the **MM Mailbox Monitor** service to access the message store. Mailbox Monitor manages the Message Waiting Indicator and Call Me servers.
- **FAX** This protocol is necessary for the server to act as the FAX server.

— **Password** Enter the password for each account.

**Note:** After changing the **LDAP** or **FAX** passwords, you must and restart the **MM Messaging Application Server** service. See **Appendix C, Modular Messaging (MM) Services**. You do not need to restart the service after changing the **IMAP4** or **IMAPI** passwords.
Auditing Dialog Box

Note: For a detailed overview of voice mail domain configuration in the Voice Mail System Configuration (VMSC) application, see Overview of VMD Configuration in VMSC on page 3-3.

With MAS Auditing, an audit event is logged whenever a security role-controlled administrative operation is attempted by a Messaging Application Server (MAS) or supplementary server. User-friendly information is logged as well as the typical system data.

This topic describes how to use the Auditing dialog box to configure auditing for the voice mail domain.

You can also configure the use of the “syslog” protocol. This allows third-party system administration tools to be used on the Modular Messaging system.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).

2. Double-click Auditing. The system displays the Auditing dialog box for the selected voice mail domain.

Tabs Available in this Dialog Box

Note: To configure this dialog box, you must be a member of a security role assigned the Auditing - Administer task. You must also have local admin rights in Windows. If you are a member of a role assigned the Auditing - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

- **General**  Use this tab to enable auditing for the voice mail domain, assign the audit server, and configure the audit database. See Auditing - General Tab on page 3-114.

- **Syslog**  Use this tab to configure a receiver for syslog messages, and the types of events that are sent. See Auditing - Syslog Tab on page 3-116.
Auditing - General Tab

You can use the Auditing dialog box, General tab to enable auditing for the voice mail domain, assign the audit server, and configure the audit database.

Note: The audit log can be viewed using the MM Audit Log Viewer application. See Chapter 10, “MM Audit Log Viewer”.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Auditing. The system displays the Auditing dialog box for the selected voice mail domain, with the General tab active.

Configuring the Screen Controls

- Enable Auditing  Select to enable auditing for the voice mail domain.

  This check box is cleared by default. Selecting it activates all the other fields in the tab.

- Audit server  Enter the name of the server on which to run the MM Audit Server. You can use the browse (...) button to select the name, using the standard Select Computer window, if necessary.

  The MM Audit Service is installed to run on each Messaging Application Server (MAS) in the voice mail domain, and the supplementary server. The name of the server that you enter here assigns the MM Audit Service on that server to act as the MM Audit Server.

  For information on Modular Messaging services, see Appendix C, Modular Messaging (MM) Services.

- Audit event retention (days)  Enter the number of days before events are purged from the audit database. The range is 1 through 365, the default is 180.

- Audit database configuration  Enter the details of the database containing audit events.

  - Database server  Enter the name of the server on which the database resides. You can use the browse (...) button to select the server, if necessary.
— **Database name**  Enter the name of the database containing audit events. The default is **MMAUDIT**.

**Note:** Avaya Modular Messaging stores the log using Microsoft SQL Server. There can be a number of SQL server instances on the same machine.

— **Database instance**  Enter the name of the SQL server instance. The default is **MMAUDIT**.
Auditing - Syslog Tab

You can use the Auditing dialog box, Syslog tab to configure a receiver for syslog messages, and the types of events that are sent.

Syslog is a protocol which allows devices to send logs across networks. This allows third-party system administration tools to be used on the Modular Messaging system.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Auditing. The system displays the Auditing dialog box for the selected voice mail domain, with the General tab active.

3. Click the Syslog tab.

Configuring the Screen Controls

- **Events to send to syslog** Use this setting to filter the events that are sent through syslog.

  If you select **All events**, then all events are sent through syslog. If you select **Custom events**, the check boxes are activated. You can then enable the check boxes to customize the types of events.

  — **Allowed events** Enable to send all allowed events through syslog.
  
  — **Denied events** Enable to send all denied events through syslog.
  
  — **Error events** Enable to send all error events through syslog.

- **Syslog servers** This displays a list of machines that can receive events through syslog. The name of each machine can be an IP address, machine name, or fully qualified domain name.

  — Adds a line to the list. You can then enter the name of the machine or select it using the browse button (...).
  
  — Deletes the machine selected in the list. The system prompts you to confirm the deletion.
  
  — Moves the selected machine up or down the list.

---

**Note:** These machines do not have to be Modular Messaging servers.
PBXs Configuration

You can configure a Private Branch Exchange (PBX) to determine the way in which it communicates with the voice mail domain.

Adding a New PBX Type

You use the Add New PBX dialog box to add one or more PBXs to the voice mail domain. See Add New PBX Dialog Box on page 3-118.

Configuring the PBX

The screens you use to configure a PBX depend on the type of voice processing you are using. Please read the appropriate topic for more information about your PBX:

- PBX Configuration Dialog Box (Dialogic Analog) on page 3-120.
- PBX Configuration Dialog Box (QSIG) on page 3-129.
- PBX Configuration Dialog Box (Set Emulation) on page 3-138.
- PBX Configuration Dialog Box (IP H.323) on page 3-147.
- PBX Configuration Dialog Box (IP SIP) on page 3-153.

Removing a PBX

If you need to remove the PBX, select it in the Voice Mail System Configuration window tree. Click the Edit > Remove PBX Type menu or use the right-click menu.
Add New PBX Dialog Box

This topic describes how to use the Add New PBX dialog box to add one or more PBXs to the voice mail domain.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Click PBXs.
3. Click the Edit > Add PBX Type menu or use the right-click menu.

The system displays the Add New PBX dialog box.

Configuring the Screen Controls

Note: To configure this dialog box, you must be a member of a security role assigned the Telephony - Administer task. If you are a member of a role assigned the Telephony - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

- Telephony Type Select the type of port board that is installed in this MAS.

The PBXs list is then updated to show the type of PBX integration for the selected telephony type.

Note: If the MultiSite feature is enabled for a voice mail domain, you can only select IP SIP as the Telephony Type.

- PBXs Select the type of PBX integration that you have.

Configuring the New PBX

When you have added a new PBX, it appears as a sub-node in the Voice Mail System Configuration tree, under the PBXs node. The screens you use to configure a PBX depend on the type of voice processing you are using:

- PBX Configuration Dialog Box (Dialogic Analog) on page 3-120.
- PBX Configuration Dialog Box (QSIG) on page 3-129.
- PBX Configuration Dialog Box (Set Emulation) on page 3-138.
- PBX Configuration Dialog Box (IP H.323) on page 3-147.
Removing a PBX

**Note:** To use this command, you must be a member of a security role assigned the **Telephony - Administer** task.

If you need to remove the PBX, select it in the tree and click the **Edit > Remove PBX** menu or use the right-click menu.
This topic describes how to use the **PBX Configuration** dialog box to configure Private Branch Exchange (PBX) properties, if you are using dialogic analog voice cards.

You can configure the PBX to determine the way in which it communicates with the voice mail domain. The PBX is sometimes referred to as the "switch".

Use the **PBX Configuration** dialog box to configure the PBX Dual Tone Multi-Frequency (DTMF) dialing tones, call transfer codes, hangup detection, and intercom paging.

**Notes:**

- In the **Voice Mail System Configuration** window, under the **Voice Mail Domain** tree, **PBXs** node, you can add new PBX types, if necessary. See **Add New PBX Dialog Box** on page 3-118.

- For more information on configuring your PBX, see the PBX configuration notes. Configuration notes are available from the Avaya Support Website at [http://www.avaya.com/support](http://www.avaya.com/support).

### Launching the Screen

1. In the **Voice Mail System Configuration** window, click the voice mail domain (VMD).

2. Double-click **PBXs**. The system expands the node to show all available types of PBX.

3. Double-click the **Dialogic** PBX. The system displays the **PBX Configuration** dialog box for the selected voice mail domain.

### Tabs Available in this Dialog Box

**Note:** To configure this dialog box, you must be a member of a security role assigned the **Telephony - Administrator** task. If you are a member of a role assigned the **Telephony - View** task, you have read-only access to this dialog box. See **Security Roles Dialog Box** on page 3-88.

- **General** Use this tab to configure DTMF dialing tones. See **PBX Configuration - General Tab (Dialogic Analog)** on page 3-122.
- **Call Transfer**  Use this tab to set up options for PBX call transfer. You can specify transfer release codes. See [PBX Configuration - Call Transfer Tab (Dialogic Analog)](on page 3-123).

- **Hangup Detection**  Use this tab to set up options for PBX hangup detection. You can specify string options and tone settings for DTMF hangup. See [PBX Configuration - Hangup Detection Tab (Dialogic Analog)](on page 3-125).

- **Intercom Paging**  Use this tab to set up options for PBX intercom paging. This allows callers to page subscribers in the building, if they do not answer their extensions. See [PBX Configuration - Intercom Paging Tab (Dialogic Analog)](on page 3-126).
PBX Configuration - General Tab (Dialogic Analog)

Use the **PBX Configuration** dialog box, **General** tab to configure the PBX Dual Tone Multi-Frequency (DTMF) dialing tones.

**Launching the Screen**

1. In the **Voice Mail System Configuration** window, click the voice mail domain (VMD).
2. Double-click **PBXs**. The system expands the node to show all available types of PBX.
3. Double-click the **Dialogic** PBX. The system displays the **PBX Configuration** dialog box for the selected voice mail domain, with the **General** tab active.

**Configuring the Screen Controls**

- **Go Off Hook when Port Disabled**  Select to place a port off hook, when it is disabled. If cleared, the port rings but does not answer. This check box is selected by default.

- **Pause before Digits (ms)**  Enter the time, in milliseconds, that the voice mail system waits after taking the voice port off hook before becoming available. The range is 100 through 9999, and the default is 580.

- **Pause Interval for Comma in Dial String (ms)**  Enter the duration, in milliseconds, represented by a comma in a dial string. The range is 100 through 9999, and the default is 2000.

- **DTMF Inter-Digit Delay during Dialing (ms)**  Enter the duration, in milliseconds, between DTMF tones when dialing. The range is 10 through 999, and the default is 80.

- **DTMF Length during Dialing (ms)**  Enter the duration, in milliseconds, of a DTMF tone when dialing. The range is 10 through 999, and the default is 80.

- **DTMF Length during Detection (ms)**  Enter the length, in milliseconds, of a DTMF tone during detection. The range is 1 through 999, and the default is 50.

- **DTMF Length during Play (ms)**  Enter the length, in milliseconds, of a DTMF tone during play. The range is 1 through 999, and the default is 50.
PBX Configuration - Call Transfer Tab (Dialogic Analog)

Use the PBX Configuration dialog box, Call Transfer tab to configure PBX call transfer properties and release codes for a voice mail domain.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).

2. Double-click PBXs. The system expands the node to show all available types of PBX.

3. Double-click the Dialogic PBX. The system displays the PBX Configuration dialog box for the selected voice mail domain, with the General tab active.

4. Click the Call Transfer tab.

Configuring the Screen Controls

- **Transfer Mode** Select the mode to be used.
  - **Full** The system listens for busy, invalid number, no answer, and connect signals.
  - **Partial** The system listens for busy and invalid number signals.

  **Note:** This should not be used for call transfers.

  — **Blind** (Default) No call progress analysis takes place.

- **Transfer Prefix Code** Enter the code which prefixes a call transfer, if required by the PBX. The default is &.

  The code can be DTMF or a combination of the letters A through D, H, N, T, X, P, M, and R, and the special characters pound (#), asterisk (*), dash (-), comma (,), plus sign (+), and ampersand (&). You can enter up to 99 characters.

  For more information about transfer sequences, see Call Transfer Codes on page 3-128.

- **Transfer Completion Code** Enter the code that completes a call transfer, if required by the PBX.
The code can be DTMF or a combination of the letters A through D, H, N, T, X, P, M, and R, and the special characters pound (#), asterisk (*), dash (-), comma (,), plus sign (+), and ampersand (&). You can enter up to 99 characters.

**Note:** Leave this field blank for C-LAN integration.

- **Transfer Release Code when Busy** Enter a transfer release code for a busy extension, if required by the PBX. The default is &. 

- **Transfer Release Code when No Answer** Enter a transfer release code for a ring-no-answer extension, if required by the PBX. The default is &.

- **Transfer Release Code when Reject** Enter a transfer release code for an extension rejection call, if required by the PBX.

- **Flash Time Interval (ms)** Enter the time, in milliseconds, that the hook switch must be pressed for the voice mail system to recognize it as a hook switch flash signal. The range is 0 through 10000, the default is 500.

- **Enable Call Progress** Select to enable full call progress. When selected and a call is placed to an extension, the system listens for busy, invalid number, no answer, and connect signals. If cleared and a call is placed to an extension, the system assumes an answer. This check box is selected by default.

  **Note:** This property may be overridden by other applications, when placing an outbound call.

Selecting this check box activates the **Start Delay for Call Progress (ms)** field.

- **Start Delay for Call Progress (ms)** Enter the duration, in milliseconds, between dialing a number and starting full call progress. The range is 0 through 5000, the default is 1000.
PBX Configuration - Hangup Detection Tab (Dialogic Analog)

Use the PBX Configuration dialog box, Hangup Detection tab to configure PBX hangup detection properties, like string options and tone settings.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).
2. Double-click PBXs. The system expands the node to show all available types of PBX.
3. Double-click the Dialogic PBX. The system displays the PBX Configuration dialog box for the selected voice mail domain, with the General tab active.
4. Click the Hangup Detection tab.

Configuring the Screen Controls

- **Maximum Continuous Tone before Hanging Up (ms)** Enter the time, in milliseconds, that the voice mail system listens to a dial tone once a caller hangs up, before dropping the line. The range is 0 through 12000, the default is 6000.

- **Hangup String** Enter the sequence of DTMF digits and call transfer codes (& - = D H N T X P M) that the PBX sends to indicate that a call has terminated (been hung up).

  **Note:** This field is applicable to only certain PBXs that support inband integration. Leave this field blank for C-LAN, DMI-4, and RS-232 integrations.

- **Hangup String Timeout (ms)** Enter the time, in milliseconds, that the voice mail system waits between digits before validating a hangup string. The range is 0 through 9999, the default is 0.

- **Minimum Duration for Drop in Loop Current (ms)** Enter the time, in milliseconds, that must elapse before the voice mail system recognizes a true drop in loop current. The range is 0 through 3000, the default is 300. Setting this field to 0 disables this feature.

- **Maximum Silence before Hanging Up (ms)** Enter the time, in milliseconds, that the voice mail system waits before hanging up, if a user falls silent while recording. The range is 0 through 12000, the default is 6000.
PBX Configuration - Intercom Paging Tab (Dialogic Analog)

Use the PBX Configuration dialog box, Intercom Paging tab to configure PBX intercom paging properties for a voice mail domain. Using intercom paging, callers can page subscribers in the building, if they do not answer their extensions.

Notes:

- For Modular Messaging to do trunk-level paging, you must have additional hardware between the Modular Messaging system, the PBX, and the paging system. For more information, contact your Modular Messaging service or technical support representative.

- After you make changes to Intercom Paging properties, you must stop and restart the MM Messaging Application Server service. If you do not do so, the changes do not take effect. See Appendix C, Modular Messaging (MM) Services.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).

2. Double-click PBXs. The system expands the node to show all available types of PBX.

3. Double-click the Dialogic PBX. The system displays the PBX Configuration dialog box for the selected voice mail domain, with the General tab active.

4. Click the Intercom Paging tab.

Configuring the Screen Controls

- **Enable Intercom Paging** Select to allow a caller to page subscribers in the building, if they do not answer their extension.

  This check box is cleared by default. Selecting it activates all the other fields in the tab.

  — **Intercom Paging Code** Enter the intercom paging code sent to the PBX to start intercom paging, if required by the PBX. This field is blank by default.

  — **Release Code for Intercom Paging** Enter the code sent to the PBX to stop intercom paging. This field is blank by default.

  — **Repeat Intercom Paging Phrase** Select to get the Automated Attendant to play the intercom paging phrase ("there is a call for <subscriber's name>") twice instead of once. This check box is cleared by default.
— **Number of Retries when Paging System is Busy**  Enter a number to specify the number of times the voice mail system attempts to page a subscriber when met by a busy response. The range is 0 through 9, and the default is 3.

— **Number of Retries when No Answer**  Enter a number to specify the number of times a caller can request to page a subscriber whose extension is not answered. The range is 0 through 9, and the default is 3.

— **Paging Wait Time (sec)**  Enter the number of seconds a caller is kept on hold after paging a subscriber. The range is 0 through 99, and the default is 10.
Call Transfer Codes

You can create a transfer sequence using the codes listed below, plus any dual tone multi-frequency (DTMF) digits.

- & (ampersand) Means flash.
- , (comma) Means pause.
- - (minus sign) Means on hook.
- + (plus sign) Means off hook.
- A, B, C or D Mean dial with full call progress, listen for busy, invalid number, no answer or connect.
- P Means dial with full call progress, listen for busy or invalid number.
- N Means dial without call progress.
- X Means place extension in dial string.
- H Means hard hangup.
- T Means dual tone multi frequency (DTMF).
- M Means multi frequency.
- R Means earth recall.
- 0-9, # and * Are valid DTMF key presses.

Call transfer codes are used in the Call Transfer tab of the PBX Configuration dialog box. See the appropriate option for your PBX type:

- PBX Configuration - Call Transfer Tab (Dialogic Analog) on page 3-123.
PBX Configuration Dialog Box (QSIG)

Note: For a detailed overview of voice mail domain configuration in the Voice Mail System Configuration (VMSC) application, see Overview of VMD Configuration in VMSC on page 3-3.

This topic describes how to use the PBX Configuration dialog box to configure Private Branch Exchange (PBX) properties, if you are using Q-Signaling (QSIG) cards.

You can configure the PBX to determine the way in which it communicates with the voice mail domain. The PBX is sometimes referred to as the “switch”.

Use the PBX Configuration dialog box to configure the PBX Dual Tone Multi-Frequency (DTMF) dialing tones, the transfer mode, tone detection, outgoing call options, and intercom paging.

Notes:

- In the Voice Mail System Configuration window, under the Voice Mail Domain tree, PBXs node, you can add new PBX types, if necessary. See Add New PBX Dialog Box on page 3-118.

- For more information on configuring your PBX, see the PBX configuration notes. Configuration notes are available from the Avaya Support Website at http://www.avaya.com/support.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).

2. Double-click PBXs. The system expands the node to show all available types of PBX.

3. Double-click the QSIG PBX. The system displays the PBX Configuration dialog box for the selected voice mail domain.

Tabs Available in this Dialog Box

Note: To configure this dialog box, you must be a member of a security role assigned the Telephony - Administer task. If you are a member of a role assigned the Telephony - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

- General Use this tab to set up general PBX options. You can use it to set options for dual tone multi-frequency (DTMF) dialing tones. See PBX Configuration - General Tab (QSIG) on page 3-131.
- **Transfer/Outcall** Use this tab to configure the transfer mode. See [PBX Configuration - Transfer/Outcall Tab (QSIG)](page 3-132).

- **Tone Detection** Use this tab to specify the maximum silence before hanging up. See [PBX Configuration - Tone Detection Tab (QSIG)](page 3-133).

- **Outgoing Call** Use this tab to set up PBX outgoing call options, including the layer 1 protocol and the number type. See [PBX Configuration - Outgoing Call Tab (QSIG)](page 3-134).

- **Intercom Paging** Use this tab to set up PBX intercom paging options. Intercom paging allows callers to page subscribers in the building, if they do not answer their extensions. See [PBX Configuration - Intercom Paging Tab (QSIG)](page 3-136).
PBX Configuration - General Tab (QSIG)

Use the PBX Configuration dialog box, General tab to configure PBX Dual Tone Multi-Frequency (DTMF) dialing tones.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).
2. Double-click PBXs. The system expands the node to show all available types of PBX.
3. Double-click the QSIG PBX. The system displays the PBX Configuration dialog box for the selected voice mail domain, with the General tab active.

Configuring the Screen Controls

- **DTMF Inter-Digit Delay during Dialing (ms)** Enter the duration, in milliseconds, between DTMF tones when dialing. The range is 10 through 999, and the default is 80.

- **DTMF Length during Dialing (ms)** Enter the duration, in milliseconds, of a DTMF tone when dialing. The range is 10 through 999, and the default is 80.

- **DTMF Length during Detection (ms)** Enter the length, in milliseconds, of a DTMF tone during detection. The range is 1 through 999, and the default is 50.
PBX Configuration - Transfer/Outcall Tab (QSIG)

Use the PBX Configuration dialog box, Transfer/Outcall tab to configure call transfer properties for a voice mail domain.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).
2. Double-click PBXs. The system expands the node to show all available types of PBX.
3. Double-click the QSIG PBX. The system displays the PBX Configuration dialog box for the selected voice mail domain, with the General tab active.
4. Click the Transfer/Outcall tab.

Configuring the Screen Controls

- **Transfer Mode** Select the mode to be used.
  - **Full** The system listens for busy, invalid number, no answer, and connect signals.
  - **Partial** The system listens for busy and invalid number signals.

  Note: This should not be used for call transfers.

- **Blind** (Default) No call progress analysis takes place.
PBX Configuration - Tone Detection Tab (QSIG)

Use the PBX Configuration dialog box, Tone Detection tab to configure hangup tone detection for a voice mail domain.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).

2. Double-click PBXs. The system expands the node to show all available types of PBX.

3. Double-click the QSIG PBX. The system displays the PBX Configuration dialog box for the selected voice mail domain, with the General tab active.

4. Click the Tone Detection tab.

Configuring the Screen Controls

- **Maximum Silence Before Hanging Up (ms)** Enter the duration, in milliseconds, that the voice mail system listens to a dial tone after a caller hangs up, before dropping the line. The range is 0 through 9999, and the default is 6000.
PBX Configuration - Outgoing Call Tab (QSIG)

Use the PBX Configuration dialog box, Outgoing Call tab to configure the properties of an outgoing call in a voice mail domain.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).

2. Double-click PBXs. The system expands the node to show all available types of PBX.

3. Double-click the QSIG PBX. The system displays the PBX Configuration dialog box for the selected voice mail domain, with the General tab active.

4. Click the Outgoing Call tab.

Configuring the Screen Controls

- **Layer1 Protocol** This value defines the Layer 1 protocol used with the outgoing call. Select one of the following supported values:
  
  - G.711µ-law (mu-law).
  
  - G.711A-law (default).

  **Note:** Ensure that the form of G.711 encoding matches that of the PBX. In general, µ-law (mu-law) is used in North America and Japan, and A-law is used in Europe. If your choice of encoding scheme does not match the PBX, then audio will sound garbled.

- **BC Transfer Cap** This value defines the transfer rate for bearer capability information. Select one of the following supported values:
  
  - Speech (default)
  
  - Unrestricted Digital Data
  
  - Restricted Digital Data

- **Number Type** Select the number type designated by the local ISDN provider. Select one of the following supported values:
  
  - Unknown (default)
  
  - International
  
  - National
— **Local**

- **Number Plan** Select the number plan designated by the local ISDN provider. Select one of the following supported values:
  - **Unknown** (default)
  - **ISDN/Telephony E.164/E.163**
  - **Private**

- **Origin Number** This is the originating telephone number for all outgoing calls. This must be a unique number that does not conflict with any other extension in the MAS. You can enter up to 32 digits, and the default is 9999.
PBX Configuration - Intercom Paging Tab (QSIG)

Use the PBX Configuration dialog box, Intercom Paging tab to configure PBX intercom paging properties for a voice mail domain. Using intercom paging, callers can page subscribers in the building, if they do not answer their extensions.

Notes:

- For Modular Messaging to do trunk-level paging, you must have additional hardware between the Modular Messaging system, the PBX, and the paging system. For more information, contact your Modular Messaging service or technical support representative.

- After you make changes to Intercom Paging properties, you must stop and restart the MM Messaging Application Server service. If you do not do so, the changes do not take effect. See Appendix C, Modular Messaging (MM) Services.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).

2. Double-click PBXs. The system expands the node to show all available types of PBX.

3. Double-click the QSIG PBX. The system displays the PBX Configuration dialog box for the selected voice mail domain, with the General tab active.

4. Click the Intercom Paging tab.

Configuring the Screen Controls

- Enable Intercom Paging Select to allow a caller to page subscribers in the building, if they do not answer their extension.

  This check box is cleared by default. Selecting it activates all the other fields in the tab.

  — Intercom Paging Code Enter the intercom paging code sent to the PBX to start intercom paging, if required by the PBX. This field is blank by default.

  — Release Code for Intercom Paging Enter the code sent to the PBX to stop intercom paging. This field is blank by default.

  — Repeat Intercom Paging Phrase Select to get the Automated Attendant to play the intercom paging phrase (“there is a call for <subscriber’s name>”) twice instead of once. This check box is cleared by default.
— **Number of Retries when Paging System is Busy**  Enter a number to specify the number of times the voice mail system attempts to page a subscriber when met by a busy response. The range is 0 through 9, and the default is 3.

— **Number of Retries when No Answer**  Enter a number to specify the number of times a caller can request to page a subscriber whose extension is not answered. The range is 0 through 9, and the default is 3.

— **Paging Wait Time (sec)**  Enter the number of seconds a caller is kept on hold after paging a subscriber. The range is 0 through 99, and the default is 10.
This topic describes how to use the **PBX Configuration** dialog box to configure Private Branch Exchange (PBX) properties, if you are using set emulation cards.

You can configure the PBX to determine the way in which it communicates with the voice mail domain. The PBX is sometimes referred to as the "switch".

Use the **PBX Configuration** dialog box to configure the PBX Dual Tone Multi-Frequency (DTMF) dialing tones, the transfer mode, call progress options, tone detection, hang-up detection, and intercom paging.

### Notes:

- In the **Voice Mail System Configuration** window, under the **Voice Mail Domain** tree, **PBXs** node, you can add new PBX types, if necessary. See [Add New PBX Dialog Box](#) on page 3-118.

- For more information on configuring your PBX, see the PBX configuration notes. Configuration notes are available from the Avaya Support Website at [http://www.avaya.com/support](http://www.avaya.com/support).

### Launching the Screen

1. In the **Voice Mail System Configuration** window, click the voice mail domain (VMD).

2. Double-click **PBXs**. The system expands the node to show all available types of PBX.

3. Double-click the **Set Emulation** PBX. The system displays the **PBX Configuration** dialog box for the selected voice mail domain.

### Tabs Available in this Dialog Box

**Note:** To configure this dialog box, you must be a member of a security role assigned the **Telephony - Administer** task. If you are a member of a role assigned the **Telephony - View** task, you have read-only access to this dialog box. See [Security Roles Dialog Box](#) on page 3-88.

- **General** Use this tab to set up general PBX options. You can use it to set options for DTMF dialing tones. See [PBX Configuration - General Tab (Set Emulation)](#) on page 3-140.
- **Transfer/Outcall**  Use this tab to set up PBX call transfer options, including the transfer mode and call progress options. See [PBX Configuration - Transfer/Outcall Tab (Set Emulation)](3-141) on page 3-141.

- **Tone Detection**  Use this tab to set up PBX hangup-detection options. See [PBX Configuration - Tone Detection Tab (Set Emulation)](3-143) on page 3-143.

- **Intercom Paging**  Use this tab to set up PBX intercom paging options. Intercom paging allows callers to page subscribers in the building, if they do not answer their extensions. See [PBX Configuration - Intercom Paging Tab (Set Emulation)](3-144) on page 3-144.
PBX Configuration - General Tab (Set Emulation)

Use the PBX Configuration dialog box, General tab to configure the PBX Dual Tone Multi-Frequency (DTMF) dialing tones.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).
2. Double-click PBXs. The system expands the node to show all available types of PBX.
3. Double-click the Set Emulation PBX. The system displays the PBX Configuration dialog box for the selected voice mail domain, with the General tab active.

Configuring the Screen Controls

- **DTMF Inter-Digit Delay during Dialing (ms)** Enter the duration, in milliseconds, between DTMF tones during detection. The range is 1 through 999, and the default is 80.

- **DTMF Length during Dialing (ms)** Enter the duration, in milliseconds, of a DTMF tone when dialing. The range is 10 through 999, and the default is 80.

- **DTMF Length during Detection (ms)** Enter the length, in milliseconds, of a DTMF tone during detection. The range is 1 through 9999, and the default is 50.

- **Port Disable Key** Select the key used to disable the port on the MAS. When disabled, the PBX cannot send calls to that port and the port cannot make outgoing calls. The default is C.
PBX Configuration - Transfer/Outcall Tab (Set Emulation)

Use the PBX Configuration dialog box, Transfer/Outcall tab to configure the transfer mode and call progress options.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).
2. Double-click PBXs. The system expands the node to show all available types of PBX.
3. Double-click the Set Emulation PBX. The system displays the PBX Configuration dialog box for the selected voice mail domain, with the General tab active.
4. Click the Transfer/Outcall tab.

Configuring the Screen Controls

- **Transfer Mode**  Select the mode to be used.
  - **Full**  The system listens for busy, invalid number, no answer, and connect signals.
  - **Partial**  The system listens for busy and invalid number signals.

  **Note:**  This should not be used for call transfers.

  - **Blind**  (Default) No call progress analysis takes place.

- **Start Delay for Call Progress**  Enter the duration, in milliseconds, between dialing a number and starting call progress. The range is 0 through 20000, and the default is 6000.

- **Initiate Transfer**  Enter the dial string required to start a transfer. You can enter up to 50 characters. The default is ^KD,L%s for NT M-1 and ^Kk,L%s for G3 PBXs.

  **Note:**  For more information on dialing string syntax, see Dialing String Syntax on page 3-146.

- **Initiate Blind Transfer**  Identifies the dial string required to start an unsupervised transfer. By default the behavior of the Initiate Blind Transfer dial string is the same as the behavior of the Initiate Transfer dial string. If required, you can add characters to control the behavior of this dial string. You can enter up to 50 characters, and the default is %s.
Complete Transfer  Enter the dial string required to complete a transfer. You can enter up to 50 characters. The default is ^KD for NT M-1, and ^Kk for G3 PBXs.

Retrieve Call  Enter the dial string required to drop a transferring call and reconnect the MAS to the calling party. You can enter up to 50 characters, and the default is ^KA.

Drop Call  Enter the dial string required to drop a call by emulating the Release key. You can enter up to 50 characters. The default is ^KR for NT M-1, and ^Kj for G3 PBXs.

Make Call Prefix  Enter the dial string required when using an alternate key for outgoing calls. This setting is used mostly for automatic call distribution (ACD) integrations, where outgoing calls are made on a different call appearance than incoming calls. You can enter up to 50 characters, and the default is blank.

Note: For information on automatic call distribution, see MAS - Telephony Interface - ACD Tab (Set Emulation) on page 4-21.
**PBX Configuration - Tone Detection Tab (Set Emulation)**

Use the **PBX Configuration** dialog box, **Tone Detection** tab to configure hangup tone detection for a voice mail domain.

**Launching the Screen**

1. In the **Voice Mail System Configuration** window, click the voice mail domain (VMD).
2. Double-click **PBXs**. The system expands the node to show all available types of PBX.
3. Double-click the **Set Emulation** PBX. The system displays the **PBX Configuration** dialog box for the selected voice mail domain, with the **General** tab active.
4. Click the **Tone Detection** tab.

**Configuring the Screen Controls**

- **Maximum Silence before Hanging Up (ms)** Enter the time, in milliseconds, that the voice mail system listens to a dial tone after a caller hangs up, before dropping the line. The range is 0 through 9999, and the default is 6000.

- **Maximum Tone before Hanging Up (ms)** Enter the time, in milliseconds, that the voice mail system listens to a continuous tone, before dropping the line. This prevents the system from recording dial tones. The range is 0 through 12000, and the default is 6000.

- **Record trim length (ms)** Enter the amount of time to trim off a recording that is terminated by the caller hanging up. That is, when a caller records a message and then hangs up, the end of the recording will be trimmed by the amount of time specified in this field. The range is 0-32000, the default is 0.
PBX Configuration - Intercom Paging Tab (Set Emulation)

Use the PBX Configuration dialog box, Intercom Paging tab to configure PBX intercom paging properties for a voice mail domain. Using intercom paging, callers can page subscribers in the building, if they do not answer their extensions.

Notes:

- For Modular Messaging to do trunk-level paging, you must have additional hardware between the Modular Messaging system, the PBX, and the paging system. For more information, contact your Modular Messaging service or technical support representative.

- After you make changes to Intercom Paging properties, you must stop and restart the MM Messaging Application Server service. If you do not do so, the changes do not take effect. See Appendix C, Modular Messaging (MM) Services.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).

2. Double-click PBXs. The system expands the node to show all available types of PBX.

3. Double-click the Set Emulation PBX. The system displays the PBX Configuration dialog box for the selected voice mail domain, with the General tab active.

4. Click the Intercom Paging tab.

Configuring the Screen Controls

- **Enable Intercom Paging** Select to allow a caller to page subscribers in the building, if they do not answer their extension.

  This check box is cleared by default. Selecting it activates all the other fields in the tab.

  — **Intercom Paging Code** Enter the intercom paging code sent to the PBX to start intercom paging, if required by the PBX. This field is blank by default

  — **Release Code for Intercom Paging** Enter the code sent to the PBX to stop intercom paging. This field is blank by default

  — **Repeat Intercom Paging Phrase** Select to get the Automated Attendant to play the intercom paging phrase (“there is a call for <subscriber’s name>”) twice instead of once. This check box is cleared by default.
— **Number of Retries when Paging System is Busy**  Enter a number to specify the number of times the voice mail system attempts to page a subscriber when met by a busy response. The range is 0 through 9, and the default is 3.

— **Number of Retries when No Answer**  Enter a number to specify the number of times a caller can request to page a subscriber whose extension is not answered. The range is 0 through 9, and the default is 3.

— **Paging Wait Time (sec)**  Enter the number of seconds a caller is kept on hold after paging a subscriber. The range is 0 through 99, and the default is 10.
Dialing String Syntax

Available Dialing String Syntax

- ^ Means substitute with the Escape key.
- L  Means wait for dial tone.
- %s Means substitute with the number dialed.
- , (comma) Means pause.
- K Identifies a particular key. For example KD identifies the D key.
- & (ampersand) Marks the transition between the destination number and the inband DTMFs played to the answering system.

Dialing string syntax is used in the Transfer/Outcall tab of the PBX Configuration dialog box. See PBX Configuration - Transfer/Outcall Tab (Set Emulation) on page 3-141.
PBX Configuration Dialog Box (IP H.323)

This topic describes how to use the **PBX Configuration** dialog box to configure Private Branch Exchange (PBX) properties for H.323-based IP integration.

You can configure the PBX to determine the way in which it communicates with the voice mail domain. The PBX is sometimes referred to as the “switch”.

Use the **PBX Configuration** dialog box to configure the PBX transfer mode, tone detection, and outgoing call options.

### Notes:

- In the **Voice Mail System Configuration** window, under the **Voice Mail Domain** tree, **PBXs** node, you can add new PBX types, if necessary. See [Add New PBX Dialog Box](#) on page 3-118.

- For more information on configuring your PBX, see the PBX configuration notes. Configuration notes are available from the Avaya Support Website at http://www.avaya.com/support.

### Launching the Screen

1. In the **Voice Mail System Configuration** window, click the voice mail domain (VMD).

2. Double-click **PBXs**. The system expands the node to show all available types of PBX.

3. Double-click the **IP H.323** PBX. The system displays the **PBX Configuration** dialog box for the selected voice mail domain.

### Tabs Available in this Dialog Box

**Note:** To configure this dialog box, you must be a member of a security role assigned the **Telephony - Administer** task. If you are a member of a role assigned the **Telephony - View** task, you have read-only access to this dialog box. See [Security Roles Dialog Box](#) on page 3-88.

- **Transfer/Outcall** Use this tab to configure the transfer mode. See [PBX Configuration - Transfer/Outcall Tab (IP H.323)](#) on page 3-149.
- **Tone Detection**  Use this tab to specify the maximum silence before hanging up. See [PBX Configuration - Tone Detection Tab (IP H.323)](#) on page 3-150.

- **Outgoing Call**  Use this tab to set up PBX outgoing call options, including the number plan and the number type. See [PBX Configuration - Outgoing Call Tab (IP H.323)](#) on page 3-151.
PBX Configuration - Transfer/Outcall Tab (IP H.323)

Use the PBX Configuration dialog box, Transfer/Outcall tab to configure call transfer properties for a voice mail domain.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).
2. Double-click PBXs. The system expands the node to show all available types of PBX.
3. Double-click the IP H.323 PBX. The system displays the PBX Configuration dialog box for the selected voice mail domain, with the General tab active.
4. Click the Transfer/Outcall tab.

Configuring the Screen Controls

- **Transfer Mode** Select the mode to be used.
  - **Full** The system listens for busy, invalid number, no answer, and connect signals.
  - **Partial** The system listens for busy and invalid number signals.

  **Note:** This should not be used for call transfers.

- **Blind** (Default) No call progress analysis takes place.
PBX Configuration - Tone Detection Tab (IP H.323)

Use the PBX Configuration dialog box, Tone Detection tab to configure hangup tone detection for a voice mail domain.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).
2. Double-click PBXs. The system expands the node to show all available types of PBX.
3. Double-click the IP H.323 PBX. The system displays the PBX Configuration dialog box for the selected voice mail domain, with the General tab active.
4. Click the Tone Detection tab.

Configuring the Screen Controls

- Maximum Silence Before Hanging Up (ms) Enter the duration, in milliseconds, that the voice mail system listens to a dial tone after a caller hangs up, before dropping the line. The range is 0 through 9999, and the default is 6000.
PBX Configuration - Outgoing Call Tab (IP H.323)

Use the PBX Configuration dialog box, Outgoing Call tab to configure the properties of an outgoing call in a voice mail domain.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).
2. Double-click PBXs. The system expands the node to show all available types of PBX.
3. Double-click the IP H.323 PBX. The system displays the PBX Configuration dialog box for the selected voice mail domain, with the General tab active.
4. Click the Outgoing Call tab.

Configuring the Screen Controls

- **Layer1 Protocol**  This value defines the Layer 1 protocol used with the outgoing call. Select one of the following supported values:
  - G.711µ-law (mu-law).
  - G.711A-law (default).

  **Note:** Ensure that the form of G.711 encoding matches that of the PBX. In general, µ-law (mu-law) is used in North America and Japan, and A-law is used in Europe. If your choice of encoding scheme does not match the PBX, then audio will sound garbled.

- **BC Transfer Cap**  This value defines the transfer rate for bearer capability information. Select one of the following supported values:
  - Speech (default)
  - Unrestricted Digital Data
  - Restricted Digital Data

- **Number Type**  Select the number type designated by the local ISDN provider. Select one of the following supported values:
  - Unknown (default)
  - International
  - National
— Local

- **Number Plan**  Select the number plan designated by the local ISDN provider. Select one of the following supported values:
  - **Unknown** (default)
  - **ISDN/Telephony E.164/E.163**
  - **Private**

- **Origin Number**  This is the originating telephone number for all outgoing calls. This must be a unique number that does not conflict with any other extension in the MAS. You can enter up to 32 digits, and the default is 9999.
PBX Configuration Dialog Box (IP SIP)

Note: For a detailed overview of voice mail domain configuration in the Voice Mail System Configuration (VMSC) application, see Overview of VMD Configuration in VMSC on page 3-3.

This topic describes how to use the PBX Configuration dialog box to configure Private Branch Exchange (PBX) properties for SIP-based IP integration.

You can configure the PBX to determine the way in which it communicates with the voice mail domain. The PBX is sometimes referred to as the “switch”.

Use the PBX Configuration dialog box to configure the PBX Dual Tone Multi-Frequency (DTMF) dialing tones, the transfer mode, and tone detection.

Notes:

- In the Voice Mail System Configuration window, under the Voice Mail Domain tree, PBXs node, you can add new PBX types, if necessary. See Add New PBX Dialog Box on page 3-118.

- For more information on configuring your PBX, see the PBX configuration notes. Configuration notes are available from the Avaya Support Website at http://www.avaya.com/support.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).

2. Double-click PBXs. The system expands the node to show all available types of PBX.

3. Double-click the IP SIP PBX. The system displays the PBX Configuration dialog box for the selected voice mail domain.

Tabs Available in this Dialog Box

Note: To configure this dialog box, you must be a member of a security role assigned the Telephony - Administer task. If you are a member of a role assigned the Telephony - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

- General Use this tab to set up general PBX options. You can use it to set options for DTMF dialing tones. See PBX Configuration - General Tab (IP SIP) on page 3-155.
- **Transfer/Outcall**  Use this tab to configure the transfer mode. See [PBX Configuration - Transfer/Outcall Tab (IP SIP)](#) on page 3-156.

- **Tone Detection**  Use this tab to specify the maximum silence before hanging up. See [PBX Configuration - Tone Detection Tab (IP SIP)](#) on page 3-157.

- **SIP**  Use this tab to configure the gateway addresses and the outgoing and incoming phone number translation rules. See [PBX Configuration - SIP Tab (IP SIP)](#) on page 3-158.
PBX Configuration - General Tab (IP SIP)

Use the PBX Configuration dialog box, General tab to configure the PBX Dual Tone Multi-Frequency (DTMF) dialing tones.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).
2. Double-click PBXs. The system expands the node to show all available types of PBX.
3. Double-click the IP SIP PBX. The system displays the PBX Configuration dialog box for the selected voice mail domain, with the General tab active.

Configuring the Screen Controls

- **PBX Name** Enter a descriptive name for the PBX. The PBX name appears in the Voice Mail System Configuration (VMSC) tree after you close the PBX Configuration dialog box, and allows you to differentiate between switches of the same type. If you do not enter a name for the PBX, the default name appears in the VMSC tree.

- **DTMF Inter-Digit Delay during Dialing (ms)** Enter the duration, in milliseconds, between DTMF tones when dialing. The range is 10 through 999, and the default is 80.

- **DTMF Length during Dialing (ms)** Enter the duration, in milliseconds, of a DTMF tone when dialing. The range is 10 through 999, and the default is 80.

- **DTMF Length during Detection (ms)** Enter the length, in milliseconds, of a DTMF tone during detection. The range is 1 through 999, and the default is 50.
PBX Configuration - Transfer/Outcall Tab (IP SIP)

Use the PBX Configuration dialog box, Transfer/Outcall tab to configure call transfer properties for a voice mail domain.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).
2. Double-click PBXs. The system expands the node to show all available types of PBX.
3. Double-click the IP SIP PBX. The system displays the PBX Configuration dialog box for the selected voice mail domain, with the General tab active.
4. Click the Transfer/Outcall tab.

Configuring the Screen Controls

- **Transfer Mode** Select the mode to be used.
  - **Full** The system listens for busy, invalid number, no answer, and connect signals.
  - **Partial** The system listens for busy and invalid number signals.

  **Note:** This should not be used for call transfers.

- **Blind** (Default) No call progress analysis takes place.
PBX Configuration - Tone Detection Tab (IP SIP)

Use the **PBX Configuration** dialog box, **Tone Detection** tab to configure hangup tone detection for a voice mail domain.

**Launching the Screen**

1. In the **Voice Mail System Configuration** window, click the voice mail domain (VMD).
2. Double-click **PBXs**. The system expands the node to show all available types of PBX.
3. Double-click the **IP SIP** PBX. The system displays the **PBX Configuration** dialog box for the selected voice mail domain, with the **General** tab active.
4. Click the **Tone Detection** tab.

**Configuring the Screen Controls**

- **Maximum Silence Before Hanging Up (ms)** Enter the duration, in milliseconds, that the voice mail system listens to a dial tone after a caller hangs up, before dropping the line. The range is 0 through 9999, and the default is 6000.
PBX Configuration - SIP Tab (IP SIP)

Use the PBX Configuration dialog box, SIP tab to configure the gateway addresses and the incoming and outgoing phone number translation rules for a voice mail domain.

**Note:** For an overview of the MultiSite feature and a detailed description of the concepts underlying MultiSite, such as translation rules, see *Avaya Modular Messaging MultiSite Guide*.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).
2. Double-click PBXs. The system expands the node to show all available types of PBX.
3. Double-click the IP SIP PBX. The system displays the PBX Configuration dialog box for the selected PBX, with the General tab active.
4. Click the IP SIP tab.

Configuring the Screen Controls

- **Gateway Addresses** Enter the IP address or FQDN for the gateway. This is the IP address that MASs use to communicate with the PBX. Select the check box preceding the IP address/FQDN to enable the gateway for the selected PBX.
  - ![Add](image) Adds a new entry to the Gateway Addresses list box.
  - ![Remove](image) Removes the selected entry from the Gateway Addresses list box.
  - ![Open](image) Opens the Advanced SIP Logging dialog box where you can configure a gateway to enable advanced logging of incoming and outgoing SIP messages from a gateway. For this procedure, see Enabling Advanced SIP Logging on page 3-160.

- **TCP/TLS** Enter either TCP or TLS, depending on which protocol the gateway uses to communicate with the MAS. The default is TLS. Avaya recommends TLS because it is secure, but the gateway must be configured to use it.

- **MWI** Select to enable the Message Waiting Indicator feature. The check box is selected by default. If this check box is not selected for the gateway, MWI is considered to be disabled for that gateway.
**VMSC - Voice Mail Domain (VMD) Configuration**

- **SRTP**  Specifies the security level for communication between the gateway and the PBX. Double-click the entry and select **High**, **Low**, or **None**. The default is **High**.

- **P-Asserted Identity**  Enter an extension number with an optional domain name, for example, 4999@example.com. This extension number is used by the PBX to grant appropriate permissions to Modular Messaging. This field is optional and is only applicable if your PBX is Communication Manager.

- **SIP Domain**  Enter the fully qualified domain name that is assigned to the SES Server.

**Note:** If you are unsure about this field, most often the SIP domain should be the root level DNS domain. For example, for the DS domain of eastcoast.example.com, the SIP domain would likely be configured to example.com.

- **Configure**  Click to open the **Translation Rules** dialog box where you can configure the rules to translate phone numbers between switch native and canonical formats. See **PBX Configuration - SIP Tab (IP SIP) - Translation Rules Dialog Box** on page 3-161.
Enabling Advanced SIP Logging

Avaya Modular Messaging Release 5.1 allows you to enable a gateway to direct the SIP message logs generated by the SIP call management software to the Operation History Viewer.

When advanced SIP logging is enabled for a gateway, the SIP message events are displayed by the Operation History Viewer for each SIP message exchanged with the selected gateway. For more information about the Operation History Viewer, see Chapter 8, “Operation History Viewer”.

Use the following procedure to enable advanced SIP logging for a gateway:

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).
2. Double-click PBXs. The system expands the node to show all available types of PBX.
3. Double-click the IP SIP PBX. The system displays the PBX Configuration dialog box for the selected PBX, with the General tab active.
4. Click the IP SIP tab.
5. Right-click a gateway and click Advanced SIP Logging or select a gateway and click .
6. The system displays the Advanced Gateway Logging dialog box. The dialog box shows current logging status for the gateway. If logging is already enabled for the gateway, the dialog also displays the remaining time.
7. To enable logging, select the number of minutes you want to enable advanced SIP logging from the Enable advanced logging for the following number of minutes drop-down box. You can enable advanced SIP logging for up to one hour, in increments of 15 minutes. SIP logging stops automatically at the end of the specified time. Click OK.
8. If logging is already enabled, click Stop logging to stop advanced SIP logging. This button is disabled if advanced SIP logging is not enabled.
PBX Configuration - SIP Tab (IP SIP) - Translation Rules Dialog Box

**Note:** For an overview of the MultiSite feature and a detailed description of the concepts underlying MultiSite, such as translation rules, see *Avaya Modular Messaging MultiSite Guide.*

This topic describes how to use the Translation Rules dialog box to configure translation rules for the voice mail domain.

**Notes:**

- Translation rules are only used in a Multisite-enabled Modular Messaging system. Configuring them for a non-Multisite system will have no effect.

- An MAS uses the translation rules to convert numbers in switch-native format to canonical numbers when receiving inbound calls. Similarly, when making outbound calls the canonical numbers are converted to switch-native format.

- In a MultiSite-enabled voice mail domain, the translation rules replace the following:
  - Rules configured on the Dialing Rules node.
  - Outcalling Restrictions configured on the Caller tab of the Telephone User Interface node.

  If MultiSite is enabled, these options are removed from the Voice Mail Configuration System.

**Launching the Screen**

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).

2. Double-click PBXs. The system expands the node to show all available types of PBX.

3. Double-click the IP SIP PBX. The system displays the PBX Configuration dialog box for the selected PBX, with the General tab active.

4. Click the IP SIP tab.

5. Click Configure to open the Translation Rules dialog box.
Configuring the Screen Controls

- **Test Inputs** Use to enter different types of phone numbers that you expect the MAS to handle. These phone numbers are used to test whether they are successfully matched by an incoming rule to produce a canonical number, and whether canonical number is also successfully matched by the corresponding outgoing rule.

  - **Add** Click to add a phone number.
  - **Delete** Click to delete the selected phone number.

- **Incoming translation rule** Use to describe the incoming phone number translation rules for converting phone numbers from switch-native form to canonical form.

  - **Description** Enter a description of the type of call the translation rule will be applied to. For example, local switch extension, national, international, or premium-rate number.

  - **Add** Click to add a phone number translation rule.

  - **Delete** Click to delete the selected phone number translation rule.

  - **Move Up/Move Down** Click to move the selected rule up or down in the list.

  - **Match** Enter the regular expression to be used for the translation rule.

**Note**: You must have a good understanding of the type of calls (local extensions, national, international, or premium-rate numbers) that your PBX is expected to handle. You must also have a thorough understanding of regular expressions and how they are used to define the translation rules for different call types. For detailed description of translation rules and regular expressions see *Avaya Modular Messaging MultiSite Guide*.
— **Output** Enter the set of characters from the corresponding group in the *match* part of the rule.

The output of an incoming phone number translation rule falls into one of the following categories:

— The input for a incoming translation rule is a switch-native number. If the rule does not match the input then there is no output, and the next rule is evaluated.

— If the rule produces an output that starts with a leading ‘+’ sign then it is a terminating rule – no further rules are evaluated because a canonical number is produced. In this case, the output is taken as the final output of the rule set.

— If the rule produces output that does not start with a leading ‘+’ sign then it is a transforming rule, and the output becomes the new input for the next rule. If no output is produced after the final rule has been evaluated, or the output is not canonical, then the input dial string is deemed to be invalid.

**Outgoing translation rule** Use to describe a matching set of outgoing phone number translation rules for converting from canonical form into switch-native format.

— **Description** Enter a description of the type of call the translation rule will be applied to. For example, local switch extension, national, international, or premium-rate number.

— **Add** Click to add a phone number translation rule.

— **Delete** Click to delete the selected phone number translation rule.

— **Move Up/Move Down** Click to move the selected rule up or down in the list.

— **Match** Enter the regular expression to be used for the translation rule.

**Note:** You must have a good understanding of the type of calls (local extensions, national, international, or premium-rate numbers) that your PBX is expected to handle. You must also have a thorough understanding of regular expressions and how they are used to define the translation rules for different call types. For detailed description of translation rules and regular expressions see *Avaya Modular Messaging MultiSite Guide*. 
— **Output** Enter the set of characters from the corresponding group in the *match* part of the rule.

The output of an outgoing phone number translation rule falls into any of the following categories:

— The input for a outgoing translation rule is a canonical number. The rules are evaluated from top to bottom. If the rule does not match the input then there is no output, and the next rule is evaluated.

— If the rule produces an output that is recognized by the Private Branch Exchange (PBX) then it is a terminating rule – no further rules are evaluated because a switch-native number is produced. In this case, the output is taken as the final output of the rule set.

— **Cost** Enter a number from 0 to 10000 for each translation rule. The cost indicates how expensive it is to dial the number that matches a certain rule. When a terminating outgoing translation rule produces a switch-native phone number, the cost associated with that call is validated against the voice mail domain-wide setting for making outbound calls. For more information on costs controlling outbound calls. See [Sites Dialog Box](#) on page 3-16.

The costs specified for outbound calls control whether, for example, a subscriber is allowed to call just the local extensions, or national, international, or premium rate numbers.
PBX Integration Dialog Box

Use the **PBX Integration** dialog box to configure SIP-based IP integration for the voice mail domain when the MultiSite feature is enabled. This provides IP connectivity between the Private Branch Exchange (PBX) and the Messaging Application Server (MAS). This is available with Avaya DEFINITY®, IP600, MultiVantage™, and Communication Manager PBXs only.

**Note:** After configuring these settings, you must stop and restart the **MM Messaging Application Server** service for the settings to take effect. See Appendix C, Modular Messaging (MM) Services.

**Launching the Screen**

1. In the **Voice Mail System Configuration** window, click the voice mail domain (VMD).

2. Double-click **SIP Integration**. The system displays the **PBX Configuration** dialog box for the selected voice mail domain.

**Configuring the Screen Controls**

- **Port Details**
  - **RTP Port Range** Enter a minimum and maximum port number to specify a block of real-time protocol (RTP) IP port numbers.
  - **Packet Size Bytes** Enter the size of the IP packets that are used for the real-time protocol.

- **Protocols Details**
  - **TLS Port Number** Enter the IP port number used for the transport layer security (TLS) protocol.
  - **TCP Port Number** Enter the IP port number used for the transaction control protocol (TCP).
  - **Enable** Select to enable communication using the transaction control protocol.
Languages Dialog Box

**Note:** For a detailed overview of voice mail domain configuration in the Voice Mail System Configuration (VMSC) application, see Overview of VMD Configuration in VMSC on page 3-3.

This topic describes how to use the Languages dialog box to configure languages for a voice mail domain.

You can configure multiple languages for use by the Telephone User Interface (TUI) and enable multilingual Text-to-Speech (TTS), if you wish.

You must set a primary language for the voice mail domain. This is played by the TUI, unless instructed otherwise, for example, by caller language selection, or by subscriber mailbox configuration. If multilingual TTS conversion is requested and the language of the text cannot be determined, then this language is used.

**Notes:**

- The primary language must be a language that is installed on all Messaging Application Servers (MASs) in the voice mail domain.

- There is another Languages dialog box in the Voice Mail System Configuration application, which appears under the tree view of each MAS in the voice mail domain. This displays a list of all languages installed on that particular MAS. See MAS - Languages Dialog Box on page 4-13.

- You can use the Edit > Refresh Domain Languages menu command to refresh the languages for the selected voice mail domain. This should be used, if you have installed a language and cannot see it for any reason, or if you have removed an MAS from the voice mail domain. This menu command is only enabled when you select a voice mail domain in the tree.

- The ScanSoft User Dictionary Editor (UDE) is an application designed to create and edit user dictionaries for TTS. This is installed automatically with Modular Messaging, and can be launched using Start > Programs > ScanSoft > RealSpeak 4.0 > Launch rsude.exe. This application has online help to describe its usage.

**Launching the Screen**

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Languages. The system displays the Languages dialog box for the selected voice mail domain, with the Domain Languages tab active.
Configuring the Screen Controls

**Note:** To configure this dialog box, you must be a member of a security role assigned the **Languages - Administer** task. If you are a member of a role assigned the **Languages - View** task, you have read-only access to this dialog box. See [Security Roles Dialog Box](#) on page 3-88.

- **Primary Language**  Select the primary language to be used by the TUI. The list contains all the languages in the voice mail domain. The system displays **Not Set** by default.

**Note:** When the MultiSite feature is enabled, the primary language setting is configured for each site and not for the entire voice mail domain. See [Sites - Site Properties Dialog Box](#) on page 3-27.

- **Enable Multilingual Text-to-Speech**  Select, if you want language recognition to be used to identify the correct language for converting TTS. If cleared, the primary language in the voice mail domain is used for all TTS conversions. This check box is cleared by default.

  Selecting this option enables the **Select one or more languages to use for text-to-speech** list.

- **Select one or more languages to use for text-to-speech**  Use the check boxes to select the languages that you want to enable for TTS conversions. By default only the primary language is selected.

  If the voice mail domain contains MASs from an earlier release, all languages supported by these MASs are listed. The languages supported by all MASs in the voice mail domain are selected by default. You can select additional languages but these will only be available on MASs that support them.
Audio Encoding Dialog Box

Note: For a detailed overview of voice mail domain configuration in the Voice Mail System Configuration (VMSC) application, see Overview of VMD Configuration in VMSC on page 3-3.

This topic describes how to use the Audio Encoding dialog box to configure Modular Messaging audio encoding formats.

Audio encoding formats determine the way in which audio is recorded on every Messaging Application Server (MAS) in the voice mail domain. This, in turn, determines the format of voice messages sent using the Telephone User Interface (TUI) and desktop clients. The client applications are then automatically configured to use the selected audio encoding format.

You can use the Audio Encoding dialog box to set up the default audio encoding format and enable support for teletypewriter (TTY) devices in the voice mail domain.

Notes:

- After setting the audio encoding format, you must stop and restart the MM Messaging Application Server service. For this procedure, see Appendix C, Modular Messaging (MM) Services.

- For detailed information on audio recording formats, see Avaya Modular Messaging Concepts and Planning Guide.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Audio Encoding. The system displays the Audio Encoding dialog box for the selected voice mail domain, with the Audio Encoding tab active.
Configuring the Screen Controls

**Note:** To configure this dialog box, you must be a member of a security role assigned the **Messaging - Administer** task. If you are a member of a role assigned the **Messaging - View** task, you have read-only access to this dialog box. See **Security Roles Dialog Box** on page 3-88.

- **Default Audio Encoding Format**  Select the audio encoding format you require.
  - Microsoft GSM 6.10 (the default).
  - G.711 µ-law (mu-law).
  - G.711 A-law.

  **Note:** Ensure that the form of G.711 encoding matches that of the PBX. In general, µ-law (mu-law) is used in North America and Japan, and A-law is used in Europe. If your choice of encoding scheme does not match the PBX, then audio will sound garbled.

- **Enable system for devices used by people who are deaf or hard of hearing (TTY)**  Select to enable support for teletypewriter devices in the voice mail domain. For instance:
  - The system plays **Hold (HD)** tones, when a call is first answered.
  - The system plays **Go Ahead (GA)** tones, when the recording starts.

  **Note:** This setting also forces audio encoding to G.711.
Dialing Rules Dialog Box

**Note:** For a detailed overview of voice mail domain configuration in the Voice Mail System Configuration (VMSC) application, see Overview of VMD Configuration in VMSC on page 3-3.

This topic describes how to use the Dialing Rules dialog box to configure Dialing Rules for the voice mail domain.

With Dialing Rules, local subscribers are given the option to either reply to call-answered messages from remote subscribers, or to return the call. You can configure rules for recognizing the remote subscriber’s calling party number so that the option to return the call is given, and configure the rules for returning that call.

**Note:** Remote subscribers belong to a different Modular Messaging voice mail domain within the enterprise. For the Modular Messaging system to identify callers as remote subscribers, their telephone numbers need to be mapped on the Avaya Message Store Server (Avaya MSS). For more information, see the Avaya Modular Messaging MSS Administration Guide.

You can use the Dialing Rules dialog box to manage a list of dialing rules and configure the codes used to dial outside of the local dialing plan, outside the local area codes, or an international number.

**Note:** You must add dialing rules for all telephone numbers. Message recipients cannot return calls to numbers that do not match any dialing rule.

**Launching the Screen**

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Dialing Rules. The system displays the Dialing Rules dialog box for the selected voice mail domain, with the General tab active.

**Note:** The translation rules replace dialing rules when MultiSite is enabled. In a MultiSite-enabled voice mail domain, the Dialing Rules node is removed from the Voice Mail System Configuration tree. For information on configuring translation rules, see PBX Configuration - SIP Tab (IP SIP) - Translation Rules Dialog Box on page 3-161 For an overview of the MultiSite feature and a detailed description of the concepts underlying MultiSite, such as translation rules, see Avaya Modular Messaging MultiSite Guide.
Configuring the Screen Controls

**Note:** To configure this dialog box, you must be a member of a security role assigned the **Telephony - Administer** task. If you are a member of a role assigned the **Telephony - View** task, you have read-only access to this dialog box. See [Security Roles Dialog Box](#) on page 3-88.

- **Trunk access code** Enter the code used to dial outside of the local dialing plan. You can type 0-20 characters, using digits 0 through 9, * (star) and # (pound).

- **Long distance code** Enter the code to dial a number outside the local area codes. You can type 0-20 characters, using digits 0 through 9, * (star) and # (pound).

- **International code** Enter the code used to dial an international number. You can type 0-20 characters, using digits 0 through 9, * (star) and # (pound).

**Dialing rules** This displays a list of dialing rules. These are configured in the **Telephony Dialing Rule** dialog box. See [Dialing Rules - Telephony Dialing Rule Dialog Box](#) on page 3-173.

You can configure a dialing rule by specifying the phone number length of the originating call, the initial sequence of digits of the originating calling party number, and whether it should be prefixed with the trunk, long distance or international dialing access codes.

- Opens the **Telephony Dialing Rule** dialog box so that you can configure a new rule. When you have clicked OK, the system adds a line to the **Dialing rules** list for the new rule.

- Opens the **Telephony Dialing Rule** dialog box for the rule currently selected in the **Dialing rules** list. You can modify the rule and click OK to update it.

- Deletes the rule selected in the **Dialing rules** list. The system prompts you to confirm the deletion.

- **Number length** Displays the phone number length of the originating call for the dialing rule.

- **Starting digits** Displays the sequence of digits of the originating calling party number for the dialing rule.
— **Dialing codes** Displays the type of dialing access for the dialing rule. This can be set to:

- None, ‘No dialing codes required’.
- One, for instance, ‘Use trunk access codes’.
- A combination, for instance, ‘Use trunk, long distance and international access codes’.
Dialing Rules - Telephony Dialing Rule Dialog Box

You can use the Telephony Dialing Rule dialog box to configure a dialing rule by specifying the phone number length of the originating call, the initial sequence of digits of the originating calling party number, and whether it should be prefixed with the trunk, long distance or international dialing access codes.

**Note:** No two dialing rules may have the same combination of values for **Number Length** and **Starting Digits**. Without this uniqueness criterion, there might be cases where the system cannot determine which dialing rule to employ.

**Launching & Closing the Screen**

Click the **Dialing rules** button or **Dialing Rules** button on the **General** tab of the **Dialing Rules** dialog box to launch the Telephony Dialing Rule dialog box.

When you have configured the rule and pressed **OK**, the information in these fields appears in the **Dialing Rules** list in the **Dialing Rules** dialog box. See **Dialing Rules Dialog Box** on page 3-170.

**Configuring the Screen Controls**

- **Number length** Enter the phone number length of the originating call. The range is 0 through 20. This field is set to 1 by default.

- **Starting digits** Enter the initial sequence of digits of the originating calling party number. You can type 0-20 characters, using digits 0 through 9, * (star) and # (pound). This field is blank by default.

  If this field is left blank, it means that the rule applies to any digit string of the number specified in the **Number Length** field for which another rule for that length does not apply.

- **Dialing plan** Select the type of dialing access. All the check boxes are deselected by default.

  If none are selected, the dialing rule is set to ‘**No dialing codes required**’. If one or more is selected, the dialing rule shows the combination, for instance ‘**User trunk, long distance and international access codes**’.

  - **Use trunk access code** Click to add the trunk access code to the dialing rule.

  - **Use long distance access code** Click to add the long distance access code to the dialing rule.

  - **User international access code** Click to add the international access code to the dialing rule.
Messaging Dialog Box

**Note:** For a detailed overview of voice mail domain configuration in the Voice Mail System Configuration (VMSC) application, see Overview of VMD Configuration in VMSC on page 3-3.

This topic describes how to use the Messaging dialog box to configure messaging for the voice mail domain.

You can use the Messaging dialog box to set the Privacy Enforcement Level to control how the system behaves with respect to subscriber attempts to forward messages marked as private, or attempts to reply to messages with the original private messages attached.

With Offline Access, subscribers can use the Telephone User Interface (TUI) to access recently recorded call-answered messages, even when the message store server is not accessible. You can use the Messaging dialog box to configure Offline Access. You can determine whether call-answered messages are kept up-to-date in the offline message store, how long they are kept up-to-date, and how often.

**Notes:**

- For more information on Offline Access, see Understanding Offline Access on page 3-180.
- To configure Messaging for the Message Application Server, see MAS - Messaging Dialog Box on page 4-11.

**Launching the Screen**

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).

2. Double-click Messaging. The system displays the Messaging dialog box for the selected voice mail domain.

**Tabs Available in this Dialog Box**

**Note:** To configure this dialog box, you must be a member of a security role assigned the Messaging - Administer task. You must also have local admin rights in Windows. If you are a member of a role assigned the Messaging - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

- **General** Use this tab to configure the privacy enforcement level for a voice mail domain.
You can set the Privacy Enforcement Level to control how the system behaves with respect to subscriber attempts to forward messages marked as private, or attempts to reply to messages with the original private messages attached. See Messaging - General Tab on page 3-176.

- **Offline Access** Use this tab to configure Offline Access for a voice mail domain.

With Offline Access, subscribers can use the TUI to access recently recorded call-answered messages, even when the message store server (Avaya MSS) is not accessible.

You can use the Offline Access tab to determine whether call-answered messages are kept up-to-date in the offline message store, how long they are kept up-to-date, and how often. See Messaging - Offline Access Tab on page 3-178.
Messaging - General Tab

Use the Messaging dialog box, General tab to configure the privacy enforcement level for a voice mail domain.

Traditional voice mail systems typically prevent subscribers from forwarding messages marked as private or from replying to private messages with the original message attached. Most e-mail systems and e-mail clients, however, do not prevent these actions, even when a message is marked as private.

You can use the General tab to set the Privacy Enforcement Level to control how the system behaves with respect to subscriber attempts to forward messages marked as private, or attempts to reply to messages with the original private messages attached.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Messaging. The system displays the Messaging dialog box for the selected voice mail domain, with the General tab active.

Configuring the Screen Controls

- Privacy Enforcement Level  Select one of the following options:

  - Full  (Default for new systems) Select to prevent subscribers from forwarding any message marked as private. It also prevents them from replying to a private message with the original message attached.

  When this option is selected, the system also restricts delivery of new private messages to recipients on networked machines (that is, other MASs, MSSs or message systems in the network). This allows private messages to be delivered only to messaging systems capable of enforcing privacy settings.

Note:  Selecting this option also overrides the Restrict Client Access to Mailboxes? class of service (COS) option on the Avaya MSS. When this option is selected, all COSs behave as if that option were set to Yes.
— **Partial** Select to prevent subscribers from forwarding any message marked as private or replying to a private message with the original message attached. It does not, however, restrict delivery of new private messages to recipients on networked machines (that is, other MASs, MSSs or message systems in the network). Private messages can be delivered to messaging systems that may not be capable of enforcing privacy settings.

**Note:** Avaya Modular Messaging subscribers may receive messages marked private from users on networked voice mail systems, such as Voice Profile for Internet Mail (VPIM) systems, who do not expect recipients to be able to forward them. This Privacy Enforcement Level does not, in all cases, preserve traditional voice mail semantics for private messages.

This also means that recipients of messages marked private may be able to forward them to others using e-mail. This includes subscribers using the Avaya Outlook “thick” client and non-Avaya IMAP4 and POP3 clients, if the class of service (COS) has the **Restrict Client Access to Mailbox?** option set to **No**.

— **Notification Only** (Default for upgrades from previous Modular Messaging releases) Select to allow subscribers to forward private messages or reply with the original private message attached. Although messages are marked and announced in the Telephone User Interfaces (TUIs) as being private, they are not restricted from client access, and may be forwarded without restriction.

**Note:** Allowing recipients to forward messages marked as private violates the VPIM specification (RFC 2421, section 4.2.13). Because of this, private messages originating from VPIM systems are not delivered to Modular Messaging subscribers when this option is selected.
VMSC - Voice Mail Domain (VMD) Configuration

**Messaging - Offline Access Tab**

Use the **Messaging** dialog box, **Offline Access** tab to configure Offline Access for a voice mail domain.

With Offline Access, subscribers can use the Telephone User Interface (TUI) to access recently recorded call-answered messages, even when the message store server (Avaya MSS) is not accessible.

You can use the **Offline Access** tab to determine whether call-answered messages are kept up-to-date in the offline message store, how long they are kept up-to-date, and how often.

**Notes:**

- For detailed information about the Offline Access feature, see [Understanding Offline Access](#) on page 3-180

- Before you can configure the **Offline Access** tab, you must create the offline message store folder, set it as a shared folder and configure the permissions. For this procedure see [Configuring the Offline Message Store Folder](#) on page 3-182.

**Launching the Screen**

1. In the **Voice Mail System Configuration** window, click the voice mail domain.

2. Double-click **Messaging**. The system displays the **Messaging** dialog box for the selected voice mail domain, with the **General** tab active.

3. Click the **Offline Access** tab.

**Configuring the Screen Controls**

- **Enable offline access to messages** Select to enable the Offline Access feature for the voice mail domain.

  When this check box is selected, the other fields in the tab are activated.

- **Synchronize offline messages with remote store** Select to allow each MAS in a multi-MAS voice mail domain to update their local offline message store with recently recorded call-answered messages in the remote offline message store.

  When this check box is selected, the **Offline Message Store** field is activated.
### Offline Message Store
Enter the directory path of the remote offline message store or select it using the **Browse** button. You can type in these details:

- The private fully qualified Windows domain name of the server where the remote offline message store is located. The path should be in the format `\hostname.domainname\offlinedirectoryname`.
- The private IP address of the server where the remote offline message store is located. The path should be in the format `\IPAddress\offlinedirectoryname`.

### Time to store offline messages (Hours)
Enter the length of time, in hours, that the system should keep call-answered messages in the offline message store. The default is 24 hours.

**Note:** This time is extended automatically, if the message store server remains offline for longer than the configured time.

### Time to store empty mailbox (Hours)
Enter the length of time, in hours, that the system should save space for an empty mailbox in the offline message store. The default is 72 hours.

An empty mailbox indicates no message activity, but the mailbox still requires allocated space.

### Allow subscribers to access messages using the TUI
Select to allow subscribers to access their messages using the TUI, when the message store server is offline.
Understanding Offline Access

**Note:** For more information about Offline Access, see *Avaya Modular Messaging Concepts and Planning Guide*.

You can configure Offline Access to call-answered messages at voice main domain level, using the **Messaging** dialog box, **Offline Access** tab. See **Messaging - Offline Access Tab** on page 3-178.

With Offline Access, subscribers can use the Telephone User Interface (TUI) to access recently recorded call-answered messages, even when the message store server (Avaya MSS) is not accessible. Subscribers cannot use the TUI to send or receive voice mail messages, however.

The Modular Messaging system evaluates whether it needs to use Offline Access on a call-by-call basis.

**Offline Message Storage**

If the voice mail domain only contains one Messaging Application Server (MAS), there is only one local offline message store. If the voice mail domain contains more than one MAS, offline messages are saved both locally and remotely:

- **Local Offline Message Store** A folder on each MAS in the voice mail domain.

- **Remote Offline Message Store** A folder on the file server. This server is networked to the voice mail domain but is not a message store server and not usually an MAS.

**Note:** You must set each offline message store folder as a shared folder and configure the permissions. For these procedures, see **Configuring the Offline Message Store Folder** on page 3-182

When a call-answered message is recorded, the TUI saves it and sends the message file to the message store server (Avaya MSS).

If Offline Access is enabled, the message is also delivered to the local offline message store folder on the MAS and the remote offline message store on the file server. The remote store holds all recently recorded call-answered messages for the voice mail domain; the local store only holds those messages received on a particular MAS.

By default, call-answered messages are retained for offline access for 24 hours, then deleted. This period is configurable for a voice mail domain. If the remote offline message store disk space is full, no further call-answered messages are taken and a major alarm is generated, **MT PERF 26**.
Offline Access

If a subscriber calls into the TUI, logs on, the message store server is offline, and Offline Access is enabled, they can access recently recorded call-answered messages.

The subscriber logs onto an MAS. If that server is part of a multi-MAS voice mail domain, the subscribers messages are retrieved from the remote offline message store and copied into the local offline message store on that MAS.

**Note:** If the system cannot access the remote offline message store, the subscriber is not presented with the option to use the Offline Access facility.

The subscriber can only review the messages. There is no other functionality for dealing with those messages until the message store server is back online.

Other Modular Messaging Features Affected by Offline Mode

When the message store server is offline, and Offline Access to call-answered messages is configured:

- The Call Me feature does not operate unless the MM Mailbox Monitor service is still online and the MM Call Me Server service is able to contact another MAS in the voice mail domain.

- The Message Waiting Indicator (MWI) feature does not operate unless the MWI server is still online and the MM Message Waiting Indicator Server service is able to contact another MAS in the voice mail domain. MWI is never triggered by the arrival of call-answered messages at an offline MAS.

- If a subscriber modifies the Find Me rule for their mailbox but the subscriber’s mailbox does not subsequently receive any messages prior to the message store server going offline, the Find Me feature in offline mode will operate using the Find Me rule that existed prior to the subscriber’s modifications.
Configuring the Offline Message Store Folder

Before you can configure Offline Access, you must create a local offline message store folder on each MAS in the voice mail domain. If you have a multi-MAS voice mail domain, you must also create a remote offline message store folder on the file server. For more information about Offline Access, see Understanding Offline Access on page 3-180.

You must set each offline message store folder as a shared folder and configure the permissions. To set up the share, follow Procedures 1, 2, 3 and 4; to set up security, follow Procedures 5, 2, 3 and 6 (see Figure 3-3).

**Procedure 1: Sharing the Offline Message Store Folder**

1. Locate the offline message store folder in Windows Explorer.
2. Select the folder and right-click to open the Properties window.
3. Select the Sharing tab.
4. Select the Share this folder option button. This activates the controls within the group box.
5. Click the Permissions button. This launches the Permissions dialog box.
6. Click the Add... button under Groups or user names. This launches the Select Users, Computers, or Groups window.
Procedure 2: Adding the Appropriate Modular Messaging Logon Accounts

1. In the Select Users, Computers, or Groups dialog box, Enter the object names to select field, enter the name of the local system account, such as system. This is the account you selected, when installing Modular Messaging.

2. Click the Check Names button to verify the name. The name is then underlined. If you do not know the correct name, just type in the first letter and the Check Names button allows you to pick from a list.

3. Click OK to return to the Permissions window. You will see that the local system account is now listed under Group or user names.

4. You can repeat this task to add other logon accounts, if required. You can build up a list of names in the Enter the object names to select field, separated by semi-colons (;).
   - Local administration account, such as dom-admin or mas2-admin, for this MAS.
   - Customer administration account, such as custacct.
   - Support group remote access account, such as craft.

Procedure 3: Adding Local Service Accounts for each MAS that Handles Calls

1. In the Select Users, Computers, or Groups dialog box, click the Object Types button. This launches the Object Types window.

2. Ensure the Computers check box is selected and click OK to return to the Select Users, Computers, or Groups window.

3. In the Enter the object names to select field enter the name of the computer, such as mymas2.

   Note: Only MASs that handle calls must access the offline share folder.

4. Click the Check Names button to verify the name. The name is then underlined. If you do not know the correct name, just type in the first letter and the Check Names button allows you to pick from a list.
5. You should repeat this procedure for each MAS that handles calls. You can build up a list of names in the **Enter the object names to select** field, separated by semi-colons (;).

**Note:** The MAS must have joined the Windows domain before the system can add the account for that server. You never need to add the account for the supplementary server. Even if the supplementary server hosts the offline store, the server handles no messages and does not require access.

---

**Procedure 4: Setting the Share Permissions for the Accounts**

6. Click **OK** in the **Select Users, Computers, or Groups** dialog box to return to the **Permissions** dialog box.

You will see the logon accounts and the accounts for the selected MASs are now listed under **Group or user names**.

7. Select the first local system account in the **Group of user names** list.

8. Click the **Allow** check box for these permissions: **Change** and **Read**.

9. Repeat this procedure for each local system account that you added.

**Note:** You should ensure that the **Everyone** group has the **Change** and **Read** permissions.

10. Click **OK** to return to the **Properties** dialog box, **Sharing** tab and click **OK**. The share and permissions are now configured.
Procedure 5: Setting Security for the Offline Message Store Folder

1. Locate the offline message store folder in Windows Explorer.
2. Select the folder and right-click to open the Properties window.
3. In the Properties dialog box, select the Security tab.
4. If there is an Everyone account listed under Group or user names, select it and click the Remove button.
5. Click the Add... button. This launches the Select Users, Computers, or Groups dialog box.
6. Follow “Procedure 2” and “Procedure 3”, above, then “Procedure 6”, below.

Procedure 6: Setting the Security Permissions for the Accounts

7. Click OK in the Select Users, Computers, or Groups dialog box to return to the Properties dialog box, Security tab.

You will see the logon accounts and the accounts for the selected MASs and is now listed under Group or user names.

8. Select the first local system account in the Group of user names list.
9. Click the Allow check box for these permissions: Modify, Read & Execute, List Folder Contents, Read and Write.

10. Repeat this procedure for each local system account that you added.
11. Click OK. The security and permissions are now configured.
Web Subscriber Options Dialog Box

**Note:** For a detailed overview of voice mail domain configuration in the Voice Mail System Configuration (VMSC) application, see Overview of VMD Configuration in VMSC on page 3-3.

This topic describes how to use the Web Subscriber Options dialog box to configure the functionality available to subscribers when they are using the Web Subscriber Options (WSO) application, the Avaya Voice Player (AVP), and the local player.

You can also determine the e-mail domains accessible to subscribers when they are configuring Notify Me, and creating Personal Distribution Lists (PDLs).

**Launching the Screen**

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Web Subscriber Options. The system displays the Web Subscriber Options dialog box for the selected voice mail domain, with the General tab active.

**Tabs Available in this Dialog Box**

**Note:** To configure this dialog box, you must be a member of a security role assigned the Web Subscriber Options - Administer task. If you are a member of a role assigned the Web Subscriber Options - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

- **General** Use this tab to configure the functionality available to subscribers when they are using the WSO application, the Voice Player, and the local player. See Web Subscriber Options - General Tab on page 3-187.

- **Email Domain Restriction** Use this tab to determine the e-mail domains accessible to subscribers when they are configuring Notify Me, and creating PDLs. See Web Subscriber Options - Email Domain Restrictions Tab on page 3-188.
Web Subscriber Options - General Tab

Use the Web Subscriber Options dialog box, General tab to configure the functionality available to subscribers when they are using the Web Subscriber Options (WSO) application, the Avaya Voice Player (AVP), and the local player.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Web Subscriber Options. The system displays the Web Subscriber Options dialog box for the selected voice mail domain, with the General tab active.

Configuring the Screen Controls

- **Enable Avaya Voice Player** Select to enable the Voice Player for the voice mail domain. Subscribers can then use the Voice Player when recording greetings or PDL names.

  This setting activates the Client installation options field.

- **Client installation options** Select to determine whether subscribers are allowed to download the Voice Player to their client desktops.

  — **Installed** Select to prevent subscribers from downloading the Voice Player to their client desktops from the WSO application.

  — **Download** Select to allow subscribers to download the Voice Player to their own desktops from the WSO application.

- **Enable Restricted Avaya Voice Player** Select to disable these commands in the Voice Player: Save, Save As, Export AVP as WAV, Export WAV as AVP, Send by Email and Send GSM by Email.

- **Enable Local Player For Audio Playback And Record** Select to enable subscribers to use the local player when recording and playing greetings and PDL names.

- **Enable Email Address In Personal Distribution List** Select to enable subscribers to add e-mail addresses as PDL list members.

Notes:

- You should select this option if the Voice Player has already been installed on all required client desktops.

- If necessary, subscribers can use the Web Client application to download the Voice Player to their desktops.
Web Subscriber Options - Email Domain Restrictions Tab

Use the Web Subscriber Options dialog box, Email Domain Restrictions tab to determine the e-mail domains accessible to subscribers when they are configuring Notify Me, and adding e-mail addresses as Personal Distribution List (PDL) members.

For example, if you restrict access to “hotmail.com”, a subscriber cannot set up the Notify Me feature to contact them on their Hotmail e-mail address, or add that address to a PDL.

For more information on Notify Me, see Notify Me Dialog Box on page 3-71.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Web Subscriber Options. The system displays the Web Subscriber Options dialog box for the selected voice mail domain, with the General tab active.

3. Click the Email Domain Restrictions tab.

Configuring the Screen Controls

- **All Email Domains Will Be** Select to determine the e-mail domains accessible to subscribers when they are configuring Notify Me, and creating PDLs.
  - **Granted Access** Select to grant subscribers access to all e-mail domains except for those listed under Except The Following.
  - **Denied Access** Select to deny subscribers access to all e-mail domains except for those listed under Except The Following.

- **Except The Following** Displays a list of e-mail domains that are exceptions to the All Email Domains Will Be setting.
  - **Domain Address** Displays the e-mail domain address.
  - **Add** Select to add an e-mail domain to the list.
  - **Remove** Select to remove the selected e-mail domain from the list.
Serviceability Dialog Box

**Note:** For a detailed overview of voice mail domain configuration in the Voice Mail System Configuration (VMSC) application, see Overview of VMD Configuration in VMSC on page 3-3.

This topic describes how to use the Serviceability dialog box to configure the ability of the MAS to generate logs and notifications related to system errors and alarms. You can also control voice port service on the MAS.

Notifications can be sent out automatically to one designated support site, either Avaya Technical Support, your own Network Management Station (NMS), or a trusted business partner. These notifications are sent out using Avaya Initialization and Administration System (INADS), Simple Network Management Protocol (SNMP) traps to an NMS, or Internet Proxies.

**Notes:**

- You must configure serviceability at voice mail domain level, as described in this topic, and at MAS level. See MAS - Serviceability Dialog Box on page 4-62.
- For information on generic traps, see Generic Traps Supported on the MAS on page 3-200.
- For information on logs, see Chapter 11, “MAS Event, Error & Alarm Logs”.

**Launching the Screen**

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).

2. Double-click Serviceability. The system displays the Serviceability dialog box for the selected voice mail domain.
## Tabs Available in this Dialog Box

**Note:** To configure this dialog box, you must be a member of a security role assigned the **Serviceability - Administer** task. If you are a member of a role assigned the **Serviceability - View** task, you have read-only access to this dialog box. See [Security Roles Dialog Box](#) on page 3-88.

- **General** Use this tab to configure the ability of the MAS to generate logs and notifications related to system errors and alarms. You can also control voice port service on the MAS. See [Serviceability - General Tab](#) on page 3-191.

- **SNMP Trap Destinations** Use this tab to configure alarm notification settings, when an SNMP tool is being used to collect and view alarms. See [Serviceability - SNMP Trap Destinations Tab](#) on page 3-194.

- **Communities** Use this tab to build a list of community names. A name can then be used as validation in communications between the SNMP client and the SNMP server. See [Serviceability - Communities Tab](#) on page 3-196.

- **Query Originators** Use this tab to configure allowable SNMP query origination points. See [Serviceability - Query Originators Tab](#) on page 3-198.

- **Internet Proxies** Use this tab to configure the relay of alarm information back to Avaya through the Internet capabilities of the SPIRIT agent. See [Serviceability - Internet Proxies Tab](#) on page 3-199.
Serviceability - General Tab

Use the Serviceability dialog box, General tab to configure the ability of the Messaging Application Server (MAS) to generate logs and notifications related to system errors and alarms.

These notifications are sent out using either Avaya Initialization and Administration System (INADS), Simple Network Management Protocol (SNMP) traps to a Network Management Station (NMS), or Internet Proxies. You can also control voice port service on the MAS.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Serviceability. The system displays the Serviceability dialog box for the selected voice mail domain, with the General tab active.

Configuring the Screen Controls

- **Alarm Origination** Use this setting to control whether Modular Messaging attempts to reach back to Avaya Technical Support for automated maintenance. Select the appropriate option button:
  - Inactive Select so that no alarm notifications are sent to Avaya.

  These fields in the tab are then grayed out: Suppress alarm notifications, Clear Alarm Notification, and Send alarm at this level or higher.

  **Note:** If you select this option, you can still view alarm logs on the MAS.

  — SNMP Select to send alarm traps to an NMS using SNMP. This is IP-based alarming.

  **Notes:**

  - You must configure your SNMP NMS to receive the traps from the MAS.

  - You must also configure the SNMP Trap Destinations tab. See Serviceability - SNMP Trap Destinations Tab on page 3-194.
— **Modem dialout** Select to use the INADS tool to send alarm notifications to an alarm collection server for analysis and corrective action. This is modem-based alarming.

**Note:** You must configure the individual MASs for INADS, using the **MAS - Serviceability** dialog box, **Modem Configuration** tab. See **MAS - Serviceability - Modem Configuration Tab** on page 4-65.

— **Internet** (Default for new installations) Select to relay alarm information back to Avaya through the Internet capabilities of the Avaya SPIRIT Agent.

**Note:** You must then configure the settings on the **Internet Proxies** tab. See **Serviceability - Internet Proxies Tab** on page 3-199.

- **Suppress alarm notifications** (Default Off) Select to temporarily suppress all alarm notifications for the voice mail domain.

If selected, this setting overrides the setting for individual MASs in the **MAS - Serviceability** dialog box, **General** tab. If not, the per-MAS settings apply. For more information see **MAS - Serviceability - General Tab** on page 4-63.

**Note:** You would typically select this setting, if you were engaged in VMD-wide maintenance and/or repair activities that would result in the generation of additional alarms and errors. In this situation, be sure to remember to clear this check box when you are finished, otherwise alarm notifications will not resume.

- **Clear Alarm Notification** (Default On) Select to be notified when all alarms on the system are corrected and cleared.

- **Send alarm at this level or higher:** Select the level at which alarm notifications are sent out:

  — **Minor** (Default) Select to send major and minor alarms.

  — **Major** Select to send only major alarms.

  — **All** Select to send major alarms, minor alarms, and warnings to Operations, Administration, and Maintenance (OAM) destinations, and to send major and minor alarms to INADS destinations.

**Note:** Warnings are for customer information only; they are not sent to Avaya Technical Support.

- **When stopping the MAS service** This section determines how the system will behave, when the **MM Messaging Application Server** service is being stopped.
For more information on Modular Messaging services, see Appendix C, Modular Messaging (MM) Services.

— **Wait for ports to become idle** Select to allow ports that are in use to become idle before being taken offline. As ports become idle, they are taken offline. This allows for a more graceful shutdown of the system and should be used whenever possible.

  **Note:** When this option is selected, if the system tries to stop the MM Messaging Application Server service, it waits until all ports are idle. As a result, some length of time may pass before service is actually stopped. During this period, while ports are becoming idle, your Windows operating system may display a timeout error 1053. Ignore this error. The stopping process is unaffected by this message and the service will stop according to the parameters you have set.

This option activates the **Wait indefinitely** and **Wait for (minutes)** options.

- **Wait indefinitely** Select so that the system will wait until all ports are idle before shutting down the MM Messaging Application Server service. If possible, this is the most desirable option, as it allows all ports to be taken offline naturally, with no interruption of service for the user.

- **Wait for (minutes)** (Default) Select to set the number of minutes that the system will wait before breaking port connections and shutting down, whether ports are in use or not. In this case, ports that become idle within the time limit are taken offline, but ports that are still busy at the end of the time limit are forcibly taken offline.

  Enter the number of minutes in the field to the right. The default is 10.

— **Stop immediately** (Default) Selecting this option causes all ports that are in use, when the MM Messaging Application Server service is being stopped, to immediately be taken offline. This should only be used as a last resort, as it interrupts any calls that may be in progress.
Serviceability - SNMP Trap Destinations Tab

Use the Serviceability dialog box, SNMP Trap Destinations tab to configure alarm notification settings, when a Simple Network Management Protocol (SNMP) tool is being used to collect and view alarms.

Notes:

- You should only configure the fields on this tab, if you are using SNMP to send traps to an SNMP Network Management Station (NMS).

- For more information on generic traps, see Generic Traps Supported on the MAS on page 3-200.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Serviceability. The system displays the Serviceability dialog box for the selected voice mail domain, with the General tab active.

3. Click the SNMP Trap Destinations tab.

Configuring the Screen Controls

- IP Address/Host  Enter the IP address or host name for the trap destination. The default for a new trap destination reads Enter address.

- Community  Select a community name from the pick list. This name is used as security validation in communications between the SNMP client and the SNMP server.

  This list is populated on the Communities tab. See Serviceability - Communities Tab on page 3-196. The default for a new trap destination is the first item in the list.

- Type  Select the type of trap destination.

  — INADS Avaya Initialization and Administration System (INADS). This is used to send alarms back to Avaya through older Service Selection Gateway (SSG) devices.

  Note: This setting is only valid, if the Alarm Origination field in the General tab is set to SNMP. See Serviceability - General Tab on page 3-191.
— **OAM** Operations, Administration, and Maintenance (OAM). This is used for customer NMSs.

- **Port** Enter the port number. The range is 1 through 65535, the default is 161.

- **Status** Displays the status of the port, **Active** or **Inactive**.

  **Note:** Trap destinations with the **Type OAM** are **Active**. The **Type INADS** will typically be **Inactive**, unless the **Alarm Origination** field in the **General** tab is set to **SNMP**.

- **Add** Select to add a new trap destination.

  A row appears in the grid with default settings. You can then configure the **IP Address/Host**, **Community**, **Type** and **Port** fields.

- **Remove** Removes the selected trap destination from the list.
Serviceability - Communities Tab

Use the Serviceability dialog box, Communities tab to build a list of community names.

A community name is used as a security validation mechanism for Simple Network Management Protocol (SNMP) versions 1 and 2c. The SNMP client includes the name in all requests to the SNMP server. The server then verifies the name against the client.

The list in the Communities tab populates the Communities pick list in the SNMP Trap Destinations tab and the Query Originators tab. See Serviceability - SNMP Trap Destinations Tab on page 3-194 and Serviceability - Query Originators Tab on page 3-198.

**Note:** Avaya recommends that you configure the communities list through the VMSC - Serviceability - Communities tab, rather than through Windows Service Management.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Serviceability. The system displays the Serviceability dialog box for the selected voice mail domain, with the General tab active.

3. Click the Communities tab.

Configuring the Screen Controls

- **Community** Click to enter a unique name for the community. This name is used as validation in communications between the SNMP client and the SNMP server.

  **Note:** The default name for a newly added community is New Community. Avaya recommends that you alter the default text to a more unique name, and avoid using the ubiquitous names, Public or Private.

- **Apply To** Select the behaviors to which the community should apply, Queries, Traps, or Both (the default).

- **Add** Select to add a new community.

  A row appears in the grid with the default New Community. You can then configure the Community and Apply To fields.
- **Remove**: Removes the selected community from the list.

  **Note**: If the community has been selected from a pick list in another tab, it cannot be removed.
VMSC - Voice Mail Domain (VMD) Configuration

Serviceability - Query Originators Tab

Use the Serviceability dialog box, Query Originators tab to configure allowable Simple Network Management Protocol (SNMP) query origination points.

**Note:** Avaya recommends that you configure query originators through the VMSC - Serviceability - Query Originators tab, rather than through Windows Service Management.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Double-click Serviceability. The system displays the Serviceability dialog box for the selected voice mail domain, with the General tab active.
3. Click the Query Originators tab.

Configuring the Screen Controls

- **IP Address/Host**  Enter a specific IP address or host name for an allowable query originator, or accept the default.

  **Notes:**
  - You cannot specify a subnet.
  - You can use Default, if you wish allow queries from any arbitrary origination point. You must, however, assign a community name.

- **Community**  Select a community name from the pick list. This name is used as validation in communications between the SNMP client and the SNMP server.

  This list is populated on the Communities tab. See Serviceability - Communities Tab on page 3-196. The default for a new query originator is the first item in the list.

- **Add**  Select to add an allowable query originator.

  A row appears in the grid with default settings. You can then configure the IP Address/Host and Community fields.

- **Remove**  Removes the selected query originator from the list.
Serviceability - Internet Proxies Tab

Use the Serviceability dialog box, Internet Proxies tab to configure the relay of alarm information back to Avaya through the Internet capabilities of the Avaya SPIRIT Agent.

---

**Note:** The values in this tab are only used by Modular Messaging, if the Alarm Origination field is set to Internet in the General tab. See Serviceability - General Tab on page 3-191.

---

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Serviceability. The system displays the Serviceability dialog box for the selected voice mail domain, with the General tab active.

3. Click the Internet Proxies tab.

Configuring the Screen Controls

- **Avaya/Business Partner Primary Destination** Enter the Avaya or Avaya Business Partner proxy primary IP address preceded by HTTPS://, or fully qualified domain name (FQDN).

- **Avaya/Business Partner Secondary Destination** Enter the Avaya or Avaya Business Partner proxy secondary IP address preceded by HTTPS://, or FQDN.

- **Enable Customer Proxy Servers** Click to enable customer internet proxies. This activates the following fields:

  - **Customer Primary Proxy Server** Enter the customer port name in the format, servername.com:PORTNUMBER.

  - **Customer Secondary Proxy Server** Enter the port name in the format, servername.com:PORTNUMBER.
Generic Traps Supported on the MAS

Modular Messaging sends standard Simple Network Management Protocol (SNMP) generic traps as information events to all Operations, Administration, and Maintenance (OAM) destinations.

**Generic Traps Configured by Alarming**

- **Cold Start** (Generic Trap 0) This indicates that the Messaging Application Server (MAS) containing the SNMP agent has rebooted. All management counters for standardized Management Information Bases (MIBs) are then reset.

- **Warm Start** (Generic Trap 1) This indicates that the SNMP agent has re-initialized itself. None of the management variables are reset.

- **Link Down** (Generic Trap 2) This indicates that a network interface has gone down. The trap contents describe which interface went down.

  **Note:** If the corporate LAN interface goes down, the MAS cannot send this trap.

- **Link Up** (Generic Trap 3) This indicates that a network interface has become available.

- **Authentication Failure for SNMP Queries** (Generic Trap 4) This indicates that an attempt has been made to query the Modular Messaging system using SNMP with an incorrect community name.

  **Note:** For this trap, you should ensure that the Send authentication trap setting has been selected on the Security tab of the SNMP Service Properties dialog box, in the Windows Services tool.
Licensing Dialog Box

**Note:** For a detailed overview of voice mail domain configuration in the **Voice Mail System Configuration** (VMSC) application, see [Overview of VMD Configuration in VMSC](#) on page 3-3.

This topic describes how to use the **Licensing** dialog box to configure licensing information for the platform, the number of seats (voice mail-enabled mailboxes), and the number of Text-to-Speech (TTS) sessions per TTS engine. You can also configure the distribution of TTS licenses across one or more MASs.

**Launching the Screen**

1. In the **Voice Mail System Configuration** window, click the voice mail domain (VMD).
2. Double-click **Licensing**. The system displays the **Licensing** dialog box for the selected voice mail domain.

**Tabs Available in this Dialog Box**

**Note:** To configure this dialog box, you must be a member of a security role assigned the **Licensing - Administer** task. If you are a member of a role assigned the **Licensing - View** task, you have read-only access to this dialog box. See [Security Roles Dialog Box](#) on page 3-88.

- **General** Use this tab to view licensing information for the platform, the number of seats and number of text-to-speech sessions per TTS engine. See [Licensing - General Tab](#) on page 3-202.

- **Text-to-Speech** Use this tab to configure the distribution of TTS licenses across one or more MASs. See [Licensing - Text-to-Speech Tab](#) on page 3-203.

**Menu Commands from this Node:**

- When you right-click the **Licensing** node in the **Voice Mail Domain System Configuration** window you can use menu commands to obtain the Voice Mail Domain Identifier (VMDID) and import the permanent license for the system. See [Host ID & License Import Wizard](#) on page 3-204.
**Licensing - General Tab**

Use the Licensing dialog box, General tab to view licensing information for the platform, the number of seats and number of Text-to-Speech (TTS) sessions per TTS engine.

**Launching the Screen**

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Licensing. The system displays the Licensing dialog box for the selected voice mail domain, with the General tab active.

**Configuring the Screen Controls**

- **Platform** Displays the platform you are using for the message store servers, that is Avaya MSS.

- **Modular Messaging Mailboxes**
  
  - **Limit** Displays the maximum number of seats (voice mail-enabled mailboxes) allowed by the license.
  
  - **Current Value** Displays the number of mailboxes that have been voice-enabled.

- **Text to Speech** Displays a list of TTS engines and states the language for each one.

  For more information on TTS, see Licensing - Text-to-Speech Tab on page 3-203.

  - **Limit** Displays the maximum number of TTS sessions per voice mail domain allowed by the license for each TTS engine.
  
  - **Current Value** Displays the number of TTS sessions that have been enabled per voice mail domain for each TTS engine.

- **Info** The yellow text box at the bottom of the tab notifies you, if you do not have a valid license.

  The license might be invalid because an integrity check on it has failed or because the license has expired. The latter case happens, only if you did not import and install a permanent license within 30 days of installation.

**Note:** For information about how to install the permanent license file, see Host ID & License Import Wizard on page 3-204.
Licensing - Text-to-Speech Tab

Use the Licensing dialog box, Text-to-Speech tab to configure the distribution of Text-to-Speech (TTS) licenses across one or more MASs. You can distribute the licenses across any or all of them on a per-TTS-engine basis.

For example, you have two MASs in your voice mail domain and eight licenses for the ScanSoft RealSpeak TTS engine. You can allocate three of those licenses to one MAS and five to the other. If, in this example, you also had another TTS engine installed on your system, you could not use any of these licenses for the other TTS engine.

**Note:** You may need to restart the MM Messaging Application Server service for the changes to take effect. See Appendix C, Modular Messaging (MM) Services.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Double-click Licensing. The system displays the Licensing dialog box for the selected voice mail domain, with the General tab active.
3. Click the Text-to-Speech tab.

Configuring the Screen Controls

- **Feature** Displays a list of all the MASs in the voice mail domain. Beneath each MAS is a list of the installed TTS engines and their languages. You should complete this procedure for each licensed TTS engine.

  1. Double-click the TTS engine beneath each MAS. The system displays the Edit Sessions window.

  2. Enter the number of TTS sessions you want to assign to the selected MAS and click OK. If you have an Avaya Message Store Server (Avaya MSS), enter 2 sessions per MAS.

- **Value** Displays the number of TTS licenses assigned to each MAS for the selected TTS engine.
Host ID & License Import Wizard

Some Modular Messaging features require a license in order to work to their full extent. A license file is usually imported during installation, but some configuration changes require an updated license file.

**Note:** To update the license file, you must be a member of a security role assigned the **Licensing - Administer** task. If you are a member of a role assigned the **Licensing - View** task, you have read-only access to this dialog box. See [Security Roles Dialog Box](#) on page 3-88.

When you right-click the **Licensing** node in the **Voice Mail Domain System Configuration** window you can use these menu items:

- **Import License...** Use this command to install a permanent license for the system, using the License Import Wizard.

- **Copy Host ID to Clipboard** Use this command to determine the Voice Mail Domain Identifier (VMDID) so that you can obtain the license file.

Temporary License

When your system is initially installed, you are automatically given a temporary license file with ten mailboxes and one Text-to-Speech (TTS) session. It is only good for 30 days. If a permanent license file is not installed within that period, the system writes a warning into the Windows event log ten days, three days, and one day before the temporary license is set to expire. After it expires, the system writes an error to the Windows event log every 90 minutes until the permanent license is installed. This also causes an alarm to be raised.

**Note:** The temporary license does not work with IP SIP integration. If you are using this integration, you must get a Release 5.1 certificate signed license. For more information, see your configuration notes.

Permanent Licence Installation & Updates

Normally, at the time of system installation the Avaya support technician installs the permanent license.

You will need to install a new license file, if you upgrade your system by adding more mailboxes or TTS sessions. You must also install a new file, if your system is upgraded to a new major Modular Messaging version number, such as Release 5.0.
Procedure 1: Obtaining the Permanent License File

You must first obtain the permanent license file from your technical or service representative. Before they can provide you with the file, you must supply the representative with the following:

- An identification code for the voice mail domain.

  Use the Licensing > Copy Host ID to Clipboard right-click menu. This copies the Voice Mail Domain ID (VMDID) to the Windows Clipboard. You can then paste the number into an e-mail or word-processing document.

- The platform on which you are running your system, that is the Avaya MSS.

- The number of mailboxes (seats) you require.

- The number of TTS sessions you want enabled.

Procedure 2: Installing the Permanent License File

1. Copy the license file to a temporary location on the MAS or to another location accessible from the Voice Mail System Configuration application.

2. Use the Licensing > Import License... right-click menu. The system starts the License Import Wizard.

3. Follow the on-screen instructions in the License Import Wizard.

4. (Only if your license files have changed your TTS session settings) Stop and restart the MM Messaging Application Server service. For this procedure, see Appendix C, Modular Messaging (MM) Services.
Tracing System Dialog Box

**Note:** For a detailed overview of voice mail domain configuration in the Voice Mail System Configuration (VMSC) application, see Overview of VMD Configuration in VMSC on page 3-3.

This topic describes how to use the Tracing System dialog box to configure the tracing system for the voice mail domain.

The tracing system is a Windows 2003 service where information about voice mail system activity (operation history events) is logged. These events are dynamically stored in the Operation History database. Periodically, this database is purged and summarized information is stored in the Transaction database.

You can use the Tracing System dialog box to specify the Messaging Application Server (MAS) on which the MM Tracing Server service is installed, and specify the Home MAS for the tracing system. You can configure operation history database properties for event logging in the voice mail domain, and transaction database properties for transaction logging.

**Notes:**

- Avaya recommends that one tracing system is installed per voice mail domain. If you install a second tracing system in a voice mail domain, it replaces the original tracing system. If your system has more than one MAS, you should install tracing on only one MAS.

- If, for any reason, you find it necessary to re-install the tracing software after the initial system installation, you must first stop all Avaya Modular Messaging (MM) services. Remember to restart those services, when the software installation is complete. See Appendix C, Modular Messaging (MM) Services.

- For more information on the tracing system, see Avaya Modular Messaging Concepts and Planning Guide.

- For information on configuring the Trace File Size at MAS level, see MAS - Trace File Size Dialog Box on page 4-67.

- You can view operation history events using the Operation History Viewer. See Chapter 8, “Operation History Viewer”.

- For a 1523 application event, use the Microsoft ODBC tool to repair the database (ophist.mdb). If it cannot be repaired, contact Avaya Technical Support.

- You can generate a number of reports from the transaction database using the Reporting Tool. See Chapter 7, “Reporting Tool”.
Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain (VMD).

2. Double-click Tracing System. The system displays the Tracing System dialog box for the selected voice mail domain.

**Note:** If you have not installed a tracing system, the Tracing System node is not displayed in the Voice Mail System Configuration window.

Tabs Available in this Dialog Box

**Note:** To configure this dialog box, you must be a member of a security role assigned the Tracing - Administer task. If you are a member of a role assigned the Tracing - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

- **General** Use this tab to specify the MAS on which the MM Tracing Server service is installed, and specify the Home MAS for the tracing system. See Tracing System - General Tab on page 3-208.

- **Operation History Collection** Use this tab to configure operation history database properties for event logging in the voice mail domain. See Tracing System - Operation History Collection Tab on page 3-209.

- **Transaction Generation** Use this tab to configure transaction database properties for transaction logging in the voice mail domain. See Tracing System - Transaction Generation Tab on page 3-210.
Tracing System - General Tab

Use the Tracing System dialog box, General tab to specify the Messaging Application Server (MAS) on which the MM Tracing Server service is installed, and specify the Home MAS for the tracing system.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Double-click Tracing System. The system displays the Tracing System dialog box for the selected voice mail domain, with the General tab active.

Configuring the Screen Controls

- **MAS Tracing Server Machine Name** Enter the name of the MAS, or supplementary server, on which the MM Tracing Server service is installed. For more information on services, see Appendix C, Modular Messaging (MM) Services.

- **Home Message Application Server** Enter the home MAS for the tracing system. This is the first MAS that the tracing system connects to in order to perform its operation. The default is the home MAS for the voice mail domain.

For more information, see Changing the Home MAS on page 3-15.
**Tracing System - Operation History Collection Tab**

Use the **Tracing System** dialog box, **Operation History Collection** tab to configure operation history database properties for event logging in a voice mail domain. For more information on these events, see Chapter 8, “Operation History Viewer”.

---

**Note:** The Windows 2003 Schedule service must be started on the tracing system machine for the configuration settings to take effect.

---

**Launching the Screen**

1. In the **Voice Mail System Configuration** window, click the voice mail domain.

2. Double-click **Tracing System**. The system displays the **Tracing System** dialog box for the selected voice mail domain, with the **General** tab active.

3. Click the **Operation History Collection** tab.

**Configuring the Screen Controls**

- **Enable Operation History Collection**  Select to log events in the operation history database. This check box is selected by default.

- **Retry Period when Connecting to a Message Application Server (secs)**  Enter the time, in seconds, between retries when connecting to an MAS. The range is 1-999, the default is 30.

- **Number of Days before Events Expire**  Enter the number of days after which events are set to expire. The range is 0 through 999, the default is 3.

  If you enter 0, events are set to expire immediately and are deleted at the time specified in the **Delete Expired Events** group box.

  Avaya recommends that you monitor the generation of events over a period of time and update the expiration time as appropriate.

- **Delete Expired Events**  Select the required option.

  - **Never**  (Default) Never delete expired events.

  - **At time**  Delete expired events at the time of day specified in the field to the right. Enter the time of day the operation history database deletes expired events.
Tracing System - Transaction Generation Tab

Use the Tracing System dialog box, Transaction Generation tab to configure transaction database properties for transaction logging in the voice mail domain.

**Note:** The Windows 2003 Schedule service must be started on the tracing system machine for the configuration settings to take effect.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Double-click Tracing System. The system displays the Tracing System dialog box for the selected voice mail domain, with the General tab active.
3. Click the Transaction Generation tab.

Configuring the Screen Controls

- **Enable Transaction Generation** Select to log voice mail system transactions in the transaction database. This check box is selected by default.

  **Note:** When using the Reporting Tool, transaction generation must be enabled for the time period you want to report on. See Chapter 7, “Reporting Tool”.

- **Time to Generate Transactions** Enter the time of day to generate transactions.

- **Number of Days before Transactions Expire** Enter the number of days after which transactions are set to expire. The range is 0-999, the default is 30.

  If you enter 0, transactions are set to expire immediately and are deleted at the time specified in the Delete Expired Transactions group box.

- **Delete Expired Transactions** Select the required option:
  
  - Never (Default) Never delete expired transactions.
  - At time Delete expired transactions at the time of day specified in the field. Enter the time of day the transaction database deletes expired events.
VMSC - Messaging Application Server (MAS) Configuration

This chapter describes how to configure the Message Application Servers branch of the Voice Mail Domains tree, in the Voice Mail System Configuration window on a messaging application server.

Topics included in this chapter:

- Overview of MAS Configuration in VMSC on page 4-2. This topic describes message application server (MAS) configuration in the VMSC. It also gives an overview of the usage of each of the following screens.
- MAS - Messaging Dialog Box on page 4-11.
- MAS - Languages Dialog Box on page 4-13.
- MAS - Telephony Interface Dialog Box on page 4-14.
- MAS - Port Groups Dialog Box on page 4-25.
- MAS - PBX Integration Dialog Box on page 4-33.
- MAS - PBX Type Dialog Box on page 4-61.
- MAS - Serviceability Dialog Box on page 4-62.
- MAS - Trace File Size Dialog Box on page 4-67.

Related topics in other chapters:

- Chapter 2, “Voice Mail System Configuration (VMSC)”.
- Overview of VMD Configuration in VMSC on page 3-3.
Overview of MAS Configuration in VMSC

You can configure properties for the selected MAS using the Message Application Servers node of the Voice Mail Domains tree in the Voice Mail System Configuration (VMSC) window.

Notes:

- The system may prompt you to stop and restart the MM Messaging Application Server service after you make changes to a property in the Voice Mail System Configuration window. If so, the changes do not take effect until you do so. See Appendix C, Modular Messaging (MM) Services.

- You must configure each MAS in your system.

Required Reading

- An overview of the entire Voice Mail System Configuration window. See Chapter 2, “Voice Mail System Configuration (VMSC)”.

- How to configure properties shared across MASs in a Voice Mail Domain. See Overview of VMD Configuration in VMSC on page 3-3.

Launching the Application & Opening the VMD Node

1. On your Windows desktop, click the Start > Programs > Avaya Modular Messaging > Voice Mail System Configuration menu. This launches the Voice Mail System Configuration window.

2. If it is not already expanded, double-click Voice Mail Domains, then double-click the appropriate voice mail domain.


4. Double-click the appropriate MAS under the Message Application Servers branch. This expands the tree to show all the available nodes.

Configuring the MAS

- Adding a New Messaging Application Server on page 4-7.

- Removing a Message Application Server on page 4-8.

- Re-deploying Caller Applications on page 4-9.

- Telephony Configuration Wizard on page 4-10.
Configuring MAS Nodes

- **Messaging** Use this node to configure peer server and directory server settings for the selected MAS.

  The peer server is the message store server that MASs communicate with when sending and receiving voice messages. The directory server is the server that contains information about subscribers.

  You can use the **Messaging** dialog box to specify the peer message store server name and primary directory server name for the MAS. See **MAS - Messaging Dialog Box** on page 4-11.

- **Languages** Use this node to see which languages are currently installed on the selected MAS.

  The **Languages** dialog box displays the list of languages. The list is for information only and cannot be edited. See **MAS - Languages Dialog Box** on page 4-13.

- **Telephony Interface** Use this node to configure the telephony interface for the selected MAS. You must configure the telephony interface for each MAS in your system.

  You can use the **Telephony Interface** dialog box to set the playback volume and configure the number of ports that connect the MAS with the Private Branch Exchange (PBX). You can enable ports and configure properties for each of them.

  The screens that you see in the dialog box depend on the type of voice boards you are using:

  - **Analog** You can configure ports for Control LAN (C-LAN), Digital Multiplexed Interface - 4 (DMI-4), Inband, and Serial RS-232 integration. See **MAS - Telephony Interface Dialog Box (Analog)** on page 4-15.

  - **QSIG** You can configure ports for Q-Signaling (QSIG) integration. See **MAS - Telephony Interface Dialog Box (QSIG)** on page 4-17.

  - **Set Emulation** There are either one or two tabs, depending on your configuration:

    - **General** This tab is always available. You can configure ports for Digital Set Emulation (DSE) integration. See **MAS - Telephony Interface Dialog Box (Set Emulation)** on page 4-19.

    - **ACD** Automatic Call Distribution (ACD) is a form of integration available only with NT M-1 PBXs using Digital Set Emulation integration. You can use this tab to configure settings for agent-based ACD and position-based ACD. See **MAS - Telephony Interface - ACD Tab (Set Emulation)** on page 4-21.
— **IP H.323/IP SIP** You can configure ports for H.323-based or SIP-based IP integration. See **MAS - Telephony Interface Dialog Box (IP H.323/IP SIP)** on page 4-23.

- **Port Groups** Use this node to configure Port Groups for the selected MAS.

You can use the **Port Groups** dialog box to create Port Groups for PC client applications, the Telephone User Interface (TUI), Call Me, Avaya’s Native Fax Support, Message Waiting Indicator (MWI), and QSIG Outbound Transfer. See **MAS - Port Groups Dialog Box** on page 4-25.

All port groups must be created in the **Port Groups** dialog box’s **General** tab, but then some are configured in the **Usage** tab and others using the **PBX Integration** dialog box. Others have no additional configuration but must be given a specific name. For more information, see **Rules for Creating Port Groups** on page 4-27.

- **PBX Integration** Use this node to configure PBX integration for the selected MAS. This determines how the PBX passes call information to the MAS.

The call information includes calling party identification, if known, called party identification, and a call type code. With PBX integration, callers who are forwarded to the MAS can leave a message for the called party or can transfer to another extension.

The number of tabs that appear in the **PBX Integration** dialog box depend on your PBX integration type. If you have SIP-based IP integration, you will only see one tab called **IP SIP**. If not, you will see all these tabs instead: **General**, **Serial General**, **Serial NEC/Ericsson/DMID**, **Inband**, **Remote**, **QSIG/SE** and **IP H323**. If you have analog telephony, the **Avaya C-LAN** tab also appears. See **MAS - PBX Integration Dialog Box** on page 4-33.

**Note:** The **PBX Integration** node is removed from the Voice Mail System Configuration tree, if the MultiSite feature is enabled. If MultiSite is enabled, you can only add SIP switches to the voice mail domain. You can configure SIP-based IP integration for the entire voice mail domain on the **IP SIP** tab of the **PBXs** node.

— **General** Use this tab to select the type of PBX integration you wish to configure for the MAS. The integration type selected in this tab determines which of the other tabs are activated.

— **Serial General** Use this tab to configure serial PBX integration for an MAS, if your PBX supports DMI-4 integration or serial RS-232 integration. With serial integration, the MAS receives incoming call information by means of a serial link.

From this tab, you can also configure settings using the **Serial Settings** dialog box.
— **Serial NEC/Ericsson/DMID** Use this tab to configure serial integration for NEC, Ericsson, and DMID protocols. This tab is activated by selecting the appropriate setting in the **Serial General** tab.

— **Inband** Use this tab to configure Inband PBX integration for an MAS. With inband integration, the MAS receives incoming call information in the form of Dual Tone Multi-Frequency (DTMF) digits.

From this tab, you can also configure settings using the **Inband Protocol Settings** dialog box and **MWI Settings** dialog box.

— **Remote** Use this tab to configure remote PBX integration for an MAS. With remote integration, the MAS receives its incoming call information through another MAS that has a serial integration.

— **QSIG/SE** Use this tab to configure an MWI port group for QSIG or Set Emulation PBX integration.

— **Avaya C-LAN** Use this tab to configure C-LAN integration. This is available with Avaya DEFINITY®, IP600, MultiVantage™, and Communication Manager PBXs only.

— **IP H323** Use this tab to configure H.323-based IP integration. This is available with Avaya DEFINITY®, IP600, MultiVantage™, and Communication Manager PBXs only.

— **IP SIP** Use this tab to configure SIP-based IP integration. This is available with Avaya DEFINITY®, IP600, MultiVantage™, and Communication Manager PBXs only.

### PBX Type

Use this node to select the PBX for the selected MAS.

You can use the **PBX Type** dialog box to specify which PBX is used for the selected MAS. You must configure this setting when you physically change the PBX connected to an MAS, or add an MAS to a voice mail domain. See **MAS - PBX Type Dialog Box** on page 4-61.

**Note:** The **PBX Type** node is removed from the Voice Mail System Configuration tree, if the MultiSite feature is enabled.

### Serviceability

Use this node to configure serviceability for the selected MAS.

In Modular Messaging, serviceability includes the ability of the MAS to generate logs and notifications related to system errors and alarms. Notifications can be sent out automatically to a designated support site, either Avaya Services, your own Network Management Station (NMS), or a trusted business partner.

The **Serviceability** dialog box has two tabs, **General** and **Modem Configuration**.
You can use the dialog box to configure Individual MAS Alarming, and configure how alarm notifications are sent out at MAS level, using the Avaya Initialization and Administration System (INADS). See MAS - Serviceability Dialog Box on page 4-62.

- **Trace File Size** Use this node to configure the default size of the tracing file for the selected MAS.

  The tracing file stores operation history events before they are sent to the tracing server. You may need to increase the size of the tracing file, particularly if you expect heavy traffic or know that the tracing server will be out of service for an extended period.

  You can use the Trace File Size dialog box to configure the tracing file size. See MAS - Trace File Size Dialog Box on page 4-67.
Adding a New Messaging Application Server

You can add a new MAS to the voice mail domain using the Add New Message Application Server dialog box.

Before you add an MAS, you must ensure that it has been removed from its old voice mail domain, if applicable. You must also ensure that the MAS is running.

**Note:** As soon as you have added an MAS, you must specify which Private Branch Exchange (PBX) to use, and stop and restart the MM Messaging Application Server service. See MAS - PBX Type Dialog Box on page 4-61 and Appendix C, Modular Messaging (MM) Services.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.

2. Click Message Application Servers.

3. Click the Edit > Add Message Application Server menu or use the right-click menu.

   The system displays the Add New Message Application Server dialog box.

Configuring the Screen Controls

Notes:

- To configure this dialog box, you must be a member of a security role assigned the Voice Mail Domain - Administer task. If you are a member of a role assigned the Voice Mail Domain - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

- If the MultiSite feature is enabled for the voice mail domain, you can add an MAS only if it has Modular Messaging 5.0 or later installed.

- **Message Application Server** Enter a name for the MAS or use the Browse button to select it.

**Note:** If you are adding the first MAS in the voice mail domain, the system displays the Primary Domain Language dialog box. Select the appropriate language and click OK.
Removing a Message Application Server

This section describes how to remove an MAS from a voice mail domain. Avaya recommends that you remove the MAS from the voice mail domain before uninstalling MAS software from the machine.

For information on removing the MAS software, see Avaya Modular Messaging Installation and Upgrades Guide for your system.

Note: After removing the last MAS that does not support multiple languages from a voice mail domain, you must refresh the domain languages. To do this, click the Edit > Refresh Domain Languages menu.

Procedure 1: Removing an MAS from the Voice Mail Domain

Note: To use this command, you must be a member of a security role assigned the Voice Mail Domain - Administer task. See Security Roles Dialog Box on page 3-88.

1. In the Voice Mail System Configuration window, click the voice mail domain.
3. Click the MAS you want to remove.
4. Click the Edit > Remove Message Application Server menu or use the right-click menu.

   The system prompts you to confirm the deletion.
5. Click OK.
Re-deploying Caller Applications

Modular Messaging Caller Applications software enables you to enhance and extend the Telephone User Interface (TUI) by creating and deploying caller applications.

You can create caller applications using the **Caller Applications Editor**. New caller applications are saved locally, then deployed to all the Messaging Applications Servers (MASs) on the voice mail domain. For more information, see Chapter 6, “Caller Applications Editor”.

**Note:** Any user can create caller applications. To deploy or re-deploy caller applications, you must be a member of a security role assigned the **Caller Applications - Administer** task. See Security Roles Dialog Box on page 3-88.

If new MASs are subsequently added to the voice mail domain, you can use the **Voice Mail System Configuration (VMSC)** application to re-deploy caller applications to the new MASs.

The **Edit > Re-deploy Caller Applications** menu command opens the **Prepare Caller Application Data** dialog box. This allows you to re-deploy caller applications already deployed on the selected MAS to any new MASs in the voice mail domain.

This command is only available when an MAS node is selected in the tree. You can also right-click the node to select the command.
Telephony Configuration Wizard

When you select an MAS in a voice mail domain for the first time, the system prompts you to run the **Telephony Configuration Wizard**.

It can also be launched using the **Edit > Telephony Configuration Wizard** menu or the right-click menu of the **Message Application Servers** node.

This wizard enables you to quickly configure the telephony interface, add PBXs, configure a PBX type, and configure the number of ports or time slots for the MAS.

**Telephony Configuration Wizard Screens**

*Note:* To configure this dialog box, you must be a member of a security role assigned the **Telephony - Administer** task. If you are a member of a role assigned the **Telephony - View** task, you have read-only access to this dialog box. See **Security Roles Dialog Box** on page 3-88.

If you launch the wizard using the top level **Edit** menu and the MAS node is not selected, you are first prompted to enter the appropriate Messaging Application Server name and click **OK**.

The wizard is then launched and you can press the **Next** button to reach each of these screens:

- **Welcome**  Displays a description of the wizard usage.

- **Select the Telephony Interface type**  You can select the telephony interface type used by the MAS from the list.

- **Select a PBX Type**  You can select from the list to specify which PBX is used for the MAS.

*Note:*  If you do not see the required PBX, click the **Add PBX Type** button to launch the **Add New PBX** dialog box. See **Add New PBX Dialog Box** on page 3-118.

- **Select the number of ports**  You can enter the number of ports to be used by the MAS.

- **Finish**  Displays advice on how to proceed with configuring the MAS.
MAS - Messaging Dialog Box

Note: For a detailed overview of Messaging Application Server (MAS) configuration in the Voice Mail System Configuration (VMSC) application, see Overview of MAS Configuration in VMSC on page 4-2.

This topic describes how to use the Messaging dialog box to configure peer server and directory server settings for the selected MAS.

Note: To configure Messaging for the entire voice mail domain, see Messaging Dialog Box on page 3-174.

The peer message store server is the message store server that MASs communicate with when sending and receiving voice messages. The directory server is the server that contains information about subscribers.

You can use the Messaging dialog box to specify the peer message store server name and primary directory server name for the MAS.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Click Message Application Servers.
3. Click the MAS you want to configure.
4. Double-click Messaging. The system displays the Messaging dialog box for the selected MAS.

Tabs Available in this Dialog Box

Note: To configure this dialog box, you must be a member of a security role assigned the Messaging - Administer task. If you are a member of a role assigned the Messaging - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

- **General** Use this tab to configure messaging settings for this MAS. You can specify the peer message store server name and primary directory server name for the MAS. See MAS - Messaging - General Tab on page 4-12.
MAS - Messaging - General Tab

Use the Messaging dialog box, General tab to configure messaging settings for this Messaging Application Server (MAS). You can specify the peer message store server name and primary directory server name for the MAS.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Click Message Application Servers.
3. Click the MAS you want to configure.
4. Double-click Messaging. The system displays the Messaging dialog box for the selected MAS, with the General tab active.

Configuring the Screen Controls

- **Peer Electronic Mail Server** This is the message store server that the MAS communicates with when sending and receiving voice messages. This is initially selected at installation.
  - **Mail Server Name** Enter the name of the peer message store server for this MAS.

    You can click the browse (...) button and use the Select Computer window to find the server, if necessary.

- **Directory Server(s)** This is the server that contains information about subscribers. The directory server is initially selected at installation.

  - **Primary Directory Server** Enter the name of the primary directory server for this MAS.

    You can click the browse (...) button and use the Select Computer window to find the server, if necessary.
MAS - Languages Dialog Box

Note: For a detailed overview of Messaging Application Server (MAS) configuration in the Voice Mail System Configuration (VMSC) application, see Overview of MAS Configuration in VMSC on page 4-2.

This topic describes how to use the Languages dialog box to see which languages are currently installed on the selected MAS. The list of languages is for information only and cannot be edited.

Note: To configure Languages for the entire voice mail domain, see Languages Dialog Box on page 3-166.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Click Message Application Servers.
3. Click the MAS you want to view.
4. Double-click Languages. The system displays the Languages dialog box for the selected MAS, with the Server Languages tab selected. This is the only tab.

Viewing the Screen Controls

Note: To view this dialog box, you must be a member of a security role assigned the Languages - Administer task, or the Languages - View task. See Security Roles Dialog Box on page 3-88.

- **Local Server Languages Installed** This displays a list of all languages installed on the MAS.

  Note: The list is view-only.
MAS - Telephony Interface Dialog Box

You can use the Telephony Interface dialog box to configure the telephony interface for the selected MAS.

**Note:** You must configure the telephony interface for each MAS in your system.

The screens that you see in the Telephony Interface dialog box depend on the type of voice boards you are using:

- [MAS - Telephony Interface Dialog Box (Analog)](page 4-15).
- [MAS - Telephony Interface Dialog Box (QSIG)](page 4-17).
- [MAS - Telephony Interface Dialog Box (Set Emulation)](page 4-19).
- [MAS - Telephony Interface Dialog Box (IP H.323/IP SIP)](page 4-23).
MAS - Telephony Interface Dialog Box (Analog)

Note: For a detailed overview of Messaging Application Server (MAS) configuration in the Voice Mail System Configuration (VMSC) application, see Overview of MAS Configuration in VMSC on page 4-2.

This topic describes how to use the Telephony Interface dialog box to configure ports, if you are using Control LAN (C-LAN), Digital Multiplexed Interface - 4 (DMI-4), Inband, or Serial RS-232 integration.

You can set the playback volume and configure the number of ports that connect the MAS with the Private Branch Exchange (PBX). You can enable ports and configure properties for each of them.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Click Message Application Servers.
3. Click the MAS you want to configure.
4. Double-click Telephony Interface.

The system displays the Telephony Interface dialog box for the selected MAS with the Analog tab selected. This is the only tab.

Note: If the Analog telephony interface is not already active, click the down arrow and click Make Active.

Configuring the Screen Controls

Note: To configure this dialog box, you must be a member of a security role assigned the Telephony - Administer task. If you are a member of a role assigned the Telephony - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

- **Playback Volume** Enter a value for the playback volume. The range is -8 (minus 8) through 8.

  Avaya recommends that you enter 2. For C-LAN and Inband integrations, the default value is 2.
- **Number of Ports**: Enter the number of ports that connect the MAS with the PBX. The default is set during installation.

  **Note**: If you increase the number of ports, you must restart the **MM Messaging Application Server** service before you can administer them. For more information, see Appendix C, Modular Messaging (MM) Services.

- **Configure the port fields listed in the grid**:

  - **Port**: The port number is read only.
  - **Extension**: Enter the port extension number. You can enter up to 10 digits. This field is blank by default.
  - **Incoming Ring Count**: Enter a number to specify the number of rings before a call on the port is answered. The range is 1 through 9, and the default is 1.
  - **Primary Id**: Enter the first part of the PBX integration identifier, known as the logical terminal number (LTN), for serial integration only. You can enter up to 10 characters and digits (including & * # and ,). This field is blank by default.

    **Note**: This field is applicable to DMI-4 and RS-232 integrations only. Leave this field blank for C-LAN and inband integrations.

  - **Secondary Id**: Enter the second part of the PBX integration identifier, known as the message desk number (MD), for serial integration only. You can enter up to 10 characters and digits (including & * # and ,). This field is blank by default.

    **Note**: This field is applicable to DMI-4 and RS-232 integrations only. Leave this field blank for C-LAN and inband integrations.
MAS - Telephony Interface Dialog Box (QSIG)

Note: For a detailed overview of Messaging Application Server (MAS) configuration in the Voice Mail System Configuration (VMSC) application, see **Overview of MAS Configuration in VMSC** on page 4-2.

This topic describes how to use the **Telephony Interface** dialog box to configure ports, if you are using Q-Signaling (QSIG) integration.

You can set the playback volume and configure the number of ports that connect the MAS with the Private Branch Exchange (PBX). You can enable specific ports.

**Launching the Screen**

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Click **Message Application Servers**.
3. Click the MAS you want to configure.
4. Double-click the **Telephony Interface**.

The system displays the **Telephony Interface** dialog box for the selected MAS with the **General** tab selected. This is the only tab.

Note: If the QSIG telephony interface is not already active, click the down arrow and click **Make Active**.

**Configuring the Screen Controls**

Note: To configure this dialog box, you must be a member of a security role assigned the **Telephony - Administer** task. If you are a member of a role assigned the **Telephony - View** task, you have read-only access to this dialog box. See **Security Roles Dialog Box** on page 3-88.

- **Playback Volume** Enter a value for the playback volume. The range is -8 (minus 8) through 8, and the default is 2. Avaya recommends the default.
- **Maximum Concurrent Calls** Enter the number of ports that connect the MAS to the PBX. The default is set during installation.
Configure the port fields listed in the grid:

- Enable or disable ports, as required, by selecting or clearing the check boxes to the left of each port. All ports are selected by default.

- **Port** The port number is read only.
MAS - Telephony Interface Dialog Box (Set Emulation)

**Note:** For a detailed overview of Messaging Application Server (MAS) configuration in the Voice Mail System Configuration (VMSC) application, see [Overview of MAS Configuration in VMSC](#) on page 4-2.

This topic describes how to use the Telephony Interface dialog box to configure ports, if you are using Digital Set Emulation (DSE) integration.

You can set the playback volume and configure the number of ports that connect the MAS with the Private Branch Exchange (PBX). You can enable ports and configure properties for each of them.

The Telephony Interface dialog box has either one or two tabs, depending on your configuration. There is always a General tab, as described in this topic below.

Automatic Call Distribution (ACD) is a form of integration available only with NT M-1 PBXs using Digital Set Emulation integration. You can use the ACD tab, to configure settings for agent-based ACD and position-based ACD. See [MAS - Telephony Interface - ACD Tab (Set Emulation)](#) on page 4-21.

**Launching the Screen**

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Click Message Application Servers.
3. Click the MAS you want to configure.
4. Double-click the Telephony Interface.

   The system displays the Telephony Interface dialog box for the selected MAS with the General tab selected.

   **Note:** If the Set Emulation telephony interface is not already active, click the down arrow and click Make Active.

**Configuring the Screen Controls**

**Note:** To configure this dialog box, you must be a member of a security role assigned the Telephony - Administer task. If you are a member of a role assigned the Telephony - View task, you have read-only access to this dialog box. See [Security Roles Dialog Box](#) on page 3-88.

- **Playback Volume** Enter a value for the playback volume. The range is -8 (minus 8) through 8, and the default is 2. Avaya recommends the default.
- **Maximum Concurrent Calls**  Enter the number of ports that connect the MAS to the PBX. The default is set during installation.

- Configure the port fields listed in the grid:
  - Enable or disable ports, as required, by selecting or clearing the check boxes to the left of each port. All ports are selected by default.
  - **Port**  The port number is read only.
  - **Extension**  Enter the extension number associated with the MAS port. The extension number is required only if you are using linear chain integration with set emulation. You can enter up to ten digits.
MAS - Telephony Interface - ACD Tab (Set Emulation)

Automatic call distribution (ACD) is a form of integration available only with NT M-1 Private Branch Exchanges (PBXs) using Digital Set Emulation integration.

You can use the Telephony Interface dialog box, ACD tab to configure settings for agent-based ACD and position-based ACD.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Click Message Application Servers.
3. Click the MAS you want to configure.
4. Double-click the Telephony Interface.
   The system displays the Telephony Interface dialog box for the selected MAS with the General tab active.
5. Click the ACD tab.

Configuring the Screen Controls

- **Enable ACD** Select to enable the voice mail system to use ACD as the form of integration. This check box is cleared by default.
  Selecting this option activates all the other fields in the tab.
  - **Outcall Key** Select the key that must be pressed to make an outgoing call. You can select from characters A through H, and the default is B.
  - **Incall Key** Select the key that must be pressed to answer a call. You can select from characters A through H, and the default is A.
  - **MSB Key** Select the key that must be pressed for ‘make set busy’. You can select from characters A through H, and the default is C.
  - **MSB Lamp** Select a value that identifies the lamp on the handset associated with ‘make set busy’. You can select a digit from 0 through 7, and the default is 2.
— Configure the port fields listed in the grid:

- Enable or disable ports, as required, by selecting or clearing the check boxes to the left of each port. All ports are selected by default.

- **Port** The port number is read only.

- **Agent ID** Enter the ACD agent login IDs for ports that you have configured on the PBX. You can enter up to thirty digits for each agent ID.
MAS - Telephony Interface Dialog Box (IP H.323/IP SIP)

Note: For a detailed overview of Messaging Application Server (MAS) configuration in the Voice Mail System Configuration (VMSC) application, see Overview of MAS Configuration in VMSC on page 4-2.

This topic describes how to use the Telephony Interface dialog box to configure ports, if you are using H.323-based or SIP-based IP integration. You can set the playback volume and configure the number of ports that connect the MAS with the Private Branch Exchange (PBX). You can enable ports and configure their properties.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Click Message Application Servers.
3. Click the MAS you want to configure.
4. Double-click the Telephony Interface.

The system displays the Telephony Interface dialog box for the selected MAS with the General tab selected. This is the only tab.

Note: If the IP H.323/IP SIP telephony interface is not already active, click the down arrow and click Make Active.

Configuring the Screen Controls

Note: To configure this dialog box, you must be a member of a security role assigned the Telephony - Administer task. If you are a member of a role assigned the Telephony - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

- **Playback Volume** Enter a value for the playback volume. The range is -8 (minus 8) through 8, and the default is 2. Avaya recommends the default.
- **Maximum Concurrent Calls** Enter the maximum number of ports that connect the MAS to the PBX. This is the maximum number of concurrent calls that the MAS can support. The default is set during installation.
Configure the port fields listed in the grid:

- Enable or disable ports, as required, by selecting or clearing the check boxes to the left of each port. All ports are selected by default.

- **Port** The port number is read only.
MAS - Port Groups Dialog Box

**Note:** For a detailed overview of Messaging Application Server (MAS) configuration in the Voice Mail System Configuration (VMSC) application, see Overview of MAS Configuration in VMSC on page 4-2.

This topic describes how to use the Port Groups dialog box to configure port groups for the selected MAS.

You can create port groups for PC client applications, the Telephone User Interface (TUI), Call Me, Avaya’s Native Fax Support, Message Waiting Indicator (MWI), and QSIG Outbound Transfer. See MAS - Port Groups Dialog Box on page 4-25.

All port groups must be created in the Port Groups dialog box’s General tab, but then some are configured in the Usage tab and others using the PBX Integration dialog box. Others have no additional configuration but must be given a specific name. For more information, see Rules for Creating Port Groups on page 4-27.

**Launching the Screen**

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Click Message Application Servers.
3. Click the MAS you want to configure.
4. Double-click Port Groups. The system displays the Port Groups dialog box for the selected MAS.

**Tabs Available in this Dialog Box**

**Note:** To configure this dialog box, you must be a member of a security role assigned the Telephony - Administer task. If you are a member of a role assigned the Telephony - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

- **General** Use this tab to create port groups for PC client applications, the Telephone User Interface (TUI), Call Me, Avaya’s Native Fax Support, Message Waiting Indicator (MWI) and QSIG Outbound Transfer.

You can specify which ports are members of each group and configure each port group to be able to receive incoming calls to the MAS and/or send outgoing calls. See MAS - Port Groups - General Tab on page 4-29.
- **Usage** User this tab to configure port group usage for PC client applications, the Telephone User Interface (TUI), the Call Me feature and Avaya’s Native Fax Support. See [MAS - Port Groups - Usage Tab](#) on page 4-31.
Rules for Creating Port Groups

All port groups are created using the Port Groups dialog box, General tab and given initial settings. See MAS - Port Groups - General Tab on page 4-29.

They can then be given additional settings in several different ways:

- Some are configured in the Port Groups dialog box, Usage tab.
- Some are configured using settings in the PBX Integration dialog box.
- Some do not have additional settings but must be given a specific name.

Port Groups configured using the Port Groups dialog box, Usage tab

You can create port groups for PC client applications, the Telephone User Interface (TUI), Call Me, and Avaya’s Native Fax Support using the Port Groups dialog box, General tab, using any appropriate name.

You can configure the initial settings for each one in the General tab, then link them to the appropriate field on the Usage tab: PC Clients, Telephone User Interface, Call Me and Fax. See MAS - Port Groups - Usage Tab on page 4-31.

When creating these ports, follow these guidelines:

- One or more ports on the MAS must be configured in the PC Clients group. The ports must be configured to allow outgoing calls.
- One or more ports on the MAS must be configured in the Telephone User Interface group. The ports must be configured to allow incoming calls.
- The ports in the Call Me group must also be in the Telephone User Interface port group.
- The ports in the Fax group are used for Avaya’s Native Fax Support outgoing faxes.

Port Groups configured using the PBX Interface dialog box

You can create a port group for Message Waiting Indicator (MWI), using any appropriate name.

You can configure the initial settings in the Port Groups dialog box, General tab, then make additional settings using the PBX Interface dialog box. The tab you use within that dialog box, depends on the type of Private Branch Exchange (PBX) interface you are using:

- For inband integration, you use the MWI Settings dialog box. This is launched using the PBX Interface dialog, Inband tab. See MAS - PBX Integration - MWI Settings Dialog Box on page 4-50.
- For IP H.323 integration, you use the PBX Interface dialog, IP H.323 tab. See MAS - PBX Integration - IP H.323 Tab on page 4-56.

- For Q-Signaling (QSIG) or Set Emulation, you use the PBX Interface dialog, QSIG/SE tab. See MAS - PBX Integration - QSIG/SE Tab on page 4-52.

**Port Groups which must have a specific name**

You can create port groups where their usage has been predefined in the Modular Messaging system. In these cases, you must give the port groups specific names so that they are recognized by the system.

You can create these groups and give them initial settings in the Port Groups dialog box, General tab:

- For QSIG:
  - "OUTBOUND TRANSFER" Create a port group with this name, when the PC Client Group cannot be used for outbound QSIG transfers.

For information on calculating the number of ports required, see Avaya Modular Messaging Concepts and Planning Guide.
MAS - Port Groups - General Tab

Use the Port Groups dialog box, General tab to create port groups and specify which ports are members of each group. You can then configure each port group to be able to receive incoming calls to the MAS and/or send outgoing calls.

**Note:** All port groups are be created on the General tab but then some are configured in the Usage tab and others using the PBX Integration dialog box. Others have no additional configuration but must be given a specific name. See Rules for Creating Port Groups on page 4-27.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Click Message Application Servers.
3. Click the MAS you want to configure.
4. Double-click Port Groups. The system displays the Port Groups dialog box for the selected MAS, with the General tab active.

Configuring the Screen Controls

- **Port Group** Select from the drop-down list the port group that you want to configure. The default is Default Group.
  
  You can then use the other fields to configure the settings for this group.

- **Port Group Members** Lists the ports available on the current MAS. All ports are selected by default, when the system is installed. Ports installed after installation are not automatically included in a port group. You must add these ports to a port group for use by the MAS.

  **Note:** Ports referenced in the port group that no longer exist are marked with an exclamation mark (!).

  — Select a port to add it to the selected port group. Clear a port’s check box to remove it from the selected port group.

- **Port Group Usage**

  — **Incoming** Select this to permit the port group to receive incoming calls to the MAS. By default, this check box is selected.

  — **Outgoing** Select this to permit the port group to send outgoing calls from the MAS. By default, this check box is selected.
Add Group  Clicking this button allows you to add a new port group:

1. Click this button to display the Add New Group dialog box.

2. In the Port Group Name field, enter a unique port group name.

3. Click OK to return to the Port Groups dialog box, where you can define the settings for the new group.

Remove Group  Clicking this button removes the port group currently selected in the Port Group field.

The system prompts you to confirm your decision before it deletes the port group.

Note: You cannot delete the Default Group.
MAS - Port Groups - Usage Tab

Use the Port Groups dialog box, Usage tab to configure port group usage for PC client applications, the Telephone User Interface (TUI), Call Me, and Avaya’s Native Fax Support.

**Note:** For details of settings which must be configured for these particular port groups, see Rules for Creating Port Groups on page 4-27.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Click Message Application Servers.
3. Click the MAS you want to configure.
4. Double-click Port Groups. The system displays the Port Groups dialog box for the selected MAS, with the General tab active.
5. Click the Usage tab.

Configuring the Screen Controls

- **PC Clients**
  - **Number of Instances** Enter the number of ports that can be accessed simultaneously by PC clients. This is limited to the number of ports configured for the port group. The range is 0 through the maximum number of ports available in the system, and the default is the maximum number of ports.
  - **Port Group** Select the port group to be used by the PC client applications. The default is Default Group.

- **Telephone User Interface**
  - **Port Group** Select the port group to be used by the TUI. The default is Default Group.

- **Call Me**
  - **Port Group** Select the port group to be used for Call Me. The default is Default Group.
FAX

- **Port Group**  Select the port group to be used for outgoing Fax calls, with Avaya's Native Fax Support. The default is **Default Group**.

**Note:** You only need to set up port groups for fax, if you want to dedicate specific ports for faxing. For normal fax functionality, you can use the **Default Group**.
MAS - PBX Integration Dialog Box

**Note:** For a detailed overview of Messaging Application Server (MAS) configuration in the Voice Mail System Configuration (VMSC) application, see Overview of MAS Configuration in VMSC on page 4-2.

This topic describes how to use the PBX Integration dialog box to configure Private Branch Exchange (PBX) integration for the selected MAS. This determines how the selected PBX type passes call information to the MAS.

**Note:** The PBX Integration node is removed from the Voice Mail System Configuration tree, if the MultiSite feature is enabled. If MultiSite is enabled, you can only add SIP switches to the voice mail domain. You can instead configure SIP-based IP integration for the entire voice mail domain on the IP SIP tab of the PBXs node.

The call information includes calling party identification (if known), called party identification, and a call type code. With PBX integration, callers who are forwarded to the MAS can leave a message for the called party or can transfer to another extension.

**Notes:**

- You must specify which PBX is used for the selected MAS before you can configure PBX integration. See MAS - PBX Type Dialog Box on page 4-61.

- For more information on configuring your PBX, see the PBX configuration notes. These are available from the Avaya Support Website at http://www.avaya.com/support.

- For more information on PBX integration, see Avaya Modular Messaging Concepts and Planning Guide.

**Launching the Screen**

1. In the Voice Mail System Configuration window, click Message Application Servers.

   You may need to expand the tree to see all the MASs in the voice mail domain.

2. Click the MAS you want to integrate.

   You may need to expand the tree to see the available PBXs.
3. Double-click **PBX Integration**. The system displays the **PBX Integration** dialog box for that MAS.

**Note:** If you have SIP-based IP integration, you will only see one tab called **IP SIP**. If not, you will see all the other tabs listed below instead: **General**, **Serial General**, **Serial NEC/Ericsson/DMID**, **Inband**, **Remote**, **QSIG/SE** and **IP H323**. If you have analog telephony, the **Avaya C-LAN** tab also appears.

**Tabs Available in this Dialog Box**

**Note:** To configure this dialog box, you must be a member of a security role assigned the **Telephony - Administer** task. If you are a member of a role assigned the **Telephony - View** task, you have read-only access to this dialog box. See *Security Roles Dialog Box* on page 3-88.

- **General** Use this tab to select the type of PBX integration for an MAS. Depending on the telephony interface, some PBX integration types may not be available. See *MAS - PBX Integration - General Tab* on page 4-36.

  **Note:** The integration type selected in this tab determines which of the other tabs are activated.

- **Serial General** Use this tab to configure serial PBX integration for an MAS, if your PBX supports Digital Multiplexed Interface - 4 (DMI-4) integration or serial RS-232 integration. With serial integration, the MAS receives incoming call information by means of a serial link. See *MAS - PBX Integration - Serial General Tab* on page 4-38.

  From this tab, you can also configure settings using the **Serial Settings** dialog box. See *MAS - PBX Integration - Serial Settings Dialog Box* on page 4-40.

- **Serial NEC/Ericsson/DMID** Use this tab to configure serial integration for NEC, Ericsson, and DMID protocols. See *MAS - PBX Integration - Serial NEC/Ericsson/DMID Tab* on page 4-41.

  This tab is activated by selecting the appropriate setting in the **Serial General** tab.

- **Inband** Use this tab to configure Inband PBX integration for an MAS. With inband integration, the MAS receives incoming call information in the form of Dual Tone Multi-Frequency (DTMF) digits. See *MAS - PBX Integration - Inband Tab* on page 4-43.

  From this tab, you can also configure settings using the **Inband Protocol Settings** dialog box and the **MWI Settings** dialog box. See *MAS - PBX Integration - Inband Protocol Settings Dialog Box* on page 4-47 and *MAS - PBX Integration - MWI Settings Dialog Box* on page 4-50.
Remote Use this tab to configure remote PBX integration for an MAS. With remote integration, the MAS receives its incoming call information through another MAS that has a serial integration. See MAS - PBX Integration - Remote Tab on page 4-51.

QSIG/SE Use this tab to configure an MWI port group for Q-Signalling (QSIG) or Set Emulation PBX integration. See MAS - PBX Integration - QSIG/SE Tab on page 4-52.

Avaya C-LAN Use this tab to configure Control LAN (C-LAN) integration. This is available with Avaya DEFINITY®, IP600, MultiVantage™, and Communication Manager PBXs only. See MAS - PBX Integration - Avaya C-LAN Tab on page 4-54.

IP H323 Use this tab to configure H.323-based IP integration. This is available with Avaya DEFINITY®, IP600, MultiVantage™, and Communication Manager PBXs only. See MAS - PBX Integration - IP H.323 Tab on page 4-56.

IP SIP Use this tab to configure SIP-based IP integration. This is available with Avaya DEFINITY®, IP600, MultiVantage™, and Communication Manager PBXs only. See MAS - PBX Integration - IP SIP Tab on page 4-59.
MAS - PBX Integration - General Tab

Use the PBX Integration dialog box, General tab to select the type of Private Branch Exchange (PBX) integration for a Messaging Application Server (MAS). The integration type determines how the PBX provides the MAS with additional information about incoming calls.

Launching the Screen

1. In the Voice Mail System Configuration window, click Message Application Servers.

   You may need to expand the tree to see all the MASs in the voice mail domain.

2. Click the MAS you want to integrate.

   You may need to expand the tree to see the available PBXs.

3. Double-click PBX Integration.

   The system displays the PBX Integration dialog box for that MAS, with the General tab active.

Configuring the Screen Controls

- **Integration Type** Select from the following options:

  - **None** Select if the PBX does not support integration. This is the default.

  - **IP** Select to specify H.323-based IP integration. The MAS receives incoming call information in the form of Q-Signalling (QSIG) messages embedded in the H.323 packet, over an IP network.

    This setting activates the IP H323 tab. For more information, see MAS - PBX Integration - IP H323 Tab on page 4-56.

  - **Serial** Select to specify serial integration. The MAS receives incoming call information through a serial link.

    This setting activates the Serial General tab. For more information, see MAS - PBX Integration - Serial General Tab on page 4-38.

  Note: Some of these options may not be available, depending on which PBX you selected for the MAS. See MAS - PBX Type Dialog Box on page 4-61.
— **Inband** Select to specify inband integration. The MAS receives incoming call information in the form of Dual Tone Multi-Frequency (DTMF) digits.

This setting activates the **Inband** tab. For more information, see [MAS - PBX Integration - Inband Tab](#) on page 4-43.

— **Remote** Select to specify remote PBX integration. The MAS receives incoming call information through another serial integration server.

This setting activates the **Remote** tab. For more information, see [MAS - PBX Integration - Remote Tab](#) on page 4-51.

— **QSIG** Select to specify QSIG integration. The MAS receives incoming call information by means of QSIG.

This setting activates the **QSIG/SE** tab.

— **Set Emulation** Select this to specify set emulation integration.

This setting also activates the **QSIG/SE** tab. For more information, see [MAS - PBX Integration - QSIG/SE Tab](#) on page 4-52.

— **CLAN** Select this to specify Control-LAN (C-LAN) integration.

This setting activates the **Avaya C-LAN** tab. For more information, see [MAS - PBX Integration - Avaya C-LAN Tab](#) on page 4-54.

- **Max time to Wait for Serial and Remote Integration Data (sec)** Enter or select the maximum amount of time, in seconds, that an incoming call waits to receive integration information before going off hook. The default is 18.

**Note:** This field is only available when either **Serial** or **Remote** is selected in the **Integration Type** list.
MAS - PBX Integration - Serial General Tab

Use the PBX Integration dialog box, Serial General tab to configure serial Private Branch Exchange (PBX) integration for a Messaging Application Server (MAS). With serial integration, the MAS receives incoming call information by means of a serial link.

Launching the Screen

1. In the Voice Mail System Configuration window, click Message Application Servers.

   You may need to expand the tree to see all the MASs in the voice mail domain.

2. Click the MAS you want to integrate.

   You may need to expand the tree to see the available PBXs

3. Double-click PBX Integration. The system displays the PBX Integration dialog box for that MAS, with the General tab active.

4. Click the Serial option button in the Integration Type list.

5. In the Max Time to Wait for Serial and Remote Integration Data (sec) field, type the maximum time, in seconds, that an incoming call waits to receive integration information before going off hook. The default is 18.

6. Click the Serial General tab.

Configuring the Screen Controls

- **Packet Format** Select the PBX serial integration data packet format from the list.
  
  — If you select either SMDI or Intercom, you only need configure this tab.

  — If you select either DMID, NEC-2400 or Ericsson MD-110, this activates the Serial NEC/Ericsson/DMID tab, where you should configure the protocol type. See MAS - PBX Integration - Serial NEC/Ericsson/DMID Tab on page 4-41.

- **Extension Field Length in Packet** Enter the number of digits in the packet sent from the integration device. The range is 2 through 10, and the default is 4.

- **Maximum Number of Remote Service Sessions** Enter the maximum number of remote MASs that are dependent on the primary server for integration. The range is 0 through 999, and the default is 0.
- **Log Serial Packets**  Select to log the serial integration data in the operation history database. This check box is selected by default.

- **Serial Settings...**  Click to open the **Serial Settings** dialog box, where you can configure the serial line settings. See [MAS - PBX Integration - Serial Settings Dialog Box](#) on page 4-40.
MAS - PBX Integration - Serial Settings Dialog Box

The Serial Settings dialog box allows you to configure serial line settings.

Launching the Screen

To reach this dialog box, you must click **Serial Settings...** on the **Serial General** tab of the **PBX Integration** dialog box (see **MAS - PBX Integration - Serial General Tab** on page 4-38).

Notes:

- If you are using NEC-2400, Ericsson MD110, or DMID, you must also configure the serial properties for these cards. See **MAS - PBX Integration - Serial NEC/Ericsson/DMID Tab** on page 4-41.

- After making these settings, you must stop and restart the MM Messaging Application Server service for the settings to take effect. See **Appendix C, Modular Messaging (MM) Services**.

Configuring the Screen Controls

- **Line Speed (Bits per Second)**  Enter the serial line speed in bits per second. The range is 110 through 115200, and the default is 9600.

- **Data Bits**  Select the number of data bits for the serial line. The default is 8.

- **Stop Bits**  Select the number of stop bits for the serial line. The default is 1.

- **Parity**  Select to specify the type of parity for the serial line: **None**, **Odd** (default), **Even**, or **Space**.

- **Flow Control**  Select to specify the flow control for the serial line: **None**, **DTR/DSR, RTS/CTS**, or **Xon/Xoff** (default).

- **Connector**  Select the serial port for the line. The default is COM1.
MAS - PBX Integration - Serial NEC/Ericsson/DMID Tab

Use the PBX Integration dialog box, Serial NEC/Ericsson/DMID tab to configure serial integration for either DMID, NEC-2400 or Ericsson MD-110 protocols.

Launching the Screen

1. In the Voice Mail System Configuration window, click Message Application Servers.

   You may need to expand the tree to see all the MASs in the voice mail domain.

2. Click the MAS you want to integrate.

   You may need to expand the tree to see the available PBXs

3. Double-click PBX Integration. The system displays the PBX Integration dialog box for that MAS, with the General tab active.

4. Click the Serial option button in the Integration Type list.

5. In the Max Time to Wait for Serial and Remote Integration Data (sec) field, type the maximum time, in seconds, that an incoming call waits to receive integration information before going off hook. The default is 18.

6. Click the Serial General tab.

7. In the Packet Format field select either DMID, NEC-2400 or Ericsson MD-110.

8. Configure any other settings as appropriate. See MAS - PBX Integration - Serial General Tab on page 4-38.

9. Click the Serial NEC/Ericsson/DMID tab.

   **Note:** Only one of the NEC-2400, Ericsson MD110 and DMID group boxes is active. This depends on whether the corresponding setting has been selected as the Packet Format in the Serial General tab.

Configuring the Screen Controls

- NEC-2400
  - **Tenant Number** Enter the tenant number used by NEC integration. The range is 1 through 99, and the default is 1.
### Ericsson MD110:

- **Filler Character**  Enter the filler character used by Ericsson integration: **Zero** or **Space** (default).

- **Port Field Length**  Enter the length of the port number field. The range is 2 through 5, and the default is 2.

- **Tenant Number**  Enter the tenant number used by Ericsson integration. The range is 1 through 99, and the default is 1.

- **First Port Number**  Enter the number of the first port to receive incoming calls. The range is 1 through 250, and the default is 1.

### DMID:

- **Enable Full Error Logging from DMID Integration Device**  Select to place any errors reported by the DMID integration device in the Windows 2000/2003 Significant Event Log. This check box is cleared by default.

- **Extension of First Port in DMID Hunt Chain**  Enter the extension number of the port that is the first directory number in the hunt chain programmed for the DMID device. This must be a valid extension number. This field is blank by default.
MAS - PBX Integration - Inband Tab

Use the PBX Integration dialog box, Inband tab to configure inband Private Branch Exchange (PBX) integration for a Messaging Application Server (MAS).

PBX integration establishes communication between the PBX and the voice mail system. The PBX supplies information such as who is calling on internal calls and the extension that the caller is trying to reach.

With inband integration, the MAS receives information about an incoming call from the PBX in a call information packet. The call information packet contains Dual Tone Multi-Frequency (DTMF) digits indicating the type of call (known as the call packet type), the called party ID, the calling party ID, and the trunk ID.

Note: After configuring these settings, you must stop and restart the MM Messaging Application Server service for the settings to take effect. See Appendix C, Modular Messaging (MM) Services.

Launching the Screen

1. In the Voice Mail System Configuration window, click Message Application Servers.

   You may need to expand the tree to see all the MASs in the voice mail domain.

2. Click the MAS you want to integrate.

   You may need to expand the tree to see the available PBXs

3. Double-click PBX Integration. The system displays the PBX Integration dialog box for that MAS, with the General tab active.

4. Click the Inband option button in the Integration Type list.

5. Click the Inband tab.

Configuring the Screen Controls

- **Maximum Inter-digit Gap (ms)** Enter the time, in milliseconds, for the delay between each DTMF digit in the call information packet. This setting does not apply to the delay until the first DTMF digit arrives in a call information packet. The range is 16 through 999, and the default is 48.

- **Pause before Inband Digits (ms)** Enter the maximum time, in milliseconds, to wait after taking the voice port off hook before the first DTMF digit arrives in a call information packet. The range is 100 through 9999, and the default is 2500.
DTMF On Time (ms) Enter the duration, in milliseconds, of a DTMF digit in a call information packet. The range is 32 through 999, and the default is 32.

Search Entire String for Reason Code Select to allow the integration service to search the entire call information packet for the call packet type (also known as the reason code). The call packet type is a string of DTMF digits that form a code for the type of call received, such as a direct call, a forwarded call, or a diverted call. This check box is cleared by default.

If check box is cleared, the integration service looks for the call packet type at the digit position specified in the Location of Inband Reason Code field. If the check box is selected that field is grayed out.

Tip: If you do not know the Location of Inband Reason Code, you can get this information by making a call of the appropriate call packet type. Then check the call information using the Operation History Viewer. See Chapter 8, "Operation History Viewer". To do this, you must first set the Maximum Inter-digit Gap (ms) and Pause before Inband Digits (ms) to high values, and select the Log Inband Packets check box.

Location of Inband Reason Code Enter the position within the call information packet of the first DTMF digit in the call packet type (also known as the reason code). The call packet type is a string of DTMF digits that form a code for the type of call received, such as a direct call, a forwarded call, or a diverted call. Each call information packet must have a call packet type.

For example, if the call packet type is the first field in the call information packet, enter 1. If the call packet type is the second field in the call information packet and follows a field that is 6 DTMF digits in length, enter 7. In this case, the first DTMF digit in the call packet type is the 7th DTMF digit in the call information packet. The range is 1 through 99, and the default is 1.

Log Inband Packets Select to log the inband call information packets in the operation history database. When selected, inband call information can be viewed in the Operation History Viewer. This check box is cleared by default.

Fixed Length Packets Select, if your PBX sends out call information packets of a fixed length. Within fixed length call information packets each piece of call information, that is, the call packet type, the calling party ID, the called party ID, and the trunk ID, is in a fixed position.

For example, the call packet type starts at position 1 (the first DTMF digit in the packet), the called party ID starts at position 4 (the 4th DTMF digit in the packet), the calling party ID field starts at position 11 (the 11th DTMF digit in the packet), and the trunk ID field starts at position 18 (the 18th DTMF digit in the packet). The total fixed packet length is 21.

If this check box is cleared, the packet length is variable. This check box is cleared by default.

Note: When this check box is selected, the Packet Length field is activated in the Inband Protocol Settings dialog box see MAS - PBX Integration - Inband Protocol Settings Dialog Box on page 4-47.
■ **Filler Character**  Select the filler character used in the call information packet. A filler character is required, if your PBX sends out fixed length call information packets. The filler character is the character that is used to fill in blanks in a fixed length field, if the number of DTMF digits received is less than the fixed number defined.

For example, if the fixed length of a called party ID field is 7 (as defined in the *Inband Protocol Settings* dialog box), but only 4 DTMF digits are received, 3 filler characters are required to maintain the fixed length of the call information packet. These are added after the DTMF digits in the *Called Id* field.

You can select from *, #, A, B, C, D, 0, or <NONE>. 0 is available, only if the *Right Alignment of Digits in a Field* check box is selected. Note that the filler character cannot be the same as the delimiter character.

In the following example, hash (#) is used as the filler character.

<table>
<thead>
<tr>
<th>Call Packet Type</th>
<th>Called Id</th>
<th>Calling Id</th>
<th>Trunk Id</th>
</tr>
</thead>
<tbody>
<tr>
<td>3 digits</td>
<td>7 digits</td>
<td>7 digits</td>
<td>4 digits</td>
</tr>
<tr>
<td>11#</td>
<td>4001###</td>
<td>6783000</td>
<td>3008</td>
</tr>
</tbody>
</table>

The default is asterisk (*).

■ **Delimiter Character**  Select the delimiter character used in call information packets to distinguish between different fields. For example, in the following call information packet, * is used to distinguish between the call packet type, called party ID, calling party ID, and trunk ID:

```
1000*4001234*6009*1200
```

You can select from *, #, A, B, C, D, or <NONE>. <NONE> is available only if the *Fixed Length Packets* check box is selected. The default is #.

**Note:** The delimiter character cannot be the same as the filler character.

■ **Right Alignment of Digits in a Field**  Select to indicate that in a fixed length call information packet, the DTMF digits in each field are to be right aligned. This check box is cleared by default.

■ **Request String Supported**  Select if your PBX requires the MAS to send it a request string before it can send the call information packet.

If selected, two fields are enabled, *Inband Request Digit String* and *Pause before Request String (ms)*.
--- **Inband Request Digit String** Enter the sequence of DTMF digits that the MAS must send to the PBX, when requesting a call information packet. The range is 0 through 99, and the default is blank.

--- **Pause before Request String (ms)** Enter the time, in milliseconds, before the MAS sends the request string to the PBX after going off hook. The PBX may require this time to stabilize. The range is 0 through 10000, and the default is 500.

- **Protocol Settings...** Opens the Inband Protocol Settings dialog box, where you can configure inband protocol types. For more information, see MAS - PBX Integration - Inband Protocol Settings Dialog Box on page 4-47.

- **MWI Settings...** Opens the MWI Settings dialog box, where you can configure MWI settings. For more information, see MAS - PBX Integration - MWI Settings Dialog Box on page 4-50.
MAS - PBX Integration - Inband Protocol Settings Dialog Box

You can use the Inband Protocol Settings dialog box to configure inband protocol types.

Launching the Screen

To reach this dialog box, click the Protocol Settings... button on the Inband tab of the PBX Integration dialog box (see MAS - PBX Integration - Inband Tab on page 4-43).

Configuring the Screen Controls

- **Packet Settings** You can use these settings to select the Call Packet Type and enter information about that type in the remaining fields. You can then select another item from the Call Packet Type field and configure that type.

  To enable your PBX to do this, you must configure the DTMF digit strings for each code. As an example, in the No Answer Extension call packet type, an external no-answer call may be A1, and an internal no-answer call may be B1.

  Codes can have up to five characters including the digits 0–9, *, #, A, B, C, or D. Note that, if you are configuring the Check Mailbox call packet type, only one code is available since the PBX uses just one code for that call information packet.

  The required DTMF codes are already defined in your PBX. See your PBX documentation for information.

- **Show Advanced Call Packet Type** Certain PBXs, such as Matra and Alcatel, may require you to configure the following call packet types: Auto Logon, Check Mailbox, Confirm Mailbox, and Transfer Initiate. Select this check box to add those types to the Call Packet Type pick list.

- **Call Packet Type** Select the call packet type you want to configure. The call packet type represents the type of call that is received.

  If the Show Advanced Call Packet Type check box is cleared, you can only configure these types:

  - Divert
  - No Answer Extension
  - Busy Extension
  - Direct Call
Immediate Transfer

If the **Show Advanced Call Packet Type** check box is selected, you can also configure these types:

- **Auto Logon**  This is used by Alcatel PBXs to identify the calling party in a direct internal call. In a regular direct internal call, the calling party is not identified. With an Auto Logon call, if the extension of the calling party is identified as a subscriber, the caller is prompted to enter a password.

- **Check Mailbox**  This is used by Matra PBXs, when an extension is forwarded to a voice mail port on a ring-no-answer condition, a busy condition, or on always. It contains the call packet type (Check Mailbox) followed by the extension number of the telephone that is forwarded.

- **Confirm Mailbox**  This is sent by Modular Messaging software, when it receives a Check Mailbox call information packet. It is required for the forwarding operation to continue.

- **Transfer Initiate**  This is sent by Matra PBXs when an attempt is made to transfer a call to an extension that has been forwarded to a voice mail port.

- **Packet Length**  Enter the total length of the selected call information packet. The range is 0 through 255.

  **Note:**  This field is available only if the **Fixed Length Packets** check box is selected in the **PBX Integration** dialog box, **Inband** tab. See **MAS - PBX Integration - Inband Tab** on page 4-43. It is also not available, if the selected **Call Packet Type** is **Check Mailbox** or **Confirm Mailbox**.

Codes for Call Type

- **Code 1, 2, 3, 4**  A PBX can send up to four different codes for each call packet type. For example, for a No Answer Extension call, the PBX may send three different codes: one for an internal call, one for an external call, and one for an external trunk call.

  **Note:**  If the selected **Call Packet Type** is **Check Mailbox** or **Confirm Mailbox**, only **Code 1** is available.

Field Type Settings  Use the fields in this group box to determine the format of call information packets in the selected call packet type.

  **Note:**  This whole group box is not available, if the selected **Call Packet Type** is **Check Mailbox** or **Confirm Mailbox**.
The fields available in this group box depend on the Fixed Length Packets check box setting in the PBX Integration dialog box, Inband tab.

If the check box is not selected, because your call information packets are of variable length, the Sequence Number fields are available. If the check box is selected, the Starting Position and Fixed Field Length fields are available instead.

— Sequence Number Enter the sequence numbers for the Called Id, Calling Id and Trunk Id in a variable length call information packet.

Note: These fields are enabled by clearing the Fixed Length Packets check box in the PBX Integration dialog box, Inband tab. See MAS - PBX Integration - Inband Tab on page 4-43.

— Starting Position Enter the starting position for the Called Id, Calling Id and Trunk Id in a fixed length call information packet.

For example, if the first DTMF digit of the called ID is the 4th digit in a call information packet, enter 4 opposite Called Id

This may be different for each call information type. For example, in a No Answer Extension call, the starting position of the Called Id field may be 9 (the 9th DTMF digit in the call information packet), whereas in a Divert call it may be 7 (the 7th DTMF digit in the call information packet.).

Note: These fields are enabled by selecting the Fixed Length Packets check box in the PBX Integration dialog box, Inband tab.

— Fixed Field Length Enter the fixed field length for the Called Id, Calling Id and Trunk Id.

Note: These fields are enabled by selecting the Fixed Length Packets check box in the PBX Integration dialog box, Inband tab.
MAS - PBX Integration - MWI Settings Dialog Box

You can use the **MWI Settings** dialog box to configure message waiting indicator (MWI) settings.

Launching the Screen

To reach this dialog box, click the **MWI Settings**... button on the **Inband** tab of the **PBX Integration** dialog box (see [MAS - PBX Integration - Inband Tab](#) on page 4-43).

Configuring the Screen Controls

- **Port Group Name**  Select the port group to be used for MWI. The **Default Group** is selected by default.

  Port groups are created in the **Port Groups** dialog box. For more information, see [Rules for Creating Port Groups](#) on page 4-27.

- **Max MWI Sessions**  Enter the maximum number of MWI sessions allowed at one time. The maximum number cannot exceed the maximum number of ports in the selected port group.

- **Indicator On/Off signals must use the same port**  Select if your PBX has port affinity. This check box is cleared by default.

  **Indicator On:**

  - **Prefix**  Enter the DTMFs, if any, that the MAS must dial before the subscriber’s extension to turn on the message waiting indicator.

  - **Suffix**  Enter the DTMFs, if any, that the MAS must dial after the subscriber’s extension to turn on the message waiting indicator.

  **Indicator Off:**

  - **Prefix**  Enter the DTMFs, if any, that the MAS must dial before the subscriber’s extension to turn off the message waiting indicator.

  - **Suffix**  Enter the DTMFs, if any, that the MAS must dial after the subscriber’s extension to turn off the message waiting indicator.
MAS - PBX Integration - Remote Tab

Use the **PBX Integration** dialog box, **Remote** tab to configure remote Private Branch Exchange (PBX) integration for a Messaging Application Server (MAS).

With remote integration, the MAS receives incoming call information through another MAS that has a serial integration connection. You can specify a primary and secondary remote server for the MAS to use.

A secondary remote server would typically be used, for example, in the case of Simplified Message Desk Interface (SMDI) from a Centrex, where the integration data is sent to both the primary and secondary remote server, and the secondary server is accessed, if the primary server is unavailable.

**Note:** After configuring these settings, you must stop and restart the **MM Messaging Application Server** service for the settings to take effect. See Appendix C, Modular Messaging (MM) Services.

Launching the Screen

1. In the **Voice Mail System Configuration** window, click **Message Application Servers**.
   
   You may need to expand the tree to see all the MASs in the voice mail domain.

2. Click the MAS you want to integrate.
   
   You may need to expand the tree to see the available PBXs

3. Double-click **PBX Integration**. The system displays the **PBX Integration** dialog box for that MAS, with the **General** tab active.

4. Click the **Remote** option button in the **Integration Type** list.

5. In the **Max Time to Wait for Serial and Remote Integration Data (sec)** field, type the maximum time, in seconds, that an incoming call waits to receive integration information before going off hook. The default is 18.

6. Click the **Remote** tab.

Configuring the Screen Controls

- **Primary Remote Server Name** Select the name of the primary server from which the MAS can get integration data for an incoming call. The default is the first server in the voice mail domain server list.

- **Secondary Remote Server Name** Select the name of the secondary server from which the MAS can get integration data for an incoming call. The default is the first server in the voice mail domain server list.
MAS - PBX Integration - QSIG/SE Tab

Use the **PBX Integration** dialog box, **QSIG/SE** tab to configure an MWI port group for QSIG and Set Emulation Private Branch Exchange (PBX) integration for a Messaging Application Server (MAS).

**Note:** After configuring these settings, you must stop and restart the **MM Messaging Application Server** service for the settings to take effect. See **Appendix C, Modular Messaging (MM) Services**.

Launching the Screen

1. In the **Voice Mail System Configuration** window, click **Message Application Servers**.
   
   You may need to expand the tree to see all the MASs in the voice mail domain.

2. Click the MAS you want to integrate.
   
   You may need to expand the tree to see the available PBXs

3. Double-click **PBX Integration**. The system displays the **PBX Integration** dialog box for that MAS, with the **General** tab active.

4. Click the appropriate option button in the **Integration Type** list:

   - **QSIG** for Q.signaling (QSIG) integration.
   - **Set Emulation** for digital set emulation (DSE) integration.

5. Click the **QSIG/SE** tab.

Configuring the Screen Controls

- **MWI Port Group** Select the port group to be used for MWI. The **Default Group** is selected by default.

  Port groups are created in the **Port Groups** dialog box. For more information, see **Rules for Creating Port Groups** on page 4-27.

- **Max MWI Sessions** Enter the maximum number of MWI sessions allowed at one time. The maximum number cannot exceed the maximum number of ports in the selected port group.
- **Indicator On/Off signals must use the same port** Select this, if your PBX has port affinity. This check box is cleared by default.

**Notes:**

- Do not select this check box for Avaya PBXs supporting QSIG integration.

- If you set this field after the initial installation of Avaya Modular Messaging and have been running for a while, you must also reset your PBX.

- **MWI On** Enter the dial string required to switch on a subscriber's MWI light. You can enter up to 50 characters. The default is ^O,%s,^O for NT M-1, and *4%s for G3. The system substitutes %s with the subscriber's extension number.

  **Note:** This field is not available with QSIG integrations.

- **MWI Off** Enter the dial string required to switch off a subscriber’s MWI light. You can enter up to 50 characters. The default is ^F,%s,^F for NT M-1, and #4%s for G3. The system substitutes %s with the subscriber’s extension number.

  **Note:** This field is not available with QSIG integrations.
MAS - PBX Integration - Avaya C-LAN Tab

Use the PBX Integration dialog box, Avaya C-LAN tab to configure the Control-LAN (C-LAN) link. You can administer the nodes with which the message store server communicates.

C-LAN is an Avaya proprietary TCP/IP protocol that provides voice integration to Avaya DEFINITY®, IP600, MultiVantage™, and Communication Manager PBXs. With C-LAN, PBX integration is performed using a local area network.

Notes:

- C-LAN is available with analog telephony only.
- After configuring these settings, you must stop and restart the MM Messaging Application Server service for the settings to take effect. See Appendix C, Modular Messaging (MM) Services.

Launching the Screen

1. In the Voice Mail System Configuration window, click Message Application Servers.
   You may need to expand the tree to see all the MASs in the voice mail domain.

2. Click the MAS you want to integrate.
   You may need to expand the tree to see the available PBXs

3. Double-click PBX Integration. The system displays the PBX Integration dialog box for that MAS, with the General tab active.

4. Click the C-LAN option button in the Integration Type list.

5. Click the Avaya C-LAN tab.

Configuring the Screen Controls

- **Message Server Number** Enter the identification number of the Message Server. The Message Server number is set on the PBX, and is normally the same value as the Switch Number. The default is 1.

- **Switch Number** Enter the identification number of the PBX that communicates with the MAS. The default is 1.

- **Switch Host Address** Do one of the following:
  
  — Click Name, and enter the domain name of the PBX on the network. For example, pbx.avaya.com.
— Click **IP Address**, and enter the IP address of the PBX on the network.

- **TCP Port** Enter the TCP number of the port on the PBX that is used to communicate with the MAS. By default, the TCP number is 5002.

- **Notes** Enter notes associated with the C-LAN integration. For example, you may find it useful to enter a description of the PBX you are using.

- **Maximum Number of Remote Service Sessions** Enter the maximum number of remote MASs that are dependent on the primary server for integration. The range is 0 through 999, and the default is 0.

- **Connect Link** This connects the C-LAN link.

---

**Notes:**

- This button is only displayed when the link between the MAS and PBX is disconnected.

- If the MAS is unable to establish a connection with the PBX, a link connection down event is logged in the Windows event log. The source of the error is gv_vserver, and the category is PBX Integration.

---

- **Disconnect Link** This disconnects the C-LAN link.

---

**Note:** This button is only displayed when the link between the MAS and PBX is connected.
MAS - PBX Integration - IP H.323 Tab

Use the PBX Integration dialog box, IP H.323 tab to configure H.323-based IP integration. This provides IP connectivity between the Private Branch Exchange (PBX) and the Messaging Application Server (MAS).

H.323-based IP integration provides voice integration to Avaya DEFINITY® (Release 10 or later), IP600, MultiVantage™ (Release 1.2), and Communication Manager PBXs.

In a Definity PBX, IP network connectivity is established using Control-LAN (C-LAN) and MedPro circuit packs on the PBX and the network interface card (NIC)/Ethernet card on the MAS. In a MultiVantage or Communication Manager PBX, IP network connectivity is established using the PROCR on the PBX and the NIC/ethernet card on the MAS.

In H.323-based IP integration, signaling or call information, message waiting indicator (MWI) information, and voice data are transmitted over the IP network. H.323 connectivity between the MAS and the PBX is accomplished by means of H.323 trunk groups configured as tie trunks supporting Q-Signaling (QSIG) features. Q-SIG is a standards-based, private networking protocol, based on Q.931 standards (ISDN). Signaling information and MWI information are transmitted using QSIG messages embedded in an H.323 packet.

Note: After configuring these settings, you must stop and restart the MM Messaging Application Server service for the settings to take effect. See Appendix C, Modular Messaging (MM) Services.

Launching the Screen

1. In the Voice Mail System Configuration window, click Message Application Servers.

   You may need to expand the tree to see all the MASs in the voice mail domain.

2. Click the MAS you want to integrate.

   You may need to expand the tree to see the available PBXs

3. Double-click PBX Integration. The system displays the PBX Integration dialog box for that MAS, with the General tab active.

4. Click the IP option button in the Integration Type list.

5. Click the IP H323 tab.

Configuring the Screen Controls

- **MAS Corporate IP Address** Enter the IP address of the MAS. This is the IP address that the MAS uses to connect to the corporate LAN.
- **PBX IP Address** Enter the IP address assigned to the device that is terminating the H.323 signaling link.
  
  — For a Definity PBX, this is the IP address of the PBX C-LAN card.
  
  — For a MultiVantage or Communication Manager PBX, this is the IP address of the PROCR.

- **Port** Enter the port number on the MAS that would be used for transmission of signaling information and MWI information. By default, the port number is 1720.

- **UDP Port Range** Enter a minimum and maximum port number to specify a block of user datagram protocol (UDP) port numbers to be used for audio connections.

  The H.323 call setup protocol dynamically negotiates the UDP ports within the specified range that are available for use. The voice channels use the available ports from this UDP port range for transmission of voice data. The default range is 5000 through 5999.

- **Packet size (ms)** Enter, in milliseconds, the size of the real time protocol (RTP) packets that are used to transmit H.323 media over the IP network. The packet size represents the amount of voice data sent per packet. The value you enter here should match the packet size sent by the PBX. Packet size is typically 30 milliseconds.

  The packet size sent by the PBX is configured at the time of administering the codec type on the PBX. See the IP Codec screen on the PBX to check the packet size value configured on the PBX. For more information on configuring your PBX, see the PBX configuration documentation.

- **Enable Tunneling** Select to enable tunneling. Tunneling is the encapsulation of protocols that are at the same layer, into one another. When you enable tunneling, the QSIG message set, which contains call information and MWI information, is encapsulated in H.323 packets. This check box is selected by default.

- **Enable Fast Start** Select to enable this feature. Fast Start, also known as Fast Connect, is a call setup method that bypasses some initial steps in order to reduce the connection setup time. This feature makes the call setup faster as the voice data transmission can start immediately after sending a Fast Start message. This check box is selected by default.

- **Silence Suppress** Select to enable silence suppression. Enabling silence suppression prevents the transmission of voice packets during silence. Silence suppression ensures that no bandwidth is used during periods of silence.

- **Max MWI Sessions** Enter the maximum number of MWI sessions allowed at one time. The maximum number cannot exceed the maximum number of ports in the port group that will be used for MWI.
- **Port Group Name**  Select the port group to be used for MWI. The Default Group is selected by default.

  Port groups are created in the Port Groups dialog box. For more information, see Rules for Creating Port Groups on page 4-27.

- **IP Supported Codecs**  Enter the supported codec standards, in descending order of priority. An IP codec is the voice line coding algorithm that is used for communication between the MAS and the PBX. IP H.323 integration supports A-law and µ-law (mu-law) codecs.

- **Move Up/Move Down**  Click to move the selected codec up or down the IP Supported Codecs list.

- **Add...**  Click to launch the Add Codec window. Select an item from the Codec pick list and click OK. This closed the window and adds the selected codec to the IP Supported Codecs list in the PBX Integration dialog box, IP H323 tab.

- **Remove**  Click to remove the selected codec from the IP Supported Codecs list.
MAS - PBX Integration - IP SIP Tab

Use the PBX Integration dialog box, IP SIP tab to configure SIP-based IP integration. This provides IP connectivity between the Private Branch Exchange (PBX) and the Messaging Application Server (MAS). This is available with Avaya DEFINITY®, IP600, MultiVantage™, and Communication Manager PBXs only.

**Note:** After configuring these settings, you must stop and restart the MM Messaging Application Server service for the settings to take effect. See Appendix C, Modular Messaging (MM) Services.

Launching the Screen

1. In the Voice Mail System Configuration window, click Message Application Servers.

   You may need to expand the tree to see all the MASs in the voice mail domain.

2. Click the MAS you want to integrate.

   You may need to expand the tree to see the available PBXs

3. Double-click PBX Integration. The system displays the PBX Integration dialog box for that MAS, with the IP SIP tab active.

Configuring the Screen Controls

- **MAS Details**
  - **Corporate IP Address** Enter the IP address of the MAS. This is the IP address that the MAS uses to connect to the corporate LAN.
  - **SIP Domain** Enter a fully qualified IP domain name to assign to the SES Server.

  **Note:** If you are unsure about this field, most often the SIP domain should be the root level DNS domain. For example, for the DS domain of eastcoast.example.com, the SIP domain would likely be configured to example.com.

  - **RTP Port Range** Enter a minimum and maximum port number to specify a block of real-time protocol (RTP) IP port numbers.
  - **Packet Size Bytes** Enter the size of the IP packets that are used for the real-time protocol.
MAS Listen Protocols

- **TLS Port Number**  Enter the IP port number used for the transport layer security (TLS) protocol.
- **TCP Port Number**  Enter the IP port number used for the transaction control protocol (TCP).
- **Enable**  Select to enable communication using the transaction control protocol.

SIP Proxies  Select the check mark to enable or disable the use of each SIP proxy in the grid.

- **Proxy**  Displays the proxy number. This number is generated automatically.
- **IP Address/FQDN**  Enter the IP address or fully qualified domain name (FQDN) of the proxy.
- **TCP/TLS**  Enter either TCP or TLS, depending on which protocol the proxy uses to communicate with the MAS. The default is TLS.
- **Port**  Enter the port number used by the protocol. The default is 5061.

Advanced...

**Note:** The Advanced setting is not currently in use by Avaya Modular Messaging.
MAS - PBX Type Dialog Box

**Note:** For a detailed overview of Messaging Application Server (MAS) configuration in the *Voice Mail System Configuration* (VMSC) application, see *Overview of MAS Configuration in VMSC* on page 4-2.

This topic describes how to use the **PBX Type** dialog box to specify which Private Branch Exchange (PBX) is used for the selected MAS. You must configure this setting when you physically change the PBX connected to an MAS, or add an MAS to a voice mail domain.

### Launching the Screen

1. In the *Voice Mail System Configuration* window, click the voice mail domain.

2. Click **Message Application Servers**.

3. Click the MAS you want to configure.

4. Double-click **PBX Type**. The system displays the **PBX Type** dialog box for the selected MAS, with the **General** tab active. There is only one tab.

### Configuring the Screen Controls

**Note:** To configure this dialog box, you must be a member of a security role assigned the **Telephony - Administer** task. If you are a member of a role assigned the **Telephony - View** task, you have read-only access to this dialog box. See *Security Roles Dialog Box* on page 3-88.

- **Telephony Type**  Select the type of PBX you require. The PBX list is then updated to show the PBXs available for that type.

- **PBXs**  Click to select the required PBX from those available for the selected **Telephony Type**.

**Note:** The **PBX Type** node is removed from the *Voice Mail System Configuration* tree, if the MultiSite feature is enabled, because you can only add IP SIP PBXs for the entire voice mail domain.
MAS - Serviceability Dialog Box

Note: For a detailed overview of Messaging Application Server (MAS) configuration in the Voice Mail System Configuration (VMSC) application, see Overview of MAS Configuration in VMSC on page 4-2.

This topic describes how to use the Serviceability dialog box to configure Individual MAS Alarming. You can also configure how alarm notifications are sent out at MAS level, using the Avaya Initialization and Administration System (INADS).

Note: You must configure serviceability at MAS level, as described in this topic, and at voice mail domain level. See Serviceability Dialog Box on page 3-189.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Click Message Application Servers.
3. Click the MAS you want to configure.
4. Double-click Serviceability. The system displays the Serviceability dialog box for the selected MAS, with the General tab active.

Tabs Available in this Dialog Box

Note: To configure this dialog box, you must be a member of a security role assigned the Serviceability - Administer task. If you are a member of a role assigned the Serviceability - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

- **General**  Use this tab to assign a unique product identifier for the MAS. This number is then used to identify the MAS when it raises an alarm. You can also temporarily suppress alarm notifications from the MAS, and configure Simple Network Management Protocol (SNMP) parameters. See MAS - Serviceability - General Tab on page 4-63.

- **Modem Configuration**  Use this tab to configure how alarm notifications are sent out at MAS level, using INADS. See MAS - Serviceability - Modem Configuration Tab on page 4-65.
VMSC - Messaging Application Server (MAS) Configuration

MAS - Serviceability - General Tab

Use the Serviceability dialog box, General tab to assign a unique product identifier for the Messaging Application Server (MAS). This number is then used to identify the MAS when it raises an alarm. You can also temporarily suppress alarm notifications from the MAS, and configure Simple Network Management Protocol (SNMP) parameters.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Click Message Application Servers.
3. Click the MAS you want to configure.
4. Double-click Serviceability. The system displays the Serviceability dialog box for the selected MAS, with the General tab active.

Configuring the Screen Controls

- ** Suppress alarm notifications** Select to temporarily suppress alarm notifications from this MAS.

  You would typically select this, if you were engaged in maintenance and/or repair activities that would result in the generation of additional alarms and errors. In this situation, be sure to remember to clear this check box when you are finished, otherwise alarm notifications will not resume.

  **Note:** If the same setting is selected in the voice mail domain-wide Serviceability dialog box, General tab, it overrides this setting. If it is not selected, the setting on this screen is used for the MAS. See Serviceability - General Tab on page 3-191.

- **Product identifier** Enter the unique 10-digit number used to identify this MAS. This number is then used to identify the MAS when it raises an alarm.

  **Note:** If this field is left blank then the default number is assigned, 2000000000.

- **System Location** Enter a description of the location at which the message store server (Avaya MSS) resides. For example, the name of the company using the system, or the room number within the company where the system is located. The field length is 256 characters, the default value is -- Unknown --.

  **Note:** This field is not required but Avaya strongly recommends that you use it.
- **System Contact** Enter the name of the network manager who administers the Modular Messaging system. The field length is 256 characters, the default value is -- *The Messaging Administrator* --.

  **Note:** This field is not required but Avaya strongly recommends that you use it.

- **Inbound SNMP Port Number** Enter the inbound port number for SNMP queries. The range is 1 through 65535, the default is 161.
MAS - Serviceability - Modem Configuration Tab

In Modular Messaging, serviceability includes the ability of the Messaging Application Server (MAS) to generate logs and notifications related to system errors and alarms. Notifications can be sent out automatically to a designated support site, either Avaya Technical Support, your own Network Management Station (NMS), or a trusted business partner.

Use the Serviceability dialog box, Modem Configuration tab to configure how alarm notifications are sent out at MAS level using the Avaya Initialization and Administration System (INADS).

Note: Modular Messaging only uses these settings, if you have set the Alarm Origination value to Modem dialout in the voice mail domain-wide Serviceability dialog box, General tab. For more information, see Serviceability - General Tab on page 3-191.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Click Message Application Servers.
3. Click the MAS you want to configure.
4. Double-click Serviceability. The system displays the Serviceability dialog box for the selected MAS, with the General tab active.
5. Click the Modem Configuration tab.

Configuring the Screen Controls

- **COM port**  Select the COM port you want to use for sending and receiving alarm notifications.

- **Phone number**  Enter the telephone number of the INADS system to which you want to send alarm notifications.

The number can be any alphanumeric character and the following characters: W, *, and #.

- **W**  Instructs the system to wait for a dial tone.
- **,**  Creates a pause.
- *****  Signals trunk or feature access codes.
- **#**  Also signals trunk or feature access codes.
- **Modem setup** Enter the modem initialization string required for the modem to make the alarm notification calls. If you do not know what this is, consult your modem documentation or contact your Avaya Technical Support representative.
MAS - Trace File Size Dialog Box

Note: For a detailed overview of Messaging Application Server (MAS) configuration in the Voice Mail System Configuration (VMSC) application, see Overview of MAS Configuration in VMSC on page 4-2.

This topic describes how to use the Trace File Size dialog box to configure the default size of tracing file for the selected MAS.

This file stores operation history events before they are sent to the tracing server. You may need to increase the size of the tracing file, particularly if you expect heavy traffic or know that the tracing server will be out of service for an extended period of time.

Notes:

- To configure the Tracing System for the entire voice mail domain, see Tracing System Dialog Box on page 3-206.
- For more information on operation history events, see Chapter 8, “Operation History Viewer”.

Launching the Screen

1. In the Voice Mail System Configuration window, click the voice mail domain.
2. Click Message Application Servers.
3. Click the MAS you want to configure.
4. Double-click Trace File Size. The system displays the Trace File Size dialog box for the selected MAS, with the Operation History File Size tab active. There is only one tab.

Configuring the Screen Controls

Note: To configure this dialog box, you must be a member of a security role assigned the Tracing - Administer task. If you are a member of a role assigned the Tracing - View task, you have read-only access to this dialog box. See Security Roles Dialog Box on page 3-88.

- Size of Operation History Trace File (MB) Enter the desired file size, in megabytes.
  
  The range is 1 through 99, and the default is 4.
Visual Voice Editor (Custom Prompts)

This chapter describes how to configure the screens available in the Visual Voice Editor. This has a graphical user interface for recording custom prompts for use by the Automated Attendant.

Procedural Topics

- Understanding Custom Prompts on page 5-2.
  - Understanding the Automated Attendant Prompts on page 5-3.
  - Editing the CustomPrompt.OVF File on page 5-5.
  - Customizing Prompts on page 5-7.
  - Deploying the Custom Prompts on page 5-16.
  - Configuring the Deployed Custom Prompts on page 5-17.

Visual Voice Editor Screens Topics

- Visual Voice Editor (VVE) Window on page 5-19.
  - Prompts View & Comments View on page 5-21.
  - Waveform View on page 5-23.
  - All Visual Voice Editor Menus & Icons on page 5-28.
Understanding Custom Prompts

Avaya Modular Messaging system ships with a set of standard, pre-recorded prompts for the system Automated Attendant. The prompts are in the CustomPrompts.OVF file.

You can use these generic prompts, if you wish. However, Avaya recommends that you use the Visual Voice Editor to customize these prompts for your company.

- **Auto Attendant Main Menu Prompt**  This is the main prompt voiced by the Automated Attendant.

  This is enabled using the Voice Mail System Configuration window’s Auto Attendant dialog box, Attendant Main Menu Editor tab. See Auto Attendant - Attendant Main Menu Editor Tab on page 3-62.

- **Holiday Prompts**  These prompts greet callers on days specified as holidays.

  This is enabled using the Voice Mail System Configuration window’s Auto Attendant dialog box, Holidays tab. See Auto Attendant - Holidays Tab on page 3-65.

- **Morning, Afternoon, Evening & Closed Prompts**  These prompts greet callers during designated business hours.

  This is enabled using the Voice Mail System Configuration window’s Auto Attendant dialog box, Time of Day tab. See Auto Attendant - Time of Day Tab on page 3-66.

- **Custom Language Selection Greeting Prompt**  This prompt asks callers to select the language they require.

  This is enabled using the Voice Mail System Configuration window’s Auto Attendant dialog box, Language/Key Association tab. See Auto Attendant - Language/Key Association Tab on page 3-67.

**Procedures for Customizing Prompts**

The following topics are procedural overviews for customizing and deploying your custom prompts.

- **Understanding the Automated Attendant Prompts** on page 5-3.

- **Editing the CustomPrompt.OVF File** on page 5-5.

- **Customizing Prompts** on page 5-7.

- **Deploying the Custom Prompts** on page 5-16.

- **Configuring the Deployed Custom Prompts** on page 5-17.
Understanding the Automated Attendant Prompts

Avaya Modular Messaging systems ship with a set of standard, pre-recorded prompts for the system Automated Attendant. Avaya recommends that you use the Visual Voice Editor to customize these prompts for your company.

Auto Attendant Main Menu Prompt

You can record the main menu prompt used by the system Automated Attendant. The purpose of this prompt is to help callers navigate the Telephone User Interface (TUI) by prompting them on how to proceed. For example, “For Sales, press 1. For Technical Support, press 2. For Accounting, press 3”.

If the Auto Attendant Main Menu Prompt is not customized, the default is: “Please enter the mailbox number of the person you are calling. If you have a mailbox on this system, press #. For assistance, press 0.”

Then, if callers are allowed to use Dial by Name: “If you do not know the mailbox number, press * to spell the name.”

Followed by: “If you do not have a DTMF telephone or require assistance, please stay on the line.”

Holiday Prompts

You can configure up to 18 holiday prompts for a voice mail domain. The TUI plays holiday prompts to callers on days you specify as holidays. For example: “Seasons Greetings from Avaya. Our offices will reopen on Monday. Please leave a message at the tone and we’ll be sure to return your call then.”

If you do not create any holiday prompts, the system treats all days as the same.

Morning, Afternoon, Evening & Closed Prompts

You can customize the following prompts. If you do not customize these prompts, callers always just hear: “Welcome to Avaya Messaging.”

- **Morning Prompt**  Greets callers during morning business hours. For example, “Good morning, thank you for calling Avaya …”

- **Afternoon Prompt**  Greets callers during afternoon business hours. For example, “Good afternoon, thank you for calling Avaya …”

- **Evening Prompt**  Greets callers during evening business hours. For example, “Good evening, thank you for calling Avaya …”

- **Closed Prompt**  Greets callers after business hours. For example, “Thank you for calling Avaya. Our business hours are between 9.00 A.M. and 5.30 P.M., Monday through Friday. Please leave a message after the tone and we’ll return your call as soon as possible”.
Custom Language Selection Greeting Prompt

If your system supports multiple languages, you can customize the prompt that asks callers to select the language they require. If you do not customize this prompt, callers hear the following default language selection greeting: “For <language 1> press 1, for <language 2> press 2...”
Editing the CustomPrompt.OVF File

You store customized prompts in the prompt file in the MAS directory. This file is called CustomPrompts.OVF. Before you record customized prompts, you must create a working copy of this file.

Notes:

- Avaya strongly recommends that you create a backup of the working copy of the CustomPrompts.OVF file before you record or edit your customized prompts. That way, you can recover from any editing mistakes by using the backup file.

- CustomPrompts.OVF contains prompts that you can modify. All other files with the OVF extension contain standard system prompts. These files should not be modified.

- If you are upgrading from an earlier version of the software, rename English3.OVF to CustomPrompts.OVF. Any changes that you made to English3.OVF are retained.

Procedure 1: Creating a Working Copy of CustomPrompts.OVF

1. Locate a messaging application server (MAS) in the voice mail domain.

2. Stop the MM Messaging Application Server service. See Appendix C, "Modular Messaging (MM) Services".

3. Locate and make a working copy of the CustomPrompts.OVF file.

   Note: The MAS directory containing the prompt files is specified at the time of installation. Typically, it is C:/Program Files/Avaya Modular Messaging/VServer/.

4. If required, change the audio format. Follow “Procedure 2”, below.

5. Make a backup of the working copy. Avaya recommends that you name the file CustomPrompts.OLD.

6. Restart the MM Messaging Application Server service.
Procedure 2: Changing the Audio Format

By default, the audio format for CustomPrompts.OVF is **Brooktrout's ADPCM**.

**Notes:**

- Avaya provides a CustomPrompt_G711.OVF file, which has the **PCM CCITT µ-law** (mu-law) audio format. If you wish to use this format, you should create a working copy of the file and rename it, CustomPrompts.OVF.

- Ensure that the form of G.711 encoding matches that of the Private Branch Exchange (PBX). In general, µ-law (mu-law) is used in North America and Japan, and A-law is used in Europe. If your choice of encoding scheme does not match the PBX, then audio will sound garbled.

If you are using **PCM CCITT A-law**, you must follow the procedure below to change the format.

1. Follow "Procedure 1", above.

2. On your **Windows** desktop, click the **Start > Programs > Avaya Modular Messaging > Visual Voice Editor** menu to launch the **Visual Voice Editor** window.

3. Click **File > Open** to launch the standard Windows **Open** dialog box.

4. Locate and open your working copy of the CustomPrompts.OVF file.

5. Click **File > Save As** to launch the standard Windows **Save As** dialog box.

6. Use the **Save as type** pick list to select **PCM CCITT A-law**.

7. Click **Save**.
Customizing Prompts

Launching the Visual Voice Editor

On your Windows desktop, click the Start > Programs > Avaya Modular Messaging > Visual Voice Editor menu to launch the Visual Voice Editor window.

For detailed information about the Visual Voice Editor screens and tools, see these topics:

- Visual Voice Editor (VVE) Window on page 5-19.
  - Prompts View & Comments View on page 5-21.
  - Waveform View on page 5-23.
  - All Visual Voice Editor Menus & Icons on page 5-28.

Procedures for Customizing Prompts

Once you have launched the Visual Voice Editor, you can follow the procedures detailed in the topics below.

- Customizing Prompts - Setting Up the Audio Device on page 5-8.
- Customizing Prompts - Recording Customized Prompts on page 5-10.
- Customizing Prompts - Playing Customized Prompts on page 5-12.
Customizing Prompts - Setting Up the Audio Device

For an overview of customizing prompts, see Customizing Prompts on page 5-7. For more on Visual Voice Editor, see Visual Voice Editor (VVE) Window on page 5-19.

You can set up the audio device for customizing prompts in the Visual Voice Editor.

Procedure 1: Setting Up the Audio Device “On the Fly”

The current audio device is indicated on the Voice Player by the following icons:

- [Icon: Telephone]
- [Icon: Multimedia]

You can record customized prompts using local multimedia or a telephone. For ease of recording and editing, Avaya recommends that you use the multimedia option. However, in some situations, you may find that you can achieve higher quality recordings using the telephone, especially if you are in an environment where a microphone would pick up background noise.

1. To quickly change the audio device for recording customized prompts, in the Voice Player right-click the icon and then click 1 Multimedia or 2 Telephone.

2. To set up permanent preferences, you can use the Media Setup dialog box. See “Procedure 2” below.

Procedure 2: Setting Preferences for the Telephone or Multimedia Audio Device

1. Click Sound > Preferences. The system displays the Modular Messaging User Properties dialog box, with the Media Setup tab active.

2. In the When composing voice messages field, click one of the following:
   - Telephone This activates the Configure button. Proceed to Step 3.
   - Multimedia Proceed to Step 5.

3. Click Configure. The system displays the Telephone Properties screen.
   - Extension number Enter the number of the extension that will be used for recording and playing prompts.
   - Mailbox number Enter the full or partial mailbox number that will be used to identify you to the desired MAS in the voice mail domain.
- **Message Application Server name** Enter the name of an MAS in the voice mail domain. If necessary, use the **Browse** button to locate the desired MAS.

4. Click **OK**.

5. The system displays the selected icon in the **Voice Player**.

6. For the configuration changes to take effect, close and restart **Visual Voice Editor**.
Customizing Prompts - Recording Customized Prompts

For an overview of customizing prompts, see Customizing Prompts on page 5-7. For more on Visual Voice Editor, see Visual Voice Editor (VVE) Window on page 5-19.

You can record custom prompts using the Visual Voice Editor.

**Important:** Use the working copy of CustomPrompts.OVF when recording and editing your customized prompts. Ensure that the OVF file is saved in the audio format that you are using. See Editing the CustomPrompt.OVF File on page 5-5.

**Procedure 1: Recording a Customized Prompt in Visual Voice Editor**

1. Click File > Open to launch the standard Windows Open dialog box.
2. Locate and open your working copy of the CustomPrompts.OVF file.
3. Click Edit > Insert. The system displays the Goto/Insert Prompt dialog box.
4. Type a unique number in the Enter a Prompt Number field and click OK to insert a new prompt.
5. Enter a description in the Comment View text box. You can use standard Windows cut, copy, and paste commands to edit text in this box.
6. Click the Comments cell for the prompt selected in the Prompts View grid. This adds the description to the prompt.
7. Verify that the correct audio device is selected. See Customizing Prompts - Setting Up the Audio Device on page 5-8.
8. Click Sound > Record and record your prompt, as follows.
   - If using local multimedia, begin speaking into the microphone.
   - If using the telephone, pick up the receiver when the telephone rings, and record the prompt after the tone.
9. When you are finished, click Sound > Stop.
10. Play back your recording to verify that it is what you want. See Customizing Prompts - Playing Customized Prompts on page 5-12.
11. If you want to re-record the prompt, repeat Steps 7 through 9.
12. If you want to edit the prompt, see Customizing Prompts - Editing Customized Prompts on page 5-13.

13. Once you are satisfied with the recording, click File > Save.

14. If you want to record more prompts, repeat Steps 3 through 11.

**Note:** When you have finished a recording or editing session, click File > Compact. This removes extra data and unused space in the file that may result from some editing operations.

15. Copy the changes to the prompt file across all MASs in the voice mail domain. See Deploying the Custom Prompts on page 5-16.

16. Configure the customized prompts for the voice mail domain. See Configuring the Deployed Custom Prompts on page 5-17.
Customizing Prompts - Playing Customized Prompts

For an overview of customizing prompts, see Customizing Prompts on page 5-7. For more information on Visual Voice Editor, see Visual Voice Editor (VVE) Window on page 5-19.

You can play (to review) any of the customized prompts that you have recorded.

Procedure 1: Playing a Customized Prompt in Visual Voice Editor

1. Click Sound > Play.

   Note: If a range of audio data is selected in Waveform View, the system plays only that range. For more information, see “Procedure 1” in Customizing Prompts - Editing Customized Prompts on page 5-13.

2. If necessary, adjust the playback using one of the commands listed below:
   - Sound > Skip Back  Moves to the previous part of a multi-part prompt.
   - Sound > Skip Forward  Moves to the next part of a multi-part prompt.
   -  Moves back five seconds in the current prompt part.
   -  Moves forward five seconds in the current prompt part
   - Sound > Stop  Stops the recording, playing back, forwarding or rewinding of prompt. You are returned to the beginning of the prompt.
   - Sound > Pause  Interrupts the playback/recording of a voice prompt.
   - Sound > Volume Up  Increases the prompt playback volume.
   - Sound > Volume Down  Decreases the prompt playback volume.

   Note: You can also use the slider bar to move backward and forward in the prompt.
Customizing Prompts - Editing Customized Prompts

For an overview of customizing prompts, see Customizing Prompts on page 5-7. For more on Visual Voice Editor, see Visual Voice Editor (VVE) Window on page 5-19.

Procedure 1: Selecting a Range of Audio Data

Most of the Visual Voice Editor editing functions require that you select the section or “range” of the prompt that you want to edit.

Figure 5-4. Selected Range of Audio Data in the Waveform View

1 Selected range

Selecting audio data is similar to selecting text in a word processor.

- Using the mouse Click the desired edit start point in Waveform View, drag to the desired edit end point, and then release. The selected range is highlighted.

- Using the keyboard Click the desired edit start point in Waveform View, hold down the Shift key, and then use the left arrow or right arrow key to highlight your selection. Using the keyboard enables more precise data selection.

These commands and fields are useful, when selecting the data:

- You can use the View > Zoom In command to zoom in for greater accuracy.

- For fine control, use the Current Position and Selection Size markers on the Waveform Infobar to guide you.

- To select the whole prompt, click Edit > Select All.
Procedure 2: Cutting, Copying, Pasting & Trimming

You can edit audio data in the Waveform View. The method is similar to editing text in a word processor. You select the range you want to edit (see “Procedure 1” above) then click the required Edit menu item.

- **Edit > Cut**  Cuts the selected section of the prompt and places it on the Windows Clipboard. Visual Voice Editor then shifts the rest of the prompt back to fill in the gap, similar to deleting text in a word processor.

- **Edit > Copy**  Copies the selected section of the prompt and places it on the Windows Clipboard.

- **Edit > Paste**  Pastes the audio data from the Windows Clipboard at the selected point in the selected prompt. Data after that point is shifted to the right, similar to inserting text in a word processor.

- **Edit > Trim**  Deletes all data except for the currently selected range. This is useful for eliminating leading or trailing silence at the beginning and end of a prompt.

These commands are useful, when selecting the data to edit:

- **Edit > Undo**  This undoes the last editing action.

  **Note:**  This can be useful, if you wish to toggle an edit on or off in order to see its effect.

- **Edit > Goto**  Opens the Goto/Insert Prompt dialog box.

  You can type a number in the Enter a Prompt Number field and click OK to move quickly to a specified prompt.

- **File > Compact**  Removes extra data and the unused space in the file that may result from the editing operation.
Procedure 3: Adjusting Amplitude & Silence

When recording, you can increase or decrease the audio level, overwrite a range with silence to remove background noise, and insert silence to add pauses.

**Note:** Adjusting amplitude and silence is only possible when the **Waveform View** is active and an audio selection has been made. See “Procedure 1” above.

- **Waveform > Increase Amplitude** Increases the audio volume by 10%. This can be done for either the entire prompt or just the selected range.

- **Waveform > Decrease Amplitude** Decreases the audio volume by 10%. This can be done for either the entire prompt or just the selected range.

- **Waveform > Overwrite Silence** Overwrites the selected range with silence. This can be useful for removing background noise.

- **Waveform > Insert Silence** Inserts silence equivalent to the selected range at the current edit point. This has the effect of adding a clean pause in the recording.
Deploying the Custom Prompts

Once you have set up your customized prompts, you must copy the changes across all the MASs in the voice mail domain.

Procedure 1: Copying Changes across Message Application Servers

1. Locate a messaging application server (MAS) in the voice mail domain.

2. Stop operation of the MM Messaging Application Server service. See Appendix C, “Modular Messaging (MM) Services”.

3. Copy the modified prompt file (CustomPrompts.OVF) to the MAS directory containing the prompt files.

4. Restart the MM Messaging Application Server service.

5. Repeat Steps 1 through 4 for all other MASs in the voice mail domain.

6. Configure the prompts for the voice mail domain using the Voice Mail System Configuration application. See Configuring the Deployed Custom Prompts on page 5-17.
Configuring the Deployed Custom Prompts

For more information about Automated Attendant custom prompts, see Understanding the Automated Attendant Prompts on page 5-3.

When you have copied your changes across all MASs in the voice mail domain, you must configure the prompts using Voice Mail System Configuration (VMSC).

**Note:** Make sure you make a note of the prompt numbers before beginning the configuration.

Procedure 1: Configuring the Auto Attendant Main Menu prompt

1. On your Windows desktop, click the Start > Programs > Avaya Modular Messaging > Voice Mail System Configuration menu to launch the Voice Mail System Configuration window.

2. In the Voice Mail System Configuration window, click the voice mail domain.

3. Double-click Auto Attendant. The system displays the Auto Attendant dialog box for the selected VMD, with the Attendant Main Menu Editor tab active. See Auto Attendant - Attendant Main Menu Editor Tab on page 3-62.

4. In the Auto Attendant Main Menu Prompt field, enter the prompt number.

5. Click OK.

**Note:** The options on the Auto Attendant Main Menu prompt tab are unavailable, if any languages have been selected in the Language/Key Association tab.

Procedure 2: Configuring Holiday Prompts

1. Launch the Voice Mail System Configuration window’s Auto Attendant dialog box, as described in “Procedure 1” above.

2. Click the Holidays tab. See Auto Attendant - Holidays Tab on page 3-65.

3. Enter the prompt numbers and corresponding dates in the relevant Prompt and Date fields.

4. Click OK.
Procedure 3: Configuring Time of Day Prompts

1. Launch the Voice Mail System Configuration window’s Auto Attendant dialog box, as described in “Procedure 1” above.

2. Click the Time of Day tab. See Auto Attendant - Time of Day Tab on page 3-66.

3. Enter the prompt numbers in the Morning Prompt, Afternoon Prompt, Evening Prompt and Closed Prompt fields.

4. Click OK.

Procedure 4: Configuring the Custom Language Selection Greeting

1. Launch the Voice Mail System Configuration window’s Auto Attendant dialog box, as described in “Procedure 1” above.

2. Click the Language/Key Association tab. See Auto Attendant - Language/Key Association Tab on page 3-67.

3. In the Custom Language Selection Greeting field, enter the appropriate prompt number.

4. Click OK.
Visual Voice Editor (Custom Prompts)

Visual Voice Editor (VVE) Window

The **Visual Voice Editor** has a graphical user interface for recording company prompts for use by the automated attendant. You can record customized prompts using the local multimedia capabilities on a personal computer. The **Visual Voice Editor** displays audio data as a waveform to enable precise editing of a prompt.

On your **Windows** desktop, click the **Start > Programs > Avaya Modular Messaging > Visual Voice Editor** menu to launch the **Visual Voice Editor** window. See Figure 5-5.

![Visual Voice Editor Window](image)

**Figure 5-5. Visual Voice Editor Window.**

The **Prompts View** lists all the prompts that are stored in the currently selected prompt file. When you add a prompt or select one from the list, you can use the **Comment View** to edit its description.

See [Prompts View & Comments View](#) on page 5-21.

The currently selected prompt is graphically represented as a waveform in the **Waveform View**. You can edit audio data, using the **Overview** and **Detailed** sections of the **Waveform View**, the **Waveform Toolbar**, the **Waveform Info** fields and the **Voice Player**.

See [Waveform View](#) on page 5-23.
Related Topics

- Understanding Custom Prompts on page 5-2.
- All Visual Voice Editor Menus & Icons on page 5-28.
Prompts View & Comments View

In the Visual Voice Editor, the Prompts View lists all the prompts that are stored in the currently selected prompt file. When you add a prompt or select one from the list, you can use the Comment View to edit its description.

For an overview of the Visual Voice Editor window, see Visual Voice Editor (VVE) Window on page 5-19. For procedures for creating custom prompts with Visual Voice Editor, see Understanding Custom Prompts on page 5-2.

Showing the Prompts View & Comment View

- View > Prompts View  Shows/hides the Prompts View in the left hand frame of the Visual Voice Editor window. The Prompts View displays three columns:
  - Prompt  The prompt number.
  - Length  The duration of prompt playback in seconds.
  - Comment  A textual description of the prompt.

- View > Comments View  Shows/hides the Comments View text box in the bottom-right hand frame of the Visual Voice Editor window.

Putting Focus on the View

You can click a view to give it focus or use these menu commands:

- Window > Comment  Puts focus on the Comment View.
- Window > Prompt  Puts focus on the Prompts View.

Adding a Prompt

You can add a new prompt to the Prompts View list:

1. Click Edit > Insert to open the Goto/Insert Prompt dialog box.
2. Type a unique number in the Enter a Prompt Number field and click OK to insert a new prompt.
3. Enter a description in the Comment View text box. You can use standard Windows cut, copy, and paste commands to edit text in this box.
4. Click the Comments cell for the prompt selected in the Prompts View grid. This adds the description to the prompt.
5. You can then record the prompt using the **Waveform View**. See [Waveform View](#) on page 5-23.

### Selecting a Prompt

You can click to select a prompt in the **Prompts View** list or use goto:

1. Click **Edit > Goto** to open the **Goto/Insert Prompt** dialog box.

2. Type a number in the **Enter a Prompt Number** field and click **OK** to move quickly to a specified prompt.

3. Edit the description in the **Comment View** text box, if you wish. You can use standard Windows cut, copy and paste commands to edit text in this box.

4. Click the **Comments** cell for the prompt selected in the **Prompts View** grid. This updates the description of the prompt.

5. You can then listen to the prompt using the **Waveform View**.

### Printing the Prompts List

- **File > Print** Launches the standard Windows **Print** dialog box. You can print a list of the prompts stored in the selected prompt file.

  This command is active for the **Prompt View** only.
Waveform View

In the Visual Voice Editor window, the prompt currently selected in the Prompts View is graphically represented as a waveform in the Waveform View.

For an overview of the Visual Voice Editor window, see Visual Voice Editor (VVE) Window on page 5-19. For procedures for creating custom prompts with Visual Voice Editor, see Understanding Custom Prompts on page 5-2.

Showing the Waveform View

View > Waveform View Shows/hides the Waveform View in the top-right hand frame of the Visual Voice Editor window. This view has three parts. See Figure 5-6.

Figure 5-6. Waveform View

1 Overview
2 Detailed
3 Voice Player

You can edit audio data, using the Overview and Detailed sections of the Waveform View, the Waveform Toolbar, the Waveform Info fields, and the Voice Player. For more information, see:

Waveform View - Toolbar, Info, Overview & Detailed View

For an overview of the Waveform View, see Waveform View on page 5-23.

You can click a view to give it focus or use the Window menu commands:

- **Window > Overview** Puts focus on the top section of the Waveform View.
  
  The Overview shows the entire recording. A white frame indicates the extent of the recording in the Detailed waveform view. Once zooming is applied to the view, you can drag the frame to move around the recording.

- **Window > Detailed** Puts focus on the middle section of the Waveform View.
  
  You can perform precise editing of audio data in the Detailed view. A white vertical bar indicates the current edit point. You can use the mouse or keyboard to select audio data in a similar way to selecting text in a word processor.

Waveform Toolbar

The Waveform Toolbar appears beneath the main toolbar at the top left of the Visual Voice Editor window.

- **View > Zoom In** Zooms in on the waveform so that you can see more detail.

- **View > Zoom Out** Zooms out on the waveform.

- **Waveform > Increase Amplitude** Increases the audio volume by 10%. This can be done for either the entire prompt or just the selected range.

- **Waveform > Decrease Amplitude** Decreases the audio volume by 10%. This can be done for the either the entire prompt or just the selected range.

- **Waveform > Overwrite Silence** Overwrites the selected range with silence. This can be useful for removing background noise.

- **Waveform > Insert Silence** Inserts silence equivalent to the selected range at the current edit point. This has the effect of adding a clean pause in the recording.
Waveform Info

The Waveform Info fields appear beneath the Waveform Toolbar at the top left of the Visual Voice Editor window. You can use these fields to guide you, when selecting a section of a prompt to edit:

- **Current Position** Displays the current edit position of the Detailed waveform selection, in seconds.
- **Selection Size** Displays the current size of the Detailed waveform selection, in seconds.

Editing Tools & Commands

You can use these commands to edit the prompt in the Waveform View.

- **Edit > Undo** This undoes the last editing action.

  **Note:** This can be useful, if you wish to toggle an edit on or off, in order to see its effect.

- **Edit > Cut** Cuts the selected section of the prompt and places it on the Windows Clipboard.

  Visual Voice Editor then shifts the rest of the prompt back to fill in the gap, similar to deleting text in a word processor.

- **Edit > Trim** Deletes all data except for the currently selected range. This is useful for eliminating leading or trailing silence at the beginning and end of a prompt.

- **Edit > Copy** Copies the selected section of the prompt and places it on the Windows Clipboard.

- **Edit > Paste** Pastes the data from the Windows Clipboard at the selected point in the selected prompt.

  Data after that point is shifted to the right, similar to inserting text in a word processor.

  **Note:** Visual Voice Editor prevents pasting data not intended for that view. You can only paste text into the Comment View and audio data into the Waveform View.

- **Edit > Select All** Selects the entire prompt.
Waveform View - Voice Player

For an overview of the Waveform View, see Waveform View on page 5-23.

The Voice Player appears at the bottom of the Waveform View. You can play, pause, record, fast forward, and rewind a recording using standard CD player-type controls. The player shows the length of the recording in seconds and indicates the currently selected audio device.

Voice Player Controls

- Right-click the icon to change the audio device for recording the prompt “on the fly” to:
  - 1 Multimedia - If you use a multimedia PC with a microphone, you can begin recording immediately.
  - 2 Telephone - If you use a telephone to record the prompt, you must wait for the system to dial the telephone and the telephone to ring.

- The green and black display area consists of the timer information, part information, and total time display.
  - Timer Displays where you are in the current prompt.
  - Part Displays which prompt part you are in, how many prompt parts there are, and the total length of the current part.
  - Total Displays the total time of the prompt.

- Sound > Play Plays back the prompt.
- Sound > Stop Stops the recording, playing back, forwarding or rewinding of prompts. You are returned to the beginning of the prompt.
- Sound > Pause Interrupts the playback/recording of a prompt.
- Sound > Skip Back Moves to the previous part of a multi-part prompt.
- Moves back five seconds in the current prompt part.
- Moves forward five seconds in the current prompt part
- Sound > Skip Forward Moves to the next part of a multi-part prompt.
- Sound > Record Click this icon to record a prompt.
- The slider displays the total length of a prompt. By clicking and dragging on the slider, you can move around in a prompt.
When playing back a prompt, the progress bar shows the progress during download.

Other Related Sound Menu Commands

- **Sound > Volume Up**  Increases the prompt playback volume.
- **Sound > Volume Down**  Decreases the prompt playback volume.
- **Sound > Preferences**  Launches the Modular Messaging User Properties dialog box.

You can specify whether you wish to work using the **Telephone** or **Multimedia**. For example, you can record greetings using multimedia and review them using the telephone.
All Visual Voice Editor Menus & Icons

The Visual Voice Editor window has a top menu bar, a standard toolbar with Windows style editing tools, and a Waveform Toolbar with tools for configuring the Waveform View. There are also icons that can be used for recording and playback.

This topic provides a reference list of all menu and icon commands.

File Menu

- **File > Open** Launches the standard Windows Open dialog box. You can open an *.OVF file to configure.

- **File > Close** Closes the *.OVF file.

- **File > Save** Saves the *.OVF file with the same filename, directory and file type.

- **File > Save As** Launches the standard Windows Save As dialog box. You can use this to save the *.OVF file in a different audio format.

  By default, the CustomPrompts.OVF file is in Brooktrout ADPCM audio format but you can change the Save as type to PCM CCITT A-law or PCM CCITT µ-law (mu-law).

- **File > Import** Launches the standard Windows Open dialog box. You can open a *.WAV file to import it.

  **Note:** Before importing the *.WAV file, verify that it has been saved in the same audio format that you are using, Brooktrout ADPCM, PCM CCITT A-law or PCM CCITT µ-law (mu-law).

- **File > Export** Launches the standard Windows Save As dialog box. You can use this to save the selected prompt as a *.WAV file.

- **File > Compact** Removes extra data and the unused space in the file that may result from the editing operation.

- **File > Print** Launches the standard Windows Print dialog box. You can print a list of the prompts stored in the selected prompt file.

  This command is active for the Prompt View only.

- **File > Print Setup** Launches the standard Windows Print Setup dialog box.

- **File > Exit** Closes down the Visual Voice Editor.
Edit Menu

- **Edit > Undo**  This undoes the last editing action.

  **Note:**  This can be useful, if you wish to toggle an edit on or off in order to see its effect.

- **Edit > Cut**  Cuts the selected section of the prompt and places it on the Windows Clipboard.

  *Visual Voice Editor* then shifts the rest of the prompt back to fill in the gap, similar to deleting text in a word processor.

- **Edit > Trim**  Deletes all data except for the currently selected range. This is useful for eliminating leading or trailing silence at the beginning and end of a prompt.

- **Edit > Copy**  Copies the selected section of the prompt and places it on the Windows Clipboard.

- **Edit > Paste**  Pasters the data from the Windows Clipboard at the selected point in the selected prompt.

  Data after that point is shifted to the right, similar to inserting text in a word processor.

  **Note:**  *Visual Voice Editor* prevents pasting data not intended for that view. You can only paste text into the *Comment View* and audio data into the *Waveform View*.

- **Edit > Select All**  Selects the entire prompt.

- **Edit > Goto**  Opens the *Goto/Insert Prompt* dialog box.

  You can type a number in the *Enter a Prompt Number* field and click *OK* to move quickly to a specified prompt.

- **Edit > Insert**  Opens the *Goto/Insert Prompt* dialog box.

  You can type a unique number in the *Enter a Prompt Number* field and click *OK* to insert a new prompt.

View Menu

- **View > Prompts View**  Shows/hides the *Prompts View* in the left hand frame of the *Visual Voice Editor* window.

  This view lists all the prompts that are stored in the prompt file. You can use this view to select a prompt file with which to work.
Visual Voice Editor (Custom Prompts)

- **View > Waveform View**  Shows/hides the **Waveform View** in the top-right hand frame of the **Visual Voice Editor** window. The view has three parts, the **Overview**, **Detailed** view and the **Voice Player**.

  The currently selected prompt is graphically represented as a waveform. You can use this view to edit audio data.

- **View > Comments View**  Shows/hides the **Comments View** in the bottom-right hand frame of the **Visual Voice Editor** window.

  This view displays the description of the currently selected prompt. You can use this view to create or edit text descriptions of prompts.

- **View > Toolbar**  Shows/hides the main toolbar.

- **View > Status Bar**  Shows/hides the status bar.

- **View > Zoom In**  Zooms in on the waveform so that you can see more detail.

- **View > Zoom Out**  Zooms out on the waveform.

  The **Zoom In/Out** commands are active for the **Waveform View** only, when a prompt has been selected.

**Sound Menu**

- **Sound > Skip Back**  Moves to the previous part of a multi-part prompt.

- **Sound > Skip Forward**  Moves to the next part of a multi-part prompt.

- **Sound > Stop**  Stops the recording, playing back, forwarding or rewinding of prompts. You are returned to the beginning of the prompt.

- **Sound > Pause**  Interrupts the playback/recording of a prompt.

- **Sound > Record**  Click this icon to record a prompt.

- **Sound > Play**  Plays back the prompt.

- **Sound > Volume Up**  Increases the prompt playback volume.

- **Sound > Volume Down**  Decreases the prompt playback volume.

- **Sound > Preferences**  Launches the **Modular Messaging User Properties** dialog box.

  You can specify whether you wish to work using the **Telephone** or **Multimedia**. For example, you can record greetings using multimedia and review them using the telephone.

  The following icons do not have a corresponding menu command:
- Moves back five seconds in the current prompt part.
- Moves forward five seconds in the current prompt part
- Right-click the icon to change the audio device for recording the prompt "on the fly" to:
  - 1 Multimedia - If you use a multimedia PC with a microphone, you can begin recording immediately.
  - 2 Telephone - If you use a telephone to record the prompt, you must wait for the system to dial the telephone and the telephone to ring.

Waveform Menu

These commands are active for the Waveform View only.

- Waveform > Increase Amplitude Increases the audio volume by 10%. This can be done for either the entire prompt or just the selected range.
- Waveform > Decrease Amplitude Decreases the audio volume by 10%. This can be done for the either the entire prompt or just the selected range.
- Waveform > Overwrite Silence Overwrites the selected range with silence. This can be useful for removing background noise.
- Waveform > Insert Silence Inserts silence equivalent to the selected range at the current edit point. This has the effect of adding a clean pause in the recording.

Window Menu

- Window > Overview Puts focus on the top section of the Waveform View.
  The Overview shows the entire recording. A white frame indicates the extent of the recording in the Detailed waveform view.
- Window > Detailed Puts focus on the middle section of the Waveform View.
  The Detailed view allows you to do precise editing of audio data. A white vertical bar indicates the current edit point.
- Window > Comment Puts focus on the Comment View.
- Window > Prompt Puts focus on the Prompts View.
Help Menu

- **Help > Help Topics** Launches the *Visual Voice Editor (Custom Prompts)* Help.

- **Help > About Visual Voice Editor** Launches the *About Modular Messaging* window.

Related Topics

- [Understanding Custom Prompts](#) on page 5-2.

- [Visual Voice Editor (VVE) Window](#) on page 5-19.
  - [Prompts View & Comments View](#) on page 5-21.
  - [Waveform View](#) on page 5-23.
6

Caller Applications Editor

This chapter describes how to configure the screens available in the Caller Applications Editor. You can create caller applications with these screens and deploy them to a voice mail domain.

Procedural Topics

- Understanding Caller Applications on page 6-3.
  - Using the Caller Applications Software on page 6-4.
  - Planning Your Caller Applications on page 6-6.
  - Creating & Editing Caller Applications on page 6-7.
  - Importing or Recording Application Prompts on page 6-10.
  - Deploying Caller Applications to a VMD on page 6-13.
  - Analyzing Deployed Caller Applications on page 6-20.

Caller Applications Editor Screens Topics

- Modular Messaging Caller Applications Window & Nodes on page 6-22.
- Modular Messaging Software Caller Apps Properties Dialog Box on page 6-34.
- Open Caller Application Dialog Box on page 6-36
- New Caller Application Dialog Box on page 6-38.
- Add Node Dialog Box on page 6-40.
- Properties Dialog Box on page 6-43.
- Change Key Dialog Box on page 6-67.
- Message Application Server Dialog Box on page 6-68
- Caller Application Deployment Wizard on page 6-69.
- Caller Application Undeployment Wizard on page 6-70.
- Add Association/Association Properties Dialog Box on page 6-71.
- Application Analysis Properties Dialog Box on page 6-73.
- Analysis Results Properties Dialog Box on page 6-74.
Understanding Caller Applications

**Note:** The Modular Messaging Caller Applications window runs as a plug-in within the Microsoft Management Console. Generic menu commands and screens are not documented here but can be accessed using the Help menu.

Modular Messaging Caller Applications software enables you to enhance and extend the Telephone User Interface (TUI) and system Automated Attendant by creating and deploying caller applications. You can:

- Automate call handling and route incoming calls directly to departments within your organization.
- Use them to create daily "bulletin board" announcements for your callers and subscribers.
- Have greater flexibility and more options with respect to system and personal greetings.

**Note:** In the Modular Messaging environment, caller applications can be used to accomplish most of the same functions as "Automated Attendants", including "Nested Automated Attendants", in AUDIX.

**Procedures**

The following topics are procedural overviews which suggest an approach to using the Caller Applications Editor, when creating, editing and deploying caller applications.

- **Using the Caller Applications Software** on page 6-4
- **Planning Your Caller Applications** on page 6-6.
- **Creating & Editing Caller Applications** on page 6-7.
- **Importing or Recording Application Prompts** on page 6-10.
- **Deploying Caller Applications to a VMD** on page 6-13.
- **Creating Associations with the TUI** on page 6-17.
- **Analyzing Deployed Caller Applications** on page 6-20.

**Related Topics**

For more information, see Appendix B, Examples of Caller Applications.
Using the Caller Applications Software

Caller Applications Editor & Caller Applications Runtime

By default, both parts of the Caller Applications software are installed on Messaging Application Servers (MASs) as part of the software installation process:

- **Caller Applications Runtime** This software is an MAS sub-system that executes caller applications.

- **Caller Applications Editor** This software consists of Microsoft Management Console (MMC) snap-ins and extensions. It allows you to create caller applications and deploy them to a voice mail domain.

You can either run this tool within the MAS environment or you can install and use it as a standalone development tool on another machine outside the voice mail domain.

Using Caller Applications Editor on a Standalone PC

If you create caller applications on a standalone PC, then you must have network connectivity to the MAS before you can deploy and use the caller applications.

To install the Caller Applications Editor on a standalone PC:

1. Insert the installation DVD, labeled *Avaya Modular Messaging Application Software*, into the DVD drive.

   The system starts the Modular Messaging Installation Wizard automatically. If it does not start automatically, locate the setup.exe file on the DVD. Double-click setup.exe to start the wizard.

2. After the Modular Messaging Installation Wizard is launched, select the Caller Applications Editor option and clear any other options.

3. Click Install and continue to follow the prompts.

Enabling Caller Applications for the Voice Mail Domain

- In the Voice Mail System Configuration window > Telephone User Interface dialog > General tab, select Enable Caller Applications check box. See Telephone User Interface - General Tab on page 3-40.

- Any user can create caller applications. To deploy caller applications, you must be a member of a security role assigned the Caller Applications - Administer task. This is configured in the Voice Mail System Configuration application, Security Roles dialog box. See Security Roles Dialog Box on page 3-88.
To analyze deployed caller applications, you must be a member of a security role assigned the **Caller Applications - Administer** task, or the **Caller Applications - View** task. This is configured in the **Voice Mail System Configuration** application, **Security Roles** dialog box.
Planning Your Caller Applications

Avaya recommends that you use the following techniques to plan your system’s use of caller applications before using the Caller Applications Editor to create and deploy them.

Note: For some detailed examples of caller applications, see Appendix B, Examples of Caller Applications.

List the Desired Behaviors for your System:

- Exactly what do you want your system to do and how you want it to behave?
- What do you want callers who reach your system to experience?
- What kinds of choices do you want to give them, and at what level?
- How many menu levels do you want to offer?

Create a Flow Chart of the Caller Application

Create a flow chart or diagram to enable you to trace the caller experience and all possible options. It also helps you determine where you will need to record and use prompts.

Plan your prompts

Create a chart or spreadsheet to list and describe the prompts you think you will need. Also assign an ID number to each prompt.

Note: Only one prompt can be assigned to a given node. If you have a node in which you want to make several menu options available to callers, you must include the information for all those options in a single prompt that is assigned to that node.

Setting Up Your Targets

If you know that one or more of your caller options will be redirecting the caller to an extension or mailbox within the system, you must set up that extension or mailbox on the system first.

If you know that your caller application will be redirecting the caller to another caller application, you should create the secondary caller application first.
Creating & Editing Caller Applications

Caller applications are built around a “node” concept. That is, you start with a base caller application node that acts as the gateway into the caller application. Then, if required, you can add nodes under it to perform additional functions. These additional nodes are called application or action nodes.

A caller application can consist of many nodes at many levels or a single node. It may provide callers with many options at multiple levels, or it could play a simple greeting and automatically transfer the caller to an extension.

Note: The following procedures suggest an approach to using the Caller Applications Editor, when creating and editing caller applications. This is a procedural overview with links to the topics that describe each tree node and screen in detail.

Procedure 1: Setting Preference for Creating Caller Applications

1. On your Windows desktop, click the Start > Programs > Avaya Modular Messaging > Caller Applications menu. This launches the Modular Messaging Caller Applications window. See Modular Messaging Caller Applications Window & Nodes on page 6-22.

2. Click the Modular Messaging Software Caller Apps node. See Modular Messaging Software Caller Apps Node on page 6-25.

3. Select Action > Properties to launch the Modular Messaging Software Caller Apps Properties dialog box. See Modular Messaging Software Caller Apps Properties Dialog Box on page 6-34.

4. Set up preferences for all the new caller applications you intend to create and click OK.

These preferences include the recording media type, audio encoding and the automatic launch of certain dialog boxes when creating or opening caller applications.

Procedure 2: Creating a Caller Application

1. Click the Modular Messaging Software Caller Apps node.

2. Select Action > New > Caller Application... This launches the New Caller Application dialog box. See New Caller Application Dialog Box on page 6-38.

3. Edit the fields to define the new caller application and click OK. The caller application node then appears in the tree.

4. Click the new caller applications node. See Caller Applications Node on page 6-26.
5. Select **Action > Properties** to launch the **Properties** dialog box for the selected caller application. See **Properties Dialog Box** on page 6-43.

6. Select the action type for this node in the **General** tab and configure the settings for that type. See **Properties - General Tab** on page 6-44.

7. Click the **Prompt** tab and set up any announcements or application prompts. See **Properties - Prompt Tab** on page 6-57.

   **Note:** See this topic for a detailed application prompt procedures: **Importing or Recording Application Prompts** on page 6-10.

8. Click the **Application** tab and set up default preferences to be used for any new node in this caller application. See **Properties - Application Tab** on page 6-62.

   These preferences include the defining the operator, setting default cancel and “no input” options, and choosing to design for a particular voice mail domain.

9. Click the **Languages** tab to view the language options for the caller application. See **Properties - Languages Tab** on page 6-66.

10. Click **OK** to close the **Properties** dialog.

11. Select the **Action > Save Application** menu command and give the file a name with a *.UMA extension.

12. If you wish to extend the caller application, follow **Procedure 3: Adding Application (Action) Nodes to the Caller Application**.

**Procedure 3: Adding Application (Action) Nodes to the Caller Application**

1. Complete “Procedure 1” above, then click the new **»** caller applications node.

2. Select **Action > New > Application Node**. This launches the **Add Node** dialog box. See **Add Node Dialog Box** on page 6-40.

3. Edit the fields to define the new application (action) node and click **OK**. The new node then appears in the tree beneath its parent node.

   **Note:** The Caller Applications Editor can be configured to launch the **Properties** dialog automatically as soon as a new application (action) node is created. If not, follow steps 4 and 5.

4. Click the new **»** application (action) node. See **Application (Action) Node** on page 6-28.

5. Select **Action > Properties** to launch the **Properties** dialog box for the selected node. See **Properties Dialog Box** on page 6-43.
6. You can modify the action type and the action type’s settings for this node in the **General** tab. See *Properties - General Tab* on page 6-44.

7. Click the **Prompt** tab and set up any announcements or application prompts. See *Properties - Prompt Tab* on page 6-57.

---

**Note:** See this topic for a detailed application prompt procedures: *Importing or Recording Application Prompts* on page 6-10.

---

8. Click **OK** to close the **Properties** dialog.

9. Select the **Action > Save Application** menu command to resave the caller application.

---

**Note:** You can follow this procedure again to add further sub-nodes to the main caller applications node. If you wish to add sub-nodes to an existing application (action) node, just click that node in place of Step 1.

---

**Procedure 4: Opening or Editing Caller Applications**

1. If the caller application is not already in the tree, click the **Modular Messaging Software Caller Apps** node.

2. Select **Action > Open Application**... This launches the standard Windows **Open** dialog box.

3. Select a *.UMA* file to open an existing caller application.

4. If the Caller Application Editor has been configured to do so, you will then be prompted with the **Open Caller Application** dialog box, where you can select which language you would like to edit. See *Open Caller Application Dialog Box* on page 6-36.

5. The **caller application node** then appears in the tree with all application (action) nodes beneath it.

6. You can edit any node using the **Action > Properties** menu, as described in “Procedure 2” and “Procedure 3” above.

7. You can then re-save the caller application.

   - **Action > Save Application** Saves the caller application with the same application name and embedded ID, and also increments its revision number.

   - **Action > Save Application As...** Saves the caller application with a new application name and embedded ID. On the next deployment, this caller application is treated as a new application by the MASs in the voice mail domain.
Importing or Recording Application Prompts

You can record application prompts yourself or have them professionally recorded.

- You (or another member of your organization) can record the prompts directly onto the MAS, using either a telephone or a multimedia CD equipped with a microphone and speakers. This approach has the advantage of being easier, but the recording quality may suffer as a result.

- Many organizations prefer to have their prompts professionally recorded and then import the prompts into the caller application.

Note: The following procedures suggest an approach to using the Caller Applications Editor, when recording and assigning prompts for caller applications. This is a procedural overview with links to the topics that describe each tree node and screen in detail.

Procedure 1: Preparing a Pre-Recorded Prompt

If you have a prompt recorded professionally, it must be in the form of G.711 encoded *.WAV file.

Note: Ensure that the form of G.711 encoding matches that of the Private Branch Exchange (PBX). In general, µ-law (mu-law) is used in North America and Japan, and A-law is used in Europe. If your choice of encoding scheme does not match the PBX, then audio will sound garbled.

Copy that file into a directory accessible by the machine where you are developing your caller applications.

Procedure 2: Selecting the Application Prompt to Assign

1. In the Modular Messaging Caller Applications window, click a caller application node or an application (action) node.

   Note: For procedures for creating caller applications, see Creating & Editing Caller Applications on page 6-7.

2. Click the Action > Properties icon or menu command. The system displays Properties dialog box for the selected node.

3. Click the Prompt tab. See Properties - Prompt Tab on page 6-57.

4. Select the Play entry prompt field and the Application prompt option button.
5. Click the icon to add a new line to the **Application prompt** grid. A **Prompt** number is assigned automatically.

6. Type in a **Comment** to identify the prompt and press Enter on your keyboard.

7. You then have these options:
   - Leave the assignment of the prompt until a later stage.
   - Assign a pre-recorded prompt file by following “Procedure 3” below.
   - Record and assign a new prompt file by following “Procedure 4” below.

**Procedure 3: Assigning an Existing Prompt File to the Prompt**

1. Follow “Procedure 1” and “Procedure 2” above.

2. Open a Windows Explorer window and display the recording file.

3. Click a prompt entry in the **Application prompts** grid for which you want to import the recording.

4. Drag and drop the desired *.WAV file into the recording device area at the bottom of the screen.

**Procedure 4: Recording a New Prompt File and Assigning it to the Prompt**

1. Follow “Procedure 2” above.

2. Click a prompt entry in the **Application prompts** grid for which you want to record a prompt.

3. You can then use the area at the bottom of the screen to record the prompt file. See **Using the Prompt Recording Device** on page 6-60.

4. Right-click the icon to select the appropriate device, either **Telephone** or **Multimedia**.

5. Click the icon and begin your recording.
   - If you are using a multimedia PC with a microphone, you can begin recording immediately.
   - If you are using a telephone to record the prompt, you must wait for the system to dial the telephone and the telephone to ring. When it does, pick up the handset and begin recording.
6. Click the □ icon to finish. The new recording is then automatically assigned to the prompt selected in the Application prompts grid.

**Note:** You can trim the end of the recording by positioning the slider at the end of the "good" recording, then pressing the Record button and Stop button in quick succession.
Deploying Caller Applications to a VMD

Simply creating and saving a caller application does not automatically place it into service and make it available to callers. Once the caller application is finished, you must still deploy (install) it on the voice mail domain before it is considered live and available to callers.

Notes:

- Any user can create caller applications. To deploy caller applications, you must be a member of a security role assigned the Caller Applications - Administer task. This is configured in the Voice Mail System Configuration application, Security Roles dialog box. See Security Roles Dialog Box on page 3-88.

- Deployed Caller Applications which contain schedules must be redeployed, if the Messaging Application Server (MAS) time zone is changed. This is not necessary for daylight savings time changes.

- The following procedures suggest an approach to using the Caller Applications Editor, when deploying caller applications. This is a procedural overview with links to the topics that describe each tree node and screen in detail.

Procedure 1: Preparing to Deploy Caller Applications

Before you begin deploying caller applications, ensure that:

- You are logged in to the domain as a System Administrator. These permission are set in the Voice Mail System Configuration application, Security Roles dialog box.

- The Caller Applications software is installed and enabled as described in this procedure Using the Caller Applications Software on page 6-4.

Procedure 2: Connecting to the MAS

It is possible to run the Caller Applications Editor on a stand-alone PC. Because of this you must configure a connection to an MAS, even if the Caller Applications Editor is currently running on that MAS.

1. In the Modular Messaging Caller Applications window, click the Deployed applications node in the tree. See Deployed Applications Node on page 6-30.

2. Click the Action > Connect to Message Application Server menu command. The system displays Message Application Server dialog box.
3. Select the message application server to connect to and click OK. The Caller Applications Editor is then able to determine the voice mail domain(s) available for caller application deployment and they appear in as nodes beneath the **Deployed applications** node.

**Procedure 3: Deploying a Caller Application**

Deployment distributes the caller application to all the running MASs in a voice mail domain.

---

**Note:** If there are other MASs in the voice mail domain which are not running during deployment, the **Caller Application Deployment Wizard** states that the deployment has failed. A subsequent attempt to deploy the same caller application, however, skips the transfers already completed and transfers the caller application only to the remaining MASs.

When a new MAS is installed into a voice mail domain where caller applications are already deployed, the system automatically transfers the caller applications deployed in the voice mail domain to the new MAS. This also happens, when an MAS is moved from one domain to another.

To deploy caller applications:

1. Complete “Procedure 2” above.

2. In the **Modular Messaging Caller Applications** window, click a caller application node.

   **Note:** The caller application must be saved before it can be deployed. For procedures for creating caller applications, see **Creating & Editing Caller Applications** on page 6-7.

3. Select the **Action > All Tasks > Deploy Caller Application** menu command. This launches the **Caller Application Deployment Wizard**. See **Caller Application Deployment Wizard** on page 6-69

4. You must specify the voice mail domain and press the **Next** button to move to each of the screens of the wizard, then click **Finish**.

5. Click the relevant voice mail domain node, beneath the **Deployed applications** node in the tree. See **Voice Mail Domain Node** on page 6-31.
The deployed caller application is listed in the right hand pane.

Notes:

- In cases where the caller application is designed for callers to access it using a key press, you must also create associations. See the procedure for Creating Associations with the TUI on page 6-17.

- After deploying the caller application, use the Application analysis tool to discover and troubleshoot any problems that may exist. See the procedure for Analyzing Deployed Caller Applications on page 6-20.

Procedure 4: Re-deploying a Caller Application

If you have made changes to a caller application, it can be deployed again, as described in “Procedure 3” above.

When re-deployment succeeds, new callers have access to the updated version of the caller application immediately. Any callers using the existing version of the caller application at the time it is re-deployed continue to interact with the old version as long as they remain connected to the caller application. Temporarily, therefore, more than one version of the caller application can be stored and running on an MAS.

Each caller application contains an embedded identifier and a revision number. The revision number is incremented each time that the caller application is saved. Even if a caller application’s *.UMA file is renamed or copied by Windows Explorer, the application’s embedded identifier does not change. The MAS treats it as the same application.

An MAS that is contacted by the Caller Applications Editor and asked to deploy an application checks to see whether it already has a copy of the application deployed. If the MAS already has an application with the same embedded identifier and the same or a higher version number, it does not accept the re-deployment, regardless of the file name on the application.

If, however, you use the Action > Save As menu option from Caller Applications Editor to rename an application, the new version of the *.UMA file has a new embedded identifier and revision number. The application is then treated as a different application, and you can successfully deploy it.

Procedure 5: Undeploying a Caller Application

If you find you no longer need a deployed caller application, or you want to replace it with a different one, you can remove the caller application from the voice mail domain using the Caller Applications Editor.
Any callers using the caller application at the time of undeployment continue to interact with it for as long as they remain connected to the caller application.

1. Click the relevant voice mail domain node, beneath the Deployed applications node in the tree. See Voice Mail Domain Node on page 6-31.

2. Click the deployed caller application listed in the right hand pane.

3. Select the Action > Delete menu command. This prompts you to confirm the action.

4. Click the Yes button to launch the Caller Application Undeployment Wizard. See Caller Application Undeployment Wizard on page 6-70.

5. Press the Next button to move to each of the screens of the wizard, the click Finish. The caller application is removed from the voice mail domain node. Copies of the *.UMA files are deleted from all MASs in the voice mail domain.
Creating Associations with the TUI

In cases where the caller application is designed for callers to access it using a key press or combination of key presses, you must create an association as part of the deployment process. For the deployment procedure, see Deploying Caller Applications to a VMD on page 6-13.

Associations are the links between a deployed caller application and the information from the Telephone User Interface (TUI) used to access the caller application. Associations enable the system to launch a caller application, if one or both of the following launch conditions are met:

- A caller enters an identifying number (ID number), when prompted by the Automated Attendant or another caller application. The ID number appears to the caller as a mailbox number.
- A caller dials a specified direct-dial number or extension number (the “called number”).

When you create an association, you must configure at least one of these launch conditions. If you configure both, meeting either condition will launch the caller application. Any given association can launch only one specified caller application. To help identify the association, you assign it a name.

You can re-use a deployed caller application by specifying multiple associations, with different ID numbers, for the same caller application. This means the deployed caller application is the same, but different mailbox numbers or Automated Attendant menu choices can be used to access it. For example, this might be useful, if you wanted to launch multiple bulletin board type applications using different mailbox numbers.

**Note:** The following procedures suggest an approach to using the Caller Applications Editor, when creating associations for deploying caller applications. This is a procedural overview with links to the topics that describe each tree node and screen in detail.

**Procedure 1: Planning Association ID Numbers**

Association ID numbers can be any length, from one digit up to the maximum number of digits used for mailbox numbers in the voice mail domain.

This means it is possible for you to create an association ID number that is identical to a single-digit Automated Attendant menu option or a valid mailbox number.

- If you set up a single-digit association ID number that requires the same key press as an Automated Attendant menu option, the Automated Attendant menu option will always be used. This is because the association ID number is only recognized, if it is followed by a timeout or terminated with a #. For this reason, Avaya recommends that you do not use a single-digit number as the association ID number.
If an association ID number is identical to a valid mailbox number, when a caller enters that number, the association ID number is used and the associated caller application runs. This can be useful, if you want to prevent caller access to a mailbox.

**Note:** In this scenario, although callers cannot leave messages, subscriber access to the mailbox is not affected.

**Procedure 2: Creating an Association in a Deployed Caller Application**

1. Follow “Procedure 1” above.

2. In the **Modular Messaging Caller Applications** window, click the relevant voice mail domain node, beneath the **Deployed applications** node in the tree. See **Voice Mail Domain Node** on page 6-31.

3. Click the **Associations** node. See **Associations Node** on page 6-32.

4. Click the **Action > New > Association** menu command. The system displays **Add Association** dialog box. See **Add Association/Association Properties Dialog Box** on page 6-71.

5. Enter the association name, association ID and/or called number.

6. Select the caller application which will be launched when the conditions are met.

7. Click **OK**. The association is listed in the right hand pane.

8. If you need to edit the association details, select the association in the right hand pane and click **Action > Properties** to launch the **Association Properties** dialog box.

**Procedure 3: Configuring Automated Attendant to Launch a Caller Application**

1. Follow “Procedure 2” above.

2. Make a note of the **Association ID** number for the caller application you wish to launch from the TUI.

3. In the **Voice Mail System Configuration** window, **Automated Attendant** dialog, **Attendant Main Menu Editor** tab, enter the association ID in the **Mailbox Number** field and click **OK**. See **Auto Attendant - Attendant Main Menu Editor Tab** on page 3-62.
Procedure 4: Deleting an Association

If you find you no longer want to use a particular association with a deployed caller application, you can delete the association without removing the caller application from the voice mail domain. This allows you to create and use new associations without having to re-deploy the caller application.

1. Click the relevant voice mail domain node, beneath the Deployed applications node in the tree. See Voice Mail Domain Node on page 6-31.

2. Click the Associations node. See Associations Node on page 6-32.

3. Click the association listed in the right hand pane.

4. Select the Action > Delete menu command. This prompts you to confirm the action.

   The association is then removed from the voice mail domain.
Analyzing Deployed Caller Applications

After deploying a caller application across the voice mail domain, Avaya strongly recommends that you analyze it using the application analysis feature. This allows you to test and debug your caller applications. This helps you to find any problems with the application before your callers do.

To analyze deployed caller applications, you must be a member of a security role assigned the **Caller Applications - Administer** task, or the **Caller Applications - View** task. This is configured in the **Voice Mail System Configuration** application, **Security Roles** dialog box. See **Security Roles Dialog Box** on page 3-88.

**Note:** The following procedures suggest an approach to using the Caller Applications Editor, when analyzing deployed caller applications. This is a procedural overview with links to the topics that describe each tree node and screen in detail.

---

**Procedure 1: Analyzing Deployed Caller Applications**

1. In the **Modular Messaging Caller Applications** window, click the relevant voice mail domain node, beneath the **Deployed applications** node in the tree. See **Voice Mail Domain Node** on page 6-31.

2. Click the **Application Analysis** node. See **Application Analysis Node** on page 6-33.

   **Note:** If you do not see this node in the tree, click the **Action > Refresh** menu command.

3. As soon as you click the node, the Caller Applications Editor performs an analysis of the deployed caller applications, then lists the results in the right hand pane:

   - ![Green Icon] Indicates no detected problems.
   - ![Red Icon] Indicates a problem that needs attention.

4. If you wish the analysis to include subscriber mailboxes that refer to caller applications, follow “Procedure 2” below.

5. If you wish to view the details of the analysis results, follow “Procedure 3” below.
Procedure 2: Configuring “Front Door” Analysis

By default, when analyzing caller applications, the Caller Applications Editor excludes subscriber mailboxes that refer to caller applications. These are known as “Front Door” applications. This is because the task of analyzing all subscriber mailboxes that refer to caller applications can take a considerable amount of time.

To include “Front Door” analysis of the deployed caller applications:

1. Click the Application Analysis node.

2. Click the Action > Properties menu command. The system displays Application Analysis Properties dialog box. See Application Analysis Properties Dialog Box on page 6-73.

3. Select the Include “Front Door” application analysis check box and click OK.

4. Click the Action > Refresh menu command to re-run the application analysis. The new results are listed in the right hand pane:

   - ![Green Check] Indicates no detected problems.
   - ![Red Cross] Indicates a problem that needs attention.

5. If you wish to view the details of the analysis results, follow “Procedure 3” below.

Procedure 3: Viewing the Results of Analyzed Deployed Caller Applications

1. Follow “Procedure 1” above and, if necessary, “Procedure 2” above.

2. Click on a deployed caller application listed in the right hand pane:

   - ![Green Check] Indicates no detected problems.
   - ![Red Cross] Indicates a problem that needs attention.

3. Click the Action > Properties menu command. The system displays Properties dialog box for the selected analyzed deployed caller application. See Analysis Results Properties Dialog Box on page 6-74.

4. The results include caller application deployment, association references, mailbox references and references from/to the caller application.

   The problem areas are marked with a red cross and include further information.

5. You can copy these results to the Windows Clipboard, if you wish, using the Copy to clipboard button.
Modular Messaging Caller Applications Window & Nodes

You can use the Caller Applications Editor to create caller applications and deploy them to a voice mail domain. Caller applications allow you to extend or even replace the system Automated Attendant, depending on your organization’s needs.

Notes:

- Any user can create caller applications. To deploy caller applications, you must be a member of a security role assigned the Caller Applications - Administer task. This is configured in the Voice Mail System Configuration application, Security Roles dialog box. See Security Roles Dialog Box on page 3-88.

- For an overview and procedures for using caller applications, see Understanding Caller Applications on page 6-3.

Launching the Caller Applications Editor

On your Windows desktop, click the Start > Programs > Avaya Modular Messaging > Caller Applications menu to launch the Modular Messaging Caller Applications window. See Figure 6-1.
Layout of the Caller Applications Editor

Figure 6-1.

You can configure caller applications from the tree in the left hand pane. When you click on a node in the tree, the menus and icons change appropriately. You can use these commands to launch the screens for creating, editing and deploying caller applications.

**Note:** The Deployed applications node appears near the top of the tree so that it is not obscured by multiple caller application nodes, which each appear as a new branch (as shown by Example 1 and Example 2 in the figure above). This guide, however, lists the nodes in the order in which you would typically use them rather than the order they appear in the tree.

Nodes in the Caller Applications Editor Tree

- **Modular Messaging Software Caller Apps**  All caller applications form branches off this top level node. You can open existing caller applications from this node and configure settings that affect all the new caller applications you create. See Modular Messaging Software Caller Apps Node on page 6-25.

- **Caller Applications Node**  When you create a new caller application or open an existing one, it appears as a sub-node of the Modular Messaging Software Caller Apps node. Each caller application has its own node, as shown by Example 1 and Example 2 in the figure above. See Caller Applications Node on page 6-26.
Application (Action) Node  When you create an application (action) node for a caller application, it appears as a sub-node of that caller application's node. Application (action) nodes typically represent the menu items and other caller options within a caller application. A caller application can have many of these nodes, as shown by Information, Support, Products and Prices in the figure above. See Application (Action) Node on page 6-28.

Deployed Applications Node  This node is displayed permanently, just beneath the Modular Messaging Caller Apps node. This node expands to show voice mail domains with deployed applications and their associations. See Deployed Applications Node on page 6-30.

Voice Mail Domain Node  This node is a sub-node to the Deployed applications node. When you click this node, it displays caller applications which have been deployed to this voice mail domain in the right hand pane. The node also expands to show deployed applications’ associations. See Voice Mail Domain Node on page 6-31.

Associations Node  This is a sub-node to the voice mail domain node. It displays any associations that have been configured for deployed caller applications. An association is a link between a deployed caller application and the information from the Telephone User Interface (TUI) used to access the caller application. See Associations Node on page 6-32.

Application Analysis Node  This is a sub-node to the voice mail domain node. It displays the results of analysis performed on deployed caller applications to test their viability. See Application Analysis Node on page 6-33.

Note: The Modular Messaging Caller Applications window runs as a plug-in within the Microsoft Management Console. Generic menu commands and screens are not documented here. You can launch both the Microsoft Management Console Help and Caller Applications Editor Help using the Help > Help Topics command.
Modular Messaging Software Caller Apps Node

This topic describes the context-sensitive commands and screens available, when the Modular Messaging Software Caller Apps node is selected in the tree of the Modular Messaging Caller Applications window.

Notes:

- For information about the main window and other nodes, see Modular Messaging Caller Applications Window & Nodes on page 6-22.
- For an overview and procedures for using caller applications, see Understanding Caller Applications on page 6-3.

Modular Messaging Software Caller Apps

All caller applications form branches off this top-level node. You can open existing caller applications from this node and configure settings that affect all the new caller applications you create.

When you select this node in the tree, the right hand pane shows the Deployed Applications node and lists the names of any caller application nodes.

Menus and Icons available from this node

- **Action > Open Application...**  Launches the standard Windows Open dialog box. Select a *.UMA file to open an existing caller application.

  If the Caller Application Editor has been configured to do so, you will then be prompted with the Open Caller Application dialog box, where you can select which language you would like to edit. See Open Caller Application Dialog Box on page 6-36.

- **Action > New > Caller Application...**  Launches the New Caller Application dialog box, where you can create a caller application. It then appears beneath the Modular Messaging Software Caller Apps node. See New Caller Application Dialog Box on page 6-38.

- **Action > Properties**  Launches the Modular Messaging Software Caller Apps Properties dialog box, where you can set preferences for all the new caller applications you create. See Modular Messaging Software Caller Apps Properties Dialog Box on page 6-34.
Caller Applications Node

This topic describes the context-sensitive commands and screens available, when a caller applications node is selected in the tree of the Modular Messaging Caller Applications window.

Notes:

- For information about the main window and other nodes, see Modular Messaging Caller Applications Window & Nodes on page 6-22.
- For an overview and procedures for using caller applications, see Understanding Caller Applications on page 6-3 and, in particular, Creating & Editing Caller Applications on page 6-7.

Caller Applications Node

When you create a new caller application or open an existing one, it appears as a sub-node of the Modular Messaging Software Caller Apps node. Each caller application has its own node.

When you select this node in the tree, the right hand pane lists the Name, Action type and Description of the application (action) nodes within the selected caller application.

The icon for the caller application node varies, depending on its current status:

- You will see this display, when the caller application node is fully configured and the caller application has been saved.
- The green arrow attached to the icon indicates this node is the start of the caller application.
- You will see this display, when you first create the caller application node. You must add one or more application (action) nodes beneath this node or change the Action type in the Properties dialog box.

Menus and Icons available from this node

- Action > Save Application  Saves the caller application with the same application name and embedded ID, and also increments its revision number.
- Action > Save Application As...  Saves the caller application with a new application name and embedded ID. On the next deployment, this caller application is treated as a new application by the MASs in the voice mail domain.
- Action > Close Application  Closes the caller application. The system prompts you to save any changes made since the last save.
- **Action > Set Application Start**  Sets the selected node as the start point of the caller application. The node then displays a green arrow (🏃‍♂️).

  **Note:** The caller application node is set as the start point by default but, if the start point has been changed, this command resets it.

- **Action > New > Application Node**  Launches the Add Node dialog box, where you can create an application (action) node within the caller application. It then appears beneath the caller application node in the tree. See Add Node Dialog Box on page 6-40.

- **Action > All Tasks > Deploy Caller Application**  Launches the Caller Application Deployment Wizard, which guides you through the deployment of the selected caller application. The caller application must be saved before this command is enabled. See Caller Application Deployment Wizard on page 6-69.

- **Action > Properties**  Displays the Properties dialog box for the selected caller application. You must use this dialog box to set properties that apply to the caller application. It is not configured correctly until you do so. See Properties Dialog Box on page 6-43.
Application (Action) Node

This topic describes the context-sensitive commands and screens available, when an application (action) node is selected in the tree of the Modular Messaging Caller Applications window.

Notes:

- For information about the main window and other nodes, see Modular Messaging Caller Applications Window & Nodes on page 6-22.
- For an overview and procedures for using caller applications, see Understanding Caller Applications on page 6-3 and, in particular, Creating & Editing Caller Applications on page 6-7.

Application (Action) Node

Application (action) nodes typically represent the menu items and other caller options within a caller application. A caller application can have many of these as sub-nodes.

The icon for an application (action) node varies, depending on its current status. These example icons show key press 1 but they can show any valid key press number.

- ![ ] You will see this display, when the application (action) node is fully configured and the caller application has been saved.

- ![ ] The green arrow attached to the icon indicates this node is the start of the caller application. The caller application node is set as the start point by default but it can be set for an application (action) node instead

- ![ ] You will see this display, when the application (action) node is configured correctly so far but ideally needs additional settings before the caller application is saved.

- ![ ] You will see this display, when the application (action) node is not configured correctly. It also ideally needs additional settings before the caller application is saved.

- ![ ] You will see this display, when the application (action) node is not configured.

**Note:** Until this is corrected, you cannot save the caller application successfully.
Menus and Icons available from this node

- **Action > Change Access Key** Displays the Change Key dialog box, where you can change the key press the caller must use to access the selected application (action) node. See Change Key Dialog Box on page 6-67.

- **Action > Set Application Start** Sets the selected node as the start point of the caller application. The node then displays a green arrow (▲).

- **Action > New > Application Node** Launches the Add Node dialog box, where you can create an application (action) node. It then appears as a sub-node beneath the application (action) node selected in the tree. See Add Node Dialog Box on page 6-40.

- **Action > Delete** Deletes the selected application (action) node. If the selected node is referenced by other nodes, the system displays a dialog box with information on the referenced nodes.

- **Action > Properties** Displays the Properties dialog box for the selected application (action) node. You must use this dialog box to set properties that apply to the application (action) node. It is not configured correctly until you do so. See Properties Dialog Box on page 6-43.
Deployed Applications Node

This topic describes the context-sensitive commands and screens available, when the Deployed Applications node is selected in the tree of the Modular Messaging Caller Applications window.

Notes:

- For information about the main window and other nodes, see Modular Messaging Caller Applications Window & Nodes on page 6-22.
- For an overview and procedures for using caller applications, see Understanding Caller Applications on page 6-3 and, in particular, Deploying Caller Applications to a VMD on page 6-13.

Deployed Applications Node

Just beneath the Modular Messaging Caller Apps node is the node for Deployed Applications. This node expands to show voice mail domains with deployed applications and their associations.

Note: There is only one voice mail domain.

When you select this node in the tree, the right hand pane shows the Name of any voice mail domain nodes.

Menus and Icons available from this node

- Action > Connect to Message Application Server... Launches the Message Application Server dialog box, where you can connect to the messaging application server (MAS) on which to deploy caller applications. See Message Application Server Dialog Box on page 6-68.
- Action > Refresh Refreshes the tree to show the latest details of all the nodes beneath the Deployed applications node.
Voice Mail Domain Node

This topic describes the context-sensitive commands and screens available, when the voice mail domain node is selected in the tree of the **Modular Messaging Caller Applications** window.

---

**Notes:**

- For information about the main window and other nodes, see [Modular Messaging Caller Applications Window & Nodes](#) on page 6-22.

- For an overview and procedures for using caller applications, see [Understanding Caller Applications](#) on page 6-3 and, in particular, [Deploying Caller Applications to a VMD](#) on page 6-13.

---

**Voice Mail Domain Node**

The voice mail domain node is a sub-node to the **Deployed applications** node. The node expands to show the **Associations** node and the **Application analysis** node.

When you click this node, the right hand pane displays a list of caller applications which have been deployed to this voice mail domain. The list details the **Name** and might show the **Caller Application ID**. It also displays the **Associations** node and the **Application analysis** node.

**Menus and Icons available from this node in the left hand pane**

- **Action > Refresh** Refreshes the tree to show the latest details of the voice mail domain node.

  You may need to do this in order to view the **Application analysis** node and use the analysis feature.

**Menus and Icons available from selecting a deployed caller application in the right hand pane**

- **Action > Copy Application ID** Copies the Globally Unique Identifier (GUID) of the selected deployed caller application to the Windows Clipboard.

- **Action > Delete** Prompts you to confirm the action before launching the **Caller Application Undeployment Wizard**. You can then undeploy the selected deployed caller application from the voice mail domain. See [Caller Application Undeployment Wizard](#) on page 6-70.
Associations Node

This topic describes the context-sensitive commands and screens available, when the **Associations** node is selected in the tree of the **Modular Messaging Caller Applications** window.

### Notes:

- For information about the main window and other nodes, see Modular Messaging Caller Applications Window & Nodes on page 6-22.
- For an overview and procedures for using caller applications, see Understanding Caller Applications on page 6-3 and, in particular, Creating Associations with the TUI on page 6-17.

** Associations Node **

An association is a link between a deployed caller application and the information from the Telephone User Interface (TUI) used to access the caller application.

When you select the **Associations** node in the tree, the right hand pane shows a list of all associations that have been configured for deployed caller applications in the voice mail domain. The list details the **Association Name**, **Caller Application**, **Association ID**, **Called Number** and **Mailbox Number**.

** Menus and Icons available from this node in the left hand pane **

- ![Action > New > Association](#)  Launches the Add Association dialog box. You can select a caller application in the voice mail domain and configure its association to the TUI. See Add Association/Association Properties Dialog Box on page 6-71.

- ![Action > Refresh](#)  Refreshes the tree to show the latest associations.

** Menus and Icons available from selecting an ** association in the right hand pane **

- ![Action > Properties](#)  Launches the Association Properties dialog box, where you can amend the selected association details. See Add Association/Association Properties Dialog Box on page 6-71.

- ![Action > Delete](#)  Deletes the selected application (action) node. If the selected action node is referenced by other nodes, the system displays a dialog box with information on the referenced nodes.
Application Analysis Node

This topic describes the context-sensitive commands and screens available, when the Application Analysis node is selected in the tree of the Modular Messaging Caller Applications window.

Notes:

- For information about the main window and other nodes, see Modular Messaging Caller Applications Window & Nodes on page 6-22.
- For an overview and procedures for using caller applications, see Understanding Caller Applications on page 6-3 and, in particular, Analyzing Deployed Caller Applications on page 6-20.

Application Analysis Node

This is a sub-node to the voice mail domain node. The Application Analysis Node node displays the results of analysis performed on deployed caller applications to test their viability.

When you select this node in the tree, the system analyzes the deployed caller applications in the voice mail domain. The results are displayed in the right hand pane.

- 🍃 Indicates no detected problems with the caller application.
- 🔴 Indicates a problem with the caller application.

Menus and Icons available from this node in the left hand pane

- 🌼 Action > Properties  Launches the Application Analysis Properties dialog box, where you can configure properties for analyzing deployed caller applications. See Application Analysis Properties Dialog Box on page 6-73.

- 🌼 Action > Refresh  Re-analyzes the deployed caller applications in the voice mail domain. The new results are displayed in the right hand pane.

Menus and Icons available from selecting an 🍃🔴 analyzed deployed caller application in the right hand pane

- 🌼 Action > Properties  Launches the Properties dialog box for the selected analyzed deployed caller application. See Analysis Results Properties Dialog Box on page 6-74.
Modular Messaging Software Caller Apps Properties Dialog Box

This topic describes how to use the Modular Messaging Software Caller Apps dialog box to set preferences for all the caller applications you create.

**Note:** For an overview see Understanding Caller Applications on page 6-3 and, in particular, Creating & Editing Caller Applications on page 6-7.

### Launching the Screen

1. In the Modular Messaging Caller Applications window, click the Modular Messaging Software Caller Apps node.

   For more information on this node, see Modular Messaging Software Caller Apps Node on page 6-25.

2. Click the Action > Properties icon or menu command. The system displays Modular Messaging Software Caller Apps Properties dialog box. It only has one tab, the General tab.

### Configuring the Screen Controls

- **Prompt recording and playback** Select the default audio device for recording the prompts: Multimedia or Telephone.

  Selecting Telephone activates the Configure button and Audio encoding field.

  — Configure... (Only for Telephone audio device). This button opens the Telephone Properties dialog box:

    - **Extension number** Enter the number of the extension that will be used for recording and playing prompts.

    - **Message Application Server name** Enter the name of an MAS in the voice mail domain. If necessary, use the Browse button to locate the desired MAS.

    — **Audio encoding** (Only for Telephone audio device). Select the appropriate digital telephony type for your region.

      If you are in a country that uses a digital telephone network other than that used in North America and Japan, select International regions including Europe.
- **Display properties when creating new application nodes** Select to automatically display the Properties dialog when creating a new application (action) node.

  Avaya recommends selecting this option, as it helps to streamline and speed up the caller application building process.

- **Allow language selection when opening caller applications** Select this check box to display the Open Caller Application dialog box, when opening caller applications.

  This enables users to select the language for a caller application or add another language to the caller application.
Open Caller Application Dialog Box

This topic describes how to use the **Open Caller Application** dialog box to select the language you would like to edit in the caller application.

The **Open Caller Application** dialog box only appears, if you have configured it to do so, using the **Modular Messaging Software Caller Apps Properties** dialog box. See [Modular Messaging Software Caller Apps Properties Dialog Box](#) on page 6-34.

**Note:** For an overview see [Understanding Caller Applications](#) on page 6-3 and, in particular, [Creating & Editing Caller Applications](#) on page 6-7.

### Launching the Screen

1. In the **Modular Messaging Caller Applications** window, click the ![Modular Messaging Software Caller Apps](#) node.

   For more information on this node, see [Modular Messaging Software Caller Apps Node](#) on page 6-25.

2. Click the ![Action > Open Application...](#) icon or menu command.

   The system displays the standard Windows **Open** dialog box.

3. Open the caller application *.UMA file.

   **Note:** By default, caller applications are saved to the directory `C:\Program Files\Avaya Modular Messaging\Vserver\CallerApps`, where `C:\` represents the root drive of the server.

4. If the Caller Application Editor has been configured to do so, you will then be prompted with the **Open Caller Application** dialog box.

### Configuring the Screen Controls

- **Select the language that you would like to edit** Select the language to use for editing this caller application.

- **Add language** (Optional, only if other languages are available). Select this check box to activate the **Edit content as language** pick list.

  — **Edit content as language** (Optional, only if other languages are available). Select the language to use for editing this caller application.

- **Always let me select the language I would like to edit** (Optional). If you do not want the Caller Applications Editor to prompt you for language selection in the future, clear this check box.
This resets the default language selection value for all caller applications.

**Note:** If you change your mind, you must re-select the **Allow language selection when opening caller applications** option in the **Modular Messaging Software Caller Apps Properties** dialog box.

- **Continue** This opens the caller application in the selected language. It then appears as a node in the tree.
New Caller Application Dialog Box

This topic describes how to use the New Caller Application dialog box to create a new caller application.

Typically, the main caller application node is set up as a menu of options presented to the caller. It can however be used to perform other functions instead, like transfer, go to, route, bypass or terminate.

Note: For an overview see Understanding Caller Applications on page 6-3 and, in particular, Creating & Editing Caller Applications on page 6-7.

Launching the Screen

1. In the Modular Messaging Caller Applications window, click the Modular Messaging Software Caller Apps node.

   For more information on this node, see Modular Messaging Software Caller Apps Node on page 6-25.

2. Click the Action > New > Caller Application icon or menu command. The system displays New Caller Application dialog box.

Configuring the Screen Controls

- **Application name** Enter the name of the caller application.

   When the application is deployed, the Caller Application Editor displays this name in the list of deployed applications.

- **Application description** (Optional, but recommended) Enter a short description of the caller application.

   This description provides the text that the system displays with the application properties. It can be useful, especially when designing large applications.

- **Language** Select the language to use for the caller application. The display lists all the languages installed with the system.

- **Design for VMD** (Optional) Select the check box, if you want to specify the voice mail domain where the caller application will be deployed. Then select the voice mail domain from the pick list.

   When selected, voice mail domain-specific values, such as the mailbox length, will be applied to the caller application.
This information is not a prerequisite for building a caller application. It is useful, if you are editing caller applications offline and cannot easily access voice mail domain information.

After Configuring the Controls

Once you have configured the fields in the New Caller Applications dialog box and clicked OK, you should configure the new caller application’s properties, using the Properties dialog box. See Properties Dialog Box on page 6-43.

You can then create sub-nodes within the caller application, if necessary, using the Add Node dialog box. See Add Node Dialog Box on page 6-40.

The icon for the new caller application node varies, depending on its current status:

- ![Icon] You will see this display, when you first create the caller application node. You must add one or more application (action) nodes beneath this node or change the Action type in the Properties dialog box.

- ![Icon] You will see this display, when the caller application node is fully configured and the caller application has been saved.

- ![Icon] The green arrow attached to the icon indicates this node is the start of the caller application. The caller application node is set as the start point by default.

**Note:** The start point can be set to a different node using the Action > Set application start menu command.
Add Node Dialog Box

This topic describes how to use the Add Node dialog box to create a new application (action) node. This is a child node of a caller application or another application (action) node.

Callers can interact with the system in a more complex fashion than a simple menu, when application (action) nodes are used. A caller application may have many nodes, however, for reasons of usability, Avaya recommends that you limit a caller application to three or four menu levels.

Note: For an overview see Understanding Caller Applications on page 6-3 and, in particular, Creating & Editing Caller Applications on page 6-7.

Launching the Screen

1. In the Modular Messaging Caller Applications window, click on a caller application node that you have created or on an existing application (action) node.

For more information on these nodes, see Caller Applications Node on page 6-26 and Application (Action) Node on page 6-28.

2. Click the Action > New > Application Node icon or menu command. The system displays Add Node dialog box.

Configuring the Screen Controls

- **Name** Enter a name for the node.

  The Caller Application Editor uses this name to identify the node in various node and application displays.

- **Action type** Select the type of action you want to assign to the node.

  Note: You can amend this setting, if necessary, when you are configuring the application node’s properties on the General tab of the node’s Properties dialog box.

  — **Menu** (Default) Select this option to present the caller with a menu. A menu usually plays a prompt and then provides the caller with a series of single digit numbered choices.

  — **Transfer** Select this option to transfer the caller to either the operator, a mailbox or an extension number, when a caller presses the associated key.
— **Goto** Select this option to route the caller directly to another application node or another caller application. This can be useful when you have a common action that you want to reuse in your system.

— **Conditional goto** Select this option to route the caller directly to another application (action) node, using criteria specified by a schedule.

— **Send message** Select this option to allow callers to send a message to a subscriber without having to listen to the subscriber’s greeting.

— **Termination** Select this option to terminate the current caller application. It either disconnects the caller from the system or re-routes the caller back to the system Automated Attendant.

— **Key press** Select the DTMF key (also known as the access key) that callers must press to activate the action assigned to this node. If you wish, you can select the keyless option so that there are no TUI key bindings.

**Note:** You can change the access key at any time using the **Action > Change Access Key** menu. See Change Key Dialog Box on page 6-67.

— **Description** (Optional, but recommended) Enter a short description of the caller application.

This description provides the text that the system displays with the application properties. It can be useful, especially when designing large applications.

### After Configuring the Controls

Once you have configured the fields in the **Add Node** dialog box and pressed **OK**, you should configure the new application (action) node’s properties, using the **Properties** dialog box. See Properties Dialog Box on page 6-43.

The icon for the new application (action) node varies, depending on its current status. These example icons show key press 1 but they can show any valid key press number.

— ![Key Press Icon] You will see this display, when the application (action) node is configured correctly so far but ideally needs some additional settings before the caller application is saved.

— ![Key Press Icon] You will see this display, when the application (action) node is not configured correctly. It also ideally needs some additional settings before the caller application is saved.
You will see this display, when the application (action) node is not configured.

**Note:** Until this corrected, you cannot save the caller application successfully.

You will see this display, when the application (action) node is fully configured and the caller application has been saved.

The green arrow attached to the icon indicates this node is the start of the caller application.

**Note:** The caller application node is set as the start point by default. The start point can be set to a different node using the **Action > Set application start** menu command.
Properties Dialog Box

This topic describes how to use the Properties dialog box to configure properties for the main caller application node or an application (action) node.

**General** and **Prompt** tabs are available for each node. **Application** and **Language** tabs are configured at caller application level for all nodes in the caller application.

**Note:** For an overview see [Understanding Caller Applications](#) on page 6-3 and, in particular, [Creating & Editing Caller Applications](#) on page 6-7.

**Launching the Screen**

1. In the **Modular Messaging Caller Applications** window, click on a caller application node that you have created or on an existing application (action) node. For more information on these nodes, see [Caller Applications Node](#) on page 6-26 and [Application (Action) Node](#) on page 6-28.

2. Click the **Action > Properties** icon or menu command. The system displays **Properties** dialog box.

**Note:** You can configure the Caller Applications Editor to launch the **Properties** dialog automatically for every new node. See [Modular Messaging Software](#) on page 6-34.

**Tabs Available in this Dialog Box**

- **General** Use this tab to configure general properties and action type properties for the caller application node or application (action) node. See [Properties - General Tab](#) on page 6-44.

- **Prompt** Use this tab to configure an application prompt or announcement for the caller application node or application (action) node. See [Properties - Prompt Tab](#) on page 6-57.

- **Application** Use this tab to configure the operator, default cancel and ‘no input’ options for all nodes in the caller application. See [Properties - Application Tab](#) on page 6-62.

- **Languages** Use this tab to view language options for the caller application. See [Properties - Languages Tab](#) on page 6-66.
Properties - General Tab

This topic describes how to use the Properties dialog, General tab box to configure general properties and action type properties for the caller application node or application (action) node.

**Note:** For an overview see Understanding Caller Applications on page 6-3 and, in particular, Creating & Editing Caller Applications on page 6-7.

Launching the Screen

1. In the Modular Messaging Caller Applications window, click on a caller application node that you have created or on an existing application (action) node.

   For more information on these nodes, see Caller Applications Node on page 6-26 and Application (Action) Node on page 6-28.

2. Click the Action > Properties icon or menu command. The system displays Properties dialog box for the selected node, with the General tab active.

Configuring the Screen Controls

- **Name** Displays the current name of the caller application. You can change the name, if you want.

   When the application is deployed, the Caller Application Editor displays this name in the list of deployed applications.

- **Description** (Optional, but recommended) Displays the short description you entered when creating the node. You can modify this description here.

   This can be useful when designing large applications.

- **Action type** Select the type of action you want to assign to the caller application node. The choice you make here determines the options that appear to the right.

**Note:** Once a caller application node or application (action) node has sub-nodes, its Action type cannot be changed unless those sub-nodes are deleted first. If the sub-nodes are keyless, however, the Action type can be changed.
— **Menu** (Default) Select this option to present the caller with a menu. A menu usually plays a prompt and then provides the caller with a series of single digit numbered choices.

For details of the fields to the right, when this option is selected, see Properties - General - Menu Action Type on page 6-46.

— **Transfer** Select this option to transfer the caller to either the system operator, a custom operator, a mailbox or an extension number, when a caller presses the associated key.

For details of the fields to the right, when this option is selected, see Properties - General - Transfer Action Type on page 6-48.

— **Goto** Select this option to route the caller directly to another application node or another caller application. This can be useful when you have a common action that you want to reuse in your system.

For details of the fields to the right, when this option is selected, see Properties - General - Goto Action Type on page 6-50.

— **Conditional goto** Select this option to route the caller directly to another application (action) node, using criteria specified by a schedule.

For details of the fields to the right, when this option is selected, see Properties - General - Conditional Goto Action Type on page 6-51.

— **Send message** Select this option to allow callers to send a message to a subscriber without having to listen to the subscriber’s greeting.

For details of the fields to the right, when this option is selected, see Properties - General - Send Message Action Type on page 6-52.

— **Termination** Select this option to terminate the current caller application. It either disconnects the caller from the system or re-routes the caller back to the system Automated Attendant.

For details of the fields to the right, when this option is selected, see Properties - General - Termination Action Type on page 6-54.
Properties - General - Menu Action Type

The Properties dialog, General tab shows a different display, depending on the Action Type selected. See Properties - General Tab on page 6-44.

Select the Menu Action Type to present the caller with a menu. A menu usually plays a prompt and then provides the caller with a series of single digit numbered choices. For example, “For product information press 1. For technical support press 2. To exit press 9.”

Configuring the Screen Controls

- Menu options
  - Menu only This option presents callers with a list of single-digit key press choices. The system considers only keys that are defined for the node as valid. The system plays an “invalid response” prompt to all other key presses.
  - Menu with extension This option presents callers with a list of single-digit key press choices. However, if the caller presses any key other than the keys defined for the node, the system attempts to locate it as an extension in the system and transfer the caller to that extension. Only if the system cannot find an extension with that number, does it respond that the key press is an invalid response.

  **Note:** When this option is selected, the # (pound/hash) key is automatically reserved for use by the Dial By Name feature. This means that callers can enter extensions, and they can also press # to access the Dial By Name feature. If you want to encourage your callers to use the Dial By Name feature, Avaya recommends that you include it in the prompt for the node.

  - Menu with mailbox This option is similar to the Menu with extension option except that, instead of transferring the caller to an extension, this option looks for and transfers the caller to the appropriate mailbox.

    **Note:** When this option is selected, the # key is automatically reserved for use by the Dial By Name feature.

  - Menu with caller application This option is also similar to the Menu with extension option. The difference in this case is that, instead of transferring the caller to an extension or a mailbox, the system looks for a caller application with an association ID that matches the five-digit number. If it finds one, it transfers the caller to that caller application. If not, it responds with the “invalid response” prompt.
- **Cancel destination node**  This allows you to select the node to which the caller application will go, if the caller cancels the operation at this node. The default is `<Parent node>`. In most cases, Avaya recommends this option.

---

**Note:** The default setting for all nodes within a caller application can be changed using the **Properties** dialog, **Application** tab. See [Properties - Application Tab](#) on page 6-62.
Properties - General - Transfer Action Type

The Properties dialog, General tab shows a different display, depending on the Action Type selected. See Properties - General Tab on page 6-44.

Select the Transfer Action Type to transfer the caller to either the operator, a mailbox or an extension number, when a caller presses the associated key.

Configuring the Screen Controls

- **Operator**  Select to transfer the caller to the default system operator configured for the voice mail domain or to a custom operator configured for this caller application.

  The settings for the caller application in the Properties dialog, Application tab determine which type of operator is used here. See Properties - Application Tab on page 6-62.

  **Note:** The “Custom Operator” is not the same as the “Personal Operator” feature described in other parts of the Avaya Modular Messaging system documentation. It is a similar concept but works differently. The personal operator can be configured for individual subscribers. It is a designated mailbox or extension where the system can transfer callers for assistance when a subscriber cannot answer their calls and the personal operator’s schedule is active. The custom operator can be configured for caller applications. It is a designated extension where the system can transfer callers when they press the operator key (0) as part of their interaction with a caller application.

- **Mailbox**  Select to transfer the caller to the mailbox number specified in the adjacent field. Enter the mailbox number to which to transfer the caller.

  The mailbox must be in the voice mail domain in which the caller application is deployed.

  **Note:**

  - If a voice mail domain is selected for the caller application, the number of digits of the mailbox you specify must be the same as that configured for the selected voice mail domain. For more information, see Number of Digits in a Mailbox, in Telephone User Interface - General Tab on page 3-40.

  - If a voice mail domain is not selected for the caller application, the mailbox number must be equal to or less than 50 digits.

- **Provided by runtime**  Select to have the system automatically use the mailbox number at runtime. If this check box is selected, the Mailbox entry field is disabled.
The number is provided:

— When the caller application has an **Association** that specifies a **Mailbox number**.

For more information, see *Add Association/Association Properties Dialog Box* on page 6-71.

— By a “Front Door” association (the subscriber mailbox has been configured to use the caller application). This association is set in the **Caller Application** field in the **Local Subscriber Administration** page.

**Extension**  Select this option to transfer the caller to a specified extension number.

**Note:** You can enter the extension number in a canonical format beginning with a leading ‘+’ sign. For more information on canonical numbers, see *Avaya Modular Messaging MultiSite Guide*. 
Properties - General - Goto Action Type

The Properties dialog, General tab shows a different display, depending on the Action Type selected. See Properties - General Tab on page 6-44.

Select the Goto Action Type to route the caller directly to another application (action) node or another caller application. This can be useful when you have a common action that you want to reuse in your system.

Configuring the Screen Controls

- **Node**  Select this option to route the caller to another application node in the same caller application. From the pick list, select the application node to which to route the caller.

- **Caller application**  Select this option to route the caller to another caller application. From the pick list, select the caller application to which to route the caller.

**Notes:**

- Caller applications already deployed on the voice mail domain show a different icon from those not deployed. You can add further non-deployed caller applications to the list by clicking on <Add application file...>. When you select the file name and click the Open button, that caller application is added to the list.

- When creating two caller applications that reference one another, any new caller applications that are added to the list should also be deployed.
Properties - General - Conditional Goto Action Type

The Properties dialog, General tab shows a different display, depending on the Action Type selected. See Properties - General Tab on page 6-44.

Select the Conditional Goto Action Type to route the caller directly to another application node, using criteria specified by a schedule.

Configuring the Screen Controls

- **During hours node**  Select the node to which you want to route callers, when the associated schedule is active.

- **After hours node**  Select the node to which you want to route callers, when the associated schedule is not active.

- **Weekly schedule**  Click this button to display the Schedule dialog. Use the schedule grid to set the blocks of time indicating when the schedule is active.

See Schedule Grid on page 6-55.

**Note:** Deployed Caller Applications which contain schedules must be redeployed, if the MAS time zone is changed. This is not necessary for daylight savings time changes.
Properties - General - Send Message Action Type

The Properties dialog, General tab shows a different display, depending on the Action Type selected. See Properties - General Tab on page 6-44.

Select the Send Message Action Type to allow callers to send a message to a subscriber without having to listen to the subscriber’s greeting.

Configuring the Screen Controls

- **Mailbox**  This option allows callers to send a message to a subscriber without having to listen to the subscriber’s greeting. Enter the mailbox number to which the recorded message is sent.

  **Note:**

  - If a voice mail domain is selected for the caller application, the number of digits of the mailbox you specify must be the same as that configured for the selected voice mail domain. For more information, see Number of Digits in a Mailbox, in Telephone User Interface - General Tab on page 3-40.

  - If a voice mail domain is not selected for the caller application, the mailbox number must be equal to or less than 50 digits.

  The mailbox must be in the voice mail domain where the caller application is deployed.

  This field is greyed out by default. You must disable the Provided by runtime field to enable it.

- **Provided by runtime**  Select this option to have the system automatically use the mailbox number at runtime. If this check box is selected, the Mailbox field is disabled. The number is provided:

  - When the caller application has an Association that specifies a Mailbox number.

    For more information, see Add Association/Association Properties Dialog Box on page 6-71.

  - By a “Front Door” association (the subscriber mailbox has been configured to use the caller application). This association is set in the Caller Application field in the Local Subscriber Administration page.

- **E-mail**  Select to enter an e-mail address for recorded messages to be sent to. Enter the e-mail address that the recorded message is sent to. The e-mail address must be in Simple Mail Transport Protocol (SMTP) format, for example, johnb@avaya.com. Use this option:

  - When a recipient does not have a voice mailbox.
— If you want to send recorded messages to multiple recipients in a group or distribution list.

- **Next node** Select the node to which the caller is routed after recording and sending the message.

- **Cancel destination node** Select the node to which the caller application goes, if the caller cancels the operation at this node. The default is `<Parent node>`. In most cases Avaya recommends this option.

---

**Note:** The default setting for all nodes within a caller application can be changed using the **Properties** dialog, **Application** tab. See [Properties - Application Tab](#) on page 6-62.
Properties - General - Termination Action Type

The Properties dialog, General tab shows a different display, depending on the Action Type selected. See Properties - General Tab on page 6-44.

Select the Termination Action Type to terminate the current caller application. It either disconnects the caller from the system or re-routes the caller back to the system Automated Attendant.

Configuring the Screen Controls

- **Disconnect** Disconnects the caller from the system.

- **Automated attendant** Routes the caller to the system Automated Attendant.
  
  This is an automated service that greets callers and instructs them on how to proceed.

- **Logon to mailbox** Routes the caller to the Automated Attendant, which then behaves as if the caller has pressed # to log in to the password protected mailbox.

- **Dial by name** Routes the caller to the Automated Attendant, which then behaves as if the caller has pressed * to key in the person's last name.
Schedule Grid

You can use the schedule grid to set the blocks of time indicating when the schedule is active.

The grid has weekdays along the y-axis and the time of day along the x-axis (see Figure 6-2).

Figure 6-2. Schedule Grid

1 Select all cells in the grid.
2 Select all cells in the column by clicking the column headers.
3 Select all cells in the row by clicking the row headers.

Launching the Screen

The Schedule grid is launched using the Weekly schedule button on the Properties dialog, General tab, for a Conditional Goto Action Type. See Properties - General - Conditional Goto Action Type on page 6-51.

Configuring the Screen Controls

- Clicking a cell toggles its state:
  - The Off state is shown in white.
  - The On state is shown in blue, if your system has a low number of colors available, or a variant of gold, if your system has enough colors.
- To toggle multiple cells at once, click and hold inside a cell and drag the mouse cursor over other cells.
- Schedule View Select the time interval to represent the cells of the grid: 1 hour (default), 15 minutes or 5 minutes.
Observe system holidays as after hours  Select to configure the caller application to check the Automated Attendant's settings. It will then observe the same holidays, like Christmas day, even if mid-week.
Properties - Prompt Tab

This topic describes how to use the Properties dialog, Prompt tab box to configure an application prompt or announcement for the caller application node or application (action) node.

Note: For an overview see Understanding Caller Applications on page 6-3 and, in particular, Importing or Recording Application Prompts on page 6-10.

Launching the Screen

1. In the Modular Messaging Caller Applications window, click on a caller application node that you have created or on an existing application (action) node.

For more information on these nodes, see Caller Applications Node on page 6-26 and Application (Action) Node on page 6-28.

2. Click the Action > Properties icon or menu command. The system displays Properties dialog box for the selected node, with the General tab active.

3. Click the Prompt tab.

Configuring the Screen Controls

- **Play entry prompt** If you want to use a prompt with the node, select this check box. Performing this action activates the other options on this tab.

You can then allocate to the node an existing application prompt, an existing announcement, or to record a new prompt.

- **Allow caller to interrupt prompt** By default the caller is able to interrupt a prompt and press a key, without listening to the full message.

If you want the caller to be forced to listen to the entire message (perhaps for legal reasons), clear this check box.

- **Application prompt** (option button) Select this to record or edit an application prompt using the device at the bottom of the Prompt tab. See Using the Prompt Recording Device on page 6-60.

These prompts are embedded in the caller application and can only be changed by changing the application itself.

Avaya recommends that you do not use application prompts for prompts that you know will need to be changed on a regular basis.
— **Application prompt** (field) You can create a new prompt or select an existing number.

- If you click this icon ![icon](media), the system creates a list entry for the prompt and automatically assigns it an ID number. The number is then displayed in this field.

- If you select an existing prompt from the grid, the system displays its ID number in this field.

— **Application prompt** (grid)

- ![icon](media) This icon adds an new line to the grid.

  **Prompt** The prompt ID number is system generated and displayed automatically.

  **Comment** Enter a brief name or description for the prompt. This is important, if you are not recording the prompt right away, as this helps you remember later what the prompt is to be. Press Enter on your keyboard.

- ![icon](media) This icon deletes the prompt selected in the grid.

— **Announcement** (option button) Select this button to display a list of announcements. These are recorded by authorized subscribers using the TUI and stored in mailboxes.

**Note:** You must set up this authorization in **Subscriber Options**.

Although announcements are called by the caller application, they are not embedded within it.

Announcements are somewhat harder to set up than application prompts but, if you know you will need to change a recording on a regular basis (such as a daily announcement or bulletin board type of arrangement), this is likely the better choice.

— **Announcement** (field) You can create a new announcement or select an existing number.

- If you click this icon ![icon](media), the system creates a list entry for the announcement and automatically assigns it an ID number. The number is then displayed in this field.

- If you select an existing announcement from the grid, the system displays its ID number in this field.

— **Announcement** (pick list) You can select `<default>` or a mailbox number.
- Enter the number of the subscriber mailbox where the announcement is located.

**Note:**

- If a voice mail domain is selected for the caller application, the number of digits of the mailbox you specify must be the same as that configured for the voice mail domain. For more information, see **Number of Digits in a Mailbox**, in [Telephone User Interface - General Tab](#).

- If a voice mail domain is not selected for the caller application, the mailbox number must be equal to or less than 50 digits.

**Note:** If you enter a number which is not already in the pick list, the Caller Applications Editor prompts you to confirm the number, when you press **OK**.

- If the mailbox number is set to `<default>`, the system does not allocate the subscriber mailbox number until the caller application runs. The mailbox number is supplied by an association.

For more information, see **Add Association/Association Properties Dialog Box** on page 6-71.

---

**Announcement** (grid)

- ! This icon adds an new line to the grid.

- **Prompt** The announcement ID number is system generated and displayed automatically.

- **Comments** Enter a brief name or description for the announcement. This is important, if you are not recording the prompt right away, as this helps you remember later what the announcement is to be. Press Enter on your keyboard.

- ✗ This icon deletes the announcement selected in the grid.
Using the Prompt Recording Device

The prompt recording device is available only when the Application prompt option button is selected in the Properties dialog box, Prompt tab. See Properties - Prompt Tab on page 6-57.

**Note:** For an overview see Understanding Caller Applications on page 6-3 and, in particular, Importing or Recording Application Prompts on page 6-10.

Existing Prompt Files

You can drag-and-drop an existing *.WAV file into the prompt recording device area. The recording is then assigned to the prompt currently selected in the Application prompts grid.

**Note:** If you have a prompt recorded professionally, it must be in the form of 8 kHz, 8 bit, mono, G.711 PCM μ-law (mu-law) encoded *.WAV file.

Recording New Prompt Files

You use the prompt recording device area to record a new prompt file. The recording is then assigned to the prompt currently selected in the Application prompts grid.

- Right-click the icon to change the audio device for recording the prompt "on the fly" to:
  - 1 Multimedia - If you use a multimedia PC with a microphone, you can begin recording immediately.
  - 2 Telephone - If you use a telephone to record the prompt, you must wait for the system to dial the telephone and the telephone to ring.

- The green and black display area consists of the timer information, part information, and total time display.
  - Timer Displays where you are in the current prompt.
  - Total Displays the total time of the application prompt.

**Note:** The Parts setting is redundant because application prompts do not have multiple parts.

- Plays back the application prompt.
- Stops the recording or playing back of prompts. You are returned to the beginning of the application prompt.
Interrupts the playback/recording of an application prompt.

Moves back five seconds in the prompt.

Moves forward five seconds in the prompt.

**Note:** The buttons for skipping are redundant because application prompts do not have multiple parts.

Click this button to record an application prompt.

**Note:** You can trim the end of the recording by positioning the slider at the end of the "good" recording, then pressing the Record button and Stop button in quick succession.

— If you are using a multimedia PC with a microphone, you can begin recording immediately.

— If you are using a telephone to record the prompt, you must wait for the system to dial the telephone and the telephone to ring. When it does, pick up the handset and proceed to the next step.

The slider displays the total length of an application prompt. By clicking and dragging on the slider, you can move around in a prompt.

When playing back an application prompt, the progress bar shows the progress during download.
Properties - Application Tab

This topic describes how to use the Properties dialog, Application tab box to configure the default operator, cancel destination node, and ‘no input’ options for all the nodes in the caller application.

**Note:** For an overview see Understanding Caller Applications on page 6-3 and, in particular, Creating & Editing Caller Applications on page 6-7.

Launching the Screen

1. In the Modular Messaging Caller Applications window, click on a caller application node.

   For more information on this node, see Caller Applications Node on page 6-26.

2. Click the Action > Properties icon or menu command. The system displays Properties dialog box for the selected node, with the General tab active.

3. Click the Application tab.

Configuring the Screen Controls

- **Operator options** Determines the type of operator used, when the Operator option is selected for a Transfer Action Type in any node within this caller application. See Properties - General - Transfer Action Type on page 6-48.

  ---
  **Default operator** Select this to route the call to the default system operator as defined for the voice mail domain, if the caller presses the operator key (0).

  To use this option, you must ensure that you have configured a default system operator mailbox number for the voice mail domain.

  **Note:** This is set using the Voice Mail System Configuration window’s Telephone User Interface dialog, Receptionist tab, Default Receptionist Mailbox Number field. See Telephone User Interface - Receptionist Tab on page 3-43.
### Custom operator
Select this to route the call to a custom operator defined for the caller application, if the caller presses the operator key (0). Enter the extension number for the custom operator.

**Note:** You can enter the extension number in a canonical format beginning with a leading '+' sign. For more information on canonical numbers, see *Avaya Modular Messaging MultiSite Guide*.

**Note:** The “Custom Operator” is *not* the same as the “Personal Operator” feature described in other parts of the Avaya Modular Messaging system documentation. It is a similar concept but works differently. The personal operator can be configured for individual subscribers. It is a designated mailbox or extension where the system can transfer callers for assistance when a subscriber cannot answer their calls and the personal operator’s schedule is active. The custom operator can be configured for caller applications. It is a designated extension where the system can transfer callers when they press the operator key (0) as part of their interaction with a caller application.

### Default cancel
Select a node for the call to transfer to, if a caller presses the cancellation key. The default destination is the `<Parent node>`. In most cases Avaya recommends this setting.

This setting is used as the default setting for the same field in the **Properties** dialog, **General** tab of any node within this caller application.

See **Properties - General - Menu Action Type** on page 6-46 and **Properties - General - Send Message Action Type** on page 6-52.

### Default cancel key
Select the key the caller must press to cancel any operation within this caller application.

Typically, the star (*) key is used for this purpose, but you can change it to something else, if you wish.

**Note:** If any key other than * is set, whenever you press the key the caller application cancels the current operation. After canceling the operation the caller application transfers the call to the **Default cancel** node.

### Call answered calls only
Select this check box when you want a caller application to be played only for call answered calls.

Clear the check box to play a caller application for all calls to a subscriber’s mailbox.
This option is used to define whether the disclaimer prompt is played only for call answered calls or for every call. When somebody calls a subscriber who does not answer the phone, and the call is transferred to call answering, a caller application is used to play disclaimer prompt before they can leave a message in the subscriber’s mailbox. The disclaimer prompt lets a caller know that the message left in a subscriber’s mailbox might not be heard and acted upon in the appropriate time frame. The disclaimer prompt is played to ensure that the caller talks to the subscriber directly instead of leaving a message.

Notes:

- The disclaimer prompt is played irrespective of whether the Call answered calls only check box is selected when a subscriber logs in to a mailbox and transfers a call to another subscriber’s mailbox, with which a caller application is associated.

- The disclaimer prompt does not play when the Find Me or Call me is enabled on a subscriber’s mailbox, and the telephone number specified to re-direct unanswered calls has a caller application associated with it.

- **Timeout** Enter the period, in seconds, after which the caller application will transfer the caller to the Next node, when no input has been detected. The default is 5.

  — **Use system default** Select this check box, if you wish to use the default timeout period inherited from the voice mail domain’s settings. The Timeout field is then disabled.

  **Note:** The system default is set using the Voice Mail System Configuration window’s Telephone User Interface dialog, General tab, Default Input Timeout in Seconds field. See Telephone User Interface - General Tab on page 3-40.

- **Retry maximum** Enter the number of times which the caller application will wait the specified Timeout period in seconds for the caller to hit a key, before it takes the timeout action. The default is 3.

  — **Use system default** Select this check box, if you wish to use the default retry number inherited from the voice mail domain’s settings. The Retry maximum field is then disabled.

  **Note:** The system default is set using the Voice Mail System Configuration window’s Telephone User Interface dialog, Receptionist tab, Maximum Number of No Entries field. See Telephone User Interface - Receptionist Tab on page 3-43.

- **Next node** Select a node for the call to transfer to after the timeout and retry period has passed.
The default is `<Disconnect>`.

- **Design for VMD** (Optional) Select this option, if you want to specify the voice mail domain where the caller application will be deployed. Select the voice mail domain from the pick list.

  When selected, voice mail domain-specific values, such as the mailbox length, will be applied to the caller application. If the MultiSite feature is enabled for the voice mail domain, the Caller Application Editor allows mailbox numbers with a length equal to or less than 50.

  This information is not a prerequisite for building a caller application but is useful, if you are editing caller applications offline and cannot easily access voice mail domain information.
Properties - Languages Tab

This topic describes how to use the Properties dialog, Languages tab box to view the language options for the caller application.

Launching the Screen

1. In the Modular Messaging Caller Applications window, click on a caller application node. For more information on this node, see Caller Applications Node on page 6-26.

2. Click the Action > Properties icon or menu command. The system displays Properties dialog box for the selected node, with the General tab active.

3. Click the Languages tab.

Viewing the Screen Controls

- **Languages in caller application** (Display only) This lists all the languages used in the caller application. The item highlighted in the list is the language that is currently being edited.

  **Note:** When you open a caller application, you can select the language you would like to edit from those installed on your Avaya Modular Messaging system. See Open Caller Application Dialog Box on page 6-36.
Change Key Dialog Box

This topic describes how to use the Change Key dialog box to change the access key for the application (action) node to a new key or swap it with an existing one.

If you wish, you can select the keyless option so that there are no TUI key bindings.

Launching the Screen

1. In the Modular Messaging Caller Applications window, click on an application (action) node that you have created.

   For more information on this node, see Application (Action) Node on page 6-28.

2. Click the Action > Change Access Key menu command. The system displays Change Key dialog box.

Configuring the Screen Controls

- **Change access to this key to use** Select this option to change the selected access key to a different access key. Select the new key from the pick list.

   The list only displays keys that have not already been used at this node level.

- **Swap access key with key** Select this option to swaps the selected access key with another node’s access key. Select the key to be swapped from the pick list.

   The list only displays keys that have already been used at this node level.
Message Application Server Dialog Box

This topic describes how to use the Message Application Server dialog box to connect to the messaging application server (MAS).

Once this connection has been made, the Caller Applications Editor is able to determine the voice mail domain(s) available for caller application deployment.

**Note:** It is possible to run the Caller Applications Editor on a stand-alone PC. Because of this you must configure a connection to an MAS, even if the Caller Applications Editor is currently running on that MAS.

Launching the Screen

1. In the Modular Messaging Caller Applications window, click on the Deployed applications node in the tree.
   
   For more information on this node, see Deployed Applications Node on page 6-30.

2. Click the Action > Connect to Message Application Server menu command. The system displays the Message Application Server dialog box.

Configuring the Screen Controls

- **Message Application Server** Enter the name of the message application server to connect to.

  You can use the Browse button, if necessary.
Caller Application Deployment Wizard

This topic describes how to use the **Caller Application Deployment Wizard** to deploy caller applications to a voice mail domain.

**Notes:**

- For an overview see [Understanding Caller Applications](#) on page 6-3 and, in particular, [Deploying Caller Applications to a VMD](#) on page 6-13.

- Any user can create caller applications. To deploy caller applications, you must be a member of a security role assigned the **Caller Apps - Administer** task. This is configured in the **Voice Mail System Configuration** application, **Security Roles** dialog box. See [Security Roles Dialog Box](#) on page 3-88.

- Deployed Caller Applications which contain schedules must be redeployed, if the MAS time zone is changed. This is not necessary for daylight savings time changes.

**Launching the Screen**

1. In the **Modular Messaging Caller Applications** window, click on a ![caller application node that you have created.](#)

   For more information on this node, see [Caller Applications Node](#) on page 6-26.

2. Click the **Action > All Tasks > Deploy Caller Application** menu command. The system displays **Caller Application Deployment Wizard**.

**Caller Application Deployment Wizard Screens**

You can press the **Next/Back** buttons to move to each of these screens:

- **Welcome** Displays a description of the wizard usage.

- **Deployment Details** You can select the voice mail domain to which to deploy the caller application.

  **Note:** There is only one voice mail domain.

- **Deployment in Progress** You can view the progress of the deployment to all message application servers (MASs) in the selected voice mail domain.

- **Finish** Displays a list of MASs within the voice mail domain to which the caller application has been successfully deployed.
Caller Application Undeployment Wizard

This topic describes how to use the Caller Application Undeployment Wizard to undeploy caller applications from a voice mail domain.

Note: For an overview see Understanding Caller Applications on page 6-3 and, in particular, Deploying Caller Applications to a VMD on page 6-13.

Launching the Screen

1. In the Modular Messaging Caller Applications window, double-click on the Deployed applications node.
2. Double-click the voice mail domain node on which caller applications are deployed.
   
   For more information on this node, see Voice Mail Domain Node on page 6-31.
3. Click on a deployed caller application listed in the right hand pane.
4. Click the Action > Delete menu command. You are prompted to confirm the action.
5. Click OK. You are then prompted with the Caller Application Undeployment Wizard.

Caller Application Undeployment Wizard Screens

You can press the Next button to reach each of these screens:

- Welcome Displays a description of the wizard usage.
- Association Removal Displays a list of associations which will be removed from the deployed caller application.
- Undeployment in Progress You can view the progress of the undeployment of the selected caller application from the MASs in the voice mail domain.
- Finish Displays a list of MASs within the voice mail domain from which the caller application has been successfully undeployed.
Add Association/Association Properties Dialog Box

This topic describes how to use the Add Association dialog box to configure links between a deployed caller application and the information from the Telephone User Interface (TUI) used to access the caller application.

Existing associations can be edited using the Association Properties dialog box. This has the same fields.

**Note:** For an overview see Understanding Caller Applications on page 6-3 and, in particular, Creating Associations with the TUI on page 6-17.

### Launching the Add Association Dialog Box

1. In the Modular Messaging Caller Applications window, double-click on the Deployed applications node.
2. Double-click the voice mail domain node on which caller applications are deployed.
3. Click the Associations node.
   
   For more information on this node, see Associations Node on page 6-32.
4. Click the Action > New > Association menu command. The system displays Add Association dialog box.

### Launching the Association Properties Dialog Box

1. Click the Associations node.
2. Click on an existing association listed in the right hand pane.
3. Click the Action > Properties menu command. The system displays Association Properties dialog box for the selected association.

### Configuring the Screen Controls

- **Association name** Enter a unique name for the association.
- **Caller application** Select the name of the caller application that will be launched when the conditions of the association are met.
- **Association ID** Enter the sequence of digits that callers are prompted to enter (as a mailbox number) by the Automated Attendant or caller application. The default is 1.
This is the number used to launch the caller application. If you do not configure this ID number, you must specify a **Called number**.

**Note:** An ID number cannot be longer than the mailbox length specified in the voice mail domain. However, if the ID number has fewer digits than a mailbox number, the caller must enter [#] at the end of the association number to replace the missing digits, or wait for a timeout period.

- **Called number** Enter the direct dial number or extension number that callers must enter to launch the application. If you do not configure this number, you must configure an **Association ID** number.

  **Note:** You must also configure the Called number on the Private Branch Exchange (PBX). Do this in the same way as you would configure an extension number for a user. Set up this Called number to forward all calls to the pilot number. The Called number will then be the number that callers dial to access Avaya Modular Messaging and the caller application.

- **Mailbox number** (Optional) Enter the number of the mailbox. This is used:
  - To supply announcements for the caller application, if the Announcement field in the caller application is set to <default>. See *Properties - Prompt Tab* on page 6-57.
  - As the target location for transfers, when a Transfer Action Type node’s Mailbox number is specified as Provided at runtime. See *Properties - General - Transfer Action Type* on page 6-48.
  - As the target location for sent messages, when a Send message Action Type node’s Mailbox number is specified as Provided at runtime. See *Properties - General - Send Message Action Type* on page 6-52.
Application Analysis Properties Dialog Box

This topic describes how to use the Application Analysis Properties dialog box to configure properties for analyzing deployed caller applications.

Note: For an overview see Understanding Caller Applications on page 6-3 and, in particular, Analyzing Deployed Caller Applications on page 6-20.

Launching the Screen

1. In the Modular Messaging Caller Applications window, double-click on the Deployed applications node.

2. Double-click the voice mail domain node on which caller applications are deployed.

3. Click the Application Analysis node.

For more information on this node, see Application Analysis Node on page 6-33.

4. Click the Action > Properties menu command. The system displays Application Analysis Properties dialog box. There is only one tab, the General tab.

Configuring the Screen Controls

- Include “Front Door” application analysis  Select this check box, if you want to include “Front door” applications in the analysis.

By default, when analyzing caller applications, the Caller Applications Editor excludes subscriber mailboxes that refer to caller applications (known as “Front door” applications.) This is because the task of analyzing all subscriber mailboxes that refer to caller applications can take a considerable amount of time.

Note: Once you have set this property, you must click the Action > Refresh menu command to re-run the application analysis. See Analysis Results Properties Dialog Box on page 6-74.
Analysis Results Properties Dialog Box

This topic describes how to use the Properties dialog box to view the results of analyzed deployed caller applications.

**Note:** For an overview see Understanding Caller Applications on page 6-3 and, in particular, Analyzing Deployed Caller Applications on page 6-20.

Launching the Screen

1. In the Modular Messaging Caller Applications window, double-click on the Deployed applications node.

2. Double-click the voice mail domain node on which caller applications are deployed.

3. Click the Application Analysis node.

For more information on this node, see Application Analysis Node on page 6-33.

**Notes:**

- As soon as you click this node, the Caller Applications Editor performs an analysis of the deployed caller applications.

- If you do not see this node in the tree, click the Action > Refresh menu command.

For more information on this node, see Application Analysis Node on page 6-33.

4. Click on a deployed caller application listed in the right hand pane.

   - Indicates no detected problems.

   - Indicates a problem that needs attention.

5. Click the Action > Properties menu command. The system displays Properties dialog box for the selected analyzed deployed caller application. There is only one tab, the Results tab.

Configuring the Screen Controls

- **Result area/comment** (Display only) The problem areas are marked with a red cross and include further information.

  — Application deployment Identifies MASs in a voice mail domain that are running different versions of the same caller application.
— **Association references** Identifies associations to mailboxes that no longer exist within the voice mail domain.

— **Mailbox references** Identifies references to mailboxes that no longer exist within the voice mail domain.

— **References from application** Identifies non-existent caller applications to which the caller application is attempting to transfer.

— **References to application** Lists the associations and mailboxes that refer to the caller application ("Front Door" mailboxes). This is useful for identifying caller applications that are not in use.

**Copy to clipboard** This copies all text displayed in the Results area/comment to the Windows Clipboard.

**Info** This displays information about whether the references were checked with user “Front Door” associations or not. For more information, see [Application Analysis Properties Dialog Box](#) on page 6-73.
This chapter describes how to use the Reporting Tool to help you monitor the voice mail system usage.

**Procedural Topics**

- **Understanding Reports** on page 7-2.
  - Enabling Transaction Generation on page 7-3.
  - Selecting a Data Source on page 7-4.
  - Exporting a Report on page 7-32.

**Reporting Tool Screens Topics**

- **Reporting Tool Window** on page 7-7.
  - Options Dialog Box on page 7-10.
  - Hourly Statistics Dialog Box on page 7-11.
  - Login Failures Dialog Box on page 7-13.
  - Port Statistics Dialog Box on page 7-15.
  - System Usage Dialog Box on page 7-19.
  - User Mailbox Statistics Dialog Box on page 7-23.
  - Basic Metrics Dialog Box on page 7-27.
  - Export Dialog Box on page 7-30.
  - All Reporting Tool Menus & Icons on page 7-34.
Understanding Reports

The tracing system includes the following storage areas:

- **Transaction database** A permanent storage area for voice mail system activity. The Reporting Tool is used for extracting information from this database. See Reporting Tool Window on page 7-7.

- **Operation history database** A temporary storage area for events that are generated by the voice mail system. The database is purged periodically. The Operation History Viewer is used for viewing events in this database. For more information, see Chapter 8, "Operation History Viewer".

Before Using the Reporting Tool

- Ensure that transaction generation is enabled for the time period you want to report on. See Enabling Transaction Generation on page 7-3.

- If the Reporting Tool is installed on the tracing system machine, a data source is created automatically. If not, you need to select a system data source before you can run the Reporting Tool. See Selecting a Data Source on page 7-4.

- A printer must be installed on the machine on which you wish to view reports.

The Reporting Tool

You can use the Reporting Tool to generate reports for monitoring voice mail system usage, planning capacity, and tracking system security. Report information is taken from the transaction database and generated for the voice mail domain.

- Reporting Tool Window on page 7-7.
- Options Dialog Box on page 7-10.
- Hourly Statistics Dialog Box on page 7-11.
- Login Failures Dialog Box on page 7-13.
- Port Statistics Dialog Box on page 7-15.
- System Usage Dialog Box on page 7-19.
- User Mailbox Statistics Dialog Box on page 7-23.
- Basic Metrics Dialog Box on page 7-27.
- Export Dialog Box on page 7-30.
Enabling Transaction Generation

Before you use the Reporting Tool, you must ensure that transaction generation is enabled for the time period you want to report on.

Procedure 1: Enabling Transaction Generation

1. On your Windows desktop, click the Start > Programs > Avaya Modular Messaging > Voice Mail System Configuration menu to launch the Voice Mail System Configuration window.

2. In the tree view, click the voice mail domain.

3. Double-click Tracing System. The system displays the Tracing System dialog box for the selected VMD, with the General tab active.

4. Click the Transaction Generation tab.

5. Click Enable Transaction Generation.

6. Click OK.

By default, transactions are generated at midnight.

Note: For more information on configuring operation history collection for the voice mail domain, see Tracing System - Transaction Generation Tab on page 3-210.
Selecting a Data Source

If the Reporting Tool is installed on the tracing system machine, a data source is created automatically. If not, you need to select a system data source before you can use the Reporting Tool.

**Note:** If you are using Microsoft Windows Vista, you need to be logged into Windows as an administrator to create a new data source.

Procedure 1: Sharing Out the Transaction Database Directory

On the MAS, or supplementary server, that is running the Tracing Server software, you must share out the directory in which the transaction database resides.

1. In Windows Explorer, locate the directory in which the transaction database (TrxDB.mdb) resides.
   
   By default the path to this directory is: C:\Program Files\Avaya Modular Messaging\Tracing\n
2. Right-click the Tracing directory and, from the pop-up menu, select Sharing & Security.
   
   The system displays the Tracing Properties dialog box.

3. On the Sharing tab, select the Share this folder option.

4. Click Permissions.
   
   The system displays the Permissions for Tracing dialog box.

5. Select Everyone and ensure that at least the Read permission is set.

   **Note:** The other settings may be set at your discretion.

6. In the Permissions for Tracing dialog box, click OK.

7. In the Tracing Properties dialog box, click Apply.

8. In the Tracing Properties dialog box, select the Security tab.

9. Verify that any users who will be using the Reporting Tool have the following permissions set:

   - Read & Execute
   - List Folder Contents
   - Read
10. In the **Tracing Properties** dialog box, click **OK**.

11. Right-click the **TrxDB.mdb** file and, from the pop-up menu, select **Properties**.

12. In the **TrxDB.mdb Properties** dialog box, select the **Security** tab.

13. Verify that any users who will be using the **Reporting Tool** have the following permissions set:
   - **Read & Execute**
   - **List Folder Contents**
   - **Read**

14. In the **TrxDB.mdb Properties** dialog box, click **OK**.

### Procedure 2: Creating a New Data Source

1. If you need to share out the directory in which the transaction database resides, follow "Procedure 1", above.

2. On your **Windows** desktop, click the **Start > Programs > Avaya Modular Messaging > Reporting Tool** menu to launch the **Reporting Tool** window. See **Reporting Tool Window** on page 7-7.

3. Click **File > Source...**

   The system displays the standard **Windows ODBC Data Source Administrator** dialog box.

4. Click the **System DSN** tab.

5. Click the **Add...** button.

   The system displays the standard **Create New Data Source** dialog box.

6. Click **Microsoft Access Driver (*.MDB)** and click **Finish**.

   The system displays the standard **ODBC Microsoft Access Setup** dialog box.

7. In the **Data Source Name** field, type **TrxDB**.

8. Click the **Select...** button.

   The system displays the standard **Select Database** dialog box.

9. Map a drive to the transaction database (**TrxDB.mdb**).
   a. Click the **Network...** button.
b. In the **Drive** field, select a drive letter that has not already been used on this MAS.

c. Enter the path to the transaction database (**TrxDB.mdb**) by doing one of the following:

   - In the **Folder** field, type the pathname using the format
     
     ```
     \servername\Tracing
     ```
     
     where `servername` is the domain name of the MAS, or supplementary server, on which the Tracing Server software is running.

   - Use the **Browse...** button to locate the **Tracing** directory on the MAS, or supplementary server, on which the Tracing Server software is running.

d. Click **Finish**.

10. In the **Select Database** dialog box, set the **Drives** field to the drive you mapped in the previous step.

    The system displays in the **Database Name** field a list of one or more databases on the mapped drive. The transaction database (**TrxDB.mdb**) should be among them.

11. Select **TrxDB.mdb**.

12. Click **OK**.

13. In the **ODBC Microsoft Access Setup** dialog box, click **OK**.

14. In the **ODBC Data Source Administrator** dialog box, click **OK**.
Reporting Tool Window

You can use the Reporting Tool to generate reports for monitoring voice mail system usage, planning capacity, and tracking system security. Report information is taken from the transaction database and generated for the voice mail domain. Some reports can also generate Messaging Application Server (MAS)-specific or user-specific information.

Once you have generated a report, you can zoom in on the screen or print it for easy reference. You can also export a report to different file formats or attach it to a message sent using a MAPI enabled e-mail system.

This chapter describes the Reporting Tool screens and the controls within those screens.

Launching the Application

Before launching the Reporting Tool, ensure that:

- Transaction generation is enabled for the time period you want to report on. See Enabling Transaction Generation on page 7-3.
- Reporting Tool data source references the transaction database on the tracing system machine. See Selecting a Data Source on page 7-4.

On your Windows desktop, click the Start > Programs > Avaya Modular Messaging > Reporting Tool menu to launch the Reporting Tool window.

Setting up Options for Generating Reports

Click the File > Options... menu to launch the Options dialog box. You can specify whether you want a generated report to be displayed on the screen, sent to a printer, or both. See Options Dialog Box on page 7-10.

Generating Reports

The commands in the Reports menu launch dialog boxes which you can use to generate reports. The report then appears in the main Reporting Tool window and/or is sent to a printer.

- Hourly Statistics You can generate a report on the number of incoming/outgoing calls for each hour in a specified time period.

- **Login Failures** You can generate a report on unsuccessful mailbox logins due to incorrect passwords or incorrect mailbox numbers being entered. You specify the time period for which you want to generate this information.

  See [Login Failures Dialog Box](#) on page 7-13, and [Login Failures Report](#) on page 7-14.

- **Port Statistics**... You can generate a report on incoming/outgoing call information for each port configured in the voice mail domain. You specify the time period, ports and MASs for which you want to generate this information.

  See [Port Statistics Dialog Box](#) on page 7-15, and [Port Statistics Report](#) on page 7-17.

- **System Usage**... You can generate a report on call and messaging statistics for the voice mail domain. You specify the time period for which you want to generate this information.

  See [System Usage Dialog Box](#) on page 7-19, and [System Usage Report](#) on page 7-20.

- **User Mailbox Statistics**... You can generate a report on calls made and messages left in each mailbox in the voice mail domain. You specify the time period and mailbox for which you want to generate this information.


- **Basic Metrics**... You can generate a report on statistical information on activity in the voice mail domain. It includes general information on TUI usage and statistical information on subscriber TUI logons. You specify the time period for which you want to generate this information.

  See [Basic Metrics Dialog Box](#) on page 7-27, and [Basic Metrics Report](#) on page 7-28.

### Cancelling a Report During Generation

The **Reporting Tool** displays a dialog box during the report generation. If you wish to cancel the generation of the report, press the **Cancel** button.
Viewing a Report in the Reporting Tool Window

The default view of a report in the Reporting Tool window is zoomed in close, so that you can read the words. Use the standard Windows scroll bars to pan around the screen view.

You can zoom out to see the layout of a report. You can also move between the pages of a multi-page report.

- **View > Zoom** This zooms the display of the report.
  - The first click zooms out.
  - The second click zooms out further to fit the report to the size of the Reporting Tool window.
  - The third click returns you to a close up view, which is the default display.

- **Moves to the previous page of a multi-page report.**

- **Moves to the next page of a multi-page report.**

Printing or Exporting a Report

- **File > Print...** You can print the report currently displayed in the Reporting Tool window.

  You can print most of the reports using either orientation. The User Mailbox Statistics report, however, must be printed in landscape.

- **File > Export...** Launches the Export dialog box, where you can export a report to save the report information, or work with it using alternative tools. See Export Dialog Box on page 7-30.

---

**Note:** You can specify whether you want a generated report to be sent to a printer automatically, using the Options dialog box.
Options Dialog Box

This topic describes how to use the Options dialog box to specify whether you want a generated report to be displayed on the screen, sent to a printer, or both.

Launching the Screen

- File > Options... Launches the Options dialog box.

Configuring the Screen Controls

- Generated report should be Select one or both check boxes.
  
  — Displayed on screen (Default On) All generated reports are displayed in the Reporting Tool window. See Reporting Tool Window on page 7-7.
  
  — Printed (Default Off) All generated reports are printed. The system displays the standard Windows Print dialog box each time a report starts to generate, allowing you to select the print settings.

You can print most of the reports using either orientation. The User Mailbox Statistics report, however, must be printed in landscape.
Hourly Statistics Dialog Box

This topic describes how to use the Hourly Statistics dialog box to generate a report on the number of incoming/outgoing calls for each hour in a specified time period.

This information is useful for monitoring incoming and outgoing call patterns for the voice mail domain.

Launching the Screen

- **Reports > Hourly Statistics...** Launches the Hourly Statistics dialog box.

Configuring the Screen Controls

- **From**
  - **Date** Enter the first date for which report information is to be generated. Use the pull-down calendar for easy selection.
  
  This field defaults to the To - Date value of the previous report run.
  
  - **Time** Enter the first time for which report information is to be generated.
  
  This field defaults to the To - Time value of the previous report run.

- **To**

  - **Date** Enter the last date for which report information is to be generated. Use the pull-down calendar for easy selection.

  - **Time** Enter the last time for which report information is to be generated.

Generating, Viewing & Saving the Report

When you have configured the fields and clicked OK. The system generates the Hourly Statistics report. See Hourly Statistics Report on page 7-12.

You can view, zoom and pan the report in the Reporting Tool window, or print it to view on paper. See Reporting Tool Window on page 7-7. You can configure one or both of these options to happen automatically, using the Options dialog box. See Options Dialog Box on page 7-10.

Generating another report closes the currently displayed report. However, exporting a report has the effect of saving it. See Export Dialog Box on page 7-30.
Hourly Statistics Report

This topic describes the contents of the Hourly Statistics report. To generate this report, see Hourly Statistics Dialog Box on page 7-11.

The Hourly Statistics report shows the number of incoming/outgoing calls for each hour in a specified time period. This information is useful for monitoring incoming and outgoing call patterns for the voice mail domain.

Information on incoming and outgoing calls

- **Date** Displays the date for which report information is generated.
- **Time Periods Starting** Displays the hourly time periods for which report information is generated.
- **Incoming Calls** Displays the number of incoming calls for each hourly time period.
- **Failed Outgoing Calls** Displays the number of failed outgoing calls for each hourly time period.
  - For intercom paging, this refers to a busy or ring-no-answer extension.
  - For calls placed on behalf of a client, this refers to a busy or ring-no-answer extension. This count does not include:
    - Playing messages.
    - Recording greetings.
    - Recording names.
    - Outcalling when the call goes to the called extension's mailbox coverage.
- **Outgoing Calls** Displays the number of outgoing calls for each hourly time period.

Viewing & Saving the Report

You can view, zoom and pan the report in the Reporting Tool window, or print it to view on paper. See Reporting Tool Window on page 7-7. You can configure one or both of these options to happen automatically, as soon as the report is generated, using the Options dialog box. See Options Dialog Box on page 7-10.

Generating another report closes the currently displayed report. However, exporting a report has the effect of saving it. See Export Dialog Box on page 7-30.
Login Failures Dialog Box

This topic describes how to use the Login Failures dialog box to generate a report on unsuccessful mailbox logins due to incorrect passwords or incorrect mailbox numbers being entered. You specify the time period for which you want to generate this information.

Use this report to help monitor voice mail system security for the voice mail domain.

Launching the Screen

- Reports > Login Failures... Launches the Login Failures dialog box.

Configuring the Screen Controls

- From
  - Date Enter the first date for which report information is to be generated. Use the pull-down calendar for easy selection.

  This field defaults to the To - Date value of the previous report run.

  - Time Enter the first time for which report information is to be generated.

  This field defaults to the To - Time value of the previous report run.

- To
  - Date Enter the last date for which report information is to be generated. Use the pull-down calendar for easy selection.

  - Time Enter the last time for which report information is to be generated.

Generating, Viewing & Saving the Report

When you have configured the fields and clicked OK. The system generates the Login Failures report. See Login Failures Report on page 7-14.

You can view, zoom and pan the report in the Reporting Tool window, or print it to view on paper. See Reporting Tool Window on page 7-7. You can configure one or both of these options to happen automatically, using the Options dialog box. See Options Dialog Box on page 7-10.

Generating another report closes the currently displayed report. However, exporting a report has the effect of saving it. See Export Dialog Box on page 7-30.
Login Failures Report

This topic describes the contents of the Login Failures report. To generate this report, see Login Failures Dialog Box on page 7-13.

The Login Failures report shows unsuccessful mailbox logins due to incorrect passwords or incorrect mailbox numbers being entered in a specified time period. Use this report to help monitor voice mail system security for the voice mail domain.

Unsuccessful mailbox login attempts due to incorrect password

- The first row displays information about individual mailboxes.
  - **Mailbox Number** The mailbox number for which an unsuccessful login is recorded.
  - **Mailbox Name** The mailbox name for which an unsuccessful login is recorded.
  - **Last Failed Login** The date and time of the last unsuccessful mailbox login due to an incorrect password being entered three consecutive times on the same call.
  - **Total Failed Logins** The total number of unsuccessful mailbox logins due to an incorrect password being entered three consecutive times on the same call.

- The second row shows system-wide information.
  - **Number of invalid mailbox numbers entered** The total number of unsuccessful mailbox logins due to an invalid mailbox number being entered.

Viewing & Saving the Report

You can view, zoom and pan the report in the Reporting Tool window, or print it to view on paper. See Reporting Tool Window on page 7-7. You can configure one or both of these options to happen automatically, as soon as the report is generated, using the Options dialog box. See Options Dialog Box on page 7-10.

Generating another report closes the currently displayed report. However, exporting a report has the effect of saving it. See Export Dialog Box on page 7-30.
Port Statistics Dialog Box

This topic describes how to use the Port Statistics dialog box to generate a report on incoming/outgoing call information for each port configured in the voice mail domain. You specify the time period, ports and MASs for which you want to generate this information. The report only includes MASs for which port statistics are recorded.

You can use this report for monitoring port usage.

Launching the Screen

- Reports > Port Statistics... Launches the Port Statistics dialog box.

Configuring the Screen Controls

- Port Numbers Specify the port numbers for which report information is to be generated.
  - All Available Select to specify all ports.
  - Selection Select to specify certain ports and enter the port numbers using a comma separator.

  You can enter a range of port numbers, for example, 1-8,16-24. No negative numbers or spaces are allowed in a range. The first number in a range must be less than the last number in a range.

- Server Selection Select the MAS or MASs for which report information is to be generated.

  You can quickly select all servers in the database by selecting All Servers. Report generation is quicker when this option is selected.

- From

  - Date Enter the first date for which report information is to be generated. Use the pull-down calendar for easy selection.

    This field defaults to the To - Date value of the previous report run.

  - Time Enter the first time for which report information is to be generated.

    This field defaults to the To - Time value of the previous report run.

- To

  - Date Enter the last date for which report information is to be generated. Use the pull-down calendar for easy selection.
— **Time**  Enter the last time for which report information is to be generated.

### Generating, Viewing & Saving the Report

When you have configured the fields and clicked **OK**. The system generates the **Port Statistics** report. See [Port Statistics Report](#) on page 7-17.

You can view, zoom and pan the report in the **Reporting Tool** window, or print it to view on paper. See [Reporting Tool Window](#) on page 7-7. You can configure one or both of these options to happen automatically, using the **Options** dialog box. See [Options Dialog Box](#) on page 7-10.

Generating another report closes the currently displayed report. However, exporting a report has the effect of saving it. See [Export Dialog Box](#) on page 7-30.
Port Statistics Report

This topic describes the contents of the Port Statistics report. To generate this report, see Port Statistics Dialog Box on page 7-15.

The Port Statistics report shows incoming/outgoing call information for each port configured in the voice mail domain. This is for a specified time period, a range of ports, and specified MASs. Note that the report only includes MASs for which port statistics are recorded.

Information on each port configured in the VMD

- **Individual Port Statistics**
  - **Server Name**  The server for which port statistics are reported.
  - **Port Number**  The port for which incoming and outgoing call statistics are reported.
  - **Incoming Calls**  The number of incoming calls to the port.
  - **Outgoing Calls**  The number of outgoing calls from the port.

  **Note:** This number does not include Call Me notification calls.

  - **Time Busy (seconds)**  The total time, in seconds, that the port was not idle.
  - **Percentage**  The percentage of time that the port was not idle.

- **All Ports Statistics**
  - **Total Number of Incoming Calls**  The total number of incoming calls to all ports.
  - **Total Number of Outgoing Calls**  The total number of outgoing calls from all ports.
  - **Time Port Availability Below Optimum**  The total time during which many ports were too busy to make any more outgoing calls.
  - **Time All Voice Ports Simultaneously Busy**  The total time during which all ports were simultaneously busy. This field displays "0" if all incalling ports are busy while outcalling only ports are idle.
Viewing & Saving the Report

You can view, zoom and pan the report in the Reporting Tool window, or print it to view on paper. See Reporting Tool Window on page 7-7. You can configure one or both of these options to happen automatically, as soon as the report is generated, using the Options dialog box. See Options Dialog Box on page 7-10.

Generating another report closes the currently displayed report. However, exporting a report has the effect of saving it. See Export Dialog Box on page 7-30.
System Usage Dialog Box

This topic describes how to use the System Usage dialog box to generate a report on call and messaging statistics for the voice mail domain. You specify the time period for which you want to generate this information.

Launching the Screen

- Reports > System Usage... Launches the System Usage dialog box.

Configuring the Screen Controls

- From
  - Date Enter the first date for which report information is to be generated. Use the pull-down calendar for easy selection.
  - This field defaults to the To - Date value of the previous report run.
  - Time Enter the first time for which report information is to be generated.
  - This field defaults to the To - Time value of the previous report run.

- To
  - Date Enter the last date for which report information is to be generated. Use the pull-down calendar for easy selection.
  - Time Enter the last time for which report information is to be generated.

Generating, Viewing & Saving the Report

When you have configured the fields and clicked OK. The system generates the System Usage report. See System Usage Report on page 7-20.

You can view, zoom and pan the report in the Reporting Tool window, or print it to view on paper. See Reporting Tool Window on page 7-7. You can configure one or both of these options to happen automatically, using the Options dialog box. See Options Dialog Box on page 7-10.

Generating another report closes the currently displayed report. However, exporting a report has the effect of saving it. See Export Dialog Box on page 7-30.
System Usage Report

This topic describes the contents of the System Usage report. For information on how to generate this report, see System Usage Dialog Box on page 7-19.

The System Usage report shows call and messaging statistics for the voice mail domain for a specified time period. Note that, if you are using a nonintegrated MAS, you do not receive information on the calling party.

VMD-wide call and messaging statistics

- General Call Information
  - Number of Incoming Calls The total number of incoming calls received by the voice mail domain.
  - Number of Times Users Logged On The total number of subscribers who successfully entered their mailbox number and password.
  - Time All Ports Busy (seconds) The total time, in seconds, during which all ports were simultaneously busy.
  - Time All Text-to-Speech Ports Busy (seconds) The total time, in seconds, during which all text-to-speech ports were simultaneously busy.
  - Number of Successful Calls to Fax Gateway The number of fax calls successfully passed from the MAS to the fax server.
  - Number of Failed Calls to Fax Gateway The number of fax calls that failed to pass from the MAS to the fax server.

- Callers Actions
  - Dialed Extension The number of times callers to the voice mail domain requested the Automated Attendant to transfer them to an extension.
  - Defaulted to Assistance The number of times callers were transferred to operator assistance by default, for example, callers using rotary telephones.
  - Dialed 0 for Assistance The number of times callers to the voice mail domain pressed [0] for operator assistance.
  - Left a Message for a Subscriber The number of times callers to the voice mail domain left a message for a subscriber.
  - Pressed # to Logon The number of times callers to the voice mail domain pressed [#] to log on. This records the number of attempted logins.
- **Asked to Leave a Quick Message**  The number of times callers were asked to leave a voice message using the Quick Message service, as set in the Automated Attendant.

**Note:** This feature is configured in the Voice Mail System Configuration application, Auto Attendant dialog box. See Auto Attendant Dialog Box on page 3-59.

### Incoming Call Summary

<table>
<thead>
<tr>
<th>Reason Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Due to Busy</strong></td>
<td>The number of calls handled by the voice mail domain because an extension was busy. This refers to calls placed directly to a busy extension using direct inward dialing (DID) and calls transferred to a busy extension by the voice mail system.</td>
</tr>
<tr>
<td><strong>Due to RNA</strong></td>
<td>The number of calls handled by the voice mail domain because an extension was not answered. This refers to calls placed directly to an unanswered extension using direct inward dialing (DID) and calls transferred to an unanswered extension by the voice mail system.</td>
</tr>
<tr>
<td><strong>Direct Calls</strong></td>
<td>The number of times that a subscriber dialed the access number of the voice mail system from that subscriber’s own extension.</td>
</tr>
<tr>
<td><strong>Diverted Calls</strong></td>
<td>The number of times that calls to an extension were automatically forwarded to the voice mail domain.</td>
</tr>
<tr>
<td><strong>Unknown Calls</strong></td>
<td>The number of times that calls to an extension were automatically transferred to the voice mail domain but for none of the reasons given in the Incoming Call Summary section of the report.</td>
</tr>
</tbody>
</table>

### Outgoing Calls Summary

<table>
<thead>
<tr>
<th>Reason Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Number of Calls Placed that Were Not Answered</strong></td>
<td>The number of calls placed on behalf of a client that were transferred to an unanswered extension.</td>
</tr>
<tr>
<td><strong>Number of Calls Placed to Busy Extensions</strong></td>
<td>The number of calls placed on behalf of a client that were transferred to a busy extension.</td>
</tr>
<tr>
<td><strong>Number of Calls that Got Connected</strong></td>
<td>The number of calls successfully transferred to an extension on behalf of a client.</td>
</tr>
<tr>
<td><strong>Total Number of Outgoing Calls Excluding Calls to Clients</strong></td>
<td>The total number of calls that were due to intercom paging.</td>
</tr>
</tbody>
</table>
— **Number of Failed Outgoing Calls Excluding Calls to Clients**  The number of unsuccessful calls that were due to intercom paging.

— **Number of Connected Outgoing Calls Excluding Calls to Clients**  The number of successful calls that were due to intercom paging.

**Message Summary**

— **Busy**  The number of voice messages left because an extension was busy.

— **RNA**  The number of voice messages left because of a Ring No Answer response.

— **Direct**  The number of voice messages left when calling the system directly, when the Automated Attendant is disabled.

— **Subscriber**  The number of messages left from another subscriber.

— **Quick Message**  The number of voice messages left using the Quick Message service, as set in the Automated Attendant.

— **Transfer to Mailbox**  The number of calls transferred directly to the mailbox of a subscriber, as set in the Automated Attendant.

These features are configured in the **Voice Mail System Configuration** application, **Auto Attendant** dialog box. See **Auto Attendant Dialog Box** on page 3-59.

**Viewing & Saving the Report**

You can view, zoom and pan the report in the **Reporting Tool** window, or print it to view on paper. See **Reporting Tool Window** on page 7-7. You can configure one or both of these options to happen automatically, as soon as the report is generated, using the **Options** dialog box. See **Options Dialog Box** on page 7-10.

Generating another report closes the currently displayed report. However, exporting a report has the effect of saving it. See **Export Dialog Box** on page 7-30.
User Mailbox Statistics Dialog Box

This topic describes how to use the User Mailbox Statistics dialog box to generate a report on calls made and messages left in each mailbox in the voice mail domain. You specify the time period and mailbox for which you want to generate this information.

Use this report to help monitor mailbox usage.

Launching the Screen

- Reports > User Mailbox Statistics... Launches the User Mailbox Statistics dialog box.

Configuring the Screen Controls

- From
  - Date Enter the first date for which report information is to be generated. Use the pull-down calendar for easy selection.
  
  This field defaults to the To - Date value of the previous report run.
  
  - Time Enter the first time for which report information is to be generated.
  
  This field defaults to the To - Time value of the previous report run.

- To
  - Date Enter the last date for which report information is to be generated. Use the pull-down calendar for easy selection.
  
  - Time Enter the last time for which report information is to be generated.

- Mailbox Numbers Specify the mailbox numbers for which report information is to be generated.
  
  - All Available Select to specify all mailboxes.
  
  - Selection Select to specify certain mailboxes and enter the mailbox numbers using a comma separator.

You can enter a range of mailbox numbers, for example, 1000-1050, 2000-2025. No negative numbers or spaces are allowed in a range. The first number in a range must be less than the last number in a range.
Sort By  Specify how the report information is to be sorted.

— Mailbox Number  This information is sorted in ascending order.

— User's Name  This is sorted in alphabetical order

Generating, Viewing & Saving the Report

When you have configured the fields and clicked OK. The system generates the User Mailbox Statistics report. See User Mailbox Statistics Report on page 7-25.

You can view, zoom and pan the report in the Reporting Tool window, or print it to view on paper. See Reporting Tool Window on page 7-7.

Note: Before you print a User Mailbox Statistics report, ensure that the page orientation is set to landscape.

You can configure one or both of these options to happen automatically, using the Options dialog box. See Options Dialog Box on page 7-10.

Generating another report closes the currently displayed report. However, exporting a report has the effect of saving it. See Export Dialog Box on page 7-30.
**User Mailbox Statistics Report**

This topic describes the contents of the **User Mailbox Statistics** report. For information on how to generate this report, see **User Mailbox Statistics Dialog Box** on page 7-23.

The **User Mailbox Statistics** report shows calls made and messages left in each mailbox in the voice mail domain for a specified time period. Note that, if you are using a non-integrated MAS, you do not receive information on the calling party.

**Mailbox Specific Statistics**

- **Mbox#** The mailbox number for which report information is generated.
- **MailboxName** The mailbox name for which report information is generated.
- **Incoming Calls Xfered to Ext**
  - **Total** The total number of incoming calls to the extension associated with the mailbox.
- **Messages Left for User**
  - **Ext. Busy** The number of voice messages left in the mailbox because the extension was busy.
  - **Ext. RNA** The number of voice messages left in the mailbox because the extension was not picked up.
  - **Direct** The number of voice messages left when calling the system directly, when the Automated Attendant is disabled.
  - **By Subscribers** The number of voice messages left by other subscribers.
  - **Via QuickMsg** The number of voice messages left using the Quick Message service, as set in the Automated Attendant.
  - **Via Xfer to MB** The number of calls transferred directly to the mailbox of a subscriber, as set in the Automated Attendant.

**Note:** This feature is configured in the **Voice Mail System Configuration** application, **Auto Attendant** dialog box. See **Auto Attendant Dialog Box** on page 3-59.

**Other**

- **Logons** The total number of successful logons to the mailbox.
— **Abandoned** The number of calls disconnected after reaching an unavailable extension without leaving a voice message, calling another extension, or transferring to the operator.

**Note:** There is one case in which an abandoned call is counted as successful. This is when a caller is put through to an extension but just before the recipient of the call has had the time to answer the call, the caller hangs up.

### Viewing & Saving the Report

You can view, zoom and pan the report in the Reporting Tool window, or print it to view on paper. See Reporting Tool Window on page 7-7.

**Note:** Before you print a User Mailbox Statistics report, ensure that the page orientation is set to landscape.

You can configure one or both of these options to happen automatically, as soon as the report is generated, using the Options dialog box. See Options Dialog Box on page 7-10.

Generating another report closes the currently displayed report. However, exporting a report has the effect of saving it. See Export Dialog Box on page 7-30.
Basic Metrics Dialog Box

This topic describes how to use the Basic Metrics dialog box to generate a report on statistical information on activity in the voice mail domain for a specified time period. It includes general information on TUI usage and statistical information on subscriber TUI logons.

Launching the Screen

- Reports > Basic Metrics... Launches the Basic Metrics dialog box.

Configuring the Screen Controls

- From
  - Date Enter the first date for which report information is to be generated. Use the pull-down calendar for easy selection.
    
    This field defaults to the To - Date value of the previous report run.
  
  - Time Enter the first time for which report information is to be generated.
    
    This field defaults to the To - Time value of the previous report run.

- To
  
  - Date Enter the last date for which report information is to be generated. Use the pull-down calendar for easy selection.
  
  - Time Enter the last time for which report information is to be generated.

Generating, Viewing & Saving the Report

When you have configured the fields and clicked OK, the system generates the Basic Metrics report. See Basic Metrics Report on page 7-28.

You can view, zoom and pan the report in the Reporting Tool window, or print it to view on paper. See Reporting Tool Window on page 7-7. You can configure one or both of these options to happen automatically, using the Options dialog box. See Options Dialog Box on page 7-10.

Generating another report closes the currently displayed report. However, exporting a report has the effect of saving it. See Export Dialog Box on page 7-30.
Basic Metrics Report

This topic describes the contents of the Basic Metrics report. To generate this report, see Basic Metrics Dialog Box on page 7-27.

The Basic Metrics report shows statistical information on activity in the voice mail domain for a specified time period. It includes general information on TUI usage and statistical information on subscriber TUI logons.

VMD-wide call and messaging statistics

- **General Information**
  - **Total Incoming Calls** Displays the total number of incoming calls answered by the system.
  - **Total Messages Processed** Displays the total number of voice messages submitted for delivery.
  - **Total Subscriber Logon (TUI) Attempts** Displays the total number of times that subscribers attempted to log onto the TUI.
  - **Total Subscriber Logon (TUI) Successes** Displays the total number of times that subscribers successfully logged onto the TUI.

- **Analysis**
  - **Percentage of Incoming Calls resulting in Messages** Displays the number of incoming calls answered, which resulted in the caller leaving a voice message, as a percentage of the total number of incoming calls answered. This percentage does not include Notify Me messages.
  - **Subscriber Logons (TUI) as a percentage of Incoming Calls** Displays the number of times subscribers successfully logged onto the TUI, as a percentage of the total number of incoming calls answered by the system.
  - **Subscriber Logons (TUI) as a percentage of Logon Attempts** Displays the number of times that subscribers successfully logged onto the TUI, as a percentage of the total number of times that subscribers attempted to log onto the TUI.
  - **Percentage of Failed Logon Attempts (Client hanging up and system failures)** Displays the number of TUI logon attempts by subscribers that failed due to subscriber action or disconnection before the retry count was reached, as a percentage of the total number of times that subscribers attempted to log onto the TUI.
Percentage of Subscriber Logon Failures (Incorrect PW or incorrect Mailbox #s) Displays the number of TUI logon attempts by subscribers that failed due to the subscriber entering an invalid password or mailbox number, as a percentage of the total number of times that subscribers attempted to log onto the TUI.

Viewing & Saving the Report

You can view, zoom and pan the report in the Reporting Tool window, or print it to view on paper. See Reporting Tool Window on page 7-7. You can configure one or both of these options to happen automatically, as soon as the report is generated, using the Options dialog box. See Options Dialog Box on page 7-10.

Generating another report closes the currently displayed report. However, exporting a report has the effect of saving it. See Export Dialog Box on page 7-30.
Export Dialog Box

The export facility supports a number of popular spreadsheet, word processor, and data interchange formats. You can also attach an exported report file to a message sent using a MAPI-enabled e-mail system. The message displays an icon to indicate a report is attached.

This topic describes how to use the Export dialog box to export a report. Each field and option is described below.

Note: For the full procedure on how to use with this dialog box and the subsequent system prompts, see Exporting a Report on page 7-32.

Launching the Screen

- File > Export... Launches the Export dialog box.

Configuring the Screen Controls

- Format Select the export file format.
  
  — Character-separated values Encloses alphanumeric field data in quotes and separates fields with the character of your choice.

  You must also specify settings in the Character-Separated Values and Number and Date Format dialog boxes. See Exporting a Report on page 7-32.

  — Comma-separated values (CSV) Encloses alphanumeric field data in quotes and separates fields with commas.

  You must also specify settings in the Number and Date Format dialog box.

  — Crystal Reports (RPT) Native Crystal Reports format

  — Data Interchange Format (DIF) Often used for the transfer of data between different spreadsheet programs.

  You must also specify settings in the Number and Date Format dialog box.

  — Excel 2.1 (XLS), Excel 3.0 (XLS), Excel 4.0 (XLS), Excel 5.0 (XLS) Microsoft Excel Spreadsheet.

— **Record style (columns of values)**  Table-like format.

  You must also specify settings in the **Number and Date Format** dialog box.

— **Rich Text Format**  Standard RTF format.

— **Tab-separated text**  Saves the data in ASCII text format with all values separated by tabs.

— **Tab-separated values**  Presents data in tabular form. Encloses alphanumeric field data in quotes and separates fields with tabs.

  You must also specify settings in the **Number and Date Format** dialog box.

— **Text**  Saves the data in ASCII text format with all values separated by spaces. This style looks most like the printed page.

— **Word for Windows document**  Standard Word for Windows format.

---

**Note:** Click **Outline** view when viewing a report. Word does not display report headings in **Normal** view. You can print a report while using any view.

---

**Destination**  Select the export file destination.

— **Disk file**  Saves the exported report in a file.

— **Microsoft Mail (MAPI)**  Attaches the exported report file to a message sent using a MAPI-enabled e-mail system. The message displays an icon to indicate a report is attached. For more information, see Exporting a Report on page 7-32.
Exporting a Report

For details of all the controls and options in the Export dialog box, see Export Dialog Box on page 7-30.

The following procedures detail how to export a report in the Reporting Tool.

Procedure 1: Exporting a Report

1. Click the File > Export menu to launch the Export dialog box.
2. Select the appropriate Format and Destination and click OK.
3. Some options launch another dialog box. Select the required formats and click OK.

   - The Character-separated values option launches the Character-Separated Values dialog box.
     - Separator Enter the character to separate the field data.
     - Quote Enter double or single quotation marks to enclose alphanumeric field data.

   - The Character-separated values, Comma-separated values (CSV), Data Interchange Format (DIF), Record style (columns of values) and Tab-separated values options launch the Number and Date format dialog box.
     - Same number formats as in report Select to export number formats as they appear in the report.
     - Same date formats as in report Select to export date formats as they appear in the report.

4. The system then launches another dialog box, depending on the selection you made in the Export dialog box, Destination field.

   For Disk file, see “Procedure 2”, below. For Microsoft Mail (MAPI), See “Procedure 3” below.

Procedure 2: Exporting to a Disk File

1. Follow “Procedure 1”, above.
2. If you selected Disk file as the Destination in the Export dialog box, the system launches the File dialog box.
3. Select a file name and directory location for the report file using this standard Windows Export dialog box. If you need more information, see your Microsoft Windows documentation.
Procedure 3: Exporting to Microsoft Mail (MAPI)

1. Follow “Procedure 1”, above.

2. If you selected Microsoft Mail (MAPI) as the Destination in the Export dialog box, the system launches the Send Mail dialog box.

3. Complete the To/Cc and Subject fields in the standard way.
   You can search for and select a recipient by clicking Address. This opens the standard Windows Address Book.

4. If you want to validate the address details, click Check Names in the Send Mail dialog box.

5. Enter your message text in the Message field.

6. Click Send to send the message and attached report.
All Reporting Tool Menus & Icons

The Reporting Tool window has a menu bar and a toolbar. This topic provides a reference list of all menu and icon commands. See Reporting Tool Window on page 7-7.

File Menu

- File > Export... Launches the Export dialog box, where you can export a report to save the report information, or work with it using alternative tools. See Export Dialog Box on page 7-30.

- File > Print... You can print a report displayed on the screen. You can print most of the reports using either orientation. The User Mailbox Statistics report, however, must be printed in landscape.

  Note: You can specify whether you want a generated report to be sent to a printer automatically, using the Options dialog box.

- File > Source... Launches the standard Windows ODBC Data Source Administrator dialog box, where you can select a system data source. See Selecting a Data Source on page 7-4.

  Note: If the Reporting Tool is installed on the tracing system machine, a data source is created automatically and you do not need to select it here.

- File > Options... Launches the Options dialog box. You can specify whether you want a generated report to be displayed on the screen, sent to a printer, or both. See Options Dialog Box on page 7-10.

- File > Exit Closes down the Reporting Tool.

View Menu

- View > Zoom This zooms the display of the report.
  
    — The first click zooms out.
  
    — The second click zooms out further to fit the report to the size of the Reporting Tool window.
  
    — The third click returns you to a close up view, which is the default display.

The following icons do not have a corresponding menu command:

- Moves to the previous page of a multi-page report.

- Moves to the next page of a multi-page report.
**Reports Menu**

- **Reports > Hourly Statistics...** Launches the **Hourly Statistics** dialog box. You can generate a report on the number of incoming/outgoing calls for each hour in a specified time period. See [Hourly Statistics Dialog Box](#) on page 7-11.

- **Reports > Login Failures...** Launches the **Login Failures** dialog box. You can generate a report on unsuccessful mailbox logins due to incorrect passwords or incorrect mailbox numbers being entered. You specify the time period for which you want to generate this information. See [Login Failures Dialog Box](#) on page 7-13.

- **Reports > Port Statistics...** Launches the **Port Statistics** dialog box. You can generate a report on incoming/outgoing call information for each port configured in the voice mail domain. You specify the time period, ports and MASs for which you want to generate this information. See [Port Statistics Dialog Box](#) on page 7-15.

- **Reports > System Usage...** Launches the **System Usage** dialog box. You can generate a report on call and messaging statistics for the voice mail domain. You specify the time period for which you want to generate this information. See [System Usage Dialog Box](#) on page 7-19.

- **Reports > User Mailbox Statistics...** Launches the **User Mailbox Statistics** dialog box. You can generate a report on calls made and messages left in each mailbox in the voice mail domain. You specify the time period and mailbox for which you want to generate this information. See [User Mailbox Statistics Dialog Box](#) on page 7-23.

- **Reports > Basic Metrics...** Launches the **Basic Metrics** dialog box. You can generate a report on statistical information on activity in the voice mail domain. It includes general information on TUI usage and statistical information on subscriber TUI logons. See [Basic Metrics Dialog Box](#) on page 7-27.

**Help Menu**

- **Help > Help Topics** Launches the **Reporting Tool Help**.

- **Help > About Modular Messaging** Launches the **About Modular Messaging** window.
This chapter describes how to use the **Operation History Viewer**. You can view events generated by voice mail system activity and logged in the operation history database.

**Procedural Topics**

- **Understanding Operation History Events** on page 8-2.
  - Enabling the Collection of Operation History Events on page 8-3.
  - Selecting a Data Source & ODBC Tracing on page 8-4.
  - Creating, Viewing & Exporting Sessions on page 8-8.

**Operation History Viewer Screens Topics**

- **Operation History Viewer Window** on page 8-14.
  - Session Properties Dialog Box on page 8-17.
  - Event Properties Dialog Box on page 8-20.
  - Options Dialog Box on page 8-21.
  - Values Dialog Box on page 8-25.
  - Export Operation History Events Dialog Box on page 8-26.
  - All Operation History Viewer Menus & Icons on page 8-27.
Understanding Operation History Events

The tracing system includes the following storage areas:

- **Transaction database**  This is a permanent storage area for voice mail system activity. The Reporting Tool is used for extracting information from this database. For more information, see Chapter 7, “Reporting Tool”.

- **Operation history database**  This is a temporary storage area for events that are generated by the voice mail system. The database is purged periodically. The Operation History Viewer is used for viewing events in this database. See Operation History Viewer Window on page 8-14.

Notes:

- For information on configuring this database, please refer to the Avaya Modular Messaging Concepts and Planning Guide.

- For a 1523 application event, use the Microsoft ODBC tool to repair the database (ophist.mdb). If it cannot be repaired, replace the corrupt ohist.mdb with an empty ohist.mdb.

Procedures for Using the Operation History Viewer

- Before you can view events in the Operation History Viewer, you must enable operation history collection for the voice mail domain. See Enabling the Collection of Operation History Events on page 8-3.

- If the Operation History Viewer is installed on the tracing system machine, a data source is created automatically. If not, you need to select a system data source before you can use the Operation History Viewer. See Selecting a Data Source & ODBC Tracing on page 8-4.

Note: If ODBC logging is enabled on the MAS, system performance degrades. ODBC tracing should be enabled for debugging only.

- See Creating, Viewing & Exporting Sessions on page 8-8.
  
  — “Procedure 1: Creating & Viewing a Live Session”.
  
  — “Procedure 2: Creating & Viewing a Historical Session”.
  
  — “Procedure 3: Saving a Session”.
  
  — “Procedure 4: Opening a Session”.
  
  — “Procedure 5: Changing Session Properties”.
  
  — “Procedure 6: Exporting Operation History Events”.
Enabling the Collection of Operation History Events

Before you can view events in the Operation History Viewer, you must enable operation history collection for the voice mail domain.

Procedure 1: Enabling the Collection of Operation History Events

1. On your Windows desktop, click the Start > Programs > Avaya Modular Messaging > Voice Mail System Configuration menu to launch the Voice Mail System Configuration window.

2. In the tree view, click the voice mail domain.

3. Double-click Tracing System. The system displays the Tracing System dialog box for the selected VMD, with the General tab active.

4. Click the Operation History Collection tab.

5. Click Enable Operation History Collection.

6. Click OK.

Note: For more information on configuring operation history collection for the voice mail domain, see Tracing System - Operation History Collection Tab on page 3-209.
Selecting a Data Source & ODBC Tracing

If the Operation History Viewer is installed on the tracing system machine, a data source is created automatically. If not, you need to select a system data source before you can use the Operation History Viewer. See “Procedure 1” and “Procedure 2”, below.

Notes:

- If you are using Microsoft Windows Vista, you need to be logged into Windows as an administrator to create a new data source.

- If ODBC logging is enabled on the MAS, performance for the system degrades. ODBC tracing should be enabled for debugging purposes only. To disable ODBC tracing, see “Procedure 3”, below.

Procedure 1: Sharing Out the Operation History Database Directory

On the MAS, or supplementary server, that is running the Tracing Server software, you must share out the directory in which the operation history database resides.

1. In Windows Explorer, locate the directory in which the operation history database (OpHist.mdb) resides.

   By default the path to this directory is: C:\Program Files\Avaya Modular Messaging\Tracing\n
2. Right-click the Tracing directory and, from the pop-up menu, select Sharing & Security.

   The system displays the Tracing Properties dialog box.

3. On the Sharing tab, select the Share this folder option.

4. Click Permissions.

   The system displays the Permissions for Tracing dialog box.

5. Select Everyone and ensure that at least the Full Control permission is set.

   Note: The other settings may be set at your discretion.

6. In the Permissions for Tracing dialog box, click OK.

7. In the Tracing Properties dialog box, click Apply.

8. In the Tracing Properties dialog box, select the Security tab.
9. Verify that any users who will be using the *Operation History Viewer* have the following permissions set:
   - Read & Execute
   - List Folder Contents
   - Read

10. In the *Tracing Properties* dialog box, click **OK**.

11. Right-click the *OpHist.mdb* file and, from the pop-up menu, select *Properties*.

12. In the *OpHist.mdb Properties* dialog box, select the *Security* tab.

13. Verify that any users who will be using the *Operation History Viewer* have the following permissions set:
   - Read & Execute
   - List Folder Contents
   - Read

14. In the *OpHist.mdb Properties* dialog box, click **OK**.

**Procedure 2: Creating a New Data Source**

1. If you need to share out the directory in which the operation history database resides, follow “Procedure 1”, above.

2. On your *Windows* desktop, click the *Start > Programs > Avaya Modular Messaging > Operation History Viewer* menu to launch the *Operation History Viewer* window. See *Operation History Viewer Window* on page 8-14.

3. Click *File > Data Source*....
   The system displays the standard Windows *ODBC Data Source Administrator* dialog box.

4. Click the *System DSN* tab.

5. Click the *Add*... button.
   The system displays the standard *Create New Data Source* dialog box.

6. Click *Microsoft Access Driver (*.MDB)* and click *Finish*.
   The system displays the standard *ODBC Microsoft Access Setup* dialog box.
7. In the Data Source Name field, type OperationHistory.

8. Click the Select... button.

   The system displays the standard Select Database dialog box.

9. Map a drive to the operation history database (OpHist.mdb).
   a. Click the Network... button.
   b. In the Drive field, select a drive letter that has not already been used on this MAS.
   c. Enter the path to the operation history database (OpHist.mdb) by doing one of the following:
      - In the Folder field, type the pathname using the format
        \servername\Tracing
        where servername is the domain name of the MAS, or supplementary server, on which the Tracing Server software is running.
      - Use the Browse... button to locate the Tracing directory on the MAS, or supplementary server, on which the Tracing Server software is running.
   d. Click Finish.

10. In the Select Database dialog box, set the Drives field to the drive you mapped in the previous step.

    The system displays in the Database Name field a list of one or more databases on the mapped drive. The operation history database (OpHist.mdb) should be among them.


12. Click OK.

13. In the ODBC Microsoft Access Setup dialog box, click OK.

14. In the ODBC Data Source Administrator dialog box, click OK.
Procedure 3: Disabling ODBC Tracing

If ODBC logging is enabled on the MAS, performance for the system degrades. ODBC tracing should be enabled for debugging purposes only. To disable ODBC tracing, follow this procedure.

1. On your Windows desktop, click the Start > Programs > Avaya Modular Messaging > Operation History Viewer menu to launch the Operation History Viewer window. See Operation History Viewer Window on page 8-14.

2. Click File > Data Source....

   The system displays the standard Windows ODBC Data Source Administrator dialog box.

3. Click the Tracing tab.

4. You will see a button which toggles to indicate the current tracing status.

   - If the button says Start Tracing Now, then tracing is not active. Press Cancel to close the ODBC Data Source Administrator dialog box.

   - If the button says Stop Tracing Now, tracing is active. Proceed to Step 5.

5. Click on the Stop Tracing Now button. This stops the tracing and the button toggles to Start Tracing Now.

6. In the ODBC Data Source Administrator dialog box, click OK.
Creating, Viewing & Exporting Sessions

You can create two types of session:

- A live session displays events as they are fed to the operation history database.
- A historical session displays events already stored in the operation history database.

These procedures are covered in this topic:

- "Procedure 1: Creating & Viewing a Live Session".
- "Procedure 2: Creating & Viewing a Historical Session".
- "Procedure 3: Saving a Session".
- "Procedure 4: Opening a Session".
- "Procedure 5: Changing Session Properties".
- "Procedure 6: Exporting Operation History Events".

Procedure 1: Creating & Viewing a Live Session

1. On your Windows desktop, click the Start > Programs > Avaya Modular Messaging > Operation History Viewer menu to launch the Operation History Viewer window.

2. Click File > New. The system displays the Session Properties dialog box.

   For a full description of all controls in this dialog box, see Session Properties Dialog Box on page 8-17.

3. In the Session Name field, enter the name of the session, if required.

4. In the Message Application Server field, select the MAS for which you want to display events. If you want to display events for all the MASs in the voice mail domain, click All Servers.

5. Under Date and Time, click Live Mode.

6. Under Select Types, select the event severity types to display. You must select Error, Warning and/or Information.

7. Under Selection Activities, select the event criteria to display.
You can restrict the display of Mailbox Activity and Port Activity events by entering a range of mailbox or port numbers in the Value field, using a comma separator. No negative numbers or spaces are allowed in a range. The first number in a range must be less than the last number in a range. For example, port numbers, 1-8, 16-24, or mailbox numbers, 1000-1050, 2000-2025.

To quickly select all activities, you can select All Activities. If you select All Activities, any mailbox or port number values you enter are ignored.

8. Click OK. The live events are then displayed in the Operation History Viewer grid.

9. For a full description of the grid, see Operation History Viewer Window on page 8-14.

---

**Notes:**

- To avoid slowing down the tracing server, Operation History Viewer displays the most recent events only. You can view older events in a historical session.

- If you want to change the number of events displayed in a live session, please contact your Avaya Modular Messaging support representative.

---

10. If you wish to view the details of an event in a live session, you must click File > Pause. You can then scroll through the events you want to view.

**Notes:**

- If you do not pause a live feed view when scrolling events in a live session, your view moves to the end of the event list each time a new event comes in.

- You can pause a live view for a maximum of 200 seconds. If you exceed this time, then you must restart the live view session.

- When you click New, Open, Save, Save As, Session Properties..., or Event Properties... from the File menu, the application automatically pauses the event feed. Once the action is complete, the application resumes the event feed without any loss of events generated during the action.

---

11. When you have finished scrolling, click File > Resume. The live event feed is resumed without any loss of events generated during scrolling.

12. If you wish to save the session, follow “Procedure 3”, below.
Procedure 2: Creating & Viewing a Historical Session

1. On your Windows desktop, click the Start > Programs > Avaya Modular Messaging > Operation History Viewer menu to launch the Operation History Viewer window.

2. Click File > New. The system displays the Session Properties dialog box.

   For a full description of all controls in this dialog box, see Session Properties Dialog Box on page 8-17.

3. In the Session Name field, enter the name of the session, if required.

4. In the Message Application Server field, select the MAS for which you want to display events. If you want to display events for all the MASs in the voice mail domain, click All Servers.

5. Under Date and Time, do one of the following:

   - If you want to restrict the display of events by date and time, proceed to Step 6.
   - If you do not want to restrict the display of events by date and time, click Clear and proceed to Step 8.

6. In the From and To fields, enter the first and last date and time for session creation.

   If you want to modify the session properties later to create different event viewing scenarios, Avaya recommends that you select one of the relative date values in the Date field, for example, Today. This saves you from re-entering an absolute date for each scenario you create.

7. To retrieve the default times and dates, click Default.

   Note: The default values set by Avaya are From Yesterday 08:00 To Today 18:00. You can modify these defaults, using the Options dialog box, Events View tab. See Options - Events View Tab on page 8-22.

8. Under Select Types, select the event severity types to display. You must select Error, Warning and/or Information.

9. Under Selection Activities, select the event criteria to display.

   You can restrict the display of Mailbox Activity and Port Activity events by entering a range of mailbox or port numbers in the Value field, using a comma separator. No negative numbers or spaces are allowed in a range. The first number in a range must be less than the last number in a range. For example, port numbers, 1-8,16-24, or mailbox numbers, 1000-1050, 2000-2025.
To quickly select all activities, you can select All Activities. If you select All Activities, any mailbox or port number values you enter are ignored.

10. Under Sort By, select the type of value by which you want events to be sorted.

   None is selected by default. This means that events are sorted in the order in which they were entered in the database.

11. Click OK. The historical events are then displayed in the Operation History Viewer grid.

   For a full description of the grid, see Operation History Viewer Window on page 8-14.

12. If you wish to save the session, follow “Procedure 3”, below.

Procedure 3: Saving a Session

File > Save  Saves the session using the standard Windows method. You can select to save in one of two formats:

- Session Files (*.SSN)  Saves only a session's properties. You can modify the properties to create different event viewing scenarios.

- Snapshot Files (*.SNP)  Saves a session's properties and the event data matching these properties. The system purges the operation history database periodically. However, by creating a snapshot file, you can keep the event data for as long as you require.

Procedure 4: Opening a Session

File > Open...  Launches the standard Windows Open dialog box. You can open live or historical sessions from one of two formats:

- Session Files (*.SSN)  Contains only a session's properties. You can modify the properties to create different event viewing scenarios.

- Snapshot Files (*.SNP)  Contains a session's properties and the event data matching these properties. The system purges the operation history database periodically. However, a snapshot file keeps the event data for as long as you require.

Procedure 5: Changing Session Properties

File > Session Properties  Launches the Session Properties dialog box, where you can amend any of the properties of the current session. See “Procedure 1” and “Procedure 2”, above.

Alternatively, you can change session selection activities using the Selection menu commands, rather than using the Session Properties dialog box.
Operation History Viewer

- **Selection > All Activities**  This selects all activities currently in the operation history database and displays them in the Operation History Viewer grid.

  **Note:** When this option is selected, any number ranges you enter in the Values dialog box for Mailbox Activity or Port Activity events are ignored.

- **Selection > Mailbox Activity**  Launches the Values dialog box. See Values Dialog Box on page 8-25.

  You can restrict the display by entering a range of mailbox numbers in the Values field and clicking OK. The Operation History Viewer grid then displays mailbox activity events for that range.

  If you do not enter a value, when you click OK it displays all mailbox activity events in the grid.

- **Selection > Port Activity**  Launches the Values dialog box.

  You can restrict the display by entering a range of port numbers in the Values field and clicking OK. The Operation History Viewer grid then displays port activity events for that range.

  If you do not enter a value, when you click OK it displays all port activity events in the grid.

- **Selection > PBX Integration Activity**  This selects all PBX Integration activity events and displays them in the Operation History Viewer grid.

**Procedure 6: Exporting Operation History Events**

You can export operation history events to view, query, and search the data using alternate tools (for example, text editors and database querying tools).

1. Do one of the following:

   - If you are exporting events in a live session, proceed from Step 2.

   - If you are exporting events in a historical session, proceed from Step 3.

2. Click  File > Pause.

3. Click  File > Export. The system displays the Export Operation History Events dialog box.

4. In the File Name field, enter a file name, or, if you want to overwrite an existing file, click that file.

5. In the List Files of Type field, select either *.TXT format for a text file or *.MDB format for a database file.
If you are exporting a text file and want to specify characters to separate and surround text fields, click Options to open the Text Export tab. See Options - Text Export Tab on page 8-24.

6. Select the location where you want to save the file in Directories and Drives.

7. Click OK.
Operation History Viewer Window

Using the Operation History Viewer, you can view events generated by voice mail system activity and logged in the operation history database. By creating a “session”, you restrict the number of events to only those that meet your criteria. You can view live events as they are added to the operation history database, or view historical events.

This chapter describes the Operation History Viewer screens and the controls within those screens.

Note: For advice on using the Operation History Viewer and procedures for creating live or historical sessions, see Understanding Operation History Events on page 8-2.

Launching the Application

Before launching the Operation History Viewer, ensure that:

- Operation history collection is enabled for the voice mail domain. See Enabling the Collection of Operation History Events on page 8-3.

- The Operation History Viewer data source references the operation history database on the tracing system machine. See Selecting a Data Source & ODBC Tracing on page 8-4.

On your Windows desktop, click the Start > Programs > Avaya Modular Messaging > Operation History Viewer menu to launch the Operation History Viewer window.

Note: Avaya recommends that you do not run multiple instances of Operation History Viewer to access the operation history database for a single voice mail domain. This has a detrimental effect on the performance of all Operation History Viewer applications that you are running.

The Operation History Viewer Toolbar & Menus

The Operation History Viewer window has a toolbar and top menu bar. For full information on these commands, see All Operation History Viewer Menus & Icons on page 8-27.

Creating or Opening a Session

Sessions can be created, or existing session files can be opened. The events then appear in the grid of the main Operation History Viewer window.
Operation History Viewer

- **File > New** Launches the **Session Properties** dialog box. You can then create a new live or historical session. See [Session Properties Dialog Box](#) on page 8-17.

- **File > Open...** Launches the standard Windows **Open** dialog box. You can open live or historical sessions from one of two formats:

  - **Session Files (*.SSN)**: Contains only a session's properties. You can modify the properties to create different event viewing scenarios.

  - **Snapshot Files (*.SNP)**: Contains a session's properties and the event data matching these properties. The system purges the operation history database periodically. However, a snapshot file keeps the event data for as long as you require.

### The Operation History Viewer Grid

The grid displays the details of the events in the current session. You can use the mouse to resize the columns. On starting, the **Operation History Viewer** remembers the last resized position of each column.

The following list is the default display of columns in the grid. If you wish, you can reorder or remove some of the columns, using the **Options** dialog box, **Columns** tab. See [Options - Columns Tab](#) on page 8-23.

- **Date** Displays the date the event occurred.

- **Time** Displays the time the event occurred.

- **Object** Displays the system component that generated the event. For example, the **Telephone User Interface**.

- **Event** Displays the event identifier.

- **Type** Displays the severity of the event.

- **Call-Id** Displays the call identifier.

- **Message Application Server** Displays the name of the MAS on which the event occurred.

- **Information** Displays the description of the event.

- **Port** Displays the port identifier, if any, associated with the event.

- **Mailbox** Displays the mailbox identifier, if any, associated with the event.

- **Directory Search Key** Displays the search key identifying the user’s mailbox on the message store server (Avaya MSS).
Studying Events in the Grid

You can use these commands to study the details of an event selected in the grid. If you are viewing a live event feed, you can pause it, to make it easier to select an event.

- **File > Pause** Pauses a live event feed. You can then scroll through the events.

Notes:

- If you do not pause a live feed view when scrolling events in a live session, your view moves to the end of the event list each time a new event comes in.

- You can pause a live view for a maximum of 200 seconds. If you exceed this time, then you must restart the live view session.

- When you click **New, Open, Save, Save As, Session Properties...**, or **Event Properties...** from the **File** menu, the application automatically pauses the event feed. Once the action is complete, the application resumes the event feed without any loss of events generated during the action.

- **File > Event Properties** Opens the **Event Properties** dialog box. This displays the details of the selected event. See **Event Properties Dialog Box** on page 8-20.

- **File > Resume** Resumes a live event feed that has been paused.

Saving a Session

- **File > Save** Saves the session using the standard Windows method. You can select to save in one of two formats:

  - **Session Files (*.SSN)** Saves only a session's properties. You can modify the properties to create different event viewing scenarios.

  - **Snapshot Files (*.SNP)** Saves a session's properties and the event data matching these properties. The system purges the operation history database periodically. However, by creating a snapshot file, you can keep the event data for as long as you require.

Exporting Events

You can also export operation history events to view, query and search the data using alternate tools, for example, text editors and database querying tools. For this procedure, see **Export Operation History Events Dialog Box** on page 8-26.
Session Properties Dialog Box

This topic describes how to use the Session Properties dialog box to configure the session to be launched in the Operation History Viewer grid. See Operation History Viewer Window on page 8-14.

You can create two types of session:

- A live session displays events as they are fed to the operation history database. For a live session, you must select Live Mode in the Date and Time group box.

- A historical session displays events already stored in the operation history database. For a historical session, you must use the From/To or Clear controls in the Date and Time group box.

For a procedural overview, see Creating, Viewing & Exporting Sessions on page 8-8.

Launching the Screen

- File > New Launches the Session Properties dialog box. You can then create a new live or historical session.

- File > Session Properties Launches the Session Properties dialog box, where you can amend the properties of the current session.

  Note: If you wish, you can change session selection activities using the Selection menu commands, rather than having to use the Session Properties dialog box.

Configuring the Screen Controls

- Session Name Enter the name of the session, if required.

- Message Application Server Select the MAS for which you want to display events. If you want to display events for all the MASs in the voice mail domain, select All Servers.

  Note: You can set up a specific MAS to be selected by default in this field, using the Options dialog box, Events View tab. See Options - Events View Tab on page 8-22.
Date and Time  To show live events, you must select the Live Mode. To view historical events, you can specify existing events by date and time. If you do not want to restrict the display of historical events, Clear all these fields.

- From/To These fields allow you to specify the date and time range for events in a historical session.

  - Select the from/to dates of the session: Today, Yesterday, 2 days before today or 3 days before today.
  - Enter the from/to times of the session.

- Clear Click this button to clear the values of the From/To fields. This means the historical events will not be restricted by time and date.

- Default Click this button to reset the default values in the From/To fields.

**Note:** The default values set by Avaya are From Yesterday 08:00 To Today 18:00. You can modify these defaults, using the Options dialog box, Events View tab.

- Live Mode Select to view events in a live session, as they are fed to the operation history database. This grays out all the other fields in the Date and Time group box and all the Sort By options.

- Select Types Select one or more of the event severity types to display: Error, Warning and Information

- Selection Activities Select the event criteria to display by clicking the appropriate check boxes:

  - All Activities This selects all activity events.

**Note:** When this option is selected, number ranges you enter in the Value field, for Mailbox Activity or Port Activity events, are ignored.

- Mailbox Activity This selects all mailbox activity events. You can restrict the display by entering a range of mailbox numbers in the Value field, below. When you click on another control, that range then appears in the Value column of the Selection Activities grid.

- Port Activity This selects all port activity events. You can restrict the display by entering a range of port numbers in the Value field, below. When you click on another control, that range then appears in the Value column of the Selection Activities grid.

- PBX Integration Activity This selects all PBX integration activity events.
- **Value** You can restrict the display of *Mailbox Activity* and/or *Port Activity* events by entering a range of mailbox or port numbers in this field, using a comma separator. No negative numbers or spaces are allowed in a range. The first number in a range must be less than the last number in a range. For example, port numbers, **1-8,16-24**, or mailbox numbers, **1000-1050, 2000-2025**.

- **Sort By** Click on an option to select the type of value by which you want events to be sorted. These options are only available for historical sessions.
  - **None** (Default) The events appear in the order in which they were entered in the database.
  - For each of the other values, the events are then sorted by the selected value: *Date/Time*, *Mailbox*, *MAS*, *Type*, *Port*, *Call-Id*, *Object*, or *Event*. 
Event Properties Dialog Box

This topic describes how to use the Event Properties dialog box to view the details of the event selected in the Operation History Viewer grid. See Operation History Viewer Window on page 8-14.

Launching the Screen

- File > Event Properties  Launches the Event Properties dialog box for the event selected in the grid. This displays the details of the selected event.

Viewing the Screen Controls

- Event  Displays the event identifier.
- Date and Time  Displays the date and time the event occurred.
- Object  Displays the system component that generated the event. For example, Telephone User Interface.
- MAS  Displays the name of the messaging application server on which the event occurred.
- Type  Displays the severity of the event.
- Port  Displays the port identifier, if any, associated with the event.
- Mailbox  Displays the mailbox identifier, if any, associated with the event.
- Message  Displays the description of the event.
Options Dialog Box

This topic describes how to use the Options dialog box to set defaults for new sessions, customize the display of the Operation History Viewer grid and set preferences for exporting text. See Operation History Viewer Window on page 8-14.

Launching the Screen

- **File > Options**... Launches the Options dialog box with the Events View tab selected.

Tabs Available in this Dialog Box

- **Events View** Use this tab to set up your own default MAS and dates/times to use for a new session. You can also set the system to automatically open a new session using these defaults, whenever you start the Operation History Viewer. See Options - Events View Tab on page 8-22.

- **Columns** Use this tab to reorder the columns displayed in the Operation History Viewer grid and/or remove some of those columns. See Options - Columns Tab on page 8-23.

- **Text Export** Use this tab to configure settings for exporting events activity sessions as text files. See Options - Text Export Tab on page 8-24.
Options - Events View Tab

This topic describes how to use the **Options** dialog box, **Events View** tab to set up your own default MAS and dates/times to use for a new session. You can also set the system to automatically open a new session using these defaults, whenever you start the **Operation History Viewer**. See **Operation History Viewer Window** on page 8-14.

**Launching the Screen**

- **File > Options...** Launches the **Options** dialog box with the **Events View** tab selected.

**Configuring the Screen Controls**

- **Default MAS** Select the MAS that you wish to appear as the default for all new sessions. The system default is **All Servers**

- **Default Date and Time From/To** Select the dates and times you wish to appear as the default values for all new sessions. The default values set by Avaya are **From Yesterday 08:00 To Today 18:00**.

  — Select the default from/to dates for all new sessions: **Today**, **Yesterday**, **2 days before today** or **3 days before today**.

  — Enter the default from/to times for all new sessions.

- **Open new session with default options on start of application** Select to automatically open a new session using these defaults, whenever you start the **Operation History Viewer**.
Options - Columns Tab

This topic describes how to use the Options dialog box, Columns tab to reorder the columns displayed in the Operation History Viewer grid and/or remove some of those columns. See Operation History Viewer Window on page 8-14.

Launching the Screen

- File > Options... Launches the Options dialog box with the Events View tab selected. You must click on the Columns tab.

Configuring the Screen Controls

- Selected Lists all the column headings that are displayed in the Operation History Viewer grid.
- Not Selected Lists any column headings that do not appear in the Operation History Viewer grid.
- Move>> Moves the column headings selected in the Selected list into the Not Selected list.
- <<Move Moves the column headings selected in the Not Selected list into the Selected list.
- Select All Selects all the column headings in the list that currently has focus.

**Note:** If you wish to select one item, you can click on it. If you wish to select several, you can use the Shift and Ctrl keyboard keys.

- Reset Moves all the column headings into the Selected list and puts them into their default order:
  
  Date, Time, Object, Event, Type, Call-Id, Message Application Server, Information, Port, Mailbox and Directory Search Key.

- Moves the selected column heading up the Selected list. This changes the display order in the Operation History Viewer grid.
- Moves the selected column heading down the Selected list. This changes the display order in the Operation History Viewer grid.
Options - Text Export Tab

This topic describes how to use the Options dialog box, Text Export tab to configure settings for exporting events activity sessions as text files.

For more information on exporting, see Export Operation History Events Dialog Box on page 8-26.

Launching the Screen

- **File > Options...** Launches the Options dialog box with the Events View tab selected. You must click on the Text Export tab.

Configuring the Screen Controls

- **Select the character to use between the fields** Select the character you want the system to use to separate text fields, when exporting events as a text file.
  
  The options are **Comma** (the default), **Space**, **Semicolon**, or **Tab**.

- **Select the character to surround text fields** Select the character you want the system to use to surround text fields, when exporting events as a text file.
  
  The options are ‘ (single quotes), “ (double quotes, the default), or **None**.
Values Dialog Box

You can use the **Values** dialog box to restrict the range, when displaying mailbox or port activity events.

You can restrict the display of each of these activities by specifying a range of values and clicking **OK**. The **Operation History Viewer** grid then displays mailbox or port activity events for that range. See **Operation History Viewer Window** on page 8-14.

Launching the Screen

The dialog box is launched automatically, when you select one of these **Operation History Viewer** menu commands:

- **Selection > Mailbox Activity** To display mailbox activity events.
- **Selection > Port Activity** To display port activity events.

Configuring the Screen Controls

- **Values** You can restrict the display of **Mailbox Activity** and/or **Port Activity** events by entering a range of mailbox or port numbers in this field, using a comma separator. No negative numbers or spaces are allowed in a range. The first number in a range must be less than the last number in a range. For example, port numbers, **1-8,16-24**, or mailbox numbers, **1000-1050, 2000-2025**.
Export Operation History Events Dialog Box

This topic describes how to use the Export Operation History Events dialog box to export the events in the current session of the Operation History Viewer window. See Operation History Viewer Window on page 8-14.

You can export operation history events to view, query and search the data using alternate tools, for example, text editors and database querying tools.

Notes:

- You cannot export events which have been opened from a Snapshot File (*.SNP). When a snapshot file is loaded, the system disables the Export command.
- You must click File > Pause to pause the feed, before you can export events in a live session. Once the export is complete, the system resumes the event feed automatically without any loss of events generated during the export.

Launching the Screen

- File > Export Launches the Export Operation History Events dialog box. This has some standard Windows features, plus two Avaya-specific buttons: Options and Help.

Configuring the Screen Controls

- File Name Enter a file name, or, if you want to overwrite an existing file, click that file.
- List Files of Type Select either Text File (*.TXT) or Database File (*.MDB) format.
  - Text File (*.TXT) Records in a text file, with field separators and text envelope characters. The text file contains event information for the currently selected columns only.
  - Database File (*.MDB) Open Database Connectivity (ODBC)-compliant database with the same columns as the operation history database.
- Drives Select the drive where you wish to save the file.
- Directories Select the directory where you wish to save the file.
- Options Opens the Options dialog, Text Export tab. If you are exporting a Text File (*.TXT), you can use this tab to specify characters to separate and surround text fields. See Options - Text Export Tab on page 8-24.
All Operation History Viewer Menus & Icons

The Operation History Viewer window has a menu bar and a toolbar. This topic provides a reference list of all menu and icon commands. See Operation History Viewer Window on page 8-14.

File Menu

- **File > New**  Launches the Session Properties dialog box. You can then create a new live or historical session. See Session Properties Dialog Box on page 8-17.

- **File > Open...**  Launches the standard Windows Open dialog box. You can open an existing session file (*.SSN) or snapshot file (*.SNP).

- **File > Save**  Saves the session using the standard Windows method. You can select to save in one of two formats:
  - **Session Files (*.SSN)**  Saves only a session's properties. You can modify the properties to create different event viewing scenarios.
  - **Snapshot Files (*.SNP)**  Saves a session's properties and the event data matching these properties. The system purges the operation history database periodically. However, by creating a snapshot file, you can keep the event data for as long as you require.

- **File > Save As...**  Launches the standard Windows Save As dialog box, where you can select a different filename or file type.

- **File > Close**  Closes the currently open session.

- **File > Session Properties**  Launches the Session Properties dialog box, where you can amend the properties of the current session. See Session Properties Dialog Box on page 8-17.

- **File > Event Properties**  Launches the Event Properties dialog box for the event selected in the Operation History Viewer grid. This displays the details of the selected event. See Event Properties Dialog Box on page 8-20.

- **File > Options...**  Launches the Options dialog box, where you can set defaults for new sessions, customize the display of the Operation History Viewer grid and set preferences for exporting text. See Options Dialog Box on page 8-21.

- **File > Export**  Launches the Export Operation History Events dialog box, where you can export operation history events as a *.TXT or *.MDB file. You can then view, query and search the data using alternate tools. See Export Operation History Events Dialog Box on page 8-26.

- **File > Pause**  Pauses a live event feed. You can then scroll through the events.
- **File > Resume**  Resumes a live event feed that has been paused.

- **File > Data Source...**  Launches the standard Windows ODBC Data Source Administrator dialog box, where you can select a system data source. See Selecting a Data Source & ODBC Tracing on page 8-4.

  **Note:** If the Operation History Viewer is installed on the tracing system machine, a data source is created automatically and you do not need to select it here.

- **File > Exit**  Closes down the Operation History Viewer.

**Edit Menu**

- **Edit > Copy** Copies the selection and places it on the Windows Clipboard.

**Selection Menu**

You can change session selection activities using the Selection menu commands, rather than having to use the Session Properties dialog box.

- **Selection > All Activities**  This selects all activities currently in the operation history database and displays them in the Operation History Viewer grid.

  **Note:** When this option is selected, any number ranges you enter in the Values dialog box for Mailbox Activity or Port Activity events are ignored.

- **Selection > Mailbox Activity**  Launches the Values dialog box. See Values Dialog Box on page 8-25.

  You can restrict the display by entering a range of mailbox numbers in the Values field and clicking OK. The Operation History Viewer grid then displays mailbox activity events for that range.

  If you do not enter a value, when you click OK it displays all mailbox activity events in the grid.

- **Selection > Port Activity**  Launches the Values dialog box.

  You can restrict the display by entering a range of port numbers in the Values field and clicking OK. The Operation History Viewer grid then displays port activity events for that range.

  If you do not enter a value, when you click OK it displays all port activity events in the grid.

- **Selection > PBX Integration Activity**  This selects all PBX Integration activity events and displays them in the Operation History Viewer grid.
Help Menu

- **Help > Help Topics**  Launches the *Operation History Viewer Help.*

- **Help > About Operation History Viewer**  Launches the *About Modular Messaging* window.

See Also

- [Understanding Operation History Events](#) on page 8-2.
This chapter describes how to use the **Port Monitor**, which provides a graphical user interface for checking and changing the status of ports on an MAS.

The **Dialogic Line Test Application** verifies that the voice ports are correctly configured and connected to the PBX. It tests Dialogic Analog, Dialogic Digital Set Emulation (DSE), and Dialogic QSIG ports. Your service technician uses this tool as part of testing the installation of your system. However, you may also use it as a troubleshooting tool.

The chapter also describes the Performance Counters that Modular Messaging exports through the Windows Performance Monitoring API. These can be used to gauge the overall status of an MAS at any given time.

**Topics included in this chapter:**

- **Port Monitor** on page 9-2.
- **Dialogic Line Tester (Dialogic Analog, Set Emulation & QSIG)** on page 9-8
- **Performance Monitoring - Modular Messaging Counters** on page 9-10.
Port Monitor

The Port Monitor provides a graphical user interface for checking and changing the status of ports on an MAS.

**Note:** To configure Port Monitor, you must be a member of a security role assigned the **Port Monitoring - Administer** task. If you are a member of a role assigned the **Port Monitoring - View** task, you have read-only access to this application. This is configured in the **Voice Mail System Configuration** application, **Security Roles** dialog box. See **Security Roles Dialog Box** on page 3-88.

Topics included in this chapter:

- Message Application Servers Dialog Box on page 9-3.
- Port Monitor Window on page 9-4.
- Port Monitor - Disabling/Enabling Ports on page 9-6.
- Port Monitor - Toolbar & Menus on page 9-7.
Message Application Servers Dialog Box

You must select the MAS for which you want to view port states. This is done using the Message Application Servers dialog box.

Launching the Message Application Servers Dialog Box

You can use the Start > Programs > Avaya Modular Messaging > Port Monitor menu on your Windows desktop to launch the Port Monitor application. At this point, the Message Application Servers dialog box is opened automatically. When you have selected the MAS, the main Port Monitor window is launched. See Port Monitor Window on page 9-4.

From the Port Monitor window, you can click the Options > Select Another Server icon or menu command to re-open the Message Application Servers dialog box, if you wish to change to a different MAS.

Note: Instead of changing the MAS, you can start multiple copies of the Port Monitor application and select a different MAS each time.

Selecting an MAS from the Current Voice Mail Domain

The Message Application Servers dialog box lists all the MASs in the voice mail domain associated with the computer running the Port Monitor application.

1. Click the MAS in the list and click Select. Alternatively, double-click the MAS.

2. The Message Application Servers dialog box closes and you see a list of ports for that MAS in the main Port Monitor window.
Port Monitor Window

You can use the main Port Monitor window to check and change the status of ports on the selected MAS.

Notes:

- To use Port Monitor, you must have administrator privileges at a Windows 2000/2003 level on the MAS. You must also be a member of a security role assigned the Port Monitoring - Administer task. If you are a member of a role assigned the Port Monitoring - View task, you have read-only access to this application. This is configured in the Voice Mail System Configuration application, Security Roles dialog box. See Security Roles Dialog Box on page 3-88.

- If two administrators attempt to change the status of a port on the same MAS at the same time, only one change takes effect, and automatically overrides the other attempt. To avoid this situation, Avaya recommends that you allocate a single machine for changing port states.

You can disable or enable a port by:

- Making a port unavailable for incoming/outgoing calls. If the port is busy, this is not done until it is released.

- Forcing the port to be disabled immediately, regardless of the activity.

- Bringing the port on hook to make it available for incoming/outgoing calls

Launching the Application

1. On your Windows desktop, click the Start > Programs > Avaya Modular Messaging > Port Monitor menu.

2. You are prompted to select an MAS from the Message Application Servers dialog box. For details on how to select a server, see Message Application Servers Dialog Box on page 9-3.

3. When you have selected the MAS, the Port Monitor is launched.

Port Monitor Toolbar & Menus

The Port Monitor window has a toolbar, a top menu bar and some right-click menus. These are available when you select a Port in the grid; they are context sensitive.

You can use these commands to change the MAS and change the status of the port selected in the grid. See Port Monitor - Disabling/Enabling Ports on page 9-6 and Port Monitor - Toolbar & Menus on page 9-7.
Port Status Grid

You can select multiple ports by holding down the Shift key or Ctrl key on your keyboard and clicking on the ports you require.

The grid in the Port Monitor window shows two columns, Port and State.

- The primary status of the port is shown by an icon in the Port column and text at the beginning of the State column.
  - Disabling An administrator has requested to disable a busy port, but the port has not yet been released by the call.
  - Disabled The port is unavailable.
  - Busy The port is in use by incoming or outgoing calls.
  - Idle The port is available.

- The secondary status is shown by the remaining text in the State column.
  - Disconnected The call has been disconnected, but the port is still off hook.
  - Offhook The port has been taken off hook from the idle state.
  - Dialtone The dial tone has been detected on this port for an outgoing call.
  - Connected The call on this port is connected.
  - Call Failed The outgoing call on this port failed.
  - In Transfer The first stage of a transfer on this port is completed.
  - Transfer Failed The transfer of the call on this port failed.
  - Waiting for Call The port is waiting for an incoming ring.
  - Ringing In The port is ringing with an incoming call.
  - Ringing Out The outgoing call on this port is ringing the targeted line.
  - Dialing The port is dialing an outgoing call.
  - Waiting for Call (Pending) The port has been requested to go into the Waiting For Call state.
  - Bad Port The port is out of service.
  - Playing Audio is playing.
  - Recording Audio is being recorded.
Port Monitor - Disabling/Enabling Ports

In order to enable or disable a port, you must select it in the status grid of the Port Monitor window. See the “Port Status Grid” heading in Port Monitor Window on page 9-4.

You can select multiple ports by holding down the Shift key or Ctrl key on your keyboard and clicking on the ports you require.

You can then either use the right-click menu, the top level Change State menu or the toolbar to disable or enable the selected ports.

Disabling a Port

Disabling a port means that it cannot be used for outgoing calls, and incoming calls on that port are not answered. Before you can disable a port, it must be Idle. If the port is busy, it is disabled the next time it becomes idle.

Click the Change State > Disable command. This makes the selected port unavailable for incoming or outgoing calls. If the port is busy, this is not done until it is released.

Note: For Analog PBX integration, the port is taken off hook when it is disabled, if the Go Off Hook when Port Disabled option is selected in the Voice Mail System Configuration application’s PBX Configuration dialog box, General tab. See PBX Configuration - General Tab (Dialogic Analog) on page 3-122.

Disabling a Port Immediately

It may be necessary to force a port to become disabled at once, irrespective of its current status.

Click the Change State > Disable Immediately command. This forces the port to be disabled immediately, regardless of the activity currently taking place on that port.

Note: Disabling a port immediately will instantly disconnect any users of the port.

Enabling a Port

Enabling a port means bringing it back into service so that it is available for incoming or outgoing calls.

Click the Change State > Enable command. This brings the selected port on hook and makes it available for incoming or outgoing calls.
Port Monitor - Toolbar & Menus

The Port Monitor window has a toolbar, a top menu bar and some right-click menus. These are available when you select a Port in the grid; they are context sensitive.

File Menu

- **File > Exit** Closes down the Port Monitor.

View Menu

- **View > Toolbar** Toggles the toolbar on/off. It is on by default.
- **View > Status Bar** Toggles the status bar on/off. It is on by default.

Change State Menu (& Right-click)

For full information, see Port Monitor - Disabling/Enabling Ports on page 9-6.

- **Change State > Enable** Brings the selected port on hook and makes it available for incoming/outgoing calls.
- **Change State > Disable** Makes the selected port unavailable for incoming/outgoing calls. If the port is busy, this is not done until it is released.
- **Change State > Disable Immediately** Forces the selected port to be disabled immediately, regardless of current activity on that port.

Options Menu

- **Options > Always on Top** Enables/disables the ability of the Port Monitor window to stay on top. This is disabled by default.
- **Options > Select Another Server** Re-opens the Message Application Servers dialog box, if you wish to change to a different MAS. See Message Application Servers Dialog Box on page 9-3.
- **Options > Port** Toggles the text in the Port column of the Port Monitor windows to show/hide the word “Port”. This is so that you can save space, if you wish to resize the Port Monitor window. It shows the word by default.

Help Menu

- **Help > Help Topics** Launches the Port Monitor Help.
- **Help > About Port Monitor** Launches the About Modular Messaging window.
Dialogic Line Tester (Dialogic Analog, Set Emulation & QSIG)

The Dialogic Line Test Application verifies that the voice ports are correctly configured and connected to the PBX. It tests Dialogic Analog, Dialogic Digital Set Emulation (DSE), and Dialogic QSIG ports.

Your service technician uses this tool as part of testing the installation of your system. However, you may also use it as a troubleshooting tool.

Note: You must stop the MM Messaging Application Server service before you use this tool. See Appendix C, Modular Messaging (MM) Services.

Launching the Application

1. On your Windows desktop, click the Start > Programs > Avaya Modular Messaging > Dialogic Line Tester menu.

   The system displays the Dialogic DSE - Line Test Application window.

   The Status column tells you the status of the channel.

Procedure 1: Testing a Port:

1. Click a port in the list.

2. Dial the number of the port from a telephone.

   The status of the port should change to Receiving Call.

3. Hang up the telephone, and wait until the port changes to Waiting for Call.

4. Click the port again.

5. Type a real telephone number into the Dial Number field, and click Dial Number.

   The status of the port should change to Dialing Number. Other status changes may follow.

   If a channel has an error, it changes to a flashing red color. If a channel is in error or locked in a state inappropriately, you can reset the channel.

Procedure 2: Correcting a Port Problem:

1. Click the channel.

2. Click Reset or, if multiple channels have problems, click Reset All.
The channel returns to the **Waiting for Call** state. If not, you may need to reconfigure or replace the voice card.

**Procedure 3: Modifying QSIG Parameters, if the Card Handles the QSIG Protocol:**

1. Click **Tools > Options**.

   The system displays the **QSIG Options** dialog box.

2. In the **Layer 1 Protocol** field, click **G.711 A-Law** or **G.711 µ-Law** (mu-law).

   **Note:** Ensure that the form of G.711 encoding matches that of the Private Branch Exchange (PBX). In general, µ-law (mu-law) is used in North America and Japan, and A-law is used in Europe. If your choice of encoding scheme does not match the PBX, then audio will sound garbled.

3. In the **Number Type** field, click **Unknown**, **International**, **National**, or **Local**.

4. In the **Number Plan** field, click **Unknown**, **ISDN/Telephony** (E.164/E.163), or **Private**.
Performance Monitoring - Modular Messaging Counters

Modular Messaging exports a variety of Performance Counters through the Windows Performance Monitoring API, which can be used to gauge the overall status of an MAS at any given time.

**Note:** For information on Performance Monitoring, see your Microsoft Windows documentation or the Microsoft *Performance Logs and Alerts Help*.

The types of counters exported range from the total number of calls taken by the MAS to the current state of each port on the server.

**Adding Modular Messaging Counters**

To launch the Microsoft Performance monitor and add the Modular Messaging counters, see *Adding Modular Messaging Counters* on page 9-11.

**Modular Messaging Counters**

For a detailed description of the modular messaging counters, see *Descriptions of the Modular Messaging Counters* on page 9-12.
Adding Modular Messaging Counters

You should be familiar with using Performance Monitor before using the Modular Messaging counters.

Notes:

- For information on the Performance Monitor, see your Microsoft Windows documentation or the Microsoft Performance Logs and Alerts online help.
- The appropriate Modular Messaging services must be running before you can monitor their performance. See Appendix C, Modular Messaging (MM) Services.

Procedure 1: Adding Modular Messaging Counters to Microsoft Performance Monitor

1. On your Windows desktop, click the Start > Programs > Administrative Tools > Performance menu. This launches the Performance window.

2. On the toolbar in the right hand pane, click the plus icon.

The system displays the Add Counters dialog box.

3. In the Select counters from this computer field, click the MAS you want to monitor.

4. In the Performance object field, click the Modular Messaging object you want to monitor (for example, MM MAS).

5. Click Select counters from list then select the counter you require (for example, Active Ports). The counters available depend on the object that you have chosen.

Note: For more information, see Descriptions of the Modular Messaging Counters on page 9-12.

6. Click the Add button.

7. If you want to add counters from another MAS to the chart, repeat Steps 3 through 6.

8. Click the Close button.
Descriptions of the Modular Messaging Counters

Adding Modular Messaging Counters

To launch the Microsoft Performance monitor and add the Modular Messaging counters, see Adding Modular Messaging Counters on page 9-11.

Modular Messaging Objects

- **MM MAS** Use these counters to monitor the current status of calls processed by the Messaging Application Server (MAS).
  
  See MM MAS on page 9-13.

- **MM MAS Messaging System** Use these counters to monitor activity in the messaging subsystem.
  
  Note: These counters are available with Avaya Modular Messaging for Microsoft Exchange only.

- **MM MAS MWI Activity** Use these counters to monitor message waiting indicator (MWI) activity.
  
  See MM MAS MWI Activity on page 9-14.

- **MM MAS OAN** Use these counters to monitor the current status of the Octel Analog Networking (OAN) gateway.
  
  Note: These counters are available with Avaya Modular Messaging for Microsoft Exchange only.

- **MM MAS Service** Use these counters to display internal information about the state of the system, for use by Avaya Modular Messaging administration tools.
  
  See MM MAS Service on page 9-15.

- **MM MAS Voice Port** Use these counters to monitor voice port activity.
  
  See MM MAS Voice Port on page 9-15.

- **MM MWI Server** Use these counters to monitor the activities of the message waiting indicator server.
  
  See MM MWI Server on page 9-15.

- **MM MWI Server Queue** Use these counters to monitor the activities of the message waiting indicator server queue.
  
  See MM MWI Server Queue on page 9-15.
Use these counters to monitor the current status of calls processed by the Messaging Application Server (MAS).

- **% Delayed Calls**  The percentage of calls today that have experienced a delay of more than 4 seconds.

- **% Time Offline**  The percentage of the complete current day that the MAS was offline.

- **Active Ports**  The number of currently active ports.

- **Active TUI Sessions**  The number of currently-active Telephone User Interface (TUI) sessions.

- **All TUI Sessions Active**  The number of times that all TUI sessions were active.

- **Calls to Non Modular Messaging Software Enabled Users**  The number of calls diverted to Modular Messaging Software for which there is no corresponding subscriber for the extension.

- **Calls While Offline**  The number of calls received while the server was offline.

- **Command Pool Queue Length**  The number of message requests waiting to be processed in the command pool.

- **Failed TUI Password Validations**  The number of invalid passwords entered today.

- **Incoming Calls**  The number of incoming calls active.

- **Integration Data Missing**  The number of calls that were missing PBX integration data.

- **Integration Unknown**  The number of calls that were missing the PBX integration type.

- **Logon Failures (Offline)**  The number of times subscribers could not complete a logon because a message store server was unavailable.

- **Logons Aborted After Delay**  The number of aborted TUI logons today due to delays opening the subscriber mailbox.

- **Non Delivery Messages**  The number of non-delivery messages in the default mailbox.

- **Number of Modular Messaging Software Enabled Users**  The number of users enabled for the Avaya Modular Messaging Software.

- **Outgoing Calls**  The number of outgoing calls active.
- **Size of TUI Port Group**  The number of channels in the TUI port group.

- **Spooler Queue Length**  The number of messages queued for delivery to the message store server(s).

- **Spooler Stalled Queue**  The number of messages stalled in the spooler queue.

- **System Problems**  The number of times any call has been terminated because the MAS could not contact a message store server.

- **Timeout Obtaining Greeting**  The number of instances a timeout occurred when trying to obtain a subscriber greeting.

- **Total Calls Today**  The total number of calls handled by Modular Messaging Software today.

- **Total Failed TTS Sessions**  The number of Text-To-Speech (TTS) sessions that failed to initiate for any reason.

- **Total TTS Sessions**  Total number of TTS Sessions that successfully started.

- **TTS Active Sessions**  The number of TTS sessions concurrently active.

- **TUI Average Logon Time**  The average time (in milliseconds) taken for TUI logins.

- **TUI Average Message Delete Time**  The average time (in milliseconds) taken to complete the deletion of TUI messages.

- **TUI Average Message Playback Time**  The average time (in milliseconds) taken for TUI message playback to start.

- **TUI Average Message Send Time**  Average time (in milliseconds) taken for TUI message send to complete.

**MM MAS MWI Activity**

Use these counters to monitor message waiting indicator (MWI) activity.

- **Total MWI Busy Failures**  The number of times the Messaging Application Server (MAS) has failed to trigger subscribers’ message waiting indicators due to a lack of resources, such as ports, trunks, or network availability.

- **Total MWI Errors**  The number of times the MAS has detected an error while trying to trigger subscribers’ message waiting indicators.
System Performance Monitoring

- **Total MWI Reset Attempts**  The number of times the MAS has attempted to turn a subscriber’s message waiting indicator off since call processing began.

- **Total MWI Set Attempts**  The number of times the MAS has attempted to turn a subscriber’s message waiting indicator on since call processing began.

**MM MAS Service**

Use these counters to display internal information about the state of the system, for use by Avaya Modular Messaging administration tools.

- **State Counter**  The current status of the service object.

**MM MAS Voice Port**

Use these counters to monitor voice port activity.

- **Inbound Calls Counter**  The number of incoming calls to the port.

- **Outbound Calls Counter**  The number of outbound calls from the port.

- **Port Status**  The current status of the port.

- **Port Status Time**  The time the port has been in its current state.

- **Total Calls Counter**  The total number of calls processed by the port.

**MM MWI Server**

Use these counters to monitor the activities of the message waiting indicator server.

- **Total MWI Enabled Subscribers**  The total number of MWI enabled subscribers being monitored.

**MM MWI Server Queue**

Use these counters to monitor the activities of the message waiting indicator server queue.

- **Average MWI Command Time in Queue**  The average time (in milliseconds) MWI commands remain in queue before processing.

- **Average MWI Commands Per Minute**  The average number of MWI commands processed per minute.
- **Average MWI Notifications Per Minute**  The average number of MWI notifications processed per minute.

- **Total MWI Queue Commands**  The total number of MWI commands queued for processing.

- **Total MWI Queue Retries**  The total number of MWI retry commands queued for processing.
This chapter describes how to use the **MM Audit Log Viewer** to audit the administrative configuration of the Windows servers in the Avaya Modular Messaging system.

**Overview**

- **MAS Auditing Overview** on page 10-2.

**MM Audit Log Viewer Screens Topics**

- **MM Audit Log Viewer Window** on page 10-4.
  - **Event Nodes** on page 10-6.
  - **Events List** on page 10-7.
- **Connect to MM Audit Database Dialog Box** on page 10-8.
- **Properties Dialog Box** on page 10-9.
- **Event Properties Dialog Box** on page 10-11.
MAS Auditing Overview

The **MM Audit Service** is installed to run on each MAS in the voice mail domain, including the supplementary server. For more information, see [Appendix C, Modular Messaging (MM) Services](#).

To activate Messaging Application Server (MAS) Auditing, the service on one MAS in the voice mail domain must be assigned to be the **MM Audit Server**. This is configured in the **Voice Mail System Configuration (VMSC)** application’s **Auditing** dialog box. For more information, see [Auditing Dialog Box](#) on page 3-113.

With MAS Auditing, an audit event is logged whenever a role-controlled administrative operation is attempted by an MAS or supplementary server. For more information, see [Security Roles Dialog Box](#) on page 3-88.

User-friendly information is logged as well as the typical system data. For example, the name of a caller application is logged, as well the Globally Unique Identifier (GUID).

Only the usage of Modular Messaging administrative applications is audited. Other usage is not logged.

**What Type of Data is *Not* Logged?**

- Passwords, or any similarly sensitive data.
- Usage of non-administrative Modular Messaging applications.
- Settings changed by subscribers.
- Subscriber Administration. This application is audited by the Avaya Message Store Server (Avaya MSS) ATI feature.

**Data Storage**

Audit logs can be configured to purge any events that are older than a specified number of days, automatically.

If the **MM Audit Server** has been assigned, logged audit events are eventually stored, even if the audit server is temporarily out of service.

The Modular Messaging system optionally sends syslog messages, if a receiver has been configured. This allows third-party system administration tools to be used.

These settings are configured in the **VMSC** application’s **Auditing** dialog box. For more information, see [Auditing Dialog Box](#) on page 3-113.
Viewing the Data

You can use the MM Audit Log Viewer to view the audit log data. See MM Audit Log Viewer Window on page 10-4.

Reporting on the Data

In the MM Audit Log Viewer, you can use the Action > Export List... command to export audit event lists, then open them into Excel or a similar application.
MM Audit Log Viewer Window

You can use the MM Audit Log Viewer to view the information captured by the MM Audit Service.

For more information on the capture and storage of audit data, see MAS Auditing Overview on page 10-2.

Launching the MM Audit Log Viewer Application

On your Windows desktop, click the Start > Programs > Avaya Modular Messaging > MM Audit Log Viewer menu to launch the MM Audit Log Viewer window.

Note: It can take a few seconds for the MM Audit Log Viewer window to launch.

MM Audit Log Viewer Window

The MM Audit Log Viewer main window works in a similar way to the Windows Event Viewer. You can navigate the view using the tree in the left hand pane. When you click a node in the tree, the menus, icons, and right hand pane change appropriately.

Note: The MM Audit Log Viewer window runs as a plug-in within the Microsoft Management Console. Generic screens and menu commands are not documented here. The Help > Help Topics menu command launches both the Microsoft Management Console Help and MM Audit Log Viewer Help.

Left Hand Pane - Tree View - MM Audit Log Viewer Node

At the top of the tree in the left hand pane, you can see the name of the server and database to which the MM Audit Log Viewer is currently connected.

This menu command is available when the MM Audit Log Viewer node is selected. You can right-click the node or use the top level menu:

- Action > Connect to Database Select to launch the Connect to MM Audit Database dialog box. You can then connect to a different database containing audit events. See Connect to MM Audit Database Dialog Box on page 10-8.

Left Hand Pane - Tree View - Event Node ( or )

Beneath the MM Audit Log Viewer node, there are some preset “views” which cannot be altered: All Events, All Events Today, All Events Last 7 Days, All Events Last 30 Days, and All Error Events. There may also be customer-created views.
For more information on event nodes, see Event Nodes on page 10-6.

**Right Hand Pane - Events List**

The right hand pane shows a list of events relevant to the node currently selected in the left hand pane.

This data is listed for each event: Type, Time, Username, Application, Operation, Object Type, Object, Old Value, and New Value.

For more information on the events list, see Events List on page 10-7.
Event Nodes

The MM Audit Log Viewer node is the top tree node in the MM Audit Log Viewer window. Beneath that node, there are a number of event nodes:

- These nodes have preset “views” which cannot be altered: All Events, All Events Today, All Events Last 7 Days, All Events Last 30 Days, and All Error Events.

- These nodes are customer-created nodes, where you have specified the parameters of the view.

Preset Views

- All Events Displays all events stored in the database.

- All Events Today Displays all events that occurred today.

- All Events Last 7 Days Displays all events that occurred within the last 7 days.

- All Events Last 30 Days Displays all events that occurred within the last 30 days.

- All Error Events Displays all events that were failed events.

Menu Commands

These menu commands are available when an event node is selected. You can right-click the node or use the top level menu:

- Action > New Log View Select to add a new customer-created view. This adds an event node in the tree. You must then configure the view using the Properties dialog box.

- Action > Properties Launches the Properties dialog box for the selected event node. See Properties Dialog Box on page 10-9.

  — If you selected one of the preset event views, the Properties dialog box is view only.

  — If you selected a customer-created view, generated using the Action > New Log View command, you can configure the Properties dialog box to the required view.

- Action > Export List... Select to export audit event lists using the Windows Export List dialog box. You can then open them into Excel or a similar application.
Events List

In the MM Audit Log Viewer window, you can click an event node ( or ) in the left hand pane tree. The right hand pane then shows a list of events relevant to the currently selected view.

You can click any column heading in the grid to sort the data in ascending or descending order.

**Note:** Use the Action > Refresh command to include newly-generated events.

Grid Column Headings

**Note:** These are the default column headings for the grid. You can alter them using the View > Add/Remove Columns menu command. This a standard feature of Microsoft Management Console.

- **Type** Displays the type of event, Allowed, Denied, or Error.
- **Time** Displays the time and date that the operation was attempted.
- **Username** Displays the Windows account used to attempt the operation, in the format domain\user.
- **Application** Displays the application that performed the change. For example, MAS.
- **Operation** Displays the operation that Avaya Modular Messaging was requested to perform. For example, Write or Read.
- **ObjectType** Displays the type of item that was changed. For example, Mailbox or Caller Application.
- **Object** Displays the name of the item that was changed. For example, the mailbox number or caller application name.
- **Old Value** Displays the old data value of the object that was changed.
- **New Value** Displays the new data value of the object that was changed.

Detailed View

You can view more event details than those displayed in the grid, if you double-click an event in the list. This launches the Event Properties dialog box for the that event. See Event Properties Dialog Box on page 10-11.
Connect to MM Audit Database Dialog Box

You can use the Connect to MM Audit Database dialog box to connect to a different database containing audit events.

Launching the Dialog Box

From the MM Audit Log Viewer window, click the MM Audit Log Viewer level of the tree.

You can right-click the node or use the top level menu, Action > Connect to Database.

Configuring the Screen Controls

- **Server** Enter the name of the server on which the database resides.

  You can use the Browse... button to select the server, if necessary.

- **Advanced >>** Press to reveal the Server Instance and Database fields. It is not usually necessary to configure these fields, as they have default values.

  - **Server Instance** Enter the name of the SQL server instance. The default is MMAUDIT.

    **Note:** Avaya Modular Messaging stores the log using Microsoft SQL Server. There can be a number of SQL server instances on the same machine.

  - **Database** Enter the name of the database containing audit events. The default is MMAUDIT.

  - **Advanced <<** Press to hide the Server Instance and Database fields.

- **Connect** Select to connect to the specified database.

  The system checks whether it can connect to the database. If so, the Connect to MM Audit Database dialog box closes, and the MM Audit Log Viewer window is updated. If not, you will see an error message and must amend the database details.

- **Cancel** Select to close the Connect to MM Audit Database dialog box and return to the MM Audit Log Viewer window, without changing the database.
Properties Dialog Box

The Properties dialog box is opened in either edit mode or view only mode, depending on the type of “view” you select. The name of the dialog box also changes to reflect the name of the selected view. For example, All Events Today Properties.

Launching the Dialog Box

From the MM Audit Log Viewer window, click one of the views in the tree.

You can right-click the node or use the top level menu, Action > Properties.

- If you selected one of the preset event views, All Events, All Events Today, All Events Last 7 Days, All Events Last 30 Days, or All Error Events, the Properties dialog box is view only.

- If you selected a customer-created view, you can configure the Properties dialog box.

Note: New nodes for customer-created views are generated using the Action > New Log View command.

Configuring the Screen Controls

- **Time Range** Select an option to filter the audit records by a particular time range.
  
  — **All** Select to view all events stored in the database.
  
  — **Today** Select to view all events stored in the database that occurred today.
  
  — **Last 7 Days** Select to view all events stored in the database that occurred in the last 7 days.
  
  — **Last 30 Days** Select to view all events stored in the database that occurred in the last 30 days.
  
  — **Custom** Select to view all events that occurred during the time range specified in the From and To fields.

  - **From** Select First Event to specify the first event stored in the database. Alternatively, select Events On, then specify the date and time.

  - **To** Select Last Event to specify the last event stored in the database. Alternatively, select Events On, then specify the date and time.
- **Event Types**  Select options to filter the audit records by their success.

  If you select **All**, then all events are included. If you select **Custom**, the check boxes are activated. You can then enable the check boxes to customize the types of events.

  — **Allowed**  Enable to select all allowed events.

  — **Denied**  Enable to select all denied events.

  — **Error**  Enable to select all error events.

- **User**  Select events based on which user initiated them. You can select **All**, or a particular user from a list of valid options.

- **Operation**  Select events based on the type of operation that Avaya Modular Messaging was requested to perform. You can select **All**, or a particular operation from a list of valid options.

- **Object Type**  Select events based on the type of item that was changed. You can select **All**, or a particular object type from a list of valid options.

- **Object**  Select events based on the name of the item that was changed. You can select **All**, or a particular object from a list of valid options.
Event Properties Dialog Box

You can use the Event Properties dialog box to view further details of an audited event.

Launching the Dialog Box

From the MM Audit Log Viewer window, in the right hand pane, double-click a row in the events list.

Event Details

- **Type** Displays the type of event: Allowed, Denied or Error.
- **Time** Displays the time and date that the operation was attempted.
- **Username** Displays the Windows account used to attempt the operation, in the format domain\user.
- **Result** Displays the HRESULT code indicating the success of the operation.
- **Application** Displays the application that performed the change. For example, MAS.
- **Operation** Displays the operation that Avaya Modular Messaging was requested to perform. For example, Write or Read.
- **ObjectType** Displays the type of item that was changed. For example, Mailbox or Caller Application.
- **Object** Displays the name of the item that was changed. For example, the mailbox number or caller application name.
- **Old Value** Displays the old data value of the object that was changed.
- **New Value** Displays the new data value of the object that was changed.
- **VMD Name** Displays the name of the voice mail domain from which the event originated.
- **VMD ID** Displays the unique identifier of the voice mail domain from which the event originated.
- **UserSID** Displays the security identifier (SID) of the user who attempted the operation.
- **SequenceID** Displays the identifier for the event. This is unique in the log when combined with the Time.
Viewing Other Events from the List

You can use these arrows to view the details of other events in the list, without having to close the Event Properties dialog box:

- 
  Displays the details of the previous event in the events list.
- 
  Displays the details of the next event in the events list.
This chapter describes how to display and view event, error, and alarm logs on the messaging application server (MAS).

Topics included in this chapter:

- Displaying MAS Event & Error Logs on page 11-3.
- Displaying MAS Alarm Logs on page 11-4.

Related Appendix

- Appendix A, “MAS Alarms”.
Overview of MAS Event, Error & Alarm Logs

The Avaya S3420 Messaging Application Server provides logs and notifications for events, errors, and alarms.

**Note**: See Appendix A, “MAS Alarms” for a description and repair procedure for events, errors and alarm that can occur on the messaging application server.

INADS & SNMP Traps

The alarm subsystem provides mechanisms for sending alarm notifications to support personnel in a timely manner. These notifications can be sent using the Avaya Initialization and Administration System (INADS) or through the use of SNMP traps.

For information about administering these notifications for the voice mail domain and at MAS level, see Serviceability Dialog Box on page 3-189, and MAS - Serviceability Dialog Box on page 4-62.

Command Line Interface Tools

Each MAS provides a set of event, error, and alarm logs, accessible to support personnel for analysis. You can access the following logs using a set of command line interface tools:

- **Maintenance events log** This contains events and errors generally of interest only to technical services and development personnel.

- **Administrator log** This contains events and errors that will likely be of interest to system administrators.

  For the Administrator log, see Displaying MAS Event & Error Logs on page 11-3.

- **Active alarms log** This contains information about alarms that are currently active on the system and is one of your primary lines of attack when problems occur.

- **Resolved alarms log** This contains a history of and information about alarms that have been raised and then resolved on the system. This log can be useful in analyzing problems and trends in the system.

  For the Active & Resolved alarms logs, see Displaying MAS Alarm Logs on page 11-4.
Displaying MAS Event & Error Logs

Note: See Appendix A, "MAS Alarms" for a description and repair procedure for events, errors and alarm that can occur on the messaging application server.

The Avaya S3420 Messaging Application Server provides two system logs related specifically to events and errors.

- **Administrator log**  This contains events and errors that will likely be of more interest to system administrators.

- **Maintenance events log**  This contains events and errors generally of interest only to technical services and development personnel.

Procedure 1: Displaying an Event and Error Log on the MAS

1. On your Windows desktop, click the **Start > Run** menu command. The system displays the **Run** dialog box.

2. In the **Open** field, type **command** or **cmd** and click **OK**. The system displays the **MS-DOS Prompt** window.

3. At the DOS prompt, enter one of the following commands, depending on the event and error log you want to view:

   - To view the administrator log, enter **displog -l admin**.
   - To view the maintenance events log, enter **displog -l maint**.

You may wish to limit the number of entries the system displays. Otherwise, you may have to sift through hundreds or thousands of entries. To do this, you can modify the displog command to retrieve records for designated days or times, for example:

   - If you wanted to view the events log for today from 3:00 p.m. to the current time, you would enter: **displog -l maint -d15:00**.

   - If you wanted to view the administrator log for all of today, starting from midnight, you would enter: **displog -l admin -dmm/dd/yy** (where **mm/dd/yy** is today’s date).

   - If you wanted to view the events log for all events starting from a certain day at 8:00 a.m. to the present, you would enter: **displog -l maint -d"mm/dd/yy 08:00"** (where **mm/dd/yy** is the starting date for the records you want to view).
Displaying MAS Alarm Logs

**Note:** See Appendix A, “MAS Alarms” for a description and repair procedure for events, errors and alarm that can occur on the messaging application server.

The Avaya S3420 Messaging Application Server provides two system logs related specifically to alarms.

- **Active alarms log**  This contains information about alarms that are currently active on the system. It is one of your primary lines of attack, when problems occur.

- **Resolved alarms log**  This contains a history of and information about alarms that have been raised and then resolved on the system. This log can be useful in analyzing problems and trends in the system.

**Procedure 1: Displaying an Alarm Log on the MAS**

1. On your Windows desktop, click the **Start > Run** menu command. The system displays the **Run** dialog box.

2. In the **Open** field, type **command** or **cmd** and click **OK**. The system displays the **MS-DOS Prompt** window.

3. At the DOS prompt, enter one of the following commands, depending on the alarm log you want to view:
   - To view active alarms, enter **displog -l act**.
   - To view resolved alarms, enter **displog -l res**.

You may wish to limit the number of entries the system displays. Otherwise, you may have to sift through hundreds or thousands of entries. To do this, you can modify the displog command to retrieve records for designated days or times, for example:

- If you wanted to view the resolved alarms log for today from 3:00 p.m. to the current time, you would enter: **displog -l res -d15:00**.

- If you wanted to view the resolved alarms log for all of today, starting from midnight, you would enter: **displog -l res -dmm/dd/yy** (where mm/dd/yy is today’s date).

- If you wanted to view the resolved alarms log for all events starting from a certain day at 8:00 a.m. to the present, you would enter: **displog -l res -d"mm/dd/yy 08:00"** (where mm/dd/yy is the starting date for the records you want to view).

**Note:** These time limiters are not generally useful for the active alarms log, but you can use them, if you so wish.
Appendix A: MAS Alarms

This appendix gives a description and repair procedure for each alarm that can occur on the Messaging Application Server (MAS). An alarm indicates a hardware, software, or environmental problem that could affect system operation.

Displaying Alarms

The system displays MAS alarms in the MAS alarm logs. To display alarm and event IDs, use the command line interface and the following commands:

- For active alarm IDs, enter `displog -l act`.
- For resolved alarm IDs, enter `displog -l res`.
- For maintenance event IDs, enter `displog -l maint`.

For more information, see Chapter 11, “MAS Event, Error & Alarm Logs”.

Alarm Application Types

The Alarm Application Identifier is the two-letter code used to identify the application or subsystem for which an alarm is being generated. For example, CM for Call Me.

- [MAS Alarms - CM (Call Me)] on page A-3.
- [MAS Alarms - MM (Mailbox Monitor)] on page A-4.
- [MAS Alarms - MT (Maintenance)] on page A-9.
- [MAS Alarms - MW (Message Waiting Indicator)] on page A-33.
- [MAS Alarms - TS (Tracing Server)] on page A-36.
- [MAS Alarms - VB (Avaya Voice Browser)] on page A-41.
- [MAS Alarms - VS (Voice Server)] on page A-51.
MAS Alarms

MAS Alarms - CM (Call Me)

The following alarms are generated by the Call Me application and indicate a problem with Call Me on the affected MAS.

CM CALLME

- MAS Alarm - CM CALLME 1 on page A-3.

MAS Alarm - CM CALLME 1

Level

Minor.

System Descriptor

CallMe is having trouble.

Description

This alarm indicates that there is a problem with the Call Me service.

The system generates this alarm whenever the “CallMe Failures” KPI (event ID 120) is incremented more than five times at an average rate faster than once every five minutes.

Repair Procedure

If there is no new alarm generated within a 15-minute period, then the system considers the alarm resolved and generates a resolved-alarm event.

If the system does not resolve the alarm automatically within a period of a few hours, contact your Avaya technical support representative for assistance.
MAS Alarms - MM (Mailbox Monitor)

The following alarms are generated by the Mailbox Monitor application and indicate a problem with the Mailbox Monitor on the affected MAS.

MM IMAPI

- [MAS Alarm - MM IMAPI 1](#) on page A-5.
- [MAS Alarm - MM IMAPI 2](#) on page A-6.

MM PERF

- [MAS Alarm - MM PERF 17](#) on page A-7.
- [MAS Alarm - MM PERF 18](#) on page A-8.
MAS Alarms

MAS Alarm - MM IMAPI 1

Level
Major.

System Descriptor
Mailbox Monitor failed to access MSS via IMAPI.

Description
This alarm indicates that the Mailbox Monitor application failed to access the Avaya Message Store Server (Avaya MSS) using the Intuity Messaging application program interface (IMAPI). This alarm can be raised by having a wrong IP address or password administered for a trusted server.

When this alarm is raised, you will typically see a number of trusted server login failures in the mmserver log.

Repair Procedure
To correct the conditions which caused this alarm, you must determine what IP address or password has been administered incorrectly and correct it.

To find more detailed information about what caused this alarm to be generated, you can check the Windows event log. See Chapter 11, “MAS Event, Error & Alarm Logs”.
MAS Alarms

MAS Alarm - MM IMAPI 2

Level
Minor.

System Descriptor
Mailbox Monitor's IMAPI call failed with ERR_COMM_FAIL.

Description
This alarm indicates that the Mailbox Monitor has problems during IMAPI calls.

Repair Procedure
The maintenance procedure for this alarm will automatically restart the MM Call Me Server, MM Mailbox Monitor, and MM Message Waiting Indicator services, and the alarm will be resolved.

If the system does not resolve the alarm automatically within a period of a few minutes, contact your Avaya technical support representative.
MAS Alarm - MM PERF 17

Level
Minor.

System Descriptor
Counter (virtual bytes) for mailbox monitor server process greater than 1.6 GB

Description
This alarm indicates that the counter (in virtual bytes) for the Mailbox Monitor server process is greater than 1.6 GB. This means that the Mailbox Monitor process has exceeded the recommended virtual memory usage.

This problem may be caused by memory leaks in the system. When this happens, the system can become unstable, and one or more processes or services can begin to fail.

Repair Procedure
To recover from this alarm, you must stop and restart the MM Mailbox Monitor service. See Appendix C, Modular Messaging (MM) Services.
MAS Alarm - MM PERF 18

Level
Major.

System Descriptor
Counter (virtual bytes) for mailbox monitor server process greater than 1.8 GB.

Description
This alarm indicates that the counter (in virtual bytes) for the Mailbox Monitor server process is greater than 1.8 GB. This means that the Mailbox Monitor process has exceeded the recommended virtual memory usage.

This problem may be caused by memory leaks in the system. When this happens, the system can become unstable, and one or more processes or services can begin to fail.

Repair Procedure
To recover from this alarm, you must stop and restart the MM Mailbox Monitor service. See Appendix C, Modular Messaging (MM) Services.
MAS Alarms - MT (Maintenance)

The following alarms indicate maintenance problems on the affected Messaging Application Server (MAS).

MT ABS_PROC
- MAS Alarm - MT ABS_PROC 1 on page A-11.
- MAS Alarm - MT ABS_PROC 7 on page A-17.

MT ALARM_ORIG
- MAS Alarm - MT ALARM ORIG 0 on page A-19.
- MAS Alarm - MT ALARM ORIG 1 on page A-20.

MT OHDB

MT PERF
- MAS Alarm - MT PERF 7 on page A-23.
MAS Alarms

- **MAS Alarm - MT PERF 27** on page A-29.

**MT WINEVT**

- **MAS Alarm - MT WINEVT 1216ERR** on page A-30.
- **MAS Alarm - MT WINEVT 1216WRN** on page A-31.
- **MAS Alarm - MT WINEVT 1200WRN** on page A-32.
MAS Alarm - MT ABS_PROC 1

Level
Major.

System Descriptor
vserver process not running.

Description
This alarm indicates that the MM Messaging Application Server service is not running.

Repair Procedure
If you see this alarm, you must restart the MM Messaging Application Server service. See Appendix C, Modular Messaging (MM) Services.

When the MM Messaging Application Server service restarts successfully, then the system considers the alarm resolved and generates a resolved-alarm event.

If the system does not resolve the alarm automatically within a period of a few minutes, contact your Avaya technical support representative.
MAS Alarm - MT ABS_PROC 2

Level
Warning.

System Descriptor
Tracing server not running.

Description
This alarm indicates that the **MM Tracing Server** service is not running.

Repair Procedure
If you see this alarm, you must restart the **MM Tracing Server** service. See Appendix C, Modular Messaging (MM) Services.

When the **MM Tracing Server** service restarts successfully, then the system considers the alarm resolved and generates a resolved-alarm event.

If the system does not resolve the alarm automatically within a period of a few minutes, contact your Avaya technical support representative.
**MAS Alarm - MT ABS_PROC 3**

**Level**
Minor.

**System Descriptor**
MWI server not running.

**Description**
This alarm indicates that the **MM Message Waiting Indicator Server** service is not running.

**Repair Procedure**
If you see this alarm, you must restart the **MM Message Waiting Indicator Server** service. See Appendix C, Modular Messaging (MM) Services.

When the **MM Message Waiting Indicator Server** service restarts successfully, then the system considers the alarm resolved and generates a resolved-alarm event.

If the system does not resolve the alarm automatically within a period of a few minutes, contact your Avaya technical support representative for assistance.
MAS Alarm - MT ABS_PROC 4

Level
Minor.

System Descriptor
Mailbox monitor process not running.

Description
This alarm indicates that the MM Mailbox Monitor service is not running.

Repair Procedure
If you see this alarm, you must restart the MM Mailbox Monitor service. See Appendix C, Modular Messaging (MM) Services.

When the MM Mailbox Monitor service restarts successfully, then the system considers the alarm resolved and generates a resolved-alarm event.

If the system does not resolve the alarm automatically within a period of a few minutes, contact your Avaya technical support representative for assistance.
MAS Alarm - MT ABS_PROC 5

Level
Minor.

System Descriptor
Call Me server not running.

Description
This alarm indicates that the MM Call Me Server service is not running.

Repair Procedure
If you see this alarm, you must restart the MM Call Me Server service. See Appendix C, Modular Messaging (MM) Services.

When the MM Call Me Server service restarts successfully, then the system considers the alarm resolved and generates a resolved-alarm event.

If the system does not resolve the alarm automatically within a period of a few minutes, contact your Avaya technical support representative for assistance.
MAS Alarm - MT ABS_PROC 6

Level
Minor.

System Descriptor
Event monitor server not running.

Description
This alarm indicates that the MM Event Monitor Server service is not running.

Repair Procedure
If you see this alarm, you must restart the MM Event Monitor Server service. See Appendix C, Modular Messaging (MM) Services.

When the MM Event Monitor Server service restarts successfully, then the system considers the alarm resolved and generates a resolved-alarm event.

If the system does not resolve the alarm automatically within a period of a few minutes, contact your Avaya technical support representative for assistance.
MAS Alarm - MT ABS_PROC 7

Level
Minor.

System Descriptor
Performance Monitor Server not running.

Description
This alarm indicates that the MM Performance Monitor Server service is not running.

Repair Procedure
If you see this alarm, you must restart the MM Performance Monitor Server service. See Appendix C, Modular Messaging (MM) Services.

When the MM Performance Monitor Server service restarts successfully, then the system considers the alarm resolved and generates a resolved-alarm event.

If the system does not resolve the alarm automatically within a period of a few minutes, contact your Avaya technical support representative for assistance.
MAS Alarm - MT ABS_PROC 8

Level
Minor.

System Descriptor
IIS Service not running.

Description
This alarm indicates that the Internet Information Server (IIS) Admin Service is not running.

Repair Procedure
If you see this alarm, you must restart the IIS Admin Service. This can be done through the Services window.

1. Click Start > Programs > Administrative Tools > Services.
2. Right-click IIS Admin Service.
3. Select the Start menu item.

When the IIS Admin Service restarts successfully, then the system considers the alarm resolved and generates a resolved-alarm event.

If the system does not resolve the alarm automatically within a period of a few minutes, contact your Avaya technical support representative for assistance.
**MAS Alarm - MT ALARM_ORIG 0**

**Level**

Minor.

**System Descriptor**

Event/Module ID not in module’s rules file.

**Description**

This alarm indicates that there was an event or module identified in the alarming service that is not defined in the alarming service’s rules file.

**Repair Procedure**

When this alarm is generated, if you have a valid service contract, the system automatically sends a notification to Avaya technical services. No further action is required on your part.

If you do not have a valid service contract, then you should contact your Avaya technical support representative for assistance.
MAS Alarm - MT ALARM_ORIG 1

Level
Warning.

System Descriptor
Too many call attempts.

Description
This alarm indicates that the system has been trying unsuccessfully to send alarm notifications for an extended period of time. When trying to send alarm notifications, if the first attempt is unsuccessful, then the system tries again at five-minute intervals. If still unsuccessful after 16 tries, then the system stops trying and generates this warning alarm.

Repair Procedure
The repair action Avaya recommends for this alarm depends on which method you are using to send alarm notifications:

- If you are using INADS, verify that your modem is connected, powered up, and running properly, and verify that your system is properly configured for INADS.

  For information about INADS configuration, see MAS - Serviceability Dialog Box on page 4-62.

- If you are using SNMP, verify that your MAS can communicate with your SNMP network management station, and verify that your system is properly configured for SNMP notifications.

  For information about SNMP configuration, see Serviceability - SNMP Trap Destinations Tab on page 3-194.

If you have completed these steps and the problem still exists, then run the testaom command in a Command Prompt window. This command provides more detailed diagnostic information, which may help you resolve the problem.

Once you have resolved the problem, to clear this warning alarm from the system and verify that the problem no longer exists, run the testaom command again.

If you have tried all this, and the problem still exists, then you should contact your Avaya technical support representative for assistance.
MAS Alarm - MT OHDB 1

Level
Minor.

System Descriptor

Database file ophist.mdb cannot be accessed for compaction. Ensure that the file is not in use (or read-only).

Description

This alarm indicates that the operation history database (OpHist.mdb) is in use by applications, such as the Operation History Viewer.

Operation History Cleaner (OHClean) needs exclusive access on this database for compaction. The compaction procedure will fail, if the database is in use.

Repair Procedure

If you see this alarm, you must close the applications which are using the operation history database, such as the Operation History Viewer.

Run the OHClean utility (under the path $InstallDrive\Program Files\Avaya Modular Messaging\Tracing) to compact and clean the operation history database, or wait for the next scheduled cleanup.
MAS Alarm - MT PERF 6

Level

Warning.

System Descriptor

MAS CPU occupancy > 90%.

Description

This warning alarm indicates that the CPU of the Messaging Application Server (MAS) has run at greater than 90% of its capacity more than four times within an hour.

Repair Procedure

Once this alarm has been raised, the system continues monitoring. If the occupancy rate subsequently falls below 70% and remains there for at least an hour, then the problem is considered resolved and the system automatically generates a resolved-alarm event.

If the system does not automatically resolve this alarm, you can open the Windows Task Manager and see what processes are putting significant demands on the CPU. If the processes are unrelated to Modular Messaging and you can safely stop them, then do so. If the processes are related to Modular Messaging, then it may indicate a more serious problem requiring in-depth attention. If that is the case, contact your Avaya technical support representative for assistance.
MAS Alarms

MAS Alarm - MT PERF 7

Level
Information alarming event.

System Descriptor
MAS disk time > 60%.

Description
This alarm indicates that the system performance counter, PhysicalDisk(_Total)\% Disk Time, exceeds 60%.

Repair Procedure
This alarm is just for information. No repair action is needed.
MAS Alarm - MT PERF 10

Level
Major.

System Descriptor
MAS disk space > 85%.

Description
This alarm indicates that the Messaging Application Server (MAS) disk space is 85% or more full.

Repair Procedure
Once this alarm has been raised, the system continues monitoring. If the disk space usage subsequently falls below 85%, then the problem is considered resolved and the system automatically generates a resolved-alarm event.

If you see this alarm, you can check your system for excessively large files. The log files can become excessively large, if not managed properly, and you may need to reconfigure your system to limit the size and/or number of these files. For the procedure to do this, see *Avaya Modular Messaging Installation and Upgrades Guide* for your system.

Also, if you have other files which seem to be consuming a large amount of space, see whether you can eliminate or compress them.
MAS Alarms

MAS Alarm - MT PERF 19

Level
Major.

System Descriptor
MAS disk space < 250MB.

Description
The available disk space on the Messaging Application Server (MAS) is less than 250 MB. When this happens, the system runs a maintenance procedure (MP) that stops the MAS. If the option to shut down gracefully is selected, then it does so according to the rules of a graceful shutdown.

Repair Procedure
To correct the condition that causes this alarm, you must free some disk space or add more disk space to the system. To free up disk space, you can:

- Use the Windows system Disk Cleanup tool.
- Run the Windows system Disk Defragmenter tool.
- Run the chkdsk command.

If the alarm persists after these actions have been taken, then contact your Avaya technical support representative for assistance.
MAS Alarm - MT PERF 24

Level
Warning.

System Descriptor
Remote offline storage disk space is greater than 85%.

Description
This alarm indicates that the remote offline storage space is 85% full.

Repair Procedure
Once this alarm has been raised, the system continues monitoring. If the disk space usage subsequently falls below 85%, then the problem is considered resolved and the system automatically generates a resolved-alarm event.
MAS Alarm - MT PERF 25

Level
Minor.

System Descriptor
Remote offline storage disk space is greater than 95%.

Description
This alarm indicates that the remote offline storage disk space is 95% full and soon the system will not be able receive and handle more messages.

Repair Procedure
Check the free storage space on the remote offline storage machine. You must free some space or add more disk space to the system. To free up disk space, you can:

- Use the Windows system Disk Cleanup tool.
- Run the Windows system Disk Defragmenter tool.
- Run the chkdsk command.

The system continues monitoring. If the storage disk usage falls below 95%, the problem is considered to be resolved. The system automatically generates a resolved-alarm event.
MAS Alarm - MT PERF 26

Level
Major.

System Descriptor
Remote offline storage disk space is full (99%).

Description
This alarm indicates that the remote offline storage space is 99% full and sending offline messages will be disabled.

Repair Procedure
Once this alarm is raised, the system automatically runs a maintenance procedure and disables remote offline access. TUI users are not be able to leave messages when the message store server is offline.

To resolve this alarm:

1. Check the free storage space on the remote offline storage machine. You must free some space or add more disk space to the system. To free up disk space, you can:
   - Use the Windows system Disk Cleanup tool.
   - Run the Windows system Disk Defragmenter tool.
   - Run the chkdsk command.

2. Once enough disk space is available, at least more than 15% free disk space, enable remote offline access.

   For information on enabling remote offline access, see Messaging - Offline Access Tab on page 3-178.
MAS Alarm - MT PERF 27

Level
Major.

System Descriptor
Disk fragmentation is greater than 75%.

Description
This alarm indicates that the disk fragmentation is very high. The system's overall performance may deteriorate, because it takes long time for writing and reading operations on a highly fragmented disk.

Repair Procedure
To resolve this alarm run Windows Disk Defragmenter tool and bring the file fragmentation percentage level below 75%.

The system will continuously monitor the defragmentation level. Once the level is below 75%, the problem is considered to be resolved and resolved-alarm event is sent.
MAS Alarm - MT WINEVT 1216ERR

Level
Major.

System Descriptor
The hard drive on MAS is failed.

Description
This alarm indicates that hard drive on MAS has failed.

Repair Procedure
None.
MAS Alarms

MAS Alarm - MT WINEVT 1216WRN

Level
Minor.

System Descriptor
The failed drive has been replaced and a RAID Recovery (Rebuild) has been started.

Description
This alarm indicates that the failed drive has been replaced and a RAID Recovery (Rebuild) has been started.

Repair Procedure
None.
MAS Alarm - MT WINEVT 1200WRN

Level
Minor.

System Descriptor
The failed hard drive has completed recovery.

Description
This alarm indicates that the failed hard drive has completed recovery.

Repair Procedure
None.
MAS Alarms - MW (Message Waiting Indicator)

The following alarms are generated by the Message Waiting Indicator (MWI) application and indicate a problem with the MM Message Waiting Indicator Server service on the affected Messaging Application Server (MAS).

**MW PERF**

- [MAS Alarm - MW PERF 15](#) on page A-34.
- [MAS Alarm - MW PERF 16](#) on page A-35
MAS Alarms

MAS Alarm - MW PERF 15

Level
Minor.

System Descriptor
Counter (virtual bytes) for MWI server process greater than 1.6 GB.

Description
This alarm indicates that the counter (in virtual bytes) for the MM Message Waiting Indicator Server service is greater than 1.6 GB. This means that the MM Message Waiting Indicator Server service has exceeded the recommended virtual memory usage.

This problem may be caused by memory leaks in the system. When this happens, the system can become unstable, and one or more processes or services can begin to fail.

Repair Procedure
To recover from this alarm, you must stop and restart the MM Message Waiting Indicator Server service. See Appendix C, Modular Messaging (MM) Services.
MAS Alarm - MW PERF 16

Level
Major.

System Descriptor
Counter (virtual bytes) for MWI server process greater than 1.8 GB.

Description
This alarm indicates that the counter (in virtual bytes) for the MM Message Waiting Indicator Server service is greater than 1.8 GB. This means that the MM Message Waiting Indicator Server service has exceeded the recommended virtual memory usage.

This problem may be caused by memory leaks in the system. When this happens, the system can become unstable, and one or more processes or services can begin to fail.

Repair Procedure
To recover from this alarm, you must stop and restart the MM Message Waiting Indicator Server service. See Appendix C, Modular Messaging (MM) Services.
MAS Alarms - TS (Tracing Server)

The following alarms are generated by the Tracing Server application and indicate a problem with the Tracing Server application on the affected Messaging Application Server (MAS), or supplementary server.

TS OHDB

TS PERF
MAS Alarms

MAS Alarm - TS OHDB 1

Level
Warning.

System Descriptor
OpHist file size is greater than 1 GB.

Description
This alarm indicates that the operation history database (OpHist.mdb) size has gone beyond 1 GB.

Repair Procedure
The system will resolve this alarm when the database size goes lower than 1 GB.

MAS Alarm - TS OHDB 2

Level
Minor.

System Descriptor
OpHist file size is greater than 1.5 GB.

Description
This alarm indicates that the operation history database (OpHist.mdb) size has gone beyond 1.5 GB. The alarm will generate an SNMP or INADS message.

Repair Procedure
The system will resolve this alarm when the database size goes lower than 1.5 GB.
MAS Alarms

MAS Alarm - TS OHDB 3

Level

Major.

System Descriptor

OpHist file size is greater than 1.8 GB.

Description

This alarm indicates that the operation history database (OpHist.mdb) size has gone beyond 1.8 GB. The alarm will generate an SNMP or INADS message.

Repair Procedure

The alarming system will run a maintenance procedure (OphistFilebackup.exe). This maintenance procedure will backup the current Operation History database (OpHist.mdb) and create a new empty database. It will also resolve the major alarm.
MAS Alarm - TS PERF 13

Level
Minor.

System Descriptor
Counter (virtual bytes) for tracing server process greater than 1.6 GB

Description
This alarm indicates that the counter (in virtual bytes) for the MM Tracing Server service is greater than 1.6 GB. This means that the MM Tracing Server service has exceeded the recommended virtual memory usage.

This problem may be caused by memory leaks in the system. When this happens, the system can become unstable, and one or more processes or services can begin to fail.

Repair Procedure
To recover from this alarm, you must stop and restart the MM Tracing Server service. See Appendix C, Modular Messaging (MM) Services.
MAS Alarm - TS PERF 14

Level
Major.

System Descriptor
Counter (virtual bytes) for tracing server process greater than 1.8 GB

Description
This alarm indicates that the counter (in virtual bytes) for the MM Tracing Server service is greater than 1.8 GB. This means that the tracing server process has exceeded the recommended virtual memory usage.

This problem may be caused by memory leaks in the system. When this happens, the system can become unstable, and one or more processes or services can begin to fail.

Repair Procedure
To recover from this alarm, you must stop and restart the MM Tracing Server service. See Appendix C, Modular Messaging (MM) Services.
MAS Alarms - VB (Avaya Voice Browser)

The following alarms are generated by the Avaya Voice Browser application and indicate a problem with the Avaya Voice Browser application on the affected Messaging Application Server (MAS).

### VB VB

- [MAS Alarm - VB VB 1](#) on page A-42.
- [MAS Alarm - VB VB 2](#) on page A-43.
- [MAS Alarm - VB VB 202](#) on page A-44.
- [MAS Alarm - VB VB 203](#) on page A-45.
- [MAS Alarm - VB VB 204](#) on page A-46.
- [MAS Alarm - VB VB 205](#) on page A-47.
- [MAS Alarm - VB VB 212](#) on page A-49.
- [MAS Alarm - VB VB 213](#) on page A-50.
- [MAS Alarm - VB VB 999](#) on page A-50.
MAS Alarm - VB VB 1

Level
Minor.

System Descriptor
Avaya Voice Browser: Unable to initialize.

Description
This alarm indicates that the Avaya Voice Browser application was unable to initialize.

Repair Procedure
When this alarm is generated, the system runs a maintenance procedure (MP) to attempt to restart the Avaya Voice Browser. If the Voice Browser software starts, then the system generates a resolved alarm event.

If the system cannot start the Voice Browser, it may indicate that there is a coding problem, that the Voice Browser cannot communicate with other parts of the system, or that the Messaging Application Server (MAS) configuration has become corrupted. The repair action will depend on the cause of the problem. If this alarm keeps being generated, contact your Avaya technical support representative for assistance.
MAS Alarms

MAS Alarm - VB VB 2

Level

Major.

System Descriptor

Restarting Avaya Voice Browser.

Description

This alarm indicates that a serious error has occurred with respect to the Avaya Voice Browser application. As a result, a maintenance procedure (MP) has stopped and restarted the Voice Browser software.

Repair Procedure

This alarm is considered self-repairing and indicates that the system is attempting to resolve it itself. If you see this alarm repeatedly or persistently, contact your Avaya technical support representative for assistance.
MAS Alarm - VB VB 202

Level

NON - Information Only.

System Descriptor

Avaya Voice Browser: Out Of Memory

Description

The system raises this alarm when the Avaya Voice Browser application requests memory and the return code says there is none. Therefore, the Avaya Voice Browser cannot start.

Repair Procedure

To correct this error, try rebooting the system. If that does not correct the problem, contact your Avaya technical support representative for assistance.
MAS Alarm - VB VB 203

Level
NON - Information Only.

System Descriptor
Avaya Voice Browser: Bad URI fetch.

Description
This alarm indicates that an attempt by the Avaya Voice Browser application for a Universal Resource Identifier (URI) resulted in an error response from the web server. The system Internet Information Server (IIS) software generates this alarm, when one of the following conditions exists:

- The web content contains coding errors.
- There is an internal conflict within the IIS software itself.
- The Messaging Application Server (MAS) cannot contact the message store server (Avaya MSS).
- When the configuration of the web application has been altered.

In the first three cases, when this alarm is generated, the system terminates the phone call in which it was generated, with a prompt to the effect that "I'm sorry, but this call is experiencing difficulty." Other calls should be unaffected. If, however, an application configuration problem is causing it, then all calls coming in will experience the same response.

Repair Procedure
The repair/recovery procedure for this alarm depends on the initial cause, as listed above:

- If the cause is that the web content contains coding errors, then this error will be generated for any call that attempts to access that web content. This will continue until the coding error has been corrected.
- If there is an internal conflict within the IIS software, in most cases, the problem will correct itself with the next call. If not, then it may be necessary to reboot the system, which should correct the problem.
- If the MAS cannot contact the message store server, in most cases the problem will correct itself with the next call. If not, then it may be necessary to reboot the system, which should correct the problem.
If the configuration of our web application has been altered, and all calls are having problems, then you must reinstall the system software.

If none of these actions correct the problem, then contact your Avaya technical support representative for assistance.

MAS Alarm - VB VB 204

Level
NON - Information Only.

System Descriptor
Avaya Voice Browser: Cannot read from URI.

Description
This alarm indicates that a connection to the Internet Information Server (IIS) software has been made, but the response to the request cannot be read. When this happens, the system terminates the phone call in which it was generated, with a prompt to the effect that “I’m sorry, but this call is experiencing difficulty.” Other calls should be unaffected.

Repair Procedure
In most cases, the problem will correct itself with the next call. If not, then it may be necessary to reboot the system, which should correct the problem.

If that still does not correct the problem, then contact your Avaya technical support representative for assistance.
MAS Alarm - VB VB 205

Level
NON - Information Only.

System Descriptor
Avaya Voice Browser: Cannot parse content from URI.

Description
This alarm indicates that the Avaya Voice Browser application successfully returned the Universal Resource Identifier (URI), but returned malformed VoiceXML. This indicates some sort of error in the web content code. When this happens, the Voice Browser cannot parse the content from the URI, and the call is terminated.

Repair Procedure
Any call that attempts to access the URI will generate this alarm until the error in the web content code is corrected.

In most cases, the problem will correct itself with the next call. If not, then contact your Avaya technical support representative for assistance.
MAS Alarms

MAS Alarm - VB VB 209

Level
NON - Information Only.

System Descriptor
Avaya Voice Browser: Caught fatal exception.

Description
This alarm indicates that the Avaya Voice Browser application contains an error in the code. When this alarm is raised, the system terminates the call.

Repair Procedure
Debug the application to locate and fix the error in the code. Contact your Avaya technical support representative to report the problem and get assistance.

MAS Alarm - VB VB 210

Level
NON - Information Only.

System Descriptor
Avaya Voice Browser: Surpassed maximum loop iterations.

Description
The Avaya Voice Browser contains a mechanism that prevents out-of-control web content in the form of pages that jump to other pages without human intervention in a never-ending loop. When this occurs, the system raises this alarm and terminates the call.

Repair Procedure
Investigation is required to find out what caused the condition to occur and correct it. You must contact your Avaya technical support representative for assistance.
MAS Alarms

MAS Alarm - VB VB 212

Level
NON - Information Only.

System Descriptor
Avaya Voice Browser: Caught JavaScriptError exception.

Description
This alarm indicates that the Avaya Voice Browser application caught a JavaScriptError exception. This indicates a coding error in the JavaScript of the web page being called. When this alarm is raised, the system terminates the call.

Repair Procedure
Any call that attempts to access the web page will generate this alarm until the error in the JavaScript code is corrected.

In most cases, the problem will correct itself with the next call. If not, then contact your Avaya technical support representative for assistance.
MAS Alarm - VB VB 213

Level
NON - Information Only.

System Descriptor
Avaya Voice Browser: Bad URI fetch for home page.

Description
This alarm indicates that the Avaya Voice Browser application returned an incorrect Universal Resource Identifier (URI) for the home page. This indicates some sort of error in the web content code. When this happens, the Voice Browser cannot parse the content from the URI, and the call is terminated.

Repair Procedure
An automatic repair procedure will be executed to restart the Internet Information Server (IIS) service. If the problem still exists, contact your Avaya technical representative for assistance.

MAS Alarm - VB VB 999

Level
Minor.

System Descriptor
Avaya Voice Browser: Internal Voice Browser error.

Description
This alarm indicates that the Avaya Voice Browser application experienced an internal voice browser error. It indicates an error in the code. When this alarm is raised, the system terminates the call.

Repair Procedure
Debug the application to locate and fix the error in the code. Contact your Avaya technical support representative to report the problem and get assistance.
MAS Alarms - VS (Voice Server)

The following alarms are generated by the **MM Messaging Application Server** service. They indicate a problem specific to the affected Messaging Application Server (MAS).

---

**Note:** In older versions of Modular Messaging, the MAS was referred to as the “Voice Server”.

---

VS COM

- **MAS Alarm - VS COM 1** on page A-54.
- **MAS Alarm - VS COM 2** on page A-55.

VS EXCEPTION

- **MAS Alarm - VS EXCEPTION 1** on page A-56.
- **MAS Alarm - VS EXCEPTION 2** on page A-57.
- **MAS Alarm - VS EXCEPTION 3** on page A-58.
- **MAS Alarm - VS EXCEPTION 4** on page A-59.
- **MAS Alarm - VS EXCEPTION 5** on page A-60.

VS FEDB

- **MAS Alarm - VS FEDB 1** on page A-61.
- **MAS Alarm - VS FEDB 3** on page A-63.

VS GENERIC

- **MAS Alarm - VS GENERIC 1** on page A-64.
- **MAS Alarm - VS GENERIC 2** on page A-64.

VS MAILBOX

- **MAS Alarm - VS MAILBOX 1** on page A-65.
VS MSS

- MAS Alarm - VS MSS 1 on page A-66.

VS MWI


VS OPHIST

- MAS Alarm - VS OPHIST 1 on page A-68.

VS PERF

- MAS Alarm - VS PERF 1 on page A-69.
- MAS Alarm - VS PERF 2 on page A-70.
- MAS Alarm - VS PERF 20 on page A-75.

VS PORT

- MAS Alarm - VS PORT 0 on page A-76.
- MAS Alarm - VS PORT 1 on page A-77.
- MAS Alarm - VS PORT 2 on page A-78.
- MAS Alarm - VS PORT 3 on page A-79.
- MAS Alarm - VS PORT 4 on page A-80.
- MAS Alarm - VS PORT 5 on page A-81.
- MAS Alarm - VS PORT 6 on page A-82.
- MAS Alarm - VS PORT 7 on page A-83.

VS SERVICE

- MAS Alarm - VS SERVICE 6 on page A-84.
VS SHUTDOWN
- MAS Alarm - VS SHUTDOWN 1 on page A-85.

VS SPOOL
- MAS Alarm - VS SPOOL 1 on page A-86.

VS SWLINK
- MAS Alarm - VS SWLINK 1 on page A-87.

VS VER_CHK

VS VOICE
- MAS Alarm - VS VOICE 1 on page A-89.
- MAS Alarm - VS VOICE 4 on page A-91.
MAS Alarms

MAS Alarm - VS COM 1

Level
Major.

System Descriptor
Voice Server Framework unable to load COM Configuration Manager. See windows event log for details.

Description
This alarm is raised when Voice Server Framework is unable to load the COM Configuration Manager. This problem typically occurs during boot-up. It means that the Messaging Application Server (MAS) software is not running correctly.

Repair Procedure
When this alarm is raised, the MAS automatically reboots, forcibly, not gracefully, to correct the problem. This alarm typically occurs during initial boot-up, and the automatic reboot usually resolves the problem.

If after rebooting the problem still exists, the system raises the alarm again, but the system does not automatically reboot again within 30 minutes. For more details about what is going on, you can check the event log. See Chapter 11, "MAS Event, Error & Alarm Logs".

If this happens, contact your Avaya technical support representative immediately, as this alarm indicates that you have no Messaging Application Server functions.
**MAS Alarm - VS COM 2**

**Level**
Major.

**System Descriptor**
Failed to initialize COM security for voice server. See windows event log for details.

**Description**
This alarm indicates that the system has failed to initialize the COM Security module for the affected Messaging Application Server (MAS). When this alarm is raised, the system runs an application that automatically and immediately busies all ports, thus effectively stopping all communications on the MAS and rendering it non-functional.

**Repair Procedure**
This problem requires a manual fix by qualified technical support personnel. If you see this alarm, contact your Avaya technical support representative *immediately*, as this alarm indicates that your MAS is not allowing any communications at all.

Once the manual fix has been applied, the repair procedure requires a reboot of the system, which should clear and resolve this alarm.
MAS Alarms

MAS Alarm - VS EXCEPTION 1

Level
Major.

System Descriptor
1299/1300 exception - the voice server has terminated the thread that caused the error.

Description
This alarm indicates that the MM Messaging Application Server service has terminated the thread that caused the error.

The system generates this alarm whenever the service generates more than ten exceptions with no specific handling code at an average rate faster than one every five minutes. When this alarm is generated, the system attempts to restart the MM Messaging Application Server service.

Repair Procedure
If you see this alarm, you must stop and restart the MM Messaging Application Server service. See Appendix C, Modular Messaging (MM) Services.

When the service restarts successfully, then the system considers the alarm resolved and generates a resolved-alarm event.

If the system does not resolve the alarm automatically within a period of a few minutes, contact your Avaya technical support representative.
MAS Alarm - VS EXCEPTION 2

Level

Warning.

System Descriptor

An exception was caught and handled. The caller/subscriber was disconnected.

Description

This alarm indicates that the **MM Messaging Application Server** service has caught and handled an exception. The system disconnected the caller or subscriber.

This alarm is generated by a Windows NT warning event 1772 or 1773.

Repair Procedure

There is no repair procedure for this alarm. In most cases, it indicates that the system has handled the problem and recovered without intervention.

In the event that this is caused by a software bug, then this alarm may be generated repeatedly. In this case, the bug must be identified and repaired before the alarm stops being generated.
MAS Alarm - VS EXCEPTION 3

Level

Major.

System Descriptor

An exception was caught and handled. The caller/subscriber was disconnected. An MP was run.

Description

This alarm indicates that the MM Messaging Application Server service has caught and handled an exception. The system disconnected the caller or subscriber. The system also ran a maintenance procedure (MP) to stop and restart the MM Messaging Application Server service.

This alarm is generated by a Windows NT warning event 1772 or 1773. It generally indicates a software bug.

Repair Procedure

If the MM Messaging Application Server service restarts successfully, then the system considers the alarm resolved and generates a resolved-alarm event.

You should contact your Avaya technical support representative and let them know about it, even if the alarm is resolved.
MAS Alarms

MAS Alarm - VS EXCEPTION 4

Level

Major.

System Descriptor

Recursive exception in MM Messaging Application Server process.

Description

This alarm indicates that the MM Messaging Application Server service has caught and handled an exception. The system also ran a maintenance procedure (MP) to stop and restart the MM Messaging Application Server service.

This alarm is generated by 5 occurrences of event 215 within 1 minute. The source is the MM Dump Helper for the MM Messaging Application Server service.

Repair Procedure

When the service restarts successfully, then the system considers the alarm resolved and generates a resolved-alarm event.

If the system does not resolve the alarm automatically within a period of a few minutes, contact your Avaya technical support representative.
MAS Alarm - VS EXCEPTION 5

Level

Major.

System Descriptor

Problem in writing to Dump file.

Description

This alarm indicates that the **MM Messaging Application Server** service took a long time while writing to the dump file. The system also ran a maintenance procedure (MP) to stop and restart the **MM Messaging Application Server** service.

Repair Procedure

When the service restarts successfully, then the system considers the alarm resolved and generates a resolved-alarm event.

If the system does not resolve the alarm automatically within a period of a few minutes, contact your Avaya technical support representative.
MAS Alarm - VS FEDB 1

Level
Minor.

System Descriptor
A registry value in HKEY_LOCAL_MACHINE is incorrect. See windows event log for details.

Description
This alarm indicates that the system had trouble reading a registry key in HKEY_LOCAL_MACHINE, or that the registry key is errant.

Repair Procedure
Although there is no repair procedure for this alarm, you can identify the registry key that caused the problem by checking the Event Viewer Application log:

1. Click the Start > Programs > Administrative Tools > Services menu command to start the Services monitor.
2. In the Tree pane, select Event Viewer (Local), expanding the tree if necessary.
3. Double-click Application.
   The system displays the Application log.
4. Locate the most recent entry for a 1436 event.

If subsequent attempts to read the errant registry key succeed, then the system considers the alarm resolved and generates a resolved-alarm event. If the system does not resolve the alarm automatically within a period of a few minutes, contact your Avaya technical support representative for assistance.
MAS Alarms

MAS Alarm - VS FEDB 2

Level
Minor.

System Descriptor
FEDB resynchronization failed.

Description
This alarm indicates that the system failed to synchronize with the front end database (FEDB).

Repair Procedure
Although there is no repair procedure for this alarm, you can locate and view more detailed information about the failure by checking the Event Viewer Application log:

1. Click the Start > Programs > Administrative Tools > Services menu command to start the Services monitor.

2. In the Tree pane, select Event Viewer (Local), expanding the tree if necessary.

3. Double-click Application.
   The system displays the Application log.

4. Locate the most recent entry for a 1447 event.

If subsequent attempts to synchronize with the FEDB succeed, then the system considers the alarm resolved and generates a resolved-alarm event. If the system does not resolve the alarm automatically within a period of a few minutes, contact your Avaya technical support representative for assistance.
MAS Alarms

MAS Alarm - VS FEDB 3

Level
Minor.

System Descriptor
FEDB resynchronization started. All Ports will be disabled.

Description
This alarm indicates that a full synchronization of the back end LDAP database with the front end database (FEDB) has been started. During a full synchronization, all necessary records from the LDAP store are copied to the FEDB (as opposed to normal operations in which only changed records are copied over).

While a full synchronization is in progress, all ports are disabled. When the synchronization has completed, the system again enables all ports.

Repair Procedure
There is no repair or recovery procedure for this alarm, as it is considered a notification only. When the synchronization is complete, the system automatically re-enables all applicable ports.
MAS Alarm - VS GENERIC 1

Level
NON - Information Only.

System Descriptor
VServer has started.

Description
This alarm indicates that the MM Messaging Application Server service has started.

Repair Procedure
This alarm is for information only. There is no repair procedure.

MAS Alarm - VS GENERIC 2

Level
NON - Information Only.

System Descriptor
VServer has stopped.

Description
This alarm indicates that the MM Messaging Application Server service has stopped.

Repair Procedure
This alarm is for information only. There is no repair procedure.
MAS Alarms

MAS Alarm - VS MAILBOX 1

Level

Major.

System Descriptor

Voice Server failed to create the monitor mailbox. See windows event log for details.

Description

This alarm indicates that the system failed to create the Monitor Mailbox. When this alarm is raised, the system runs an application that automatically and immediately busies all ports, thus effectively stopping all communications on the Messaging Application Server (MAS) and rendering it non-functional.

Repair Procedure

This problem requires a manual fix by qualified technical support personnel. If you see this alarm, contact your Avaya technical support representative immediately, as this alarm indicates that your MAS is not allowing any communications at all.

Once the manual fix has been applied, the repair procedure requires a reboot of the system, which should clear and resolve this alarm.
MAS Alarm - VS MSS 1

Level
Major.

System Descriptor
Inaccessible MSS server(s).

Description
This alarm indicates that the affected Messaging Application Server (MAS) cannot communicate with the Avaya Message Store Server (Avaya MSS). This can be caused, among other things, by taking the MSS offline for scheduled maintenance or updates.

If you have a multiple-MAS system, each MAS that is in communication with the affected Avaya MSS should generate this alarm.

If you have a planned outage on the Avaya MSS (for a software update, for example), Avaya recommends that you manually disable MAS alarming for each MAS until the MSS is back online. For details about manually disabling MAS alarming via the Voice Mail System Configuration window, see Serviceability - General Tab on page 3-191.

Repair Procedure
If you see this alarm, do the following:

1. Verify that the affected Avaya MSS is running properly and is not in offline mode.
   For information on how to check your Avaya MSS for proper operation, see the Avaya Modular Messaging MSS Administration Guide.

2. If the Avaya MSS is running, verify that the connections between the MAS and the Avaya MSS are good by running ping commands for both public and private IP addresses.

3. If the servers are able to communicate, use the Services application to check that the Modular Messaging services are configured and running properly on the MAS.
   For more information see Appendix C, Modular Messaging (MM) Services and your Avaya Modular Messaging Installation and Upgrades Guide.

   If none of these steps identifies and resolves the cause of the problem and the alarm persists, then you should contact your Avaya technical support representative for assistance.
MAS Alarm - VS MWI 1

Level
Minor.

System Descriptor
MWI is having trouble.

Description
This alarm indicates that there is a problem with the MM Message Waiting Indicator service.

The system generates this alarm whenever the MWI Failures KPI (event ID 1434) is incremented more than five times at an average rate faster than once every five minutes.

Repair Procedure
The system is designed to restart the service whenever there is a failure. If it does so, and there is no new alarm generated within a 15-minute period, then the system considers the alarm resolved and generates a resolved-alarm event.

Although there is no repair procedure for this alarm, you can locate and view more detailed information about the failure by checking the Event Viewer Application log:

1. Click the Start > Programs > Administrative Tools > Services menu command to start the Services monitor.
2. In the Tree pane, select Event Viewer (Local), expanding the tree if necessary.
3. Double-click Application.
   The system displays the Application log.
4. Locate the most recent entry for a 1434 event.

If the system does not resolve the alarm automatically within a period of a few hours, contact your Avaya technical support representative for assistance.
MAS Alarm - VS OPHIST 1

Level
Warning
OR
Minor.

System Descriptor
Operation History Buffer is 40 percent full
OR
Operation History Buffer is 80 percent full.

Description
If a warning, it indicates that the Operation History Buffer is more than 40% full.
If a minor alarm, it indicates that the Operation History Buffer is more than 80% full.

Repair Procedure
Clear out space in the Operation History Buffer.
If the indication persists or recurs frequently, then you should contact your Avaya technical support representative for assistance.
MAS Alarm - VS PERF 1

Level
Warning.

System Descriptor
Delayed Interaction Alarm.

Description
This alarm indicates that too many callers are experiencing delays while interacting with the system. An internal monitor checks the system every 15 minutes, and if three of these checks within an hour indicate that more than 1% of calls have experienced delays, the system generates this warning.

Repair Procedure
There is no repair procedure for this warning. This alarm could be generated simply as a result of heavier than normal system traffic. Once the system indicates that fewer than 1% of calls are experiencing delays again, then the problem is considered resolved and the system automatically generates a resolved-alarm event.

If you are seeing an excessive number of these warnings or they are not resolved within a reasonable amount of time, then you should contact your Avaya technical support representative for assistance.
MAS Alarm - VS PERF 2

Level

Warning.

System Descriptor

Logons Aborted After Delay Alarm.

Description

The system generates this alarm when an excessive number of logon attempts are being aborted because of system delays. If more than five logon attempts are aborted at an average rate of more than one every five minutes, then the system generates this warning alarm.

Repair Procedure

There is no repair procedure for this warning. Once this alarm has been raised, if the system then detects no new aborted logon attempts for 15 minutes, then the problem is considered resolved and the system automatically generates a resolved-alarm event.

If you are seeing an excessive number of these warnings or they are not resolved within a reasonable amount of time, then you should contact your Avaya technical support representative for assistance.
MAS Alarms

MAS Alarm - VS PERF 3

Level

Warning.

System Descriptor

Spool queue length >= 200.

Description

This warning alarm indicates that the spool queue length is greater than or equal to 200. This means that the message spooler has 200 or more messages waiting to be delivered.

Repair Procedure

There is no repair procedure for this warning. This condition can be caused simply by an excessive amount of message traffic during heavy traffic periods.

Once this alarm has been raised, if the system then detects that the spool queue length drops below 150, then the problem is considered resolved and the system automatically generates a resolved-alarm event.

If you are seeing an excessive number of these warnings or they are not resolved within a reasonable amount of time, then you should contact your Avaya technical support representative for assistance.
MAS Alarms

MAS Alarm - VS PERF 4

Level

Warning.

System Descriptor

MAS active TUI ports greater than maximum number of ports.

Description

This warning alarm indicates that the demand for active TUI ports exceeds the number of ports for which you are licensed.

This alarm may indicate that one or more ports is stuck. A stuck port is one that:

- Is not available to take or make calls
- Has been in its current Busy state for a period of time longer than the maximum allowable message time.

To view and manage port status for the system, use the Port Monitor application. See Port Monitor Window on page 9-4.

Repair Procedure

When the system detects a stuck port, it automatically attempts to disable and re-enable the port. If it does so successfully, then the problem is considered resolved and the system automatically generates a resolved-alarm event.

If the system is not able to successfully disable and re-enable the stuck port, you can attempt to do so manually. For details on how to do this, see Port Monitor - Disabling/Enabling Ports on page 9-6.

As soon as a port becomes available, then the problem is considered resolved and the system automatically generates a resolved-alarm event.

If you are seeing these warnings on a regular basis, and there appears to be no problem with ports being stuck, it may indicate a need to increase the number of ports in your system.

If you are consistently having problems with stuck ports, or these alarms are not resolved within a reasonable amount of time, then you should contact your Avaya technical support representative for assistance.
MAS Alarms

MAS Alarm - VS PERF 11

Level

Minor.

System Descriptor

Counter (virtual bytes) for vservr process greater than 2.6 GB.

Description

This alarm indicates that the counter (in virtual bytes) for the MM Messaging Application Server service is greater than 2.6 GB. This means that the service has exceeded the recommended virtual memory usage. When this happens, the system can become unstable, and one or more processes or services can begin to fail.

Repair Procedure

To recover from this alarm, you must stop and restart the MM Messaging Application Server service. See Appendix C, Modular Messaging (MM) Services.

Restarting the service resolves the alarm, but the memory leak must also be addressed. You should contact your Avaya technical support representative for advice.
MAS Alarm - VS PERF 12

Level
Major.

System Descriptor
Counter (virtual bytes) for vserver process greater than 2.8 GB

Description
This alarm indicates that the counter (in virtual bytes) for the MM Messaging Application Server service is greater than 2.8 GB. This means that the service has exceeded the recommended virtual memory usage. When this happens, the system can become unstable, and one or more processes or services can begin to fail.

Repair Procedure
To recover from this alarm, you must stop and restart the MM Messaging Application Server service. See Appendix C, Modular Messaging (MM) Services.

Restarting the service resolves the alarm, but the memory leak must also be addressed. You should contact your Avaya technical support representative for advice.
MAS Alarm - VS PERF 20

Level
Major.

System Descriptor
Counter (virtual bytes) for vserver process greater than 2.9 GB

Description
This alarm indicates that the counter (in virtual bytes) for the MM Messaging Application Server service is greater than 2.9 GB. This means that the service has exceeded the recommended virtual memory usage. When this happens, the system can become unstable, and one or more processes or services can begin to fail.

Repair Procedure
The system will automatically run a maintenance procedure to restart the MM Messaging Application Server service.
MAS Alarm - VS PORT 0

Level
Minor.

System Descriptor
Port maintenance is required on channel. See windows event log for details.

Description
This alarm indicates that port maintenance is required on the indicated channel. The system generates this alarm whenever a port has been idle for 16 hours or more.

Repair Procedure
There is no recovery/repair procedure for this alarm. When the system generates this alarm, a maintenance procedure (MP) is run to disable and re-enable the affected port. Therefore, this alarm is considered self-correcting.

To find more detailed information about what caused this alarm to be generated, you can check the Windows event log. See Chapter 11, “MAS Event, Error & Alarm Logs”.
MAS Alarms

MAS Alarm - VS PORT 1

Level
Major.

System Descriptor
An error occurred while restarting telephony board drivers. See the Windows event log for details.

Description
This alarm indicates that the system was not able to start or restart one or more telephony board drivers. When this alarm is raised, the system runs an application that automatically and immediately busies all ports, thus effectively stopping all communications on the Messaging Application Server (MAS) and rendering it non-functional.

Repair Procedure
You should power-cycle your system. If this does not resolve the problem, you should turn the power off and re-seat the Dialogic cards.

If this does not resolve the alarm, you should contact your Avaya technical support representative.
MAS Alarm - VS PORT 2

Level
Minor.

System Descriptor
Port configuration corrupt. Voice server will not start.

Description
This alarm indicates that the Messaging Application Server (MAS) could not read the port configuration for inbound ports successfully. This may mean that the inbound ports are either not configured properly or that the port configuration information for the system has been corrupted.

Repair Procedure
Verify that the inbound ports are properly configured for your system (see Avaya Modular Messaging Installation and Upgrades Guide for your system).

If subsequent attempts to read the configuration for inbound ports succeed, then the system considers the alarm resolved and generates a resolved-alarm event.

If reconfiguring the inbound ports does not correct the problem, or if subsequent attempts by the system to read the inbound port configuration fail, then you should contact your Avaya technical support representative for assistance.
MAS Alarm - VS PORT 3

Level
Major.

System Descriptor
The number of failed ports is above a significant level.

Description
This alarm indicates that more than two thirds of the ports in the system are stuck. A stuck port is one that:

- Is not available to take or make calls.
- Has been in its current Busy state for a period of time longer than the maximum allowable message time.

To view and manage the status of ports on the system, use the Port Monitor application. See Port Monitor Window on page 9-4.

Repair Procedure
When the system detects stuck ports, it automatically attempts to disable and re-enable them.

If it does so successfully with the stuck ports in this situation, and the number of stuck ports falls below one third of the total number, then the problem is considered resolved and the system automatically generates a resolved-alarm event.

If the system is not able to successfully disable and re-enable the stuck ports, you can attempt to do so manually. For details on how to do this, see Port Monitor - Disabling/Enabling Ports on page 9-6.

If the system cannot successfully reset the stuck ports, you have tried manually disabling and re-enabling the stuck ports, and the problem is still not resolved, then contact your Avaya technical support representative for assistance.
MAS Alarm - VS PORT 4

Level
Warning.

System Descriptor
A channel has been disabled. See Windows event log for details.

Description
This alarm indicates that a channel port has been disabled.

Repair Procedure
There is no repair procedure for this alarm.

To find more detailed information about what caused the port to become disabled, you can check the Windows event log. See Chapter 11, “MAS Event, Error & Alarm Logs”.
MAS Alarm - VS PORT 5

Level
Minor.

System Descriptor
A channel has failed. See windows event log for details.

Description
This alarm indicates that a port has failed. This may result from a problem in the system, or it may occur because the system has been manually taken out of service.

Repair Procedure
The system is designed to automatically re-enable ports, if possible, when they fail.

If the system does not enable the port automatically, you can attempt to enable it manually. For the procedure, see Port Monitor - Disabling/Enabling Ports on page 9-6.

To find more detailed information about what caused the port to fail, you can check the Windows event log. See Chapter 11, "MAS Event, Error & Alarm Logs".

If manual attempts to re-enable the port still do not resolve the problem, or you are seeing a great number of these warnings, it may indicate a more serious problem within the system. Contact your Avaya technical support representative for assistance.
MAS Alarm - VS PORT 6

Level
Minor.

System Descriptor
A channel operation has failed. See windows event log for details.

Description
This alarm indicates that a port operation has failed. This usually indicates a problem in the system.

Repair Procedure
The system is designed to automatically re-enable ports, if possible, when they fail. If the system does not enable the port automatically, you can attempt to enable it manually. For the procedure, see Port Monitor - Disabling/Enabling Ports on page 9-6.

To find more detailed information about what caused the port to fail, you can check the Windows event log. See Chapter 11, “MAS Event, Error & Alarm Logs”.

If manual attempts to re-enable the port still do not resolve the problem, or you are seeing a great number of these warnings, it may indicate a more serious problem within the system. Contact your Avaya technical support representative for assistance.
MAS Alarm - VS PORT 7

Level
Minor.

System Descriptor
MaintainAPortMP.exe: Failed to disable/enable the port.

Description
This alarm indicates that a port maintenance process has failed. This means that the port will not be re-enabled automatically.

Repair Procedure
You can attempt to re-enable the port manually. For the procedure, see Port Monitor - Disabling/Enabling Ports on page 9-6.

To find more detailed information about what caused the port maintenance to fail, you can check the Windows event log. Look at the MAINT log, when the MIN alarm was raised. See Chapter 11, “MAS Event, Error & Alarm Logs”.

If the port maintenance process continues to fail, contact your Avaya technical support representative for assistance.
MAS Alarms

MAS Alarm - VS SERVICE 6

Level
Major.

System Descriptor
Service experienced restart problem. See windows event log for details.

Description
This alarm indicates that a Modular Messaging service has stopped repeatedly for some reason, or it has failed to restart. When the service first fails unintentionally, the system attempts to restart it automatically. This alarm is raised only after one such system automatic restart of the indicated service has failed again within a 30 minute period.

Repair Procedure
When this alarm is raised, a maintenance procedure is executed which reboots the Messaging Application Server. This alarm is resolved once the MM Messaging Application Server service restarts.
MAS Alarm - VS SHUTDOWN 1

Level
Minor.

System Descriptor
MM Application server has encountered some problem and will be gracefully shutdown.

Description
This alarm indicates that the Messaging Application Server (MAS) has encountered a serious error and needs to restart.

Repair Procedure
When this alarm is raised, the MAS attempts to reboot gracefully.

If the reboot corrects the problem, the alarm is resolved automatically. If not, contact your Avaya technical support representative.
MAS Alarm - VS SPOOL 1

Level
Minor.

System Descriptor
Message spool directory access failed.

Description
This alarm indicates that the system is unable to access the message spool directory.

Repair Procedure
There is no repair procedure for this alarm. Once the alarm has been raised, if the system is then able to access the message spool directory, then the problem is considered resolved and the system automatically generates a resolved-alarm event.

When this alarm is raised, you can locate and view more detailed information about the failure by checking the Event Viewer Application log:

Although there is no repair procedure for this alarm, you can identify the registry key that caused the problem by checking the Event Viewer Application log:

1. Click the Start > Programs > Administrative Tools > Services menu command to start the Services monitor.
2. In the Tree pane, select Event Viewer (Local), expanding the tree if necessary.
3. Double-click Application.
   The system displays the Application log.
4. Locate the most recent entry for a 1527 or (unintentional) 1014 event.

Note: A manual service shutdown currently results in a 1014 event being generated.

If the system does not resolve the alarm automatically within a period of a few minutes, contact your Avaya technical support representative for assistance.
MAS Alarms

MAS Alarm - VS SWLINK 1

Level
Minor.

System Descriptor
Switch link is down.

Description
This alarm indicates that the system cannot verify that a Private Branch Exchange (PBX) link is operational.

Repair Procedure
Verify that the PBX link is operational. When it is, then the problem is considered resolved and the system automatically generates a resolved-alarm event.

If the system does not resolve the alarm automatically within a period of a few minutes, or you are seeing a great number of these warnings on your system, contact your Avaya technical support representative for assistance.
MAS Alarm - VS VER_CHK

Level
Minor.

System Descriptor
Software versions on the MM system are inconsistent.

Description
This alarm indicates that Messaging Application Server (MAS) has detected that software versions within the voice mail domain are inconsistent.

The Windows Event 1865 triggers this alarm. The event identifies each MAS by its Product ID, and contains information on the version of each MAS, and the Avaya MSS.

Repair Procedure
Verify that all MASs in the voice mail domain have the same version of Avaya Modular Messaging installed.

When the versions are consistent, Windows Event 1864 resolves the alarm.
MAS Alarm - VS VOICE 1

Level
Major.

System Descriptor
An error occurred while restarting telephony board drivers. See windows event log for details.

Description
This alarm indicates that the MM Messaging Application Server service has stopped repeatedly for some reason, or it has failed to restart. When the service first fails unintentionally, the system attempts to restart it automatically. This alarm is raised only after one such system automatic restart of the indicated service has failed within a 30 minute period.

This alarm is related to the MT ABS_PROC 1 alarm. See MAS Alarm - MT ABS_PROC 1 on page A-11.

Repair Procedure
When this alarm is raised, you can locate and view more detailed information about the failure by checking the Event Viewer Application log:

1. Click the Start > Programs > Administrative Tools > Services menu command to start the Services monitor.

2. In the Tree pane, select Event Viewer (Local), expanding the tree if necessary.

3. Double-click Application.

   The system displays the Application log.

4. Locate the most recent entry for a 1242 event.

If the system does not resolve the alarm automatically within a period of a few minutes, contact your Avaya technical support representative for assistance.
MAS Alarm - VS VOICE 2

Level
Minor.

System Descriptor
The primary and secondary server names for remote integration are invalid.

Description
This alarm indicates that the primary and/or secondary server names for remote integration are invalid.

Repair Procedure
Verify that the system has the correct primary and secondary server names configured for remote integration. For detailed information on configuring these using the Voice Mail System Configuration application, see MAS - PBX Integration - Remote Tab on page 4-51.

Once the primary and secondary remote server names are recognized as being valid, then the problem is considered resolved and the system automatically generates a resolved-alarm event.

If the remote server names are configured properly and the alarm persists, contact your Avaya technical support representative for assistance.
MAS Alarm - VS VOICE 3

Level
Major.

System Descriptor
The product license is invalid/expired. Please obtain a new license.

Description
This alarm indicates that the Avaya Modular Messaging product license either is invalid or has expired.

Repair Procedure
Contact your Avaya technical support representative for a new product license. For more information, see Host ID & License Import Wizard on page 3-204.

MAS Alarm - VS VOICE 4

Level
Minor.

System Descriptor
The license does not refer to the existing platform.

Description
This alarm indicates that the Avaya Modular Messaging product license does not refer to the existing platform.

Repair Procedure
Contact your Avaya technical support representative for assistance.
MAS Alarms - Auditing

The following alarms are generated by the MM Auditing Service and indicate a problem with the MM Auditing Service on the affected Messaging Application Server (MAS).

- **MAS Alarm - AS WINEVT 1858** on page A-93.
- **MAS Alarm - AS WINEVT 1860** on page A-94.
- **MAS Alarm - AS WINEVT 1861** on page A-95.
- **MAS Alarm - AS WINEVT 1862** on page A-96.
MAS Alarm - AS WINEVT 1858

Level
Minor

System Descriptor
The MM Audit database could not be contacted, is offline or has a problem.

Description
This alarm indicates that the Auditing system could not contact the Audit database. This may be because the database has yet to be configured or is incorrectly configured. The alarm may also indicate a transient error that the Auditing system will resolve automatically.

Audit events are not lost (unless the retention period has expired), but the administrator can not see all or new events in the Audit Viewer. If the alarm indicates that the database is offline for a number of days, contact your Avaya technical support representative for assistance.

Repair Procedure
Correctly configure the Audit database.
MAS Alarm - AS WINEVT 1860

**Level**

Minor

**System Descriptor**

The MM Audit service could not initialize COM..

**Description**

The Auditing system will fail to function at all because the COM runtime could not be initialized.

Audit events are not lost (unless the retention period has expired), but the administrator can not see all or new events in the Audit Viewer. If restarting the Audit service does not resolve the problem, contact your Avaya technical support representative for assistance.

**Repair Procedure**

Restart the MM Audit Service.
MAS Alarms

MAS Alarm - AS WINEVT 1861

Level
Minor

System Descriptor
The MM Message Queue could not be created or opened.

Description
The Auditing system could not use Microsoft Message Queuing normally because it is not installed. Audit events are not lost (unless the retention period has expired), but the administrator can not see all or new events in the Audit Viewer.

If the alarms indicate that a queue could not be created for a number of days, contact your Avaya technical support representative for assistance.

Repair Procedure
Install MSMQ and restart the MM Audit service.
MAS Alarm - AS WINEVT 1862

Level
Minor

System Descriptor
The MM Message Queue could not be initialized.

Description
The Auditing system could not use Microsoft Message Queuing normally because it was not installed. Audit events are not lost (unless the retention period has expired), but the administrator can not see all or new events in the Audit Viewer.

If the problem persists for a number of days, contact your Avaya technical support representative for assistance.

Repair Procedure
Install MSMQ and restart the MM Audit service.
MAS Alarm - AS WINEVT 1863

Level
Minor

System Descriptor
The MM Audit service could not read its configuration from the voice mail domain.

Description
The Auditing system could not read its voice mail domain settings from an MAS service.

Audit events are not lost (unless the retention period has expired), but the administrator can not see all or new events in the Audit Viewer. This problem may be transient that the Auditing system will resolve automatically. If the problem persists for a number of days, contact your Avaya technical support representative for assistance.

Repair Procedure
Restart the MM Audit service.
Appendix B: Examples of Caller Applications

This appendix provides examples of caller applications, including ideas on how to use them effectively, how to design and create them, and how to deploy them.

Topics included in this Appendix:

- Example 2: Call Transfer Using Dial By Name on page B-10.
- Example 5: Non-Resident Subscribers on page B-20.
- A Word to AUDIX Users on page B-25.

Related Chapters

- Chapter 6, “Caller Applications Editor”
Example 1: Alternative “Auto Attendant” Main Menu

This example has been created to illustrate how you can use a caller application as an alternative to the system Automated Attendant. This caller application is designed to be the caller’s first contact with the system.

The Scenario

XYZ Company has operations throughout North America, including Mexico and French-speaking areas of Canada. For this reason, they want their callers to have the option to continue in either Spanish or French. However, they also want to:

- Allow callers to reach the intended party’s extension at any time by entering the subscriber’s extension.
- Use a custom prompt before the transfer if a caller chooses to transfer to the operator.
- Allow callers to reach the Technical Support department, with the call being automatically directed either to the Help Desk live extension (during business hours) or to the Tech Support voice mailbox (after business hours).
- Give callers the option to hear the menu again, using the 9 key.

Since the system Automated Attendant does not perform any of these options, and since they are not concerned about using the call blocking, call screening, and intercom paging features, XYZ has decided to disable the system Automated Attendant and use a custom one instead, in the form of a caller application.

Planning the Application

After discussing their business needs, XYZ Company devised the following caller application diagram. See Figure B-1 on page B-3.
Figure B-1.

Examples of Caller Applications

[Diagram showing a flowchart of a caller reaching a modular messaging system (MAS) and navigating through various options such as transferring calls, making conditional go to (goto) by time of day (TOD), and selecting options in multiple languages.]
Notes:

- The yellow areas (boldface) indicate what type of action is assigned to the node. The blue areas indicate what the prompt is to say (if anything). The pink areas indicate some action or response taken by either the caller or the MAS.

- The caller application base node is of action type **Menu with extension**. This allows callers to dial a subscriber’s extension number, which on XYZ Company’s system must have 5 as the first digit.

- The **Conditional goto** node routes the caller to the Tech Support Help Desk or voice mailbox, depending on what time the call comes in. To accomplish this, though, you must reserve two other key presses, in this case the 7 and the 8. These keys were chosen so as to minimize the likelihood of a caller pressing the wrong key and getting one of these options by mistake.

- The caller can reach the Technical Support help desk or voice mailbox directly by pressing 7 or 8, respectively, but you do not want to include that as an option in the main menu prompt. This is indicated by the dotted lines.

- The multi-language options (2 and 3) both exit this caller application to access other caller applications. XYZ Company planned these applications during the planning phase, but they are not shown here.

- Key presses of 4, 6, other multi-digit key press combinations that are not valid extensions or mailboxes will result in an “invalid response” prompt from the system.

Setting up the Targets

Before building the application, you must set up the following targets:

- System operator phone number (see **Telephone User Interface - Receptionist Tab** on page 3-43).

- Technical Support Help Desk extension number 50000.

- Technical Support voice mailbox number 50000.

- (Recommended, but not required) The Spanish language caller application.

- (Recommended, but not required) The French language caller application.
Building the Caller Application

The following procedure assumes that you have already started the Caller Applications Editor. It presents a step-by-step method for building the **Example 1** caller application.

1. Create the caller application base node. Name it **Main Menu**. Provide a brief **Description** and select the **Language**. See New Caller Application Dialog Box on page 6-38.

2. Modify the caller application base node properties. See Properties Dialog Box on page 6-43.
   - Select **Menu with extension** as the **Action type**.
   - Select **Play entry prompt** and then select **Application prompt** (Prompt tab).
   - Add a prompt and enter “**Welcome and Main Menu**” under **Comments**.

   **Note:** You will not actually record the prompt at this point, you are merely creating a placeholder for it.

   - Verify that the **Application** tab is set to use the **Default operator**, `<Parent node>` as the **Default cancel** setting, and the * key as the **Default cancel key**.

3. Add an application (action) node to the base node. This node will transfer the caller to the operator. See Add Node Dialog Box on page 6-40.
   - Name it **Transfer to operator**.
   - Select **Transfer** as the **Action type**.
   - Select 0 for the **Key press**.
   - Enter a brief **Description** for it.

4. Modify the application (action) node properties. See Properties Dialog Box on page 6-43.
   - On the **General** tab, verify that **Operator** is selected.
   - Select **Play entry prompt** and then select **Application prompt**.
   - Add a prompt and enter “**Please wait while I transfer you to the operator**” under **Comments**.

   **Note:** You will not actually record the prompt at this point, you are merely creating a placeholder for it.
5. Add another application (action) node to the base node. This node will be used by the **Conditional goto** node to transfer the caller to the Technical Support Help Desk during business hours.

   - Name the node **Transfer to Tech Support desk**.
   - Select **Transfer** as the **Action type**.
   - Select 7 for the **Key press**.
   - Provide a brief **Description**.

6. Modify the application (action) node properties:

   - On the **General** tab, verify that **Extension** is selected and set 50000 as the extension number.
   - You do not need a prompt for this node, so verify that the **Play entry prompt** check box is cleared (**Prompt** tab).

7. Add another application (action) node to the base node. This node will be used by the **Conditional goto** node to transfer the caller to the Technical Support voice mailbox after business hours.

   - Name the node **Transfer to Tech Support MB**.
   - Select **Transfer** as the **Action type**.
   - Select 8 for the **Key press**.
   - Provide a brief **Description**.

8. Modify the application (action) node properties:

   - On the **General** tab, verify that **Mailbox** is selected and set 50000 as the mailbox number.
   - You do not need a prompt for this node, so verify that the **Play entry prompt** check box is cleared (**Prompt** tab).

9. Add another application (action) node to the base node. This is the node that will actually transfer the caller to the appropriate Technical Support extension (during business hours) or voice mailbox (after business hours).

   - Name the node **Contact Technical Support**.
   - Select **Conditional goto** as the **Action type**.
   - Select 1 for the **Key press**.
   - Provide a brief **Description**.
10. Modify the application (action) node properties:
   - On the General tab, select node 7 as the During hours node.
   - Select 8 as the After hours node.
   - Because XYZ Company wants the help desk available only during regular business hours, click Weekly schedule... and set the schedule grid to be active Monday through Friday from 8:00 a.m. to 6:00 p.m.

   You do not need a prompt for this node, so verify that the Play entry prompt check box is cleared (Prompt tab).

11. Add another application (action) node to the base node. This node will exit this caller application and transfer the caller to the Spanish language caller application.
   - Name the node Continue in Spanish.
   - Select Goto as the Action type.
   - Select 2 for the Key press.
   - Provide a brief Description.

12. Modify the application (action) node properties:
   - On the General tab, verify that Caller application is selected.
   - If you have created and deployed the Spanish caller application, you can select that caller application from the drop-down list. Otherwise, you will have to create and deploy the Spanish caller application before you can complete this node.
   - You do not need a prompt for this node, so verify that the Play entry prompt check box is cleared (Prompt tab).

13. Add another application (action) node to the base node. This node will exit this caller application and transfer the caller to the Spanish language caller application.
   - Name the node Continue in French.
   - Select Goto as the Action type.
   - Select 3 for the Key press.
   - Provide a brief Description.

14. Modify the application (action) node properties:
   - On the General tab, verify that Caller application is selected.
If you have created and deployed the French caller application, you can select that caller application from the drop-down list. Otherwise, you will have to create and deploy the French caller application before you can complete this node.

You do not need a prompt for this node, so verify that the Play entry prompt check box is cleared (Prompt tab).

15. Add another application (action) node to the base node. This is the final node in this application, and its job is simply to redirect the caller back through this menu.

- Name the node Repeat this menu.

- Select Goto as the Action type.

- Select 9 for the Key press.

- Provide a brief Description.

16. Modify the application (action) node properties:

- On the General tab, verify that Node is selected.

- From the drop-down box, select the caller application node for this caller application, Main Menu.

- You do not need a prompt for this node, so verify that the Play entry prompt check box is cleared (Prompt tab).

17. Save the application, if you have not already done so.

Recording and Assigning the Prompts

Although XYZ Company has decided to have their prompts recorded professionally, you can record the prompts for test purposes. This caller application requires only two prompts, but the Main Menu prompt, especially, must be carefully scripted, so as to provide the options in the correct order and form. Avaya recommends that you write out all prompts before recording them, as this helps ensure that the prompts say exactly what you want them to say.

XYZ Company created the following script for the Main Menu prompt (numbered 1 in the application):

"Thank you for calling XYZ Company. We value your business, so please listen carefully to the following options.

"If you know the extension number of the party you are trying to reach, please enter it at any time.

"To speak to an operator, you can press 0 at any time.

"To reach Technical Support, please press 1."
Examples of Caller Applications

“Para continuar en español, prensa 2.

“Pour continuer en français, pression 3.

“To hear this menu again, press 9.”

**Note:** It is possible that you might want to present the options in a different order, but that is something you should decide during the planning phase. We recommend that you present the options in numerical order, and that this idea be central in your planning.

For the **Transfer to Operator** prompt, they created the following script:

“Please wait while I transfer you to the operator.”

While waiting for the prompts to be recorded by a professional studio, you can make your own temporary recordings. Once recorded, these prompts become part of the application. After recording the prompts, (prompt 1 and 2, respectively) verify that you have the correct prompt assigned to the appropriate node.

Later on, when the professionally recorded *.WAV files have been received, you can replace the existing prompt recordings with the new ones.

For more information, see [Importing or Recording Application Prompts](#) on page 6-10

**Deploying the Caller Application**

After saving the application again, you are ready to deploy the application.

For the procedure to do this, see [Deploying Caller Applications to a VMD](#) on page 6-13.

**Analyzing the Application**

Immediately after deploying the application across the voice mail domain, Avaya recommends that you analyze the application, which tests it for integrity and flags any errors it finds. This is a valuable tool for debugging your caller applications.

For the procedure to analyze the application, see [Analyzing Deployed Caller Applications](#) on page 6-20.
Example 2: Call Transfer Using Dial By Name

This example has been created to illustrate how you can use a caller application to allow callers to take advantage of the Dial by Name feature. This feature allows callers to "spell" the name of the party they are trying to reach, and the system automatically looks up and tries to match the number entered with a subscriber on the system.

Considerations

Normally, it is not necessary to use a caller application to access the Dial by Name feature. In most cases, the system Automated Attendant can access Dial by Name directly by assigning any numeric key press to Directory.

However, in cases where you do not want to use the system Automated Attendant, you can still access the Dial by Name feature using caller applications.

The key is to use a Menu with extension or Menu with mailbox action type. In both these action types, the # key is reserved for the Dial by Name application.

This means that all you really have to do to make use of the Dial by Name feature with a caller application is create an application node with one of these two action types. You do not need to create a separate caller application to use Dial by Name.

The Caller Application Design

The following is a possible call flow for this caller application. Note that this does not necessarily need to be an entire application by itself. In fact, it will more likely be used to best effect by simply creating an application node within an application (for instance, it could be used as an additional option in Example 1: Alternative “Auto Attendant” Main Menu on page B-2).

This example is intended primarily to illustrate how to set up the node. See Figure B-2 on page B-11.
Building the Application

The following procedure assumes that you have already started the Caller Applications Editor. It presents a step-by-step method for building the Example 2 caller application.

1. Create the caller application base node. Name it Transfer by Name. Provide a brief Description and select the Language. See New Caller Application Dialog Box on page 6-38.

2. Modify the caller application base node properties. See Properties Dialog Box on page 6-43.
   - Select Menu with extension as the Action type.
   - Select Play entry prompt and then select Application prompt (Prompt tab).
Examples of Caller Applications

- Add a prompt and enter “Transfer to Dial by Name” under Comments.

  **Note:** You will not actually record the prompt at this point, you are merely creating a placeholder for it.

- Verify that the Application tab is set to use the Default operator, <Parent node> as the Default cancel setting, and the * key as the Default cancel key.

3. Save the application, if you have not already done so.

  **Note:** Because you are using the Menu with extension action type, the # key is automatically reserved for the Dial by Name feature (as it is with the Menu with mailbox action type). This means that it is not available for other options.
Example 3: Automated Fax Attendant

This example has been created to illustrate how you can use a caller application to act as an auto attendant for relaying faxes to a subscriber’s fax-enabled extension.

Considerations

The advantage of this arrangement is that you can provide fax delivery for your subscribers without paying for additional Direct Inward Dialing (DID) lines or personal trunks for fax extensions. The disadvantage is that incoming calls cannot be automatically dialed, because the caller must enter touch tones to select from the caller application menu and then press the start key on the fax machine to begin transmitting the fax.

Essentially, when you set up an automated fax attendant, you are simply transferring the caller to a fax-enabled mailbox (which is set up using the Subscriber Admin page). To send the fax, the caller needs to know only the pilot number of the Avaya Modular Messaging system and the fax-enabled mailbox number. Upon reaching the caller application (or application node) that will transfer them to the fax-enabled mailbox, callers hear a prompt instructing them to press the extension number and then press the start button on their fax machines after they hear the mailbox greeting to start or the fax tone (if no greeting is being used in the mailbox).

The subscriber must provide fax senders the system number to call (in this case, it might be xx3-7001) and the subscriber’s fax-enabled mailbox number (in this case, 51234).

Important: Setting up fax-enabled mailboxes with numbers that begin with trunk dial access codes could contribute to toll fraud. Always assign extensions that do not allow access to any outside lines.

The Caller Application Design

The following is a possible call flow for this caller application. Note that this need not necessarily be an entire application by itself. In fact, it will more likely be used to best effect by simply creating an application node within an application (for instance, it could be used as an additional option in Example 1: Alternative “Auto Attendant” Main Menu on page B-2).

Also, the prompt does not need to be contained within the caller application; it could just as easily be created within the fax-enabled mailbox, as a greeting. If the target mailbox is dedicated for fax only, then it might be better to place the instruction prompt within the mailbox. However, if the mailbox is also used for voice mail, as it will in most cases, then it might be better to place the instruction prompt within the caller application, as planned here.

See the example call flow in Figure B-3 on page B-14.
Building the Application

The following procedure assumes that you have already started the Caller Applications Editor. It presents a step-by-step method for building the Example 3 caller application.

1. Create the caller application base node. Name it Auto fax attendant. Provide a brief Description and select the Language. See New Caller Application Dialog Box on page 6-38.

2. Modify the caller application base node properties. See Properties Dialog Box on page 6-43.

   - Select Menu with extension as the Action type.
   - Select Play entry prompt and then select Application prompt (Prompt tab).
   - Add a prompt and enter “Enter extension or fax machine number” under Comments. You will not actually record the prompt at this point, you are merely creating a placeholder for it.
   - Verify that the Application tab is set to use the Default operator, <Parent node> as the Default cancel setting, and the * key as the Default cancel key.

3. Save the application, if you have not already done so.
Example 4: Shared Extension

It is possible for several subscribers share a single telephone extension, using a caller application to set it up. An extension set up this way might, for instance, allow a caller to speak with a particular individual subscriber or leave a message that is available to anyone on the shared extension.

The following example has been created to illustrate how to set up a shared extension using a caller application. In this example, four individuals work in the sales department of a company. When the caller reaches the system by dialing the shared extension number, the system offers a menu to speak with any of the individuals or to leave a message in the group voice mailbox.

This sample application also allows the caller to reach a receptionist who works for the entire sales department, and to hear the menu again.

Considerations

In this example, only the caller application ID number (4350) is administered as an extension at the Private Branch Exchange (PBX). Nonresident subscriber extensions, that is, extensions that are not administered at the PBX, are used for each of the sharing subscribers. The caller application can transfer callers directly to these extensions or to the group mailbox, which is accessible to each of the shared extension subscribers.

In this case, if the individual subscriber is not available to answer the call, the system automatically transfers the caller to the individual’s voice mailbox.

After creating and deploying this caller application, you must remember to create an association with an ID number of 4350 for this application. This caller application ID number then overrides the extension 4350 when the caller reaches the system (so that you could still use the extension number of 4350 for the group's receptionist).

The Caller Application Design

The following is a possible call flow for a shared extension. See Figure B-4 on page B-16.
Examples of Caller Applications

Figure B-4.

- Caller transferred to caller application 4350

- Menu only
  - Thank you for calling...
  - To speak with Adam, press 1.
  - To speak with Barbara, press 2.
  - To speak with Charlie, press 3.
  - To speak with Donna, press 4.
  - To leave a message for anyone at this extension, press 9.
  - To speak with a receptionist, press 0.
  - To hear this menu again, press #.

- #
  - Transfer to extension 4351 (no prompt)

- 1
  - Transfer to extension 4352 (no prompt)

- 2
  - Transfer to extension 4353 (no prompt)

- 3
  - Transfer to extension 4354 (no prompt)

- 9
  - Transfer to mailbox 4350 (no prompt)

- 0
  - Transfer to custom operator (no prompt)

Legend
- Node
- Action type
- Prompt
- User or system response
Building the Application

The following procedure assumes that you have already started the Caller Applications Editor. It presents a step-by-step method for building the Example 4 caller application.

1. Create the caller application base node. Name it Shared extension. Provide a brief Description and select the Language. See New Caller Application Dialog Box on page 6-38.

2. Modify the caller application base node properties. See Properties Dialog Box on page 6-43.
   - Select Menu only as the Action type.
   - Select Play entry prompt and then select Application prompt (Prompt tab).
   - Add a prompt and enter “Shared extension menu” under Comments.
   - Verify that the Application tab is set to use the Custom operator, 4350 as the Custom Operator number, and the * key as the Default cancel key.

Note: You will not actually record the prompt at this point, you are merely creating a placeholder for it.

Note: The “Custom Operator” is not the same as the “Personal Operator” feature described in other parts of the Avaya Modular Messaging system documentation. It is a similar concept but works differently. The personal operator can be configured for individual subscribers. It is a designated mailbox or extension where the system can transfer callers for assistance when a subscriber cannot answer their calls and the personal operator’s schedule is active. The custom operator can be configured for caller applications. It is a designated extension where the system can transfer callers when they press the operator key (0) as part of their interaction with a caller application.

3. Add four application (action) nodes to the base node. These nodes will all be Transfer nodes used to transfer the caller to the desired sales person. See Add Node Dialog Box on page 6-40
   - Name the nodes Transfer to Adam, Transfer to Barbara, etc.
   - Select Transfer as the Action type.
   - Select 1, 2, 3, and 4 for the Key presses.
   - Provide brief Descriptions.
4. Modify the application (action) nodes’ properties. See Properties Dialog Box on page 6-43.
   - On the General tab, verify that Extension is selected and set 4351, 4352, 4353, and 4354 as the extension numbers.
   - You do not need a prompts for these nodes, so verify that the Play entry prompt check boxes are cleared (Prompt tab).

5. Add another application (action) node to the base node. This node will allow the caller to leave a message in the common (group) mailbox.
   - Name the node Leave message.
   - Select Transfer as the Action type.
   - On the General tab, verify that Mailbox is selected and set 4350 as the mailbox number.
   - Select 9 for the Key press.
   - Provide a brief Description.

6. Add another application (action) node to the base node. This node will allow the caller to reach the sales department's receptionist.
   - Name the node Transfer to receptionist.
   - Select Transfer as the Action type.
   - Select 0 for the Key press.
   - Provide a brief Description.

7. Modify the application (action) node properties:
   - On the General tab, verify that Operator is selected.
   - You do not need a prompt for this node, so verify that the Play entry prompt check box is cleared (Prompt tab).

8. Add another application (action) node to the base node. This is the final node in this application, and its job is simply to redirect the caller back through this menu.
   - Name the node Repeat this menu.
   - Select Goto as the Action type.
   - Select # for the Key press.
   - Provide a brief Description.

9. Modify the application (action) node properties:
Examples of Caller Applications

- On the **General** tab, verify that **Node** is selected.

- From the drop-down box, select the caller application node for this caller application, **Shared extension**.

- You do not need a prompt for this node, so verify that the **Play entry prompt** check box is cleared (**Prompt** tab).

10. Save the application, if you have not already done so.
Example 5: Non-Resident Subscribers

Non-resident subscribers are Modular Messaging subscribers who do not have an extension administered on a Private Branch Exchange (PBX) that is served by the Modular Messaging system. An example of a non-resident subscriber might be a sales representative who needs to receive messages from clients, but who does not have a “live” extension on the system. To accommodate this type of subscriber, a caller application (or node) can be set up to move callers directly to the non-resident subscriber’s mailbox. In this case, the caller needs to know only the number of the non-resident caller application ID (in this case, 73003) and the non-resident subscriber’s mailbox (in this case, 4222).

Considerations

After creating and deploying this caller application, you must remember to create an association with an ID number of 73003 for this application.

**Note:** Setting up nonresident subscribers with numbers that begin with trunk dial access codes could contribute to toll fraud. Always assign extensions that do not allow access to any outside lines.

The Caller Application Design

The following is a possible call flow for this caller application. Note that this need not necessarily be an entire application by itself; it can be used as a node of a larger application (for instance, it could be used as an additional option in Example 1: Alternative “Auto Attendant” Main Menu on page B-2).

See the call flow in Figure B-5 on page B-21.
Building the Application

The following procedure assumes that you have already started the Caller Applications Editor. It presents a step-by-step method for building the Example 5 caller application.

1. Create the caller application base node. Name it Non-resident subscribers. Provide a brief Description and select the Language. See New Caller Application Dialog Box on page 6-38.

2. Modify the caller application base node properties. See Properties Dialog Box on page 6-43.
   - Select Menu with mailbox as the Action type.
   - Select Play entry prompt and then select Application prompt (Prompt tab).
   - Add a prompt and enter “Enter mailbox number” under Comments.

   **Note:** You will not actually record the prompt at this point, you are merely creating a placeholder for it.

   - Verify that the Application tab is set to use the Default operator, <Parent node> as the Default cancel setting, and the * key as the Default cancel key.

3. Save the application, if you have not already done so.
Example 6: Bulletin Boards & Daily Announcements

For situations in which you need to make daily or frequent announcements to all the callers or subscribers who reach the system, it is more efficient to set it up so that the announcements are created and recorded within a special mailbox, rather than embedding the prompt into the caller application.

For these “bulletin board” or daily announcement types of mailboxes, you can create a special single-node caller application that will play the announcement and then automatically transfer the caller or subscriber to the main menu, for instance.

Considerations

When used in this way, the mailbox that the caller application accesses must be enabled for announcements (see Subscriber Options). You must also remember to create and enable this mailbox before creating the caller application.

Then, instead of using an Application prompt for the caller application prompt, you assign an Announcement prompt to the base caller application node.

You will also need to create and deploy the Main Menu caller application with an association ID of 4000 before building this caller application.

After creating and deploying this caller application, you must remember to create an association with an ID number of 80071 for this application.

The Caller Application Design

The following call flow is an example of how you can set up an announcement-enabled mailbox to be used as a daily announcement or bulletin board mailbox. When callers access this caller application by dialing xx8-0071, they hear the announcement recorded in the announcement-enabled mailbox and then are immediately transferred to the Main Menu caller application, which has an association ID of 4000.

See the call flow in Figure B-6 on page B-23.
Building the Application

The following procedure assumes that you have already started the Caller Applications Editor. It presents a step-by-step method for building the Example 5 caller application.

1. Create the caller application base node. Name it Bulletin board. Provide a brief Description and select the Language. See New Caller Application Dialog Box on page 6-38.

2. Modify the caller application base node properties. See Properties Dialog Box on page 6-43.

   - Select Goto as the Action type.
   - Select Caller application and, from the drop-down menu select the Main Menu caller application, 4000
   - Select Play entry prompt and then select Announcement (Prompt tab).
   - In the drop-down list, select <default>.

   **Note:** You cannot record Announcement prompts. You can only view a list of the available Announcements, if any.
Examples of Caller Applications

- Verify that the Application tab is set to use the Default operator, <Parent node> as the Default cancel setting, and the * key as the Default cancel key.

3. Save the application, if you have not already done so.
A Word to AUDIX Users

Those who are coming from and familiar with an Intuity AUDIX environment should be aware that there are some fundamental differences between the way that AUDIX and the way that Modular Messaging handle call flows.

Automated attendants versus caller applications

In the AUDIX environment, caller interaction is controlled mostly through the use of “automated attendants,” and particularly “nested automated attendants.” Modular Messaging achieves the same kind of functionality with the use of caller applications.

In the Modular Messaging environment, the term “Automated Attendant” is reserved strictly for the system Automated Attendant and has a much narrower use. The Automated Attendant in Modular Messaging is, generally speaking, a top-level menu that acts as a gateway into the system. Though the system Automated Attendant can be used in an even stricter sense to provide only one route into the system, such as a simple call transfer, that is not the way it is designed to be used. In a case like this, a caller application would be much easier and more efficient to use.

Therefore, if you want to use multiple levels of menus and a wider range of caller options in Modular Messaging, you must use caller applications (which, again, are roughly analogous to nested automated attendants).

“Bottom-Up” versus “Top-Down”

System designers in the AUDIX environment are advised to plan their systems carefully, then start at the deepest level of menus (the “bottom”) and work their way up from there.

Modular Messaging makes it much easier and often more practical to design and build from the top levels and work your way down. This aspect of Modular Messaging design also makes it somewhat easier to add on to your caller applications later, should you find the need.

A brief comparison of AUDIX versus Modular Messaging functionality

Although the end result is the same in many cases, AUDIX and Modular Messaging sometimes take different approaches to get there. The following is a brief summary of how AUDIX and Modular Messaging handle various functions or tasks, summarizing both the similarities and the differences:
**Examples of Caller Applications**

**Note:** This is by no means an exhaustive list of the differences and similarities, but merely a representative sampling.

<table>
<thead>
<tr>
<th>Intuity AUDIX</th>
<th>Modular Messaging</th>
</tr>
</thead>
<tbody>
<tr>
<td>Uses “automated attendants” and “nested automated attendants”.</td>
<td>Uses caller applications and application nodes.</td>
</tr>
<tr>
<td>Must create the “main automated attendant” as the starting point.</td>
<td>May use the system (built-in) Automated Attendant or bypass it in favor of a caller application as the starting point.</td>
</tr>
<tr>
<td>Automated attendants are always treated as subscriber mailboxes. Automated attendants require no special treatment after being created, other than a special mailbox property designating them as automated attendants.</td>
<td>Caller applications may use ID numbers similar to subscriber mailbox numbers, but are not required to do so, and they are not necessarily treated as subscriber mailboxes. Also, caller applications must be deployed on the system after being created.</td>
</tr>
<tr>
<td>Automated attendants may have up to 10 options, corresponding with the DTMF keys 0 through 9.</td>
<td>Caller applications may have up to 11 menu options, corresponding with all DTMF keys, including the * and # keys (minus the key assigned for cancellation operations).</td>
</tr>
<tr>
<td>You may administer the automated attendant as an extension on the Private Branch Exchange (PBX) or solely in the AUDIX system (as an internal extension only).</td>
<td>You may administer caller application ID numbers on the PBX or solely in the Modular Messaging system (as an internal extension only).</td>
</tr>
<tr>
<td>Requires * 8 for transfers.</td>
<td>Offers built-in transfer capability.</td>
</tr>
<tr>
<td>Allows up to 4 special (“holiday”) schedules to be defined and in use at one time.</td>
<td>Allows up to 18 special (“holiday”) schedules to be defined and in use at one time.</td>
</tr>
<tr>
<td>Multi-lingual options may be configured using system-wide and subscriber-specific settings or an automated attendant.</td>
<td>Multi-lingual options may be configured using either the system Automated Attendant, subscriber-specific settings, or a caller application.</td>
</tr>
<tr>
<td>Allows call routing based on a time-of-day schedule.</td>
<td>Allows call routing based on a time-of-day schedule.</td>
</tr>
<tr>
<td>Prompts are created as “mailbox greetings” (thus offering little quality control over recordings).</td>
<td>Prompts created either as recorded (*.WAV) files embedded in caller application or as “mailbox greeting” (announcements).</td>
</tr>
</tbody>
</table>
Appendix C: Modular Messaging (MM) Services

There are a number of Avaya Modular Messaging services which can be managed in the standard Windows Services dialog box.

Enable these services on each MAS in the voice mail domain that handles calls:

- MM Messaging Application Server  Provides a Telephone User Interface (TUI) for external callers and Avaya Modular Messaging subscribers.
- MM Service Connector  COM service through which clients can connect to Avaya Modular Messaging services.

Enable these services on each MAS and supplementary server in the voice mail domain:

- MM Alarming Server  Provides alarm generation and notification services for Avaya Modular Messaging.
- MM Event Monitor Server  Monitors application event log entries to raise appropriate alarms.
- MM Fault Monitor  Monitors faults in the Avaya Modular Messaging Application.
- MM Performance Monitor Server  Monitors Avaya Modular Messaging and Windows performance counters to raise appropriate alarms.
- MM Process Monitor Server  Monitors critical Avaya Modular Messaging processes, and raises alarms if they are down.
Modular Messaging (MM) Services

- **MM Audit Service**: Records information about administrative configuration of the Avaya Modular Messaging system.

  **Note**: If auditing is required, the **MM Audit Service** must be running on all MASs in the voice mail domain, including the supplementary server. Only one of these services is then assigned to be the **MM Audit Server**, using **Voice Mail System Configuration (VMSC)**.

- **Avaya SPIRIT**: Relays alarms, Simple Network Management Protocol (SNMP) traps, and software inventory records to Technical Support providers and customer Network Management Stations (NMSs).

Enable these services *only once* in the voice mail domain, either on an MAS or on the supplementary server:

- **MM Call Me Server**: Enables Avaya Modular Messaging subscribers to be alerted when Call Me and Notify Me rules are met.

- **MM Mailbox Monitor**: Monitors Avaya Modular Messaging subscriber mailboxes.

- **MM Message Waiting Indicator Server**: Enables Avaya Modular Messaging subscribers to be notified when MWI rules are met.

  **Note**: **MM Call Me Server**, **MM Mailbox Monitor** and **MM Message Waiting Indicator Server** services must all be enabled on the same server.

- **MM Fax Sender Server**: Provides a fax routing service for Avaya Modular Messaging subscriber mailboxes with Native Fax Support.

  **Note**: Fax is currently unavailable for IP H.323 integrations.

- **MM Tracing Server**: Records information about operational activity within Avaya Modular Messaging components.

**Stopping and Starting Services**

You must stop all Modular Messaging services before installing or re-installing software on the MAS. You can use `stopmmservices.exe` and `serverrecovery.vbs` to stop and start all Modular Messaging services during an installation or upgrade.

When you make configuration changes to applications such as **Voice Mail System Configuration (VMSC)**, you are sometimes required to stop and restart the **MM Messaging Application Server** service, or another service, manually. For this procedure, see **Stopping/Restarting a Modular Messaging Service** on page C-3.
Stopping/Restarting a Modular Messaging Service

When you make configuration changes to applications such as **Voice Mail System Configuration (VMSC)**, you are sometimes required to stop and restart the **MM Messaging Application Server** service, or another service, manually.

**Note:** This topic provides the procedures for stopping and restarting a Avaya Modular Messaging service. Avaya recommends that you perform these operations during a scheduled down time of the system and voice mail domain.

**Procedure 1: Stopping a Modular Messaging Service**

1. Click **Start > Programs > Administrative Tools > Services**.
2. From the list in the **Services** dialog box, right-click the name of the service you want to stop.
3. On the pop-up menu, click **Stop**.

   After a short interval, the Modular Messaging service stops.

**Procedure 2: Restarting a Modular Messaging Service**

1. Click **Start > Programs > Administrative Tools > Services**.
2. From the list in the **Services** dialog box, right-click the name of the service you want to start.
3. On the pop-up menu, click **Start**.

   After a short interval, the MAS service starts. A 1241 event confirms that the service has started.
Appendix D: Glossary

This chapter provides short definitions of the terms and acronyms used to describe features of the Messaging Application Server (MAS).

These glossary definitions refer to many parts of the Avaya Modular Messaging system, but they are focussed on how the system relates to MASs and the voice mail domain. For the full range of glossary terms relating to other parts of the Modular Messaging system, see the appropriate Avaya User Guides.
.UMA file
A file that contains a caller application. By default, the file type in which the Caller Applications Editor will choose to save applications is *.UMA. Although the user can select any legal name type for the application, the internal format will always be the same.

.WAV
A file extension used for Windows multimedia format audio data.

Access Codes
See Canonical Addressing.

Access Number
The number the subscriber dials to get into the Modular Messaging software system.

Adaptive Differential Pulse Code Modulation (ADPCM)
A speech encoding method that produces a digital signal with a lower bit rate than standard pulse code modulation (PCM). ADPCM calculates the difference between two consecutive speech samples in standard PCM-coded telecom voice signals. The ADPCM encoding rate is 32 kilobit per second.

Alarm
An alert raised by an MAS, or supplementary server, or the Avaya MSS, to indicate to another system that a problem exists.

The alarm can be manifested as an SNMP trap or, if the system is configured for modem-based servicing, as an outbound data call over a modem to Avaya.

See also: Trap.

Aria
Type of telephone user interface.

Audio Encoding Formats
These formats determine the way in which audio is recorded on every MAS in the voice mail domain. This, in turn, determines the format of voice messages sent using the TUI and desktop clients. Avaya Modular Messaging supports these formats: GSM 6.10, G.711 µ-law (mu-law) and G.711 A-law.

The system administrator should ensure that the form of G.711 encoding matches that of the PBX. If the encoding scheme does not match the PBX, then audio will sound garbled.

AUDIX
Type of telephone user interface.

Automated Attendant
Modular Messaging's Automated Attendant is used to prompt callers with the system greeting and collect their input (in the form of DTMF key presses). It can be configured to offer single-digit menu choices, for transfers or quick messages, and use the Dial By Name feature to reach subscribers.
Glossary

System Administrators can configure this feature in VMSC.

AVP

See Voice Player (AVP).

Back End

In older documentation, this term was used to refer to the Message Store Server.

Call-Answered Messages

Received Modular Messaging voice messages can originate from two different sources:

- Subscriber-to-subscriber messages are sent by a Modular Messaging subscriber using either a TUI or a client.
- Call-answered messages result when somebody calls a subscriber who does not answer the phone. The Modular Messaging system answers, the caller leaves a message in the TUI, and the message arrives in the subscriber's inbox. Call-answered messages may or may not come from another Modular Messaging subscriber.

Called Number

The direct dial number or extension number that callers must enter to launch a caller application.

Caller Applications

These are used to extend or even replace the Automated Attendant by automating call handling and routing incoming calls directly to departments within an organization. They can be configured with daily "bulletin board" announcements, and have more options with respect to system and personal greetings.

Caller Applications Editor

A Modular Messaging administration tool that can be installed on the MAS or a standalone PC. It is used to create caller applications. A system administrator can then deploy caller applications to the voice mail domain.

Call Handling

A feature that allows Modular Messaging software to screen or block calls and to specify what greetings are played when an extension is busy or not answered.

Call Information Packet

A string of DTMF digits sent by the PBX to the MAS in inband integration. The call information packet contains information on the call packet type, the called party ID, the calling party ID, and the trunk ID.

Call Management

A component of the MAS that provides an interface between the voice cards and Modular Messaging software telephony applications.
**Call Me**
With this feature, subscribers can configure the system to call them, at one or more designated numbers, each time they receive a message that meets certain criteria. The subscriber can then log on to the TUI in order to review the message.

System Administrators can configure this feature in **VMSC**. See also MM **Call Me Server**.

**Call Packet Type**
A string of DTMF digits that form a code for the type of call received during inband integration, such as a direct call, a forwarded call, or a diverted call. Also known as the “reason code”.

**Call Screening**
A call answering option that requires callers to announce themselves before a subscriber answers the call. If a call is screened and the subscriber is not available to answer it, the caller has the choice of leaving a message, or being forwarded to a different extension or to the operator.

**Call Transfer**
PBX call transfer properties and release codes for a voice mail domain.
System Administrators can configure this feature in **VMSC**.

**Canonical Addressing**
A method of addressing that specifies the full location, including country code and area code, in the following order:

+CountryCode[(AreaCode)] SubscriberNumber.

For example, +1 (408) 345 800.

**Concurrent Calls**
The number of concurrent **Call Me** processes supported by the voice mail system. This number should not exceed the number of ports configured for Call Me in the voice mail domain.

**Custom Operator**
There is a system-wide **Operator**, but custom operators can be configured for caller applications.

The custom operator is a designated extension where the system can transfer callers when they press the operator key (0) as part of their interaction with a caller application.

System administrators can configure this feature using the **Caller Applications Editor** tool.

**Note:** Custom operator is *not* the same as a “Personal Operator”.

**Custom Prompts**
Recordings which are made in or imported into the **Visual Voice Editor** application. These recordings are saved as custom prompts to be used by the Automated Attendant or Caller Applications.
Deployed Caller Application
A “live” caller application that has been installed in the Modular Messaging voice mail domain, and is currently available to callers.

Dial By Name
A method of addressing by which a caller spells the recipient's name on the telephone keypad when using the telephone user interface.

Dialing Rules
With Dialing Rules, local subscribers are given the option to either reply to call-answered messages from remote subscribers, or to return the call.

System administrators can configure this feature using the VMSC. They can configure rules for recognizing the remote subscriber's calling party number so that the option to return the call is given. They can also configure the rules for returning that call.

Dialogic Line Test Application
A Modular Messaging diagnostic tool that is installed on the MAS. It is used by Avaya service technicians as part of the testing the installation of a Modular Messaging system.

System administrators can also use it as a troubleshooting tool to verify that Dialogic voice ports are correctly configured and connected to the PBX.

DID
See Direct Inward Dialing (DID).

Digital Meridian Integration Device (DMID)
A device that provides integration with Nortel switches, such as the Meridian M-1. The DMID physically sits between the PBX and the MAS. It appears as one or two digital telephones to the PBX, depending on the number of analog ports required. Analog line circuits for the voice path appear on the digital set of the DMID. When a call is received on the DMID, it simultaneously rings at the analog port. The DMID interprets the call display information and transmits it to the messaging application server, which answers the caller with the appropriate personal greeting.

Digital Set Emulation (DSE)
A digital protocol used to connect digital telephones to PBXs in order to emulate digital telephone sets.

Direct Inward Dialing (DID)
A feature that allows callers to dial inside an organization to reach a telephone extension directly without going through a receptionist.

Distribution List
A name assigned to a group of recipients. When the subscriber addresses a message to a distribution list, each recipient in the list receives the message.

DMID
See Digital Meridian Integration Device (DMID).
DSE
See Digital Set Emulation (DSE).

DTMF
See Dual Tone Multi-Frequency (DTMF).

Dual Tone Multi-Frequency (DTMF)
A combination of two tones that uniquely identify each button on a telephone keypad.

Event
A significant occurrence in a voice mail system, which may be of interest to an administrator for diagnostic or reporting purposes.

Extended Absence Greeting (EAG)
Subscribers can set up a greeting for specific situations. For example, the greeting could advise callers that the subscriber is away from the office for a vacation and will be checking messages infrequently.

Fax
With Fax, subscribers can send and receive faxes using their mailboxes. System Administrators can configure this feature in VMSC. See also MM Fax Sender Server.

Fax Routing Address
An e-mail address consisting of a string of digits that uniquely identify the subscriber to the MM Fax Sender Server.

FEDB
See Front End Database (FEDB).

Find Me
A feature that enables a subscriber’s mailbox to re-direct unanswered calls to a list of telephone numbers. Calls are directed to each telephone number in the list, unless the subscriber answers. If the subscriber does not answer at any telephone number in the list, callers are asked if they would like to leave a message.

System Administrators can configure this feature in VMSC.

Forward
A command that is used to forward a copy of a message. Subscribers can include their comments in the message by attaching a voice message.

Front End Database (FEDB)
Each MAS maintains an FEDB. It is used to cache subscriber data from the directory and message store. This is an SQL 2005 Express database.

Full Mailbox Number
A mailbox number of the subscriber in a MultiSite-enabled voice mail domain that includes the site group and site identifiers and the short mailbox number.

See also Short Mailbox Number.

G.711 A-law.
See Audio Encoding Formats. In general, A-law is used in Europe.
G.711 µ-law (mu-law)
See Audio Encoding Formats. In general, µ-law (mu-law) is used in North America and Japan.

Global System for Mobile Communications (GSM)
An audio encoding format with an encoding rate of approximately 13 kilobits per second. This is a format for storing sound files. Files encoded in this format can be opened using Microsoft Sound Recorder.

Globally Unique Identifier (GUID)
This identifier is unique from any other identifier in the Modular Messaging system.

Greetings
A pre-recorded message that callers hear when the subscriber's extension is busy or not answered.

GSM 6.10
See Audio Encoding Formats.

GUI
Graphical User Interface.

Hangup Detection
The method by which the PBX determines that a caller has hung up the phone.
System Administrators can configure this feature in VMSC.

HRESULT
The data type used to indicate the status of operations in Microsoft's Component Object Model (COM). The value has 32 bits divided into three fields: a severity code, a facility code, and an error code.

Hunt Group
A group of telephone lines where the incoming calls are distributed according to a priority scheme.

IMAP4

In-band Signaling
A method of connecting the MAS to the PBX as if it were a series of single-line telephones or a series of trunks in a hunt group. The term “in-band” is used because all of the call identification information is passed from the PBX to the messaging application server using DTMF signals on the same line as the voice connection.

INADS
See Initialization and Administration System (INADS).

Inbox
The folder in which a subscriber normally receives new mail.

Individual MAS Alarming
This can be configured in VMSC by system administrator, to identify which MAS generated an alarm.
Initialization and Administration System (INADS)
A method for sending alarms for the Modular Messaging system back to Avaya, so that the MM Alarming Server can be appropriately serviced.

Intercom Paging
A method of automatically paging subscribers if they do not answer their telephones. If a subscriber does not respond to the page, the PBX transfers the caller to the subscriber’s mailbox.

System Administrators can configure this feature in VMSC.

Integrated Services Digital Network (ISDN)
A set of standards for transmission of simultaneous voice, data and video information over fewer channels than would otherwise be needed, through the use of out-of-band signaling.

International Code
The code used to dial an international number. For example 011, if the user is dialing from the United States.

Invalid Mailbox
A mailbox number not recognized by the Modular Messaging system.

IP
Internet Protocol.

IP Codec
This is the voice line coding algorithm that is used for communication between the MAS and the PBX.

IP Telephony
The use of networks running IP to send and receive messages, such as voice data.

ISDN
See Integrated Services Digital Network (ISDN).

Lamp State
An indicator as to whether the subscriber has messages waiting for them on the Modular Messaging system.

See also: Message Waiting Indicator (MWI).

Languages
System administrators can use the VMSC to configure multiple languages for use by the TUI and enable multilingual text-to-speech, if necessary.

LDAP

Licensing
The Modular Messaging system has licensing information for the platform, the number of seats (voice mail-enabled mailboxes), and the number of Text-To-Speech (TTS) sessions per TTS engine.

System administrators can configure this feature using VMSC.
Local Mailbox Number
A method of addressing voice messages through the telephone user interface to recipients in a voice mail domain.

Locale ID
The unique identifier for the language used in the subscriber’s TUI.

LOS
Local Offline Message Store.

Long Distance Code
The code used to dial a telephone number outside the local area codes. For example, 1, if the user is in the United States.

Mail Server
In older documentation, this term was used to refer to the Message Store Server.

Mailbox
A Modular Messaging subscriber mailbox where all voice, fax, telephone answering messages, e-mail, and data messages (including documents and forms) are stored. Messages can be viewed, listened to, or retrieved using the telephone or PC.
See also Full Mailbox Number and Short Mailbox Number.

Management Information Base (MIB)
A formal description or schema describing the information about a server available through various SNMP mechanisms.
For more information, see Simple Network Management Protocol (SNMP).

MAS
See Messaging Application Server (MAS).

MAS Auditing
With MAS Auditing, an audit event is logged whenever a role-controlled administrative operation is attempted by an MAS or supplementary server. User-friendly information is logged as well as the typical system data.
System administrators can configure this feature using VMSC, and view audit information using the MM Audit Log Viewer.

Message Confirmation
A notice confirming that a message was delivered to a recipient.

Message Store Server
The server where the messages are stored in the Modular Messaging system. This is an Avaya-produced MSS.
In older documentation, this server is sometimes referred to as the “mail server”, “messaging server”, or “back end”. 
Message Waiting Indicator (MWI)
A method of alerting subscribers when messages meeting specified criteria arrive in their mailbox. Subscribers are alerted either by a lamp indicator on their telephone, or an audible tone (stutter dial-tone) when they pick up the receiver. The indicator is cleared using the Telephone User Interface (TUI) or a client.

System administrators can configure this feature using VMSC. They can set the system to perform scheduled MWI updates or on-demand updates. See also MM Message Waiting Indicator Server.

Messaging
In the VMSC, “Messaging” configuration covers Privacy Enforcement Level, Peer Server, and Offline Access.

Messaging Server
See Message Store Server.

Messaging Application Server (MAS)
Part of the Avaya Modular Messaging system.

A Windows server which performs PBX integration. It provides an interface between the message store and directory, and the telephone system.

System administrators can use the administration software on the MAS to configure the whole voice mail domain as well as individual MASs, and run diagnostic tools.

In older documentation, the MAS is sometimes referred to as the “voice server”.

Maximum Errors
The maximum number of errors a caller is permitted to make, when attempting to use the TUI, before the Modular Messaging system disconnects or transfers the call.

Microsoft Management Console (MMC)
A common console framework for Microsoft management applications. MMC does not provide any management functionality, but forms a common environment for modular management components called snap-ins.

The Caller Applications Editor and the MM Audit Log Viewer both run as a snap-ins to the MMC.

MM
Modular Messaging.

MMSnap
See Modular Messaging Snapshot Utility (MMSnap).

MM Alarming Server
Modular Messaging service that runs on all MASs. It provides alarm generation and notification services for Avaya Modular Messaging.

MM Audit Service
Modular Messaging service that runs on all MASs. It records information about the administrative configuration of the Avaya Modular Messaging system.
To activate **MAS Auditing**, the service on one MAS in the voice mail domain must be assigned to be the **MM Audit Server**.

**MM Audit Server**
See **MM Audit Service**.

**MM Audit Log Viewer**
A Modular Messaging auditing tool that is installed on the MAS. It is used by system auditors to audit the administrative configuration of the MASs, and any supplementary servers, in the voice mail domain.

**MM Call Me Server**
Modular Messaging service that runs on one MAS, or supplementary server, in the voice mail domain. It enables Avaya Modular Messaging subscribers to be alerted when **Call Me** and **Notify Me** rules are met.

**MM Event Monitor Server**
Modular Messaging service that runs on all MASs. It monitors application event log entries to raise appropriate alarms.

**MM Fault Monitor**
Modular Messaging service that runs on all MASs. It monitors faults in the Avaya Modular Messaging Application.

**MM Fax Sender Server**
Modular Messaging service that runs on one MAS, or supplementary server, in the voice mail domain. It provides a **Fax** routing service for Avaya Modular Messaging subscriber mailboxes.

**MM Mailbox Monitor**
Modular Messaging service that runs on one MAS, or supplementary server, in the voice mail domain. It monitors Avaya Modular Messaging subscriber mailboxes.

**MM Message Waiting Indicator Server**
Modular Messaging service that runs on one MAS, or supplementary server, in the voice mail domain. It enables Avaya Modular Messaging subscribers to be notified when **Message Waiting Indicator (MWI)** rules are met.

**MM Messaging Application Server**
Modular Messaging service that runs on all MASs that handle calls. It provides a telephone user interface for external callers and Avaya Modular Messaging subscribers.

**MM Performance Monitor Server**
Modular Messaging service that runs on all MASs. It monitors **Modular Messaging Performance Counters** to raise appropriate alarms.

**MM Process Monitor Server**
Modular Messaging service that runs on all MASs. It monitors critical Avaya Modular Messaging processes, and raises alarms if they are down.

**MM Service Connector**
Modular Messaging service that runs on all MASs. This is a COM service through which clients can connect to Avaya Modular Messaging services.
**Glossary**

**MM Tracing Server**
Modular Messaging service that runs on one MAS, or supplementary server, in the voice mail domain. It records information about operational activity within Avaya Modular Messaging components.

**MN**
Message Networking.

**Modular Messaging Performance Counters**
Modular Messaging exports a variety of Performance Counters through the Windows Performance Monitoring API. They can be used to gauge the overall status of an MAS at any given time.

**Modular Messaging Snapshot Utility (MMSnap)**
A Modular Messaging diagnostic tool that is installed on the MAS. It is used by system administrators to collect information about the system on which it is run, create a compressed archive, and (optionally) transmit that archive to another system.

**Modular Messaging Subscriber Administration**
A Modular Messaging administration tool that is used by subscriber administrators to enable subscribers, groups, or contacts to use Modular Messaging software. This tool runs on the Avaya MSS.

**Modular Messaging System**
This consists of at least one MAS and an Avaya-produced Message Store Server (Avaya MSS). Modular Messaging supports a maximum of five MAS units in a voice mail domain; plus a standalone supplementary server.

**Multimedia**
A PC has multimedia capabilities if it has a sound card, microphone, and speakers or headphones.

**MultiSite**
MultiSite is a new feature introduced in Modular Messaging in Release 5.05.1 through which you can use a single Modular Messaging system to serve subscribers at multiple locations. With MultiSite, MASs in a single Voice Mail Domain (VMD) communicate with multiple PBXs possibly with different dial plans, in different locations.

**MSS**
See Message Store Server.

**MWI**
See Message Waiting Indicator (MWI).

**Network Management Server (NMS)**
A server that intends to oversee or manage other servers; it collects SNMP traps and uses other SNMP methods functionality to monitor a collection of servers.

**Notify Me**
With this feature, subscribers can configure the system to send an e-mail or e-mail client to their pager, each time they receive a message that meets certain criteria. The subscriber can then call the Modular Messaging system in order to review the message.
System administrators can configure this feature using VMSC. See also MM Call Me Server.

**Numeric Address**
A string of digits that uniquely identifies a recipient or a distribution list across the organization. A numeric address is used by the TUI as a means of addressing a message.

**OAM**
See Operations, Administration, and Maintenance (OAM).

**OAM MIB**
The Avaya OAM MIB is used by customers that have no alarm code database and therefore need the alarm description in ASCII text. The Avaya OAM MIB does not support informs or return traps from the customer NMS.

For more information, see Management Information Base (MIB).

**Offline Access**
With Offline Access, subscribers can use the TUI to access recently recorded call-answered messages, even when the message store server is not accessible.

System administrators can configure this feature using VMSC.

**Offline Message Store**
If Offline Access is enabled, call-answered messages are delivered to the Local Offline Message Store folder on the MAS and the Remote Offline Message Store on the file server. The remote store holds all recently recorded call-answered messages for the voice mail domain; the local store only holds those messages received on a particular MAS.

**Operation History Database**
A temporary storage area for events generated by Modular Messaging software.

System administrators can access this information through the Operation History Viewer.

**Operation History Viewer**
A Modular Messaging diagnostic tool that is installed on the MAS. It is used by system administrators to view events generated by Modular Messaging software activity and logged in the operation history database.

By creating a “session,” administrators can restrict the number of events to only those that meet their criteria. They can view live events “live” as they are added to the operation history database, or view historical events.

**Operations, Administration, and Maintenance (OAM)**
An Avaya division.

**Operator**
The person to whom callers are transferred when they request to speak with an operator, exceed the maximum number of errors permitted on the system, or call from a rotary telephone.
This is a system-wide operator. The operator is sometimes referred to as the "Receptionist".

System administrators can configure this feature using VMSC.
See also: Personal Operator and Custom Operator.

**Password**
Subscribers must enter their passwords to gain access to Modular Messaging software through the telephone user interface. Subscribers can change their passwords using the TUI or Modular Messaging software.

**PBX**
See Private Branch Exchange (PBX).

**PBX Integration**
A method that establishes communication between the PBX and the voice mail system. The PBX supplies information such as who is calling on internal calls and the extension that the caller is trying to reach.
System administrators can configure PBX Integration using VMSC.

**PDL**
Personal Distribution List. See also: Distribution List.

**Peer Electronic Mail (E-Mail) Server**
See Peer Server.

**Peer Server**
The particular Message Store Server that MASs communicate with when sending and receiving voice messages. This is an Avaya-produced MSS.

**Performance Monitoring**
See Modular Messaging Performance Counters.

**Personal Greeting**
A personalized prompt that greets callers when they are transferred to a subscriber’s mailbox, if the extension is busy or not answered.

**Personal Operator**
There is a system-wide Operator but personal operators can be configured for individual subscribers.

The personal operator is a designated mailbox or extension where the system can transfer callers for assistance, when a subscriber cannot answer their calls and the personal operator’s schedule is active.

---

**Note:** Personal operator is *not* the same as a “Custom Operator”.

---

**Pilot Number**
A dummy extension number assigned to a group of phone extensions on a PBX, arranged to share the load.

**Playback Controls**
CD-type controls with which the user can play, pause, forward, and rewind messages.
**Port Group**
A group of ports allocated to a specific application, such as the PC client, or the TUI.

System administrators can configure ports using **VMSC**.

**Port Monitor**
A Modular Messaging diagnostic tool that is installed on the MAS. It is used by system administrators to check and change the status of ports on a particular MAS.

**Privacy Enforcement Level**
A setting that determines how the Modular Messaging system behaves with respect to subscriber attempts to forward messages marked as private, or attempts to reply to messages with the original private messages attached.

System administrators can configure this feature using **VMSC**.

**Private Branch Exchange (PBX)**
A telephone exchange local to a particular organization that uses, rather than provides, telephone services. In older documentation, this is sometime referred to as the “Switch”.

**Private Messages**
Messages marked as private by the caller.

System administrators can configure this feature using **VMSC**.

Subscribers cannot send private messages through the TUI. However, they can reply to and forward private messages, depending on the **Privacy Enforcement Level** setting.

**Prompt**
A spoken greeting or instruction that directs callers whose calls have come through the Automated Attendant or Caller Applications. See also **Custom Prompts**.

**Q Signaling (QSIG)**
A protocol for ISDN-based inter-PBX signaling based on the European Q.931, Q.9212, and DPNSS protocols.

**Quick Message**
This Automated Attendant feature allows a caller to leave a voice message, when a particular key is pressed and followed by the extension number.

**RBAC**
Role-Based Access Control. See **Security Roles**.

**Real Time Protocol (RTP)**
Internet-standard protocol for the transport of real-time data, including audio and video.

**Reason Code**
See **Call Packet Type**.
Glossary

Receptionist
See Operator.

Record Cue
The Modular Messaging system will prompt users with beeps, when they are silent while recording.

Remote Access Service (RAS)
A Microsoft Windows service which allows users to remotely log into a LAN or WAN network using a modem.

ROS
Remote Offline Message Store.

Reporting Tool
A Modular Messaging reporting tool that is installed on the MAS. It is used by system administrators to generate reports for monitoring voice mail system usage, planning capacity, and tracking security.

Once a report is generated, it can be viewed on screen or printed for easy reference. It can also be exported to many popular file formats or attached to a message sent using a MAPI-enabled e-mail system.

RNA
Ring No Answer.

Rotary Telephone
A non-DTMF telephone.

S3500
The Avaya-provided server platform used for all new installations of the MAS software.

Schedule Grid
A tool for setting a weekly schedule. These can be applied to several parts of the Modular Messaging system. It can be used to schedule:

- The route that a caller follows through a Caller Application.
- When a caller is routed to a Personal Operator, rather than the system Operator.
- The performance of Message Waiting Indicator Updates.

System administrators can use the Schedule Grid in the Caller Applications Editor, and VMSC.

SID
Security Identifier.

SEAR
See Secure Enhanced Alarming Receiver (SEAR).

Secure Enhanced Alarming Receiver (SEAR)
An alarming module.

Security Roles
System administrators can set up the permissions constituting a Modular Messaging Security Role. They can assign users, groups, or computers to perform that role.
There are preset roles for **Servers, System Administrator, System Auditor, Subscriber Administrator, Subscriber Auditor** and **Subscriber Helpdesk**, as well as customer-created roles.

System administrators can configure this feature using **VMSC**.

**Serenade**

Type of telephone user interface.

**Serviceability**

The generation of logs and notifications related to Modular Messaging system errors and alarms.

System administrators can configure this feature using **VMSC**.

**Serviceability through Product Integrated Remote Intelligent agents and Transport (SPIRIT)**

A serviceability agent to the MAS and Avaya MSS. This agent contains two modules, the **Secure Enhanced Alarming Receiver (SEAR)** and an inventory module.

**Session Initiation Protocol (SIP)**

Used to establish real-time audio and multimedia calls in a converged IP network environment.

**Set Emulation**

See **Digital Set Emulation (DSE)**.

**Short Mailbox Number**

A mailbox number of the subscriber in a MultiSite-enabled voice mail domain from which the site identifier is stripped. Subscribers can use the short mailbox number to send voice messages to other subscribers in the same site.

See also **Full Mailbox Number**.

**Simple Network Management Protocol (SNMP)**

SNMP provides a means to monitor and control network devices, and to manage configurations, statistics collection, performance, and security.

The Avaya SNMP MIB is used to send traps to the Avaya Technical Service Center, or to products that act like the Avaya Technical Service Center. That is, the recipient is expected to take a numeric alarm code and other data and match them against a database that maps the full meanings and maintenance procedures.

For more information, see **Management Information Base (MIB)**.

**Simplified Message Desk Interface (SMDI)**

A protocol for sending PBX integration data, that does not require a caller to re-enter the telephone number if the extension is busy or not answered.

**Site**

A Modular Messaging site represents a location, or a community of subscribers. A site is identified by a number that is also used at the start of all mailbox numbers of subscribers associated with that site.
Site Group
A site group is a collection of sites, typically based upon their location. For example, Boston, Denver, and San Francisco can be members of the United States site group. A site group can also contain other site groups. A site group may or may not have an identifier.

SMDI
See Simplified Message Desk Interface (SMDI).

SMTP
Simple Mail Transport Protocol.

Snapshot Utility
See Modular Messaging Snapshot Utility (MMSnap).

SNMP

SO
See Subscriber Options (SO).

SPIRIT

Spoken Name
A personalized prompt that states the subscriber’s name when, for example, their extension is busy or unanswered and they have not recorded a personal greeting.

SSG
Service Selection Gateway.

Subscriber
A user whose profile is enabled for voice messaging. A subscriber can use both the TUI and the GUI of Subscriber Options.

Subscriber Administration
See Modular Messaging Subscriber Administration.

Subscriber Options (SO)
An application that allows subscribers to configure their mailboxes using their PCs. Subscribers can record all personal greetings and prompts, personalize their call handling options, and select whether to use multimedia or the telephone for recording and playing back voice messages.

Supplementary Server
In older versions of Modular Messaging, prior to 3.0, this server was referred to as the “tracing server”. It was renamed because it now has other functions in addition to tracing.

This server is supplementary to the MASs in the voice mail domain. This server is not connected to the PBX and does not run the MM Messaging Application Server service. The server is still part of the voice mail domain, however, and it does generate alarms.
In case of a new installation of Avaya Modular Messaging Release 5.1 system, the MM Messaging Application Server service must be running on the supplementary server.

For load balancing purposes, the system administrator can enable certain Modular Messaging services on this server: MM Tracing Server, MM Event Monitor Server, MM Alarming Server, MM Call Me Server, MM Mailbox Monitor, and MM Message Waiting Indicator Server.

Switch
See Private Branch Exchange (PBX).

Syslog
A protocol which allows devices to send logs across networks. Third-party system administration tools can then be used on the Modular Messaging system.

System administrators can use VMSC to configure a receiver for syslog messages, and the types of events that are sent.

TCP
See Transaction Control Protocol (TCP).

Telephone User Interface (TUI)
An interface through which callers and subscribers can access the Modular Messaging software system using the telephone. The TUI is also an automated attendant and voice messaging system that controls call handling. It greets incoming callers and instructs them on how to proceed.

System administrators can configure the TUI using VMSC.

Telephony Interface
An interface that enables communication between the voice boards and Modular Messaging software. The types of interface are Analog, QSIG, Set Emulation, IP H.323 or IP SIP.

Teletypewriter (TTY)
Device used by people who are deaf or hard of hearing.

Text-to-Speech (TTS)
The conversion of text into speech (speech synthesis). Using TTS, Modular Messaging software subscribers can listen to their e-mail messages over the telephone.

TLS
Transport Layer Security.

Tone File
A file that enables the application to recognize the tones generated by a PBX.

Tracing Server
This has two meanings:

1) In older versions of Modular Messaging, prior to 3.0, this term was used to describe the machine now referred to as the Supplementary Server.
2) The Modular Messaging service, MM Tracing Server. This is typically installed on the supplementary server, but can be installed on an MAS instead.

**Tracing System**
A system that captures information related to the operation of the MAS, for both diagnostic and reporting purposes. The tracing system maintains connections with all MASs in the voice mail domain and receives notification of events from each of them. These events are written to two storage areas: the **Operation History Database** and the **Transaction Database**.

**Transaction Control Protocol (TCP)**
A connection oriented protocol over IP.

**Transaction Database**
A storage area where information about voice messaging events in the voice mail domain is written. It is a permanent database containing summary information.

System administrators can access this information through the **Reporting Tool**.

**Translation Rules**
Rules based on regular expressions used by the MAS to convert phone numbers between switch-native and canonical formats.

**Transport Layer Security (TLS)**
Protocol providing communications security over the internet.

**Trap**
A specific SNMP behavior to alert or send information from a managed system (such as an MAS, or supplementary server, or the Avaya MSS) to the NMS.

An SNMP trap is one way to manifest a Modular Messaging Alarm.

In certain circumstances, the trap may be acknowledged by a return trap. That is, data sent from the NMS to the managed system (the MAS, or supplementary server, or the Avaya MSS).

See also, **Alarm**.

**Trunk Code**
The code used to dial outside of the local dialing plan.

**TDD**
Telecommunication Device for the Deaf.

**TTS**
See **Text-to-Speech (TTS)**.

**TTY**
See **Teletypewriter (TTY)**.

**TUI**
See **Telephone User Interface (TUI)**.
Tutorial

Modular Messaging software setup tutorial that guides a subscriber through personalizing their mailbox. If configured, they hear it the first time they dial into their mailbox.

System administrators can configure this feature using **VMSC**.

**Visual Voice Editor**

A Modular Messaging administration tool that is installed on the MAS. It is used by system administrators to record customized prompts used by Modular Messaging software.

They can record using multimedia or the telephone user interface. When modifying a prompt, they are presented with a graphical rendering of the sound, which allows precise editing of the audio data.

**VMD**

See **Voice Mail Domain (VMD)**.

**VMDID**

Voice Mail Domain Identifier.

**VMSC**

See **Voice Mail System Configuration (VMSC)**.

**Voice Card**

A plug-in circuit card for a computer that provides the capability to enter data and commands by voice.

**Voice Mail Domain (VMD)**

A group of Modular Messaging software MASs that share a common set of properties. All subscribers who are provided with telephone answering by these MASs are said to “belong” to the same voice mail domain.

**Voice Mail System Configuration (VMSC)**

A Modular Messaging administration tool that is installed on the MAS. It is used by system administrators to configure the MASs on two levels:

- Properties shared across MAS groups in a VMD, where configuration is carried out centrally. These features are configurable at VMD level: **Telephone User Interface (TUI)**, **Sites**, **Automated Attendant**, **Call Me, Notify Me, Message Waiting Indicator (MWI)**, **Fax**, **Security Roles**, **MSS Security**, **MAS Auditing**, **Private Branch Exchange (PBX)**, **Languages**, **Audio Encoding Formats**, **Dialing Rules**, **Privacy Enforcement Level**, **Offline Access**, **Serviceability**, **Licensing**, and **Tracing System**.

- Properties specific to an MAS, where configuration is carried out for each MAS in a VMD. These features are configurable at MAS level: **Peer Server**, **Languages**, **Telephony Interface**, **Port Group**, **PBX Integration**, **Serviceability** and Trace File.

**Voice Player (AVP)**

A tool used by subscribers when recording greetings or PDL names.

**Voice Server**

See **Messaging Application Server (MAS)**.
Web Subscriber Options (WSO)
Set of web pages to manage voice mail and e-mail configuration for the subscriber.

WSO
See Web Subscriber Options (WSO).
Index

Symbols
% Delayed Calls
  Counter for MM MAS (SPM), 9-13
% Time Offline
  Counter for MM MAS (SPM), 9-13

A
Abandoned
  User Mailbox Statistics Report (RT), 7-26
Access Codes
  General tab, Fax dialog (VMSC - VMD), 3-82
Access Codes dialog (VMSC - VMD)
    Fax, 3-85
ACD tab
    Telephony Interface dialog (VMSC - MAS)
      Set Emulation, 4-21
Action
  Auto Attendant Keys tab, Site Properties dialog (VMSC - VMD), 3-36
Action type
  Add Node dialog (CA), 6-40
  General tab, Properties dialog (CA), 6-44
Active
  SNMP Trap Destinations tab, Serviceability dialog (VMSC - VMD), 3-195
Active alarms log (Logs), 11-4
Active Ports
  Counter for MM MAS (SPM), 9-13
Active TUI Sessions
  Counter for MM MAS (SPM), 9-13
Add
  Add Counters dialog (SPM), 9-11
  Communities tab, Serviceability dialog (VMSC - VMD), 3-196
  Dialing Rules dialog (VMSC - VMD), 3-171
  Email Domain Restrictions tab, Web Subscriber Options dialog (VMSC - VMD), 3-188
  General tab, Message Waiting Indicator dialog (VMSC - VMD), 3-76
  IP H.323 tab, PBX Integration dialog (VMSC - MAS), 4-58
  Members tab, Security Roles dialog (VMSC - VMD), 3-95
  Message Servers dialog (VMSC - VMD)
    MSS, 3-111
    Protocol, 3-111
  Personal Operator Schedules tab, Telephone User Interface dialog (VMSC - VMD), 3-54
  Query Originators tab
    Serviceability dialog (VMSC - VMD), 3-198
  SIP tab, PBX Configuration dialog (VMSC - VMD), 3-158
  SNMP Trap Destinations tab, Serviceability dialog (VMSC - VMD), 3-195
  Syslog tab, Auditing dialog (VMSC - VMD), 3-116
  Tasks tab, Security Roles dialog (VMSC - VMD), 3-104
Add application file
  General tab, Properties dialog (CA), 6-50
  Add Association dialog (CA), 6-71
  Add Codec dialog, 4-58
  Add Counters dialog (SPM), 9-11
  Add Group
    General tab, Port Groups dialog (VMSC - MAS), 4-30
Add language
  Open Caller Application dialog (CA), 6-36
  Add New Message Application Server dialog (VMSC - MAS), 4-7
  Add New Message Application Server menu command (VMSC), 4-7
  Add New PBX dialog (VMSC - VMD), 3-117
  Add New Voice Mail Domain dialog (VMSC - VMD), 3-12
  Add New Voice Mail Domain menu command
Index

(VMSC), 3-12
Add Node dialog (CA), 6-40
Add PBX Type menu command (VMSC), 3-118
Add Task dialog (VMSC - VMD), 3-105
Adding a New Caller Application (CA), 6-38
Adding a New Message Application Server (VMSC), 4-7
Adding a New PBX (VMSC - VMD), 3-118
Adding a New Site (VMSC), 3-23
Adding a New Site Group (VMSC), 3-22
Adding a New Voice Mail Domain (VMSC), 3-12
Adding an Application (Action) Node (CA), 6-40
Adding Application (Action) Nodes to the Caller Application (CA), 6-8
Adding Modular Messaging Counters (SPM), 9-11
Adding Modular Messaging Performance Counters (SPM), 9-11
Adjusting Amplitude & Silence (VVE), 5-15
Administrator log (Logs), 11-3
Advanced
Connect to MM Audit Database dialog box (Aud), 10-8
General tab, Fax dialog (VMSC - VMD), 3-81
Advanced Fax dialog (VMSC - VMD), 3-84
After hours node
General tab, Properties dialog (CA), 6-51
After Hours Receptionist Mailbox Number
Receptionist tab, Telephone User Interface dialog (VMSC - VMD), 3-43
Afternoon Prompt
Time of Day tab, Auto Attendant dialog (VMSC - VMD), 3-66
Agent ID
ACD tab, Telephony Interface dialog (VMSC - MAS) Set Emulation, 4-22
Alarm Origination
General tab, Serviceability dialog (VMSC - VMD), 3-191
All
General tab, Serviceability dialog (VMSC - VMD), 3-192
Properties dialog box (Aud), 10-9 to 10-10
All Activities
Session Properties dialog (OHV), 8-18
All Available
Port Statistics dialog (RT), 7-15
User Mailbox Statistics dialog (RT), 7-23
All Email Domains Will Be
Email Domain Restrictions tab, Web Subscriber Options dialog (VMSC - VMD), 3-188
All Error Events
MM Audit Log Viewer (Aud), 10-6
All Events
MM Audit Log Viewer (Aud), 10-6
All events
Syslog tab, Auditing dialog (VMSC - VMD), 3-116
All Events Last 30 Days
MM Audit Log Viewer (Aud), 10-6
All Events Last 7 Days
MM Audit Log Viewer (Aud), 10-6
All Events Today
MM Audit Log Viewer (Aud), 10-6
All mailboxes in voice mail domain
Start On-Demand MWI Update dialog (VMSC - VMD), 3-79
All Ports Statistics
Port Statistics Reports (RT), 7-17
All Servers
Events View tab, Options dialog (OHV), 8-22
Port Statistics dialog (RT), 7-15
All TUI Sessions Active
Counter for MM MAS (SPM), 9-13
Allow caller to interrupt prompt
Prompt tab, Properties dialog (CA), 6-57
Allow language selection when opening caller applications
Modular Messaging Software Caller Apps Properties dialog (CA), 6-35
Allow personal operators that are not local mailboxes
Receptionist tab, Telephone User Interface dialog (VMSC - VMD), 3-45
Allow Private Call Answer Messages
General tab, Telephone User Interface dialog (VMSC - VMD), 3-42
Allow subscribers to access messages using the TUI
Offline Access tab, Messaging dialog (VMSC - VMD), 3-179
Allowed
MM Audit Log Viewer (Aud), 10-7
Properties dialog box (Aud), 10-10
Allowed events
Syslog tab, Auditing dialog (VMSC - VMD), 3-116
Always let me select the language I would like to edit
Open Caller Application dialog (CA), 6-36
Analog, 3-120, 3-122 to 3-123, 3-125 to 3-126, 4-15, 9-1, 9-8
Analogue tab
Telephony Interface dialog (VMSC - MAS)
Analogue, 4-15
Analysis
Basic Metrics Report (RT), 7-28
Announcement
Prompt tab, Properties dialog (CA), 6-58
Index

Application
  Event Properties dialog box (Aud), 10-11
  MM Audit Log Viewer (Aud), 10-7
Application (Action) Node (CA), 6-28
Application Analysis Node (CA), 6-33
Application Analysis Results dialog (CA), 6-74
Application deployment
  Properties dialog (CA)
    Analyzed Deployed Applications node, 6-74
Application description
  New Caller Application dialog (CA), 6-38
Application name
  New Caller Application dialog (CA), 6-38
Application prompt
  Prompt tab, Properties dialog (CA), 6-57
Application tab, Properties dialog (CA), 6-62
Apply To
  Communities tab, Serviceability dialog (VMSC - VMD), 3-196
Area Code
  General tab, Fax dialog (VMSC - VMD), 3-82
As a message is abandoned
  Operation History Collection tab, Tracing System dialog (VMSC - VMD), 3-209
  Transaction Generation tab, Tracing System dialog (VMSC - VMD), 3-210
Assigning an Existing Prompt File to the Prompt (CA), 6-11
Association ID
  Add Association/Association Properties dialog (CA), 6-71
Association name
  Add Association/Association Properties dialog (CA), 6-71
Association Properties dialog (CA), 6-71
Association references
  Properties dialog (CA)
    Analyzed Deployed Applications node, 6-75
Associations Node (CA), 6-32
At time
  Operation History Collection tab, Tracing System dialog (VMSC - VMD), 3-209
  Transaction Generation tab, Tracing System dialog (VMSC - VMD), 3-210
Attendant Main Menu Editor tab
  Auto Attendant dialog (VMSC - VMD), 3-62
Audio encoding
  Modular Messaging Software Caller Apps Properties dialog (CA), 6-34
Audio Encoding dialog (VMSC - VMD), 3-168
Audit database configuration
  General tab, Auditing dialog (VMSC - VMD), 3-114
Audit Event Details dialog box (Aud), 10-11
Audit event retention (days)
  General tab, Auditing dialog (VMSC - VMD), 3-114
Audit server
  General tab, Auditing dialog (VMSC - VMD), 3-114
Auditing - Administer
  Add Task dialog (VMSC - VMD), 3-109
  Tasks tab, Security Roles dialog (VMSC - VMD), 3-97
Auditing - View
  Add Task dialog (VMSC - VMD), 3-109
  Tasks tab, Security Roles dialog (VMSC - VMD), 3-101
Auditing dialog (VMSC - VMD), 3-113
Authentication Failure for SNMP Queries
  Generic Traps (VMSC-VMD), 3-200
Auto Attendant - Administer
  Add Task dialog (VMSC - VMD), 3-105
  Tasks tab, Security Roles dialog (VMSC - VMD), 3-97
Auto Attendant - View
  Add Task dialog (VMSC - VMD), 3-105
  Tasks tab, Security Roles dialog (VMSC - VMD), 3-101
Auto Attendant dialog (VMSC - VMD), 3-59
Auto Attendant Main Menu Prompt
  Attendant Main Menu Editor tab, Auto Attendant dialog (VMSC - VMD), 3-63
Auto Logon
  Inband Protocol Settings dialog (VMSC - MAS), 4-48
Automated attendant
  General tab, Properties dialog (CA), 6-54
Avaya C-LAN tab
  PBX Integration dialog (VMSC - MAS), 4-54
Avaya/Business Partner Primary Destination Internet Proxies tab
  Serviceability dialog (VMSC - VMD), 3-199
Avaya/Business Partner Secondary Destination Internet Proxies tab
  Serviceability dialog (VMSC - VMD), 3-199
Average MWI Command Time in Queue
  Counter for MM MWI Server (SPM), 9-15
Average MWI Commands Per Minute
  Counter for MM MWI Server (SPM), 9-15
Average MWI Notifications Per Minute
  Counter for MM MWI Server (SPM), 9-16
<table>
<thead>
<tr>
<th>B</th>
<th>Call Me - View</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bad Port</td>
<td>Add Task dialog (VMSC - VMD), 3-105</td>
</tr>
<tr>
<td>Basic Metrics</td>
<td>Tasks tab, Security Roles dialog (VMSC - VMD), 3-101</td>
</tr>
<tr>
<td>BC Transfer Cap</td>
<td>Call Me dialog (VMSC - VMD), 3-69</td>
</tr>
<tr>
<td>Blind</td>
<td>Call Me Server</td>
</tr>
<tr>
<td>Call Transfer tab</td>
<td>General tab, Call Me dialog (VMSC - VMD), 3-70</td>
</tr>
<tr>
<td>Call Transfer Codes</td>
<td>Call Packet Type</td>
</tr>
<tr>
<td>Call Transfer tab</td>
<td>Inband Protocol Settings dialog (VMSC - MAS), 4-47</td>
</tr>
<tr>
<td>Call Transfer tabs</td>
<td>IP H.323, 3-151</td>
</tr>
<tr>
<td>Call Packet Type</td>
<td>QSIG, 3-134</td>
</tr>
<tr>
<td>Callers Actions</td>
<td>Callers Actions Editor (CA), 6-4</td>
</tr>
<tr>
<td>Callers Actions</td>
<td>Callers Actions Node (CA), 6-26</td>
</tr>
<tr>
<td>Called number</td>
<td>Call Applications - Administer</td>
</tr>
<tr>
<td>Caller Applications</td>
<td>Add Task dialog (VMSC - VMD), 3-108</td>
</tr>
<tr>
<td>Caller tab</td>
<td>Tasks tab, Security Roles dialog (VMSC - VMD), 3-97</td>
</tr>
<tr>
<td>Caller tab</td>
<td>Call Id</td>
</tr>
<tr>
<td>Caller tab</td>
<td>Columns tab, Options dialog (OHV), 8-23</td>
</tr>
<tr>
<td>Caller tab</td>
<td>Operation History Viewer window (OHV), 8-15</td>
</tr>
<tr>
<td>Caller tab</td>
<td>Session Properties dialog (OHV), 8-19</td>
</tr>
<tr>
<td>Caller tab</td>
<td>Calling Id (Inband Protocol Settings dialog), 4-49</td>
</tr>
<tr>
<td>Caller tab</td>
<td>Calls to Non Modular Messaging Software Enabled Users</td>
</tr>
<tr>
<td>Caller tab</td>
<td>Counter for MM MAS (SPM), 9-13</td>
</tr>
<tr>
<td>Caller tab</td>
<td>Calls While Offline</td>
</tr>
<tr>
<td>Caller tab</td>
<td>Counter for MM MAS (SPM), 9-13</td>
</tr>
<tr>
<td>Caller tab</td>
<td>Cancel destination node</td>
</tr>
<tr>
<td>Caller tab</td>
<td>General tab, Properties dialog (CA)</td>
</tr>
<tr>
<td>Caller tab</td>
<td>Menu Action Type, 6-47</td>
</tr>
<tr>
<td>Caller tab</td>
<td>Send Message Action Type, 6-53</td>
</tr>
<tr>
<td>Business hours</td>
<td>Connect to MM Audit Database dialog box (Aud), 10-8</td>
</tr>
<tr>
<td>Call answered calls</td>
<td>Call-Id</td>
</tr>
<tr>
<td>Call answered calls</td>
<td>Columns tab, Options dialog (OHV), 8-23</td>
</tr>
<tr>
<td>Call answered calls</td>
<td>Operation History Viewer window (OHV), 8-15</td>
</tr>
<tr>
<td>Call answered calls</td>
<td>Session Properties dialog (OHV), 8-19</td>
</tr>
<tr>
<td>Call answered calls</td>
<td>Calling Id (Inband Protocol Settings dialog), 4-49</td>
</tr>
<tr>
<td>Call answered calls</td>
<td>Calls to Non Modular Messaging Software Enabled Users</td>
</tr>
<tr>
<td>Call answered calls</td>
<td>Counter for MM MAS (SPM), 9-13</td>
</tr>
<tr>
<td>Callers Actions</td>
<td>System Usage Report (RT), 7-20</td>
</tr>
<tr>
<td>Busy</td>
<td>Connect to MM Audit Database dialog box (Aud), 10-8</td>
</tr>
<tr>
<td>Busy Extension</td>
<td>Call-Id</td>
</tr>
<tr>
<td>Busy Extension</td>
<td>Columns tab, Options dialog (OHV), 8-23</td>
</tr>
<tr>
<td>Busy Extension</td>
<td>Operation History Viewer window (OHV), 8-15</td>
</tr>
<tr>
<td>Busy Extension</td>
<td>Session Properties dialog (OHV), 8-19</td>
</tr>
<tr>
<td>Busy Extension</td>
<td>Calling Id (Inband Protocol Settings dialog), 4-49</td>
</tr>
<tr>
<td>Busy Extension</td>
<td>Calls to Non Modular Messaging Software Enabled Users</td>
</tr>
<tr>
<td>Busy Extension</td>
<td>Counter for MM MAS (SPM), 9-13</td>
</tr>
<tr>
<td>Busy Extension</td>
<td>Calls While Offline</td>
</tr>
<tr>
<td>Busy Extension</td>
<td>Counter for MM MAS (SPM), 9-13</td>
</tr>
<tr>
<td>Busy Extension</td>
<td>Cancel destination node</td>
</tr>
<tr>
<td>Busy Extension</td>
<td>General tab, Properties dialog (CA)</td>
</tr>
<tr>
<td>Busy Extension</td>
<td>Menu Action Type, 6-47</td>
</tr>
<tr>
<td>Busy Extension</td>
<td>Send Message Action Type, 6-53</td>
</tr>
</tbody>
</table>
Index

Canonical Addressing
  General tab, Fax dialog (VMSC - VMD), 3-82
Change access to this key to use
  Change Key dialog (CA), 6-67
Change Key dialog (CA), 6-67
Changing Session Properties (OHV), 8-11
Changing the Audio Format (VVE), 5-6
Changing the Home MAS (VMSC), 3-15
Changing the Key (CA), 6-67
Character-separated values
  Export dialog (RT), 7-30
Character-Separated Values dialog (RT), 7-32
Check Mailbox
  Inband Protocol Settings dialog (VMSC - MAS), 4-48
C-LAN
  General tab, PBX Integration dialog (VMSC - MAS), 4-37
Clear
  Session Properties dialog (OHV), 8-18
Clear Alarm Notification
  General tab, Serviceability dialog (VMSC - VMD), 3-192
Client hanging up and system failures
  Basic Metrics Report (RT), 7-28
Client installation options
  General tab, Web Subscriber Options dialog (VMSC - MAS), 4-187
Close
  Time/Greeting tab, Telephone User Interface dialog (VMSC - VMD), 3-47
Close time
  TUI tab, Site Properties dialog (VMSC - VMD), 3-31
Closed All Day
  Time/Greeting tab, Telephone User Interface dialog (VMSC - VMD), 3-47
  TUI tab, Site Properties dialog (VMSC - VMD), 3-31
Closed Prompt
  Time of Day tab, Auto Attendant dialog (VMSC - VMD), 3-66
CM CALLME 1 (MAS Alarms), A-3
Code 1, 2, 3, 4
  Inband Protocol Settings dialog (VMSC - MAS), 4-48
Codes for Call Type
  Inband Protocol Settings dialog (VMSC - MAS), 4-48
Cold Start
  Generic Traps (VMSC-VMD), 3-200
Columns tab
  Options dialog (OHV), 8-23
COM port
  Modem Configuration tab, Serviceability dialog (VMSC - MAS), 4-65
Comma
  Text Export tab, Options dialog (OHV), 8-24
Comma Separated Value (*.CSV)
  Export dialog (RT), 7-30
Command Line Interface Tools (Logs), 11-2
Command Pool Queue Length
  Counter for MM MAS (SPM), 9-13
Comment
  Prompts View
    Visual Voice Editor window (VVE), 5-21
Comment View
  Visual Voice Editor window (VVE), 5-21
Communities tab
  Serviceability dialog (VMSC - VMD), 3-196
Community
  Communities tab, Serviceability dialog (VMSC - VMD), 3-196
  Query Originators tab
    Serviceability dialog (VMSC - VMD), 3-198
    SNMP Trap Destinations tab, Serviceability dialog (VMSC - VMD), 3-194
Company Address
  Fax Cover Page dialog (VMSC - VMD), 3-83
Company Fax Number
  General tab, Fax dialog (VMSC - VMD), 3-81
Company Name
  Fax Cover Page dialog (VMSC - VMD), 3-83
Complete Transfer
  Transfer/Outcall tab, PBX Configuration dialog (VMSC - VMD) Set Emulation, 3-142
Conditional goto
  Add Node dialog (CA), 6-41
  General tab, Properties dialog (CA), 6-45
Conditional Goto Action Type
  General tab, Properties dialog (CA), 6-51
Configure
  IP SIP tab, PBX Configuration dialog (VMSC - VMD), 3-159
  Media Setup tab
    Modular Messaging User Properties dialog (VVE), 5-8
    Modular Messaging Software Caller Apps Properties dialog (CA), 6-34
    Sites dialog (VMSC - VMD), 3-18
    Telephone
      Options dialog (VMSC - VMD), 3-21
Configure advanced SIP logging
  SIP tab, PBX Configuration dialog (VMSC - VMD), 3-158
Configuring Access Codes & Dialing Rules (VMSC
Index

- VMD), 3-170
Configuring Application Analysis Properties (CA), 6-73
Configuring Audio Encoding (VMSC - VMD), 3-168
Configuring Automated Attendant (VMSC - VMD), 3-59
Configuring Automated Attendant to Launch a Caller Application (CA), 6-18
Configuring Call Me (VMSC - VMD), 3-69
Configuring Caller Application Properties (CA) Application (Action) Node, 6-43
Caller Applications Node, 6-43
Configuring Caller Applications (CA), 6-22
Configuring Dialing Rules (VMSC - VMD) Access Codes, 3-170
Configuring Dialogic Analog PBX (VMSC - VMD), 3-120
Configuring Fax Support (VMSC - VMD), 3-80
Configuring Holiday Prompts (VVE), 5-17
Configuring IP H.323 PBX (VMSC - VMD), 3-147
Configuring IP SIP PBX (VMSC - VMD), 3-153
Configuring Languages (VMSC - MAS), 4-13
Configuring Languages (VMSC - VMD), 3-166
Configuring Licensing (VMSC - VMD), 3-113, 3-201
Configuring Message Waiting Indicator (VMSC - VMD), 3-73
Configuring Messaging (VMSC - MAS), 4-11
Configuring Messaging (VMSC - VMD), 3-174
Configuring Messaging Application Servers (VMSC), 4-2
Configuring Messaging Servers Security (VMSC - VMD), 3-111
Configuring Offline Access (VMSC - VMD), 3-180
Configuring PBX Integration (VMSC - MAS), 4-33
Configuring PBXs (VMSC - VMD), 3-117
Configuring Port Groups (VMSC - MAS), 4-25
Configuring QSIG PBX (VMSC - VMD), 3-129
Configuring Security Roles (VMSC - VMD), 3-88
Configuring Serviceability (VMSC - MAS), 4-62 to 4-63, 4-65
Configuring Serviceability (VMSC - VMD), 3-189
Configuring Set Emulation PBX (VMSC - VMD), 3-138
Configuring Site Properties (VMSC - VMD), 3-27
Configuring Sites (VMSC - VMD), 3-19
Configuring Text-to-Speech Licenses (VMSC - VMD), 3-203
Configuring the Auto Attendant Main Menu prompt (VVE), 5-17
Configuring the Custom Language Selection Greeting (VVE), 5-18
Configuring the PBX Type (VMSC - MAS), 4-61
Configuring the Peer Server and Directory Server (VMSC - MAS), 4-11
Configuring the Privacy Enforcement Level, 3-176
Configuring the Telephone User Interface (VMSC - VMD), 3-38
Configuring the Telephony Interface (VMSC - MAS), 4-14
Analog, 4-15
IP H.323, 4-23
QSIG, 4-17
Set Emulation, 4-19
Configuring the Trace File Size (VMSC - MAS), 4-67
Configuring the Tracing System (VMSC - VMD), 3-206
Configuring Time of Day Prompts (VVE), 5-18
Configuring Voice Mail Domains (VMSC), 3-3
Configuring Web Subscriber Options (VMSC - VMD), 3-186
Confirm Mailbox
Inband Protocol Settings dialog (VMSC - MAS), 4-48
Connect
Connect to Database dialog box (Aud), 10-8
Connect Link
Avaya C-LAN tab, PBX Integration dialog (VMSC - MAS), 4-55
Connect to Message Application Server
Add New Voice Mail Domain dialog (VMSC - VMD), 3-12
Remove Voice Mail Domain dialog (VMSC - VMD), 3-13
Rename Voice Mail Domain dialog (VMSC - VMD), 3-14
Connect to MM Audit Database dialog box (Aud), 10-8
Connected
Port Monitor window (SPM), 9-5
Connecting to the MAS (CA), 6-13
Connector
Serial Settings dialog (VMSC - MAS), 4-40
Continue
Open Caller Application dialog (CA), 6-37
Copy As
Personal Operator Schedules tab, Telephone User Interface dialog (VMSC - VMD), 3-55
Copy Host ID to Clipboard menu command (VMSC), 3-204
Copy Role dialog (VMSC - VMD), 3-92
Copy schedule IDs to clipboard menu command (VMSC), 3-39
Copy to clipboard
Properties dialog (CA)
Analyzed Deployed Applications node, 6-75
Index

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copying Changes across MASs (VVE)</td>
<td>5-16</td>
</tr>
<tr>
<td>Corporate IP Address</td>
<td>4-59</td>
</tr>
<tr>
<td>IP SIP tab, PBX Integration dialog (VMSC - MAS)</td>
<td></td>
</tr>
<tr>
<td>Costs controlling outbound calls</td>
<td>3-17</td>
</tr>
<tr>
<td>Sites dialog (VMSC - VMD)</td>
<td></td>
</tr>
<tr>
<td>Country Code</td>
<td>3-82</td>
</tr>
<tr>
<td>General tab, Fax dialog (VMSC - VMD)</td>
<td></td>
</tr>
<tr>
<td>Cover Page</td>
<td></td>
</tr>
<tr>
<td>General tab, Fax dialog (VMSC - VMD)</td>
<td></td>
</tr>
<tr>
<td>Create New Role dialog (VMSC - VMD)</td>
<td>3-92</td>
</tr>
<tr>
<td>Creating &amp; Viewing a Historical Session (OHV)</td>
<td>8-10</td>
</tr>
<tr>
<td>Creating &amp; Viewing a Live Session (OHV)</td>
<td>8-8</td>
</tr>
<tr>
<td>Creating a Caller Application (CA)</td>
<td>6-7</td>
</tr>
<tr>
<td>Creating a New Data Source (OHV)</td>
<td>8-5</td>
</tr>
<tr>
<td>Creating a Working Copy of CustomPrompts.OVF (VVE)</td>
<td>5-5</td>
</tr>
<tr>
<td>Creating Sessions (OHV)</td>
<td>8-8</td>
</tr>
<tr>
<td>Credentials</td>
<td></td>
</tr>
<tr>
<td>Message Servers dialog (VMSC - VMD)</td>
<td>3-111</td>
</tr>
<tr>
<td>Crystal Reports (RPT)</td>
<td></td>
</tr>
<tr>
<td>Export dialog (RT)</td>
<td>7-30</td>
</tr>
<tr>
<td>Current Position</td>
<td></td>
</tr>
<tr>
<td>Waveform Info</td>
<td></td>
</tr>
<tr>
<td>Visual Voice Editor window (VVE)</td>
<td>5-25</td>
</tr>
<tr>
<td>Current Value</td>
<td></td>
</tr>
<tr>
<td>General tab, Licensing dialog (VMSC - VMD)</td>
<td>3-202</td>
</tr>
<tr>
<td>Custom</td>
<td></td>
</tr>
<tr>
<td>Properties dialog box (Aud)</td>
<td>10-9</td>
</tr>
<tr>
<td>10-10</td>
<td></td>
</tr>
<tr>
<td>Custom events</td>
<td></td>
</tr>
<tr>
<td>Syslog tab, Auditing dialog (VMSC - VMD)</td>
<td>3-116</td>
</tr>
<tr>
<td>Custom Language Selection Greeting</td>
<td></td>
</tr>
<tr>
<td>Language/Key Association tab, Auto Attendant dialog (VMSC - VMD)</td>
<td>3-68</td>
</tr>
<tr>
<td>Custom operator</td>
<td></td>
</tr>
<tr>
<td>Application tab, Properties dialog (CA)</td>
<td>6-63</td>
</tr>
<tr>
<td>Customer Primary Proxy Server</td>
<td></td>
</tr>
<tr>
<td>Internet Proxies tab</td>
<td></td>
</tr>
<tr>
<td>Serviceability dialog (VMSC - VMD)</td>
<td>3-199</td>
</tr>
<tr>
<td>Customer Secondary Proxy Server</td>
<td></td>
</tr>
<tr>
<td>Internet Proxies tab</td>
<td></td>
</tr>
<tr>
<td>Serviceability dialog (VMSC - VMD)</td>
<td>3-199</td>
</tr>
<tr>
<td>Customer-Created Roles</td>
<td></td>
</tr>
<tr>
<td>Tasks tab, Security Roles dialog (VMSC - VMD)</td>
<td>3-104</td>
</tr>
<tr>
<td>CustomPrompt_G711.OVF (VVE)</td>
<td>5-6</td>
</tr>
<tr>
<td>CustomPrompts.OVF (VVE)</td>
<td>5-5</td>
</tr>
<tr>
<td>Cutting, Copying, Pasting &amp; Trimming (VVE)</td>
<td>5-14</td>
</tr>
</tbody>
</table>

D
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Daily Settings</td>
<td></td>
</tr>
<tr>
<td>Time/Greeting tab, Telephone User Interface dialog (VMSC - VMD)</td>
<td>3-46</td>
</tr>
<tr>
<td>Data Bits</td>
<td></td>
</tr>
<tr>
<td>Serial Settings dialog (VMSC - MAS)</td>
<td>4-40</td>
</tr>
<tr>
<td>Data Interchange Format (DIF)</td>
<td></td>
</tr>
<tr>
<td>Export dialog (RT)</td>
<td>7-30</td>
</tr>
<tr>
<td>Data Storage (Aud)</td>
<td>10-2</td>
</tr>
<tr>
<td>Database</td>
<td></td>
</tr>
<tr>
<td>Connect to MM Audit Database dialog box (Aud)</td>
<td>10-8</td>
</tr>
<tr>
<td>Database File (*.MDB)</td>
<td></td>
</tr>
<tr>
<td>Export Operation History Events dialog (OHV)</td>
<td>8-26</td>
</tr>
<tr>
<td>Database instance</td>
<td></td>
</tr>
<tr>
<td>General tab, Auditing dialog (VMSC - VMD)</td>
<td>3-115</td>
</tr>
<tr>
<td>Database name</td>
<td></td>
</tr>
<tr>
<td>General tab, Auditing dialog (VMSC - VMD)</td>
<td>3-115</td>
</tr>
<tr>
<td>Database server</td>
<td></td>
</tr>
<tr>
<td>General tab, Auditing dialog (VMSC - VMD)</td>
<td>3-114</td>
</tr>
<tr>
<td>Date</td>
<td></td>
</tr>
<tr>
<td>Auto Attendant Holidays tab, Site Properties dialog (VMSC - VMD)</td>
<td>3-35</td>
</tr>
<tr>
<td>Basic Metrics dialog (RT)</td>
<td>7-27</td>
</tr>
<tr>
<td>Columns tab, Options dialog (OHV)</td>
<td>8-23</td>
</tr>
<tr>
<td>Holiday tab, Auto Attendant dialog (VMSC - VMD)</td>
<td>3-65</td>
</tr>
<tr>
<td>Hourly Statistics dialog (RT)</td>
<td>7-11</td>
</tr>
<tr>
<td>Hourly Statistics Report (RT)</td>
<td>7-12</td>
</tr>
<tr>
<td>Login Failures dialog (RT)</td>
<td>7-13</td>
</tr>
<tr>
<td>Operation History Viewer window (OHV)</td>
<td>8-15</td>
</tr>
<tr>
<td>Port Statistics dialog (RT)</td>
<td>7-15</td>
</tr>
<tr>
<td>System Usage dialog (RT)</td>
<td>7-19</td>
</tr>
<tr>
<td>User Mailbox Statistics dialog (RT)</td>
<td>7-23</td>
</tr>
<tr>
<td>Date and Time</td>
<td></td>
</tr>
<tr>
<td>Event Properties dialog (OHV)</td>
<td>8-20</td>
</tr>
<tr>
<td>Session Properties dialog (OHV)</td>
<td>8-18</td>
</tr>
<tr>
<td>Date/Time</td>
<td></td>
</tr>
<tr>
<td>Session Properties dialog (OHV)</td>
<td>8-19</td>
</tr>
<tr>
<td>Day greetings</td>
<td></td>
</tr>
<tr>
<td>Auto Attendant tab, Site Properties dialog (VMSC - VMD)</td>
<td>3-32</td>
</tr>
<tr>
<td>Days before Password Expiry</td>
<td></td>
</tr>
<tr>
<td>Subscriber tab, Telephone User Interface dialog (VMSC - VMD)</td>
<td>3-51</td>
</tr>
</tbody>
</table>
Default
Query Originators tab
Serviceability dialog (VMSC - VMD), 3-198
Session Properties dialog (OHV), 8-18
Default Audio Encoding Format
Audio Encoding dialog (VMSC - VMD), 3-169
Default cancel
Application tab, Properties dialog (CA), 6-63
Default cancel key
Application tab, Properties dialog (CA), 6-63
Default Date and Time
Events View tab, Options dialog (OHV), 8-22
Default Input Timeout in Seconds
General tab, Telephone User Interface dialog (VMSC - VMD), 3-41
Default MAS
Events View tab, Options dialog (OHV), 8-22
Default operator
Application tab, Properties dialog (CA), 6-62
Default Receptionist Mailbox Number
Receptionist tab, Telephone User Interface dialog (VMSC - VMD), 3-43
Defaulted to Assistance
System Usage Report (RT), 7-20
Delete
Dialing Rules dialog (VMSC - VMD), 3-171
General tab, Message Waiting Indicator dialog (VMSC - VMD), 3-76
Message Servers dialog (VMSC - VMD), 3-111
Personal Operator Schedules tab, Telephone User Interface dialog (VMSC - VMD), 3-55
Syslog tab, Auditing dialog (VMSC - VMD), 3-116
Delete Expired Events
Operation History Collection tab, Tracing System dialog (VMSC - VMD), 3-209
Delete Expired Transactions
Transaction Generation tab, Tracing System dialog (VMSC - VMD), 3-210
Deleting a Site Group or a Site (VMSC), 3-25
Deleting an Association (CA), 6-19
Delimiter Character
Inband tab, PBX Integration dialog (VMSC - MAS), 4-45
Denied
MM Audit Log Viewer (Aud), 10-7
Properties dialog box (Aud), 10-10
Denied Access
Email Domain Restrictions tab, Web Subscriber Options dialog (VMSC - VMD), 3-188
Denied events
Syslog tab, Auditing dialog (VMSC - VMD), 3-116
Deployed Applications Node (CA), 6-30
Deploying a Caller Application (CA), 6-14
Deploying Caller Applications (CA), 6-69
Description
Add Node dialog (CA), 6-41
General tab, Properties dialog (CA), 6-44
Start On-Demand MWI Update dialog (VMSC - VMD), 3-79
Design for VMD
Application tab, Properties dialog (CA), 6-65
New Caller Application dialog (CA), 6-38
Destination
Export dialog (RT), 7-31
Detailed
Waveform View
Visual Voice Editor window (VVE), 5-24
Dial by name
General tab, Properties dialog (CA), 6-54
Dial By Name tab
Telephone User Interface dialog (VMSC - VMD), 3-58
Dial Number
Dialogic Line Test Application window (SPM), 9-8
Dialing
Dialing Rules dialog (VMSC - VMD), 3-172
Dialing Number
Dialogic Line Test Application window (SPM), 9-8
Dialing rules
Dialogic Line Test Application window (SPM), 9-1
Dialtone
Port Monitor window (SPM), 9-5
Direct
System Usage Report (RT), 7-22
User Mailbox Statistics Report (RT), 7-25
Direct Call
- Inband Protocol Settings dialog (VMSC - MAS), 4-47

Direct Calls
- System Usage Report (RT), 7-21

Directories
- Export Operation History Events dialog (OHV), 8-26

Directory
- Attendant Main Menu Editor tab, Auto Attendant dialog (VMSC - VMD), 3-63
- Auto Attendant Keys tab, Site Properties dialog (VMSC - VMD), 3-36

Directory Search Key
- Columns tab, Options dialog (OHV), 8-23
- Operation History Viewer window (OHV), 8-15

Directory Server(s)
- General tab, Messaging dialog (VMSC - MAS), 4-12

Disabled
- Port Monitor window (SPM), 9-5

Disabling
- Port Monitor window (SPM), 9-5

Disabling ODBC Tracing (OHV), 8-7

Disconnect
- Application tab, Properties dialog (CA), 6-65
- General tab, Properties dialog (CA), 6-54

Disconnect all Rotary Callers
- Receptionist tab, Telephone User Interface dialog (VMSC - VMD), 3-43

Disconnect Link
- Avaya C-LAN tab, PBX Integration dialog (VMSC - MAS), 4-55

Disconnected
- Port Monitor window (SPM), 9-5

Disk file
- Export dialog (RT), 7-31

Display properties when creating new application nodes
- Modular Messaging Software Caller Apps Properties dialog (CA), 6-35

Displayed on screen
- Options dialog (RT), 7-10

Displaying MAS Alarm Logs, 11-4
Displaying MAS Event & Error Logs, 11-3
displog -l act (Logs), 11-4
displog -l admin (Logs), 11-3
displog -l maint (Logs), 11-3
displog -l res (Logs), 11-4

Divert
- Inband Protocol Settings dialog (VMSC - MAS), 4-47

Diverted Calls
- System Usage Report (RT), 7-21

DMID
- Serial NEC/Ericsson/DMID tab, PBX Integration dialog (VMSC - MAS), 4-42

Domain Address
- Email Domain Restrictions tab, Web Subscriber Options dialog (VMSC - VMD), 3-188

Domain Languages tab
- Languages dialog (VMSC - VMD), 3-166

Double Quotes
- Text Export tab, Options dialog (OHV), 8-24

Download
- General tab, Web Subscriber Options dialog (VMSC - VMD), 3-187

Drives
- Export Operation History Events dialog (OHV), 8-26

Drop Call
- Transfer/Outcall tab, PBX Configuration dialog (VMSC - VMD) Set Emulation, 3-142
- DSE, 3-138, 3-140 to 3-141, 3-143 to 3-144, 4-19, 4-21, 4-52

DTMF Inter-Digit Delay during Dialing (ms)
- General tab, PBX Configuration dialog (VMSC - VMD)
  - Dialogic Analog, 3-122
  - IP SIP, 3-155
  - QSIG, 3-131
  - Set Emulation, 3-140

DTMF Key 1, 2, 3
- Language/Key Association tab, Auto Attendant dialog (VMSC - VMD), 3-68

DTMF Length during Detection (ms)
- General tab, PBX Configuration dialog (VMSC - VMD)
  - Dialogic Analog, 3-122
  - IP SIP, 3-155
  - QSIG, 3-131
  - Set Emulation, 3-140

DTMF Length during Dialing (ms)
- General tab, PBX Configuration dialog (VMSC - VMD)
  - Dialogic Analog, 3-122
  - IP SIP, 3-155
  - QSIG, 3-131
  - Set Emulation, 3-140

DTMF On Time (ms)
- General tab, PBX Configuration dialog (VMSC - VMD)
  - Dialogic Analog, 3-122

Due to Busy
- System Usage Report (RT), 7-21
Due to RNA
  System Usage Report (RT), 7-21
During hours node
  General tab, Properties dialog (CA), 6-51

E

Edit content as language
  Open Caller Application dialog (CA), 6-36
Edit Sessions dialog (VMSC - VMD), 3-203
Editing a Caller Application (CA), 6-9

E-mail
  General tab, Properties dialog (CA), 6-52

E-mail Address
  Dial By Name tab, Telephone User Interface dialog (VMSC - VMD), 3-58

Email Domain Restrictions Tab
  Web Subscriber Options dialog (VMSC - VMD), 3-188

Enable
  IP SIP tab, PBX Integration dialog (VMSC - MAS), 4-60
  PBX Integration dialog (VMSC - VMD), 3-165
Enable ACD
  ACD tab, Telephony Interface dialog (VMSC - MAS) Set Emulation, 4-21
Enable Auditing
  General tab, Auditing dialog (VMSC - VMD), 3-114
Enable Automated Attendant
  General tab, Telephone User Interface dialog (VMSC - VMD), 3-40
Enable Avaya Voice Player
  General tab, Web Subscriber Options dialog (VMSC - VMD), 3-187
Enable Call Me
  General tab, Call Me dialog (VMSC - VMD), 3-70
Enable Call Progress
  Call Transfer tab, PBX Configuration dialog (VMSC - VMD)
    Dialogic Analog, 3-124
Enable Caller Applications
  General tab, Telephone User Interface dialog (VMSC - VMD), 3-40
Enable Confirmation before Deleting Messages
  Subscriber tab, Telephone User Interface dialog (VMSC - VMD), 3-50
Enable Customer Proxy Servers
  Internet Proxies tab
    Serviceability dialog (VMSC - VMD), 3-199
Enable Email Address In Personal Distribution List
  General tab, Web Subscriber Options dialog (VMSC - VMD), 3-187
Enable Extended Password Security
  Subscriber tab, Telephone User Interface dialog (VMSC - VMD), 3-50
Enable Fast Start
  IP H.323 tab, PBX Integration dialog (VMSC - MAS), 4-57
Enable Full Error Logging from DMID Integration Device
  Serial NEC/Ericsson/DMID tab, PBX Integration dialog (VMSC - MAS), 4-42
Enable Intercom Paging
  Intercom Paging tab, PBX Configuration dialog (VMSC - VMD)
    Dialogic Analog, 3-126
    QSIG, 3-136
    Set Emulation, 3-144
Enable Local Player For Audio Playback And Record
  General tab, Web Subscriber Options dialog (VMSC - VMD), 3-187
Enable Message Waiting Indicator (MWI)
  General tab, Message Waiting Indicator dialog (VMSC - VMD), 3-75
Enable Multilingual Text-to-Speech
  Domain Languages tab, Languages dialog (VMSC - VMD), 3-167
Enable MultiSite
  Sites dialog (VMSC - VMD), 3-17
Enable New Mailbox Initialization
  General tab, Telephone User Interface dialog (VMSC - VMD), 3-41
Enable Notify Me
  General tab, Notify Me dialog (VMSC - VMD), 3-72
Enable offline access to messages
  Offline Access tab, Messaging dialog (VMSC - VMD), 3-178
Enable Operation History Collection
  Operation History Collection tab, Tracing System dialog (VMSC - VMD), 3-209
Enable Password Expiry
  Subscriber tab, Telephone User Interface dialog (VMSC - VMD), 3-51
Enable Restricted Avaya Voice Player
  General tab, Web Subscriber Options dialog (VMSC - VMD), 3-187
Enable system for devices used by people who are deaf or hard of hearing (TTY)
  Audio Encoding dialog (VMSC - VMD), 3-169
Enable Transaction Generation
  Transaction Generation tab, Tracing System dialog (VMSC - VMD), 3-210
Enable Transfer to Voicemail Using Extension
Index

Number
   General tab, Telephone User Interface dialog (VMSC - VMD), 3-42
Enable Tunneling
   IP H.323 tab, PBX Integration dialog (VMSC - MAS), 4-57
Enabling Caller Applications for the Voice Mail Domain (CA), 6-4
Enabling the Collection of Operation History Events (OHV), 8-3
Enabling Transaction Generation (RT), 7-3
Enter a Prompt Number
   Goto/Insert Prompt dialog (VVE), 5-21
Enter address
   SNMP Trap Destinations tab, Serviceability dialog (VMSC - VMD), 3-194
Ericsson MD110
   Serial NEC/Ericsson/DMID tab, PBX Integration dialog (VMSC - MAS), 4-42
Error
   MM Audit Log Viewer (Aud), 10-7
   Properties dialog box (Aud), 10-10
   Session Properties dialog (OHV), 8-18
Error events
   Syslog tab, Auditing dialog (VMSC - VMD), 3-116
Evening Prompt
   Time of Day tab, Auto Attendant dialog (VMSC - VMD), 3-66
Event
   Columns tab, Options dialog (OHV), 8-23
   Event Properties dialog (OHV), 8-20
   Operation History Viewer window (OHV), 8-15
   Session Properties dialog (OHV), 8-19
Event log (Logs), 11-3
Event Properties dialog (OHV), 8-20
Event Type
   Properties dialog box (Aud), 10-10
Events to send to syslog
   Syslog tab, Auditing dialog (VMSC - VMD), 3-116
Events View tab
   Options dialog (OHV), 8-22
Excel 2.1/3.0/4.0/5.0 (XLS)
   Export dialog (RT), 7-30
Except The Following
   Email Domain Restrictions tab, Web Subscriber Options dialog (VMSC - VMD), 3-188
Export dialog (RT), 7-30
Export Operation History Events dialog (OHV), 8-26
Exporting a Report (RT), 7-32
Exporting Operation History Events (OHV), 8-12,

8-26
Ext. Busy
   User Mailbox Statistics Report (RT), 7-25
Ext. RNA
   User Mailbox Statistics Report (RT), 7-25
Extension
   Analog tab, Telephony Interface dialog (VMSC - MAS), 4-16
   General tab, Properties dialog (CA), 6-49
   General tab, Telephony Interface dialog (VMSC - MAS) Set Emulation, 4-20
Extension Field Length in Packet
   Serial General tab, PBX Integration dialog (VMSC - MAS), 4-38
Extension number
   Telephone Properties dialog (CA), 6-34
   Telephone Properties dialog (VVE), 5-8
   Tools, Sites Configuration dialog VMSC-VMD), 3-21
Extension of First Port in DMID Hunt Chain
   Serial NEC/Ericsson/DMID tab, PBX Integration dialog (VMSC - MAS), 4-42

F
Failed Outgoing Calls
   Hourly Statistics Report (RT), 7-12
Failed TUI Password Validations
   Counter for MM MAS (SPM), 9-13
Fast Forward
   Prompt tab, Properties dialog (CA), 6-61
   Fast Forward (VVE), 5-26
Fault Monitor - Generate Dump
   Add Task dialog (VMSC - VMD), 3-109
   Tasks tab, Security Roles dialog (VMSC - VMD), 3-97
Fault Monitor - View
   Add Task dialog (VMSC - VMD), 3-109
   Tasks tab, Security Roles dialog (VMSC - VMD), 3-101
Fax
   Message Servers dialog (VMSC - VMD), 3-112
   Usage tab, Port Groups dialog (VMSC - MAS), 4-32
Fax - Administer
   Add Task dialog (VMSC - VMD), 3-106
   Tasks tab, Security Roles dialog (VMSC - VMD), 3-97
Fax - View
   Add Task dialog (VMSC - VMD), 3-106
   Tasks tab, Security Roles dialog (VMSC - VMD), 3-101
Fax Configuration, 3-86
Fax Cover Page dialog (VMSC - VMD), 3-83
Fax dialog (VMSC - VMD), 3-7, 3-80
Fax Enable
  General tab, Fax dialog (VMSC - VMD), 3-81
Fax Mailbox
  General tab, Fax dialog (VMSC - VMD), 3-81
Fax Receive Speed
  General tab, Fax dialog (VMSC - VMD), 3-81
Fax Send Speed
  General tab, Fax dialog (VMSC - VMD), 3-81
Feature
  Text-to-Speech tab, Licensing dialog (VMSC - VMD), 3-203
Field Type Settings
  Inband Protocol Settings dialog (VMSC - MAS), 4-48
Filler Character
  Inband tab, PBX Integration dialog (VMSC - MAS), 4-45
  Serial NEC/Ericsson/DMID tab, PBX Integration dialog (VMSC - MAS), 4-42
First Port Number
  Serial NEC/Ericsson/DMID tab, PBX Integration dialog (VMSC - MAS), 4-42
Fixed Field Length
  Inband Protocol Settings dialog (VMSC - MAS), 4-49
Fixed Length Packets
  Inband tab, PBX Integration dialog (VMSC - MAS), 4-44
Flash Time Interval (ms)
  Call Transfer tab, PBX Configuration dialog (VMSC - VMD)
    Dialogic Analog, 3-124
Flow Control
  Serial Settings dialog (VMSC - MAS), 4-40
Format
  Export dialog (RT), 7-30
From
  Basic Metrics dialog (RT), 7-27
  Events View tab, Options dialog (OHV), 8-22
  Hourly Statistics dialog (RT), 7-11
  Login Failures dialog (RT), 7-13
  Port Statistics dialog (RT), 7-15
  Properties dialog box (Aud), 10-9
  Session Properties dialog (OHV), 8-18
  System Usage dialog (RT), 7-19
  User Mailbox Statistics dialog (RT), 7-23
From/To
  Start On-Demand MWI Update dialog (VMSC - VMD), 3-79
Full
  Call Transfer tab, PBX Configuration dialog (VMSC - VMD), 3-123
  General tab, Messaging dialog (VMSC - VMD), 3-176
Site Configuration dialog (VMSC - VMD), 3-20
Transfer/Outcall tab, PBX Configuration dialog (VMSC - VMD)
  IP H.323, 3-149
  IP SIP, 3-156
  QSIG, 3-132
  Set Emulation, 3-141

G
G.711 μ-law (mu-law)
  Audio Encoding dialog (VMSC - VMD), 3-169
  Outgoing Call tab, PBX Configuration dialog (VMSC - VMD)
    IP H.323, 3-151
    QSIG, 3-134
    QSIG Options dialog (SPM), 9-9
    Visual Voice Editor (VVE), 5-6
G.711 A-law
  Audio Encoding dialog (VMSC - VMD), 3-169
  Outgoing Call tab, PBX Configuration dialog (VMSC - VMD)
    IP H.323, 3-151
    QSIG, 3-134
    QSIG Options dialog (SPM), 9-9
    Visual Voice Editor (VVE), 5-6
Gateway Addresses
  IP SIP tab, PBX Configuration dialog (VMSC - VMD), 3-158
General Call Information
  System Usage Report (RT), 7-20
General Information
  Basic Metrics Report (RT), 7-28
General tab
  Auditing dialog (VMSC - VMD), 3-114
  Call Me dialog (VMSC - VMD), 3-69
  Dialing Rules dialog (VMSC - VMD), 3-170
  Fax dialog (VMSC - VMD), 3-81
  Licensing dialog (VMSC - VMD), 3-202
  Message Waiting Indicator dialog (VMSC - VMD), 3-75
  Messaging dialog (VMSC - MAS), 4-12
  Messaging dialog (VMSC - VMD), 3-176
  Notify Me dialog (VMSC - VMD), 3-71
  PBX Configuration dialog (VMSC - VMD)
    Dialogic Analog, 3-122
    IP SIP, 3-155
    QSIG, 3-131
    Set Emulation, 3-140
  PBX Integration dialog (VMSC - MAS), 4-36
  PBX Type dialog (VMSC - MAS), 4-61
Port Groups dialog (VMSC - MAS), 4-29
Serviceability dialog (VMSC - MAS), 4-62 to 4-63
Serviceability dialog (VMSC - VMD), 3-191
Telephone User Interface dialog (VMSC - VMD), 3-40
Telephony Interface dialog (VMSC - MAS)
  IP H.323/IP SIP, 4-23
  QSIG, 4-17
  Set Emulation, 4-19
  Tracing System dialog (VMSC - VMD), 3-208
  Web Subscriber Options dialog (VMSC - VMD), 3-187
General tab, Properties dialog (CA), 6-44
Generated report should be
  Options dialog (RT), 7-10
Generic Traps (VMSC - VMD), 3-200
Give incoming call priority to
  Subscriber tab, Telephone User Interface dialog (VMSC - VMD), 3-51
Go Off Hook when Port Disabled
  General tab, PBX Configuration dialog (VMSC - VMD)
    Dialogic Analog, 3-122
Goto
  Add Node dialog (CA), 6-41
  General tab, Properties dialog (CA), 6-45
Goto Action Type
  General tab, Properties dialog (CA), 6-50
Goto/Insert Prompt dialog (VVE), 5-21
Granted Access
  Email Domain Restrictions tab, Web Subscriber Options dialog (VMSC - VMD), 3-188
Greeting start times
  TUI tab, Site Properties dialog (VMSC - VMD), 3-30

H
Hangup Detection tab
  PBX Configuration dialog (VMSC - VMD)
    Dialogic Analog, 3-125
Hangup String
  Hangup Detection tab, PBX Configuration dialog (VMSC - VMD)
    Dialogic Analog, 3-125
Hangup String Timeout (ms)
  Hangup Detection tab, PBX Configuration dialog (VMSC - VMD)
    Dialogic Analog, 3-125
Holidays tab
  Auto Attendant dialog (VMSC - VMD), 3-65
  Home Message Application Server
    General tab, Tracing System dialog (VMSC - VMD), 3-208
  Options dialog (VMSC - VMD), 3-15
  Hourly Statistics dialog (RT), 7-11
  Hourly Statistics Report (RT), 7-12
  Hunt Group
    General tab, Site Properties dialog (VMSC - VMD), 3-29

I
ID
  Site Configuration dialog (VMSC - VMD), 3-19
Idle
  Port Monitor window (SPM), 9-5
IMAP4
  Message Servers dialog (VMSC - VMD), 3-112
IMAPI
  Message Servers dialog (VMSC - VMD), 3-112
Immediate Transfer
  Inband Protocol Settings dialog (VMSC - MAS), 4-48
Import License menu command (VMSC), 3-204
In Transfer
  Port Monitor window (SPM), 9-5
Inactive
  General tab, Serviceability dialog (VMSC - VMD), 3-191
  SNMP Trap Destinations tab, Serviceability dialog (VMSC - VMD), 3-195
INADS
  SNMP Trap Destinations tab, Serviceability dialog (VMSC - VMD), 3-194
INADS (Logs), 11-2
Inband
  General tab, PBX Integration dialog (VMSC - MAS), 4-37
  Inband Protocol Settings dialog (VMSC - MAS)
    PBX Integration, 4-47
  Inband Request Digit String
    Inband tab, PBX Integration dialog (VMSC - MAS), 4-46
Inband tab
  PBX Integration dialog (VMSC - MAS), 4-43
  Inbound Calls Counter
    Counter for MM MAS Voice Port (SPM), 9-15
  Inbound SNMP Port Number
    General tab, Serviceability dialog (VMSC - MAS), 4-64
Incall Key
  ACD tab, Telephony Interface dialog (VMSC - MAS) Set Emulation, 4-21
Index

Incoming
- General tab, Port Groups dialog (VMSC - MAS), 4-29

Incoming Call Summary
- System Usage Report (RT), 7-21

Incoming Calls
- Counter for MM MAS (SPM), 9-13
- Hourly Statistics Report (RT), 7-12
- Port Statistics Reports (RT), 7-17

Incoming Calls Xfered to Ext
- User Mailbox Statistics Report (RT), 7-25

Incoming Ring Count
- Analog tab, Telephony Interface dialog (VMSC - MAS), 4-16

Incoming translation rule
- PBX Configuration - SIP Tab (IP SIP), Translation Rules Dialog (VMSC - VMD), 3-162

Incorrect PW or incorrect Mailbox #s
- Basic Metrics Report (RT), 7-29

Indicator Off
- MWI Settings dialog (VMSC - MAS), 4-50

Indicator On
- MWI Settings dialog (VMSC - MAS), 4-50

Indicator On/Off signals must use the same port
- MWI Settings dialog (VMSC - MAS), 4-50
- QSIG/SE tab, PBX Integration dialog (VMSC - MAS), 4-53

Individual Port Statistics
- Port Statistics Reports (RT), 7-17

Info
- General tab, Licensing dialog (VMSC - VMD), 3-202
- Properties dialog (CA)
  - Analyzed Deployed Applications node, 6-75

Inform Subscriber Transfer is from Auto Attendant Receptionist tab, Telephone User Interface dialog (VMSC - VMD), 3-43

Information
- Columns tab, Options dialog (OHV), 8-23
- Operation History Viewer window (OHV), 8-15
- Session Properties dialog (OHV), 8-18

Information on each port configured in the VMD
- Port Statistics Reports (RT), 7-17

Information on incoming and outgoing calls
- Hourly Statistics Report (RT), 7-12

Initiate Blind Transfer
- Transfer/Outcall tab, PBX Configuration dialog (VMSC - VMD), Set Emulation, 3-141

Initiate Transfer
- Transfer/Outcall tab, PBX Configuration dialog (VMSC - VMD), Set Emulation, 3-141

Installed
- General tab, Web Subscriber Options dialog

Integration Data Missing
- Counter for MM MAS (SPM), 9-13

Integration Type
- General tab, PBX Integration dialog (VMSC - MAS), 4-36

Integration Unknown
- Counter for MM MAS (SPM), 9-13

Intercom Paging Code
- Intercom Paging tab, PBX Configuration dialog (VMSC - VMD)
  - Dialogic Analog, 3-126
  - QSIG, 3-136
  - Set Emulation, 3-144

Intercom Paging tab
- PBX Configuration dialog (VMSC - VMD)
  - Brooktrout Analog, 3-126
  - QSIG, 3-136
  - Set Emulation, 3-144

International
- Outgoing Call tab, PBX Configuration dialog (VMSC - VMD)
  - IP H.323, 3-151
  - QSIG, 3-134
  - QSIG Options dialog (SPM), 9-9

International Code
- Access Codes dialog (VMSC - VMD), 3-85
- Dialing Rules dialog (VMSC - VMD), 3-171

International regions including Europe
- Modular Messaging Software Caller Apps Properties dialog (CA), 6-34

Internet
- General tab, Serviceability dialog (VMSC - VMD), 3-192
- Internet Proxies tab
  - Serviceability dialog (VMSC - VMD), 3-199

Interval
- Personal Operator Schedules tab, Telephone User Interface dialog (VMSC - VMD), 3-55
- Update Schedule tab, Message Waiting Indicator dialog (VMSC - VMD), 3-77

Invalid
- Attendant Main Menu Editor tab, Auto Attendant dialog (VMSC - VMD), 3-63
- Auto Attendant Keys tab, Site Properties dialog (VMSC - VMD), 3-36

IP
- General tab, PBX Integration dialog (VMSC - MAS), 4-36

IP Address
- Avaya C-LAN tab, PBX Integration dialog (VMSC - MAS), 4-55

IP Address/FQDN
- IP tab, PBX Integration dialog (VMSC -
Index

**MAS**, 4-60
**IP Address/Host**
- Query Originators tab
  - Serviceability dialog (VMSC - VMD), 3-198
- SNMP Trap Destinations tab, Serviceability dialog (VMSC - VMD), 3-194
**IP H.323**, 3-147, 3-149 to 3-151, 4-23, 4-56
**IP H.323 tab**
- PBX Integration dialog (VMSC - MAS), 4-56
**IP SIP**, 3-153, 3-155 to 3-157, 4-23, 4-59
**IP SIP tab**
- PBX Integration dialog (VMSC - MAS), 4-59
**IP Supported Codecs**
- IP H.323 tab, PBX Integration dialog (VMSC - MAS), 4-58
**ISDN/Telephony E.164/E.163**
- Outgoing Call tab, PBX Configuration dialog (VMSC - VMD)
  - IP H.323, 3-152
  - QSIG, 3-135
- QSIG Options dialog (SPM), 9-9

**K**

**Key**
- Auto Attendant tab, Site Properties dialog (VMSC - VMD), 3-34
**Key press**
- Add Node dialog (CA), 6-41
**Key Settings**
- Attendant Main Menu Editor tab, Auto Attendant dialog (VMSC - VMD), 3-63

**L**

**Language**
- Auto Attendant tab, Site Properties dialog (VMSC - VMD), 3-34
- New Caller Application dialog (CA), 6-38
**Language 1, 2, 3**
- Language/Key Association tab, Auto Attendant dialog (VMSC - VMD), 3-67
**Language/Key Association tab**
- Auto Attendant dialog (VMSC - VMD), 3-67
**Languages - Administer**
- Add Task dialog (VMSC - VMD), 3-107
  - Tasks tab, Security Roles dialog (VMSC - VMD), 3-97
**Languages - View**
- Add Task dialog (VMSC - VMD), 3-107
  - Tasks tab, Security Roles dialog (VMSC - VMD), 3-101
- Languages dialog (VMSC - MAS), 4-13
- Languages dialog (VMSC - VMD), 3-166
- Languages in caller application
  - Languages tab, Properties dialog (CA), 6-66
- Languages tab, Properties dialog (CA), 6-66
- Last 30 Days
  - Properties dialog box (Aud), 10-9
- Last 7 Days
  - Properties dialog box (Aud), 10-9
- Last Failed Login
  - Login Failures Report (RT), 7-14
- Lastname, Firstname
  - Dial By Name tab, Telephone User Interface dialog (VMSC - VMD), 3-58
- Launching the Visual Voice Editor (VVE), 5-7
  - Layer 1 Protocol
    - QSIG Options dialog (SPM), 9-9
  - Layer 1 Protocol
    - Outgoing Call tab, PBX Configuration dialog (VMSC - VMD)
      - IP H.323, 3-151
      - QSIG, 3-134
- LDAP
  - Message Servers dialog (VMSC - VMD), 3-112
  - Leave failed zero-out messages in
    - Receptionist tab, Telephone User Interface dialog (VMSC - VMD), 3-45
  - Left a Message for a Subscriber
    - System Usage Report (RT), 7-20
- Length
  - Prompts View
    - Visual Voice Editor window (VVE), 5-21
- Licensing - Administer
  - Add Task dialog (VMSC - VMD), 3-108
  - Tasks tab, Security Roles dialog (VMSC - VMD), 3-98
- Licensing - View
  - Add Task dialog (VMSC - VMD), 3-108
  - Tasks tab, Security Roles dialog (VMSC - VMD), 3-101
- Licensing dialog (VMSC - VMD), 3-201
- Limit
  - General tab, Licensing dialog (VMSC - VMD), 3-202
- Limit requests
  - General tab, Message Waiting Indicator dialog (VMSC - VMD), 3-75
- Line busy retries
  - General tab, Call Me dialog (VMSC - VMD), 3-70
- Line Speed (Bits per Second)
  - Serial Settings dialog (VMSC - MAS), 4-40
## Index

<table>
<thead>
<tr>
<th>Link Down</th>
<th>Generic Traps (VMSC-VMD), 3-200</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link Up</td>
<td>Generic Traps (VMSC-VMD), 3-200</td>
</tr>
<tr>
<td>List Files of Type</td>
<td>Export Operation History Events dialog (OHV), 8-26</td>
</tr>
<tr>
<td>Live Mode</td>
<td>Session Properties dialog (OHV), 8-18</td>
</tr>
<tr>
<td>Local</td>
<td>Outgoing Call tab, PBX Configuration dialog (VMSC - VMD)</td>
</tr>
<tr>
<td></td>
<td>IP H.323, 3-152</td>
</tr>
<tr>
<td></td>
<td>QSIG, 3-135</td>
</tr>
<tr>
<td></td>
<td>QSIG Options dialog (SPM), 9-9</td>
</tr>
<tr>
<td>Local Fax Printer</td>
<td>3-80</td>
</tr>
<tr>
<td>Local Offline Message Store (VMSC)</td>
<td>3-180</td>
</tr>
<tr>
<td>Local Server Languages Installed</td>
<td>Server Languages tab, Languages dialog (VMSC - MAS), 4-13</td>
</tr>
<tr>
<td>Location of Inband Reason Code</td>
<td>Inband tab, PBX Integration dialog (VMSC - MAS), 4-44</td>
</tr>
<tr>
<td>Log Inband Packets</td>
<td>Inband tab, PBX Integration dialog (VMSC - MAS), 4-44</td>
</tr>
<tr>
<td>Log Serial Packets</td>
<td>Serial General tab, PBX Integration dialog (VMSC - MAS), 4-39</td>
</tr>
<tr>
<td>Login Failures before Lockout</td>
<td>Subscriber tab, Telephone User Interface dialog (VMSC - VMD), 3-51</td>
</tr>
<tr>
<td>Login Failures dialog (RT)</td>
<td>7-13</td>
</tr>
<tr>
<td>Login Failures Report (RT)</td>
<td>7-14</td>
</tr>
<tr>
<td>Login Failures (Offline)</td>
<td>Counter for MM MAS (SPM), 9-13</td>
</tr>
<tr>
<td>Logon to mailbox</td>
<td>General tab, Properties dialog (CA), 6-54</td>
</tr>
<tr>
<td>Logons</td>
<td>User Mailbox Statistics Report (RT), 7-25</td>
</tr>
<tr>
<td>Logons Aborted After Delay</td>
<td>Counter for MM MAS (SPM), 9-13</td>
</tr>
<tr>
<td>Long Distance Code</td>
<td>Access Codes dialog (VMSC - VMD), 3-85</td>
</tr>
<tr>
<td></td>
<td>Dialing Rules dialog (VMSC - VMD), 3-171</td>
</tr>
<tr>
<td>Lotus 1-2-3 (WK1/WK3/WKS)</td>
<td>Export dialog (RT), 7-30</td>
</tr>
</tbody>
</table>

### M

| Mail Server Name          | General tab, Messaging dialog (VMSC - MAS), 4-12 |

### Mailbox

| Auto Attendant Keys tab, Site Properties dialog (VMSC - VMD), 3-37 |
| Columns tab, Options dialog (OHV), 8-23 |
| Event Properties dialog (OHV), 8-20 |
| General tab, Properties dialog (CA) |
| Send Message Action Type, 6-52 |
| Transfer Action Type, 6-48 |
| Operation History Viewer window (OHV), 8-15 |
| Session Properties dialog (OHV), 8-19 |
| Start On-Demand MWI Update dialog (VMSC - VMD), 3-79 |

### Mailbox Activity

| Session Properties dialog (OHV), 8-18 |

### Mailbox Name

| Login Failures Report (RT), 7-14 |
| User Mailbox Statistics Report (RT), 7-25 |

### Mailbox Number

| Attendant Main Menu Editor tab, Auto Attendant dialog (VMSC - VMD), 3-64 |
| Login Failures Report (RT), 7-14 |
| Site Configuration dialog (VMSC - VMD), 3-19 |
| User Mailbox Statistics dialog (RT), 7-24 |

### Mailbox number

| Add Association/Association Properties dialog (CA), 6-72 |
| Telephone Properties dialog (VVE), 5-8 |
| Tools, Sites Configuration dialog VMSC-VMD, 3-21 |

### Mailbox Numbers

| User Mailbox Statistics dialog (RT), 7-23 |

### Mailbox references

| Properties dialog (CA) |
| Analyzed Deployed Applications node, 6-75 |

### Mailbox Specific Statistics

| User Mailbox Statistics Report (RT), 7-25 |

### Mailboxes in the following range

| Start On-Demand MWI Update dialog (VMSC - VMD), 3-79 |

### Main Menu Greeting 1, 2, 3

| Language/Key Association tab, Auto Attendant dialog (VMSC - VMD), 3-68 |

### Maintenance event logs (Logs)

| Maintenance event logs (Logs), 11-3 |

### Major

| General tab, Serviceability dialog (VMSC - VMD), 3-192 |

### Make Call Prefix

| Transfer/Outcall tab, PBX Configuration dialog (VMSC - VMD) Set Emulation, 3-142 |

### MAS

| Event Properties dialog (OHV), 8-20 |
| Session Properties dialog (OHV), 8-19 |
MAS Corporate IP Address
   IP H.323 tab, PBX Integration dialog (VMSC - MAS), 4-56

MAS Fax Sender Server
   General tab, Fax dialog (VMSC - VMD), 3-81

MAS Listen Protocols
   IP SIP tab, PBX Integration dialog (VMSC - MAS), 4-60

MAS MWI server
   General tab, Message Waiting Indicator dialog (VMSC - VMD), 3-75

MAS Tracing Server Machine Name
   General tab, Tracing System dialog (VMSC - VMD), 3-208

MASAd-VMSC-VMD-Tel, 3-38
MASAll.bkf (MAS Intro), 1-11
MASSingle.bkf (MAS Intro), 1-12

Match names using
   Dial By Name tab, Telephone User Interface dialog (VMSC - VMD), 3-58

Max Concurrent Outgoing Calls
   Advanced Fax dialog (VMSC - VMD), 3-84

Max MWI Sessions
   IP H.323 tab, PBX Integration dialog (VMSC - MAS), 4-57
   MWI Settings dialog (VMSC - MAS), 4-50
   QSIG/SE tab, PBX Integration dialog (VMSC - MAS), 4-52

Max no. retries
   Advanced Fax dialog (VMSC - VMD), 3-84

Max Pages Per Fax
   Advanced Fax dialog (VMSC - VMD), 3-84

Max Time to Wait for Serial and Remote Integration Data (sec)
   General tab, PBX Integration dialog (VMSC - MAS), 4-37

Maximum Call Duration in Minutes
   General tab, Telephone User Interface dialog (VMSC - VMD), 3-41

Maximum Concurrent Calls
   General tab, Telephony Interface dialog (VMSC - MAS)
   IP H.323/IP SIP, 4-23
   QSIG, 4-17
   Set Emulation, 4-20

Maximum Continuous Tone before Hanging Up (ms)
   Hangup Detection tab, PBX Configuration dialog (VMSC - VMD)
   Dialogic Analog, 3-125

Maximum Inter-digit Gap (ms)
   Inband tab, PBX Integration dialog (VMSC - MAS), 4-43

Maximum Mailbox Prompt Length in Seconds
   Message Timing tab, Telephone User Interface dialog (VMSC - VMD), 3-48

Maximum number of concurrent calls
   General tab, Call Me dialog (VMSC - VMD), 3-70

Maximum Number of Digits in a PBX Extension
   General tab, Telephone User Interface dialog (VMSC - VMD), 3-42

Maximum Number of Errors
   Receptionist tab, Telephone User Interface dialog (VMSC - VMD), 3-44

Maximum Number of No Entries
   Receptionist tab, Telephone User Interface dialog (VMSC - VMD), 3-44

Maximum Number of Remote Service Sessions
   Avaya C-LAN tab, PBX Integration dialog (VMSC - MAS), 4-55
   Serial General tab, PBX Integration dialog (VMSC - MAS), 4-38

Maximum requests per minute
   General tab, Message Waiting Indicator dialog (VMSC - VMD), 3-76

Maximum Silence Before Hanging Up (ms)
   Hangup Detection tab, PBX Configuration dialog (VMSC - VMD)
   Dialogic Analog, 3-125
   Tone Detection tab, PBX Configuration dialog (VMSC - VMD)
   IP H.323, 3-150
   IP SIP, 3-157
   QSIG, 3-133
   Set Emulation, 3-143

Maximum Tone Before Hanging Up (ms)
   Tone Detection tab, PBX Configuration dialog (VMSC - VMD)
   Set Emulation, 3-143

Mbox#
   User Mailbox Statistics Report (RT), 7-25

Media Setup tab
   Modular Messaging User Properties dialog (VVE), 3-21, 5-8

Members
   Members tab, Security Roles dialog (VMSC - VMD), 3-95

Members tab
   Security Roles dialog (VMSC - VMD), 3-94

Menu
   Add Node dialog (CA), 6-40
   General tab, Properties dialog (CA), 6-45

June 2009
Avaya Modular Messaging Release 5.1 with the Avaya MSS
MAS Administration Guide
Index

Menu Action Type
  General tab, Properties dialog (CA), 6-46
Menu Commands (Aud)
  Action > Connect to Database, 10-8
  Action > Export List, 10-6
  Action > New Log View, 10-6
  Action > Properties, 10-9
Menu Commands (CA)
  Action > All Tasks > Deploy Caller Application, 6-69
  Action > Change Access Key, 6-67
  Action > Close Application, 6-26
  Action > Connect to Message Application Server, 6-68
  Action > Copy Application ID, 6-31
  Action > Delete Application (Action) Node, 6-29
  Action > Refresh, 6-30 to 6-33
  Action > Open Application, 6-25, 6-36
  Action > Properties Application (Action) Node, 6-43
  Action > New > Application Node, 6-40
  Action > New > Association, 6-71
  Action > New > Caller Application, 6-38
  Action > Open Application, 6-25
  Action > Properties Association, 6-71, 6-73 to 6-74
  Action > Properties Caller Application, 6-43
  General, 6-34
Menu Commands (OHV)
  Edit > Copy, 8-28
  File > Close, 8-27
  File > Data Source, 8-5, 8-7
  File > Export, 8-26
  File > New, 8-17
  File > Open, 8-15
  File > Options, 8-21
  File > Pause, 8-16
  File > Resume, 8-16
  File > Save Application, 6-26
  File > Save Application As, 6-26
  File > Set Application Start, 6-27
Menu Commands (RT)
  File > Exit, 7-34
  File > Export, 7-30
  File > Options, 7-10
  File > Print, 7-9
  Help > About Modular Messaging, 7-35
  Help > Help Topics, 7-35
  Reports > Basic Metrics, 7-27
  Reports > Hourly Statistics, 7-11
  Reports > Login Failures, 7-13
  Reports > Port Statistics, 7-15
  Reports > System Usage, 7-19
  Reports > User Mailbox Statistics, 7-23
  View > Zoom, 7-9
Menu Commands (SPM)
  Change State > Disable, 9-6
  Change State > Disable Immediately, 9-6
  Change State > Enable, 9-6
  File > Exit, 9-7
  Help > About Port Monitor, 9-7
  Help > Help Topics, 9-7
  Options > Always on Top, 9-7
  Options > Port, 9-7
  Options > Select Another Server, 9-3
  Tools > Options Dialogic Line Test Application, 9-9
  View > Status Bar, 9-7
  View > Toolbar, 9-7
Menu Commands (VMSC)
  Edit > Add Message Application Server, 4-7
  Edit > Add PBX Type, 3-118
  Edit > New Voice Mail Domain, 3-12
  Edit > Refresh Domain Languages, 4-8
  Edit > Remove Message Application Server, 4-8
  Edit > Remove PBX Type, 3-117, 3-119
  Edit > Remove Voice Mail Domain, 3-13
  Edit > Rename Voice Mail Domain, 3-14
  Edit > Telephony Configuration Wizard, 4-10
  Tools > Options, 3-15
Menu Commands (VVE)
  Edit > Copy, 5-25
  Edit > Cut, 5-25
  Edit > Goto, 5-22
  Edit > Insert, 5-21
  Edit > Paste, 5-25
  Edit > Select All, 5-25
  Edit > Trim, 5-25
  Edit > Undo, 5-25
  File > Close, 5-28
  File > Compact, 5-28
  File > Exit, 5-28
  File > Export, 5-28
Index

File > Import, 5-28
File > Open, 5-10, 5-28
File > Print, 5-22
File > Print Setup, 5-28
File > Save, 5-28
File > Save As, 5-28
Help > About Visual Voice Editor, 5-32
Help > Help Topics, 5-32
Sound > Pause, 5-26
Sound > Play, 5-26
Sound > Preferences, 5-27
Sound > Record, 5-26
Sound > Skip Back, 5-26
Sound > Skip Forward, 5-26
Sound > Stop, 5-26
Sound > Volume Down, 5-27
Sound > Volume Up, 5-27
View > Comments View, 5-21
View > Prompts View, 5-21
View > Status Bar, 5-30
View > Toolbar, 5-30
View > Waveform View, 5-23
View > Zoom In, 5-24
View > Zoom Out, 5-24
Waveform > Decrease Amplitude, 5-24
Waveform > Increase Amplitude, 5-24
Waveform > Insert Silence, 5-24
Waveform > Overwrite Silence, 5-24
Window > Comment, 5-21
Window > Detailed, 5-24
Window > Overview, 5-24
Window > Prompt, 5-21

Menu only
General tab, Properties dialog (CA), 6-46
Menu options
General tab, Properties dialog (CA), 6-46
Menu with caller application
General tab, Properties dialog (CA), 6-46
Menu with extension
General tab, Properties dialog (CA), 6-46
Menu with mailbox
General tab, Properties dialog (CA), 6-46
Menus in the VMSC, 2-6
Message
Attendant Main Menu Editor tab, Auto Attendant dialog (VMSC - VMD), 3-64
Auto Attendant Keys tab, Site Properties dialog (VMSC - VMD), 3-37
Event Properties dialog (OHV), 8-20
Message Application Server
Add New Message Application Server dialog (VMSC - MAS), 4-7
Columns tab, Options dialog (OHV), 8-23
Message Application Server dialog (CA), 6-68
Operation History Viewer window (OHV), 8-15
Session Properties dialog (OHV), 8-17
Message Application Server name
Telephone Properties dialog (CA), 6-34
Telephone Properties dialog (VVE), 5-9
Tools, Sites Configuration dialog
VMSC-VMD), 3-21
Message Application Servers dialog (SPM), 9-3
Message Application Servers that support MWI
General tab, Message Waiting Indicator dialog (VMSC - VMD), 3-76
Message Server Number
Avaya C-LAN tab, PBX Integration dialog (VMSC - MAS), 4-54
Message Servers
Message Servers dialog (VMSC - VMD), 3-111
Message Servers dialog
Security (VMSC - VMD), 3-111
Message Servers tab
Message Servers dialog (VMSC - VMD), 3-111
Message Summary
System Usage Report (RT), 7-22
Message Timing tab
Telephone User Interface dialog (VMSC - VMD), 3-48
Message Waiting Indicator - Administer
Add Task dialog (VMSC - VMD), 3-105
Tasks tab, Security Roles dialog (VMSC - VMD), 3-98
Message Waiting Indicator - Update Lamps
Add Task dialog (VMSC - VMD), 3-106
Tasks tab, Security Roles dialog (VMSC - VMD), 3-98
Message Waiting Indicator - View
Add Task dialog (VMSC - VMD), 3-106
Tasks tab, Security Roles dialog (VMSC - VMD), 3-101
Message Waiting Indicator dialog (VMSC - VMD), 3-73
Messages Left for User
User Mailbox Statistics Report (RT), 7-25
Messaging - Administer
Add Task dialog (VMSC - VMD), 3-107
Tasks tab, Security Roles dialog (VMSC - VMD), 3-98
Messaging - View
Add Task dialog (VMSC - VMD), 3-108
Tasks tab, Security Roles dialog (VMSC - VMD), 3-102
Messaging dialog (VMSC - MAS), 4-11
Messaging dialog (VMSC - VMD), 3-174
Microsoft Fax Printer Configuration (VMSC - VMD), 3-86
Microsoft GSM 6.10
  Audio Encoding dialog (VMSC - VMD), 3-169
Microsoft Mail (MAPI)
  Export dialog (RT), 7-31
Minimum Duration for Drop in Loop Current (ms)
  Hangup Detection tab, PBX Configuration dialog (VMSC - VMD), Dialogic Analog, 3-125
Minimum Message Length in Seconds
  Message Timing tab, Telephone User Interface dialog (VMSC - VMD), 3-49
Minimum Password Length
  Subscriber tab, Telephone User Interface dialog (VMSC - VMD), 3-50
Minor
  General tab, Serviceability dialog (VMSC - VMD), 3-192
MM Audit Log Viewer (Aud), 1-9, 10-4
MM Audit Server (Aud), 10-2
MM Audit Service (Aud), 10-2
MM Fax Service Provider, 3-80, 3-86
MM IMAPI 1 (MAS Alarms), A-5 to A-6
MM MAS (SPM), 9-13
MM MAS MWI Activity (SPM), 9-14
MM MAS Service (SPM), 9-15
MM MAS Voice Port (SPM), 9-15
MM MWI Server (SPM), 9-15
MM MWI Server Queue (SPM), 9-15
MM PERF 17 (MAS Alarms), A-7
MM PERF 18 (MAS Alarms), A-8
MM Services, 1-2
Avaya SPIRIT, C-2
  MM Alarming Server, C-1
  MM Audit Server, 3-114, C-2
  MM Audit Service, 3-114, C-2
  MM Call Me Server, 3-69, 3-71, 3-181, C-2
  MM Event Monitor Server, C-1
  MM Fault Monitor, C-1
  MM Fax Sender Server, 3-80, 3-86, C-2
  MM Mailbox Monitor, 3-69, 3-112, 3-181, C-2
  MM Message Waiting Indicator, C-2
  MM Message Waiting Indicator Server, 3-73, 3-75, 3-181
  MM Messaging Application Server, 3-3, 3-112, 3-126, 3-136, 3-144, 3-165, 3-168, 3-203, 3-205, 4-2, 4-7, 4-16, 4-40, 4-43, 4-51 to 4-52, 4-54, 4-56, 4-59, C-1
  MM Performance Monitor Server, C-1
  MM Process Monitor Server, C-1
  MM Service Connector, C-1
  MM Tracing Server, 3-206, 3-208, C-2
  Stopping/Restarting, C-3
MM Shared Fax Driver, 3-86
MMSnap, 1-8
Modem Configuration tab
  Serviceability dialog (VMSC - MAS), 4-65
Modem dialout
  General tab, Serviceability dialog (VMSC - VMD), 3-192
Modem setup
  Modem Configuration tab, Serviceability dialog (VMSC - MAS), 4-66
Modify
  Dialing Rules dialog (VMSC - VMD), 3-171
Modular Messaging Mailboxes
  General tab, Licensing dialog (VMSC - VMD), 3-202
Modular Messaging Objects (SPM), 9-12
Modular Messaging Password Policy Editor, 1-5
Modular Messaging Services, C-1
Modular Messaging Snapshot Utility, 1-8
Modular Messaging Software Caller Apps Node (CA), 6-25
Modular Messaging Software Caller Apps Properties dialog (CA), 6-34
Modular Messaging User Properties dialog (VVE), 5-8
Morning Prompt
  Time of Day tab, Auto Attendant dialog (VMSC - VMD), 3-66
Move
  Columns tab, Options dialog (OHV), 8-23
  General tab, Message Waiting Indicator dialog (VMSC - VMD), 3-76
  IP H.323 tab, PBX Integration dialog (VMSC - MAS), 4-58
  Syslog tab, Auditing dialog (VMSC - VMD), 3-116
MSB Key
  ACD tab, Telephony Interface dialog (VMSC - MAS) Set Emulation, 4-21
MSB Lamp
  ACD tab, Telephony Interface dialog (VMSC - MAS) Set Emulation, 4-21
Index

MT ABS_PROC 1 (MAS Alarms), A-11
MT ABS_PROC 2 (MAS Alarms), A-12
MT ABS_PROC 3 (MAS Alarms), A-13
MT ABS_PROC 4 (MAS Alarms), A-14
MT ABS_PROC 5 (MAS Alarms), A-15
MT ABS_PROC 6 (MAS Alarms), A-16
MT ABS_PROC 7 (MAS Alarms), A-17
MT ABS_PROC 8 (MAS Alarms), A-18
MT ALARM_ORIG 0 (MAS Alarms), A-19
MT ALARM_ORIG 1 (MAS Alarms), A-20
MT OHDB 1 (MAS Alarms), A-21
MT PERF 10 (MAS Alarms), A-24
MT PERF 19 (MAS Alarms), A-25
MT PERF 24 (MAS Alarms), A-26
MT PERF 25 (MAS Alarms), A-27
MT PERF 26 (MAS Alarms), A-28
MT PERF 27 (MAS Alarms), A-29
MT PERF 6 (MAS Alarms), A-22
MT PERF 7 (MAS Alarms), A-23

Multilingual greetings
Auto Attendant tab, Site Properties dialog (VMSC - VMD), 3-33

Multimedia
Modular Messaging Software Caller Apps Properties dialog (CA), 6-34
Modular Messaging User Properties dialog (VVE), 5-8
Prompt tab, Properties dialog (CA), 6-60
Telephone
Options dialog (VMSC - VMD), 3-21
Voice Player (VMSC-VMD), 3-20
Voice Player (VVE), 5-26

MultiSite - Administer
Tasks tab, Security Roles dialog (VMSC - VMD), 3-100

MultiSite - View
Tasks tab, Security Roles dialog (VMSC - VMD), 3-103

MultiSite Enable
Tasks tab, Security Roles dialog (VMSC - VMD), 3-96

MW PERF 15 (MAS Alarms), A-34
MW PERF 16 (MAS Alarms), A-35

MWI
IP SIP tab, PBX Configuration dialog (VMSC - VMD), 3-158
MWI (VMSC - VMD), 3-73
MWI On/Off
QSIG/SE tab, PBX Integration dialog (VMSC - MAS), 4-53
MWI Port Group
QSIG/SE tab, PBX Integration dialog (VMSC - MAS), 4-52

MWI Settings
Inband tab, PBX Integration dialog (VMSC - MAS), 4-46
MWI Settings dialog (VMSC - MAS)
PXB Integration, 4-50

N
Name
Add Node dialog (CA), 6-40
Avaya C-LAN tab, PBX Integration dialog (VMSC - MAS), 4-54
General tab, Properties dialog (CA), 6-44
Site Configuration dialog (VMSC - VMD), 3-20

National
Outgoing Call tab, PBX Configuration dialog (VMSC - VMD)
IP H.323, 3-151
QSIG, 3-134
QSIG Options dialog (SPM), 9-9

NEC-2400
Serial NEC/Ericsson/DMID tab, PBX Integration dialog (VMSC - MAS), 4-41

Network Fax Printer, 3-80

Never
Operation History Collection tab, Tracing System dialog (VMSC - VMD), 3-209
Transaction Generation tab, Tracing System dialog (VMSC - VMD), 3-210

New Caller Application dialog (CA), 6-38

New Community
Communities tab, Serviceability dialog (VMSC - VMD), 3-196

New Value
Event Properties dialog box (Aud), 10-11
MM Audit Log Viewer (Aud), 10-7

Next
Reporting Tool window (RT), 7-9

Next node
Application tab, Properties dialog (CA), 6-64
General tab, Properties dialog (CA), 6-53

No Answer Extension
Inband Protocol Settings dialog (VMSC - MAS), 4-47

Node
General tab, Properties dialog (CA), 6-50

Nodes in the VMSC, 2-4

Non Delivery Messages
Counter for MM MAS (SPM), 9-13

None
General tab, PBX Integration dialog (VMSC - MAS), 4-36
Session Properties dialog (OHV), 8-19
Text Export tab, Options dialog (OHV), 8-24
Normal Messages (sec)
  Advanced Fax dialog (VMSC - VMD), 3-84
North America and Japan
  Modular Messaging Software Caller Apps Properties dialog (CA), 6-34
Not Selected
  Columns tab, Options dialog (OHV), 8-23
Notes
  Avaya C-LAN tab, PBX Integration dialog (VMSC - MAS), 4-55
Notification Only
  General tab, Messaging dialog (VMSC - VMD), 3-177
Notify Me - Administer
  Add Task dialog (VMSC - VMD), 3-105
  Tasks tab, Security Roles dialog (VMSC - VMD), 3-98
Notify Me - View
  Add Task dialog (VMSC - VMD), 3-105
  Tasks tab, Security Roles dialog (VMSC - VMD), 3-102
Number and Date format dialog (RT), 7-32
Number Attempts Rotary Transfer to Busy Receptionist
  Receptionist tab, Telephone User Interface dialog (VMSC - VMD), 3-44
Number length
  Dialing Rules dialog (VMSC - VMD), 3-171
  Telephony Dialing rule dialog (VMSC - VMD), 3-173
Number of Calls Placed that Were Not Answered
  System Usage Report (RT), 7-21
Number of Calls Placed to Busy Extensions
  System Usage Report (RT), 7-21
Number of Calls that Got Connected
  System Usage Report (RT), 7-21
Number of Connected Outgoing Calls Excluding Calls to Clients
  System Usage Report (RT), 7-22
Number of Days before Events Expire
  Operation History Collection tab, Tracing System dialog (VMSC - VMD), 3-209
Number of Days before Transactions Expire
  Transaction Generation tab, Tracing System dialog (VMSC - VMD), 3-210
Number of Digits in a Mailbox
  General tab, Telephone User Interface dialog (VMSC - VMD), 3-41
Number of Failed Calls to Fax Gateway
  System Usage Report (RT), 7-20
Number of Failed Outgoing Calls Excluding Calls to Clients
  System Usage Report (RT), 7-22
Number of Incoming Calls
  System Usage Report (RT), 7-20
Number of Instances
  Usage tab, Port Groups dialog (VMSC - MAS), 4-31
Number of invalid mailbox numbers entered
  Login Failures Report (RT), 7-14
Number of Modular Messaging Software Enabled Users
  Counter for MM MAS (SPM), 9-13
Number of Ports
  Analog tab, Telephony Interface dialog (VMSC - MAS), 4-16
Number of Previous Passwords Disallowed
  Subscriber tab, Telephone User Interface dialog (VMSC - VMD), 3-51
Number of Retries when No Answer
  Intercom Paging tab, PBX Configuration dialog (VMSC - VMD)
    Dialogic Analog, 3-127
    QSIG, 3-137
    Set Emulation, 3-145
Number of Retries when Paging System is Busy
  Intercom Paging tab, PBX Configuration dialog (VMSC - VMD)
    Dialogic Analog, 3-127
    QSIG, 3-137
    Set Emulation, 3-145
Number of Successful Calls to Fax Gateway
  System Usage Report (RT), 7-20
Number of Times Users Logged On
  System Usage Report (RT), 7-20
Number Plan
  Outgoing Call tab, PBX Configuration dialog (VMSC - VMD)
    IP H.323, 3-152
    QSIG, 3-135
    QSIG Options dialog (SPM), 9-9
Number Type
  Outgoing Call tab, PBX Configuration dialog (VMSC - VMD)
    IP H.323, 3-151
    QSIG, 3-134
    QSIG Options dialog (SPM), 9-9
O
OAM
  SNMP Trap Destinations tab, Serviceability dialog (VMSC - VMD), 3-195
Object
  Columns tab, Options dialog (OHV), 8-23
  Event Properties dialog (OHV), 8-20
  Event Properties dialog box (Aud), 10-11
<table>
<thead>
<tr>
<th>Index</th>
</tr>
</thead>
<tbody>
<tr>
<td>MM Audit Log Viewer (Aud), 10-7</td>
</tr>
<tr>
<td>Operation History Viewer window (OHV), 8-15</td>
</tr>
<tr>
<td>Properties dialog box (Aud), 10-10</td>
</tr>
<tr>
<td>Session Properties dialog (OHV), 8-19</td>
</tr>
<tr>
<td>Object Type</td>
</tr>
<tr>
<td>Properties dialog box (Aud), 10-10</td>
</tr>
<tr>
<td>ObjectType</td>
</tr>
<tr>
<td>Event Properties dialog box (Aud), 10-11</td>
</tr>
<tr>
<td>MM Audit Log Viewer (Aud), 10-7</td>
</tr>
<tr>
<td>Observe system holidays as after hours</td>
</tr>
<tr>
<td>Schedule dialog (CA), 6-56</td>
</tr>
<tr>
<td>Octel Analog Networking - Administer</td>
</tr>
<tr>
<td>Add Task dialog (VMSC - VMD), 3-107</td>
</tr>
<tr>
<td>Tasks tab, Security Roles dialog (VMSC - VMD), 3-98</td>
</tr>
<tr>
<td>Octel Analog Networking - View</td>
</tr>
<tr>
<td>Add Task dialog (VMSC - VMD), 3-107</td>
</tr>
<tr>
<td>Tasks tab, Security Roles dialog (VMSC - VMD), 3-102</td>
</tr>
<tr>
<td>ODBC Data Source Administrator (OHV), 8-5</td>
</tr>
<tr>
<td>ODBC Tracing (OHV), 8-4</td>
</tr>
<tr>
<td>Offhook</td>
</tr>
<tr>
<td>Port Monitor window (SPM), 9-5</td>
</tr>
<tr>
<td>Offline Access tab</td>
</tr>
<tr>
<td>Messaging dialog (VMSC - VMD), 3-178</td>
</tr>
<tr>
<td>Offline Message Store (Offline Access tab, Messaging - VMD), 3-179</td>
</tr>
<tr>
<td>Offline Message Store Folder (VMSC), 3-182</td>
</tr>
<tr>
<td>Old Value</td>
</tr>
<tr>
<td>Event Properties dialog box (Aud), 10-11</td>
</tr>
<tr>
<td>MM Audit Log Viewer (Aud), 10-7</td>
</tr>
<tr>
<td>On-Demand MWI Refresh (VMSC), 3-78</td>
</tr>
<tr>
<td>Open</td>
</tr>
<tr>
<td>Time/Greeting tab, Telephone User Interface dialog (VMSC - VMD), 3-47</td>
</tr>
<tr>
<td>Open All Day</td>
</tr>
<tr>
<td>Time/Greeting tab, Telephone User Interface dialog (VMSC - VMD), 3-47</td>
</tr>
<tr>
<td>TUI tab, Site Properties dialog (VMSC - VMD), 3-31</td>
</tr>
<tr>
<td>Open Caller Application dialog (CA), 6-36</td>
</tr>
<tr>
<td>Open during</td>
</tr>
<tr>
<td>TUI tab, Site Properties dialog (VMSC - VMD), 3-31</td>
</tr>
<tr>
<td>Open new session with default options on start of application</td>
</tr>
<tr>
<td>Events View tab, Options dialog (OHV), 8-22</td>
</tr>
<tr>
<td>Open time</td>
</tr>
<tr>
<td>TUI tab, Site Properties dialog (VMSC - VMD), 3-31</td>
</tr>
<tr>
<td>Opening a Caller Application (CA), 6-9</td>
</tr>
<tr>
<td>Opening a Session (OHV), 8-11</td>
</tr>
<tr>
<td>Operation</td>
</tr>
<tr>
<td>Event Properties dialog box (Aud), 10-11</td>
</tr>
<tr>
<td>MM Audit Log Viewer (Aud), 10-7</td>
</tr>
<tr>
<td>Properties dialog box (Aud), 10-10</td>
</tr>
<tr>
<td>Operation History Collection tab</td>
</tr>
<tr>
<td>Tracing System dialog (VMSC - VMD), 3-209</td>
</tr>
<tr>
<td>Operation History Database (OHV), 8-2</td>
</tr>
<tr>
<td>Operation History Database (RT), 7-2</td>
</tr>
<tr>
<td>Operation History Viewer window (OHV), 8-14</td>
</tr>
<tr>
<td>Operator</td>
</tr>
<tr>
<td>General tab, Properties dialog (CA), 6-48</td>
</tr>
<tr>
<td>Operator (VMSC - VMD), 3-43</td>
</tr>
<tr>
<td>Options</td>
</tr>
<tr>
<td>Export Operation History Events dialog (OHV), 8-26</td>
</tr>
<tr>
<td>Options dialog (OHV), 8-21</td>
</tr>
<tr>
<td>Options dialog (RT), 7-10</td>
</tr>
<tr>
<td>Options dialog (VMSC - VMD), 3-15</td>
</tr>
<tr>
<td>Options dialog (VMSC-VMD), 3-21</td>
</tr>
<tr>
<td>Origin Number</td>
</tr>
<tr>
<td>Outgoing Call tab, PBX Configuration dialog (VMSC - VMD), 3-152</td>
</tr>
<tr>
<td>QSIG, 3-135</td>
</tr>
<tr>
<td>Other</td>
</tr>
<tr>
<td>User Mailbox Statistics Report (RT), 7-25</td>
</tr>
<tr>
<td>Outbound Calls Counter</td>
</tr>
<tr>
<td>Counter for MM MAS Voice Port (SPM), 9-15</td>
</tr>
<tr>
<td>Outcall Key</td>
</tr>
<tr>
<td>ACD tab, Telephony Interface dialog (VMSC - MAS) Set Emulation, 4-21</td>
</tr>
<tr>
<td>Outcalling Restrictions</td>
</tr>
<tr>
<td>Caller tab, Telephone User Interface dialog (VMSC - VMD), 3-52</td>
</tr>
<tr>
<td>Outgoing</td>
</tr>
<tr>
<td>General tab, Port Groups dialog (VMSC - MAS), 4-29</td>
</tr>
<tr>
<td>Outgoing Call tab</td>
</tr>
<tr>
<td>PBX Configuration dialog (VMSC - VMD), 3-151</td>
</tr>
<tr>
<td>QSIG, 3-134</td>
</tr>
<tr>
<td>Outgoing Calls</td>
</tr>
<tr>
<td>Counter for MM MAS (SPM), 9-13</td>
</tr>
<tr>
<td>Hourly Statistics Report (RT), 7-12</td>
</tr>
<tr>
<td>Port Statistics Reports (RT), 7-17</td>
</tr>
<tr>
<td>Outgoing translation rule</td>
</tr>
<tr>
<td>PBX Configuration - SIP Tab (IP SIP), Translation Rules Dialog (VMSC - VMD), 3-163</td>
</tr>
<tr>
<td>Overview</td>
</tr>
<tr>
<td>Waveform View</td>
</tr>
<tr>
<td>Visual Voice Editor window (VVE), 5-24</td>
</tr>
</tbody>
</table>
Overview of Voice Mail System Configuration, 2-2

P
Packet Format
  Serial General tab, PBX Integration dialog (VMSC - MAS), 4-38
Packet Length
  Inband Protocol Settings dialog (VMSC - MAS), 4-48
Packet Settings
  Inband Protocol Settings dialog (VMSC - MAS), 4-47
Packet size (ms)
  IP H.323 tab, PBX Integration dialog (VMSC - MAS), 4-57
Packet Size Bytes
  IP SIP tab, PBX Integration dialog (VMSC - MAS), 4-59
  PBX Integration dialog (VMSC - VMD), 3-165
Paging Wait Time (sec)
  Intercom Paging tab, PBX Configuration dialog (VMSC - VMD)
    Dialogic Analog, 3-127
    QSIG, 3-137
    Set Emulation, 3-145
Parent node
  Application tab, Properties dialog (CA), 6-63
  General tab, Properties dialog (CA)
    Menu Action Type, 6-47
    Send Message Action Type, 6-53
Parity
  Serial Settings dialog (VMSC - MAS), 4-40
Part
  Voice Player (VVE), 5-26
Partial
  Call Transfer tab, PBX Configuration dialog (VMSC - VMD) Dialogic Analog, 3-123
  General tab, Messaging dialog (VMSC - VMD), 3-177
Transfer/Outcall tab, PBX Configuration dialog (VMSC - VMD)
  IP H.323, 3-149
  IP SIP, 3-156
  QSIG, 3-132
  Set Emulation, 3-141
P-Asserted Identity
  IP SIP tab, PBX Configuration dialog (VMSC - VMD), 3-159
Password
  Message Servers dialog (VMSC - VMD), 3-112
Password Policy - Administer
  Add Task dialog (VMSC - VMD), 3-109
  Tasks tab, Security Roles dialog (VMSC - VMD), 3-98
Password Policy - View
  Add Task dialog (VMSC - VMD), 3-109
  Tasks tab, Security Roles dialog (VMSC - VMD), 3-102
Password Policy Editor, 1-5
Pause
  Prompt tab, Properties dialog (CA), 6-61
  Pause before Digits (ms)
    General tab, PBX Configuration dialog (VMSC - VMD)
      Dialogic Analog, 3-122
    Pause before Inband Digits (ms)
      Inband tab, PBX Integration dialog (VMSC - MAS), 4-43
    Pause before Request String (ms)
      Inband tab, PBX Integration dialog (VMSC - MAS), 4-46
    Pause Interval for Comma in Dial String (ms)
      General tab, PBX Configuration dialog (VMSC - VMD)
        Dialogic Analog, 3-122
PBX
  Site Configuration dialog (VMSC - VMD), 3-20
PBX Configuration dialog (VMSC - VMD)
  Dialogic Analog, 3-120
  IP H.323, 3-147
  IP SIP, 3-153
  QSIG, 3-129
  Set Emulation, 3-138
PBX Integration Activity
  Session Properties dialog (OHV), 8-18
PBX Integration dialog (VMSC - MAS), 4-33
PBX IP Address
  IP H.323 tab, PBX Integration dialog (VMSC - MAS), 4-57
PBX Name
  General tab, PBX Configuration dialog (VMSC - VMD)
    IP SIP, 3-155
PBX Type dialog (VMSC - MAS), 4-61
PBXs
  Add New PBX dialog (VMSC - VMD), 3-118
  General tab, PBX Type dialog (VMSC - MAS), 4-61
PC Clients (Usage tab, Port Groups dialog box), 4-31
Peer Electronic Mail Server
  General tab, Messaging dialog (VMSC - MAS), 4-12
Percentage
  Port Statistics Reports (RT), 7-17
Index

Percentage of Failed Logon Attempts
Basic Metrics Report (RT), 7-28

Percentage of Incoming Calls resulting in Messages
Basic Metrics Report (RT), 7-28

Percentage of Subscriber Logon Failures
Basic Metrics Report (RT), 7-29

Performance Monitoring (SPM), 9-10

Performance object
Add Counters dialog (SPM), 9-11

Permit Callers to Access Directory Services
Caller tab, Telephone User Interface dialog (VMSC - VMD), 3-52

Permit Callers to Leave Multiple Messages
Caller tab, Telephone User Interface dialog (VMSC - VMD), 3-52

Personal Operator, 3-54

Personal Operator Schedules tab
Telephone User Interface dialog (VMSC - VMD), 3-54

Phone number
Modem Configuration tab, Serviceability dialog (VMSC - MAS), 4-65

Planning Association ID Numbers (CA), 6-17

Platform
General tab, Licensing dialog (VMSC - VMD), 3-202

Play
Prompt tab, Properties dialog (CA), 6-60

Play entry prompt
Prompt tab, Properties dialog (CA), 6-57

Playback Volume
Analog tab, Telephony Interface dialog (VMSC - MAS), 4-15

General tab, Telephony Interface dialog (VMSC - MAS)
IP H.323/IP SIP, 4-23
QSIG, 4-17
Set Emulation, 4-19

Playing
Port Monitor window (SPM), 9-5

Playing a Customized Prompt (VVE), 5-12

Port
ACD tab, Telephony Interface dialog (VMSC - MAS) Set Emulation, 4-22
Analog tab, Telephony Interface dialog (VMSC - MAS), 4-16
Columns tab, Options dialog (OHV), 8-23
Event Properties dialog (OHV), 8-20
General tab, Telephony Interface dialog (VMSC - MAS)
IP H.323/IP SIP, 4-24
QSIG, 4-18
Set Emulation, 4-20
IP H.323 tab, PBX Integration dialog (VMSC - MAS), 4-57
IP SIP tab, PBX Integration dialog (VMSC - MAS), 4-60
Operation History Viewer window (OHV), 8-15
Session Properties dialog (OHV), 8-19
SNMP Trap Destinations tab, Serviceability dialog (VMSC - VMD), 3-195

Port Activity
Session Properties dialog (OHV), 8-18

Port Disable Key
General tab, PBX Configuration dialog (VMSC - VMD) Set Emulation, 3-140

Port Field Length
Serial NEC/Ericsson/DMID tab, PBX Integration dialog (VMSC - MAS), 4-42

Port Group
General tab, Port Groups dialog (VMSC - MAS), 4-29

Usage tab, Port Groups dialog (VMSC - MAS)
Call Me, 4-31
FAX, 4-32
PC Clients, 4-31
Telephone User Interface, 4-31

Port Group Members
General tab, Port Groups dialog (VMSC - MAS), 4-29

Port Group Name
IP H.323 tab, PBX Integration dialog (VMSC - MAS), 4-58
MWI Settings dialog (VMSC - MAS), 4-50

Port Group Usage
General tab, Port Groups dialog (VMSC - MAS), 4-29

Port Groups dialog (VMSC - MAS), 4-25

Port Monitor window (SPM), 9-4

Port Monitoring - Administer
Add Task dialog (VMSC - VMD), 3-108
Tasks tab, Security Roles dialog (VMSC - VMD), 3-98

Port Monitoring - View
Add Task dialog (VMSC - VMD), 3-108
Tasks tab, Security Roles dialog (VMSC - VMD), 3-102

Port Number
Port Statistics Reports (RT), 7-17

Port Numbers
Port Statistics dialog (RT), 7-15

Port Statistics dialog (RT), 7-15

Port Statistics Report (RT), 7-17

Port Status
Counter for MM MAS Voice Port (SPM), 9-15

Port Status Time
Counter for MM MAS Voice Port (SPM), 9-15
<table>
<thead>
<tr>
<th>Index</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preparing a Pre-Recorded Prompt (CA), 6-10</td>
</tr>
<tr>
<td>Preparing to Deploy Caller Applications (CA), 6-13</td>
</tr>
<tr>
<td>Pressed # to Logon</td>
</tr>
<tr>
<td>System Usage Report (RT), 7-20</td>
</tr>
<tr>
<td>Preview</td>
</tr>
<tr>
<td>Site Configuration dialog (VMSC - VMD), 3-20</td>
</tr>
<tr>
<td>Previous</td>
</tr>
<tr>
<td>Reporting Tool window (RT), 7-9</td>
</tr>
<tr>
<td>Primary Directory Server</td>
</tr>
<tr>
<td>General tab, Messaging dialog (VMSC - MAS), 4-12</td>
</tr>
<tr>
<td>Primary Domain Language dialog (VMSC - MAS), 4-7</td>
</tr>
<tr>
<td>Primary Id</td>
</tr>
<tr>
<td>Analog tab, Telephony Interface dialog (VMSC - MAS), 4-16</td>
</tr>
<tr>
<td>Primary Language</td>
</tr>
<tr>
<td>Domain Languages tab, Languages dialog (VMSC - VMD), 3-167</td>
</tr>
<tr>
<td>Primary language</td>
</tr>
<tr>
<td>General tab, Site Properties dialog (VMSC - VMD), 3-29</td>
</tr>
<tr>
<td>Primary Remote Server Name</td>
</tr>
<tr>
<td>Remote tab, PBX Integration dialog (VMSC - MAS), 4-51</td>
</tr>
<tr>
<td>Printed</td>
</tr>
<tr>
<td>Options dialog (RT), 7-10</td>
</tr>
<tr>
<td>Priority level</td>
</tr>
<tr>
<td>Start On-Demand MWI Update dialog (VMSC - VMD), 3-79</td>
</tr>
<tr>
<td>Privacy Enforcement Level</td>
</tr>
<tr>
<td>General tab, Messaging dialog (VMSC - VMD), 3-176</td>
</tr>
<tr>
<td>Private</td>
</tr>
<tr>
<td>Outgoing Call tab, PBX Configuration dialog (VMSC - VMD)</td>
</tr>
<tr>
<td>IP H.323, 3-152</td>
</tr>
<tr>
<td>QSIG, 3-135</td>
</tr>
<tr>
<td>QSIG Options dialog (SPM), 9-9</td>
</tr>
<tr>
<td>Procedure (CA)</td>
</tr>
<tr>
<td>Adding Application (Action) Nodes to the Caller Application, 6-8</td>
</tr>
<tr>
<td>Analyzing Deployed Caller Applications, 6-20</td>
</tr>
<tr>
<td>Assigning an Existing Prompt File to the Prompt, 6-11</td>
</tr>
<tr>
<td>Configuring 'Front Door' Analysis, 6-21</td>
</tr>
<tr>
<td>Configuring Automated Attendant to Launch a Caller Application, 6-18</td>
</tr>
<tr>
<td>Connecting to the MAS, 6-13</td>
</tr>
<tr>
<td>Creating a Caller Application, 6-7</td>
</tr>
<tr>
<td>Deleting an Association, 6-19</td>
</tr>
<tr>
<td>Deploying a Caller Application, 6-14</td>
</tr>
<tr>
<td>Enabling Caller Applications for the Voice Mail Domain, 6-4</td>
</tr>
<tr>
<td>Installing Caller Applications Editor on a Standalone PC, 6-4</td>
</tr>
<tr>
<td>Opening or Editing Caller Applications, 6-9</td>
</tr>
<tr>
<td>Planning Association ID Numbers, 6-17</td>
</tr>
<tr>
<td>Planning Your Caller Applications, 6-6</td>
</tr>
<tr>
<td>Preparing a Pre-Recorded Prompt, 6-10</td>
</tr>
<tr>
<td>Preparing to Deploy Caller Applications, 6-13</td>
</tr>
<tr>
<td>Recording a New Prompt File and Assigning it to the Prompt, 6-11</td>
</tr>
<tr>
<td>Re-deploying a Caller Application, 6-15</td>
</tr>
<tr>
<td>Selecting the Application Prompt to Assign, 6-10</td>
</tr>
<tr>
<td>Setting Preference for Creating Caller Applications, 6-7</td>
</tr>
<tr>
<td>Undeploying a Caller Application, 6-15</td>
</tr>
<tr>
<td>Viewing the Results of Analyzed Deployed Caller Applications, 6-21</td>
</tr>
<tr>
<td>Procedures for Customizing Prompts (VVE), 5-7</td>
</tr>
<tr>
<td>Product identifier</td>
</tr>
<tr>
<td>General tab, Serviceability dialog (VMSC - MAS), 4-63</td>
</tr>
<tr>
<td>Prompt</td>
</tr>
<tr>
<td>Auto Attendant Holidays tab, Site Properties dialog (VMSC - VMD), 3-35</td>
</tr>
<tr>
<td>Auto Attendant tab, Site Properties dialog (VMSC - VMD), 3-34</td>
</tr>
<tr>
<td>Holiday tab, Auto Attendant dialog (VMSC - VMD), 3-65</td>
</tr>
<tr>
<td>Prompts View</td>
</tr>
<tr>
<td>Visual Voice Editor window (VVE), 5-21</td>
</tr>
<tr>
<td>Prompt recording and playback</td>
</tr>
<tr>
<td>Modular Messaging Software Caller Apps Properties dialog (CA), 6-34</td>
</tr>
<tr>
<td>Options dialog (VMSC - VMD), 3-21</td>
</tr>
<tr>
<td>Prompt tab, Properties dialog (CA), 6-57</td>
</tr>
<tr>
<td>Prompts View</td>
</tr>
<tr>
<td>Visual Voice Editor window (VVE), 5-21</td>
</tr>
<tr>
<td>Properties dialog (CA)</td>
</tr>
<tr>
<td>Analyzed Deployed Applications node, 6-74</td>
</tr>
<tr>
<td>Application (Action) Node, 6-43</td>
</tr>
<tr>
<td>Application Analysis Node, 6-73</td>
</tr>
<tr>
<td>Associations Node, 6-71</td>
</tr>
<tr>
<td>Caller Applications Node, 6-43</td>
</tr>
<tr>
<td>Caller Apps Node, 6-43</td>
</tr>
<tr>
<td>Modular Messaging Software Caller Apps Node, 6-34</td>
</tr>
<tr>
<td>Modular Messaging Software Caller Apps node, 6-34</td>
</tr>
<tr>
<td>Properties dialog box (Aud), 10-9</td>
</tr>
<tr>
<td>Protocol</td>
</tr>
<tr>
<td>Message Servers dialog (VMSC - VMD), 3-112</td>
</tr>
<tr>
<td>Protocol Settings</td>
</tr>
<tr>
<td>Inband tab, PBX Integration dialog (VMSC - VMD), 3-112</td>
</tr>
</tbody>
</table>

Avaya Modular Messaging Release 5.1 with the Avaya MSS
MAS Administration Guide
June 2009
MAS), 4-46
Provided by runtime
   General tab, Properties dialog (CA)
   Send Message Action Type, 6-52
   Transfer Action Type, 6-48
Proxy
   IP SIP tab, PBX Integration dialog (VMSC -
   MAS), 4-60
pwd_consecutive
   Password Policy Editor, 1-5
pwd_leadingzero
   Password Policy Editor, 1-5
pwd_length
   Password Policy Editor, 1-5
pwd_notreverseofmailbox
   Password Policy Editor, 1-6
pwd_notsameasmailbox
   Password Policy Editor, 1-5
pwd_notsameasprevious
   Password Policy Editor, 1-6
pwd_numeric
   Password Policy Editor, 1-5
pwd_repeated
   Password Policy Editor, 1-5
pwd_updatefrequency
   Password Policy Editor, 1-6
Q
QSIG, 3-129, 3-131 to 3-134, 3-136, 4-17, 4-52,
   9-1, 9-8
   General tab, PBX Integration dialog (VMSC -
   MAS), 4-37
QSIG Options dialog (SPM), 9-9
QSIG/SE tab
   PBX Integration dialog (VMSC - MAS), 4-52
Queries
   Communities tab, Serviceability dialog (VMSC -
   VMD), 3-196
Query Originators tab
   Serviceability dialog (VMSC - VMD), 3-198
Quick Message
   Attendant Main Menu Editor tab, Auto Attendant
   dialog (VMSC - VMD), 3-64
   Auto Attendant Keys tab, Properties dialog
   (VMSC - VMD), 3-37
   System Usage Report (RT), 7-22
Quote
   Character-Separated Values dialog (RT), 7-32
Quotes
   Text Export tab, Options dialog (OHV), 8-24
R
RBAC (VMSC - VMD, 3-88
Receiving Call
   Dialogic Line Test Application window
   (SPM), 9-8
Receptionist Mailbox
   TUI tab, Site Properties dialog (VMSC -
   VMD), 3-30
Receptionist tab
   Telephone User Interface dialog (VMSC -
   VMD), 3-43
Record
   Prompt tab, Properties dialog (CA), 6-61
   Record style (columns of values)
   Export dialog (RT), 7-31
   Record trim length (ms)
   Tone Detection tab, PBX Configuration dialog
   (VMSC - VMD) Set Emulation, 3-143
Recording
   Port Monitor window (SPM), 9-5
   Recording a Customized Prompt (VEV), 5-10
   Recording a New Prompt File and Assigning it to the
   Prompt (CA), 6-11
   Re-deploying a Caller Application (CA), 6-15
   Re-deploying Caller Applications (VMSC), 4-9
   Re-evaluate mailbox MWI rules for lamp state
   Start On-Demand MWI Update dialog (VMSC -
   VMD), 3-79
   Update Schedule tab, Message Waiting Indica-
   tor dialog (VMSC - VMD), 3-77
References from application
   Properties dialog (CA)
   Analyzed Deployed Applications
   node, 6-75
References to application
   Properties dialog (CA)
   Analyzed Deployed Applications
   node, 6-75
Refresh Domain Languages menu command
   (VMSC), 4-8
Release Code for Intercom Paging
   Intercom Paging tab, PBX Configuration dialog
   (VMSC - VMD)
   Dialogic Analog, 3-126
   QSIG, 3-136
   Set Emulation, 3-144
Remote
   General tab, PBX Integration dialog (VMSC -
   MAS), 4-37
   Remote Offline Message Store (VMSC), 3-180
   Remote tab
   PBX Integration dialog (VMSC - MAS), 4-51
   Remove
   Communities tab, Serviceability dialog (VMSC -
Index

IN-28  Avaya Modular Messaging Release 5.1 with the Avaya MSS
MAS Administration Guide  June 2009

- Email Domain Restrictions tab, Web Subscriber Options dialog (VMSC - VMD), 3-188
- IP H.323 tab, PBX Integration dialog (VMSC - MAS), 4-58
- Members tab, Security Roles dialog (VMSC - VMD), 3-95
- Query Originators tab
  Serviceability dialog (VMSC - VMD), 3-198
- SIP tab, PBX Configuration dialog (VMSC - VMD), 3-158
- SNMP Trap Destinations tab, Serviceability dialog (VMSC - VMD), 3-195
- Tasks tab, Security Roles dialog (VMSC - VMD), 3-104
- Remove Group
  General tab, Port Groups dialog (VMSC - MAS), 4-30
- Remove Message Application Server menu command (VMSC), 4-8
- Remove PBX Type menu command (VMSC), 3-117, 3-119
- Remove Voice Mail Domain menu command (VMSC), 3-13
- Removing a Message Application Server (VMSC), 4-8
- Removing a Security Role (VMSC - VMD), 3-93
- Removing a Voice Mail Domain (VMSC), 3-13
- Rename
  Personal Operator Schedules tab, Telephone User Interface dialog (VMSC - VMD), 3-55
  Rename Security Role dialog (VMSC - VMD), 3-93
  Rename Voice Mail Domain dialog (VMSC - VMD), 3-14
- Rename Voice Mail Domain menu command (VMSC), 3-14
- Renaming a Voice Mail Domain (VMSC), 3-14
- Repeat Intercom Paging Phrase
  Intercom Paging tab, PBX Configuration dialog (VMSC - VMD)
    Dialogic Analog, 3-126
    QSIG, 3-136
    Set Emulation, 3-144
- Reporting Tool window (RT), 7-7
- Reports (RT)
  Basic Metrics, 7-28
  Hourly Statistics, 7-12
  Login Failures, 7-14
  Port Statistics, 7-17
  System Usage, 7-20
  User Mailbox Statistics, 7-25
- Request String Supported
  Inband tab, PBX Integration dialog (VMSC - MAS), 4-45
- Reset
  Columns tab, Options dialog (OHV), 8-23
  Dialogic Line Test Application window (SPM), 9-8
- Reset All
  Dialogic Line Test Application window (SPM), 9-8
- Resolved alarms log (Logs), 11-4
- Restarting a Modular Messaging Service, C-3
- Restoring MAS System Data, 1-14
- Restricted Digital Data
  Outgoing Call tab, PBX Configuration dialog (VMSC - VMD)
    IP H.323, 3-151
    QSIG, 3-134
- Result
  Event Properties dialog box (Aud), 10-11
- Result area/comment
  Properties dialog (CA)
    Analyzed Deployed Applications node, 6-74
- Retrieve Call
  Transfer/Outcall tab, PBX Configuration dialog (VMSC - VMD)
    Set Emulation, 3-142
- Retry Interval
  Advanced Fax dialog (VMSC - VMD), 3-84
- Retry maximum
  Application tab, Properties dialog (CA), 6-64
- Retry Period when Connecting to a Message Application Server (secs)
  Operation History Collection tab, Tracing System dialog (VMSC - VMD), 3-209
- Rewind
  Prompt tab, Properties dialog (CA), 6-61
- Rewind (VVE), 5-26
- Rich Text Format
  Export dialog (RT), 7-31
- Right Alignment of Digits in a Field
  Inband tab, PBX Integration dialog (VMSC - MAS), 4-45
- Right-Click Menu Commands (Aud)
  Action > Connect to Database, 10-8
  Action > Export List, 10-6
  Action > New Log View, 10-6
  Action > Properties, 10-9
- Right-Click Menu Commands (CA)
  Application (Action) > Change Access
    Key, 6-67
  Application (Action) > Delete, 6-29
  Application (Action) > Properties, 6-43
  Application (Action) > Set Application
    Start, 6-29
Index

Application Analysis > Caller Application > Properties, 6-74
Application Analysis > Properties, 6-73
Association > Delete, 6-32
Associations > Add Association, 6-71
Associations > Association > Properties, 6-71
Caller Application > All Tasks > Deploy Caller Application, 6-69
Caller Application > Close Application, 6-26
Caller Application > New > Application Node, 6-40
Caller Application > Properties, 6-43
Caller Application > Save Application, 6-26
Caller Application > Save Application As, 6-26
Caller Application > Set Application Start, 6-27
Deployed Applications > Connect to Message Application Server, 6-68
MM Software Caller Apps > New Caller Application, 6-38
MM Software Caller Apps > Open Application, 6-25, 6-36
MM Software Caller Apps > Properties, 6-34
Voice Mail Domain > Caller Application > Delete, 6-70

Right-Click Menu Commands (SPM)
Change State > Disable, 9-6
Change State > Disable Immediately, 9-6
Change State > Enable, 9-6
Right-Click Menu Commands (VMSC)
Licensing > Copy Host ID to Clipboard, 3-204
Licensing > Import License, 3-204
MAS > Remove Message Application Server, 4-8
MAS > Telephony Configuration Wizard, 4-10
Message Application Servers > Add Message Application Server, 4-7
Message Waiting Indicator > Show MWI Progress, 3-79
Message Waiting Indicator > Start MWI Update, 3-78
PBX > Remove, 3-117, 3-119
PBXs > Add New PBX Type, 3-118
Telephone User Interface > Copy schedule IDs to clipboard, 3-39
VMD > Refresh Domain Languages, 4-8
VMD > Remove Voice Mail Domain, 3-13
VMD > Rename Voice Mail Domain, 3-14
Voice Mail Domains > New Voice Mail Domain, 3-12

Ringing In
Port Monitor window (SPM), 9-5

Ringing Out
Port Monitor window (SPM), 9-5

RNA
System Usage Report (RT), 7-22
Role-Based Access Control (VMSC - VMD), 3-88
RTP Port Range
IP SIP tab, PBX Integration dialog (VMSC - MAS), 4-59
PBX Integration dialog (VMSC - VMD), 3-165

S
Same date formats as in report
Number and Date format dialog (RT), 7-32
Same number formats as in report
Number and Date format dialog (RT), 7-32
Saving a Session (OHV), 8-11
Schedule dialog (CA), 6-55
Schedule Grid
Attendant Schedules tab, Telephone User Interface dialog (VMSC - VMD), 3-56
Update Schedule tab, Message Waiting Indicator dialog (VMSC - VMD), 3-77
Schedule View
Schedule dialog (CA), 6-55
Scheduled MWI Refresh (VMSC), 3-77
Scheduled MWI updates
General tab, Message Waiting Indicator dialog (VMSC - VMD), 3-75
Schedules
Personal Operator Schedules tab, Telephone User Interface dialog (VMSC - VMD), 3-54
Search Entire String for Reason Code
Inband tab, PBX Integration dialog (VMSC - MAS), 4-44
Secondary Id
Analog tab, Telephony Interface dialog (VMSC - MAS), 4-16
Secondary Remote Server Name
Remote tab, PBX Integration dialog (VMSC - MAS), 4-51
Seconds to Fast Forward Message when Fast Forward Button Pressed
Message Timing tab, Telephone User Interface dialog (VMSC - VMD), 3-48
Seconds to Pause Message when Pause Button Pressed
Message Timing tab, Telephone User Interface dialog (VMSC - VMD), 3-48
Seconds to Rewind Message when Rewind Button Pressed
Message Timing tab, Telephone User Interface dialog (VMSC - VMD), 3-48
Security - Administer
Add Task dialog (VMSC - VMD), 3-106
Tasks tab, Security Roles dialog (VMSC -
Index

Security - View
  Add Task dialog (VMSC - VMD), 3-106
  Tasks tab, Security Roles dialog (VMSC - VMD), 3-102
Security Roles (VMSC - VMD), 3-88
Security Roles dialog (VMSC - VMD), 3-91
Select
  Message Application Servers dialog (SPM), 9-3
Select All
  Columns tab, Options dialog (OHV), 8-23
Select Computer
  General tab, Auditing dialog (VMSC - VMD), 3-114
Select Computer window
  General tab, Messaging dialog (VMSC - MAS), 4-12
Select counters from list
  Add Counters dialog (SPM), 9-11
Select counters from this computer
  Add Counters dialog (SPM), 9-11
Select one or more languages to use for text-to-speech
  Domain Languages tab, Languages dialog (VMSC - VMD), 3-167
Select the character to use between the fields
  Text Export tab, Options dialog (OHV), 8-24
Select the language that you would like to edit
  Open Caller Application dialog (CA), 6-36
Select Types
  Session Properties dialog (OHV), 8-18
Select User or Group dialog (VMSC - VMD), 3-95
Selected
  Columns tab, Options dialog (OHV), 8-23
Selected Hours
  Time/Greeting tab, Telephone User Interface dialog (VMSC - VMD), 3-47
Selecting a Data Source (OHV), 8-4
Selecting a Data Source (RT), 7-4
Selecting a Range of Audio Data (VVE), 5-13
Selecting the Application Prompt to Assign (CA), 6-10
Selection
  Port Statistics dialog (RT), 7-15
  User Mailbox Statistics dialog (RT), 7-23
Selection Activities
  Session Properties dialog (OHV), 8-18
Selection Size
  Waveform Info
    Visual Voice Editor window (VVE), 5-25
Semicolon
  Text Export tab, Options dialog (OHV), 8-24
Send alarm at this level or higher
  General tab, Serviceability dialog (VMSC - VMD), 3-192
Send cover page for fax printer jobs
  Fax Cover Page dialog (VMSC - VMD), 3-83
Send message
  Add Node dialog (CA), 6-41
  General tab, Properties dialog (CA), 6-45
Send Message Action Type
  General tab, Properties dialog (CA), 6-52
Separator
  Character-Separated Values dialog (RT), 7-32
Sequence Number
  Inband Protocol Settings dialog (VMSC - MAS), 4-49
SequenceID
  Event Properties dialog box (Aud), 10-11
Serial
  General tab, PBX Integration dialog (VMSC - MAS), 4-36
Serial General tab
  PBX Integration dialog (VMSC - MAS), 4-38
Serial NEC/Ericsson/DMID tab
  PBX Integration dialog (VMSC - MAS), 4-41
Serial Settings
  Serial General tab, PBX Integration dialog (VMSC - MAS), 4-39
Serial Settings dialog (VMSC - MAS)
  PBX Integration, 4-40
Server
  Connect to MM Audit Database dialog box (Aud), 10-8
Server Instance
  Connect to MM Audit Database dialog box (Aud), 10-8
Server Languages tab
  Languages dialog (VMSC - MAS), 4-13
Server Name
  Port Statistics Reports (RT), 7-17
Server Selection
  Port Statistics dialog (RT), 7-15
Serviceability - Administer
  Add Task dialog (VMSC - VMD), 3-108
  Tasks tab, Security Roles dialog (VMSC - VMD), 3-98
Serviceability - View
  Add Task dialog (VMSC - VMD), 3-108
  Tasks tab, Security Roles dialog (VMSC - VMD), 3-102
Index

Serviceability dialog (VMSC - MAS), 4-62
Serviceability dialog (VMSC - VMD), 3-189
Services dialog box, C-1
Session Files (*.SSN) (OHV), 8-15 to 8-16
Session Name
  Session Properties dialog (OHV), 8-17
Session Properties dialog (OHV), 8-17
Set Emulation, 3-138, 3-140 to 3-141, 3-143 to 3-144, 4-19, 4-21, 4-52, 9-1, 9-8
  General tab, PBX Integration dialog (VMSC - MAS), 4-37
Setting Preference for Creating Caller Applications (CA), 6-7
Setting Preferences for the Audio Device (VVE), 5-8
Setting Up the Audio Device “On the Fly” (VVE), 5-8
Sharing Out the Operation History Database Directory (OHV), 8-4
Sharing Out the Transaction Database Directory (RT), 7-4
Short
  Site Configuration dialog (VMSC - VMD), 3-20
Show Advanced Call Packet Type
  Inband Protocol Settings dialog (VMSC - MAS), 4-47
Show MWI Progress menu command (VMSC), 3-79
Show progress window
  Start On-Demand MWI Update dialog (VMSC - VMD), 3-79
Silence Suppress
  IP H.323 tab, PBX Integration dialog (VMSC - MAS), 4-57
Single Quotes
  Text Export tab, Options dialog (OHV), 8-24
SIP Domain
  IP SIP tab, PBX Configuration dialog (VMSC - VMD), 3-159
  IP SIP tab, PBX Integration dialog (VMSC - MAS), 4-59
SIP Proxies
  IP SIP tab, PBX Integration dialog (VMSC - MAS), 4-60
Site/group
  Site Configuration dialog (VMSC - VMD), 3-19
Size of Operation History Trace File (MB)
  Operation History File Size tab, Trace File Size dialog (VMSC - MAS), 4-67
Size of TUI Port Group
  Counter for MM MAS (SPM), 9-14
Snapshot Files (*.SNP) (OHV), 8-15 to 8-16
SNMP
  General tab, Serviceability dialog (VMSC - VMD), 3-191
  SNMP (Logs), 11-2
  SNMP Trap Destinations tab
    Serviceability dialog (VMSC - VMD), 3-194
  Software Upgrade - Administer
    Add Task dialog (VMSC - VMD), 3-109
    Tasks tab, Security Roles dialog (VMSC - VMD), 3-99
Sort By
  Session Properties dialog (OHV), 8-19
  User Mailbox Statistics dialog (RT), 7-24
Space
  Text Export tab, Options dialog (OHV), 8-24
Speech
  Outgoing Call tab, PBX Configuration dialog (VMSC - VMD)
    IP H.323, 3-151
    QSIG, 3-134
  SPIRIT, 3-189, 4-62, C-2
Spooler Queue Length
  Counter for MM MAS (SPM), 9-14
  Counter for MM MAS (SPM), 9-14
SRTP
  IP SIP tab, PBX Configuration dialog (VMSC - VMD), 3-159
Start Delay for Call Progress
  Call Transfer tab, PBX Configuration dialog (VMSC - VMD)
    Dialogic Analog, 3-124
  Transfer/Outcall tab, PBX Configuration dialog (VMSC - VMD) Set Emulation, 3-141
Start MWI Update menu command (VMSC), 3-78
Start of Afternoon
  Time/Greeting tab, Telephone User Interface dialog (VMSC - VMD), 3-47
Start of Evening
  Time/Greeting tab, Telephone User Interface dialog (VMSC - VMD), 3-47
Start of Morning
  Time/Greeting tab, Telephone User Interface dialog (VMSC - VMD), 3-47
Start On-Demand MWI Update dialog (VMSC - VMD), 3-78
Start Tracing Now
  Tracing tab
    ODBC Data Source Administrator dialog (OHV), 8-7
Starting digits
  Dialing Rules dialog (VMSC - VMD), 3-171
  Telephony Dialing Rule dialog (VMSC - VMD), 3-173
Starting Position
  Inband Protocol Settings dialog (VMSC -
Index

MAS), 4-49
State Counter
Counter for MM MAS Service (SPM), 9-15
Status
Dialogic Line Test Application window (SPM), 9-8
SNMP Trap Destinations tab, Serviceability dialog (VMSC - VMD), 3-195
Stop
Prompt tab, Properties dialog (CA), 6-60
Stop Bits
Serial Settings dialog (VMSC - MAS), 4-40
Stop immediately
General tab, Serviceability dialog (VMSC - VMD), 3-193
Stop Tracing Now
Tracing tab
ODBC Data Source Administrator dialog (OHV), 8-7
Stopping a Modular Messaging Service, C-3
Subscriber
System Usage Report (RT), 7-22
Subscriber - Administer
Add Task dialog (VMSC - VMD), 3-109
Tasks tab, Security Roles dialog (VMSC - VMD), 3-103
Subscriber - Reset Fax Authorization Code
Add Task dialog (VMSC - VMD), 3-110
Tasks tab, Security Roles dialog (VMSC - VMD), 3-103
Subscriber - Reset Password
Add Task dialog (VMSC - VMD), 3-110
Tasks tab, Security Roles dialog (VMSC - VMD), 3-103
Subscriber - Unlock Mailbox
Add Task dialog (VMSC - VMD), 3-110
Tasks tab, Security Roles dialog (VMSC - VMD), 3-103
Subscriber - View
Add Task dialog (VMSC - VMD), 3-110
Tasks tab, Security Roles dialog (VMSC - VMD), 3-104
Subscriber Administrator
Security Roles dialog (VMSC - VMD), 3-90
Tasks tab, Security Roles dialog (VMSC - VMD), 3-103
Subscriber Auditor
Security Roles dialog (VMSC - VMD), 3-90
Tasks tab, Security Roles dialog (VMSC - VMD), 3-104
Subscriber Helpdesk
Security Roles dialog (VMSC - VMD), 3-90
Tasks tab, Security Roles dialog (VMSC - VMD), 3-104
Subscriber Logons (TUI) as a percentage of Incoming Calls
Basic Metrics Report (RT), 7-28
Subscriber Logons (TUI) as a percentage of Logon Attempts
Basic Metrics Report (RT), 7-28
Subscriber tab
Telephone User Interface dialog (VMSC - VMD), 3-50
Suppress alarm notifications
General tab, Serviceability dialog (VMSC - MAS), 4-63
General tab, Serviceability dialog (VMSC - VMD), 3-192
Swap access key with key
Change Key dialog (CA), 6-67
Switch Host Address
Avaya C-LAN tab, PBX Integration dialog (VMSC - MAS), 4-54
Switch Number
Avaya C-LAN tab, PBX Integration dialog (VMSC - MAS), 4-54
Synchronize offline messages with remote store
Offline Access tab, Messaging dialog (VMSC - VMD), 3-178
Syslog servers
Syslog tab, Auditing dialog (VMSC - VMD), 3-116
Syslog tab
Auditing dialog (VMSC - VMD), 3-116
System Administrator
Security Roles dialog (VMSC - VMD), 3-90
Tasks tab, Security Roles dialog (VMSC - VMD), 3-97
System Auditor
Security Roles dialog (VMSC - VMD), 3-90
Tasks tab, Security Roles dialog (VMSC - VMD), 3-101
System Contact
General tab, Serviceability dialog (VMSC - MAS), 4-64
System default interval between calls (mins)
General tab, Call Me dialog (VMSC - VMD), 3-70
System Location
General tab, Serviceability dialog (VMSC - MAS), 4-63
System minimum interval between calls (mins)
General tab, Call Me dialog (VMSC - VMD), 3-70
System Performance Monitoring (SPM), 9-1
System Problems
Counter for MM MAS (SPM), 9-14
System Usage dialog (RT), 7-19
System Usage Report (RT), 7-20

**T**

Tab
Text Export tab, Options dialog (OHV), 8-24
Tab-separated text
Export dialog (RT), 7-31
Tab-separated values
Export dialog (RT), 7-31
Tasks tab
Security Roles dialog (VMSC - VMD), 3-96
TCP Port
Avaya C-LAN tab, PBX Integration dialog (VMSC - MAS), 4-55
TCP Port Number
IP SIP tab, PBX Integration dialog (VMSC - MAS), 4-60
PBX Integration dialog (VMSC - VMD), 3-165
TCP/TLS
IP SIP tab, PBX Configuration dialog (VMSC - VMD), 3-158
IP SIP tab, PBX Integration dialog (VMSC - MAS), 4-60
Telephone
Modular Messaging Software Caller Apps Properties dialog (CA), 6-34
Modular Messaging User Properties dialog (VVE), 5-8
Options dialog (VMSC - VMD), 3-21
Prompt tab, Properties dialog (CA), 6-60
Voice Player (VMSC-VMD), 3-20
Voice Player (VVE), 5-26
Telephone Properties dialog (CA), 6-34
Telephone Properties dialog (VVE), 3-21, 5-8
Telephone User Interface
Usage tab, Port Groups dialog (VMSC - MAS), 4-31
Telephone User Interface - Administer
Add Task dialog (VMSC - VMD), 3-105
Tasks tab, Security Roles dialog (VMSC - VMD), 3-99
Telephone User Interface - View
Add Task dialog (VMSC - VMD), 3-105
Tasks tab, Security Roles dialog (VMSC - VMD), 3-102
Telephone User Interface dialog (VMSC - VMD), 3-38
Telephony - Administer
Add Task dialog (VMSC - VMD), 3-106
Tasks tab, Security Roles dialog (VMSC - VMD), 3-99
Telephony - View
Add Task dialog (VMSC - VMD), 3-107
Tasks tab, Security Roles dialog (VMSC - VMD), 3-102
Telephony Configuration Wizard (VMSC - MAS), 4-10
Telephony Dialing Rule dialog (VMSC - VMD), 3-171, 3-173
Telephony Interface dialog (VMSC - MAS), 4-14
Analog, 4-15
IP H.323/IP SIP, 4-23
QSIG, 4-17
Set Emulation, 4-19
Telephony Type
Add New PBX dialog (VMSC - VMD), 3-118
General tab, PBX Type dialog (VMSC - MAS), 4-61
Tenant Number
Serial NEC/Ericsson/DMID tab, PBX Integration dialog (VMSC - MAS)
Ericsson MD110, 4-42
NEC-2400, 4-41
Termination
Add Node dialog (CA), 6-41
General tab, Properties dialog (CA), 6-45
Termination Action Type
General tab, Properties dialog (CA), 6-54
Text
Export dialog (RT), 7-31
Text File (*.TXT)
Export Operation History Events dialog (OHV), 8-26
Text to Speech
Domain Languages tab, Languages dialog (VMSC - VMD), 3-167
General tab, Licensing dialog (VMSC - VMD), 3-202
Text-to-Speech tab
Licensing dialog (VMSC - VMD), 3-203
Time
Basic Metrics dialog (RT), 7-27
Columns tab, Options dialog (OHV), 8-23
Event Properties dialog box (Aud), 10-11
Hourly Statistics dialog (RT), 7-11
Login Failures dialog (RT), 7-13
MM Audit Log Viewer (Aud), 10-7
Operation History Viewer window (OHV), 8-15
Port Statistics dialog (RT), 7-15
System Usage dialog (RT), 7-19
User Mailbox Statistics dialog (RT), 7-23
Time All Ports Busy (seconds)
System Usage Report (RT), 7-20
Time All Text-to-Speech Ports Busy (seconds)
System Usage Report (RT), 7-20
Index

Time All Voice Ports Simultaneously Busy
  Port Statistics Reports (RT), 7-17
Time Busy (seconds)
  Port Statistics Reports (RT), 7-17
Time of Day tab
  Auto Attendant dialog (VMSC - VMD), 3-66
Time Periods Starting
  Hourly Statistics Report (RT), 7-12
Time Port Availability Below Optimum
  Port Statistics Reports (RT), 7-17
Time Range
  Properties dialog box (Aud), 10-9
Time to Generate Transactions
  Transaction Generation tab, Tracing System dialog (VMSC - VMD), 3-210
Time to store empty mailboxes (Hours)
  Offline Access tab, Messaging dialog (VMSC - VMD), 3-179
Time to store offline messages (Hours)
  Offline Access tab, Messaging dialog (VMSC - VMD), 3-179
Time Zone
  General tab, Site Properties dialog (VMSC - VMD), 3-29
Time/Greeting tab
  Telephone User Interface dialog (VMSC - VMD), 3-46
Timeout
  Application tab, Properties dialog (CA), 6-64
Timeout Obtaining Greeting
  Counter for MM MAS (SPM), 9-14
Timer
  Prompt tab, Properties dialog (CA), 6-60
  Voice Player (VVE), 5-26
TLS Port Number
  IP SIP tab, PBX Integration dialog (VMSC - MAS), 4-60
  PBX Integration dialog (VMSC - VMD), 3-165
To
  Basic Metrics dialog (RT), 7-27
  Events View tab, Options dialog (OHV), 8-22
  Hourly Statistics dialog (RT), 7-11
  Login Failures dialog (RT), 7-13
  Port Statistics dialog (RT), 7-15
  Properties dialog box (Aud), 10-9
  Session Properties dialog (OHV), 8-18
  System Usage dialog (RT), 7-19
  User Mailbox Statistics dialog (RT), 7-23
Today
  Properties dialog box (Aud), 10-9
Tone Detection tab
  PBX Configuration dialog (VMSC - VMD)
    IP H.323, 3-150
    IP SIP, 3-157

QSIG, 3-133
  Set Emulation, 3-143
Total
  Prompt tab, Properties dialog (CA), 6-60
  User Mailbox Statistics Report (RT), 7-25
  Voice Player (VVE), 5-26
Total Calls Counter
  Counter for MM MAS Voice Port (SPM), 9-15
Total Calls Today
  Counter for MM MAS (SPM), 9-14
Total Failed Logins
  Login Failures Report (RT), 7-14
Total Failed TTS Sessions
  Counter for MM MAS (SPM), 9-14
Total Incoming Calls
  Basic Metrics Report (RT), 7-28
Total Messages Processed
  Basic Metrics Report (RT), 7-28
Total MWI Busy Failures
  Counter for MM MWI Service (SPM), 9-14
Total MWI Enabled Subscribers
  Counter for MM MWI Server (SPM), 9-15
Total MWI Errors
  Counter for MM MAS MWI Activity (SPM), 9-14
Total MWI Queue Commands
  Counter for MM MWI Server (SPM), 9-16
Total MWI Queue Retries
  Counter for MM MWI Server (SPM), 9-16
Total MWI Reset Attempts
  Counter for MM MAS MWI Activity (SPM), 9-15
Total MWI Set Attempts
  Counter for MM MAS MWI Activity (SPM), 9-15
Total Number of Incoming Calls
  Port Statistics Reports (RT), 7-17
Total Number of Outgoing Calls
  Port Statistics Reports (RT), 7-17
Total Number of Outgoing Calls Excluding Calls to Clients
  System Usage Report (RT), 7-21
Total Subscriber Logon (TUI) Attempts
  Basic Metrics Report (RT), 7-28
Total Subscriber Logon (TUI) Successes
  Basic Metrics Report (RT), 7-28
Total TTS Sessions
  Counter for MM MAS (SPM), 9-14
Trace File Size dialog (VMSC - SPM), 4-67
Tracing - Administer
  Add Task dialog (VMSC - VMD), 3-108
  Tasks tab, Security Roles dialog (VMSC - VMD), 3-99
Tracing - View
  Add Task dialog (VMSC - VMD), 3-108
  Tasks tab, Security Roles dialog (VMSC - VMD), 3-102
Tracing System dialog (VMSC - VMD), 3-206
Transaction Database (OHV), 8-2
Transaction Database (RT), 7-2
Transaction Generation tab
  Tracing System dialog (VMSC - VMD), 3-210
Transfer
  Add Node dialog (CA), 6-40
  Auto Attendant Keys tab, Site Properties dialog (VMSC - VMD), 3-37
  General tab, Properties dialog (CA), 6-45
Transfer Action Type
  General tab, Properties dialog (CA), 6-48
Transfer Calls to Receptionist after Maximum Errors Receptionist tab, Telephone User Interface dialog (VMSC - VMD), 3-44
Transfer Completion Code
  Call Transfer tab, PBX Configuration dialog (VMSC - VMD)
    Dialogic Analog, 3-123
Transfer Failed
  Port Monitor window (SPM), 9-5
Transfer Initiate
  Inband Protocol Settings dialog (VMSC - MAS), 4-48
Transfer Invalid Mailboxes after Business Hours Receptionist tab, Telephone User Interface dialog (VMSC - VMD), 3-45
Transfer Invalid Mailboxes during Business Hours Receptionist tab, Telephone User Interface dialog (VMSC - VMD), 3-44
Transfer Mode
  Call Transfer tab, PBX Configuration dialog (VMSC - VMD) Dialogic Analog, 3-123
  Transfer/Outcall tab, PBX Configuration dialog (VMSC - VMD)
    IP H.323, 3-149
    IP SIP, 3-156
    QSIG, 3-132
    Set Emulation, 3-141
Transfer Prefix Code
  Call Transfer tab, PBX Configuration dialog (VMSC - VMD)
    Dialogic Analog, 3-123
Transfer Release Code when Busy
  Call Transfer tab, PBX Configuration dialog (VMSC - VMD)
    Dialogic Analog, 3-124
Transfer Release Code when No Answer
  Call Transfer tab, PBX Configuration dialog (VMSC - VMD)
    Dialogic Analog, 3-124
Transfer Release Code when Reject
  Call Transfer tab, PBX Configuration dialog (VMSC - VMD)
Dialogic Analog, 3-124
Transfer to
  Attendant Main Menu Editor tab, Auto Attendant dialog (VMSC - VMD), 3-64
Transfer to Mailbox
  System Usage Report (RT), 7-22
Transfer/Outcall tab
  PBX Configuration dialog (VMSC - VMD)
    IP H.323, 3-149
    IP SIP, 3-156
    QSIG, 3-132
    Set Emulation, 3-141
Traps
  Communities tab, Serviceability dialog (VMSC - VMD), 3-196
Trunk Access Code
  Dialing Rules dialog (VMSC - VMD), 3-171
Trunk Code
  Access Codes dialog (VMSC - VMD), 3-85
Trunk Id (Inband Protocol Settings dialog), 4-49
TS OHDB 1 (MAS Alarms), A-37
TS OHDB 2 (MAS Alarms), A-37
TS OHDB 3 (MAS Alarms), A-38
TS PERF 13 (MAS Alarms), A-39
TS PERF 14 (MAS Alarms), A-39 to A-40
TTS Active Sessions
  Counter for MM MAS (SPM), 9-14
TTY
  Audio Encoding dialog (VMSC - VMD), 3-169
TUI (VMSC - VMD), 3-38
TUI Average Logon Time
  Counter for MM MAS (SPM), 9-14
TUI Average Message Delete Time
  Counter for MM MAS (SPM), 9-14
TUI Average Message Playback Time
  Counter for MM MAS (SPM), 9-14
TUI Average Message Send Time
  Counter for MM MAS (SPM), 9-14
Type
  Columns tab, Options dialog (OHV), 8-23
  Event Properties dialog (OHV), 8-20
  Event Properties dialog box (Aud), 10-11
  MM Audit Log Viewer (Aud), 10-7
  Operation History Viewer window (OHV), 8-15
  Session Properties dialog (OHV), 8-19
  SNMP Trap Destinations tab, Serviceability dialog (VMSC - VMD), 3-194
U
UDP Port Range
  IP H.323 tab, PBX Integration dialog (VMSC - MAS), 4-57
Index

Undeploying a Caller Application (CA), 6-15
Undeploying Caller Applications (CA), 6-70
Understanding Automated Attendant Prompts (VVE), 5-3
Understanding Custom Prompts (VVE), 5-2
Understanding Offline Access (VMSC - VMD), 3-180
Understanding Operation History Events (OHV), 8-2
Understanding Reports (RT), 7-2
Unknown
   Outgoing Call tab, PBX Configuration dialog (VMSC - VMD)
      IP H.323, 3-151
      QSIG, 3-134
      QSIG Options dialog (SPM), 9-9
Unknown Calls
   System Usage Report (RT), 7-21
Unrestricted Digital Data
   Outgoing Call tab, PBX Configuration dialog (VMSC - VMD)
      IP H.323, 3-151
      QSIG, 3-134
Unsuccessful mailbox login attempts due to incorrect password
   Login Failures Report (RT), 7-14
Update Schedule tab
   Message Waiting Indicator dialog (VMSC - VMD), 3-77
Update the Message Waiting Indicator for the following
   Start On-Demand MWI Update dialog (VMSC - VMD), 3-78
Urgent Messages
   Advanced Fax dialog (VMSC - VMD), 3-84
Usage tab
   Port Groups dialog (VMSC - MAS), 4-31
Use cached MWI lamp state
   Start On-Demand MWI Update dialog (VMSC - VMD), 3-79
   Update Schedule tab, Message Waiting Indicator dialog (VMSC - VMD), 3-77
Use long distance access code
   Telephony Dialing Rule dialog (VMSC - VMD), 3-173
Use system default
   Application tab, Properties dialog (CA), 6-64
Use trunk access code
   Telephony Dialing Rule dialog (VMSC - VMD), 3-173
User
   Properties dialog box (Aud), 10-10
   User international access code
   Telephony Dialing Rule dialog (VMSC - VMD), 3-173
V
   Value
      Session Properties dialog (OHV), 8-19
      Text-to-Speech tab, Licensing dialog (VMSC - VMD), 3-203
Values dialog (OHV), 8-25
   VB VB 1 (MAS Alarms), A-42
   VB VB 2 (MAS Alarms), A-43
   VB VB 202 (MAS Alarms), A-44
   VB VB 203 (MAS Alarms), A-45
   VB VB 204 (MAS Alarms), A-46
   VB VB 205 (MAS Alarms), A-47
   VB VB 209 (MAS Alarms), A-48
   VB VB 210 (MAS Alarms), A-48
   VB VB 212 (MAS Alarms), A-49
   VB VB 213 (MAS Alarms), A-50
   VB VB 999 (MAS Alarms), A-50
Via QuickMsg
   User Mailbox Statistics dialog (RT), 7-23
Via Xfer to MB
   User Mailbox Statistics Report (RT), 7-25
Visual Voice Editor window (VVE), 5-19
VMD default configuration
   Password Policy Editor, 1-6
VMD ID
   Event Properties dialog box (Aud), 10-11
VMD Name
   Event Properties dialog box (Aud), 10-11
VMDID
   Determining the VMDID (VMSC), 3-204
VMD-wide call and messaging statistics
   Basic Metrics Report (RT), 7-28
   System Usage Report (RT), 7-20
VMSC, 2-2
Configuring Translation Rules, 3-161
Test Inputs
   PBX Configuration - SIP Tab (IP SIP), Translation Rules Dialog, 3-162
Voice Mail Domain - Administer
   Add Task dialog (VMSC - VMD), 3-109
   Tasks tab, Security Roles dialog (VMSC - VMD), 3-173
User Mailbox Statistics dialog (RT), 7-24
User Mailbox Statistics Report (RT), 7-25
User’s Name
   User Mailbox Statistics dialog (RT), 7-24
Username
   Event Properties dialog box (Aud), 10-11
   MM Audit Log Viewer (Aud), 10-7
UserSID
   Event Properties dialog box (Aud), 10-11
Unknown Calls
   System Usage Report (RT), 7-21
Unrestricted Digital Data
   Outgoing Call tab, PBX Configuration dialog (VMSC - VMD)
      IP H.323, 3-151
      QSIG, 3-134
      QSIG Options dialog (SPM), 9-9
Unknown Calls
   System Usage Report (RT), 7-21
Unrestricted Digital Data
   Outgoing Call tab, PBX Configuration dialog (VMSC - VMD)
      IP H.323, 3-151
      QSIG, 3-134
Unsuccessful mailbox login attempts due to incorrect password
   Login Failures Report (RT), 7-14
Update Schedule tab
   Message Waiting Indicator dialog (VMSC - VMD), 3-77
Update the Message Waiting Indicator for the following
   Start On-Demand MWI Update dialog (VMSC - VMD), 3-78
Urgent Messages
   Advanced Fax dialog (VMSC - VMD), 3-84
Usage tab
   Port Groups dialog (VMSC - MAS), 4-31
Use cached MWI lamp state
   Start On-Demand MWI Update dialog (VMSC - VMD), 3-79
   Update Schedule tab, Message Waiting Indicator dialog (VMSC - VMD), 3-77
Use long distance access code
   Telephony Dialing Rule dialog (VMSC - VMD), 3-173
Use system default
   Application tab, Properties dialog (CA), 6-64
Use trunk access code
   Telephony Dialing Rule dialog (VMSC - VMD), 3-173
User
   Properties dialog box (Aud), 10-10
   User international access code
   Telephony Dialing Rule dialog (VMSC - VMD), 3-173
V
   Value
      Session Properties dialog (OHV), 8-19
      Text-to-Speech tab, Licensing dialog (VMSC - VMD), 3-203
Values dialog (OHV), 8-25
   VB VB 1 (MAS Alarms), A-42
   VB VB 2 (MAS Alarms), A-43
   VB VB 202 (MAS Alarms), A-44
   VB VB 203 (MAS Alarms), A-45
   VB VB 204 (MAS Alarms), A-46
   VB VB 205 (MAS Alarms), A-47
   VB VB 209 (MAS Alarms), A-48
   VB VB 210 (MAS Alarms), A-48
   VB VB 212 (MAS Alarms), A-49
   VB VB 213 (MAS Alarms), A-50
   VB VB 999 (MAS Alarms), A-50
Via QuickMsg
   User Mailbox Statistics dialog (RT), 7-23
Via Xfer to MB
   User Mailbox Statistics Report (RT), 7-25
Visual Voice Editor window (VVE), 5-19
VMD default configuration
   Password Policy Editor, 1-6
VMD ID
   Event Properties dialog box (Aud), 10-11
VMD Name
   Event Properties dialog box (Aud), 10-11
VMDID
   Determining the VMDID (VMSC), 3-204
VMD-wide call and messaging statistics
   Basic Metrics Report (RT), 7-28
   System Usage Report (RT), 7-20
VMSC, 2-2
Configuring Translation Rules, 3-161
Test Inputs
   PBX Configuration - SIP Tab (IP SIP), Translation Rules Dialog, 3-162
Voice Mail Domain - Administer
   Add Task dialog (VMSC - VMD), 3-109
   Tasks tab, Security Roles dialog (VMSC - VMD), 3-173
User Mailbox Statistics dialog (RT), 7-24
User Mailbox Statistics Report (RT), 7-25
User’s Name
   User Mailbox Statistics dialog (RT), 7-24
Username
   Event Properties dialog box (Aud), 10-11
   MM Audit Log Viewer (Aud), 10-7
UserSID
   Event Properties dialog box (Aud), 10-11
Using the Prompt Recording Device (CA), 6-60
V
   Value
      Session Properties dialog (OHV), 8-19
      Text-to-Speech tab, Licensing dialog (VMSC - VMD), 3-203
Values dialog (OHV), 8-25
   VB VB 1 (MAS Alarms), A-42
   VB VB 2 (MAS Alarms), A-43
   VB VB 202 (MAS Alarms), A-44
   VB VB 203 (MAS Alarms), A-45
   VB VB 204 (MAS Alarms), A-46
   VB VB 205 (MAS Alarms), A-47
   VB VB 209 (MAS Alarms), A-48
   VB VB 210 (MAS Alarms), A-48
   VB VB 212 (MAS Alarms), A-49
   VB VB 213 (MAS Alarms), A-50
   VB VB 999 (MAS Alarms), A-50
Via QuickMsg
   User Mailbox Statistics Report (RT), 7-25
Via Xfer to MB
   User Mailbox Statistics Report (RT), 7-25
Visual Voice Editor window (VVE), 5-19
VMD default configuration
   Password Policy Editor, 1-6
VMD ID
   Event Properties dialog box (Aud), 10-11
VMD Name
   Event Properties dialog box (Aud), 10-11
VMDID
   Determining the VMDID (VMSC), 3-204
VMD-wide call and messaging statistics
   Basic Metrics Report (RT), 7-28
   System Usage Report (RT), 7-20
VMSC, 2-2
Configuring Translation Rules, 3-161
Test Inputs
   PBX Configuration - SIP Tab (IP SIP), Translation Rules Dialog, 3-162
Voice Mail Domain - Administer
   Add Task dialog (VMSC - VMD), 3-109
   Tasks tab, Security Roles dialog (VMSC - VMD), 3-173
User Mailbox Statistics dialog (RT), 7-24
User Mailbox Statistics Report (RT), 7-25
User’s Name
   User Mailbox Statistics dialog (RT), 7-24
Username
   Event Properties dialog box (Aud), 10-11
   MM Audit Log Viewer (Aud), 10-7
UserSID
   Event Properties dialog box (Aud), 10-11
Using the Prompt Recording Device (CA), 6-60
Index

VMD), 3-99
Voice Mail Domain - View
  Add Task dialog (VMSC - VMD), 3-109
  Tasks tab, Security Roles dialog (VMSC - VMD), 3-103
Voice Mail Domain Name
  Add New Voice Mail Domain dialog (VMSC - VMD), 3-12
  Rename Voice Mail Domain dialog (VMSC - VMD), 3-14
Voice Mail Domain Node (CA), 6-31
Voice Mail System Configuration window, 2-2
Voice Player
  Waveform View
    Visual Voice Editor window (VVE), 5-26
VS COM 1 (MAS Alarms), A-54
VS COM 2 (MAS Alarms), A-55
VS EXCEPTION 1 (MAS Alarms), A-56
VS EXCEPTION 2 (MAS Alarms), A-57
VS EXCEPTION 3 (MAS Alarms), A-58
VS EXCEPTION 4 (MAS Alarms), A-59
VS EXCEPTION 5 (MAS Alarms), A-60
VS FEBD 1 (MAS Alarms), A-61
VS FEBD 2 (MAS Alarms), A-62
VS FEBD 3 (MAS Alarms), A-63
VS GENERIC 1 (MAS Alarms), A-64
VS GENERIC 2 (MAS Alarms), A-64
VS MAILBOX 1 (MAS Alarms), A-65
VS MSS 1 (MAS Alarms), A-66
VS MWI 1 (MAS Alarms), A-67
VS OPHIST 1 (MAS Alarms), A-68
VS PERF 1 (MAS Alarms), A-69
VS PERF 11 (MAS Alarms), A-73
VS PERF 12 (MAS Alarms), A-74
VS PERF 2 (MAS Alarms), A-70
VS PERF 20 (MAS Alarms), A-75
VS PERF 3 (MAS Alarms), A-71
VS PERF 4 (MAS Alarms), A-72
VS PORT 0 (MAS Alarms), A-76
VS PORT 1 (MAS Alarms), A-77
VS PORT 2 (MAS Alarms), A-78
VS PORT 3 (MAS Alarms), A-79
VS PORT 4 (MAS Alarms), A-80
VS PORT 5 (MAS Alarms), A-81
VS PORT 6 (MAS Alarms), A-82
VS PORT 7 (MAS Alarms), A-83
VS SERVICE 6 (MAS Alarms), A-84
VS SHUTDOWN 1 (MAS Alarms), A-85
VS SPOOL 1 (MAS Alarms), A-86
VS SWLINK 1 (MAS Alarms), A-87
VS VER_CHK (MAS Alarms), A-88
VS VOICE 1 (MAS Alarms), A-89
VS VOICE 2 (MAS Alarms), A-90
VS VOICE 3 (MAS Alarms), A-91
VS VOICE 4 (MAS Alarms), A-91

W
Wait for (minutes)
  General tab, Serviceability dialog (VMSC - VMD), 3-193
Wait for ports to become idle
  General tab, Serviceability dialog (VMSC - VMD), 3-193
Wait indefinitely
  General tab, Serviceability dialog (VMSC - VMD), 3-193
Waiting for Call
  Dialogic Line Test Application window (SPM), 9-8
  Port Monitor window (SPM), 9-5
Waiting for Call (Pending)
  Port Monitor window (SPM), 9-5
Warm Start
  Generic Traps (VMSC-VMD), 3-200
Warning
  Session Properties dialog (OHV), 8-18
Waveform Info
  Visual Voice Editor window (VVE), 5-25
Waveform Toolbar
  Visual Voice Editor window (VVE), 5-24
Waveform View
  Visual Voice Editor window (VVE), 5-23
Web Subscriber Options - Administer
  Add Task dialog (VMSC - VMD), 3-108
  Tasks tab, Security Roles dialog (VMSC - VMD), 3-100
Web Subscriber Options - View
  Add Task dialog (VMSC - VMD), 3-108
  Tasks tab, Security Roles dialog (VMSC - VMD), 3-103
Web Subscriber Options dialog (VMSC - VMD), 3-186
Weekly schedule
  General tab, Properties dialog (CA), 6-51
When composing voice messages
  Media Setup tab
    Modular Messaging User Properties dialog (VVE), 5-8
When should the mailboxes by updated by the MWI server
  Start On-Demand MWI Update dialog (VMSC - VMD), 3-79
When stopping the MAS service
  General tab, Serviceability dialog (VMSC - VMD), 3-192
Word for Windows document
  Export dialog (RT), 7-31