php security update (RHSA-2006-0708)

Original Release Date: October 20, 2006
Last Revised: October 10, 2008
Number: ASA-2006-234
Risk Level: Medium
Advisory Version: 4.0
Advisory Status: Final

1. Overview:

PHP is a general purpose scripting language widely used in World Wide Web (WWW) pages and applications.

PHP's memory handling functions were found to contain an integer overflow vulnerability. Using a specially constructed request message, an attacker could possibly execute arbitrary code as the user apache on the server running PHP. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2006-4812 to this issue.

More information about this vulnerability can be found in the security advisory issued by RedHat Linux:

Avaya S87XX/S8500/S8300 is marked with a Risk Level of Low as PHP is installed in CM 2.x, but PHP is not utilized by anything on the system.

Avaya Intuity LX is marked with a Risk Level of Low as PHP is installed on the system but is not utilized by any applications.

Avaya CCS/SES is not affected as this vulnerability does not affect the versions of PHP installed on the various CCS/SES releases.

2. Avaya System Products with php installed:

Product: Affected Version(s): Risk Level: Actions:
Avaya S87XX/S8500/S8300 CM 2.2 versions prior to Load 126 Low Upgrade to CM 2.2 Load 127 or later in the CM 2.2 series or CM 3.1 or later in the CM 3.x series to remove PHP.
Avaya Intuity LX IALX 1.x Low Upgrade to IALX 2.0 or later.
Avaya Messaging Storage Server MSS 1.x - 3.x Medium Upgrade to MSS 3.1 or later.
Avaya Message Networking MN 1.x - 2.0 Medium Upgrade to MN 3.1 or later.

Recommended Actions:
For all system products which use vulnerable versions of PHP, Avaya recommends that customers restrict local and network access to the server. This restriction should be enforced through the use of physical security, firewalls, ACLs, VPNs, and other generally-accepted networking practices until such time as an update becomes available and can be installed.

3. Avaya Software-Only Products

Avaya software-only products operate on general-purpose operating systems. Occasionally vulnerabilities may be discovered in the underlying operating system or applications that come with the operating system. These vulnerabilities often do not impact the software-only product directly but may threaten the integrity of the underlying platform.

In the case of this advisory Avaya software-only products are not affected by the vulnerability directly but the underlying Linux platform may be. Customers should determine on which Linux operating system the product was installed and then follow that vendors guidance:

4. Software-Only Products:

Product: Affected Version(s): Risk Level: Actions:
CVLAN All None Depending on the Operating System provided by customers, the affected package may be installed on the underlying Operating System supporting the CVLAN application. The CVLAN application does not require the software described in this advisory.
Avaya Integrated Management Suite(IMS) All None Depending on the Operating System provided by customers, the affected package may be installed on the underlying Operating System supporting the IMS application. The IMS application does not require the software described in this advisory.

Recommended Actions:
Avaya recommends that customers follow recommended actions supplied by RedHat Linux or remove the affected package.

5. Additional Information:

Additional information may also be available via the Avaya support website and through your Avaya account representative. Please contact your Avaya product support representative, or dial 1-800-242-2121, with any questions.

6. Disclaimer:

ALL INFORMATION IS BELIEVED TO BE CORRECT AT THE TIME OF PUBLICATION AND IS PROVIDED "AS IS". AVAYA INC., ON BEHALF ITSELF AND ITS SUBSIDIARIES AND AFFILIATES (HEREINAFTER COLLECTIVELY REFERRED TO AS "AVAYA"), DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE AND FURTHERMORE, AVAYA MAKES NO REPRESENTATIONS OR WARRANTIES THAT THE STEPS RECOMMENDED WILL ELIMINATE SECURITY OR VIRUS THREATS TO CUSTOMERS' SYSTEMS. IN NO EVENT SHALL AVAYA BE LIABLE FOR ANY DAMAGES WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH THE INFORMATION OR RECOMMENDED ACTIONS PROVIDED HEREIN, INCLUDING DIRECT, INDIRECT, CONSEQUENTIAL DAMAGES, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF AVAYA HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

THE INFORMATION PROVIDED HERE DOES NOT AFFECT THE SUPPORT AGREEMENTS IN PLACE FOR AVAYA PRODUCTS. SUPPORT FOR AVAYA PRODUCTS CONTINUES TO BE EXECUTED AS PER EXISTING AGREEMENTS WITH AVAYA.

7. Revision History:

V 1.0 - October 20, 2006 - Initial Statement issued.
V 2.0 - October 30, 2006 - Adjusted the Risk Level of Intuity LX from Medium to Low based on further review and made some grammatical changes.
V 3.0 - November 22, 2006 - Updated Actions for Avaya S87XX/S8500/S8300 to indicate there is now a load available that removes PHP from CM 2.x systems.
V 4.0 - October 10, 2008 - Updated Recommended Actions for Intuity LX, Message Networking and Message Storage Server. Removed Avaya CCS/SES from the list of affected System Products since it is not vulnerable to these issues. Changed the Advisory Status to Final.

Send information regarding any discovered security problems with Avaya products to either the contact noted in the product's documentation or securityalerts@avaya.com.

© 2006 Avaya Inc. All Rights Reserved. All trademarks identified by the ® or ™ are registered trademarks or trademarks, respectively, of Avaya Inc. All other trademarks are the property of their respective owners.