PHP security update (RHSA-2007-0076)

Original Release Date: March 6, 2007
Last Revised: January 7, 2008
Number: ASA-2007-101
Risk Level: Medium
Advisory Version: 4.0
Advisory Status: Final

1. Overview:

PHP is a general purpose scripting language widely used in World Wide Web (WWW) pages and applications.

Buffer overflow flaws have been reported in the PHP session extension, the str_replace() function, and the imap_mail_compose() function. An attacker could send long strings to the str_replace() function causing a memory allocation integer overflow. An attacker could use a script including the imap_mail_compose() function which could result in a heap overflow. Either of these flaws could lead to an attacker executing arbitrary code as the 'apache' user. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2007-0906 to this issue.

In some instances, the zend_hash_init() function can be forced to enter an infinite loop on 64-bit machines. An attacker could exploit this vulnerability to cause a limited denial of service. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2007-0988 to this issue.

A vulnerability in the wddx extension could cause a random section of heap memory to be exposed. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2007-0908 to this issue.

A vulnerability with the odbc_result_all() function could potentially lead to an attacker executing arbitrary code. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2007-0909 to this issue.

A one byte memory read will always occur before the beginning of a buffer, which could be triggered for example by any use of the header() function in a script. However it is unlikely that this would have any effect. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2007-0907 to this issue.

Several vulnerabilities have been reported in PHP which could allow an attacker to override some super-global variables via unspecified vectors. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2007-0910 to this issue.

More information about these vulnerabilities can be found in the security advisory issued by RedHat Linux:

2. Avaya System Products with PHP installed:

Product: Affected Version(s): Risk Level: Actions:
Avaya S87XX/S8500/S8300 CM 2.x


CM 3.x

CM 4.0
Low


None

Medium
CM 2.0 has PHP installed, but does not utilize the packages. Avaya recommends upgrading to CM 2.2 load 127 in the 2.x load line to address this issue.

PHP is not installed in CM 3.x.

Avaya recommends upgrading to CM 4.0.1 or later to resolve these issues.
Avaya CCS/SES All Medium Avaya recommends that customers upgrade to SES 5.0 to resolve this issue.
Avaya AES AES 4.0 Medium Avaya recommends that customers upgrade to AES 4.0.1 or later to resolve this issue.

Recommended Actions:
For all system products which use vulnerable versions of PHP, Avaya recommends that customers restrict local and network access to the server. This restriction should be enforced through the use of physical security, firewalls, ACLs, VPNs, and other generally-accepted networking practices until such time as an update becomes available and can be installed.


3. Avaya Software-Only Products:

Avaya software-only products operate on general-purpose operating systems. Occasionally vulnerabilities may be discovered in the underlying operating system or applications that come with the operating system. These vulnerabilities often do not impact the software-only product directly but may threaten the integrity of the underlying platform.

In the case of this advisory Avaya software-only products are not affected by the vulnerability directly but the underlying Linux platform may be. Customers should determine on which Linux operating system the product was installed and then follow that vendors guidance.

4. Software-Only Products:

Product: Affected Version(s): Risk Level: Actions:
CVLAN All None Depending on the Operating System provided by customers, the affected package may be installed on the underlying Operating System supporting the CVLAN application. The CVLAN application does not require the software described in this advisory.
Avaya Integrated Management Suite(IMS) All None Depending on the Operating System provided by customers, the affected package may be installed on the underlying Operating System supporting the IMS application. The IMS application does not require the software described in this advisory.

Recommended Actions:
Avaya recommends that customers follow recommended actions supplied by RedHat Linux or remove the affected package.

5. Additional Information:

Additional information may also be available via the Avaya support website and through your Avaya account representative. Please contact your Avaya product support representative, or dial 1-800-242-2121, with any questions.

6. Disclaimer:

ALL INFORMATION IS BELIEVED TO BE CORRECT AT THE TIME OF PUBLICATION AND IS PROVIDED "AS IS". AVAYA INC., ON BEHALF ITSELF AND ITS SUBSIDIARIES AND AFFILIATES (HEREINAFTER COLLECTIVELY REFERRED TO AS "AVAYA"), DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE AND FURTHERMORE, AVAYA MAKES NO REPRESENTATIONS OR WARRANTIES THAT THE STEPS RECOMMENDED WILL ELIMINATE SECURITY OR VIRUS THREATS TO CUSTOMERS' SYSTEMS. IN NO EVENT SHALL AVAYA BE LIABLE FOR ANY DAMAGES WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH THE INFORMATION OR RECOMMENDED ACTIONS PROVIDED HEREIN, INCLUDING DIRECT, INDIRECT, CONSEQUENTIAL DAMAGES, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF AVAYA HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

THE INFORMATION PROVIDED HERE DOES NOT AFFECT THE SUPPORT AGREEMENTS IN PLACE FOR AVAYA PRODUCTS. SUPPORT FOR AVAYA PRODUCTS CONTINUES TO BE EXECUTED AS PER EXISTING AGREEMENTS WITH AVAYA.

7. Revision History:

V 1.0 - March 6, 2007 - Initial Statement issued.
V 2.0 - June 11, 2007 - Updated Actions for Avaya S87XX/S8500/S8300 servers.
V 3.0 - September 6, 2007 - Updated actions for AES.
V 4.0 - January 7, 2008 - Updated actions for SES and changed advisory status to final.

Send information regarding any discovered security problems with Avaya products to either the contact noted in the product's documentation or securityalerts@avaya.com.

© 2007 Avaya Inc. All Rights Reserved. All trademarks identified by the ® or ™ are registered trademarks or trademarks, respectively, of Avaya Inc. All other trademarks are the property of their respective owners.