PCRE security update (RHSA-2007-1068)

Original Release Date: December 12, 2007
Last Revised: January 9, 2009
Number: ASA-2007-505
Risk Level: Medium
Advisory Version: 4.0
Advisory Status: Interim

1. Overview:

PCRE is a Perl-compatible regular expression library.

A number of vulnerabilities have been discovered in the way PCRE handles malformed regular expressions. An attacker could potentially exploit this vulnerability to run arbitrary code as the user running an application linked against PCRE, such as grep. This vulnerability could lead to privilege escalation in certain circumstances. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the names CVE-2 006-7225, CVE-2 006-7226, CVE-2 006-7228, CVE-2 006-7230 and CVE-2 007-1659 to these issues.

A number of Avaya products have the PCRE package installed. In certain systems, the PCRE vulnerability could potentially be exploited to escalate privilege. In these cases the risk level is listed below as Medium, in accordance with Avaya's Vulnerability Classification Policy.

This advisory is specific to the versions of PCRE installed on Red Hat Enterprise Linux 4 (RHEL 4). Separate advisories will be issued for versions of PCRE on other RHEL platforms.

More information about these vulnerabilities can be found in the security advisory issued by RedHat Linux:

2. Avaya System Products with RHEL 4 versions of PCRE installed:

Product: Affected Version(s): Risk Level: Actions:
Avaya Communication Manager CM 3.1.4, 4.0.1 and earlier, 5.0 Medium CM 3.1.x - A patch is only available for CM 3.1.4 and may be downloaded from here. Please refer to Product Correction Notice (PCN) 1625P for details.

CM 4.0.1/5.0 - A fix is available via Security Service Pack PLAT-rhel4-1000 or later. Security Service Packs may also be downloaded from here under the Software Downloads section. Please refer to PCN 1625P for details.

CM 5.1 and later than CM 4.0.1 - A fix is included in the release, there is no need to apply PLAT-rhel4-1000.
Avaya SIP Enablement Services SES 3.1.x, 4.0 and 5.0 Medium SES 3.1.x/4.0 - A fix is only available in the latest Service Pack for SES 4.0 and may be downloaded from her e. Please refer to Product Correction Notice (PCN) 1626P for details.

SES 5.0 - A fix is available via Security Service Pack PLAT-rhel4-1000 or later. Security Service Packs may also be downloaded from here under the Software Downloads section. Please refer to PCN 1626P for details.

SES 5.1 or later - A fix is included in the release, there is no need to apply PLAT-rhel4-1000.
Avaya AES AES 4.0.1, 4.1 Low Upgrade to AES 4.2 or later.
Avaya Intuity AUDIX LX IALX 2.0 Low Upgrade to IALX 2.0 SP2.
Avaya Message Networking 3.1 Low See recommended actions below.  This issue will be addressed in accordance with Avaya's Product Security Vulnerability Response Policy
Avaya Messaging Storage Server MSS 3.x Low See recommended actions below.  This issue will be addressed in accordance with Avaya's Product Security Vulnerability Response Policy

Recommended Actions:
For all system products which use vulnerable versions of PCRE, Avaya recommends that customers restrict local and network access to the server. This restriction should be enforced through the use of physical security, firewalls, ACLs, VPNs, and other generally-accepted networking practices until such time as an update becomes available and can be installed.

3. Avaya Software-Only Products:

Avaya software-only products operate on general-purpose operating systems. Occasionally vulnerabilities may be discovered in the underlying operating system or applications that come with the operating system. These vulnerabilities often do not impact the software-only product directly but may threaten the integrity of the underlying platform.

In the case of this advisory Avaya software-only products are not affected by the vulnerability directly but the underlying Linux platform may be. Customers should determine on which Linux operating system the product was installed and then follow that vendor's guidance.

Product: Actions:
CVLAN Depending on the Operating System provided by customers, the affected package may be installed on the underlying Operating System supporting the CVLAN application. The CVLAN application does not require the software described in this advisory.
Avaya Integrated Management Suite (IMS) Depending on the Operating System provided by customers, the affected package may be installed on the underlying Operating System supporting the IMS application. The IMS application does not require the software described in this advisory.

Recommended Actions:
In the event that the affected package is installed, Avaya recommends that customers follow recommended actions supplied by RedHat Linux.

4. Additional Information:

Additional information may also be available via the Avaya support website and through your Avaya account representative. Please contact your Avaya product support representative, or dial 1-800-242-2121, with any questions.

5. Disclaimer:

ALL INFORMATION IS BELIEVED TO BE CORRECT AT THE TIME OF PUBLICATION AND IS PROVIDED "AS IS". AVAYA INC., ON BEHALF ITSELF AND ITS SUBSIDIARIES AND AFFILIATES (HEREINAFTER COLLECTIVELY REFERRED TO AS "AVAYA"), DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE AND FURTHERMORE, AVAYA MAKES NO REPRESENTATIONS OR WARRANTIES THAT THE STEPS RECOMMENDED WILL ELIMINATE SECURITY OR VIRUS THREATS TO CUSTOMERS' SYSTEMS. IN NO EVENT SHALL AVAYA BE LIABLE FOR ANY DAMAGES WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH THE INFORMATION OR RECOMMENDED ACTIONS PROVIDED HEREIN, INCLUDING DIRECT, INDIRECT, INCIDENTAL, STATUTORY, CONSEQUENTIAL DAMAGES, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF AVAYA HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

THE INFORMATION PROVIDED HERE DOES NOT AFFECT THE SUPPORT AGREEMENTS IN PLACE FOR AVAYA PRODUCTS. SUPPORT FOR AVAYA PRODUCTS CONTINUES TO BE EXECUTED AS PER EXISTING AGREEMENTS WITH AVAYA.

6. Revision History:

V 1.0 - December 12, 2007 - Initial Statement issued.
V 2.0 - March 4, 2008 - Updated Communication Manager and SIP Enablement Services with available fixes.
V 3.0 - July 21, 2008 - Updated content with the release of Communication Manager 4.0.3/5.1, SIP Enablement Services 5.1 and AES 4.2.
V 4.0 - January 9, 2009 - Changed IALX recommended actions.

Send information regarding any discovered security problems with Avaya products to either the contact noted in the product's documentation or securityalerts@avaya.com.

© 2007 Avaya Inc. All Rights Reserved. All trademarks identified by the ® or ™ are registered trademarks or trademarks, respectively, of Avaya Inc. All other trademarks are the property of their respective owners.