libxml2 security update (RHSA-2008-0988)

Original Release Date: January 5, 2009
Last Revised: July 1, 2009
Number: ASA-2009-002
Risk Level: Low
Advisory Version: 5.0
Advisory Status: Interim

1. Overview:

libxml2 is a library for parsing and manipulating XML files. It includes support for reading, modifying, and writing XML and HTML files.

An integer overflow flaw causing a heap-based buffer overflow was found in the libxml2 XML parser. If an application linked against libxml2 processed untrusted, malformed XML content, it could cause the application to crash or, possibly, execute arbitrary code. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2008-4226 to this issue.

A denial of service flaw was discovered in the libxml2 XML parser. If an application linked against libxml2 processed untrusted, malformed XML content, it could cause the application to enter an infinite loop. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2008-4225 to this issue.

More information about these vulnerabilities can be found in the security advisory issued by RedHat Linux:

Avaya has rated this as a Low risk level as either the package is installed but not used by any application or exploitation would require direct non-standard user interaction.

2. Avaya System Products with libxml2 installed:

Product: Affected Version(s): Risk Level: Actions:
Avaya Communication Manager 5.1 and earlier Low Upgrade to CM 5.2 or later.
Avaya Intuity AUDIX LX 2.0, 2.0 SP1, 2.0 SP2 Low This will not be addressed as no further releases are planned.
Avaya Message Storage Server 5.0 and earlier Low Upgrade to MSS 5.1 or later.
Avaya Message Networking All Low See recommended actions below.  This issue will be addressed in accordance with Avaya's Product Security Vulnerability Response Policy
Avaya SIP Enablement Services 5.1 and earlier Low Upgrade to SES 5.2 or later.
Avaya Voice Portal 4.1 and earlier Low Upgrade to VP 5.0 or later.
Avaya Meeting Exchange All Low See recommended actions below.  This issue will be addressed in accordance with Avaya's Product Security Vulnerability Response Policy
Avaya Proactive Contact 4.0, 4.1 Low Upgrade to PC 4.1.1 or later.
Avaya AES 4.2.1 and earlier Low Upgrade to AES 4.2.2 or later.

Recommended Actions:
For all vulnerable system products, Avaya recommends that customers restrict local and network access to the server. This restriction should be enforced through the use of physical security, firewalls, ACLs, VPNs, and other generally-accepted networking practices until such time as an update becomes available and can be installed.

3. Avaya Software-Only Products:

Avaya software-only products operate on general-purpose operating systems. Occasionally vulnerabilities may be discovered in the underlying operating system or applications that come with the operating system. These vulnerabilities often do not impact the software-only product directly but may threaten the integrity of the underlying platform.

In the case of this advisory Avaya software-only products are not affected by the vulnerability directly but the underlying Linux platform may be. Customers should determine on which Linux operating system the product was installed and then follow that vendor's guidance.

Product: Actions:
CVLAN Depending on the Operating System provided by customers, the affected package may be installed on the underlying Operating System supporting the CVLAN application.
Avaya Integrated Management Suite (IMS) Depending on the Operating System provided by customers, the affected package may be installed on the underlying Operating System supporting the IMS application.
Voice Portal Depending on the Operating System provided by customers, the affected package may be installed on the underlying Operating System supporting the Voice Portal application.

Recommended Actions:
In the event that the affected package is installed, Avaya recommends that customers follow recommended actions supplied by RedHat Linux.

4. Additional Information:

Additional information may also be available via the Avaya support website and through your Avaya account representative. Please contact your Avaya product support representative, or dial 1-800-242-2121, with any questions.

5. Disclaimer:

ALL INFORMATION IS BELIEVED TO BE CORRECT AT THE TIME OF PUBLICATION AND IS PROVIDED "AS IS". AVAYA INC., ON BEHALF ITSELF AND ITS SUBSIDIARIES AND AFFILIATES (HEREINAFTER COLLECTIVELY REFERRED TO AS "AVAYA"), DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE AND FURTHERMORE, AVAYA MAKES NO REPRESENTATIONS OR WARRANTIES THAT THE STEPS RECOMMENDED WILL ELIMINATE SECURITY OR VIRUS THREATS TO CUSTOMERS' SYSTEMS. IN NO EVENT SHALL AVAYA BE LIABLE FOR ANY DAMAGES WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH THE INFORMATION OR RECOMMENDED ACTIONS PROVIDED HEREIN, INCLUDING DIRECT, INDIRECT, INCIDENTAL, STATUTORY, CONSEQUENTIAL DAMAGES, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF AVAYA HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

THE INFORMATION PROVIDED HERE DOES NOT AFFECT THE SUPPORT AGREEMENTS IN PLACE FOR AVAYA PRODUCTS. SUPPORT FOR AVAYA PRODUCTS CONTINUES TO BE EXECUTED AS PER EXISTING AGREEMENTS WITH AVAYA.

6. Revision History:

V 1.0 - January 5, 2009 - Initial Statement issued.
V 2.0 - February 10, 2009 - Added statement clarifying reason for risk level assignment.
V 3.0 - May 7, 2009 - Changed CM and SES affected versions and actions.
V 4.0 - June 2, 2009 - Changed IALX, VP, PC, and AES affected versions and actions.
V 5.0 - July 1, 2009 - Changed MSS affected versions and actions.

Send information regarding any discovered security problems with Avaya products to either the contact noted in the product's documentation or securityalerts@avaya.com.

© 2009 Avaya Inc. All Rights Reserved. All trademarks identified by the ® or ™ are registered trademarks or trademarks, respectively, of Avaya Inc. All other trademarks are the property of their respective owners.